Cсылки. Неофициальный сайт по программированию контроллеров Simatic фирмы SIEMENS.

Содержание официального форума Siemens за 1999...2004 года

Автоматизация и приводы (A&D) - Форум

Контроллеры серии SIMATIC и SCADA, визуализация SIMATIC HMI

http://www.automation-drives.ru/cgi-bin/forum/forum.cgi?dir=1008101941&year=2004

за 1999...2004 года

Разнесено по годам как есть и ещё составлен общий отсортированный список.
Остальные разделы будут добавлены позже
Несколько сообщений удалил из списка по причине возникавшего из-за них сбоя в компиляторе CHM
Как уже сейчас понял, у компилятора слетает крыша на некоторых длиннющих ссылках, а их искать по тексту не очень хочется.
---------------------------------------------------------------------------------

Для разностороннего развития смотри неофициальные сайты по программированию контроллеров Simatic
http://www.simatic.nm.ru/phorum
http://simatic.net.ru
http://files.svalka.net/index.php
Ссылки, приведённые в форуме, могут сдыхать по независящим от нас причинам


text

Где взять документацию по User Archives на русском/английском ???
Eugene Artamoshin; 18.10.99

Где найти документацию на русском/английском по User Archives ??? url please... задолбал немецкий...

помогите ! не пройдите мимо !!!
Re: Где взять документацию по User Archives на русском/английском ???
Иванов Павел (Сименс-Москва); 18.10.99

С октября этого года документацию в электронном виде на английском (и других иностранных языках) можно бесплатно скачать с нашего основного сервера.

В разделе Product Support.
Далее по дереву выбираете соответствующий продукт, и в правом окне будет раздел Manuals.

На русский язык документацию по User Archives еще никто не переводил.

См. http://www.ad.siemens.de/simatic-cse

Re: Где взять документацию по User Archives на русском/английском ???
vitaly; 18.11.00

Ваше сообщение...

I need user manual of "gigaset 2015" phone in russian.
Thank you,
Vitaly.

Не работает Gigaset c Definity
Kanth; 19.12.00

У меня не работает Gigaset 2030 c УАТС AT&T Definity, нет вызывного сигнала. Спецы по Definity говорят необходимо в Gigaset-е установить уровень порога чувствительности к вызывному напряжению. У меня есть коды для 2010/2011 и нет для 2030. Хоть кто-нибудь помогите!!!

kanth@online.ru
Re: Не работает Gigaset c Definity
Katy; 16.3.01

I need user manual of "gigaset 3025" phone in russian.

Thank you,
Katy
gigaset 3015 comfort
Mina; 17.3.01

Несколъко месяцов назад купила телефон Сименса. В комплекте не было инструкции на Русском. До сих пор не могу пользоватся им. Помогите мне разобратся.

спасибо Мина :)


text

Не хватает памяти при работе с UserArchives
max; 5.8.99

При выполнении функции TlgUpdateRecord на архиве в 480 записей

типа int компьютер с Win95osr2 с 64 Mb памяти орет, что ему
не хватает памяти. Приходится делать поштучно через TlgSetUsrFieldDataAsText.
Сколько же нужно РАМов?
Re: Не хватает памяти при работе с UserArchives
Никаноров - Сименс; 20.1.00

Вышел HotFix2 для WinCC4.02\SP1 (на 6-ти дискетах).

Он решает Вашу проблему.
Для получения обращайтесь ко мне по e-mail.


text

Лог-файл базы Sybase проекта WinCC
Дмитрий Маслов; 14.12.99

Господа, такой трабл:

В проекте WinCC ведется довольно масштабная архивация тегов.
При этом лог-файл базы Sybase разрастается до невероятных размеров
довольно быстро.
Пробовал отменить ведение лог-файла с помощью утилитки DBLOG.
Все замечательно, но после ближайшего запуска WinCC восстанавливает
первоначальные настройки лога (т.е. он вновь заводится).
Периодическое удаление файла лога тоже не проходит - он блокируется
при работе с базой и, соответственно, при запущенной WinCC.

Может кто уже сталкивался? Подскажите, пли-и-из...
Можно отменить Лог-файл базы Sybase
Никаноров (Сименс - Москва); 15.12.99

Можно использовать Sybase Central (SCVIEW.exe) для отмены лога. Для этого служит утилита Change LOG FILE Information.

Re: Можно отменить Лог-файл базы Sybase
Дмитрий Маслов; 17.12.99

Отмена лога с помощью Sybase Central спасает только вплоть до

ближайшей загрузки WinCC. При загрузке WinCC восстанавливает Log-файл.
Говорят, что пятая WinCC это уже не делает, но у меня - 4.02.
Re: Можно отменить Лог-файл базы Sybase
Никаноров (Сименс - Москва); 21.12.99

WinCC 4.x действительно восстанавливает log-файл при перезапуске, в отличие от версии 5.х.

Однако, начиная с версии 4.х WinCC ведет две базы данных: база данных конфигурационных параметров - ProjectName.db, и база данных - ProjectNameRT.db.
Log-файл ведется только для базы конфигурационных параметров, соответственно он меняет свой размер только при изменении конфигурации проекта.

Если же при архивации у Вас растет log-файл, то возможны две причины этого:
1. Вы создавали проект в одной из предыдущих версий WinCC, и при переходе на версию 4.х не сделали (или некорректно сделали) Upgrade базы данных (разделение на две базы).
2. Вы случайно удалили базу ProjectNameRT.db. При этом все данные помещаются в конфигурационную базу, и Log файл начинает расти.
Для исправления этой ситуации достаточно скопировать файл WinCCrt.db из каталога \WinCC\bin в каталог проекта, и переименовать ее в ProjectNameRT.db. При этом надо учитывать, что Вы потеряете Runtime данные.

Re: Можно отменить Лог-файл базы Sybase
siemargl; 22.12.99

1.Данные RUntime не потеряются, он останутся в базе конфигурации

2.Есть утилита DataBase Upgrade - она просто выделит из базы конфигурации RT-данные.
3.Если RT данные в XXXrt.db, то log-Файл на конфигурацию не растет при реальной работе.


text

Циклы опроса
Максим Поджидаев; 10.12.99

Здравствуйте!

При проектировании динамических полей (с помощью WinCC Graphics disigner)
доступны следующие циклы опроса тега: Tag, Standart cycle, Picture cycle, Window cycle.
Какова наилучшая стратегия применения этих циклов с точки зрения экономии ресурсов на станции WinCC?
Что такое Picture cycle и Window cycle?
Если на картинке 50 полей с циклом опроса "Tag 1с " ,будет ли 50 независимых 1с циклов?
Re: Циклы опроса
Никаноров (Сименс - Москва); 10.12.99

Достаточно подробная информация по оптимизации циклов приведена в Online Help WinCC(раздел Configuration Notes, если не ошибаюсь). Оптимальным является Direct connection какого-либо атрибута объекта с переменной (по сравнению с Dynamic Dialog), а также Tag Trigger по сравнению c Time Trigger.

Второй вопрос, - будет ли 50 независимых циклов, или данные будут считаны единовременно - является комплексным. Ответ на него зависит от того, какие контроллеры Вы используете (S7-300, S7-400, S5-?) и от текущей конфигурации WinCC (количество запрашиваемых переменных, их типы, как они расположены в памяти контроллеров и др).
При идеальных условиях для S7-300 количество переменных типа WORD, считываемых за одну телеграмму- 104, для S7-400 - 224. При неоптимальных условиях - 17 и 37 соответственно.

Смотрите FAQ по приведенной ссылке, объясняющий вышеприведенные цифры. Смотрите также другие FAQ в этом же разделе.

См.

Забыл указать номер FAQ
Никаноров - Сименс; 10.12.99

вот он: 07/20/1998 378956.

Re: Циклы опроса
Максим Поджидаев; 21.12.99

Здравсвуйте!

1.Мы соединяемся с S5 через CP1413 - CP1430. Тип связи Write-Write. Данные из PLC в OS посылаются без запроса со стороны OS. Однократно в цикле OB13 вызывается SEND для отправки 1го DB. Всего отправляется 12 DB.
2. Я не нашел к сожалению информации о том, что же такое Window cycle и Picture cycle и когда их выгодно использовать
3. FAQ 378956 называется "Number of variables per protocol data unit (PDU)" Это немного не то что нас интересует
Re: Циклы опроса
Никаноров - Сименс; 21.12.99

Picture Cycle - цикл обновления текущего экрана. Удобно использовать, когда все элементы экрана должны обновляться с одинаковым циклом.

Window Cycle - тоже самое, только для текущего окна.


text

OP7 (ProTool)
And; 15.12.99

Возможно ли управлять принтером,используя ESC-последовательности, (как конфигурировать эти команды из ProTool) при выводе на принтер экрана OP7, или хотя-бы отменить FormatFeed после печати определенного экрана (PLC Job 52).


text

Где взять документацию по "C actions of User Archive wizard"???
Евгений Артамошин; 6.12.99

Здравствуйте.

Помогите найти документацию по "C actions of User Archive wizard".
Особенно необходима информация по следующим Си акциям: "TlgUsArchLoadRecord" и "TlgUsArchStoreRecordTo" (описание, примеры, хотя бы что-нибудь).
Только в комментариях к этим стандартным функциям.
Никаноров (Сименс - Москва); 8.12.99

...

Re: Только в комментариях к этим стандартным функциям.
Евгений Артамошин; 8.12.99

Здравствуйте.

Комментарии к этим стандартным функциям в
WinCC 4.02 sp1 при нажатии Ctrl+F1 и выделении
любой стандартной функции User Archive Wizard выглядят таким образом:

"WinCC online help"
"No additional information available"

Может быть я не там ищу?
Re: Только в комментариях к этим стандартным функциям.
Евгений Артамошин; 8.12.99

Здравствуйте.

Комментарии к этим стандартным функциям в
WinCC 4.02 sp1 при нажатии Ctrl+F1 и выделении
любой стандартной функции User Archive Wizard выглядят таким образом:

"WinCC online help"
"No additional information available"

Может быть я не там ищу?
Re: Только в комментариях к этим стандартным функциям.
Никаноров (Сименс - Москва); 8.12.99

Я имел ввиду комментарии к тексту программы этих функций.

online Helpа действительно нет.
Re: смотрите ODK
Перцев Александр; 10.12.99

TlgUsArchLoadRecord и другие TlgUsArch используют соотвествующие им

функции из опции Open Development Kit (например, TLGGetUserArchivFieldData),
где они подробно описаны с примерами.


text

WinCC+OPC+Adam
Максим Поджидаев; 29.10.99

Здравствуйте!

При использовании WinCC (v.4.02 sp1) у нас возникли проблемы с использованием канала OPC. Не могли бы Вы помочь в решении следующей задачи - применение WinCC в качестве системы визуализации для АСУ ТП, где в качестве нижнего уровня должны быть применены модули сбора данных Advantech ADAM 4018.
Для передачи данных в WinCC мы попытались использовать Fastwel Adam OPC Server с демонстрационного диска журнала СТА номер 3-99. К сожалению, WinCC не смог распознать и получить доступ к сконфигурированным Items. В качестве единственного видимого со стороны WinCC item выступает само устройство ADAM, т.е. самый верхний уровень иерархии тегов OPC сервера. С другой стороны, SCADA Genesis-32 (с того же диска) получает данные с Fastwel Adam OPC Server нормально, а при обращении к WinCC видит все теги одной группой. При соединении WinCC - WinCC разбивка тегов по группам также не доступна.
В результате проделанных экспериментов нами был сделан вывод о некорректной работе WinCC при обмене данными через OPC. Нам хотелось бы окончательно определиться (с вашей помощью) действительно это так, или мы ошибаемся. Если OPC работает некорректно в версии 4.02, исправлено ли это в версии 5 и, если да, как произвести обновление? Если некорректность осталась и в версии 5, есть ли другие проверенные способы сбора данных из ADAM?

Re: WinCC+OPC+Adam-работает
Никаноров Владимир (Сименс-Москва); 29.10.99

В результате проведения тестирования и изучения документации удалось установить следующее.

Fastwel Adam OPC Server поддерживает спецификацию OPC версии 1.01а.
WinCC V4 использует спецификацию OPC версии 1.0а.
WinCC V5 использует спецификацию OPC версии 2.0 (последняя версия), а также 1.0а.
Видимо, в результате несовпадения версий, действительно не происходит отображение Items в WInCC V4, соответственно нельзя автоматически перенести сконфигурированные Items в переменные WinCC.

Однако, если переменные WinCC конфигурировать вручную, то Adam OPC Server РАБОТАЕТ НОРМАЛЬНО КАК С WinCC V4 ТАК И С WinCC V5.
При этом, в параметрах соединения (connection)задается имя OPC сервера: Fastwel.Adamopc.
В качестве Items для переменной надо задать, например, следующее: Device1.Slot0_AI_00.
Кроме того, программой dcomcnfg.exe надо настроить соответствующие права доступа к OPC серверу.

Здесь также можно указать, что с OPC серверами фирмы SIEMENS WinCC работает совершенно корректно.
Так что, вывод о неправильной работе WinCC, видимо, сделан неправильно.

Теперь есть ADAM OPC Server 2.0
Александр Локотков; 26.11.99

Уважаемые коллеги,

На ftp://ftp.prosoft.ru/pub/software/adamopc/version2/russian лежит 2-я версия Fastwel Adam OPC-сервера, который соответствует OPC Data Access 2.0.
Должен сказать, что в приведенном выше обсуждении ошибочно утверждается о причине невозможности сделать IOPCBrowseServerAddressSpace из WinCC в нашем сервере. Просто ряд клиентских приложений не поддерживают иерархическую организацию имен OPC-элементов. Есть и вторая возможная причина, состоящая в том, что некоторые клиенты OPC, часть кода которых была позаимствована год назад из бесплатных исходников с OPC Programmers Connection, пытаются вызывать некоторые необязательные к реализации интерфейсы OPC-сервера.
Мы имеем аналогичный опыт с некоторыми версиями BridgeVIEW, InTouch и Intellution OPCDRV.

Re: Теперь есть ADAM OPC Server 2.0
Максим Поджидаев; 3.12.99

Всем спасибо.

Благодаря вашим советам добились обмена
между WinCC и Fastwel Adam OPC Server.


text

Работа с полями и записями в User Archives
Евгений Артамошин; 24.11.99

Здравствуйте!

Возможно ли в Graphics Designer в разные "I/O Felds" вывести сразу все поля заданной записи User Archive?(желательно пример).
Возможно ли в трех "I/O Felds" при помощи
"Slider Object" пролистать все записи заданного
User Archive?(желательно пример).


text

Помогите в решении простой задачи в Graphics Designer
Евгений Артамошин; 22.11.99

Здравствуйте!

Помогите в решении простой задачи в Graphics Designer.
Необходимо, чтобы при вводе в "I/O Field1" буквы
"K" цвет шрифта в "I/O Field1" становился зеленым,
а при вводе "P" -красным.
При использовании вместо "K" и "P" соответствен-но "0" и "1" и при замене соответсвующих тэговых процедур таких как GetTagChar на GetTagBit и т.д. все работает замечательно.
Подскажите пожалуйста путь решения для использования букв.
Re: Помогите в решении простой задачи в Graphics Designer
Никаноров (Сименс - Москва); 22.11.99

Для "I/O Field1" найдите Event: Output Value - Change, и поместите туда следующий скрипт:

#include "apdefap.h"
void OnPropertyChanged(char* lpszPictureName, char* lpszObjectName, char* lpszPropertyName, char* value)
{
if (*value=='K')
SetForeColor(lpszPictureName,lpszObjectName,CO_RED); //Return-Type :BOOL
else if (*value=='P')
SetForeColor(lpszPictureName,lpszObjectName,CO_GREEN);
else SetForeColor(lpszPictureName,lpszObjectName,CO_BLACK);

}


text

GlobalScripts, Actions/Triggers
Дмитрий Молодцов; 21.11.99

время рекции Action's в GlobalScripts составляет минимум 100ms (если использовать User Update Cicle). Можно ли обойти это ограничение?

Можно ли обойти оганичение на Update Cicle в 250 ms при использовании WinCC в качестве OPC-сервера?

Какие еще временные ограничения существуют в WinCC?

Re: GlobalScripts, Actions/Triggers
Никаноров (Сименс - Москва); 22.11.99

Минимальный триггер для Actions, также как и для Update Cycles (в том числе и для OPC), составляет 100 мс. Обойти это никак нельзя. А, кстати, зачем?


text

SCL & пересылка данных в WinCC
v_zozulja; 8.11.99

Как в SCL выполнить блочную пересылку данных, т.е.

аналог примера на СИ

struct {
int a, b, c;
char d;
} st_src;
char *dst;
///.....
memcpy(dst, &st_src.c, 3);

Требуется для оптимизации по размеру программ.
А исходно нормально написать нельзя (например массив в массив),
поскольку одна из структур экспортируется в WinCC.


text

О клиентах WinCC
Oles V. Usimoff; 31.8.99

Господа, примитивный вопрос

Сколько же реально можно прицепить клиентов
на сервер в WinCC 4.02 и 5.0 ?
Сведения самые противоречивые, но конкретных указаний нет. Под клиентами понимаются станции с оператором.
Заранее благодарен

Re: О клиентах WinCC
Михайлин Сергей; 2.9.99

Приветсвую всех участников!

Вопрос отнюдь не примитивный!!!!
Для версии 4.02 декларируется возможность подключения до 16 клиентов к одному серверу, но, как я понял(могу ошибаться), эта цифра возникла из факта, что ПРОТЕСТИРОВАНО было до 16 клиентов, и на этом остановились. Дальше пробуйте сами.
Из моего опыта могу сказать, что явных ограничений на кол-во клиентов для WinCC я не нашел, главное чтоб сеть и сервер "тянули".
Я думаю, что 16-ти "за глаза".
Для версии 5.0 требование сохранилось, но теперь клиенты не привязаны к одному серверу, т. е. данные на клиенте могут принадлежать многим (до 6; тоже интересная цифра)серверам. А вот как считать возможные соединения и кол-во клиентов для тоже пока вопрос! "Пятерку" мы сами еще не получили. Пока...
См. WinCC v.5.1

Re: О клиентах WinCC
Никаноров В. (Сименс-Москва); 6.9.99

Теоретическое число клиентов - 64 макс.

Рекомендуемое число - до 16 (из соображений производительности сервера).
Имеет значение также то, какую операционную систему Вы используете на сервере. 16 клиентов может быть достигнуто только при применении Windows NT Server.


text

PCS
Максим Поджидаев; 20.8.99

Была у Siemens система PCS, под UNIX.

Сейчас в фаворе PCS7 под Windows NT.
От UNIX направления отказались? Если да,
почему? Как поддерживается и развивается
PCS?

Думаю, это будет Вам ответом на вопрос!
Михайлин Сергей; 20.8.99

Dear PCS Customer

We are overdue in providing an update for the PCS customer base especially relating to our plans for this product line. As you may know, there have been annual PCS User Group meetings held in the United States for the past three years. The next one is scheduled for May 23 - 26 in Atlanta, Georgia. At this meeting Siemens provides updates to our product plans and there are presentations from both Users and Siemens regarding various topics.
With the great worldwide emphasis on the use of Windows NT in industrial plants, Siemens has been extremely aggressive, promoting and selling our Process Control System, SIMATIC PCS 7, a Windows NT based system. As you may be aware our latest release of the PCS system, version 4.0.0, now supports the use of S7-414 and S7-416 controllers in addition to the 505 and S5 controllers. Also, the software for configuring the controllers is the PCS 7 Engineering System (ES) Toolset along with a new function block library, the OSx/APT Library. As a result of this we have extended its name to be SIMATIC PCS 7 OSx, the Unix platform of our Process Control System family utilizing the latest S7 technologies.
For PCS 7 OSx we are nearing completion of our next release, version 4.1.0. This is targeted for August 1999 availability. This release will have a variety of enhancements targeted mainly at usability improvements. The enhancements include:
• improved backup and restore process
• filters for the log file to more easily view a subset of the log file information
• filters for the tag lists using tag type, tag name or descriptions
• date- to- date Archive search capabilities with selection criteria
• improved tag installation process
• user defined tag type creation in the PCS database based on tag types created in the PCS 7 Engineering system
• support for the S7-417-4 controller
Beyond this we are working with the PCS User Council to establish priorities for additional enhancements.
For those PCS customers that are evaluating the SIMATIC S7 technologies for use in their plants, we are developing migration paths with products and utilities to make this transition easier. For example, we already have a 505 RBC for Profibus DP and are completing development of a like RBC-DP for the 500 series I/O. We are also developing an APT to ES conversion utility that will convert at least 80% of an APT program to an ES program. Our objective with these products and utilities is to allow installed I/O to be utilized and preserve the large engineering investment in the control programs.
The technology paths that will be supported for migration are:
• OSx system (UNIX) with S7 controllers utilizing existing 500/505 I/O or 85 I/O and conversion of APT programs to ES programs for the S7 controller. This might be useful for updating an existing system based on UNIX but utilizing the S7 controllers and the Engineering Toolset.
• OSx system with S7 controller utilizing new S7 I/O. If the project has similarity to existing projects, then conversion of APT programs to ES programs could be used to preserve original engineering investments. This might be a case when adding a new process area.
• PCS 7 (NT based) system with S7 controllers. This may be a new process area but you want to preserve engineering investment in re-usable APT programs. The APT to ES conversion utility would be used to convert the APT programs. The I/O, if it is a new system, would be S7 I/O. This could also be a case where a system is being completely updated to PCS 7 NT and you want to re-use existing 505 I/O.
To assist you in obtaining information about PCS Unix systems we are preparing a list of Siemens Sales and Technical support staff that are knowledgeable about the PCS Unix product line for each country throughout the world. This will make getting information easier. In addition, if you are not already enrolled on the PCS User Connection, you should do so. This provides you Internet access to current information about PCS and APT. There are libraries of Application Notes, Technical Advisories and threaded discussions. The threaded discussions allow you to ask questions, or look for solutions, on a subject that you may need help with where other PCS Users or Siemens staff may be able to assist you.
In closing let me assure you that we are firmly committed to providing you with regular up-to date information in order to make the integration of our Products and Systems, as well as the transition to new technologies, easier for you.
Yours sincerely!

См. Дополнительно здесь:


text

Тренды в WinCC
Alexander Lifanov; 19.7.99

Имеем WinCC 4.0.2.15.

Вопрос: как настроить тренды, которые должны находиться на фейсплейте MEAS_MONа?

В меас_мон имя тэга передано правильно, текущее значение есть, на закладке "Тренд" - No trend display configured. Мож темплейт для тренда надо как-то хитро обозвать? Или куда пальцем тыкать?
Re: Тренды в WinCC(в составе PCS7)
Михайлин Сергей; 20.7.99

Надо сделать так:

Например, мы имеем структуру типа PID регулятор с именем PROJECT_CFC1_PID.
- в Tag Logging создать trend template с именем @CONL1_ (в нашем случае: @CONL1_PROJECT_CFC1_PID) и сконфигурировать его на нужные таги этого контура.
- в Graphic Designer создать картинку с точно таким же именем (@CONL1_PROJECT_CFC1_PID)
- в нее вставить объект Application Window и связать его с нужным трендом.
- изменить имя этого объекта, через его свойства, на @CurvonlWindow
... и попробовать!!!


text

OLE Control
Mabroolo; 7.7.99

Разработанные в других средах программирования элементы ActiveX вызавают ошибку графического редактора в WinCC при вставке их в разрабатываемое приложение.

Прошу совета как этого избежать, какой конфликт вызывает ошибку.
Если у кого-то получалась вставка свыоих OLE Control пусть сообщат мне в какой среде создавались элементы.

Заранее благодарен!
Re: OLE Control
Никаноров (Сименс-Москва); 7.7.99

Для разработки ActiveX объектов для WInCC существует опция IndustrialX, которая учитывает все особенности WinCC как ActiveX контейнера.

Эта опция применяется совместно с Visual Basic 5 Professional или Enterprise Edition. Она представляет из себя один Wizard к Visual Basic, который позволяет облегчить разработку собственных объектов и позволяет избежать ошибок, а также ряд примеров, готовых объектов и документацию.
Что касается стандартных или созданных в другой среде ActiveX объектов, то нет никакой гарантии, что они будут нормально работать и не приводить к зависанию системы. Хотя некоторые объекты нормально вставляются и работают.

P.S. Для получения дополнительной информации по IndustrialX свяжитесь со мной напрямую.
Re: OLE Control
Кирилл Калишев; 8.7.99

У меня хорошо вставился ocx-объект, созданный в C++ Builder 3

(я делал нечто похожее на user archive). Но если
есть возможность прикупить опцию IndustrialX, то я думаю,
что будет разумно ее использовать. У меня возникали
некоторые проблемы с некорректным отображением
компонента на листе WinCC (элемент "урезался").

Re: OLE Control
siemargl; 8.7.99

Открытая система...

Стандарные интерфейсы...
Нужно давать список интерфейсов OLE, которые поддерживаются "стандартным" OLE -контейнером WinCC.
А вы предлагаете IndustrialX за отдельные деньги (правда это еще и "песочница" для больщей стабильности).
К сожалению, к другим SCADAм это тоже относится.


text

Разное по PCS7
Шурик; 27.6.99

Q1. Функциональное назаначение PDM (process device manager) и DFC77 с компакта Upgrade to 4.02

Q2.Возможно ли с помощью существующего ПО обьединить две сети Profibus (CP443-5 Bas),работающих на разных скоростях,т.е.организовать CP router
Re: Разное по PCS7
Михайлин Сергей; 28.6.99

A1. SIMATIC PDM предназначен для работы с интеллектуальными

датчиками по HART-протоколу, PROFIBUS-PA, их
удаленного парметрирования и поверки. Требует авторизации!
SIMATIC DFC77 - софт для сихронизации времени в
распределенной АСУ, в том числе через спутник.
А2. Будет отвечено позже!
Re: Разное по PCS7, Q2
Иванов Павел (Сименс-Москва); 5.7.99

Не существует стандартного ПО для пересылки данных из одной сети в другую.

Но Вы можете сами это легко написать, исполшзуя стандартные FB:
- принимаете данные пользователя из одного СР (первая сеть) в какой-то блок данных
- передаете этот блок данных в другой СР (вторая сеть)

Это обычная часто встречающаяся задача.

Благодарю за ответы !
Шурик; 5.7.99

Большой привет московскому представительству SIEMENS (AD/AS)от партнеров из Краснодара


text

PCS7
Шурик; 20.6.99

Q1.Требуется ли ServicePack для WinCC 4.02 для WinNT с установленным SP5

Q2.Как можно сократить количество переменных (служебных переменных)в стандартных блоках (например CTRL_PID),передаваемых процедурой Transfer to WinCC (не используя снятие атрибута S7_m_c с каждого сигнала)
Re: PCS7
Михайлин Сергей (Siemens-Москва); 22.6.99

Уважаемый ШУРИК! ;-)

Ответы таковы:
А1. Вообще-то, пока даже с 4-ым Service Pack PCS7 v. 4.02 толком не опробирована. Говорится, что для этого случая скоро выйдет Service Pack for PCS7, а пока рекомендуется применять №3. Последствия от всех остальных вариантов остаются на вашей совести.
Кстати, а где найти №5?
А2. Без снятия этого атрибута - НИКАК. Конечно, можно принудительно удалить кое-какие таги из WinCC, но тогда вы лишитесь возможности использовать стандартные фэйсплейты для этих блоков, а это как раз самое приятное - не рисовать свои панели для управления регуляторами.


text

Настройка буферизации архивируемых данных в WinCC
Александр Перцев; 14.5.99

Известно, что система архивации Tag Logging буферизирует

оперативные данные перед тем как их сбросить на диск в таблицы БД.
Размер буфера равен 50 записям. Это написано в ODK для функции
DBFlushArrayRecords, хотя это можно определить просто эмпирическим путём.
Каким образом принудительно "выталкивать" данные из буфера?
Упомянутая функция не срабатывает, и видимо служит только для таблиц
пользователя. Если нельзя принудительно, то каким образом уменьшить
размер буфера?
Re: Настройка буферизации архивируемых данных в WinCC
A&D S Никаноров; 18.5.99

Из ответа Simatic Hotline следует, что принудительно сбрасывать буфер Tag Logging в таблицы базы данных на диск нельзя.

Повлиять на размер буфера также невозможно.


text

Связь WinCC по Profibus с устройствами третьих фирм
Лев Шерешевский; 26.4.99

Не сталкивался ли кто-нибудь из читающих и пишущих в эту рубрику с проблемой подключения PC/WinCC по протоколу Profibus к устройствам

не Сименсовского производства (например PEP). Проблема в том, что программа ComProfibus не воспринимает GSD-файл, созданный программой
из комплекта ISAGraf (поставка PEP). Известно, что такая проблема потенциально решаема (в частности с использованием не Сименсовского DP-конфигуратора).
Будем благодарны за любую информацию по данной теме.
Re: Связь WinCC по Profibus с устройствами третьих фирм
Иванов Павел (Siemens-Москва); 26.4.99

Этот вопрос больше относится к проектированию сетевой карты

персонального компьютера в качестве DP-Master.
Для проектирования сетевых карт PROFIBUS фирмы SIEMENS
используется пакет конфигурирования COM PROFIBUS.
Стандартно в его постаке содержится информация о Slave,
поставляемых фирмой SIEMENS. Для проектирования устройств
других производителей нужно добавить GSD-файл в директорию GSD пакета
COM PROFIBUS и обновить каталог командой File > Scan GSD-file.
GSD-файлы (содержат параметры Slave) поставляет производитель
самих устройств.
Если возникают проблемы с GSD-файлом, то его правильност можно
протестировать специальной программой, которую можно скачать с
сайта ассоциации PROFIBUS: www.profibus.com.


text

Log файлы WinCC
Поджидаев М.А.; 24.3.99

Здравствуйте!

Может ли кто нибудь рассказать как
расшифровывать log-файлы WinCC.
Хотелось бы знать, какая строчка в какое время пишеться в log и что она значит. Как отображается
в логе нормальная работа и что появляется только
при сбоях.
Re: Log файлы WinCC
A&D S Nikanorov; 26.4.99

LOG-файлы WinCC находятся в директории \WINCC\DIAGNOSE. Создаются следующие основные файлы:

1. Рабочие сообщения: WinCC_Op_xx.log
2. Системные сообщения при старте системы: WinCC_SSTART_xx.log
3. Системные сообщения в период работы: WinCC_Sys_xx.log
4. Проверка лицензии: License.log
где хх==0..99

Log-файлы работают по принципу циклического буфера, т.е. гарантируется фиксированный максимальный размер на диске. Желаемый размер можно указать в файле WInCC\BIN\WinCC_LOG.INI. По умолчанию установлен размер 64 КБайт.

Рабочие сообщения конфигурируются следующим образом:
Дата,время,номер сообщ.,имя компьютера, пользователь,приложение,старое значение,новое значение,статус переменной, текст сообщения,
где статус переменной: ==0-отмена, ==1-принято.

Системные сообщения имеют следующие поля:
Дата,время,номер,класс,компьютер,пользователь,приложение, текст сообщения,
где класс: ==1-информационное сообщение, ==2-предупреждение, ==3-ошибка.

В LOG-файлах используются следующие сокращения для поля "приложение":
WCCRT MCP Runtime
PDLRT HMI runtime
TLGRT PDU runtime
ALGRT Message runtime
RPTRT Protocols
TXTRT Text library runtime
GSCRT Global scripts
SCRIPT Scripts
USERT Password monitor runtime
LBMRT Life beat monitoring
STRRT Storage
SAMRT Group display

Дополнительно могут создаваться некоторые другие файлы, например:
Authorinformation.INF- подробная информация об установленных и требуемых лицензиях
S7chnхх.log- сообщения S7 Channel
SplitScreenWizard.log- cсообщения от Split Screen Wizard.
CCRedCodi.log- сообщения Redundancy Coordinator
и т.д.


text

Русификация WinCC
Максим Поджидаев; 26.1.99

Есть ли в природе переведенные на русский язык lng файлы для WinCC, и если есть где их взять?) (lng файлы - файлы содержащие ресурсы. Ресурсы в Windows - блоки диалогов, меню, строки, и.т.д.)

Re: Русификация WinCC
A&D S Никаноров; 26.1.99

К сожалению, пока нет.


text

mktime
dma198; 4.4.00

Все компиляторы C с которыми я встречался выдают

в нижепреведенном коде одинаковое время.
В WinCC C-Script после mktime получается время
на 1 час большее чем задавалось.
Что это? bug в интерпретаторе?
///////////////////////////////////////////
#include "stdio.h"
#include "string.h"
#include "time.h"

main()
{
time_t t;
struct tm *tt,tt1;

time(&t);
tt=localtime(&t);
printf("Current time %02d/%02d/%04d %02d:%02d:%02d\n",
tt->tm_mday,tt->tm_mon+1,tt->tm_year+1900,
tt->tm_hour,tt->tm_min,tt->tm_sec);

tt1.tm_mday=tt->tm_mday;
tt1.tm_mon=tt->tm_mon;
tt1.tm_year=tt->tm_year;
tt1.tm_hour=tt->tm_hour;
tt1.tm_min=tt->tm_min;
tt1.tm_sec=tt->tm_sec;
//!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
t=mktime(&tt1); //чтобы данный кусок кода
// работал корректно в WinCC
// почему то нужно писать:
// t=mktime(&tt1)-3600;
//!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
tt=localtime(&t);
printf("Converted time %02d/%02d/%04d %02d:%02d:%02d\n",
tt->tm_mday,tt->tm_mon+1,tt->tm_year+1900,
tt->tm_hour,tt->tm_min,tt->tm_sec);
}

Re: mktime - флаг DST
Евгений Трунов; 6.11.01

Это из-за того, что WinCC-шный mktime разделяет понятие летнего и зимнего времени, и использует признак tm_isdst, который при несовпадении с флажком "Учесть переход на летнее время" Windows NT приводит к описанному эффекту.


text

Аварийные сообщения в ProTool
Юрий Оганесян; 17.5.00

Добрый день!

При работе с ProTool при создании конфигурации для Windows я столкнулся с тем, что аварийные сообщения сопровождаются индикатором синего цвета, тогда как правила эргономики требуют индикацию аварийных состояний красным цветом. Есть ли возможность изменить цвет индикатора на красный?
С уважением Юрий.
Re: Аварийные сообщения в ProTool
Sergey Molotkov; 17.5.00

А какая версия протула и софта поподробнее пожалуйста !!!

Сергей Молотков.

Re: Аварийные сообщения в ProTool
Никаноров В. - Сименс, Москва; 25.5.00

Protool v5.2 поддерживает конфигурацию сообщений с выбором цветов, миганий и прочих атрибутов

Проблемка...
Руслан; 9.4.01

При сохранении сессии на PC с ProTools обратный возврат и открытие сессии не получается. Помогите, пожалуста. Спасибо за ранее!


text

Надо описание возможностей Win CC !!!
Sergey Molotkov; 7.6.00

Господа,

Если у кого завалялась общая информация о WinCC
- имеется в виду максим. кол-во тагов, поддерживаемые протоколы, возможные типы подключаемых баз данных (внешних и внутренних), ограничения на использование, языки программирования, возможные типы подключаемых контроллеров (в том числе и не только Сименсовские, интересуют также Аллен-Бредлей, Митсубиси и т.д. и т.п.).
Кол-во подключемых клиентов. Производительность системы. Времена реакций. Типы поддерживаемых ОС-ов (Винды, ПолуОСи, Юниксы, .....). Рекомендуемое железо (имеются в виду ПиСюки - в том числе нужна детальная инфа - что нужно для сервера, что нужно для клиентов, рекомендуемые типы сетевых карт, ...).

Интересует абсолютно всё из этой области, если у кого даже есть отдельные обрывки данных (в том числе личные впечатления особо интересны - особенно впечатления программистов, кто что-то писал самостоятельно под этой оболочкой).

Инфа принимается по адресу:
sergey.molotkov@jt-int.com

Кое-что с немецкого сайта Сименса у меня уже есть,
но информация там не систематизирована и мало технической детализации - больше идёт реклама.

Если кому потом надо сбросить общую подборку данных - свистните мне я скину (мой адрес смотри выше).

Сергей Молотков.
Компания ОАО "Петро"
7.06.2000
Re: Надо описание возможностей Win CC !!!
Чистяков Дмитрий ОАО "СеверСталь"; 7.6.00

Решение проблемы может быть выполнено несколькими способами:

1.Зайди в каталог CA01 по адресу
http://www3.ad.siemens.de/ca01online/index.asp?lang=en&aktprim=0
Этот каталог можно получить на CD-ROM на русском языке.
2. Посетить специализированные странички по SCADA системам Siemens - http://www.ad.siemens.de/hmi/html_76/scada.htm
3. Попросить бесплатный CD-ROM с пакетом на 128 тэгов и русской документацией - http://www.siemens.ru/ad/as/ru/news/index.html

Re: Надо описание возможностей Win CC !!!
Никаноров В. - Сименс, Москва; 13.6.00

Был выпуск журнала МКА (мир компьютерной автоматизации), посвященный целиком SCADA системам. Информация по WinCC туда тоже включена.

Там в табличном виде собрана основная информация.
Можно также посмотреть зарубежные специализированные издания: SPS Magazine, Control Engineering.
Кое что можно найти и на этом сайте: раздел продукты/SIMATIC HMI.

Re: Надо описание возможностей Win CC !!!
Никаноров В. - Сименс, Москва; 26.1.01

На этом сайте в разделе продукты/HMI можно посмотреть "Системное описание WinCC5", представляющее из себя описание возможностей этого продукта..


text

ODK
Богдан Кудлак; 28.11.00

В своем приложении я могу по какому-то запросу (таймер, кнопка)
читать или передавать значения в WinCC.

Dim Mcp As Object
Set Mcp = CreateObject("WinCC-Runtime-Project")
Wert = Mcp.GetValue(fy1)
success = Mcp.SetValue(var_name(z), dm_var)

А как сделать, чтобы при каком-то событии (например изменении тега),
WinCC сам передавал данные моему приложению?

Re: ODK
Шестаков Сергей, ООО "Профиль" Ст.Оскол; 30.11.00

Уважаемый Богдан!

Что касается DDE-обмена, просмотрите раздел справочной системы WinCC - "DDE-server/Local DDE-connection". Я проверял обмен с EXCEL, работает нормально. Хотя WinCC запускает свой DDE-server, тем не менее приложения Windows видят его нормально, хотя в Windows NT существует менеджер
DDESHARE, показывающий активные DDE-серверы, который не понимает DDE-сервер WinCC. Из-за этого не всегда корректно работает(а иногжа и совсем не работает)NetDDE.

С уважением
Шкстаков Сергей
Re: ODK
Василенко П; 19.1.01

Может я не то отвечаю на другой вопрос, но в ODK для многих вещей есть CALLBACK-функции входы в пользовательское приложение, используемое WINCC по разным поводам например для реакции на изменение тегов кусок реальной программы:

...
void CGetPrijInfoDlg::OnGetInfo()
{
static int m_User = 103; // key
PCMN_ERROR pError = &err; // Global Error Block
m_straVarNames.RemoveAll();
ZeroMemory( &dmVarFilter, sizeof(DM_VARFILTER));
ZeroMemory(pError, sizeof(CMN_ERROR));
dmVarFilter.dwFlags = DM_VARFILTER_GROUP;
dmVarFilter.lpszGroup = __T("ExportTags");
dwCycle = 0;
hDlg = m_hWnd;
if (!DMConnect(AppName, DmgNotifyCon, &m_User, pError))
MessageBox(err.szErrorText, NULL, MB_OK);
if (!DMGetRuntimeProject(project, (DWORD)sizeof(project), &err))
MessageBox(err.szErrorText, NULL, MB_OK);
if(!DMEnumVariables((LPSTR)(LPCTSTR) project, &dmVarFilter, EnumVariablesProc,
&m_User, &err))
MessageBox(err.szErrorText, NULL, MB_OK);
if(!DMBeginStartVarUpdate(&dwTAID, pError))
MessageBox(err.szErrorText, NULL, MB_OK);
nNum = m_straVarNames.GetSize();
lpdmVarKey = GetVarKeys();
SetDlgItemText(IDC_STATIC_NAME1,lpdmVarKey[0].szName);
SetDlgItemText(IDC_STATIC_NAME2,lpdmVarKey[1].szName);
SetDlgItemText(IDC_STATIC_NAME3,lpdmVarKey[2].szName);
SetDlgItemText(IDC_STATIC_NAME4,lpdmVarKey[3].szName);
SetDlgItemText(IDC_STATIC_NAME5,lpdmVarKey[4].szName);

if(!DMGetVarInfo (project, lpdmVarKey, nNum, &err))
MessageBox(err.szErrorText, NULL, MB_OK);
for( int i=0; i<nNum; i++)
IDNum[i] = lpdmVarKey[i].dwID;

if(!DMStartVarUpdate(dwTAID, lpdmVarKey, nNum,dwCycle,
NotifyVariableProc, &m_User, pError))
MessageBox(err.szErrorText, NULL, MB_OK);
if(!DMEndStartVarUpdate(dwTAID, pError))
MessageBox(err.szErrorText, NULL, MB_OK);
}

...


text

OP-15 password
Станислав Хмельницкий, СП "ТИГИ-Рихтер"; 20.12.00

Добрый день!

У нас на производстве имеется панельоператора OP-15, с которой
осуществляется управление отдельными функциями технологического
процесса, но на все меню программирования параметров поставлен пароль,
которого, естественно, никто не знает, включая установщиков из Германии.(!!!)
Вопрос - как можно обойти парольную защиту, если очень хочется чегой-нибудь
подправить в программе?
Заранее всем спасибо.

Stah Chmelnicki

Re: OP-15 password
Дедовец Павел; 26.12.00

По умолчанию пароль 100. Но немцы об этом обычно знают. Еще проект из ОР-15 можно считать и посмотреть пакетом COMTEXT (запускается из под STEP5) и если я не ошибаюсь то в системных настройках проекта, кроме контрастности и пр. можно увидеть пароль. Но мой Вам совет, требуйте его с установщиков из Германии. (Самый простой способ)


text

Еще раз о Global Script
Александр Родин, ООО "Нева Электрик"; 21.12.00

Обнаружил такую "интересную" вещь:

Надо было по заполнении архива переписать его в какое-то место на диске. Для этого написал функцию, в соответсвии с требованиями Tag Logging-а для данного действия. Функция содержит ряд операторов со строками, в частности формирует строку заголовка для нового и исходного файла, для последующей их передачи функции CopyFileA, которая, собственно, и осуществляет то самое копирование. Так вот, первый вызов созданной функции проходит на "ура". Строки формируются как надо, файлы переносятся. Последующий вызов той же функции приводит к зависанию. Посмотрел при отладке, что же происходит. Оказалось, указатели, которые представляют сами строки при втором и последующих обращениях к функции не обнуляются, даже если там напрямую указан оператор <="";>. Вот и не соображу никак, что делать-то ? Может ту же самую задачу можно другим способом решить ?

Заранее спасибо.


text

Динамическое создание объектов в WinCC
Максим Елхов; 21.12.00

Можно ли создать новый графический объект (например, типа Rectangle) в RT из самой WinCC при помощи скриптов? Кто-нибудь делал это САМ? Если да, то как - или где можно прочитать?

Re: Динамическое создание объектов в WinCC
Никаноров В. - Сименс; 21.12.00

Для этого служит пакет ODK.

Можно создавать свое приложение, из которого есть доступ к функциям конфигурации и Runtime WinCC.
В пакете имеется много готовых примеров (как в исходниках, так и скомпилированных), в том числе создание нового объекта, изменение его свойств и т.п.
Из WinCC скрипта можно, например, вызвать свое приложение или dll, созданное с помощью ODK.


text

Protool/Pro V5.2
Никаноров - Сименс; 15.2.00

Вышел Protool/Pro V5.2.

Теперь поддерживается OPC интерфейс (как клиент, и как сервер).
Также теперь поддерживается генерация отчетов и др.
Смотрите ссылку.
См. http://www.ad.siemens.de/hmi/dhtml_76/opintface/protpro/protpro_version52.html

Re: Protool/Pro V5.2
Yugoslavia; 15.12.00

Please could you send me a SIMATIC ProTool/Pro V5.2 SP2 manual or user guide?

Yours faithfully
Vladimir Puvaca


text

Вышел новый ProTool/Pro V5.2 SP2
Никаноров В. - Сименс, Москва; 30.8.00

Вышел новый ProTool/Pro V5.2 SP2

Новые функции:
1. Разрешена работа под Win2000
2. Разрешено подключение к SIMATIC S7-200/300/400 через PC-MPI Adapter с заказными номерами 6ES7 972-0CA22-0XA0 и 6ES7 972-0CA23-0XA0
3. Поддержка новых устройств на базе WinCE.

Те, кто приобретал ProTool/Pro V5.2 SP1, обновление на V5.2 SP2 могут сделать бесплатно.

Re: Как получить?
Евгений Артамошин; 10.10.00

обновление на V5.2 SP2 могут сделать бесплатно.

Каким образом?
Re: Как получить?
Никаноров В. - Сименс, Москва; 10.10.00

Вы можете связаться с Германией по указанному ниже адресу, и заказать Update, предъявив Software Product Sertificate.

Альтернативно, можно обратиться в ближайший офис Сименс в России.

Customers that already possess V5.2+SP1, can order an update free
of charge - after presenting the delivery bill or the software
product card of the respective software package - from the
following address: Siemens AG
Mrs. Gaiser
A&D SE ES 45
Wuerzburger Str. 121
D-90766 Fuerth

Phone: 0911-750-2012
Fax: 0911-750-2030

When ordering, please indicate the corresponding software package
material number:

ProTool/Lite Update: 200065011
ProTool Update : 200065012
ProTool/Pro Update : 200065013

Re: Вышел новый ProTool/Pro V5.2 SP2
Yugoslavia; 15.12.00

Please, where can I download a user's guide for SIMATIC ProTool/Pro V5.2 SP2


text

ProToolPro V5.2
Шапиро М.; 29.11.00

Неисправен фаил PTREG.DAT для версии 5.2

М.б. кто-нибудь может поделиться.
Re: ProToolPro V5.2
Никаноров В. - Сименс; 30.11.00

Скорее всего, Вы устанавливали ProTool с диска SimaticHMI выпуска 08.2000.

Если так, то на этом диске в инсталляционных файлах содержится ошибка.
Правильную версию Вы можете получить в техцентре в Нижнем Новгороде: диск SimaticHMI выпуска 09.2000.


text

Вывод значений на видеокадры.
Богдан Кудлак; 27.11.00

1.Можно ли выводить в I/O Field цифровые и строковые данные одновременно?

Например: значение давления и размерность.
2.Как сделать, чтобы при подводе курсора к обьекту
выводился комментарий и цифровое значение одновременно (Tooltip Text)?
Например: "Уровень в емкости Е21 равен 342 мм"
Re: Вывод значений на видеокадры.
Сергей Шестаков, ООО "Профиль" Ст.Оскол; 27.11.00

Уважаемый Богдан!

Мне трудно представить, зачем это Вам понадобилось, но сделать это можно с помощью C-Action примерно такого содержания:

#include "apdefap.h"
char* _main(char* lpszPictureName, char* lpszObjectName, char* lpszPropertyName)
{
char* ToolTips;
int i;
ToolTips=(char*)malloc(32);
i=GetPropWord(lpszPictureName,"Slider Object2","Process"); //Return-Type :long int
sprintf(ToolTips,"Значение: %3d, m3/h",i);
return(ToolTips);
}
Для I/O FIELD задаете тип String и привязываете C-акцию к свойству Output Value.
Это работает достаточно медленно (я применял триггер Windows cycle). Вообще, я видел только одну SCADA-систему, где на поля вывода можно было накладывать шаблон и динамически его менять. В современных системах, я пока еще такой функции не наблюдал.

С уважением
Шестаков Сергей

Re: Вывод значений на видеокадры.
Никаноров В. - Сименс; 28.11.00

Достаточно конвертировать цифру в *char и склеить две строки. Затем выводить полученную строку в I/O Field или в ToolTip.


text

Задержка или буфер?
Максим; 24.11.00

Заметил интересную особенность - скрипт вызывается через Action раз в минуту. Занимается выдачей лога в файл (через fprintf). Так вот, теги и поля в самой WinCC (в RT) обновляются сразу по прошествии минуты, а информация в файле появляется через некоторое время (около минуты). Подозреваю, что это случается при следующем вызове скрипта, так как при изменении интервала вызова на раз в 10 секунд - информация в файле появляется через интервал около 10 секунд, после того, как она появилась в окне RT. Это буфер или какая-то задержка?


text

средства визуализации при отрицательных температурах
Василий; 23.11.00

Существуют ли у Siemens текстовые дисплеи (ОР), способные работать при отрицательных температурах до минус 25 градусов.Если такие есть- дайте ссылку.

Спасибо.


text

Буфер Tag Login
Максим Поджидаев; 21.11.00

Здравствуйте Господа!

Следя за обновлениями данных в в таблицах трендов (обновление - 1 мин) через SCView я заметил задержки в приходе новых данных(10-30м). На графике WinCC данные появлялись без задержек. Буфер??
Если это буфер то как можно управлять его
глубиной?
Мы используем архивы WinCC в качестве источника данных для вышестоящих систем
поэтому хотелось бы чтобы данные в архиве
появлялись быстрее.
Re: Буфер Tag Login
Никаноров В. - Сименс; 21.11.00

Да, есть буфер.

Управлять буфером никак нельзя.
До данных буфера можно добраться с помощью API функций, например, GetArchiveData.
Можно подсоединиться из Excel (MS Query), тогда данные будут обновляться сразу.
Для передачи данных на верхний уровень можно также использовать экспорт данных: с помощью ISQL.exe или API функций (см. Customer Support).


text

Alarm Logging
Сергей Шестаков ООО "Профиль"; 18.11.00

Здравствуйте!

Подскажите, пожалуйста, существует ли возможность в RT при формировании сообщения в Alarm Logging изменить значение поля, например, Point of Error, на другое. Часто возникает необходимость обрабатывать одинаковые сообщения с однотипных агрегатов. Достаточно бы было менять только место события.

Заранее благодарен.


text

Перечеркнутый текст в окне сообщений
Харгелия Олег; 17.11.00

В WinCC 5 используем OCX для вывода сообщений.

Поле в котором выводится время сообщения иногда содержит перечекнутый текст. Что это обозначает и где это настраивается.

Заранее благодарен за помощь


text

Координаты мыши в WinCC
Медведев Игорь; 16.11.00

Здравствуйте.

Подскажите, пожалуйста, как в WinCC можно получить координаты мыши.
Спасибо.

Re: Координаты мыши в WinCC
Никаноров В. - Сименс; 17.11.00

Смотрите ссылку

См. http://www4.ad.siemens.de/csinfo/livelink.exe/2028968?func=ll&objId=2028968&objAction=csView&lang=en&aktprim=0&nodeID0=4000520&siteid=cs


text

Многопользовательские окна в WinCC
Казахстан, Алматы, ТОО "Дебют"; 14.11.00

Ваше сообщение...Вопросы начинающего:

В WinCC на экранах мнемосхем обычно создаются скрытые сервисные окна, которые вызываются пользователем. В механизме их отображения/скрытия обычно задействуется внутренний тег. Как это будет работать в многопользовательской системе? Достаточно ли тут назначения свойств тега, как Computer-local update?

Среди внутренних функций Global Script есть наборы функций чтения тегов Wait и State. Сколько-нибудь подробного описания их не имеется. Для чего нужны подобные функции? Какаие состояния тегов возможны?
Re: Многопользовательские окна в WinCC
Никаноров В. - Сименс, Москва; 15.11.00

1. Для работы с окнами не обязательно использовать внутренние теги. Обычно достаточно управлять свойством Visible окна.

2. В случае, если Вы выбираете Computer-local update для внутреннего тега, то тег будет обновляться индивидуально для каждой рабочей станции, и может иметь разные значения.
3. Функции типа Get(Set)Tagxxx(Wait)(State) описаны во многих источниках. В том числе можно посмотреть по указанной ссылке.

См. http://www4.ad.siemens.de/csinfo/livelink.exe/2952161?func=ll&objId=2952161&objAction=csView&lang=en&open0=-346-344-331-1-356-354-351-352-&aktprim=0&nodeID0=4000525&siteid=cs


text

COROS OP 25
Орешков Игорь; 11.11.00

Господа.

Можно ли извлечь программу из пульта для модернизации или необходим
первоисточник. Если можно, то чем.
Заранее благодарен.

Re: COROS OP 25
Никаноров В. - Сименс, Москва; 13.11.00

Это уже обсуждалось здесь

См. http://www.siemens.ru/ad/as/ru/forum/hmi/forum.cgi?message=184


text

Рецепты в OP7
Штепа С.А.; 3.11.00

Подскажите, где можно почерпнуть доходчивую информацию о том, как правильно сконфигурировать панель OP7 для работы с CPU 314.

Проблема: Создан проект в STEP7 v5.1 и ProTool Pro v5.2, использующий работу с рецептами OP7. Панель выдает ошибку $505 "ПЕРЕДАЧА ЗАБЛОКИРОВАНА" при попытке передачи рецепта в контроллер, хотя чтение его из контроллера происходит без ошибок. В хелпе необходимая для рецептов настройка "Area pointers" в OP для контроллеров S7 300/400 практически не описана (я думаю, что именно здесь причина ошибки). Помогите, пожалуйста.
Re: Рецепты в OP7
Никаноров В. - Сименс, Москва; 9.11.00

Передача рецепта заблокирована, потому что заблокирован Data Mailbox (установлен бит 0 в Interface Area).

Для успешной передачи рецепта с текстовой панели в PLC необходимо создать два Area Pointers:
-Data Mailbox длиной 5 слов
-Interface Area.
Контроллер должен проверять биты в Interface Area, и, если передача произошла без ошибок, сбрасывать бит 0 в Interface Area.
Детальное описание Area Pointers находится в руководстве по коммуникациям.
Могу выслать по мэйлу (на англ. языке).
Или скачайте по ссылке.

См. http://www4.ad.siemens.de/csinfo/livelink.exe/1137086?func=ll&objId=1137086&objAction=csView&lang=en&open0=-1-324-326-327-&aktprim=0&nodeID0=4000507&siteid=cs


text

Terminal SUTRON BT-30
Китин Владислав; 3.11.00

Подскажите пожалуйста где можно взять функциональный блок для связи с устройством визуализации SUTRON BT-30 Bedienterminal.

Контроллер S5-115 (922) si2 FAP or 511
Re: Terminal SUTRON BT-30
Никаноров В. - Сименс, Москва; 4.11.00

Что такое SUTRON BT-30 Bedienterminal я, к сожалению, не знаю.

Но для всех панелей оператора, подключаемых с Simatic S5 контроллерам, необходимы функциональные блоки:
6AV3 980-1AA21-0AX0 V3.31 - 169 Euro.


text

WinCC 4.02 SP1 HF2. Text List
Шестаков Сергей,Старый Оскол,ООО "Профиль"; 2.11.00

Здравствуйте!

Подскажите, менял ли кто-нибудь динамически свойство Assignments объекта Text List? Список можно загрузить в текстовый тег, а вот обратно - никак! Я пробовал через PDLRTSetPropEx, но при этом вылетает ошибка 21, которой нет в списках ошибок. Как быть?


text

Архивация текстовых тегов
Шахмин Александр, ЗАО "Камасталь", г. Пермь"; 24.10.00

Подскажите пожалуйста, можно ли как-то архивировать текстовые теги в WinCC ?

Re: Архивация текстовых тегов
Никаноров В. - Сименс; 1.11.00

С помощью UserArchive без проблем


text

Авторизация на WinCC для Win9x
Максим; 31.10.00

Случайно обнаружил, что дискета авторизации для WinCC5.0 for WinNT авторизует WinCC4.02 под Win9x Это что, подарок?

Re: Авторизация на WinCC для Win9x
игпрщ; 31.10.00

Авторизации для WinCC 4-ой и 5-ой версии взаимозаменяемы.

Только сама авторизация не всегда устанавливается под Win95.


text

Трансфер сообщений в WinCC
Соловьев Алексей; 24.10.00

Добрый день!

Возникла небольшая проблема:
В функциональные блоки вставляем ALARM_8P, создаем объект WinCC и заполняем сообщения. По изменению некоторых условий часть сообщений чистятся, т.е. оставляются пустыми. При трансфере в WinCC эти сообщения появляются в WinCC, но пустые. Причем те пустые, которые изначально не редактировались не переносятся. Если полностью из Message удалить объект WinCC и снова забить только те, что есть - то все нормально.
Есть ли возможность избежать трансфера пустых сообщений в WinCC кроме описанной выше?
Re: Трансфер сообщений в WinCC
Никаноров В. - Сименс, Москва; 24.10.00

Попробуйте делать трансфер с опцией "Clear operator station"

Re: Трансфер сообщений в WinCC
Соловьев Алексей; 24.10.00

Опция "Clear operator station" стоит всегда, проблема не в том, что остаются старые сообщения, а в том, что переносятся очищенные пустые. При создании сообщений в блоке Alarm_8P в текстовой базе Step7 под них выделяются строки, при удалении сообщений строки остаются, но пустые, и в таком виде переносятся в WinCC.

Сам себе отвечаю
Соловьев Алексей ; 28.10.00

Одна из возможностей: проставить класс сообщения <no message>, и сообщение вообще не будет переноситься.

Но долго это, когда уже много удалено.
Re: Сам себе отвечаю
Чистяков Дмитрий ОАО "СеверСталь"; 30.10.00

Вообщето с TRANSFERom проблем много у нас было.

Но все проблемы устранились сами собой, когда мы приобрели ProAgent for WinCC v5.0 (совместно с Pdiag v5.0).
Сразу и длина сообщений прошла без проблем и поля заполняются как надо. Если сообщений в вашем проекте много, то рекомендую закупить эту сладкую парочку.


text

Функции UserArchives
Андрей Миндрин; 12.10.00

Где можно узнать про функции UserArchives начинающимся с Tlg. Например, TlgUsArchOpen.

Для чего они служат? В документации и Help'е описания к ним нет.
Заранее благодарен.
Re: Функции UserArchives
Никаноров В. - Сименс, Москва; 13.10.00

Эти функции остались от старых версий WinCC для совместимости.

Если Вы делаете новый проект, то использовать функции типа Tlg..... не следует, так как это может привести к существенному снижению производительности.
Новые функции, которые описаны в документации, Help'е и Comprehensive Support, полностью заменяют старые функции.


text

OP396 - ? где найти описание и soft
Кривитченко Александр; 10.10.00

Буду очень признателен за любую информацию по

OP396.
Re: OP396 - ? где найти описание и soft
Никаноров В. - Сименс, Москва; 10.10.00

Это очень старая панель.

Имеется описание на английском объемом 1,38Мб в *.pdf. Могу выслать.
Софт к ней называется COM396 для программаторов PG635, 675, 685, 695, 730, 750.


text

Связь OP17-PP и CPU 943 (7UA22)
Ольштейн Эдуард; 22.9.00

Связал OP17-PP и двухпортовый CPU 6ES5 943-7UA22

через SI1. При загрузке CPU от программатора PG685
через свободный порт CPU SI2,OP и CPU связываются
нормально.После программирования EPROM (пробовал
375-1LA1(пр.номер 422) и 375-0LA15) программным файлом и загрузки CPU из EPROM соединение между CPU и OP не происходит.Периодически появляется сообщение 115-идет запуск AG(ПОСТРОЕНИЕ ЛОГИЧЕС-
КОЙ СВЯЗИ).Сравнение (Compare) программного файла
и ОЗУ CPU показывает,что они совпадают!!!
Кто знает,что это значит,пожалуйста сообщите.
Ольштейн Эдуард оАСУТП АО"Мечел".
Re: Связь OP17-PP и CPU 943 (7UA22)
Дедовец Павел; 25.9.00

Похоже у Вас поблемы с блоком данных ОР. Создайте в ОВ21,ОВ22 блок данных (с номером) для ОР (командой G DBXX) и скопируйте в него данные из шаблона (в EEPROMе).

Re: Осторжно DB в старых CPU943
Ольштейн Эдуард; 5.10.00

Спасибо Павлу Дедовцу за ответ. Ваше сообщение помогло мне обойти некорректность в работе CPU, невозможность изменить DB записанные в ОЗУ CPU943 из EPROM, которая мешала установлению связи между CPU и OP17.

В новых CPU943 ,покупки 2000 года, эта ошибка исправленна.


text

WinCC и Windows 2000
Александр Родин, ООО "Нева Электрик"; 28.9.00

Возникла очень серьезная проблема при работе с Global Script в среде Windows 2000. При попытке компилирования скриптов вылетает системная ошибка и Global Script рушится. По сути нет возможности добавлять свою динамику в объекты. Пробовали на разных машинах (по конфигурации) - везде одно и то же. Попробовали 5-ю версию WinCC, с надеждой, что может там эта проблема решена - аналогично. Что можете посоветовать ??.. Обратно ставить NT не хочется - слишком много софта уже установлено.

И еще один вопрос. По Tag Logging-у. В изготовленном проекте создано всего 5 архивов, причем только в одном из них около 40 переменных. Часть переменных пересчитывается с помощью скриптов и в архив записываются значения пересчетов. Некоторые переменные имеют синхронно-селективный способ записи (по событию). Скрипты не включают в себя операций циклов, работу с файлами и проч. Обыкновенные арифметические операции и опрос внешних тагов. Пока не было архивов загрузка процессора при работе Run Time составляла порядка 10%. Теперь же процессор грузится на 100%. Комплектация станции следующая: CPU - Intel Celeron 466MHz, RAM - 128Mb, HDD - 10Gb, Video - 16Mb AGP RIVA TNT2. Неужели Tag Logging такая ресурсоемкая функция ????.. Или может я что-то неправильно понимаю в его работе ??? Не могли бы указать ссылочку на информацию по оптимизации проектов.

Заранее спасибо
Re: WinCC и Windows 2000
Никаноров В. - Сименс, Москва; 29.9.00

1.WinCC и Win2000.

Работа WinCC под Win2000 будет разрешена, начиная с WinCC V5 SP2, которая выйдет в 4-ом квартале этого года. Пока же не все функции работают под Win2000. Используйте WinNT 4 SP5 или SP6.

2. Tag Logging
Сколько переменных в секунду должно архивироваться в среднем?
Данные по производительности и оптимизации приведены в Comprehensive Support и Customer Support
Re: WinCC и Windows 2000
А. Родин; 29.9.00

Те архивы, которые уже есть - это только десятая часть того, что должно быть. Предполагается архивировать порядка 100 параметров, причем в различных вариациях и с различной дискретностью.

В указанной документации даются лишь смутные советы по оптимизации ведения архивов. Будет ли более удачным решением прямое обращение к представителям Siemens, если да, то к кому конкретнее ?

Заранее спасибо
Re: WinCC и Windows 2000
Никаноров В. - Сименс, Москва; 29.9.00

В указанной документации даются конкретные ответы по производительности подсистемы архивирования.

Если что-то непонятно, обращайтесь ко мне.
Re: WinCC и Windows 2000
Чистяков Дмитрий ОАО "СеверСталь"; 4.10.00

Проблемы в Windows 2000 в основном связаны с пакетом разработки. Мы заметили, что не работает программирование акций в режиме C и Global Script. Но в качестве рабочей станции у нас проблем не возникало (пока), если не считать проблемой предупреждение при запуске Windows 2000.


text

Связь ОР17-РР с CPU943
Ольштейн Эдуард ; 22.9.00

Связал OP17-PP и двухпортовый CPU 6ES5 943-7UA22

через SI1. При загрузке CPU от программатора PG685 через свободный порт CPU SI2,OP и CPU связываются нормально.После программирования EPROM (пробовал 375-1LA1(пр.номер 422) и 375-0LA15) программным файлом и загрузки CPU из EPROM соединение между CPU и OP не происходит.Периодически появляется сообщение 115-идет запуск AG(ПОСТРОЕНИЕ ЛОГИЧЕСКОЙ СВЯЗИ).Сравнение (Compare) программного файла
и ОЗУ CPU показывает,что они совпадают!!!
Кто знает,что это значит,пожалуйста сообщите.
С CPU 944 таких проблем нет.
Ольштейн Эдуард оАСУТП АО"Мечел".


text

Связь с контроллером в STOPе
Дима Веткин; 15.9.00

При установке контроллера в стоп, wincc теряет с ним связь :(. А очень хотелось бы считать с контроллера что-нибудь в стопе, например, считать текущий режим, диагностический буфер. Ведь STEP7 это умеет!!!

Спасибо.
Re: Связь с контроллером в STOPе
Чистяков Дмитрий ОАО "СеверСталь"; 19.9.00

Можно воспользоваться финкциями AS OS Eng.

Но он требует Step 7. Там можно вообще показать программу Step 7 в кадре WinCC и посмотреть лбые параметры контроллера.
Re: Связь с контроллером в STOPе
Никаноров В. - Сименс, Москва; 19.9.00

Какой версией WinCC Вы пользуетесь?

Если 5-ой, то там можно выбрать, прерывать ли связь при останове контроллера, или нет. Это выбирается в настройках канала S7.
В 4-ой версии, насколько я помню, при останове контроллера значения переменных, тем не менее, считываются.


text

WinCC
VITEX, Коренькова И.; 24.3.00

Существует ли какой-либо свободно настраеваемый

драйвер связи WinCC для последовательного порта?

Re: WinCC
Чистяков Дмитрий ОАО "СеверСталь"; 6.9.00

Я так понимаю, Вы хотите связаться с каким нибудь советским контроллером типа Ломиконт, Ремиконт.

Так Вам будет проще создать свой канал WinCC при помощи пакета CDK WinCC.
Там есть примеры (заготовки, болванки ) исходников. И Ваша задача лишь вставить в соответствующие процедуры свои подпрограммки для реализации Вашего протокола.

Есть ещё два способа решить проблему:
1. Написать свой OPC Server.
2. Написать свой DDE Server.

В принципе и тот и другой не представляют собой сложных задач, так как есть хорошие описания, и даже на русском языке.


text

Сетевой NETDDE с Excel?
Симахин Александр; 31.8.00

При соединении WinCC с клиентом Excel по сети с помощью DDE канала данные приходят на первый лист таблицы. Как обмениваться данными с другими листами таблицы? Где и как указывать, какой именно лист нужен?

Заранее благодарен за помощь.

Re: Сетевой NETDDE с Excel?
Никаноров В. - Сименс, Москва; 31.8.00

Указывается это в поле Item настройки DDE переменной WinCC: что-то типа Лист2!R1C1.

Конкретный синтаксис зависит, к сожалению, от того, какой Excel Вы используете (версия и локализация).
Проще, если Вы поименуете ячейку Excel, тогда в WinCC можно в качестве Item задавать ее имя.


text

Библиотека graphics для PROTOOL
Брындин Павел; 28.8.00

Коллеги, не знаете ли где взять картинки для конфигурирования графических панелей, сверх того, что предлагается стандартно в PROTOOL.


text

Русские сообщения в Report Designer
Дмитрий Маслов; 21.8.00

Re: Русские сообщения в Report Designer
Никаноров В. - Сименс, Москва; 21.8.00

Попробуйте сделать поддержку кириллицы, как показано по этой ссылке.

Хотя смены шрифта обычно достаточно.

См. http://www.siemens.ru/ad/as/ru/forum/gen/forum.cgi?message=92


text

кабель для ОРе
Нагель Андрей; 21.8.00

Для связи преобразователя частоты Есо и панели управления ОРе используется трехметровый кабель. Этот кабель входит в комплект при заказе панели управления или заказывается отдельно?? Если отдельно, то какой заказной номер????

У панели управления ОРе есть только RS232 или еще и RS485??? Каким образом она подключается к преобразователю???
Ответы прошу направлять на email.
Заранее благодарен.


text

OP15C1 -> PROTOOL старая версия 2.11 не поддерживается
Dima; 19.8.00

уважаемые

каким образом можно работать с OP15C1 ежели PROTOOL не поддерживает версию 2.11(такая зашита в мою OP-шку )он гадюка так прям и пишет
не могу мол поддержать версию 2.11
а могу только начиная с 2.30
приходится мучится с древне Египедским COROS
он ужас какой неудобный
может существуют патчи для PROTOOL или если есть
пришлите дамп прошивки для OP15C1 пзу новой версии
буду безмерно благодарен


text

Во время установки Hotfix 2 возникает ошибка
Сергей М.; 18.8.00

Следующего содержания (индикатор прогресса 10%):

ComponentMoveData had the folowing error:
MediaName: MEDIA
Component:
File Group:
File:
Error Number: -132 (refer to the online help);
после чего установка прерывается.
Версия WinCC: R4.0.2.16 B482.18, OS: NT4SP6.
Как с этим бороться?
Заранее спасибо.


text

TP170a & system limits
Денис Галягин; 15.8.00

Для панели оператора TP170A прочитал системные ограничения (help для ProTool v.5.2):

tags ----- 100
tags per screen -- 20
..... и т.д.

В проекте ввёл 110 тэгов (INT) на одном screen'е...
При компиляции ProTool предупредил что превышено максимальное количество тэгов. Загрузил в панель... все работает...

Может кто-нибудь ответит с чем связаны системные ограничения?
На что они влияют? и т.д.
можно по e-mailу.

заранее спасибо,
с уважением Денис.

Re: TP170a & system limits
Никаноров В. - Сименс, Москва; 17.8.00


text

Проблема с User Archives
Андрей; 3.8.00

В Graphics Designer не работает кнопка

General->Source->Select свойства объекта User Archive - Table Element, хотя архив создан. Система : NT4.0, WinCC 5.0 Hotfix 4.
В чем может быть проблема?
Заранее благодарен.
Re: Проблема с User Archives
Никаноров В. - Сименс, Москва; 15.8.00

Попробуйте следующее:

Запустите "CCClientAPIs.exe" файл из директории WinCC с ключем "/Regserver" из командной строки.


text

Неприятности с Tag Logging в WinCC 5.0
Штепа С.А.; 11.8.00

После создания архива в редакторе Tag Logging, при запуске этого редактора появилось окно сообщения с заголовком "TlgCS" и текстом "Tag Logging CS is already started on another computer. Computer name:", после чего он перешел в режим защиты от записи. Из-за этого невозможно продолжать работу над проектом. Помогите !!!

Re: Неприятности с Tag Logging в WinCC 5.0
Никаноров В. - Сименс, Москва; 14.8.00

Попробуйте удалить файл "TLGCS.log" или "TLGRT.log" из директории проекта.


text

protool V5.10 and win2000
Sergey; 29.3.00

Не хочет ставиться под Win 2000 (сборка 2195)

Пишет что не та ОП. Может кто подскажет, какую строчку прописать в os.dat?

Re: protool V5.10 and win2000
Eugene; 13.8.00

Поставь сперва Windows NT, потом STEP7, Protool.

Затем обнови до Win2K.
Или подожди до конца года, пока SIEMENS сертифицирует свое ПО под Win2K.


text

Архивирование максимальных значений тегов
Клейн Александр; 8.8.00

При создании архива в TagLogging указывается какое значение тега заносить в архив: actual, mean, sum, maximum, minimum и т.д. Если выбрать значения actual или mean, то все работает нормально, если же выбрать maximum, то в архив заносятся нулевые значения, не смотря на то, что значения тега отлично от нуля. Может тут ошибка какая-то?

(WinCC4.02.16, WinNT 4.0)


text

OP15
Бородаенко; 17.4.00

Нужно линк на доку по OP15 на русском языке.

Re: OP15
Павел Иванов (Сименс-Москва); 7.8.00

Вы можете обратиться к нашему сотруднику, который постоянно находиться в Тольяти (у Вас на АвтоВАЗе):

Матвеев Дмитрий Викторович
siemens@tlt.volga.ru


text

COROS 2000
Кочин Алексей; 25.7.00

Ваше сообщение...Система визуализации COROS 2000

работающая с MMC216,не понятным причинам перестала загружаться с винчестера .Проявляется это следующим образом,при загрузке на дисплее следующие сообщения :
eeprom ok!
check sum 179B H ok!
И с интервалом 10 сек.все повторяется вновь......
Не запускается с винчестера и не грузится с системной дискеты.Версия V4.2. Операционная система RMX!!!!!
Как оживить - подскажите.
Re: COROS 2000
Павел Иванов (Сименс-Москва); 25.7.00

К сожалению у нас в Москве нет специалиста знающего COROS 2000 (она была снята с производства как минимум 10 лет назад).

Поэтому по данному вопросу лучше обратиться в центральный Hotline в Германии, в котором есть соответствующие специалисты. Вы можете им написать факс или E-mail на английском или немецком языке. Адрес E-Mail:
simatic.support@nbgm.siemens.de


text

WinCC - S7 400
Igor; 22.7.00

Как в WinCC отобразить режим работы PLC (RUN, STOP), состояние LTD's, ошибки ?

C уважением, Igor.


text

сообщения в ALARM LOGGING
Константин Сенин ОАО"СеверСталь"; 19.7.00

Добрый день!

Мы заметили разницу в работе различных версий пакета WinCC ver4.02 и ver 5.0.
Это заключается в следующем:
Мы использовали генерацию сообщения в ALARM LOGGING по изменению тега.
В версии 4.02 сообщение появлялось по фронту (из «0» в «1»), а если в свойствах сообщения установить галочку «is created on a negative edge», то сообщение появляется по отрицательному фронту (из «1» в «0»). И это нас вполне устраивает.
А в версии 5.0 сообщение появляется и по тому фронту и по другому, и это не зависит от галочки.

Вопрос как решить эту проблему? Нам хотелось бы, что бы появлялось одно сообщение по положительному фронту (0->1), а по отрицательному фронту (1->0) ни чего не появлялось.

С уважением, Константин Сенин.

См. http://www.stal.ru


text

WinCC 4.02
Кабанов И.В.; 14.7.00

Почему команда SetTag...()возвращает TRUE

(даже, когда указывается не существующий тег или
нет связи с PLC)?
Спасибо.
Re: WinCC 4.02
Макс; 17.7.00

Потому что данные в канал отправлены, а анализом результата никто не занимается. Используй функцию SetTagState(...)

Re: WinCC 4.02
Кабанов И.В., AVTOVAZ; 18.7.00

Я так и делаю, анализируя 0 бит статусного флага,

для контроля связи. Но когда же он (SetTagByte()
на прим.) возвращает FALSE, описанный в Helpe?
Спасибо.


text

WinCC 4.02
Кабанов И.В.; 14.7.00

Почему свойство графического объекта Transpfrent в Graphics Designer работает нестабильно на разных

РС и под разными ОС (93/NT)?
Спасибо.


text

Стек WinCC
Аксельрод В.Ю.; 7.7.00

Ваше сообщение...Какой размер стека устанавливается при выполнении проекта WinCC в режиме RunTime. Если есть возможность его увеличить, то как.

Re: Стек WinCC
Никаноров В. - Сименс, Москва; 12.7.00

Какой именно стек Вы имеете ввиду, и зачем Вам это нужно?


text

Кириллица в новой TD200
Александр Бобков; 5.7.00

Как "добраться" до русского языка в новой TD-200

6ES7272-0AA20-0YA0?

Re: Кириллица в новой TD200
Андрей Гуленок; 7.7.00

Очень просто. В STEP-7micro V3.1, в TD-200 ассистенте надо выставить в окошке дополнительных знакогенераторов кириллицу. Дальше всё просто, до тех пор, пока не начнёшь писать собственно текст сообщения. В окошечках будет всякая аброкадабра, но когда блок данных будет сформирован, там будут русские буквы. Можно отредактировать непосредственно блок данных, там русские слова читаются очень наглядно.


text

Как работать с Function Trend ?
Занчевский Ю.В. - ООО ; 19.6.00

В WinCC 5.0 - появился новый Control - Function Trend. В предидущих версиях WinCC массив данных можно было вывести на график с пом.ф-ции TLGSetTemplate(). Как тоже самое сделать в 5 версии ? Возможно для этого и служит Function Trend ?


text

Как вывести свой массив на график в WinCC5.0
Занчевский Ю.В. ООО"АСК"; 19.6.00

В WinCC 5.0 - появился новый Control - Function Trend. В предидущих версиях WinCC массив данных можно было вывести на график с пом.ф-ции TLGSetTemplate(). Как тоже самое сделать в 5 версии ? Возможно для этого и служит Function Trend ?


text

Как редактировать "Выбор времени" в Report Designer?
Максим Елхов; 24.2.00

Вопрос в следующем - хочет юзер распечатать данные из TagLOG или, скажем, AlarmLOG. И приходится заходить в Report Designer и там в свойствах динамической таблицы ручками ставить. А как этот же диалог привязать к кнопочке в Graphics Designer?

Изменение свойств PrintJob с помощью ODK
Никаноров В. - Сименс, Москва; 29.2.00

Если я правильно понял, то речь идет о динамическом выборе диапазона времени для отчета из Runtime.

Это можно сделать, применяя функции ODK для изменения свойств PrintJob's.
Порядок примерно следующий.

1. Задание даты\времени через поля ввода\вывода.

SYSTEMTIME TimeFrom()
{
static SYSTEMTIME st;

st.wYear = GetTagWord("U16i_ex_rep_f1");
st.wMonth = GetTagWord("U16i_ex_rep_f2");
st.wDay = GetTagWord("U16i_ex_rep_f3");
st.wHour = GetTagWord("U16i_ex_rep_f4");
st.wMinute = GetTagWord("U16i_ex_rep_f5");
st.wSecond = GetTagWord("U16i_ex_rep_f6");
return st;
}

SYSTEMTIME TimeTo()
{
static SYSTEMTIME st;

st.wYear = GetTagWord("U16i_ex_rep_t1");
st.wMonth = GetTagWord("U16i_ex_rep_t2");
st.wDay = GetTagWord("U16i_ex_rep_t3");
st.wHour = GetTagWord("U16i_ex_rep_t4");
st.wMinute = GetTagWord("U16i_ex_rep_t5");
st.wSecond = GetTagWord("U16i_ex_rep_t6");
return st;
}

2. Изменение свойств PrintJob'а. Это универсальная функция изменения свойств любого joba.

BOOL ModifyPrintJob(SYSTEMTIME st1,SYSTEMTIME st2,char jobname[200])
{
BOOL fRet;
PCMN_ERROR pError;
HPROPERTIES hProp;
LPVOID ptr1,ptr2;
DWORD typ;
DWORD dwVal;
char propname1[200],propname2[200];
char buffer[200];
TCHAR g_szProj[MAX_PATH+1];

typ = VT_DATE;
strcpy( propname1, "ABSOLUTESELECTIONFROM");
strcpy( propname2, "ABSOLUTESELECTIONTO");
ptr1 = (LPVOID)&st1;
ptr2 = (LPVOID)&st2;

//-----get project path
if( !DMGetRuntimeProject( g_szProj, MAX_PATH, pError))
{
printf("Error DMGetRuntimeProject(...)\r\n");
return FALSE;
}

//-----create property handle
hProp = RPJCreatePropertyHandle ( g_szProj, pError );
if( !hProp)
{
printf("Error RPJCreatePropertyHandle(...)\r\n");
return FALSE;
}

//-----get job properties
if ( !RPJGetJobProps ( hProp, jobname, pError ))
{
printf("Error RPJGetProps(...)\r\n");
RPJDeletePropertyHandle ( hProp, pError);
return FALSE;
}

//-----set property
if ( !RPJSetProperty ( hProp, propname1, ptr1, (VARTYPE) typ, 200, pError ))
{
printf("Error RPJSetProperty(...)\r\n");
RPJDeletePropertyHandle ( hProp, pError);
return FALSE;
}

//-----save job properties
if ( !RPJSetJobProps ( hProp, jobname, pError))
{
printf("Error RPJSetProps(...)\r\n");
RPJDeletePropertyHandle ( hProp, pError);
return FALSE;
}

//-----get job properties
if ( !RPJGetJobProps ( hProp, jobname, pError ))
{
printf("Error RPJGetProps(...)\r\n");
RPJDeletePropertyHandle ( hProp, pError);
return FALSE;
}

//-----set property
if ( !RPJSetProperty ( hProp, propname2, ptr2, (VARTYPE) typ, 200, pError ))
{
printf("Error RPJSetProperty(...)\r\n");
RPJDeletePropertyHandle ( hProp, pError);
return FALSE;
}

//-----save job properties
if ( !RPJSetJobProps ( hProp, jobname, pError))
{
printf("Error RPJSetProps(...)\r\n");
RPJDeletePropertyHandle ( hProp, pError);
return FALSE;
}

//-----delete property handle
fRet = RPJDeletePropertyHandle ( hProp, pError);

//-----print out written time settings
printf("\r\nJob : %s ;\r\n\r\n",jobname);

printf("Prop: %s ;\r\n",propname1);
printf("%d.%d.%d %d:%d:%d\r\n",(WORD)st1.wDay, (WORD)st1.wMonth, (WORD)st1.wYear,
(WORD)st1.wHour, (WORD)st1.wMinute, (WORD)st1.wSecond );
printf("Prop: %s ;\r\n",propname2);
printf("%d.%d.%d %d:%d:%d\r\n",(WORD)st2.wDay, (WORD)st2.wMonth, (WORD)st2.wYear,
(WORD)st2.wHour, (WORD)st2.wMinute, (WORD)st2.wSecond );

return TRUE;

}

3. Теперь можно по кнопке в GraphicDesigner вызвать эту функцию.

ModifyPrintJob(TimeFrom(),TimeTo(),"Указатель на имя printjob");

4. Эти функции работают в WinCC V4.x-V5.0

Re: Изменение свойств PrintJob с помощью ODK
Максим Елхов; 13.6.00

При всем вышесказанном важно не забыть сделать две вещи

1. Отключить выбор времени в свойствах динамических объектов в Report Designer
2. Включить Absolute Time Select в свойствах Print Job


text

ключевые дискеты
Леонид М.; 8.6.00

Утеряны ключевые дискеты от WinCC.

Где и как их можно поиметь?

Re: ключевые дискеты
Никаноров В. - Сименс, Москва; 13.6.00

Если пакет официально покупался, то Вы имеете возможность восстановить дискеты, заполнив и отослав соответствующую форму, которая находится как на авторизационных дискетах, так и на CD.


text

coros OP15 /c1
Papik; 7.6.00

ребята помогите связать панель op15 -( S5 )

с IBM на ней есть 15 штыревой разьем (PG/PRINT)
но TTY переходник которым я конекчюсь с контроллерами
не подходит . А связываю я ее c COROS COMTEXT
пришлите кто небуд распайку или может кто самопальный делал
Re: coros OP15 /c1
Чистяков Дмитрий ОАО "СеверСталь"; 8.6.00

Все вопросы по подключению различных OP можно найти в разделе SIMATIC HMI / SIMATIC Panels / TD/OP Cables

На сраницах поддержки пользователей (Customer Support) по адресу

http://www4.ad.siemens.de/infocs/livelink.exe?func=cslib.csinfo&objId=2651&objAction=csBrowse&lang=en&aktprim=0&siteid=cs

там же можно найти всю бесплатную документацию на продукцию Siemens. Включая и OP15.

Re: coros OP15 /c1(продолжение)
Чистяков Дмитрий ОАО "СеверСталь"; 8.6.00

Вот по SIMATIC Customer Support - Newsletter 06.08.00 пришёл адресок на эту тему

Re: coros OP15 /c1(продолжение)
Чистяков Дмитрий ОАО "СеверСталь"; 8.6.00

Извиняюсь!

Сообщение:

############################################################
>>> SIMATIC HMI / SIMATIC Panels / TD/OP Cables
############################################################

>> [FAQ]: Power supply connection of OP`s/PG`s, network
>> components for MPI and PROFIBUS (06/06/2000) [1070096]
>> Update
-
- Which connectors and cables do I need to connect an OP/PG
- to an S7 controller? Is there a standard cable? You can
- connect PROFIBUS and MPI networks via an RS485, so the
-
==>> http://www4.ad.siemens.de/supportnews/cs/en/1070096

А вообще рекомендую подписаться.
Можно будет получать свежую информацию, как по софту, так и по железу.

Re: coros OP15 /c1
Дедовец Павел; 12.6.00

Пару наводящих вопросов.

1) Порт IBM машины к которому Вы подключаетесь PG кабелем имеет токовый или потенциальный выход?
2) Переподит панель в режим связи с COM TEXT или нет? (что на индикаторе)
3) Что именно в TTY переходнике не подходит.

Если получится ответить на эти вопросы то и со связью особых проблем не должно быть. (при отсутствии аппаратной неисправности конечно)


text

HOTFIX 2 for WinCC V 4.02_SP1
Евгений Артамошин; 6.6.00

Попытки установить несколько раз закачанный мной

HOTFIX 2 for WinCC V 4.02_SP1 с урла http://www.siemens.ru/ad/as/ru/info/hotfix2/disk1.exe
При попытке установки приводят к сообщению
"data5.cab broken archive...."

Пришлите пожалуйста по эл. почте.

WINCC ver. R 4.02.16 B 482.18


text

Доступ к базам из GlobalScript.
Занчевский Ю.В., ООО"АСК" ; 30.5.00

Как с помощью С-функций из WinCC доставать данные из баз данных(например DBase III)?

Re: Доступ к базам из GlobalScript.
Перцев Александр; 30.5.00

Для работы с Sybase можно использовать функции из ODK.

Для этого в скрипте нужно включить одну DLL
(она уже есть в bin директории)
#pragma code("db.dll")
#include "db.h"
#pragma code()
После этого можно подсоединяться к базе, получать данные,
делать вставку и т.д. Функции описаны в разделе Database functions.
Для dBase III тоже есть своя dll (dbase.dll), однако, описание прототипов
её функций я не встречал. Для работы с Oracle WinCC не предлагает
никакого API. Существует возможность подключения через шлюз
(Transparent Gateway Interface). Кроме того можно самому написать
dll на MS Visual C++ или Delphi для работы с любой БД.

Re: Доступ к базам из GlobalScript.
Перцев Александр; 31.5.00

Забыл упомянуть, что для работы с базами данных для WinCC

существуют Add-ons. Например, DBExt - dll, которая по описанию
позволяет осуществлять доступ к любой БД из WinCC-скриптов.
PM ODBC ещё одно дополнение к WinCC для доступа к БД.
Естественно, эти дополнения распространяются не бесплатно.

Re: Доступ к базам из GlobalScript.
Никаноров В. - Сименс, Москва; 31.5.00

С помощью ODK функций можно также непосредственно выполнять SQL инструкции.

См.ODK help.
По поводу ORACLE и прочих
Чистяков Дмитрий ОАО "СеверСталь"; 3.6.00

http://www.ad.siemens.de/sw-haus/html_00/software.htm

на страничке даны адреса специалистов. которые ответят на вашы вопросы
Re: По поводу ORACLE и прочих
Чистяков Дмитрий ОАО "СеверСталь"; 3.6.00

http://www.ad.siemens.de/hmi/html_76/addons/wcc_addon_profil_ixodbc.htm

А вот ещё конкретнее по этому вопросу. Существует WinCC Add-Ons под названием IXODBC, котрый собственно и предназначен для связи с системами типа Oracle, Sybase, SQL-Server. Но через ODBC.


text

Доступ к базам из GlobalScript.
Занчевский Ю.В., ООО; 30.5.00

Как с помощью С-функций из WinCC доставать данные из баз данных(например DBase III)?

Re: Доступ к базам из GlobalScript.
Никаноров В. - Сименс, Москва; 31.5.00

пишите в соответствующий раздел


text

OP 27 BACKUP
Петр , PEPSI-Спб; 30.5.00

Ваше сообщение...

Скажите пожалуйста можно ли зарезервировать информацию или "выкачать" её из операционной графической панели OP 27? В Protool 5 этой функции я не нашел.
Re: OP 27 BACKUP
Никаноров В. - Сименс, Москва; 30.5.00

1. Существует бесплатная программа ProSave, которая позволяет считать скомпилированную программу панелей в файл. Этот файл может использоваться только в Buckup целях, т.е. для последующей загрузки его в панель (но не для редактирования).

Эта программа находится на дисках Protool. В случае необходимости можем также ее выслать.
2. Возможность Upload имеется только у новых панелей на базе Windows CE: MP270, MP370.
Re: OP 27 BACKUP
Петр, PEPSI C.Петербург.; 31.5.00

Ваше сообщение...

Большое спасибо за консультацию!


text

Версия Simatic NET и WinCC v5.0
Андрей; 18.5.00

Будет ли работать протокол FDL в WinCC v5.0 с драйвером Prifibus DP5412 for Windows NT v4.2 или необходима версия 5 этого драйвера?

Re: Версия Simatic NET и WinCC v5.0
Никаноров В. - Сименс, Москва; 19.5.00

Работать, может быть, и будет.

Но общее правило по совместимости драйверов с WinCC: необходимо, чтобы версии драйверов совпадали с версией WinCC.
Сейчас актуальная версия драйверов: V5.2
Могу выслать по email (6 дискет).

Re: Версия Simatic NET и WinCC v5.0
Андрей; 21.5.00

Буду очень признателен, если вышлите.


text

Storage
Максим Поджидаев; 17.5.00

Здравствуйте Господа!

Не встречался ли кто нибудь из вас со следующей проблемой:
На станции WinCC производится запись последовательных архивов. Подчистка данных старше 5 суток производится с помощью опцииональной службы Storage. Режим запуска периодический, 1 раз в час. Экспорт данных не производится за ненадобностью. Иногда Storage самопроизвольно отключается. После принудительного старта подчистки за время простоя не происходит, что ведет к необратимому росту базы данных. Буду рад если кто нибудь поможет советом.


text

Как архивировать кадры сообщений в TagLoggin с S7-400
Занчевский Юрий; 17.5.00

Обьясните пожалуйста как архивировать кадры сообщений в TagLoggin с S7-400. Если можно - с примерами.


text

Где взять SP к WinCC V4.02
Занчевский Юрий; 17.5.00

Где можно достать SP1 к WinCC V4.02

Re: Где взять SP к WinCC V4.02
Марамыгин Вячеслав; 17.5.00

Здравствуте Юрий!

Обратитесь в "Siemens-Buro" в родном городе Екатеринбурге и мы запишем нужный Вам софт.


text

WinCC
Михаил; 17.5.00

Можно ли создать систему из нескольких расходомеров типа SITRANS F или SITRANS FM, соединенных по PROFIBUS через DP/PA Link с рабочей станцией на которой установлена WinCC4.02, не используя контроллер или WinAC.

Если можно, то что для этого необходимо?(драйвер WinCC, какое-то ПО для датчиков с которым WinCC сможет обмениваться данными по DDE или OPC.)


text

Связь WinCC сразу с двумя СР через один CPU
Занчевского Юрия; 13.4.00

Как организовать чтение-запись данных в память контроллера из РС с помощью програмных средств WinCC по Ethernet через один CPU с двумя CP 414-2 в одном каркассе


text

TagLogging - Архивирование кадров сообщений
Юра Занчевский; 13.4.00

Как производить архивирование кадров сообщений с Simatic S7 в TagLogging архивах? Какой должен быть формат данных от S7?


text

DLL
Аксельрод В.Ю.; 10.4.00

Ваше сообщение...Как собрать DLL функций, которые в свою очередь вызывают "GetTag"

Re: DLL
Перцев А.С.; 10.4.00

Если Вы пишите DLL, функции которой должны устанавливать или считывать

значения некоторых тегов из WinCC, то GetTag и SetTag для этого не подходят,
так как они внутренние. Нужно воспользоваться API для Data Manager,
который описан в ODK. По сути Вам потребуются DMGetValue и
DMSetValue. Если DLL вызываются не внутри WinCC необходимо
присоединятся к Data Manager. Для этого есть функция DMConnect.
Необходимые headers и libraries для Data Manager следующие:
OHIOAPI.H
DMDEFS.H
DMCLIENT.lib
DMCLIENT.h
License.h


text

Упала база данных :(((
Максим Елхов; 2.4.00

На системе Celeron366/32Mb WinNT4.0WS WinnCC4.02 при эксплуатации пропала связь с базой данных TLG. При перезагрузке связь не восстанавливается. Графика работает, работу оборудования в RT кажет, но при попытке получить информацию из TLG - пустой экран. Можно ли восстановить потерянные данные? И что делать :(((

P.S. Памяти, конечно, маловато - но работай медленно, падать то зачем :)
Re: Упала база данных :(((
Никаноров В. - Сименс, Москва; 6.4.00

Такое я еще не наблюдал.

Вряд ли база данных упала.
Часто бывает, что задано неправильное имя компьютера в сети. Это имя не должно использовать специальных символов и не должно превышать 14 знаков.
Если дело не в этом, то можно использовать утилиты к базе данных. Можно выгрузить RUntime данные, а затем загрузить снова или в новую базу (см.WinCC Help).
Можно также проверить базу данных на целостность.


text

Поддерживает ли WinCC отечественных производителей?
ВИТЭКС; 25.3.00

Не писал ли кто драйвер для WinCC для отечественных контроллеров Ломиконт Л-110. Это необходимо для постепенного перехода Заказчика с Ломиконтов на Simatic S7.

Может быть, есть OPC сервер для Ломиконтов???
Никаноров В. - Сименс, Москва; 31.3.00

Если кто знает, есть ли OPC или DDE сервер для Ломиконт'ов, то большая просьба сообщить.

Re: Поддерживает ли WinCC отечественных производителей?
Максим Елхов; 2.4.00

Иногда отечественные производители поддерживают продукты Сименса. Так, например, контроллер АвтоВАЗ С-300 имеет поддержку протокола 3964R ;)


text

WinCC и S7-400 CPU417
Чистяков Дмитрий "СеверСталь"; 27.3.00

Здравствуйте, господа!

Унас возникла не большая проблема с WinCC 4.02.
А заключается она в следующем:
Мы используем в своём проекте контроллер S7-400 с CPU 417, максимальное
адресное пространство которого составляет 16К входов/выходов. Мы пытаемся
создать тэг в WinCC с привязкой к сигналу более 511 (например, i560.0) и
WinCC говорит, что адрес ошибочный.
Вопрос, как обойти данную проблему. Мы пока конечно можем все адреса
перекидывать в DB , а затем подвязывать к нему тэги, но хотелось бы всё
делать на прямую.

Мы так же закупаем WinCC 5.0 - имеется ли эта проблема в новом пакете или
она устранена.

С уважением, Чистяков Дмитрий.

Re: WinCC и S7-400 CPU417
Чистяков Дмитрий "СеверСталь"; 29.3.00

Отвечаю сам себе. Ну и может кому будет тоже интересно.

WinCC 4.02 работает, только с адресами до 511.
WinCC 5.0 поддерживает все два байта адресации.


text

Farbmonitor 51cm, тех. документация
Герасимов И.; 28.3.00

Ваше сообщение...

Господа,
необходима техническая документация на монитор
6AV8011-1JE22-ODAO
51cm, color.
При подключении к стандартному PC(WinCC)происходит сильное смещение растра вниз.
Регулировка в блоках развёртак ничего не даёт.


text

Звуковая сигнализация в WinCC
Максима; 14.3.00

Как организовать непрерывную звуковую сигнализацию в WinCC по аварийному значению(состоянию)тега(аналогового и дискретного)через обычную звуковую карту (типа SB). Звуковой сигнал должен сниматься по квитированию.

Если возможно, пожалуйста, пришлите примеры.
Re: Звуковая сигнализация в WinCC
Никаноров В. - Сименс, Москва; 14.3.00

1. Скрипт проигрывания *.wav файла.

#pragma code ("Winmm.dll ")
VOID WINAPI PlaySoundA ( char* pszSound, char* hmode, DWORD dwflag );
#pragma code()

PlaySoundA("C:\\Winnt.400\\Media\\tada.wav",NULL,1);

2. Параметры.
Parameter DWORD dwflag.
SND_SYNC = 0x0000: sound file is played once and the Script waits until it has finished.
SND_ASYNC = 0x0001: sound file is played once and the Script is processed in parallel.
SND_NODEFAULT = 0x0002: if sound file cannot be found, then not a default value is played, but nothing at all.
SND_LOOP = 0x0008: repeats the sound file until the next PlaySoundA call comes (only possible with 0x0001) => always define 0x0009.

You can also combine these parameters through bit by bit ORs (e.g.: SND_ASYNC | SND_LOOP)

3. Фиксация события.
Может быть использована стандартная функция GMsgFunction(...), которая вызывается автоматически при инициации сообщения, у которого установлен флажек "Trigger an action".
В этой функции есть фрагмент кода, который определяет параметры пришедшего сообщения (в том числе параметры квитирования).


text

Simatic S7, HMI
Darius Stonkus; 29.2.00

MPI сеть с радио модемами и ТС адаптерами к WinCC.

Возможно ли подключитъ несколъко отдоленных S7 PLC к WinCC използуя MPI протокол.
Re: Simatic S7, HMI
Никаноров В. - Сименс, Москва; 1.3.00

Существует протестированное решение:

PLC(MPI)-TeleServise - Modem-WinCC.


text

CDK - проблема с созданием канала
Александр Савченко; 25.2.00

Господа!

Нет ли у кого исходника какого-нибудь (любого) канала для
WinCC Channel Development Kit с прилагающемся к нему описанием
или хотя-бы краткими комментариями внутри исходника на английском,
а не на немецком как в стандартной поставке примера в пакете CDK?
Пытаюсь разобраться со структурой и написанием таких каналов.

---
И еще: если не трудно, то неплохо бы, чтобы этот канал работал
с контроллером через последовательный (COM) порт :)

Просьба выслать на Sumbura@mail.ru

Re: CDK - проблема с созданием канала
vzozulja; 28.2.00

Я в свое время не стал подкидываться с CDK, а написал маленький DDE-сервер (работающий в т.ч. с COM-портом).

Re: CDK - проблема с созданием канала
Никаноров В. -Сименс, Москва; 1.3.00

В CDK есть исходники, например MODBUS CHANNEL.


text

Связь Protool (OP) с Simatic S5 через FAP
vzozulja; 15.2.00

Есть у кого живой пример? Проблема с подключением.

И так пробовал и этак (в т.ч. и по AS511). То ли IF1A дохлый ( но внутренний тест OP25 проходит), то ли программа кривая.
Сейчас пробую сквозь PPI|RS232 преобразователь с соответствующей разводкой концов (на панели 232 - на PLC135U IF2 с TTY модулем)
Re: Связь Protool (OP) с Simatic S5 через FAP
vzozulja; 17.2.00

1й Вопрос снят. Примеры есть в protool 4.0 (но не в 5.0).

2.А подключался ли кто сквозь TTY|RS323 convertor?

Re: Связь Protool (OP) с Simatic S5 через FAP
vzozulja; 28.2.00


text

Принтер
Гусаков Константин; 26.2.00

Необходимо подключить к операционной панели цветной принтер.

Какой принтер можно подсоединить. и можно ли использовать autoswitch для переключения между двумя панелями?


text

Потеря привязки к тегам в Alarm Logging
Дмитрий Молодцов; 15.2.00

В многопользовательском проекте создано несколько тысяч тревог. Эти тревоги привязаны только к внутренним тегам. В проекте кончно же есть и внешние теги. В один непрекрасный момент в очередной раз открыв проект обнаруживаем что привязки к тегам в тревогах частично или полностью исчезли. Слава богу что мы сохранили перед этим тревоги в файлах и сумели относительно быстро восстановить. Через некоторое время ситуация повторилась. У нас есть подозрение что проблема возникает когда мы начинаем создавать/удалять внешние теги. Однако как было сказано выше, внешние теги в тревогах не используются. В чем дело и как нам избежать этих проблем?

Re: Потеря привязки к тегам в Alarm Logging
Никаноров - Сименс; 15.2.00

Такого пока ни у кого не наблюдалось.

По крайней мере, мне неизвестно.
Напишите более подробно, что Вы делаете, какая у Вас конфигурация, версия WInCC, версия Win и т.п.
Re: Потеря привязки к тегам в Alarm Logging
Дмитрий Молодцов; 15.2.00

WinСС 4.02 c бесплатного диска, HotFix 2.

1 сервер (NT Server 4.0 SP6), 5-6 клиентов (NT Workstation RUS SP5).
В проекте около 1000 внешних и около 30000 внутренних тегов. Около 20000 тревог.
Около 300 пользовательских архивов. Пока проект реализован гдето на 70% поэтому все перечисленные значения увеличатся. В связи с большим объемом
обрабатываемой информации, над проектом работают одновременно несколько человек. Делают они это с рабочих станций. Сервер - выделенный. Когда был этап активного создания тегов, один раз возникла проблемы потери тегов. Теги попали в несуществующие группы. Правда было такое 1 раз и успешно исправили ISQL-ем. Теперь вот всплыла эта проблема. Могу только строить догатки о том как устроена внутри WinCC привязка тревог к тегам. Но факт остается фактом - после того как мы создали и привязали тревоги, манипуляции над тегами (думаю не только внешними)не участвующими в тревогах, приводят к потере привязок. Будем благодарны если поможете решить проблему.
Re: Потеря привязки к тегам в Alarm Logging
vzozulja; 15.2.00

Знаю эту проблему.

1.Некстати,но Hotfix2 ставится на WinCC 4.02SP1, а на халявном диске версия без SP.
2.Проблема возникает при экспорте переменных из STEP7 AS-OS engineering'ом. Проэкспериментируй, снимая флаги "Clear operatos stn's" и "Changes only" вместо "All"


text

Связь ProTool/Pro c S5 через PROFIBUS
Андрей Миндрин; 13.2.00

Конфигурация: S5 944, CP5431, СP5412(A2), PC.

Возможно ли связать ProTool/Pro v 5.10 c _S5_ через _PROFIBUS_? Если да, то что для этого надо дополнительно? В нескольких найденных источниках информация по этому поводу различается. Кто сталкивался с подобным решением поделитесь опытом. В долгу не останусь.
Заранее благодарен.
Re: Связь ProTool/Pro c S5 через PROFIBUS
Никаноров - Сименс; 15.2.00

Через Cp5412 разрешены коммуникации Protool/Pro только с контроллерами S7.

Но попробовать можно, только без гарантии работы.
Для этого Вам нужны дополнительно драйверы для 5412: DP-5412/Winxx.
А, также, функциональный блок, который идет вместе с Protool.
И COM5431 для проектирования CP5431 и STEP5 для CPU944.
Re: Связь ProTool/Pro c S5 через PROFIBUS
Андрей Миндрин; 15.2.00

Спасибо за ответ, но то что вы написали пробовалось. Функциональные блоки загрузили в CPU944, CP5431 отконфигурировали. Связи нет, ProTool даже не пытается обратиться к драйверу

DP-5412. В то же время связь с S7 устанавливается без проблем. Всвязи с этим вопрос: возможно ли в
принципе установить связь с S5 через Profibus, чтобы наверняка работала и какая конфигурация необходима (проверенный вариант)?
Re: Связь ProTool/Pro c S5 через PROFIBUS
Никаноров - Сименс; 15.2.00

Связь Protool\Pro с Simatic S5 через Profibus-DP можно установить только через CP5611, CP5511(не для Win98).(проверенный вариант).

Используйте WinCC для CP5412 (проверенный вариант).
Re: Связь ProTool/Pro c S5 через PROFIBUS
Никаноров - Сименс; 15.2.00

Еще один вариант:

поставить OPC сервер поверх DP-5412 и связывать Protool/Pro V5.2 через OPC (непроверенный вариант).


text

CDK, RawTag
Дмитрий Молодцов; 15.2.00

Функция GetTagRaw имеет 3-й параметр - длину буфера.

Данная функция вызывает внутреннюю функцию ChnStartRead.
Этой функции передается указатель на массив структур VariableStruct.
В структуре есть поле AsDataSize. Казалось бы именно это поле
WinCC долежн заполнить 3-м параметром функции GetTagRaw.
Однако этого не происходит. Где тогда используется и для
чего нужен третий параметр GetTagRaw?


text

DELPHI клиент
shurik; 12.2.00

Кто-нить делал собственное клиентское приложение (например на DELPHI) для вытягивания данных из базы Wincc - поделитесь опытом - у меня какая-то ерунда при открытии базы идет сообщение типа DATABASE INDEX FILE CORRUPT и усе

Re: DELPHI клиент
Sergey; 14.2.00

У меня ни каких проблем ни в DELPHI 4 ни в 5 не было. Я построил на на них систему отчетов для WinCC. WinCC создает ODBC alias по которому я работаю в Delphi через компанент DataBase для удобства свойство LoginPromt устанавливаю в False.

Далее можно работать с TTABLE но удобнее через SQL.
клиент Sybase
Перцев Александр; 14.2.00

На Visual C++ 5.0 такой опыт есть. Здесь всё просто, создаётся класс на базе

СRecordset, и передаётся connection string: например "ODBC;DSN=CC_trend_99-07-29_16:10:06R".
или "ODBC;UID=dba;PWD=sql;DSN=CC_trend_99-07-29_16:10:06R".
Вообще рекомендую читать SQL Anywhere User's Guide. Его можно посмотреть
запустив утилитку ISQL. По поводу возникшей ошибки "Database index file corrupt..." ,
посмотрите в том же Guide: CHAPTER 43. Watcom-SQL Statements.VALIDATE TABLE statement.


text

Графики + Upon Change archiving
Максим Поджидаев; 18.1.00

Здравствуйте господа!

Столкнулся со следующей проблемой.
При архивировании тегов по изменению
(Tag Logging -> Properties of display tag->
Parameters->Archive only upon change)
я получаю короткий архив, но имею проблемы при его ОТОБРАЖЕНИИ. Если диапазон отображения выбран так , что в него не попадают архивные точки, или такая точка одна, то кривая не отображается.

Мы пытались, с помощью этого метода, отображать циклограммы работы механизмов. Когда механизм ноходится долгое время в одном состоянии соответствующая ему кривая пропадает.
Спасибо за ответы.
Re: Графики + Upon Change archiving
Никаноров (Сименс - Москва); 20.1.00

Вышел HotFix2 для WinCC4.02\SP1 (на 6-ти дискетах).

Он решает Вашу проблему.
Для получения обращайтесь ко мне по e-mail.

Re: Графики + Upon Change archiving
siemargl; 12.2.00

Кстати графики и Tag Logging лучше всего работали в версии 4.02 без сервис-паков. Вот.


text

Не собирается ли Сименс переводить WinCC на TCP/IP?
Елхов Максим; 28.1.00

Вопрос - не будет ли доступны сетевые функции WinCC через TCP/IP?

Re: Не собирается ли Сименс переводить WinCC на TCP/IP?
siemargl; 30.1.00

Вопрос бессмыслен - какие сетевые ф-ции?

Клиетн-сервер и так TCP/IP
Re: Не собирается ли Сименс переводить WinCC на TCP/IP?
Никаноров - Сименс; 31.1.00

Вопрос не очень понятен.

1.Если речь идет о клиент\сервере, то он и так работает через TCP/IP.
2.Кроме того, существует WInCC Add-ons, который позволяет получать переменные и сообщения WinCC на удаленной WinCC станции по TCP/IP протоколу (не в архитектуре клиент\сервер). Описание этого Add-ons есть на бесплатном диске WInCC или в интернет.
3. В WInCC V5 в очередном релизе будет разрешена к поставке опция WEB CLient - реализация рабочего места под Internet Explorer'ом.


text

Software Simatic->SQL
Sergio L; 6.1.00

Pls, расскажите, есть ли Software для сбора информации с Simatic-S5

в базы данных типа SQL, DB и т.д. Если есть, то где его можно посмотреть в работе.

Спасибо

Re: Software Simatic->SQL
Никаноров (Сименс - Москва); 7.1.00

По всей видимости, Вас должна устроить SCADA система WinCC, которая использует базу данных Sybase SQL Anywhere и имеет все драйверы к контроллерам Simatic S5. Версию на 128 переменных мы предоставляем бесплатно (см.Home Page)


text

OP-363-3
Самойлов А.Г.; 27.12.01

Где взять описание OP-363-3? Добро.

Re: OP-363-3
Никаноров, Сименс; 27.12.01

Может, OP-393?

Re: OP-363-3
Самойлов А.Г.; 27.12.01

Бывает проруха! Действительно OP-393-3. Г.Никоноров, вопрос не снимается. Добро.

Re: OP-363-3
Никаноров, Сименс; 27.12.01

Есть на русском языке. Около 4Мб. Могу выслать.

Либо, если у Вас или Ваших коллег есть один из наших дисков ProTool, то там эта документация содержится.


text

OPC и S7-200
Сергей; 27.12.01

Не могу считать данные с аналоговых входов 224 контроллера через EM 277. Где почитать описание подобной процедуры?

Re: OPC и S7-200
Юрий Оганесян; 27.12.01

Очень интересно.. А с дисретных входов/ меркеров / блока данных - получается?

Re: OPC и S7-200
Сергей; 27.12.01

Блоки данных нет, остальное вами перечисленное да


text

Вопрос по WinCC и Dynamic Wizard
Сергей; 10.12.01

Иногда пропадает все содержание Dynamic Wizard в Graphics Designer WinСС5.00 SP2.

Подскажите, пожалуйста, как с этим бороться!!!

Спасибо!!!

Сергей

Re: Вопрос по WinCC и Dynamic Wizard
Сергей другой; 27.12.01

При установке WinCC птицу в списке не поставили.


text

OP 396 - cable scheme - PC
Martin KALINA Slovakia; 27.12.01

Does anybody something to the cable connecting

OP 396 to PC ?


text

Передача сообщений от Step7 к Protool
Alexander; 27.12.01

Нужна помощь... Как передать сообщения от из Step7 на панель оператора, сконфигурированную в Protool.

Re: Передача сообщений от Step7 к Protool
Чистяков Дмитрий ОАО "СеверСталь"; 27.12.01

Для этого существуют специальные пакеты S7-PDiag для STEP7 и ProAgent for ProTool. Подробнее о них Вы сможете почитать в разделе Продукты


text

ошибка при загрузке проекта в ProTool RT
Valeriy; 19.12.01

системное сообщение выдает: ошибка в точке доступа или параметризации модуля, что это значит??? PLC S7-224

Re: ошибка при загрузке проекта в ProTool RT
Юрий Оганесян; 27.12.01

Ето значит что параметры сети и (или)контролера, заданные в проекте ProTool отличаются от того, что прошито в контроллере и(или) от того что стоит "Set PC/PG" .

Проверьте все:
- параметры сети, тип интерфейса, адрес контроллера из MicroWin
- установки в "Set PC/PG" для ProTool и MicroWin
- параметры сети, тип интерфейса, адрес контроллера и компьютера в проекте ProTool


text

COROS COM GRAPH
Лобков Е.; 23.10.01

Умерли дискеты с пакетом COM GRAPH ver.A2.31 -как восстановить продукт. Или аналогичный пакет для PG720-PII.

Re: COROS COM GRAPH
Павел Иванов; 11.12.01

Данный пакет снят с производства несколько лет назад.

Но если Вы обратитесь к ближайшему сотруднику нашего департамента, то постараемся решить Вашу проблему. (В том случае, если Вы официально приобретали данный пакет)


text

PROTOOL DEMO
Александр Шустик (НИИСИ РАН); 6.12.01

Нужно получить тексты программ проекта сделанного предположительно на ProTool. Годится ли он для этого PROTOOL DEMO? Где его можно взять?

Заранее благодарен за ответ.
Re: PROTOOL DEMO
Чистяков Дмитрий ОАО "СеверСталь"; 7.12.01

И где же там в ProTool тексты программ? :-)

Их там просто нет.
Другое дело если Вы хотите отредактировать существующий проект. Но это возможно, если проект имеется на винчестере или дискетке. Если Вы хотите "выкачать" из какой-либо панели программу и редактировать, то это не возможно с любой версией ProTool.


text

OPC client link with WinCC
Александр Башкиров (АСК); 4.12.01

Подскажите пожалуйста, что нужно поставить минимально на клиентскую машину для связи с WinCC по OPC. Приложение написано на Delphi5 используется компонент DOPC.

С Уважением,
Александр Башкиров


text

ProTool Pro CS V5.2 SP2
Михаил Загорный ; 20.10.01

Мщжно ли скачать ProTool Pro CS V5.2 SP2. Спасибо за FM 357-2

Re: ProTool Pro CS V5.2 SP2
Чистяков Дмитрий ОАО "СеверСталь"; 30.10.01

Нет скачать его нигде нельзя.

Представительство Siemens распростаняет CD-ROM с демо версиями пакетов HMI. Там имеется и ProTool Pro.
Незнаю, сейчас это практикуется или нет. На это ответят представители Siemens.
А вообще Вы уже покупали его (ProTool) или нет. Если Вы его уже покупали и просто хотите обновить версию (например, для работы под Win2000), то обратитесь к ближайшему дилеру или в представительство).
Re: ProTool Pro CS V5.2 SP2
Контсантинов Вячеслав; 30.11.01

5.1 к сожалению не работает с W2000 - хотелось бы иметь свежую версию.

мой адрес Череповец ул.Первомайская 52-225


text

Client WebNavigator
Юрий Оганесян; 26.11.01

Объясните, пжалста, ежли WebNavigator Server конвертит экраны WinCC в Стандартный Открытый формат Всемирной Сети, то зачем нужен WebNavigator Client? По логике весь просмотр этих страниц должен уметь делать сам Browser?

Re: Client WebNavigator
Чистяков Дмитрий ОАО "СеверСталь"; 26.11.01

На клиенте используются элементы ActiveX для отображения состояния различных объектов. Также клиент переносит на компьютер поддержку библиотеки элементов WinCC.

Дело в том, что на основе HTML, JavaScript и т.д. очень трудно создать "живые" баки, трубы и т.д. вот они и отображаются через ActiveX. Ну а по скольку ни один браузер не знает таких элементов их необходимо загрузить на компьютер пользователя, что и делает WebNavigator Client.

Это конечно ответ в кратце по теме. Более подробно тут не напишешь - читайте книжки.


text

C7-624
Медет Закирьянов; 21.11.01

При загрузке на ОР выдается ошибка E4018: Protocol error with MPI connection 00031A4FH.

Спасибо.


text

WebNavigator
Максим Поджидаев; 19.11.01

Здравствуйте.

Имею проблему с выпонением скриптов в WebNavigator (теги и статика отображаются нормально). Такое впечатление , что их как бы нет, хотя код (CISS скрипт) имеется. Например, кнопка должна менять цвет.
Вот код WinCC

#include "apdefap.h"
void OnRButtonDown(char* lpszPictureName, char* lpszObjectName, char* lpszPropertyName, UINT nFlags, int x, int y)
{
SetPropWord(lpszPictureName,lpszObjectName,"BackColor",CO_RED);
}

#include "apdefap.h"
void OnRButtonUp(char* lpszPictureName, char* lpszObjectName, char* lpszPropertyName, UINT nFlags, int x, int y)
{
SetPropWord(lpszPictureName,lpszObjectName,"BackColor",CO_GREEN);
}

Вот CISS код
//------------------------------------------------------------------
// Object: Button1

void Button1_OnRButtonDown(UINT nFlags, int x, int y)
{
char* lpszPictureName = "keyboard";
char* lpszObjectName = "Button1";
char* lpszPropertyName = "";
DWORD __dw_CycleTime = 1000;

SetPropWord(lpszPictureName,lpszObjectName,"BackColor",CO_RED);

}
//------------------------------------------------------------------
// Object: Button1

void Button1_OnRButtonUp(UINT nFlags, int x, int y)
{
char* lpszPictureName = "keyboard";
char* lpszObjectName = "Button1";
char* lpszPropertyName = "";
DWORD __dw_CycleTime = 1000;

SetPropWord(lpszPictureName,lpszObjectName,"BackColor",CO_GREEN);

}
в WinCC RT код работает, в WebNavigator нет.
Парметры машины: WinCC 5.0 SP2, WebNavigator 1.1 IE 5.5, Windows 2000, IIS 5.0.
Может кто нибудь встречался с подобными проблемами?

Re: WebNavigator
Никаноров, Сименс; 20.11.01

Вам нужно создать и опубликовать хотя бы одну проектную функцию. Например, пустую Dummy-функцию.


text

Большие задержки при перекл между экранами OP (ProTool CS V5.2 SP2 )
Ефременко Денис (НКМЗ); 16.11.01

После того, как я перезакчал OP17 из нового ProToolV5.2 SP2 , появились просто огромные (5-6сек) задержки при переключении между экранами, причем, чем больше тагов на экране, тем ощутимее тормоза.

Провел эксперимент. Создал в PT5.1 проект, закачал панель. Затем закачал тот же проект из PT5.2 SP2. Разница оказалась просто огрмной.
Что делать? Как это объяснить? Помогите, пожалуйста. Может нужно перешивать ПЗУ панели, или нужны заплатки на PT?
Re: Большие задержки при перекл между экранами OP (ProTool CS V5.2 SP2 )
Никаноров, Сименс; 16.11.01

Попробуйте ProToolV5.2 SP3.

Re: Большие задержки при перекл между экранами OP (ProTool CS V5.2 SP2 )
Ефременко Денис (НКМЗ); 20.11.01

SP3 не помог. Однако, помогла установка предыдущей версии FirmWare 5.22. А в PT5.2SP3 встроена FirmWare 5.23. Напишите ваши соображения по этому поводу.

Заранее спасибо.


text

Hot-keys
Александр Родин, ООО "Нева Электрик"; 19.11.01

На рисунке создана кнопка. К ней назначен Hot-Key. Срабатывание по Hot-Key аналогично действию Mouse-Click, и туда же, собственно, программируется. А вот возможно ли обрабатывать нажатое или отпущенное состояние Hot-Key?

Вопрос возник при создании проекта, реализованного на SIMATIC PC FI45. Требуется создать кнопки плавного увеличения и уменьшения. Т.е., пока кнопку держим, даем сигнал. Кнопку отпустили - сигнал снялся. Мышью там пользоваться неудобно, руки устают.

Заранее спасибо.

PS: Группа технической поддержки ODK-WinCC отправила по этому вопросу в Customer Support. :)


text

Сенсорная панель TP7
Павел Брындин; 13.11.01

Имеется сенсорная панель оператора ТР7.

Помогите найти информацию о ней, и сколько она стоит.
Re: Сенсорная панель TP7
Андрей Рябов; 14.11.01

Здесь,

http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&startNode=4000024&table=ProductNodes&lang=en&open0=-1-404-406-410-408-409-&aktprim=0&nodeID0=4000509&siteid=cs&jumpto=409
Re: Сенсорная панель TP7
Павел Брындин; 15.11.01

Там ничего нет и не было.

Панель именно ТР7.
Заказной номер 6AV3607-1NH00-0AX0.
Version: V13-13-12.
Serial number:TP007814.
Откуда она взялась?
К ней ещё есть конфигурационная программа TP7.
Re: Сенсорная панель TP7
Андрей Рябов; 15.11.01

В каталоге департамента A&D такого нет ...

Может быть это изделие другого департамента SIEMENS (смотря по характеру оборудования на котором оно стоит), тогда надо искать в других каталогах.
Re: Сенсорная панель TP7
Михаил Скотников; 16.11.01

Мы искали информацию о этой панели везде. Более того, на обычных поисковиках: Google, Altavista, Yahoo также о ней упоминаний нет...

Re: Сенсорная панель TP7
Никаноров, Сименс; 16.11.01

Среди стандартных продуктов Сименс такого изделия нет.

Возможно, что это заказной дизайн панели.
Тогда Вам нужно выяснять подробности через Вашего поставщика.
Re: Сенсорная панель TP7
Михаил Скотников; 16.11.01

То что это не стандартный продукт, мы поняли с самого начала, как только её увидели.

Вряд ли это заказной дизайн, так как она не похожа ни на одну из существующих TP фирмы Siemens. Скорее это заказная панель.Бывают ли такие?

К ней у нас есть программа для конфигурации. The Configuration Software For TP7 Operator Panels. Version 2.53.01 Copyright (c) 1998-2000 Siemens AG. Она чем-то(отдаленно)напоминает TP Designer из пакета MicroWin.

При осуществлении выгрузки из панели с помощью этой программы появляются 2 файла с расширением *.AP1 и *.AP2. Они не открываются с помощью конфигуратора. Конфигуратор работает с файлами *.P3W.

Информация нам необходима для осуществления русификации. Так же эта панель нам понравилась, хотя она очень простая и обладает минимумом возможностей. И при приемлемой цене мы хотели бы использовать её в своих проектах.

Кстати, панель нам попала вместе с перемоточным станком английской фирмы Proton.


text

Process Value Blocks in AlarmLogging
Александр Родин, ООО "Нева Электрик"; 15.11.01

Конфигурирую в AlarmLogging Process Value Block размером 80 символов и привязываю его к строковой переменной такой же длины. Затем ставлю этот блок в строку сообщения. По сути строка сообщения состоит только из самого этого блока. Строка сообщения имеет размер 100 символов. Однако же, в рантайме в окне сообщений выводятся строки длиной только 32 символа. С чем это связано ?

Заранее спасибо.


text

Работа / WinCC
Дмитрий; 12.11.01

Требуется на работу в Москве программист WinCC, з/п высокая.

Резюме по e-Mail dmyegorov@geolink-group.com

Re: Работа / WinCC
Александр Родин, ООО "Нева Электрик"; 13.11.01

Высокая - это какая ?


text

?подключение окна с БД из DLL (Delphi)
Сергей Шимолин; 10.11.01

Может

сталкивались с такой ситуацией: Делаю в dll-ке окно с таблицей, и
экспортирую функции по отображению окна (для редактирования таблицы), по
получению текущей выбранной записи, навигации по таблице. Из WinCC RunTime работаю с
этой библиотекой - всё нормально. А вот при закрытии WinCC появляется
ошибка в модуле kernel32.dll. По выгрузке dll-ки вроде окно уничтожаю, у вас
ничего подобного не было?
Re: ?подключение окна с БД из DLL (Delphi)
Сергей Шестаков, "Профиль", Ст.Оскол; 12.11.01

Да, у меня была похожая фишка, именно с DLL на Delphi... Не знаю, что там у Вас, но я столкнулся с проблемой передачи параметров. Пришлось перейти на String и Integer , другие типы данных в DLL передать без ошибок мне не удалось. Попробую найти Вам свой пример на Delphi, может быть поможет...

С уважением
Сергей Шестаков.


text

Tag Logging и Process Controled Tag
Дмитрий Родиончиков; 12.11.01

Необходимо архивировать значения со штампом времени из контроллера S7-300 и отображать их на трендах WinCC.

Я предполагаю, м.б. не верно, что это можно сделать с помощью Process Controled Tag.
Обьясните пожалуйста как этим пользоваться.
Где можно найти пример?

Спасибо.


text

Принтер DR215-N и монитор SCM 1782
Николай Терещенко; 9.11.01

Где можно взять драйвера под WINDOWS 95 для принтера DR215-N и монитора SCM 1782 (SIEMENS)?


text

WinCC, notebook & S7-200 - ProfibusDP
Андрей Таранов; 9.11.01

Может-ли WinCC работать с PCMCIA-картой CP 5511 ?

необходимо связать ноутбук с контроллером s7200 c модулем PROFIBUS-DP EМ 277


text

Проверка потери связи Protool'а с PLC.
Сергей Фесенко (НКМЗ).; 7.11.01

Существует ли возможность обработать событие потери связи (PC+Windows+ProtoolPro RT v5.2) с контроллером Simatic S7-300 (снятие питания с PLC) средствами Protool'а?

(Protool выдает системное сообщение, однако программно (например, в скрипт) это событие передать нельзя).
Благодарю за любую помощь.


text

WinCC Redundancy и WinCC User Administrator
Евгений Трунов; 6.11.01

1. WinCC Redundancy.

Тот же вопрос, что и в сообщении № 374. Несмотря на то, что настроено все по описанию из "WinCC Configuration & Communication Manuals 3/3" и online-Help'a к WinCC, собственно выравнивания данных не происходит. Отмечены опции синхронизации данных подсистем Tag Logging и Alarm Logging при старте runtime-системы на каждом из серверов. На одном из серверов программа CCRedCodi.exe вообще выдает runtime-ошибку времени выполнения при каждой своей активизации(?), при этом в журнал заносятся сообщения типа "REDRT: Partner server started"; при отключении одного из серверов никакого сообщения в журнале второго не
генерируется, при запуске сервера, бывшего отключенным, заносится сообщение "REDRT: Partner Server Project has not started" при том, что второй сервер работает и runtime-система на нем активизирована. Заполнения "провалов" в архивах не просходит ни в каком случае, равно как и появления сообщений "REDRT: Tag/Alarm Logging Syncronization started/ended".
Большая просьба к сделавшим _работающую_ Redundancy-систему описать конфигурацию и последовательность действий.

2. WinCC User Administrator.

При старте системы необходимо произвести вход с заранее предопределенным именем пользователя, для чего в функции OnOpenPicture главной .pdl-схемы вызывается функция PWRTSilentLogin. Проблема в том, что срабатывание этой функции происходит примерно в 50% случаев, т.е. при половине запусков регистрации пользователя в системе не происходит. Причем при вызове этой функции в журнал заносятся два подряд системных сообщения WinCC "USERRT: Manual Login". С чем это может быть связано и есть ли к.-л. другой путь запуска системы с предопределенным именем пользователя?


text

Доступ к данным типа VARIANT
Евгений Трунов; 3.11.01

Как добраться к значениям, хранящимся в типе VARIANT, возвращаемым многими ф-ями WinCC API из ф-й Global Script? Тип значания vt, например, виден, а содержимое

union
{
unsigned char bVal;
short iVal;
...
}
недоступно. Используется стандартный С, где недопустимы безымянные объединения? Однако все попытки классификации типа n3.iVal, где n3 - имя объединения, взятое из заголовочных файлов Microsoft, тоже отвергаются компилятором.
А значение iVal узнать хочется :). ODK под рукой нет.


text

ProTool/Pro Demo
Николай Терещенко; 31.10.01

Должен ли ProTool Pro Demo открывать хотя-бы для просмотра готовый полноценный(напр. с большим числом тегов) проект?

Как узнать какие дополнительные пакеты ( напр. модули СР) использовались при разработке проекта по его файлам?
Проект интегрирован с Step7 а может наоборот

Re: ProTool/Pro Demo
Чистяков Дмитрий ОАО "СеверСталь"; 1.11.01

Как правило проект ProTool интегрируется со Step7, хотя можно и отдельно его использовать. Естественно интеграция даёт много плюсов, например, при создании тегов, Вам доступна символьная таблица, что значительно упрощает поиск требуемой метки в программе.

В том же проекте Вы и увидите какие CP там использовались. Хотя с точки зрения ProTool нет никакой разницы, что за CP стоит в PLC. Лишь бы были правильно указаны адреса, скорость и протоколы обмена.

Проект может быть открыт при помощи ProTool/Pro CS. Какой пакет у Вас CS - разработка или RT - исполнение?
Re: ProTool/Pro Demo
Николай Терещенко; 1.11.01

Пакет ProTool/Pro CS и RT но:( DEMO.

В STEP7 открывается по дереву до SIMATIC 300(1) и пишет, что проект не может быть открыт полностью т.к. он содержит опцию "Drive ES" и просит установить его.
При попытке открыть иконку ProTool (то-же и из самого ProTool) Выдает два сообщения
"Unexpected file format"
"Opening of configuration unsucessful"
Конечная цель - русифицировать тексты на ОР27
В проекте уже заложено переключение на русский но не доделан перевод из итальянского а точнее там нужны, специфические для нашего производства, термины

Re: ProTool/Pro Demo
Никаноров, Сименс; 2.11.01

Соответственно:

1.Нужно установить Drive ES, поскольку он использовался в проекте.
2. Использовать последнюю версию ProTool, поскольку проект был сделал в более новой версии, чем есть у Вас.
Re: ProTool/Pro Demo
Николай Терещенко; 2.11.01

Ответьте, пожалуйста, на самый принципиальный сейчас вопрос.

Смогу ли я сделать желаемое в DEMO версии ProTool/Pro CS? Пусть даже последней версии и со всеми примочками и потом загрузить в ОР27. Или надо начинать с приобретения нормального софта.
Нужен экономный вариант т.к. кроме русификации ничего пока не нужно.


text

Как программировать OP3 через COM порт
Вырмаскин В.В.; 1.11.01

Как программировать OP3 через COM порт?

при сбросе панели загружается программа по умолчанию и программировать не дает!
Re: Как программировать OP3 через COM порт
Андрей Рябов; 1.11.01

В ОР3 Вы можете только загружать созданный проект. Для этого Вам надо перевести панель в режим передачи: вызвать стандартный экран System -> OPMode ;выбрать режим Transfer.

Если в текущей конфигурации нет выхода на стандартные экраны, то надо удалить эту конфигурацию: выключить панель, нажать клавиши [ESC]+[стрелка вниз]+[стрелка вправо] одновременно и, удерживая их, включить питание на панель. При этом текущая конфигурация удаляется и загружаются стандартные экраны.


text

Отсохли AH,AL,WH,WL
Петрова Андрея; 26.10.01

На работающей 3 месяца установке исчезли аварийные и предупредительные сообщения, генерируемые монитором (MeasMon, Mon). Системные сообщения генерятся. Да, отсохли и GroupDisplays. Они все потухшие, любые изменение уставок AH,AL,WH,WL, подавление сообщений никакого влияния не оказывают.

Re: Отсохли AH,AL,WH,WL
Михайлин Сергей; 26.10.01

Первый совет: выйти из RunTime-запустить PictureTreeManager и сделать просто сохранение.

ВНИМАНИЕ: проследить чтобы сохранение прошло до конца(активации крестика закрытия окна).
Если не пройдет звоните мне!
Re: Отсохли AH,AL,WH,WL
Петрова Андрея; 29.10.01

Это-то как раз и было сделано, вплоть до полной перезагрузки сервера. Первоначально было подозрение все-таки на Alarm Logging. Внесли туда изменение, сохранили, запустили RunTime... Не помогло. Но проблема разрешилась. Просмотренный архив сообщений показал наличие Locked сообщений. Когда зашли в архиве новых сообщений в опцию Locked, индикация показывала отсутствие Locked сообщений. Однако произведя Locked & unLocked одного из сообщений, все мгновенной встало на свои места. Вот такая прозаическая ситуация.

Существует проблемка и с трендовой системой. Если выводится группа трендов и первый из них вдруг отсутствует в Tag Logging, то зачастую они просто не прорисовываются. Помогает только опция Zoom.


text

Ошибка ProTool/Pro - SM332-5HD01
Остров ShPA; 24.10.01

При старте Protool/Pro RT выдается сообщение об "ошибке адреса контроллера" (190004) на модуле AO 4x12 SM332-5HD01. Но при подаче сигнала на выход ошибка снимается, всё выполняется правильно (!) и сообщение возникает вновь. Проверял всё! Не нашел. Работает правильно, но забивается буфер сообщений.

Нет ли соображений по этому поводу?
Спасибо.


text

WinCC
YKonnov; 24.10.01

При первой инсталяции в WinCC была доступна политра стандартных функций на си (переходы по кнопкам, запуски приложений Windows и т.д.).

Потом стандартная ситуация- падеж системы, после переустановки палитра компанентов недоступна.

Re: WinCC уточнение
YKonnov; 24.10.01

Имелась ввиду палитра Dinamik Wizard


text

Архивирование в WinCC
Игорь; 22.10.01

Нужно начинать и заканчивать архивирование по событию.как это сделать? если можите превидите пример подробнее.и еще нужно производить однакратное архивирование по событию.

Re: Архивирование в WinCC
Александр Родин, ООО "Нева Электрик"; 24.10.01

Для этого стоит почитать Руководство по Tag Logging.

Для первого случая вам надо использовать тип архивирования переменных "Ciclic-Selective", для второго случая "Aciclic". Они выставляются в свойствах архивных тагов в TagLogging-е.

Для обоих случаев нужно написать процедурки в Global Script, которые и будут давать вам стартовое и стоповое событие. (в главе 5 Руководства шаблоны этих процедурок приведены).

Например:

BOOL StartEvent ()
{
return GetTagBit ("SomeTag");
//^^^^^^^^^^^^^^^ получаем событие для старта
}
аналогичная StopEvent..

Далее, пишем имена этих процедурок в полях Start Event и Stop Event в свойствах архивных тагов.

Собссно и все...


text

Связь ProTool c OP7 (+)
dmi3o; 22.10.01

Здравствуйте!

Подскажите, пожалуйста, в чем м.б. причина ошибки связи
E4027: Synchronization faulty

Спасибо. Дмитрий

Re: Связь ProTool c OP7 (+)
Юрий Оганесян; 23.10.01

Это или разные настройки сети у абонентов: скорости и т.д. или физика (то бишь "плавающие" контакты - было и такое)


text

ОР7 и поле ввода/вывода
Сергей; 22.10.01

Скажите пожалуйста, возможно ли для операторной панели ОР7 для тега типа String установить величину поля ввода/вывода равной 1 (для вывода 1 символа). Попытки сделать это приводили к ошибкам при компиляции.


text

Вопрос о плате PLC-741 ф. Advantech
Сергей; 22.10.01

Здравствуйте.

Скажите пожалуйста, если я добавлю 2 СОМ-порта к своему ПК с помощью платы PLC-741 ф. Advantech, то будет ли воспринимать эти порты WinCC при условии, что эти порты будут иметь каждый свое прерывание и область ввода/вывода?
Появяться добавленные порты в AS511-Admin, будут ли они доступны?

Большое спасибо.


text

AuthorsW под Windows 2000
Юрий Оганесян; 18.10.01

AuthorsW под Windows 2000 не видит авторизации под "Пользователем" (выдает ошибку доступа к какой-то там DLL) и видит ее только под "Адванснутым пользователем", соответственно и ProTool/RT переходит в демо-режим, но мы не хотим давать юзверям права "Адванснутого пользователя", так как они могут наделать черт знат что. Может нужна новая версия AuthorsW?

Re: AuthorsW под Windows 2000
Чистяков Дмитрий ОАО "СеверСталь"; 19.10.01

AuthorsW в данном случае не причём. Эта программа лишь управляет лицензиями.

Во-первых, какая версия ProTool/RT у Вас?
Поддержка Windows 2000 появилась, только в версии 5.2 SP2.
Вероятно проблема таже, что и с другими продуктами Siemens (Step 7, WinCC). Эти программы активно используют реестр и ведут логи, и для этого им требуются определённые права.
Иногда можно выкрутиться следующим образом:
1. Дать первоначально соответствующие права пользователю.
2. Запустить проект.
3. Он что надо пропишет в реестр.
4. Завершить его.
5. Отобрать права у пользователя.
6. Запустить проект.

А для того, что бы пользователь ни чего не натворил в системе, можно использовать встроенные средства для запрещения системных клавишь.


text

Pro Tool Pro CS и RT
Pavel Davidov; 18.10.01

В чем отличие между ProTool Pro CS и ProTool Pro RT

Re: Pro Tool Pro CS и RT
Чистяков Дмитрий ОАО "СеверСталь"; 18.10.01

Pro Tool Pro CS - это система проектирования.

Pro Tool Pro RT - это система, которая работает на персоналке, отображая кадры визуализации.

Подробнее можно почитать на русском языке вот здесь
http://195.146.64.23/ad/as/ru/info/04_hmi/04_man/


text

Вопросы по Alarm Logging
Евгений Трунов; 31.7.01

А вопросы следующие:

1. Сохранение сообщений с дополнительными аргументами. Например: "Изменение задания контура регулирования с <x1> на <x2>". Для заполнения этих x1 и x2 я использую Process Value Blocks с номерами 9 и 10, на которые у меня назначены соответствующие теги, которые инициируются необходимыми значениями перед сменой состояния тега "задание". Однако в большинстве случаев сохранение идет как бы с запаздыванием. Т.е. в полях PV9 и PV10 видны предыдущие значения, а требуемые появляются при сохранении следующего сообщения. Иногда несколько раз подряд дублируются одни и те же значения x1 и x2 для разных сообщений. При этом в тегах находятся именно занесенные мной значения. В чем ошибка? Есть ли другой метод сохранения сообщения с одним номером, но всякий раз с различными дополнительными аргументами?

2. Почему сообщения типа System, Without Acknowledgement/Process Control System все инициируются при старте runtime? Как сделать так, чтобы сообщение, связанное с дискретным тегом (который может сразу после запуска принять значение как 1, так и 0), не создавалось при старте?
Уточнение
Евгений Трунов; 1.8.01

Фраза "Изменение задания контура" выглядит как "Изменение задания контура регулирования с x1 на x2 - просто написал их в угловых скобках, забыв, что это может трактоваться как тег HTML.

Re: Вопросы по Alarm Logging
Светлана; 28.8.01

Те же проблемы (никаких угловых скобок не используем!): если последовательно вводить два тега в окна ввода/вывода - процессное значение, затем тег инициирующий аларм - все срабатывает, но если программно написать то же в нескольких вариациях, то процессное значение дико отстаёт!!

Re: Вопросы по Alarm Logging
Андрей Миндрин; 9.9.01

Проблему 1 можно решить с помощью "Global Script". Используйте опцию "triggers an action", где принудительно читайте значения тэгов и с помощью функции MSRTCreateMsg создайте требуемое сообщение. Вариант, конечно, не идеальный ;), зато будет работать точно.

Re: Вопросы по Alarm Logging
Никаноров, Сименс; 10.9.01

Скорее всего, Ваши теги, которые Вы подставляете в PVх, больше нигде не актуализируются в проекте, т.е. не запрашиваются ни графической подсистемой, ни TagLogging или AlarmLogging.

А WinCC берет значение тегов из DataManager (среза значений переменных).
В DataManager теги обновляются, когда они запрашиваются какой-либо подсистемой WinCC, либо в скриптах функциями типа GetTagxxx. Например, если хотя бы один раз запросить в Action значение переменной функцией GetTagxxx, то в дальнейшем она актуализируется автоматически с циклом 2с.
В Вашем случае, если переменные более нигде не опрашиваются, то в сообщение подставляется значение из DataManager, которое было запрошено при выдаче предыдущего сообщения.
Таким образом, Вам нужно обеспечить автоматическое обновление переменных в DataManager. Это можно сделать, либо однократно вызвав в GlobalScript Action функцию GetTagxxx для нужной переменной, либо при установке флага Trigger an Action в GMsgFunction запустить функцию GetTagxxxWait(State).

Re: Вопросы по Alarm Logging
Максим Елхов; 18.9.01

Вопросы по Alarm Logging - всем спасибо
Евгений Трунов; 16.10.01

Спасибо 415,416 и 423. По 416 - эта особенность работы Data Manager интуитивно понятна, но ее четкого описания я в справочном руководстве не видел.


text

OP 27 Color
Баландин Дмитрий ; 16.10.01

Операторская панель ОР 27

(6AV3627-1LK00-1AX0).Необходимо "скачать" с неё
проект для частичной доработки.С ProTool/Pro V5.2
ничего не вышло. Использовали CP5511.

Re: OP 27 Color
Чистяков Дмитрий ОАО "СеверСталь"; 16.10.01

Увы! Сие невозможно.


text

WinCC Comprehensive Support
Denisjuk; 9.10.01

В Интернете на сайте Сименс я нашел упоминание о

WinCC Comprehensive Support. Что это за поддержка и можно ли заиметь этот демо на СD?
C наилутшими пожеланиями Александр
Re: WinCC Comprehensive Support
Чистяков Дмитрий ОАО "СеверСталь"; 12.10.01

Это файл размером 117 мбайт.

Выполнен в виде help`а на основе HTML.
Он имеется на CD-ROM WinCC 5 Option
Нам он был любезно предоставлен московским представительством.

В принципе он представляет собою сборку вопросов ответов из "Базы знаний", которая доступна в Internet
http://www4.ad.siemens.de/skm/index.asp?lang=en&Access=inter


text

AS511 и много СОМ портов
Сергей; 11.10.01

Подскажите как быть!!!

У меня есть SIMATIC S5, MOXA 4 портовая, WinCC.
Я не могу связаться через WinCC c S5 через новые СОМ порты от МОХА.
Что такое СОМх и как с ним работать?!!!!
И где взять демо Wsendcom.dll

Спасибо!!!
Re: AS511 и много СОМ портов
Никаноров, Сименс; 12.10.01

WinCC может связываться с S5 через COM1-4.

Настройка производится в панели управления в As511-Admin.
Если Вы выбираете COMx, то Вы вручную можете задать прерывание и порт ввода-вывода для Вашего COMа.
Демо Wsendcom.dll в природе не имеется.


text

Проблемы с WinCC 5 SP2
Андрей Миндрин; 17.8.01

При переходе с версии WinCC 5 SP1 возникли следующие проблемы:

1) Если установлен язык в "Language Setting at Run Time" отличный от английского, то в свойствах "UA - Table Element" невозможно выбрать архив, кнопка "Source" не работает;
2) Невозможно отключить отображение поля ID в "UA - Table Element", снятие галочки в "Columns" не помогает.
В версии WinCC 5 SP1 всё работало. Как добиться нормальной работы? Заранее спасибо.

Re: Проблемы с WinCC 5 SP2
Василенко Петр; 10.10.01

Может в Text Library добавить русский язык забыл?

Re: Проблемы с WinCC 5 SP2
AMI; 11.10.01

Нет, не забыл. Этот же проект работает под SP1 нормально. Проблемы возникли именно после перехода на SP2.


text

ODK - Создание таблицы в БД
Роман; 4.10.01

Здраствуйте !

Вопрос следующий: для создания таблицы использую функцию DBCreateTable, таблица создается, НО мне удаётся задать только одно поле. Как добавить ещё несколько ?

Re: ODK - Создание таблицы в БД
Alexis; 10.10.01

Ты ей должен передать указатель на массив структур описывающих твои поля... а ОДК-шные функции вроде как не позволяют добавлять... Поля определяются только при создании... Хотя надо проверить...


text

Опять-таки Protool/Pro v5.2 SP3
Eugene; 3.10.01

Три независимых станции Simatic S7-300 завязаны по сети MPI на один промышленный компьютер - рабочую станцию оператора.

В качестве системы визуализации на компьютере используется ProTool v5.2 SP3 - для каждой станции существует своя группа экранов.
При снятии питания с любого контроллера значения индицируемых переменных этой группы экранов "замораживаются" на последних значениях и визуально невозможно отличить состояние экрана при отключенном контроллере от нормального рабочего состояния станции. ProTool автоматически формирует системное сообщение о потере связи, однако нет возможности "поймать" это событие и обработать программно (например, средствами ProTool'a заблокировать указанную группу экранов).
Вопрос: есть ли какой-нибудь способ поймать и обработать указанное событие только средствами ProTool'a (станции S7-300 между собой функционально связаны быть не должны).


text

Проблемы Protool/Pro v5.2 SP3
Eugene; 7.9.01

В новейшей версии Protool/Pro мягко говоря некорректно работают функции управления протоколированием - Start_Archiving и Stop_Archiving. Может кто знает, где взять "заплатку"?

aim@land.ru
aim; 15.9.01

В чём заключается их некоректнач работа !?

Re: aim@land.ru
Eugene; 18.9.01

Ну неужели не понятно?

Они ВООБЩЕ не работают из скриптов!!!
Re: aim@land.ru
Максим Елхов; 18.9.01

Не знаю про ProTool, а в WinCC они начинают работать после запуска GSCRT.

Архивы
Юрий Оганесян; 21.9.01

Не пробовал. Может быть... А может стоит попробовать назначить их на изменение какого-нить тэга (или кнопку, уж не знаю какая там у Вас ситуация), а не в скрипт? По-моему скриптами лучше не увлекаться, там много что не работает, например, ограничения на верхнее и нижнее значение тэга.

Re: aim@land.ru
Eugene; 29.9.01

В WinCC скрипты на чем пишутся? На Си.

А в Protool/Pro - на Визуал Бэйсике, да еще и ограниченном.
Обидно другое - в версии 5.1 управление протоколированием из скриптов работало.
В версии 5.2 SP3, конечно, появилось много нового (например - ОТКАТ - как долго мы его ждали :-) ) и работать рантайм стал вроде быстрее, но зачем же переделывать то, что отлажено и нормально работало.
Re: Архивы
Eugene; 3.10.01

Да я понимаю, что скриптами лучше не увлекаться.

Но у меня такая ситуация: по изменению переменной с 0 в 1 необходимо начать протоколирование, а с 1 в 0 - закончить. А возможно назначение функции на изменение переменной. Если без скрипта - приходится вводить дополнительные переменные, то есть получается некрасиво, но зато работает.
Вопрос то в другом - до каких пор все эти глюки всплывать то будут?


text

Замена панели MP20
Дмитрий (ОАО "НЛМК"); 26.9.01

Здраствуйте, Господа !

Подскажите возможные варианты замены
панели MP20/23 6AV 5020-1AC11-1AA0
(снятую с производства)
на современный аналог (желательно не меняя
коммуникационный процессор CP526 и установленное
ПО к нему).
Заранее благодарны.
Re: Замена панели MP20
Никаноров, Сименс; 27.9.01

К сожалению, прямой замены нет.

Либо покупайте MP20 как запчасть, либо используйте жидкокристаллические мониторы ф.Сименс с разверткой от 15кГц (для CP526).
Re: Замена панели MP20
Дмитрий (ОАО "НЛМК"); 28.9.01

Cпасибо за ответ !

1.Подскажите,где можно заказать MP20 как запчасть,
так как с нашего отдела закупок импортного
оборудования пришёл ответ о прекращении на ф.Сименс выпуска данной продукции и невозможности
выполнения заказа.

2.Если можно напишите подробнее
типы мониторных панелей совместимых с CP526.
(в смысле просто подсоединив предлагаемую
панель не придёться менять программу в CP526 и СРU 928)

Re: Замена панели MP20
Никаноров, Сименс; 28.9.01

1. Если Ваш отдел уже запрашивал Сименс, то, видимо, цикл жизни изделия действительно истек, и заказать его нельзя.

2. Мониторные панели в настоящее время Сименс не выпускает. Возможная замена - соответствующий жидкокристаллический монитор + клавиатура. См. русскоязычный каталог ST70 (напр. с этого сайта).


text

Pro Tool Pro RT
Papik; 27.9.01

Пользовался кто небуть

программулей под названием Pro Tool Pro RT
( не путать с Pro tool cs )
это что то на вроде Win CC
Вопрос:
если написан проект для S5-го
с помощью какого переходника я могу сконектить
PC с контроллером и нормально работать
в созданном проекте
Re: Pro Tool Pro RT
aim; 28.9.01

М.п. очень удобная программулька ;-)))

Очень помогает при отладке программ на стенде.
Если связываться с S5, то всё зависит от того, какое железо имеется в наличии (желательно фирменные карточкм от Siemens). Мы используем CP-5412a (правда в Simatic`е должен иметься IM-308).
Если их нет - можно использовать связь по 511 интерфейсу. НО поскольку в PC нет стандартного интерфейса токовой петли необходимо спаять конвертор RS->TTY. Его схему можно найти по адресу: http://www.runmode.com/downloads/232_20ma.zip
Ну а дальше - конфигурируем связь и... поехали ;-)


text

WinCC на SIMATIC PC FI45
Александр Родин, ООО "Нева Электрик"; 25.9.01

Имеется этот самый агрегат из сабжа. На нем установлена WinCC 5.0 SP2. проблема следующего плана. Как можно заставить WinCC воспринимать нажатие кнопок F13-F20, а так же весь ряд S1-S16. По проекту это очень нужно. Может драйвер какой к родной клавиатуре есть ?

На Protool переходить уже не получится, потому как весь проект на WinCC сваян, а он не маленький. Пользоваться местным тачпадом тоже не удобно - расположение вертикальное, пальцы потом болят, да и точностью он не отличается.

Заранее спасибо.
Re: WinCC на SIMATIC PC FI45
Чистяков Дмитрий ОАО "СеверСталь"; 26.9.01

Вот ответ на Ваш вопрос

http://www4.ad.siemens.de/news/cs/en/775946


text

OP7
Николай; 24.9.01

Ваше сообщение...Привет! Ребята помогите.

Как выгрузить проект из панели управления OP7?
Спасибо.

Re: OP7
Дедеовец Павел; 25.9.01

Выгрузить можно (программкой PROSAVE.EXE идет с ProToolPro)но не для редактирования, а для сохранения проекта с целью дальнейшей загрузки в панель (например после сбоя или замены панели). Получается один файл содержащий весь проект.


text

Global Script, подключение библиотек Си
Роман; 14.9.01

Каким образом можно подключить стандартные библиотеки Си для использования в скрипте ?

Re: Global Script, подключение библиотек Си
Максим Елхов; 18.9.01

Стандартные и так входят (смотри GS). Прочие можно подкючить через dll при помощи инструкции

#pragma code (описано, например в документе ST-BWINCCS).


text

Alarm logging (сортировка)
Igor, AVTOVAZ; 28.3.01

Здравствуйте, есть такая проблема...

В окне последнее по времени сообщение оттображается последним (в низу) в списке. Это не удобно листать и читать снизу вверх.
Как можно сделать наоборот? Фильтры-есть, а
сортировки что-то я не нашел. :(

Заранее спасибо за помощь.
Re: Alarm logging (сортировка)
Никаноров В. - Сименс; 28.3.01

Можно установить автоскроллинг.

ТОгда не придется листать.
Сортировки же, как таковой, нет.
Re: Alarm logging (сортировка)
Андрей Миндрин; 17.9.01

Надо установить свойство OCX "MsgCtrlFlags"

в "- 1".


text

WinCC
Моос Вячеслав; 6.9.01

1. Где можно получить инсталяцию по WinCC, и условия получения?

2. В работающей программе визуализации пропало отображения части сигналов. Возможные причины?

Вопросы и ответы прошу скидывать на ящик.

С уважением, Вячеслав.


text

Layer's -> WinCC 5 RT -> Как скрыть?
Dr. Kren; 9.8.01

Изображение достаточно объемное. Все объекты распределены на три Layer's (15, 14, 13).

Как в RunTim'e WinCC 5 скрыть все объекты, находящиеся на Layer=14. Какую функцию для этого можно использовать?

Re: Layer's -> WinCC 5 RT -> Как скрыть?
Никаноров, Сименс; 13.8.01

Слои в WinCC используются только для удобства проектирования. Т.е. в Runtime управлять слоями нельзя.

Re: Layer's -> WinCC 5 RT -> Как скрыть?
Максим Елхов; 27.8.01

Сделать битные теги, типа V_Layer_1, V_Layer_2 ... , а свойство Display компонента привязать к нужному тегу. И управлять этим тегом.

Re: Layer's -> WinCC 5 RT -> Как скрыть?
Dr. Kren; 28.8.01

Бо-о-о-о-льшое (огромное) спасибо! :)


text

авторизация
Igor; 18.5.01

При переносе авторизации на дискету,

последняя (дискета) упала, комп ее не видит
вообще.. :(
Что делают в таких случаях?

спасибо....
Re: авторизация
Д.К.; 21.5.01

в таких случаях выкидывают и комп и дискету

Re: авторизация
Михайлин Сергей; 23.5.01

И говорят - куда!

А обычно делают так, как написано у нас на сайте в раделе Поддержка, Обучение и Сервис и далее Восстановление авторизаций.
Re: авторизация
aim; 8.8.01

А может попробовать поднять дискету с пола и положить на стол, что-бы компьютер её увидел.

И вообще, далась Вам эта авторизация ;-)))


text

Работа с массивом в STL
Роман; 30.7.01

В DB описан массив, состоящий из n элементов (одномерный). Вопрос такой: есть ли способ читать значения массива в цикле (чтобы индекс был переменной, а не конкретным числом) , а не конкретно каждый элемент (например L db1.massiv [1]).

Re: Работа с массивом в STL
Чистяков Дмитрий ОАО "СеверСталь"; 2.8.01

Такой способ работы будет работать, только в SCL.

В STL же придётся использовать косвенную адресацию.
Более подробно про это можно почитать в главе 8 описания STL на русском языке c CD-ROMа. STL_r.pdf
Или на английском http://www4.ad.siemens.de/csinfo/livelink.exe/fetch/1127178/AWL_e.pdf?func=doc.Fetch&nodeid=1126519
глава 9.


text

ОР37
Василий; 24.7.01

Добрый день.Хотелось бы поделиться информацией по ОР37. В течении года происходили зависания ОР37 несколько раз,причем всегда по-разному.

1)Иногда переставала реагировать на кнопки с сохранением картинки на экране.
2)Происходила постоянная перезагрузка панели без появления Screens. При снятии и восстановлении питания нормальная работа сохранялась.
3)Происходила постоянная перезагрузка панели, причем нормальная работа появлялась только после стирания памяти и новой загрузки.
Такие вещи происходили и на другой панели, но гораздо реже.
Может у кого есть информация по данному вопросу или какая статистика.
Или это Сименс стал выпускать продукцию низкого качества.
Хотелось бы услышать ответ и от представителей Сименса.
Re: ОР37
Никаноров, Сименс; 24.7.01

Если Вы сообщите заказной номер панели, версию Firmware, версию пакета ProTool - тогда посмотрим.

Re: ОР37
Василий; 1.8.01

1)Панель оператора ОР37

зак.№6AV36371LL000AX1
зав.№ LB M6 100315482
2)ProTool/Pro CS V5.2 Sp2, Aug 4. 2000
Пришел с диском на WinCC V5.0 SP1
Зак.№6AV63811BN040BX0
лиц.0048400151
3)STEP 7 v5.0 SP3
ID:KHE 0022463444


text

Распайка кабеля для соединения s7-300 и OP17
Андрей Таранов Блисс Самара; 23.7.01

Дайте пожалуйста схему

Re: Распайка кабеля для соединения s7-300 и OP17
Чистяков Дмитрий ОАО "СеверСталь"; 24.7.01

А по какому интерфейсу?

Или с каким модулем Вы хотите его связать?
И для начала почитайте инструкцию
http://www4.ad.siemens.de/csinfo/livelink.exe/fetch/1145112/Op717_e.pdf?
Страница D-1
Re: Распайка кабеля для соединения s7-300 и OP17
А.Таранов; 26.7.01

от S7-314IFM к панели op17 по интерфейсу MPI

Re: Распайка кабеля для соединения s7-300 и OP17
Чистяков Дмитрий ОАО "СеверСталь"; 27.7.01

Тогда подойдёт вариант распайки для RS-485 из таблиц D3-D5 руководства.

А именно 9 pin разъём с обоих сторон:
3 - DATA B
8 - DATA A
То бишь, можно использовать стандартные разъёмы Profibus. Желательно и кабель использовать стандартный Profibus. Хотя всё зависит от его длины и скорости обмена.

Re: Распайка кабеля для соединения s7-300 и OP17
А.Таранов; 31.7.01

Спасибо, я еще припаял экран кабеля к pin 1

все работает


text

Создание библиотек DLL
Сарычев Л.И.; 25.7.01

Ваше сообщение...Какае средства(продукт,его версия, фирма-разработчик и др.)необходимы для создания библиотеки DLL, включающую в себя проектные функции, реализованные в среде WinCC V.5.0 SP1


text

Проблема с PROTOOL
Мещеряков Егор; 25.7.01

Пробую посмотреть PROTOOL DEMO, при выборе устройства HMI (любого) и нажатии NEXT (FINISH)выдаётся ошибка "File access error: file D:\siemens\protool\ptreg.dat not found"

Файл физически существует.
Система:
CELERON 400, 64mB
Windows NT 4.0 WS + SP5(пробовал на 98 - то же самое)
Step 7 v5.0 + SP2 (demo) release D5.0.2.0
Protool Pro/CS demo v5.2 + SP2 B5.3.0.23
Re: Проблема с PROTOOL
Никаноров, Сименс; 25.7.01

При записи этих Демо-дисков произошла ошибка.

В результате пакет ProTool не работает, хотя и инсталлируется без ошибок.
Вы можете получить текущую версию CD в ближайшем представительстве Сименс.


text

Нужна информация по панели OP30
Светлана; 20.7.01

На http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&objId=4000506&objAction=csBrowse&lang=en&aktprim=0&siteid=cs

почти ничего нет...
Re: Нужна информация по панели OP30
Никаноров, Сименс; 20.7.01

А что Вы там искали?

OP30 - это панель оператора, снятая с производства.
В настоящее время поставляется только как запчасть.
Re: Нужна информация по панели OP30
Светлана; 23.7.01

У нас она (панель OP30) установлена на оборудовании. И хоть она и снята с производства, информация о ней все-таки нужна!!!

Re: Нужна информация по панели OP30
Никаноров, Сименс; 23.7.01

Присылайте запрос.

Указывайте максимально подробную информацию о Вашей панели. Желательно заказной номер.
Наши координаты представлены на этом сайте в разделе "О нас".

См. http://195.146.64.23/ad/region/center.htm


text

Визуализация в энергетике
shurik; 20.7.01

Существуют ли библиотеки PCS7 для динамической визуализации элементов электрических схем (автоматы,пускатели и т.д.)


text

request for russian language for OP15-C2
flurat; 5.7.01

Please, tell me where I can find russian language for OP15-C2!!

P.S. Reply in my e-mail!!

flurat@sakha.com
Re: request for russian language for OP15-C2
Никаноров, Сименс; 5.7.01

OP15-C2 support Russian itself.

You can select the Russian language in ComText or ProTool.


text

Стандартные функциональные блоки.
Мильчук Виталий (Донской табак); 4.7.01

Где бы раздобыть стандартный функциональный блок FB51 для реализации связи контроллера S5 100 с панелью оператора OP7 через интерфейс AS511?

Продаёт ли Сименс этот блок отдельно, или только в составе пакета?
Re: Стандартные функциональные блоки.
Никаноров, Сименс; 4.7.01

Блоки для подключения панелей оператора к Simatic S5 продаются пакетом:

6AV3 980-1AA21-0AX0 - 170 EURO.


text

Панель COROS OP5
Мильчук Виталий; 19.6.01

Господа!

Возможно ли в панели OP5 осуществить опрос одного бита данных контроллера, за исключением битов сообщений о событиях и авариях???
Re: Панель COROS OP5
Ольштейн Э. "Мечел"; 3.7.01

Если правильно вас понял вам требуется на панели ОР5 отобразить состояние бита входа, выхода, маркера(флага). OP20 напрямую это не позволяет. Я не знаю возможности ОР5, но ОР5 более примитивна, поэтому сомневаюсь.

При работе с ОР20 я действовал в обход:

- выделяем флажковое слово FWxx,
- в каждом цикле программы, заносим в FWxx константу KF0,если наш бит 0, заносим константу KF1 , если наш бит 1.
Примерно такая программа:
A Fx.y
JC =M001
L KF 0
T FWxx
JU =M002
M001 L KF 1
T FWxx
M002
- в программе панели определяем символьное поле с текстом "0" и "1", в Process link ставим ему в соответствие FWx.y.

получаем цепочку Fx.y -> FWxx -> символьное поле.

Текст в символьном поле повторяет состояние бита.

Если ОР5 позволяет так сделать то можно попробовать. Если что-то непонятно отвечу.


text

OLE Control
Дима Веткин, АвтоВАЗ; 27.6.01

Привет

графический дизайнер позволяет вставлять сабжи
и работать с их свойствами, а как из си - акшенов
или глобал скрипта вызывать их методы, нужно какую-то ссылку на них получить, извините если чего недоглядел, подскажите где рыть, вопрос какой-то чайниковский вышел:)

спасибо
Re: OLE Control
Никаноров, Сименс; 28.6.01

Например, вот так:

#include "apdefap.h"
void OnClick(char* lpszPictureName, char* lpszObjectName, char*
lpszPropertyName)
{
#define GetObjectA GetObject

__object *obj = NULL, *pic = NULL, *ocx = NULL;
obj= __object_create("PDLRuntime");
if(!obj)
{
printf("obj = NULL\r\n");
return;
}
pic = obj->GetPicture("NewPdl0");
if( pic == NULL){
__object_delete(obj);
printf("pic != NULL\r\n");
return;
}
ocx=pic->GetObject("OLE Control1");
if( ocx == NULL){
printf("ocx = NULL\r\n");
__object_delete(obj);
__object_delete(pic);
return;
}
ocx->AboutBox();
__object_delete(obj);
__object_delete(pic);
__object_delete(ocx);

}


text

TlgOnlineTrend
Пастухов; 25.4.01

Работаю в WinCC V5SP1.В TagLogging создаю Sequence archive . В Graphics Designere размещаю

TlgOnlineTrend. Всё хорошо кроме одного - кнопки перемещения по временной оси не работают.
В Short-time архивах всё работает.
Может кто подскажет как это обойти

Re: TlgOnlineTrend
Maximka; 19.6.01

Надоть кнопочку STOP вначале нажать, потом заработает


text

Установка авторизации
Михаил М.; 24.5.01

После установки WinCC v.5 sp1 не переносится авторизация (RC130 на 128 tags)на диск С. ОС Windows NT, формат NTFS.

Re: Установка авторизации
Maximka; 19.6.01

Нужно установить AutorsW и делать оное действие с правами рута.


text

Неправильно отображаются русские буквы
Максим Поджидаев; 1.6.01

Здравствуйте!

Неправильно отображаются русские буквы
в проекте ProTool v5.2 на графической панели MP270.
Используемые шрифты - cour.ttf, tahoma.ttf (в MP270 других нет).
MP270PC (режим теста)
Статический текст OK OK
поле ввода вывода :-( OK
поле вывода :-( OK

Для вывода использовался формат S7_sring
в списке Language assignment Device Languages присутствует только русский язык.

Проверка производилась с обоими шрифтами.
Оба шрифта были закачены с MP270 и проверены на наличие русских букв.
В обоих шрифтах русские буквы есть.
как побороть?
Re: Неправильно отображаются русские буквы
Максим Поджидаев; 4.6.01

Прошу прощения, это более удобочитаемый вариант.

Здравствуйте!
Неправильно отображаются русские буквы
в проекте ProTool v5.2 на графической панели MP270.
Используемые шрифты - cour.ttf, tahoma.ttf (в MP270 других нет).

MP270
Статический текст OK
поле ввода вывода :-(
поле вывода :-(

PC (режим теста)
Статический текст OK
поле ввода вывода OK
поле вывода OK

Для вывода использовался формат S7_sring
в списке Language assignment Device Languages присутствует только русский язык.

Проверка производилась с обоими шрифтами.
Оба шрифта были закачены с MP270 и проверены на наличие русских букв.
В обоих шрифтах русские буквы есть.
как побороть?
Re: Неправильно отображаются русские буквы
Никаноров, Сименс; 7.6.01

Строковые переменные пока по-русски отображаются неправильно. Проблема не в шрифте.

В остальном проблем с русским быть не должно (статические тексты, сообщения и т.п.)


text

Обмен WinCC c CP5613
Павел; 11.5.01

Нет обмена WinCC c CP5613, хотя с STEP7 обмен есть. Что делать?

Re: Обмен WinCC c CP5613
Чистяков Дмитрий ОАО СеверСталь; 11.5.01

А посмотрите в Tag Management -> PROFIBUS -> правая кнопка мыши-> System Parameter -> закладка UNIT -> Поле Logocal device name.

Посмотрите соответствует ли значение этого поля каналу, который Вы запараметрировали через SET PG/PC interface.
По умолчанию WinCC всегда устанавливает логическое имя:
CP_H1_1 для Ethernet
CP_L2_1 для Proifibus

Step7 же использует имя S7ONLINE (STEP7).
Вам необходимо, либо установить имя S7ONLINE, либо настроить CP_L2_1

Re: Обмен WinCC c CP5613
Павел; 12.5.01

Всё это я давно сделал, но обмена нет. Вернее он односторонний, я могу установить выход контроллера или меркер, но все выходные данные из контроллера нулевые. Status - Logical Connections -Ok.

Re: Обмен WinCC c CP5613
Никаноров, Сименс; 14.5.01

Сделайте следующее:

- закройте WinCC.
- переименуйте файл "Projectname.DCF" в любой др.
- скопируйте файл "Server.DCF" из "siemens\wincc\bin" в каталог проекта.
-переименуйте файл "Server.DCF" в "Projectname.DCF".
- сделайте рестарт WinCC.

Re: Обмен WinCC c CP5613
Павел; 6.6.01

Получилось.

Но теперь нет обмена WinCC -> CP5613 -> CP 342-5.
Status - Logical Connections - Disconnected.
Тест через Set PG/PC Interface - Ok.
Обмен с Step7 - Ok.
В чём дело?


text

OP37 -> OP37PRO
Sergey A. Tsyermik; 30.5.01

Возможно ли провести апгрейд операторской панели OP37 до ОР37PRO, чтобы получить полноценную возможность работы с клавиатурой на панели и MPI портом из-под Windows? Если возможно, то расскажите поподробнее о процедуре. Есть подозрение, что все упирается в BIOS. Было бы интересно узнать, где можно взять такой BIOS.

См. http://www.odescable.com.ua


text

sutron BT-30
НТМК,ЛСПУ; 28.5.01

Имеется в наличии панель оператора sutron bt-30, но нет программного обеспечения и тех.документации. Может кто хоть чем поделится??? или подскажет где взять ?????? Заранее благодарен.


text

ODK, перемещение по записям...
Igor; 25.5.01

Здравствуйте

Недавно начал разбираться с функциями работы
с базами данных (ODK).
Такой вопрос: читал хелп и так и не понял,
как позиционироваться по записям :(
где, что то вроде, movefirst, ..last, ..next?
если можно-примерчик, можно в почту..:)

заранее спасибо...


text

Redundancy
Дмитрий; 21.5.01

Плмлгите настроить Redundancy В WinCC. вСЁ СДЕЛАЛ КАК НАПИСАНО В DOCах.


text

Печать с ОР17 на принтер кирилицей, а не транслитералами
Ефременко Денис; 8.5.01

В наличии: принтер Siemens DR2030-9 с интерфейсом DR232 и панель OP17-DP.

При непосредственной печати с ОР на DR русских букв принтер печатает фонетические аналоги английских (транслитералы). Как заставить ОР печатать на принтер кирилицу и можно ли это сделать вообще?
Я уже понял, что это связано со способом хранения русского текста в памяти ОР. Но ведь на экран выводятся уже транслитерированные символы, так почему при печати они не переворачиваются?
Помогите, пожалуйста, очень надо!!!
Re: Печать с ОР17 на принтер кирилицей, а не транслитералами
Никаноров, Сименс; 11.5.01

Нужен принтер с ECMA раскладкой, например:

DR 2040 + ECMA 9014 карта


text

TLC386S
creekl; 16.4.01

Помогите разобраться с тем, что я написал. Помогите найти российские аналоги, пришлите схемы, в общем все, что можете


text

WinCC HotKeys
Манушин А.А.; 9.4.01

Как запрограммировать "горячие клавиши"?

Определяю свойство HotKey у объекта command button. Если фокус на кнопке - клавиша работает, если нет то бывает работает, бывает нет.


text

Использование DB функций
Alexis; 30.3.01

Господа, интересует Ваше мнение по следующему вопросу: корректно ли использование Database function описанных в ODK для хранения своей информации в базах WinCC-проекта?

Функции примечательны тем, что позволяют использовать базы данных WinCC-проекта для собственных нужд являясь своего рода Database Engine.
User Archive - стоит денег, да к тому же он медленный по сравнению с DB-функциями. Хранить свою информацию в какой-то внешней базе данных - это конечно тоже вариант, но раз под рукой уже есть две готовые базы данных (конфигурационная и RT) и средства доступа к ним, то и напрашивается вопрос а почему бы и нет?

Может у кого-то уже есть практический опыт?

Заранее спасибо.
Re: Использование DB функций
Sergey G. Shestakov,"Профиль",Старый Оскол; 31.3.01

Я пытался идти эти путем, однако мне не всегда удавалось подключиться к базе RT, ошибка "Доступ не разрешен!", правда я конфигурировал однопользовательский проект. Многопользовательский не пробовал. К тому же, как мне кажется, не совсем хорошо использовать базы проекта для хранения своих данных. Я выбрал такой путь: с помощью SYBASE CENTRAL (см.\siemens\common\sqlany\scview.exe) я создал

свою базу, с которой споокойно работаю и с помощью DB-функций, и посредством ODBC.
Re: Использование DB функций
Alexis; 3.4.01

Чем мне не нравится создание еще одной базы, дык это то, что прийдется таскать за собой еще один файл, прописывать днс... А так зашил в конфигурационную базу свои данные и успокоился :)

А проблема в следующем: почему-то для тэгов не предусмотренно коментариев, а хочется что бы юзеры в последствии при эксплуатации проекта могли как то понять что это за тэг такой.
Есть в составе WinCC программка такая TrendOnl.exe, которая позволяет в run-time трэнды выводить - написал аналог, где вместо "корявых" названий архивных переменных выводятся нормальные понятные русские названия, получилось классно. Естественно эти нормальные названия надо где-то хранить - вот и храню в конфигурационной базе. Теперь хочется что бы все тэги имели нормальные названия....
Re: Использование DB функций
Илья; 3.4.01

Согласен с Сергеем. Ведь это ПРОМЫШЛЕННАЯ автоматизация, а не хакерский полигон. Если есть желание поиметь головняк - то храните все до кучи в одной базе. Хотя существуют более правильные решения (ну, хотябы разделение RT-архива и пользовательского источника данных)

См. http://www.industrialauto.ru

Re: Использование DB функций
Alexis; 4.4.01

Ну почему сразу хакерский полигон то? Есть куча функций, есть описание этих функций, есть примеры работы с этими функциями и поставляется все это хозяйство самим Сименсом... На счет выражения ПРОМЫШЛЕННАЯ АВТОМАТИЗАЦИЯ стоит заглянуть внутрь некоторых файлов WinCC и начинаешь сомневаться видя там фразы типа "greetings to all master of puppets ... and death to false metal !!!" :)

И на счет разделения RT-архива и пользовательского источника данных - User Archive, он же хранит свои данные именно в RT-базе.

P.S. Странно что представители Сименса отмалчиваются... или они нынче только на Симатик-Карты откликаются?
Re: Использование DB функций
Никаноров В. - Сименс; 4.4.01

А что Вы хотели бы услышать от представителей Сименса?

Для оперативного решения вопросов у нас есть хотлайн (российский и центральный). Пока бесплатный.
Кстати, кто Вы, коллега?

Re: Использование DB функций
Alexis; 4.4.01

Господин Никаноров, все таки хотелось бы услышать мнение представителей Сименса по вопросу использования баз данных WinCC-проекта для хранения какой-либо пользовательской информации и использования функций db.dll для доступа к данным.

На сколько это корректно?
А если это неправильно, то зачем все эти возможности описанны в ODK?

Re: Использование DB функций
Никаноров В. - Сименс; 4.4.01

Я бы не рекомендовал Вам менять проектные базы, хотя это принципиально возможно.

Создайте новую базу для хранения Ваших данных.
Re: Использование DB функций
Alexis; 5.4.01

Все таки не вижу смысла заводить дополнительную базу. В данный момент использую конфигурационную базу для хранения своей конфигурационной информации (только для чтения), траблов пока не наблюдал.

Re: Использование DB функций
Василенко Петр; 5.4.01

Мы в проекте большого АСУТП используем WinCC-евую(Sybase) для своих нужд. Доступ при помощи ODK. Как из приложения, которое может быть вызвано при работе RT WINCC(например по нажатию кнопки), так и совсем самостоятельно.

(кратко - на подстанции есть переносные заземления они разных типов имеют разные состояние и атрибуты. Информация об этом всем хозяйстве мы поместили в базу WinCC проекта. При работе АСУТП вид изображения заземлений управляется на основе данных из таблиц отдельным приложением,которое стартует в режиме управления заземлениями-по кнопке и отработав кончается. Отчеты по этому хозяйству формируются отдельным приложением написанном на MSVC++ 6.0)
Работает нормально.
И причин не использовать родную СУБД не вижу.(тем более что сам СИМЕНС заставляет нас программировать на С).

Re: Использование DB функций
Alexis; 5.4.01

Большое Вам спасибо за информацию. Приятно видеть, что есть люди, которые не боятся трудностей.


text

TLGDrawCurvesInDC
Alexis; 5.4.01

Господа, кто-нибудь использовал сабж в своих приложениях?


text

Связать S7-200 c WinCC
Андрей Таранов; 3.4.01

Нам необходимо связать компьютер с WinCC (менее 128 сигналов в системе) с сетью MPI или PPI - не знаю какая будет предпочтительней, с контроллером S7- 200, сначала с одним в перспективе еще с 10-20, на экране нужно иметь картинку с мнемосхемой, должна быть возможность оперативно перелючаться между котроллерами или иметь несколько наиболее важных сигналов с каждого контроллера одновременно на одной мнемосхеме.
Особенности - длина сегмента между компьютером и контроллером ~500м
какие нужны для такой системы аппаратные и программные средства
Заранее спасибо А.Таранов.


text

Экспорт Трендов
Александр Родин, ООО "Нева Электрик"; 15.3.01

Знаю, что можно экспортировать кривые из TagLogging-а в файл формата Excel. Но вот каким образом ?

В Customer Support лежит проектик, в котором данная функция применяется. Но немцы его за так отдавать не хотят. Причем не понятно, толи денег надо (но кому ?), то ли что-то еще.

Очень бы хотелось все-таки узнать, как этот самый экспорт можно выполнить ?

Заранее спасибо.

Re: Экспорт Трендов
Чистяков Дмитрий ОАО СеверСталь; 16.3.01

Это требуется купить Simatic Card.

Более подробно см. http://www.siemens.ru/ad/as/ru/support/s-card.htm
Re: Экспорт Трендов
Никаноров В. - Сименс; 16.3.01

Этот проект можно загрузить при помощи Simatic Card.

Он также будет содержаться на новом диске WinCC5 SP2.
Re: Экспорт Трендов
Alexis; 21.3.01

Александр, если необходимо экспортировать данные из архивов, то чем Вас не устраивает функция TLGBackup? Она может сохранить архив в csv-формате.

Re: Экспорт Трендов
Александр Родин, ООО "Нева Электрик"; 23.3.01

Функция может быть и устраивает, но тогда следующие вопросы:

1. Где можно найти спецификацию на данную функцию ?

2. Какие приложения способны читать формат csv и возможно ли построение графических трендов в этих приложениях ?

Заранее спасибо.
Re: Экспорт Трендов
Alexis; 24.3.01

Описание функции есть в ОДК, если надо то на мыло кину. Правда написано что она только в CSV сохраняет (хотя может это у меня ОДК древний :), но в файле pdertdef.h указывается еще форматы Format DBASE III, Format DIF, Format FoxPro, Format Lotus 123... но их я не пробовал.

А вот так функция сохраняет в CSV:
2001-03-24 10:12:33.052000,0,528384
2001-03-24 10:12:34.053000,0,528384
дата+время , значение , и еще что-то
а CSV и Excel-ем читается...
Re: Экспорт Трендов
Александр Родин, ООО "Нева Электрик"; 25.3.01

Спасибо за информацию.

На самом-то деле было бы интересно как сам по себе вызов функции делается. И если она требует ODK, то где его взять и сколько он будет стоить.

Просто есть уже готовый проект, использующий из опций только Basic Process Control. В нем требуется периодически сохранять накопленные тренды в какое-нибудь место на диске. Для этого написан скрипт, который напрямую копирует файлы архивов. Для копирования используются функции WinAPI. Первый и, иногда, второй вызов этого скрипта происходит нормально. Последующие вызовы вешают Run Time. Вот и пытаюсь найти альтернативные способы.

Привлекать еще какие-то опциональные пакеты не очень хочется, потому как это дополнительных денег стоит и не малых, а больше не дают.

Поэтому буду рад любой помощи.
Заранее спасибо.

Re: Экспорт Трендов
Alexis; 26.3.01

А что за функции используются в том проекте?

А ОДК - это хелп + либы с хедерами для MSVC++. Оказывается это стоит 2500 евро.... В принципе, из состава ОДК интересен только хелп, где содержится описание большинства функций из WinCC-евых dll-ек. Вот... А прототипы функций и так описаны в хэдерах лежащих в каталоге wincc\aplib\ поэтому не вижу "криминала" в использовании внутренних wincc-евых функций в своих приложениях без купленного ОДК....
Так как TagLogging идет в составе WinCC (а не всяких там xxx Process Control) значит необходимые для работы pdertcli.dll и pdertcli.h должны всегда быть.

Ну а алгоритм работы простой:

CMN_ERROR Error;
TLGConnectA(NULL,&Error);
// далее необходимо достать имя архива используя
// BOOL WINAPI TLGEnumArchivsA(DWORD dwArchivTyp,TLG_ENUMTABLES lpfnCallback,LPVOID lpUser,PCMN_ERROR lpError);
// и прописав свою каллбачную функцию типа TLG_ENUMTABLES
// ну и получим имена архивов:
CString arhName="PDE#HD#EBS_PVA#EBSMBTTEMPOIL.FLT";
CString fileName="c:\\data\\"+arhName;
TLG_IO_BACKUP_SELECT ibs;
ibs.sysFrom=... - время от которого начинаем сброс
ibs.sysTo=... - время до куда сбрасываем
ibs.lpszSqlString=NULL;
TLGBackupA(arhName,fileName,&ibs,TLG_BACKUP_EXPORT,TLG_BAKFMT_CSV,&Error);
TLGDisConnectA(&Error);

Вот так вот я и делаю, работает... но выяснилось, что сброс данных с "работающего" архива происходит примерно в десять раз дольше, чем с "заблокированного" архива (что теоретически и правильно). Для блокировки архива используется TLGLockArchivA...
Ну вот вроде и все...

Re: Экспорт Трендов
Александр Родин, ООО "Нева Электрик"; 26.3.01

Re: Экспорт Трендов
Alexis; 26.3.01

Попробовал в настройках архива указать Action for exporting archive свой скрипт типа void archUploads(LPTSTR lpszArchiveName,LPTSTR lpszTagName,DWORD dwNumberOfRecords), дык вот только странно, она имя архива выдает, а имя архивного тэга нет.... у тебя также?

Re: Экспорт Трендов
Александр Родин, ООО "Нева Электрик"; 26.3.01

Выдает и то и другое... С этим проблем не было.

Проблема в другом.

1. Когда в проекте работает только TagLogging, т.е. нет динамической обработки графики, все пишется замечательно.

2. Если переносим этот скрипт в проект, где есть работа с графическим интерфейсом (смена кадров, обработка нажатия кнопок, вывод значения внешних тагов и т.д.) проект виснет напрочь.

Уже второй месяц бьюсь...

Попутно вопрос:
Там где было указание времени начала и конца записи в TLGBackup. В каком виде давать этот параметр ? В доках стоит тип SYSTEMTIME. Это что, получается оно в миллисекундах от какого-то нулевого времени должно высчитываться ?
И еще. Если мне надо автоматом за фиксированные промежутки писать, то откуда тогда этот параметр брать ?
Re: Экспорт Трендов
Alexis; 27.3.01

Ну то что виснет это и понятно, графика в WinCC - вещь довольно ресурсоемкая (особенно с использованием split-а). Я уже говорил, что при незаблокированном архиве экспорт данных довольно длителен... Пример - цикличный получасовой посекундный архив (в архиве 80 тэгов), сброс 15-ти минутного окна на работающем архиве происходит примерно за 10 минут :) а при заблокированном архиве сброс занимает менее минуты.... (сброс данных осуществляется внешним приложением)

Я просто уверен, что при реализации такого сброса через внутренние скрипты, GlobalScript просто подвиснет...
SYSTEMTIME согласно MSDN - это:
typedef struct _SYSTEMTIME {
WORD wYear;
WORD wMonth;
WORD wDayOfWeek;
WORD wDay;
WORD wHour;
WORD wMinute;
WORD wSecond;
WORD wMilliseconds;
} SYSTEMTIME;
Ну а взять текущее время можно GetSystemTime...
Либо используй MFC-шные классы CTime и CTimeSpan
Например:
CTime curTime=CTime::GetCurrentTime();
CTimeSpan span20min(0,0,20,0);
CTime sTime20=curTime-span20min;
TLG_IO_BACKUP_SELECT tbs;
curTime.GetAsSystemTime(tbs.sysTo);
sTime20.GetAsSystemTime(tbs.sysFrom);
- ну вот и получили временное окно за прошедшие двадцать минут.
Re: Экспорт Трендов
Никаноров В. - Сименс; 27.3.01

С использованием TlgBuckup непосредственно из GlobalScript экспорт архивов (незаблокированных) происходит очень быстро. Никаких подвисаний нет.

См. проект на CustomerSupport.
Re: Экспорт Трендов
Александр Родин, ООО "Нева Электрик"; 27.3.01

А вот такой вопрос.

Если в архиве больше одной переменной, то каллбачная функция возвращает только строку с именем последней. А как тогда получить остальные ?

Или я не так что-то понял ?...

Заранее спасибо.
Re: Экспорт Трендов
Alexis; 27.3.01

Каллбачная функция вызывается для каждой переменной, т.е. внутри нее надо либо сохранять информацию в какой-либо динамически увеличивающийся массив, либо сразу использовать полученное имя переменной.

Кстати, может кто-нибудь поделится проектом который лежит на сайте Siemens-а "The sample project "Export.exe" calls the TLGBackupA function several times." (Entry ID: 3008467 )
А то господин Никаноров говорит что "с использованием TlgBuckup непосредственно из GlobalScript экспорт архивов (незаблокированных) происходит очень быстро...." - хотелось бы проверить...
Re: Экспорт Трендов
Александр Родин, ООО "Нева Электрик"; 27.3.01

Я так и предполагал... %)

А проектом могут на самом Сименсе поделиться... Он на новом диске с WinCC будет.

В принципе, емыл в имени действующий ?.. ;)
Re: Экспорт Трендов
Alexis; 27.3.01

Мэйл действующий, за проект буду очень признателен.

А что за новый диск? в смысле WinCC 5.0 SP2?
Re: Экспорт Трендов
Александр Родин, ООО "Нева Электрик"; 27.3.01

А проектик-то так себе... Ничего нового. Все что там есть, уже обсуждено и применено... %)

Тем не менее, хвала Сименсу... :)

Про диск говорили, что это новый с WinCC 5.0 SP2.
Это который под Win2K живет.

Re: Экспорт Трендов
Alexis; 28.3.01

Спасибо за проект.

Если это тот проект, про который господин Никаноров говорил, что экспорт происходит очень быстро - дык это действительно так :) там ведь всего три архивируемых переменных...

Теоретически можно попробовать еще функцию DBExport из db.dll (набор этих DB функций позволяет достучаться до любой внутренней таблицы WinCC). Попробовал - работает, но скорость еще не оценивал.
Re: Экспорт Трендов
Александр Родин, ООО "Нева Электрик"; 28.3.01

У меня и на TLGBackup мой проект пару раз завис. Но я кажется достучался из-за чего это. Действительно скрипты. Причем ладно бы работа с файловой системой. ХА ! Зависает стабильно на операциях обработки строк. Например strcat. Особливо, если сращиваются две строки одна из которых взята с помощью GetTagChar. Выход пришел с присланным проектом (опять же, Хвала Сименсу :). Там строки кататинируются при помощи sprintf. Так что вот. Может теперь и старый вариант экспорта заработает... %)

ЗЫ: А пообщались неплохо. Максимум информации за столь короткое время. :) Не хотелось бы становиться навязчивым, но с Сименса проставка за повышенный трафик... :)


text

Database Functions из ODK
Alexis; 21.3.01

Господа, кто-нибудь имеет положительный результат работы subj-а?

Re: Database Functions из ODK
Sergey G. Shestakov, "Профиль",Старый Оскол; 23.3.01

О положительном результате говорить трудновато, я проверил почти все функции. Не смог добиться работы функции DBGetRecord (не знаю, как правильно задать параметр фильтрации записей. Пример из ODK у меня не пошел). Кроме того, в модуле db.dll имеется больше функций, чем описано в ODK. Я вышел из положения тем, что написал свою DLL на Delphi, конкретно под свою задачу.

Re: Database Functions из ODK
Alexis; 24.3.01

Ну вот и у меня заработало :)

А DBGetRecord оказывается работает так - он возвращает первую удовлетворяющую условию запись, а условие задается так: dwKeyField - это номер колонки в таблице (нумерация с еденицы) и lpValue - это указатель на значение.
Например: высасываем данные из таблицы MSArcLong
dwKeyField=1; - это поле дата+время
char *lpValue="2001-03-24 10:13:42.000000"; - ищем запись с таким значением

далее вызываем DBGetRecord(hTBL,rec,dwKeyField,(LPVOID)lpValue,&err);
ну и разбираем rec....


text

WinCC.Graphics designer.
Г.Пермь ЗАО " Камасталь " . Баландин Дмитрий; 22.3.01

Подскажите пожалуйста, как вставить в WinCC нарисованный в другом редакторе

объект. В принципе получается, но вместе с объектом переноситься задний фон.

Re: WinCC.Graphics designer.
Sergey G. Shestakov, "Профиль", Старый Оскол; 23.3.01

Я рисую графические объекты на Corel Draw 9.0, экспортирую их в формат EMF и вставляю в WinCC как внешний файл рисунка. Пока проблем не было. Я думаю, что не будет проблем и при переносе изображений из других векторных редакторов. Растровые редакторы почти всегда объединяют рисунок с фоном.


text

Вывод трендов на печать
Александр Родин, ООО "Нева Электрик"; 23.3.01

А есть ли возможность вывода на принтер графиков трендов ?

Пользуется WinCC версии 4.02/SP2


text

Состояние TLG архивов в RT
Alexis; 21.3.01

Господа, интересует следующий вопрос:

можно ли в RT узнать текущее состояние архивов TagLogging-а - т.е. Lock или Unlock?

А то как-то странно получается, функции блокирования/разблокирования архивов/переменных есть, а функций выдающих текущее состояние архивов/переменных нет...


text

Transfer error #13 (for OP37)
Lobanov Dmitriy; 21.3.01

В работающей системе, на панели ОР37 периодически появляется сообщение "Transfer error #13".(Описание ошибки в документации нет). При этом всё работает нормально, после сброса сообщение исчезает. Пробовали менять скорость передачи - эффекта нет.

Подскажите возможные причины появление этой ошибки.


text

Режим Read only в User archives editor
Victor; 12.3.01

Есть проект, сделанный под Windows 98SE на WinCC 4.0. Сейчас он работает под Windows NT 4.0 и WinCC v.4.02 SP2.

Возникла необходимость конвертировать user архивы в новый формат, но при открытии редактора в проекте он открывается в режиме read only и ничего нельзя сделать.
Связано ли это с тем, что версии операционок разные?

Re: Режим Read only в User archives editor
Никаноров В. - Сименс; 19.3.01

Попробуйте удалить файл ua*.loc из каталога проекта.


text

Вот такой вот вопрос про авторизацию WinCC.
Чистяков Дмитрий ОАО СеверСталь; 13.3.01

Ставим WinCC RC 64k, WinCC Server. v5.0 SP1 + HF3+HF4.

Всё работает хокей!
А вот заглянув в диагностику видим, что не хватает лицензии на WinCC RT 128. Лично я всегда считал, что RC - это RT + CS.
Так зачем же тогда ещё и RT-то нужна.
Проблема появилась лишь при попытке запустить WebNavigator. Он требует, что бы ни каких проблем с лицинзиям небыло.

Re: Вот такой вот вопрос про авторизацию WinCC.
Никаноров В. - Сименс; 16.3.01

Лицензии тут ни причем.

Нужно в свойствах компьютера WinCC в список старта добавить WebNavigatorRT.exe.
Должно быть все Ок.


text

Связь с микроконтроллером
Игорь; 14.3.01

WINCC определяет подключен ли микроконтроллер

при запуске и если связи нет то это видно. А как самому в рантайме установить связь, ведь не перезапускать же рантайм после каждой замены кого либо микроконтроллера.


text

WinCC 5.0 SP2
Андрей Миндрин; 2.3.01

Пожелание: нельзя ли выложить файл Readme от SP2, чтобы можно было узнать что в нем исправлено и стоит ли его устанавливать в конкретном случае?

Re: WinCC 5.0 SP2
Никаноров В. - Сименс; 5.3.01

См. ссылку.

К сожалению, пока только на немецком языке.
См. также новости Simatic HMI
См. http://www4.ad.siemens.de/csinfo/livelink.exe/6883784?func=ll&objId=6883784&objAction=csView&lang=de&aktprim=0&nodeID0=4000529&siteid=cs

Re: WinCC 5.0 SP2
Чистяков Дмитрий ОАО СеверСталь; 13.3.01

А вот и на английском:

http://www4.ad.siemens.de/news/cs/en/6883784


text

128 Tags -> Demo
"СиЭлСи", Рульков Ярослав; 2.3.01

Запускаю проект WinCC с лицензией на 128 Тэгов. Использую Tag Logging, симулятор Тэгов, Report Disigner(печать циклическая).

В режиме Runtime через несколько минут выскакивает окошко, предупреждающее ,что проект запущен в Демо-моде. Нажимаешь ОК - окошко убирается, а Runtime как крутился - так и крутится.

Re: 128 Tags -> Demo
Maximka; 10.3.01

Именно так оно и работает при отсутствии всех необходимых авторизаций. А насчет почему демо при имющейся авторизации RT128 - может быть установлена какая-либо опция WinCC, требующая доп. авторизации (например User Archive или Storage)


text

Protool/Pro RT V5.1
Piter; 5.3.01

Имеется система на базе Protool/Pro RT V5.1. Катастрофически не хватает тагов(128) и скриптов(50). Чего можно докупить для полного счастья?

Для тагов нашел Power tag, но только для V5.0 и V5.2. не уверен подойдет ли для V5.1. В общем HELP MEEEEE...
Re: Protool/Pro RT V5.1
Никаноров В. - Сименс; 5.3.01

Надо просто прикупить PowerPack вплоть до 2048 тегов.

А апгрейд с 5.1 до версии 5.2 SP2 (SP3) бесплатен.
Re: Protool/Pro RT V5.1
Piter; 7.3.01

Вопросы вдогонку...

1.Увеличит ли это PowerPack-2048 число скриптов ?
2.Какова процедура апгрейда до версии 5.2 ?

Re: Protool/Pro RT V5.1
Никаноров В. - Сименс; 7.3.01

Число скриптов это не увеличит.

По вопросам апгрейдов звоните в ближайший офис Сименс.


text

Цены на WinCC
Харгелия Олег; 5.3.01

1. Хотелось бы узнать, что представляет из

себя апгрейт с версии 4.х до версии 5.0 SP1
(з/н 6AV6 381-1AA05-0BX4)
2. Имеется ли апгрейт до мерсии 5.0 SP2
3. Цена на WinCC v4.02+SP2
(з/н 6AV6 381-1BF04-0DX0)
4. Цена на WinCC v5.0+SP1
(з/н 6AV6 381-1BF05-0BX0)
5. Цена на апгрейт с версии 4.х до версии 5.0 SP1
(з/н 6AV6 381-1AA05-0BX4)

Re: Цены на WinCC
Никаноров В. - Сименс; 5.3.01

Upgrade с версии 4.х на 5.0 SP2:

6AV6 381-1AA05-0CX4 - 675 Euro.
Остальные цены см.в разделе "Продукты" на этом сайте.

См. http://www.siemens.ru/ad/as/ru/info/index.html


text

Вызов внешних функций
Александр Родин, ООО ; 23.2.01

Наткнулся на следующий глюк:

При использовании внешних функций, к примеру CopyFileA и CreateDirectoryA, при выполнении скриптов часто вылазит ошибка.
Т.е., после создания скрипта и объявления этих функций

#pragma code ("kernel32.dll")
CreateDirectoryA(LPCTSTR, LPSECURITY_ATTRIBUTES);
CopyFileA(LPCTSTR, LPCTSTR, BOOL);
#pragma code ()

компиляция проходит успешно.

Вызов выполнен следующим образом:

CreateDirectoryA(&MyPathTag[0], NULL);
.
.
.
CopyFileA(&SourcePathTag[0], &TargetPathTag[0], FALSE);

Но при исполнении вылазит ошибка "can not find function CreateDirectoryA in kernrel32.dll" (то же самое у CopyFileA), причем в списке функций kernel32.dll эти функции есть 100%. Не совсем понятно, из-за чего такое происходит. Причем глюк плавающий, то появляется, то исчезает.

Что интересно, бывает так, что и стандартные функции так же не могут обнаружиться. Например несколько раз терялись функции GetTagChar и SetTagChar.

Может есть какие-то тонкости при вызове внешних функций, которых я не знаю ?

Заранее спасибо.
Re: Вызов внешних функций
Александр Родин, ООО "Нева Электрик"; 28.2.01

Добавление.

Все-таки функции выполняются. Но ошибка всеравно лезет.


text

Добавление записи в User Archives
Денис Кудряшов; 26.2.01

Имеем Windows NT4.0 SP5 + WinCC v4.02 SP2 + авторизации.

Проблема - не получается осуществить добавление новой записи в архив. При использовании управляющих тегов (ID= -1, Job=7) возвращается код ошибки -1.
При использовании функции uaArchiveInsert()возвращается код ошибки 105. Еще вопрос - где описаны подробно эти коды?
Или может имеет значение некая поседовательность действий?

Re: Добавление записи в User Archives
Денис Кудряшов; 27.2.01

Спасибо, уже не надо. Сам разобрался...


text

Организация связи WinCC по PROFIBUS DP
Занчевский Ю.В.; 27.2.01

Не могу настроить канал связи в WinCC Profibus DP.

С помощью COM Profibus V 3.3 создаю проект, где мастером является CP 5412, а слэйвом - ET200M.
Создаю ASCII файл и указываю егос путем как конфигурационный в системных параметрах настройки канала WinCC. Создаю соеденение и в нем указываю слэйв адрес ЕЕ200M (как в COM Profibus). На это WinCC мне выдает , что указанного адреса нет в конфигурационном файле. Подскажите как решить эту проблему

Не дублируйте вопрос в разные разделы форума.
Никаноров В. - Сименс; 27.2.01

Если у Вас WinCC версии 5, то тогда не нужно подставлять текстовый файл. Достаточно подставить *.ldb файл в CP5412.На сообщение об отсутствии текстового файла можно не обращать внимание.

Не дублируйте вопрос в разные разделы форума.
В дальнейшем такие вопросы будут удаляться без предупреждения.


text

Связь WinCC с ET200M по PROFIBUS DP
Занчевский Ю.В.; 27.2.01

Не могу настроить канал связи в WinCC Profibus DP.

С помощью COM Profibus V 3.3 создаю проект, где мастером является CP 5412, а слэйвом - ET200M.
Создаю ASCII файл и указываю егос путем как конфигурационный в системных параметрах настройки канала WinCC. Создаю соеденение и в нем указываю слэйв адрес ЕЕ200M (как в COM Profibus). На это WinCC мне выдает , что указанного адреса нет в конфигурационном файле. Подскажите как решить эту проблему


text

Неприятности с Tag Logging
Ярослав Бойков; 21.2.01

1. В Tag Logging у меня отсутсвует пункты создания/редактирования "шаблонов графиков и таблиц". Как их активизировать?

2. Можно ли создавать архив (временные или последовательные) если теги создаются посредством симулятора?

Re: Неприятности с Tag Logging
Никаноров В. - Сименс; 22.2.01

Наверное, у Вас WinCC версии 5.

В этом случае графики м таблицы настраиваются с помощью ActiveX непосредственно в GraphicDesigner.
Читайте readme.


text

Преобразование символов
Александр Родин, ООО "Нева Электрик"; 19.2.01

Требуется преобразовать символ в код таблицы ASCII или обратно, как можно это сделать ?

В GlobalScript есть функция ToAscii, но спецификации по ней нет. Стандартная С-шная спецификация на эту функцию, похоже, не распространяется, потому как если сделать вызов этой функции по спецификации ANSI C, GlobalScript при компиляции выдает ошибку "error (006) Not enough arguments for function 'ToAscii'"
Re: Преобразование символов
Alexis; 20.2.01

Ну вот описание ToAscii...

Может поможет...

The ToAscii function translates the specified virtual-key code and keyboard state to the corresponding character or characters. The function translates the code using the input language and physical keyboard layout identified by the keyboard layout handle.

int ToAscii(
UINT uVirtKey, // virtual-key code
UINT uScanCode, // scan code
CONST PBYTE lpKeyState, // key-state array
LPWORD lpChar, // buffer for translated key
UINT uFlags // active-menu option
);

Parameters
uVirtKey
[in] Specifies the virtual-key code to be translated.
uScanCode
[in] Specifies the hardware scan code of the key to be translated. The high-order bit of this value is set if the key is up (not pressed).
lpKeyState
[in] Pointer to a 256-byte array that contains the current keyboard state. Each element (byte) in the array contains the state of one key. If the high-order bit of a byte is set, the key is down (pressed).
The low bit, if set, indicates that the key is toggled on. In this function, only the toggle bit of the CAPS LOCK key is relevant. The toggle state of the NUM LOCK and SCROLL LOCK keys is ignored.

lpChar
[out] Pointer to the buffer that receives the translated character or characters.
uFlags
[in] Specifies whether a menu is active. This parameter must be 1 if a menu is active, or 0 otherwise.
Return Values
If the specified key is a dead key, the return value is negative. Otherwise, it is one of the following values.

Re: Преобразование символов
Никаноров В. - Сименс; 20.2.01

В С символ преобразуется автоматически, например:

int i;
char c;
i=c;
c=i; //значение с не изменится.

Если Вам нужно преобразовывать строку в число, и обратно, то нужно пользоваться стандартными С-функциями atoi и itoa.


text

PDLRTSetPropInd и PDLRTGetPropInd
Alexis; 16.2.01

Господа, может быть кто-нибудь в курсе, что делают эти функции PDLRTSetPropInd и PDLRTGetPropInd???


text

WinCC масштабирование тэгов
Игорь; 9.2.01

Надо прочитать из микроконтроллера Слово(Word)

по ModBus Протоколу. А затем разделить на 10.
Wincc поддерживает маштабирование,но тип данных не изменяет, поэтому десятые доли отбрасываются,
что делать?
Где можно взять документацию на написание OPC драйвера, и сервера?

Re: WinCC масштабирование тэгов
Александр Родин, ООО "Нева Электрик"; 9.2.01

Кстати, я такую фишку уже встречал. Вышел из сложившейся ситуации посредством написания функции в Global Script-е

float Make_Float(int a, float c)
{
float b;
b = a/c; // с - число кратное 10
return b;
}

Вызов лучше делать следующий:

Val = Make_Float (Val1, 10.0);

Тогда количество нулей после запятой опредит вам количество знаков.

Собственно вот.
Re: WinCC масштабирование тэгов
Никаноров В. - Сименс; 12.2.01

Язык C поддерживает конверсию форматов, например:

unsigned short Tag_Name;
(double) Tag_Name;
Re: WinCC масштабирование тэгов
Никаноров В. - Сименс; 14.2.01

Самый простой способ, это объявить в WinCC переменную типа Float 32-bit или Float 64-bit.

А затем задать конверсию форматов (Adapt Format): FloatToWord или DoubleToWord (прямо в диалоге объявления переменной). При этом из контроллера читается Word и преобразуется соответственно во Float или Double в WinCC. (обратите внимание, что при преобразовании, например, DoubleToWord Double относится к WinCC, а Word - к PLC)


text

WinCC и ActiveX
Alexis; 12.2.01

Почему WinCC5 в RT не переваривает ActiveX(сделанные в MS Visual C++ 6)? В часности - WinCC RunTime зависает при переключении картинок на которых расположены ActiveX.

Re: WinCC и ActiveX
Никаноров В. - Сименс; 13.2.01

Используйте VisualBasic + опцию IndustrialX.

Тогда проблем с OLE-интерфейсами не будет.
Re: WinCC и ActiveX
Alexis; 13.2.01

Да, но разве IndustrialX есть в пятой версии WinCC?

Re: WinCC и ActiveX
Никаноров В. - Сименс; 13.2.01

ДА, конечно. Нет разделения между 4-ой и 5-ой версией.

6AV6 371-1EL15-0AX0.


text

Tag Logging
Аленксандр Родин, ООО "Нева Электрик"; 6.2.01

В subj есть возможность писать архивы и сохранять их в любом месте на диске в определенные моменты времени, что, несомненно, очень удобно. Однако, возникла следующая сложность. Допустим, у меня накопилось достаточно много подобных записей. просмотреть трендовый график я могу только за текущий (еще не переписанный) период. Но, я бы хотел просмотреть тренд, например, недельной давности, не разрывая текущий. Как это можно сделать возможностями того же subj, или с привлечением GS? Далее, могу ли я просматривать тренды одной и той же переменной за разные периоды времени и на разных графиках (сравнить)?Попутно к этому такой вопрос: Если сделать тип архива не коротко срочный (Short Term), а длительный (Continous), то можно ли из него выбирать куски соответствующей длительности и записывать их на диск в удобном для чтения другими приложениями формате ?

Вопросов много, но жду скорейшего на них ответа.

Заранее спасибо.
Re: Tag Logging
Никаноров В. - Сименс; 7.2.01

Я, откровенно говоря, иало что понял.

О чем речь?
Re: Tag Logging
Александр Родин, ООО "Нева Электрик"; 8.2.01

Попробуем попроще.

1. Тип архивов Short Term, в них пишется отрезок времени по 4 часа (время опроса 500 мс, время архивирования 1 мин, количество записываемых параметров, соответсвенно, 240), по заполнении архивы переписываются в архивную папку (в Global Script сконфигурирована специальная процедура записи по заполнению). Как произвести чтение и отображение тренда из уже переписанного архива ?

2. Есть переменная, изменение которой я хотел бы отследить, например, за вчерашний и сегодняшний день. Я хочу просмотреть это изменение на одном графике, где одна кривая была бы изменением этой переменной за вчера, а другая кривая - за сегодня. как можно это сделать ?

3. Если сделать тип архива Siquence, то возможно ли делать из него выборки по времени и перезаписывать куда-либо на диске в каком-либо формате ?

Надеюсь, так понятнее...

Заранее спасибо.
Re: Tag Logging
Максим Елхов; 13.2.01

По первым двум пунктам - можно, если пользовать ODK, но не совсем просто. Проще ( и большинство это делает) доставать опять же через функции ODK из архива данные, пихать их в Excel и там строить график. По третьему пункту - надо покупать Storage или опять же самому в через ODK писать процедуру архивирования накопленного и очистки текущего архива.

P.S. Если хорошо владеете SQL - можно все сделать через него.


text

Работа в режиме Offline
Александр Родин, ООО "Нева Электрик"; 30.1.01

Проблема возникла в случае сконфигурированного соединения, но отсутствия контроллера. При запуске проекта машина зачастую виснет.

Есть ли какие-либо средства для обработки случаев отсутсвия контроллера ?
Пример: Есть сеть, объединяющая несколько контроллеров, причем каждый из них может быть выключен или включен в любой момент времени. В WinCC сформированы базы тагов для всех контроллеров и ряд процедур обработки значений, т.к. они требуются в процессе работы проекта. Если один или несколько членов сети оказываются отключенными, то происходит зависание.
При этом, подобное поведение наблюдается не всегда, что приводит к большим затруднениям с отладкой.
Re: Работа в режиме Offline
Никаноров В. - Сименс; 31.1.01

Если у Вас WinCC версии 5 и Вы используете S7_Protocol_Suite, то в системных параметрах Вы можете активизировать опцию "Monitoring of CPU-stop":

S7_Protocol_Suite -> Profibus (например) -> правая кнопка мыши -> System Parameters -> Channel
Если эта опция активизирована и CPU недоступен, то WinCC разрывает соединение.
Re: Работа в режиме Offline
Александр Родин, ООО "Нева Электрик"; 1.2.01

А если версия 4.02 ???

5.0 пробовали ставить, но у нее не компилируются скрипты.
Re: Работа в режиме Offline
Никаноров В. - Сименс; 2.2.01

Все компилируется 100%

Вы должны в общем случае сделать Upgrade скриптов и функций для корректной работы в WinCC5. Этот Upgrade производится с помощью утилиты CCScriptUpgrade.exe, входящей в поставку WinCC5 Sp1. Читайте (внимательно!!!) файлы releasenotes.pdf & SmartToolsenu.chm.
Сделайте также Regenerate Header в Global Script.

Re: Работа в режиме Offline
Александр Родин, ООО "Нева Электрик"; 2.2.01

И все-таки, хотелось бы вернуться к исходному вопросу.

Есть ли какие-нибудь средства обработки отключенного состояния контроллера в версии 4.02 ?

Заранее спасибо.

Re: Работа в режиме Offline
Максим Елхов; 13.2.01

Пользуйте функцию GetTagWordState("MyTag",&State) Младший битик в State (DWORD) становится в 1, если нет связи. На странице 33 учебника по WinCC расписаны еще 15 бит состояния связи.


text

COM порт
Игорь; 9.2.01

Как WInCC определяет

к какому СОМ порту устройство подключено?
Re: COM порт
Igor; 12.2.01

Номер порта устанавливается ручками

в своствах Driver Connection или
в своствах Driver -> System Parameter в зависимости от типа драйвера.
(все это в Tag Management разумеется)
Re: COM порт
Никаноров В. - Сименс; 12.2.01

В зависимости от того, по какому каналу Вы подключаетесь.

Если через AS511, то конфигурация COM-портов задается в утилите AS511-Admin.
Если, например, по Modbus Serial, то искать надо в системных параметрах канала (вызывается по правой кнопке мыши).


text

Где взять WinCC 5.0 SP2
Илья , ОАО "ЧТПЗ"; 10.2.01

Прошу сообщить, где взять SP2 для WinCC 5.0

для работы в Windows 2000 (или WinCC 5.0 SP2)
См. http://www.chtpz.ru

Re: Где взять WinCC 5.0 SP2
Никаноров В. - Сименс; 12.2.01

SP2 для WinCC 5.0 будет поставляться где-то с марта месяца.


text

COROS LS-B под Flex OS
Фомин Н.; 29.1.01

Подскажите, может кто ни-будь имел дело c Flex-OS

У нас эта операционка поддерживает винт 1024 цилиндра, а таких винтов больше не найти. Как избавиться от этого недостатка.
Заранее благодарен!

Re: COROS LS-B под Flex OS
Рябов А.; 1.2.01

Старые версии FlexOS поддерживали винты объемом до ~540Mb. Но можно её запускать и с большим винчестером. А именно, это зависит от файла flexos.sys (он где-то там во вложенных каталогах зарыт). Надо только его новую версию поиметь и перезаписать. У меня где-то это было. Если надо - мыльни.

Re: COROS LS-B под Flex OS
Фомин Н.; 2.2.01

Я дико извиняюсь мыльнуть это сказать свой Еmail или как... Если можно будте добры, пришлите пожалуйста Email ksn@stal.ru


text

Tagloggin
Kabanov Igor, AVTOVAZ, Togliatty; 31.1.01

Уважаемые господа,

имеется проект, в котором не используется "мышь".
Как можно по кнопкам с помощью C Action скрыть/показать один
или несколько столбцов/кривых в окне отображения?

Заранее спасибо..
Re: Tagloggin
Никаноров В. - Сименс; 31.1.01

У кнопки есть свойство, которое называется HotKey.

Здесь Вы можете назначить горячую клавишу для срабатывания этой кнопки.
Re: Taglogging - г-ну Никанорову В.
Kabanov Igor, AVTOVAZ, Togliatty; 1.2.01

Прошу за беспокойствие еще раз, может быть я неясно выразился...

Я имел ввиду следующее.
В графическом редакторе выбираю Application Window, устанавливыю
свойство Window contents - Tag Logging.
В редакторе Tag Logging в Trend Window Template делаю несколько
trend'ов. В режиме Runtime у объекта с трендами есть кнопка в панели
инструментов Set Parameters и активизируетсся она мышкой, и там можно
показать/скрыть любой из трендов.
Так вот я спрашивал, есть ли какая-нибудь C Action, с помощью которой
можно скрыть/показать Trend1 или TrendХ.

А то, что Windows Objects -Button имеет свойство HotKey это и так ясно,
вопрос, что написать в Events'ах ? :((

Заранее спасибо..
Re: Taglogging - г-ну Никанорову В.
Никаноров В. - Сименс; 1.2.01

В Tag Logging для кнопок Toolbar опять же можно задать Hotkey. Это делается в TagLogging\Template для WinCC4. Для WinCC5 лучше не использовать ApplicationWindow, а применять ActiveX объект для отображения кривых.

Кроме того, Вы можете нарисовать свои кнопки и назначить им функции, аналогичные функциям кнопок Toolbar. Эти функции находятся в разделе StandartFunctions\Taglog\ToolbarButtons.
В WinCC5 у ActiveX объекта имеется также свойство Index, с помощью которого можно выбрать нужную кривую и сделать ее видимой\невидимой.


text

Переменные типа float в Global Script
Андрей Миндрин; 29.1.01

Есть код:

float f=1234.56;
printf("%f",f);

Выводится значение 1234.560059, а надо 1234.56.
Как исправить это, изменить точность?

Заранее спасибо.
А как насчет DOUBLE?
Никаноров В. - Сименс; 30.1.01

...

Re: А как насчет DOUBLE?
Maximka; 31.1.01

man printf

надо было printf("%.2f",f);


text

WinCC 5.0
Александр Родин, ООО "Нева Электрик"; 31.1.01

Помнится,обещался выход SP2 к subj в конце прошлого года. После этого никакой информации. Вышел-таки или нет ? Если да, то на каких условиях происходит распространение ?

Заранее спасибо.

Re: WinCC 5.0
Никаноров В. - Сименс; 31.1.01

SP2 ожидается к марту месяцу сего года.


text

Резервирование Industrial Ethernet сети для S5-155H в WinCC
Гришко Андрей; 29.1.01

Как реализовать функцию резервирования Industrial Ethernet сети для S5-155H в WinCC.

Где можно найти информацию по данному вопросу

См. Резервирование Industrial Ethernet сети для S5-155H в WinCC


text

OP7 и траснферт рецептов на S7-300
Крючков В; 26.1.01

Возникла проблема:

при передаче рецепта с OP7 на S7-312 высвечивается сообщение: "Передача заблокирована" (ошибка 505). Was ist das? И как с этим бороться?
Заранее благодарен.

Re: OP7 и траснферт рецептов на S7-300
Никаноров В. - Сименс; 26.1.01

См. http://www.siemens.ru/ad/as/ru/forum/hmi/forum.cgi?message=221


text

Service Pack 2 для ProTool 5.2
Serge Dovgopolyuk; 19.1.01

Здравствуйте Все!

Срочно нужен Service Pack 2 для ProTool 5.2.
Подскажите где взять или сбросьте на мыло.

Спасибо.

Re: Service Pack 2 для ProTool 5.2
Никаноров В. - Сименс; 19.1.01

...

См. http://www.siemens.ru/ad/as/ru/forum/hmi/forum.cgi?message=166


text

hotfix2 для WinCC 4.02
Веткин Дима; 9.1.01

Здравствуй All!

Нельзя ли поконкретней о проблемах, которые решает subj. У меня проблема такая: проект с UsAr периодически виснет в разных местах(comp: celeron400 128ram WinNT4)(использую и функции из GScript и соотв. OLEControl), причем это в большом проекте, где много разных экранов и т.д. а в маленьком, где отлаживаю только UsAr все нормально. Вот думаю, то ли руки кривые(хотя вроде все проверил), то ли сабжа не хватает
Спасибо.

Re: hotfix2 для WinCC 4.02
Никаноров В. - Сименс, Москва; 9.1.01

В настоящее время имеется ServicePack 2 для WinCC4.02, который включает в себя все предыдущие Hotfix'ы. Его можно бесплатно заказать на CustomerSupport, если Вы покупали WinCC4.02. Или Вы можете обратиться в ближайший офис Сименс, где мы запишем Вам диск.

Re: hotfix2 для WinCC 4.02
Igor; 16.1.01

А WinCC 5.0 лишена этих глюков?


text

op-25
яковлев михаил; 2.1.01

Ваше сообщение...

Подскажите как избавится от черных линий, напоминающих сетку на экране.Регулирование яркости и констрасности не помагает.

Re: op-25
Андрей Гуленок; 16.1.01

Обратиться в службу сервиса. Никакой сетки на экране быть не должно.


text

список всех тегов в WinCC
Богдан Кудлак; 15.1.01

Как получить список всех тегов WinCC из своей программы?

(Через ODK, ODBC или другим методом)

Re: список всех тегов в WinCC
Никаноров В. - Сименс; 15.1.01

Это возможно с помощью ODK.


text

Массив тегов?
Богдан Кудлак; 4.1.01

Можно ли в WinCC создавать массивы тегов, для работы с ними в цикле?

Re: Массив тегов?
Max; 4.1.01

Смотря что нужно. Можно, например, создать свою структуру, состоящую из необходимых тэгов. А при создании нового тэга, указать в качестве его типа новую структуру. Другой способ заключается в том, чтобы создать набор тэгов MyTag_000, MyTag_001 ... MyTag_999. Затем создавать имя тэга через wsprintf и его использовать в цикле.

void Ex(void)
{
int i;
char buff[15];
short Arr[999];
for(i=0;i<1000;i++)
{
wsprintf(buff,"MyTag_%03d",i);
Arr[i]=GetTagWord(buff);
}
}


text

драйверы Moscad (MOTOROLA)?
Богдан Кудлак; 3.1.01

Есть ли драйверы (DLL, DDE, OPC) под WinCC для Moscad (MOTOROLA)?


text

Ошибка Coros
Дмитрий; 3.1.01

Кто-нибудь ещё использует Coros LS-B/Win?

Есть проблема: в Run-time постоянно появляется ошибка: "Abnormal terminated task MEZ_PTE.EXE".
В чём может быть причина и как её устранить?
Заранее благодарен.


text

Синхронизация даты и времени в ОР170В.
Аленксандр Туманов; 26.11.02

В PLC программирую:

call sfc1
ret_val:=mw100
cdt:=P#DB30.DBX6.0 BYTE 8

В ОР170В конфигурирую Area Pointers:
Date/Time-PLC с адресом DB30.DBW6 с циклом опроса 60 секунд. НЕ РАБОТАЕТ!

Вопрос: Достаточно ли этого или необходимо программировать PLC JOB?
Какую JOB?

Re: Синхронизация даты и времени в ОР170В.
Илья; 30.12.02

Да. Такие вещи делаются через PLCjobs. Причем вы можете делать TimeSync как ОР -> PLC (OP - time master) так и PLC -> OP (PLC - time master). В первом случае вам потребуется еще и анализ бита завершения задания. Во втором - 2 разных задания. Одно на установку времени, второе - даты.


text

OP27-чтобы сделать обычную кнопку нужно на событие Press навесить Set, на Release-Reset.Проблемы при обрыве связи.
Ефременко Денис; 24.12.02

При этом если, например, управлять приводом в толчковом режиме (пока держишь-едешь) при кратковременном обрыве связи ОР не иницииирует событие Release кнопки, то есть бит в DB не сбрасывается при отпускании кнопки и привод продолжает движение. Подскажите самы простой способ решения поблемы. Life bit не подходит, т.к. у него период 2 сек,кран может за это время съехать с рельс. Один из вариантов - прицепить OP27 как OP27DP-Key на мастер устройство. Тогда вопросы:

1. При обрыве связи эта передаточная память сбрасывается в 0.
2. Подскажите расшифровку передаточной памяти (соответствие каждого бита кнопке и светодиоду)?

Re: OP27-чтобы сделать обычную кнопку нужно на событие Press навесить Set, на Release-Reset.Проблемы при обрыве связи.
Никаноров, Сименс; 24.12.02

Самый правильный способ - это действительно использовать DP-direct keys. Расшифровку передаточной памяти можно посмотреть в Communication Manual для обычных ОР.

Re: OP27-чтобы сделать обычную кнопку нужно на событие Press навесить Set, на Release-Reset.Проблемы при обрыве связи.
Ефременко Денис; 24.12.02

Спсибо за отклик.А для тех, кого тоже волнует эта проблема: соответствие битов передаточной памяти я нашел в Communication User's Manual- Supplement в разделе Simatic HMI Communication на стр. 11-20


text

Как послать сигнал в WinCC с другой машины.
jh; 3.6.02

Привет.

У меня проблема:
Имеется многопользовательский проект WinCC. На другой машине работает другая сисетма которая по своим событиям должна послать в WinCC три сигнала(два дискретных и один аналоговых). Подскажите, как это сделать? Локально, через DMSetValue все работает, но нужно запускать мой программу на машине без WInCC.

заранее благодарен.

Re: Как послать сигнал в WinCC с другой машины.
Владимир Ерохин; 15.11.02

А если попробовать на этой "другой" станции (источнике) подключить станцию-приемник по ОРС и там менять. Конечно аналоговые и дискретные здесь не идут, но их значения можно послать.

Re: Как послать сигнал в WinCC с другой машины.
Антон Глухов; 19.12.02

Мы делали следующим образом. На машине с WinCC ставили свой сервис в который по своему протоколу передавали данные, а сервис уже пропихивал их в WinCC


text

BSTR переменные
Константин; 19.12.02

Подскажите, пожалуйста, каким способом можно передать (преобразовать)данные из переменной типа "char" в переменную типа "BSTR"? Спасибо.

Re: BSTR переменные
Alexis; 19.12.02

Takes an ANSI string as input, and returns a BSTR that contains an ANSI string. Does not perform any ANSI-to-Unicode translation.

BSTR SysAllocStringByteLen(
LPCSTR psz,
unsigned int len
);

Parameters

psz
A zero-terminated string to copy, or NULL to keep the string uninitialized.

len
Number of bytes to copy from psz. A null character is placed afterwards, allocating a total of len plus the size of OLECHAR bytes.
Allocates a new string of len bytes, copies len bytes from the passed string into it, and then appends a null character.

Return Value
Points to a copy of the string, or NULL if insufficient memory exists.


text

Структурные теги в WinCC
Хлопин Денис; 11.12.02

Можно ли в С-шном коде написать функцию, где на вход подается имя структурного тега, а внутри функции обрабатываются все теги данной структуры? Если можно, то как?

Re: Структурные теги в WinCC
Василенко; 11.12.02

А если использовать GAPIEnumTypeMembersEx4 и еще несколько функций из ODK

Re: Структурные теги в WinCC
Костенич Дмитрий; 11.12.02

Можно. См. описание ODK-функций GAPIEnumTypeMembers, GAPIEnumTypeMembersEx, GAPIEnumTypeMembersEx4.

Re: Структурные теги в WinCC
Хлопин Денис; 15.12.02

Если не секрет, где я могу посмотреть эти описания?

Re: Структурные теги в WinCC
Alexis; 15.12.02

Ну дык в ODK и посмотри :)

Re: Структурные теги в WinCC
Хлопин Денис; 16.12.02

Я понял, что у меня нет пакета ODK! Можно ли его скачать где-нибудь? Если можно, то где?


text

Провалы в обновлении тегов.
Максим Прилепский ; 5.12.02

Существует станция WinCC 5.1 с каналом связи Profibus на CP 5611. В проекте на станции около 800 тегов, максимальный размер тега - 32 бита (Float), теги берутся из контроллера S7-300 через порт MPI на плате CPU. Теги организованы в 15 разных DB контроллера.

При этом обнаружилась следующая проблема: Войдя в экран, где теги отображаются в виде таблицы из объектов "I/O Field" (около 10 тегов), видны значения тегов, отличные от нуля, в WinCC Explorer (Tag Management) эти значения тоже видны, с кодом 80 (good). При переходе в экран, где теги не отображаются, но опрашиваются из скрипта функцией GetTagMultiWait() по событию OpenPicture, мы имеем в Tag Management значения этих тегов равными нулю, а коды 4с (start value). При обратном переходе в экран с таблицей, опять видим ненулевые значения с кодом 80.

Может кто-нибудь сталкивался с подобной проблемой?

Re: Провалы в обновлении тегов.
Чистяков Дмитрий ОАО "СеверСталь"; 5.12.02

Вы, наверное установили обновление тэгов по изменению. Задайте жёстко время обновления, например 500 мс.

Re: Провалы в обновлении тегов.
Максим Прилепский; 6.12.02

При чем тут время обновления?

При переходе в ДРУГОЙ экран, где теги НЕ ОТОБРАЖАЮТСЯ, но опрашиваются из скрипта функцией GetTagMultiWait() по событию OpenPicture, мы имеем в Tag Management значения этих тегов равными нулю, а коды 4с (start value).
Re: Провалы в обновлении тегов.
Максим Прилепский; 7.12.02

Забыл добавить одну деталь: теги, отображаемые в таблице из полей расположены во вложенном в экран объекте Picture Window. Для отображения значений разных тегов в полях я динамически меняю свойство Tag Prefix у Picture Window.

Может быть проблема связана с использованием Tag Prefix ?
Re: Провалы в обновлении тегов.
Владимир; 9.12.02

Не совсем понятно, что происходит...

Вообще же просто при смене TagPrefix у Picture Window как правило ничего не происходит :-( ;необходимо принудительно закрыть и снова открыть этот Picture Window.
Re: Провалы в обновлении тегов.
Костенич Дмитрий; 11.12.02

Проблема знакомая - код 4с (start value) означает что значение тега не запрашивалось менеджером данных с момента старта RunTime. Данная проблема уже обсуждалась в форуме (см. ссылку), правда там утверждалось, что вызова функции типа GetTagMultiWait() достаточно для регистации тега на опрос менеджером данных.

Отсюда мораль - нужно гарантированно поставить теги на опрос. Как это сделать - самый верный вариант это привязать теги к чему-нибудь и задать циклический опрос. Правда такой вариант не всегда приемлем :)...

См. http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=996589679&year=2001


text

Еще раз про автозапуск
Владимир; 1.11.02

Снова поднимаю вопрос про автозапуск проекта WIN CC.

Утилита Autostart не решает проблем запрета доступа пользователя к системе, поскольку во-первых довольно долго идет загрузка проекта и за это время можно переключиться на desktop, можно нажать Ctrl-Alt-Del и т.д. я уж не говорю про кнопку Cancel.
Подскажите, как решать эти проблемы? Особенно интересует os WIN 2000.
Re: Еще раз про автозапуск
Коротов Дмитрий; 1.11.02

Используй редактор системных политик Poledit

Re: Еще раз про автозапуск
Владимир; 9.12.02

Пришлось воспользоваться

NT4 DeskTop Lock


text

Некоректно работают функции writetag и readtag в UserArchive.
Руслан; 9.12.02

В USERARCHIV есть такая штука как константы, определенные для прямого соединения с таблицей пользованельского архива. Так вот все константы работают, кроме ReadTag и WriteTag. В общем проблемма обстоит следующим образом, нужно мышкой клацнуть на строчку архива и по кнопке передать его значения, не по стандартной. Если кто знает как это сделать, пишите.


text

Фильтрация по классам а Alarm Logging'е
Бычков Андрей группа компаний "СПУТНИК"; 25.10.02

Добрый день всем!

При работе с фильтрами Alarm Logging'а возникла непонятная ситуация: фильтрация без проблем происходит по любым критериям, кроме класса сообщения.
Как только в структуре MSG_FILTER_STRUCT заполняю поля dwMsgClass и dwMsgType запрос перестает возвращать что-либо

Re: Фильтрация по классам а Alarm Logging'е
Alexis; 10.11.02

Привет!

У меня тоже не фильтровалось только по классам. Поговорил с wincc.odk-hotline@siemens.com, они сказали, что у них "...it works fine"....
А тут на днях проапгрейтился с WinCC 5.0 SP2 до WinCC 5.1 - и все заработало!
У тебя версия какая?
Re: Фильтрация по классам а Alarm Logging'е
Бычков Андрей ГП "Спутник"; 10.11.02

Привет!

Спасибо за отклик.
как раз у меня версия WinCC 5.0 SP2
И в самом деле, после того как сделал апгрейд до WinCC 5.1 - все заработало!

Re: Фильтрация по классам а Alarm Logging'е
Alexis; 11.11.02

Кстати, вот и подтверждение с wincc.odk-hotline@siemens.com пришло:

filtering by message classes are not possible by working with WinCC Verison
5.0 SP 2.
But is no problem by working with WinCC 5.1. In the following a code example how to filter by message classes

ZeroMemory(&Error,sizeof(CMN_ERROR));
ZeroMemory(&MsgFilter,sizeof(MSG_FILTER_STRUCT));

strncpy(MsgFilter.szFilterName,"Meldefenster",sizeof(MsgFilter.szFilterName));

MsgFilter.dwFilter=MSG_FILTER_CLASS;
MsgFilter.dwMsgClass=2;
MsgFilter.dwMsgType[1]=1;

bRet=MSRTStartMsgService(m_dwServiceID,CallBack_MSG_Servive,&MsgFilter,MSG_NOTIFY_MASK_ALL,NULL,&Error);

Так что пора тотально переползать под новую WinCC и искать новые глюки :)

... хоть бы евры платили за тестинг ...
Re: Фильтрация по классам а Alarm Logging'е
Шёл мимо; 9.12.02

Filter.dwFilter = MSG_FILTER_CLASS;

Filter.dwMsgClass =255;
Filter.dwMsgType[0]=3;
Filter.dwMsgType[1]=12;
Filter.dwMsgType[2]=48;
Filter.dwMsgType[3]=192;
Filter.dwMsgType[4]=64;
Filter.dwMsgType[5]=256;
Filter.dwMsgType[6]=512;


text

OP3 и русский язык ???
Wizzard; 12.11.02

В одной документации на ОР3,ОР7 было сказано что они могут поддерживать русский язык, может быть кто нибудь скажет как заставить ОР3 заговорить по русски???

Re: OP3 и русский язык ???
Павел; 28.11.02

OP3 по русски не может никак.

Есть подтверждение в каталоге и в жизни.


text

WinCC и OPC-Server
Роман; 28.11.02

При попытке просмотреть OPC сервер на одной WinCC машине с другой WinCC машины на компьтере, который предполагается сервером выскакивает сообщение "wrong opccomn_pc.dll version is registered". Что это такое. Может ли на это влиять то, что на этой машине установлен ещё один другой OPC сервер, но он полностью открывается и хорошо работает. Или может быть дело в авторизации?


text

панель Omron с S7/300
Papik; 25.11.02

Кто когда небуть конектил

панель NT31-Omron с s7/300
Парился,парился работает 5 секунд и
все.
Подскажите мог-быть хитрости какие есмть.


text

Косвенная адресация
Владимир; 12.10.02

Столкнулся с проблемой.

В PLC имеется около 80 DB состояний устройств с определенной одинаковой структурой. Требуется отображать состояние определенного DB по запросу оператора.
Для выполнения этой задачи на дисплее отображения состояния устройства используется большое (20-30) количество C Action (вычисление имен нужных тегов для отображения). При вызове дисплея система некоторое время (6-7 сек) "тормозит", затем все отображается нормально.
Предполагаю, что это происходит из-за процедуры регистрации в Tag Image тегов, используемых в C Action. Почему-то эта процедура отнимает очень много времени.
Как вариант можно использовать Global Action для предварительной регистрации тегов НО лавинообразно возрастает количество опрашиваемых тегов, поскольку нет процедуры "отрегистрации" тегов из Tag Image.

Можете подсказать способы решения проблемы???

PS Еще как вариант можно в PLC использовать только определенный DB и при вызове дисплея сообщать PLC нужный номер устройства для копирования в него состояния нужного устройства.
Re: Косвенная адресация
Костенич Дмитрий; 22.11.02

Ну вообще то, косвенная адресация напрямую поддерживается редактором Graphics Designer - если при привязке тега к свойству графического объекта поставить птицу в поле Indirect, то считается что привязанный тег содержит имя тега, из которого будт получаться значения присваиваемые данному свойству. Понятно, что привязываемый таким образом тег должен быть исключительно текстового типа.

Re: Косвенная адресация
Владимир; 22.11.02

Этот метод не подходит, т.к. специфика задачи требует именно "вычисления" нужного имени тега.

Пока найден выход в использовании Tag Prefix - но это не есть решение проблемы.
Кстати , уже поднимался вопрос об использовании в кадре с Tag Prefix "общих" тегов состояния.(http://www.automation-drives.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1027057738&year=2002) Кто как решил эту проблему?
Есть один вариант - при описанном выше методе (косвенная адресация) Tag Prefix не подставляется в имя, указанное в косвенном теге.


text

Проблемы с запуском RT
Алексей Понасенко; 22.11.02

Установлена ОС NT4.SP6

Проект WINcc работает когда вхожу в систему под свойм паролем .
А при входе других пользователей
в систему и попытке загрузить проект
выдает ошибку,ссылается на DCOM.


text

Бар графики в TP Designer
Рустам; 22.11.02

Как снять огарничение на количсетво на бар графики в Step 7 MicroWin 32/ТР designer для панели OP 070.


text

ODBC Sybase удалённый доступ.
Туманов А.; 25.1.02

Не удаётся подключиться к работающей базе RUNTIME проекта WinCC с помощью Sybase Central с удалённой станции (например, с мульти-клиента к серверу), в то время как проблем подключения к открытой базе с самого сервера, т.е. локально, или к закрытой базе удалённо не возикает.

Re: ODBC Sybase удалённый доступ.
И. Данилушкин; 29.1.02

Тут главное правильно настроить Пользовательский DSN в ODBC.

Нам помогло следующее.

1. Добавляется новый источник данных с драйвером Adaptive Server Anywhere 7.0

2. Заполняются поля:
2.1. на закладке Database
2.1.1. Server name = <сетевое имя сервера>
2.1.2. Start line = <сетевой путь до папки Sybase на сервере>\SQLAnyWhere7\win32\dbeng7.exe
2.1.3. Database name = <страшное имя, которое сгенерил WinCC на сервере, типа CC_Projekt_01-11-20_17:22:57>
2.1.4. Database file = <сетевой путь до файла базы данных, в нашем примере, до файла ProjektRT.db>
2.2. на закладке Network поставить галочку в окошке напротив поля TCP/IP

После этого мы смогли подключиться.

Да, всё это работает на WinCC 5.0 SP2
Re: ODBC Sybase удалённый доступ.
Владимир Ерохин; 15.11.02

Кстати, где "сетевое имя":

Если имя содержит тире (xxx-xxx-srv), то нужно ставить xxx_xxx_srv в DSN.

з.ы. С чего бы ему не понимать нормальное имя...


text

WinCC связать с Simatic S5
Денис Дроздов; 4.11.02

Устанавливаю драйвер S5 Ethernet Level 4, прописываю адрес контроллера и TSAPы. Вопрос: в контроллере в СР 143 что прописывать - хардварный ethernet адрес сетевой карточки в компе? Связаться пытаюсь посредством обычной сетевухи типа Intel.

Возможно ли вообще решение с использованием обычной сетевухи?
Re: WinCC связать с Simatic S5
Алексей; 4.11.02

Да в СР 143 прописываешь Mac адрес сетевой карточки компа.Связь должна быть без проблем.

Re: WinCC связать с Simatic S5
Денис Дроздов; 5.11.02

Попробуем... А как диагностировать связь?

Re: WinCC связать с Simatic S5
Алексей; 5.11.02

А диагностировать связь ты хочеш иметь постоянный контроль или просто убидится что сязь есть?

Чтобы убидится что сязь есть используй
WinCCExplorer-Tools-StatusDriver Connections.Или Channel Diagnosis.
Re: WinCC связать с Simatic S5
Денис Дроздов; 6.11.02

А, один хрен! Все равно не получилось через 3com сетевуху подрубиться - чего-то в ВинСеСе не хватает.

Re: WinCC связать с Simatic S5
Алексей; 6.11.02

Странно,а у меня на пробном проекте все

прекрасно работает.Сетевая 3Com S5-115 и S5-155 c CP1430TF.
Re: WinCC связать с Simatic S5
Денис Дроздов; 10.11.02

У меня в контроллере стоит CP 143. Может от этого?

Re: WinCC связать с Simatic S5
Baby; 10.11.02

Привет, Денис !!!

Как настрой ????????
Надо задать вопрос, я надеюсь вдруг кто ответит...
А что, это за зверь такой СР143......
А то Вы , да и наверно и я не можем до конца разобраться с терминологией CP....

CP1430TF ??????
CP 143 ???????

Что это..... за CP ???
Удачи !!!! ;-) !!!!!

Re: WinCC связать с Simatic S5
Денис Дроздов; 10.11.02

Ну почему же... CP - коммуникационный процессор по терминологии Siemens'а. СР 143 - пихается в корзину контоллера для подключения оного к H1-Bus, т.е. Industrial Ethernet.

СР 1413 и СР 1613 тоже коммуникационные процессоры, но вставляются в компьютер. Нужны для связи с контроллером или его программирования. СР 1613 - PCI карта.
Что такое СР 1430TF не знаю, не видал.
Re: WinCC связать с Simatic S5
Baby; 10.11.02

Снова я .....

Денис, большое Вам спасибо за просвещение..... особенно насчёт
СP143 и СР 1613...
Не знаю, что бы я без Вас делал... :))))))) !!!!!

Пока......

Re: WinCC связать с Simatic S5
Алексей; 11.11.02

СР 1430TF - тоже пихается в корзину контоллера для подключения к H1-Bus, т.е. Industrial Ethernet.Номер 6GK1143-0TA02.

Re: WinCC связать с Simatic S5
Денис Дроздов; 12.11.02

Контроллер ковырять нельзя, только компьютер. Поэтому решение в лоб - ставим плату СР 1613 и наслаждаемся.


text

Вопрос по ОР7
Николай; 5.11.02

Можноли какимнибудь средствами скачать прошивку из панели ОР7 ?

Re: Вопрос по ОР7
Сергей; 5.11.02

Prosave

Re: Вопрос по ОР7
Чистяков Дмитрий ОАО "СеверСталь"; 11.11.02

Но только для переноса прошивки в другую панель. Открыть в проекте ProTool не получиться.


text

WinCC в WindowsXP!?
Хлопин Денис; 1.11.02

Можно ли поставить WinCC на комп с операционкой WindowsXP? Если да, то как?

Re: WinCC в WindowsXP!?
Сергей; 5.11.02

Поставить можно любым способом, НО работать не будет ПО ЛЮБОМУ. Эмуляции ОС не помогут.

Совместимость с ХР Сименс обещает к концу года.


text

Документация по РР7
Сергей; 25.10.02

Здравствуйте!

Мне очень нужна документация по РР7 на русском языке. Может кто знает где она есть.

Спасибо

Re: Документация по РР7
Сорокин В.; 4.11.02

На русском нет, есть на английском бесплатно, конечно, на ООО "Сименс".


text

Доступ по сети к папке с WinCC
Юрий Оганесян; 29.10.02

WinCC при запуске самостоятельно открывает ПОЛНЫЙ доступ по сети к папке с проектом для "Всех", что создает угрозу понятно чего (W2k pro). Как можно защитить проект от постороннего вмешательства? Можно ли заставить WinCC не зашаривать папку? Или какие административные меры нужно предпринять, чтобы пользователи со стороны не смогли испортить проект?

Re: Доступ по сети к папке с WinCC
Eleria; 29.10.02

Не пробовал создать другого пользователя и назначить права ему а все остальные отменить ????

либо пошарься в политике удаленного доступа попробуй что то вроде этого же....
Re: Доступ по сети к папке с WinCC
Алексей; 29.10.02

Можно воспользоватся свойствами файловой систымы NTFS.

Кому только чтение,а кому и Full Acces.
Re: Доступ по сети к папке с WinCC
Юрий Оганесян; 30.10.02

Если бы все было так просто, я бы не стал утомлять Уважаемых Участников Форума. Дело в том, что WinCC САМА открывает доступ к папке проекта (и делает полный доступ для "Всех"), а если запустить ее на профиле пользователя, который не имеет на это прав (обычный User, не адванснутый), то она отказывается работать - даже проект не открывает!

Re: Доступ по сети к папке с WinCC
Дмитрий Филь; 1.11.02

Я решил для себя эту проблему так:

К примеру есть Step7 проект с HMI на WinCC, лежит по такому пути C:\S7Proj в нем есть папка Wincproj, на уровень ниже лежит папка с названием проекта (к примеру OS1). На папке Wincproj кликаешь правой кнопкой мыши -> Доступ -> Безопасность. Убираешь галку "Переносить наследуемые от родительского объекта разрешения на этот объект" Убираешь группу пользователей "Все", вписываешь нужных тебе пользователей и раздаешь им нужные права. Далее жмешь на кнопку "Дополнительно" и ставишь галку "Сбросить разрешения для всех дочерних объектов и включить перенос наследуемых разрешений". Жмешь на кнопку "Ок" раз, а потом еще раз, происходит перенос разрешений. После этого запускаешь WinCC и ... о чудо! в папку с WinCC по сетке ломятся только те кто нужно.


text

Срочно нужна помощь!!!
vitalgan; 29.10.02

На другой машине поставил WINCC. Записал туды проект, который был сделан на другой машине с таким же WINCC.

Появляется ошибка:
Server not avialble
После этого проет не активизируется.
Re: Срочно нужна помощь!!!
Бычков Андрей ГП "СПУТНИК"; 30.10.02

Re: Срочно нужна помощь!!!
vitalgan; 30.10.02

Ставлю начальную страницу загрузки, а она пропадает после принятия изменений.

Активирую проект, он начинат активироваться и сразу вываливается не активировавшись. Аврийные сообщеня кудато делись. Ничего не понимаю!
Хотя переписал проект целиком. Такое ощущение как будто бы чтото не доусановлено.
Помогите, срочно нужно!
Re: Срочно нужна помощь!!!
Владимир; 30.10.02

Ххы

а авторизация?
Re: Срочно нужна помощь!!!
vitalgan; 30.10.02

Авторизация есть!

Установлено кажется все. Кажется WinCC не видит этот проект. Нету аварийки и графических страниц тоже не видит. Ничего не видит.
Re: Срочно нужна помощь!!!
Максим Поджидаев; 30.10.02

Могу ошибаться, что то подобное встречалось, когда меняли статус компьютера с клиента на сервер. При этом компьютер хотя и считался сервером всё равно пытался подключаться к своему прежнему "хозяину". Мы лечили это удаляя компьютер из списков "хозяина" и отключением сети в момент первого запуска .

Вариант 2. Криво поставлена WinCC, Windows.
Re: Срочно нужна помощь!!!
Хлопин Денис; 30.10.02

У меня была такая же ситуация! Комп тормозил, я решил систему переставить, переустановил WinCC, Step7, переписал проект и точно такая же фигня, рисунки не отображаются и т.п. и т.д. Весь день переставлял Windows 2000, глюк все повторялся и повторялся. Лишь один раз проект запустился, но Винды настолько криво встали, что Step7 не поставился, дальнейшие переустановки не привели к успеху, пришлось взять другой комп, с установленным софтом.

Однозначно, проблема в установке! Скорее всего Винды кривые или с железоm что-то?! Эта проблема возникла у меня лишь с одним компьютером, при чем, до переустановки все работало!
Re: Срочно нужна помощь!!!
Юрченко Владимир; 31.10.02

В данном случае все было проще - не была установлена сеть с TCP/IP протоколом, а без этого проект не запускается. Подробности смотрите на

немецком FAQ: www4.ad.siemens.de:8080/news/csi/en/9126124
Re: Срочно нужна помощь!!!
Александр, СКТЦ; 31.10.02

Проверь установки на закладке StartUp

в Computer Properties
Re: Срочно нужна помощь!!!
vitalgan; 31.10.02

Проблема уже решена!

Всем спасибо за помощь.
Особая благодарность Владимиру Юрченко.


text

WinCC 5.x OPC Сервер. Зависания.
Владимир Ерохин; 31.10.02

Здравствуйте!

Никто из присутствующих на форуме не сталкивался с проблемой необоснованного зависания OPC сервера (OPCServer.WinCC)? Зависает именно клиент при обращении к методам сервера при чтении данных.Зависания происходят по непонятным причинам и "намертво".
На станции WinCC при этом выводится сообщение что-то вроде Access Violation.
Подскажите, как с этим бороться.
Re: WinCC 5.x OPC Сервер. Зависания.
Юрченко Владимир; 31.10.02

Я думаю дело не в WinCC, а в клиенте.

Скорей всего что то с передачей параметров в функциях чтения. Или Вы обращаетесь к опционным методам OPC сервера не проверив их наличие. Проверьте на других серверах (могу выслать сервер для теста). По крайней мере примеры клиентов с call-back - функцией OPC мною проверялись и работают с WinCC OPC без проблем.
Могу выслать примеры клиентов на VB, VBA и Delphi.

Re: WinCC 5.x OPC Сервер. Зависания.
Ерохин Владимир; 31.10.02

С другими ОРС серверами проверялось (и с несколькими). Никаких опциональных методов не используется. Используется только IOPCSyncIO::Read().

Callback работает нормально. Зависание только при периодическом (!) вызовом (период около 3-5сек). Причем зависание может произойти и через несколько минут и через сутки.
Клиент работает с ОРС сервером через DCOM, по сетке. Локально не используется.
Попробуйте периодически опрашивать тегов этак 20 (у меня больше используется, но я проверял и с 2мя тегами - такая же петрушка).


text

Графики и перевод времени
Максим Поджидаев; 28.10.02

Здравствуйте господа.

Интересный глюк проявиля в WinCC 5.1 hotfix1 с переходом на зимнее время. Напомню, что 27.10.02 у нас два раза повторился диапазон времени 2-3 ночи. После этого данный диапазон невозможно стало просмотреть, сплошная вертикальная решётка. Однако играя диапазоном отображения (<=25 мин) можно добится нормального отображения (с одной вертикальной линией на границе диапазона). Частота опроса/записи - 1 секуна. Рядом стоящие станции под WinCC 4.02 проявили себя нормально. Интересно, я один с этим встретился, или кто нибудь ещё?

Re: Графики и перевод времени
Евгений Трунов; 28.10.02

Это грустный "прикол" трендов WinCC (в 5.0 SP1 то же самое). При любом наложении временных меток отображаемых данных (например, при заполнении "дыр" с помощью WinCC Redundancy) - изображение портится таким вот образом. Кто-нибудь знает, как это лечится, если вообще лечится?


text

Запаздывание записей в Tag Logging
Петров Андрей; 24.9.02

Помогите, пожалуйста, решить проблему с 2-10 часовым отставанием записей данных в архив. Просмотр RunTime базы средствами Sybase подтверждает отставание. Данные при этом не теряются.

Re: Запаздывание записей в Tag Logging
Колпащиков Сергей. Аквтехнология; 25.9.02

Этот вопрос уже обсуждался.

В Sybase данные поступают точно с запаздыванием, т.к. WinCC использует буфер которым нельзя управлять. Если хотите брать данные без запаздывания пользуйтесь ODK.
Re: Запаздывание записей в Tag Logging
Бычков Андрей группа компаний "СПУТНИК"; 25.10.02

Функция TLGGetArchivDataEx заставляет сбросить кэш по архиву, который указан в параметре, в базу.

Поэтому, если есть возможность, перед SQL запросом вызывайте TLGGetArchivDataEx


text

Доступ к ActiveX из script'a
Юрий Оганесян; 2.10.02

Добрый день!

Можно ли вызвать МЕТОД внедренного на страницу WinCC "чужого" ActiveX-control'a? И как...?
Re: Доступ к ActiveX из script'a
Евгений Трунов; 2.10.02

А если использовать вот это из pdlrtapi.h:

BOOL WINAPI PDLRTInvoke(
ADRMODE adrMode,
LPCSTR lpszPictureName,
LPCSTR lpszObjectName,
LPCSTR lpszMetName,
VARTYPE vtRet,
LPVOID pvRet,
DISPPARAMS* pDisp,
PDLRT_CALLBACKA pfn,
LPVOID pvUser,
PCMN_ERRORA pError
);
Re: Доступ к ActiveX из script'a
Юрий Оганесян; 4.10.02

А где можно посмотреть описание этой функции?

В ".h" файле она действительно есть, но я не смог найти ее описание в ODK.
Re: Доступ к ActiveX из script'a
Евгений Трунов; 7.10.02

А нигде :). Её там и нет. Жизнь, как известно, это борьба с трудностями.

Но сама по себе эта функция - классический IDispatch::Invoke(), с поправкой на WinCC-шные реалии. Invoke() подробнейшим образом описан в любом учебнике по OLE-автоматизации.
Re: Доступ к ActiveX из script'a
Sergey G. Shestakov; 11.10.02

Самое смешное... Можно доступится ко многим методам стандартных ActiveX. Я , например, много раз использовал методы ComboBox и ListBox, и даже подключил через OLE MS Excel. К несчастью, я обнаруживаю, что со временем это дает сбои в работе Global Script. Скорее всего проблемы не в WinCC конкретно, а в механизмах взаимодействия Windows.На мой взгляд, кажется, разработчикам WinCC пора бы сменить платформу, и переходить, может быть на Unix, или что-нибудь подобное. Это мое, может быть субъективное мнение....

Re: Доступ к ActiveX из script'a
Костенич Дмиртий; 25.10.02

Эта тема обсуждалась в прошлом году. Впрочем, можно и напмнить (привожу пример):

#include "apdefap.h"
void OnClick(char* lpszPictureName, char* lpszObjectName, char*
lpszPropertyName)
{
#define GetObjectA GetObject

__object *obj = NULL, *pic = NULL, *ocx = NULL;
obj= __object_create("PDLRuntime");
if(!obj)
{
printf("obj = NULL\r\n");
return;
}
pic = obj->GetPicture("NewPdl0");
if( pic == NULL){
__object_delete(obj);
printf("pic != NULL\r\n");
return;
}
ocx=pic->GetObject("OLE Control1");
if( ocx == NULL){
printf("ocx = NULL\r\n");
__object_delete(obj);
__object_delete(pic);
return;
}
ocx->AboutBox();
__object_delete(obj);
__object_delete(pic);
__object_delete(ocx);

}


text

Видео
Андрей; 21.10.02

Подскажите, как из WinCC запускать видео файлы (*.avi,*.mpeg,...).

Только сразу, а не так, что сначала запускается оболочка, а потом вручную открывается видео файл.Спасибо.
Re: Видео
Василенко; 22.10.02

Smart Objects/Controls/Media Plaer

Property/.../File=<мультимедиа филе>
может чего забыл


text

Панель OP170B
Mazda; 21.10.02

Пауза при переключении между экранами достигает до 5сек. Является ли это нормальным для панелей с Win CE или может существуют тонкости в её параметрировании?


text

Backup базы данных в WinCC
Коротов Дмитрий; 14.10.02

Какими средствами можно сделать backup базы данных на ленту.

Re: Backup базы данных в WinCC
Иван Данилушкин; 17.10.02

Уже обсуждалось:

http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1026131719&year=2002


text

Передача сообщений из Step->WinCC
Sol; 17.10.02

Здравствуйте.

Есть проблемма с диагностическими сообщениями, переданными из Step-а в WinCC.
Делаю так:
1) В Simatic Manager-е станция-> Hardware->CPU , в меню Options->Report System Error
Создаю диагностический блок (FB,DB)
2) После генерации, созданная DB -> Special Object Properties->Message открывается Message Configuration, где отображаеться информация по всей набранной линейке, типа
Rack 0,
Rack 0 Slot 1
и т.д.
Напротив каждого , в General Data находится сгенерированное сообщение.
3) Добавляю New Device ->WIN_CC, где в 3 блоке помещаются эти сообщения,напр:
Rack 0: @1W%t#ErrTextLib@\nName: UR\nCPU: CPU 315-2 DP,
где ErrTextLib - это имя текстовой библиотеки Step-а, где храняться сами тексты ошибок.
4) Options->PLC-OS Connection Data-> Transfer, передаю в WinCC.
5) Передача проходит успешно, после чего в Alarm Logging появляються все эти сообщения в соответсвующем блоке 3(кроме Info Text).
До этих пор все абсолютно ясно, но при запуске WinCCRT и генерации какого нибудь трабла(например извлечение батарейки из контроллера) выдаётся таки соответсвующая ошибка, только без
текста самой ошибки (или левый текст ошибки).
Т.е макрос @1W%t#ErrTextLib@ обращения к текстовой библиотеке ErrTextLib выполняется неверно(или вообще не выполняется).
В Step-e же,PLC->CPU Message - все эти сообщения выводятся абсолютно корректно.
Таже история и с Symbol-Related Messages, которые параметрируются из символьной таблицы.


text

Graphics Designer
Андрей; 16.10.02

Подскажите, где скачать рядовую картинку для WinCC парового котла со всем оборудованием, или пришлите пожалуйста.

Нужна для личных целей, а рисовать самому ... ну, придется самому рисовать если не пришлете... Спасибо.


text

Ограничение на количество панелей с серменте для CPU 315-2DP
Ruslan; 16.10.02

Существует такая проблема. Есть проект CPU 315-2DP, 3 панели OP 7, и WinCC станция, так вот больше 3 OP не хочет работать, т. е. либо работают 3 панели либо 2 панели и WinCC, 3 панели и WinCC никак не хотят... подскажите пожалуйста в чем дело ?


text

CFC, Dig_Mon: message classes - смысл?
Зверев Игорь; 14.10.02

Просветите, пожалуйста!

В мануале есть лишь описание 6-ти классов сообщений данного блока. Но как они работают при переходе дискретного входного сигнала из "0" в "1" и обратно?
Проблема is: нужна сигнализация перехода из "1" в "0". любой же назначенный message class (1-6) сигналит только при переходе из "0" в "1"!
Что такое "инверсия входа" знаю :), не подходит...

Заранее спасибо.
Игорь.
Re: CFC, Dig_Mon: message classes - смысл?
Евгений Трунов; 15.10.02

А почему, собственно? :) Для срабатывания "по срезу" (1 -> 0) вполне подходит флажок "is created on a negative edge" (Alarm Logging->Single Message->Properties).

Re: интересует мессага именно от контроллера,
Зверев Игорь; 16.10.02

а не из WinCC.

Спасибо, это конечно же вариант :)
Но все-таки, в DIG_MON есть такая возможность?


text

Не запускается ни один проект на ТР-170ВС
Гапонов Сергей; 11.10.02

В момент загрузки проекта с компьютера в панель отключилось питание. После включения панель выдает стартовое меню, каждые 10 сек пытается запустить проект, каждый раз-неудачно, тут же возвращается в стартовое меню.

Новые проекты грузятся благополучно, если не установлена функция обратной загрузки (иначе-не грузится:
"Insufficient storage space for PDZ file...")
Операционку в панели меняли - безрезультатно.
Кто сталкивался - подскажите, есть ли выход?


text

Как передать некий набор данных в MSFlexGrid?
Роман Чуликов; 11.10.02

Дело в том что БД в которой хранятся данные уже выросла и стандарным способом вывода AplicationWindow->Tag-Loging данные отображаются все,а нам необходимо отобразить только последнии 100 записей.

Версия WinCC 4.02Sp2 используется старый способ работы с юзер архивыми,т. е. через Tlg функции.
Есть идея воспользоватся ADO методами и получить необходимую информацию в табличной форме с помощью MSFlexGrid, но как конкретно перекинуть данные из Recordset незнаю.
Может кто уже разбирался с подобной задачей?
Если есть другие идеи-ради бога, буду только презнателен.
С уважением Роман Чуликов.


text

Проблемы с архивированием в RT
Коротов Дмитрий; 11.10.02

не могли-бы написать пример использования какой-нибудь ODK-функции, котороя-бы принудительно скидывала данные из архивов из буфера в базу RT. Уже всю голову себе сломал. Пришлите пример на Email


text

Проблемы с графиками WinCC
Руслан; 10.10.02

Существует такая проблема, когда вставляешь в Graphics Designer график Online Trend Control можно показывать внизу графика значения, функция dispay value and position, там 4 колонки: название тега, путь тега, значение и время, можно ли одну из этих колонок, например путь тега, убрать ?

Re: Проблемы с графиками WinCC
Александр Родин, ООО "Нева Электрик"; 10.10.02

Возможно, если кто-то отважится переписать ActiveX-элемент Online Trend Control, то можно будет и убирать все колонки по выбору... А пока сие невозможно... :)


text

GlobalActions замирают на время...
Александр Туманов; 9.10.02

Ситуация: на WinCC-сервере крутятся GlobalActions, но иногда они останавливаются, повторный запуск их может быть инициирован без остановки проекта - достаточно открыть этот проект на удалённом WinCC-User (WinCC-User открывается на станции, на которой штатно работает WinCC Multi-Client - его предварительно нужно закрыть). Что происходит?


text

Нужна помощь по Alarm Logging
Владимир; 8.10.02

Задача - при изменении некоего параметра необходимо выдать сообщение о том что он изменился и выдать новое значение.

При формировании аварийного сообщения в тексте сообщения используются переменные процесса.
Однако почему-то в Alarm Control выдается не новое а старое значение переменной!
Помогите разобраться!
Могу на мыло выслать тестовый проект с этой задачей.
Re: Нужна помощь по Alarm Logging
Александр, СКТЦ; 8.10.02

Эта тема обсуждалась, поищи ниже.

Re: Нужна помощь по Alarm Logging
Владимир; 9.10.02

Может есть у кого пример генерации вручную сообщения в Alarm Logging?

(чтобы я сам мог сформировать текст сообщения)
HELP!


text

пароль для OP
Mike Lourier; 1.10.02

Есть несколько панелей (op7,op17,op27,op37), доступ к системным параметрам и программированию закрыт паролем. Как можно его узнать?

Re: пароль для OP
Alex; 1.10.02

Обычтно 100

а если нет то только в проекте

Re: пароль для OP
fog; 9.10.02

Раньше у панелей была такая клемма - если подать 24В, то это равносильно заданию пароля администратора - желаю удачи!


text

Protool v.5.2 vs Protool v.6.0
Фирсов Антон; 6.10.02

Вопрос в следующем: прочитает ли Protool v.6.0 программу, сделанную в Protool v.5.2?

Re: Protool v.5.2 vs Protool v.6.0
Александр, СКТЦ; 6.10.02

Прочитает

Re: Protool v.5.2 vs Protool v.6.0
Фирсов Антон; 6.10.02

И потом никаких проблем с перепрошивкой не будет?

Re: Protool v.5.2 vs Protool v.6.0
Александр; 8.10.02

Проект сохраненный в Protool v.6.0 не открывается в Protool v.5.2

Я работаю с Protool v.6.0 sp1, проблем с перепрошивкой панелей не было.
Единственное, для загрузки проекта в панель MP270 с помощью v.6, потребовалось обновить ПО панели.

Re: Protool v.5.2 vs Protool v.6.0
Фирсов Антон; 8.10.02

Спасибо, у нас OP 17.


text

WinCC Client/Server адресация
Хлопин Денис; 8.10.02

Есть готовая программа на WinCC - сервер, как лучше состряпать из сервера полнофункциональный клиент, практически ничего не меняя? Как я понял, адресация в клиенте изменяется полностью, а проект большой, что посоветуете?

Re: WinCC Client/Server адресация
Колпащиков Сергей. Акватехнология; 8.10.02

Не очень понятно какую адресацию вы имеете в виду.

Если добавить еще один компьютер-client в проект, то все работает автоматически: ТЭГи, PDL, Actions и т.д.
Re: WinCC Client/Server адресация
Хлопин Денис; 8.10.02

Скорее не адреса, а наименования тегов. При создании клиента нужно сначала на сервере создать пакет данных, а с клиента их считывать,к примеру, на сервере тег имеет имя TAG, а клиент обращается к нему как к тегу с именем что-то типа PackName:Tag , если проект большой, то придется все имена менять ручками. Можно ли это как-нибудь обойти?

Re: WinCC Client/Server адресация
Колпащиков Сергей. Акватехнология; 8.10.02

А вы какой проект создаете

Multi-Client?

Re: WinCC Client/Server адресация
Хлопин Денис; 8.10.02

Да


text

Количество осей в трендах WinCC
Руслан; 8.10.02

Существует такая проблемма есть 6 графиков в тренде а нужно чтоб было 2 оси, остальные повторяются, можно ли сделать такое с помощью WinCC, и хотелось бы чтоб один был спправа а другой слева, спасибо за любую рекомендацию.


text

Адресация через OPC сервер
Vitalgan; 4.10.02

Была проблема подключения 200 контроллера по ProfiBus-у как slave устройство, где мастером выступает комп. Решили эту проблему через OPC сервер. В WinCC данные прибывают в Байтах. А надо их разбить на биты. А как? Может есть другое решение проблемы?


text

Скачать файл .pdb из OP37 в Protool V5.2 ?
Алексей Сизов; 22.3.02

Имеется ли такая возможность? В меню есть опция Download back... и требует соединения. Пробовал ли кто-нибудь?

Re: Скачать файл .pdb из OP37 в Protool V5.2 ?
Чистяков Дмитрий ОАО "СеверСталь"; 26.3.02

Скачать, то можно, но вот только для перезаписи его в другую OP.

Редактировать этот как проект нельзя.

Re: Скачать файл .pdb из OP37 в Protool V5.2 ?
Борис Дертунов;НПО"Автоматика"ММК; 30.9.02

Опция "Download back" служит не для выкачивания проекта, а для дополнения(насколько я знаю)А проект для ОР можно выцепить из полного zip файла либо срисовать все экраны и написать всё заново


text

Как узнать имя тэга от которого сработал action???
Колмыков Дмитрий; 30.9.02

Как узнать имя тэга от которого сработал action, если action настроен на изменение нескольких тэгов???


text

Связь WinCC и Simatic S5
Александров К.; 27.9.02

Возможно ли связать контроллер Simatic S5 и станцию на базе WinCC через Ethernet без использования CP через обычную сетевую карту?

Re: Связь WinCC и Simatic S5
Евгений; 27.9.02

Можно попробовать завязаться по com порту через AS-511 интерфейс

Re: Связь WinCC и Simatic S5
Alex; 27.9.02

У меня контроллеры Simatic S5 с Cp1430TF работают через Ethernet с использованием 3Com сетевой карты.

В Wincc использую "SIMATIC S5 Ethernet Layer 4".Проблем незамечено.


text

Имя тага в ProTool6:сколько же символов допускается?
Ефременко Денис; 27.9.02

В ProTool Pro 6.0 допускается в поле ввода имени тега вводить уже не 12 символов, а больше. Однако, в хелпе, в частности к графическим панелям, указано, что максимум все же 12 символов. Попробовал таги с именем больше 12 символов закачать в OP27, вроде все нормально. Сколько же все-таки символов писать в имени для избежания возможных глюков.

Re: Имя тага в ProTool6:сколько же символов допускается?
Юрченко Владимир; 27.9.02

Связь тегов с реальными адресами в контроллере идет не по именам, а по внутренним индексам в сконфигурированном ProTool файле. А упоминание о длине в 12 символах осталось в файлах описаний созданных, когда это было актуально для старых версий ProTool.


text

Связь Protool v5.2 с Simatic S5
URALEX; 27.9.02

Связь по АS511 работает нормально, без замечаний.

Изменили связь на Profibus DP через IM308C, на контроллере все светодиоды горят зеленым цветом, т.е. все в порядке, но в Protool.е постоянно появляется что то вроде "светомузыки",хаотично мигают теги. Подключаемся по АS511 параллельно с другого компьютера, этот проект работает, а через Profibus не хочет, в чем проблема, в настройках Protool? Что нужно менять при переходе от соединения по АS511 на Profibus?


text

Срочно нужна OP7 c DP-интерфейсом со склада в Москве
Юрий Рузаев; 27.9.02

До 30 сентября 2002 г. купим OP7 c DP-интерфейсом (6AV3607-1JC20-0AX1) со склада в Москве.

Тел. 095-279-44-11, -93-33, 24-94.
Моб. 8-902-173-92-71


text

Возможно ли сделать Beep() на WEB-клиенте ?
Дмитрий; 26.9.02

Возможно ли сделать Beep() на WEB-клиенте. По кнопке (Mouse Action) работает , а как бы сделать по событию ? (WebNav 1.1, WinCC 5.0 sp2)


text

Отладка DLL, подключаемой к WinCC
Сергей Мельник; 24.9.02

Имеется DLL, чьи функции вызываются из скрипта WinCC.

Очень хочется отлаживать эти функции в пошаговом режиме непосредственно при их вызове из WinCC.
Я работаю в VisualC++. Подскажите, пожалуйста, как это сделать.
Re: Отладка DLL, подключаемой к WinCC
Василенко; 25.9.02

Сделать Set as active проект DLL и его Run. Executable for debug sessin сделать Siemens\WinCC\bin\WinCCExplorer.exe

. Контрольные точки в DLL будут срабатывать(может я что-то забыл еще проставить)

Re: Отладка DLL, подключаемой к WinCC
Сергей Мельник; 25.9.02

Поясните пожалуйста, что значит "Сделать Set as active проект DLL и его Run".

Re: Отладка DLL, подключаемой к WinCC
Василенко; 25.9.02

Сделать активным проект который создает DLL и запустить его. VC при первом запуске спросит где взять exe для выполнения, нужно выбрать WinCC....


text

Coros LS-C на WinCC
Денис Дроздов; 25.9.02

Вот такая вот задача стоит. Вопрос в подключениии к контроллерам. Есть несолько контроллеров S5 соединенных Sinec H1, в одной корзине стоят коммуникационные процессоры CP-30 для связи с рабочими станциями COROSa. Как туда врубиться(программно) чтобы заменить COROS на WinCC? Варианты: сделать сервера новой нодой в сети(меняем программу в контроллерах) или попытаться поключиться вместо рабочей станции COROSa(непонятем принцип адресации и сбора данных).

Re: Coros LS-C на WinCC
Baby; 25.9.02

Привет,Денис !!!

Как погода, у Вас ?
Немного ошибок в Вашем послании:
несолько ???
CP-30 ?????
непонятем принцип адресации и сбора данных ?????

Уважаемый Денис... Ведь Mr. Чистяков Д. ОАО "СеверСталь",
Вам в Промышл. сети SIMATIC NET очень подробно расписал, что делать....
Узнайте до мелочей всю систему базисной автоматизации,какая стоит на установке (агрегате или ....) и решение придёт....

Re: Coros LS-C на WinCC
Дроздов Денис; 25.9.02

Погода ничего, довольно тепло.

Контроллеров 13 штук, в одном из них собираются данные со всех остальных и передаются куда надо, в т.ч. и в систему COROS LS-B. Терминалы подключены к плате СР-С30(6AV1-222-0AD20) заточенной специально под это дело(COROS присоединять).
С сетями разобрался в том смысле как физически подключиться. Неясен вопрос - можно ли подключить комп через эту самую плату или вешать в сеть отдельной нодой, меняя программу в контроллере.


text

GAPICreateNewVariable
OrionS35; 30.4.02

Функция GAPICreateNewVariable может изменить свойства тега.

В WinCC 4.02 она вызывается а в
WinCC 5 выдает ошибку
Project editmode requiered
С чем это связано ?
Re: GAPICreateNewVariable
Костенич Дмитрий; 15.5.02

А ты, случайно, не забыл указать флаг MCP_NVAR_FLAG_MODIFY в поле dwFlags структуры, идущей первым параметром этой функции? Если не забыл, то проверь - этот флаг не любит, когда вызов GAPICreateNewVariable выполняется при запущенном RunTime.

Re: GAPICreateNewVariable
Александр; 16.5.02

Из ODK:

DM_E_OP_REQUIERES_PRJEDITMODE
Project editmode requiered
Example: An operation requieres that the project is not active

Похоже что 5-ка (в отличие от 4-ки) для использования CS функций явно требует закрытия Runtime.

Обходной путь - работать с таблицей MCPVARIABLEDESC напрямую с помощью например DB функций того же ODK. Правда для того, что-бы изменения вступили в силу, все равно необходимо будет перезапустить Runtime.
См. http://СКТЦ

Re: GAPICreateNewVariable
Евгений Трунов; 16.5.02

Ну хорошо, флаг не любит. Так надо ведь именно при запущенном Runtime. А есть кто-то (флаг, функция...), которая любит? Короче говоря, как изменить свойства тега с помощью функций WinCC API в режиме Runtime? Чтобы изменения сразу вступили в силу и сохранились в последующих сессиях как Editmode, так и Runtime?

Re: GAPICreateNewVariable
Александр; 16.5.02

Для того чтобы изменения свойств тега (например масштабирование) вступили в силу сразу (без перезагрузки Runtime) после редактирования (неважно, делается это с помощью SQL или вызова GAPICreateNewVariable) таблицы MCPVARIABLEDESC в конфигурационной базе WinCC необходимо каким-то образом заставить Data Manadger перечитать эту таблицу.

Если кто знает, как это сделать
прошу поделиться информацией.
Re: GAPICreateNewVariable
Яковлев Лев; 24.9.02

Свойства тэга можно менять в RunTime функцией GAPICreateNewVariable4Ex, но перед этим необходимо в CS-mode поменять у этого тэга dwCreatorID = 10101 той же функцией.Не забудьте пронулить структуры : ZeroMemory(&NVarData, sizeof(NVarData)). С dwCreatorID = 10101 тэг не удаляется и не редактируется в tag manager.Кстати, так можно менять и Start value, т.е.восстанавливать внутренний тэг при перезагрузке.


text

Почему OCX - CCUATableCtl1 не отображается через WEB ???
Дмитрий; 16.9.02

Имеем WinCC v5.0 sp2, WebNavigator v1.1

всё хорошо, но вот компонент WinCC User Archive - Table Element отказывается показываться в браузере. Может, кто нибудь подскажет, в чём дело
?

Re: Почему OCX - CCUATableCtl1 не отображается через WEB ???
Юрченко Владимир; 24.9.02

User Archive в WebNavigator (v.1.1 и 1.2) и не должны работать. Смотрите в файле описания (WebNavigator.chm) ограничения на использумые компоненты и опции WinCC.


text

Re: ОР-25
Эрик; 14.6.02

Как изменить дату и время в панели оператора ОР-25?

Re: Re: ОР-25
Ефременко Денис; 23.9.02

Самое простое при создании в проекте новой OP25 в визарде в последнем окне поставь галочку "Use standard project". И в экране Z_SETTINGS ставь.

А вообще это делается с помощью функций Date Display/Edit, Time Display/Edit в свойствах стринговых тегов.


text

OP7 печать по русски
yura; 19.6.02

Как заставать принтер DR2030 печатать с ОР 7 по русски

Re: OP7 печать по русски
Ефременко Денис; 23.9.02

Нужен принтер с ECMA раскладкой, например:

DR 2040 + ECMA 9014 карта.
Я в свое время тоже столкнулся с такой проблемой, однако решить ее не хватило времени.Просто печать идет транслитералами - эксплуатация привыкла, так как все довольно читабельно


text

Переменные из WinCC в PLC не записываются
Дмитрий Филь; 19.9.02

Переменные считываются из контроллера, а запись в контроллер корректно не происходит (например, возьмем кнопку, при нажатии на которую взводится бит. Так вот "1" записывается в контроллер только после 20-30 нажатий на кнопку). В проекте около 650 переменных, время обновления 100мс (почти у всех перемнных).

У меня сеть MPI, на ней PLC(315 2DP) и PC(PIII,450MHz, 128Mb ОЗУ, OS WinNT4) c WinCC(V5.1 HF2).

Подскажите, почему так происходит?
Зараннее благодарен за любую помощь.
Re: Переменные из WinCC в PLC не записываются
Евгений; 20.9.02

А с upon change та же ситуация? Кнопка случайно сделана не в собственной "панели" как элемент? Если да , то надо "разобрать панель" и отдельно для этой кнопки побаловаться параметрами.

Re: Переменные из WinCC в PLC не записываются
Дмитрий Филь; 20.9.02

Кнопка самая обычная, на событие Mouse Action которой написана функция, которая должна взводить бит в контроллере. C upon change тэги из контроллера читаются примерно раз в секунду-две, а с записью все то же самое.

P.S. А что имеется в виду под "собственной панелью"?
Re: Переменные из WinCC в PLC не записываются
Евгений; 23.9.02

Кнопка может являться составной частью какого то объекта, собранного как "create object" в Graphic Designer, странно всё должно работать.

Re: Переменные из WinCC в PLC не записываются
Дмитрий Филь; 23.9.02

Проблема с _ЗАПИСЬЮ_ПЕРЕМЕННЫХ_В_КОНТРОЛЛЕР_ решена. И вот каким образом: нужно убрать "галочку" в WinCC Explorer'е по такому пути: Tag Management -> Simatic S7 protokol suite -> MPI -> "клик" правой клавишей мыши -> System Parameter -> убрать "галочку" <by PLC> в рамочке "Cycle formation".

Вот такое вот решение.
Re: Переменные из WinCC в PLC не записываются
Дмитрий Филь; 23.9.02

Проблема с _ЗАПИСЬЮ_ПЕРЕМЕННЫХ_В_КОНТРОЛЛЕР_ решена. И вот каким образом: нужно убрать "галочку" в WinCC Explorer'е по такому пути: Tag Management -> Simatic S7 protokol suite -> MPI -> "клик" правой клавишей мыши -> System Parameter -> убрать "галочку" <by PLC> в рамочке "Cycle formation".

Вот такое вот решение.


text

Доступ к имени тэга из actiona'a
Колмыков Дмитрий; 23.9.02

Нужен один action на 300 тэгов.

Как получить доступ к имени тэга из actiona'a, когда последний срабатывает на изменение значения тэга? Заранее благодарен.

Re: Доступ к имени тэга из actiona'a
Василенко; 23.9.02

DMSetValue[Wait] /DMGetValue[Wait]

Re: Доступ к имени тэга из actiona'a
Колмыков Дмитрий; 23.9.02

Нужно не значение тэга(DMSetValue[Wait] /DMGetValue[Wait] ). Нужно узнать имя тэга от которого сработал action.


text

OP27 как Slave OP27/TP27 KEYS-назначение битов обмена?
Ефременко Денис; 23.9.02

OP27 можно прицепить на DP-master систему слейвом. При этом можно управлять светодиодами и контролировать клавиши через адресное пространство мастера (3 байта входов, 4 байта выходов), а не конфигурировать Interface Area в ProTool. Нигде в документации не нашел назначение всех этих байтов. Может у кого есть расшифровка назначения каждого бита этой области обмена? Или подскажите, где можно об этом почитать.


text

Связь между PLCSIM и проэктом WinCC
Павлов Сергей; 18.4.02

Я хочу проимитировать работу проекта WinCC для чего запускаю PLCSIM загружаю в него програму с Step7 потом открываю соответствующий проэкт WinCC но не знаю как установить связь между ними.

Re: Связь между PLCSIM и проэктом WinCC
Евгений Трунов; 18.4.02

PLCSIM не имеет отношения к WinCC и служит только для отладки программ S7, созданных в Step7. С его помощью нельзя "обмануть" драйвер канала связи S7 Protocol Suite, например, и заставить его считать PLCSIM "реальным" устройством. Для имитации реальных значений переменных в WinCC служит WinCC Tag Simulator, работающий с Internal Tags.

Re: Связь между PLCSIM и проЕктом WinCC
Михайлин Сергей; 18.4.02

Погодите, погодите ....

Симулятор прекрасно дружит с WinCC и с S7 Protocol Suite по каналу MPI. Заводиться MPI соединение настраивается как на реальное устройство, настраивается PG/PC и вперед. Все работает. Другое дело, что PLCSIM может не поддерживать некоторые функции реального контроллера, а во вторых, что если реальное соединение будет по другой сети (Profibus или Ethernet) то придется потом перенастраивать соединение в WinCC и переносить все тэги. Так что не все так глухо.
Re: Связь между PLCSIM и проэктом WinCC
Евгений Трунов; 22.4.02

Вот по MPI никогда не пробовал. Да и вообще пробовал уже достаточно давно. Специально посмотрю внимательнее.

Re: Связь между PLCSIM и проэктом WinCC
Slava; 8.8.02

Привет !

Люди, где можно скачать PLCSIM ?
Re: Связь между PLCSIM и проэктом WinCC
Евгений Л.; 8.8.02

Всё работает по MPI, испытано многократно, из опыта могу сказать , чтобы не портить Hardware configuration, добавляем просто новое соединение MPI. И всё что требуется для перехода с PLCSim на реальный объект, это при трансфере перевести (в данном случае) с MPI на IE. А "лишнее" соединение по MPI пусть болтается, всегда пригодится для отладки.

Re: Связь между PLCSIM и проэктом WinCC
Андрей; 9.9.02

Вы пишете, что PLCSIM может не поддерживать некоторые функции реального контроллера.Какие например? С чем Вы уже столкнулись?

Re: Связь между PLCSIM и проэктом WinCC
Ефременко Денис; 23.9.02

Кстати, не обязательно для связи MPI. У меня в проекте один лишь Profibus и драйвер прекрасно конектится с PLCSIM.

Здесь важно чтобы проект OS находился на Simatic PC Station. Так что никакие перепривязки тегов не требуются. Делай проект, как для реального соединения, запускай PLCSim и симулируй.
P.S. Был глюк, у меня на машине все нормально, а у сотрудника тот же проект, но ни в какую не хотел WinCC драйвер конектиться с PLCSim. Так вот, как выяснилось после поисков, для нормальной работы нужен PLCsim не ниже V5.0+SP1+HotFix2. Именно из-за отсутствия HF2 конекта и не было.

Re: Связь между PLCSIM и проэктом WinCC
Ефременко Денис; 23.9.02

Небольшая поправка: важно чтобы не OS, а WinCC Application находился на Simatic PC Station (а OS находится на WinCC Application)


text

Доступ к имени тэга из actiona'a
Колмыков Дмитрий; 23.9.02

Нужен один action на 300 тэгов.

Как получить доступ к имени тэга из actiona'a, когда последний срабатывает на изменение значения тэга? Заранее благодарен.


text

изменение уставок в analog alarm
Власкин Павел; 19.9.02

Как реализовать? Нужно, чтоб оператор мог выставить верхний и нижний аварийные уровни или вообще отключить их.

Re: изменение уставок в analog alarm
Евгений; 19.9.02

Я бы посоветовал купить дополнительную библиотеку, там есть так называемые faceplate посредством которых можно в режиме Runtime менять уставки или вообще их отключать

Re: изменение уставок в analog alarm
Власкин Павел; 20.9.02

:) А стандартными средствами?

Re: изменение уставок в analog alarm
Евгений; 20.9.02

А стандартными, самому разработать что-то подобное средствами ActiveX.

Re: изменение уставок в analog alarm
Василенко; 21.9.02

Можно,наверно, попробывать менять поля MAXLIMIT и MINLIMIT

в таблице MCPTVARIABLEDESC для нужного тега, но,скорее всего, есть и в ODK средство доступа к этим свойствам.


text

WinCC 3.1
Сергей; 19.9.02

Подскажите, кто знает, пожалуйста!

Возможно ли связаться с S5-135U через AS511, используя WinCC 3.1? На ПК стоит Windows 98 и NT 4.0
Особенно было бы приятно услышать мнение представителей Сименса.

Спасибо...


text

Что за ошибки?
Владимир; 16.9.02

При смене кадра в объекте PictureWindow возникает ошибка.

Но не всегда!
где копать, подскажите?

кадр меняю вот так:
SetPictureName("Start_picture","WorkArea",NewPicName);

в кадре NewPicName отрисован объект restangl с изменяемым свойством BackGroundColor
(достаточно просто указать return CO_BLUE к примеру)
при перезагрузке кадра возникает ошибка
====================================OnErrorExecute====================================
dwErrorCode1: (ThreadId 2488) 1007007
dwErrorCode2: (ThreadId 2488) 1
szErrorText: (ThreadId 2488) PDLRTAPI oder DMAPI
szErrorTextInfo: (ThreadId 2488) Error in PDLRTSetProp
szApplicationName: (ThreadId 2488) PDLRuntimeSystem
bCycle: (ThreadId 2488) cycle
szFunctionName: (ThreadId 2488) @38f
lpszPictureName: (ThreadId 2488) START_PICTURE.WORKAREA:ZONE_PL12-13
lpszObjectName: (ThreadId 2488) Border_TE9-4
lpszPropertyName: (ThreadId 2488) BackColor
dwParamSize: (ThreadId 2488) 12
szErrortext: (ThreadId 2488) WinCC Runtime: PDL Run time: Property not found

====================================OnErrorExecute====================================
@38f (7) : general protection fault..
====================================OnErrorExecute====================================
dwErrorCode1: (ThreadId 2488) 1007001
dwErrorCode2: (ThreadId 2488) 4100
szErrorText: (ThreadId 2488) Exception in Action
szErrorTextException: (ThreadId 2488) access violation
szApplicationName: (ThreadId 2488) PDLRuntimeSystem
bCycle: (ThreadId 2488) cycle
szFunctionName: (ThreadId 2488) @38f
lpszPictureName: (ThreadId 2488) START_PICTURE.WORKAREA:ZONE_PL12-13
lpszObjectName: (ThreadId 2488) Border_TE9-4
lpszPropertyName: (ThreadId 2488) BackColor
dwParamSize: (ThreadId 2488) 12
====================================OnErrorExecute====================================

Re: Что за ошибки?
Владимир; 17.9.02

Уже разобрался

Тогда еще вопрос
Какой функцией можно определить
есть ли объект в кадре или нет?
название объекта известно

Re: Что за ошибки?
Василенко; 19.9.02

PDLCSEnumObjListEx или PDLCSEnumAvailableObjTyp


text

Подскажите!
Владимир; 17.9.02

Какой функцией меняется параметр

ControlProperties -> SymbolAppearance (значения Original - Shaded - Solid - Hollow
у элементов
SymbolLibrary ???

Re: Подскажите!
Василенко; 18.9.02

PDLRTSetPropEx

Re: Подскажите!
Владимир; 18.9.02

спасибо!


text

GIF в WinCC
Хлопин Денис; 9.9.02

Кто-нибудь, когда-нибудь работал с гифами в WinCC! Как это делать? Или ActiveX-компонент для работы с ними(GIFами) никто не находил? Хотелось бы сделать простую анимацию, Status Display не устраивает!

Re: GIF в WinCC
Поджидаев М.А.; 10.9.02

Anigif.ocx.

Могу отправить по почте.
Re: GIF в WinCC
Хлопин Денис; 11.9.02

Буду признателен!

khlopin_den@mail.ru - мой мэйл!
GIF в WinCC
Дмитрий; 11.9.02

Если не сложно, скинь и мне попробовать

L-Dmitrij@yandex.ru
Re: GIF в WinCC
Владимир; 11.9.02

Плиз и сюда тоже

ovm@smtp.ru
Re: GIF в WinCC
Сергей; 11.9.02

Какая популярность ;-).

Будем рады
refraktor@narod.ru
Re: GIF в WinCC
Хлопин Денис; 11.9.02

Спасибо большое! Получил!

Re: GIF в WinCC
Сергей; 11.9.02

Пожалуйста, пришлите и мне тоже.

Спасибо.

zabotkin79@yandex.ru
Re: GIF в WinCC
Алексей; 12.9.02

Плиз пришлите и мне тоже.

Заранее Спасибо.
Re: GIF в WinCC
Александр Родин, ООО "Нева Электрик"; 12.9.02

По-моему, проще уже где-нибудь на ftp положить... ;) А то так каждый будет приходить и просить... :)))

Кстати, а мне можно ?.. Пожалуйста... :)
Re: GIF в WinCC
Игорь; 16.9.02

Пожалуйста, пришлите и мне тоже.

Спасибо.

Re: GIF в WinCC (Прекращаю рассылку)
Поджидаев М.А.; 17.9.02

Прекращаю рассылку.

Не возражаю если кто нибудь другой её продолжит.


text

Web-Navigator
Алексей; 13.9.02

Кто подскажет где можно взять

данный продукт (скачать например)
Интересует серверная часть.
Хочется попробовать как оно работает.


text

Запретить кнопки
Владимир; 11.9.02

Вот проблема не могу пока найти решения

подскажите!
В кадре установлен объект PictureWindow в котором размещен кадр принятия решения типа ДА-НЕТ.
Как мне отключить возможность нажатия кнопок основного кадра до выбора решения ДА или НЕТ???

Re: Запретить кнопки
Хлопин Денис; 12.9.02

Попробуй поиграться с MessageBox'ом , там есть флаг MB_SYSTEMMODAL, окошечко с вопросом будет модальное! Если проблемы с С++ тогда воспользуюся, Dynamic Wizard'ом.


text

Загрузка проекта в OP170B
Серёжа; 11.9.02

Нужен совет, граждане...

Проект загружается в панель нормально. ProTool (6.0 демо) не ругается. А запуститься не может, вылазит сообщение, мол не могу запустить PDATA.FWD...
Не из-за демонстрационного же софта?
Да, кстати, как у неё FLASH почистить?


text

WinCC + "обман" входов контроллера
Андрей; 9.9.02

Можно ли из WinCC на входы PLC(и в другие места...)подавать ложный сигнал? Step 7 позволяет это делать с помощью функции Force.А можно ли это делать из WinCC или из WinCC через Step 7? Это было бы интересней, чем использование PLC SIM.


text

Плохо вводятся цифры в поле ввода IOFiled в WinCCRT
Хоружевский Роман; 6.9.02

В WinCC режиме RT при вводе в поле IOFiled цыфру можно ввести с 5-го и более раз. Пробовал различные настройки по вводу но они ничего не дают.

Re: Плохо вводятся цифры в поле ввода IOFiled в WinCCRT
fog; 6.9.02

1. После ввода нужно нажимать ENTER

2. Для I/O field есть две настройки для ввода:
- стирать старое значение ввода при указании курсором на поле ввода
- не стирать.
Лучше оставить второе.

Re: Плохо вводятся цифры в поле ввода IOFiled в WinCCRT
Хоружевский Роман; 9.9.02

Ну то что нужно нажимать Enter это и ежу понятно, с настройками по вводу уже пробовал. Нроисходит такая гадость, как зависание значения в поле ввода, набираешь цифру а она визуально не отображается, затем нажимаешь Enter и ничего не происходит.


text

WinCC и несколько DP-мастеров
Иван Данилушкин; 4.9.02

Имеется две независимых технологических линии, каждая из них обслуживается своим контроллером S7-315-2DP, контроллеры сконфигурированы как DP-мастера и объединены в одну сеть по PROFIBUS, к ней же подключается операторская станция с карточкой CP5611 и WinCC. Работоспособен ли WinCC-проект, в котором часть тегов будет привязана к одному контроллеру, а часть к другому?

Re: WinCC и несколько DP-мастеров
fog; 6.9.02

Итак, два S7-315-2DP включены в одну сеть PROFIBUS через свои встроенные DP-порты и являются мастерами для своих DP-slaves, одновременно OS с WinCC подключается через CP5611 к этой же сети. Если так, то есть три мастера: WinCC и два S7-315-2DP и обмен между ними не возможен.

Re: WinCC и несколько DP-мастеров
Strannik; 6.9.02

WinCC по S7-протоколу (S7 Protocol Suite) будет работать без проблем с двумя и более S7-контроллерами через встроенные DP-интерфейсы и 5611.


text

Ошибка лицензии Web-Navigator.
Александр Туманов; 6.9.02

В журнал событий приложениий сыпятся ошибки от источника WinCCWeb:

1. Error Initialize AppRT: WebiagServer License service failed 0
2. WebNavigator: WinCC enterring Runtime Mode.
При этом на ПК установлен Web Navigator V1.1 и авторизация Webnavig 3 clients V1.x 6AV6371-1DH05-0AX0 (S79220-A5011-F268-01)


text

Работа с Com портами в WinCC посылка и прием
Хоружевский Роман; 20.8.02

Как организовать посылку и прем из Com порта на WinCC исполльзуя OLE объект или C++

Re: Работа с Com портами в WinCC посылка и прием
siemargl; 21.8.02

just write wincc .chn driver ;-))

Работа с Com портами в WinCC посылка и прием
Хоружевский Роман; 21.8.02

Спасибо за ответ некому "siemargl", но вы мне предложили использовать драйвер обмена по последовательному порту для SIMATIC, а мне нужно просто послать на порт посылку и принять ее. Например есть лабораторные весы Mettler Toledo которые могут управляться через Com порт, им нужно задать вопрос в виде команды которую передать на порт и получить от них ответ. Вот и вся "проблема"

Re: Работа с Com портами в WinCC посылка и прием
Евгений Трунов; 22.8.02

Если посылка разовая, то возможно включение в С-скрипт вызовов функций Win32 API типа ReadFile и WriteFile для чтения/записи из/в порта. Есть объекты АctiveХ, инкапсулирующие в себе низкоуровневый обмен данными с СОМ-портами - можно разместить их на формы в Graphic Designer'e.

Если же необходимо связать данные о весе с каким-либо тегом WinCC, то, действительно, нужно писать драйвер канала .chn либо OPC-сервер.
Re: Работа с Com портами в WinCC посылка и прием
Iva; 22.8.02

Не соглашусь с Евгением Труновым насчёт того, что если надо связать данные о весе с тегом то требуется драйвер канала или OPC-сервер. Используя в скрипте команды чтения-записи COM-port можно тут же записывать полученный вес в тег. А скрипт пусть будет глобальным и крутится с какой-то периодичностью.

Работа с Com портами в WinCC посылка и прием
Хоружевский Роман; 22.8.02

Ребята советы Ваши понятны, но есть ли у кого нибудь пример скрипта с открытием, закрытием, приемом из порта. А то у меня опыта с такими "вещами" нет и я не знаю даже с чего начинать "рисовать" программулину.

P.S.
Спасибо всем за ответы.
Re: Работа с Com портами в WinCC посылка и прием
Iva; 22.8.02

Может за тебя ещё проект сделать? Смотри MSDN, заодно и опыт решения нетривиальных задач получишь. Если не справишься, то покупай у Siemens весы Siwarex с готовым софтом.

Работа с Com портами в WinCC посылка и прием
Хоружевский Роман; 22.8.02

Ну проект за меня стряпать не нужно, своих хватает уже реализованных. Просто как всегда хотчестся усё побыстрее заделать. Но походу без букварей и многих часов стучания по клавишам не обойтись.

Re: Работа с Com портами в WinCC посылка и прием
Евгений Трунов; 22.8.02

Iva, чтобы _только связать_ и вызвать SetValue(), действительно, достаточно С-скрипта. Но если нежелательно замедлять работу всей системы периодическим разбором Р-кода функции ReadFile, то тег должен быть внешним и связанным с каким-либо каналом .chn. Такая архитектура :).

Re: Работа с Com портами в WinCC посылка и прием
siemargl; 3.9.02

Ну, слава богу, со мной согласились ;-)

Re: Работа с Com портами в WinCC посылка и прием
Костенич Дмитрий; 4.9.02

Ну а я все-таки не соглашусь с siemargl - *.chn драйвер или OPC-сервер не единственные варианты.

НАМНОГО проще, быстрее, а в данном случае и удобнее, будет сделать следующее:
1. Прием из COM-порта. Пишется программка, выполняющая мониторинг событий COM-порта (с помощью стандартной системной функции WaitCommEvent) и, при получении чего-нибудь осмысленного, записывающая это значение в тег WinCC (с помощью функции ODK DMSetValue). Программка указывается в списке программ для загрузке в RunTime. И все - после загрузки работает абсолютно независимо от WinCC.
2. Вывод в COM-порт. Создается глобальный скрипт, срабатывающий по изменению тега. Скрипт выполняет запись значения этого тега в COM-порт (с помощью хотя-бы WriteFile). И опять все - никаких циклических вызовов.

Единственный тонкий момент - теги на прием и посылку данных должны быть разные (RX и TX).

Ну а если нужно почитать как работать в Win32 API с COM-портами, то читайте MSDN - раздел "Platform SDK\windows Base Service\Files and I/O\Communications"

Желаю удачи!!!


text

WinСС работа с тегами
Лиля; 3.9.02

Работаю на NT Server 4.0 SP5, WinCC 5.0 SP1 c Multi-User Project.

Добавляю новый тег в группу тегов.
Он не отображается в окне WinCC Explorer, даже при выполнении View/Refresh.
Отображение нового тега происходит только при позиционировании курсора на другую группу тегов или при перезагрузке проекта.
Возможные причины?
Можно ли развивать проект, чем это чревато в будущем
Спасибо.
Re: WinСС работа с тегами
Eugene; 3.9.02

Работал на NT Workstation 4.0 SP6, WinCC 5.0 SP1 c Single-User Project. Глюки вылезали в самых неожиданных местах (как в Вашем случае). С выходом

WinCC 5.0 SP2, а в последствии - и 5.1 глюков стало поменьше, да и в Win2k работать приятнее.
Попробуйте поставить WinCC 5.1, хотя это не панацея.
Re: WinСС работа с тегами
Костенич Дмитрий; 4.9.02

А тут вообще угрозы для развития проекта нет - реально теги то добавляются (это можно проверить в БД проекта).

Проблемы только с отображением и рефрэшем, но в WCC 5.0 SP1 их навалом и в самом WinCCExplorer и в AlarmLogging (особенно при создании объектов с помощью ODK).


text

Порядок объектов на экране
Den; 26.8.02

Как в режиме RunTime изменить порядок отображения графических объектов на экране (на задний план-на передний план)?

Re: Порядок объектов на экране
aim; 26.8.02

В свойствах объектов можно установить привязку к переменным проекта и поведение объектов в зависимости от значений переменных.

Ну а дальше сами решайте, управлять переменными в панели или в симатике.
Удачи...

Порядок объектов на экране
Den; 27.8.02

Поясню вопрос: требуется отображать на переднем плане одно из многих развернутых в полный экран окон просмотра трендов. Людям лень разворачивать их руками. Нужна, по видимому, функция из WINCC API меняющая порядок объектов на экране. Можно с примером 8-).

Re: Порядок объектов на экране
Костенич Дитрий; 4.9.02

Если требуется менять порядок окон, развернутых во весь экран, то достаточно динамически менять у них свойство видимости (SetVisible(lpszPictureName,lpszObjectName,bVisible); //Return - Type :BOOL). Т.е. будет одно видимое окно и все остальные - невидимые.


text

DBOpen()
Константин; 27.8.02

Подскажите, пожалуйста, как должно выглядеть имя таблицы в базе данных, которое требует фукция DBOpen(). В примере из ОДК эта функция работает с волшебным словом "MCPTVARIABLEDESC", все другие попытки присоединится к таблицам проекта не получаются.

Re: DBOpen()
siemargl; 3.9.02

Использовать scview.exe и посмотреть наименования таблиц (или создать свои).

userid=dba
passw=sql


text

Печать экранов в Run-time
Иван Федоров; 26.8.02

Где поменять ориентацию принтера в WinCC? Не могу распечатать содержимое Run-time на альбомном листе. Использую функцию Hardcopy.

Re: Печать экранов в Run-time
Михайлин Сергей; 27.8.02

А WinCC здесь ни при чем! Надо просто по правой кнопки мыши зайти в Printing Preferences (настройки печати по умолчанию) для принтера по умолчанию и там изменить ориентацию страницы.

Re: Печать экранов в Run-time
Максим Поджидаев; 31.8.02

WinExec("PRTSCR.EXE -hardcopy -l",SW_SHOWNORMAL);


text

Непонятки с перекрестными ссылками в ProtoolPro CS 5.1
Петр Сологубов; 23.7.02

У тэга перекрестные ссылки - одна строка вида :

VScales_10 - (REF==QVSCAN) REF0(2==0)/REF1(2==0)/REF2(0==0)
Что бы это значило? Удалить тэг невозможно...
Re: Непонятки с перекрестными ссылками в ProtoolPro CS 5.1
Dmitry; 25.7.02

Я тоже задавался вопросом что означает такая строка...

Единственное место где смог найти ответ - Knowledge Base. Ну а решение проблемы вообще похоже больше на шаманство, чем на нормальную работу. Привожу выдержку из KB:

- In ProTool go in the user project to "View > Cross-reference".
- You are presented with the cross-reference list as a result.
- Press "CTRL + right mouse button" and in the select dialog that opens you select the item "Scan All Log Error". (The process can take several minutes depending on the size of the project).
- All the "log errors" found are displayed.
- Again press "CTRL + right mouse button" and select "Repair All". (This process is completed immediately).

???
Не знаю на счет поможет ли в версии 5.1 но в 6.0 помогало.

Кстати вопрос. Никто случайно не знает можно ли чем нибудь кроме Protool прочитать файл конфигурации .pdb?

Re: Непонятки с перекрестными ссылками в ProtoolPro CS 5.1
Петр Сологубов; 26.7.02

Спасибо! Помогло!

Re: Непонятки с перекрестными ссылками в ProtoolPro CS 5.1
Ефременко Денис; 29.8.02

Отлично, в версии 5.2 все ок, помогло. Спасибо.


text

Фильтр полей с кириллицей у CCUATableCtl
Александр; 27.8.02

Добрый день, знатоки !

Проблема: почему-то выдается пустой результат при фильтрации записей в элементе CCUATableCtl.Filter с условием по полю типа String с кириллицей, например
"Shifr_Name = 'Я-00-482'",
тогда как с латиницей этот номер проходит ("Shifr_Name = 'Z-00-482'")?
Записи, удовлетворяющие такому условию, объективно существуют и результат запроса в InteractiveSQL (Sybase Central)
"SELECT * FROM "DBA"."UA#C_Recipe_1"
WHERE Shifr_Name = 'Я-00-482'" возвращает непустое множество.
Не помогло и выражение "Shifr_Name like '%Я-00-483%'"
Перестановка character set в БД на 866RUS изменений тоже не дала.

Кто-то решал такую проблему для
WinCC 5.1? Может, есть особые телодвижения для такого случая?


text

Синхронизация часов PLC -> OP7
Серых Андрей; 21.8.02

Как организовать загрузку в ОР 7/ ОР17 значение времени контроллерного... Как осуществить синхронизацию, подскажите plz. заранее благодарю

Re: Синхронизация часов PLC -> OP7
Eugene; 21.8.02

Есть PLC job № 41 "Transfer Date/Time to PLC".

Только тут наоборот - время панели передается в PLC.
Re: Синхронизация часов PLC -> OP7
Серых Андрей; 21.8.02

А обратно что никак нельзя???

По выключению питания происходит сброс всех параметров ОР, в том числе и дата/время, вот и хотелось бы каким нибудь образом восстанавливать хотябы с помощью контроллера
Re: Синхронизация часов PLC -> OP7
Eugene; 23.8.02

OP17 может быть оснащена батарейкой, а вот с OP7 - проблема.

Лови на мыло проект из Customer Support.
Re: Синхронизация часов PLC -> OP7
Юрий Оганесян; 26.8.02

А какая, собственно говоря, проблема?

PLC job number 14 "SetTime" и
PLC job number 15 "SetDate"
Если у тебя панель и контроллер запитаны от одного источника, то имей ввиду, что если будешь для стартового события для этих Job'ов использовать бит запуска панели, то получается фишка, которая заключается в том, что времена загрузки напели и контроллера разные и этот бит может "проскакивать"


text

Ещё раз о "падении задачи PDLRT.EXE"
Gunter; 22.8.02

Уважаемые участники форума!

В проекте регулярно слетает задача PDLRT.exe.
Run-time на сервере и клиенте сохраняется.
Приходится вручную загружать PDLRT.EXE и так до следующего слёта.

Анализ диагностики WinCC паказал полное отсутствие ошибок в собственных скриптах.
На машине установлены NT 4.0 sp5, WinCC v5.0 SP2 HF7.

Вопрос по данной проблеме уже задавался на форуме, но остался к сожалению без внимания

Надеюсь на помощь представителей SIEMENS.

Заранее благодарен!

Re: Ещё раз о "падении задачи PDLRT.EXE"
Хоружевский Роман; 22.8.02

У тебя HotFix какой??? Попробуй поставить 5 версию. Мож поможет.

Re: Ещё раз о
Хоружевский Роман; 22.8.02

Извиняюсь за тоорможение не обратил внимания на HF7. У меня вообще 5 стоит. Ха-ха.


text

WebNavigator troubles
Stadnik; 22.8.02

Есть проект, который является синтезом двух разных проектов, причем один из них делался в WinCC v.4.x, другой в v.5.x. Установив WebNavigator(v.1.1 путем апгрейда v.1.0), наблюдаю огромное количество error'ов в скриптах при publishing'е. Преимущественно "лезут" error 0040, 003a и 0005. Часть кнопок не работает, кнопки , отображаемые посредством *.bmp гарантированно не работают. Что делать?

Re: WebNavigator troubles
Lozovsky; 22.8.02

Сдаваться Андрей....сдаваться:-)

Re: WebNavigator troubles
Хоружевский Роман; 22.8.02

Да переделай все потихонечку на новой версии, и скрипты перетащи и т.д. Зато будешь уверен, что у тебя все ошибки будут устранены в процессе "переноса", хотя може это и глупо. Желаю успехов.


text

Андронов Е.
Alarm_S на OP; 22.8.02

Не поделится ли кто опытом по сабжу : создание, конфигурирование сообщений на ОП посредством Alarm_S для 300-х контроллеров?


text

ОП37
Андронов Е.; 22.8.02

Есть ОП37 соединенная с контроллером по DP - интерфейсу. Постоянно, на ОП, выходит сообщение "ошибка передачи данных 13", если кто сталкивался разъясните, plz.


text

Переключение экранов OP7
НТМК , ЛСПУ; 25.1.01

Согласно руководствa пользователя ProTool установлена область ScreenNumber в PLC S7-200 для отображения состояния экранов панели. Однако запись данных в область ScreenNumber самим контроллером не вызывает вызов соответствующего экрана на OP7. Пожалуйста, подскажите,назначение битов в данной области, а также, что необходимо сделать для включения контроллером нужного экрана

на OP7 ?

Re: Переключение экранов OP7
Никаноров В. - Сименс, Москва; 26.1.01

Область ScreenNumber служит для передачи номера экрана с ОР в ПЛК.

Если Вам нужно управлять сменой экрана из ПЛК, то Вы должны запустить так называемый JOB. Для смены кадра на ОР служит JOB51.
Для того, чтобы Вы могли запускать JОBы, Вам нужно объявить Interface Area в Area Pointer.
Детальное описание Area Pointer и JOBов находится в руководстве по коммуникациям (отдельная книжка, не входит в книгу описания собственно Protool). Вы можете найти ее либо на диске с английскими руководствами, либо скачать с сайта Customer Support (www.ad.siemens.de/simatic-cs)
Re: Переключение экранов OP7
НТМК , ЛСПУ; 30.1.01

Спасибо, все получилось. Однако вызывает удивление отсутствие описания JOB-возможностей в стандартной документации по ProTool.

Re: Переключение экранов OP7
Никаноров В. - Сименс; 30.1.01

Удивляться не надо.

Структура документации при использовании панелей оператора следующая:
-книга1 - руководство на данную панель
-книга2 - руководство на ProTool
-книга3 - описание вариантов коммуникаций между различными контроллерами и панелями.
Символ "|" для OP7
Гамбург Сергей; 8.7.02

Подскажите, каким образом ввести сивол "|" (вертикальная черта) для ОР7 (используется для переключения экранов).

Сергей.
Re: Переключение экранов OP7
Ольштейн Эдуард ОАО "Мечел"; 24.7.02

Можно проделать операцию copy - paste и вставить этот символ в любое место.

Где он находится на клавиатуре мне тоже найти не удалосью

Впрочем прекрасно смотрятся вместо этого символа и буквы I или Y (последнюю я и применяю)
P.S. Не следует забывать, что редактор выполняет операцию вставки, но не замещения. Так, что если поле экрана заполнено символами, ввод новых не будет успешным (старые не замещаются). Необходимо забить ненужные, а на их место вставить новые.

Re: Переключение экранов OP7
Серых Андрей; 21.8.02

Если создать проект не используя "стандартный проект" не получится вставить такой символ "|" при русском языке никак. Он в буфер копируется но в проект не вставляется...


text

Си для WINCC
Владимир; 20.8.02

Есть где-нибудь полная документация по использованию СИ в WINCC?

В частности, интересует программное создание аварийных тегов.
Но и полное собрание не помешает.
Если есть возможность, вышлите на мыло.

Re: Си для WINCC
siemargl; 21.8.02

RTFM ODK


text

Печать трендов в WinCC
Алексей; 20.8.02

Как в WinCC печатать тренды?

Re: Печать трендов в WinCC
Александр Туманов; 20.8.02

В Report Designer есть такая функция

(смотри стандартный Layout - @CCTlgRtCurves.RPL).


text

WinCC и DDE
Никонов Виталий; 15.8.02

Приветствую участников форума!

Возможно ли использование WinCC 5.0 SP2 в качестве DDE-клиента, если сервером является другая программа (написанная на языке Delphi). При работе в WinCC 4.0 такой проблемы не возникало. Необходима ли установка HotFix на версию WinCC 5.0 SP2 для решения этой проблемы?
Re: WinCC и DDE
Gunter; 19.8.02

Решалась аналогичная задачка.

Исходные данные:
-Windows NT Workstation 4.0 SP5
-WinCC 5.0 SP2
-DDE сервер разработан на С++Builder 5
Решилась после установки HotFix7.


text

Замена RT-базы проекта
Лев Шерешевский; 15.8.02

При разработке проекта чтобы удобнее

было производить резервное копирование
периодически перекрывал RT-базу
пустышкой WinCCRT_7.db, расположенной
в каталоге Siemens\WinCC\bin\. С какого-
то момента времени этот прием перестал
действовать: проект при старте говорит,
что не может установить связь с базой,
и автоматически останавливается. Есть
подозрение, что это произошло после
переноса проекта со станции разработки
на станцию заказчика, но привезенный
назад проект также не работает с
пустышкой, а таскать вместе с ним
большую базу что-то не хочется.

Буду благодарен за совет, если кто-либо
сталкивался с похожей проблемой.
Re: Замена RT-базы проекта
Сергей Колпащиков, Акватехнология; 15.8.02

Добрый день Лев.

Было что-то похожее.
На сколько я помню проблема состояла в том, что в каталоге проекта создался log файл и пока его не убили проект не стартовал.
А вот от чего создался log мы не выясняли.

Сергей.
Re: Замена RT-базы проекта
Лев Шерешевский; 15.8.02

Привет, Сергей!

Ты прав, удаление log-файла помогло. Спасибо!


text

Авторизация WinCC
Eugene; 26.7.02

На компьютере установлен WinCC v5 SP2, лицензия RC+RT на 64к переменных. Иногда выскакивает сообщение "Your software license has expired! Please obtain a valid license." В заголовке окна сообщения значатся программы PASSDBRT.EXE, XREFS.EXE и SCRIPT.EXE. Нажимаю кнопку "Details". Появляется окно со списком авторизаций, которые не установлены, однако список пуст. Просматриваю дополнительную информацию. Там три столбца: "installed", "needed", "to install". В столбце "to install" все значения - No. В столбце "needed" для авторизации A9WRC130 (WinCC Runtime+Configuration 128 PowerTags) - значение Yes.

Что происходит? Становится боязно использовать WinCC.
Re: Авторизация WinCC
Юрченко Владимир; 26.7.02

Если у вас была установлена лицензия на 64k, то должен быть файл A9WRC430.

Запустите программу AuthorsW и посмотрите какие лицензии установлены или просто поищите этот файл в каталоге
AX NF ZZ. Но лицензии сами не пропадают, скорее всего вы что то не то установили или ...
Re: Авторизация WinCC
Eugene; 26.7.02

Уважаемый Владимир!

Я же русским языком написал: "На компьютере установлен WinCC v5 SP2, лицензия RC+RT на 64к переменных".
А ответы типа "у вас что-то не так стоит" не принимаются в принципе, так как я уже задолбался WinCC переставлять (да и не только его) :-).
Re: Авторизация WinCC
Евгений Трунов; 26.7.02

Сообщение о том, что "your license has expired" имеет, к сожалению, место быть, причём все требуемые лицензии установлены. Напрямую зависит от загруженности системы и количества работающих подсистем (*Logging, Script etc.). Очень похоже на ошибку в реализации сервера защиты и проверки лицензий :(.

И, действительно, в столбце "needed" возле A9WRC130 (WinCC Runtime+Configuration 128 PowerTags) в таких случаях стоит "Yes". Это при Runtime на 64K тегов :(.
Re: Авторизация WinCC
Чистяков Дмитрий ОАО "СеверСталь"; 26.7.02

>Очень похоже на ошибку в реализации сервера защиты и проверки лицензий :(.

Именно так и есть.
От загрузки зависимости не замечал, но вот как только один из клиентов не верно завершит свою работу, так часто начинает появляться сообщение об ошибке в скриптах и авторизации и при запуске других клиентов и на самом сервере.

Re: Авторизация WinCC
Евгений; 1.8.02

Если я правильно понял, то вам действительно необходимо установить лицензию на 128 Power Tags (несмотря на то что стоит 64К). Если сообщение о лицензии не пропадёт, то подобного рода проблема была решена следующим образом:

1. Сносим лицензию на 64К
2. Сносим лицензию на 128 Power Tags
3. Запускаем и останавливаем RunTime
4. Ставим лицензию на 128
5. Ставим лицензию на 64
Re: Авторизация WinCC
Eugene; 1.8.02

Это все конечно хорошо, но где взять авторизацию на 128 тэгов?

Специально покупать что-ли?

Re: Авторизация WinCC
Cергей; 1.8.02

Не паникуй.

Было и у нас такое. Когда переменных было меньше 128 - WinCC не мудрствуя напомнило о нехватке соответствующей лицензии. Один раз. Когда в процессе разработки переменных стало более 128, при выходе появилось сообщение о нехватке лицензии на 1024. :-)
Хлеба к обеду, так сказать, вмеру бери. Желаю успеха
Re: Авторизация WinCC
Евгений; 1.8.02

Странно вообще-то на 64К есть лицензия , а на 128 нет? А вы территориально находитесь?

Re: Авторизация WinCC
Евгений; 1.8.02

где?

Re: Авторизация WinCC
Чистяков Дмитрий ОАО "СеверСталь"; 1.8.02

Авторизация 128 тэгов требуется для клиентов. Там 64К могут и не сработать.

Re: Авторизация WinCC
Евгений; 2.8.02

Совершенно верно. Просто действительно надо купить(достать) лицензию на 128.

Re: Авторизация WinCC
Eugene; 9.8.02

Спасибо за советы.

Предлагаю прекратить обсуждение данного вопроса.
Я понял одно: глюк, описанный мною, исключительно на совести программистов ф. Siemens. И они должны исправить его.
Re: Авторизация WinCC
Чистяков Дмитрий ОАО "СеверСталь"; 13.8.02

Нет, собственно, глюка здесь нет никакого. Всё работает согласно документации. Если там написано, что клиент должен иметь авторизацию на 128 тэгов, то он и должен иметь именно такую авторизацию.

Вы имеете в наличии, лишь серверную часть авторизации.
Почему всё так работает?
Для понимания этого вопроса надо взглянуть в самое начало. А именно изначально система (в самом простом варианте) имеет один компьютер. Если Вам или Вашему руководству потребовалось установить ещё один компьютер, то вы должны были бы закупить авторизацию на полную катушку (т.е. например, 64К).
Для экономии средств ф. Siemens (как и многие другие) предлагает купить лицензию на сервер и лицензии на клиентов. При этом клиенты должны иметь минимальную стоимость. Именно по этому им и установлена минимальная цифра в 128 тэгов.

Вопрос, по чему так? Да потому, что в мире принято покупать софт на каждое рабочее место.

Вопрос, по чему нас никто не предупредил? Тут следует обратиться к фирме, которая проводила инжениринг вашего проекта. Они были обязаны закупить все авторизации, и тем более знать о таких вещах.
Если же инжениринг проводили Вы, то все вопросы к Вам. ;-)

Re: Авторизация WinCC
Eugene; 14.8.02

2Дмитрий Чистяков:

Уважаемый!
Да разве я говорил что-нибудь о клиентах и серверах в своем вопросе? У меня однопользовательский проект (Single-User Project) и WinCC иногда выдает сообщение об отсутствии авторизации. Вот и вся проблема. Спасибо Владимиру Юрченко - он нашел на немецком сайте Сименса описание этой проблемы (я так понял слово "глюк" болезненно воспринимается). Там советуют наращивать ресурсы компьютера.
Я еще раз предлагаю закончить обсуждение - уважаемые его участники ушли в сторону от описанной проблемы.

Re: Авторизация WinCC
Евгений Трунов; 14.8.02

А где именно там об этом написано? Приведите ссылку, пожалуйста.

Re: Авторизация WinCC
Евгений Трунов; 14.8.02

Уже нашёл сам.

Re: Авторизация WinCC
Чистяков Дмитрий ОАО "СеверСталь"; 14.8.02

я так понял слово "глюк" болезненно воспринимается

Да нет, конечно же. ;-)
Программ без глюков не бывает.

А ресурсы само собой. Siemens чётко пишет минимум 96 Мбайт для WinCC. Да ещё надо не забывать о самом Windows`е. Если это W2k то 128 метров вынь да положь.

Re: Авторизация WinCC
Евгений Трунов; 15.8.02

NT 4.0 SP5 Eng. 128 Мб. Single-User Project, примерно 450 внешних тегов S7-соединения, около 100 из них архивируются с интервалом в 10 сек. Используются все подсистемы, кроме Report Designer. Дополнительно - Redundancy. Других задач на рабочую станцию не возложено. То есть, проект не то, чтобы очень грандиозный :). Использование памяти - в пределах 130-140 Мб.


text

Нужна клавиатура 6AV9 020-1DB00
Игорь; 14.8.02

Нужна клавиатура 6AV9 020-1DB00 б/у или рабочая. Можно только контактную часть (пленку). Предложите чем заменить.

Re: Нужна клавиатура 6AV9 020-1DB00
Чистяков Дмитрий ОАО "СеверСталь"; 14.8.02

Купите клаву, например в NIX`е

Кл-ра Cherry G83-6392LCNRG 104КЛ водо-,пыле-защита

Кл-ра Cherry G83-6300/92LRNRG <PS/2> 104КЛ водо-,пыле-защита

стоит 27 у.е.

Re: Нужна клавиатура 6AV9 020-1DB00
Игорь; 15.8.02

И что с ней потом делать?


text

"зависает" Web - сервер
Александр Туманов; 13.8.02

Время от времени Web-сервер "слетает" со следующими ошибками в журнале событий приложений:

1. Error: Initialize AppRT: WebDiagServer License service failed 0.
2. Web Navigator: WinCC entering RuntimeMode.
Могу выслать файл журнала весь
целиком. В чём дело?


text

Как правильно открыть окно с приходом сообщения
Gennady; 5.8.02

Подскажите, как открыть необходимый экран с приходом сообщения в WinCC 5.0.

Re: Как правильно открыть окно с приходом сообщения
Костенич Дмитрий; 13.8.02

Таак ведь много способов есть.

Самый простой - это указать имя pdl-ки в свойствах сообщения на последней вкладке (это у них называется экран Loop In Alarm).
Посложнее, но более гибче - оптичить поле triggers an action в тех же свойствах сообщения, но на первой вкладке и переписать глобальноскриптовую функцию GMsgFunction, которая будет вызываться для всех сообщений, у которых установлен этот флаг.
Наконец, можно сделать скрипт, срабатывающий по изменению дискретного параметра, к которому привязано сообщение, и в нем открывать нужную pdl.

Да, собственно открытие pdl осуществляется функцией
OpenPicture(char *lpszPictureName).

Впрочем, это далеко не все способы, т.ч. желаю твоческих успехов.


text

TlgOnlineTrendControl
Александр Родин, ООО "Нева Электрик"; 24.6.02

Динамически формирую вывод графиков с помощью subj.

В нем есть атрибуты BeginTime, EndTime, которые вроде как должны определять начальное и конечное время вывода графиков. Вроде как стоит поле, которое говорит, что они могут быть изменены динамически. При открытии окна C-Action видим, что возвращаемое значение должно иметь тип DATE (?!).

А теперь вопрос знатокам: Что это за тип DATE ? Собственно, какое представление он имеет (число, структура, строка, или что) ?
Второй вопрос, какой из известных SetProp-функций пользоваться для назначения данных атрибутов ?

Имеется ли в доках описание данного типа ?

Заранее спасибо.
Re: TlgOnlineTrendControl
Alexis; 24.6.02

импортируем и получаем:

inline DATE ICCTlgOnlineTrend::GetBeginTime ( ) {
DATE _result;
HRESULT _hr = get_BeginTime(&_result);
if (FAILED(_hr)) _com_issue_errorex(_hr, this, __uuidof(this));
return _result;
}

inline void ICCTlgOnlineTrend::PutBeginTime ( DATE pvarBeginTime ) {
HRESULT _hr = put_BeginTime(pvarBeginTime);
if (FAILED(_hr)) _com_issue_errorex(_hr, this, __uuidof(this));
}

inline DATE ICCTlgOnlineTrend::GetEndTime ( ) {
DATE _result;
HRESULT _hr = get_EndTime(&_result);
if (FAILED(_hr)) _com_issue_errorex(_hr, this, __uuidof(this));
return _result;
}

inline void ICCTlgOnlineTrend::PutEndTime ( DATE pvarEndTime ) {
HRESULT _hr = put_EndTime(pvarEndTime);
if (FAILED(_hr)) _com_issue_errorex(_hr, this, __uuidof(this));
}

смотрим и видим:
typedef double DATE;
Re: TlgOnlineTrendControl
Евгений Трунов; 25.6.02

DATE - это действительно тип данных double. Целая часть - число дней, прошедших от 30.12.1899, дробная - относительная часть суток в часе. Т.е., например, 28.10.2001 16:30:00 будет представляться как 37192.6875 (GMT+2). Часто используется для представлении времени в OCX-объектах.

Можно задавать BeginTime и EndTime как строки, т.е. как

sprintf(szBeginTime, "%02d.%02d.%4d %02d:%02d:%02d", <аргументы>);

SetPropChar(<имя схемы>, <имя тренда>, "BeginTime", szBeginTime);

Он поймёт :).
Re: TlgOnlineTrendControl
Александр Родин, ООО "Нева Электрик"; 2.7.02

... да, спасибо... все заработало при подстановке строки...

теперь вот есть еще одна проблема... :)

Посредством ODK-шной функции TLGPressToolbarButton мы можем осуществить опосредованное нажатие любой тулбарной кнопки. В частности вызвать линейку (инструмент весьма удобный и нужный). Вызов организован с экранной кнопки по нажатию определенного хоткея, работа мышью исключается (работа происходит с SIMATIC PC FI45, где работа мышью весьма нежелательна, потому как расположение вертикально и "руки затекают" - фраза заказчика :). Вызов обеспечили - линейка вывелась, стрелками можем линейку по экрану двигать. Но закрыть ее обратно по тому же хоткею уже не получается... да и другие кнопки тоже не в фокусе, поэтому их хоткеи тоже не срабатывают. Хорошо, прописываем в скрипте кнопки Set_Focus на нее саму же, чтобы не терять с ней связь. Но тогда вызванную линейку двигать стрелочками уже не получается... %) Ну и чего теперь делать ?..

Заранее спасибо.
Re: TlgOnlineTrendControl
Александр Родин, ООО "Нева Электрик"; 17.7.02

... продолжу мучать глупыми вопросами... :)

Через все ту же функцию TLGPressToolbarButton можно включить инструмент "линза". Включается. Но вот установка области увеличения может быть выполнена только посредством мыши. А как сделать выделение области с помощью клавиатуры ???
Re: TlgOnlineTrendControl
Александр Родин, ООО "Нева Электрик"; 13.8.02

Сам себе отвечу... :)

По поводу линейки.
Если фокус установить не на кнопку, а на окно с графиками, то можно и двигать линейку, и обработать кнопку, которая этот инструмент закроет...

А вот по поводу линзы идей нет... пока... Может кто-нить что-нить подсоветует ?.. %)

Заранее спасибо.


text

Alarm Logging
Александр Родин, ООО "Нева Электрик"; 15.5.01

Имеетеся сеть из N контроллеров. Программы и наборы переменных в них идентичные. В WinCC сконфигурирован проект. В текущий момент времени работа графического интерфейса идет только с одним контроллером. При этом, в зависимости от выбранного контроллера, переменные из него копируются во внутреннюю область памяти. В Alarm Logging-е сформирован список сообщений, классы, типы, виды строк и окон сообщений. Сообщений для одного контроллера порядка 400. Но есть необходимость в текущий момент времени принимать сообщения от всех контроллеров сразу. Если браться за эту задачу в лоб, то получается, что необходимо завести N*400 сообщений, причем одних и тех же, а это не очень удобно. Есть ли какая-нибудь возможность избежать столь утомительного труда ?

Re: Alarm Logging
Костенич Дмитрий; 7.2.02

Можно предложить следующее решение:

привязать к какому-нибудь из Process Value Block каждого сообщения тег, содержащий идентификатор контроллера.
Re: Alarm Logging
Костенич Дмитрий; 7.2.02

Можно предложить следующее решение:

привязать к какому-нибудь из Process Value Block каждого сообщения тег, содержащий идентификатор контроллера.
Re: Alarm Logging
Alexis; 8.2.02

Можно написать софтинку которая относительно имеющихся сообщений для одного контроллера сгенерит для оставшихся. Получится N*400 сообщений, но ручками прописать прийдется только 400.

Использовать MSCSEnumSingleMessageEx и
MSCSGenSingleMessageEx.
Re: Alarm Logging
Чистяков Дмитрий ОАО СеверСталь; 8.2.02

А что мешает экспортировать сообщения в, например, в Excel.

Там скопировать все 400 сообщений.
Изменить одно из полей, указывающее контроллер.
И импортировать обратно в WinCC
Re: Alarm Logging
Александр Родин, ООО "Нева Электрик"; 15.2.02

Всем доброго времени суток.

Дже не ожидал, что вдруг вытянут эту тему... :)

Что касается решения этой проблемы, я как раз поступал в соответствии с последним сообщением (от Чистякова Дмитрия). Но здесь тоже всплывает неудобство - для каждой группы сообщений надо назначать свои переменные... Так например: Для ПЛК 1 мы формируем таги регистрации тревог под именами Alarm_1_1, Alarm_2_1, и т.д. Зависит от количества тревог и размерности переменных. Для ПЛК 2 делаем тоже самое, только последний индекс ставим _2. И т.д. Далее в AlarmLogging-е ставим соответсвие битов сформированных переменных соответсвующим строкам в списке сообщений, который мы импортировали из Excel. Как ни крути, а ручками работать все-равно приходится... :) Впрочем, название переменной в Excel имеет строковый тип, можно поменять. Однако названия классов и типов имеют численное значение. Честно-говоря, по памяти ставить эти значения очень осложнительно. :)

Непонятность
Александр Родин, ООО "Нева Электрик"; 12.8.02

Наткнулся на большую проблему при работе AlarmLoggingRT.

Веду два архива: ShortTerm на 1000 сообщений, селектирование выполняется по статусу; LongTerm на 365 дней, селектрирование выполняется так же по статусу (пришедшее/ушедшее/квитированное).
Окно для вывода архива сформировано для вывода ShortTerm-архива. Какое-то время все архивировалось нормально. Даже при общем количестве сообщений больше 1000 новые сообщения добавлялись в конец, а более старые затирались. Потом, вдруг, затирание прекратилось. Новое сообщение на какое-то время показывается в конце списка и пропадает, затираясь новым.... Хорошо. Переконфигурировал окно на вывод LongTerm-архива. Опять. Какое-то время все архивировалось нормально. Потом, станцию отключили - ненормальностей не наблюдалось. При последующем включении обнаружилось, что часть сообщений куда-то пропала. Посмотрел при помощи SCVIEW таблицу MSArc в RT-базе проекта. Записи о пропавших сообщениях есть, однако в окно они не выводятся. Проверил свойства фильтра для окна - селектирование выполнено по статусу. Однако часть сообщений в окно так и не выводится. Причем новые сообщения корректно добавляются в конец архива.

Кто может объяснить в чем дело ?.
Версия WinCC 4.02 SP2

Заранее спасибо.


text

FuzzyControl++ & WinCC
Eugene; 12.8.02

Как "прикрутить" oll-объект FuzzyContol++ к WinCC v5.1? WinCC v5.0 SP1 его подхватывал, а вот v5.0 SP2 и v5.1 уже не хотят, говорят "FUZZY.OLL Not a legal .OLL!", хотя все необходимые файлы скопированы в WinCC\bin. То же самое происходит с oll-объектом NeuroSystems.

Не надо только отсылать на http://www.ad.siemens.de/fuzzycontrol/html_76/service_update.htm: оттуда уже давно все выкачано.
Да и вообще, почему такой перспективный продукт не развивается?


text

Как лучше в WinCC выловить приход аварийного сообщения
Дмитрий; 12.8.02

Как лучше в WinCC выловить приход аварийного сообщения, и скажем бибикнуть.

Re: Как лучше в WinCC выловить приход аварийного сообщения
Александр Родин, ООО "Нева Электрик"; 12.8.02

Можно, например, назначить для сообщения флажок "triggers an action" и отредактировать функцию gmsgfunc.fct для вывода звука. Можно еще назначить класс/тип "АВАРИЯ" и для этого класса/типа создать статусный таг, и потом контроллировать этот таг через GlobalScript-функцию, в которой так же делать вывод звука.


text

WINCC..... не могу подключится к контроллеру по MPI HELP me PLEASE!!!!
Сергей Борисович; 9.8.02

Коллеги помогите....столкнулся с такой проблемой....есть контролер 400й, установленно на машину STEP7 v5.1 + SP3, WINCC 5.0...глюк такой проект по MPI грузится в контроллер нормально...но WINCC его не видит пишет "no connection to PLC" настройки "Set PG-PC Interface" правильные проверял не я один...в чем трабл????

Re: WINCC..... не могу подключится к контроллеру по MPI HELP me PLEASE!!!!
Юрченко Владимир; 9.8.02

Посмотрите в WinCC в диалоговом окне Connection Parameter адрес контроллера и номер слота - должен стоять номер слота занимаемый контроллером (посмотрите какой он в проекте Step'а).


text

TP270 / OP270
Сергей Велинов; 7.8.02

Подскажите, пожалуйста: есть ли какая нибудь информация о панелях оператора TP270 и/или OP270 на русском языке? Заранее спасибо за любые отклики.


text

Работа / WinCC
Дмитрий; 12.11.01

Требуется на работу в Москве программист WinCC, з/п высокая.

Резюме по e-Mail dmyegorov@geolink-group.

Re: Работа / WinCC
Бочков Д.В.; 7.8.02

Р Е З Ю М Е .

-на должность начальника лаборатории по разработке СМО;
-старшего инженера (руководителя группы);
-инженера-математика (программиста).

Бочков Дмитрий Викторович, 39 лет.

-образование высшее: 4 курса Казанского государственного университета им. В. И. Ульянова-Ленина (прикладная математика), 5-ый курс Военного инженерного Краснознаменного института им. А. Ф. Можайского г. Ленинград (АСУ и связь);
-cпециальность - инженер-математик;
-стаж работы по специальности 17 лет:
в должности МНС, инженера –испытателя на ВЦ космодрома Байконур;
старшего инженера испытателя в Центре управления полетами.
-разработкой СМО на ЕС ЭВМ занимаюсь с 1985 года(PL-1, Assembler);
-разработкой СМО на ПК с 1995 года(C, C++, Paradox, C++ Builder 6.0);
-иностранный язык – английский (технический перевод);
-исполнителен, аккуратен, коммуникабелен, способен самостоятельно освоить новые средства разработки СМО, имею опыт руководства группой программистов и вести разработку направления.
-место жительства: Москва.

e-mail:botchkov@audio-label.soyuz.ru для Бочкова Д. В.
Контактный телефон: дом. 435-35-25

Ответы на вопросы:
I. Опыт работы с СУБД.
1. Проектировал схему БД в СУБД PARADOX.
2. Писал запросы при помощи BDE в C++ BUILDER.
II. Опыт разработки СМО по проекту: «Автоматизированная система сбора и обработки телеметрической информации (ТМИ) при испытаниях ракетно-космической техники (РКТ)».
Руководил группой программистов и лично разрабатывал подсистему:
«Ввод, запись и предварительная обработка ТМИ» (постановка задачи, создание структур базы данных, взаимодействие с подсистемами комплекса - основные информационные сечения).
III. В разработке клиентской части по проекту использовались как стандартные классы VCL C++ BUILDER, так и собственной разработки.
IV. Участвовал во внедрении программного обеспечения по проекту: «Автоматизированная система сбора и обработки ТМИ при испытаниях РКТ» со стороны Исполнителя на космодроме «Байконур» и «Мирный».
1. Выполнялась настройка СМО.
2. Выполнялась разработка отчетов.
3. Выполнялась разработка дополнительной функциональности СМО.
4. Участвовал в закачке и выверке данных.
5. Участвовал в обучении пользователя системы.


text

Эмулятор PLC и OP37???
Сергей Павлович; 5.8.02

Подскажите как эмулировать PLC для панели OP 37...

это вяжется по MPI ...

Re: Эмулятор PLC и OP37???
Юрченко Владимир; 6.8.02

В ProTool симуляция переменных предусмотрена только для проектов под Windows (то есть PC и панелей с Windows CE). Для текстовых и графических панелей (не с Windows CE) симуляция не предусмотрена. Для отладки можно сделать проект с нужным разрешением под RT, а затем копировать отлаженные картинки и теги в новый проект для OP37.


text

Отключение стандартных комбинаций клавиш в WinCC
Eugene; 16.7.02

Попробовал недавно ради эксперимента отключить в рантайме комбинации клавиш Ctrl-Alt-Del, Alt-TAB и т. д. После корректной деактивации рантайма вышеуказанные комбинации клавиш работали. Но когда из рантайма "вышел" при помощи RESET, комбинации работать перестали вообще. Может ли кто-нибудь подсказать точно, что именно WinCC меняет в реестре касательно клавиатуры?

Re: Отключение стандартных комбинаций клавиш в WinCC
Александр Цихоцкий; 16.7.02

Для отключения клавиш вызова контекстного и главного меню, WinCC меняет значение ветви

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout

HEX: Scancode Map

которое по-умолчанию равно:

00,00,00,00,00,00,00,00,04,00,00,00,00,00,5b,e0,00,00,5c,e0,00,00,5d,e0,00,00,00,00

Наверное, там же происходит и изменение для Ctrl-Alt-Del, Alt-TAB и т. д.

Re: Отключение стандартных комбинаций клавиш в WinCC
Eugene; 17.7.02

Спасибо, Вы подтвердили мою догадку.

Re: Отключение стандартных комбинаций клавиш в WinCC
Федун Николай, АО АНХК; 6.8.02

Насколько я знаю, комбинация Ctrl+Alt+Del для WinCC под WinNT отключается путём замены Microsoft-овской DLL-ки MSGINA.DLL на Siemens-овскую ALMXGINA.DLL.

Посмотрите в разделе реестра HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\Winlogon параметр GinaDLL. Он равен "almxgina.dll".

Эта DLL-ка заведует входом пользователя в систему, и, соответственно, обработкой Ctrl+Alt+Del. Что внутри неё - не знаю. О работе Microsoft-овской MSGINA.DLL можно посмотреть тут:
http://www.microsoft.com/windows2000/techinfo/administration/security/msgina.asp


text

Организация косвенной переадресации тегов
Gennady; 5.8.02

В WinCC 5.0 организовал косвенную переадресацию 30 тегов и проект при переключении картинок начал тормозить безбожно. Как уйти от этого?KGN@Mailru.com


text

WinCC - есть проблема с Tag/Action(Alarm Login)
Gennady; 2.8.02

Всем привет.

Есть проблемка - не удаётся вывести по пришедшему сообщению необходимую картинку в WinCC 5.0 . В аларм логин в свойствах сообщения в Tag/Action указал картинку, указал function на открытие, установил loop in alarm
а она не хотит.
Может чего-то не доделал?

Зараннее благодарю.
Ответы по адресу kgn@mailru.com


text

Распайка кабеля для соединения AS511
Николай; 23.5.02

Вышлите, пожалуйста, распайку кабеля для соединения AS511 между PC(COM1, COM2) и PLC S5 (по каталогу это кабель 6ES5734-1BD20).

Спасибо.
Re: Распайка кабеля для соединения AS511
Руслан; 24.5.02

Здравствуй Николай !!!!

Меня заинтересовала твоя тема и хотелось бы пообщаться с тобой по поводу связи S5 с PC , как ты это осуществляешь и что при этом используешь.
А на счет распайки , напиши маил я тебе скину документашку.
Re: Распайка кабеля для соединения AS511
Александр; 27.7.02

Здравствуй Николай.

Помогу, нужен твой маил.
Re: Распайка кабеля для соединения AS511
Чистяков Дмитрий ОАО "СеверСталь"; 29.7.02

Вот несколько ссылок

Распайка кабеля для PG и S5-130, S5-150
http://www4.ad.siemens.de/news/cs/en/35676
http://www4.ad.siemens.de/news/cs/en/217845

Драйверы для связи
http://www4.ad.siemens.de/news/cs/en/40009
http://www4.ad.siemens.de/news/cs/en/9715828
Re: Распайка кабеля для соединения AS511
Евгений Л.; 1.8.02

При реализации такого соединения в своё время был глюк с WinCC (в составе PCS7 v 5.1), а точнее глюкнул User Administration, исчезло деление на экранные формы. Если удасться "победить" такое соединение поделитесь плиз.


text

Web & DB
Rinat; 31.7.02

Здравствуйте!

Подскажите, pls, есть ли возможность подключаться к базе данных через Internet Explorer.
Локально всё работает без проблем, а как только пытаюсь через IE ругается...
Re: Web & DB
Чистяков Дмитрий ОАО "СеверСталь"; 31.7.02

Подробности в студию!

Слишком мало информации.
Re: Web & DB
Rinat; 31.7.02

К базе подключаюсь при помощи функций из db.dll.

При публиковании в WEBNAVIGATOR ругается на присутствие ошибок в проекте, а когда комментирую строки подключения к БД - всё проходит.


text

Временные файлы WinCC немерянного размера
Сверчков Александр; 31.7.02

Есть один проектик, во время работы которого в корневом каталоге диска С: создаются временные файлы с именем типа asat0000.tmp, asat0001.tmp и т.д. Размер некоторых из них успевает вырасти до 800 Мб (возможно, наверное, и больше, да места на диске не остается). Причем не остановив проект обычно самый большой из них и не удалишь. Вопрос: как ограничить размер этих файлов или на крайняк сделать так, чтобы они создавались на другом диске.


text

Реакция WinCC Runtime на Ctrl+Alt+Del под WinNT
Федун Николай, АО АНХК; 14.5.02

Здравствуйте!

У нас WinCC v5.0 SP1 HotFix3 под WinNT 4.0 SP6. Запускаем небольшой тестовый проект с 1 картинкой. Все HotKeys для Runtime отключены. В "Start sequence for WinCC runtime" включен только Graphics Runtime. При нажатии Ctrl+Alt+Del однократно мигает экран, после чего Диспетчер задач показывает загруженность процессора 100%, которая сохраняется до деактивации проекта. Если вставить и включить Gl.Script, то он может не успевать выполнять некоторые действия. Изменение приоритетов в Диспетчере задач только ухудшает ситуацию. Как этого избежать?

Прошу прощения, если вопрос слишком элементарный.

Заранее огромное спасибо!
Re: Реакция WinCC Runtime на Ctrl+Alt+Del под WinNT
Вера Прокопенко; 15.5.02

Попробуйте включить в Startup опцию Alarmlogging, у нас без нее проект даже в runtime не грузился.

Re: Реакция WinCC Runtime на Ctrl+Alt+Del под WinNT
Федун Николай, АО АНХК; 20.5.02

Уважаемая Вера,

Спасибо за отклик.

Такой вариант я уже пробовал в самом начале. Я и отключать-то все опции начал и к тестовому проекту перешёл потому, что на реальном проекте, где все опции включены, компьютер виснет.

Зависания не наблюдается, только если запустить проект со всеми отключенными опциями.

У нас недавно появился SP2 для WinCC, как поставлю, если проблема исчезнет, сообщу в форуме.
Re: Реакция WinCC Runtime на Ctrl+Alt+Del под WinNT
Федун Николай, АО АНХК; 31.7.02

Похоже, я обнаружил, в чём было дело. У меня на компьютере стоит 3 системы - Windows NT 4.0 SP6, Windows 2000 и Windows 98. Ставил я их в таком порядке: Win98 -> WinNT -> SP6 -> Win2000. Проблема с Ctrl+Alt+Del бесследно исчезла (под NT!), когда я поставил SP2 на Win2000. Видимо, когда Win2000 устанавливается рядом с WinNT на одной машине, 2000-й заменяет часть загрузчика NT на свою. SP2 для Win2000, видимо, что-то там поправил.

А вообще-то руководство по WinCC запрещает подобную совместную установку.

См. http://Nick


text

CP 2000 и COROS LS-C
Александр; 27.7.02

Кто подскажет, как связать коммуникационный процессор CP2000 (6AV1222-OAC20), который использовался для связи CPU928(S5-135) с COROS LS-C, с WinCC.

Где взять хоть какую-нибудь информацию на CP-2000???


text

WinCC 5.0. Где находится Service Pack 2?
Евгений Трунов; 24.7.02

Где именно на ad.siemens.de находится SP2? Указанная в документе ID 6883784:VF/LF: SIMATIC WinCC Version 5.0 Service Pack 2 ссылка недействительна; раздела "Process Visualization" в "SIMATIC HMI Products/Systems" нет вообще. Поиск выдаёт только описания, без указания "места отгрузки". Откуда его брать-то?

Re: WinCC 5.0. Где находится Service Pack 2?
Чистяков Дмитрий ОАО "СеверСталь"; 25.7.02

Он уже давно от туда изчез, как устаревшый. ;-)

Re: WinCC 5.0. Где находится Service Pack 2?
Василенко; 25.7.02

В sea.siemens.com/software

в разделе Quick download
Re: WinCC 5.0. Где находится Service Pack 2?
Юрченко Владимир; 25.7.02

Уточню, что по последней ссылке лежат только HotFix для WinCC, а не SP. Если нужен этот сервис пак обращайтесь в наши технические центры - переслать по почте не реально, но диск записать можем.

Re: WinCC 5.0. Где находится Service Pack 2?
Евгений Трунов; 25.7.02

> Он уже давно от туда изчез, как устаревшый. ;-)

Угу. Тем не менее, сервиспаки к WinCC 4.2 доступны для загрузки.

Или после SP2 вышло что-то ещё? Для WinCC 5.0, а не 5.1. Тогда где оно?

> sea.siemens.com/software в разделе Quick download

Там только хотфиксы. Ими пока нечего фиксить :).
Re: WinCC 5.0. Где находится Service Pack 2?
Чистяков Дмитрий ОАО "СеверСталь"; 26.7.02

>Угу. Тем не менее, сервиспаки к WinCC 4.2 доступны для загрузки.

Они размером по меньше. ;-)
Держать четыре сотни метров на серваке накладно будет.

>Или после SP2 вышло что-то ещё? Для WinCC 5.0, а не 5.1. Тогда где оно?

Был WinCC 5.0 SP2 HF7 - всё одним скопом.

Был ещё 9-ый HF, но вот я не знаю как он был оформлен - примочкой или гуртом.

Re: WinCC 5.0. Где находится Service Pack 2?
Юрченко Владимир; 26.7.02

HF 9 для WinCC 5.0 SP2 запрашивали от немецкого саппорта в Московский офис. Отдельная примочка около 8 Мб.


text

WinCC hotfix + virus
vzozulja; 26.7.02

Похоже, что в hotfixe 2 для WinCC 5.1, который с http://www.sea.siemens.com/, есть троянец в _isdel.exe.. Ловите ;-)


text

Архивирование больших объемов в TagLogging
Лобанов Денис; 12.7.02

Здраствуйте!

Возможно ли средствами WinCC архивировать следующее количество тегов:
- 100 аналоговых циклически
- 700 аналоговых по изменению
Период архивации 2 секунды. Архив short-term, расчитанный на 2 недели.

Для эксперимента был взят компьютер Athlon 750, RAM 96Mb, HDD 20Gb (5400 об).
В результате система загрузилась на 100% и через некоторое время run-time завис...

Архивирование можно сделать и спомощью внешней программы (и оно уже есть, как
одна из опций OPC сервера, где данные сохраняются в dbf-таблице), но тогда
теряется возможность использовать стандартные средства отобращения трендов.

Можно ли как-нибудь решить проблему средствами WinCC?
Re: Архивирование больших объемов в TagLogging
Юрченко Владимир; 12.7.02

Максимальная производительность архивирования в WinCC порядка 300-400 тегов в секунду. Если необходима большая производительность, можно использовать недавно появившуюся опцию WinCC пакеты PDA и PPA. Их производительность до 1500 тегов в секунду. В ближайшее время постараюсь поместить в разделе HMI описание этих продуктов на русском языке с заказными номерами и стоимостью. Если нужно быстро , но на английском - обращайтесь по е-mail Vladimir.Yurchenko@mow.siemens.ru

Re: Архивирование больших объемов в TagLogging
Александр Родин, ООО "Нева Электрик"; 15.7.02

Нужно. Быстро. :)

Если можно, перешлите пожалуйста на емыл.

Заранее спасибо.
Re: Архивирование больших объемов в TagLogging
Юрченко Владимир; 16.7.02

Информацию по PDA/PPA смотрите в http://www.aud.ru/as/products/08_hmi/02_pr/10_PDA_PPA_r.ppt

Re: Архивирование больших объемов в TagLogging
Вера Прокопенко; 17.7.02

Хорошо использовать гистерезис для записи аналоговых тегов. И не желательно использовать запись в архив по событию.На архивирование по событию, если оно сконфигурировано в TagLogging через Evevt start / Even stop есть ограничения: не рекомендуется более чем для 10 тегов. Если отследить работу этих событийных функций, то видно, что они запускаются по 4 и более раз в секунду для каждого тега, видимо, это и нагружает систему. Лучше использовать запрет и разрешение на запись всего архива (если это возможно по условиям работы проекта) с использованием ODK функции TLGLockArchiv (NULL,имя архива,0-разрешение записи или 1-запрет,&pError ). Для разовой записи значения тега в архив можно использовать функцию TLGInsertArchivData().

Re: Архивирование больших объемов в TagLogging
Александр Родин, ООО "Нева Электрик"; 23.7.02

А вот вопрос на засыпку...

Документацию по PDA/PPA получил, большое спасибо, там все очень красиво написано, что возможно вона сколько... А поюзать на время дать могут? Обещаю, никому больше не давать %)

Просто у нас ситуация такая: есть проект, где, возможно потребуется обрабатывать большие объемы данных. Вот и стоим на перепутье: либо платить много денег и купить PDA, и до конца не понятно как он тогда в проект врастет... вдруг глючить будет, вещь-то новая; либо делать все как раньше делали через связку TagLogging-ODK, геморройно, но проверено и наработано.

Заранее спасибо.
Re: Архивирование больших объемов в TagLogging
Евгений Трунов; 24.7.02

Исходя из описания, возможно использовать RTDS+РРА+HHD для обработки данных полностью самостоятельно, без участия подсистемы TagLogging? И, возможно ли то же самое для хранения/обработки сообщений подсистемы AlarmLogging?

Re: Архивирование больших объемов в TagLogging
Юрченко Владимир; 25.7.02

К сожалению какого то демо или реального PPA/PDA у нас в России пока еще нет.

Как заявлено работать он может самостоятельно через OPC сервера (и кажется только через них). И пока использует только Data Access OPC, то есть архивирует только теги, а об алармах и понятия пока не имеет.


text

Transfer
Владимир; 23.7.02

Где можно найти информацию о передаче тегов из Step 7 в WinCC при помощи опции Transfer?

Re: Transfer
Михайлин Сергей; 23.7.02

Опция называется PLC-OS Engineering! Под WinCC инсталируется и запускается отдельной программой. Переносит автоматически переменные из символьной таблицы и instans-db, помеченные специяльным атрибутом S7_m_c=true. Подробная информация содержится в readme и online-help.Путь инсталятора \\WinCC\SETUP\PRODUCTS\MAPPER

Re: Transfer
Владимир; 24.7.02

Спасибо!


text

Transfer DB
Владимир Мельников; 24.7.02

Трансфером не можем передать элементы DB...атрибут S7_m_c назначен блоку DB...отдельным элементам атрибут не назначается(флажок не ставится)...данный DB создан для UDT

При трансфере создался стуктурный тег DB1.DBBO
Вопрос: Будет ли работать Transfer для DB, основанного на UDT с массивами? Или только на FB?
Как посмотреть поля созданного структурного тега?


text

Как лучше восстановить значения внутренних тэгов при перезапуске WinCC-RT
Евгений; 19.7.02

Как лучше восстановить значения внутренних тэгов при перезапуске WinCC-RT. Теги разного формата и в хорошем количестве, этакая таблица 34х9 записи которой нужно периодически двигать вверх.

Re: Как лучше восстановить значения внутренних тэгов при перезапуске WinCC-RT
Колпащиков Сергей. Аквтехнология; 19.7.02

Мы реализовали примерно такую же задачу

следующим образом.
Написали программку на "C" которая берет из базы данных привязку тэгов к таблице значений, считывает значения и через ODK функцию засылает в значения в ТЭГи. Запускается программка через StartUp List. Правдо быстродействие нас не сильно волновало. Мы ставим условие заказчику, что проект не начинает работу до завершения работы нашей программки восстановления.
Все настроечные таблицы создали в dbrt.

Re: Как лучше восстановить значения внутренних тэгов при перезапуске WinCC-RT
Евгений Трунов; 19.7.02

Смотри <A HREF="http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1024565911&year=2002>обсуждение от 21.06.2002</A>

Re: Как лучше восстановить значения внутренних тэгов при перезапуске WinCC-RT
Евгений; 19.7.02

Это единственный выход ?


text

Создание тегов при помощи WinCC ODK
Александр; 18.7.02

Каким образом при программном создании тега типа internal установить его

свойство, отвечающее за Project-wide update/Computer-local update?
В WinCC ODK явного описания этого свойства, имеющегося при "ручном" создании тега, нет. Для создания использовалась переменная типа MCP_NEWARIABLE_DATA и функция GAPICreateNewVariable.
Заранее спасибо !!!
Re: Создание тегов при помощи WinCC ODK
Александр, СКТЦ; 18.7.02

В ODK описана константа DM_INTERNAL_VAR_LOCAL, а вместе с ней еще несколько интересных констант,

но что с ней делать не особо понятно.
По всей видимости что-то вроде:

MCP_NEWARIABLE_DATA NVarData;
NVarData.Common.dwVarProperty |= DM_INTERNAL_VAR_LOCAL для Computer-local

и соответсвенно NVarData.Common.dwVarProperty &= ~DM_INTERNAL_VAR_LOCAL для Project-wide

Других претендентов для использования этого флага пока не видно.

Re: Создание тегов при помощи WinCC ODK
Александр; 19.7.02


text

Запаздывание в Alarm Logging
Лобанов Денис; 15.7.02

Здраствуйте!

При записи сообщения используется ProcessValue блок. Значение, извлекаемое из связанного тега (тип text8) и затем сохраняемое в сообщении, отстает от реального на 1-2 секунды. Можно ли синхронизировать запись значений и возможно ли создавать запись сообщения через скрипт?
Re: Запаздывание в Alarm Logging
Александр, СКТЦ; 16.7.02

Смотри обсуждение от 16.10.01

Сообщения создаются с помощью функции
MSRTCreateMsg

См. http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=996589679&year=2001


text

Связь S7 с WinCC без Simatic-а (виртуальная)
Андрей; 4.2.02

Возможна ли виртуальная связь S7 с WinCC без Simatic-а ? Для обучения на одном компьютере без simatic-а...

Re: Связь S7 с WinCC без Simatic-а (виртуальная)
Чистяков Дмитрий ОАО СеверСталь; 7.2.02

Да, возможна. Установите CC_Simulator из папки SmartTools с установочного CD-ROM WinCC.

Пример использования симулятора имеет в GetStarting на русском и английском языках.

Re: Связь S7 с WinCC без Simatic-а (виртуальная)
Дмитрий Назаров ЗАО "Номбус"; 5.3.02

Можно воспользоваться OLE функциями WINCC описанными в руководстве Configuration Manual и написать программку, например в Visual Basic, изменяющую значения одних тегов при изменении других. Но теги должны быть внутренними. Получается еще интересней, чем с симулятором.

Re: Связь S7 с WinCC без Simatic-а (виртуальная)
Александр Туманов; 14.3.02

Для отладки проектов я использую WinCC* + WinCC Simulator (эмулирует теги) и STEP7* + S7-PLSSIM* (эмулирует PLC). Виртуальная связь между PLC и WinCC по MPI - полная имитация работы программ в реальном времени. Пакеты, помеченные * требуют авторизаций.

Re: Связь S7 с WinCC без Simatic-а (виртуальная)
Диденко Е.; 15.7.02

Только когда у меня была WinCC V4.xx, S7-PLCSIM с ним не работал! А с WinCC V5.xx без проблем.


text

OP37
Диденко Е.; 12.7.02

Хотелось бы получить ответ на следующий вопрос.

У нас в проекте присутствуют 2-е операторские панели OP37. Как известно, в ProTool в меню Systm->Settings устанавливается пароль Supervisor ( по-умолчанию 100 ). В операторской панели, я так понял этот пароль хранится в энергонезависимой памяти, поддерживаемой батареей. При этом, мы в проекте для задания и редактирования этого (и паролей других уровней меньше 9-ого)мы применяем экран с использованием стандартных функций Z_LOGON и Z_PASSW. Однако если мы поменяли пароль при работающем проекте в этом экране (экране паролей), то последующие загрузки в OP новых версий проекта с изменённым паролем supervisora через SYSTEM->SETTINGS ни к чему не приводят. Ну то есть я хочу сказать, что как бы эта функция в ProToole "не работает и бесполезна", а пароль меняется только если используешь в проекте Z_LOGON и S_PASSW, и после таких изменений пароль прописывается в энергонезависимой памяти. Это первый вопрос.
Второй заключается в следующем: После задания пароля с помощью экрана в котором заложены Z_PASSW и Z_LOGON он (пароль)некоторое время хранится в памяти, а затем (недели через 2-3)"пропадает". Не воспринимается ни наш заданный пароль, ни пароль по умолчанию 100. Приходится вытаскивать батарейку из OP(при этом сбрасываются все настройки панели), затем ставить её на место и грузить весь проект заново(загружаются и все необходимые настройки). Да, в этом случае как раз устанавливается ,по-моему, пароль supervisora из SYSTEM->SETTINGS. Подскажите,почему так происходит, или я в чём то не разобрался?


text

Загрузка данных из архива в Trend Control
Денис; 10.7.02

Здраствуйте всем!

Вопрос по отображению трендов в WinCC:

Имеется окно TrendControl1 с одним трендом, предназначеное для отображения N-ного количества тегов. Выбранный тег записывается в свойство TagName. После записи окно очищается, строится новый график, но данные из архива не подгружаются, не смотря на установленный флаг Load Archive Data. Добиться этого можно, нажав кнопку stop, а затем "переход на последнюю запись". Попытался повторить нажатия этих клавиш программно, но функции возвращают ошибки:
if (! TlgTableWindowPressStartStopButton("TrendControl1")) printf("err_1\n");
if (! TlgTableWindowPressLastButton("TrendControl1")) printf("err_2\n");
Кто-нибудь сталкивался с подобной проблемой?

Re: Загрузка данных из архива в Trend Control
Александр Родин, ООО "Нева Электрик"; 10.7.02

Достаточно просто перещелкнуть флаг в атрибуте "Activate"


text

Поиск на диске AutoStart ничего не дал
Андрей А.; 28.3.02

Если утилиты AutoStart нет, то как его получить(скачать или переустановить WinCC)?

Re: Поиск на диске AutoStart ничего не дал
Александр Туманов; 29.3.02

Приложение AutoStartRT находится в папке C:\Siemens\WinCC\bin после инсталляции WinCC. Gjghj,попробуй переустановить WinCC, а потом Windows.

Кстати, какие у тебя версии WinCC и Windows? После установки WinCC нужно ставить ещё и HotFix (см. на установочном диске WinCC).
Версии
Андрей А.; 1.4.02

У нас Windows NT 4.0 SP4,WinCC 4.02 SP2.

А HotFix посмотрю.Насчет порядка установки ПО не совсем врубился.Обычно устанавливают сначала Windows,а потом всё остальное.Напиши свою мысль поподробнее.
Re: Поиск на диске AutoStart ничего не дал
Александр Туманов; 1.4.02

Про установку: когда с WinCC бывают глюки иногда помогает полная переустановка WinCC, а иногда только переустановка (поверх) Windows без переустановки других программ. Про AutoRunRT: у меня работал с Windows NT 4.0/2000 server и WinCC SP1/2.

Re: Поиск на диске AutoStart ничего не дал
Максим Елхов; 3.4.02

AutoStart (насколько мне известно) идет только в WinCC 5. В четвертой версии запускайте mcp.exe из Автозагрузки.

утановка WinCC?
Олег; 10.7.02

Добре люди есть у кого-нибудь документация по установке WinCC в электронном виде или подскажите где найти.

Re: Поиск на диске AutoStart ничего не дал
Юрченко Владимир; 10.7.02

Смотри http://www.aud.ru/as/products/08_hmi/04_man/02_GettingStarted_V4_r.pdf

или на дистрибутиве GettingStarted.


text

Установка WinCC_5.0_SP2
Николай Зорин, ОАО"СПбКПК"; 9.7.02

При установке WinCC_5.0_SP2 появилось сообщение "The dynamic link library SHLWAPI.dll could not be found...". После установки при попытке запустить WinCC_5.0 опять появляется сообщение "The dynamic link library SHLWAPI.dll could not be found...". Установку осуществляли по WindowsNT_SP4. Возможно причина в диске.

Если кто откликнется, отправьте пожалуйст на e-mail этот файл и путь по которому его необходимо установить.

Re: Установка WinCC_5.0_SP2
Евгений Трунов; 9.7.02

shlwapi.dll размещается рядом со всеми своими сёстрами в %SystemRoot%\system32. В ней собраны различные функции конверсии строк, работы с реестром и т.п. Весит 282 896 байт (WinNT 4.0 RUS, SP5).

Re: Установка WinCC_5.0_SP2
Евгений Трунов; 9.7.02

Является частью установки Internet Explorer'a 3.0 и выше.


text

Как автоматизировать backup базы *RT.db?
Александр Туманов; 8.7.02

Требуется автоматизировать (написать скрипт на Си) архивирование RT базы данных WinCC аналогично работе функции backup в Sybase Central.

Как это сделать?
Re: Как автоматизировать backup базы *RT.db?
Александр Родин, ООО "Нева Электрик"; 9.7.02

А Storage не пробовали ? Вроде как он для этого и создан...

Re: Как автоматизировать backup базы *RT.db?
Александр, СКТЦ; 9.7.02

Используйте утилиту dbbackup.exe из Sybase. С её помощью можно делать backup при запущенном проекте.


text

Tag Logging ручная запись
Антон Глухов; 8.7.02

Скажите пожалуйста, как записать в длинный архив Tag Logging значение в ручную, причем с указанным временем, а не с тем, которое установит сама WinCC.

Re: Tag Logging ручная запись
Александр Родин, ООО "Нева Электрик"; 9.7.02

Чисто теоретически можно воспользоваться ODK-шной функцией TLGInsertArchivData.

Более, на мой взгляд, корректный способ запись через SQL. Причем тонкость есть: не желательно производить запись в запущенный RT архив. Может здорово глюкнуть.
Если что-то конкретное интересует - обращайтесь на емыл.


text

WinCC попробовать
Кулагин Павел; 6.7.02

Вопрос такой:было такое что можно было получить 1 комплект WinCC RT+CS на 128 тегов бесплатно можно ли это сейчас и если можно то как? А если нет то можно ли найти некую демо версию (к примеру работающию в Run Time 1час)?

Re: WinCC попробовать
Сергей; 6.7.02

Демо WinCC 5.1 можно было бы Вам передать. Она записана на диске и неплохо было бы знать куда ее направить и чем вы занимаетесь. Мы же партнеры Сименса.

С уважением, Сергей.


text

HotFix 2,3,5 for WinCC 5.1
Василенко; 5.7.02

смотри sea.siemens.com/software

есть раздел Quick Download
там же и обновления всех других продуктов


text

Документация по Sybase
Руслан; 4.7.02

Уважаемые господа!!!

У кого есть документация по Sybase или ссылки, желательно на русском языке. Интересует любая информация. Заранее благодарен.

Re: Документация по Sybase
Юрченко Владимир; 4.7.02

На английском можно найти на http://sybooks.sybase.com/aw.html

Re: Документация по Sybase
Александр Родин, ООО "Нева Электрик"; 5.7.02

www.sybase.ru


text

Добавление данных в Function Trend в WinCC
Александр Цихоцкий; 14.5.02

Столкнулся с этим контролом (CCTLGFUNCTIONTREND) при работе в WinCC. Взял бы OnLine, так нужна ось OX не с временем, а с обычнами числами. Понятно практически всё, кроме добавления данных в этот тренд.

Ответьте, пожалуйста, какие действия необходимо произвести.
Re: Добавление данных в Function Trend в WinCC
Игорь; 1.7.02

А где он такой есть ?

Мне тоже надо
Re: Добавление данных в Function Trend в WinCC
Александр Цихоцкий; 1.7.02

Так там он и есть...

В Smart Objects закладки Standard палитры объектов есть вохможность добавить Control, разворачивая который появится список всех контролов, где и можно выбрать WinCC Function Trend Control.

Только вот как в него запихнуть нужные значения я все равно не знаю
Re: Добавление данных в Function Trend в WinCC
Юрченко Владимир; 2.7.02

Имеется описание на английском языке этого контрола с разными способами настройки. Смотрите файл FunctionTrendControl.pdf (или *.chm) в WinCC\Documents\english

Re: Добавление данных в Function Trend в WinCC
Александр Цихоцкий; 3.7.02

Владимир. Я просмотрел все файлы в указанной Вами папке... Ни файла с подобным названием, ни содержащего какую-либо информацию об этом контроле я там не нашел.

Укажите, если можно, ссылку, где его можно откопать или отправте по почте.

Заранее благодарен.


text

HotFix2 для WinCC V5.1
Пётр; 2.7.02

Вышел HotFix2 для WinCC V5.1

Брать отсюда:
http://www.sea.siemens.com/sw/download/hot2cc51.zip


text

S7200 OPC Server авторизация ???
Дмитрий Л.; 26.6.02

Что нужно для нормальной работы S7200 OPC Server - лицензия, авторизация и сколько она стоит ?

Re: S7200 OPC Server авторизация ???
Юрченко Владимир; 28.6.02

Нужна авторизация, заказной номер

и цену можно посмотреть в файле
http://www.aud.ru/as/products/01_micro/02_pr/02_S7-220_r.pdf


text

Загадочное предупреждение
Игорь; 27.6.02

wincc 5.0

В каталог /siemens/common/objengin/output постоянно пишутся файлы *.err с одной и той же записью вроде
#Thu Jun 27 11:17:21 2002
file: DistribConfig line: 998 err_class: Warning err_no: 0x80070057
function: CDistribConfig::LookupPrefix
message: Warning: No matching prefix found for name = >@TLGRT_SIZEOF_DATABASE_QUEUE<, ServerType = >IVAR2<. 0x80070057 Параметр задан неверно.
В качестве имени указывается один из тэгов.
Кто-нибудь знает , что сие может означать ?


text

Масштабирование тегов
Роман; 25.6.02

Как сделать так, чтобы считанное из контроллера BCD слово записать в архив или вывести в сообщение поделённое на 10 или 100 без потери знаков после запятой.

В ахиве форума нашёл вот это:
"Самый простой способ, это объявить в WinCC переменную типа Float 32-bit или Float 64-bit.
А затем задать конверсию форматов (Adapt Format): FloatToWord или DoubleToWord (прямо в диалоге объявления переменной). При этом из контроллера читается Word и преобразуется соответственно во Float или Double в WinCC. (обратите внимание, что при преобразовании, например, DoubleToWord Double относится к WinCC, а Word - к PLC)".
Я так попробовал и ничего, пишет нуль. Даже это число выведенное в график-дизайнере на экран не отображается, т.е. тоже нули, только затемнённый и цифры наклонены в разные стороны.
Может кто может дать более подробную консультацию как преобразовать допустим слово BCD без знака 999 в 9,99, чтобы оно именно так записывалось.
Заранее благодарен.
Re: Масштабирование тегов
Александр Родин, ООО "Нева Электрик"; 25.6.02

Если надо в архив писать поделенное значение, то читайте раздел 5 описания по TagLogging-у. Там есть описание шаблонов функций преобразования. В частности, можно создать функцию, которая будет текущее значение делить на 10, или на 100 и т.д. А далее эту функцию подставляем в свойствах архивного тэга.

Если вам на экране надо поделенное значение выводить, то вабще просто. Пишите скрипт типа:
return GetTagWord("SomeTag")/10.0;

Можно привязать масштабирование к Dynamic Dialog, так же в свойствах поля ввода/вывода.

Можно, конечно, заморочиться и с линиаризацией... но там знаки теряются. Если поставить конвертацию формата при этом, может конечно и получится что-нибудь, но я это не пробовал... :)
2 Александр Родин
Роман; 25.6.02

Спасибо за совет.

Но я не имел ввиду теги для архива Tag Logging и для вывода на экран. Здесь мименно так и делаю. Мне нужно тег записать в таблицу User Archive.
А здесь по-моему идёт привязка к конкретному тегу из Tag Management.
Можете ли вы сказать что-либо по этому поводу.
Re: Масштабирование тегов
Александр Родин, ООО "Нева Электрик"; 27.6.02

Честно говоря, опцией UserArchiv я никогда не пользовался... Но думаю, возможности по форматированию данных там тоже есть.

Попробуйте почтитать раздел 4 описания по User Archive... может там что-то есть.


text

WinCC проектирование
Константин Рылов; 25.6.02

Скажите, пожалуйста, отличается ли среда разработки WinCC в зависимости от того, на сколько тэгов система? Или можно взять среду разработки + RT на 128 тэгов, сделать одну систему, а для следующей купить только RunTime на 1024?

Я думал, что нет, а судя по прайсу- да..
Re: WinCC проектирование
Александр Родин, ООО "Нева Электрик"; 27.6.02

Да хоть на 64К возьми... Среда одна и та же. :)

Цена зависит только от количества РТ-тэгов и опций, которые вы закупаете. Вот если опции какие-нить куплены, то среда меняется только добавлением редактора для данной опции. :)

А в остальном все одно и то же.


text

Динамическая переадресация тегов в WinCC
Сергей Архипов; 17.6.02

Уважаемые участники форума!

Подскажите: возможно ли осуществить динамическую переадресацию тегов в WinCC. Тип тега может оставаться тем же, а вот адрес должен меняться,например, по событию. Возможно есть в ODK что-нибудь подобное. Заранее благодарен за помощь.
Re: Динамическая переадресация тегов в WinCC
Alexis; 18.6.02

А косвенная адресация не устраивает?

Re: Динамическая переадресация тегов в WinCC
Евгений Трунов; 18.6.02

> А косвенная адресация не устраивает?

Я так понимаю, что необходимо динамически менять привязку тега к области памяти ПЛК по к.-л. событию. Т.е. тег, имевший адрес "DB12.DD8" должен стать "DB20.DD16", например. Такая ситуация действительно возникает достаточно часто. Чем тут поможет косвенная адресация?
Re: Динамическая переадресация тегов в WinCC
Alexis; 18.6.02

В таком случае заводятся два тэга с адресами "DB12.DD8" и "DB20.DD16", а далее через косвенную адресацию :)

Re: Динамическая переадресация тегов в WinCC
Александр Родин, ООО "Нева Электрик"; 18.6.02

Я лично делаю так: создаю два тега одинакового типа, например DW_Tag_1 и DW_Tag_2... а далее, там где мне требуется подставляю нужный мне индекс. К примеру так:

{
...
sprintf (buffer1, "DW_Tag_%d\0", 1);
GetTagDWord (buffer1);
...
}

Возможно есть еще способы...
Re: Динамическая переадресация тегов в WinCC
Сергей Архипов; 18.6.02

Спасибо за предложенные варианты. Косвенная адресация это конечно хорошо, но в этом случае увеличивается количество внешних IO тегов, а это уже не есть хорошо. Если бы в WinCC был механизм динамической переадресации (например, такой как существует в InTouch, без увеличения внешних тегов), то это бы спасло отца Русской демократии, а так - нет!

Еще раз благодарю за ответы.
Re: Динамическая переадресация тегов в WinCC
Александр Родин, ООО "Нева Электрик"; 19.6.02

Честно говоря, пролистал я доку по InTouch, и не нашел как там можно на один тег засадить сразу хотя бы два адреса.. :(

Если говорить о связи InTouch - SIMATIC, то в лучшем случае она идет через OPC, а в нем, кажися, на каждый отдельно взятый ресурс назначается только одна переменная... Или я чего-то не понял ?...
А?..
Re: Динамическая переадресация тегов в WinCC
Евгений Трунов; 20.6.02

Два тега через переключатель - это понятно :). Человек спрашивал, как сделать, чтобы не надо было плодить эти самые теги. Потому что SIEMENS только того и ждёт, чтобы их намножили, чтобы ненавязчиво предложить рантайм на 64.000 тегов :).

Вопрос, вообще говоря, более общий - о возможности изменений свойств тега "на ходу" в режиме Runtime. Это часто бывает необходимо, но WinCC считает, что это излишества :).
Re: Динамическая переадресация тегов в WinCC
Alexis; 20.6.02

2 Евгений Трунов

Если поглядеть на файлы WinCC\Bin\*.CHN, то возникает мысль, а нельзя ли попытаться использовать их для слива данных с PLC без WinCC или параллельно с ней. Описание набора функций содержащихся в этих переименованных длл-ках есть в CDK.

Может у кого-нибудь имеется опыт?
Re: Динамическая переадресация тегов в WinCC
Евгений Трунов; 20.6.02

2 Alexis:

Чем мучиться с *.CHN, не проще ли через ОРС? Или нет нужного сервера?
Re: Динамическая переадресация тегов в WinCC
Чистяков Дмитрий ОАО "СеверСталь"; 20.6.02

Привет Сергей!

Ну я предложу свой вариант, исходя из следующего:
Видимо тебе надо сделать проект визуализации объекта, на котором много однотипных подсистемок.
Так вот мы ещё на ДС-2 делали так:
1. в контроллере создаются DB (они и так там уже видимо имеются). Все они однотипные (ведь подсистемы тоже однотипные, например, DB1, DB2, DB3 и т.д.
2. Создаётся ещё один DB, скажем 20.
3. В программе PLC пишеться простая программа, которая по одному "тэгу-перключателю" (например, обычное слово) пересылает один из блоков в DB20.
4. В WinCC описываем тэги, указывающие на DB20. Плюс ещё один, через который будем переключать DB.
5. В кадрах визуализации при переключении на новый кадр, достаточно в "тэг-перключатель" послать код требуемой подсистемы и вызвать тот же самый PDL.

У нас так и было сделано на ДС№2, только на COROSе

Re: Динамическая переадресация тегов в WinCC
Игорь; 26.6.02

Есть опыт использования *.chn без WinCC.

Пишите на e-mail


text

Simatic IT Framework
Максим Поджидаев; 26.6.02

Здравствуйте господа! прошу прощения, что не совсем в тему. Недавно нашел на сайте Siemens упоминание продукта Simatic IT Framework. Судя по всему это продукт класса MES. Информации на сайте мало, хотелось бы больше. Может кто нибудь помочь?


text

SIMATIC S5 PMC Ethernet
Алексей; 30.5.02

Как правильно настроить соединение

"SIMATIC S5 PMC Ethernet" в Wincc.
Может есть какая нибудь документация.
Особенно интересует параметрирование
Cpu S5 и Cp1430TF.В доках по Wincc
этого нет.

Re: SIMATIC S5 PMC Ethernet
Алексей; 3.6.02

Ну ктонибудь ответит на мой вопрос?

Re: SIMATIC S5 PMC Ethernet
Павел Иванов (Сименс-Москва); 24.6.02

Это описано в руководстве WinCC Communication Manual. Там все очень доступно написано - прям по шагам и с картинками.

Параметрирование CP1430TF описано в руководстве по COM1430,
программирование контроллера S5 описано в соответствующем руководстве по этому контроллеру и в руководстве по пакету STEP5.
Re: SIMATIC S5 PMC Ethernet
Алексей; 25.6.02

Здраствуйте.В этом руководстве описано

соединение "SIMATIC S5 Ethernet Layer4"
а по "SIMATIC S5 PMC Ethernet" я нечего ненашел только вроде что используются функции Send/Reciv.
пробывал по разному так нечего неполучилось.


text

Как восстановить значение тега из архива WinCC ?
Дмитрий; 20.6.02

Как восстановить значение внутреннего тега из архива WinCC при перезапуске RT ?

Re: Как восстановить значение тега из архива WinCC ?
Игорь К; 20.6.02

Привет.

Из какого архива?

Re: Как восстановить значение тега из архива WinCC ?
Евгений Трунов; 20.6.02

Я делал вручную, при открытии главной формы, путем вызова функций TLGGetArchiveDataRaw. Может быть, действительно есть путь попроще?

Re: Как восстановить значение тега из архива WinCC ?
Дмитрий; 21.6.02

А как именно записть ф-ю ( TLGGetArchiveDataRaw )в скрипте, что подключить и т.п., чтобы WinCC её поняла и какие у неё аргументы ?

Re: Как восстановить значение тега из архива WinCC ?
Евгений Трунов; 21.6.02

В принципе, я лучше ODK не расскажу :). Если нет ODK, то смотри файл pdertcli.h, там объявления всех функций. Можно догадаться, что к чему. В общем, примерно так:

PTLG_ARCHIVDATARAW pDataRaw;
SYSTEMTIME stFrom, stTo;
DWORD dwFlags = 0;
DWORD dwNumberOfData = 10000;
CMN_ERROR Error;
//--------------------------------
if (TLGConnect(NULL, &Error)) // подключение к подсистеме TagLogging
{
TLGGetArchivDataEx(szArchiveName /* имя архива */, szTagName /* имя архивного тега */, &stFrom /* с... */, &stTo /* ...по */, &pDataRaw /* куда сохранять */, &dwNumberOfData /* считанное количество записей */, &dwFlags /* вспомогат. флаги */, &Error /* инф-ция о возможной ошибке */);

// Перенос считанного значения в тег szTagName (имя архивного тега совпадает с таким же тегом в пространстве имен DataManager)
SetTagDouble(szTagName, dwNumberOfData ? pDataRaw[dwNumberOfData-1].doValue : 0);

TLGFreeMemory(pDataRaw); // освобождение выделенной ф-ей TLGGetArchivDataEx памяти
}

TLGDisconnect(NULL); // отключение от подсистемы TagLogging
}

Указатель на выделенную ф-ей TLGGetArchivDataEx память, представляющую собой массив структур типа PTLG_ARCHIVDATARAW и количеством dwNumberOfData взвращается в аргументе pDataRaw. Его необходимо освободить. Вроде всё :).


text

Внешние тэги вWinCC.
Игорь К., AVTOVAZ; 20.6.02

Здравствуйте господа.

Когда читается тэг из контроллера размером в 1 бит - телеграмма занимает 1 байт.
В чем вопрос: имеется 8 однобитовых тэгов в пределах одного байта контроллера. Как система будет их читать: 1 раз весь байт и 8 раз по байту?
Вопрос возник потому, что фирма партнер предлагает использовать только однобитовые тэги (около 3 тыс. штук или больше).
Не повлечет ли это большую загрузку сети, чем в варианте с тэгами кратными байту?

Спасибо.
Re: Внешние тэги вWinCC.
Игорь.К, AVTOVAZ; 20.6.02

пардон -опечатка:

"В чем вопрос: имеется 8 однобитовых тэгов в пределах одного байта контроллера. Как система будет их читать: 1 раз весь байт ИЛИ 8 раз по байту?"


text

Basic Process control и Multi-Client
Антон Глухов; 18.6.02

Подскажите пожалуйста, как настраивать верхнее меню в Basic process control на multi-client'е, если в WinccExplorer отсутствует Picture Tree manager? Он есть только на серверном проекте. Или у нас что-то не так работает?

Re: Basic Process control и Multi-Client
Alexis; 20.6.02

А Вы пакаджи с сервера подгрузили? и необходимые сервера отконфигурили? Все это в закладке Server Data настраивается на мульти-клиентском проекте....

Re: Basic Process control и Multi-Client
Антон Глухов; 20.6.02

Пакаджи подгрузили и сервера сконфигурили :)

Все, как написано в документации :)
Более того, в документации есть рисунок и на нем тоже отсутствует Picture Tree manager.
Может это все как-то надо на сервере конфигурить?

Re: Basic Process control и Multi-Client
Alexis; 20.6.02

На скоко я помню, надо сгенерить на серверном проекте иерархию картинок, затем создать пакадж. На мульти-клиентском проекте через Base Data-Split Screen Wizard создать Multiclient Serverview, загрузить пакадж с сервеного проекта и указать в Standard Server компоненты pictures, ssm, screen hierarchy, signal collection. Вроде этого достаточно, по крайней мере у меня так работало. А авторизация WINCC Basic Process Ctrl у вас везде присутствует?


text

связь AB PLC5 и PC(ProTool)
Николай; 19.6.02

Ребята! Расскажите, что за драйвер DF1 нужен для связи контроллера Allen Bradley PLC5 и PC с установленным ProTool? Если есть возможность, пожалуйста, вышлите его.

Спасибо.

Re: связь AB PLC5 и PC(ProTool)
Юрченко Владимир; 19.6.02

В ProTool/Pro v.5.2 и 6.0 драйвера для DF1 уже включены в среду RunTime и не надо ничего добавлять. Что за версия ProTool у вас?


text

ProTool|/Pro CS V.5.2 SP3 Download back
Светлана; 14.6.02

Объясните, в ProTool|/Pro CS V.5.2 SP3 в меню функция Download back неужели наконец позволяет скачать программу с панели? Как панель перевести в режим передачи? Какая распайка кабеля? Жизненно важный вопрос, ответьте, пожалуйста.

Re: ProTool|/Pro CS V.5.2 SP3 Download back
Юрий Оганесян; 14.6.02

Енто только для некоторых панелей, работающих под WinCE.

Re: ProTool|/Pro CS V.5.2 SP3 Download back
Юрченко Владимир; 14.6.02

Обратно с панели можно скачать только откомпилированный образ конфигурации. Редактировать его невозможно. Относительно перевода пенели в режим ожидания и кабеля для загрузки - зависит от панели (какая у вас панель?).

Re: ProTool|/Pro CS V.5.2 SP3 Download back
Светлана; 14.6.02

OP7

Re: ProTool|/Pro CS V.5.2 SP3 Download back
Юрий Оганесян; 17.6.02

Низя


text

DDE-соединение по сети
Александр Сверчков; 21.3.02

Выполняю пример локального DDE-соединения с Excel - никаких проблем.

Пробую выполнить пример "DDE-соединение по сети" - не получается.

В ячейке Excel - #Н/Д (нет данных).

Формула: ='\\uvsnt\ndde$'|winccmy!TankerLevel.
DDE-ресурс winccmy создал.
NetDDE работает и на сервере, и на клиенте.
Пробовал создать исключительную ситуацию: в формуле вместо winccmy писал имя несуществующего ресурса - в журнале событий сервера регистрируется событие-ошибка "сетевое имя не существует".
Значит клиент пытается что-то взять!

Помогите!!!

Re: DDE-соединение по сети
Сверчков Александр; 22.3.02

У меня подозрение, что я неправильно конфигурирую DDE-ресурс в Ddeshare.exe.

Это нужно делать только на компе где WinCC? Или на компе с Excel тоже? И каким образом?

Если у кого-то работает сетевое DDE-соединение WinCC c Excel (отображение тэгов в Excel)- помогите!!!

Можно прислать примеры настроек на адрес said46@rambler.ru
Re: DDE-соединение по сети
Сверчков Александр; 22.3.02

Отвечу сам:

При настройке DDE-ресурса в поле "Название документа" пишется ключевое слово Project, а не имя проекта WinCC. А я, читая документацию, понял так, что Project - это не ключевое слово, а имя проекта.
Так что одно из двух - или я тормоз, или документацию понятней нужно писать.
Re: DDE-соединение по сети
Антон; 11.6.02

Ну как? Победил?

Я тоже с этим парюсь сейчас...


text

WinCC Redundancy. Проблемы.
Евгений Трунов; 10.6.02

Тестируется работа WinCC Redundancy на двух WinCC-станциях. На обеих время синхронизируется один раз в сутки. Сам процесс заполнения "дыр" в архивах проходит вроде бы успешно. Данные появляются, логи Redundancy свидетельствуют о том же. Однако компонент WinCC Online Trend Control перестаёт выполнять свои функции. На временном участке, заполненном данными с другой станции, происходит рисование "леса" из вертикальных линий наподобие тех, что отображаются при "разрыве" временной шкалы. И всё. Собственно кривые отсутствуют.

Кто сталкивался с подобным? Это проблемы онлайн-тренд-контрола или...? У кого вообще получилось успешное резервирование согласно документации Siemens?

WinCC v. 5.0, SP1.


text

Подключение к базе с клиента
Alexis; 25.4.02

Кто-нибудь знает как в клиент-серверном проекте, с клиента приконнектится к cs-ной базе используя db.dll?

Re: Подключение к базе с клиента
Александр Родин, ООО "Нева Электрик"; 30.5.02

Кстати о птичках..

Посмотрел я тут ODK более внимательно и детально, и нашел такую штуку, что на всех функциях, работающих с CS стоит пометочка: The function cannot be accessed from multi-client projects.

Наверное поэтому и не подключиться к серверу с клиента...
Re: Подключение к базе с клиента
Alexis; 30.5.02

Александр, функциям db.dll понятие multi-client, CS/RT по барабану, они и к проекту особого отношения не имеют. Им важно только наличие базы и все.

Фишка вся в том, что после открытия проекта (проект клиент/сервер) на сервере, я никак не могу подключится к конфигурационной базе с любой "левой" машинки, а по идее-то должен! Настройки DSN (где-то на форуме это описано) приводят к ошибке типа database already in use.
В чем трабл?

P.S. предистория - захотелось считывать (в любом месте в рамках проекта) комментарии к архивам TagLogging :)

Re: Подключение к базе с клиента
Иван Данилушкин; 7.6.02

Трабл в том, что тот механизм, который обеспечивает обращение файлу базы данных открывает его для изменения в безрадельное пользование (non shared) И выход, вобщем-то один - подключаться через DSN. По-крайней мере, сама WinCC (клиент), делает так.


text

WinCC и DLL
Павел Власкин; 23.5.02

не могу вызвать функцию из dll-ки. при компиляции все ок, при исполнении:

255,23.05.2002,15:05:21:634,1007001,4,,ASU_TP_2,SCRIPT,ExecuteError in Action @6

ошибка возникает именно на вызове функции. DLL написана в дэлфи, WinCC 5.0sp1, вызывающий скрипт:

{
#pragma code("RVSPasp.dll");
float LevToVol(int rvs, float level);
#pragma code();

float a=GetTagFloat("r1_lev");
float res = LevToVol(1,a);
return (res);
}
Re: WinCC и DLL
Костенич Дмитрий; 28.5.02

А ты не забыл случайно указать чтобы DLL собиралась для вызова функций в C-шной конвенции (в MSVC для этого служит extern "C"{})?

Если не забыл - отлаживай свою DLL...
Re: WinCC и DLL
Павел Власкин; 28.5.02

Не забыл. Там и через WinAPI можно, по идее :)

Function LevToVol(rvs:integer;level:single):single;cdecl;

Dll работает на ура, сделал в дельфе програмку, которая ее гоняет - все ок.

расшифровать бы ошибку...
Re: WinCC и DLL
Колпащиков Сергей; 7.6.02

Добрый день.

Если вы писали DLL на Delphi, то может быть в этом проблема.
Если использовать RECORD,
необходимо снять флаг Aligned record field.
Иначе возникает проблема при использовании функций DLL не из под Delphi и если вы вызываете, например, ODK функции из свой DLL.


text

S7-200 + 2TD + 2OP
NTMK LSPU; 30.5.02

Возможно ли подключить один S7-200 к двум TD200 и двум OP7 через RS485 ?

Re: S7-200 + 2TD + 2OP
Юрий Оганесян; 6.6.02

Если нужно, то можно

Re: S7-200 + 2TD + 2OP
NTMK LSPU; 6.6.02

Большая просьба уточнить - будет ли данная конфигурация работать через один порт PPI контроллера и какие можно ожидать проблемы.


text

?ProTool: можно ли на картинке динамически менять привязку тегов
Шимолин Сергей; 5.6.02

В проекте десяток одинаковых мнемосхем. Можно ли при открытии картинки динамически менять привязку тегов к объектам. (Что-то наподобие косвенной адресации в WinCC...)?

Спасибо

Re: ?ProTool: можно ли на картинке динамически менять привязку тегов
Юрий Оганесян; 6.6.02

Можно использовать мультипликсированные тэги, т.е. при переходе оператором к другой мнемосхеме на самом деле происходит не переключение экранов, а изменение мультиплексора для тэгов данного экрана и соответственно отображаются данные о другой установке. Понятно, что при таком подходе надо тщательно продумать расположение данных и разных установках в памяти PLC


text

ошибка PDLRT при работе с компонентом отображения трендов
Шимолин Сергей; 19.1.02

Динамически меняю список отображаемых трендов в компоненте (WinCC версия 5sp2) при этом при доступе к открытию линейки (Ruler) появляется ошибка которая весит весь RunTime-проект, причем происходит это через раз. В компоненте трендов в Design-time установил нужное количество возможных отображаемых трендов (NumItems), и при открытии картинки (OpenPicture) устанавливаю свойства всех трендов (Name, TagName, Label, ItemVisible=No ...). Затем по выбору из лист-бокса устанавливаю свойство ItemVisible = Yes для выбранных элементов. Также елси не открывать линейку все нормально отрабатвыается, деактивация проекта происходит без ошибок, а при закрытии WinCC выдает ошибку (kernel32) (Windows 2000 prof). Интересно будет узнать у кого какие были проблемы и решения с динамическим отображением графиков.

TlgOnlineTrend - тот еще компонент
Евгений Трунов; 29.1.02

Компонент TlgOnlineTrend достаточно своеобразный. Очевидные недостатки:

1. Отсутствие координатной сетки. Ту, которая есть, показывать никому нельзя :).

2. Рулер. Жалкое зрелище. Отображение текущих значений в жутких форматах в доп. окне MSFlexGrid, имеющем свойство выскакивать в самый неподходящий момент (из-за чего приходится постоянно вызывать TlgSetRulerWindowVisible([окно], FALSE)).

3. "Выезд" последнего текущего значения от правого края. Кстати, общая проблема для многих компонентов-трендов. Так, конечно, удобнее программировать, и на перья самописца похоже, но достаточно неудобно.

4. Два режима STOP/GO, во многом принципиально различных, причем в режиме GO недоступно зумирование и прочие радости.

5. Обязательное отображение даты около начала координат. Дата часто не нужна (а оси при этом должны быть видны).

6. Невозможность задания цвета осей отличным от цвета самого верхнего пера тренда.

7. Неудачное адаптивное разбиение осей метками шкалы.

8. При временных разрывах, даже малых, отметка места разрыва вертикальной линией и сдвиг правой части оси времени вниз.

9. Отсутствие точек входа (событий) для пользовательских функций ВООБЩЕ.

10. Практически полная невозможность настроить архивный тренд на что-либо, кроме архивов TagLogging.

11. Неудачная форма выбора временного интервала в американском формате, которую приходится заменять на собственную.

Из удачного:

1. Встроенный доступ к собственным архивам :).

2. Почти все свойства доступны для изменения через Set/Get-функции.

Действительно имеет проблемы при runtime-изменении некоторых свойств. В частности, у меня выдавал ошибку PDLRT.EXE (тоже через раз, а то и десять) при динамическом изменении имени присоединенного к тренду тега. Очень часто при открытии формы архивного тренда (особенно, если их на этой форме несколько) один или два не заполняются архивными данными, из-за чего требуется повторная насильственная перечитка.

Как мне представляется, он изначально был задуман для отображения чего-то типа пилообразных/прямоугольных импульсов, а затем эволюционировал в то, что есть, унаследовав все недостатки первоначального замысла разработчиков.

Вопрос к знатокам:

Открывается форма. При ее загрузке все расположенные на ней компоненты инициализируются своими сконфигурированными значениями. Т.е. если для архивного трендв установлено свойство "Load Data Immediately", то он обращается к TagLogging и т.д.
На открытие формы срабатывает ф-я OnOpenPicture, в которой свойства архивного тренда меняются через Set-функции.
Какова последовательность выполнения этих действий и как они синхронизируются? Т.е. сначала выполняется инициализация всех компонентов формы, затем, ПОСЛЕ ОКОНЧАНИЯ, вызывается OnOpenPicture, затем форма отображается? Или OnOpenPicture не ждет завершения инициализации? Где можно прочесть об этом подробнее?
Re: ошибка PDLRT при работе с компонентом отображения трендов
А. Туманов; 5.2.02

1)Если активизировать кнопку "Can be closed" для возможности закрыть окно OnLine Trend Control на Web-страничке, то при нажатии на эту кнопку закрывается с ошибкой весь Internet Explorer.

2)Office 2000 нужно ставить до установки WinCC, иначе при вызове редактора!!! TagLogging из режима Run-Time Windows предлагает... вставить установочный диск Office 2000!!!
Re: ошибка PDLRT при работе с компонентом отображения трендов
Bright; 23.4.02

В какой версии WinCC вы нашли весь этот список глюков с TlgOnlineTrendControl?? В частности про рулер, окно которого "имеет свойство выскакивать в самый неподходящий момент", про цвет осей и ""Выезд" последнего текущего значения от правого края"?

Re: ошибка PDLRT при работе с компонентом отображения трендов
Bright; 23.4.02

В какой версии WinCC вы нашли весь этот список глюков с TlgOnlineTrendControl?? В частности про рулер, окно которого "имеет свойство выскакивать в самый неподходящий момент", про цвет осей и ""Выезд" последнего текущего значения от правого края"?

Re: ошибка PDLRT при работе с компонентом отображения трендов
Евгений Трунов; 23.4.02

WinCC v 5.0, SP1. Это не глюки, просто так сделано :).

Re: ошибка PDLRT при работе с компонентом отображения трендов
Bright; 25.4.02

В WinCC v5.0 sp2 некоторого из перечисленного вроде уже нет :)

Новый TlgOnlineTrendControl в SP2
Евгений Трунов; 29.4.02

О, он стал лучше :). Чего именно нет?

Re: ошибка PDLRT при работе с компонентом отображения трендов
Вера Прокопенко; 5.6.02

В runtime режиме с помощью приложения, использующего ODK функции, формирую список трендов на отображение для компонента WinCC Online Table Control и меняю необходимые свойства данного объекта. После нескольких вызовов приложение выдает ошибку:

ERR: E1=0x2; E2=0x0; E3=0x0; PDLRTAPI.DLL : Exception was catched
Картинка= :MAIN.PICTUREWINDOW_SCHEMA:TRD_DSC_TABLE
Объект= Control1
Свойство= Variable

Система выдает сообщение об ошибке:
C:\Siemens\WinCC\bin\ccTlgOnlineTableCtrl.dll: pdlrt.exe – Application error...
The instruction at “0x77f6754ab” referenced memory at “0x30303044”. The memory could not be “read”.

Графика рушится. Ошибка всегда происходит при записи свойства Variable. Не думаю, что это из-за неправильного использования ODK функций. Подобная программа для объекта WinCC Online Trend Control работает давно и корректно. Может быть кто-нибудь сталкивался с такой проблемой. Очень нужно выводить архивы в таблицы и пока не получается…
(Используется WinCC версия 5.0 SP2 Hotfix 7).


text

еще раз DDE
Евгений; 4.6.02

я почитал на форуме что у многих не получилось связать WinCC и Excel посредством DDE(через сеть), но так и не смог найти решения этой проблемы.

вроде все делал как написанно в документации(примера, якобы правильного, в SP2 не нашел), но Excel так и не хочет отоброзить значение тэга.

Помогите пожалуйста.
спасибо.


text

GRAPHEXE.exe вылетает при удалении Action'а
Александр Цихоцкий; 29.5.02

Не знаю, что это может быть, но когда хочу удалить из вкладки Events (из Properties всё нормально) Action (из контекстного меню выбрать позицию Delete), Graph Designer после вопроса "Уверены ли вы, что хотите удалить" и получении положительного ответа сообщает мне, что

"Инструкция по адресу '...' обратилась к памяти по адресу '...'.
Память не может быть 'writen'

А затем подобное сообщение, только о том, что память не может быть 'read'.
Причем, замечу ещё раз, что это только во вкладке Events окна Object Properties.

Знает ли кто-либо, что это за глюки такие и как с ними справиться. Только, пожалуйста, без фраз "Переустанови всё к ...".

Заранее спасибо
Re: GRAPHEXE.exe вылетает при удалении Action'а
Чистяков Дмитрий ОАО "СеверСталь"; 4.6.02

У Вас случайно не Win2k установлен?

А WinCC v5.0 или v5.0 SP1?
Re: GRAPHEXE.exe вылетает при удалении Action'а
Александр Цихоцкий; 4.6.02

Windows NT 4.0 Workstation

WinCC v5.0 SP1


text

Разъем OP5
Щербаков А.И.; 31.5.02

Есть ОР5 панель. Кто-либо мог бы подсказать раскладку 15-пинового разъема по ножкам ?

Re: Разъем OP5
Юрченко Владимир; 31.5.02

15-pin mail OP5

RxD- 2
TxD+ 6
TxD- 7
RxD+ 9
20mA 11
GND 12
20mA 13
GND 15


text

Хелп! нужна распайка кабеля OP17 <-> PC
Олег; 29.5.02

Нужна распайка кабеля OP17 <-> PC, чтобы можно залить в неё софт. Хелп

Re: Хелп! нужна распайка кабеля OP17> PC
В. Сорокин.; 29.5.02

С удовольствием.

PC сом1 или 2(классика 9pin)-if2 OP.
if2 OP.
3-RxD
4-TxD
5-CTS
10-RTS
14-+5V
15-GND
PC OP
RxD-TxD
TxD-RxD
Всё написано в описании ОР.


text

Coros 2000
Святкин Владимир; 17.5.02

Не подскажете возможно ли найти какую-либо информацию по Coros 2000.

Re: Coros 2000
fog; 18.5.02

т. (812)1130466

Re: Coros 2000
Святкин Владимир; 20.5.02

Уважаемые,

"спасибо" за телефончик, отзвонился - это СПб Siemens: о Coros 2000 у них только смутные воспоминания. Может кто имел с этой штукой дело.
Re: Coros 2000
Макс; 23.5.02

какая именно информация нужна

пиши на мыло maksim@tbf.ru
Re: Coros 2000
Павел Иванов (Сименс-Москва); 28.5.02

Эта система визуализация была снята с продажи в 1990 году. После нее были COROS LS-C/LS-B, а теперь WinCC.

У нас в московском офисе сохранился каталог за 1989 год по средствам визуализации COROS и руководство по COROS 2000 в трех томах на немецком языке в бумажном виде.
Сименс-Германия отдел поддержки заказчиков до сих пор оказывает поддержку по этой системе.


text

Падение задачи PDLRT.exe в WinCC v5.0 sp2
Петров Андрей; 27.5.02

Уважаемые участники форума!

В проекте регулярно (раз в месяц) слетает задача PDLRT.exe. Анализ диагностики WinCC паказал полное отсутствие ошибок в собственных скриптах и наличие сбоев (access violation) в стандартной msvcrt.dll. На машине установлены NT 4.0 sp5, WinCC v5.0 sp2. Возникает желание перетрясти все системные DLL sp5, но поможет ли...
У кого-нибудь случалось подобное?
Заранее благодарен!


text

SCADA для simatic S5135U
Руслан; 16.5.02

Кто может посоветовать , что необходимо использовать для визуализации с simaticS5135U , и где можно взять бесплатную версию , помогите пожайлуста .....

Re: SCADA для simatic S5135U
siemargl; 20.5.02

Чистая WinCC. Взять в локальном представительстве Sie

Re: SCADA для simatic S5135U
Руслан; 24.5.02

Посредством 525 связь с PC делается ???? И нужны ли какие -нибудь дополнительные установки кроме WINCC???


text

диагностика МР270
Алексей,; 20.5.02

Здравствуйте,

я имею 11 мультипанелей МР270 (Scada -Protool) с одинаковыми проектами, отличающиеся друг от друга только сетевыми адресами, и PLC S7-400.
Нужно продиагностировать отключение любой панели. Как это сделать при конфигурации с одной панелью - понятно (используя Area pointers).
1)А что делать при конфигурации с 11 панелями?
2)Имеется ли в S7 функция, определяющая статус абонента сети типа ОС c WinCC, Protool, OP, TD и т.д.
Re: диагностика МР270
Baby; 22.5.02

Привет, Алексей !

На чём сидят МР270 ?

Re: диагностика МР270
Alexey; 22.5.02

МР 270 сидят на Profibus

Re: диагностика МР270
aim; 22.5.02

см. FC3 DP_DIAG из библиотеки - Laibraries/ Standsrt Libraries/ Cimmunication Blocks/FC3

Re: диагностика МР270
Алексей; 23.5.02

На сколько я понимаю FC3 предназначена для диагностики PLC, ЕТ, исполнительных устройств и датчиков, сидящих на Profibus. OP, MP и ТD не имеют стартового диагностического адреса (первый формальный параметр FC3). Или я не прав?


text

Панель MP370
Кулаков Геннадий; 22.5.02

Проблема: проект успешно компилируется в ProTool, пересылается в панель.

В ProTool появляется сообщение, что передача произошла. Панель также получила все, появилась надпись о сохранении проекта во Флеш-памяти. И все. Проект не стартует. Только (на панели) появляется окошко как при завершении работы симулятора ProTool - подождите завершения работы ProTool Rt.


text

Как узнать имя сервера
Александр; 22.5.02

Как с клиента-WinCC программно получить имя сервера-WinCC

Re: Как узнать имя сервера
Alexis; 22.5.02

BOOL DMGetMachineTable(LPCSTR lpszProjectFile,LPDM_MACHINE_TABLE lpdmMachineTable,LPCMN_ERROR lpdmError);

и смотришь у кого lpdmMachineTable->tm[i].fServer ревен TRUE.


text

Русский язык в Tag Logging
Shurik; 18.5.02

TAG Logging почему-то не поддерживает ввод параметров русскими буквами - да и вообще база данных WINCC кажется не поддерживает кодовую страницу 1251. Никто не разбирался с этой проблемой - подскажите пожалуйста

Re: Русский язык в Tag Logging
Костенич Дмитрий; 22.5.02

Привет всем!

С этой проблемой мы сталкивались и запрашивали московскую службу поддержки. Вот их ответ:

"TagLogging (само приложение) конвертирует все специальные символы (в том числе и из русской раскладки, кроме цЦдДьЬЯ, которые преобразует в немецкие Umlaut'ы) автоматически. Можно создать таблицу архивов на русском непосредственно в базе данных WinCC. И это будет работать. Но в TagLogging название архива отображаться будет все-равно неправильно."

Кроме того, нам было рекомендовано не использовать русские названия не только у архивных тегов, но и у обыкновенных, процессных.

С уважением ко всем.


text

Неясность...
Александр Родин, ООО "Нева Электрик"; 21.5.02

Пишу скрипт... В нем использую ряд ODK-шных функций... Запускаю, смотрю диагностику.. ОШИБКА ! Не может найти такую функцию... Перегружаюсь, запускаю снова... Смотрю диагностику... ОПЯТЬ ОШИБКА ! Не может найти такую функцию... (А при компилировании дал 0 ошибок) Смотрю в заголовочный файл - Функция прописана... Смотрю в DLL - функция прописана... Еще раз запускаю - снова та же ошибка... Бред...

Все вышеописанное происходило при попытке использовать функцию TLGReadVariable, а так же ряд других функций из библиотеки pdecscli.h (pdecscli.dll) Ругается на всех...

Да и фиг бы сними, с функциями этими - но может кто знает как другим способом информацию об архивном таге вытащить ?(Коментарий, ссылку на процессный таг, границы ?)

Используем WinCC 5.0 SP2
Re: Неясность...
Александр; 21.5.02

В начале скрипта нужно написать

#pragma code ("pdecscli.dll")
BOOL TLGReadVariable (HANDLE hProject,
LPTSTR lpszArchivName, LPTSTR lpszVariableName, PTLG_VAR_STR lpVariable, LPCMN_ERROR lpoes );
#pragma code ()

Re: Неясность...
Александр Родин, ООО "Нева Электрик"; 22.5.02

Падла...

через #pragma зафурычила... %)

Спасибо...


text

Запись параметров
Александр Родин; 29.11.01

Возникла следующая проблема.

Когда мы сохраняем большой объем данных, это, естественно, занимает большой промежуток времени. Все бы ничего, но при этом теряется возможность управления процессом. Т.е., пока выполняется процедура сохранения, управляющие воздействия к контроллеру не передаются. Правда, после завершения записи, все кнопки, которые до этого нажимались, передаются.

Однако, потеря возможности управления в процессе записи является большой проблемой.

Если кто-то сталкивался с таким поведением, и может что-то посоветовать, очень бы хотелось пообщаться.

Заранее спасибо.
Re: Запись параметров
Юрий Оганесян; 30.11.01

Есть стандартный прием: записывать гораздо ЧАЩЕ (соответственно меньшими кусками), ну а далле:

опитмизация базы данных, использование для неё другого компьютера и т.д.
Re: Запись параметров
Александр Родин, ООО "Нева Электрик"; 30.11.01

Пробовал меньшими кусками.

Для полноты картины привожу конкретный пример:

В архиве сохраняется порядка 50 переменных. Цикл опроса 1 секунда, архив расчитан на сутки.
Таких архивов 2. Одновременно экспорт ведется только из одного из них. Причем, экспортируются сразу все переменные этого архива (так надо по заданию). Экспорт не циклический, а по команде оператора с выбранным фрагментом.

Так вот, если мы выбираем фрагмент 5 минут, экспорт длится порядка 2-х минут, а при выборе фрагмента 2 часа, экспорт длится порядка 4 минут. Причем, перед тем как выполнять экспорт я предварительно останавливаю архивирование (с помощью TLGLockArchiv). Ладно, пусть он и длится сколько угодно. Но в это время невозможно управлять, а это не очень хорошо.

Насчет другой машины я тоже думал. Но заказчик на это не пойдет.
Вот такая вот незадача.

Заранее спасибо.
Re: Запись параметров
Юрий Оганесян; 3.12.01

Судя по приведенным Вами цифрам основное время при экспорте уходит не на саму передачу и конвертирование данных, а на поиск необходимых данных в архиве. В этом случае надо ускорить именно поиск.В случае последовательного архива технологических данных самое лучшее - это КЛАСТЕРНЫЙ индекс по полю времени (дате).

Правда, это мои общие соображения, я это применял при работе с архивом на MS SQL, а Вы,
как я понял, работате на WinCC. Можно ли там через централь Sybase'a или как-то еще
внедриться таким образом в связь WinCC-Sybase я не знаю.
В целом, насколько я в курсе, под Windows нет средств увеличения системного приоритета
законченным приложениям (exe-шникам), так что, по-моему, без дополнительного компьютера
можно только качественно влиять на описанную ситуацию, но ничего кардинального
на уровне алгоритмов сделать не удастся, разве что кардинально пересмотреть весь механизм архивирования.
Посмотрите что можно сделать с железом - например, хранить архив на отдельном винте
с RAID 0/1, кстати, если хорошо объяснить, что это такое, то заказчик на это может
даже и согласиться, правда есть очень большой риск самому пролететь - если от этого
произоводительность не увеличится :)

Re: Запись параметров
Александр Родин, ООО "Нева Электрик"; 3.12.01

Из WinCC, насколько я знаю есть возможность вызова внешних приложений.

В принципе, если обеспечить вызов внешней утилиты SQL-евской базы с ключами для экспорта во внешний файл, то это, по-моему, должно решить проблему. Правда, возникает ряд вопросов: ждет ли WinCC флага выполнения внешнего приложения, будет ли работать указанная утилита (если она такая есть) при запущенном RunTime'е, насколько такой метод загрузит систему ? Да и вообще, возможно ли найти описание подобного метода ? Может кто-то так уже делал.

Заранее спасибо.
Re: Запись параметров
Александр Родин, ООО "Нева Электрик"; 27.12.01

Используемая для экспорта данных функция TLGBackUp очень медленно выполняет экспорт. Причем на скорость мало влияет и размер фрагмента, и использование другого железа. Но самое большое неудобство приносит тот факт, что на момент выполнения этой функции RunTime перестает воспринимать команды от оператора (нажатие кнопок и т.д.). Если бы возможно было убрать процесс экспорта в фоновый режим, было бы просто замечательно (обратите хотя бы внимание на опыт других SCADA, к примеру Intellution FIX). Правда, есть вариант выполнения экспорта внешним приложением (утилита isql.exe), но при этом не сохраняется информация об уже выполненном экспорте, и, соответсвенно, нет возможности вести историю сохранений. Конечно, все это можно сделать самому, но тратить на это время, когда на выполнение достаточно объемного проекта дается от силы месяц, не очень хочется. Как я успел заметить, что в 4-х, что в 5-х версиях WinCC проблема эта одна и та же. Могу только одно сказать: обидно, что из-за какой-то ерунды приходится искать возможности перехода на другие SCADA. На самом деле, если бы не этот "глобальный" недостаток, WinCC мне нравится больше.

Может, все-таки, подскажете как можно выполнять экспорт данных при помощи других системных функций и при этом вести историю сохранений ?

Заранее спасибо.
Re: Запись параметров
Никаноров, Сименс; 27.12.01

Эх.

Дело не в фоновом режиме и не в функции TLGBackUp, а в том, что загрузка процессора при таких операциях возрастает до 100%.
Вы можете делать экспорт, используя утилиты Sybase (isql.exe, dbisql.exe). При этом Вы можете точно также как и при использовании TLGBackUp, вести "историю сохранений". Вызываете из скрипта isql.exe с нужными параметрами, формируете нужное имя файла или каталога и т.п. Всего несколько строк кода. Примеры можно посмотреть в ConfigurationManual, в ComprehensiveSupport (на наших дисках WinCC) и в CustomerSupport.
Re: На заметку разработчикам СИМЕНС
Александр Родин, ООО "Нева Электрик"; 27.12.01

Как вызвать isql с ключами для экспорта я нашел. Как сделать то же самое для восстановления тоже нашел. Но вот как вести историю сохранений ?.. В указанных ресурсах этой информации, к сожалению, нет.

Заранее спасибо.
Re: Запись параметров
Никаноров, Сименс; 27.12.01

А что Вы понимаете под историей сохранений?

И как Вы это делаете в настоящее время?
Вот так ответ!
Юрий Оганесян; 27.12.01

Вот так ответ: все развернуто наоборот: оказывается, виновата не функция, загружающая процессор, а сам процессор, который, почему-то загружается от этой самой функции.

А вообще-то загрузка процессора на 100% - это совершенно нормальная ситуация, которая возникает практически постоянно при любой, самой "офисной" работе на компьютере.
Re: Вот так ответ!
Александр Родин, ООО "Нева Электрик"; 27.12.01

Если бы это можно было считать нормальной ситуацией, я бы не сидел сейчас здесь с обсуждением этой "ерундовой" проблемки.

Конечного заказчика не устраивает такое поведение системы, на разработку которой он тратит свои деньги. И чем не мотивируй, лучше от этого не станет.

Такие дела.
Re: На заметку разработчикам СИМЕНС
Александр Родин, ООО "Нева Электрик"; 27.12.01

История сохранения ведется автоматически при использовании функции TLGBackup. И заносится в таблицу PDE#Backup (кажется так). Потом всю информацию о выполненных сохранениях (экспортах) можно вытащить посредством функции TLGBackupEnum.

Собственно, так оно все и делалось. Но это приводило (да и приводит) к очень большим задержкам даже при попытке восстановить 5-и минутный архив из 50 переменных.

Кстати говоря, при достаточно заполненной RunTime базе, даже при использовании isql получается чувствительная задержка при выдаче команд управления. (В архив записываются последние 24 часа, с дискретностью в 1 секунду, количество переменных - 42; Максимальный фрагмент для экспорта - 8 часов)

И на самом деле, загрузка процессора при выполнении этого приложения держится на уровне 100%.
Re: На заметку разработчикам СИМЕНС
Никаноров, Сименс; 27.12.01

1. Загрузка процессора.

Имелась ввиду загрузка процессора на 100% на длительное время. Пиковые загрузки до 100% - это действительно нормальная ситуация. Но длительная загрузка до 100% естественно приводит к затруднению управления. И дело здесь не в какой-то функции ODK, а в том что операции типа экспорт-импорт по сути сводятся к поиску в базе и записи на диск, что и вызывает продолжительную загрузку ЦПУ и дисковой подсистемы.
Остается только оптимизировать этот процесс. В связи с этим см. нижеследующий текст.

2. ISQL делает экспорт\импорт несколько быстрее, чем ODK-функции. Поэтому имеет смысл использовать эту возможность. А "чувствительная задержка" связана с тем, что в Вашем случае Вы экспортируете 8х3600х42=1209600 записей. Запись занимает в среднем 40 байт. Итого 48384000 байт. Т.е. нужно извлечь из базы и записать на диск порядка 40Мб. Даже если Вы будете просто копировать 40Мб файл, Вы почувствуете "задержку управления".

3. История сохранений, если я правильно понял, используется для последующего восстановления (импорта) данных. Кроме того, импорт приводит к значительно большим задержкам, чем экспорт. В связи с этим не очень понятно, зачем вообще нужен импорт, если у Вас кольцевой архив на 24 часа? Т.е. Вы делаете не экспорт данных, а свопинг с последующим восстановлением?

Все вышесказанное я хочу подвести к следующему.
- использовать ISQL.exe
- обойтись без импорта, если это возможно
- если все-таки нужен импорт, делать его при помощи опять-же ISQL, а историю сохранений делать самостоятельно (по сути для импорта необходимо только имя архива и имя файла)
- также остается возможность модернизации хардвера: два жестких диска, процессор и т.п.
- использовать опцию Storage, которая все нужные Вам функции делает автоматически
Re: На заметку разработчикам СИМЕНС
Александр Родин, ООО "Нева Электрик"; 27.12.01

Если позволите, несколько замечаний:

1. я читал мануал по TagLogging, и там указан размер для одной записи порядка 28 байт. Хотя, да... с учетом формата экспорта в ASCII размер записи приближается к 40 байтам. Но при этом, как не странно, экспорт в ASCII занимает намного меньше времени и размер файла для одной переменной(8 часов) не превышает 1 Мб. Пакуются такие данные в 10-15 раз (например для переноса на дискету).
2. Импорт нужен даже не мне, а заказчику. Мотивация: Не до конца проработанная система, по которой нужно хранить всю историю работы, с целью потом поднять заархивированные данные, где-нибудь месячной давности. С учетом того, что объект находится, например, в Сибири, а производитель здесь, в Питере, то, естественно, проще получить из Сибири дискету с трендовыми данными, чем копировать весь проект. В связи с этим, возможность импорта необходимо предусмотреть.

И вопрос: а можно где-нибудь посмотреть подробную информацию о функциях Storage?

Заранее спасибо.
Re: На заметку разработчикам СИМЕНС
Никаноров, Сименс; 27.12.01

С первым пунктом полностью согласен. ПРавда не указано, по сравнению с чем "экспорт в ASCII занимает намного меньше времени". Да и размер записи варьируется от 30 до 50 байт.

С импортом опять не все понятно. Если данные нужны для разбора полетов, то процесс импорта не является критичным по времени. Да и при экспорте не нужно удалять данные в базе. Импортируйте, как Вам удобнее: через TlgBackup или через ISQL. Хотя анализ данных не обязательно делать в WinCC.
Описание на Storage Вы можете найти в рук-ве на BasicProcessControl (содержится на любом из дисков WinCC). А лучше всего взять и попробовать, благо без авторизации все работает в демо-режиме.
Re: На заметку разработчикам СИМЕНС
Александр Родин, ООО "Нева Электрик"; 27.12.01

Речь велась об экспорте в ASCII относительно DBASEIII.

С импортом я сам до конца заказчика не пойму... ну да ладно. Требования есть требования - их выполнять надо.
Storage не очень подходит, потому, что, как я понял, он экспортирует и импортирует данные с внешних носителей. А по заданию мне надо вести сохранение на том же носителе, и иметь возможность переноса сохраненных данных.

Вопрос до кучи: Я веду архивирование по принципу Ciclic Selective. При этом включено архивирование по изменению (Upon Change)с определенным гистерезисом. Допустим, переменная долгое время не менялась. Время последнего значения давным давно уехало за пределы фрагмента сохранения. После выполнения экспорта файл для данной переменной будет пустым. Как можно этого избежать ?
Re: Запись параметров
siemargl; 3.1.02

---- 1.bat----

isql -q -c "databasefile=E:\Siemens\Common\sqlany\sademo.db;userid=dba;password=sql" 1.sql

----1.sql----
select * from customer;
/*insert into customer (id) values (51);*/
delete from customer where id < 99;

---
etc
Re: Запись параметров
Alexis; 5.1.02

Привет Александр! :)

С Новым годом Вас и с наступающим Рождеством!

Извини, но дискутировать как раньше не могу, так как наша бедная контора не может обеспечить нас инетом :(( вот... (может к себе на работу возмете :) а то уж очень сильно я Невское Класическое люблю, а у Вас наверное оно свежее, да на разлив)

Я построил свой дампер архивов следующим образом:
- это внешнее приложение (MS Visual C++ 6);
- имена архивов получаю через EnumArchive и EnumVariable;
- высасываю данные функцией GetArchiveDataEx - при этом теряю аудит сбросов (но это мне и так до лампочки) - но выигрываю в том, что записываю полученные данные куда хочу и как хочу! (функция возвращает массив данных из выбранной таблицы);
- если данных за выбранный промежуток времени нет, то пытаюсь найти последнее существующее значение связкой функций GetClosestTime и GetArchiveDataEx.

Вот в принципе и весь алгоритм...
Да, название функций привожу так как они обозваны в моей библиотеке, поэтому прибавляй к названию TLG и возможно где-то надо вместо Archive читать Archiv :))

О производительности - сброс за час сотни посекундных архивов менее двух минут... т.к. приложение внешнее то и в WinCC никаких зависов... а у Вас наверное через скрипты? бррр...

С удовольствием выслал бы Вам эту программульку, но я не на работе... :(

За сим прощаюсь...

Best regards, Alexis.

P.S. Когда-нибудь наверное прочитаю Ваши благодарности :))) если конечно мой подход чем-нибудь вам поможет...
Re: Запись параметров
Александр Родин, ООО "Нева Электрик"; 8.1.02

Hi, Alexis !

Вас так же с наступившими ! :)

На работу бы с удовольствием взял... Токма не я этим распоряжаюсь...:) А так, ради бога - резюме рассмотрим. И специалисты подобные нам нужны, и пиво "Невское" в обеденный перерыв устроить можно. :)

Что касается процедур импорта-экспорта, да, интересное предложение... И в достаточной степени простое решение... но для опытного программиста. :) Я же в общем несколько иной аспект хотел затронуть. А именно, почему я должен исхитряться и писать весь этот механизм сам под WinCC, если скажем на других скадах он уже целиком есть в виде полноценного приложения ? Опять же, на другие скады мне переходить не выгодно, т.к. у них нет нормального драйвера для сименсовских контроллеров. Вот и получается круг замкнутый... :( Обидно блин.

В любом случае, спасибо за совет. Когда в достаточной степени изучу VisC, может и воспользуюсь им... :)

Удач в новом году..
Re: Запись параметров
Dr. Kren; 10.1.02

Всем привет!

Пожелания успехов в неравной борьбе с разработчиками "SIEMENS"!

Пункт № 1.
Вся проблема с потерей управления - в кривизне ПО от SIEMENS и прохладном подходе к разработке алгоритмов.
Дело, по всей видимости, в том, что процесс архивирования выполняется самим ПО от SIEMENS без передачи управления процессом архивирования внешнему приложению, запускаемому как отдельный поток, либо внешнее приложение работает в контексте потока приложения-родителя. В результате все поступающие от системы сообщения (нажатия кнопок и т.п.) ставятся в очередь на обслуживание процессом. А процесс пока обслуживает алгоритм архивирования данных. Т.е. он полностью забирает на себя ВСЕ ресурсы процессора, выделенные системой данному процессу.
В нормальных системах это решается левой ногой. Т.к. процесс архивирования явно циклический
"SELECT что-то FROM откуда-то WHERE пока",
в нормальных системах подразумевается как минимум два варианта отработки алгоритма.
Вариант 1-й. Приоритет процесса максимальный. До момента завершения операции все остальное не важно. Это иногда полезно.
Вариант 2-й. Приоритет процесса нормальный. Архивирование выполняется в фоновом режиме. Это полезно всегда.
Вариант 3-й (десертный. А кто не любит десерт?). Приоритет процесса минимальный. Архивирование выполняется в моменты бездействия системы. Это полезно как и вариант № 1.
Организовать назначение приоритета - задача тривиальная (знающие да соображающие поймут сами, для остальных - переменная в контексте окружения WinCC).
В случае максимального приоритета - поведение WinCC закономерно.
В случае нормального (фонового) подход примерно следующий. Во всех уважающих себя языках программирования под Win* (а, простите, какой язык считает себя не уважаемым?) доступны функции WinAPI "PeekMessage", "TranslateMessage", "DispatchMessage". С их помощью организовывается процесс передачи управления остальным задачам системы при каждом проходе цикла архивирования. В результате и данные архивируются, и SCADA живет и здравствует.
В случае минимального приоритета процесса (вспомним о языках программирования) обрабатывается состояние "Idle" системы (простой). В этом случае процесс архивирования ВООБЩЕ не заметен для пользователя и не мешает другим задачам.
Ну и, естественно, все вышеперечисленное (кроме варианта № 1) возможно только в случае порождения нового процесса при запуске алгоритма архивирования.
Так что, друзья, остается только посочувствовать Вам (не в обиду) и себе за такие трудности, ну и разработчикам SIEMENS.DE (за их IQ).

Пункт № 2.
Не надейтесь на SIEMENS & WinCC как на Господа Бога. Плюхи и баги у них были, есть и будут.
Alexis поступает единственно верным в данном случае способом – сам порождает новый процесс, не зависящий от WinCC. Что делает и ваш покорный слуга (разница лишь в средствах MS Visual С ++ против связки Delphi+InterBase).
Я вообще отказался от хранения таких объемов данных во встроенном архиве. Там я храню только теги для отображения в трендах. Все остальные теги я записываю во внешнее хранилище. И своими собственными программами выдаю какие угодно отчеты и в каком угодно виде. Набор инструментов - широчайший.

С уважением ко всем...
В том числе и "товарищам" из SIEMENS.DE

Re: Запись параметров
Alexis; 10.1.02

Привет Всем!

Александр, исхитряться и писать механизм импорта-экспорта вроде как и незачем, так как Siemens предусмотрел опцию Storage. Вещь вроде как работоспособная, но приспособленная только под конкретную цель (типа сброса непрерывных архивов). Что мне в ней особенно не нравится, так это то, что оно еще и дополнительных денег стоит.

Dr. Kren, к Вам маленький вопрос, что подразумевается под фразой “хранение ТАКИХ ОБЪЕМОВ данных”? Имеется в виду что Вы используете TagLogging для хранения только ProcessValueArchive, а функции CompressedArchive берете на свои приложения?

Best regards, Alexis.
Re: Запись параметров
Dr. Kren; 10.1.02

Всем привет!

Пожелания успехов в неравной борьбе с разработчиками "SIEMENS"!

To Alexis
Несколько не так.
Все нужные теги для отображения как в трендах, так и в таблицах я храню во встроенном архиве. Только архивы я делаю циклическими с количеством записей 1 - 2 тысячи. И не более.
Параллельно этому архиву я веду свой собственный, в который произвожу запись тех тегов, которые нужно хранить все время жизни проекта. Например информация о расходе цемента, песка, гравия на бетонном заводе. Вот эту информацию я и храню во внешнем архиве.
На счет "ТАКИХ ОБЪЕМОВ" данных. Давайте посчитаем.
Для хранения одного значения во встроенном архиве требуется 28 байт. Хорошо. Что же там хранится?
1. Дата и время записи значения - 4 байта.
2. Само значение - 4 байта.
3. Что-то непонятное (либо 0, либо 64) - 4 байта.
4. Индекс для ускорения обработки запросов на выборку данных - 4 + 4 (в случае индексирования по дате и по значению двумя разными индексами).
Итого 20 байт. Где еще 8?
И так на КАЖДОЕ ЗНАЧЕНИЕ ТЕГА, записанное в архив.

Я же группирую теги по событию записи в одну таблицу. Индексы по значению мне и даром не нужны - важно корректно показать значения на заданное время. В результате в 28 байт вмещаются
1. Дата и время записи значения - 4 байта.
2. Значение № 1 - 4 байта. (Double, DWord, SDWord)
3. Значение № 2 - 4 байта. (Double, DWord, SDWord)
4. Значение № 3 - 4 байта. (Double, DWord, SDWord)
5. Значение № 4 - 4 байта. (Double, DWord, SDWord)
6. Значение № 5 - 4 байта. (Double, DWord, SDWord)
7. Индекс для ускорения обработки запросов на выборку данных - 4 (индексирование по дате).
Во встроенном архиве эта же информация займет 28 байт * на 5 значений = 140 байт.
И чем больше тегов надо хранить, тем больше выигрыш.
При записи 5 тегов один раз в минуту имеем 28 * 60 * 24 * 366 получаем около 16 Mb за год. Пусть 20.
Во встроенном архиве то-же самое займет в пять раз больше, т.е. около 100 Mb.
При 50 тегах встроенный архив съест около 1 Gb за год. В моем случае это 100 Mb.
Вот это я и имел ввиду, когда говорил "вообще отказался от хранения таких объемов данных во встроенном архиве" .

С уважением ко всем...

Re: Запись параметров
Dr. Kren; 14.1.02

Всем привет!

Пожелания успехов в неравной борьбе с разработчиками "SIEMENS"!

Сильно извиняюсь!
К предыдущему message
Структура записи Sybase ASA
1. Дата и время записи значения - TIMESTAMP 16 байт.
2. Само значение - DOUBLE 8 байта.
3. Что-то непонятное (либо 0, либо 64) - INTEGER 4 байта.
4. Индекс для ускорения обработки запросов на выборку данных - минимум 4 байта. Индекса по по значению нет.
Итого 28 байт данных + 4 байта индекса.

С уважением ко всем...

Re: Запись параметров
Александр Родин, ООО "Нева Электрик"; 24.1.02

Всем доброго времени суток.

Ответте пожалуйста на такой вопрос:
Для того чтобы производить сохранение данных требуется иметь информацию об архиве, в котором хранятся значения переменных. Если переменных немного, то задача решается просто - архив всего один. Другое дело, когда их много (больше 50 для версии 4 или больше 300 для версии 5). Тогда более выгодно иметь несколько архивов. Так же несколько архивов полезно иметь в случае, если архивирование ведется с разной идеологией (циклическое, ациклическое, с разными циклами опроса и т.д.). Как правило сохранять надо сразу кучу переменных, причем из разных архивов. И вот здесь-то и возникает проблема. А как произвести такое сохранение за один цикл ? Естественный напрашивающийся ответ - создать массив, в котором хранить данные по каждой из архивных переменных (к какому архиву принадлежит, полное SYBASE-имя, на какой процессный таг ссылается). В принципе такой массив можно создать какой-нибудь инициализационной функцией и сделать его доступным для других функций ("С" это делать умеет, а WinCC поддерживает такую возможность). Второй путь - создать некотрое количество внутренних тагов по числу архивных переменных и так же заполнить их посредством инициализационной функции. И наконец третий путь - это создать файл-список, в котором так же хранить данные об архивных переменных.
Каждый из этих способо в чем-то лучше, в чем-то хуже. Но вот хотелось бы узнать мнение опытных разработчиков, какому способу отдать предпочтение.

Заранее спасибо.
Re: Запись параметров
Alexis; 8.2.02

Александр, вот тебе еще и четвертый путь :)

При конфигурировании архивов занеси в поле Comment или Unit (в принципе все зависит от фантазии разработчика :) какую-нибудь идентифицирующую информацию. Далее перед сбросом данных считывай информацию об архиве и анализируй идентификаторы относительно которых и производи сброс.
Единственный минус подхода - считывание данных об архиве процесс медлительный.
Re: Запись параметров
Александр Родин, ООО "Нева Электрик"; 21.5.02

2 Alexis:

Собссно, вот и воткнулся на те самые грабли... Как вот теперь этот 4-й путь реализовать ?.. :)))))) Вроде и функция есть, а использовать ее никак...
Re: Запись параметров
Alexis; 21.5.02

2 Александр Родин

>Вроде и функция есть, а использовать ее никак...
Это точно, особенно если установленна только RT. Повозившись с TLGReadVariable пришлось на нее плюнуть и обойти эту проблему прямым чтением (db.dll) из CS-ной базы, но и тут трабл, никак не могу подключится к CS-ной базе с клиента. Поэтому моя софтинка пока может жить только на сервере :(
Re: Запись параметров
Александр Родин, ООО "Нева Электрик"; 21.5.02

2 Alexis:

А если проект однопользовательский, то надежда есть ?.. %)
Надо будет попробовать...

Re: Запись параметров
Alexis; 22.5.02

В однопользовательском все работает нормально :)


text

Не работает клавиша Win при WinCC
Ефременко Денис; 17.5.02

После установки WinCC перестала работать клавиша Win. Можно ли заставить ее работать

Re: Не работает клавиша Win при WinCC
Лев Шерешевский; 18.5.02

Можно. Для этого надо удалить ключ реестра HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout Но после этого WinCC не сможет блокировать нажатия спец. комбинаций клавиш.

Re: Не работает клавиша Win при WinCC
Лев Шерешевский; 18.5.02

(!) Исправление (!)

В предыдущем постинге у меня скопировалась не вся строка. Удалять надо HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout\Scancode Map, который изначально равен hex:00,00,00,00,00,00,00,00,04,00,00,00,00,00,5b,e0,00,00,5c,e0,00,00,5d,e0,00,00,00,00

Re: Не работает клавиша Win при WinCC
Ефременко Денис; 18.5.02

Огромное cпасибо! Помогло. Добавлю только совет для других: этот ключ можно просто переименовать, чтоб потом при необходимости ,быстро вернуть блокировки WinCC.


text

Как задействовать кнопки на PC670 в WinCC?
Ефременко Денис; 17.5.02

ProTool позволяет это сделать без проблем. А как получить доступ к мембранным кнопкам панельного компьютера PC670 в WinCC V5.0 SP2?

Заранее спасибо.
Re: Как задействовать кнопки на PC670 в WinCC?
Александр Родин, ООО "Нева Электрик"; 17.5.02

... пошукай в комплекте с документацией на PC есть диск Documentation and Drivers SIMATIC PC...

на нем есть программка, которая в биос прошивает коды сенсорных клавиш... после этого можешь их назначать... :)

Кстати, прикол или фича - оценивайте сами... Все сенсорные клавиши распознаются как комбинации функциональных клавиш (F1 - F12) и Ctrl, или Ctrl+Shift, или Ctrl + Alt :)

Меня это повеселило очень... :)


text

OP7, печать по-русски
Павел Берляков; 18.4.02

Подскажите, пожалуйста, можно ли печатать из OP7 по-русски, а не латиницей? Принтер LX-300.

Или мне нужен Сименсовский принтер ?
Re: OP7, печать по-русски
Юрченко Владимир; 18.4.02

Не знаю насчет LX-300, но есть информация о том, что Сименсовский принтер DR2040 (6GF6520-1LD)точно может печатать по русски с панелей OP7 и OP17.

Re: OP7, печать по-русски
Ефременко Денис; 17.5.02

Нужен принтер с ECMA раскладкой, например:

DR 2040 + ECMA 9014 карта


text

WinCC Hotfix u.a.
Павел Берляков; 1.4.02

Товарищи, подскажите, какие Hotfix и прочие заплатки существуют?

Эксплуатируем WinCC 5.0 SP2.
Re: WinCC Hotfix u.a.
Юрченко Владимир; 2.4.02

Последний для WinCC 5.0 SP2 HotFix 9.

Теперь поставляется WinCC 5.1
С проблемами обращайтесь в московский
офис - т.737 24 14

Re: WinCC Hotfix u.a.
Павел Берляков; 8.4.02

Спасибо.

Re: WinCC Hotfix u.a.
Eugene; 16.5.02

А ссылочку, где скачать HotFix 9 для WinCC 5.0 SP2 можно узнать?

И еще вопрос.
Сколько стоит перейти с WinCC 5.0 SP1 или SP2 на WinCC 5.1?

Re: WinCC Hotfix u.a.
Александр Туманов; 17.5.02

Два маленьких замечания:

1. HotFix 9 ставится только поверх HotFix7.
2. Оба этих HotFix 7 и 9 ставятся только под Windows NT (не под Windows 2000).


text

Как изменить формат времени?
Александр Туманов; 10.1.02

В объекте WinCC Online Table Control

время выводится в формате
mm/dd/yyyy mm:ss, как изменить формат
на dd/mm/yyyy mm:ss ?

Re: Как изменить формат времени?
Лев Шерешевский; 15.5.02

Для трендов (да и всей системы в целом) мне удалось поменять формат времени и даты путем установки в американской Win2k локали English (United States) и принудительного изменения всех форматов (в т.ч. и даты/времени).


text

Русификация диалоговых окон WinCC
Лев Шерешевский; 9.5.02

Всем здравствуйте!

Недавно безуспешно пытался решить проблему русификации стандартных диалоговых окон WinCC.
К примеру, хотелось бы заменить сообщение "Insufficient permissions" на нечто более понятное рядовому оператору. Или использовать стандартное окно выбора диапазона времени в трендах, вместо того, чтобы на ODK повторять этот же диалог только по-русски.
Простой поиск искомых строк на диске ни к чему не привел. Также не увенчались успехом попытки с помощью Spy++ из состава VisualStudio выяснить, какой процесс порождает эти окна, а затем отредактировать соответствующие ресурсы.

На мой взгляд, проблема эта достаточно общая и может расцениваться как отсутствие возможности полной локализации проекта.

Буду крайне признателен, если кто-нибудь поделится опытом решения подобных проблем.

С уважением,
Лев Шерешевский
Re: Русификация диалоговых окон WinCC
Колпащиков Сергей. Аквтехнология; 11.5.02

Здравствуй Лев.

Русификация замечательно получилась.
Для это мы использовали программку Restorator (кажется).
А править ей надо файлы с расширение lng из WinCC Bin и в покаталогах относящихся к соответствующим сервисам.

Сергей.
Re: Русификация диалоговых окон WinCC
Лев Шерешевский; 11.5.02

Привет, Сергей!

Огромное спасибо, удалось русифицировать все нужные диалоги в точности как ты описал.

Лев
Re: Русификация диалоговых окон WinCC
Костенич Дмитрий; 15.5.02

Привет, народ!

Подскажите где такую програмку найти (я про Restorator).
Вообще-то, я *.lng файлы правил прямо в MS VC++ (открывал их как ресурсы), но может быть этой програмкой удобнее ;)

Заранее благодарен.
Re: Русификация диалоговых окон WinCC
Лев Шерешевский; 15.5.02

http://www.bome.com/Restorator/download.html

Очень неплохой редактор ресурсов, но shareware (ломалки в сети также несложно найти). При редактировании одного-двух файлов, мне кажется, MS VC++ ничем не хуже, но при работе со многими ресурсами Restorator несомненно удобнее.


text

проект на 2 монитора
Сергей; 10.5.02

Подскажите, кто знает, пожалуйста!

Как заставиться проект работать на 2 монитора. Средствами WinCC, ее редактором Screen Wizard, сделать это не удается.
Получается просто "растянуть" по горизонтали рабочий стол и больше ничего.
Буду ждать совета!

С уважением, Сергей
Re: проект на 2 монитора
Alexis; 13.5.02

Во первых тебе нужна двух-головая видеокарта, далее цепляешь соответственно два монитора. В настройках десктопа виндозы устанавливаешь необходимое разрешение, например 2560х1024 или 1280х2048 - в зависимости от того как у тебя расположены мониторы. Точно также конфигуришь Split Screen Wizard-ом настройки проекта на два монитора и получишь соответствующую картинку @screen.pdl и т.д. Все это при условии что ты пользуешься (и будешь пользоваться) функциями Split Screen Manager-а из Basic Process Control-а.

В хелпаке к WinCC это все подробно расписано.

Вопрос: запускаю "двух-мониторный" проект на одномониторном компе - начинает жутко тормозить Global Script... кто-нибудь сталкивался с подобным?
Re: проект на 2 монитора
Alexis; 13.5.02

Во первых тебе нужна двух-головая видеокарта, далее цепляешь соответственно два монитора. В настройках десктопа виндозы устанавливаешь необходимое разрешение, например 2560х1024 или 1280х2048 - в зависимости от того как у тебя расположены мониторы. Точно также конфигуришь Split Screen Wizard-ом настройки проекта на два монитора и получишь соответствующую картинку @screen.pdl и т.д. Все это при условии что ты пользуешься (и будешь пользоваться) функциями Split Screen Manager-а из Basic Process Control-а.

В хелпаке к WinCC это все подробно расписано.

Вопрос: запускаю "двух-мониторный" проект на одномониторном компе - начинает жутко тормозить Global Script... кто-нибудь сталкивался с подобным?


text

Wincc резервирование
Антон Глухов; 8.5.02

Подскажите, уважаемые!

Установлены 2 сервера Wincc под управлением Windows 2000 Server. Пытались настроить резервирование. Работает очень странно и не стабильно. В руководствах написано, что прежде чем запускать резервирование, надо прогнать Dcomtest.
Попробовал. Выдает ошибку и закрывается.
Судя по всему Dcom надо как-то настраивать, а вот как - не написано.
Кто-нибудь сталкивался с такой проблемой?

Re: Wincc резервирование
Вера Прокопенко; 11.5.02

Описание настроек DCOM есть в файле KB_5_e.chm от Siemens


text

Движение на мнемосхемах
Евгений Трунов; 29.4.02

Кто сталкивался с проблемой отображения движения на мнемосхемах, созданных в графическом редакторе WinCC? Например, в большинстве поточно-транспортных систем необходимо отображать постоянное перемещение материала по конвейерам, например, с помощью бегущей пунктирной линии. Однако реализация такого "бега" механизмами WinCС (да и не только) сопряжены с серьезными трудностями.

Кто может дать хороший совет? Ведь делали, я знаю! :-)
Re: Движение на мнемосхемах
Костенич Дмитрий; 29.4.02

Если делать "бег" линией, то можно в цикле менять ее стиль (например с Dash Dot на Dash Dot Dot и обратно).

Если нужна более сложная анимация, то в WinCC Graphics Desiner есть графический элемент Status Display, позволяющий отображать разные катринки (bmp и emf) в зависимость от значения конкретного тега (т.е. устроить мультик).

С уважением ко Всем.
Re: Движение на мнемосхемах
Евгений Трунов; 30.4.02

Средствами WinCC получается не бег, а мигание. А нужен именно "бег", т.е. бесконечное движение в одном направлении. С несколькими картинками -так можно вставить компонент ActiveX, реализующий GIF-анимацию, например. В общем, с простыми решениями - беда :-). В любом случае, спасибо.

Re: Движение на мнемосхемах
Чистяков Дмитрий ОАО "СеверСталь"; 30.4.02

---------------------------

Средствами WinCC получается не бег, а мигание.
---------------------------

Так ведь бег - это и есть мигание. 8-)
Только для более "качественного бега" лучше всегда использовать не менее трёх объектов. Достаточно вспомнить про обычные бегущие огни.
В Вашем же случае "качественный бег" можно достичь так,например:
1.взять три линии из точек.
2.распределить их со сдигом в одну треть расстояния между точками.
3.включать линии по тэгу с кодом от 1 до 3
Re: Движение на мнемосхемах (в догонку)
Чистяков Дмитрий ОАО "СеверСталь"; 30.4.02

Собственно говоря, в GIF-е так и делается.

Мигание - не совсем движение
Евгений Трунов; 8.5.02

Так пробовал. Не совсем так, но похоже. Не получается :-). При любом количестве линий из точек движение идет до того момента, пока не придет время перехода с последней на первую линию. И тут происходит скачок назад :(. Движение - это когда можно визуально проследить путь каждой точки пунктирной линии от начала пути и до конца. Прыжки же сбивают эту картину. Можно реализовать, управляя отдельно каждым квадратиком пунктирной линии, либо имея возможность рисовать средствами Win32 API. Ни то, ни другое неприемлемо.

Решение где-то рядом, но не могу его ухватить :-).


text

TD200+S7
NTMK LSPU; 7.5.02

Как организовать 1 PLC S7-200 + 4 TD200, чтобы адресоваться к каждому TD отдельно?

Re: TD200+S7
Юрченко Владимир; 7.5.02

Описание как это сделать есть в руководстве по TD200 (на английском языке, файл TD200_e.pdf). Если у Вас его нет - могу выслать по электронной почте.


text

OP35
Логинов Павел; 17.4.02

Господа!

Может кто знает как перенести (или скачать) программу с OP35 кроме как с помощю MEMORY CARD.(или как скачать проект с MEMORY CARD в ProTool, или .. любые варианты)????
Re: OP35
Aleks; 20.4.02

А никак

Re: OP35
Павел Иванов (Сименс-Москва); 22.4.02

Для этого используется бесплатная программа ProSave.

С ее помощью можно скачать проект с панели в бинарном виде и закачать его обратно.
Она входит в состав поставки ProTool или ее можно скачать с центрального сайта поддержки.
Re: OP35
Логинов Павел; 29.4.02

Увы!

ProSave не поддерживает OP35.
А у OP35 нет serial download.
(Вы маненько изучите чем торгуете).
Re: OP35
aim; 30.4.02

Как это нет !?

Если руки не оттуда растут - нечего на Siemens пенять.
Для "одарённых" - открой пример проекта для OP35 (в комплекте с PT) и посмотри как это делается
Re: OP35
Aleks; 3.5.02

Для aim

А причем тут PT это же OP35.
С OP35 Ты никак не скачаеш обратно
не предусмотрено это.

Re: OP35
Логинов Павел; 6.5.02

Огромное спасибо ВСЕМ за живое участие! Проект перенс с OP на OP c помощью MEMORY CARD и черт с ним (никакого желания разбираться в чужом творчестве)


text

Как установить ODBC драйвер Adaptive Server Anywhere 7.0
Александр Туманов; 6.5.02

Этот драйвер устанавливается вместе с WinCC, а мне нужно его установить отдельно для реализации связи с базой данных из Excel с любого ПК в той же подсети, в которой работает WinCC сервер. Как его установить?

Re: Как установить ODBC драйвер Adaptive Server Anywhere 7.0
Александр Родин, ООО "Нева Электрик"; 6.5.02

Adaptive Server Anywhere 7 лежит на WinCC-диске в папке

\WinCC\setup\Products\Sybase_7\
Re: Как установить ODBC драйвер Adaptive Server Anywhere 7.0
Иван Данилушкин; 6.5.02

Как нам объяснил г-н Смирнов (microOLAP Support Team),

чтобы иметь право доступаться на сервер Sybase ASA (SQL Anywhere) c N
рабочих станций, нужно иметь N клиентских лицензий.

В идеале нужно просто взять полный дистрибутив Sybase ASA (полный, а не урезанный, который поставляется с WinCC) и установить оттуда клиентскую часть на каждого клиента.
Но можно обойтись и без этого: поищите в Sybase ASA хелповнике на соответствующую версию сервера слово "distribution" - получите список требуемых DLL, которые Вы можете, например, запихать в свой инсталлятор.

Лицензионный аспект такого деяния: Вы незаконно распространяете программное обеспечение Sybase.

Удачи...
Re: Как установить ODBC драйвер Adaptive Server Anywhere 7.0
Герман Лиховских; 6.5.02

ODBC драйвер Sybase SQL Anywhere 5.0 получалось перенести путем копирования кусков реестра относящихся к ODBC и Sybase и соответствующих библиотек.

Всего доброго!


text

Управл. записями в UserArchive из-под GlobalScript
Зверев Игорь; 30.4.02

Баг такой: GlobalScript контролирует количество записей в UA (в режимное время убивает первые, добавляет новые, поддерживая заданное количество) и обрабатывает значения в текущей последней записи. Видимо при увеличении загрузки системы, напр. параллельном запуске S7, работы в нем, иногда происходит "зависание" глобал-скриптов, все скрипты перестают реагировать, машину приходится перегружать. В результате после запуска Runtime работа скрипта с UA идет некорректно - добавление записей происходит, но удаление, перемещение и работа в указанной - как попало, указатель не перемещается и все происходит в какой-либо произвольной записи. Вылечивается убиванием ВСЕХ записей в UA и перезапуском Runtime. Как можно такое лечить не очищая UA? или предотвращать/контролировать непосредственно в работе скрипта?

Заранее спасибо.
PS: кстати, ИМХО, форуму не хватает поиска...или я не там искал?


text

Как можно скачать программу с ОР-7 на РС?
Олег; 15.4.02

Подскажите, пожалуйста, как можно скачать программу с ОР-7 на РС? Пробовали использовать Prosave, связь между ОР и РС никак не устанавливается. Кабель используем с разводкой 2-4, 3-3, 5-12 . Пробовали и в DOS режиме

Re: Как можно скачать программу с ОР-7 на РС?
dmi3o; 16.4.02

Никак... :(

Re: Как можно скачать программу с ОР-7 на РС?
Олег; 17.4.02

А Prosave? С его помощью нельзя Backup data получить?

Re: Как можно скачать программу с ОР-7 на РС?
Павел Иванов (Сименс-Москва); 22.4.02

Для этого как раз используется бесплатная программа ProSave.

С ее помощью можно скачать проект с панели в бинарном виде и закачать его обратно.
Она входит в состав поставки ProTool или ее можно скачать с центрального сайта поддержки.
Re: Как можно скачать программу с ОР-7 на РС?
dmi3o; 26.4.02

Пардон. А может есть возможность привести его к "нормальному" виду? Было бы замечательно!

Re: Как можно скачать программу с ОР-7 на РС?
Павел Иванов (Сименс-Москва); 27.4.02

К сожалению нет.

Для новых панелей оператора (например,OP/TP/MP 270 - 370), которые поддерживают PC-Card интерфейс, можно вставить карту памяти и на нее записать и весь проект.


text

Как вызвать экран ...
dmi3o; 12.4.02

... OP7 из программы S7 через "Area Poiters - Screen Number"?

С ув., Дмитрий Фиронов.

Re: Как вызвать экран ...
dmi3o; 26.4.02

Спасибо за участие! Больше не надо! :)


text

WinCC работает на windows 2000 или XP
Alexandr; 25.4.02

WinCC работает на windows 2000 или XP

Если работает то какая версия
Re: WinCC работает на windows 2000 или XP
Юрченко Владимир; 25.4.02

Поддержка Windows 2000 SP1 есть у

WinCC 5.0 SP2.
WinCC 5.1 может работать с Windows 2000 SP2.
Windows XP пока официально не поддерживается.
Re: WinCC работает на windows 2000 или XP
Александр Родин, ООО "Нева Электрик"; 26.4.02

WinCC 5.0 SP2 гарантированно пашет под Win2K - проверенно.

Под ХР можно настроить совместимость. По крайней мере установить под ним тот же WinCC удалось без проблем. И даже проект загрузился. И даже редактор графики работает. И даже (что удивительно) скрипты компилируются.
Так что, можно сказать, что в черне все пашет. Если будут глюки проявляться - напишу подробнее.

По большому счету, разницы ХР и 2К нет, поэтому вроде как особых проблем быть не должно.


text

БЕДА!!! Не устанавливается связь с ОР
Gluzer; 10.4.02

Братья по разуму, БЕДА!!! ProTol 5.2 не может (или не хочет) установить связь с панелями ТР27/ТР37 по PROFIBUS/MPI. STEP7 по этому же кабелю с S7-400 работает без проблем. Пожалуйста помогите, у меня оборудование линии стоит :-(

Re: БЕДА!!! Не устанавливается связь с ОР
Чистяков Дмитрий ОАО "СеверСталь"; 11.4.02

Так по подробнее бы - Что значит не хочет?

Какую ошибочку пишет?
Как там у Вас с адресами станций дела обстоят?
Более конкретное описание проблеммы
Gluzer; 11.4.02

Связь ТР27 с программатором не устанавливается. При тестировании связи через Пуск-Настройка-Панель управления-установки PG/PC-тест MPI интерфейса проходит отлично, пульт не видно (ну это из-за того что в нем ничего нет-флэш чистый) Адрес программатора MPI 0. ТР27 стоит в готовности к загрузке-READY FOR SERIAL TRANSFER, DIL переключатель установлен в положении DP/MPI/PPI(все 4 стоят в OFF). В настройки самого пульта где устанавливается скорость передачи и другие параметры соединения войти не получается(а есть ли у него вообще эта установка?). Запускаю внутренний тест ТР - при проверке интерсфейса IF1A пишет следущее:

Testing IF1
IF1a V24/Adapter 1 or
IF1a TTY/Adapter 2 Timeout!
IF1b 2 wired/Adapter 4 ok
IF1b 4 wired/Adapter 4 Timeout
Ниже заключение Defekt

PS: Я точно знаю, что пульт рабочий, у него только обнулился флэш - батейка померла. До сноса флеша у пульта был установлен MPI адрес 6. Родная программа есть некомпилированная.
В мой ответ вкралась ошибка
Gluzer; 11.4.02

ИСПРАВЛЕНИЕ! Следует читать "Запускаю внутренний тест ТР - при проверке интерсфейса IF1", а не "IF1A" как у меня указанно в предыдущем письме

Re: БЕДА!!! Не устанавливается связь с ОР
Александр Туманов; 11.4.02

Если ты связываешься в первый раз, то нужно подключатья не через

MPI, а через TTY-токовая петля (кабель для связи с simatic S5 - входит в комплект
PG). Связываться вообще имеет смысл, если у тебя есть проект для TP,
если его у тебя нет, то скачать из TP ты его не сможешь. Процедура
загрузки проекта описана в руководстве. Интерфейс тестировать можно
только со вставленной в него заглушкой!!! иначе, естественно,
диагностируется ошибка.
Александр, если есть возможность, то включите аську
Gluzer; 11.4.02

Александр, если есть возможность, то включите аську

Re: БЕДА!!! Не устанавливается связь с ОР
Любитель Симатика; 12.4.02

Вы загрузите первый раз проект через TTY или RS232(V24). Разводку кабеля можно посмотреть на этом сайте.

После этого догружать можно и через MPI.
Связь с ОР
Gluzer; 12.4.02

Загрузил проект через TTY (спасибо Александру Туманову за подсказку), но по прежднему не могу связатся с ОР через MPI. Также не могу выполнить Download Back из ОР посредством ProTol`a через serial port

Подскажите где скачать утилиту PTProSave
Gluzer; 12.4.02

Подскажите где можно скачать утилиту PTProSave. При инсталяции ProToоl она не записывается на да хард-диск. На CD ее тоже нет

Подскажите где скачать утилиту PTProSave
Gluzer; 12.4.02

Подскажите где можно скачать утилиту PTProSave. При инсталяции ProToоl она не записывается на да хард-диск. На CD ее тоже нет

Подскажите где скачать утилиту PTProSave
Gluzer; 12.4.02

Подскажите где можно скачать утилиту PTProSave. При инсталяции ProToоl она не записывается на да хард-диск. На CD ее тоже нет

Утилиту нашел, но проблемма осталась
Gluzer; 15.4.02

Утилиту ProSave нашел, запускаю ее конфигурю, жму BackUp, указываю имя файла для сохранения - процесс пошел. На панели идет листинг. После того как прошел листинг на пульт выходит надпись Init Tansfer 0, а на компе пишет Protocol Error, пресс ани кей. В чем заключенна моя ошибка

Re: БЕДА!!! Не устанавливается связь с ОР
Александр Туманов; 15.4.02

Чтобы подготовить ОР к загрузке по MPI необходимо:

1. загрузить стандартный проект для этой ОР (см. в каталоге SAMPLES ProTool).
2. Вызвать окно System Settings и выбрать в нём режим "MPI Download"
3. Настроить протокол MPI с теми же параметрами, что и в PG.
3. Теперь можно делать Download (см. раздел Recommissioning.
Re: БЕДА!!! Не устанавливается связь с ОР
Александр Туманов; 15.4.02

Исправление к моему предыдущему сообщению -

открывать стандартный проект нужно так: при создании нового проекта с помощью визарда необходимо поставить галочку "Use Standard Project".
Проблемма осталась
Gluzer; 15.4.02

Александр спасибо! Проделав все указанные Вами операции, я смог загрузить проект через MPI, но проблемма с выгрузкой проекта из ОР через любой из интерфейсов (MPI или Serial) осталась

Проблемма осталась
Gluzer; 15.4.02

Александр спасибо! Проделав все указанные Вами операции, я смог загрузить проект через MPI, но проблемма с выгрузкой проекта из ОР через любой из интерфейсов (MPI или Serial) осталась

Re: БЕДА!!! Не устанавливается связь с ОР
Александр Туманов; 16.4.02

Необходимости сохранять проект с помощью Prosave у меня никогда не возникало (зачем, если у меня есть исходный проект). Но, насколько я могу судить по Вашим сообщениям, возможно ошибка кроется в том, что Вы "жмёте BackUp" вместо Serial Download (в стандартном окне) - процедура BackUp используется для сохранения проекта во внешней Flash EPROM карте!!!, но не по последовательному интерфейсу.

Непоняточка возникла
Gluzer; 16.4.02

Насколько я понимаю, то ProSave предназначена для загрузки и выгрузки компилированного пректа через СОМ1 или СОМ2 в файл на хард-диске. В моем случае ОР27 сконфигурен на Serial Download и установлен в режим Ready for Serial Transfer. Програматор подключен посредством TTY через СОМ1 к IF2. Запускаю ProSave, вижу что у меня в ОР загружен проект PRO1, устанавливаю в пареметрах связи СОМ1(38400 Baud), далее жму F2(BackUp Data). На экране ОР выходят четыре строки

Init Transfer 0,
SincTel,
ReadTel: E0000,
Init Transfer 0,
В это же время на програматоре выводится запрос "BackUp to file", указываю произвольное имя С:\123, жму Enter. Програматор пишет "BackUp Data to OP", весело начинает шуршать винтом, на панели ОР бегут строчки, и тут как рояль в кустах-"Рrotocol Error, пресс ани кей" Вот в чем вся беда, где тут собака порылась :-(

Re: БЕДА!!! Не устанавливается связь с ОР
Александр Мельничук; 25.4.02

Такая проблема встречалась. Уменьшите скорость связи, хотя бы в два раза (19200), и всё должно получиться, конечно не так быстро.

Не устанавливается связь с ОР
Gluzer; 25.4.02

пытался устанавливать связь на всех скоростях - 4800, 9600, 19200, 38400. Все бестолко, не пролазиет


text

WinCC & ПЛК Schnieder Electric Modicon или ABB
Lidiya; 25.4.02

Пожалуйста, подскажите как организовать взаимодействие

WinCC с ПЛК Schnieder Electric Modicon или ABB?

Заранее благодарю всех за помощь.
Re: WinCC & ПЛК Schnieder Electric Modicon или ABB
Юрченко Владимир; 25.4.02

У Wincc есть драйвер для Modbus RTU протокола для последовательного порта.

Если эти контроллеры имеют поддержку этого протокола (у этих фирм много чего разного) то используйте этот канал WinCC.
Другой путь использование OPC. У WinCC есть канал для OPC и вы можете связаться с этими контроллерами по OPC интерфейсу, при наличии конечно OPC серверов.


text

Архивирование через RAW теги
Костенич Дмитрий; 24.4.02

Привет всем!

Есть такая проблема - нужно архивировать значения чаще чем раз в 0.5 сек. Для этого в S7-400 используется функция SFB37 (AR_SEND), которая посылает целый блок значений (DB, в котором лежит заголовок (20 байт) для раскодирования блока в WinCC TagLogging и, собственно, архивные данные). В WinCC этот посланный блок кладется в RAW тег типа RAW_ARCHIVE и дальше должен раскодироваться системой TagLoggingRT и пихаться в соответствующую таблицу.

Так вот, все было сделано как описано в документации и примерах (кстати довольно скупых); передача данных из контроллера выполнялась успешно (без ошибок), а на приеме в RAW теге имели лишних 30 байт в самом начале блока (дальше честно шла вся наша посылка).

Может кто уже сталкивался с подобной ситуацией - подскажите окуда ноги растут и как бороться.

Да, связь осуществлялась по SIMATIC S7 PROTOCOL SUITE через протоколы TCP/IP и Industrial Ethernet через локальную сеть.

С уважением ко всем.


text

Нужна срочно ПОМОЩЬ!!!
Сергей; 22.4.02

Подскажите, кто знает!!!

Не удается "заставить" WinCC 5.0 SP2 "запомнить" более 1000 сообщений в RunTime (ActiveX элемент для Alarm Login). Краткосрочный и долгосрочный архивы настроены на архивирование более чем 1000 записей. В документации путных советов не нашел!
С нетерпением жду ответа
Re: Нужна срочно ПОМОЩЬ!!!
Александр Туманов; 23.4.02

Предположение!!!

Возможно ограничение есть только на отображение 1000 записей, а в самой базе данных записей может быть гораздо больше. Поэтому попробуйте использовать фильтр (по времени, по типам, по источникам и т.п.), ограничивающий список сообщений для вывода в окне ActiveX.

Re: Нужна срочно ПОМОЩЬ!!!
Наталья; 23.4.02

Это предположение абсолютно верно, ограничене есть действительно только на отображение записей в этом окне, в архиве же в действительности лежит столько, сколько вы запрограммировали. Решается это только использованием указанных фильтров


text

OP15B
Сычёв Андрей; 15.4.02

Имею в наличии OP15B (6AV3515-1MA01),

но мой ProTool Pro CS v5.2 SP3
не видит её при выборе OP.
Что делать?

Re: OP15B
Павел Иванов (Сименс-Москва); 22.4.02

Насколько я помню панель OP15B была снята с производства в 1995-1996 году.

Тогда еще никакого ProTool не было.
Она проектировалась при помощи пакета COM TEXT.


text

Конфликт между S7 и MPI
Александр Туманов; 15.4.02

Планирую на одном контроллере (CPU315-2DP+CP342-5DP) использовать обмен по MPI через Global Data с другим PLC параллельно с обменом по PROFIBUS S7 (CP342-5DP и CP5613-WinCC) и с обменом по PROFIBUS DP (встроенный порт CPU315-2DP - ET200M). Могут быть конфликты при таком трёхстороннем обмене или нет?

Re: Конфликт между S7 и MPI
Павел Иванов (Сименс-Москва); 22.4.02

Конфликтов не будет.

Только надо учитывать один ньюанс,
что текущие модели CPU и CP поддерживают коммуникации с партнерами до 4 статических соединений и 8 динамических.
Поэтому это м.б. ограничением.
С новыми CP это ограничение расширеяется до 16 соединений.


text

Работа с содержимым архивов
Шихарбеев Михаил; 20.4.02

Произведено архивирование в Tag Loggin аналогового тега. Как при отчетности осуществить суммирование всех значений этого тега. Кстати я пока не могу и вывести из архива, в дизайнере отчета, все значения конкретного тега.

Re: Работа с содержимым архивов
Александр Туманов; 22.4.02

Например, с помощью такой SQL-команды:

select sum(value) from Table;
где Table-имя таблицы, а value-переменная для суммирования.


text

Редактирование архивов
Шихарбеев Михаил; 20.4.02

Как редактировать сам архив процессных тегов? Например, удалить строчки в архиве или совсем очистить его?

Re: Редактирование архивов
Александр Туманов; 22.4.02

База данных под держивает все SQL-команды, в том числе команды удаления и вставки (см. справочник языка SQL).


text

Отображение архивов
Шихарбеев Михаил; 20.4.02

В RunTime период воспроизведения тренда из архива (From,To) выводится не верно. Ставишь реальный период (Дата,Время), все равно вместо года заносит 65535 и т.д. так же и с таблицами. С чем это связано?


text

Borland C/C++ development environment
Павел Берляков; 18.4.02

Что такое Borland C/C++ development environment ?

Возможно ли для создания программ, использующих функции API WinCC использовать Borland C ?
Re: Borland C/C++ development environment
Юрченко Владимир; 18.4.02

ODK для WinCC поставляется с библиотеками для Visual C v.5.0 Все API функции WinCC находятся в соответствующих DLL. Их имена можно найти в *.lib для VC и используя борландовские утилиты implib и impdef получить вариант библиотек для BС. Но нужны ли все эти усилия?

Re: Borland C/C++ development environment
Alexis; 18.4.02

Можешь использовать хоть Бейсик...

Берешь описание функций из хэдеров в \aplib или из ODK и подгружаешь dll-ки...


text

Реализация "паспорта резервуара" в WinCC
Павел Власкин; 17.4.02

Есть резервуар 12 метров высотой, есть паспорт резервуара - соответствие уровня объему (~1200 значений).

Как оптимально хранить и использовать эти паспорта?
Re: Реализация
Юрченко Владимир; 18.4.02

Насколько я понимаю задача стоит в пересчете значений показаний уровнемера в объем жидкости в резервуаре. Если бы эта зависмость была линейной или описывалась несложной формулой - это можно было бы сделать масщтабированием переменной или с помощью скриптов WinCC. Но интерполяция с использованием 1200 значений на скриптах будет очень медленной. Лучше написать отдельную DLL , определить в ней функцию для экспорта и ее уж вызывать из скриптов.

А как ваша DLL будет хранить эти значения - статически в коде или считывать с базы данных при загрузке DLL - ваш выбор.


text

Замена ProTool -> MS SQL на WinCC -> MS SQL ???
Дмитрий Л.; 16.4.02

Существует проект PLC's -> ProTool -> MS SQL -> клиенты. Возникла необходимость заменить ProTool на WinCC. Возможно ли средствами WinCC писать в ту же базу или только переделывать всё???


text

Оптимальный hardware для сервера
Александр Туманов; 8.4.02

Господа! Предложите оптимальную (цена-надёжность-работоспособность)конфигурацию для сервера WinCC 5.0 SP2 и Windows 2000 Server. Акцент - на резервирование компонентов.

Re: Оптимальный hardware для сервера
Чистяков Дмитрий ОАО "СеверСталь"; 9.4.02

Задано слишком мало условий

Сколько клиентов будет?
Количество тегов?
Будете ли архивировать теги?

А так, немного о нашей системе.
Сервер
ASUS P2B-DS
2xPIII 550
RAM 512Mb PC100
HDD SCSI IBM 36Gb 10.000rpm - 2шт.
видео карта ASUS V3800
MOD 1,3Gb Fujitsu 3,5"
PLC Simadyn D(CSH11), Simatic S7 (CP443-1)
для связи с PLC используется CP1613
для связи с клиентами 3Com 995-T, это гигабит.

WinCC клиентов на сегодняшний день - 13.
Тегов более 18.000
Всего машин в сети - 27

Пока всё тянет. В дальнейшем будет увеличение PLC, тэгов и клиентов.
Но это уже там видно будет. видимо просто придётся памяти добавить.

Re: Оптимальный hardware для сервера
Логинов Павел; 15.4.02

А ASUS V3800 для души ?

Re: Оптимальный hardware для сервера
Александр Туманов.; 15.4.02

Была такая проблема:

поработав 2-3 месяца сервер стал периодически зависать (каждые 3-5 дней). Заменили память на лучшую (Micron), установили дополнительный вентилятор в корпус и заменили Cooler на более дорогой - перестал зависать!


text

PowerSuite 2000 (InTouch) VS WinCC (5.0/5.1)
Алесандр Родин, ООО "Нева Электрик"; 10.4.02

Кто сталкивался с WonderWare InTouch, чем она хуже/лучше WinCC ?

А то вот есть проектик вкусный, уже просчитали на WinCC, а заказчик рогом упреся и хочет InTouch. Чем заказчика преубедить ? Кто-нибудь имел опыт работы с ней и, в частности, в плане интеграции с контроллерами Сименс.

В релизе по InTouch говорится, что Сименс поддерживается.

Если у кого есть что сообщить, пишите сюда или мыльте...

С уважением ко всем.
Re: PowerSuite 2000 (InTouch) VS WinCC (5.0/5.1)
Чистяков Дмитрий ОАО "СеверСталь"; 10.4.02

Опыт у нас на СеверСтали имеется. И опыт показал, что сам InToch работает нормально, а вот связь с контроллерами постоянно подвисает.

Все запросы по этому поводу отсылаются к автору драйвера связи. А его можно уже и не найти (перешёл в другую фирму, или ещё чего), а то и просто скажет, что некогда мне тут с Вами возиться.
Виновата в этом политика WonderWare в плане того, что сама она драйвера связи не пишет, а отдаёт эту нишу на откуп третьим лицам, фирмам. Оно понятно, что эта ниша пожалуй самая муторная с точки зрения поддержки и фирме лениво заниматься этим. Но получается, что пользователь отсаётся один на один с этой проблемой.
Потому наши коллеги (даже самые ярые интачевцы) постепенно переводят проекты на WinCC.

Ещё можно заинтересовать заказчика вкусными вещами, типа PDiag, ProAgent for WinCC.
Ещё тем, что только в совместном использовании STEP 7 и WinCC возможна интеграция тэгов визуализации и символьной таблицы из программы PLC. Т.е. В проекте WinCC видны все переменные в программе контроллера.
А так же тем, что драйверы связи InTouch не поддерживают расширенных фунций в интеграции с контроллером.
Ну и как правило все эти драйверы требуют организации канала связи в контроллере. А для WinCC не требуется ни каких извращений в программе.
Например, ни какой пакет SCADA не поддерживает протоколирование быстро изменяющихся сигналов. В Simatic`е для этого имеются специальные блоки SFC17,18,19.
Ну и в конце концов, один производитель двух систем всегда лучше согласовываются.

Re: PowerSuite 2000 (InTouch) VS WinCC (5.0/5.1)
Логинов Павел; 15.4.02

Геморрой один и тот же (нюансы что с чем глючит не в счет). Но у WonderWare значительней проколочены понты. Так что упирайте на одного производителя.


text

WinCC и Alarm Login
Сергей; 8.4.02

Помогите, кто знает в следующей ситуации... В Alarm Logine пытаюсь сделать появление сообщения о состоянии устройства по фронтам сигнала, т.е. когда по адресу тега "0"-появляется одно сообщение, а когда там "1", то другое. При этом, в первом случае в свойствах сообщения стоит "галочка" о срабатывании по отрицательному фронту, а во втором она конечно же снята. Если опрашивать только один тег на наличие по адресу 0 или 1, то срабатывает только на "1", а на отрицательный фронт-нет. Подскажите, как с этим бороться, т.к. не хочется использовать один тег для регистрации "1", а второй-для регистрации "0".

У меня WinCC 5.0 SP2
Re: WinCC и Alarm Login
Олег; 9.4.02

Придется создать два тега, ссылающиеся на один и тот же сигнал и регистрировать сообщения у одного тега по положительному фронту, а у другого по отрицательному. Проблема в том, Alarm Logging (будь он неладен)просматривает список сообщений и ищет первое, которое привязано к тегу, а остальные игнорирует. В документации этого я не нашел, но по опыту работы всегда так происходит еще с V4.02.

Re: WinCC и Alarm Login
Колпащиков Сергей; 9.4.02

Здравствуйте всем кто читает!

Собственно готового решения предложить не могу.
Но когда разрабатывали систему сообщений под свой проект родилась идея, но довести ее до ума (или сказать что тупик) нет времени.
Идея состоит в следующем: если у Вас есть битовое сообщение то фактически формируются сообщения как на положительный так и на отрицательный фронт come in и went out. Таким образом если подменять тексты сообщений то все бы неплохо работало.
Вопрос как подменять? Впринципе поддерживается подстановка в сообщение значений Tag-ов.
Но ват как менять значения ???
(Толи Action вешать - так ведь умрешь, толи пытаться анализировать в обработчике сообщений через Global Script)

Если взойдете попробовать напишите пожалуйста что получилось.
Спасибо.
Re: WinCC и Alarm Login
Костенич Дмитрий; 12.4.02

To: Колпащиков Сергей

Идея, в принципе, рабочая. Подменять тексты конечно же нужно в GMsgFunction. Правда, с сообщением сам текстовый блок не шлется, п.э. нужно его прочитать из таблицы с конфигурацией (сейчас не помню из какой именно).
НО!!! Все сообщения должны сохраняться в архиве, с возможностью просмотра в оффлайне - здесь корректность сохраненных значений никто гарантировать не сможет.

С уважением ко всем.
Re: WinCC и Alarm Login
Колпащиков Сергей; 12.4.02

То: Костенич Дмитрий

Если текстовый блок жестко прошит, то он должен браться по номеру из Text Library (TXTTable). И пожалуй если даже его удасться подменить online, то в offline он не изменится.
Другое дело если текстовый блок сообщения настроен с отображением значения Tag-а. Меняя значение TAG-а меняется текст сообщения и значение TAG-а на момент сообщения дожно сохранятся в таблице-архиве сообщений(MSArcShort). Причем при настройке сообщений можно подцеплять текстовые TAG-и.
??????????
Но ставит в тупик тот факт, что поля для хранения значений PValue1..10 определены в таблице MSArcShort как Double!!!
??????????

Вот такая несуразица.


text

Скрыть Control Center
Андрей А.; 28.3.02

При запуске WinCC с входом в RunTime окно управления проектом Widows Control Center невидим,но висит на заднем плане. Иногда,при возникновении какой-нибудь ошибки или случайного нажатия сочетания клавиш используемых Windows NT(например,ALT-F4),происходит выход из RunTime. При этом окно управления проектом становится на передний план и с проектом можно делать все что угодно,а также через него можно выйти на содержимое дисков.

Так вот,как решить эту проблему раз и навсегда.
Re: Скрыть Control Center
Александр Родин, ООО "Нева Электрик"; 28.3.02

Заходите в Control Center в свойства компьютера, открываете закладку Parameters и ставите все галочки в разделе Disable Keys галочки, потом открываете закладку Graphics-Runtime и там ставите все галочки в разделе Turn-Off. После этого при запущенном рантайме не воспринимаются виндовые сочетания клавиш.

Фича: Под WinNT Ctrl-Alt-Del все-таки воспринимаются... %)

Не знаю, отключаются ли Win-Keys как-нибудь на клавах ? Хотя под WinNT они все-равно не работают... :)
Re: Скрыть Control Center
Александр Туманов; 28.3.02

После выхода в RUN-TIME WiNCC EXPLORER можно закрыть отдельно.

Re: Скрыть Control Center
Александр Родин, ООО "Нева Электрик"; 28.3.02

Это на какой версии Control Center можно закрыть независимо от рантайма ? Если закрыть Control Center, то и WinCC-Runtime тоже закроется... А при следующем запуске Control Center сразу стартует рантайм...

Не закрывается СС отдельно... специально проверил только что.. %)
Re: Скрыть Control Center
Alexis; 28.3.02

Стопудово закрывается :))

Оно предлагает Close project and exit WinCC Explorer или просто Exit WinCC Explorer.
А версия у меня WinCC 5.0 SP2
Re: Скрыть Control Center
Александр Родин, ООО "Нева Электрик"; 29.3.02

а.. точно... на 5-й версии закрывается... %))))))

CTRL-ALT-DEL,CTRL-ESC,ALT-F4,версия WinCC
Андрей А.; 1.4.02

Сочетание клавиш CTRL-ALT-DEL WinCC блокирует капитально-это проверено неоднократно,но CTRL-ESC все равно работает. У меня в реестре WinNT эти клавиши настроены на открытие менеджера задач,хотя это не совсем хорошо в смысле безопасности,но как же тогда закрыть подвисший WinCC.

Кстати,а как часто у вас подвисает WinCC.
По сочетанию клавиш ALT-F4 галочка в Turn Off не помогает. Если их нажать, то все равно происходит закрытие Runtime, причем кнопка активации в WinCC Explorere остаётся недоступной серой, как будто Runtime запущен.
Чтобы исключить выход из Runtime,я назначил это сочетание для функции LogOff,тем более что у нас реализована автоматическая регистрация оператора простым нажатием кнопки на картинке.
Версия WinCC у нас 4.02 с сервиспаком 2.
Вопрос: Можно ли просто скопировать утилиту Autostart из пятой версии WinCC в четвёртую или это бредовая идея.
Re: Скрыть Control Center
Костенич Дмирий; 12.4.02

Вопрос: если такая стремная ситуация, то зачем вообще запускать WinCCExplorer? Не проще ли написать простенькую програмку с использованием ODK, которая открывает конкретный проект и запускает его в RunTime? Вызовы ODK будут работать и без загруженного WinCCExplorer'а (это проверено).

С уважением ко всем.
Re: Скрыть Control Center
Костенич Дмитрий; 12.4.02

Маленькое дополнение - при установке WinCC можно указать ставить только компоненты RT.

С уважением ко всем.


text

Проблемы с WinCC & AS511
Alexander; 27.3.02

На машине установлен Win2000 и WinCC V5.0+sp2. Связь с 4 контроллерами ведется по интерфейсу AS511. Под каждый канал связи отведен собственный COM порт со своим прерыванием.

Проблема: После запуска проекта вначале все идет нормально, связь есть.
Потом спустя 20-40 минут (время постоянно разное) начинают отваливатся каналы. Причем в диагностике - ничего. Связь есть (только обмена данными нет).
Если кто-нибудь сталкивался с подобным, объясните что не так и почему связь исчезает именно через время.
Re: Проблемы с WinCC & AS511
Любитель Симатика; 28.3.02

В WinCC V5.0+sp2 под Win2000 канал AS511 не работает. Т.е. он работает, но разрешения к использованию нет. См. readme на WinCC V5.0+sp2.

Нормально этот канал разрешен под WinCC 5.1.
Re: Проблемы с WinCC & AS511
Alexander; 28.3.02

Спасибо. Прочитал. Сименс опять продает софт, который не соответствует своим параметрам.

Вопрос: Где можно взять V5.1 (не купить, уже официально купленых 5.0 - 6шт.) или скачать, можно демку.
Re: Проблемы с WinCC & AS511
siemargl; 10.4.02

А WinCC v4.02 работает gut ;-)

Re: Проблемы с WinCC & AS511
Любитель Симатика; 11.4.02

Об этом то раньше надо думать. Перед покупкой софта. Нужно читать соответствующую инфу.

Re: Проблемы с WinCC & AS511
Alexander; 11.4.02

Всем большое спасибо за "помощь".

Через 2 недели получу новую версию софта.
Проблему решил довольно просто.


text

ТР 070
Биленко Алексей; 10.4.02

Возможно ли подключение и работа двух ТР 070 на один S7-224-й контроллер?

Re: ТР 070
Юрченко Владимир; 10.4.02

Нет, можно подключить только один TP 070.


text

Динамические графики в WimCC 5.1
OrionS35; 10.4.02

- Создание динамических графиков в WinCC 5.1 : добавление тренда по

выбору и изменение свойств тренда программным способом.
От функции ODK не могу получить надежных результатов.
Re: Динамические графики в WimCC 5.1
Alexis; 10.4.02

2 OrionS35

Нормально все через ODK-шные функции (PDLRTSetPropEx) добавляется и конфигурируется в стандартном WinCC-евом Online Trend Control-е :)


text

ProTool/Pro Runtime v5.2+SP3 лживый OPC сервер
Николай Михалев; 18.2.02

Здравствуйте,

Подключился к Protool как к OPC серверу. Создал группу с периодом обновления 1 сек. Вижу, что клиент получает данные с заданным периодом, но неправильным штампом времени. Вот реальные значения штампа времени за 10 сек.: 38.0; 39.999; 40.0; 41.0; 42.999; 43.0; 44.999; 45.999; 46.0; 47.999; 48.0.
Re: ProTool/Pro Runtime v5.2+SP3 лживый OPC сервер
Юрченко Владимир; 4.4.02

А цикл обновления этого тега в проекте ProTool у Вас какой? Скорей всего 2 секунды, что и показывает штамп.

Re: ProTool/Pro Runtime v5.2+SP3 лживый OPC сервер
Николай Михалев; 5.4.02

У меня нет исходника - цикл обновления тега не знаю. Но период обновления группы я задавал и 2 и 10 сек. В любом случае целая часть секунд в штампе времени тега - правильная, а дробная - 0 или 999 - случайным образом.

Re: ProTool/Pro Runtime v5.2+SP3 лживый OPC сервер
Юрченко Владимир; 5.4.02

OPC сервер ProTool дает штамп того времени , когда он отправил данные клиенту . К сожалению он не сохраняет и не передает штамп времени из контроллера или из другого OPC сервера (проверено на WinAC OPC). Впрочем также работает и OPC сервер WinCC

Так что если уж вам так важен точный штамп времени, то лучше использовать Net OPC сервер. Но это опять с какой точностью – на самом деле и там штамп времени будет ставиться сервером по мере чтения их сети, а не когда они изменились реально в контроллере. Разница я думаю небольшая, в зависимости от параметров и типа сети , но где то в пределах 10-100 мс, не меньше. Можно конечно заносить в буфер в контроллере данные с меткой времени и считывать их- есть специальная функция SFB 37 AR_SEND и соответствующие настройки в WinCC, но это уже отдельный разговор…

Re: ProTool/Pro Runtime v5.2+SP3 лживый OPC сервер
Николай Михалев; 8.4.02

Чтобы исключить влияние сети, запустил проект из под эмулятора FwSim.exe - картина та же.

Решил повнимательнее взглянуть на штамп времени архивных данных - для сравнения с штампом времени OPC тегов. Вот последние 4 цифры колонки с сотнями миллисекунд: 5080, 5196, 5312, 5430, 5546, 5661, 5778, 5894, 6010, 6126.
Получается, что Protool знает время получения тегом значения с точностью 100 мсек. но в штамп времени OPC тега ничего, кроме 0 и 999 мсек не пишет.
Мне важен штамп времени менее похожий на результат ошибки в программе - если OPC сервер показывает 0 и 999 мсек., значит разрешающая способность метки времени составляет 1000 - 999 = 1 мсек. Почему же хоть иногда не проскальзывают значения отличные от 0 и 999?
Кстати, разработчики проекта сказали, что период записи в архив задан 10 сек., но фактически время между моментами записи составляет в среднем 519,6 - 508,0 = 11,6 сек.


text

WinCC и Profibus DP Slave
Иван Данилушкин; 5.4.02

Здравствуйте!

Скажите пожалуйста, можно ли привязать тэг к DB контроллера серии S7-300, использующегося как интеллектуальное slave устройство (Intelligent DP Slave)?

С уважением.

Re: WinCC и Profibus DP Slave
Евгений Трунов; 8.4.02

Области памяти DB и прочие (М, I, Q) вводятся только на уровне протокола S7. При работе по протоколу DP необходимо узнать соответствие этих блоков памяти адресации, принятой в протоколе DP.


text

Обсудим способы оптимизации WinCC и Windows.
Александр Туманов; 8.4.02

Господа! Давайте обсудим здесь все взможные (кому что помогло) способы оптимизации проекта WinCC 5.0 SP2 и настроек Windows 2000 можно реализовать. Конфигурация: четыре сервера (Windows 2000 Server, WinCC Server + Web Navigator, CP5613-протокол S7 PROFIBUS, сетевые карты 3COM Ethernet), два мульти-клиента ко всем четырем серверам и четыре толстых клиента-юзера (по два на два из 4 серверов), 10 Web-клиентов, количество тегов - по 1500 на двух серверах и по 500 на других двух серверах.


text

WinCC и Long-Term Archiv
Сергей; 6.4.02

Здравствуйте...

Подскажите кто знает, как настроить долгосрочный архив в Alarm Login. Методика описанная в документации не срабатывает.
Спасибо...


text

ProTool Simulator
Александр Туманов; 26.3.02

Как в симуляторе ProTool имитировать нажатие глобальных функциональных кнопок К1...К10 для ОР170В?

Re: ProTool Simulator
Юрченко Владимир; 3.4.02

В меню System запустите окно Screen/Keys, тогда будет доступ к программированию K1-K10.

Re: ProTool Simulator
aim; 4.4.02

Ув. админы

Уберите плиз пред-й ответ деб..
Вопрос достаточно актуален, т.к. в процессе симуляции действительно доступна симуляция только фунциональных клавиш.
Вопрос не опрограммировании, а о режиме симмуляции !!!
Re: ProTool Simulator
Юрченко Владимир; 4.4.02

В ProTool 6.0 симуляция есть.

Извини что не проверил на предыдущей версии.


text

Обмен данными через ОРС
Москалев Михаил; 1.4.02

Подскажите,как можно прочитать значения процессных тегов WinCC в Excel, через OPC сервер.

С уважением, Михаил.
Re: Обмен данными через ОРС
Юрченко Владимир; 3.4.02

Надо писать программку- скрипт на VBA.

Пример могу выслать по е-mail.


text

Multi-User или Multi-Client
Александр Туманов; 2.4.02

Реализована конфигурация WinCC Multi-User (WinCC 5.0 SP2, Windows 2000 Server) пока на одном сервере (CP5613+3COM) и двух клиентах-юзерах (3COM), которая тормозит и зависает (наиболее вероятная причина - чрезмерный трафик через Ethernet).

Есть ли смысл переделать эту конфигурацию в Multi-Client с двумя мульти-клиентами, каждый из которых будет обрабатывать свою часть тегов (которые не пересекаются). Уменьшится ли трафик в такой конфигурации , поскольку в мульти-юзерной конфигурации каждый клиент получает весь объём тегов - как свой так и другого клиента (хотя объекты управления у них разные).

Re: Multi-User или Multi-Client
Михайлин Сергей; 2.4.02

Что-то я не верю, что при одном сервере и двух клиентах сетка Ethernet тормозила! Даже на обычном 3Сом-е. Народ ставит до 3 серверов и 10 клиентов и нормально. Сколько тегов на сервере? Скорее всего дело в настройках или недостаточной оптимизации проекта. Можно и нужно организовать кеш картинок, можно уменьшить кол-во отображаемых переменных на каждой картинке, оптимизировать архивы и саму сеть наконец. Это все в доках описано. Смысла переносит на МультиКлиента нет никакого: кол-во тегов в сети все равно не уменьшится, а кол-во серверов увеличится.


text

Автозагрузка RunTime(WinCC)
Андрей А.; 28.3.02

Существует ли ключ (типа /*) для запуска WinCC автоматически в RunTime,даже если в предыдущем запуске не был в RunTime.

Re: Автозагрузка RunTime(WinCC)
Любитель Симатика; 28.3.02

Существует утилита специально для загрузки проекта в RunTime без запуска ControlCenter. Называется она AutoStart.

Re: Автозагрузка RunTime(WinCC)
Андрей А.; 28.3.02

И где же достать магическую утилиту AutoStart.Очень буду признателен.

Где взять утилиту AutoStart
Андрей А.; 28.3.02

И где же достать магическую утилиту AutoStart.Очень буду признателен.

Re: Автозагрузка RunTime(WinCC)
Александр Туманов; 28.3.02

Autostart уже устанавлена вместе с WinCC:

жми кнопку ПУСК-SIMATIC-WINCC-AUTOSTART.


text

Проблема регистрации времени в WinCC
Шихарбеев Михаил; 15.3.02

Здравствуйте.

Недавно узнал о прекрасном программном продукте WinCC и сразу начал его изучение.
По роду своей деятельности мне приходится иметь дело с устройствами автоматизации
произведенными фирмой SIMENS. Работаю я на Иркутском Пивоваренном Комбинате и
все производство опирается на контроллера Simatic5.
При разработке проекта на WinCC я столкнулся с некоторыми проблемами. Сама система
достаточна сложна, а доступной литературы не хватает.
Конкретная задача состоит в следующем. Необходимо проследить простои оборудования. Нужно архивировать только время останова агрегата и продолжительность его простоя. Tag, отслеживающий событие работы или не работы агрегата я сделал. Вот пока и все. Я добросовестно прочитал всю документацию, которая была, но так и не обнаружил доступные средства работы со временем. Помогите пожалуйста разобраться в этой проблеме. Желательно с примером.

За ранее благодарен.
Михаил Юрьевич.
E-mail: shiha2@yandex.ru

Re: Проблема регистрации времени в WinCC
aaaaaaaaaaaaaa; 15.3.02

jhdtjjsdyjytsdjrtjrtsdt

Re: Проблема регистрации времени в WinCC
Alexis; 18.3.02

Дык и архивируй этот тэг по изменению... вот и получишь продолжительность работы/простоя по разнице во времени между двумя записями в базе.

А как достать из базы, дык это как сможешь :) либо через sql-запросы, либо читай odk.
Re: Проблема регистрации времени в WinCC
Александр Туманов; 18.3.02

Step by Step:

1. создать тэг "Работа"
2. Создать в Alarm Logging сообщение "Простой" с галочкой "Архивировать по отрицательному фронту"
3. Создать в Graphics Designer окно с объектом WinCC Alarm Control и в нём выбрать Message Block "Длительность" (Duration)
4. В RunTime в поле Duration будет время простоя оборудования.
Re: Проблема регистрации времени в WinCC
Dr. Kren; 23.3.02

Привет всем!!!

Разрешите встрять в базар.
"Создать в Alarm Logging сообщение "Простой" с галочкой "Архивировать по отрицательному фронту" ничерта не фурычит.
Проверено на WinCC 5.01+sp5

С уважением ко всем...

Re: Проблема регистрации времени в WinCC
Олег; 26.3.02

Не фурычит, если тэг используется в Alarm Logging дважды в списке сообщений. Ищется первое сообщение по этому тэгу. Остальные игнорируются.


text

Alarm Logging Filter
Leonid; 28.12.01

может кто подскажет, как сделать чтобы в фильтре AlarmLoging можно

было ставить более чем один символ при фильтрации по текстовому
сообщению. У меня пока так: Filter.szTB[-1][MSG_MAX_TB_CONTENT+1]='C';

Re: Alarm Logging Filter
Александр Туманов; 26.3.02

Это работает:

strcpy(Filter.szTB[0], "Мама мыла раму");


text

Как работает Tag Export в Storage?
Александр Туманов; 11.1.02

Запускаю опцию Storage (WinCC V5 SP2, Windows 2000 Server), выбираю Configuration, Data Carrier и хочу выбрать теги для экспорта (думаю, что так же как в Sybase Control Center), но вижу только пустое поле - выбирать не из чего. Как быть?

Re: Как работает Tag Export в Storage?
Fog; 26.3.02

Storage работает только с LongTerm архивами и сразу со всеми, поэтому выбирать не приходится.


text

Распайка кабеля для программирования ОР27
Александр Туманов; 20.3.02

Где можно найти распайку кабеля для программирования панели оператора ОР27?

Re: Распайка кабеля для программирования ОР27
Fog; 25.3.02

Используй стандартный TTY-кабель.

Re: Распайка кабеля для программирования ОР27
Чистяков Дмитрий ОАО "СеверСталь"; 25.3.02

А вообще распайка всех разъёмов панели OP27 дано в приложении B руководства по OP27.

Там расписываются вс типы интерфейсов:
RS-232 и TTY


text

WinCC 5.1 и AS511
Сергей; 22.3.02

Здравствуйте!

Слышал о выходе WinCC 5.1. Отдельным пунктом в новинках этой версии выделена работа AS511 под Windows 2000. Мне интересно, что именно улучшенно в AS511, т.к. и в WinCC 5.00 SP2 под Windows 2000, AS511 и так уже работает и относительно неплохо.

Подскажи, пожалуйста, кто знает.

Спасибо

Re: WinCC 5.1 и AS511
Юрченко Владимир; 25.3.02

Я наоборот слышал от нескольких человек, что под Windows 2000 AS511 для WinCC 5.0 не работает или работает неустойчиво. Как Вы добились работы AS511 под Windows 2000? Поделитесь информацией - у Вас какая Windows русская или английская и какой SP для Windows?


text

Контроль за состоянием CPU
Парфентьев Константин; 22.3.02

Подскажите, пожалуйста, как в WinCC runtime организовать контроль за состоянием CPU? Есть необходимость формировать для оператора сообщение об отсутствии соединения с контроллером.

Re: Контроль за состоянием CPU
Михайлин Сергей; 22.3.02

Пример 1

Надо завести тестовый тэг(двойное слово) и тестировать его периодически на качество с помощью GetTagDWordState("<тестовый тэг>", &dwState) и если &dwState будет ошибочно то значит связи нет! Ошибки могут быть разные, так что см. Хелп.

Пример 2
Если имеется установленная и авторизованная опция Basic Process Control, то можно воспользоваться редактором LifeBeat Monitoring. Она все сделает сама: и картинку(примитивную конечно), и тэг, и скрипт.
Re: Контроль за состоянием CPU
Alexis; 22.3.02

Кстати, после трансфера, в WinCC и так появляются сообщения о состоянии CPU.

И еще одну примочку видел на https://itps-mall.erlm.siemens.de/cgi-bin/index.pl?show=PCS7/WinCC%20Tools
называется CPU-Diagnose, кстати с ней никто не разбирался?
Re: Контроль за состоянием CPU
Михайлин Сергей; 22.3.02

Я разбирался!

Это фича в основном под PCS7. Там только поледние версии процессоров 414 и выше поддерживаются. Штука неплохая: показывает общее состояние, буфер диагностики, состояние всех светодиодов. Но можно это и самому написать при желании. Описаловку могу выслать кому надо или кто не добрался по ссылке.

Re: Контроль за состоянием CPU
Парфентьев Константин; 25.3.02

Спасибо за помощь! С функциями GetTag...State() все работает так, как я и хотел.


text

Библиотека графических об'ектов WinCC
Шихарбеев Михаил; 15.3.02

Есть ли библиотеки готовых графических об'ектов для WinCC, в частности для

пищевой промышленности
Re: Библиотека графических об'ектов WinCC
Михайлин Сергей; 19.3.02

Библиотека готовых элементов ессно есть, но она непривязана к конкретным отраслям. Это нереально на все отрасли предлагать готовые картинки. 100% их меняют потом. А всяких труб, танков, моторов, вентиилей, по всякому нарисованных, с анимацией и без, цветных и ч/б, 3Д и 2Д, НАВАЛОМ!!!!!!!

Нажми кнопочку на панели ГрафикДизайнера с коробчкой в которую что-то сыпется. ;-))
Re: Библиотека графических об'ектов WinCC
Александр Родин, ООО "Нева Электрик"; 19.3.02

2 Михайлин Сергей:>

интересно, а где вы в той библиотеке нашли символы с анимацией ?... %)
или какой опцией она включается ?...
Re: Библиотека графических об'ектов WinCC
Михайлин Сергей; 19.3.02

Под анимацией я имел ввиду не мультики, а возможность заливки, моргания и тд. Согласен, анимацией в полном смысле сложно назвать! Скажем, динамическое изменение свойств. :-)

Re: Библиотека графических об'ектов WinCC
Александр Родин, ООО "Нева Электрик"; 21.3.02

А, кстати, существенный вопрос к представителям Siemens.de (модно теперь так обращаться стало.. :).

Будет ли предусмотрена возможность включения анимации в графических библиотечных символах, или хотя бы возможность использования в GraphDesigner изображений с анимацией... например Animated GIF... А?

С уважением ко всем.


text

Alarm Logging + WinCC Alarm Control = ?
Парфентьев Константин; 20.3.02

Почему при конфигурировании таблицы WinCC Alarm Control портятся названия блоков сообщений, заданные предварительно в редакторе Alarm Logging? Кто-нибудь встречался с такой проблемой?

Re: Alarm Logging + WinCC Alarm Control = ?
Евгений Трунов; 20.3.02

Да. По всей видимости, там проблемы с сохранением названий блоков сообщений в Text Library. Они иногда двоятся, а иногда затирают другие (затираются другими). Может проявляться при наименовании полей русскими буквами, вставке/удалении полей. Мне помогала тщательная вычистка и корректирование соответствующих записей Text Library вручную.

Re: Alarm Logging + WinCC Alarm Control = ?
Парфентьев Константин; 21.3.02

Спасибо!

Действительно в Text Library после многочисленных экспериментов с Alarm Control у меня накопилось порядка 200 "левых" записей.


text

Координаты мышки в WinCC RT
Костенич Дмитрий; 19.3.02

Здравствуйте.

Я собственно с таким вопросом - в событии по нажатию на кнопку мышки мне нужно обрабатывать экранные координаы указателя мыши (например чтобы отобразить контекстное меню). Координаты передаются в качестве параметров в скрипт; все бы хорошо, но они даются относительно pdl-ки, непосредственно в которой живет графический объект.
Теперь предположим такую ситуацию - pdl-ка имеет размеры 400х3300 и при ее отображении разрешена прокрутка.
Я выкрутился из этой ситуации вставив такую pdl-ку в объект PictureWindow на другой pdl-ке и использовав свойства "Picture Offset X" и "Picture Offset Y" для получения координат начала видимой области pdl-ки.
А что делать если это главная pdl-ка для RunTime? И вообще не хотелось бы городить лишнюю вложенность...

Может знает кто как бы тут выкрутиться?
Заранее спасибо.

Re: Координаты мышки в WinCC RT
Евгений Трунов; 20.3.02

Если нет желания возиться с пересчетом координат вложенных окон, вызови в событии OnClick или OnL(R)ButtonDown(Up) функцию GetCursorPos из user32.dll. Получишь экранные координаты указателя мыши.


text

Modbus для WinCC
Александр Туманов; 20.3.02

Имеем WinCC V5.0 SP2 с драйвером для протоколоа Modbus и четыре расходомера "Взлёт" (УРСВ-010М), подключенных по RS485 (преобразователь RS485-RS232 - ADAM-4510 в шкафу сервера). Настройки Modbus: протокол - RTU, Stop Bits - 1, Parity - NONE, Baudrate - 1200, Serial Port Name - COM2. Опрос тегов - регистров (по два тега на станцию) организован в Action (5 сек.)по очереди - сначала станции с адресом 1, потом - 2 и т.д. Проблема в следующем -считывание новых значений тегов происходит не в каждом цикле (причём, чем старше адрес станции - тем реже), пауза между разными значениями тегов доходит до 10 минут (при цикле 5х4=20 сек.).


text

Многоязыковая поддержка в WinCC
Олег; 15.3.02

Привет всем!

Разрабатываю проект с поддержкой English и Russian.
В Alarm Logging создаю сообщения для Russian. Смотрю в Text Library, а текст этих сообщений помещен в English!
Затем в Alarm Logging создаю сообщения для English, а в Text Library нахожу их
в Russian.
Кто-нибудь сталкивался с такой проблемой?
Re: Многоязыковая поддержка в WinCC
Михайлин Сергей; 19.3.02

Просто надо контролировать, в каком языке ты сейчас находишся и редактируешь. В АлармЛогинге как и в ГрафикДизайнере есть менюшка для выбора текущего языка.Хочешь занести русские сообщения переключись в русский, и наоборот.

Re: Многоязыковая поддержка в WinCC
Олег; 20.3.02

Ну ты вообще меня за инвалида держишь!

Re: Многоязыковая поддержка в WinCC
Михайлин Сергей; 20.3.02

Гы-гы! ;-)

Сорри если обидел! :-(
Но ты же не написал, что КОНТРОЛИРУЮ А ВСЕ РАВНО ... Мало ли...


text

WinnCC и база данных в Access
Alexandr; 27.2.02

Вопрос вот в чём, надо на WinCC привязать графический экран для вывода статистики из базы данных в формате Access, как реализовать это

P.S. только начал заниматься этим, поэтому просьба не пинать за ламерский вопрос :)
Re: WinnCC и база данных в Access
Дмитрий; 5.3.02

Я бы написал ActiveX в Visual Basic, который подключен к базе Access, и вставил его в WinCC.

Re: WinnCC и база данных в Access
Vetkin Dima, VAZ; 16.3.02

привет, я использовал DAO объекты

таким образом:
скрипт WINCC
{
__object *dbe,*db, *rs;

dbe=__object_create"DAO.DBEngine.36");
db=dbe->OpenDatabase("....asd.mdb);
rs=db->OpenRecordset("имя табл");

rs->имя поля=111;
rs->Update();изменить например

rs->Close();
db->Close();
__object_delete(rs);
__object_delete(db);
__object_delete(dbe);
}
все прекрасно, программить очень удобно
НО, через какое то время(ну месяц например) непрерывной работы (тоже статистику веду) DAO кричит что открыто слишком много объектов и все - тока перезапуск компа, как будто я чего забываю убирать за собой
кто ходил по этому посмотрите а?, где лажа?

Удачи! ICQ 103398038


text

Фильтр для Alarm на Multi-Client.
Александр Туманов; 14.3.02

Требуется написать настраиваемый фильтр

с помощью функции AXC_SetFilter на станции Multi-Client (как на сервере написать - знаю). Проблема в том, что на мульти-клиенте в системном фильтре нельзя выбрать те классы и типы, которые есть на серверах, а только класс Error и типы Alarm, Warning, Failure (но для Text Blocks можно ?).


text

WinCC+Industrial Ethernet+ProfiBus
Маруськевич Сергей; 12.3.02

У нас появилась необходимость объединить две АСУТП, а именно:

- состав первой: два 400-х контроллера + одна станция визуализации (проект на WinCC) с платой CP5412 объединены в сеть ProfiBus-ом;
- состав второй: два 400-х контроллера + пять станции визуализации (проект на WinCC) с платами CP1613 объединены в сеть IndustrialEthernet
Цель: объединить аппаратно две информационных сети (как?) + объединение 2-х проектов на WinCC в один так, чтобы любая станция визуализация видела любой контроллер (в сети ProfiBus или в сети IndustrialEthernet). Все шкафы с контроллерами находятся рядом. Какое «железо» необходимо закупить для этого. Спасибо за советы

Re: WinCC+Industrial Ethernet+ProfiBus
Чистяков Дмитрий ОАО СеверСталь; 12.3.02

Здесь несколько вариантов

1. Установить два сервера WinCC каждый в своей системе и подключать клиентские места как Multiclient
2. Сделать один WinCC сервер, вдуть туда и IE(CP1613), и PB(CP5412). А все остальные станции в режиме клиент-сервер.
3. Купить в каждую станцию ещё по недостающему CP1613 или CP5412. Но это самый дорогой вариант.

Поскольку шкафы находяться рядом, то видимо будет проще сделать второй вариант.
А вот как это сделать можно посмотреть на слайдах и в документации.

В принципе, вообще, можно было не покупать дорогие CP1613 в каждую станцию визуализации. При работе в режиме клиент-сервер там прекрасно работают 3Com, Intel и т.д.
А на вырученые средства можно было приобрести опцию WinCC-server. Да ещё и на крутой сервер бы осталось.

Re: WinCC+Industrial Ethernet+ProfiBus
Любитель СИМАТИКа; 13.3.02

А еще я слышал, что появился какой-то новый модуль IE/PB. Это что-то типа аппаратного моста между этими двумя сетями. Подробностей не знаю, надо смотреть, но такая штука есть.

To Любитель Симатика
Маруськевич Сергей; 13.3.02

Про данный модуль я тоже знаю. Но у меня есть подозрения, что он только для программатора (программиста) заточен (для диагностики перифирии на шине ProfiBus-DP например). Может я и ошибаюсь конечно. Спасибо


text

DMSendApplicationData
Alexis; 18.2.02

Привет Всем!

Кто-нибудь баловался с subj-ем?
Вопрос: как обмениваться данными между приложениями крутящимися на разных компах используя subj? (обмен между приложениями на одном компе с использованием DMSendApplicationData работает)

Re: DMSendApplicationData
Alexis; 10.3.02

Вопрос снимается. Siemens сказал что у них баг. Функция работает только в пределах одного компьютера.


text

AXC_SetFilter - фильтр для Alarm Control
Александр Туманов; 1.3.02

Существует ли более подробное описание этой функции, чем то, которое дано во встроенном Help? В частности, не понятно как задать фильтр для нескольких классов или по времени (как написать - понятно, но реально не работает).

#pragma code("kernel32.dll");
void GetLocalTime(SYSTEMTIME* lpst);
#pragma code();

SYSTEMTIME time_from, time_to; //
BOOL ret;
MSG_FILTER_STRUCT Filter;
CMN_ERROR Error;

//Reset the filter struct memset
( &Filter, 0, sizeof( MSG_FILTER_STRUCT ) );

//Set the filter name strcpy
( Filter.szFilterName, "table");

Filter.dwFilter = MSG_FILTER_DATE | MSG_FILTER_DATE_FROM | MSG_FILTER_DATE_TO | MSG_FILTER_TIME | MSG_FILTER_TIME_FROM | MSG_FILTER_TIME_TO;
time_from.wYear = GetTagWord ("Year_from");
time_to.wYear = GetTagWord("Year_to");
time_from.wMonth = GetTagWord("Month_from");
time_to.wMonth = GetTagWord("Month_to");
time_from.wDay = GetTagWord("Day_from");
time_to.wDay = GetTagWord("Day_to");
time_from.wHour = GetTagWord("Hour_from");
time_to.wHour = GetTagWord("Hour_to");
time_from.wHour = GetTagWord("Minute_from");
time_to.wMinute = GetTagWord("Minute_to");
time_from.wSecond = GetTagWord("Second_from");
time_to.wSecond = GetTagWord("Second_to");

Filter.st[0] = time_from;
Filter.st[1] = time_to;

ret = AXC_SetFilter("alarm","table",&Filter,&Error);

Re: AXC_SetFilter - фильтр для Alarm Control
Alexis; 1.3.02

Описание в ODK такое же как и во встроенном хелпе.

Я не пробовал задавать фильтр на Alarm Control, но пробовал в своих софтинках (надо было сбрасывать сообщения за определенный промежуток времени, но в читабельном виде в отличие от MSRTBackup). Фильтрация по времени работает нормально (заполняем st[] и dwFilter=MSG_FILTER_DATE|MSG_FILTER_TIME). Для классов пока не пробовал (позже займусь :), но вроде надо так заполнять: dwFilter|=MSG_FILTER_CLASS
dwMsgClass= устанавливай бит по номеру класса (Alarm=0x01 Warning=0x02 и тд по ИЛИ)и заполняй соответственно
dwMsgType[номер класса]= усанавливай биты по номеру типа (AH=0x01 AL=0x02 и тд по ИЛИ). Если получится пиши... Как сам попробую напишу :)

Re: AXC_SetFilter - фильтр для Alarm Control
Евгений Трунов; 1.3.02

Фильтрация по времени может не работать для Short-Term архивов. Для Long-term у меня проблем с фильтром по дате/времени не было.

Re: AXC_SetFilter - фильтр для Alarm Control
Alexis; 7.3.02

Кстати, можно же написать функцию GetFilter и разобрать полученную структурку, тем самым научится задавать нужные фильтры :)


text

WinCC и координатор S5
Alexander; 7.3.02

Можно ли где-нибудь узнать как при связи с контроллерами S5 через координатор типа 6ES5923-3UC11 получить доступ одновременно к двум контроллерам в двухпроцессорной системе? В WinCC при создании соединения AS511 галочка есть, но она неактивна.


text

Как защитить проект WinCC?
Dr. Kren; 5.12.01

Как защитить проект WinCC от редактирования?

Так, что бы лицо, не знающее пароль администратора проекта не могло внести в проект изменения.
Re: Как защитить проект WinCC?
Dr. Kren; 29.12.01

Так что?

Полная лажа ваш WinCC ?
Кто угодно может войти в проект имея права администратора рабочей станции (а с другими правами WinCC работать отказывается) и творить что угодно ?
А заказчик потом выворачивает руки разработчику. А разработчик от "товарищей" из Siemens не может добиться внятного ответа ?
Re: Как защитить проект WinCC?
siemargl; 3.1.02

0.Во-первых, сам лопух...

1.Нужно права только "power user"
2.Нужно при установке не ставить редакторы (RT-only)
3.абсолютной защиты (на уровне файлов) все равно нет.

Re: Как защитить проект WinCC?
Dr. Kren; 4.1.02

0. Во первых - на лопух мало похож. Лопухи в 2 метра ростом - редкость великая. Да и цвет лица здоровый, зеленого совсем нет.

1. Ну и что далее? Копируем файлы на носитель (достаточно *.PDL), изменяем на другой станции и забрасываем обратно. И ВСЕ !!!
2. Изолировать станцию? А как насчет архивирования проекта на случай слета станции? Передачи данных на другие станции объекта?

Это защита от "дурака". А "дураков" на взлом пректов на нанимают...

Для примера.

На обычном сахарном заводе в сутки перерабатывается в среднем более 200 тонн сахара-сырца. Изменяя прект проводим через программу лишних 2-3 тонны (2-3 % от объема).
За месяц имеем 60-90 тонн сырца. Что в денежном эквиваленте равно примерно 10 000 баксов.
Так что дело того стоит.

Так что, WinCC для разработки серьезных систем автоматизации и учета по уровню защищенности не годится ?
Re: Как защитить проект WinCC?
Максим Поджидаев; 8.1.02

Здравствуйте!

Последний вопрос мне тоже интересен. Например можно было бы использовать систему безопасности Windows как это делается например в MSSQL.
А в вашем случае необходимо,я думаю, отделить машины WinCC (закрытая сеть) от открытой сети. Связь открытой и закрытой сети должна контролироваться администратором (с помощью подручных средств :), шлюз например) За администратором смотрит отдел коммерческой безопасности :). Без администратора безопасности вы не обеспечите.
Re: Как защитить проект WinCC?
Dr. Kren; 10.1.02

To Максим Поджидаев

Весьма признателен за идею.
Но уж очень хотелось решить проблему только средствами WinCC. Но, как видно, не судьба...

Однако еще раз спасибо!

С уважением ко всем...
В том числе и "товарищам" из SIEMENS.DE

Re: Как защитить проект WinCC?
Михайлин С.; 15.2.02

Гы-гы! Про "товарищей" хорошо!!!

Пара заметок от "тамбовского волка" от siemens.ru
- программу, которая ворочает такими деньгами(считает сахер), т.е. сам счетчик никогда не загоняют на комп. Она должна крутится в контроллере. А то и штатный останов компа тоже приведет к потере/навару денег. А защитить ЦПУ проще и надежнее. ЭТО ГЛАВНОЕ! Точный расчет ТЭП должен быть жестко привязан к ходу течения процесса и не зависить от системы отображения. Если показатели передаются куда-то в другое место(на другой комп или прложение, то см. ниже по поводу сети и доступа)
- ессно, ставить блокировку системных комбинаций для RT и ставить также пароль Админа именно для RT. Это не даст потециальному ГАДУ выйти из RT и добраться до файлов с локальной машины. При этом минимизировать использование внешних программ.
-использовать автологон NT и автостарт RT
-выше высказанные предложения верны. Power User достаточно.
-ессно, если так все строго, то сеть АСУ должна быть несколько обособлена и ограничена в доступе. И здесь вопрос не к WinCC, а к СисАдмину.
-опять же, если так все строго, то помещение АСУ должно быть ограничено в доступе и это вопрос к службе безопасности предприятия. Если кто угодно может сесть за комп, тогда я не удивлюсь если сахара ваще не будет.
Так что хаить WinCC рано, она имеет необходимые (для нее) средства защиты, остальное надо продумать и реализовыватьна в общей системе АСУ ТП. На НПЗ его тоже ставят и ничего, бензин не вороют. Конечно, вскрыть можно все, но таких «дураков» интересует не сахар, а банки. ;-)))

Re: Как защитить проект WinCC?
Dr. Kren; 23.2.02

Всем привет!

To [Михайлин С.; 15.2.02]
Спасибо за разъяснения!
Несколько слов о вышесказанном.

>- программу, которая ворочает такими деньгами(считает сахер), т.е. сам счетчик никогда не загоняют на комп. Она должна крутится в контроллере.
Все бы хорошо, да система измерения веса установлена другой конторой и не имеет прямого канала для передачи данных в контроллер. Данные можно взять только через OPC.

> штатный останов компа тоже приведет к потере/навару денег
Как раз нет. При останове компа останавливается процесс управления подачей и выгрузкой. Смене не выгодно вести учет в ручную, так как в этом случае весь недостающий "сахер" вешается на дежурную смену.

>опять же, если так все строго, то помещение АСУ должно быть ограничено в доступе и это вопрос к службе безопасности предприятия
С этим порядок. Кто угодно за комп не сядет.

А решить проблему хотелось бы несколько иначе. А именно - задать пароль на право изменения проекта (пароль администратора), а пользователям дать права только на чтение. Тогда даже если проект перенесут на другую станцию (где имеется RC) не зная пароля администратора проекта внести изменения будет ОЧЕНЬ нелегкой задачей.

С уважением ко всем...
Re: Как защитить проект WinCC?
Чистяков Дмитрий ОАО СеверСталь; 26.2.02

Так а чем же Вам User Administrator не подходит.

Сделайте вход со станции под пользователем User Adm., которому разрешено, только картинки переключать. Для каких либо запрещённых оператору действий к кнопке(или другому объекту) привяжите авторизацию более высокого уровня. В общем далее по инструкции User Adm.
При этом запрещаете все комбинации системных клавишь.
С рабочего стола удаляются все иконки. Также удаляются все иконки из меню "Пуск".
Запрещаете доступ пользователю к сетевому окружению. При этом WinCC в режиме клиент-сервер работать всёравно будет.
Делеаете автологин с запуском WinCC.

У нас так все станции сделаны, т.к. соблазн побаловаться у технологов велик. И их не интересует производство, а просто поиграть-бы или ещё чего.
Re: Как защитить проект WinCC?
Alexis; 26.2.02

Дык вместо удаления иконок проще наверное с ключиком HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\"Shell"="Explorer.exe" поиграться...

Re: Как защитить проект WinCC?
Павел Берляков; 27.2.02

Вопрос состоит еще и в том, что при рестарте системы (а такое вполне может быть) автозагрузка идет достаточно медленно для того, чтобы успеть нажать CANCEL. После этого делай что хочешь.

Re: Как защитить проект WinCC?
siemargl; 6.3.02

Еще раз для сомневающихся.

По _официальной_ whitepaper от Microsoft - хоть какая-либо надежность может присутствововать только, если физического доступа с компьютеру нет.

Все остальное - "защита от дурака". А как известно, есть защита от дурака, но только не от изобретательного.
Re: Как защитить проект WinCC?
Александр Родин, ООО "Нева Электрик"; 6.3.02

2 Alexis:

Кстати, попробовал побаловаться с реестром... Результат весьма забавный... :)
Если иметь несколько профилей пользователя, то этот метод очень хорошо подходит. :)


text

EXEC SQL в Global Script
Александр Туманов; 20.2.02

Поддерживает ли интерпретатор С в WinCC команду EXECute SQL (выполнить команды SQL без вызова ISQL с обращением к файлу *.sql с кодом на SQL)?

Какую библиотеку нужно подключить?

Re: EXEC SQL в Global Script
siemargl; 6.3.02

то-же см. C:\SIEMENS\WinCC\aplib\db.h, dbimpl.h


text

Алексей М.
WinCC + SQL; 28.2.02

Возник вопрос по WinCC, помимо визуализации ТП, также необходимо взаимодействие с обычным MS SQL Server’ом, надо посылать ему стандартные SQL-запросы (select, insert и хранимые процедуры исполнять) причем при выполнении select надо результат запроса в wincc-теги получать. Это возможно стандартными средствами сделать? Писать для этого специальные DLL или EXE, работающие синхронно с WinCC, не хотелось бы из "стратегических" соображений.

Hапример, в InTouch есть встроенные "обертки" ODBC-функций. А в WinCC???

Re: Алексей М.
siemargl; 6.3.02

см.C:\SIEMENS\WinCC\aplib\db.h, dbimpl.h


text

AutoStartRT, проблемы
Павел Берляков; 27.2.02

Отчего могут быть проблемы с автозагрузкой приложения ?

Через некоторое время после начала загрузки появляется "Deactivate".
Такое бывает, если база данных имя.db или имяrt.db уже открыта в Sybase.
Еще я понял (мог быть и посообразительней), что несмотря на наличие Sybase7, база данных WinCC проекта (5-я версия) создана в предыдущей версии Sybase. Возможно это - еще одна причина проблем с AutoStartRT.
Кстати, даже при наличии базы данных
имяrt.db, сделанной с помощью ASA7.0 (reingeneering в Power Designer c разными добавками к стандартной базе) наблюдается такая ситуация - если написать строчку типа AutostartRT.exe путь active = YES и т.д.(точно не помню - строчка взята из системного реестра) и воткнуть ее в какой-нибудь bat-файлик, то он чаще всего, запускается без всяких криков. А вот штатно - не хочет. Was ist das, г-да из Siemens.de ?
В неминуемом стремлении улучшить то, что есть я, клнечно залез туда, куда не все заходят, но очень уж хочется использовать некоторые механизмы Sybase.
Тут недавно упоминали триггеры в связи с Alarm Logging'ом.
Давно возникла мысль - триггеры реагируют на INSERT INTO, UPDATE и т.д.
А что если использовать эту чудную возможнность для получения полей времени, когда куча логически, казалось бы связанных тегов, да еще от разных контроллеров... Это к вопросу о записи параметров.(в ближайшее время попробую)
Удачи всем
Re: AutoStartRT, проблемы
Товарищи из Сименс.ру; 27.2.02

Вам нужно ввести задержку между загрузкой ОС и автозапуском проекта.

Это можно сделать, например, написав bat-файлик с включить его в автостарт вместо MCP. Сименс, например, предлагает подобный файл. Читайте CustomerSupport или COmprehensiveSupport.

См. http://www.ad.siemens.de/simatic-cse

Re: AutoStartRT, проблемы
Павел Берляков; 27.2.02

Дык енто я и так понял. Но все равно, спасибо.


text

"Левые" сообщения с перечеркнутым временем
Харгелия Олег Резович, ЗАО "Искра-Энергетика""; 15.2.02

Так получилось, что у нас переодически возникают кратковременные (на 1-2сек)проблемы со связью между операторскими станциями и контроллерами (эти проблемы описаны в форуме в разделе контроллеров). При востановлении связи WinCC 5.0 SP2 придумывает порядка тысячи сообщений и присваивает им сама время (в журналах сообщений она это отмечает перечеркивание времени сообщения, т.е. контроллерного времени она не получила). Каждое сообщение заносится в базу со всеми тремя статусами (пришедшее, ушедшее, квитированное).

Стандартные ocx-объекты журнала сообщений не имеют соответсвующего фильтра, позволяющего отделить проблемные сообщения от нормальных. (Хотя в соотвествующей таблице RT-шной базы данных имеется поле , говорящее о нормальности сообщения)
Эти "левые" сообщения забивают весь архив (в 10-ти дневном архиве они составляют 90%)
Разъясните пожалуйста механизм "придумывания" сообщений и как с этим можно бороться.

ЗЫ:
Сейчас обдумывается идея написать тригер на вставку записи в таблицу сообщений, но тут есть одна проблема, как не удалить сообщения которые действительно имеют место быть (не ушедшие сообщения) во время загрузки проекта, ведь о времени их появления WinCC тоже ничего не знает.

Re:
Харгелия Олег Резович, ЗАО "Искра-Энергетика" ; 26.2.02

Что никто никогда не видел сообщений с перечеркнутым временем и не задумывался о их сущности?


text

Прозрачный фон у надписи
Сергей; 21.2.02

Подскажите как сделать прозрачный фон у Статического текста в Графическом Редакторе WinCC.

Спасибо.

Ответ я уже нашел.
Сергей; 21.2.02

Ответ нашел. Спасибо за внимание


text

WinCC 5. Таблицы
Павел Берляков; 27.12.01

Здравствуйте.

Подскажите, кто знает, почему в таблицах (элемент WinCC online table control) шрифт - перечеркнутый.
Font сконфигурен (в свойствах таблицы) без подчеркивания. Может быть, где-то еще оговаривается это свойство ?
Интересно, что часть колонок в таблице - то с подчеркиваниемя, то без. Цикл обновления Picture objekt 2 секунды. Цикл Arhiving/Display cycle в TagLogginge - 5 c.
Заранее благодарен.
Re: WinCC 5. Таблицы
Dr. Kren; 29.12.01

А вот это - отдельная тема.

И не на один вопрос-ответ.
Я сам нарвался на подобную ситуацию, но у меня цикл архивирования НЕ МЕНЕЕ 300 секунд !!!
Я так понимаю, что разработчики WinCC если и думали о чем-то, то не о разработке действительно промышленной системы HMI, т.к. уже оно только определение "промышленный процесс" подразумевает ведение статистики результатов работы процесса с высокой точность, надежностью и долговечностью.

Проблема не в "WinCC online table control", а в TagLoggin. А точнее не в нем самом, а в способе организации структуры архива.

----------------------------------
ТАКОГО БРЕДА я еще не встречал !!!
----------------------------------
Пример: сохраняем в чении 300 секунд с частотой в 1 секунду в архив три тега с целочисленными значениями (тип тега не важен - важно время записи и интервал записи). Можно подобрать и другой пример (это "товарищам" из Siemens).
Для этого создаем архив для хранения этих самых тегов.
Что делает WinCC?
Имея в своем составе достаточно мощный SQL сервер "Sybase Adaptive Server Anywhere" (на www.sybase.com проходит как ASA, ASE - Adaptive Server Enterprise) и не особенно напрягая мозги WinCC формируе ТРИ таблицы для хранения этих самых тегов.

Структура у этих таблиц следующая.
1-е поле "Т" - дата и время записи в архив.
2-е поле "V" - значение тега.
3-е поле "F" - что оно дает - так и не понял. В нем только два значения - 0 или 64. Логики появления того или иного значения я не нашел.

Для каждого из тегов можно назначить свое событие для записи. Да, это удобно.
НО АБСОЛЮТНО БЕССМЫСЛЕННО!
Гораздо удобнее разбить все теги по событиям архивирования на группы, из этих групп создать архивы, А ДЛЯ АРХИВА НАЗНАЧИТЬ СОБЫТИЕ ЗАПИСИ.
Мы ведь записываем не три несвязных параметра, а три логически неразрывных значения, например вес (самая сложная и довольно частая задача). Вес пустой емкости перед заполнением, вес полной емкости после заполнения, вес пустой емкости после опорожнения (это реальный случай, цикл архивирования не менее 300 сек). Так как емкость проходит все три процедуры, то мы назначим одно событие для архивирования написав UserFunction и привяжем к этим трем тегам дабы иметь в одной строке все три веса. Это логически, а физически в параллельных строках трех разных таблиц.
Я не использую циклическую запись по той простой причине, что в реальной жизни в 95 случаях из 100 (не берем значения датчиков для последующего отображения в трендах) запись нужно производить по событию, т. е. заранее нельзя сказать когда наступит условие. Вот эту ситуацию мы и моделируем.

Итак, с частотой в одну секунду мы производим запись в архив. И вот тут-то мы и попадаем в капкан. Видимо, "товарищам" из Siemens чуждо понятие реляционных моделей баз данных, и далее логики "dBase III+" у них мозгов не хватает. Не даром они рекомендуют для обработки больших массивов данных преобразовывать архивы в формат dBase.

Что получается? Событие для записи в архив как-бы одно. Но результат разный.
1-й тег.
В момент создания записи в таблице WinCC заносит дату и время ее созданиия + заполняет остальные поля.
2-й тег.
В момент создания записи в таблице WinCC заносит дату и время ее созданиия + заполняет остальные поля.
3-й тег.
В момент создания записи в таблице WinCC заносит дату и время ее созданиия + заполняет остальные поля.

И как результат сам WinCC разрывает логику между записями в таблицах. Разрыв в 1 секунду между появлениями записей в трех таблицах (одно архивирование трех тегов) если не норма, то уж явление ОЧЕНЬ ЧАСТОЕ.
Теряется всякая корреляция между данными. Если вдруг по каким-либо причинам в одной из таблиц (тегов) значение не будет записано (система имеет высший приоритет перед другими процессами, а дисковые операции высший приоритет в системе, а они-то как раз как правило самые длительные), либо записано с опозданием (основание выше), получаем что
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
НИКТО И НИКОГДА НЕ СМОЖЕТ С УВЕРЕННОСТЬЮ СКАЗАТЬ, ЧТО ТРИ РАЗНЫХ СТРОКИ В ЭТИХ ТРЕХ ТАБЛИЦАХ ПОЯВИЛИСЬ ПО ОДНОМУ И ТОМУ-ЖЕ СОБЫТИЮ И ЯВЛЯЮТСЯ ЧАСТЯМИ ОДНОГО ЦЕЛОГО
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Если кто против - поспорим.
Пример вышлю без проблем !!!
Все сделано ТОЛЬКО СРЕДСТВАМИ WinCC.

Как WinCC выкручивается из этого - не представляю.
Но как вариант могу предложить следующее объяснение (в моей ситуации эта логика просматривалась четко).
WinCC выбирает из трех таблиц данные за диапазон времени.
Если количество отобранных строк из трех таблиц совпало - на экране все красиво. Видим нормальную таблицу.
Но если количество разное - выбирает колонку с максимальным количеством строк и отрисовывает, а остальные колонки (где меньше) просто перечеркивает.
Почему? Да все потому-же. WinCC сам не может точно сказать, где достоверные данные, а где нет. И если значение какого-либо тега выпало из архива - то к какой именно строке это значение относилось.

Вылечить эту болезнь нельзя. Если только разработчики Siemens не соизволят пошевелить-таки мозгами, наложить некоторые ограничения на архивы, но зато сделать значения в архивах достоверными.

Извините за такое длинное письмо - короче никак не объяснить.

А если кому не нравится тон или содержание - НУ ИЗВИНИТЕ.
Так воспитан.
ЧТО ДУМАЮ - ТО И ГОВОРЮ.

С уважением ко всем...
В том числе и "товарищам" из SIEMENS.DE
Re: WinCC 5. Таблицы
Павел Берляков; 3.1.02

Я в добавление к сказанному.

Сделал таблицу из 2-х колонок - 2 тега типа Floating point 32 + время - текст нормальный.
Глюк наблюдался в случае таблицы с 5-ю процессными тегами.
Что до меня, я понял, что средствами WinCC надо пользоваться очень осторожно. Базу данных делаю в Sybase. Надо еще разобраться с перебросом данных. Скорей всего, для ликвидации наших проблем, нужно перебрасывать данные из Short - Term архива из ОЗУ, а не с HDD. Тогда, может быть не будет заморочек с полями timestamp.

И еще одно. Вызрело такое решение: чтобы нормально работать с большими объемами данных (у меня задачка где-то всего лишь на 100 внешних переменных была) нужен OPC - сервер. А с данными, приходящими с Симатика как-нибудь разберемся. На то есть Borland C (упаси меня Бог от изделий Microsoft !).
Всех с Новым Годом.
O'k, теперь все ясно.
Павел Берляков; 3.1.02

Перечеркнутый текст в таблице возникает, когда оптичено свойство Common Time column. Как только птицу снял - все хорошо.

Но проблема с primary key для моих таблиц остается.
Мораль - архивировать не все значения, полученные из тегов опросом upon change, а только усредненные по некоторому промежутку времени (который можно сделать достаточно коротким). Сейчас попробую. Как только появистя результат - сообщу. Думаю, для таких, как я "чайников" это будет полезным (только без обид - ведь и я не слишком опытен в WinCC !)
Хотя для Сименса это харроший вопрос!
Всякая уважающая себя фирма, хотя бы в целях поддержания репутации, выложила бы (бесплатно) в И-нет fix для таких вот вещей. Или я чего не понимаю ?
Все было просто
Павел Берляков; 3.1.02

Взял и в TagLogging'е назначил "параллельные" теги (Also in tag).

Теперь, даже если времена обновления исходных тегов не совпадают - ничего страшного.
Re: WinCC 5. Таблицы
Dr. Kren; 4.1.02

Всех с НОВЫМ ГОДОМ !!!

Удачи и больших побед в неравной борьбе с разработчиками SIEMENS.DE !!!

Беда в том, что экранное отображение данных для заказчика - "филькина грамота", и не более.
Всякий уважающий себя конечный продукт имеет хотя-бы минимальный набор отчетов о работе процесса.

Возвращаемся к весу (см message № 2).
Требование - выдать отчет за прошедшие сутки с разбивкой и подведением итогов за каждый час.
Форма отчета примерно следующая
+-------------+-------------------------+--------+----------+----------+
! № цикла ! Дата/время ! Пуст ! Полн ! Выгр !
+-------------+-------------------------+--------+----------+----------+
! 1 ! 01/12/01 0:05:15 ! 380 ! 2600 ! 2220 !
! 2 ! 01/12/01 0:11:10 ! 380 ! 2700 ! 2320 !
! 3 ! 01/12/01 0:17:22 ! 380 ! 2750 ! 2370 !
! 4 ! 01/12/01 0:22:12 ! 380 ! 2650 ! 2270 !
! ! Итого ! 1520 ! 10700 ! 9180 !
+-------------+-------------------------+--------+----------+----------+
! 1 ! 01/12/01 1:05:15 ! 380 ! 2600 ! 2220 !
! 2 ! 01/12/01 1:11:10 ! 380 ! 2700 ! 2320 !
! 3 ! 01/12/01 1:17:22 ! 380 ! 2750 ! 2370 !
! 4 ! 01/12/01 1:22:12 ! 380 ! 2650 ! 2270 !
! ! Итого ! ! 2600 ! 2220 !
+-------------+-------------------------+--------+----------+----------+
Ну и так далее.

Попробуйте теперь построить такой отчет в WinCC !!!
При всем этом, отчет нужно выдать за ЛЮБЫЕ прошедшие сутки (не обязательно с 0 до 24, но и допустим с 18 до 18 след дня). Еще круче - запросить отчет за неизвестное заранее количество часов - допустим за 50 прошедших.

Логичное решение - Microsoft Excel. Там такие вещи деляются левой ногой.

НО !!! Нужно ведь вытащить данные из базы.
ODBC драйвер есть - уже легче. Да вот беда - данные из внешнего источника независимо от его происхождения в Excel (да и в любую другую программу на чем-угодно писанную) из базы данных
"Sybase Adaptive Server Enywhere 7" можно вытащить лишь при помощи выражений SQL. Ведь сам "Sybase ASA 7" по определению - SQL-сервер.

Вот вам и проблема!
Как вытащить корректные данные, если мы знаем что в архиве между ними не гарантируется жесткая корреляция ?

SQL - выражение
==================================================
SELECT CHour.T,
CHour.V,
DoseBunker1_Empty.V,
DoseBunker1_Full.V,
DoseBunker1_Out.V
FROM DBA."PDE#HD#ArcBunker1#CurrentHour" CHour,
DBA."PDE#HD#ArcBunker1#DoseBunker1_Empty" DoseBunker1_Empty,
DBA."PDE#HD#ArcBunker1#DoseBunker1_Full" DoseBunker1_Full,
DBA."PDE#HD#ArcBunker1#DoseBunker1_Out" DoseBunker1_Out
WHERE CHour.T = DoseBunker1_Empty.T
AND CHour.T = DoseBunker1_Full.T
AND CHour.T = DoseBunker1_Out.T
AND ((CHour.T>'2001-12-01 00:00:00') AND (CHour.T<= '2001-12-01 00:59:59'))
==================================================

Это выражение в корне не работоспособно (в силу организации логической структуры архива). И как теперь быть?

Я пришел к следующему решению:
1. Установил InterBase SQL server 6.0 (абсолютно халявный, а по мощности мало чем уступающий многим более именитым серверам)
2. Создал базу данных, а в ней таблицу из 4-х полей (дата, вес пустого, полного, и разница веса)
3. Написал DLL на Delphi, выполняющую запись данных в архив.
4. По мере необходимости из WinCC вызаваю библиотечную функцию с параметрами.

5. Microsoft Excel - средство создания отчетов.

И ВСЕ !!!
Все проблемы с достоверность сняты с повестки дня.

TagLoggin - лишь средсво для хранения показаний датчиков.

Естественно есть и другие способы решения этих проблем.
Все зависит лишь от фантазии разработчика.

Но тогда один вопрос (маленький, но очень вонючий)

ЗАЧЕМ ПРИОБРЕТАТЬ "WinCC" И ДОВЕШИВАТЬ НА НЕГО ВСЯКИЕ ПРИМОЧКИ, ЕСЛИ ИСПОЛЬЗУЯ ПОЛНОЦЕННЫЙ ЯЗЫК ПРОГРАММИРОВАНИЯ И СООТВЕТСТВУЮЩИЙ OPC-server КОНЕЧНЫЙ ПРОДУКТ НА ГОЛОВУ ВЫИГРЫВАЕТ У АНАЛОГИЧНОГО ПРОЕКТА, РЕАЛИЗОВАННОГО В "WinCC".
И ПО СКОРОСТИ, И ПО ФУНКЦИОНАЛЬНОСТИ.

Да, есть доводы в пользу WinCC - малое время разработки, открытая архитектура. Типа грамотный разработчик WinCC взяв чужой проект разберется и доведет его до кондиции.
Но извините ребята, если грамотный разработчик на Delphi или C-Builder возьмет чужой проект - он его так-же точно доведет до кондиции.
Основное - понимать логику автоматизируемого объекта.

А вот чего очень хотелось-бы - так это приобретая WinCC и пользуясь ТОЛЬКО встроенными возможностями решать практически любые задачи при разработке проекта.

"И не грешно умному послушать дурака" - как говорили древние мудрецы - "Ибо даже дурню открыта доля мудрости".

Я (естественно) не претендую ни на первое звание, ни на второе.
Но очень, знаете ли, хочется узнать мнение разработчиков SIEMENS о путях и способах решения вышеописанных проблем.

С уважением ко всем...
В том числе и "товарищам" из SIEMENS.DE
Re: WinCC 5. Таблицы
Юрий Оганесян; 16.1.02

С любопытством почитал про попытки заархивировать четыре разных тэга, логически связанных и относящиеся к одному событию. Поднята проблема, что потом невозможно это понять, анализируя архив, и приведено решение этой проблемы. Но мне хотелось бы поднять еще один вопрос. Он касается аналогичной проблемы, но не на участке связи WinCC-архив, а на участке связи PLC-WinCC! Работаю по S7- протоколу. Если я правильно понимаю, то установление одинаковой частоты обновления для 4 тэгов (например 1 сек) еще не означает, что эти данные будут переданы на компьютер в едином пакете и за одну «дырку» между работой OB1. Т. е. можно получить 3 тэга, потом 20ms работы OB1, и оставшийся тэг.

Но вот в чем перец – за время работы OB1 данные могли поменяться совершенно объективно (быстро меняющиеся процессы)!
Если непонятно перечитайте еще раз – мне лень писать подробнее :)
Таким образом, я вижу общее решение проблемы составлением одного большого ROW-тэга. Это решит также проблему совместной архивации нескольких тэгов.
Если я чего-то не понимаю – поправьте

Re: WinCC 5. Таблицы
Чистяков Дмитрий ОАО СеверСталь; 17.1.02

Уважаемый Юрий Оганесян, я с Вами абсолютно согласен! Только хочю добавить, что ко всему прочему WinCC берёт данные асинхронно по отношению к циклу программы в контроллере.

Т.е. Если значение переменной изменяется несколько раз на протяжении программы, то при отображении его на WinCC будет замечено "мельтешение" значения. Сей факт нами был получен практическим путём - то бишь на реальном проекте.

Re: WinCC 5. Таблицы
Юрий Оганесян; 17.1.02

Чистякову Дмитрию:

Ваше замечание (по поводу того, когда WinCC берет данные по отношению к циклу работы контроллера), очевидно, относится или к S7-400 или НЕ к S7 протоколу, потому что я такой вопрос задавал на этот форум года 1.5 – 2 назад (к сожалению, не смог его сейчас найти) и мне ответили, что для S7-200 и S7-300 связь с HMI может осуществляться ТОЛЬКО после завершения работы OB1 (и перед следующим его началом), что, кстати, подтверждается manual-ами, а для S7-400 есть специально обученные функции.

Re: WinCC 5. Таблицы
Alexis; 17.1.02

Привет Всем!

Dr. Kren, на счет третьего поля «F», в ODK дается следующее описание:
dwFlags - For each value written to the archive, Tag Logging sets a flag which indicates tag status. In order to analyse the flags, the value must be converted into hex format! The "left" word (HighWord) indicates Data Manager or Quality Code flags (depending on whether the PDE_RT_QUALITYCODE bit has been set or not), while the "right" word (LowWord) represents Tag Logging status flags.

TagLoggingStatusFlags (LowWord):
PDE_RT_DAYLIGHT (Value:0x0001) Daylight saving time
PDE_RT_SUBSTITUTION (Value:0x0002) Substitute value
PDE_RT_TIME_BEVOR_JUMP (Value:0x0004) Value before a time jump
PDE_RT_TIME_BEHIND_JUMP (Value:0x0008) Value after a time jump
PDE_RT_TIME_OVERLAPPED (Value:0x0010) Values during a time overlap
PDE_RT_LOAD_SYSTEM (Value:0x0020) Value saved to archive for the first time after the archive has been created
PDE_RT_RELOAD_SYSTEM (Value:0x0040) First value after activation of RT
PDE_RT_CMPCOPY (Value:0x0080) Compressed value
PDE_RT_TIME_CHANGED (Value:0x0100) Time has been changed
PDE_RT_HAND (Value:0x0200) manual tag assignment
PDE_RT_ONCHANual tag assignment
PDE_RT_ONCHAN)
PDE_RT_ONCHANGEBACKUPVALUESTOP (Value:0x0800)
PDE_RT_QUALITYCODE (Value:0x1000)

Теперь о перечеркнутом времени – я сталкивался с этим в сообщениях AlarmLogging-а, там время перечеркнуто когда установлен флаг MSG_FLAG_TIMEINVALID, но у dwFlags TagLogging-a подобной фишки вроде нет. Так что попробуйте проанализировать значение флага когда время будет перечеркнуто, и если нетрудно, то сообщите в форум.

Best regards, Alexis.

Re: WinCC 5. Таблицы
Соколов Влексей (ЗАО "АСК" Екатеринбург); 18.1.02

Здравствуйте!

По поводу отчетности в WinCC, хотел бы сообщить информацию, которая возможно будет вам интересна.
Все TagLogging гарфики и таблицы для отчетов я формирую из программы, написанной на CBuilder. Благо в новой версии WinCC реализовано корректное обращение к обоим базам данных WinCC через ODBC. Для этого Есть ODK-функция, которая возвращает ODBC-ссылку на запущенный проект. Обращение к архивам TagLogging возможно, например с помощью компоненты CBuilder ADOQuery, посредством SQL-запроса. Единственное неудобство, что архивация данных в TagLogging-таблицы производится по внутренним событиям из буффера памяти, поэтому в реальном времени данные в таблице не всегда можно увидеть.
Насчет же ActiveX фирмы Siemens, который отображает TagLogging - графики, хочу сказать, что глюков, особенно раньше он содержал много.
Немного философии...
Павел Берляков; 22.1.02

Речь шла не о "перечеркнутом" времени (звучит как-то слишком мистически...), хотя, спасибо Alexis'у, теперь я и об этом знаю. Состояние флагов - посмотрю завтра.

Знаете, я не слишком опытен в программировании, но по простоте душевной скажу - хвала Microsoft'ам, Сименсу и иже с ними !
Когда мы получили Win95 с его глюками - волей-неволей потихоньку приобщились к программированию. Я, например, начал писать на Watcom C. Под QNX, конечно.
WinCC в мире автоматизации - примерно то же самое, что и Windows в мире операционных систем. Для меня общение с WinCC превратилось в один хороший урок...
Как-то надоело жаловаться на всевозможные глюки.
Удачи всем.

Re: WinCC 5. Таблицы
Dr. Kren; 25.1.02

Привет всем !

Удачи и больших побед в неравной борьбе с разработчиками SIEMENS.DE !!!

To [Alexis; 17.1.02]
За информацию - большое спасибо!

PDE_RT_TIME_CHANGED (Value:0x0100) Time has been changed
PDE_RT_TIME_CHANGED (Value:0x0100) "Время изменялось"

Да вот только проблему это не решает...
Что произошло изменение времени при записи - и так известно.

Проблема в том, что бы связать записи разных таблиц в единое целое, при том что время записи у них разное.

С уважением ко всем...
Re: WinCC 5. Таблицы
Юрий Оганесян; 25.1.02

Уважаемый Dr. Kren!

Прочтите, пожалуйста, мое предыдущее замечание. С учетом того, что там сказано, задача, над которой Вы бьетесь, изначально неверно поставлена!
Re: WinCC 5. Таблицы
Чистяков Дмитрий ОАО СеверСталь; 25.1.02

Как то прочитал вот такой прикол:

"90% глюков Windows вызваны не знанием пользователем как пользовать им. И надеждой пользователя на то, что Windows сам должен догадаться о том, что хочется пользователю"

:-)
Re: WinCC 5. Таблицы
Dr. Kren; 25.1.02

Привет всем !

Удачи и больших побед в неравной борьбе с разработчиками SIEMENS.DE !!!

To [Юрий Оганесян; 25.1.02]
За информацию - большое спасибо!

Корректнее будет "RAW-tag".

Да вот только и такой подход проблемы не решает.
Как вариант - тэги берутся из разных контроллеров. Объективно уже невозможно объединить их в один.

С уважением ко всем...

Re: WinCC 5. Таблицы
Юрий Оганесян; 30.1.02

Если логически взаимосвязанные тэги берутся из разных контроллеров, то задача становится порядка на два сложнее (но это в том случае, когда эти устройства действительно самостоятельные контроллеры, а не децентрализованная периферия, которую было бы более логично использовать в данном случае) Что нужна синхронизация времени контроллеров – это само собой разумеется - а вот все остальное… даже думать страшно…:)

Я бы все-таки программно передавал данные в один контроллер, формировал там таблицы или еще чего-нибудь подобное и оттуда забирал их WinCC-ой

Re: WinCC 5. Таблицы
Костенич Дмитрий; 3.2.02

Привет всем!

К вопросу о получении достоверных архивов по логически связанным тегам. Таки да, в TagLogging это сделать невозможно, т.к. на каждый тег заводится своя таблица, со всеми вытекающими отсюда последствиями вроде рассонхронизации циклов архивирования.
Однако, в WinCC Options есть такая вещь как UserArchives, которая как раз и служит для архивирования логически связанной информации (и помещается эта информация в ОДНУ таблицу!!!). Я глубоко с ней не разбирался, но понял про нее две вещи:
1. Есть возможность получать и архивировать данные непосредственно от контроллера (через RAW-теги)
2. Создавая элемент View можно выбирать для просмотра необходимые поля архива, а так же объединять поля из нескольких архивов.
Для отображения заархивированной информации в GraphicsDesigner есть специальный ActiveX в виде таблицы (как его зовут сейчас не помню).

Единственно что, - я не разобрался как (по какому событию) происходит архивирование, т.к. циклов там вроде бы нет. Есть скриптовые функции, но их применять не хочется.
Буду благодарен если кто растолкует.
Re: WinCC 5. Таблицы
Павел Берляков; 5.2.02

А вы почитайте, какую производительность обеспечивает этот User Archives. Чем больше записей, тем хуже. Единственное, для чего его можно использовать - это хранить всевозможные рецепты. Ну это так, к слову.

А теперь вопрос. Что мешает нам посредством ISQL, или еще как вытянуть данные из разных таблиц ? Время там ставится до 3-го знака. Что мешает обработать эти таблицы (назначить квант времени больший, чем интервал поступления данных из тегов, которые должны быть логически связанными)? Все упирается в величину этого кванта времени и возможность коллизии между данными. Но если грамотно все прописать в SQL, проблема может быть решена.
Ясно одно. WinCC никогда не претендовала на роль система real-time. И ею не будет, пока не произойдет кардинальной переработки. Кому нужна real-time - используйте QNX + написанное в PhAb (почти все делается ручками, зато работает быстро и на компах где-то 32 Мб RAM - большой опыт по этой части у словацкой фирмы Procesna Automatisazia, Кошице).
Удачи всем

Re: WinCC 5. Таблицы
Alexis; 6.2.02

To Dr. Kren

Кстати на счет твоей проблемы с записью взаимосвязанных данных, может тебя устроит следующее решение:
Предположим тебе надо сохранять три переменных. Создаешь в TagLogging три циклических архива на необходимое кол-во длинны и лочишь их. Далее отлавливаешь перую переменную и запоминаешь время и значение, ловишь остальные и запоминаешь значения, а затем записываешь в соответствующие таблицы через TLGInsertArchivData с одинаковым временем. Ну и получаешь связь данных через одинаковое время.
Re: WinCC 5. Таблицы
Dr. Kren; 6.2.02

Привет всем !

Удачи и больших побед в неравной борьбе с разработчиками SIEMENS.DE !

To [Юрий Оганесян; 30.1.02]
----------------------------------------
Я бы все-таки программно передавал данные в один контроллер, формировал там таблицы или еще чего-нибудь подобное и оттуда забирал их WinCC-ой
----------------------------------------
Проект уже более полугода как реализован и сдан. Программированием контроллеров занималась другая фирма. Так что даже собрать данные в один контроллер - проблема. Такой вариант уже рассматривался.
Но все равно спасибо.

To [Костенич Дмитрий; 3.2.02]
----------------------------------------
Однако, в WinCC Options есть такая вещь как UserArchives, которая как раз и служит для архивирования логически связанной информации (и помещается эта информация в ОДНУ таблицу!!!).
----------------------------------------
Проверялось. Быстродействие оставляет желать лучшего.
Но за совет спасибо.

To [Павел Берляков; 5.2.02]
----------------------------------------
Но если грамотно все прописать в SQL, проблема может быть решена.
----------------------------------------
В каком SQL - SQL-выражении или SQL-базе данных?
В стандарте ANSI SQL нет вообще такого понятия как "установка времени с точностью до 3-го знака" по той простоя причине, что время не есть Real, Double или Float значение.
К алгоритму записи данных в TagLogging (на сколько я знаю) нет доступа из WinCC. Так что ч какой точностью WinCC запишет время - одному SIEMENS известно.
В придачу ко всему обсуждается вопрос не как вытянуть данные из базы ASAnywhere, а как в случае разрыва по времени записи корректно отразить их "WinCC Table on-line" с показом времени записи данных в одной колонке, а не во всех.
За совет спасибо (но толком не понял "грамотно все прописать в SQL").

To [Alexis; 6.2.02]
----------------------------------------
Кстати на счет твоей проблемы с записью взаимосвязанных данных, может тебя устроит следующее решение:
----------------------------------------
А вот на счет "TLGInsertArchivData" как-то даже и не подумали.
Проверим.
Большое спасибо!

С уважением ко всем...

Re: WinCC 5. Таблицы
А. Туманов; 12.2.02

"Перечёркивание" может быть связано и с ошибкой при отображении - достаточно лишь изменить (увеличить) диапазон времени для отображения.


text

Дискриптор окна "HWND"
Dr. Kren; 7.2.02

Привет всем!

Для обращения к системным WinAPI в ряде случаев необходимо передавать дискриптор окна, вызвавшего эта самую API.

HWND hWnd, // handle of owner window

Graphic Designer Runtime явно создает окно выполнения проекта, в котором и крутит *.PDL

Вопрос - подскажите, каким образом получить дискриптор этого окна в режиме RT.

Сразу скажу, что передача вместо дискриптора значения NULL приводит к неестественному поведению вызванной функции. Слета системы или проекта не происходит, но функция WinAPI отрабатывается несколько не так, как описывается в документации.
Проверялось в Delphi и CBuilder - при передаче дискриптора все работает как должно.
Re: Дискриптор окна
Alexis; 7.2.02

А так

HWND hWnd=FindWindow(NULL,"WinCC-Runtime - ");
Дескриптор окна
Евгений Трунов; 7.2.02

Что касается основного окна PDLRT, то действительно через FindWindow. Оно принадлежит классу <B>"PDLRTisAliveAndWaitsForYou"</B> и имеет заголовок <B>"WinCC-Runtime - "</B>.

Кстати, попытка изменить этот заголовок через SetWindowText работает как-то странно - меняет, но через какое-то время самопроизвольно возвращает старое названние <B>"WinCC-Runtime - "</B>.

А вот с произвольными графическими объектами в системе дело обстоит хуже. Они почти все принадлежат "классическим классам" MFC AfxFrameOrView42 и AfxWnd42. Если не делать всем различные заголовки, то получить HWND определенного picture window затруднительно.
Re: Дискриптор окна
Dr. Kren; 7.2.02

Всем привет!

To [Alexis; 7.2.02]
To [Евгений Трунов; 7.2.02]

Большое спасибо!

Как по маслу. И да же лучше!

С уважением ко всем...


text

Импорт в User Archive
Павел; 2.7.01

У меня возникла проблема с User Archive. Экспортирую архив в CSV формате. Затем импортирую его же.WinCC 5 SP2.

Ошибка в LogFile:
[06/29/01 11:30:03] Archive: Tec - Insert failed (ID=1)!
[06/29/01 11:30:04] Import - Archive: Tec - Insert failed (ID=1)!
Почему?
И будет ли возможность экспортировать архивы в других форматах кроме CSV?(Вопрос представителям SIEMENS)

Re: Импорт в User Archive
Костенич Дмитрий; 7.2.02

У меня такая ошибка возникала при добавлении одиночных записей в архив посредством скриптовых функций.

Все дело заключается в том, что поле ID (с номером 0), КОТОРОЕ ВЫ САМИ НЕ СОЗДАЕТЕ, нужно ВАМ САМИМ устанавливать в номер добавляемой записи (и номер этот должен быть уникальным).
Судя по приведенному логу у вас непустой архив на момент экспорта. Может быть в этом все дело?


text

WinCC & WinAPI
Serg; 8.8.01

При вызове функций Windows API из WinCC подключение необходимых ".dll" и включение ".h" осуществляется примерно так:

#pragma code ("comdlg32.dll")
#include "commdlg.h"
#pragma code ()
Вопрос: "Возможно ли сделать так чтобы не нужно было копировать эти файлы в директорию library WinCC? Говоря другими словами можно где нибудь ли указать путь к различным включаемым файлам в дополнение к стандартным WinCC-ишным? Например подобно тому как это делается в Microsoft Visual Studio

С уважением Serg.
Re: WinCC & WinAPI
Евгений Трунов; 19.10.01

Попробуйте изменить значение параметра Include ветви реестра HKLM\SOFTWARE\Siemens\WinCC\ScriptControl\PATH. Стандартно там находится путь к папке \aplib.

Re: WinCC & WinAPI
Костенич Дмитрий; 7.2.02

В документации по ODK написано буквально следующее:

"The project path\library catalog is searched for includefiles (includng includefiles which are in turn called by the includefiles located there). If these files are stored at a different location of the file system, the complete path has to be entered."
Т.е. либо *.h файл ищется в каталоге library текущего проекта, либо указывайте полный путь.


text

Таблицы RT
Павел Берляков; 4.1.02

Re: Таблицы RT
Туманов А. В. ; 8.1.02

Всякий раз когда "глючит" TagLogging

удаляю все таблицы из *rt.db - помогает! Превентивно - всякий раз после изменения TagLogging. При запуске
RT все таблицы создаются заново.
Re: Таблицы RT
Павел Берляков; 8.1.02

Спасибо, но есть еще вопрос.

Делал ли кто-нибудь такое:
в Sybase Central изменить положение таблиц sequence arhive TagLogging'а -
свойство DB space - дабы не держать sequence на системном диске.
Можно, конечно, весь проект забросить на достаточно большой другой диск (у меня система и WinCC сидит на Fat16 - 2Гб, а в системе есть логический диск F на 15 Гб.), но вот возник такой вопросик...
Re: Таблицы RT
Dr. Kren; 14.1.02

Привет всем!

Пожелания успехов в неравной борьбе с разработчиками "SIEMENS"!

Взято из "Configuration-1.pdf"
Без комментариев.

-----------------------------------------
Файлы в каталоге WinCC по умолчанию
Во время установки WinCC, в ниже перечисленные папки копируются следующие
приложения:

\sqlany\isql.exe
Интерактивная программа, используемая для просмотра информации в базе данных проекта WinCC.

\bin\Wunload.exe Мастер, используемый для очистки online таблиц в базе данных проекта WinCC, например, удаляет сообщения и сохраненные значения. Мастер автоматически предоставляет runtime таблицы для выгрузки; в любое время пользователь может удалить или добавить дополнительные таблицы.
Этот инструмент должен использоваться в то время, когда проект WinCC находится в режиме offline. Его нельзя использовать во время исполнения. Сообщения и измеренные значения могут экспортироваться во время выполнения с помощью дополнительного пакета STORAGE.

\bin\Wrebuild.exe Мастер для восстановления базы данных; не может быть использован во время выполнения!

\SmartTools\CC_GraficTools\metaVw.exe Программа просмотра графических файлов (например. задания для печати, экспортируемые символы) в формате EMF (extended meta file).

\SmartTools\CC_GraficTools\wmfdcode.exe Программа просмотра графических файлов в формате WMF (windows meta file).

\SmartTools\CC_OCX_REG\ocxreg.exe Программа предназначена для регистрации или разрегистрации дополнительных элементов управления OLE (OCX).

\SmartTools\CC_OCX_REG\Regsvr32.exe Вызывается программой ocxreg.exe.
-----------------------------------------

А в общем-то весьма рекомендую
-----------------------------------------
Documentation on SIMATIC WinCC in Russian
This entry is available in the following languages:

Entry ID: 9821863
Date: 01/09/2002

http://www4.ad.siemens.de/skm/frameset.asp?lang=en&url=1&Query=9821863&TOPIC=All%20Topics&searchID=320561840&advanced=&smart-id=
-----------------------------------------

С уваженим ко всем...
Re: Таблицы RT
Костенич Дмитрий; 3.2.02

Павел, закинуть проект на другой диск конечно можно, но хочу предупредить что WinCC 5.0 SP2 не работает с проектами, находящимися на диске с FAT32 (не открывает существующие проекты, не создает новые). Проверено на практике (и официально подтверждено представителями Siemens).

Re: Таблицы RT
Павел Берляков; 5.2.02

А как с NTFS ?

На ней у меня проект работал.
Re: Таблицы RT
Dr. Kren; 6.2.02

Привет всем!

To [Павел Берляков; 5.2.02]
Абсолютно нормально. Проверено на практике - мин нет.
Диск "С:" система и WinCC,
диск "D:" - проект.
Оба раздела - NTFS 4 (WinNT 4 workstation).

С уважением ко всем...


text

WINCC с S5-ми ( аналоговые проблеммы )
Papik; 1.2.02

Во время приема данных с аналогового

модуля ( PLC S5 115 -942B )
в WINCC возникла проблемма с адоптацией
принимаемых значений и вывода их в поле
( I/O ).
С контроллером типа S7 все ясно там
принял данные в виде "DD" и WICC
принял их как "Floating-point number 32-bit 1EEE 754" "Float to Float"
И удачно все выводится на дисплей ( цифирьки с запятой )
А как это сделать с S5.
В каком формате принимать значения в программе?
И в каком таком мудренном формате
принимать их самой WINCC?
Я уже все варианты перепробовал ( Или не все?)
Помогите кто небуть если знаете а то я уже мозги на изнанку вывернул
Он гад или округляет числа ( как будто запятой для него не существует ,или выводит полную лобуду )

Re: WINCC с S5-ми ( аналоговые проблеммы )
А. Никулин, "УралСофт"; 6.2.02

Для S7 в WinCC5 существует отдельный формат преобразования действительных чисел: заходишь в Tag Properties, открываешь Adapt Format и на дне коробки изыскиваешь формат FloatToS5Float. Всего делов


text

WINCC с S5-ми ( аналоговые проблеммы )
Papik; 1.2.02

Во время приема данных с аналогового

модуля ( PLC S5 115 -942B )
в WINCC возникла проблемма с адоптацией
принимаемых значений и вывода их в поле
( I/O ).
С контроллером типа S7 все ясно там
принял данные в виде "DD" и WICC
принял их как "Floating-point number 32-bit 1EEE 754" "Float to Float"
И удачно все выводится на дисплей ( цифирьки с запятой )
А как это сделать с S5.
В каком формате принимать значения в программе?
И в каком таком мудренном формате
принимать их самой WINCC?
Я уже все варианты перепробовал ( Или не все?)
Помогите кто небуть если знаете а то я уже мозги на изнанку вывернул
Он гад или округляет числа ( как будто запятой для него не существует ,или выводит полную лобуду )
Re: WINCC с S5-ми ( аналоговые проблеммы )
Чистяков Дмитрий ОАО СеверСталь; 4.2.02

В Simatic S5 аналоговый вход дополняется тремя служебными битами. Для получения текущего значения достаточно сдвинуть полученное слово в право на три бита.

Более подробно можно почитать в описании S5.
Также в S5 имеется имеются дополнительные стандартные функциональные блоки. Один из которых предназначен для ввода аналогового сигнала и масштабирования сигнала в величину измерения (бары, тонны и т.д.)


text

новый -- comеxt --
Dima; 28.8.00

люди добрые

существует ли такой софт COMTEXT
для программирования TDOP (меня интересуе новая версия --- последняя --- )
а то у меня до того древняя что смотреть на нее тошно
а PROTOOL OP15 панель со старой версией прошивки (2.11) не хочет даже нюхать.
Re: новый -- comеxt --
Никаноров В. - Сименс, Москва; 28.8.00

COMTEXT - это старый программный продукт для программирования панелей оператора. Новых версий этого пакета не существует.

Для более-менее новых панелей COMTEXT полностью заменяется ProTool`ом.
Так что пользуйтесь Вашим COMTEXT`ом.

Re: новый -- comеxt -
Сергей; 1.2.02

Поделитесь дистрибом СОМТЕХТ, возникли проблемы с ТД20, а дистрибутив за годы хранения на дискетах размагничен :(


text

Регистрация продуктов Siemens
Дмитрий Потанин; 31.1.02

Есть ли необходимость официально регистрировать приобретенные продукты от Siemens, для получения какой-либо технической поддержки?

Дмитрий Потанин, ОАО НЛМК
Re: Регистрация продуктов Siemens
Юрий Оганесян; 1.2.02

Гарантийные обязательства и т.д. осуществляет фирма-продавец. По поводу технической поддержки: если Ваш поставщик не в состоянии ответить на Ваши технические вопросы и не делает никаких усилий в эту сторону - меняйте поставщика. На сайте SIEMENS есть регистрация ("подписка") для получения тех. информации, но это никак не связано с уже приобретенным "железом".


text

Звуки в WinCC
Игорь; 15.1.02

Вопрос чайника к профи

как звук издать(из компа) при возникновении алрменного сообщения.
Звук нужен однократный, и непрерывный пока оператор не сквитирует сообщение
если есть примеры в доках сошлитесь на них плиз.
Re: Звуки в WinCC
Dr. Kren; 15.1.02

Привет всем!

Пожелания успехов в неравной борьбе с разработчиками "SIEMENS"!

#pragma code ("kernel32.dll")
BOOL Beep(DWORD dwFreq, DWORD dwDuration);
#pragma code()

// Вызов SaveBunkerInfo
//SaveBunkerInfo(_Smena, 1, _DoseFull, _DoseEmpty, _DoseUse);
Beep(400, 1000);

С уважением ко всем...
Re: Звуки в WinCC
Чистяков Дмитрий ОАО СеверСталь; 17.1.02

В "Базе знаний" имеется описание и пример для решения Вашей задачи.

К тому же там предлагается разным сообщениям (по номеру) выдавать разные wav файлы.

Могу выслать этот кусок + программа ~400кБ
Re: Звуки в WinCC
Сергей; 30.1.02

Разработан компонент ActiveX, решающий практически все вопросы со звуком в WinCC. Основные ТТХ:

формат файлов - wav;
размещение файлов - сервер или ОС;
возможность оперативного отключения отдельных сообщений;
организация очередности сообщений;
реакция на фронта alarm (чтобы не утомлял);
размер файла 20кб
контакты: refraktor@narod.ru

Re: Звуки в WinCC
Игорь; 30.1.02

и где взять этот компонент


text

Перехват ошибок в WinCC
Игорь; 28.1.02

каким образом ошибки в WinCC

перехватываются?
если можно приведите пример


text

сменить тригер у акшена
Дмитрий Веткин; 27.1.02

Всем привет!

есть акшены которые запускаются по времени, задача - менять это время программно, лучше на лету, но не обязательно. В ОДК нашел вроде подходящие функции (AP_GEN_ReplaceTrigger и GSCGenReplaceTrigger) но как их использовать не понял, там куча не понятных параметров где их брать?, может кто делал уже такое, помогите а:)
лучше из глобал скрипта, но можно и из внешнего приложения


text

Protool Pro CS V5.2
Lakatos Tihomir; 18.1.02

Plese help me.I need update Simatic Protool/Pro V5.2 CS fom SP1 to SP2 or SP3

Re: Protool Pro CS V5.2
Чистяков Дмитрий ОАО СеверСталь; 22.1.02

Обратитесь в ближайшее представительство Siemens. Скачать его нельзя. Всю информацию по получению обновлений можно прочитать вот здесь http://www4.ad.siemens.de/news/cs/en/6656152


text

Взаимодействие WinCC и ИТС
Максим Поджидаев; 16.1.02

Re: Взаимодействие WinCC и ИТС
Чистяков Дмитрий ОАО СеверСталь; 17.1.02

Для связи с БД верхнего уровня, средства в WinCC заложены. Прочитать и посмотреть информацию по этой теме можно в "Базе знаний". Это файл 117 МБ. Он имеется на дополнительных дисках WinCC. Это подборка вопросов-ответов из службы поддержки Siemens. Т.е. Вы так же можете воспользоваться этой "базой знаний"(Knowledge Manager) в Internet по адресу http://www.ad.siemens.de/csi_e/km

Существуют и готовые решения для связию с БД верхнего уровня. Например Информацию по дополнительному пакету IXODBC для связи WinCC с MS Access, Oracle, Sybase, SQL-Server, можно найти здесь
http://www1.ad.siemens.de/hmi/html_76/products/software/wincc_addons/wcc_addon_profil_nr52.htm

В том же разделе Вы сможете найти и поддержку систем SAP/3


text

Не выгружаются задачи
Павел Берляков; 11.1.02

Здравствуйте.

Вот уже 5 минут, как закрыл WinCC explorer, а все еще Task Manager показывает CCProject и пр.
Это нормально ? Я имею в виду, может это остается в памяти для быстрой загрузки (как делают многие Windows- приложения).
Вообще, с памятью WinCC работает как-то уж оч. странно.
Re: Не выгружаются задачи
Александр Туманов.; 14.1.02

То, что висит CCProject - это нормально. Рекомендую "убивать" процессы WinCC вручную после зависания и сбоев - помогает! WinCC V5 SP2 "выключается" намного быстрее, чем SP1.

Re: Не выгружаются задачи
Dr. Kren; 14.1.02

Привет всем!

Пожелания успехов в неравной борьбе с разработчиками "SIEMENS"!

Разрешите встрять в базар.
WinCC сам по себе довольно нестабильный продукт. И при сбое в памяти остается очень много различного мусора - незавершенные приложения пакета WinCC, потерянные потоки. При этом перестартовать проект корректно - задача не из легких.

Посему рекомендую просто-напросто ПОЛНОСТЬЮ перегрузить компьютер.
Во всяком случае при сбоях я поступаю именно таким образом.

С уважением ко всем...
Re: Не выгружаются задачи
Павел Берляков; 15.1.02

O'k, в общем я так и делаю.

Проблема в другом - вот поработает моя система суток так 20, а потом линия встанет в ремонт. Надо вырубить.
Штатно задача решается соответствующим обработчиком для кнопки.
Но где гарантия, что при выходя эта штука не повиснет ?
Ведь оператору не скажешь :
"Войди в Task Manager и т.д.".
Надо ее как-то гасить...
Re: Не выгружаются задачи
Dr. Kren; 15.1.02

Привет всем!

Пожелания успехов в неравной борьбе с разработчиками "SIEMENS"!

В общем-то все сбои у меня приходятся на стадию разработки, когда приходится много эксперементировать.
После завершения разработки все работает достаточно стабильно. И выгружается WinCC нормально.
Покажи им где кнопка "Reset" - и достаточно.

С уважением ко всем...


text

OP 25
Dmitry; 2.1.02

Нигде не могу найти описание панелей OP 25. Как ее программировать. Имеющаяся у меня версия ProTool ее не?поддерживает.

Re: OP 25
Чистяков Дмитрий ОАО СеверСталь; 3.1.02

Во-первых, а какая у Вас версия ProTool? Не Lite, случайно?

Для графических панелей необходим один из пакетов ProTool или ProTool/Pro.

Описание пакетов на русском языке вот здесь. http://195.146.64.23/ad/as/ru/info/04_hmi/04_man/

Описание по OP25 на английском могу выслать по почте 1,3 Мб - пишите.

Re: OP 25
Чистяков Дмитрий ОАО СеверСталь; 3.1.02

А вот посмотрел есть и в Internete на английском по адресу http://www4.ad.siemens.de/news/cs/en/1142693


text

Построчная печать в WinCC 5.0
Алексей; 24.12.03

Как настроить шрифт, которым производится построчная печать алармов в WinCC 5.0? У меня вместо русских букв печатаются прочерки. В шаблоне для построчной печати выбора шрифта нет. Как сделать, чтобы печать производилась шрифтом принтера, а не в графическом режиме? Принтер матричный Epson LX300.

Re: Построчная печать в WinCC 5.0
Роман Папировский; 25.12.03

Добрый день Алексей.

Печать построчных отчетов производится шрифтом, установленным в вашем принтере. Шрифт настраивается в принтере переключением DIP переключателей. Смотрите инструкцию к вашему принтеру. В конце её даны все таблицы символов с соответствующее им положение переключателей. Если ваш принтер не поддерживает русский шрифт, то принтер придется перепрошивать.

С уважением, Роман Папировский.

Re: Построчная печать в WinCC 5.0
Алексей; 25.12.03

Большое спасибо за ответ. Действительно в принтере есть только 866 кодовая страница, а WinCC посылает видимо в 1251. Может кто подскажет кто какие принтеры использует для построчной печати с поддержкой CP 1251?

Или может есть способ отловить возникающие сообщения из Аlarm loggera, перекодировать и напечатать их вручную?

Re: Построчная печать в WinCC 5.0
Владимир; 29.12.03

У нас используются принтеры LX-300 и LX-300+

Никаких проблем при тестировании построчной печати не возникало. В настоящее время печать работает по запросу оператора (средствами Win), но я могу в ближайшее время посмотреть настройки принтеров.
Re: Построчная печать в WinCC 5.0
Yrok; 29.12.03

Может тебе эти функции пригодятся

они перекодируют кодовые таблицы туда сюда
Файл User32.Dll
BOOL CharToOem(
LPCTSTR lpszSrc, // pointer to string to translate
LPSTR lpszDst // pointer to translated string
);
BOOL OemToChar(
LPCSTR lpszSrc, // pointer to string to translate
LPTSTR lpszDst // pointer to buffer for translated string
);


text

MP370 и S5(AS511). Вопрос о производительности
Сергей; 28.12.03

Здравствуйте!

Имеется панель МР370 и контроллер S5. Связь по протоколу AS511. Проект довольно большой и наблюдаю замедленную реакцию(2-3 сек.) на процесс. Как я понял из различных источников, для этой панели не надо создавать, да и нет такой возможности, "Interface Area",как например для панели ОР7 при связи с S5.
Меня волнует вопрос увеличения быстродействия и Interface Area для этой панели.

Буду рад любым советам.

Спасибо

Re: MP370 и S5(AS511). Вопрос о производительности
Юрченко Владимир; 29.12.03

Вообще то быстродействие как то очень слабо связано с Interface Area, и определяется количеством переменных в проекте и скоростью сети . А настройка Interface Area ничем не отличается особо от конфигурирования для других сетевых интерфейсов - почитайте www.automation-drives.ru/as/download/doc/simatic_hmi/protool/05%20User%20data%20areas%20for%20SIMATIC%20S5_r.pdf. Там не упоминается о MP370, но работает она также как например MP270.


text

Ошибка компиляции в Pro Tool 6.0
Grigoriy; 27.12.03

Господа! Кто-нибудь встречал следующую ошибку компиляции: E3499 Internal error: no protocol data for PT instances (52,657,-1) received.В описании написано, что при нормальной работе Pro Toolа такой ошибки быть не должно.


text

S7-200 OPC Server v 1.0
Anosov P.A.; 25.12.03

S7-200 OPC Server v 1.0 не хочет устанавливаться под Win2k. Ему надо NT,95,98. Кто знает Есть ли версии S7-200 OPC Server которые дружат с win2k. Или какое нибуть другое решение проблеммы (кроме запуска ProToolPro с встроенным OPC Server`om).

Заранее благодарен

Re: S7-200 OPC Server v 1.0
Юрченко Владимир; 26.12.03

Скачайте S7-200 OPC Server SP1, он работает под Win2k.

См. http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.csinfo&objId=9928227&lang=en&aktprim=0&u=NDAwMDAxNwAA&siteID=cseus

Re: S7-200 OPC Server v 1.0
Anosov P.A.; 26.12.03

Спасибо


text

Ladder/IL визуализация
Евгений Кузнецов; 26.12.03

Всем привет!

С наступающими всех праздниками.
Встречал ли кто-нибудь АктивХ или
какую-то утилиту для отображения текста/мониторинга FB/DB?
Re: Ladder/IL визуализация
Юрченко Владимир; 26.12.03

Может быть то что Вы ищете WinCC/ProAgent?

См. http://www.automation-drives.ru/as/download/ascat/software/eng/04_PDiag+ProAgent_r.pdf


text

Куплю или обменяю OP-7, OP-17
Андрей; 21.12.03

Куплю по сходной цене можно б\у операторскую панель OP7 и\или OP17

Ваши варианты предлагайте ниже

Re: Куплю или обменяю OP-7, OP-17
а на что обменять могешь?? (правда есть тольео OP-15....); 22.12.03

есть OP-15 могу махнуть на ченить хорошее..

Re: Куплю или обменяю OP-7, OP-17
joker; 25.12.03

Есть б\у ОР 7 но сгорел контроллер связи DP,а так фурычит (т.е. 232 живой)

Re: Куплю или обменяю OP-7, OP-17
Андрей; 25.12.03

Нужен желательно OP-7 вязать планирую по dp. Но на всякий случай скинь свою цену на почту

Re: Куплю или обменяю OP-7, OP-17
Андрей; 26.12.03

Если OP-15C напиши свой вариант обмена или продажи


text

RT база WinCC 6.0
Дмитрий; 25.12.03

Здравствуйте!

Подскажет кто-нибудь, как обновить RT базу проекта WinCC 6.0, типа как в 5-ой версии я использовал файл WinCCRT_7.db, вот есть файлик WinCC_SQL.MDF, это он?
Спасибо!
Re: RT база WinCC 6.0
Маслов Дмитрий; 25.12.03

Могу ответить на ваш вопрос частично. В WinCC 6.0 Runtime-база данных содержится не в одном файле, а разделена на master database и набор архивов. Все архивы хранятся в каталоге проекта в подкаталоге ArchiveManager (там внутри три папки - для архивов Tag Logging, быстрых и медленных, и для архивов Alarm Logging). Все файлы в папке Archive Manager можно безболезненно удалять.

Re: RT база WinCC 6.0
Дмитрий; 25.12.03

Дмитрий, насколько я понимаю под master database подразумевается файл ProjectNameRT.mdf в корневом каталоге проекта? И ещё, может тогда скажете, где хранятся значения из UserArchive?

Заранее СПАСИБО!
Re: RT база WinCC 6.0
Маслов Дмитрий; 25.12.03

Master database - это действительно файл ProjectNameRT.mdf в корневом каталоге проекта. И его размер не растет с ростом архивов. Т.е. для удаления архивов надо просто удалить содержимое папки Archive Manager.

А можно то же самое сделать и визуально:
1. Откройте Tag Logging
2. Щелкните левой кнопкой на Archive Configuration.
3. Щедкните правой кнопкой на TagLogging Fast или TagLogging Slow и выберете пункт меню Reset.

В результате Вы удалите все архивные данные.

Про User Archive пока не знаю. Просто не интересовался этой проблемой.

См. Центр технической поддержки по WinCC


text

Перенос проекта WinCC на другой комп
Дмитрий; 24.12.03

Здравствуйте!

Кто-нибудь знает КАК ПРАВИЛЬНО переносить проект WinCC с одного компа на другой? Моя ситуация:
есть проект на PCS7 v6.0 хочу перенести из него проект WinCC на другой комп, копирую, меняю имена машин, запускаю RT - результат: "No connection to the data server!" вместо сообщений. Как только запускаю RT на машине, откуда взят проект (они в одной локалке) - появляются сообщения.
Подскажите, где прописано, что сообщения запускаются с исходного компа, и почему тогда работает Taglogging?
Спасибо!
Re: Перенос проекта WinCC на другой комп
Маслов Дмитрий; 24.12.03

Дело в том, что в окне Alarm Logging указывается, с какого сервера отображать сообщения. Видимо, у Вас там жестко прописано имя компьютера, на котором первоначально был создан проект. Я Вам рекомендую сделать следующее:

1. Откройте диалог настройки окна сообщений, дважды щелкнув на требуемом окне в Graphics Designer
2. В группе Server Selection произведите следующие настройки:
- снимите флажок All Servers
- в поле ввода под кнопкой Selection введите следующую строку:
localhost;
3. Подтвердите настройки, сохраните картинку.

После этого у Вас данное окно будет отображать сообщения только с текущего сервера.
См. Центр технической поддержки по WinCC

Re: Перенос проекта WinCC на другой комп
Дмитрий; 24.12.03

Дмитрий, СПАСИБО!

Усё в ажуре :)


text

Архивы измеренных значений в WinCC 6.0
Goodvin; 9.7.03

Приветсвую!

Вопросы для тех, кто юзал WinCC 6.0:
1.Насколько я понял из доки, после создания архива изм. знач. и самих архивных тегов, нужно привязать этот самый архив к TagLoggingFast/Slow посредством Link archive, но вот что-то она у меня закомментирована, подскажите, плиз, что пропустил?

2.И ещё: для чего в TagLogging придуманы TagLogging Fast/Slow, в доке написано: Если цикл архивирования меньше минуты, то используй Fast, если больше - то Low, а если в моём архиве переменные с разными циклами архивирования, тогда что? :)

Заранее благодарю за отклики!
Re: Архивы измеренных значений в WinCC 6.0
Goodvin; 11.7.03

Вопросы снимаются, кажись сам разобрался, правда появились новые :)

P.S. Всем спасибо за отклики.
Re: Архивы измеренных значений в WinCC 6.0
Goodvin; 24.12.03

Под рукой компьютера этого нет, попробуйте найти здесь:

http://www3.fujitsu-siemens.com/services/drivers/start.php
Удачи!


text

ОР и мороз
В. Сорокин.; 19.12.03

Может кто-нибудь сталкивался? Необходимо иметь операторный интерфейс, уровня ОР17 или выше, на шкафу уличного исполнения: зима, снег, мороз. Внутри тепло и сухо, печка топится, а в лицо панели ветер дует. Посоветуйте, пожалуйста, если кто делал или видел.

Re: ОР и мороз
Владимир, Минск; 20.12.03

Сталкивался я с этой неприятностью. OP27 температура -20, на экране все цвета искажены и плохая видимость. Поставил тепловентилятор тёплый воздух в "лицо OP27", через некоторое время всё востановилось и так работал всё холодное время. Выход - ставим в нижней части экрана нагревательный элемент тёплый воздух поднимаясь вверх образуёт защиту OP от холода.

Re: ОР и мороз
В. Сорокин.; 22.12.03

Спасибо. А нагреватель ставите снаружи?

Re: ОР и мороз
Владимир, Минск; 22.12.03

Я предполагаю что OP стоит на передней панели эл/шкафа. Скорее всего рядом находится PLC который требует температуры окружающей среды 0...+70 C (если не исполнение Outdoor или Siplus).А это значит, что где в этом шкафу стоит обогреватель и он также обогревает заднюю часть OP. Остаётся обогревать наружную часть панели. Вроде в контроллерах серии

"Альфа" (-25 С ...)так и сделано.


text

руссификация отчётов в ProTool 6.0 SP1
ViT; 18.12.03

Хочу отпечатать проект сделанный в ПроТуле. Все русские надписи в виде крякозяблин. Это можно как-нибудь исправить?

Re: руссификация отчётов в ProTool 6.0 SP1
Юрченко Владимир; 18.12.03

Это исправляется прописыванием в регистре. На форуме (для другого случая) приводилась процедура правки регистра для поддержки русского языка:

См. http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1054723697&year=2003

Re: руссификация отчётов в ProTool 6.0 SP1
ViT; 18.12.03

Спасибо!!! получилось....

Re: руссификация отчётов в ProTool 6.0 SP1
Игорь; 22.12.03

Ребяты!!!

Все это хорошо получается под W2K или NT. А вот под Win98SE - никак, сколько ни старался. Уже весь реестр перелопатил!
Отзовитесь, пожалуйста, если кто-нибудь решил эту проблему (именно под Win98SE)!
Я, конечно, понимаю, что самый лучший вариант - просто установить у себя W2K. Но дело в том, что я работаю на своём личном ноутбуке, а у него "мозгов" для W2K маловато - 64 метра.


text

WinCC OPC Client валит IIS ?????
Юрий Оганесян; 16.12.03

Добрый день!

WinCC 5.1 + WebNavigator Server 1.2. (Windows 2000)
Есть проект, в котором WinCC выступает в том числе и в качестве OPC клиента (OPC Server – Protool 6.0 на другой машине, если интересно), тут же стоит WebNavigator Server 1.2. Так вот, такая конфигурация валит IIS. А конкретно inetinfo.exe через 1 - 5 часов работы вылетает по недопустимой операции и больше обратиться к virtual folder проекта не удается (к другим virtual folder обращение идет). Сама WinCC работает, отваливается именно WebNavigator. Пробовал по разному – и как virtual folder и как stand-alone Web Site, пробовал не публиковать OPC-шные тэги на экранах WebNavigator’а, а публиковать там только внутренние тэги, в которые global script’ом переписываю значения из OPC-шных тэгов. Ничего не помогло, но с наличием в проекте WinCC OPC connection’а я это все-таки связываю (исторически), то бишь работающий DCOM и WebNavigator Server на одной машине дружить не хотят (Так как совершенно не понятно, как Web Navigator Server общается с WinCC ничего более конкретного предположить не удается). Переставлял все, что только есть сименсовского на машине и пробовал на 2 разных комптютерах. Есть маленькая тонкость - безопасность OPC построена на принципе «зеркальных» учетных записей – но, вроде бы это допускается. Может ли кто-нибудь помочь в этой ситуации? Есть ли возможность использовать разные машины для WinCC и Web Navigator Server? Имеет ли смысл и чем патчить IIS 5.0? Удалось ли кому-нибудь скачать Update для Web Navigator Server 1.2 (мне пообещали и молчок)? Также надеюсь на ответ со стороны специалистов Siemens, поверьте, проблема не надумана, хоть и проявляется не сразу.

Re: WinCC OPC Client валит IIS ?????
Юрий Оганесян; 22.12.03

Уф.... спасибо всем, кто отвечал мне на ящик.

Вроде бы помог (2 дня в выходные простояло) Hotfix3 for WinCC/WebNavigator 1.2.
Хотя по описанию на этот Hotfix даже приблизительно в мыслях не было, что он помочь может в описанной ситуации.


text

Симулятор в ProTool.....
Baby; 20.12.03

Привет !!!

Ситуация ....
Создан проект в ProTool 6.0 SP1.
Хотелось запустить симуляцию, но почему то, надпись симуляция не активна.
Вопросы....
1. Авторизация на симулятор нужна или нет, из доки что-то непонятно.Или это нормальная стандартная функция в ProTool и надо дальше по мануалу просто разбираться в чём дело.
2. Симулятор в Step7 v5.1 ,возможно ли связать с симулятором ProTool (если будет работать конечно). Подобие того, как это делается в WinCC.

Re: Симулятор в ProTool.....
Назаров Дмитрий; 22.12.03

Симуляция в ProTool работает следующим образом:

1. Если желаете связать ProTool связать с PLCSIM, то проект надо интегрировать в STEP 7.
2.Если проект не интегрированный, то пользуетесь сиулятором ProTool который устанавливается с пакетом ProTool Pro RT. Вероятно эта программная часть не установлена поэтому кнопка неактивна.

Авторизация на симулятор как отдельный продукт не нужна.


text

Horn in the Multiuser project
Кишко Сергей; 16.12.03

В многопользовательском проекте нет возможности независимого отключения(и включения)сирены - Horn.В качестве audio device используются стандартные аудио-карты с выходом на активные колонки.Так вот сирена начинает выть в случае аварийной ситуации одновременно и на сервере, и на клиентских машинах.Выключить раздельно ее тоже нельзя (например,чтобы на сервере она звучала,а на клиенте - нет).Проблема в том,что включение сирены (и ее выключе-

ние) привязывается к тэгу,а не к компьютеру.Проблема может быть решена с использованием вместо Horn элемента ActiveX WindowsMediaPlayer, но на него нет описания,а среди его свойств
я не нашел тех,которые его запускают и останавливают(что-то вроде "Play" and "Stop"), мне удалось лишь запустить его при открытии с помощью установки "AutoPlay" в "Yes".Был бы очень признателен тому,кто помог бы в этом вопросе.

Re: Horn in the Multiuser project
Александр Родин, ООО "Нева Электрик"; 17.12.03

В приниципе, вопрос вывода звука уже обсуждался здесь много раз, правда многопользовательские системы не затрагивались. Попробуйте использовать API-шные функции. Если надо, могу выслать пример.

Re: Horn in the Multiuser project
Yrok; 17.12.03

PlaySound("C:\\FileName",NULL,SND_FILENAME);

#define SND_FILENAME 0x00020000L
}
Re: Horn in the Multiuser project
Alexis; 18.12.03

На счет мультиюзверевского проекта - чтобы звук был общий для всех компов или раздельный: там же весь смысл в том, что есть тэги @Signal1-3 (которые Computer-local update) и в startup-е на каждом компе запускается hmrt.exe который и взводит тэги при наличии сообщений. Ну дык смысл - @Signal1-3 сделать Project-wide update и hmrt.exe запускать токо на сервере - тогда звук должен быть единым для всего проекта и отключение тоже должно быть единым. Попробуй... :)

Re: Horn in the Multiuser project
Сергей Кишко; 18.12.03

пробовал использовать функцию WinAPI PlaySound,но не могу пропихнуть ее под WINCC (v6.0). Под C++Builder для этого достаточно прописать

#include <mmsystem.h> и все.
Без включения этой строки WINCC этой функции,естественно, не находит. Пробовал включить эту строку в файл "apdefap.h", а сам файл скопировать в тот же каталог - ошибки
при компиляции - компилятор WINCC не понимает многих директив в этом файле. В чем тут дело?
Был бы признателен,если вышлете пример.

Re: Horn in the Multiuser project
Маслов Дмитрий; 19.12.03

Создайте функцию проекта со следующим кодом:

#pragma code ("winmm.dll")
BOOL WINAPI PlaySound(LPCSTR pszSound, HMODULE hmod, DWORD fdwSound);
#pragma code()

void PlaySoundWinCC(LPCSTR Name)
{
if (!PlaySound(Name, NULL, 0x00020000L)) printf("Playing the sound %s failed\r\n", Name);
}

Вызывайте ее там, где нужно, передаваю в нее имя wav-файла.

См. Центр технической поддержки по WinCC

Re: Horn in the Multiuser project
Кишко Сергей; 21.12.03

Большое спасибо всем, особое - Дмитрию Маслову и Александру Родину.


text

Wincc: как получить пароль??
pAYK; 19.12.03

Подскажите, как можно узнать пароль администратора в проекте wincc????

Re: Wincc: как получить пароль??
Yrok; 19.12.03

Я бился очень долго, но так и не пришёл ни к чему. Мне так кажется что это зарезервированное для SIEMENS.


text

Как можно получить данные из OP27
Антон Ковалев; 19.12.03

Как можно получить данные из буфферов ошибок и событий OP27

Re: Как можно получить данные из OP27
Baby; 19.12.03

Привет !!!!

Подробней plz, что это "буфферов ошибок и событий OP27".
Re: Как можно получить данные из OP27
Антон Ковалев; 19.12.03

В OP27 есть два буффера, 1-ошибки

2-события. Нужно как-то переносить их в базу данных на PC. Как это проще всего реализовать????


text

Analog Alarm - вопрос
beginner; 15.12.03

датчик давления от 0 до 1 Бар.

нужно сделать сигнализацию при превышении верхнего и нижнего уровней давления.
в Alarm Logging в меню Tools -> Add Ins
добавил Analog Alarm. Затем добавляю тэг который нужно мониторить, номер сообщения. далее к этому тэгу два Limit Value - верхнее и нижнее.
В свойствах единичного сообщения проставляю: Class, Type, will be archived.
Но это не работает.
WinCC мониторит их или нет ?
Или нужно в контроллере делать обработку этого датчика, и при граничных значениях взводить бит в DBxx
и MessageTag в Alarm Logging тогда сработает ?
Помогите советом, плиз...
Re: Analog Alarm - вопрос
Роман Папировский; 17.12.03

Добрый день Beginner.

Конечно, делать обработку датчика в контроллере было бы «прямее». Мало ли что произойдет с станцией WinCC. Например, во время перезагрузки станции контроль по уставкам будет отсутствовать.
Теперь вторая проблема как сделать чтобы работал Analog Alarm.
1. Проверьте, нет ли у вашего сообщения привязки к тегу. Её быть НЕ должно.
2. Analog Alarm начинает проверку значения тега на нарушение граничных значений только когда эти самые значения хоть раз изменились. Например: значение вашего тега изменяется от 0 до 5, значение нижней уставки 1 верхней 4. Вы прописываете значение уставок как начальные значения тегов (Start Value). Запускаете проект. Значение контролируемого тега 0 значение нижней уставки 1, а сообщения о нарушении нижнего предела НЕТ. Изменяете значение контролируемого тега на 5, а сообщения о превышении уставки опять НЕТ. Но если вы теперь измените, значение верхней уставки на 4,1, то сообщение появится. Сообщений не появляются в двух первых случаях, потому что статус тегов хранящих уставки «Start Value», как только статус тегов изменяется Analog Alarm активизирует контроль.
Возможно причина в этом.
С уважение, Папировский Роман.

Re: Analog Alarm - вопрос
beginner; 19.12.03

Спасибо, разобрался. Теперь всё работает. Как оказалось, в STEP7 actual value например 8,837963е, я ставлю в Upper limit 8 и это не работало,

а нужно было 0.8

вот так..


text

Как настроить сервер Sybase для предоставления удаленного доступа к БД WinCC?
Михаил; 9.12.03

Как настроить сервер Sybase для предоставления удаленного доступа к БД WinCC? Доступ предполагается через приложение Delphi(Builder).

Пробовал использовать демо Sybase, однако не ясно как настроить серверную часть для доступа к БД WinCC.
Доступ к демо БД самой Sybase удаленного клиента настроил.
Может быть есть где-то документация по этому вопросу или кто-то уже решил этот вопрос. Окажите помощь.
Механизм локального подключения к БД WinCC понятен.

Re: Как настроить сервер Sybase для предоставления удаленного доступа к БД WinCC?
Михаил; 9.12.03

Сам себе и отвечаю. Можно обойтись без настройки Sybase сервера. Во всяком случае это один из вариантов. Нужно настроить соотвествующим образом ODBC драйвер на клиенте.

Т.е. указать правильно имя сервера,
базу данных, прописать путь до БД (при условии что эта папка расшарена с сохранением настроек безпасности коннечно), установить птичку на сетевом протоколе.
Впрочем если есть другой вариант, может быть даже лучший я не против.
Re: Как настроить сервер Sybase для предоставления удаленного доступа к БД WinCC?
Михаил; 18.12.03

Достаточно сделать так:

1. На сервере запустить WinCC. Это необходимо для того, чтобы база
данных проекта была запущена. К незапущенной базе данных можно
присоединяться только через файл - как Вы делали раньше.
2. На клиенте настроить ODBC DSN. При этом важно указать следующие
настройки: login/password - DBA/SQL; Database name - сюда вписать имя
базы данных, которое надо скопировать из соответствующего поля ввода в
настройках DSN на сервере; установить флажок TCP/IP, при этом в поле
ввода справа от TCP/IP ничего не указывать. Кроме перечисленнх
настроек указать имя DSN и больше ничего не изменять.

Должно получиться.

Если что - пишите.

С уважением, Маслов Дмитрий

P.S. В дополнение к вышеуказанному, при настройке ODBC на клиенте, в поле ServerName необходимо добавить имя сервера, иначе система выдает сообщение, что сервер не запушен.

Трушин Михаил.


text

опять ProTool
ViT; 16.12.03

создан проект в ProTool 6.0 SP1:

15 экранов
у меня один и тот же тег подключен к трём экранам: на первых двух этот тег подключен к кнопке и работает как сигнализация изменения этого дискретного сигнала (она начинает моргать при его изменении); на третьем экране этот дискретный тег подключен к обычному ползунку (Bar) аналогового сигнала и столбик этого ползунка должен изменять свой цвет на другой при изменении этого дискретного тега (сигнал от электроконтактного манометра).

Начинаю тестировать используя встроеный симулятор сигналов: ползунок на Bar'е изменяет свой как положено и кнопка тоже, но как только начинаешь переключаться между этими экранами, столбик на Bar'е вновь оставляет свой цвет на прежнее состояние (то есть скидывает его), хотя сигнал остаёться в том же состоянии, то есть не сбрасываеться. А кнопка продолжает моргать при переключении сигнала и при переключении экранов без проблем...

В чём тут дело? Это случайно не глюк? или может быть я что-то не так понимаю или не так делаю?


text

бесполезности для wincc
Alexis; 8.12.03

См. страШныйСайт :)

Re: бесполезности для wincc
Евгений Трунов; 9.12.03

При запуске выдает сообщение:

"Не удается открыть пакет установки. Свяжитесь с поставщиком приложения и убедитесь, что это правильный пакет Windows Installer".
Re: бесполезности для wincc
Akorostel; 9.12.03

у меня тоже самое

Re: бесполезности для wincc
Alexis; 9.12.03

Вроде теперь качается и ставится :)

Re: бесполезности для wincc
Шимолин Сергей; 10.12.03

Прикольно!

На VC++ делал?
Re: бесполезности для wincc
Alexis; 10.12.03

Да, MS Visual C++ 2002

Re: бесполезности для wincc
shurik; 13.12.03

а нет ли мыслей по формированию журнала действий оператора в читабельном виде, а не смотреть на шифры параметров

Re: бесполезности для wincc
Alexis; 15.12.03

2 shurik:

А точнее можно? А то я что-то сути не уловил... :)
Re: бесполезности для wincc
shurik; 15.12.03

смысл в том что при выполнении какого-то действия оператором (например изменения уставки регулятора SP для CTRL_PID) в журнал сообщений выводится Device1\CFC\CTRL_PID.SP новое =1 старое =0.А как вставить в текст вместо шифра что это типа РЕГУЛЯТОР ПОДАЧИ СРЕДЫ.Простите,может быть вопрос не по теме,но если Вы что то можете посоветовать буду благодарен.

Re: бесполезности для wincc
Alexis; 15.12.03

Как это делаю я.

Ручками в ALG создаю сообщение:
NR=1015001 (номер на Ваше усмотрение)
CLASS=18 TYPE=247 (т.е. системное без подтверждения)
TEXT1=@1%s@
TEXT2=@2%s@
TEXT3=@3%s@
TEXT4=@1%g@
TEXT5=@2%g@

Функция генерации сообщения (этакий упрощеный псевдокод:):
BOOL WINAPI ChangeParam
(double dblNewValue, double dblOldValue, /*новое и старое значения*/
LPCTSTR lpszTagName, LPCTSTR lpszSyffix, /*имя тэга - структурного и поля структуры*/
LPCTSTR lpszDesc, LPCTSTR lpszUser, LPCTSTR lpszComment) /*описание, юзер и комментарий*/
{
BOOL bRet=FALSE;
DM_VARKEY dmvk;
ZeroMemory(&dmvk,sizeof(dmvk));
lstrcpy(dmvk.szName,lpszTagName);
lstrcat(dmvk.szName,_T("."));
lstrcat(dmvk.szName,lpszSyffix);
dmvk.dwKeyType=DM_VARKEY_NAME;
CMN_ERROR wccError;
ZeroMemory(&wccError,sizeof(wccError));
DWORD dwState=0;
VARIANT vtValue;
::VariantInit(&vtValue);
vtValue.vt=VT_R8;
vtValue.dblVal=ablNewValue;
if ( bRet=DMSetValue(&dmvk,1,&vtValue,&dwState,&wccError) )
{
MSG_RTCREATE_STRUCT msgCreate;
MSG_COMMENT_STRUCT msgComment;
ZeroMemory(&msgCreate,sizeof(msgCreate));
ZeroMemory(&msgComment,sizeof(msgComment));
::GetLocalTime(&msgCreate.stMsgTime);
msgCreate.dwMsgNr=1015001;
lstrcpyn(msgCreate.mtTextValue[0].szText,lpszTagName,MSG_MAX_TEXTVALUE);
lstrcpyn(msgCreate.mtTextValue[1].szText,lpszSyffix,MSG_MAX_TEXTVALUE);
lstrcpyn(msgCreate.mtTextValue[2].szText,lpszDesc,MSG_MAX_TEXTVALUE);
msgCreate.dPValue[0]=dblNewValue;
msgCreate.dPValue[1]=dblOldValue;
msgCreate.wTextValueUsed=0x07;
msgCreate.wPValueUsed=0x03;
msgCreate.dwMsgState=MSG_STATE_COME;
DWORD dwServiceID=0;
if ( MSRTStartMsgService(&dwServiceID,NULL,NULL,0,NULL,&wccError) )
{
if ( MSRTCreateMsg(dwServiceID,&msgCreate,&wccError) )
{
msgComment.dwMsgNr=msgCreate.dwMsgNr;
memcpy(&msgComment.stTime,&msgCreate.stMsgTime,sizeof(SYSTEMTIME));
lstrcpyn(msgComment.szUser,lpszUser,MSG_MAX_USERNAME);
lstrcpyn(msgComment.szApplicationName,"ALX",MSG_MAX_APPLNAME);
dwState=MAX_COMPUTERNAME_LENGTH;
::GetComputerName(msgComment.szComputerName,&dwState);
lstrcpyn(msgComment.szText,lpszComment,MSG_MAX_TB_CONTENT);
MSRTSetComment(dwServiceID,&msgComment,&wccError);
}
MSRTStopMsgService(dwServiceID,&wccError);
}
}
::VariantClear(&vtValue);
return bRet;
}
Описание ставим сами
Юзера берем из @CurrentUser
Комментарий берем из lpszTagName.#comment

Настраиваю журнал сообщений о действиях оператора MsgFilterSQL->MSGNR=1015001

Все взаимодействие пользователей ведется через мои ActiveX, где на каждое изменение пареметра генерится подобное сообщение, на различные команды другое...
Re: бесполезности для wincc
shurik; 16.12.03

Ну,честно говоря не ожидал,СПАСИБО

Единственно чего я не совсем понял-механизм формирования Process_Value и соответствующие @?%s@.Может где почитать можно,а то пишут что например формат @1%s@ соответствует Process_Value_1 а откуда он берется ???
Re: бесполезности для wincc
Alexis; 16.12.03

Вызови встроенную справку в wincc и в поиске задай @ и смотри справку по @...@ - Message Texts of a Single Message

Process Value - это вроде как сопутствующие параметры для alarm_8p, ну и для собственных нужд :)

В RT-шной базе хранятся PV1-PV10 как double (в основной таблице) и как char[] (в дополнительной таблице). Если ты записываешь как double, то читай как @1%g@ - @10%g@, если как char, то читай как @1%s@ - @10%s@.
Re: бесполезности для wincc
shurik; 16.12.03

Ну,честно говоря не ожидал,СПАСИБО

Единственно чего я не совсем понял-механизм формирования Process_Value и соответствующие @?%s@.Может где почитать можно,а то пишут что например формат @1%s@ соответствует Process_Value_1 а откуда он берется ???
Re: бесполезности для wincc
shurik; 16.12.03

насчет OCX с часиками - смотрится хорошо, но мне кажется, было бы удобно добавить свойство Visible для изображений иконки пользователя и переключателя часов и переключатель часов сдвинуть вправо.Кстати работаю на WinCC 6 и после внедрения часиков на кадр иногда pdlrt стал рушится при деактивации проекта,могу прислать отчет DrWatsona,но может это и не связано с OCX

Re: бесполезности для wincc
Alexis; 16.12.03

Под шестеркой не проверял, но под пятеркой у меня нормально работает.

Посмотри, может pdlrt чего-нибудь успел сохранить в siemens\wincc\diagnose\ - точно не помню (давно не рушилось :), но помоему pdlrt свою диагностику пишет в файл pdltrash.log


text

WinCC и Delphi
Ковалев Антон; 16.12.03

Откликнитесь, кто работал с данной связкой... нужна пара советов.

Если можно на аську
UIN 25707018
или мыло.
Заране благодарен


text

О выводе русских String в TP170А
Бурдуков Владимир; 1.12.03

имеется ТР170А и S7-313C. В экранной форме пристутствует поле вывода типа String ссылающеся на строку String (такой же длины) в CPU . В процессе выполнения в эту строку заносяться некоторые текстовые константы (русоязычные). Проблема в том что в экранной форме они отображаються не по русски(иероглифы). Причем в Protool Sim все нормально. В чем причина ? пробовал назначать атрибуты Language не помогло. Можно ли вобще это сделать (кроме принудительного присваивания в панели).

Re: О выводе русских String в TP170А
Alex; 15.12.03

Та же проблема. Решения не нашел. А Вы?

Re: О выводе русских String в TP170А
aa; 15.12.03

А вы попробуйте набрать константы русским языком из протула. Т.е. тем языком, который протул добавляет в систему при написании на русском.

Это так- мысли...

Re: О выводе русских String в TP170А
Дмитрий; 16.12.03

Господа! S7-313 не компьютер в котором можно установить и использовать русские шрифты. Пишите латинскими буквами!


text

ProTool как OPC клиент
Соловьев Владимир; 11.12.03

Необходимо использовать ProToolRT как OPC клиент. В Help написано: создайте новый проект, в мастере выберите драйвер OPC. Но вся проблема в том, что в списке драйверов его нет. Поможите, кто может.

Re: ProTool как OPC клиент
Eugene Sergeev; 11.12.03

Ручками пропиши. У меня прописывается без проблем.

Re: ProTool как OPC клиент
Соловьев Владимир; 15.12.03

Ручками, это куда и что писать? Пришлите пример , пожалуйста. можно директом solov@ste.ru

Re: ProTool как OPC клиент
Владимир, Минск; 15.12.03

Я сейчас как раз занимаюсь подобной вещью. Связываю ProTol как OPC клиент c OPC сервером фирмы ICP DAS. Сначала установил OPC сервер, зтем создаю проект ProToll (v6.0+SP2). В процессе создания проекта выбираю OPC server и в параметрах подключаюсь к OPC серверу (можно и позже конечно). Затем создаю теги. Проблем в общем нет. Можешь мне позвонить объясню подробнее. т. +375-172-99-67-98.


text

WinCC 60 vs WebNavigator
Роман; 11.12.03

А где в шестой WinCC WebNavigator? В эксплорере он не появился. И на дисках чего то не нашел. Как тогда опубликовать картинки.

Re: WinCC 60 vs WebNavigator
Дмитрий ; 11.12.03

А вы его поставили? Это дополнительный продукт...

Re: WinCC 60 vs WebNavigator
Роман; 11.12.03

А можно его где-нибудь найти для пробы?

Re: WinCC 60 vs WebNavigator
Goodvin; 15.12.03

WebNavigator v6 в пакет WinCC не входит и поставляется отдельно. "Весит" это удовольствие 225Mb и работает только с WinCC v6.


text

Контроль связи PLC -ProTool
Лександр; 27.10.03

Как можно сообщить контроллеру (7-му) об обрыве связи с протуул?

У меня дисплеем PC...
и если после нажатия кнопки ПУСК, пропадёт связь, как остановить привод, например???

Re: Контроль связи PLC -ProTool
Игорь; 25.11.03

Нужно в программе SIMATIC`a циклически устанавливать какой-нибудь маркерный бит (с периодичностью не менее 200mS )и контролировать его состояние в начале следующего цикла (перед установкой ), а в ProTool`e сбрасывать его. Принцип такой. Всё очень просто.

Re: Контроль связи PLC -ProTool
Сергей; 12.12.03

Необходимо в протуле задать область координтрования. Протут в этой области будет взводить и сбрасывать определенный бит, а на прграмматоре контролировать изменение этого бита.


text

Расчет необходимого числа тегов для лицензии
Григорий; 8.12.03

В каталогу HMI про WinCC Написано, что системы RT могут иметь лицензии на обслуживание 128, 256, 1024, 8192 ( в версии 6.0) или 64 тегов . Под термином тег понимается одна внешняя переменная любого формата ,

которая может быть считана системой WinCC из памяти программируемого контроллера или записана из
WinCC в память контроллера . Один тег способен нести информацию о значении до 32 дискретных сигналов". Что означает последнее предложение: возможность упаковки дискретных тегов в 32-хразрядное слово, используя аналоговый тег или что-то иное. Как считать необходимое число тегов для лицензии?
Вообще какие существуют приемы по минимизации тегов?
Re: Расчет необходимого числа тегов для лицензии
Шимолин Сергей; 9.12.03

Один тег может и 64 дискретных значения нести (если тип тега поставить 64-bit float number) или 8 значений типа byte и т.д. Если задать тип поля Text и размер 255, соответственно можно в один тег завернуть 256*8 дискретных значений... Еще можно создать один тег типа RAW Data type, его размер зависит от кадра передачи данных. Размер кадра зависит от аппаратного обеспечения и для серии S7-300 (насколько изменяет память) в районе 240 байт, и для S7-400 около 400 байт.

На WinCC эти теги нельзя будет подключить напрямую - нужно будет писать выражения разбора на Си. Соответственно, если проект большой, может повыситься нагрузка на станцию WinCC и могут появиться проблемы с обновлением данных.
Так же повышается нагрузка на разработчика. Будешь считать деньги на лицензию - посчитай стоимость работы программиста, который будет тратить на всё это дополнительное время.
Вобщем, "минимизировать" теги - неблагодарное занятие.
Ну а про подсчет тегов - это зависит от разработчика. Например, на обработку 1 аналогового сигнала, может понадобиться несколько десятков тегов (задание настроек, границ и т.п.), а можно и одним обойтись..
Re: Расчет необходимого числа тегов для лицензии
Хоружевский Роман; 9.12.03

Не согласен с Сергеем, по поводу на 1 аналог. сигнал несколько тегом (задание настроек, уставок регуляторов) можно осуществлять используя аналоговый тэг, а вот брать и ложить инфу, можно используя так называемый массив организованный в контроллере, меняя индекс массива, читай из контроллера все что тебе нужно, соответственно и писать можно таким образом, получается какое угодно (в определенных пределах конечно) количество аналоговых значений используя два-три тега. Это так называемая упаковка аналоговых значений. А дискретные нет смылса паковать, во первых скорость опроса будет на на лучьшем уровне, а во вторых меньше прийдется писать скриптов по распаковке.

Re: Расчет необходимого числа тегов для лицензии
Иван Данилушкин; 9.12.03

Поверьте, иногда есть смысл упаковки и дискретных сигналов, особенно когда требуется гарантированное одновременное изменение нескольких булевских переменных!

Re: Расчет необходимого числа тегов для лицензии
Шимолин Сергей; 10.12.03

С такими методами можно и вообще весь проект забабахать через два тега :). А еще можно вообще без тегов обойтись - написать собственную dll - в ней через S7API работать и в internal tags значения передавать. Ну а на internal tags лицензия не нужна.. Так что, у кого есть желание - "работайте".

Re: Расчет необходимого числа тегов для лицензии
Колпащиков Сергей; 11.12.03

Добрый день!

Сергей, а не подскажите где можно прочитать по S7API (ссылочку),
как использовать, что купить и т.д.

Заранее спасибо.
Re: Расчет необходимого числа тегов для лицензии
Шимолин Сергей; 12.12.03

Ссылку не помню - кинул мылом описание в pdf формате.

Хотя, если уж, совсем не хотите использовать WinCC, лучше купить OPC-сервер и работать через него. Тогда можно будет работать хоть из своей программы, хоть из любой другой, где VB встроен.. (например, Word :) ). Это и дешевле будет чем разбираться с S7API, и потом без проблем можно будет любой SCADA-пакет поставить. Сейчас все SCADA-системы поддерживают OPC.


text

Устройство Web Navigator Server
Кирилов Владимир; 11.12.03

Добрый день! Может кто-нибудь рассказать как устроена связь

WinCC<->Web Navigator Server. Оно конечно так-то все работает, но все-таки понимать такие вещи хотелось бы..


text

распайка кабеля дляпрограмирования op27
ddt; 2.12.03

нужна распайка кабеля для програмирования ОР27

заранее благодарен
Re: распайка кабеля дляпрограмирования op27
Baby; 3.12.03

Привет !!!

ddt читайте, plz, доку !!!!!!

Re: распайка кабеля дляпрограмирования op27
VVV; 10.12.03

Давайте мыло - вышлю...Имеется ввиду кабель в СОМ порт?

Re: распайка кабеля дляпрограмирования op27
Роман Абзаев; 11.12.03

Господа - на центральном сайте сервисной поддержки посмотрите!!!

См. http://www.ad.siemens.de/support


text

Ошибки в WinCC из-за архивов
PAS; 14.11.03

Ошибки в WinCC из-за архивов. Когда архивы более 4 Гб WinCC выдает ошибку, и начинает работать, только после того как файл архивов будет обнулен.

Re: Ошибки в WinCC из-за архивов
Вадим Печёрских; 4.12.03

Данная проблема возникала при не правильной настройке Storage.

Кроме этого на качество работы базы WinCC влияет то как проект запускают и останавливают.
P.S. Хранить 4 Гб данных в системе реального времени по-моему не совсем корректно.
Re: Ошибки в WinCC из-за архивов
Шимолин Сергей; 8.12.03

А файловая система какая?

Подозреваю что FAT32.
Под FAT32 максимальный размер файла - 4ГБ и WinCC тут не причём.
Под NTFS ограничение - 16384ГБ.
Re: Ошибки в WinCC из-за архивов
Шимолин Сергей; 10.12.03

И, кстати -

Runtime Database

Maximum data volume of runtime database

The maximum data volume of the runtime database should not exceed 2 GB on the hard disk.

Re: Ошибки в WinCC из-за архивов
Nick; 10.12.03

>> The maximum data volume of the runtime database should not exceed 2 GB on the hard disk.

А для WinCC6.0 вышесказанное справедливо?
Re: Ошибки в WinCC из-за архивов
Юрченко Владимир; 10.12.03

Вопрос о размере базы данных для MS SQL Server - это к Microsoft. На сайте http://www.microsoft.com/rus/sqlserver/overview.mspx написано для MS SQL Standard:

Максимальный размер базы данных: 2 ГБ.
Но в 6-ой версии можно создавать несколько файлов с архивами, а потом и бэкапить их в другое место, так что о максимальном размере файла говорить не имеет особого смысла.
Re: Ошибки в WinCC из-за архивов
Шимолин Сергей; 11.12.03

>>MS SQL Standard:

>>Максимальный размер базы данных: 2ГБ.

2ГБ - это ограничение на ОЗУ. А на размер БД: 1 048 516 TБ.


text

uaArchive vs WebNavigator
Роман; 10.12.03

Господа, подскажите пожалуйста как расместить таблицу пользовательского архива на экране клиента WebNavigator.

Очень надо.

Re: uaArchive vs WebNavigator
Юрченко Владимир; 10.12.03

Опция User Archives поддерживается только в новом WebNavigator 6 (для него нужен WinCC 6 SP1). WebNavigator v.1.* (в комплекте с WinCC 5.*) User Archives не поддерживает.

Re: uaArchive vs WebNavigator
Роман; 10.12.03

А как же быть :-(

Как можно выйти из положения (если можно)?


text

WinAC функция чтения данных
Papik; 10.12.03

Кто может описать функцию

Компонента S7DATA --- ReadVariable(BSTR VariableName, VARIANT* Value, long* State,long TimeOut);
Если можно то по подробнее каждый параметр.

Re: WinAC функция чтения данных
Юрченко Владимр; 10.12.03

Читайте файл compute_e.pdf, страница 206. Файл можно найти на www4.ad.siemens.de/WW/llisapi.dll?func=cslib.csinfo&objid=10953179&lang=en&aktprim=0&u=NDAwMDAxNwAA&siteID=cseus


text

Печать проекта ProTool/Pro V6.0
Игорь; 9.12.03

Приветствую всех в Форуме!

Подскажите, пожалуйста, как добиться печати проекта ProTool/Pro V6.0 SP2 с нормальными (кириллица) комментариями для тэгов и пр. Вместо них выводятся всякие центральноевропейские "зюки".
Пробовал менять кодовые страницы в реестре - не помогает. Может быть я что-то пропустил?
Операционная система - MS Win98 SE.
Поможите, люди добрые, христа ради!


text

DB25F-DB15F
Евгений; 9.12.03

Подскажите распайку 25 пин на 15 пин.

Для принтера - ОР 27.
Заранее большое спасибо.


text

Печать таблицы архива пользователя
Дмитрий; 8.12.03

Для печати данных из UserArchive испольую User Archive-Runtime.Table

в 5-ой версии всё было нормально, а в WinCC 6.0 SP1 цифровые значения не отображаются!
Помогите решить проблему, ПЛИИЗ!
Спасибо!

Re: Печать таблицы архива пользователя
Лев Шерешевский; 8.12.03

Для начала убедитесь, что Вы используете правильный десятичный разделитель. Если это не поможет, опишите подробнее метод печати данных, может что-то удастся подсказать.

Re: Печать таблицы архива пользователя
Дмитрий; 9.12.03

Лев, спасибо за отклик проблема решилась. Разделитель был правильный, а проблема была в использовании в архиве формата поля float, поменял на double и всё заработало. Кривая всё-таки WinCC 6.0


text

CP 1430 TCP и WinCC
Денис Дроздов; 8.12.03

Есть ли какие нибудь нюансы в связи между ЦП и ВинЦеЦе? В частности в программировании SEND/RECEIVE контроллера S5 135. Примеры приветствуются. А то у нас данные идут только на контроллер, а обратно нет.


text

Status Display в WinCC 6.0
Дмитрий; 8.12.03

Здравствуйте!

Господа есть вопросец:
В WinCC 6.0 SP2 в объекте Status Display не работает установка прозрачности цвета.
Посоветуйте, чем можно заменить данный объект и может кто-то его "вылечил"?


text

ProTool...
ViT; 4.12.03

Как организовать цепочку в протуле из множества тегов (условие ИЛИ), чтобы при изменении любого из них включался определённый тег? ProTool 6, SP1.

Re: ProTool...
Юрченко Владимир; 4.12.03

В принципе такие вещи лучше и проще делать в контроллере, но для данного случая легко сделать это, заведя для каждого тега (с условиями или) функцию на изменение значения. А в этой функции уж и изменять другой тег.

Re: ProTool...
ViT; 4.12.03

А какую именно функцию поставить для этих тегов (которые ИЛИ)? В списке функций нету такого - изменение значения. Нужно чтобы каждый тег из этой цепочке (ИЛИ) при его включении устанавливал конечный тег в 1, а при отключении - в 0.

Извините, но может быть у меня примитивные вопросы, но я не знаю как это сделать.
Re: ProTool...
ViT; 4.12.03

"Нужно чтобы каждый тег из этой цепочке (ИЛИ) при его включении устанавливал конечный тег в 1, а при отключении - в 0. " - но если включенно одновременно, допустим 2 тэга из этой цепочки, то конечный тэг продолжает оставаться единицей, при отключении одного из этих тэгов, он также остаёться -1, при отключении всех тегов - он сбрасываеться на 0. Ну это обычное условие цепочки ИЛИ... :)))

Re: ProTool...
Юрченко Владимир; 4.12.03

Ну во первых последнее Ваше задание отличается от первого (в первом было просто изменение). Можно сделать и это написав скрипт на VB (если проект для Windows CE или RT), где все эти условия и описать, а вызывать этот скрипт из функции изменения тегов.

А еще лучше (повторяюсь) сделать это в контроллере - надежней и легче.


text

Конфигурация Tag Logging
Коростелёв; 2.12.03

Есть ли какой-нибудь быстрый способ редактировать конфигурацию Tag Logging? Существует ли экспорт в CSV или еще какой-нибудь быстрый метод?

Re: Конфигурация Tag Logging
Лев Шерешевский; 2.12.03

Используйте опцию WinCC Configuration Tool для быстрого редактирования конфигурации проекта в Excel.

Re: Конфигурация Tag Logging
Коростелёв; 2.12.03

Эта опция продаётся за деньги или доступна бесплатно?

Re: Конфигурация Tag Logging
Лев Шерешевский; 4.12.03

Этот пакет входит в комплект поставки WinCC. См. раздел Smart Tools справочной системы WinCC.


text

? Кто-нибудь работал с GSCGenGetSourceCode из под Delphi
Шимолин Сергей; 4.12.03

Нужно программно (из Delphi) изменить и перекомпилировать скрипты объектов. Для этого получаю компилированный скрипт PDLCSGetAction, перевожу в строковое представление с помощью GSCGenGetSourceCode. Код скрипта выдает следующий:

#include "apdefap.h"
long int _main (char* lpszPictureName, char* lpszObjectName, char* lpszPropertyName)
{
/*V10 3 1 3 1 AI_ALKALINE/T_PIPE_2163_2.EN_UPDATE 3 0 5 COLOR_PARAM_EN_UPDATE('AI_ALKALINE/T_PIPE_2163_2.EN_UPDATE')//@ExpEnde */
#include "apdefap.h"
long _main(char* lpszPictureName, char* lpszObjectName, char* lpszPropertyName){
// WINCC:TAGNAME_SECTION_START
// syntax: #define TagNameInAction "DMTagName"
// next TagID : 2
#define TAG_1 "AI_ALKALINE/T_PIPE_2163_2.EN_UPDATE"
// WINCC:TAGNAME_SECTION_END

// WINCC:PICNAME_SECTION_START
// syntax: #define PicNameInAction "PictureName"
// next PicID : 1
// WINCC:PICNAME_SECTION_END

return (COLOR_PARAM_EN_UPDATE((unsigned long)GetTagDouble (TAG_1)));
}
}

Собственно, смущает что полученный код скрипта вложен еще в какой-то код, и в начале что-то в двоичном виде идет. Это формат какой-то кода скрипта или у меня ошибки. Ну и функция GSCGenGetSourceCode первый раз отрабатывает нормально, а затем Exception вылетает.

У кого-нибудь есть опыт по этой теме?


text

Ошибка связи канала PROFIBUS
Макс Прилепский, ОАО "ЗСМК"; 20.11.03

Кто - нибудь встречался с ошибкой , имеющей код 0xFFDF D801 (код находился в файле SIMATIC_S7_PROTOCOL_SUITE.LOG)?

При этом связь PLC (S7-300) со станцией WinCC то появляется, то исчезает ("мигание" полей вывода примерно раз в секунду). Может быть, имеет место перегруженность канала?
Re: Ошибка связи канала PROFIBUS
Baby; 3.12.03

Привет !!!!

Какой PLC ?
Как организована связь по Profibus ?

Re: Ошибка связи канала PROFIBUS
Макс Прилепский, ОАО "ЗСМК"; 4.12.03


text

число экранов в ProTool 6.0 SP1?
ViT; 2.12.03

использую панель TP270 10". Про тул после 10-ти созданных экранов пишет, что максимальное число экранов уже достигнуто... Неужели можно всего 10 экранов забабахать? или это ограничения отсутствия авторизации?

Re: число экранов в ProTool 6.0 SP1?
Юрченко Владимир; 2.12.03

На ProTool для панелей никаких лицензий для работы не требуется. Просто есть ограничения на ресурсы - память в панели не резиновая. Постарайтесь уменьшить размер файлов с картинками, которые вставляются на экраны.

Re: число экранов в ProTool 6.0 SP1?
Игорь_К; 2.12.03

В тех докумендации, например на панель ТР 170А, написано число экранов, число сообщений и т. д., а далее приписка, что каждое число получено при условии единоличного занятия памяти.

Re: число экранов в ProTool 6.0 SP1?
ViT; 2.12.03

вот описание к моей панели:

Память
·Тип
Flash / RAM
·Используемая память для данных пользователя 2048 KByte
(мой проект - 3 файла .fwd,.pdb и .tfx занимает 492 кБ)

Экранов процесса 300
·текстовых объектов
10.000 текстовых элементов
·переменных на экран
200
·графических объектов
Bitmaps, Icons, подложки, векторная графика
·динамических объектов
Диаграммы, балки, слои, невидимые клавиши
-библиотеки
Да

В чём может быть проблема?

Re: число экранов в ProTool 6.0 SP1?
ViT; 3.12.03

извините, конечно, за ложную тревогу, но у меня всё заработало. Незнаю из за чего это было - то ли ПроТул глуканул, то ли система, но сейчас всё заработало (видимо после перезагрузки)...


text

Поменять шкалу тэга в RunTime
Коростелёв; 2.12.03

Можно ли в режиме RanTime поменять пределы шкалы (Scale) тэга в WinCC?

Re: Поменять шкалу тэга в RunTime
Евгений Трунов; 2.12.03

К сожалению, нельзя.


text

Advantech+WinCC
Олег; 28.11.03

Кто нибудь пробовал Advantechовские платы к WinCC подключать. Через ADSAPI.DLL или через ActiveXы из ActiveDAQ или еще как-то.

Пробовал через функции ADSAPI.DLL, но что-то не выходит, а через ActiveDAQ - не знаю, как из скрипта WinCC сделать команду на BitInput для ActiveXа.
Если есть примеры, пришлите - буду благодарен.
Re: Advantech+WinCC
Yrok; 29.11.03

Без номера платы ничего не могу конкретно сказать, но скажу одно у меня есть подобная плата и она работает через функции в DLL так что необходимо подключать к WinCC DLL-ку.

А вообще WinCC нормально работает с Advantech.
Re: Advantech+WinCC
Олег ; 1.12.03

PCI-1733

Re: Advantech+WinCC
Олег; 2.12.03

C ADSAPI.DLL у меня проблема следующая:

Функции DRV_DeviceOpen, DRV_DeviceClose, DRV_AIConfig, DRV_GetErrorMessage работают нормально, а вот функции, производящие считывание/запись дискретных и аналоговых сигналов с плат (DRV_AIVoltageIn, DRV_DioReadPortByte и т.д.), при попытке их вызова отвечают:
=============On Error Execute==========
dwErrorCode1: (ThreadId 2456) 1007001
dwErrorCode2: (ThreadId 2456) 4100
szErrorText: (ThreadId 2456) Exception in Action
szErrorTextException:(ThreadId 2456) access violetion
szApplicationName:(ThreadId 2456) PDLRuntimeSystem
bCycle: (ThreadId 2456) acycle
szFunctionName: (ThreadId 2456) @2
lpszPictureName:(ThreadId 2456) NEWPDL0
lpszObjectName: (ThreadId 2456) Button1
lpszPropertyName:(ThreadId 2456) (NULL)
dwParamSize :(ThreadId 2456) 12
=============On Error Execute==========
Уточняю, что я пока работаю с виртуальной платой Advantech DEMO. Возможно, ситуация изменится, когда будет реальная плата. А, может быть, я как-то не правильно задаю параметры при вызове этих функций, или не правильно заданы приемные структуры данных, или типы данных. Хотя я все делаю по примерам Advantech'а.
А может сама Windows 2000 не дает DLL'ке считать данные с портов? Но Advantech пишет, что на Windows 2000 данная DLL'ка должна работать.
Если есть примеры работающих скриптов WinCC с этими функциями – вышлите на email.

Re: Advantech+WinCC
Yrok; 2.12.03

К сожалению я не нашёл свой старый проект на дельфи но раскажу в кратце. Вместе с платой поставлялся компакт диск на диске были драйвера и примеры для бейсика, посмотрел как делают и подключал на С++ и там всё делалось через динамическую билиотеку, так что ищи в драйверах и примерах к плате, кстати на диске должно быть и описание.

У меня кстати плата PCI-1750
Вот тебе ссылка на твою плату и драйвер.
http://service.advantech.com.tw/eservice/index.asp

Re: Advantech+WinCC
Yrok; 2.12.03

А ты когда открываешь к примеру порт или устройство полученный HANDLE ты не теряешь после этого, если да то примерно такие ошибки и будут

Re: Advantech+WinCC
Олег; 2.12.03

Нет, в том то и дело, что не теряю, я даже потом могу пользуясь этим HANDLЕ'ом сделать DRV_DeviceClose, и оно нормально делается.

И еще, так вы прямо из скрипта WinCC вызывали функции ADSAPI.DLL или писали свою маленькую DLL'ку на C++, в которой делали функцию, вызывающую функции ADSAPI.DLL, а уже эту самодельную функцию вызывали из скрипта WinCC?
Re: Advantech+WinCC
Yrok; 2.12.03

Дело в том что WinCC как то не понятно работет иногда, поэтому я писал свою DLL а от туда уже вызывал функции Advantech.

Re: Advantech+WinCC
Олег; 2.12.03

Все понял, буду писать свою DLL.

До этого я пытался работать прямо из WinCC. Вы очень точно подметили: "WinCC как то не понятно работет иногда".
Спасибо за содействие.
Если и из DLL'ки работать не будет, тогда еще отпишусь.


text

Edit
Yrok; 29.11.03

Подскажите как сделать чтобы окно ввода в WinCC без подсоединённого тега позваляло вводить данные в него.

Re: Edit
Лев Шерешевский; 1.12.03

Для события Change свойства Input Value поля ввода создайте прямое соединение, копирующее значение Input Value в атрибут Output Value.

Re: Edit
Yrok; 2.12.03

Спасибо


text

Русские надписи в ProTool 6.0 SP1
ViT; 25.11.03

Проблема такова:

Подгружаю в sistem-language assignment русский язык, ставлю его везде (в editing, в reference language, в online languages). В toolbar'е ставлю русский язык. Делаю русскую надпись и английскую,но при старте протула - русских надписей не видно, а англицкие есть. Подскажите что делать? Не охота делать картинки с русскими надписями...
Re: Русские надписи в ProTool 6.0 SP1
Игорь; 25.11.03

Если у Вас в "online languages" стоит только русский, то все будет нормально видно. Если в "online languages" более одного языка, то при STARTUPe инициализируется тот язык, который стоит первым в "online languages", а далее надо переключаться, используя "Functions - Toggle - Language". Всё очень просто.

Re: Русские надписи в ProTool 6.0 SP1
ViT; 25.11.03

Спасибо, получилось. А описания Pro Tool'а 6-го на РУССКОМ языке с каким-нибудь get starting'ом нету у вас? Было бы просто замечательно...

Re: Русские надписи в ProTool 6.0 SP1
Игорь; 25.11.03

Документацию на русском языке можно скачать на русском сайте SIEMENS ( http://www.automation-drives.ru/as/products/doc.php?l1=SIMATIC%20HMI&l2=ProTool&l3=doc ).Правда, там нет документации по V6.0, но для начала работы вполне достаточно.

Re: Русские надписи в ProTool 6.0 SP1
ASU; 1.12.03

Спасибо Игорь.

Мне тоже помог Ваш совет.


text

Ввод отрицательных чисел
Александр Клейн; 27.11.03

Столкнулся с глупой ситуацией: а как в поле ввода/вывода ввести отрицательное число? WinCC полностью игнорирует нажатие клавиши "минус" как на основной, так и на дополнительной клавиатуре. Тег "floating Point". Вроде бы все должно работать, но не работает.

Re: Ввод отрицательных чисел
Лев Шерешевский; 28.11.03

В свойствах поля ввода-вывода у атрибута Output Format в начале строки формата добавьте s для явного указания использования знака.

Re: Ввод отрицательных чисел
Александр Клейн; 30.11.03

Спасибо за совет, проблема решена!


text

распайка LPT-- RS232
Евгений; 28.10.03

Re: распайка LPT-- RS232
Чистяков Дмитрий ОАО СеверСталь; 28.10.03

Такого быть в принципе не может из-за разных электрических параметров сигналов. ;-)

Re: распайка LPT-- RS232
Yrok; 28.10.03

Есть специальные преобразователи RS232-LPT. Для справки: RS232 последовательный порт (Достаточно трёх проводов для связи), LPT Паралельный порт проводов дохрена, (данные передаются паралельно)

Re: распайка LPT-- RS232
Eugen Sergeev; 29.10.03

К ОР27 подключается только последовательный принтер. Копай или в сторону встраиваемых пром. принтеров (они почти все с 232) или ищи ширпотребовский с соответствующим модулем (таких я дааааавно не видал).

Re: распайка LPT-- RS232
В. Сорокин.; 31.10.03

В старых букварях (80-х лет) по электронике или цифровым системам встечались такие преобразователи. Можно и самому собрать, если горит. Громоздко, но дёшево.

Re: распайка LPT-- RS232
Чистяков Дмитрий ОАО СеверСталь; 31.10.03

В. Сорокин.

Я думаю Вы не совсем правы, что это так просто. Т.к. если преобразовать электрические сигналы просто, то ведь не стоит забывать и том, что должен быть ещё и софт, который сможет со всем этим добром работать. Я не уверен, что подобный софт включён в состав OP27. ;-)

Re: распайка LPT-- RS232
В. Сорокин.; 3.11.03

Так ведь софт-то можно и симмитировать, когда-то до этого доходило дело. Потому и громоздко будет. А правильнее, действительно, купить последовательный принтер - это сейчас не проблема.

Re: распайка LPT-- RS232
Yrok; 4.11.03

Да именно нужно купить принтер с последовательным интерфейсом. И я опять повтаряюсь яя лично держал преобразователь в руках который не требует никакого софта, к примеру подключал к прибору который выдаёт на последовательный порт распечатку и через преобразователь подключал принтер HP DJ400 и всё работало без всякого софта.

Re: распайка LPT-- RS232
Чистяков Дмитрий ОАО СеверСталь; 4.11.03

Значит этот преобразователь интелектуальный. То бишь в нём имеется CPU и два порта (LPT и COM). Соответственно такой софт зашит в преобразователь.

Вот только вопрос сколько такой преобразователь стоит?
Re: распайка LPT-- RS232
Eugen Sergeev; 4.11.03

Таких прибамбасов лет 10 назад изрядно было, даже сам как-то ваял, работы на пару дней. Правда, уже давно таких не видал.

Re: распайка LPT-- RS232
Yrok; 4.11.03

У меня был тайванский defender

Re: распайка LPT-- RS232
Eugen Sergeev; 5.11.03

Гугла на запрос serial LPT converter выдает кучу ссылок. Самопальный, правда, только один нашел.

Re: распайка LPT-- RS232
В. Сорокин.; 6.11.03

Не мучайтесь. Принтер здесь.

http://www.megashop.ru/basket/index.php?level=1&c_flag=1&PHPSESSID=d64d2e210588e8cec1abc7e71eedb5e5
Re: распайка LPT-- RS232
В. Сорокин.; 6.11.03

А преобразователь здесь.

http://www.vibrotek.com/pl36/more.htm

А ещё фраза такая встречается:
Converter SP-1000 Преобразователь в LPT
© 2000 Компания TERSYS г.Москва, ул.Солянка, д.1/2 стр.1, тел./факс (095) 230-60-57
Попробуйте позвонить.

Re: распайка LPT-- RS232
Yrok; 6.11.03

Кстати у меня и был SP-1000

Re: распайка LPT-- RS232
ddt; 29.11.03

пожалуй принтер lx300 будет дешевле этого преобразователя, а COM порт у него есть

Re: распайка LPT-- RS232
Yrok; 29.11.03

Это точно лучше принтер, у меня кпримеру подвисоны блока были конкретные, всё зависело от того какое устройство было включено первым, прибор или принтер.


text

op27mono & распайка кабеля для програмирования
ddt; 29.11.03

1 op27 прчемуто не хочет переходить в режим програмирования.

2 необходима распайка кабеля COM-IF2,
пробовал собрать, не пошло.
буду благодарен за помощ

Re: op27mono & распайка кабеля для програмирования
Yrok; 29.11.03

У меня панель TP27-10 при загрузке она сама высвечивает меню в катором есть кнопка переключения в режим Transfer. А на OP7 нужно нажать две кнопки одновременно вверх и вправо и подать питание. На OP27 наверняка тоже какие нибудь кнопки. Кстати кабель который подходит к OP7 подходит и TP27 поэтому следует предположить что и подходит к OP27 так что в понедельник отвечу какая распайка.


text

Картинки в WinCC+ProTool
Дмитрий; 28.11.03

Повторяюсь конечно, но может кто даст дельный совет как исправить положение дел с библиотекой символов.

нужно:
1) WinCC - runtime на PC
2) WebNavigator Server (шоб на клиенте все было Ok)
3) Protool - для работы на панельку (MP370)
Нрмально работает последний установленный (WinCC или ProtooL неважно) предыдущий отображает картинки НАСОСИКАМИ.
Re: Картинки в WinCC+ProTool
Александр Родин, ООО "Нева Электрик"; 28.11.03

Ага, есть такой глюк... причем очень смешной.. :)

А делать надо следующее:
1. открыть рисунок, на котором насосики;
2. двойной щелчок на каждом насосике;
3. закрыть окно конфигурации элемента.

После этого все будет нормально.. :)

Re: Картинки в WinCC+ProTool
Дмитрий; 28.11.03

Это не глюк. Это надо программистам СИМЕНС по шапке надавать. Эти картинки выполнены как ActiveX компоненты и идут с WinCC и Protool и ставятся в разные директории!!! Кто последний, тот и прав!


text

совместимость авторизаций для Web Navigator
Роман Журавлев; 26.11.03

Уважаемые коллеги, подскажите ,пжлста, если сделать апгрейд с 3 до 10 клиентов для WN ver.1.0, а затем поставить WN ver.1.1, останется ли действительной лицензия на 10 клиентов? спасибо

Re: совместимость авторизаций для Web Navigator
Роман Папировский; 28.11.03

C апгрейтом лицензий для WN я не сталкивался, но лицензия для версии 1.0 работает и с версией 1.1 и 1.2


text

OLE DB Provider
Alexey; 27.11.03

Поможите!!!! Как подключить эту весчь скажем к Borland C++ или скажем к VB.

Срочно. Желательно с примерами извлечения тэгов с их значениями. :)
Re: OLE DB Provider
Маслов Дмитрий; 28.11.03

Если у Вас на той машине, где запущен WinCC Runtime, установлен Visual

Basic, то процедура соединения с базой данных WinCC через WinCC OLE DB
Provider крайне проста и производится с помощью визуальных средств.
Этот процесс пошагово описан в WinCC Information System
в разделе "Interfaces - Database Ports - Access to WinCC Archive Data -
Display of the Archive Data - Configuring the Display of the Archives
with Visual Basic".

Об интерфейсе OLE DB можно
прочитать практически в любой книжке по Visual C++ или Visual Basic.
Неплохо написано, например, в довольно старой книжке:

Беннет Д. и др. VISUAL C++. Руководство разработчика. - Москва,
Диалектика, 1998.


text

Обмен сообщениями PLC->WinCC
Михаил; 26.11.03

Немогу понять и найти документацию желательно с примерами как организовать отображение аварийных сообщений в WinCC но не битовым методом а с помощью посылки сообщ из PLC в WinCС. Инициатор PLC

Re: Обмен сообщениями PLC->WinCC
Маслов Дмитрий; 28.11.03

Читайте руководство на сайте Siemens:

http://www4.ad.siemens.de/WW/news/en/1144907

Там же есть пример кода на STL

Если что-то не понятно, или не получается, пишите мне на wincc@industrialauto.ru

Или приезжайте к нам на курсы - покажу все на реальном железе...


text

! Нужен ODGSC.hlp
Шимолин Сергей; 26.11.03

У кого есть киньте файл ODGSC.hlp. Я так понимаю в нем должно быть описание Script Programming функций.

Re: ! Нужен ODGSC.hlp
Шимолин Сергей; 26.11.03

разобрался - ссылка в помощи просила файл ODGSC.hlp, а на самом деле он называется ODGSCenu.hlp (т.е. для английского языка).


text

Protool
Павел; 24.11.03

Чем отличаются 6AV6581-3BX06-0BX0 и 6AV6581-3BX06-0CX0.

Re: Protool
Юрченко Владимир; 26.11.03

6AV6581-3BX06-0BX0 - ProTool 6SP1

6AV6581-3BX06-0CX0 - ProTool 6SP2.
Новое в SP2 :
Mobile Panel 170
MP370 15”
Ethernet (ProTool/Pro)
Data type „StringChar“
Option ThinClient/MP
поддержка WinXP
интеграция со STEP7 V5.2


text

OP7
Алексей; 23.11.03

Можно ли ввести стрелочки вверх вниз в текст экрана?

В символьном наборе OP7 они существуют и их можно вывести через тег типа STRING (коды символов C1 C2).
А вот как их поместить на экране в ProTool без перенных на прямую?
К сожалению не получилось. Может кто знает.
Заранее спасибо.

Re: OP7
VVV; 25.11.03

Я использую это так ^ вверх v вниз...


text

Alarm Logging RT - нет текстов в таблицах
Александр Родин, ООО "Нева Электрик"; 8.10.03

Столкнулся со следующей проблемой.

У себя на рабочей машине создал проект. В нем на некоторых экранах есть вывод таблиц ShortTerm Archive от Alarm Logging-а. Проверял, связь работает, реакция на алармы есть, тексты в таблицах выводятся.
Скопировал проект на другой компьютер, запустил проект - связь с контроллером есть, визуально наблюдаю реакцию на алармы, а вот текстов в таблицах нет. Точнее строчки выводятся, но пустые или с каким-то мусором.
Разница между машинами только в версии SIMATIC NET. На той, где проект создавался стоит SIMATIC NET с CD 05/2000, а там, куда копирвал установлен SIMATIC NET с CD 07/2001+SP5

Вычистил Alarm Logging, вычистил TextTable, заново набил все сообщения и сформировал классы/типы/группы. ситуация та же.

Сконфигурированный язык - Русский

ОС Windows 2000 Pro RUS+SP3
WinCC 5.1
Re: Alarm Logging RT - нет текстов в таблицах
Евгений Трунов; 8.10.03

Если тексты на русском языке, то ещё и не то может быть :-). Попробуйте english message textes - ежели их не калечит, значит, причина в настройках великого и могучего на машине #2.

Re: Alarm Logging RT - нет текстов в таблицах
Александр Родин, ООО "Нева Электрик"; 17.10.03

Проблема решилась установкой HF4.

Но возникла новая беда. На всех машинах, которые есть у меня проекты выполняются отлично.
На компьютерах заказчика ситуация следующая: если HotFix не установлен, то возникает ситуация, которая описана в предыдущем топике, если установить HotFix, то при открытии WinCC Explorer вылезает ошибка "Could not open mcp_cs.dll", далее проект открывается, но в нем отсутствует Graphics Designer, а при попытке запуска RunTime, запуск обрывается.

Наличие библиотечки я проверил - в папке она присутствует.

Конфигурация компа следующая: Pentium II 450MHz, 128Mb RAM, мать на Intel BX440, HDD 20Gb, сеть Intel 10/100 Mbit, Video ATi Rage 128.
Re: Alarm Logging RT - нет текстов в таблицах
Александр Родин, ООО "Нева Электрик"; 24.11.03

Нашел в чем беда:

Клиенту ставил WinCC c диска, который был вложен в сумку с форума для партнеров.. (я его использовал до этого как резервную копию при разъездах :) М-да, вот и получилась коза.. Так что если кто хочет использовать партнерский "подарок", как рабочий - ничего не выйдет... ;)
Вот... Но лишнюю неделю на севере просидеть пришлось.


text

Установка бита в теге
mihaha; 18.11.03

Есть ли возможность в WinCC устанавливать отдельно биты тегов формата Dword или word.Например,есть тег tt , тип word.Необходимо изменить не весь тег а только один бит в заданном разряде.Какими средсвами это можно осуществить.

Re: Установка бита в теге
Yrok; 18.11.03

void CBBBDlg::SetByteBit(int* iSource,int NumBit,bool bStatus)

{//Устанавливаем нужный бит в 1 или 0 в слове
//iSource = Слово в котором нужно
//установить бит
//NumBit = номер бита
//bStatus = TRUE или FALSE

int iBits=1;
iBits=iBits<<NumBit;
if(bStatus)
*iSource|=iBits;
else
{
iBits=~iBits;
*iSource&=iBits;
}
}

bool CBBBDlg::GetByteBit(int* iSource,int NumBit)
{int itemp=1;
itemp<<=NumBit;
if(*iSource & itemp)
return true;
else
return false;
}
Эти два примера я отлаживал на С++ также проверял и в WinCC всё работает.
Первый пример устанавливает бит
Второй пример считывает
И есть способ средствами самого WinCC
К примеру контроль бита
Поставь кнопку на кадр, войди в свойства цвета, выбери любой цвет и правой кнопкой выбери Dinamic Dialog
В появившеемся окне мышкой кликни на радио баттоне BIT в области Data Type
далее выбери нужный Тэг и нужный бит.

А про установку где то читал сейчас не помню поищу если найду напишу.

Re: Установка бита в теге
Yrok; 18.11.03

Слушай что то похожее нашёл и кажется делают с помощью "С" а вообще лучше скачай документацию по конфигурированию здесь

http://automation-drives.ru/as/products/doc.php?l1=SIMATIC%20HMI&l2=WinCC&l3=doc
Re: Установка бита в теге
mihaha; 19.11.03

спасибо за помощь,буду пробовать.

Re: Установка бита в теге
Шимолин Сергей; 20.11.03

Как-то у вас всё запущено! :)

Биты можно устанавливать так:
1. В окне Dynamic Wizard выбираем страничку Standard Dynamics
2. И запускаем Setting/Resetting bit или Setting/Resetting bits

по этому мастеру сгенерируется примерно следующий код:

#define TAG_0 "NewTag_5"
PicNameInAction "PictureName"

DWORD dwHelp1,dwHelp2;

dwHelp1=GetTagDWordWait(TAG_0);
dwHelp2=dwHelp1|8;
SetTagDWordWait(TAG_0,dwHelp2);

//8 - это маска установки бита, в данном случае 3-го бита слова dwHelp2.

Re: Установка бита в теге
mihaha; 23.11.03

Огромное спасибо Сергей.Буквально вчера я сам тоже нарыл эту возможность в волшебнике динамизаций.

Re: Установка бита в теге
Yrok; 24.11.03

Не третьего а четвёртого и в твоём случае это маска а в моём примере это конкретный бит.


text

ГОСТ 21829-76 Система "Человек - Машина"
Victor; 21.11.03

У кого есть ГОСТ 21829-76 Система "Человек - Машина". Пришлите пожалуйста.


text

Запускаю Runtime, а WinCC...
Игорь Одесса; 17.11.03

Господа, подскажите, в чем причина,есть WinCC 5.1 с лицензией 256, как только запускаю runtime комп перезагружается,OS Windows 2000 sp3. Ничего не помогает, а работать надо.

Re: Запускаю Runtime, а WinCC...
Александр Родин, ООО "Нева Электрик"; 17.11.03

Скорее всего перезагрузка связана с появлением ошибки Critical Stop... В простонародии "синий экран". Чтобы уточнить это, надо в настройках (Пуск\Настройка\Панель управления\Система\Дополнительно\Загрузка и Восстановление системы) убрать галку "автоматическая перезагрузка". Из-за чего? По всей видимости драйвер связи. Какой у вас коммутационный процессор воткнут ? Такое поведение у меня многократно наблюдалось после накатывания сервис-паков к виндам при уже установленном софте сименса. В основном глюки идут с драйверами под PROFIBUS, в частности под CP5611.

Re: Запускаю Runtime, а WinCC...
Игорь Одесса; 17.11.03

Да, это синий экран. дело в том, что на этом компе у меня нет коммуникационной карты :),но и без карты все же должно работать.Подскажите,что происходит, что надо сделать.

Re: Запускаю Runtime, а WinCC...
Любитель Симатика; 17.11.03

А вот и нет! В readme читать надо. Сися без сетевухи вообще работать не будет. Как минимум(если сетевика нет) надо поставить MS Loopback Adapter как програмную эмуляцию сетевой карты.

Re: Запускаю Runtime, а WinCC...
Игорь Одесса; 18.11.03

"Обычная" сеть у меня есть(Ethernet карта присутствует)

Re: Запускаю Runtime, а WinCC...
DEE; 18.11.03

Hi!

Таже самая байда и у меня сейчас! Раньше, кстати, не наблюдалось а потом такой баг появился, с чем связано не знаю...Снёс WinCC ,буду переставлять, может поможет...Может, нужно было попробовать, что г-н Родин предлагает.. Но уже поздно.:-)

Re: Запускаю Runtime, а WinCC...
Александр Родин, ООО "Нева Электрик"; 18.11.03

Без сетевушки можно работать и это вполне нормальная ситуация при отладках. А вот то, что WinCC обрушивает иногда систему - это не нормально. Причем, скорее всего обрушивает ее даже не WinCC, а, как я говорил, драйвер связи. Не знаю с чем это связано, но видимо (возвращаясь к своему первому сообщению), при установке сервиспака что-то изменяется или в реестре, или в копируемых библиотеках, в результате чего происходит конфликт. Единственный выход из этого переутсановка системы, установка сервис пака, и только после этого установка всего сименского софта. Мне помогало только это. Если у кого есть иные предложения - готов выслушать.

Re: Запускаю Runtime, а WinCC...
Игорь Одесса; 19.11.03

Все переставил, но все равно ничего не работает. Может есть еще варианты?

Re: Запускаю Runtime, а WinCC...
Юрченко Владимир; 20.11.03

Проверенный и надежный вариант -английская Windows2000 SP2 или SP3. И естественно форматированный с NTFS диск. По крайней мере из выше описанного я не понял так это или нет.

Re: Запускаю Runtime, а WinCC...
Роман; 21.11.03

Ребята, выход один ставить и сносить софт до тех пор, пока он не встанет нормально, была похожая проблема, это единственный способ. А софт очень часто встает криво. А еще иногда зависит от железа, на нормальных машинах, собранных не где-то за углом, все работает нормально, проверено.


text

Export/import в ProTool
Соловьев Владимир; 13.11.03

Подскажите, имеются ли в ProTool средства экспорта/импорта тегов, multiplex tags, текстовых списков.

А то получается куча непроизводительной работы по заданию тех же multiplex tags для различного оборудования, из прямо скажем, неудобного интерфейса их конфигурирования. И может кто подскажет, к кому (куда) обращаться с пожеланиями по улучшению и с багами ПО Сименс.
Re: Export/import в ProTool
Симахин Александр; 18.11.03

Это возможно только для контроллеров S7-300-400. Т.е. при установке ProTool

нужно его интегрировать в Step7. Тогда можно при создении тега выбирать его в ProTool во всплывающем окне отображающем таблицу символов из Step7. Также создавать проект в ProTool лучше из Step7 путем вставки в проект ОР. Создается иконка кликаем по ней открывается ProTool и в нем создаем проект для нужной нам панели. Остается только в настройках контроллера выбрать нужный нам PLC и тогда в окне создания тегов можно будет поставить галочку With Symbol и откроется долгожданное окно.
Re: Export/import в ProTool
Соловьев Владимир; 20.11.03

Спасибо, я так все и делаю. Вопрос в другом!!!! У мнея есть 10 (100) однотипных объектов (клапанов, задвижек, танков ....). Я их хочу отображать на одной картинке по изменению некоего индексного тега. В ProToolе для этого есть такой метод - подстановка тегов(tag multiplexing). Так вот для подготовки этой таблицы подстановок вызывается жутко неудобное диалоговое окно, которое я должен заполнить для КАЖДОГО свойства КАЖДОГО объекта руками (путем выбора тегов из выпадающего списка). Тегов в списке отображается мало, всегда начиная с первого, длина поля маленькая, а теги длинные все это приводит к большому количеству опечаток при выборе(просто ткнул в соседний тег и не заметил после трех часов такой мышиной возни)

Так вот вопрос был в том, КАК избежать такой дурацкой работы. По опыту работы с другими продуктами я бы сделал так, отработал бы один-два объекта, после чего экспортировал бы полученнные списки тегов в текстовый файл и способом вырезать/вставить, заменить заполнил бы оставшиеся объекты. Но в ProTool'е я этого не нашел!!! Поэтому работу, которую можно сделать за полчаса и без ошибок, мне пришлось делать в течении двух дней, а потом еще два дня вылавливать опечатки. И как с этим бороться, кто подскажет?


text

PCS 7 6.0
Дмитрий; 12.11.03

При старте операционки запускается "SIMATIC NET information service", может кто-нибудь сказать что это за вещь и зачем она нужна?

Re: PCS 7 6.0
Михайлин Сергей; 18.11.03

Вы спрашиваете про службу или программу?

Re: PCS 7 6.0
Дмитрий; 19.11.03

Здравствуйте, Сергей!

Меня интересует служба, зачем она запускается каждый раз и зачем потом висит в памяти?


text

PCS7
Виктор; 18.11.03

Как можно слить два проекта в PCS7 V5.2 ?

Как установить русский язык в WinCC V5.2 ?
Re: PCS7
Любитель Симатика; 18.11.03

Использовать функцию Merge в Simatic Manager.

В Text Library сказать Add Language и добавить Russian.


text

принтер
Евгений; 20.10.03

Может кто подскажет общую концепцию

вывода сообщений на печать через OP27
(PLC S7-CPU314 2DP).
заранее брагодарен.

Re: принтер
Симахин Александр; 18.11.03

При создании проекта для ОР27 в ProTool

предлагается использовать стандартный проект. Печать идет картинки экрана либо буфера сообщений (возможна печать сообщений с фильтром). Т.е. формируешь картинку которую хочеш видеть на принтере и отправляешь ее на печать. В стандартном примере все это есть. Только не стоит забывать о том, что принтер должен быть с последовательным портом (с параллельным ОР37)


text

Vallo
Нужна распайка кабелей PG6xx - PG6xx и PG6xx - PC; 17.11.03

Нужна распайка кабелей PG6xx - PG6xx и PG6xx - PC.

Есть ли в AG-разъеме PG6xx интерфейс RS232 (кроме TTY).
Требуется обмен файлами в обе стороны (в случае PG - PC).


text

PCS 7 FaceplateDesigner библиотеки
Исаев Георгий Михайлович; 6.11.03

Есть ли у вас руссифицированные библиотеки стандартных объектов (клапана, регуляторы, аналоговые входа и т.д.). Если есть то какие ваши условия по их передачи нам.

Re: PCS 7 FaceplateDesigner библиотеки
Михайлин Сергей; 11.11.03

А для какой версии PCS7? Для 5 или 6? Это принципиально, потому что в 5 faceplate это осх объекты, а в 6 это простые pdl.

Re: PCS 7 FaceplateDesigner библиотеки
Исаев Георгий; 12.11.03

Для версии 6.0. Кстати никто не пытался руссифицировать стандартные Control Object WINCC v 6.0? (WINCC Alarm Control, WINCC Function Trend Control и т.д). Если аварийные сообщения можно перевести с помощью Text Library, pdl частично переводятся(хотя и криво) с помощью Easy Language, то как руссифицировать Control Object не понятно.

Re: PCS 7 FaceplateDesigner библиотеки
Михайлин Сергей; 12.11.03

Для 6 версии перевод faceplate в процессе. До конца года надеюсь будет. Насчет объектов, здесь сложнее - они ж все осх. Хотя наши ребята в Самаре (wincc@industrialauto.ru) делали переводы некоторых объектов путем вскрытия их как ресурсов. В принципе можно и самому сделать через Restorator или другую прогу для редактирования ресурсов.

Re: PCS 7 FaceplateDesigner библиотеки
Исаев Георгий; 14.11.03

Спасибо за информацию


text

User Urchive
Сергей; 12.11.03

Здравствуйте!

Может кто подскажет:
Есть WinCC 6.0.1.1 используются юзер архивы, значения архива отображаются посредством стандартной табличкой WinCC UA TableElement, очень часто возникает ситуация: в таблицу ничего не выводится, а в статусной строке пишется "Waiting to connect to the server" и ВСЁ! Так и неочухивается :(
Если кто сталкивался - поможите.
P.S. авторизация на UA есть.


text

Проблемы связи Client-Server в WinCC 6 Sp1
Юрий ; 11.11.03

Установил WinCC V6.0 Sp 1.

Возникла следующая проблема в клиент-серверном режиме работы (не мультиклиент - проект один).
Если я останавливаю Runtime на клиенте и на сервере, а затем повторно его запускаю на сервере, то на клиенте проект не автоматически не запускается, хотя он остается открытым WinCC Explorerom ?
Если кто сталкивался с такой проблемой, подскажите как ее решить ?
Re: Проблемы связи Client-Server в WinCC 6 Sp1
Юрченко Владимир; 12.11.03

Это особенность 6-ой версии. Прочитать об этом можно на http://www4.ad.siemens.de/news/cs/en/11846274.

Если кратко - надо перелогиниться на клиенте.


text

Связь WinCC с "Логикой"
Linsky; 25.10.03

Уважаемые господа!

Имел ли кто опыт общения со счетчиками "Логика" (СПТ-961) в своих WinCC проектах. Мне необходимо подключить их к WinCC и качать из них информацию.
Re: Связь WinCC с
Роман; 29.10.03

У "Логики" есть протокол обмена для таких целей, желательно использовать адаптер АПС79 - это новый адаптер где они убрали маркеры доступа к приборам,у меня то же есть такие приборы и есть WInCC, но я еще не ковырял их, весь запрос сводится к посылке через СОМ порт строки запроса, в которой нужно указать массив данных и адрес ячейки, у них в протоколе все достаточно подробно расписано, а вот как через порт посылку слать это уже отдельная тема если не знаешь спрашивай, чем могу подмогну.

Re: Связь WinCC с
Nick; 7.11.03

Где можно почитать как работать с COM-портом в WinCC для обмена данными.

Re: Связь WinCC с
Чистяков Дмитрий ОАО СеверСталь; 10.11.03

Есть такой зверь WinCC CDK

Там имеются и примеры для написания своих каналов связи.
Re: Связь WinCC с
Шимолин Сергей; 11.11.03

Создавать свой драйвер или работать с СОМ-портом из WinCC - не самые "простые" варианты выхода из положения.

Если знаешь что-нибудь типа C++, Delphi то можно написать собственную программку для работы с устройством и с WinCC обмениваться данными через DDE-канал.
Если есть контроллер, то лучше вообще эту часть перенести на нижний уровень - к контроллеру подключить модуль с интерфейсом RS-232 (485) и работу с устройствами организовать из программы контроллера. А отображение данных в WinCC тогда будет обеспечиваться стандартными средствами..


text

Печать трендов в WinCC
Дроздов Денис; 10.11.03

А можно как-нибудь изменить вид тренда печатаемого через DynamicMetafile в Report Desginere? Уж больно по-уродски получается... Например, совершенно не нужны названия осей или метки на них.

Re: Печать трендов в WinCC
Лев Шерешевский; 10.11.03

см.

http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1044712660&year=2003
http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1062070357&year=2003
Re: Печать трендов в WinCC
Дроздов Денис; 10.11.03

Спасибо. Однако порнуха какая-то получается...

Ну ладно, попробуем. А есть ли возможность создания метафайла графического, тогда еще лучше получится?


text

TD200. максимум 16 сообщений?
Волков; 7.11.03

Ввел блок параметров на 20 сообщений.При переходе к 17-му высвечивается SIMATIC TD200.

//DATA BLOCK COMMENTS
//
//Press F1 for help and example data block
//
//BEGIN TD200_BLOCK 0
//
//(Comments within this block should not be edited or removed)
//
VB0 'TD'
VB2 16#10 //Set Language to English, set Update to as fast as possible
VB3 16#F1 //Set the display to 40 character mode; Up key V3.2; Down key V3.3;
VB4 20 //Set the number of messages
VB5 0 //Set the Function Keys notification bits to M0.0 - M0.7
VW6 34 //Set the starting address for messages to VW34
VW8 14 //Set the starting address for message enable bits to VW14
VW10 0 //Global Password (if enabled)
VW12 3 //Character Set = Cyrillic
//MESSAGE 1
//Message Enable Bit V14.7
VB34 '1 '
//MESSAGE 2
//Message Enable Bit V14.6
VB74 '2
Ну и т.д.
В программе следующее:
NETWORK 1 //Инициализация панели оператора TD200
//
//Записать в ячейку состояний дисплея 2#1000000000000000.
//Записать в ячейку подпрограмм ноль
//Очистить область функциональных клавиш
LD SM0.1
MOVW 16#8000, VW14
MOVW +0, VW5000
MOVB 16#00, MB0

NETWORK 2 //Сдвиг ячейки состояний дисплея
//
LD SM0.0
MOVW 16#8000, VW14
SRW VW14, VB5001

NETWORK 3 //При нажатии "Вверх" прибавить 1 к ячейке состояний дисплея
//
LD V3.3
INCW VW5000

NETWORK 4
LD V3.3
R V3.3, 1

NETWORK 5 //При нажатии "Вниз" убавить 1 от ячейки состояний дисплея
//
LD V3.2
DECW VW5000

NETWORK 6
LD V3.2
R V3.2, 1


text

Резервирование
Игорь Одесса; 6.11.03

Уважаемые Господа, необходимо реализовать систему резервирования с использованием двух рабочих станций (АРМ1 - основная станция,АРМ2 - резервная)оператора(обычные ПК)с WinCC, пакета redundancy для PLC S7 300 и redundancy для WinCC. Каким образом наиболее правильно можно подключить АРМ1,АРМ2 к системе с PLC 300. Каждый PLC имеет коммуникационный процессор для синхронизации с другим PLC,к встроенному порту каждого PLC(2DP)подключены ET 200м по profibus,поддерживающие конфигурацию Redundancy

Re: Резервирование
Nick; 7.11.03

IMHO,Можно подключить через Ethernet-коммуникационный модуль.(можно по две сетевые карты в сервер+ 2HUBa для разделения ПЛК между серверами)


text

Статус соединения WinCC и ПЛК
Титаев Александр; 5.11.03

В WinCC 4.02 не удается определить динамически (программно)

текущий статус соединения с ПЛК SIMATIC S7-314С-2DP
(connected/disconnected).
Попытки использовать функцию GAPICreateNewConnection с флагом
MCP_NCON_FLAG_TEST приводят к выводу текста ошибки "requested service not
available".
Существует ли действующий пример использования данной функции,
либо альтернативный способ решения проблемы в целом ?
Re: Статус соединения WinCC и ПЛК
Александр Родин, ООО "Нева Электрик"; 5.11.03

действующий пример есть.

если интересно, могу выслать готовый код.


text

Синхр. TP27 -> PLC (Date\Time)
marat; 31.10.03

Как проще всего сделать синхронизацию даты и времени, вводимых с панели TP27, с CPU 316?


text

Первый запуск
Роман; 16.10.03

Существует ли какой нибудь способ ускорить процесс инициализации тагов при первом запуске скрипта, при использовании их только в Global Action.

Способ создать на эране объекты и их свойства привязать к этим тагам через динамический диалог не пойдёт - слишком их много, все на экран и не уместятся.

Re: Первый запуск
Маслов Дмитрий; 31.10.03

Если скрипт вызывается не часто, то можно использовать GetTagWait вместо GetTag. Она вызывается синхронно, и, как следствие, сильно выигрывает у GetTag при первом вызове (никакой инициализации нет), но проигрывает при последующих.

Re: Первый запуск
Роман; 31.10.03

Спасибо. Попробую.


text

Архивы WinCC v6
Diman; 29.10.03

Как достучатся до значений архивнутых тегов WinCC через ODBC. (Там что-то с сжатием)

Re: Архивы WinCC v6
Маслов Дмитрий; 31.10.03

Боюсь, что никак. Для быстрых архивов (быстрее чем раз в минуту) в WinCC 6.0 применяется сжатие данных, поэтому в таблицах лежат сжатые значения в бинарном виде. Через ODBC Вы сможете из получить, но расшифровать - увы...

Поэтому Siemens поставляет теперь специальный OLE DB Provider. При обращении к архивам через него, насколько я понимаю, производится автоматическое разжатие данных.
А к медленным архивам по-прежнему можно обращаться через ODBC.


text

OP3
Игорь Одесса; 30.10.03

Возможен ли вывод текстовых сообщений на русском языке в панели op3?

В перечне доступных языков, в тех. документации к панели, русский не указан, но предполагаю, что кто-то уже решал данную проблему.

Re: OP3
VVV; 31.10.03

Выыод русского текста не возможен. Мы решали это так PY-ручной режим, ВО- вода и т. д. :))


text

Групповой дисплей
shurik; 21.10.03

Почему то не получается заблокировать групповой дисплей на видеокадре,то есть в Graphics Designer при установке свойства GroupDisplay->Lock все получается - но в Runtime при установке этого свойства групповой дисплей продолжает сигнализировать аварийные ситуации. ???

Re: Групповой дисплей
??; 27.10.03

никто ничего, абидно!

Re: Групповой дисплей
Yrok; 28.10.03

Вообще то Групповой дисплей тонкая штука, попробуй отключать его в контроллере, управляет ведь им контроллер.

Re: Групповой дисплей
shurik; 28.10.03

Да в том то все и дело что даже без привязки к контроллеру не получается в Runtime отобразить заблокированный групповой дисплей (т.е. с принудительно установленным в Graphics Designer свойством Lock=True) !!!!?

Re: Групповой дисплей
Yrok; 29.10.03

Слушай он ведь ничего не должен отображать если у него значение 65535

которое задается в свойствах тега при старте системы. Может я не понимаю до конца. Попробуй сделать так: в области кнопок есть кнопка (она всегда невидима, сделай видимой) Test Utilites при нажатии открывается маленький кадрик с кучей кнопок и там есть кнопка тестирования этих дисплеев.
Там только вводишь имя тега который привязан к Групповому дисплею и там ты разберёшся.

Re: Групповой дисплей
shurik; 29.10.03

Спасибо за отклик,очень интересно про невидимую кнопку! Но как ее открыть честно говоря я не понял.Если можно чуть подробнее пожалуйста про нее. Но вот мысли все про тот же групповой дисплей - дело в том что при блокировке значение привязанного тэга или статические 65535 должны игнорироваться и на четырех квадратиках отображаться какой-то предустановленный символ (например "*"), а вот этого то и не происходит.Кстати WinCC 6.0

Re: Групповой дисплей
Yrok; 30.10.03

Открой в графическом дизайнере кадр @Buttons12.PDL на нем будет расположена кнопка с именем Button6 она вторая слева и установи Yes в свойстве Display (можешь открыть с акцию в этом свойстве и поменять уровень доступа, я так и сделал поставил свой уровень или вообще удали с акцию)У меня WinCC 5.0 на днях поробую как ты говоришь.

Re: Групповой дисплей
shurik; 30.10.03

спасибо,попробую


text

Форматы областей данных для OP17
Андрей; 29.10.03

Уважаемые коллеги!

Помогите, пожалуйста, нигде не могу
найти форматы областей данных (Messages, Alarms, Acknowledgment и т.д.) для ОР170. Т.е. область такая-то столько-то слов, бит и т.п.
Сбросьте ссылку.


text

WinCC and S5-100U
Eugen Sergeev; 29.10.03

Возможно ли подключить к ВинЦЦ такую седую древность, как S5-100U? Хоть тушкой, хоть чучелом? Надо некоторые переменные процесса оперативно наблюдать.


text

Стандартный кабель для подсоединения компа с TP170B ???
Максим Ал.; 21.10.03

В хелпе написано возмите стандартный кабель ?? Стандартный кабель ето какой кабель от розетки или еще от чего ??

Re: Стандартный кабель для подсоединения компа с TP170B ???
VVV; 24.10.03

Ага, с одной стороны 15 пин, а с другой вилка в 220V :))

Ну это шутка, конечно, а распайку (если это то о чем я думаю) я вам по электронке сбросил

Re: Стандартный кабель для подсоединения компа с TP170B ???
Дмитрий; 25.10.03

Максим, юмора у Вас многовато! Если у вас "стандартный кабель" это кабель от розетки, то пользуйтесь им. А если вы читаете про связь между компьютером и панелью оператора по RS232, то стандартный кабель, это обычный кабель для связи через 9 pin COM порт.


text

WinCC + S5-115U
Кулагин Андрей; 24.10.03

WinCC+S5-115U(943B) через AS511

Возникла проблема с крайне долго обновляющимися объектами (5минут).
На картинке есть объекты с си-акциями, которые по какой-то причине, то ли подвисают, то ли первый запуск происходит только через несколько минут (потом все обновляется достаточно оперативно). Причем "виснет" обновление даже элементарных акций.
Подскажите плиз, хотя бы направление куда копать ?
Понятно что информации мало - я могу уточнить детали - не знаю что нужно.

Re: WinCC + S5-115U
Чистяков Дмитрий ОАО СеверСталь; 24.10.03

Объектам обновление установлено как Update или указано жёсткое время?

Если update, то укажите время, скажем 1 секунда.
Re: WinCC + S5-115U
Кулагин Андрей; 24.10.03

Пробовали по-разному. Толку нет.

Кстати в WinCCScopeDiag как любые акции не выставляй - определяются как цикл типа 65535 (вариабле тиггер)


text

Ошибка при запуске WinCC
Александр Родин, ООО "Нева Электрик"; 19.12.02

Раюотали в WinCC v. 5.0 SP2 под Win2K.

Ни с того, ни с сего при запуске вдруг стала выдаваться ошибка:
HResult Error
0x80004005 - Неопознанная ошибка

теперь не открывается ни один проект...

Кто в курсе, чего это такое и как это лечится ?
Re: Ошибка при запуске WinCC
Костенич Дмитрий; 19.12.02

Привет!

Лично у меня такая ошибка была когда вдруг, ни с того, ни сего, закончилось место на диске где лежали проекты :)...
Re: Ошибка при запуске WinCC
Евгений Трунов; 23.12.02

Кое-что по этому поводу можно посмотреть здесь (хотя кода ошибки 0х80004005 среди указанных там и нет):

http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&startNode=4000024&table=ProductNodes&lang=en&aktprim=0&nodeID0=10805585&siteid=cs&foldersopen0=-156-602-625-631-632-633-&jumpto=633
Re: Ошибка при запуске WinCC
Romer; 26.12.02

Вообще-то это ошибка DCOM....

Re: Ошибка при запуске WinCC
Евгений; 2.1.03

Попробуй закрыть проект, закрыть WINCC, сделать папке проекта и всем вложенным Readonly = TRUE, затем обратно в FALSE и запусти проект. У меня срабатывало.

Re: Ошибка при запуске WinCC
Юрий Оганесян; 5.1.03

1. Если ты уже сам разобрался, в чем было дело - мог бы и поделиться информацией.

2. Если нет, то вспомни, не менял ли ты какие-нить настройки безопасности у пользователя - может поможет.

Romer'у-> А как ты это определил?
Re: Ошибка при запуске WinCC
Александр Родин, ООО "Нева Электрик"; 13.1.03

Всем привет.

1. Да, это действительно ошибка DCOM - определил по сообщению в журнале ошибок системы.
2. Вылечил перестановкой WinCC - к тому времени не успел еще перечитать эту тему... %)

Всем спасибо за отклики... :)
Всех с наступившими праздниками.. :)
Re: Ошибка при запуске WinCC
Александр Родин, ООО "Нева Электрик"; 31.3.03

А вот такая еще проблема:

Работаю теперь в WinCC 5.1 HF4 под Win2K SP3.

Работало все нормально, проекты открывались, запускались, редактировались, опять же до какого-то момента. Возможно до установки какой-то программки, не помню уже какой... Одним из последних устанавливал ProTool.

Так вот не понятно с чего вдруг WinCC перестал запускаться вообще. Начинает стартовать, даже окно WinCCExplorer появляется, но потом просто завершается и все. И молчит. В логах ничего нет, в журнале системы ничего нет, сообщений об ошибках тоже нет.

Снес WinCC, переставил ее по новой - никакого эффекта.
Снес весь сименсовский софт с чисткой реестра, переустановил заново - таже фигня...

Вопрос простой - что делать ????!!!
Re: Ошибка при запуске WinCC
Игорь; 4.4.03

мне всю винду пришлось переустанавливать из за такой же фигни

Re: Ошибка при запуске WinCC
Александр Родин, ООО "Нева Электрик"; 7.4.03

м-да...

до этого я и сам додумался.. я вот все думал, что можно малой кровью обойтись...
Re: Ошибка при запуске WinCC
Павел; 11.4.03

А может не в Сименсовском софте дело ?

Всякая ерунда типа HResultError и т.д. у меня всплывала из-за Sybase 7.
Правда все это было на NT4, а под Win2K, я слышал, там уже не Sybase...
Re: Ошибка при запуске WinCC
Александр Родин, ООО "Нева Электрик"; 14.4.03

как оно было везде Sybase, так оно Sybase и осталось. Вполне возможно, что и из-за него. Как его-таки оживить без переустановки виндов ?

Re: Ошибка при запуске WinCC
VladimirK; 24.10.03

Только сейчас увидел вашу дискуссию, но для меня она тоже актуальна. Ну что, в чём причина и смогли-ли вы её устранить? У меня такая проблема возникала несколько раз. Причём, я в основном возился с OPC и иногда менял настройки DCOM. Пару раз мне удавалось приводить в чувство WinCC, но пару раз всё кончилось переинсталляцией виндов. Кстати, DCOMCONFIG как мне показалось, не такая уж безопасная штука. Один раз "доигрался" до того что в нём(DCOMCONFIG) перестали быть видны большинство COM-компонентов, удивительно, что не все. Но система, вроде, продолжала нормально работать. Вылечил переинсталляцией виндов.

С WinCC есть предположение, что она по каким-либо причинам неможет сконнектиться с БД и дело скорее в Sybase. Я думаю, эта ситуация довольно типична и если хорошо разбираться в тонкостях архитектуры взаимодействия между модулями WinCC, то её можно разрешить положительно без переинсталляции виндов.

Бывало ещё при манипуляции с правами на папки и файлы проекта и сетевой доступ к ним возникала похожая ситуация, но её удалось решить(всё пооткрывать, а потом уже после того как всё начнёт работать ограничить до нужного уровня).


text

Проблемы в ProTool
Соловьев Владимир; 24.10.03

При разработке проекта в ProTool v6.0 SP2 возникает следующая проблема. Рисую некий агрегат для MP370 из различных элементов разных типов, отлаживаю, все замечательно. После этого группирую объекты, и тут начинается безобразие: Внутри группы возникают дополнительные элементы с произвольными размерами и свойствами. Приходится их вычишать ручками. Причем если группу разгруппировать, то эти дополнительные элементы могут или исчезнуть с экрана, или нет. Также данный эффект может проявиться не сразу, а при копировании группы и ее редактировании при использовании в качестве шаблона и не каждый раз, а произвольно. Все это жутко раздражает и заставляет тратить лишнее время, а его всегда не хватает. Может кто подскажет что с этим делать или кому в Сименсе пожаловаться на баг?

Проект не маленький, порядка 1000 тегов, десяток экранов, на каждом экране от 100 до 600 элементов.


text

MP370
Кулаков Г.К.; 6.10.03

Может ли кто-нибудь популярно объяснить, как связаться с панелью MP370 по Ethernet и что это даст.

Re: MP370
Юрченко Владимир; 6.10.03

В настоящий момент с RunTime ProTool'a на MP370 (как и на других панелях) по Ethernet связаться нельзя. OPC сервер в панелях под Windows CE также не был реализован. Есть возможность связи по Ethernet с WinAC MP (опционный пакет, софт контроллер в панели) по S7 протоколу.

В конце года должен появиться новый продукт WinCC flexible и в рамках этого проекта будет реализована связь между RT ProTool'а (для панелей с Windows CE начиная с *P270) и в том числе и OPC сервера на мультипанелях.
Re: MP370
Кулаков Г.; 22.10.03

Речь не идет о ProTool, вообще для чего на панели разъем Ethernet. Есть возможность конфигурирования. Можно ли подойти с Notebook-ом и считать архивы?

Re: MP370
Соловьев Владимир; 24.10.03

Через Ethernet можно закачать проект в панель, это намного быстрее чем по RS 232. Также можно, используя ProSave закачать в панель дополнительный софт для WinCE 3.0 Например мне понадобилось прочитать LOg, созданный протулом, пришлось найти в Инете текстовый редактор, закачать его а\в панель и прочитать что надо. Также можно подрубить панель к корпоративной сети. Правда у меня получилась только одностороняя связь, т.е панель видит сеть и компьютеры в ней, и следовательно может читать файлы, а с рабочего компьютера я панели не вижу. Но может я чего недоконфигурировал. Вообще то MP370 это WinCE компьютер.


text

WinCC v5.0 sp2... и DynWizEdit.exe
Петров Андрей; 20.10.03

Почему в версии WinCC 5.0 отсутствуют файлы (DynWizEdit.exe) для создания резервной связи с контроллером. В версии 4.0 они присутствуют. Или в 5-й версии Software Redun-cy работает иначе. Кто-нибудь с подобным сталкивался, поделитесь опытом. Заранее благодарен.

Re: WinCC v5.0 sp2... и DynWizEdit.exe
Петров Андрей; 24.10.03

Отвечу сам на свой вопрос. В WinCC v5.0 DynWizEdit поставляется дополнительным софтом на том же инсталляционном диске в папке SmartTools. Берете копируйте их в Siemens\WinCC\bin и все само сабой цепляется. Не вздумайте запускать всевозможную компиляцию скриптов, там и без этого так все криво. В версии 5.1 все гораздо веселее. Никаких *.exe файлов нет. Имеется только DynWizEdit.dll и все. Да, самое интересное. Когда создаете проект, прежде чем запускать SplitScreenWizard и т.д. сделайте Redundancy conection из Graphic Designer, а то он потом исчезнет.


text

Вопросы по OP25
BIGNICK; 23.10.03

Что за зверь? Как с ним работать. Суть в том, что мне в системе управления надо оставить 3 такие панели, но по всей видимости контроллеры Сименс использоваться не будут. Возможно ли такое совокупление или нет? По какому протокоу эти панелки общаються?

Николай


text

Виснит Global Script после выполнения функции записи в файл
Хоружевский Роман; 9.9.03

Данный скрипт написан на встроенном в WinCC С. Скрипт работает вроде нормально, записывает в файл как положено, но после выполнения все остальные скрипты подвисают и не работают, кто знает, в чем может быть причина?

void SaveUstToFile()
{
float Test[36];//Массив значений уставок

char* szPrjPath;//Каталог файлов проекта

char* szNameFile;
FILE *outf;//Файловый идентификатор

//char szNameTag[30];//Имя тега
//int iIndex,jIndex;
//jIndex = 0;//Текущий индекс массива уставок
{

Test[0]= GetTagFloatWait("P_vac");
Test[1]= GetTagFloatWait("I_vac");
Test[2]= GetTagFloatWait("D_vac");
Test[3]= GetTagFloatWait"Zone_vac");
Test[4]= GetTagFloatWait "T_call_vac");
.
.
.

Test[35]= GetTagFloatWait("Dead_PG");

szPrjPath = GetTagChar("ProjectDir");

szNameFile = strcat(szPrjPath,"PID_REGU.DAT");

outf=fopen(szNameFile,"wb");//Откр файл

fwrite (Test, sizeof(float),36,outf);//Сохранить уставки в файл

fclose(outf);//Закрыть файл

}
Re: Виснит Global Script после выполнения функции записи в файл
Roy; 9.9.03

У меня вначале тоже висло, но записываемый файл создавай заранее. Например текстовой wb.ust.

Re: Виснит Global Script после выполнения функции записи в файл
Goodvin; 10.9.03

Попробуй писать в файл посредством fprintf, я обычно так делаю - не было проблем.

Re: Виснит Global Script после выполнения функции записи в файл
Шестаков Александр; 21.10.03

Ошибка в следующей строке:

szNameFile = strcat(szPrjPath,"PID_REGU.DAT");

Функция strcat добавляет строку PID_REGU.DAT в конец строки по указателю szPrjPath. Но т.к. это указатель на строку в памяти, размер которой равен размеру строки в теге. Таким образом ты выходишь за диапазон строкового массива выделенного при чтении текстового тега. Отсюда и зависание!
Re: Виснит Global Script после выполнения функции записи в файл
Шимолин Сергей; 22.10.03

А вообще когда нужно сохранять какие-нибудь настройки удобно работать через INI-файлы..не надо заботиться о структуре файла. если надо вышлю..

Re: Виснит Global Script после выполнения функции записи в файл
Шимолин Сергей; 23.10.03

несколько человек заинтересовалось, поэтому кидаю пример на форум..

//INI file write
#pragma code("kernel32.dll");
BOOL WritePrivateProfileStringA(LPCTSTR lpAppName, LPCTSTR lpKeyName, LPCTSTR lpString, LPCTSTR lpFileName);
#pragma code();
WritePrivateProfileStringA("First","FirstKey","testFirstKey","d:\\TEMP\\initest.ini");

//INI file read
#pragma code("kernel32.dll");
DWORD GetPrivateProfileStringA(LPCTSTR lpAppName, LPCTSTR lpKeyName, LPCTSTR lpDefault, LPTSTR lpReturnString,DWORD nSize,LPCSTR lpFileName);
#pragma code();
char ReturnString[100];
DWORD nSize = 100;
GetPrivateProfileStringA("Third","teststring","Pitch!!",ReturnString,nSize,"d:\\TEMP\\initest.ini");
printf("value of nSize %d\r\n",nSize);
printf("ini-file read inisection third=%s\r\n",ReturnString);


text

cp5613 & Visual C++
Елена Протасова; 23.10.03

Низ написан как и полагается на Step7, конроллер, разумеется, Сименс, плата CP5613. Нужно написать верх полностью на Visual C++! Кто-нибудь этим занимался, писал драйвера связи и т.п., есть ли SDK какой-нибудь? CDK, как я поняла, только для WinCC(хотя я сильно в него не углублялась, могу и ошибаться), может у где-нибудь завалялись исходники?

Заранее благодарю за любую помощь!
Re: cp5613 & Visual C++
Yrok; 23.10.03

Через OPC драйвера или DDE драйвера.

У меня например попадалась программка называется KepServer она значит через ком порт связывалась с контроллером (при том что при установке программы указываешь какой драйвер нужен(ы)S7-200, TI505....)предварительно указываешь какие слова или байты нужны для скачки и запускаешь, а потом примерчик на С++ и качаешь от туда или туда данные.
Re: cp5613 & Visual C++
Yrok; 23.10.03

Загдяни сюда http://simatic.nm.ru/download_main.htm

там есть примерчик на delfhi но я думаю можно переложить на С++, а вообще ищи документацию на OPC и драйвера. Они для этого и придуманы
Re: cp5613 & Visual C++
Чистяков Дмитрий ОАО СеверСталь; 23.10.03

Не понятно какой смысл во всём этом - повторить пройденый кем-то уже путь и изобрести велосипед. Но тем неменее (можно уже заносить в FAQ) :-)

1. Использовать OPC сервер (необходимо будет купить).
Это самый, пожалуй простой способ для связи с контроллером.
2. Использовать OLE/DDE менеджер (купить или найти в инете халявный).
3. Написать программу на С (Pascal, Delphi и т.д.), использую S7-API.
Это набор функций для работы с коммуникационными процессорами от Siemens, с установленным Simatic Net (имеется в комплекте с CP5613 на CD-ROM).
http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.csinfo&lang=en&siteid=CSEUS&objid=11186885
Re: cp5613 & Visual C++
Чистяков Дмитрий ОАО СеверСталь; 23.10.03

Не понятно какой смысл во всём этом - повторить пройденый кем-то уже путь и изобрести велосипед. Но тем неменее (можно уже заносить в FAQ) :-)

1. Использовать OPC сервер (необходимо будет купить).
Это самый, пожалуй простой способ для связи с контроллером.
2. Использовать OLE/DDE менеджер (купить или найти в инете халявный).
3. Написать программу на С (Pascal, Delphi и т.д.), использую S7-API.
Это набор функций для работы с коммуникационными процессорами от Siemens, с установленным Simatic Net (имеется в комплекте с CP5613 на CD-ROM).
http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.csinfo&lang=en&siteid=CSEUS&objid=11186885
Re: cp5613 & Visual C++
Елена Протасова; 23.10.03

Спасибо за ответы. Теперь немного разобралась, буду выбирать.

Скорее всего выберу 3 вариант.


text

S5-115 и WinCC
San; 16.10.03

Как подсоединить станцию WinCC (или ProTool RT) к контроллеру S5-115 CPU943, порт AS511 занят (подключена ОР17)? Какие есть дополнительные модули для связи, и нужно ли что-то для их конфигурирования?

Re: S5-115 и WinCC
Чистяков Дмитрий ОАО СеверСталь; 23.10.03

По Profibus CP5431

По Ethernet CP1430
PPI (токовая петля или RS232) CP523, CP524,CP544


text

WinCC перестал видеть ОРС сервера
Хоружевский Роман; 22.10.03

Поставил в слот ISA платту Hilchser для связи по Profibus, диаппазон адресов в котором она работает следующий D0000-D07FF, а WinCC перестал видеть ОРС сервера все сразу, точнее в окне поиска сервера находит а вот когда пытаюсь увидеть тэги он пишет следующее:

HRESULT=80004005
E_FAIL
Unspecifed error

И еще одно

HRESULT=800040154
REGDB_E_CLASSNOTREG
Class not rigistered

Кто сталкивался с токой проблемой, может пересекаются адреса в памяти.Настройки DCOM проверял все в норме.

Вот перечень адресного пространства на машине.

System Information report written at: 20.10.2003 08:19:42
[Memory]

Range Device Status
0xA0000-0xBFFFF PCI bus OK
0xA0000-0xBFFFF Intel 82443LX/EX Pentium(r) II Processor to AGP Controller OK
0xA0000-0xBFFFF ASUS V7100MAGIC v11.01 OK
0xCC800-0xDFFFF PCI bus OK
0x10000000-0xFEBFFFFF PCI bus OK
0xFEC01000-0xFEDFFFFF PCI bus OK
0xFEE01000-0xFFFDFFFF PCI bus OK
0xFCA00000-0xFEAFFFFF Intel 82443LX/EX Pentium(r) II Processor to AGP Controller OK
0xCC800000-0xDC8FFFFF Intel 82443LX/EX Pentium(r) II Processor to AGP Controller OK
0xE0000000-0xEFFFFFFF Intel 82443LX/EX Pentium(r) II Processor to AGP Controller OK
0xFD000000-0xFDFFFFFF ASUS V7100MAGIC v11.01 OK
0xD0000000-0xD7FFFFFF ASUS V7100MAGIC v11.01 OK
0x0000-0x9FBFF System board OK
0x9FC00-0x9FFFF System board OK
0xE0000-0xFFFFF System board OK
0x100000-0xFFFFFFF System board OK
0xFEC00000-0xFEC00FFF System board OK
0xFEE00000-0xFEE00FFF System board OK
0xFFFE0000-0xFFFFFFFF System board OK

Кто знает помогите пожалуйста.
Re: WinCC перестал видеть ОРС сервера
Чистяков Дмитрий ОАО СеверСталь; 23.10.03

А Windows какой, 2000?

Скорее всего ситуация та же что и с CP5412. Старые карты ISA не поддерживаются под Win2K.
Производитель указал в описании, что драйыера под W2K работают? Или нет?
Ещё вариант - это то что в настройках BIOSа необходимо зарезервировать эту область памяти(D0000-D7FFF).

Re: WinCC перестал видеть ОРС сервера
Хоружевский Роман; 23.10.03

Спасибо Дмитрий уже разобрался, адрес действительно от D0000-D7FFF, именно это пространство памяти и не использует W2K, причем железо работало и в другой области памяти а вот софт отказывался, конкретно сам драйвер. А с WinCC - пришлось убить ее, затем заново поставить карту, и только потом, после переустановки WinCC, все заработало, т.е. WinCC перестал глючить и увидел все сервера нормально. А по поводу BIOS это конечно идея, может попробую в другой раз, пока все работает. Всем спасибо.


text

Перенос переменых в PCS7 6.0
JoeBlack; 22.10.03

Есть два компа на них двое работают над одним проектом, один занимается верхним уровнем (WinCC), другой нижним (step7), после создания новых переменных в Step7 надо делать перенос AS->OS, приходится гонять проект с одной станции на другую - сеть тормозная, много времени уходит. В PCS7 v5 достаточно было скопировать файлик Project.db, а вот в 6-ой версии каких файлов будет достаточно?


text

Проблема с загрузкой проекта с Protool 6 в TP170B
Максим Ал.; 20.10.03

У меня проблема с загрузкой проекта с Протоол 6 в ТП170Б ! Я не знаю какой кабель необходимо для этого использовать. Я использовад кабель RS232 + подсоединял PC Adapter MPI/DP и при подключении кабеля к панели не загорается лампочка POWER на PS Adaptere видимо вследствии этого и не загрузается проект. при затрузке проекта Проотоол пишет что то про кабеля и интерфейсы. Возможно у неправиль отконфигурирована в Control Panel Pc/Pg Interface ?

Re: Проблема с загрузкой проекта с Protool 6 в TP170B
Дмитрий; 21.10.03

Попробуйте через RS232. А для самостоятельного решения этой проблемы неплохо бы иногда читать технические руководства. По ссылке русское описание работы с ТП170Б.

См. http://www.automation-drives.ru/as/products/doc.php?l1=SIMATIC%20HMI&l2=Панели&l3=doc

Re: Проблема с загрузкой проекта с Protool 6 в TP170B
Роман Абзаев; 21.10.03

А система в панели свежая?

Re: Проблема с загрузкой проекта с Protool 6 в TP170B
Максим Ал; 21.10.03

А как узнать свежая система или нет ?? Я пока еще на стоко не силен


text

protool
Александр; 16.10.03

недавно начал создавать проект protool rt

есть вопрос . имею четыре тега int
в одом теге число с количеством продукции в остальных описание(размеры)
количество увеличевается до тех пор пока не будет перехода на новые размеры
как отловить переход количества на 0
и преведущее значение вместе с остальными параметрами сохранить для дальнейшей печати . за смену возможны несколько переходов , а отчёт нужен один где былобы какого размера и сколько


text

Переход с одной версии драйверов симатика на другую в скаде IFix
ViT; 15.10.03

Имееться проект написанный в SCADA-системе IFix 3.0 с базой данных тегов, описанных с использованием драйверов S_7 - Siemens Simatic S7 v6.12f. Необходим переход на более новые драйвера, а именно SI7 - Siemens Simatic S7 v7.22. Дак вот - как сделать этот переход наиболее безболезненно? Я имею ввиду не перебивая старую базу с 6-ми дровами на новый синтаксис от 7-х?

Re: Переход с одной версии драйверов симатика на другую в скаде IFix
Чистяков Дмитрий ОАО СеверСталь; 15.10.03

Это уже к авторам этих драйверов надо обращаться. Это ж ведь не Siemens`овские драйвера.


text

Смена слоя объекта
Александр Клейн; 12.10.03

Уважаемые господа! Не подскажет ли кто, как в Graphics Designer сменить слой объекта, например со 2-го на 10-ый?

Re: Смена слоя объекта
Лев Шерешевский; 13.10.03

Стандартными средствами в runtime это сделать нельзя. В документации же написано: "The 'Layer' attribute can not be made dynamic"

См. Центр компетенции WinCC

Re: Смена слоя объекта
Шимолин Сергей; 13.10.03

Если правильно понял, то вопрос как в _редакторе_ Graphics Designer установить слой объекта. Для этого открываешь окно свойств объекта, щелкаешь на типе объекта (самый верхний уровень в структуре свойств) и в правой части окна свойство Layer. Слоя (в WinCC до 6 версии) используются только для удобства разработки, как уже было отмечено в предыдущем письме, ничего в RunTime-режиме с ними сделать нельзя.

В 6-й WinCC уже появилось 32 слоя.. несколько переделана работа со слоями и есть возможность настройки - какие слоя отображать в CS, а какие в RT..

Re: Смена слоя объекта
Александр Клейн; 14.10.03

Спасибо за подсказку. Речь шла именно о редакторе Graphics Designer, а не о RunTime-режиме. Я подозревал, что это должно быть в свойствах объекта, облазил все уровни свойств, а щелкнуть на самом верхнем не догадался.


text

Проясните ситуацию с Ethernet на MP270B
fresco; 14.10.03

в файле http://www.aud.ru/as/download/ascat/simatic_hmi/panels/05_MP270_370_r.pdf

написано что для МР270 нужна дополнительная сетевая карта, а в МР370 Ethernet встроеный.

А в МР270В встроеный или нужна дополнительная карта?

Re: Проясните ситуацию с Ethernet на MP270B
Юрченко Владимир; 14.10.03

Да в MP270B есть встроенный Ethernet. Смотрите www.aud.ru/as/download/ascat/simatic_hmi/panels/kb_mp270b_mp370_flex_e.pdf

Спасибо.
fresco; 14.10.03

.


text

Не отображается нормально кадр
Yrok; 7.10.03

Установил на клиентскую машину только RT пакет и загружаю проект с сервака, почему то часть билиотечных рисунков не отображается а на их месте

белые квадраты. Может кто ни будь сталкивался с такой проблеммой помогите пожалуйста!
Re: Не отображается нормально кадр
Дмитрий Маслов; 8.10.03

Вообще-то все должно и так работать, но попробуйте скопировать все файлы из директории GraCS в каталоге проекта на сервере в директорию ...\WinCC\Bin\PdlCache на клиенте (ее придется создать). Если не поможет - напишите, какую версию WinCC и какой тип клиента Вы используете, и какие именно библиотечные картинки у Вас не отображаются.

См. WinCC Competence Center

Re: Не отображается нормально кадр
Yrok; 8.10.03

Спасибо сегодня поробую

Re: Не отображается нормально кадр
Yrok; 8.10.03

Ни хрена не показывает. Использую версию WinCC 5.0, Библиотечный элемент "Flange With bolts on Top" из Pipes библиотеки HMI Simbol Library 1.2 Ну и кучу ещё таких элементов.

Re: Не отображается нормально кадр
Дмитрий Маслов; 10.10.03

Сложно дать точные рекомендации при таких симптомах. Могу посоветовать следующее:

1. Установите WinCC 5.1 с последним Hotfix на обе машины (на клиент и сервер). Причем и там, и там поставьте полный комплект WinCC (включая RC). С точки зрения лицензии это нормально - просто не надо запускать систему разработки на клиенте.
2. Если после выполнения пункта 1 проблема сохранится, попробуйте на клиенте открыть в графическом редакторе Graphics Designer одну из тех картинок сервера, на которой есть библиотечные элементы. Если она и здесь нормально не откроется - значит проблема в установке библиотеки Simatic HMI Symbol Library на клиенте.
См. WinCC Competence Center

Re: Не отображается нормально кадр
Yrok; 10.10.03

Спасибо за совет но я как то не хотел на клиенте ставить весь пакет. я сейчас извернулся таким образом: сделал копия экрана а в паинте вырезал нужную картинку и вставил на кадр как графический объект.

Re: Не отображается нормально кадр
Alexis; 10.10.03

Дык может проще было бы установить ручками на клиенте Siemens HMI Symbol Library? Или ты не ее используешь?

Re: Не отображается нормально кадр
Шимолин Сергей; 13.10.03

Объекты Siemens HMI Symbol Library отображаются через ActiveX-объект. Раз отображаются белые квадраты - значит в системе не установлен данный ActiveX. Можно попробовать найти на сервере ocx-файл (FWSYMF~1.ocx) и зарегестрировать его на клиенте...

Re: Не отображается нормально кадр
Yrok; 13.10.03

Щяс поищу ocx.

Re: Не отображается нормально кадр
Yrok; 14.10.03

У меня он распологается вот тут:

C:\Siemens\WinCC\bin\CCGraphics\SymbolFactory\FwSymFacX.ocx
Кстати окно выбора компонентов не показывает полное имя файла FWSYMF~1.ocx

Re: Не отображается нормально кадр
Шимолин Сергей; 14.10.03

Re: Не отображается нормально кадр
Yrok; 14.10.03

Да! Спасибо всем кто мне помогал особенно Шимолину Сергею


text

Динамическая переадресация тегов
Андрей ; 10.10.03

Господа !!!

У меня следующая проблема! Необходимо организовать динамическую переадресацию тегов в WinCC. Например имеется тег "X" с адресом DB10.DBW0. Необходимо по событию присвоить этому тегу адрес DB10.DBW2 и т. д...
Косвенная адресация (Indirect) в данном случае для меня не подходит. Организация переадресации в самом PLC тоже не подходит.
Имею пакет PRODAVE который позволяет это делать, но только по MPI. Как это реализовать на PROFIBUS.

Понимаю, что вопрос сложный ! Но очень надеюсь на ваши советы и подсказки!
На форуме слышал про работу с файлами
"*.CHN". Может кто подскажет что это такое?...

Re: Динамическая переадресация тегов
Шимолин Сергей; 13.10.03

Вообще правильно будет не менять адреса тегов, а привязывать новый тег. Т.е. в проекте создаешь все теги с которыми будешь работать, а потом через SetLink можешь менять привязку свойств на другой тег.

Re: Динамическая переадресация тегов
GorA; 13.10.03

Можно попробовть следующее:

Тэг "X" - DB10.DBW0;
Тэг "Y" - DB10.DBW2;
и так далее - столько тэгов сколько нужно.
И, наконец, локальный char Тэг "ZZ".
В требуемом объекте пишется C - функция, где осуществляется присвоение имени нужного тэга к "ZZ".
И в конце получаем значение откуда хотим.
return GetTagValue(ZZ);

Re: Динамическая переадресация тегов
Шимолин Сергей; 14.10.03

.. и правда - через косвенную адресацию (indirect) гораздо проще и удобнее работать. А с SetLink это я загнул.. :)


text

ProTool в локальной сети???
Лександр; 21.8.03

А можно ли проект созданный с помощю ProTool разместить в локальной сети???

Т.е. можно ли наблюдать или управлять процессом с обычного РС, через сеть???
И какое ПО необходимо к S7-300 для этого (и железо?)???
Re: ProTool в локальной сети???
Юрий Оганесян; 22.8.03

Начиная с версии 5.2 ProTool RT может выступать в качестве OPC сервера.

Re: ProTool в локальной сети???
kip; 22.8.03

Можно узнать поподробнее по поводу ОРС сервера?

Re: ProTool в локальной сети???
Чистяков Дмитрий ОАО СеверСталь; 25.8.03

Тут стоит для начала уточнить вопрос.

===
А можно ли проект созданный с помощю ProTool разместить в локальной сети???
Т.е. можно ли наблюдать или управлять процессом с обычного РС, через сеть???
==
Что под этим подразумевалось?
Персоналка на которой будет работать ProTool?
Или это будет персоналка, которая должна будет подключаться к какой-то станции с ProTool?

Если Вам просто необходимо запустить проект ProTool на персоналке, то Вам понадобиться
1.Коммуникационный процессор (сетевая карта) CP5611,CP5613.
2. Программа 6AV6584-1AB06-0BX0
ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ RUNTIME PROTOOL/PRO RUNTIME V6.0 НА CD С RUNTIME ЛИЦЕНЗИЯ НА 128 ДНЕЙ,(ЛИЦЕНЗИЯ ДЛЯ RT V5.X UND V6.X) ДЛЯ WIN98 SE/ME/NT4.0 SP6A /2000 SP2 , С ЛИЦЕНЗИЕЙ ДЛЯ УСТАНОВКИ НА 1 РАБОЧЕЕ МЕСТО
Стоимость 705 евро за границей

Re: ProTool в локальной сети???
Лександр; 27.8.03

У меня PG на S7-300 по PPI и в локалке по витой паре... А можно ли увидеть теперь процесс с другой персоналки в этой же локалке??? Заранее спасибо!

Re: ProTool в локальной сети???
Лександр; 8.10.03

М...ДА...!!!

...MPI!!!
(а не РРI!!!)

Re: ProTool в локальной сети???
San; 10.10.03

Какое ПО нужно иметь на клиентском компьютере, чтобы получить доступ к ОРС серверу ProTool по локальной сети?


text

WinCC как организовать задержку при выполнении функции?
Author; 9.10.03

Здравствуйте, коллеги :)

Подскажите пожалуйста, как организовать задержку при выполнении функции (Project function)? sleep и GetTickCount()не подходят, так-как на время исполнения задержки с использованием этих функций все процессы приостанавливаются, что не очень приятно. Заранее благодарен.
Re: WinCC как организовать задержку при выполнении функции?
Александр Родин, ООО "Нева Электрик"; 9.10.03

Имеется ввиду Global Script или свойства объектов ?

Если Global Script, то вы просто можете заставить его выполняться по событию (например изменению тега). В принципе, в таком случае в задержках просто нет смысла.
Если же вам надо тормозить выполнения скриптов в свойствах объектов, то здесь скорее всего ничего не получится, т.к. они и так привязаны к определенным событиям..

Честно говоря, не могу предположить ситуацию, в которой потребовалось бы осуществлять задержку выполнения какой-то операции.

Вы бы не могли поподробнее описать вашу ситуацию ?


text

GetTagValue (Пример )
BAB ; 8.10.03

Господа !

Кто может пояснить как можно использовать стандартную функцию WinCC GetTagValue()?? Если можно с примером!
И еще один вопрос. Можно ли в сценариях WinCC добраться до адреса внешнего тега и менять этот адрес в зависимости от событий? В других SCADA такая возможность существует.
Буду признателен за любой ответ!


text

Дескриптор
Nic; 30.9.03

Подскажите как получить дескриптор окна? например WinCC Online Trend Control

Re: Дескриптор
Лев Шерешевский; 7.10.03

Ну, примерно так, как показано ниже. В данном примере функция приложения VisualC ищет окно трендов и закрывает его. Использовалось в Win2k SP4 с WinCC 5.1.

typedef UINT (WINAPI *lpfnRealGetWindowClass)(HWND hwnd, LPTSTR pszType, UINT cchType);

BOOL CALLBACK EnumChildProc(HWND hWnd, LPARAM lParam)
{
const size = 100;
char szType [size+1];
CString Msg;
lpfnRealGetWindowClass RealGetWindowClass;

HMODULE hUser32 = GetModuleHandle("USER32.DLL");

RealGetWindowClass = (lpfnRealGetWindowClass)GetProcAddress(hUser32, "RealGetWindowClass");

RealGetWindowClass(hWnd, szType, size);
if (!strcmp(szType, "WinCC Online Trend Control"))
{
::PostMessage(hWnd, WM_SYSCOMMAND, SC_CLOSE, 0);
return FALSE;
}
return TRUE;
}

void CTestFindWindowDlg::OnBtn1()
{
HWND hWndP;
hWndP = ::FindWindow("PDLRTisAliveAndWaitsForYou", NULL);
EnumChildWindows(hWndP, EnumChildProc, 0);
}

См. Центр компетенции WinCC

Re: Дескриптор
Маслов Дмитрий; 8.10.03

Дескриптор окна можно получить так (пример для калькулятора):

HWND Handle = FindWindow("SciCalc", NULL);

Функция FindWindow ищет окно по типу или по заголовку. В данном примере используется поиск по типу.

См. WinCC Competence Center


text

Откуда берутся файлы ?
Владимир; 29.9.03

В корневой директории системного диска появляются файлы asatХХХХ.tmp , в директории WinNT файлы DFXXXX.tmp, где ХХХХ - некое число.

Что это за файлы, откуда появляются и как это дело пофиксить ?
Re: Откуда берутся файлы ?
Сергей; 7.10.03

а чем, позвольте полюбопытствовать, они Вам мешают???

Re: Откуда берутся файлы ?
Владимир; 7.10.03

Вопрос конечно интересный.

Просто их не должно быть, вот и все.
Кстати, система NT 4.0 sp6.
Может быть это остатки каких то неверно завершенных функций проекта ???


text

Не открывается проект в WinCC (срочно)
Ломакин Николай; 2.10.03

Установили на новом компьютере WinCC и в ней проект созданный на другом комьютере как-бы открывается, но не видны экраны в графическом дизайнере и не запускается RunTime.

Re: Не открывается проект в WinCC (срочно)
Dmitry; 2.10.03

А имя компа в Computer properties поменять не забыли?

Re: Не открывается проект в WinCC (срочно)
Александр; 3.10.03

У меня такое было, когда у пользователя не хватало прав в Win2k(он входил в группу "Пользователи"). Тогда описанная ситуация возникла на клиенте в сетевой конфигурации. Перевод в группу "Администраторы" сразу решил все проблемы. Возможно, что поможет и группа "Опытные пользователи", но я не пробовал.

Re: Не открывается проект в WinCC (срочно)
Ломакин Николай; 6.10.03

Всем спасибо!!! Проблема решена!!!

Re: Не открывается проект в WinCC (срочно)
Владимир; 7.10.03

Хоть рассказали бы что там случилось и каким образом решили проблему.


text

Распечатка видиокадра ОР37
DEE; 6.10.03

Hi!

А вот, народ, какая проблема. Понадобилось тут распечатать кадр в online с панели ОР37. Ну в проекте организовал кадр настройки принтера (стандартный), запрограммировал клавишу распечатки экрана (Start/stop print screen), загрузил это хозяйство в ОР37. В кадре настройки принтера выбрал нужный принтер (LaserJet1100 - его соответственно подключил к панели), выбрал опцию печати в графическом режиме и пытаюсь распечатать экран. Панель ругается - что выбранный принтер не может печатать графику. Вопросы соответственно - почему такая байда получается? Что графику (графики, гистограммы и др.) вообще нельзя таким образом распечатать? А тогда зачем в настройках принтера на панели нужен выбор текстового/графического режима?

Re: Распечатка видиокадра ОР37
Юрченко Владимир; 6.10.03

В настройках принтера в ProTool'e (System/Printer/Settings) в стандартном списке такого принтера нет. Можно добавить (New), но надо знать управляющие команды для инициализации многих параметров принтера(Parameters/graphic).

Re: Распечатка видиокадра ОР37
DEE; 6.10.03

Да, нет, как раз такой принтер есть. Именно LaserJet1100...В том то и загвоздка, т.е. драйвер этого принтера в панели есть, а графику печатать он отказывается(о чём панель и сообщает). Патался выбрать другие принтеры из списка - рез-т тот же.


text

TP270 не работает touch
Александров Константин; 6.10.03

Не работает функция touch

для панели TP270 10''
в версии Windws CE 3.0
image version b 6.0.2.16
Обновил операционку и загрузил
проект ProTool.
Помогите решить проблему!!!

Re: TP270 не работает touch
Виктор; 6.10.03

У нас такое было. Вам нужно сдавать в ремонт саму панель.


text

WinCC и время на графиках
Сергей; 26.9.03

Здравствуйте!

Подскажите, как сделать чтобы на экране с графиками (Online Trend) в режиме Run-Time время отображалась в формате 24 часов, а не с АМ и РМ?
Re: WinCC и время на графиках
Goodvin; 29.9.03

Надо поменять в системе настройки в закладке "языки и стандарты", сначала поставить в "общих" Английский (США), а потом настроить формат времени и даты.

Re: WinCC и время на графиках
Юрий; 1.10.03

Операционная система W2000 английская,

WinCC 5.1, пробовал - не получилось.
Re: WinCC и время на графиках
Маслов Дмитрий; 6.10.03

Попробуйте аккуратно выполнить следующую последовательность действий:

1. Открываете Control Panel -> Regional Settings.
2. В поле выбора под названием 'Your locale' выбираете 'English (United States)'
3. Переходите во вкладку Time и в поле ввода 'Time format' вводите 'HH:mm:ss'.
4. Переходите во вкладку Date и в поле ввода 'Short date format' вводите 'dd.MM.yyyy'. То же самое вводите в поле ввода 'Long date format'.
5. Нажимаете кнопку Apply, закрываете окно.

Должно помочь.

См. WinCC Competence Center


text

Диагностика нажатой клавиши
Александр; 3.10.03

Господа! Какая функция в WinCC возвращает код нажатой клавиши? Необходимо выполнять скрипт в момент отпускания клавиши Enter после ввода числа в поле ввода/вывода.

Re: Диагностика нажатой клавиши
Роман Папировский; 3.10.03

Возможно, вам просто необходимо назначить скрипт на Event “Input Value”-“Change”. Это событие вызывается при завершении ввода в I/O Field

Re: Диагностика нажатой клавиши
Александр; 3.10.03

Да, все работает, спасибо! Но все-таки было бы интересно знать, как отловить произвольно нажатую клавишу.

Re: Диагностика нажатой клавиши
Дмитрий Маслов; 6.10.03

Для отлавливания нажатия клавиш у многих графических объектов WinCC имеется группа событий Keyboard с событиями press и release, срабатывающими при нажатии и отпускании любой кнопки на клавиатуре, если данный объект находится в фокусе. В качестве параметра в функции обработки указанных событий передается код нажатой (или отпущеной) клавиши.

См. WinCC Competence Center


text

Печать окна Web Navigator
Юрий Оганесян; 2.10.03

Добрый день!

Удалось ли кому-нибудь распечатать из IE страницу с мнемосхемой, отображаемой Web Navigator Client'ом?

Re: Печать окна Web Navigator
Лев Шерешевский; 2.10.03

Да, удалось.

Re: Печать окна Web Navigator
Юрий Оганесян; 3.10.03

Хм... а в чем тогда подвох?

У меня IE 6.0 SP1, WebNavogator Client 1.0 и печать (как и предварительный просмотр) странички c WebNavigator демонстрирует чистый лист с педантично напечатанными колонтитулами.
Попробовали на 5 различных компьютерах - везде также.
А у Вас печать сама собой получилась, или какое-то волшебное слово говорили?
Re: Печать окна Web Navigator
Роман Папировский; 3.10.03

Печать содержимого экрана делали непосредственно из WinCC.

Для этого на форме размещали кнопку и на Event по нажатию вешали скрипт

#include "apdefap.h"
void OnClick(char* lpszPictureName, char* lpszObjectName, char* lpszPropertyName)
{
#pragma code ("prtscrn.dll")
BOOL WINAPI PrtScreenPart ( ULONG left, ULONG top, ULONG width, ULONG height);
#pragma code()

HWND Handle;
BOOL WinMax;
RECT rect, rectW;
float ScaleX,ScaleY,Scale;
int X,Y,Width,Height,BordX,BordY;
char ParentPicture[256], PictureObject[256], *pos1, *pos2, PicName[256];
int Lenght,i,CountTrend;
DWORD arrColor[12];

if ( MessageBox(
Handle,
"Вы действительно желаете распечатать копию содержимого экрана?",
"Подтверждение",
MB_OKCANCEL | MB_ICONEXCLAMATION | MB_SETFOREGROUND|MB_SYSTEMMODAL
)
== 2 ) return;

#ifdef RUN_ON_WEBNAVIGATOR
Handle = FindWindow(NULL, "WinCC Web Navigator - Microsoft Internet Explorer");
#else
Handle = FindWindow("PDLRTisAliveAndWaitsForYou",NULL);
#endif
if (Handle==NULL)
{
Beep(440,500);
return;
}

//Max Screen
WinMax = IsZoomed(Handle);
if (!WinMax)
{
PostMessage(Handle , WM_SYSCOMMAND,0xf030,0); //Max
}
///////////////////////////

GetWindowRect(Handle , &rectW);
printf("rectW.left= %d\r\n",rectW.left);
printf("rectW.top= %d\r\n",rectW.top);
printf("rectW.bottom = %d\r\n",rectW.bottom);
printf("rectW.right = %d\r\n",rectW.right);
GetClientRect(Handle , &rect);
printf("rect.left= %d\r\n",rect.left);
printf("rect.top= %d\r\n",rect.top);
printf("rect.bottom = %d\r\n",rect.bottom);
printf("rect.right = %d\r\n",rect.right);

ScaleX = (float)1280/(float)(rect.right-rect.left);
#ifdef RUN_ON_WEBNAVIGATOR
ScaleY = (float)800/(float)(rect.bottom-rect.top);
#else
ScaleY = (float)1024/(float)(rect.bottom-rect.top);
#endif
if (ScaleY<ScaleX)
{
Scale=ScaleX;
}
else
{
Scale=ScaleY;
}
BordX = ((rectW.right-rectW.left)-(rect.right-rect.left )) /2;
BordY = ((rectW.bottom-rectW.top)-(rect.bottom-rect.top))-BordX;
printf("BordX = %d\r\n",BordX);
printf("BordY = %d\r\n",BordY);

X=rectW.left+rect.left+BordX;
Y=BordY+rectW.top+rect.top;
Width=1280/Scale;
Height=1024/Scale;

PrtScreenPart (X, Y, Width, Height);
if (!WinMax)
{
PostMessage(Handle , WM_SYSCOMMAND,0xF120,0); //Normal
}
}


text

Связь OP25 & OP5 с S5-135
Виталий; 1.10.03

Подскажите, плиз, как завязать в одну систему обе панельки (по какой связи), а также какие и куда блоки нужно будет дописать - если связь по TTY то понятно, что в CPU (но как по TTY включить обе?), а если PROFIBUS то соответственно в CP или как?


text

МР370 и S5
Сергей; 30.9.03

Здравствуйте!

Есть панель МР370, контроллер S5 с процессором 928В. Надо добавить разъем для связи с панелью по AS511. Есть мысль, что для этого надо PG-модуль (6ES5752-0AA53), хотя вроде есть и интерф.модуль TTY (6ES5752-0AA12). Соединиться думаю по кабелю 6XV1440-2AH32 для связи между контроллером и панелью.
Не понятно какой интерфейсный модуль надо выбрать, чтобы получить на контроллере еще один порт токовой петли для AS511.

Буду рад услышать совет


text

Проблема с конвертацией v.4.0 в v.5.1
Коротов Д.В.; 27.9.03

Привет ФОРУМ!

Есть необходимость в переходе на новую версию WinCC, в частности установлена версия 5.1 + HF4. До этого проект был сделан в версии 4.02. После конвертации картинок и библиотек RunTime запускается, но не работают Си-акции. Помогите. Проблему необходимо срочно решить.


text

Tag multiplexing в функциях и скриптах ProTool
Соловьев Владимир; 23.9.03

Можно ли использовать мультиплексирование адресов (multiplex tag) в функциях и скриптах ProTool? И как ?


text

Отображение шрифтов
Александр; 15.9.03

Надписи в проекте на одних клиентах в сети отображаются правильно, а на других в виде нескольких знаков вопросов. Компьютеры одинаковые, системы тоже - Win2k. Язык WinCC установлен один - английский. WinCC V5.1. Может кто-чего подскажет?

Re: Отображение шрифтов
LostAngel; 18.9.03

Измени шрифты с Arial на Arial Cyr - и все дела......

Re: Отображение шрифтов
Александр; 19.9.03

Да, все заработало - спасибо!


text

антивирус для сервера WinCC
Роман Журавлев; 11.9.03

Подскажите, как грамотно обеспечить антивирусную защиту серверов и рабочих станций с WinCC?

Какие антивирусные программы посоветует для использования вместе с WinCC?
Re: антивирус для сервера WinCC
Юрий Оганесян; 12.9.03

Стоит Panda. Конфликтов не замечено

Re: антивирус для сервера WinCC
Юрченко Владимир; 12.9.03

Четких рекомендаций у Сименса на этот счет нет. Протестирован в работе на станциях оператора PCS7 v.6 пакет "Trend Micro" из пакета Office Scan (См. www4.ad.siemens.de/news/cs/en/10154608). Но использование и этого антивирусного пакета во время инсталляции софта и RunTime может привести к проблемам.

Re: антивирус для сервера WinCC
Шимолин Сергей; 16.9.03

Где-то в документации попадалось:

1. вообще не использовать антивирусы на сервере WinCC
2. отключать Screen Saver`ы
Re: антивирус для сервера WinCC
Шимолин Сергей; 16.9.03

Ну вот в догонку:

////////////////////////////
Use of Virus Scanners

Using a virus scanner while operations are running can cause hardware expansion errors. When operating WinCC, this can lead to a blockage of the process connection modules.

This means that particularly a dynamic virus protection via Gatekeeper mechanisms is not possible.

It is recommended that you perform virus tests offline and then activate a process connection after resetting the hardware.

Updates of Virus Scanners

Updates of virus scanners that are started automatically via the network can overload the system.

It is recommended to perform virus scanner updates offline and then activate a process connection after resetting the hardware
/////////////////////////////


text

Protool v6.0 RT OPC Server
Юрий Оганесян; 28.8.03

Добрый день!

Поставил Protool v6.0 SP1a
создал проект RT под Windows с опцией "OPC Server" и не могу обратиться к этому серверу клиентом - выдается сообщение "OPCCOMN_PS.dll:OLD Version Installed"! И это при том, что с v5.2 проблем не было.
В чем дело? Хотелось бы получить ответ от представителей Siemens
Re: Protool v6.0 RT OPC Server
Юрченко Владимр; 3.9.03

У меня была такая же проблема. Скачал с www.opcfoundation.org/Downloads/

OPC Common 1.10 Redistributable.zip
и обновил файл OPCCOMN_PS.dll, после чего подобного безобразия не наблюдал. Почему не обновился этот файл при установке - скорей всего что то не учли в инсталляционной программе, или вообще забыли включить OPCCOMN_PS.dll в новый SP. Ну а суть - скорее всего новая версия OPC DA v.3, разработчики ProTool могли использовать новые функции из этой версии и из-за этого конфликт с предыдущей версией.
Re: Protool v6.0 RT OPC Server
Юрий Оганесян; 9.9.03

Хм.. да, после такого вливания система заработала.

А что, OPC.SimaticHMI.PTPro (v6.0) имеет претензию на соответствие OPC 3.0? В «What’s new» я ничего такого не нашел... Владимир! не могли бы Вы указать мне manual (а еще лучше страницу в manual) где упоминается про соответствие Protool RT v 6.0 OPC Server’a соответствующим спецификациям OPC? В силу определенных обстоятельств данный вопрос для меня является непраздным.

Re: Protool v6.0 RT OPC Server
Юрченко Владимир; 10.9.03

Упоминаний о версии OPC DA, которые поддерживаются ProTool Pro OPC сервером я не видел (искал, но не нашел). Есть утилиты для проверки OPC серверов на соответсвие спецификациям OPC. С помощью такой утилиты, скачанной по ссылке на www.opcconnect.com, выяснилось, что ProTool Pro OPC поддерживает v.1 и 2 OPC DA. Конфликт между какими версиями OPCCOMN_PS.dll мог быть, остается не ясным, так как во второй версии OPC DA были модификации (текущая v.2.05a). Но главное, что пока OPC DA 3 сервера ProTool 6.0 и WinCC 6.0 не поддерживают.


text

WinCC и ее база
Сергей; 30.7.03

Здравствуйте!

Подскажите, кто знает, как обнулить полностью базу проекта WinCC, т.е. чтобы в ней не было записей за прошлый период времени.

Спасибо!
Re: WinCC и ее база
Alexis; 31.7.03

Подмени ее пустой базой ..\siemens\wincc\bin\WinCCRT_7.db

Re: WinCC и ее база
Диман; 31.7.03

Через консоль Sybase unload-upload структуры базы. IMHO это единственное верное решение

Re: WinCC и ее база
Александр Родин, ООО "Нева Электрик"; 31.7.03

Подмена базы все-таки вернее.. :) Сразу размер меньше становится.. :)

Re: WinCC и ее база
Сергей; 31.7.03

Спасибо за советы, вот только с последним советом не очень понятно.Объясните, если не сложно.

Спасибо
Re: WinCC и ее база
Александр Родин, ООО "Нева Электрик"; 4.8.03

Да объяснять-то особо нечего.

Просто размер пустой РТ-базы составляет прмерно 1.6 Мб. А размер рабочей РТ-базы может достигать нескольких Гб. Кажется арифметика простая.

Re: WinCC и ее база
Unity; 10.9.03

Здесь не все так сложно как на самом деле :). Пуск ->...-> WinCC -> Tools -> Project Duplicator -> Save As ... В итоге чистая база - 1 638 400.


text

? задание строкового свойства из Delphi - PDLCSSetPropertyEx
Шимолин Сергей; 8.9.03

Из Delphi работаю с ODK-функциями PDLCSSetPropertyEx, PDLCSGetPropertyEx. При доступе к числовым свойствам всё отрабатывает нормально, при работе со строковыми свойствами какие-то проблемы.. Если кто работал - киньте работающий примерчик.

Спасибо.
Re: ? задание строкового свойства из Delphi - PDLCSSetPropertyEx
Alexis; 8.9.03

BSTR bstr=::SysAllocString(L"Ops!");

PDLCSSetPropertyEx(lpszProjectName,lpszPictureName,lpszObjectName,lpszPropName,VT_BSTR,&bstr,0,NULL,&wccError);
::SysFreeString(bstr);

Так пробовал?
Re: ? задание строкового свойства из Delphi - PDLCSSetPropertyEx
Шимолин Сергей; 9.9.03

У меня вобщем-то проблема была в вызове функции на pascal`e, а в документации все на C. Но всё равно спасибо, ответ навел на мысль - тип VT_BSTR на Delphi заменяется на WideString, а я работал с обычным String. Заработало всё вот так:

var
s : WideString;
begin
PDLCSGetPropertyEx( pchar(ProjectName), PAnsiChar(Form1.CurrPictureName), lpInfoStruct.szObjectName, 'Позиция', varOleStr, @s, 0, nil, @Error)
end;

И насчёт выделения памяти: здаётся мне специально выделять память не надо -
BSTR bstr=::SysAllocString(L"Ops!");

В документации написано:

For types which have a buffer (e.g. BSTR), the buffer is allocated by the function and must be cleared afterwards by the calling application.

Т.е. память выделяется внутри функции, а вот освобождать её как раз должны мы.
Re: ? задание строкового свойства из Delphi - PDLCSSetPropertyEx
Alexis; 9.9.03

В дока много чего написано :))

BSTR все равно надо инициализировать...

BSTR bstr=::SysAllocString(NULL);
PDLCSGetPropertyEx(...,VT_BSTR,&bstr...);
::SysFreeString(bstr);
Re: ? задание строкового свойства из Delphi - PDLCSSetPropertyEx
Alexis; 9.9.03

А хотя можно и не инициализировать... GetProperty сам все сделает...

Кстати, наскоко я помню не все строковые свойства VT_BSTR, некоторые VT_LPSTR...


text

RACK PC IL не пулучается сделать автовход для юзера
Хоружевский Роман; 16.8.03

RACK PC IL не пулучается сделать автовход для юзера, есть админ и юзер с правами админа, хочу сделать автоматическую регистрацию под юзером,пробовал ConfigNT, ставлю юзера Kotel вместо админа, при рестарте 1 раз хводит все нормально, как только выключил машину,вход опять под админом, плюнул на все,залез в реестр, поменял DefaultUser на Kotel, та же песня, при следующем просмотре в реестре опять появляется админ в этом поле, что делать не знаю, может где прописано что на данной машине должен быть только админ или что то еще, или реестр защищен, кто знает помогите плиз.

Re: RACK PC IL не пулучается сделать автовход для юзера
Олег; 18.8.03

Там, вроде, надо еще одну запись в реестр добавить в тот же раздел где и DefaultUser находится DefaultPassword и присвоить ей значение пароля этого юзера (открытым текстом) только не помню в кавычках или нет.

Re: RACK PC IL не пулучается сделать автовход для юзера
Хоружевский Роман; 18.8.03

Все записи в реестре есть, на форуме по Win2000,написано следующее:

"4.05. Как отключить требование ввода пароля при загрузке Windows 2000?

1. Если машина не является членом домена, можно воспользоваться апплетом
Пользователи и Пароли (User and Passwords) из Панели управления. На закладке
Пользователи убрать галочку "Требовать ввод имени пользователя и пароля".

2. В противном случае идем в Control Panel -> Administrative Tools. Далее -
апплет Local Security Policy -> Security Options, опцию "Disable CTRL+ALT+
DEL requirement for logon" выставляем в Enable (не будет появляться окошко с
предложением нажать "три заветные кнопки"). Проверяем, чтобы опция "Do not
display last user name in logon screen" была выставлена в Disable. Запускаем
regedit. Добавляем (если отсутствует) параметр AutoAdminLogon: REG_SZ: 1
в ветку HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon.

Изменяем значение ключа DefaultUserName на имя нужного пользователя. Создаем
ключ DefaultPassword (тип STRING) и присваиваем ему тот пароль, какой нужен.
Закрываем regedit, делаем Log Off. Происходит выход из под вашего аккаунта и
автоматический вход с именем пользователя, которое указано в DefaultUserName.

Теперь при любой перезагрузке W2k всегда будет запускаться под этим аккаунтом.
Если все же возникнет необходимость войти в систему под другим пользователем,
можно во время логона держать нажатой клавишу SHIFT. Однако в следующий раз
система загрузится под тем пользователем, который указан в DefaultUserName."

Все это я сделал, не помогает.
Re: RACK PC IL не пулучается сделать автовход для юзера
Олег; 19.8.03

Я делал только это

((Запускаем regedit. Добавляем (если отсутствует) параметр AutoAdminLogon: REG_SZ: 1 в ветку KLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon.
Изменяем значение ключа DefaultUserName на имя нужного пользователя. Создаем
ключ DefaultPassword (тип STRING) и присваиваем ему тот пароль, какой нужен. ))

и у меня уже все заработало.

Re: RACK PC IL не пулучается сделать автовход для юзера
Хоружевсий Роман; 19.8.03

Да я уже все раз 10 перепроверил и переделал,толку нет, при выключении машины в поле DefaultUserName вновь появляется Administrator. Может товарищи из Сименса что-то где-то закрыли не написав об энтом, а вот где энто искать неизвестно. Это единственная машина которая не поддается автовходу, на других все работает, я на нее даже не смог поставить прогу для УПС, которая бы отключала машину корректно, дело в том что на ней стоит заточенная только под данную машину ОС Win2000, вот и думай теперь, что и где они "заточили".

Re: RACK PC IL не пулучается сделать автовход для юзера
Олег; 19.8.03

Снеси все, и поставь по новой.

Re: RACK PC IL не пулучается сделать автовход для юзера
Хоружевский Роман; 19.8.03

Да это проще всего,хочу найти где этот глюк прячется, правда я думаю что это совсем не глюк,а банальная защита.

Re: RACK PC IL не пулучается сделать автовход для юзера
Олег ; 19.8.03

А если это защита, то страхово все сносить. Можно, ведь, потом и не смочь все обратно поставить.

Re: RACK PC IL не пулучается сделать автовход для юзера
Василенко; 20.8.03

Ты проверь что действительно правишь реестр в разделе HKEY_LOCAL_MASHINE,

а не в CURRENT_USER

Re: RACK PC IL не пулучается сделать автовход для юзера
Роман; 20.8.03

Да точно в этой ветке, в ветке юзера даже таких ключей нет,вот сегодня опять пробовал,снова все перепроверил,бестолку.

Re: RACK PC IL не пулучается сделать автовход для юзера
Юрченко Владимир; 8.9.03

Смотрите информацию на www4.ad.siemens.de/news/cs/en/13706130.


text

EIB Visualisation
Evgeny; 7.9.03

Где можно получить ннформацию по визуализации проектов, реализованных на витой паре EIB.Раньше занимался автоматикой LANDIS (UNYGYR),теперь столкнулся с новым для меня напрвлением. Может,SIEMENS, проводит какие-то курсы? Заранее всем благодарен.

Re: EIB Visualisation
Роман Абзаев; 8.9.03

Курсов в России пока нет. Но Николай Фролов с присущей ему энергией вроде как их собирается организовывать и вообще очень активно продвигать стандарт в России. Попробуйте с ним связаться и переговорить на предмет интересующих Вас вопросов. Контактная информация см:

См. http://www.aud.ru/et/about/index.php

Re: EIB Visualisation
Роман Абзаев; 8.9.03

Кстати, Landis & Staefa - это ведь теперь SIBT? Может быть у них что есть?


text

считать циферки из *.csv
Олег; 5.9.03

Есть файл (file.csv) с коэффициентами (float).

Числа в нем записаны в столбик (или через разделитель - неважно).
Числа имеют разное число знаков и могут быть записаны как в простом, так и в показательном виде.
Нужно считать эти числа в тэги.
Как это можно сделать.

Re: считать циферки из *.csv
Юрченко Владимир; 5.9.03

Для начала посмотрите в

www4.ad.siemens.de/news/cs/en/71078, где приводится пример записи в текстовый файл. Ну а для считывания из файла используйте fscanf(), параметры в ней смотрите в справочнике по С в соответсвии со своими нуждами. Потом считаннные значения в переменных скрипта функциями SetTag...() загоните в теги.
Re: считать циферки из *.csv
Олег; 5.9.03

Спасибо.

Уже сам разобрался.
Сделал через fgets, затем atof, затем SetTagFloat.
(Через fscanf может и лучше, но переделывать уже не буду)


text

логи WinCC
Роман Журавлёв; 5.9.03

где посмотреть описание сообщений в логах WinCC, в Knowledge Base кое-что есть, но оч. мало. Может, кто сталкивался с подобными ошибками :

1007009,4,,<имя компьютера> ,SCRIPT,APDMConnect-Thread said good-bye


text

WinCC flexible Compact, Micro, etc.
fresco; 4.9.03

Прочитал новости раздела HMI, и возникло несколько вопросов :-)

Не могли бы представители Сименса рассказать о будущем HMI софта от Сименса?
Будут ли существовать параллельно две линейки - WinCC и ProTool - или одна из них прекратит существование?
Что есть WinCC flexible - новое название ProTool или радикально другой продукт?
Будет ли возможен относительно дешевый апгрейд для пользователей ProTool/Pro CS v6 или предлагается начать с нуля?
Из предварительной информации о новых панелях исчезло упоминание Windows CE. Что это означает?
Какова будет политика защиты от копирования? (без авторизации/авторизация на дискете/на другом носителе)

Re: WinCC flexible Compact, Micro, etc.
Павел Иванов (Сименс-Москва); 5.9.03

Краткую информацию о WinCC flexible Вы можете прочитать в разделе новостей.

Все новые панели работают под управлением Windows CE.
Мы готовим новую информацию на русском языке по новым продуктам. Как только она будет готова, мы опубликуем ее на сайте.

См. http://www.automation-drives.ru/as/


text

WinCC не может добавить драйвер
Алексей Светличный; 4.9.03

Имеется WinCC 5.1 Hotfix4. При попытке в TagManagment добавить новый драйвер вылетает ошибка и программа выгружается из памяти. Переустановка непомогает. Где лыжи мазать?


text

ProTool
Александр; 29.8.03

Где можно скачать 2 SP для ProTool 6.0

Re: ProTool
VVV; 3.9.03

Он очень большой 450МБ


text

Кто такой РМС?
Денис Дроздов; 29.8.03

Кто такой Simatic S5 PMC и где про него читать? Как им пользоваться в ВинЦЦ и в котнтроллере?

Re: Кто такой РМС?
Чистяков Дмитрий ОАО СеверСталь; 29.8.03

S5 PMC это набор функциональных блоков для организации коммуникаций Simatic S5 с системами визуализации.

Это блоки, которые обеспечивают обмен данными примерно, так же как это позволяет делать S7. Т.е. не вводя в программу контроллера сбор данных из различных DB и с последующей передачей этих данных в сеть.
Так же в пакете имеются блоки для посылки сообщений по изменению сигнала, блоки измеряемых значений сигналов.
По умолчанию этих блоков в STEP5 нет. Это дополнительный пакет и его надо покупать отдельно.
Re: Кто такой РМС?
Денис Дроздов; 1.9.03

Ага! Понятно. Каталожный номер не подскажете?

Re: Кто такой РМС?
Чистяков Дмитрий ОАО СеверСталь; 2.9.03

Вот ещё краткое описание

------------------------
Стандартное программное обеспечение PMC (Process Monitoring and Control System) позволяет обеспечивать удобство управления и мониторинга процесса, а также отображения его состояния.
PMC/LS-B позволяет конфигурировать до 4 каналов управления и мониторинга.

Характеристики
PMC для COROS LS-B имеет следующие характеристики:
Простая организация связи между SIMATIC S5 и COROS LS-B.
Мощная обработка данных.
Гибкость.
Координация всех коммуникационных операций между COROS LS-B и SIMATIC S5.
Стандартное представление объектов в COROS LS-B, включая функции мониторинга.

Кроме стандартных коммуникационных блоков KOM-OS, поддерживаемых всеми устройствами COROS LS-B, могут быть использованы следующие коммуникационные расширения:
Сигнальные функции.
Состояния, стандартные изображения и объекты.
Эти функции конфигурируются, настраиваются и тестируются с помощью пакета PMC PRO.

PMC/LS-B: Сигнальные функции
Пакет „PMC/LS-B: Signaling functions„ позволяет легко и просто конфигурировать различные сообщения. С COROS LS-B эти сообщения выдаются на экран или принтер из архива сообщений.
COROS LS-B позволяет выбирать и квитировать получение сообщений. События, зарегистрированные центральным процессором ПЛК, могут выводиться не более чем через 48 каналов:
COROS LS-B по шине ПЛК (VP-B)
COROS LS-B по Industrial Ethernet (IW-B, OP-B)
CP 524/5 (для регистрации)
CP 526/7/8 (отображение сообщений)
CP 581 (в сочетании с пакетом PMC 581)

PMC/LS-B: состояния, стандартные изображения и объекты
Пакет „PMC/LS-B: status, standard displays and objects„ стандартизует объекты представления для COROS LS-B, включая соответствующие функции мониторинга. Пакетом поддерживается передача данных в/из PMC объектов и структуры данных объектов.
PMC/LS-B поддерживает следующие типы объектов:
Структура регулирования R64: регулятор непрерывного действия, шаговый регулятор, точки измерения
Компактный контроллер SIPART DR: регулятор непрерывного действия, шаговый регулятор
Резервированный модуль регулирования IP 260: регулятор непрерывного действия, шаговый регулятор
Окно измеренных величин
Резервированный модуль пропорционального действия IP 261
Исполнительные элементы системы управления: двигатели, задвижки, выключатели
Любые аналоговые величины с мониторингом граничных значений
Любые двоичные состояния
Модульные регуляторы: регулятор непрерывного действия, шаговый регулятор
--------------------------
6ES5895-4SA21
SIMATIC S5, ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ НАСТРОЙКИ ПАРАМЕТРОВ COM 525, С РУКОВОДСТВОМ, 3,5" И 5,25"-ДИСКЕТЫ, АНГЛИЙСКИЙ ЯЗЫК
326 евро


text

Звук в WinCC - предпусковая сигнализация
Мишуткин Александр; 2.9.03

Уважаемые коллеги !

Есть такая проблема - не могу ПРАВИЛЬНО включить проигрывание звукового файла( определяется состоянием тега).
Не аларм - предпусковая сигнализация.


text

OP170B и USB адаптер
Гусев; 1.9.03

Никто не сталкивался с проблемой программирования OP170B через новый USB адаптер? Питание 24 В на него подаётся через разъём MPI, а на панели оператора (разъём IF1B) на ногах 2 и 7 питания нет...


text

OPС-server
макс; 23.8.03

У нас на заводе имеется технологический процесс, который управляется контроллером S5-155u c коммуникационным процессором Industrial Ethernet. Визуализация работает на очень старом РС(486-33 mhz) под управлением аналога MS-DOS.

Вопрос: возможно ли создать новую визуализацию на современном РС с обычной сетевой картой (Ethernet), установив на нем ОРС-сервер и написав программу визуализации например на С++ или Visual Basic.Если это возможно, то подскажите пожалуйста как называетя ОРС-сервер и где можно найти описание ОРС-коммуникаций. Зарание СПАСИБО!!!
Re: OPС-server
Чистяков Дмитрий ОАО СеверСталь; 25.8.03

Пожалуй тут будет более правильно купить Siemens`овскую карту. Необязательно покупать CP1613, можно обойтись и CP1612 (120 евро), но ещё придётся купить и SoftNet (450 или 956 евро) OPC там имеется в комплекте.

Re: OPС-server
Александр Родин, ООО "Нева Электрик"; 25.8.03

Все работает на любой сетевухе, если конечно вам не требуется выполнение специализированных S7 функций. И OPC, как дешевое решение очень даже ничего - правда стоимость SoftNet эту дешевизну перебивает, когда станций немного, но при этом OPC более тормозной, когда есть большое количестов станций.

Кстати, под WinCC для Ethernet OPC не требуется.
Про OPC-коммуникации смотрите на www.opc.org
Re: OPС-server
Юрий Оганесян; 25.8.03

??? www.opc.org ??? Ха-ха-ха... Хорошая шутка ...

Re: OPС-server
Александр Родин, ООО "Нева Электрик"; 25.8.03

Да.. смешно получилось.. :))

Прошу прощения, ошибся

http://www.opcfoundation.org/

Так будет правильно.. :)

Re: OPС-server
Макс; 29.8.03

Большое спасибо за советы!!!


text

Печать Тренда
Константин; 28.8.03

Возможно ли распечатывать тренды из WinCC(вапианты кроме PrintScreen)

Re: Печать Тренда
Александр Родин, ООО "Нева Электрик"; 28.8.03

теоретически можно распечатывать тренды с помощью ReportDisigner-a.

Для этого в нем настраивается шаблон CCTlgRtCurves.RPL или CCTlgRtTables.RPL, смотря чего печатать; далее конфигурируется PrintJob @Report Tag Logging RT Curves или @Report Tag Logging RT Tables, эти же PrintJobs можно выполнять при помощи API из скриптов.

На практике же я не знаю кто вообще этим пользуется... %) Потому что оЧЧЧень неудобно и абсолютно не то что обычно хочется.

Re: Печать Тренда
Goodvin; 29.8.03

Можно использовать функцию PrtScreenPart.


text

Мнемосхема
Виктор; 25.8.03

Вышлите пожалуйста образы мнемосхем PDL (желательно пищевой или химической промышленности) vponamarev@smtp.ru

Re: Мнемосхема
Любитель Симатика; 25.8.03

А что, конкретное производство не имеет значение? ;-) В пищевой, и уж тем более в химической отрасли немеряна туча технологий и у каждой будут свои мнемосхемы. Да мало того, они еще и на разных заводах разные. Или просто как демки нужны? Тогда так и говори.

ЗЫ. А самому не нарисовать что-ли?
Re: Мнемосхема
Виктор; 25.8.03

Делаю свой первый проект.

Ну и надо посмотреть как у других сделано.

Re: Мнемосхема
Eugene; 28.8.03

Лучше самому сделать. Быстрее разберешся. А если хочешь посмотреть, есть журнал специальный. Называется "Автоматизация..." чего-то там. :)


text

Глюк ProToolPro RT
Eugene Sergeev; 27.8.03

Добрый день!

В ProToolPro RT 6.0 периодически наблюдается следующий глюк - исчезают
кириллические надписи с кнопок. Как
бороться?


text

Кто-нибудь работал с PCS7?
Олег; 6.1.03

Привет всем!

Ситуация такова: группа разработчиков трудится над одной задачей и каждый делает в ней свою часть.
Как сделать так чтобы все разработчики этой задачи работали с одним проектом в среде PCS7 и разделяли его по сети?
Дело в том, что просто открыв папку с проектом для доступа из сети не решается проблема совместного использования проектных данных. В то время когда один открыл проект, другой наслаждается сообщением типа:Cannot open database.
Подскажите, если знаете.
Re: Кто-нибудь работал с PCS7?
Михайлин Сергей; 8.1.03

Надо кроме простого расшаривания настроить SIMATIC Workplace в Контрольной панели на сетевой доступ. После этого расшаренный проект могут открыть для разработки несколько пользователей. Проверено! Единственное, у них должны быть четко разделены задачи, а то если они будут одновременно трудиться над программной для одного контроллера то разработка превратится в муку; медленно. А вариант один человек - один контроллер и один человек - один проект WinCC очень даже работоспособен.

Re: Кто-нибудь работал с PCS7?
Евгений; 26.8.03

Сергей, можно ли поподробнее про данную процедуру, и что такое SIMATIC Workplace, где находится.

Re: Кто-нибудь работал с PCS7?
Михайлин Сергей; 26.8.03

Данная фича находиться в Control Panel. Там надо проверить наличие галки Multi-User project.

Re: Кто-нибудь работал с PCS7?
Yrok; 26.8.03

Чтобы было всем известно SIMATIC Workplace с WinCC не поставляется так что его в Control Panel может и не быть, для этого надо его установить с диска STEP 7 V5.1

Re: Кто-нибудь работал с PCS7?
Чистяков Дмитрий ОАО СеверСталь; 26.8.03

Вообще, что-то тут не так. Так как мы работаем без проблем, установив PCS7 и расшарив папку на сервере (W2k Server, W2k Prof, NT).

Естественно, даётся право изменять один блок только одному пользователю. А все свободные (не открытые кем-то) на здоровье открывай.
OnLine делаем по TCP/IP с нескольких станций и то же самое.


text

Создание Text tag
Прокопенко Вера; 7.8.03

Нужно , используя фунции ODK, создать тег типа Text 8-bit character с определенным начальным значением. Есть функция GAPICreateNewVariableEx4 (и еще две подобные), создающая тег, есть структура MCP_NEWVARIABLE_DATA_EX, где, казалось бы можно задать все нужные параметры, но дело в том, что ни одна из функций создания тега не может использовать данную структуру. А в других структурах нет возможности задать начальное значение текстовому тегу. Чья здесь ошибка: моя или WinCC? Используются: WinCC v5.1, ODK v5.0 - все *.h *.lib файлы от 8.12.2001г.

Re: Создание Text tag
Yrok; 7.8.03

Слушай а может можно определить свою структуру. Хотя честно говоря я с ODK практически не работаю.

Попробуй задай вопрос ещё тут:
http://simatic.nm.ru/phorum.dhtml

Re: Создание Text tag
Костенич Дмитрий; 21.8.03

... А если повнимательнее почитать документацию то вдруг обнаруживается функция GAPICreateNewVariable5, которая как раз и позволяет задавать стартовые значения и для текстовых тегов ... :)

Re: Создание Text tag
Евгений Трунов; 26.8.03

Да, только там проблемы с типом VARIANT :-).


text

Deactivate
Владимир; 25.8.03

Win CC 5.1

В проекте создано соединение TCP/IP
Если нет связи с контроллером, проект RT не останавливается. Висит сообщение Deactivate Data Manager на 75 %.
Если в WinCCExplorer убить это соединение, все становится нормально.
Где покопать, чтобы устранить эту проблему ?


text

WinCC - проблемы с графикой
Серегй Колпащиков, Акватехнология; 21.8.03

Добрый день.

Возникла проблема:
Есть проект, на PDL-ках куча различных объектов из библиотеки символов (трубы и т.д.).

Однажды открыли PDL на другой маштне,а все символы отображаются насосами (и после этого и на родной машине показываются насосы), причем по двойному щелчку в окне редактирования устанавливается на правильный объект.
Исправили все вручную :(((
После переустановки компьютера возникла такая же проблема с другим проектом.

Не встречасля ли кто с такой проблемой, и можно ли как-нибудь зарефрешить картинку?

ПО: W2K+WinCC 5.1

Заранее спасибо.
Re: WinCC - проблемы с графикой
Дмитрий; 21.8.03

Было такое :-) ProTool'а на компьютере не было? Как я понял, когда разбирался, WinCC и ProTool ставят одну и ту же библиотеку символов, но в разные каталоги. На другом компе библиотека оказалась в другом месте и все сбросилось. Вывод - надо делать одинаковую конфигурацию софта.

Re: WinCC - проблемы с графикой
Серегй Колпащиков, Акватехнология; 22.8.03

Да вариант с протулом подходит для обоих случаев.

А как исправить картинки по проще, не пробегая по всем символам вручную?

Заранее спасибо.


text

WinCC графика
Виктор; 22.8.03

Как повернуть графический обьект с лево на право и вокруг?

Re: WinCC графика
Eugene; 22.8.03

Посмотри стандартные примеры проектов. везде есть. В крайнем случае, это всего-лишь математика :)


text

ProTool
Юрий; 20.8.03

Не подскажет ли мне кто : существует ли пакет-аналог protool? Необходимо отредактировать и залить проект в OP-17.

Re: ProTool
Чистяков Дмитрий ОАО СеверСталь; 20.8.03

А какой смыл в аналоге?

Может проще взять родной ProTool или хотябы ProTool Lite?
Re: ProTool
Юрий; 21.8.03

Так ведь его еще надо где-то взять...

Свободно ведь не распространяется.
К примеру, на Step7 существуют аналоги, используя которые можно выказать/закачать а также отредактировать программу контроллера.

Re: ProTool
Bkmz; 21.8.03

А что, аналоги халявные?!!!! Дай ссылку!!!!!

Re: ProTool
Юрий; 21.8.03

Не...не халявные. Не полнофункциональные.Одни не входят в online, другие входят, но не показывают текст программы...Но через пень-колоду можно что-то сделать...


text

Computer Name
Alexis; 4.8.03

Трабл: если открывать проект в котором имя сервера отлично от текущего имени компьютера, то естественно WinCC начинает ругаться на тему Start server locally...

Может кто-нибудь знает как программно сменить имя сервера в проекте? (смену имени компьютера на предлагать :)
Re: Computer Name
Yrok; 4.8.03

так ты открой его локально поменяй имя сервера как у твоёй машины и закрой а потом открой снова.

Re: Computer Name
Alexis; 5.8.03

Когда засовываешь WinCC-проект в инсталятор, то естественно неизвестно на какой компьютер его будут инсталировать... А по доброте душевной хочется оградить глупых юзеров от необходимости ковырятся в проекте.

Re: Computer Name
Yrok; 5.8.03

Слушай насколько я понимаю тебе надо устанавливать проект на сервер та это делает специалист (ТЫ). А на клиентские машины ставишь пакет WinCC без CS то есть RT (RunTime) и всё. После этого клиент не сможет запустить проводник WinCC, значит и поменять имя servera. А на серваке тут уж должен квалифицированный человек заниматся, а то с дуру чего нибудь сломать можно.

Re: Computer Name
Alexis; 5.8.03

:)

Нужно проект типа Single-User System запихать в инсталятор и при инсталяции на автомате подменить имя компьютера в проекте.
Нифига не получается...
Re: Computer Name
Костенич Дмитрий; 21.8.03

Решение то довольно простое - подменить значение в поле MACHINENEME в таблице MCPTMACHINE в CS базе проекта. А уж как это сделать в инсталляторе - тебе виднее ... (каким уж ты там инсталлятором пользуешься)

Re: Computer Name
Alexis; 21.8.03

2 Костенич Дмитрий

Дык не все так просто... Это-то я в первую очередь попробовал - не проходит :(
Надо еще каким-то образом в файле .mcp имя подменить...
Будет время надо попробовать Project Duplicator расковырять - он как-то это умудряется делать...


text

Блокировка в User Archives Editor
vvgut; 21.8.03

Раздел "Configuration tips" WinCC HelpSystem содержит следующую фразу "If after the start of the User Archives Editor all icons of the tool bar are grayed out (except for "Restore"), the "UAEditor.loc" file must be deleted from the project path". У меня такая ситуация возникала. В связи с этим 2 вопроса: 1) причины возникновения; 2) режим RT: возможность возникновения, последствия, способ автоматического обнаружения и устранения (видимо, удаление файла).

Заранее благодарю всех откликнувшихся.


text

Redundancy + Slot
Олег; 13.8.03

Были ли прецеденты по установке Redundancy на серверы в одном из которых стоит Slot-контроллер?

Через какое соединение осуществляется его связь с Redundancy-системой?
Какие для этого нужны коммуникационные процессоры и сколько их нужно?
Можно ли например так:
- CP1613 2шт. в сервере со Slot(один для Slot-контроллера и один для WinCC)
- CP1613 1шт. в сервере без Slot-контроллера
- на клиентах (2шт.) обычные сетевые карты

Какое программное обеспечение может понадобиться еще? (Я имею ввиду кроме обычных авторизаций: WinCC-CS, WinCC-server, WinCC-Redundancy)

Re: Redundancy + Slot
Олег; 18.8.03

Что Slotы никто не юзает?

Re: Redundancy + Slot
Дмитрий; 21.8.03

Slot юзают, прецендентов не было :-) И в описании на Redunancy такого варианта не встречал. Боюсь что не получиться.


text

Последний Hotfix для WinCC v5.1
Рящиков Вячеслав; 18.8.03

Подскажите, пожалуйста, какой последний Hotfix существует для WinCC v5.1 и где его можно скачать?

Re: Последний Hotfix для WinCC v5.1
Оганесян Юрий; 20.8.03

Siemens в этом отношении довольно щепетилен. Нужо вначале описать проблему и потом спецы с Siemens подумают и, если ваша проблема решается каким-то HotFix'ом, то соответствующий вышлют.

Re: Последний Hotfix для WinCC v5.1
Godvin; 21.8.03

Последний - HotFix4. Он есть на диске PCS7_V5.2_SP3 весит почти 17 мег.


text

Документация Basic Process Control
Дмитрий; 19.8.03

У кого есть документация Basic Process Control (желательно на русском)или ссылочку, где ее можно взять.

А так-же если есть то документацию по Faceplate (*.ocx объекты)
Re: Документация Basic Process Control
Михайлин Сергей; 19.8.03

Дока на BPС по ссылке.

Описание faceplate есть в описании технологической библиотеки PCS7 (если я правильно понял про какие ocx Вы спрашиваете)

См. WinCC-BPC Rus


text

PCS7
Добронравов Сергей; 18.8.03

Где взять PCS7

Re: PCS7
Михайлин Сергей; 19.8.03

оформить покупку пакета PCS7 (какого?) можно в любом региональном представительсве Сименс. См. раздел "О нас"


text

VBA в wincc6
Alec; 19.8.03

Что-то глючная реализация VBA для Grafics Designer. Неделю занимаюсь уже 2 глюка:

1. свойство Icon объекта MenuItem не устанавливается.
2. Создал форму VBA, поместил на нее TextBox. Почему-то символы "+" и "-" в TextBox не вводятся.

Может кто сталкивался с подобным. Как решить?
Может конечно у меня глюки.


text

Проблемы с открытием проекта в Protool
Виктор; 18.8.03

Здравствуйте!

Помогите, пожалуйста. Есть проект на протуле. У автора на компьютере он открывается, а у нас нет. Выдает следующую ошибку:
Error on converting OID5==OID_POB_CTDRIVER_MANAGER. Please contact the manufactored.
Подскажите в чем проблема? (Версии протула одинаковые)


text

WinCC и линия разлива
Павел Синица; 15.8.03

Работаю на пивовареном заводе мы много используем WinCC для управления технологическими процессами (некоторые делали сами). Возникла идея сделать проект на линию разлива (KHS) но мы никогда не видели такого проекта итрудно представить как он вылядит.

Если кто-то использует WinCC для визуализации лини разлива помогите!!!!
e-mail:snaric@rambler.ru
Re: WinCC и линия разлива
Buka; 17.8.03

Какая задача, просто визуализация или управление ?

на нашем пивзаводе 3 линии розлива, с этих линий на 3 компьютера выводится информация: кол-во вход/вых бутылок, тип бутылки, номер смены и др.
Программа написана на Watcom C, данные передаются по RS422 (CP441-1 -> на PC, ISA адаптер Moxa-I132).
Если интересует могу дать программу, и исходники.

Re: WinCC и линия разлива
Роман Абзаев; 18.8.03

А Вы, батенька, посмотрите во-первых референцы, а во-вторых информацию по Braumat - это спец. система для пивоварения на PCS7.


text

TP170A
Игорь_К; 30.7.03

Здравствуйте.

Начал разбираться с TP и вот такая проблема. При загрузке в панель проекта пишет, что загрузка не возможна из-за несоответствия операционнки. Через PTUpdate пытаюсь сменить её, вылетает окно:
Establishing connection
please boot the operating unit
:-((( Чего делать-то? Подскажите кто знает!
Re: TP170A
Юрченко Владимир; 30.7.03

Всего навсего выключить - включить питание, чтобы панель перестартовала

Re: TP170A
Игорь_К; 30.7.03

Заработало! Большое спасибо

Re: TP170A
Игорь_К; 14.8.03

Здравствуйте!

Не получается организовать обмен сигналами м/у S7 318-2DP и TP170A.
На экране рисуем кнопку. По нажатию выставляем SET_bit тег Старт (М0.0)в единицу.
В симмуляторе при этом тег меняет своё значение с 0 на -1 (грабли?).
В Step 7 в проекте сконфигурирован PLC, Tp, оба подключены к сети Profibus. Пакет Protool интергрирован в Степ.
Кстати при нажатии на кнопку панель задумывается (о чем? :-)) секунд на 10.
Какие есть мысли, поделитесь опытом?
Re: TP170A
Александр; 14.8.03

У меня такая же мутота была с писишным проектом. Почему так получается так и не разобрался. Поборол так:

Взял байт (слово или дв слово) и записал 1 (через Set Value)
Все пошло.
Пиши помогу чем смогу... aleks_ostrov@inbox.ru
Re: TP170A
Игорь_К; 14.8.03

Ещё раз Привет!

Косяк был в скорости обмена по сети Profibus. Была 1,5 Мbit/s поставил 187,5 Kbit/s, и всё заработало.


text

OP и форматы данных
Поздняков Андрей; 16.7.03

Hello!

В панели оператора OP7 не "понимает" форматы данных DATE и TIME_OF_DAY. Пришлось писать функцию перевода в формат WORD. Может можно было сделать проще?

С уважением.
Re: OP и форматы данных
Александр; 14.8.03

Привет!

Я не очень понял что ты имел под словами "Пришлось писать функцию перевода в формат WORD", но сделать можно очень просто.
Дата - 3 байта
Время - 3 байта
В опэшке создаешь 6 полей (через :,/ и т.п.) и смотришь их в HEX.
Попробуй так, тока напиши получилось или нет, а то давненько это уже было может чего и подзабыл ;)
aleks_ostrov@inbox.ru
Re: OP и форматы данных
Yrok; 14.8.03

Попробуй через тег Z_DATE это системный тэг. Я лично делал вот так для ТР27:

Завёл в панели тэг Z_DATE типа стринг
длинной 10, в функции тэга поключил
Date Display/Edit. Далее на экране установил Input/Output Field и подключил тэг Z_DATE, указал что поле ввода стринг, длинна 10, тип поля Input/Output и всё. Панель сама выводит дату в нужном формате.
Re: OP и форматы данных
Поздняков Андрей; 14.8.03

Hello Alexander & Yrok!

1. Да просто функция, на входе у которой переменная типа Time_Of_Day, а на выходе переменные Hour, Min, Sec, Msec типа Word. Как только будет возможность попробую сделать как вы рекомендуете, но сомневаюсь, что получиться. :)

2. К сожалению ни OP7 ни OP17 не знают функций Date Display/Date Edit.

С уважением.


text

Redundancy + синхронизация файлов
Олег; 13.8.03

- Допустим каждый сервер пишет в файл данные процесса через определенный интервал времени (допустим 5 сек.)

- Произошел сбой на одном из серверов
- На втором сервере файл продолжает писаться

Будут ли пропуски в записях на исправном сервере в момент переподключения на него клиентов и т.д.?

Как сделать синхронизацию записанного файла после восстановления второго сервера?

Кто нибудь уже делал что-нибудь подобное?

Re: Redundancy + синхронизация файлов
Михайлин Сергей; 13.8.03

Ответы:

Нет
Автоматом
Да многие
Re: Redundancy + синхронизация файлов
Олег; 13.8.03

Вы уверены во втором ответе "Автоматом"

Насколько я понял из документации на Redundancy автоматом он синхронизирует только alarm logging, tag logging, user archives и всё, а остальное, извините.

А файлы, записанные через Сишные функции из скриптов он автоматом то вряд ли будет синхронизировать.

В связи с этим и ответ на третий вопрос я не считаю столь однозначным

Re: Redundancy + синхронизация файлов
Михайлин Сергей; 14.8.03

Тогда да. Файлы созданные Вами самими(через Си-функции) Вы сами и должны синхронизировать. Просто в исходном посте это не было сказано. Автоматом синхронизируются штантные файлы-архивы WinCC. Все остально, действительно извините... ;-)


text

Аудио собщения из WINCC
pas; 12.8.03

Подскажите, как можно запусвкать wav файлы в фоновом режиме из WinCC по событию

Re: Аудио собщения из WINCC
Александр Родин, ООО "Нева Электрик"; 12.8.03

Элементрано.

Пишите на мыло - вышлю готовую функцию.
Re: Аудио собщения из WINCC
В. Сорокин.; 12.8.03

Александр, здравствуйте!

Неужели Вам пригодился "опус" Стаса?
Если это что-то другое, то, если можно, и мне, пожалуйста.

Re: Аудио собщения из WINCC
Олег; 13.8.03

И мне пожалуйста!

Re: Аудио собщения из WINCC
Роман; 13.8.03

Ребята, а для чего форум, выложите на форуме инфу, ведь он для этого и создан!


text

Redundancy + Win2K
Олег; 13.8.03

В документации везде написано, что Redundancy работает только под WinNT.

Нигде не сказано, что под Win2K тоже работает.
Так все таки, работает Redundancy под Win2K или нет?
Может документация выпущена когда еще не было Win2K?
Да, и если работает, то что надо ставить на серверы (PROFESSIONAL или SERVER)?
Re: Redundancy + Win2K
Юрченко Владимир; 13.8.03

Для WinCC v.5.1 серверы ставятся на NT4 SP6a или W2000 SP2 Professional и соответсвенно на них может работать и Redundancy. Документация по Redundancy действительно старая и в ней о W2000 поэтому ничего нет.

На новой 6-ой версии WinCC сервера ставятся только на W2000 Server и Advanced Server и соответсвенно Redundancy для серверов ставится там же (я не беру случай резервирования Single Station - это можно, но на мой взгляд не очень нужно).

Re: Redundancy + Win2K
Олег ; 13.8.03

Спасибо за ответ.


text

Group Display
Yrok; 4.8.03

Подскажите как правильно организовать Групповые сообщения:

Для примера создаю три кадра NewPdl0.Pdl, NewPdl1.Pdl, NewPdl2.Pdl
Размещаю на каждом кадре GroupDisplay,
в GroupValue каждого дисплея указываю имя тэга NewTag.EventState. Далее в Alarm Logging создаю одиночное сообщение, в качестве Message Tag указываю TagAlarm (bool), Status Tag указываю NewTag.StatusTag бит 7. После чего Открываю Picture Tree Manager и сохраняю дерево, далее в кадре NewPdl2.Pdl устанавливаю TagAlarm в 1
в результате обзорной области сообщение выводится но не более. Беру с помощью тестовой утилиты задаю в NewTag.EventState разную комбинацию
аварий GroupDisplay всё отображает по дереву всё вроде бы окей но не работает подтверждение аварии в single line в обзорной облости. Подскажите как коректнее всё это сделать.
Re: Group Display
Yrok; 5.8.03

Подскажите каким образом связать состояние [активности аварии + квитирование аварии] с GroupDisplay (Находящемся в кадре-источнике аварии)

Re: Group Display
Alexis; 5.8.03

Сгенери проект Split Screen Manager-ом и посмотри как там это сделано.

Re: Group Display
Yrok; 5.8.03

Так я это и сделал, только GroupDisplay там в области Owerview и всё. А чтобы этот GroupDisplay (в Owerview)замигал нужно ещё поставить GroupDisplay в самом верхнем кадре, согласно PictureTreeManeger. Я даже могу добится чтобы они магали (Но тогда я ручками изменяю значение в теге подключённом к GroupDisplay к свойству GroupValue). Но интересно чтобы система сама согласно ситуации [Активность аварии + Квитирование аварии] изменяла этого подключённого тега.

Re: Group Display
Yrok; 5.8.03

Если есть какой-либо минимальный простенький примерчик, Вышлите пожалуйста на E-mail XrykOne@rambler.ru

Re: Group Display
Yrok; 6.8.03

Слушайте раскопал в примере что Всеми вопросами по установке и квитированию ошибок занимается PLC, это на самом деле так?

Re: Group Display
Ф.Неверов; 11.8.03

Да это так. Я тоже хожу вокруг этого вопроса. Можешь прочитати на этом же форуме вопрос "PCS7 Лишние тэги при трансфере PLS-OS". Вот по ним то обмен и идет. Но механизма Михалин не объяснил. Предложил уити в мыло. На твое мыло введу в курс до чего договорились с Михалиным.

Ф.Неверов

Re: Group Display
Yrok; 11.8.03

XrykOne@rambler.ru


text

Доступ к базам WinCC
NIKOLAHA; 11.8.03

При выполнениии рекомендаций документации, при получении доступа к базе данных WinCC хоть CS, хоть RT обнаруженно следующее:

1. При выгруженном WinCC возможен доступ к любой из баз проекта, хоть через EXEL, хоть через интерактивный SQL, или что нибудь еще.
2. При загруженном WinCC и не запущенном RT картина та же
3. После активации проекта (RT TagLog отключен) доступ к базе CS становится невозможным, доступ к базе RT возможен
4. Если активировать RT TagLog или влепить на форму таблицу пользовательского архива, в общем заставить WinCC обращаться к базе RT получить доступ к обеим базам из "вне" становиться не возможно.
Такое впечетление что после того как к базе начинает обращаться WinCC никто другой это сделать не может.
Использовалась версия WinCC 5.1, OC WIN2000+sp3. Все запускалось на одной машине, доступ к источникам данных производился через "шаровую" память.
Помогите пожалуйста если кто может.
Желательно как нибудь так все решить чтобы не наворачивать много кода, не то чтобы совсем не умею писать код, но хотелось бы как нибудь попроще.

Re: Доступ к базам WinCC
Юрий Оганесян; 11.8.03

Через Sared memory не получится держать 2 клиента - это особенность работы Sybase в "несетевом режиме" - а WnCC только так и работает. А вот через TCP/IP - клиента цеплять можно. Только одного. Видимо, лицензионное ограниечение. Примечание: при определенном наборе устанволенного SIMENS'овского soft'a связь по TCP не устанавливается - даже пот 2638 не присутствует в списке открытых. Мучились довольно долго. Толком в причинах не разобрались. Но мое уверждение можно проверить на "чистой" WinCC без вской предистории со STEP 7 и т.д.


text

Coros OP25
Lego; 9.8.03

На панели OP25 появилась горизонтальная полоса через весь экран, примерно по середине экрана. Может кто подскажет что бы это значило и чем это грозит.

Lego.

Re: Coros OP25
Александр Родин, ООО "Нева Электрик"; 9.8.03

Однозначно подыхает LCD-дисплей - несите в гарантию... если таковая действует.

Re: Coros OP25
Lego; 11.8.03

А если не действует?


text

ProTool - не работает запись значения в тэг
Александр Родин, ООО "Нева Электрик"; 8.8.03

Имею след. конфигурацию:

Компьютер с CP5613, с установленным ProTool и OPC-сервером (SIMATIC NET V.6.0 +SP5 + HF2), работает как мастер на ProfiBus-DP. Кроме него в сети еще 4 слейва.

Данные помеченные как Inputs читаются из ProTool без каких либо проблем.

А вот те данные, которые заданы как Outputs почему-то не принимают значений из ProTool (например по нажатию кнопки пытаюсь изменить определенный бит и он не изменяется).

Что еще интересно, подобная конфигурация но с установленным SIMATIC NET CD 05/2000 работает как на чтение, так и на запись...

Не понятно - это глюк или где-то в конфигурации что-то не так ? Тогда где ?

ЗЫ: Алиасы для первого и второго варианта создавались отдельно.


text

OP17, распайка com-кабеля
Елена Протасова; 7.8.03

Не подскажете распайку прошивочного COM-кабеля для панели OP17 (15pin-9pin, либо 15pin-25pin)?

И можно ли прошить по MPI? Если да, то как?
Re: OP17, распайка com-кабеля
Александр; 7.8.03

По MPI врядли, не пробовал, а распиновка разьемов есть в документации.

пиши на мыло, подскажу, помогу чем смогу.
aleks_ostrov@inbox.ru


text

МР270
Александр; 4.8.03

Люди помогите кто чем может!

Не могу скачать проект с панели, Step ее видит, а с Protool связи нет может шнурок какой специательный есть!?

Заранее огромное спасибочки.
Re: МР270
kot; 4.8.03

а с панели просто так скачать проект невозможно. И с приплясываниями тоже очень сложно.

Re: МР270
Mag; 4.8.03

Есть прога позволяет скачать :) Но уже не под ProTool :(

Re: МР270
Александр; 4.8.03

Mag, и чем же ее можно оттуда выдрать

и главное потом подкорректировать и обратно закачать...;)))
кстати у меня есть аська 288861965
Re: МР270
aim; 4.8.03

Re: МР270
Александр; 5.8.03

В документации по МР270 вродебы как написано что возможно выкачать проект если только при его загрузке была поставлена галочка в строке Enable Upload :

"Загрузка текущего файла проекта из компьютера, используемого для
проектирования, в устройство управления должна быть выполнена с
использованием опции Enable upload [Разрешить обратную загрузку].
Эта опция может быть активизирована в ProTool CS через File →
Download → Preferences [Файл → Загрузить → Предпочтения]".
Re: МР270
Никаноров, Сименс; 5.8.03

Для MPx70 панелей можно загрузить исходник проекта (сжатый) одновременно с бинарным проектом. Если такой исходник был загружен, то его можно выкачать и отредактировать ProToolом.

Но обычно исходники не загружают, так как для этого, как правило, требуется установка большой Flash карты.
Re: МР270
В. Сорокин.; 5.8.03

Есть простой способ. Написать всё заново. Долго, но надёжно.

МР270
Александр; 6.8.03

Спасибо всем кто откликнулся.

Согласен, что исходник я заполучить не смогу, а то что сидит в панели, бинарный проект, я могу оттуда скачать и обратно закачать?


text

PCS7 ES v 6.0 -> Тормозит Graphics Runtime в WinCC v6.0!
Штепа С.А,; 4.8.03

Во время работы Runtime проекта переключение между экранами осуществляется очень медленно: 20 секунд при 100% загрузке процессора (все ресурсы загребает процесс PdlRT.exe). А при выходе из WinCC появляется сообщение о выполнении ошибки программой CCDeltaLoader.exe

Особенности: 3 мнемосхемы 1280x825,на каждой мнемосхеме присутстуют объекты типа "Connector" и "Static Text" (200, 100 и 1 шт. соответственно), ни к одному из объектов не подключен тэг. Чем меньше объектов, тем быстрее открывается мнемосхема, причем система тормозит и при открытии мнемосхем в графическом редакторе.

О системе:
мать - TUSL2-C
CPU - PIII 1,2 Hz
HDD - Barracuda 80 Gb
RAM - 512 Mb
Video - GeForce 2 Ti
Windows 2000 Pro/rus + SP3

При установке PCS7 ES v.6.0. Были соблюдены все требования документации. Из не-SIEMENS ПО установлено только Office XP Pro, WinRAR, WinAMP. Попытка установить SP4 для Windows и переустановить PCS не дала положительного результата.
Помогите, если можете, избавиться от этих тормозов!

P.S. Или лучше поставить ВСЕ с нуля??!!
Re: PCS7 ES v 6.0 -> Тормозит Graphics Runtime в WinCC v6.0!
Чистяков Дмитрий ОАО СеверСталь; 5.8.03

Под каким пользователем Вы это делаете.

Необходим как мимниму Power User (опытный пользователь).
Или дайте пользователю полный доступ к ветке реетра HKey_Local_Machine в regedt32.

Re: PCS7 ES v 6.0 -> Тормозит Graphics Runtime в WinCC v6.0!
Сергей; 5.8.03

Относительно последнего совета.

Более глупого совета я бы и не придумал, или просто хотелось чего-то написать?
Как Вы думаете, уважаемый Чистяков Дмитрий, если человек работает с Сименсом не первый год и отлично знает принципы работы программного обеспечения под управлением Windows 2000, то не кажется ли Вам, что Ваш совет просто смешной!!!
Re: PCS7 ES v 6.0 -> Тормозит Graphics Runtime в WinCC v6.0!
Shade; 5.8.03

Для Сергея.

Уважаемый Сергей, если для Вас некоторые вопросы (или ответы на них) кажутся глупыми, возможно Вам нет смысла посещать этот форум, а для того чтобы "брызгать слюной" есть более подходящие места.
Или просто хотелось что-то написать??? ;-)
Re: PCS7 ES v 6.0 -> Тормозит Graphics Runtime в WinCC v6.0!
Штепа С.А.; 5.8.03

Я все же поставил ВСЕ с нуля! Только Windows и PCS7 ES v6.0. Тормоза так и остались, только при выходе из WinCC сообщение о выполнении ошибки не появляется...

И тут мне в голову пришла идея...Я убрал с мнемосхем объекты типа "Connector" - и, о чудо, та же мнемосхема открывается почти мгновенно!!!
ОБИДНО...мне так понравилось рисовать с этим объектом (убыстряет разработку).

Может кто знает, как побороть эти тормоза с коннекторами?
Или ждать выхода HF или SP для WinCC?
Re: PCS7 ES v 6.0 -> Тормозит Graphics Runtime в WinCC v6.0!
Чистяков Дмитрий ОАО СеверСталь; 5.8.03

Сергей

Человек же не написал, что он уже работает много лет с обрудованием Siemens. :-)
А на ответ навело упоминание об ошибках при запуске и завершении. И чаще всего именно эта проблема доступа вызывает эти сообщения и тормоза.

Что же касается быстродействия. То тут видимо банальный недостаток ресурсов компьютера. Т.к. объем памяти в Вашей системе соответствует минимальному требованию. А кадры визуализации у Вас тем не менее весьма загружены.
Посмотрите системным монитором W2K (не диспетчером задач!) чего у Вас не хватает и какой процесс больше всего загружает CPU.


text

МР270
Александр; 4.8.03

Люди помогите кто чем может!

Не могу скачать проект с панели, Step ее видит, а с Protool связи нет может шнурок какой специательный есть!?

Re: МР270
Юрченко Владимир; 5.8.03

Наверняка вы пытаетесь загрузиться по MPI, а загрузка по нему по умолчанию запрещена. Подключайтесь через COM порт PC и RS232 порт панели - должно работать наверняка ( если еще какая то программа не заняла порт).


text

WinCC trial?
Sergey Tkachenko; 4.8.03

Где бы качнуть WinCC на посмотреть? Начальство нужно убедить в необходимости покупки - нужно что-то показать.

Re: WinCC trial?
Сергей; 4.8.03

Здравствуйте!

Я представляю партнера ф.Сименс на Украине. Если Вы обратитесь к нам, то мы предоставим Вам демо версию WinCC БЕСПЛАТНО!!!
Re: WinCC trial?
Sergey Tkachenko; 5.8.03

На один час? :)))

Пишите пожалуйста - bigbo@ukrpost.net


text

Тренд для дискретных тегов
Алексей; 26.7.03

Есть несколько дискретных тегов. Вопрос: Как их отобразить на одном тренде, разными полосами, чтобы между ними были расстояния и они не пересекались?

Re: Тренд для дискретных тегов
Лев Шерешевский; 27.7.03

Достаточно просто. Надо сделать шкалы параметров со смещением, например для трех трендов подойдет [0,6], [-2,4], [-4,2]. Чтобы оси не сбивали пользователя с толку, тренд надо поместить в picture window и сдвинуть влево так, чтобы оси значений скрыть.

Re: Тренд для дискретных тегов
Лев Шерешевский; 4.8.03

Забыл упомянуть самый простой способ - использовать режим 'Display trends staggered'


text

Вывод звука в ProTool
Александр Родин, ООО "Нева Электрик"; 31.7.03

В ProTool-е сконфигурирована PC-station. В определенные моменты (например приход аварийного сообщения) необходимо прогирывать определенный звук (громко, поэтому пукалка не подходит), но как это сделать ? По идее как-то можно привязать в скрипт вызов функции по типу sndPlaySoundA из winmm.dll, но чего-то я не могу понять, как ее к скрипту пристегнуть...

У кого какие соображения ?
Re: Вывод звука в ProTool
Юрченко Владимир; 31.7.03

Единственный способ из скриптов ProTool общаться с другими программами - через функцию Start_Programm. Можно вызывать Program Files\Windows Media Player\mplayer2.exe с параметрми нужного *.wav. В параметрах можно установить также чтобы приложение было минимизировано, только медиаплеер не закрывется автоматом и при повторном вызове он появляется на экране. Лучше написать на Дельфях программку, которая бы выполняла аналогичную работу и закрывалась.

Re: Вывод звука в ProTool
В. Сорокин.; 31.7.03

Всё очень интересно. Но можно дополнительный вопрос?

Программка FM-Edit: вызываем её упомянутой функцией, не закрываем. А потом, сколько раз вызываем - столько раз она и открывается. А можно-ли, чтобы она повторно не открывалась, а только появлялась, как сказано выше? Очень бы хотелось этого.
Re: Вывод звука в ProTool
Александр Родин, ООО "Нева Электрик"; 31.7.03

выше писалось о поведении Media Player-а... любая другая программка будет себя вести так, как она написана. Например открываться ровно столько раз, сколько ее вызвали.

По любому не очень удобно. Вот если бы можно было в скриптах ProTool-а использовать функции внешних библиотек, как в скриптах WinCC, то цены б ему не было... Но это видимо ограничения встроенного басика. Можно конечно и свою программку написать, тем более что она займет 2 - 3 строчки кода, но как-то ради этого ставить Visual Studio или Delphi не очень хоцца..
Re: Вывод звука в ProTool
Yrok; 1.8.03

Надо написать свою программу (Например на с++) которой прередовать при запуске командную строку которая будет содержать имя файла wav.

в InitInstance
//прописать строчку
//****************
CCommandLineInfo pInfo;
//****************
CWinCCRunDlg dlg;
m_pMainWnd = &dlg;
//прописать строчку
//***************
dlg.m_AppName = pInfo.m_strFileName;
//***************
int nResponse = dlg.DoModal();

В h файле обьявить переменную
типа CString m_AppName;
там же подключаем
#include "mmsystem.h"
далее в настройках проекта в закладке Link в окне Object/Librares modules:
Прописываем winmm.lib, что бы загружалась библиотека.
// далее при запуске в функции
void CWinCCRunDlg::OnShowWindow(BOOL bShow, UINT nStatus)
{
CDialog::OnShowWindow(bShow, nStatus);
// Выделяем память переменной szPath
char* szPath=(char*)HeapAlloc(GetProcessHeap(),HEAP_ZERO_MEMORY,m_AppName.GetLength()+1);
// Копируем значение из одной переменной в другую
strcat(szPath,m_AppName.GetBuffer(m_AppName.GetLength()));
// Проиграть файл
PlaySound(szPath,NULL,SND_FILENAME);
// Освобождаем переменную
HeapFree(GetProcessHeap(),0,szPath);
// Уничтожаем программу (Закрываем её)
this->DestroyWindow();}

Например:
PlaySound("C:\\start.wav",NULL,SND_FILENAME);
Re: Вывод звука в ProTool
В. Сорокин.; 4.8.03

Ко мне тут в выходные сын заглянул. Мою проблему он решил. Кому нужно, пишите - вышлю.

Re: Вывод звука в ProTool
Александр Родин, ООО "Нева Электрик"; 4.8.03

Ну если ваша проблема имеет общую тему с нашей, то может тогда поделитесь опытом ?.. :)

емыл указан вместе с именем..


text

Ошибка штатного "просморщика" таблиц User Archive
Александр; 4.8.03

Обнаружил ошибку в работе компонента CCUATableCtl (просмотр User Archive в экранных формах): периодически в настроенные поля для отображения (режим Form) данного компонента при открытии окна, его содержащиего, подставляются значения ИЗ ДРУГИХ ПОЛЕЙ этой же записи. При переключении в режим Table - то же самое.

После нескольких открытий/закрытий окна с компонентом CCUATableCtl данная ошибка исчезает - видимо, при инициализации компонента поля "путаются". Причем, чем больше загружен процессор станции визуализации, тем чаще возникает "перекрещивание" полей.

Также почти всегда после завершения работы проекта с пользовательским архивом в процессе деактивации появляется окно с ошибкой работы данного компонента.

WinCC 5.1 HotFix4+Win2000Pro,
200 столбцов в таблице UA.

Как это вылечить?


text

WinCC и Routing
Максим Поджидаев; 25.7.03

Здравствуйте!

Кому нибудь удавалось соединить клиента и сервера WinCC работающих в разных IP сетях?
Пример:
Клиент 10.2.97.5
Сервер 10.2.100.6
Я в курсе что Siemens пишет:
"Using routers:
The client-server mode is not released for using routers."
Однако непонятно почему и как это обойти.

Re: WinCC и Routing
Yrok; 26.7.03

Я как раз бьюсь над этим, и WINS подамал и DNS и всё бестолку. Хочу теперь втавить интелектуальную сетевую карту которая создаёт до 32 виртуальных сетей, может прокатит.

Хотя честно немцы косячники то там что то не то то тут, может в 6 версии это устранили.
Re: WinCC и Routing
Yrok; 29.7.03

Вобщем добился таких результатов:

у клиентских машин могут быть разные IP адреса но группа должна быть одна.
Дефект конкретный.
Re: WinCC и Routing
Максим Поджидаев; 31.7.03

Тут скорее не Siemens виноват а Sybase.

По крайней мере к Sybase SQL Anywhere из другой сети без явного указания host=x.x.x.x не подключишся. А WinCC конечно использует только дефолтовый способ подключения.
Re: WinCC и Routing
Yrok; 31.7.03

Я кстати пробывал и в источниках данных ODBC указывать TCP Server-а и имя, всё равно бестолку. Кстати а где это ты указываешь host=x.x.x.x

Re: WinCC и Routing
Максим Поджидаев; 4.8.03

Третья закладка,

Поле ввода напротив CheckBox TCP/IP.
При этом сам CheckBox должен быть отмечен.
x.x.x.x - IP адрес сервера


text

Help!!! WinXP+WinCC
Павел Ш.; 1.8.03

Как установить wincc на winXP? При установке вышло сообщение, что нужна win2k sp2. Помогите!!!

Re: Help!!! WinXP+WinCC
Владимир; 1.8.03

По-моему под WinXP можно поставить только WinCC v.6 . WinCC v.5.1 идет только под Win2000

Re: Help!!! WinXP+WinCC
Александр Родин, ООО "Нева Электрик"; 1.8.03

какая версия WinCC?

Re: Help!!! WinXP+WinCC
Павел Ш.; 1.8.03

Версия wincc 5.1.

Модет есть какие-либо патчи для wincc для XP?
Re: Help!!! WinXP+WinCC
Юрченко Владимир; 1.8.03

Патчи вообще то делают чтобы поправить то, что уже установлено. Лучше разыщите английский Win2000 SP2 или NT4.0 SP6a.

Re: Help!!! WinXP+WinCC
Чистяков Дмитрий ОАО СеверСталь; 1.8.03

WinCC 5.1 под XP запустить можно, но работать нормально всё равно не будет!

Ставьте W2k и всё будет ОК! :-)


text

Помогите с ОР37
Спажев Николай; 30.7.03

Уважаемые коллеги.

(Особенно обладатели ОР37)
В ператорской панели ОР37 оказались запорчены файлы операционной системы OP37 Windows 95 (autoexec.bat, Msdos.sys, Config.sys, Msdos.dos).
Может кто-то обладает их копией?

См. http://Спажев Николай


text

Update OS в ОР37
Спажев Николай; 30.7.03

Существует ли процедура восстановления

(обновления)OS в операторской панели ОР37.
На сайте SIEMENS я нашел описание как выполнить Update OS в более новых панелях с помощью
ProSave V6.0. Об ОР37 - ничего.

См. http://Спажев Николай


text

Тренды онлайновые
Дроздов Д.Е.; 24.7.03

Попал в забавную ситуацию - контроллер типа S5 не заморачиваясь с числами с плавающей запятой выдает их в виде целого числа. А вот в трендах они должны отображаться уже в виде числа с запятой, те, например, поделенные на 10. Что делать? Писать на шкале что-то типа *0,1 т. не интересно.

Короче, в тренде нужны числа с запятой, полученные путем деления целых пришедших с контроллера.

Re: Тренды онлайновые(конверсия)
Дроздов Д.Е.; 24.7.03

Re: Тренды онлайновые
Лев Шерешевский; 27.7.03

А почему Вы не хотите использовать Linear Scaling (закладка General свойства тега)?

Re: Тренды онлайновые
Дроздов Д.Е.; 29.7.03

Дробная часть теряется при этом. Решение уже нашел - функция должна возвращать исключительно тип double.


text

TLGGetArchivDataEx
Yrok; 28.7.03

Кто ни будь работал с этой функцией?

Re: TLGGetArchivDataEx
Alexis; 28.7.03

А что интересует? В ОДК описание есть...

Re: TLGGetArchivDataEx
Yrok; 29.7.03

Да мне бы примерчик рабочий а то в ODK пример с этой функцией матерится кошмар. Там ещё куча всякого барахла, а мне только нужно что бы при SQL запросе к базе данных буфер скидывался в базу данных.

Re: TLGGetArchivDataEx
Alexis; 29.7.03

Ну вот простой кусочек (работает под WinCC 5.1)

CMN_ERROR wccError;
if ( TLGConnect(NULL,&wccError) )
{
TLG_ARCHIVDATARAW *pTlgDataRaw=NULL;
DWORD dwNumberOfDataRaw=10000;
if ( TLGGetArchivDataEx(szArchiveName,szVariableName,&stStart,&stTo,&pTlgDataRaw,&dwNumberOfDataRaw,NULL,&wccError) )
{
//что хотим то и творим :)
}
if ( pTlgDataRaw ) TLGFreeMemory(pTlgDataRaw);
TLGDisconnect(&wccError);
}

ну и естественно проверяем dwNumberOfDataRaw на 10000...


text

Печать отчетов
Антон Глухов; 24.7.03

Здравствуйте.

Кто-нибудь сталкивался с такой проблемой...?
Необходимо организовать автоматическую печать отчета каждые 6 часов. В настройках печати отчета можно указать время начала печати, а далее выбратьт из списка цикл (каждый час, день, месяц и т.д.). А вот множителя, как это было для Tag Logging нет. Каким же образом я могу напечатаь отчет каждые 6 часов...?

Re: Печать отчетов
Лев Шерешевский; 27.7.03

Можно завести action и использовать в нем функцию RPTJobPrint. При этом в trigger для action надо указать пользовательский цикл, который настраивается произвольно.


text

WinCC v.6 и SQL server
Владимир; 25.7.03

Я установил Microsoft SQL server 2000 + SP3 к нему под Win2000 Pro,а WinCC v6 все равно выдает сообщение при установке, что SQL сервер не найден.Подскажите в чем может быть дело ? Остальные условия для установки соблюдены.

Re: WinCC v.6 и SQL server
Владимир; 26.7.03

ух.. сам разобрался


text

Event "On change" в ПроТул
Eugen Sergeev; 26.7.03

Когда наступает ивент "On change" применительно к тэгу float в ProTool?

Прибавлял к нему 0.01, прибавлял, а оно все не наступает и не наступает...


text

формат переменных TIME в панели ОР
Таранов ; 14.7.03

Делаю панель в ProTool переменная типа TIME в панель оператора вытащил только объявив ее как DWORD уже в ProTool'е , и то отображается все в милисекундах, пересчитывать пришлось, почему так, объясните. Еще, как импертировать теги из проекта в протул, а то муторно их по новой делать. Спасибо.

Re: формат переменных TIME в панели ОР
Bkmz; 25.7.03

Андрюха! Ты уже года 3 с контроллерами возишься, а документацию читать так и не научился. Посмотри доки - там черным по белому (или по-нерусски по белому) сказано, что TIME - это в МИЛИСЕКУНДАХ!!! Кстати, тебе предлагали обучение - вы отказались...

Re: формат переменных TIME в панели ОР
А! Илья,привет. я в блиссе 100 лет уже не работаю. я в москве теперь в ТАС; 25.7.03

subj


text

PCS7 Лишние тэги при трансфере PLS-OS
Ф. Неверов; 24.7.03

Дело в следующем. Берем из библиотеки PCS7 стандартный блок

(например VALVE ) вставляем в свой проект STEP7, создаем для него
экземплярные(инстансные) блоки данных, указывам что эти блоки подлежат
операторскому контролю и наблюдению S7_m_c= true и выполняем трансфер
PLS-OS. В WinCC наблюдаем все тэги которые мы заказывали назначая
свойство S7_m_c= true параметрам блока (для стандартных (из
библиотеки PCS7) это уже сделано Сименсом) и дополнительно 3 СТАННЫХ тэга
EventState, EventRaw#1, EventTrans#1
все они смотрят на одно и тоже место (в смысле адрес ) DB73.DD0
все они являются внешними, т.е. за них деньги плачены
кто будет оплачивать банкет?
Re: PCS7 Лишние тэги при трансфере PLS-OS
Михайлин Сергей; 24.7.03

Это очень нужные и полезные теги для комплексного переноса сообщений от блока. Удалять их настоятельно не рекомендую. Их нужность Вы оцените при отображении состояния контура с помощью group display в WinCC. Вообще, в PCS7 нет лишних тегов, а вопрос про оплату банкета не очень существенен, исходя из того что станция PCS7 всегда комплектуется лицензией от 64к и "лишние" три тега не помеха.

Re: PCS7 Лишние тэги при трансфере PLS-OS
Ф. Неверов; 24.7.03

Кроме счастливых обладателей станций PCS7 c 64К есть еще и простые

люди с Basic Process Control и WinCC c гораздо меньшим количеством
тегов вольно или невольно приходиться экономить. Поэтому и хотелось
узнать для чего нужны эти тэги и как они работают если, они указывают
на область DB уже занятую другими тэгами. Если долго объяснять
отошлите к литературе. Как то не вериться что на данном форуме нет
специалиста который бы досконально не знал бы суть этого вопроса.
Кстати удалить их невозможно. Нельзя даже отредактировать, а очень бы
хотелось потрогать свойство substitute value. В проекте Step их вообще
не видно. Как то страшно пользоваться вещами которые не можешь
настроить.

Re: PCS7 Лишние тэги при трансфере PLS-OS
Михайлин Сергей; 25.7.03

Ну звиняйте, где-то находишь, а где-то теряешь. Раз используются библиотеки PCS7, то надо уже мерять рамками PCS7.

Все эти вещи не надо трогать, настраивать и редактировать. Поверьте мне. Этим и отличается PCS7 от простой связки S7+WinCC.
Насчет объяснения: раз используете блок из PCS7, то наверняка и faceplate к нему тоже и Picture Tree Manager. В левом верхнем углу faceplate или напротив каждой кноgки в Overview стоит 4-ех сегментный индикатор комплексного отображения сообщений Group Dispaly. Он находиться в палитре объектор Graphik Designer. Именно с ним и связывается тэг EventState. Его распиновка описана в руководстве по "известному Вам" Basic Process Control. Остальные два связаны с пакетной передачей информации этих сообщений от данного контура. Более конкретные вопромы прошу в мыло.


text

Global Script заточен под Pentium III ?!
Шестаков Александр; 24.7.03

Ребята такая вот ситуация имеет место быть. Имеются две машины:

1. Pentium III 700Мгц, SDRAM 256Мб, материнка Abit на чипсете 440BX, частота системной шины естественно 100МГц,видео Riva TNT2 Pro 32Мб.

2. Pentium 4 1,7ГГц, DDR 384Мб, материнка Intel на чипсете 845GE.. (далее не помню), частота системной шины 400 МГц, память работает на частоте 266МГц, видео Matrox G450 32Мб.

На обох компьютерах стоит Windows 2000 Professional Ru + SP3. Далее WinCC 5.1

Итак, собственно суть: Запускаю один и тотже проект на этих машинах, открываю Диспетчер задач Windows, для наблюдения за загрузкой процессора и что я вижу...

ОКАЗЫВАЕТСЯ ЧТО НА ПЕРВОЙ МАШИНЕ ЗАГРУЗКА ПРОЦЕССОРА МЕНЬШЕ ЧЕМ НА ВТОРОЙ.

При это основной вклад вносят такие процессы как script.exe - как я понимаю который собственно и выполняет все скрипты написанные на ANSI С, а также pdlrt.exe - крутит графику.

При это по очень простой формуле можно
ориентировочно вычислить, что на первой машине ПРОЕКТ ЗАГРУЖАЕТ ПРОЦЕССОР НА 40% МЕНЬШЕ !!! (в моем случае).

КАК ЭТО МОЖЕТ БЫТЬ? Кто-нибуть может мне ответить.


text

Ошибка ActiveX в WinCC
Lidiya; 23.7.03

Добрый день!

В WinCC используется ActiveX, написанный на Delphi. После некоторого времени нормальной работы, WinCC перестает видеть ActiveX. Почему такое может происходит?

Re: Ошибка ActiveX в WinCC
Yrok; 24.7.03

Вообще то WinCC не очень дружит с ActiveX. Смотри исходник компонента где то глюк.


text

Низкая скорость обмена данными м/у WinCC и S7-300
Lidiya; 18.7.03

Добрый день!

Есть WinCC 5.1 и S7-315-2DP. Обмен по Profibus DP. Скорость - 12 м/бит.
Рабочая станция: Win2000 Prof., P4 2.4GHz, 512Mb RAM. Время цикла обработки программы в контроллере - 24мс.
При этом скорость чтении/записи внешних тегов в скриптах очень низкая, чтение 1 тега примерно за 5 сек.
Подскажите, пожалуйста, с чем это может быть связано? Буду признательна за любую информацию.
Re: Низкая скорость обмена данными м/у WinCC и S7-300
Дмитрий; 21.7.03

Имеются ввиду скрипты в Global Action? Вероятно цикл вызова скриптов установлен в 5 сек.

Re: Низкая скорость обмена данными м/у WinCC и S7-300
Lidiya; 21.7.03

Нет, скрипт вызывается по кнопке: считываем значения тегов из контроллера и выводим в окно диагностики. При этом происходит сильное торможение, задержка около 5 сек.

Re: Низкая скорость обмена данными м/у WinCC и S7-300
Дмитрий; 21.7.03

Надо проанализировать скрипт.

Re: Низкая скорость обмена данными м/у WinCC и S7-300
Lidiya; 21.7.03

Например, скрипт обнуления переменных:

char temp1[50];
int i=1;

for ( i=1; i<9; i++ )
{
sprintf(temp1,"W1To_%d",i);
SetTagBitWait(temp1,0);
printf("%s=%d\r\n",temp1,
GetTagBitWait(temp1));
}

Re: Низкая скорость обмена данными м/у WinCC и S7-300
Дмитрий; 21.7.03

Попробуйте тоже но без Wait.

Re: Низкая скорость обмена данными м/у WinCC и S7-300
Дмитрий; 22.7.03

Помогло?

Re: Низкая скорость обмена данными м/у WinCC и S7-300
Lidiya; 22.7.03

Нет, я думаю, дело не в функции, а в каких-то настройках.

Re: Низкая скорость обмена данными м/у WinCC и S7-300
Юрий Оганесян; 23.7.03

Дмитрий прав, не надо использовать *Wait, т.к. при этом выполнение команды идет после отработки всех S7-функций и в ТОМ же потоке, что и WinCC.

А иначе - в отдельном потоке и с частотой обновления в 2 раза быстрее чем задал программер.
Про принципы обновления тэгов примененные в WinCC можно прочитать в Help'e, сделав поиск по GetTagXXX.
А у приведенного тобою скрипта КАЧЕСТВЕННО лучшего быстродействия не добиться.

Re: Низкая скорость обмена данными м/у WinCC и S7-300
Чистяков Дмитрий ОАО СеверСталь; 23.7.03

Для обнуления какого либо участка памяти в контроллере лучше всего использовать соответствующий блок SFC 21. А из WinCC достаточно лишь выдать на его входы параметры и дать команду на выполнение. Данные будут обнулены за один скан контроллера.


text

Где взять WinCC Web Navigator
Хоружевский Роман; 23.7.03

Где взять WinCC Web Navigator, хочу покрутить его в демо режиме, где нибудь на сайте есть, или нужно брать у представителей в регионе?

Re: Где взять WinCC Web Navigator
Чистяков Дмитрий ОАО СеверСталь; 23.7.03

Именно у представителей. Так будет проще. :-)


text

PCS7 FaceplateDesigner поврежден @FPD_BedBinär.PDL
Ф.Неверов; 14.7.03

GraphicsDesigner при открытии этого файла ругается <<Failed open document>>

А сам файл нужен чтобы заработали примеры из GetStarted с диска PCS 7 ToolsetV5.2
Если кто в курсе помогите плизззз.

Ф.Неверов
kvi999@rambler.ru
Re: PCS7 FaceplateDesigner поврежден @FPD_BedBinär.PDL
Михайлин Сергей; 22.7.03

Скорее всего ругается на имя файла с умляутом. Попробуйте переименовать его просто на *BedBinar.

Re: PCS7 FaceplateDesigner поврежден @FPD_BedBinär.PDL
Ф.Неверов; 23.7.03

Благодарю. Это действительно так. Амляут я со слепу не разглядел. Но зачем же немцы туда его заложили.

В качестве учебных граблей что ли.


text

OCP Client на Delphi
Алексей Светличный; 14.7.03

Здравствуйте!

Кто-нибудь писал OCP Client'а на
Delphi? Использую для соединения с сервером ActiveX-компонент TDatCon (SIMATEC NET OPC Data (Version 1.0)) но метод WriteVariable вылетает с сообщением "Несовпадение типов".
Где лыжи смазать?

Re: OCP Client на Delphi
Юрченко Владимир; 15.7.03

На Delphi клиента писал, но не с помощью дополнительных ActiveX компонент. Примеры клиента на Delphi можно найти на http://www.opcconnect.com/delphi.php

Но в принципе ошибки понятные - есть типы запрашивамых данных по OPC (подробности смотрите на opcfoundation.org) и типы данных сервера. Поразбирайтесь в документации по типам сервера и вашего ActiveX. А можно скачать с вышеупомянутого сайта готовые компоненты OPC для Delphi, почитать внимательно help и вперед ...
Re: OCP Client на Delphi
Сергей, Акватехнолгия; 15.7.03

Вопрос в догонку.

Вопрос по security:
Если клиент конектится с удаленной машины возникает проблема с доступом.
Т.е. если машины под одним user-ом то все в норме.
А если разные, то выдает ошибку 'нет доступа'
Причем собственно коннект к серверу удается произвести с явным указанием user-a и passworda (cocreateinstanceEx), а вот дальше при создании группы говорит:"отвали"
Неподскажите как с этим бороться?

Заранее спасибо ...

Re: OCP Client на Delphi
Алексей Светличный; 16.7.03

Дело в том что OPC-сервер по сути является DCOM-сервером, со всеми его особенностями. Поэтому вам надо сконфигурировать его с помощью утилиты dcomcnfg.exe. Она находится в папке $(Windows)\system32. Для своего сервера необходимо настраивать парметры безопасности. Используйте пользовательские разрешения доступа и определите кто может иметь доступ к серверу.

Re: OCP Client на Delphi
Сергей, Акватехнолгия; 18.7.03

А если сервером выступает WinCC, его тоже можно сконфигурить? Или как быть то?

Re: OCP Client на Delphi
Алексей Светличный; 21.7.03

Да, конечно. Как правило он называетя OPCServer.WinCC. Выбираешь его в списке приложений и конфигурируешь.


text

Проблема Клиент-Сервер
miha-CC; 16.7.03

Делаю одну машину как сервер, вторую подключаю как клиента по сети.Проект работает и запускается на обеих машинах.Но на клиенте возникает проблема с отображением текстовых полей.Вместо надписей вопросы,хотя запускаю на клиенте тот же проект с сервера из тойже папки.Даже пробую отдельно открыть графическую картинку на клиенте эфект тотже.На сервере открываю ее,все тексты на месте.Я не пойму в чем дело,обращаюсь же к одному и томуже файлу, только с разных мест.Проясните ситуацию пожалуйсто кто сможет.

Re: Проблема Клиент-Сервер
Alexis; 16.7.03

На вскидку: глянь как языки сконфигурены для компов проекта, похоже у тебя они разные.

Re: Проблема Клиент-Сервер
miha-CC; 17.7.03

Дело в том, что когда я с клиентской машины открываю редактор проекта и захожу в свойства текстового поля или поля ввода\вывода, то там вместо текста вопросы и если я их исправляю на нужный мне текст то в последствии он проявляется в real-time нормально.

Если все тексты исправлять то все будет нормально, но таких текстов в проекте гиганское количество.Все равно я языки проверил,все идентично.Может что-то еще?
Re: Проблема Клиент-Сервер
Goodvin; 17.7.03

Из вопроса не понятно, в текстовых полях русские буквы или нет, если буквы русские, то, как вариант измени шрифт в полях на тот же только с дополнением CYR, (Arial --> Arial CYR).

Иногда помогает.

Re: Проблема Клиент-Сервер
miha-CC; 18.7.03

Букв вообще никаких нет.Есть вопросы.Ситуация такая, как будто толоько ставишь текстовое поле в графическом редакторе,сначало без текста то в реал-тайме WinCC ставит туда знаки вопроса.Я в курсе того,что если нет Русских фонтов, то будет всякая абра-кадабра.Но тут ситуация такая что WinCC не видит сами надписи на серверной машине и ставит вместо них вопросы.Но если внести надписи по новой то они нормально появляются.

Re: Проблема Клиент-Сервер
miha-CC; 21.7.03

Alexis спасибо Вам большое.Действительно языки не были сконфигурированы.Весьма благодарен за помощь, все надписи проявились.


text

Ограничение движения экранов на OP
Поздняков Андрей; 16.7.03

Hello!

Кстати ещё такой момент. Каким образом можно ограничить переключение (сдвиг) экранов в панеле при нажатии на клавишу Down (вниз). А то когда закангчиваются экраны с текстом дальше идут просто пустые экраны.

С уважением.


text

Два сервера и один TI505 через Сом порт
Yrok; 16.7.03

Подскажите плиз! У меня два сервера с Установленным WinCC (используемый канал для связи SIMATIC TI SERIAL) и имеется один контроллер TI505, на Ком портах одного и второго сервера стаят преобразователи RS232-RS485. После чего оба преобразователя включены паралельно по линии RS485 и подключены к контроллеру. оба сервера настроены на резервирование. Вопрос? не будет ли конфликта при запросах к к контроллеру, так как запрос одного из серверов будет поподать через преоброзователь интерфейсов на ком порт другого сервера.


text

Global Action
Антон Глухов; 14.7.03

К Global Action, как триггер можно пределать событие изменения значения тега. Причем для одного триггера может быть несколько тегов по изменению которых сапустится Action. А кто-нибудь знает, как определить от какого тега сработал Action?

Re: Global Action
Дмитрий; 15.7.03

Есть окно диагностики Global Action в RT, напишите в Action вывод информации в это окно и наблюдайте какой тег вызвал выполение.

Re: Global Action
Антон Глухов; 15.7.03

Дело в том, что мне нужно не просто наблюдать, а сам action должен знать, какой тег вызвал его срабатывание...

Re: Global Action
Василенко; 15.7.03

А если сделать по Action на каждый из тегов. И каждый использует функцию,которая все делает как раньше,но получив в виде параметра имя тега.

Re: Global Action
Антон Глухов; 15.7.03

Это понятно... Но у меня следить на данный момент надо за 100 тегами... Не очень хочется делать 100 action`ов :)))

Гораздо более изящным способом было бы просто поймать имя тега. Но я что-то не могу найти таких функций...


text

Обмен через нетипизированные тэги с помощью BSEND/BRCV
Дмитрий Картинник; 14.7.03

Подскажите, может кто сталкивался и просто знает, где можно найти детальное описание структур телеграмм для обмена данными через RawData Tag с помощью Bsend/Brcv с UserArchive (WinCC 5.1)?

С помощью найденой информации в Configuration Manual как то глючено работате: не считывает полность запись из архива....(только первых 2 поля)?


text

Как уменьшить размер базы?
Игорь; 17.6.03

Стоит WinCC V5.0 SP2 ну и соответственно Adaptive Server Anywhere 7.0 . Со временем данные добавляются удаляются а размер базы только увеличивается. Может кто знает как её можно уменьшить?

Re: Как уменьшить размер базы?
Yrok; 23.6.03

У нас был такой глюк. Удаляя таблицу в TagLoging реально она остаётся в базе, хотя перестаёт быть видимой в TagLoging. Решение одно: удалять SQL запросом из своей проги.

Re: Как уменьшить размер базы?
Олег; 4.7.03

А поподробнее про свою прогу.

И еще, в v5.1+SP3 этот глюк исправлен или нет?
Re: Как уменьшить размер базы?
Юрий Оганесян; 9.7.03

Фишка тут есть еще и такая, что даже если удалить таблицу из базы, используя централь Sybase (scview.exe), то размер файла от этого тоже не уменьшается - приходится делать полный reload/upload. Понятно, что делаем это сравнительно редко - раз в год-два во время ремонтов и т.д.

Re: Как уменьшить размер базы?
Yrok; 11.7.03

Подробнее про прогу: Используя язык прогроммирования С++ подсоединяюсь к источнику данных WinCC с помощью SQL запроса удаляю таблицу и всё. Хотя можно использовать любой другой язык программирования Delphi, Visual Basic и т.д. Если хочешь вышлю свой пример на мыло.


text

Крах системы (WinCC)
Евгений; 1.7.03

Здравствуйте, коллеги.

Столкнулся с такой проблемой:
На чистый винт ставлю Windows 2000 английский + сервис пак 2. Устанавливаю WinCC v.5.1. Работаю.
При активации пректа, созданного на другой машине, при загрузке Data Manager Runtime появляется синий экран смерти с сообщением об ошибке в ntoskrnl.exe. Что делать? Слышал, что у продуктов Сименса бывают проблемы со встроенными сетевыми картами. Так ли это?
Заранее благодарен за помощь.
Re: Крах системы (WinCC)
siemargl; 2.7.03

а я слышал, у некоторых специалистов Сименса проблемы с руками

Re: Крах системы (WinCC)
beginner; 3.7.03

Было такое и другие глюки.

а HotFix' ы ставили ?

Помоему WinCC 5.1 все же лучше ставить
на Windows NT 4.0 SP6.
глюков и тормозов меньше....

Re: Крах системы (WinCC)
Евгений; 4.7.03

Хотфиксы ставил. И 5.1 заявлен для работы с Win2k+sp2. На другой машине все работало отлично. Вопрос не в этом. Хотелось бы знать, использует ли WinCC какие-либо ресурсы или IRQ для своей работы. Вопрос о совместимости с ЖЕЛЕЗОМ.

Re: Крах системы (WinCC)
Хоружевский Роман; 7.7.03

Попробуй еще раз переустановить систему, бывает софт "встает" криво, у меня было что-то похожее, правда не было синего экрана, но WinCC работать отказывалась, систему переустанавливал 2 раза, потом все заработало и по сей день без глюков, вот такая вот беда.

Re: Крах системы (WinCC)
Александр Родин, ООО "Нева Электрик"; 7.7.03

А какая карточка для связи используется ? У меня были подобные проблемы при работе с картой CP5611 на PROFIBUS.


text

Переход с WinCC 5.0 на 5.1
Олег; 30.6.03

Есть необходимость перехода с версии 5.0 на 5.1. В проекте использован компонент User Archive. В версии 5.1 используются другие базы данных, чем в 5.0, так что не знаю есть ли тут какие нибудь подводные камни. Кто нибудь имел подобный опыт?

Re: Переход с WinCC 5.0 на 5.1
Олег; 4.7.03

Че, никто не имел?

Re: Переход с WinCC 5.0 на 5.1
Василенко; 4.7.03

Перешли незаметно. Не помню никаких сильных неприятностей.


text

Летнее время в сообщениях
Олег; 27.6.03

Ситуация следующая:

Передаю из контроллера в WinCC сообщения, имеющие четкий хронологический порядок. Сообщения передаются с меткой времени контроллера. Контроллер синхронизирован по времени с компом, на котором стоит WinCC.
Все бы было замечательно, но сообщение, сгенерированное контроллером, скажем в 8:00 видно в WinCC как произошедшее в 9:00.
Сейчас лето. Если перевожу часы и в PC и в контроллере, скажем, на январь, то все становится ОК.
Какую галочку надо убирать(поставить) чтобы летом, тоже было OK?

Re: Летнее время в сообщениях
APS; 30.6.03

Насколько я знаю, в контроллере идет время без учета летнее-зимнее. WinCC сама по настройкам операционнки добавляет или не добавляет час ко времени контроллера. В 2000 это во времени галочка автоматический переход на летннее-зимнее время. Мы обычно синхронизируем операторскую станцию по времени контроллера. И проблем нет совсем. А если наоборот, то в один прекрасный миг время в контроллере перескочит на час, что не есть хорошо. А для установки времени в контроллере написана маленькая приблудка, и оператор при желании может установить время в контроллере.

Re: Летнее время в сообщениях
Олег; 4.7.03

А чем плох перескок времени в контроллере?


text

драйвер modbus protocol suite
Виктор; 27.6.03

Для связи WinCC и Modicon по modbus+ установил драйвер modbus protocol suite.

Дискретные сигналы читает , а аналоговые нет.
В чем может быть причина?

Re: драйвер modbus protocol suite
Shade; 30.6.03

В порядке бреда:

Не знаю как из Modicon, но из Simaticа WinCC напрямую с модулей, тоже только дискретные вх\вых читает, а аналоговые только через буфер в виде DB.
Re: драйвер modbus protocol suite
Виктор; 3.7.03

Можно поподробней как задействовать этот буфер?

Re: драйвер modbus protocol suite
Shade; 3.7.03

Я имел ввиду, в контроллере данные "перетащить" со входов в блок данных или в слово "маркеров" (внутренних переменных), а уже оттуда читать из WinCC.

Re: драйвер modbus protocol suite
Виктор; 4.7.03

Данные начали читаться.

Но я не могу их правильно преобразовать.
В модиконе преобразую
0_100 в -32768 _ 32767 (signet 16 bit)
Какой Adapt format надо применить в
WinCC чтобы получить 0_100

Re: драйвер modbus protocol suite
Shade; 4.7.03

Предлагаю в Модиконе перетаскивать "один в один", а преобразовывать с помощью WinCC, главное чтобы был выбран правильный размер - насколько я понял это 16 бит=слово (Word). А Adapt format скорее всего word-to-float. А там уже методом "тыка", с использованием линеризации, задаете верх-низ шкалы входной величины, и верх-низ шкалы уже вашего выходного(отображаемого) параметра.


text

Печать отчета & OP7
Алексей; 3.7.03

В наличии: CPU <-> OP7 -> Принтер

В процессе работы в DB копятся данные, каким образом их передать на принтер в оформленном виде???
Помогите, плиз...

Re: Печать отчета & OP7
kot; 3.7.03

С принтером вяжется сама ОР7. Как сконфигурить не помню но как-то через системное меню. Либо какой-нибудь СР

и принтер работающий через СОМ-порт.
Re: Печать отчета & OP7
Юрченко Владимир; 3.7.03

Почитайте пожалуйста документацию на русском языке на http://www.aud.ru/as/products/doc.php?l1=SIMATIC%20HMI&l2=Панели&l3=doc

Распечатать можно как экраны так и сообщения. Для оформления в ProTool используйте Headers/Footers.


text

драйвер modbus protocol suite
Виктор; 1.7.03

Для связи WinCC и Modicon по modbus+ установил драйвер modbus protocol suite.

Дискретные сигналы читает , а аналоговые нет.
В чем может быть причина?


text

ProTool6.0 + Win98 + кирилица
Сергей Архипов; 1.7.03

Господа! Может кто-нибудь сталкивался с такой проблемой.

Имеется проект, созданный в ProTool 6.0, но в английской раскладке по-русски (такая вот кривизна).
Под W2K и WinNT вся кириллическая информация отображается корректно, а вот при переносе под Win98 начинаются кряки.
Правка в реестре Win98 кодовых страниц на CP_1251 (по аналогии с W2K и WinNT) не помогает.
Есть ли еще способы победить данное зло без применения полного переделывания проекта под русскую раскладку.
Заранее благодарен за помощь.


text

Экспорт - импорт Тэгов
Serg; 30.6.03

1. Как портировать переменные из Step7 в Wincc без PCS7?

2. Как портировать настройки тэгов из одного проекта Wincc в другой?
Re: Экспорт - импорт Тэгов
Василенко; 1.7.03

1

Сделать Export для Symbol Table.
Немного поправить.
При помощи Tools/Variable ImportExport импортировать.

2
При помощи Tools/Variable ImportExport экспортировать а потом импортировать

Можно вписать проект WinCC в проект Step 7 и тогда все теги Step будут родными в WinCC


text

ОР3
Андрей; 27.5.03

Можно найти на ОР3 русскую документацию

Re: ОР3
Павел Иванов (Сименс-Москва); 1.7.03

Руководство по ОР3 на русвский язык не переводилось, т.к. данную панель используют в России редко.


text

Отличия Wincc 5.1, работа с MScomm
Григорий; 30.6.03

1. Поставил WIncc 5.1 с демонстрационного диска (который 2003г вместе с Protool). Он замечательно работает с Plcsim 5.0. После этого ставил WINCC 5.1 c Поставочног диска (получено на днях). Эта установка с PLCSIM работать не желает, но если поставить с демо-диска после сноса этой версии, то все становится нормально.

В чем отличия этих версий, либо в задании параметров? Обе версии(установки) настраивались для работы по MPI.
2. Кто встаивал MSCOMM от Visual Basic, хотелось бы знать как это делалось? В форуме уже было сообщение, что Active-X от Visual Basic встают под WInCC отлично.

Re: Отличия Wincc 5.1, работа с MScomm
Хоружевский Роман; 1.7.03


text

Затормозить пуск ОР27
Eugene Sergeev; 30.6.03

Есть такая проблема - при пуске на панель питание подается одновременно с контроллером (S7-315 DP). Пока контроллер там разбирается с тем, что у него висит на Профибасе, панель успевает загрузиться и радостно вещает о том, что "Контроллер в СТОП моде". Операторы нервничают и лезут в шкаф.

Как затормозить пуск панели? Не реле времени ведь, в самом деле, ставить?
Re: Затормозить пуск ОР27
Baby; 30.6.03

Привет !!!!

А бесперебойник не решит проблему ????
Re: Затормозить пуск ОР27
Eugene Sergeev; 30.6.03

Не думаю, бо там бывают длительные перерывы в работе, когда они обестачивают весь цех. Как вариант - включать 24В на панель релюхой с выхода контроллера, но это съест один выход - не есть хорошо. Реле времени проще как-то... Но, ИМХО, должен быть какой-то финт ушами...


text

коллизия времепи архив-ия
miha-CC; 30.6.03

WinCC V4.00

Многоуважаемые Господа. Помогите разобраться. Наблюдается некоторая коллизия в архивации тегов.Например ставлю время регестрирования тега 10мин., а время архивирования 10*3, т.е. 30мин. Все едет нормально до определенного момента.Архивирует раз в полчаса, а спустя некоторое время может съархивировать на 1мин.раньше или позже.В последний ра вообще на 10мин.раньше положенного съархивировала.С чем это связано? За ранее благодарен.


text

Пуск\Стоп архивов
miha-CC; 3.6.03

WinCC 4.00. Только начал разбираться.

Помогите пожалуйсто разобраться с запуском архивов по событию.Например
начать архивировать когда тег процесса ровняется определенному числу.Не могу понять как это делать с помощью глобальных сценариев.Синтаксис не понятен, да и в С++ я не очень силен.
Re: Пуск\Стоп архивов
Василенко; 4.6.03

Можно в Tag Logging нажав правой мышкой на архивируемом теге вывести Properties of process tag.Выбрать тип архивирования Cyclic-selective на закладке Archive Tag. Выбрать закладку Events в которой задать Start Event и Stop Event. Написать два скрипта в проекте один для старта и один для стопа архивирования.

Например начать если Tag>100
и кончить если <50
Скрипт начала:
return (GetTagWord("Tag")>100);
Скрипт конца:
return (GetTagWord("Tag")<50);

Re: Пуск\Стоп архивов
miha-CC; 5.6.03

Огромное спасибо, я еще не пробывал но мне кажется теперь что все очень просто.

Re: Пуск\Стоп архивов
miha-CC; 9.6.03

Re: Пуск\Стоп архивов
Василенко; 9.6.03

В папке Project Functions например.

Re: Пуск\Стоп архивов
miha-cc; 11.6.03

Все здаюсь.Пробывал так и этак, не получается.Как должен этот скрипт выглядеть полностью.Мне бы один раз увидеть чем много раз слышать.

Re: Пуск\Стоп архивов
Василенко; 11.6.03

Наверно что-то не так. Давай по шагам:

1.В Global Script в разделе Project functions создаешь новую функцию например-
BOOL StartArch()
{
return (GetTagWord("Tag")>100);
}
Нажми кнопку Compile, Generate Heading и сохрани.
2.В Tag Logging в нужном архиве смотришь св-ва нужного тега.
-На 1-ой закладке Archive Tag выбираешь в окошке acquisition type значение Cyclic-selective.
-На 4-ой закладке Events в окне Start Event жмешь Select... и в разделе Project Function выбираешь созданный скрипт. Можно руками задать имя скрипта не выбирая.

Если не получилось-переставляй WinCC.
Re: Пуск\Стоп архивов
miha-CC; 13.6.03

Огромное спасибо за помощь! Все получилось.Вот что значит недостаток знаний С++.Дело то было в синтаксисе написания функции.

Re: Пуск\Стоп архивов
Прокопенко Вера; 13.6.03

На архивирование по событию, если оно сконфигурировано в TagLogging через Evevt start / Even stop есть ограничения: не рекомендуется более чем для 10 тегов. Если отследить работу этих событийных функций, то видно, что они запускаются несколько раз в секунду для каждого тега, что нагружает систему. Лучше использовать разрешение и запрет на запись всего архива (если это возможно по условиям работы проекта) с использованием ODK функции TLGLockArchiv(...).

Re: Пуск\Стоп архивов
miha-CC; 17.6.03

Я недавно только с WinCC разобрался, а тут еще ODK.Что это и как с этим работать? Заранее примного благодарен за краткую информацию.

Re: Пуск\Стоп архивов
Прокопенко Вера; 23.6.03

Чтобы запустить и остановить запись конкоретного архива можно использовать следующий скрипт:

#pragma code("kernel32.dll");
void GetLocalTime(SYSTEMTIME* lpst);
#pragma code ();

SYSTEMTIME time;
CMN_ERROR pError;
TLG_ARCHIVDATARAW pTlgData;
DWORD dwNumberOfData=1;
DWORD dwFlags=0; //0 -останов, 1 -пуск архива

char *szArchivName="arch_sec"; //имя архива

GetLocalTime(&time);
pTlgData.dwFlags=0;
pTlgData.stTime=time;

TLGConnect(NULL,NULL);
TLGLockArchiv (NULL,szArchivName,dwFlags, &pError );
TLGDisconnect(NULL);

скрипт можно привязать на изменение тега
Re: Пуск\Стоп архивов
miha-CC; 27.6.03

Огромное спасибо тебе Прокопенко Вера.


text

Скачать из OP17 без системного меню
ADA; 25.6.03

Есть старый механизм с панелью ОП17. Символы на нем отображаеются не в той кодировке: немецкий русскими буквами. Никак не добраться до системного меню панели (кажется на него нет переходов).

Вопрос: как можно скачать из панели программу для редактирования.

Re: Скачать из OP17 без системного меню
Александр,СКТЦ; 26.6.03

Для редактирования никак (даже если бы была возможность перехода в системное меню). Выкачать можно только бинарный файл для загрузки в другую панель.


text

Отображение пользователя WebNavigator
Максим Поджидаев; 26.6.03

Здравствуйте!

Как определить в проекте имя пользователя подключенного через WebNavigator, чтобы можно было отображать его на экране. Речь идёт о имени указываемом в WebAdministrator


text

WinCC Client и WinCC Server в разных доменах
Олег; 25.6.03

Проблема вот в чем: ВинЦЦ сервер и ВинЦЦ клиент находятся в одной подсети и общаются между собой по ТЦП/ИП без проблем. ВинЦЦ сервер входит в рабочую группу, а ВинЦЦ клиент входит в домен. Вот здесь и начинаются чудеса. Клиент не может связаться с сервером через ВинЦЦ Эксплорер, хотя по сети прекрасно его видит. Открывается база с помощью СЦВЬЮ и т.п., а проект активироваться не хочет, потому что он якобы закрыт на сервере. Хотелось бы узнать всёта-ки какие необходимы настройки, чтобы клиент открывал проект с сервера независимо от того в каком домене или рабочей группе они находятся. Да, кстати, когда сервер и клиент входят в одну рабочую группу проект сразу открывается и активизируется.

С уважением, Олег.
Re: WinCC Client и WinCC Server в разных доменах
Yrok; 25.6.03

Олег я эту тему уже задавал ПРОБЛЕММА КЛИЕНТ-СЕРВЕР но пока никто не ответил всё ещё жду.

Re: WinCC Client и WinCC Server в разных доменах
Максим Поджидаев; 26.6.03

Это особенности Windows. Сервер не пускает клиента потому что не может проверить его права.

Решения:
1) Лучший вариант. Все участники проекта переводятся в один домен. На обеих машинах проект запускается от имени одного и того-же пользователя.
2) Худший, некрасивый, вариант.Снижается уровень безопасности на сервере и клиенте .Разрешается и добавляется в группу "опытные пользователи" учетная запись "гость".


text

Проблема трансфера текстовых библиотек драйверных блоков
Бычков Андрей ; 26.6.03

При трансфере сообщений в WinCC текстовые библиотеки MOD_xx_TXT драйверных блоков не передаются, если в проекте STEP7 отсутствует язык немецкий (германия).

Можно ли избежать привязанности к немецкому языку?
Верс. STEP7 5.1+SP6 WinCC 5.1 hfx1


text

В чём разница проектов
Yrok; 25.6.03

Подскажите в чём разница проекта Сервер или Клиента. Имеется сервер, создаю проект сервер подключаю клиента. Вопрос? экран стартовый у проекта сервера другой ведь чем у клиента. Даже обзорная область другая.

Попатался во время загрузки для клиента подменять кадры, но через несколько минут работы машины виснут напрочь.
Пришлось сдалать стандартный проект, тогда всё нормально. Так вот чем они отличаются только ли кадрами или ещё чем нибудь.


text

WinCC и функциональные клавиши PC670(870)
Eugene; 11.6.03

Насколько я понимаю, специальные клавиши PC670(870) генерируют код сочетания клавиш. Например, нажатие S1 тождественно сочетанию SHIFT-F9.

В WinCC помещаю на экран кнопку, в качестве hotkey задаю SHIFT-F9 и запускаю рантайм. При нажатии кнопки мышкой, при нажатии сочетания SHIFT-F9 и при нажатии сочетания SHIFT-S1 действие выполняется, а вот при нажатии S1 - ничего.
То, что S1 и SHIFT-F9 генерируют одинаковый скан-код - факт неоспоримый (проверено программой KeyView от Siemens).

Так что я делаю неправильно?
Re: WinCC и функциональные клавиши PC670(870)
Виктор; 13.6.03

Извините за вопрос не по теме. Где можно скачать - KeyView от Siemens?

Re: WinCC и функциональные клавиши PC670(870)
Eugene; 13.6.03

Высылаю по мылу

Re: WinCC и функциональные клавиши PC670(870)
Сергей; 16.6.03

В windows помимо скан кода клавиши есть слово состояния нажатия специальных клавиш. Поэтому вам приходится нажимать shift+S1.

А не пробовали поставить код просто F9?

Крик отчаяния
Eugene; 25.6.03

Неужели никто не использовал WinCC на PC670(870), в частности кнопки Sx?

2Сергей: код F9 генерируется кнопкой F9, а не S1.
S1 по документации по умолчанию соответствует SHIFT-F9.


text

WinCC и CP342-5
Владимир; 4.6.03

Подскажите как настроить WinCC на связь с CPU315-2DP через CP342-5. Set PG interface видит все узлы в сети . А из WinCC не видно ?

Re: WinCC и CP342-5
Yrok; 24.6.03

Тебе нужно из WinCC подключатся через точку входа СP_L2_1 или CP_L2_2 в зависимости какая у тебя сетевая карта в компе. А в Set PG/PC выбрать СP_L2_1 или CP_L2_2 на MPI или ProfiBus.

Re: WinCC и CP342-5
Shade; 24.6.03

Re: WinCC и CP342-5
Владимир; 24.6.03

Дык я все так и делал . У меня дпже все работало , но через встроенный DP в CPU315-2DP . А тут сетку переделали и связь теперь через CP342-5 и нет связи

Re: WinCC и CP342-5
Shade; 24.6.03

Надеюсь соответствующие изменения в Network Communications Simatic Managerа были внесены, адресация и проч. ЦПУ понимает, что он теперь работает через 342-5, а не через встроенный DP? С ним все в порядке, он ровненько зеленым светом горит?

Если все в порядке - я пас.


text

Проблемма клиент-сервер
Yrok; 24.6.03

Задача: есть две рабочие группы

А и В клиентов WinCC (соотвественно используют разные шлюзы 10.1.24.1 и 10.1.5.1) Но WinCC сервер находится в группе "WinCC" со шлюзом 10.1.30.1
Как, не меняя условия отличия групп и шлюзов, обеспечить функциональность системы клиент-сервер.
1.У нас не запускаются клиенты.
2. машины пингуются так как все их адреса прописаны в маршрутизаторе (а вот WinCC их не видит)


text

S7 и ProTool
Порохов Андрей; 24.6.03

У меня S7 v 5.1 ProTool v 6 интегрированный в S7, контролер соединен с ОР27 по МРІ когда я изменю поект ProTool и сделаю download будет ли он загружатся в ОР27 и какие могут быть последствия

Re: S7 и ProTool
Редников Василий; 24.6.03

Если вы грузите проект первый раз, то загрузку необходимо проводить через COM порт. Далее, если вы при создании проекта выбрали галочку как стандартный проект, то Protool вам сгенерит стандартные экраны. В экране Z_SETTINGS есть возможность выбрать различные варианты загрузки панели, в том числе и по MPI.


text

10 сек в ProTool/Pro RT
Eugene Sergeev; 21.6.03

Как поучить интервал времени 10 сек.

в Протул РТ? Я имею в виду, есть какое-либо событие (на кнопку нажали)
и через 10 сек. нужно сделать еще что-то. Киньте пример скрипта, если можно.


text

4 OP на одном MPI
Eugene Sergeev; 14.6.03

Можно ли подключить 4 панели OP170 с одинаковыми программами на 1 MPI?

Re: 4 OP на одном MPI
Александр Родин, ООО "Нева Электрик"; 16.6.03

а почему бы и нет ?.. Дайте им различные адреса и вперед. Только еще на всякий случай пропишите их в сетевой конфигурации контроллера.

Re: 4 OP на одном MPI
Любитель Симатика; 16.6.03

Гы-гы. Повесить-то можно, только потянет ли один процессор всех их? Вот в чем вопрос...

Например 300-ых имеет ограниченное кол-во S7 соединений и 4 панели вряд ли потянет. Хотя, надо читать доку...
В вашем случае надо исходить из возможностей ЦПУ, а не из сетевых требований.
Re: 4 OP на одном MPI
LeXX; 18.6.03

Подключить можно. Будут работать. Но не указан тип ЦПУ и ОР170А или ОР 170В... Думайте сами...

Re: 4 OP на одном MPI
Eugene Sergeev; 18.6.03

CPU - 315DP2, OP - OP170B

И?

Re: 4 OP на одном MPI
LeXX; 21.6.03

Ну, типа, работать будут... Но. периодически, одна будет отваливаться (это если старый 315-2ДР). Если новый (с ММС) - все будет хорошо.

Re: 4 OP на одном MPI
Eugene Sergeev; 21.6.03

А в чем отваливание будет проявляться?


text

Как запустить скрипт при старте RT?
Каменков Алексей; 9.6.03

Возможно, вопрос глупый и ответ всем известен, но в форуме и в справке по WinCC я не нашел способа запустить функцию при старте проекта. Хотя, казалось бы, это ключевая возможность - ну в самом деле, не жать же оператору на кнопку Connect, чтобы подключиться к какому-либо удаленному оборудованию по TCP/IP. Все должно происходить автоматом. Но как? Подскажите пожалуйста!

Re: Как запустить скрипт при старте RT?
Шестаков Александр; 21.6.03

Можно это сделать различными способами например, по событию Open Picture на главном экране. Или написать функцию Global Action и привязать ее к тегу, который не будет никогда изменяться. При этом при запуске RT данная функция сработает один раз. Я думаю если подумать можно придумать еще что-нибудь. Если использовать ODK, то там есть событие, которое возникает если запускается RT.


text

SetTagBit
Yrok; 19.6.03

Как установить Tag из моей проги на С++

Re: SetTagBit
Василенко; 19.6.03

Вот отдельные операторы из моей проги:

VARIANT VarVal;
DWORD VarSta;
PCMN_ERROR pError=&err;
VarVal.vt = VT_BOOL;
VarVal.boolVal = bval // присваиваемое значение;

if (!DMConnect(AppName, NULL, &m_User, pError)) {

if (!DMGetRuntimeProject(szProject, (DWORD)sizeof(szProject), pError)) {

if(!DMGetProjectInformation(szProject, &Info, pError)) {

DMSetValue(pVarKey, 1, &VarVal, &VarSta, pError);
Могу намылить всю.

Re: SetTagBit
Yrok; 19.6.03

Огромное спасибо!


text

Group Display - Переход к ист-ку. аварии
Yrok; 17.6.03

Помогите,плиз! Не могу связать источник аварии с Group Display в области Overwiev. Например: на 5-м экране имеется источник аварии - аварийное значение велечины. Необходимо находясь на другом экране :

1. чтобы Group Display в области Overwiev начал индицировать вид аварии (warning, alarm)
2. чтобы по клику на индикаторе Group Display в области Overwiev осуществлялся переход к экрану содержащему изображение аварийной велечины (в данном случае к 5-му экрану)
Re: Group Display - Переход к ист-ку. аварии
Михайлин Сергей; 17.6.03

5 экран это вглубь или просто номер экрана? Сколько уровней вложения картинок?

Принцип такой: на вашем 5-ом экране должен быть обязательно Group Display привязанный к нужной структуре, т. е. он в первую очередь должен начать моргать при приходе сообщения.Затем, если 5 экран это вложенный, то на уровнях выше, тоже должны быть обязательно Group Display но привязанные к картинкам. Т. е. по простому, сообщения передаются только через Group Display от тэга к картинке, от картинки нижнего уровня к картинке верхнего уровня и так далее до Overview. Не забудь по окончанию сказать Save в Picture Tree Manager, иногда это нужно сделать для обновления связей. Переход реализуется автоматом. Если сообщений много, то переход производится на экран после которого происходит размножение сообщений. Подробнее надо читать доку по Basic Proccess Control для WinCC или PCS7.
Re: Group Display - Переход к ист-ку. аварии
Yrok; 17.6.03

Извините плиз! 5-й экран это просто картинка 2-го уровня вложения. можно ли по подробней описать

1.связь картинки с её Group Display в Tree Manager.
2. И далее связь, этого Group Display с Group Display на уровень выше.
В документации по Basic Proccess Control для WinCC всё туманно и размыто описано. Имеется даже Demo project DSRv501_withHW но много непонятных моментов:
1. Group Display в области Overwiev не подвязан ни к одному тэгу. Каким образом он индицирует что либо.
2. А Group Display находящиеся в картинках уровнями ниже подвязаны к структурному тегу, Вопрос: структурный тег нигде толком не описан.
3. Может существует какой либо мастер конфигурирования которого у нас нету, может его надо использовать.
Re: Group Display - Переход к ист-ку. аварии
Михайлин Сергей; 19.6.03

В письменном виде подробно объяснить очень долго.

Кратко:
В Overview подвязка Group Display к корневой картинке происходит автоматом через Picture Tree Manager. Далее в этой корневой картинке у Вас должен быть еще один Group Display привязанный с помощью визарда из окна Dinamic Wizard, который кажется называется Connect Group Display to picture, к картинке на уровен ниже(ваша 5-ая картинка) и уже на этой 5-ой картинке должен находиться Group Display, привязанный с помощью визарда из окна Dinamic Wizard, который кажется называется Connect Group Display to tag structure к определенному 32-битному тэгу где эти все алармы хранятся. Распиновка этого тэка есть доке на Basic Proccess Control. Итого, происходит последовательное "поднятие" алармов через Group Display от тэга к картинке №5, от картинки №5 к корневой картинке, которая контролируется Group Display в области Overview.
Уф-ф-ф. Подробней наверно тока за реальной машиной можно показать.
Re: Group Display - Переход к ист-ку. аварии
Yrok; 19.6.03

Премного блогадарен!!!!!!!!

С уважением пацаны из
Ростова-на-Дону


text

WinCC+кнопки/лампочки
Eugene Sergeev; 5.6.03

Есть надобность передавать в ВинЦЦ нажатия кнопок на пульте, и, соответственно, зажигать некие лампочки за минимальную цену. С помощью какого контроллера это можно сделать. Крайне не хочется вставлять в раб. станцию плату MPI, хорошо бы обойтись компортом.

Re: WinCC+кнопки/лампочки
Yrok; 19.6.03

Поставь OPC Server для S7-200 (KepServer) и подключи к Com порту контроллер. Любой 200 -й серии и всё.


text

WinCC 5.1 + Step7 5.2
Александр Родин, ООО "Нева Электрик"; 16.6.03

Установил Step 7 v. 5.2 (поверх предыдущего Step 7 v.5.1 SP4), при этом был установлен WinCC 5.1

После установки перестали запускаться WinCC-шные проекты. :( Рантайм стартует и сразу же деактивируется. Кто виноват и что делать ?
Re: WinCC 5.1 + Step7 5.2
Юрченко Владимир; 17.6.03

Виноваты какие то новые общие dll. Какие можно пытаться выяснять, но быстрей переустановить WinCC. И вообще лучше первым ставить Step 7, а потом WinCC, ProTooll и т.д.

Re: WinCC 5.1 + Step7 5.2
Василенко; 17.6.03

А возможно и Windows придется переставить.

Re: WinCC 5.1 + Step7 5.2
Александр Родин, ООО "Нева Электрик"; 17.6.03

WinCC я уже переставил - та же ситуация... по логам смотрел, идет ругань на уровне SQL-базы...

Вот пример из лога при старте проекта:

255,17.06.2003,10:22:05:327,1003000,1,Администратор,NE_PROJECTING_4,Alarm Logging,connecting to database CC_Kolomna_02-04-16_13:24:50R ...
255,17.06.2003,10:22:05:898,1003000,1,Администратор,NE_PROJECTING_4,Alarm Logging,Connection 0 O.K.
255,17.06.2003,10:22:05:918,1003000,1,Администратор,NE_PROJECTING_4,Alarm Logging,Connection 1 O.K.
255,17.06.2003,10:22:05:918,1003000,4,Администратор,NE_PROJECTING_4,Alarm Logging,Connection Error : 4 - [Sybase][ODBC Driver][Adaptive Server Anywhere]Database server rejected connection: Database server connection limit exceeded

И дальше идет длинная вереница из записей вида:

255,17.06.2003,10:22:08:983,1007001,4,,NE_PROJECTING_4,SCRIPT,ExecuteError in Action @2

И все.. и так на каждом проекте..
Re: WinCC 5.1 + Step7 5.2
Юрченко Владимир; 17.6.03

На немецком сайте по этому поводу (Entry ID: 14685938 ) говорят нужно поставить HotFix0 для WinCC v.5.1 с диска STEP 7 V5.2.

Re: WinCC 5.1 + Step7 5.2
Александр Родин, ООО "Нева Электрик"; 17.6.03

сам спрашивал, сам и отвечаю... ЧИТАЙТЕ CUSTOMER SUPPORT !!!... :)

Только странно, что они указывают использовать HotFix0 для WinCC... Получается, что все HF с высшим номером просто не нужны... :\

См. WinCC 5.1 & Step7 5.2 on one PG/PC


text

WinCC
Павел; 3.6.03

Где можно скачать SP2 для WinnCC5.0- т.к. на сайте Siemens его нет, несмотря на много ссылок на сайт?

Re: WinCC
Назаров Дмитрий; 16.6.03

Давно это было... SP2 для WinCC нигде нельзя скачать, т.к. его размер равен размеру новой инсталляции WinCC. В нем был реализован переход с Sybase 5 версии на Sybase 7.


text

Text Library
Павел Синица; 15.6.03

В Text Library описаны два языка но при переключении их в Run Time на русском теряется шрифт.

Re: Text Library
Александр Родин, ООО "Нева Электрик"; 16.6.03

В графическом редакторе, если вы хотите использовать надписи на нескольких языках необходимо эти надписи указывать в свойствах для каждого языка.

TextLibrary содержит тексты только для AlarmLogging


text

WinCC $ TS Adapter
Ceргей Федеров; 15.6.03

Как соединить WinCC c S7 через TS Adapter? Адаптер у меня работает по DP настроен в ТeleService. Мне нужно описать PC станцию Нardware S7 но в каталоге я его не нахожу. Чем его можно заменить или где он находится.


text

WinCC v6.0 - проблема с кирилицей в тагах и Alarm Logging
Виктор; 4.6.03

Установил на Windows 2000 Professional +SP3 - WinCC v.6.0. И сразу возникла проблема: не могу создать таг с русским названием (название отображается в таком виде: ?????_??????), в Alarm Logging не могу создать собитие с русским текстом сообщения (аналогично: ??????? ????).

Много чего пробовал - результат нулевой.
См. http://WinCC

Re: WinCC v6.0 - проблема с кирилицей в тагах и Alarm Logging
Боков; 4.6.03

В v5 WinCC такое бывает если в Text Library не добавлен русский язык.

Re: WinCC v6.0 - проблема с кирилицей в тагах и Alarm Logging
Юрий; 5.6.03

Добавление русского в Text Library ничего не меняет. Видимо проблема в кодировках SQL.

Кто нибудь знаут, как эту проблему решить ?
Re: WinCC v6.0 - проблема с кирилицей в тагах и Alarm Logging
Бычков Андрей ГП Спутник; 6.6.03

Проблема решается путем подмены кодовой страницы.

если мне не изменяет память надо
в HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage
"1250"="c_1250.nls"
заменить на "1250"="c_1251.nls"

Re: WinCC v6.0 - проблема с кирилицей в тагах и Alarm Logging
Виктор; 13.6.03

Спасибо за помощь, подмена кодовой страницы сработала. Только я поменял

HKEY_LOCAL_MACHINE \ SYSTEM \ ControlSet001 \ Control \ Nls \ CodePage \ "1250"="c_1251.nls" і "1251"="c_1251.nls" і "1252"="c_1251.nls"
HKEY_LOCAL_MACHINE \ SYSTEM \ ControlSet002 \ Control \ Nls \ CodePage \ "1250"="c_1251.nls" і "1251"="c_1251.nls" і "1252"="c_1251.nls"
HKEY_LOCAL_MACHINE \ SYSTEM \ ControlSet003 \ Control \ Nls \ CodePage \ "1250"="c_1251.nls" і "1251"="c_1251.nls" і "1252"="c_1251.nls"
HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Control \ Nls \ CodePage \ "1250"="c_1251.nls" і "1251"="c_1251.nls" і "1252"="c_1251.nls"
HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows NT \ CurrentVersion \ FontMapper \ DEFAULT / REG_DWORD / cc


text

TFT монитор SCD 1597-K - управление LEDs из WinCC
Виктор; 4.6.03

Есть TFT монитор SCD 1597-K (с итегрированной клавой и мышей).

Проблема: как управлять LEDs из WinCC?В инструкции к устройству описан формат специальной команды, которую нужно послать на клаву. Но как послать эту команду?

Re: TFT монитор SCD 1597-K - управление LEDs из WinCC
Eugene; 11.6.03

Прочитал ответ на Automation and Drives Service & Support

Создаешь скрипт:

// Incorporating the DLL:
#pragma code("tastdr32.dll")

// Prototype fur DLL function CallTastdrv:
int __cdecl CallTastdrv(int Cmd, void* pCmdPara);
// Keyboard controller command for LED sides:
#define TASTCON_LED_CMD 0xD6
// SwitchLed: set LED <LedNo> to mode <Mode>
// LedNo: 1 to 39 (see table)
// Mode: 0=off, 1=on, 2=blinking
// Return: Status=0: OK; Status!=0: Error
int SwitchLed(BYTE LedNo, BYTE Mode)
{
BYTE Para[3];
int Status;
BYTE SetNumber;
BYTE LedNumber;
// Determine LED group and –Number:
SetNumber = (BYTE) ((LedNo - 1) / 16);
LedNumber = (BYTE) (((LedNo - 1) % 16) + 1);
Para[0] = SetNumber;
Para[1] = LedNumber;
Para[2] = Mode;
// Call DLL function:
Status = CallTastdrv(TASTCON_LED_CMD, Para);
return Status;
}

Номера LED:
F1 - 34
F2 - 35
F3 - 33
F4 - 8
F5 - 5
F6 - 7
F7 - 3
F8 - 1
F9 - 6
F10 - 23
F11 - 30
F12 - 31
F13 - 29
F14 - 27
F15 - 28
F16 - 25
F17 - 26
F18 - 37
F19 - 38
F20 - 36
S1 - 16
S2 - 13
S3 - 15
S4 - 12
S5 - 10
S6 - 14
S7 - 9
S8 - 11
S9 - 18
S10 - 20
S11 - 22
S12 - 17
S13 - 19
S14 - 24
S15 - 21
S16 - 2
ACK - 32
HELP - 4
TEMP - 39

Пример использования в событии OnClick:
#include "apdefap.h"
void OnClick(char* lpszPictureName, char* lpszObjectName, char* lpszPropertyName)
{
SwitchLed (11, 1); // Switch on LED with key S8
if (SwitchLed (1, 2) != 0) // Set LED to blinking with key F8...
{ // ...with error handling
}
}

Re: TFT монитор SCD 1597-K - управление LEDs из WinCC
Виктор; 13.6.03

Пробовал скрипт - не работает(функция SwitchLed возвращает код ошибки =13). В Automation and Drives Service & Support в шапке к этому скрипту указаны Panel PC - PC670, PC870. Может работает только для них ?

Пробовал метод перебора для константы #define TASTCON_LED_CMD 0xD6 (прогнал от 0-10000, дальше не пробовал. Та же ошибка.)
Пробовал даже из под DOSа писать в порт клавы указанную в инструкции специальную команду - не работает (циклы для паузы):
outp(0x60,0xea);
for(i=0; i<4000; i++);
outp(0x60,0x46);
for(i=0; i<4000; i++);
outp(0x60,0x46);
for(i=0; i<4000; i++);
outp(0x60,0x46);
for(i=0; i<4000; i++);
outp(0x60,0x46);
for(i=0; i<4000; i++);
outp(0x60,0x46);
for(i=0; i<4000; i++);
outp(0x60,0x46);
for(i=0; i<4000; i++);
outp(0x60,0x46);
for(i=0; i<4000; i++);
outp(0x60,0x46);
for(i=0; i<4000; i++);
outp(0x60,0x46);
for(i=0; i<4000; i++);
outp(0x60,0x46);


text

Как запустить скрипт при старте RT?
Каменков Алексей; 9.6.03

Возможно, вопрос глупый и ответ всем известен, но в форуме и в справке по WinCC я не нашел способа запустить функцию при старте проекта. Хотя, казалось бы, это ключевая возможность - ну в самом деле, не жать же оператору на кнопку Connect, чтобы подключиться к какому-либо удаленному оборудованию по TCP/IP. Все должно происходить автоматом. Но как? Подскажите пожалуйста!

Re: Как запустить скрипт при старте RT?
Евгений Трунов; 9.6.03

Можете написать свою программу в виде .exe-файла и включить её в список задач, стартующих вместе с подсистемами WinCC, там можно с вызовом функций ODK. Можете вставить код на CScript в метод OnOpenPicture главной формы проекта.

Re: Как запустить скрипт при старте RT?
Каменков Алексей; 11.6.03

Спасибо. Способ, в принципе хороший. Но есть и осложнения - случай с внешней программой сразу отбрасываем, как громоздкий, он хорошо только если эта самая программа делает еще что-нибудь. А в случае с OnOpenPicture - вызов будет происходить при каждой загрузке странице - могут же быть переходы по кадрам. То есть надо заводить какой-то лишний тег...Как-то все это неэлегантно...Неужели нет банального AutoStart - даже в Windows он есть :)

Re: Как запустить скрипт при старте RT?
В.Румянцев; 11.6.03

Попробуйте создать внутренний бинарный тэг. В tag properties установите опцию Start value 1.Это значит что при запуске RUN TIME тэг примет это значение. Установите этот тег в качестве триггера для вашего скрипта, а в конец скрипта поставте reset этого тега если скипт должен выполняться однократно при запуске. Вроде бы должно работать.

Re: Как запустить скрипт при старте RT?
Eugene; 12.6.03

О какой ЭЛЕГАНТНОСТИ Вы говорите ?!!!

Уж если работает на OnOpenPicture, то это разве не хорошо? Вообще-то в любой нормальной софтине должен быть пароль на вход в систему. Загружается один раз... при старте проекта.


text

WinCC и функциональные клавиши PC670(870)
Eugene; 11.6.03

Насколько я понимаю, специальные клавиши PC670(870) генерируют код сочетания клавиш. Например, нажатие S1 тождественно сочетанию SHIFT-F9.

В WinCC помещаю на экран кнопку, в качестве hotkey задаю SHIFT-F9 и запускаю рантайм. При нажатии кнопки мышкой, при нажатии сочетания SHIFT-F9 и при нажатии сочетания SHIFT-S1 действие выполняется, а вот при нажатии S1 - ничего.
То, что S1 и SHIFT-F9 генерируют одинаковый скан-код - факт неоспоримый (проверено программой KeyView от Siemens).

Так что я делаю неправильно?


text

4 панели с одинаковым софтом
Дмитрий; 11.6.03

Скажите, пожалуйста.

На 4 панели OP170B установлены одинаковые программы, связь осуществляется по IP. Будут ли они конфликтовать?


text

Как создать свою Format DLL ?
Андрющенко Александр; 5.6.03

Как устроена Format DLL? Возможно ли написать и подключить свою?

Re: Как создать свою Format DLL ?
Бычков Андрей ГП Спутник; 10.6.03

В ODK подробно расписаны принципы работы Format DLL, мы пробовали - проблем и нюансов не возникало.


text

Тайны Transfer
Сергей; 10.6.03

Приношу извинения если эти тайны неоднократно разрешены на страницах форума, но найти ответ пока не удалось.

Итак, вопрос...
Если генерация сообщений посредством Т осуществляется в базовом пакете Step7 (без использования CFC), то в AlarmLogging не появляются некоторые поля (Event и др), а некоторые поля появляются ... Что и как нужно сделать, чтобы избежать этого неприятного бага


text

таблицы
miha-CC; 6.6.03

Есть ли возможность в WinCC4.0 ограничить количество знаков после запятой при выводе архивных тегов с помощью таблицы.

Re: таблицы
Василенко; 6.6.03

А почему бы на v5 не заменить

Re: таблицы
miha-CC; 9.6.03

нет авторизаций под v5.

Re: таблицы
Василенко; 9.6.03

Разве авторизации для v4 и v5 разные?

Re: таблицы
miha-cc; 10.6.03

Я не знаю как где, но у нас на WinCC 5 не точто авторизации не встают с WinCC 4 , а вообще не видит никаую авторизацию с авторизационной дискеты.


text

Периодически возникающие сбои связи с Protool
Нарышев Алексей; 9.6.03

На одной сети (оптическая Profibus DP, 12Mb/sec) "висят" 6 панелей MP270, 7 PC, PLC S7-400 (414-3)и ЕТ200М. В проекте Protool периодически возникают сообщения "Связь с контроллером прервана", висят 5 секунд, после чего связь восстанавливается. С чем это связано? Влияет ли на качество связи установленное количество коммуникационных Job-ов (для моей версии CPU - 600)?

Re: Периодически возникающие сбои связи с Protool
LeXX; 9.6.03

Этот вопрос в том или ином виде поднимался на форуме. Это связано с S7 протоколом или с нехваткой времени на коммуникации. Попробуйте его увеличить


text

IPX и WinCC
Dmitry Fil; 6.6.03

Не сталкивался ли кто с такой задачей?

Имеем один PC с WinCC(Win2K SP3) и второй PC(DOS). На втором PC c DOS вращается программка, к-рая по IPX должна передавать и принимать некоторые данные с первого PC c Win2K. Каким образом можно реализовать получение этих данных в WinCC. Зараннее благодарен за любые мысли.

Re: IPX и WinCC
Лев Шерешевский; 6.6.03

Формулировка "передавать и принимать данные по IPX" допускает огромное множество конкретных вариантов реализации. В вашем случае определяющим звеном является DOS-программа, т.к. на WinCC под Windows Вы можете использовать большое количество разных интерфейсов, весь вопрос в том, как умеет общаться программа. Простейший вариант - использовать для обмена данными файловый буфер.


text

PROTOOL
Евгений; 6.6.03

Может кто подскажет как получить исходный файл для ProTool(для модификации и изменения проекта) имея только бинарную копию сделанную при помощи ProSave.

Заранее благодарю.

Re: PROTOOL
LeXX; 6.6.03

Хренушки!!!! Это не предусмотрено, к сожалению...


text

PROTOOL
Евгений; 5.6.03

Может кто знает как получить рабочий

проект для PROTOOL(возможность модификаций) -- имея только бинарную
копию проекта скаченную при помощи ProSave (OP7,OP27).
Заранее благодарен.


text

Изменение внутреннего тега
miha-CC; 5.6.03

Как можно изменить состояние внутреннего тега плавно (например от 0 до 100) по событию от внешнего тега, не привязываясь не к какой графической динамике.За ранее благодарен.

Re: Изменение внутреннего тега
Андрющенко Александр; 5.6.03

Очень просто - Global Script - Actions - global Actions - New. Info/Trigger (Ctrl-I).Выбрать триггер - Tag (внешний тег), Upon change.


text

sp2 для WinCC 5.0
Viic; 30.5.03

Где можно скачать sp2 для WinCC 5.0?

Re: sp2 для WinCC 5.0
Чистяков Дмитрий ОАО СеверСталь; 2.6.03

Скачать ни где нельзя.

Раньше он заказывался в виде CD-ROMа.
А вот сейчас не знаю, можно ли эту версию заказать.
Попробуйте обратится к ближайшему представителю.


text

OP30C
Андрей; 2.6.03

Данный операторский пульт просит заменить батарею CR2450. Но проблема в том, что все батарейки имеют обратную полярность. Реально ли найти родную батарею или прийдется все таки проводки выводить? И, если проводки, то что за информация пропадет при полном выключении и изъятии батарейки?


text

Работа с БД WinCC-проекта из Delphi?
Lidiya; 28.5.03

Добрый день.

Мне необходимо получить доступ к БД WinCC-проекта из Delphi. При попытке подключения компонента TTable к таблице из БД WinCC-проекта и вводе пользователя и пароля возникает ошибка "Invalid parameter". Что еще необходимо сделать для подключения? Буду признательна за быстрый ответ.

Re: Работа с БД WinCC-проекта из Delphi?
Евгкний; 31.5.03

Работайте через компоненты ADO


text

Работа с User Archives Views
Lidiya; 30.5.03

Добрый день.

Подскажите, пригодны ли функции User Archives, н-р, uaQueryArchiveByName, uaArchiveOpen и др., для работы с представлениями?
Мне необходимо объединить 2 таблицы, я это делаю с помощью представлений, а считать данные из него не удается.


text

многострочный ToolTip у объектов PDL
Бычков Андрей; 30.5.03

Возможно ли создание у объектов PDL многострочного ToolTip?

Если да, то как?


text

Связь между PLCSIM и проектом WinCC по MPI и PROFIBUS
Политов Игорь; 12.5.03

Обсуждение этого вопроса закончилось в 2002 году,

а проблема осталась.

Версии используемого ПО: WinCC 5.1, PLCSIM 5.0+SP1
(без HotFix), STEP7 5.1.
В проекте WinCC добавлено соединение по MPI,
сконфигурированы rack, slot и теги.
В проекте для STEP7 добавлено соединение по MPI
(кстати без этого соединения эффект тот же).
Попытки были и для конфигурации с PG/PC и для
конфигурации с Simatic PC Station.
В результате чего в WinCC MPI-соединение показывает
‘Satus: OK’, а теги ‘Quality: 4c – Start value’. Т.е. текущие
данные не поступают, но при этом время в Last Change
непрерывно изменяется.

Подскажите, что это может означать и как это можно поправить.
Надо ли, что-нибудь настраивать в ‘Set PG/PC’. Дело в том, что
используется Windows 2000 и отсутствуют карты CP для
ПЭВМ. Поэтому в окне ‘Set PG/PC’ доступен только ‘PC Adapter’.

Аналогичные вопросы в отношении соединения по PROFIBUS.
Для вышеизложенной конфигурации в этом случае нет даже
соединения, не говоря уже об обмене данными.

Re: Связь между PLCSIM и проектом WinCC по MPI и PROFIBUS
Назаров Дмитрий; 14.5.03

По моему опыту особо настраивать ничего ненадо, даже при отсутствии реальных СР. А эти теги вызываются для отображения в RunTime? Они не "серые" (признак отсутствия соединения)? Насколько я помню, если тег не вызвать, то он не не опрашивается и висит как у вас Start Value.

Re: Связь между PLCSIM и проектом WinCC по MPI и PROFIBUS
Политов Игорь; 28.5.03

Спасибо, все действительно работает, но только по MPI


text

Login-dialog в WinCC5.1
Андрющенко Александр; 27.5.03

Не работает PWRTLogin('1'). Вроде куда-то выводится, но не видно куда. И тишина. Скрипт дальше не идет.

Re: Login-dialog в WinCC5.1
Лев Шерешевский; 27.5.03

Попробуйте так:

#pragma code ("useadmin.dll")
#include "pwrt_api.h"
#pragma code()
PWRTLogin('1');


text

Login-dialog в WinCC 5.1 RT
Андрющенко Александр; 27.5.03

Не работает PWRTLogin('1') из скрипта. Диалог будто открывается - но не видно где.


text

Доступ к архивам через ODBC
Olzhan; 16.5.03

Пожалуйста помогите!!!! Создаю Long-Term архив. Пытаюсь через ODBCсделать выборку из архива. Почему то данные не хотят обновлятся в реальном времени. В чем дело?

При использовании dBase баз для коротких архивов все без проблем!
НО МНЕ НУЖНО ВЫДИРАТЬ ИМЕННО ИЗ Sybase!!!!!!
Re: Доступ к архивам через ODBC
Лев Шерешевский; 18.5.03

В реальном времени данные не обновляются из-за того, что Sybase производит их внутреннюю буферизацию для достижения более высокой производительности. В Вашем случае придется применять функции пакета ODK.

Re: Доступ к архивам через ODBC
Olzhan; 19.5.03

Я так и предполагал,но не был уверен. Спасибо. И если не затруднит, то где взять этот пакет, документацию к нему и нет ли скажем способа заставить сам Sybase отключить буфферизацию? Заранее благодарен!

Re: Доступ к архивам через ODBC
Юрченко Владимир; 19.5.03

Задать размер буфера можно в регистре ключом:HKEY_CURRENT_USER\Software\SIEMENS\WINCC\SQLANY\DBDSN -> Block size

.По умолчанию он равен 100. Если установить меньше - упадет производительность архивирования, при 1 - до 30 значений в секунду.
Re: Доступ к архивам через ODBC
Лев Шерешевский; 19.5.03

Пакет ODK Вы можете приобрести у региональных представителей Siemens или официальных партнеров. Заказной номер

6AV6371-1CC05-0AX0, поставляется с документацией в электронном виде. Однако, учтите, он недешев. Если соблюдать все формальности, Вам будет проще "попросить" какую-либо фирму, официально владеющую данным пакетом, написать для Вас требуемый код.
Re: Доступ к архивам через ODBC
Iva; 20.5.03

ODK не надо приобретать так как он абсолютно открыт и не требует никакой авторизации. Это просто библиотека функций. Так что смело устанавливай и используй.

Re: Доступ к архивам через ODBC
Olzhan; 22.5.03

И все таки - покупается или бесплатно?

До региональных представителей мне ой как далеко!!!!
Re: Доступ к архивам через ODBC
Лев Шерешевский; 22.5.03

Если для себя, то можно и бесплатно, но неофициально. Авторизаций никаких для него действительно не требуется и ограничений тоже никаких нет.

Если писать софт на продажу с использованием ODK, то покупать обязательно (хотя в России на copyright традиционно плюют).

Re: Доступ к архивам через ODBC
Olzhan; 26.5.03

Спасибо всем!!!! Спасибо что не оставили вопрос без внимания!!!


text

Громкость звука
Владимир; 23.5.03

Как я могу регулировать громкость звука в системе из проекта WIN CC ?

Никто не решал такую задачу ?
Re: Громкость звука
Eugene; 24.5.03

А функции API на что? Надо в MSDN'е покопаться чуть-чуть :)

Re: Громкость звука
Лев Шерешевский; 24.5.03

Прочитав Ваше сообщение понял, что возможность регулировки громкости звука из WinCC пригодилась бы во многих проектах.

Регулировка громкости в Windows не слишком сложна, но парой строк тут никак не обойдешься. Полезную статью по данной теме и фрагменты кода Вы сможете найти, посмотрев ссылку (обратите внимание на correction by Greg James). На базе предлагаемых в статье классов я создал DLL для работы со звуком из WinCC. Если заинтересует - пишите, вышлю.

См. Классы C++ для работы с громкостью звука

Re: Громкость звука
Владимир; 25.5.03

Спасибо


text

Data Manager
Прокопенко Вера; 20.5.03

Почему такое может быть?

Во время работы проекта растет используемая оперативная память, в частности задача CCRTLOADER.EXE (Data Manager)использует все больше и больше памяти, проект уже через сутки работы начинает подтормаживать. Сообщений об ошибках явных нет, очереди скриптов нет. Может ли такое происходить из-за загруженности сети Profibus? В сети два контроллера S300, панель оператора, два РС с карточками 5611. Есть еще связь с контроллером Ломиконт 110, драйвер писали сами. База на 1040 тегов. Кажется, ситуация обострилась после добавления в сеть панели оператора. И что именно делает задача CCRTLOADER.EXE?

Re: Data Manager
Евгений Трунов; 20.5.03

А этот самый драйвер Ломиконта, который собственный, еще в каких-нибудь Ваших проектах использовался? Была ли там такая ситуация? Потому как очень хочется думать именно на него.

Re: Data Manager
Eugene; 20.5.03

Может тормозить из-за некорректного построения опроса CPU, неправильного использования динамически выделяемой памяти и машинного времени процессора.

Re: Data Manager
Василенко; 22.5.03

Скорее всего не освобождается динамически выделяемая оперативная память. Если сами каких-нибудь скриптов или модулей не дописывали кроме этого драйвера Ломиконта - надо искать в нем утечку. Последнее время появились и автоматизации для этого дела. А раз исходники ваши, вам легко это дело отловить просто включив мониторинг управления памяти в отладочном проекте драйвера.


text

Time delay
Student; 19.5.03

Как организовать задержку, например, перед изменением состояния клапана.

Т.е. чтобы после нажатия кнопки состояние тега изменилось не сразу, а через некоторое время.
Заранее спасибо.
Re: Time delay
Eugene; 20.5.03

ну, напимер, функцией Sleep. А какова задача? Может быть, Вы не туда копаете? :)

Re: Time delay
Student; 21.5.03

Можно подробней?

Не нашел функцию sleep среди стандартных C-акций :(
Re: Time delay
Владимир; 22.5.03

не sleep

а Sleep
например,
Sleep(1000);
Re: Time delay
Владимир; 22.5.03

Ну ладно, вот :

#pragma code("kernel32.dll");
VOID Sleep(DWORD dwMilliseconds);
#pragma code();

Sleep(1000);


text

ОШИБКА или ОГРАНИЧЕНИЕ WInCC 5.1 !?
Александр Шестаков; 21.5.03

Вводная:

1. Создаем глобальный указатель на строку:

char* pBuffer = NULL;

void Dummy ()
{
}

2. Прописываем вызов этой функции при открытии стартового окна (думаю ясно для чего).

3. Создаем на стартовом окне поле ввода-вывода IOField1. Его свойства Data Format устанавливаем в String. Для свойства Output Value пришем C Action сделующего содержание (приведен пример, только тела акции):

extern char* pBuffer;
return pBuffer;

и привязываем Event Name к тегу count (предварительно созданному и имеющему типа Unsigned 32-bit value) c циклом Upon change. Компилируем и сохраняем.

4. Создаем кнопку Button1 и на событие Mouse Action пишем следующий код (приводится только тело акции):

#define STR_LEN 100 // Длина строки

// Произвольный символ
#define DUMMY_CHAR 'x'

extern char* pBuffer;
int i = 0;

if (pBuffer) { free(pBuffer); pBuffer = NULL; }

pBuffer = (char*) calloc (STR_LEN+1,sizeof(char));

if (pBuffer==NULL) { printf ("Error!\r\n"); return; }

// Заполняем строку

for (i=0; i<STR_LEN; i++) pBuffer[i] = DUMMY_CHAR;
pBuffer[i] = '\0';

// Извещаем поле ввода-вывода
//об изменении буфера строки

SetTagDWord ("count",GetTagDWord("count")+1);

printf ("Ok!\r\n");

5. Запускаем RunTime.(Неплохо было бы перед этим создать окно диагностики для просмотра сообщений о результатах выполнения акции и средства для освобожнения выделенной памяти при выходе из RunTime).

Главная часть:

Первонаначально устанавливам размер буфера для строки равным 100 (корректируем STR_LEN). Компилируем перезапускаем RunTime и щелкаем по кнопке сколько угодно раз все работает замечательно! В окне диагностики Ok!, в поле ввода-вывода в нашем случае xxxxx... .

Затем последовательно увеличиваем размер буфера строки и повторяем все выше описанные действия. Все работает отлично, но при превышении размера буфера строки 4030 (в моем случае), при первом же щелчке (или втором) на кнопке WinCC 5.1 вешается напрочь!

Применание: По данной технологии передачи длинных строк были опробаваны также ActiveX-компоненты. Эффект тот-же.

Вопросы:

1. Это ошибка или все-таки ограничение WinCC 5.1?

2. Какие еще способы передачи длинных строк можно придумать для передачи их в визуальные компоненты формы для их отображения в требуемом формате или как обойти это ограничение?


text

upload с ор3 и ор17
Andy; 21.5.03

Как выполнить upload с ор3 и ор17

Re: upload с ор3 и ор17
Чистяков Дмитрий ОАО СеверСталь; 21.5.03

Этот вопрос пожалуй можно уже записать в FAQ.

1. Выгрузить программу из панелей можно при помощи программы ProSave. Она идёт в комплекте с самим ProTool
2. Выгруженный проект можно будет лишь загрузить в другую панель того же типа. Редактироватье её будет нельзя.


text

Блокировка "CTRL + SHIFT" при старте WinCC
vvgut; 21.5.03

Как предотвратить запуск WinCC в режиме конфигурирования при нажатии комбинации клавиш "CTRL + SHIFT" (ранее был закрыт активный проект)?

Заранее благодарю.


text

ОФФ:Редактор скриптов
Владимир; 20.5.03

Слева была колонка со списком скриптов, функций проекта.

Куда-то пропала.
Где искать ?

Re: ОФФ:Редактор скриптов
Eugene; 20.5.03

В настройках посмотри...


text

Time delay
Student; 19.5.03

Как организовать задержку, например, перед изменением состояния клапана.

Т.е. чтобы после нажатия кнопки состояние тега изменилось не сразу, а через некоторое время.
Заранее спасибо.
Re: Time delay
Чистяков Дмитрий ОАО СеверСталь; 19.5.03

Это Вы про что?

Про WinCC или Step7?

Re: Time delay
Student; 19.5.03

Пардон, ошибся разделом

Про WinCC


text

Функция округления вещ.числа?
Lidiya; 15.5.03

Есть ли в WinCC функция округления вещ.числа до указаного числа разрядов после запятой?

Re: Функция округления вещ.числа?
Владимир; 15.5.03

Re: Функция округления вещ.числа?
Lidiya; 15.5.03

причем здесь Abs()?

Есть несколько вещ. тегов. Необходимо, чтобы сумма тегов была 100%. Более 2-х цифр после запятой ввести невозможно (Output Format=999.99). Но при сложении в итоговом теге появляются значения в младших разрядах, н-р, 100.0000001000. Как от этого избавится?
Re: Функция округления вещ.числа?
Юрченко Владимир; 15.5.03

Проблема не WinCC, а знания языка С.

1. округлить до нужной точности можно через sprintf() c нужным форматом,
а потом преобразовать строку обратно функцией double atof(const char *s);
2. на самом деле нужно - во первых проверять чтобы число не было больше 100, а потом какое то число из суммы подогнать, чтобы в сумме было 100:
a= 100-b-c-d...

Re: Функция округления вещ.числа?
Владимир; 15.5.03

Lidiya, сразу не понял Вашу проблему :-)

Re: Функция округления вещ.числа?
Eugene; 15.5.03

Дорогая Lidia, прочитайте пожалуйста документацию по WinCC и какую нибудь книгу по языку С. Там есть ответы на все Ваши вопросы, которые Вы задаете в форуме.


text

? ODK : Linking Tag Connections
Шимолин Сергей, ОАО "УМЗ"; 16.4.03

Кто-нибудь работал с ODK-ми функциями для реализации команды Linking Tag Connections.

Задача : В базе список тегов, по ним в картинке pdl нужно создать индикаторы (заданные групповые объекты) и автоматически привязать теги из базы. Копирование, привязка получается. Не получается сделать функцию замены, как в Linking Tag Connection. Может кто делал что-нибудь похожее.. и поделится... :)
Re: ? ODK : Linking Tag Connections
Лев Шерешевский; 18.4.03

Если я правильно понял Вашу задачу, необходимо использовать функцию ODK PDLRTSetLink или использовать макрос LinkInstance. Оба эти варианта работают нормально, но с ними достаточно много возни. Если есть возможность, удобнее использовать TagPrefix, хотя и с ним есть свои сложности.

Re: ? ODK : Linking Tag Connections
Прокопенко Вера; 8.5.03

Аналогичная проблема. Нужно скопировать объект , в котором изменение свойства (цвет) привязано к тегу через Dynamic Dialog и поменять имя тега. Функция PDLCSSetLink в данном случае имя тега меняет, но сбрасывает динамические привязки. Я допускаю ошибку, или PDLCSSetLink работает только с тегами, привязанными напрямую? Что такое макрос LinkInstance и как он использеутся?

Re: ? ODK : Linking Tag Connections
Лев Шерешевский; 10.5.03

Давайте четко определимся с поставленной задачей. Суда по тому, что Вы пытаетесь использовать функции CS, цель состоит в создании в design-time идентичных копий объектов, привязанных к разным тегам. Если число дубликатов, которые необходимо создать, не чрезмерно, проще всего ограничиться стандартным методом: создать копии и перепривязать их используя Edit->Linking->Tag Connections. Этот способ корректно меняет теги, динамические привязки и даже привязку к тегам в скриптах (если все сделать правильно). С функцией же PDLCSSetLink, скорее всего, Вы не сможете создать копию привязки Dynamic Dialog, т.к. это сгенерированный с помощью wizard-а скрипт.

Второй вариант действий - это использовать перепривязывание во время исполнения. Здесь, как я уже писал, можно применять TagPrefix (работает и с привязками Dynamic Dialog), функцию PDLRTSetLink и макрос LinkInstance.
Альтернативный вариант - использовать технологию Picture Module (см. одноименную закладку Dynamic Wizard)

По поводу LinkInstance. Это макрос, определенный в файле WinCC\aplib\PicBlck.h. Принципиальных преимуществ он не дает, но может быть удобен при большом количестве связей. Как он действует Вы сможете понять, изучив результаты работы wizard-ов Picture Module.
Re: ? ODK : Linking Tag Connections
Владимир; 12.5.03

Интересует функция PDLRTSetLink.

Можно примерчик, как это прилепить к какому-либо свойству объекта ?

Re: ? ODK : Linking Tag Connections
Лев Шерешевский; 12.5.03

Эта функция достаточно подробно описана в ODK. Особых неожиданностей при ее использовании вроде бы не возникает, но если будут проблемы, пишите по электронной почте, будем разбираться.

Re: ? ODK : Linking Tag Connections
Владимир; 14.5.03

PDLRTSetLink не работает с привязками Dynamic Dialog. Какие еще есть варианты чтобы работало с Dynamic Dialog?

Re: ? ODK : Linking Tag Connections
Лев Шерешевский; 15.5.03

Вы можете использовать TagPrefix, он распространяется и на связи, созданные Dynamic Dialog. Есть и другие способы, но они уж слишком трудоемкие и медленно работающие.

Re: ? ODK : Linking Tag Connections
Владимир; 15.5.03

Кстати о TAG Prefix. Уже обсуждался вопрос о том, как избавиться на некоторых объектах в Picture Window от этого свойства. Кроме связей Indirect я ничего не смог применить. Есть ли еще способы?


text

Почему не зупускается sql-скрипт?
Lidiya; 27.3.03

Беру пример:

*********************************
char ExportArchive[256];
char* path="E:\\SIEMENS\\Common\\sqlany\\isql.exe -q -b -c";
char* parameters="UID=DBA;PWD=SQL;DBF=E:\\Projects\\WinCC\\Demo\\Demo.db";
char* action="read E:\\Projects\\WinCC\\Demo\\SQL\\archiv.sql";

sprintf(ExportArchive,"%s %s %s",path,parameters,action);
ProgramExecute(ExportArchive);
*********************************
содержимое archiv.sql:
SELECT * FROM "DBA"."MCPTVARIABLEDESC";
OUTPUT TO E:\Projects\WinCC\Demo\archive.txt FORMAT ASCII
*********************************
В Runtime при запуске скрипта выдается сообщение: "Specified database not found".Почему?

Re: Почему не зупускается sql-скрипт?
Александр Родин, ООО "Нева Электрик"; 28.3.03

Потому что надо

1. указывать не Demo.DB, а DemoRT.DB;
2. лучше указывать не файловый доступ, а доступ через DSN, т.е. писать не "DBF=", а "DSN=".

Имя DSN можно посмотреть в настройках ODBC в виндах.

ну и замечание по написанию скриптов: таким способом строки лучше всего не делать...
лучше делать так:

char* path, parameters, action;
path = (char*) SysMalloc (256);
parameters = (char*) SysMalloc (256);
//... и т.д.
sprintf (path, "<ваша строка>\0");
// и т.д.

так есть больше уверенности, что в этих строчках не будет никакого мусора.
Re: Почему не зупускается sql-скрипт?
Lidiya; 28.3.03

А можно таким же способом запускать sql-скрипт, и указывать DSN любой другой БД, прописанной в ODBC?

Re: Почему не зупускается sql-скрипт?
Чистяков Дмитрий "СеверСталь"; 28.3.03

Можно. Если конечно имеется её драйвер.

Re: Почему не зупускается sql-скрипт?
Александр Шестаков; 27.4.03

1. Что касается исходного примера то, способ определения строковых массивов не приводит к появлянию мусора, а выделение памяти под строки через функцию SysMAlloc громоздко и неудобно, помимо того что необходимо еще осводождать память.

2. Таблица которая приведена в примере (описание тегов) находится в конфигурационной базе данных, а не в базе данных RunTime.
3. Что касается указания DSN, вместо имени файла, то полностью с этим согласен. Для автоматического получения DSN для текущего проекта можно использовать функции работы с базами данных из ODK (рекомендую).

Re: Почему не зупускается sql-скрипт?
Lidiya; 14.5.03

Заменила в строке "DBF=" на "DSN=", DSN скопировала из ODBC. Все равно выдает ошибку "Specified database not found". Почему? непонятно...

Подскажите пожалуйста, какая функция ODK позволяет автоматически получать DSN?


text

SIMATIC WinCC V6
VAdzzik; 14.5.03

Необходима информация по WinCC V6 как то:

Где скачать/заказать
Документация-обзор продукта, проектипование (pdf).
Зарание благодарен.

Re: SIMATIC WinCC V6
Василенко; 14.5.03

http://www.ad.siemens.de/hmi/html_76/microsites/wincc-v6.htm

Re: SIMATIC WinCC V6
Лев Шерешевский; 14.5.03

Скачать не получится. Заказать WinCC, получить демонстрационную версию, документацию и т.п. Вы можете в офисах региональных представителей или официальных партнеров Siemens.

См. Региональные представительства

Re: SIMATIC WinCC V6
OLEG; 14.5.03

Позвони 69-13.


text

Связь WinCC с Excel посредством чего бы можно было организовать??
Сизарев Сергей, АРХБУМ; 12.5.03

Посредством какого инструмента можно организовать работу WinCC с файлами Екзеля на удалённом компьютере.

Пробовал применять DDE, ODBC. Не подходит. Может у кого есть по OPC или OLE документация, чтобы обеспечить такой доступ?
Re: Связь WinCC с Excel посредством чего бы можно было организовать??
Илья; 13.5.03

Смотри http://www.opcfoundation.org/

WinCC может работать как ОРС-сервер.
Re: Связь WinCC с Excel посредством чего бы можно было организовать??
Назаров Дмитрий; 14.5.03

С каждой поставкой WinCC идет диск WinCC Configuration & Communication Manual где довольно подробно расписаны возможности связи с Excel через OLE и приведен пример. Пример кинул на мейл.

А еще есть диск WinCC Knowlege Base, там очень подробно расписана связь с Excel через ODBC, DDE и настройка WinCC как OPC сервера.


text

Можно ли русифицировать сообщения WinCC?
Lidiya; 7.5.03

Добрый день.

Можно ли русифицировать сообщения WinCC, например, такие как "Insufficient permissions" или "The value exceeds the limits". Если можно, то как это сделать?

Re: Можно ли русифицировать сообщения WinCC?
Александр,СКТЦ; 7.5.03

Нужно отредактировать ресурсы в одном из файлов с расширением lng в каталоге \\WinCC\Bin

Re: Можно ли русифицировать сообщения WinCC?
Lidiya; 7.5.03

А в чем редактировать этот файл? В текстовом редакторе?

Re: Можно ли русифицировать сообщения WinCC?
Коротов Д.В.; 8.5.03

Возьми прогу Resorator она позволяет это делать.

Re: Можно ли русифицировать сообщения WinCC?
Коротов Д.В.; 8.5.03

Прошу прощения, Restorator

Re: Можно ли русифицировать сообщения WinCC?
Lidiya; 12.5.03

Что-то не получилось отредактировать с помощью Restorator 2.52 build 772. При открытии lng-файлы запускаются с помощью Notepad. Похоже, что Restorator не распознает эти lng-файлы. Другие файлы (н-р, ocx, dll, exe)доступны для редактирования. Может версия не та, или еще что?

Re: Можно ли русифицировать сообщения WinCC?
Лев Шерешевский; 12.5.03

Restorator lng-файлы распознает. Вместо double-click, перетащите файлы в левый фрейм или используйте пункт меню open. Можно также воспользоваться очень удобной функцией поиска заданного образца во всех ресурсных файлах.


text

Внешние взаимодействие с User Archive
Антон Глухов; 12.5.03

Скажите пожалуйста, пользовался ли кто-нибудь функциями внешнего взаимодейстивия с UserArchive, такими как UAArchiveUpdate, UAArchiveInsert и т.д. Дело в том, что получается добавлять и удалять записи таким образом, а вот редактировать не получается. UAArchiveUpdate возвращает ошибку. Работать с User Archive как с обычной базой нельзя, т.к. необходима поддержка функции резервирования. Может кто-нибудь сталкивался с такой проблемой?

Заранее спасибо.


text

Запись бита по FDL в S5 из WinCC
Карпов Евгений; 9.5.03

Используется Profibus FDL S5 для связи контроллера S5-95 c WinCC .На WinCC посылается слово и там нормально раздергивается на биты. А обратно ? Написано ,что FDL не поддерживает запись битов. Как это обойти?


text

WinCC 6.0
Чистяков Дмитрий ОАО СеверСталь; 8.5.03

http://www4.ad.siemens.de/news/cs/en/15195529


text

Расчеты конфигурации проектируемых систем
Евгений Трунов; 7.5.03

Вопрос скорее по теме "Промышленные сети SIMATIC NET", но лучше сюда.

На этапе проектирования системы имеются данные о:

- количестве локальных узлов (пунктов), входящих в систему и расстояниях между ними;
- количестве параметров, обрабатываемых на каждом узле;
- количестве параметров, которые должны передаваться в центральный диспетчерский пункт (ЦДП);
- требованиях по хранению информации и представлению данных;

На этом основании должны быть выбраны:

- количество и типы контроллеров на каждом узле;
- количество операторских станций и серверов на каждом узле и в ЦДП;
- вид сети и тип сетевого соединения между между объектами;

В общем, обычная задача. Так вот, имея все исходные данные, как можно рассчитать в design-режиме (с определенной степенью условности, конечно), параметры работы проектируемой сети и локальных станций в построенной конфигурации? Примерную загрузку сети и процессоров рабочих станций, подсистем WinCC? Справятся ли серверы, к примеру, с проектируемым объемом передаваемых данных, или нужно уменьшать количество параметров и увеличивать количество выч. оборудования? Чем делаются такие расчеты для оборудования/сетей Сименса? Что предлагает сам Сименс?

Или можно опираться только на свой и других опыт и рекомендуемые-проверенные конфигурации?
Re: Расчеты конфигурации проектируемых систем
Чистяков Дмитрий ОАО СеверСталь; 8.5.03

Вот здесь имеется собранная база на основе реальных испытаний по связи различных серий контроллеров с использованием различных ком.процессоров

http://www4.ad.siemens.de/news/cs/en/1651770

А так же все временнЫе параметры сети Вы сможете получить ещё на этапе проектирования в Step7. После ввода всей конфигурации системы, посмотрите параметры сети в свойствах.
Максимальное количество связей указано в описании каждого CPU, от этого и плясать придётся.

ЧТо же касается WinCC, то там расписаны все требования к железу в описании.


text

Как организовать асинхронную связь между PLC и SCADA?
Александр Туманов; 1.4.03

Требуется обновлять теги по инициативе PLC, т.е. асинхронно, чтобы не грузить сеть. S7 протокол работает синхронно. Как реализовать такой обмен между S7-400H и WinCC?

Re: Как организовать асинхронную связь между PLC и SCADA?
Чистяков Дмитрий "СеверСталь"; 1.4.03

Сеть и так должна работать не загружаясь. Т.е. из контроллера в WinCC не передаются все тэги, которые прописаны в WinCC. А только те, которые в данный момент отображаются на кадрах визуализации и те, что учавствуют в AlarmLogging для формирования сообщений.

Так, например, у нас сейчас в проекте 26 тыс. тэгов и 1 сервер и 23 клиентских станции. Если бы все тэги передавались из контроллера в сервер WinCC, то проект, просто на просто завис бы. ;-)
А так коммутатор говорит, что загрузка канала лежит в пределах 3-8%. У нас используется CP443-1 в S7-400 (CPU417-4) и CP1613 в сервере.
А вообще, какая у вас сеть. Возможно проблема в канальном или физическом уровне сети.
Re: Как организовать асинхронную связь между PLC и SCADA?
Александр Туманов; 1.4.03

Сеть проектируется. Тем не менее, мне хочется узнать как реализуется именно асинхронная связь (про синхронную я и сам почти всё знаю), причём только S7-400 позволяет её реализовать.

Re: Как организовать асинхронную связь между PLC и SCADA?
Чистяков Дмитрий "СеверСталь"; 2.4.03

Так а в WinCC как раз и так асинхронная связь. Тут народ наоборот жалуется, что она асинхронная. ;-)

http://www.automation-drives.ru/cgi-bin/forum/forum.cgi?dir=1008101932&root=1048671221&year=2003
Re: Как организовать асинхронную связь между PLC и SCADA?
Маслов Дмитрий; 9.4.03

Ну это смотря что подразумевать под асинхронной связью. В первоначальном варианте вопроса требовалось, чтобы теги обновлялись по инициативе контроллера. В WinCC это по умолчанию так и есть, а устанавливается это здесь: правой кнопкой щелкнуть на типе используемого соединения (например, Industrial Ethernet), выбрать System Parameter, в открывшемся диалоге есть флажки "Cycle formation by PLC" и "With trasfer of changes". Только надо учитывать, что это довольно сильно нагружает CPU контроллера и количество циклов обновления тегов у контроллера ограничено. Особенно это касается трехсотых. В рантайме можно посмотреть, сколько циклов опроса тегов формируется контроллером, а сколько операторской станцией. Для этого надо при запущенном WinCC Runtime запустить Simatic->WinCC->Tools->Channel Diagnosis.

В случае использования дублированного контроллера все точно также. Просто надо сконфигурировать соединение в Step'e и использовать его в WinCC как Named Connection.
Re: Как организовать асинхронную связь между PLC и SCADA?
Евгений Трунов; 7.5.03

Разбиение по кадрам визуализации большого числа переменных - это хорошо, конечно. А как быть в случае, если при этом необходима работа TagLogging, к примеру? При необходимости архивации 2.000 тегов на том же сервере разбиение их на 20 кадров по 100 тегов ничего не даст в плане загрузки - TagLogging-то будет инициировать свои запросы к DataManager'у, на все 2.000 штук :-(.

И, кстати, у AlarmLogging'a разве другой принцип? Т.е., имеются analog alarms для тех же 2.000 тегов, к примеру. Для того, чтобы зафиксировать alarm message по любому из них, аларм-логгингу необходимо опрашивать все 2.000, вне зависимости от того, сколько выведено на текущий экран. Или это реализовано как-то по-другому?
Re: Как организовать асинхронную связь между PLC и SCADA?
Чистяков Дмитрий ОАО СеверСталь; 7.5.03

У TagLogging и AlarmLogging действительно другой принцип связи.

Я так понял, Вы хотите сделать на базе WinCC обычный самописец?
Тут стоит отметить, что разбивать ничего не потребуется - сетевые службы сами разобьют посылки на несколько кадров. Только вот тут можно напороться на недостаточность быстродействия канала связи.
С какой частотой Вы предполагаете записывать данные?
А может Вам для этой цели будет удобнее использовать специализированные для этого системы?
Например, IBA. www.iba-germany.com

Re: Как организовать асинхронную связь между PLC и SCADA?
Евгений Трунов; 8.5.03

Под "разбиением на кадры" имелось в виде не разбиение на сетевые пакеты, а разделение на 20 мнемосхем (кадров) по 100 тегов. В теории в каждый момент времени будут запрашиваться только те 100 тегов, м/схема с которыми открыта на этот момент. Это от Graphic-subsystem. А наличие Tag- и Alarm-logging подсистем сводят идею на нет :-(.

А какой может быть иной принцип? Простейший случай - таг-логгингу необходимо архивировать X тегов с интервалом в T секунд. Для этого он должен иметь на момент архивации срез переменных с мгновенными реальными значениями, полученный от DataManager'a. Вне зависимости от того, когда в последний раз они запрашивались другими подсистемами.

Аларм-логгингу, для регистрации отклонения аналогового параметра, необходимо это самое отклонение зафиксировать. Вот тут можно и "по инициативе контроллера", при том, что аналоговые значения меняются в каждом цикле :-).

Самописец - да нет, не совсем. Просто если уж параметр заслужил право отображаться, то он с вероятностью 90% заслужил и право быть сохраненным для потомков, и сигнализировать о своих проблемах.

По поводу быстродействия канала связи - это перекликается с моим же :-) вопросом от 07.05.2003 о примерных расчетах такого быстродействия при проектировании системы.


text

Диагностика, что ли...
Кирилов Владимир; 5.5.03

Уф…. Перестал запускаться AlarmLogging говорит: «к базе подключиться не могу…»

Причем, если предварительно выполнить просто тест DSN из ODBC Administarator’a то в следующий раз WinCC грузится просто зашибись… Проделал все шаманские заклинания, какие только нашел на форуме: галочку ReadOnly на папке туда-сюда, галочку AlarmLogging в свойствах проекта туда-сюда, проект на другую машину скопировал, имя компьютера в проекте WinCC туда-сюда – ну ниче не помогает…. WinCC не переставлял, так как этот проект на всех машинах себя также плохо ведет…-везде, что ли переставлять..:) Чушь какая-то, надо пойти выспаться… Короче, замучился совсем, а тут еще время от времени начало выскакивать окошко от проги SdiagRT.exe – (в WinCC/bin есть такая, там еще иконка со шпионом) - говорит, мол «WCD-Server Service у вас запущен» - это еще что за зверь??? Судя по названию диагностика какая-то??? Inet поиск ничего не дал. Попробуйте сами запустить этого зверя при работающей WinCC - очень интересно. Может на форуме есть кто-нибудь поумнее, чем Google? Плиз, доки, или хотя бы ваши соображения.

Re: Диагностика, что ли...
Александр,СКТЦ; 6.5.03

http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1045810003&year=2003


text

? Работа с OLE-Control`ом - ListBox в скрипте Graph Designer`а
Шимолин Сергей; 8.1.02

Работаю с ListBox`ом в экранной форме. ListBox с возможностью выбора многих строк (MultiSelect). Так вот, не могу программно (из скрипта) установить Выделение для некоторой строки ListBox`а. Вроде должно устанавливаться через :

ListBox->Selected(i) = TRUE;
но выводит ошибку - недоступно свойство Selected. Может кто работал с ListBox`ом и есть какие-нибуль решения?

Спасибо.
Re: ? Работа с OLE-Control`ом - ListBox в скрипте Graph Designer`а
Игорь; 12.1.02

Свойства оле объектов

устанавливаются через какую то функцию Set..... где указываетс графический объект и свойство, где то в документации есть пример
Re: ? Работа с OLE-Control`ом - ListBox в скрипте Graph Designer`а
Евгений Трунов; 15.1.02

Проблема доступа к свойствам очень многих OLE-объектов в Global Script в том, что в большинстве методов этих объектов (особенно компоненты от МС) параметры передаются по ссылке, что невозможно в стандартном С. Корректное решение данной проблемы мне неизвестно. Возможно, что-то на эту тему указано в ODK.

Работа со свойствами в С++/VB стиле вообще практически невозможна, т.к. по своей сути реализация понятия "property" в С очень затруднена. Только через set\get.
Re: ? Работа с OLE-Control`ом - ListBox в скрипте Graph Designer`а
Сергей Шестаков,"Профиль"; 25.1.02

Я достучался до свойств многих таких компонентов. Это подобно открытию объекта, например, в MS Excel. Если нужны подробности, пишите, постараюсь ответить.

---------------------------------
Re: ? Работа с OLE-Control`ом - ListBox в скрипте Graph Designer`а
Programmist; 7.3.02

На основе ОСХ можно сделать свой ОСХ,

свойства и методы которого доступны.
Если нужны подробности, пишите, постараюсь ответить.

Re: ? Работа с OLE-Control`ом - ListBox в скрипте Graph Designer`а
Dmitry Kashulskiy; 6.5.03

Всё очень просто. Надо менять свойство

ItemIndex

Какое значение присвоешь, такой же пункт и выделится:

ListBox1.ItemIndex:=0;


text

WinCC & ActiveX?
Lidiya; 30.4.03

ActiveX написан на Delphi 6 (Windows NT), в WinCC работает нормально. Переношу проект на другую машину c Windows 2000 Server и WinCC не видит ActiveX-объект. Подскажите, в чем проблема?

Re: WinCC & ActiveX?
Александр Шестаков; 30.4.03

Проблема в том, что на другой машине необходимо зарегистрировать даннай ActiveX c помощью regsvr32.exe утилиты, которая имеется на любом компьютере, передав имя ActiveX компонента в качетсве парамерта. Также его можно зарегистрировать в системе из

графического дизайнера (для WinCC 5.0 b выше).
Re: WinCC & ActiveX?
Lidiya; 30.4.03

Нет, я его уже зарегистрировала с помощью данной утилиты regsvr32.exe, однако WinCC все равно не видит этот компонент. В чем еще может быть проблема?

Re: WinCC & ActiveX?
Lidiya; 30.4.03

И еще. Графический редактор автоматически закрывается при попытке вставить эту ActiveX.

Re: WinCC & ActiveX?
Лев Шерешевский; 30.4.03

Похожая проблема в свое время обсуждалась на форуме control.com. Посмотрите ссылку, возможно, какие-то сведения окажутся полезны.

А вообще, о проблемах использования в WinCC написанных в Delphi компонентов, говорят достаточно часто.
См. Delphi-created ActiveX controls in WinCC

Re: WinCC & ActiveX?
Александр Шестаков; 1.5.03

А все ли связанные с ActiveX-компонентом библиотеки (OCX или DLL) ты перенесла на другой компьютер (если есть таковые)?

Re: WinCC & ActiveX?
Александр Шестаков; 1.5.03

Кстати, я рекомендую писать ActiveX-компоненты для WinCC на Visual Basic. Т.к. из моего опыта все компоненты написанные на VB замечательно работают в WinCC без всяких проблем.

Re: WinCC & ActiveX?
Александр Камакин; 6.5.03

Временный выход из создавшейся ситуации я нашел, установив среду Delphi на станцию оператора, работающую под Win2000. Предварительная установка MS Office 97 и ХР, на что были основные подозрения, не решила данной проблемы.

Кстати, с компонентами, сделанными в Delphi 7 - то же самое: видимо, какая-то инсталляционная библиотека Borland^овской реализации требуется...

Да, еще по прошлым проектам: некоторые ActiveX объекты упорно не желали появляться на мнемосхемах Genesis 6.0, работающих под управлением WIn2000 Server из-зи отсутствия в разделе реестра, отвечающего за регистрацию ActiveX компонента, ключа Insertable - может, и здесь что-то подобное!


text

Синхронизация времени
Олег; 4.5.03

Как синхронизировать время WinCC (то есть PC) и время слот контроллера CPU412-2 PCI. Надо чтобы PC был мастером, а CPU - слэйвом.

Re: Синхронизация времени
Олег; 4.5.03

Других CP в компьютере нет. По этому стандартная программа синхронизации не хочет работать.

Re: Синхронизация времени
Чистяков Дмитрий "СеверСталь"; 5.5.03

Тогда сделай в WinCC тэги времени (часы, минуты, секунды и т.д.), передавай их из CPU412, взяв системное время.

В Global Script воспользуйся стандартными функциями C для установки системного времени. Ну, и задай цикл вызова этого скрипта, с которым хочешь синхронизировать время.


text

Как заставить работать WinCC с диска CD-Demo
Student; 20.4.03

Установил под W2k SP3 ДЕМО-версию WinCC 5, но она вылетает сразу после запуска... Как заставить работать? Может дело в том, что при установке нужно ввести серийник (для демо-версии???), на диске его не нашел?

Заранее благодарен.
Re: Как заставить работать WinCC с диска CD-Demo
Чистяков Дмитрий "СеверСталь"; 21.4.03

Какая версия WinCC?

По Win2k WinCC работает только начиная с версии 5.0 + SP2.

Re: Как заставить работать WinCC с диска CD-Demo
Student; 21.4.03

Версия 5.1

штука в том что она ставится нормально, но после запуска почти сразу вылетает

Re: Как заставить работать WinCC с диска CD-Demo
Хоружевский Роман; 28.4.03

Поробуй переустановить Win2k у меня тоже такой глюк был, после переустановки все заработало. Иногда софт встает криво вот и глючит.

Re: Как заставить работать WinCC с диска CD-Demo
Дмитрий; 3.5.03

Все дело в SP3. Установите Win2K SP2, все будет нормально. С этим мы уже боролись.


text

WinCC & ActiveX?
Lidiya; 30.4.03

ActiveX написан на Delphi 5 (Windows NT), в WinCC работает нормально. Переношу проект на другую машину c Windows 2000 Server и WinCC не видит ActiveX-объект. Подскажите, в чем проблема?

Re: WinCC & ActiveX?
Илья; 30.4.03

Чтобы можно было обратиться к любому СОМ-объекту - необходимо его зарегистрировать в системе (прописать в Registry). Обычно это делается regsrv32.exe


text

обновление User Archives Table Element
Lidiya; 30.4.03

Обновление данных в User Archives - Table Element происходит очень медленно. Можно ли принудительно вызывать обновление Table Element? Задать время обновления?


text

Изучение SCADA
Alex; 8.4.03

Здравствуйте, я студент технического университета

Моя дипломная работа "Разработка учебно-методического комплекса по изучению систем SCADA"
Знаю GENESIS32, Genie, FactorySuite, Trace Mode. Помогите найти учебник по SCADA в html формате (в электронном виде). Как можно получить демоверсию MasterSCADA? (послал анкету и тишина)
Пишите burilin.alexei@inbox.ru
Fank you for co-operation
Re: Изучение SCADA
Любитель Симатика; 8.4.03

Ндяяя....перефразируя вопрос, дайте нахаляву дипломную работу! ;-) Извини за резкость. Ты-ж должен такой учебник написать, а не искать его! Хотя я не представляю как ты сможешь такую штуку сделать. Если серьезно, я думаю такого учебника нет и создать его невозможно или архи-трудно. Можно сделать обобщение по функциям SCADA систем, но внутренности систем разных производителей отличаются очень намного и особенности создания проектов, я уж не говорю о фокусах, абсолютно уникальны. Выбери одну систему и напиши о ней. Иначе получишь простой обзор/сравнение SCADA систем разных фирм, которые можно найти в любом журнале.

Кстати, а что за MasterSCADA? Кто производитель? Первый раз слышу.
А WinCC почему в расчет не берешь? Тоже SCADA, от Сименса(инфу см на этом сайте). Свои особенности и свои баги конечно, но работает ведь народ.
Удачи в дипломе.
Re: Изучение SCADA
Iva; 9.4.03

MasterSCADA - это творение фирмы ИнСАТ.

Занятная штука - Trace Mode и рядом не стоит.
Re: Изучение SCADA
Alex; 30.4.03

Всем спасибо

Теперь у меня аж два демо-диска MasterSCADA.
SIMATIC WinCC знаю уже давно.
Теперь самое главное научить студентов


text

Связь WinCC и Excel по сети
Хоружевский Роман; 27.2.03

Есть ли возможность организовать на WinCC такую схему:

На рабочей станции WinCC крутится проект, на другой машине установлен Excel, обе
машины в сети. Нужно из Excel управлять булевым тегом в WinCC.
Re: Связь WinCC и Excel по сети
Л. Шерешевский; 27.2.03

Да, такая схема реализуема. Наиболее простой вариант -- по NetDDE. Пусть, на компьютере ExcelWks ячейку Excel R1C1 (то же самое, что A1) необходимо связать с тегом (например, unsigned int) TagR1C1 WinCC проекта, запущенного на компьютере WinCCWks. Для этого необходимо

1. На компьютере ExcelWks
Запустить ddeshare.exe
Создать разделяемый ресурс DDE, например TestDDEtoWinCC.
В свойствах DDE-ресурса для варианта Static задать
Application Name = Excel,
Topic Name = <Имя_Вашего_Excel_файла.xls>
При необходимости скорректировать права доступа.
Проверить, что в Excel не стоит флажок "Игнорировать DDE-запросы от других приложений"

2. На компьютере WinCCWks
В проект добавить канал Windows DDE
Для этого канала задать
Computer Name = ExcelWks
Topic = TestDDEtoWinCC
Для данного канала создать тег TagR1C1 и адресовать его к нужной ячейке листа Excel:
Item Name = R1C1.

Протестировано в следующей конфигурации:
Windows 2000-Eng SP3, WinCC 5.1 HotFix2, Office 2000-Rus SR-1.

См. Центр компетенции WinCC

Re: Связь WinCC и Excel по сети
Хоружевский Роман; 29.4.03

Все получилось спасибо Лев.


text

глобальные переменные/константы в WinCC
иван жуков; 28.4.03

В Си-actions меняю цвета элементов на экране. Чтобы легко изменить цвет всех элементов, завел макросы в своем файле определений (defines) который включаю в apdefap.h Предполагалось, что если я только в этом файле изменю определения, то при выполнении скриптов цвета будут заменены на новые. Конечно, этого не произошло: нужно перекомпилировать все скрипты на всех элементах. Так вот: можно ли эти цвета задавать глобально не defin'ами, а глобальными переменными или константами, так чтобы не требовалось перекомпиляции всех скриптов?

Re: глобальные переменные/константы в WinCC
Лев Шерешевский ; 28.4.03

С событием открытия стартовой экранной формы можно связать С-action, в котором создаются и инициализируются обычные переменные С, описывающие нужные цвета. Во всех остальных скриптах достаточно описать те же переменные с атрибутом extern.

Альтернативный способ - хранить цвета в тегах (работать будет медленнее).
Re: глобальные переменные/константы в WinCC
иван жуков; 29.4.03

> С событием открытия стартовой

> экранной формы можно связать С-
> action, в котором создаются и
> инициализируются обычные переменные
> С, описывающие нужные цвета. Во всех
> остальных скриптах достаточно описать
> те же переменные с атрибутом extern.

Это то что надо. Только где привязка таких actions производится? Вроде бы только по изменению тегов и по таймеру они запускаются. Или там какой-то специальный тег есть, который на старте изменяется? (Я конечно понимаю, что где-то в документации есть пояснения, но очень долго искать придется...)

Re: глобальные переменные/константы в WinCC
иван жуков; 29.4.03

вот я нашел событие Open Picture, оно определяется для каждого экрана. Получается переменные/константы надо в скрипте, прикрепленном к событию, определить? А не будут эти определения между собой конфликтовать?

Re: глобальные переменные/константы в WinCC
Лев Шерешевский; 29.4.03

Да, надо использовать событие OpenPicture и в связанном с ним скрипте определить и инициализировать переменные (без модификатора extern!). Как правило, в любом проекте есть стартовая экранная форма, которая открывается ОДНАЖДЫ в самом начале работы системы. Если в Вашем случае это не так, можно придумать еще какое-либо ухищрение.

Re: глобальные переменные/константы в WinCC
иван жуков; 29.4.03

вот я нашел событие Open Picture, оно определяется для каждого экрана. Получается переменные/константы надо в скрипте, прикрепленном к событию, определить? А не будут эти определения между собой конфликтовать?


text

как считать текущую запись из User Archives - Table Element ?
Lidiya; 7.4.03

Добрый день.

1. Отображаю данные в User Archives - Table Element. Есть ли возможность работать с указателем Table Element? Н-р, считывать поля выбранной записи в форму для редактирования, не используя стандартную панель Table Element.

2. Мне необходимо динамически заполнять TextList значениями из таблицы User Archives. Как это можно сделать?

Re: как считать текущую запись из User Archives - Table Element ?
Кирилов Владимир; 8.4.03

> 2 Мне необходимо динамически заполнять TextList значениями из таблицы User Archives. Как это можно сделать?

Сам не пробоваол, но вообще-то в Help'e написано, что "The ASSIGNMETS attribute cannot be made dynamic"

Re: как считать текущую запись из User Archives - Table Element ?
Lidiya; 8.4.03

Так что средствами WinCC нельзя сделать обыкновенный список (динамически заполняемый)?

Re: как считать текущую запись из User Archives - Table Element ?
Кирилов Владимир; 9.4.03

Ну если уж "совсем" надо :), то, пожалуй, можно - если не использовать WinCC'овый TextList, а подключить левую компоненту.

Re: как считать текущую запись из User Archives - Table Element ?
Lidiya; 28.4.03

Обновление данных в User Archives - Table Element происходит очень медленно. Можно ли принудительно вызывать обновление Table Element? Задать время обновления?


text

WinCC и два монитора
Алексей Светличный; 10.4.03

Кто нибудь пробовал работать в WinCC с двумя мониторами? Судя по документации всё необходимо использовать Basic Process Control но вся эта документация умещается в несколько строчек. И всё благополучно не работает:(

Re: WinCC и два монитора
Alexis; 10.4.03

Все благополучно работает :)

А что именно интересует?
Re: WinCC и два монитора
Алексей Светличный; 11.4.03

WinCC 5.1 Создаю новое приложение. Запускаю Split Screen Wizard указываю разрешение и размещение мониторов. Потом отрабатываю конвератцию нужных файлов и библиотек как указано в документации. После этого запускаю приложение. Выводится только одно окно на основном мониторе. Второй остаётся пустым.

Re: WinCC и два монитора
Alexis; 11.4.03

А десктоп виндозы правильно сконфигурен? То есть если ты собираешься использовать два монитора горизонтально расположенных, то соответственно в виндозе у тебя десктоп тогоже размера, например (1280*2)х1024. И проверь, что гнусный скрин-сплит-менеджер тебе правильно создал @screen.pdl, те его размер тоже (1280*2)х1024. Соответственно картинка выводится фулскрином, хотя все должно на автомате сконфигурится.

У меня все работает, WinCC51, видюха MatroxG450DualHead. Проверял и под NT4 и под W2K.
И вообще BasicProcessControl must die! Стоит бешеных денег, а из него все равно все только сплит и используют...
Re: WinCC и два монитора
Любитель Симатика; 11.4.03

Не согласен!!

BasicProcessControl рулит!!!
Как насчет PictureTreeManager и автоматической навигации по нему, а?
А автоматическое создание всех системных картинок? А как насчет готового системного интерфейса? А генерация системных алармов?
А мелочей скока еще...
Так что ИМХО поклеп лишний.
Re: WinCC и два монитора
Алексей Светличный; 11.4.03

Вот при такой конфигурации всё как раз работает на ура. Просто тут недавно получили демо-версию WinCC 6.0 так товарищ, который с ней игрался, говорит там без проблем получается работь когда в винде два монитора Но десктоп 1280х1024 а второй монитор юзается как расширение десктопа. Работать в такой системе, конечно, несравненно удобнее.

Re: WinCC и два монитора
Alexis; 11.4.03

2 Любитель Симатика:

Энто все можно сваять ручками, причем быстро и гораздо качественней.
Не понятно почему Сименс не оставит в составе BPC только элементы управления своими технологическими блоками - все равно они у них убогие, а все остальное внедрить в WinCC на постоянку...

2 Алексей Светличный:
На счет WinCC6 пока ничего сказать не могу. Помню что на уровне pdl-ек новый SSM генерит тоже что и старый, но поиграться с двумя мониторами не успел :(
Re: WinCC и два монитора
Чистяков Дмитрий "СеверСталь"; 14.4.03

В версии 6.0 BasicProcessControl входит в базовый пакет.

Re: WinCC и два монитора
Шестаков Александр; 27.4.03

Я сейчас заканчиваю проект где используется двухмониторная система. Надо сказать что все работает нормально (Win 2000, WinCC 5.1). Единственное, неудобство как было сказано выше, это разрешение по формуле x*2 x y. В результате все системые сообщение (например, с использованием MessageBox)появляюстя по центру. Пришлось обходить это. И кстати, карточку Matrox G450 DualHead не рекомендую использовать, т.к. разъем для второго монитора крепится к плате видеокарты через ненадежный разъем (мы на этом обожглись). Лучше уж использовать G400. А вообще, если уж говорить о поддрежке в WinCC для двухмониторной системы, то это первый и последний раз когда я ее использую. Если выгорит еще проект с двухмонитроной системой, то буду писать что-то свое.

Re: WinCC и два монитора
Alexis; 28.4.03

2 Шестаков Александр:

На счет MessageBox по центру - в настройках у Matrox-а можно указать что-бы он всплывал на том мониторе, где в данный момент находится мышь.


text

CreateListbox
Игорь Од; 15.4.03

В SIEMENS\WinCC\documents\english\

есть wizardoвский файл demo.wnf.
При просмотре коего обнаружил вызовы функций CreateListbox,CreateStaticBox и т.д. Внимание вопрос-
Может кто подскажет могу ли я таким же способом создавать и работать в своих pdl файлах c данными компонентами. Сходу не получилось.

Re: CreateListbox
Александр Шестаков; 27.4.03

Эти функции касаются только создания окон диалога визарда и в dpl-файлах их использовать нет никакой возможности. Если тебе необходимо использовать данные компоненты, а также другие стандартные компоненты, то быстро и просто их можно использовать простой вставки ActiveX компонентов, или написав обвертку (для придания необходимой функциональности)для данных компонентов на VB или VC++.


text

Русские кодировки в архивах ProTool
Lucky; 21.4.03

При архивировании Alarm, System and Event сообщений в создаваемом csv файле слетает кодировка русского языка и текст отображается некорректно (ProTool Pro CS 6.0, Runtime 6.0 ), хотя тексты сообщений отображаются в Runtime без проблем.

Может кто-либо сталкивался с подобным и нашел способ решить проблему? Архив открывался Excel,Notepad.
Заранее спасибо.


text

Национальные языки для ОП7
Андрей; 14.4.03

Как сделать так, чтобы ОП7 по-человечески поддерживал бы русский язык (866-ю или 1251-ю страницу) и, главное, не конфгурированые Сиеменсом языки (например, украинский, эстоский и т.д.) Когда-то национальные языки можно было конфигуриривать для Protool с помощью утилиты Prosave, но с версией Protool 6.0 SP2 они работают некорректно (т.е. в Protool все нормально, но на ОП7 получается абракадабра).

Re: Национальные языки для ОП7
Илья; 21.4.03

Скорее всего вы что-то не так дклаете. На ОР7 нет НИКАКИХ ПРОБЛЕМ с русским языком


text

Печать из WinCC
Александр; 19.4.03

Не подскажете, можно ли динамически (программно) задать временной диапазон (произвольно, а не в привязке к текущему времени) для печати графика в объекте Dynamic Metafile ?

Re: Печать из WinCC
Оганесян Юрий; 21.4.03

Ха-ха-ха...

http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1044712660&year=2003


text

Protool and Runtime --help me
Андрей; 19.4.03

Правильно ли я понимаю, что при проектировании и использовании панелей операторов SIEMENS , например OP27 нужен только пакет разработки PROTOOL/PRO, а PROTOOL/PRO RUNTIME с лицензией на определенное количество тегов не надо ???

Заранее благодарен

Re: Protool and Runtime --help me
Андрей В.; 20.4.03

Для проектирования OP27 нужен только ProTool Pro CS, а ProTool Pro RT нужен для большинства Windows-Based систем и начиная с V6.0 для имитации Windows-Based систем.(OP170, MP270/370,TP270/OP270 и т.д.)


text

WinCC&ActiveX
Lidiya; 18.4.03

Как в WinCC вызывать методы ActiveX компоненты?

Re: WinCC&ActiveX
Лев Шерешевский; 18.4.03

Примерно так:

#define GetObject GetObject
__object* pPDLRT = NULL;
__object* pPicture = NULL;
__object* pObject = NULL;
pPDLRT = __object_create("PDLRuntime");
printf("pPDLRT %x\r\n", pPDLRT);
if ( pPDLRT )
{
pPicture = pPDLRT->GetPicture(""); // "": stands for the current picture
pPicture = pPDLRT->GetPicture(lpszPictureName);

// If the OCX is contained in another
// picture, then you have to fill in
// the name of that picture.
if( pPicture )
{
pObject = pPicture->GetObject("Control1"); // The name you gave the OCX within WinCC

if(pObject)
{
if (pObject->Visible)
{
pObject->Enable(1); // 1: enable operation
// 0: disable operation
}
__object_delete(pObject);
}
__object_delete(pPicture);
}
__object_delete(pPDLRT);
}


text

Как изменить перекрытие объектов в WinCC
иван жуков; 17.4.03

Извиняюсь за возможно тупой вопрос, но не нашел в документации ответа:

Предположим, я создаю новый графический объект на экране (например, закрашенный прямоугольник); теперь если я буду перемещать прямоугольник по экрану, он всегда будет перекрывать предварительно созданные объекты; а мне нужно поместить его в качестве фона для этих объектов, чтобы они отображались поверх прямоугольника. Посоветуйте, как это сделать?

Re: Как изменить перекрытие объектов в WinCC
Костенич Дмитрий; 17.4.03

А layer тебе на что существует?!! Пихаешь свой прямоугольник в, скажем, нулевой слой; все остальные объекты распихиваешь по слоям с первого и выше (или все в один). Собственно и все...

Re: Как изменить перекрытие объектов в WinCC
Владимир; 17.4.03

В графичеком дизайнере меню

Arrange - Within the layer - Place on Top / Place on Bottom

Удачи :-)


text

WinCC и DataGrid
Алексей Светличный; 8.4.03

Коннекчусь к внешней базе данных через ADO. Всё работает замечательно, данные выбираются, но возникает проблема в отображении этих данных в WinCC. Использовать для этого обычный Grid довольно долго и хлопотно.:(

Кто-нибудь использовал для этой цели ActiveX-компоненты? Такие как DataGrid, DBGrid, MSFlexGrid или что-нибудь подобное?
Re: WinCC и DataGrid
Евгений; 8.4.03

Для отображения и различных опираций с БД (сортировки, выборки и т.д.) писался и прекрасно использовался Active-X компонент в виде формы.

Re: WinCC и DataGrid
Алексей Светличный; 9.4.03

А поподробнее можно? ActiveX писАлся самостоятельно ручками или использовалось что-либо готовое? А с выше названными компонентами, я так понимаю работать неполучится:( Т. к. Siemens, судя по всему, понимает стандарт ActiveX несколько по своему, и поддержки COM/OLE интерфейсов в WinCC нет как таковой:( Ы?

Re: WinCC и DataGrid
Iva; 9.4.03

Зря ты гонишь на Siemens - что что а уж стандарт ActiveX в WinCC работает как надо. И свои контролы вставлял и чужие использовал - проблем не было. Другой вопрос что вышеназванные элементы возможно написаны криво. Попробуй вставить их в VB и посмотри разницу с WinCC. Дело в том что если в контроле интерфейсы реализованы не через IDispatch то WinCC их не понимает.

Re: WinCC и DataGrid
Алексей Светличный; 10.4.03

Разница состоит в том что в VB эти компоненты должны нормально работать, по крайней мере согласно документации. А вот в Visual C++ всё работает без каких либо проблем.

Re: WinCC и DataGrid
Шимолин Сергей, ОАО "УМЗ"; 16.4.03

По поводу ActiveX - делал собственный ActiveX на машине разработки всё нормально работает. Ставлю, регестрирую на машине-клиенте WinCC появляются проблемы - не видит объект. Устанаил Delphi на клиентскую машину (ActiveX в D7 делал) - компонент заработал, удалил Delphi - опять пропал. Может кто сталкивался, библиотеку какую-нибудь подтянуть нужно?

По поводу DBGrid - завернул приложение (окно с таблицей, ADO-подключением, и всякими кнопками) в DLL-ку, а из WinCC уже с библиотекой DLL гораздо проще работать чем с ActiveX-ми и ничего регестрировать не надо.

Re: WinCC и DataGrid
Алексей Светличный; 17.4.03

2 Шимолин Сергей: Скорее всего, что-то забыл подтащить. Но тут надо знать что за компонент ты писал. Ты строковые переменные не передаешь ему случайно. Т.к. у Делфей с этим был напряг, в худшем случае прийдётся таскать за собой BORLNDMM.DLL. Но это можно и обойти. И таких глюков может быть много.


text

ProSave V6.0_SP2
Андрей; 11.4.03

Как сделать BackUP с помощью ProSave если OP7 (C7-633P) не переводиться в режим 'transmit' (отсутствуют стандартные экраны, и исходный проект для ProTollCS). А на других экранах ProSave показывает что нет связи с ОР.


text

HResult Error
Александр Туманов; 1.8.02

Пытаюсь открыть свои проекты - получаю ошибки HResult Error: "0х2 Не удаётся найти указанный файл" и "0х80046206 (null)". Переставил Windows и WinCC - тот же результат. Что делать?

И это после того как я внедрил кучу проектов.
Re: HResult Error
SDolganov; 2.8.02

Было у меня такое чудо. В моем случае все оказалось просто: комп на котором делался проект имел в составе сетевую кару(изернет в смысле) а рабочая станция на которую проект перенесли нет. Проблема решилась установкой на рабочей станции "петли сам на себя" тобиш эмуляции сетевой карты. И на сладкое :) Не работает эта схема если в свойствах сетевого подключения не поставить галку на "отображать значек подключения в системном трее". Попробуйте может получится =)

Re: HResult Error
Костенич Дмитрий; 13.8.02

У меня такая фича случилась после перехода на WinCC 5.0 SP2 при попытке открыть/создать проект на диске с FAT32. Мосовский Siemens на это рекомендовал создавать проекты на "родных" для NT файловых системах (т.е. FAT16 и NTFS)

Re: HResult Error
SDolganov; 16.8.02

Да кстати, я про это забыл. Причем уродская особенность если диск не преобразован в NTFS при установке виндовс то последующее преобразование результатов не дает.

Re: HResult Error
Eugene; 21.8.02

Вообще то ни сетевая карта, ни ее "эмуляция" не нужны. Переношу проекты с машины, на которой установлена сетевая карта, на машину без таковой - и все работает. Скорее всего вполне достаточно установить поддержку сети.

Re: HResult Error
Илья; 24.3.03

Народ помогите, нужен эмулятор сетевой

карты!!!!!!!! Киньнте на мыло если есть?
Re: HResult Error
Александр Туманов; 24.3.03

А для какой цели?

Можно воспользоваться PLCSim и коннектиться к виртуальному PLC как по MPI.

Re: HResult Error
Павел; 11.4.03

Переустановите Sybase 7


text

Связь Botec PC с S7-400
Андрей; 9.4.03

Кто-нибудь встречался с системой визуализации Botec PC используемой фирмой Steineker (Syskrone)? Подскажите, пожалуйста, каким образом в данной системе задаются связи с блоками данных программы, загруженной в контроллер S7-400.


text

WinCC и MatLab
Lambda; 8.4.03

Есть ли возможность передавать данные из MatLab в проект WinCC.

Re: WinCC и MatLab
Маслов Дмитрий; 9.4.03

Можно написать программку с использованием ODK, которая берет данные откуда угодно и кладет их в теги WinCC.


text

WinCC и DDE
Сергей; 21.1.02

Уважаемые участники форума!

Подскажите: возможно ли использование WinCC в качестве DDE-клиента со сторонними DDE-серверами. Система однопользовательская.
Пробовал сконфигуриарвать в демоверсии
WinCC 5 с Service Pack1 : безуспешно.

Re: WinCC и DDE
Юрий Оганесян; 22.1.02

В мануалах есть пример DDE- связи WinCC с Exell-ем

Re: WinCC и DDE
Сергей Шестаков, "Профиль"; 25.1.02

В добавление...

Да, действительно, в мануалах есть примеры, только к сожалению допущены либо опечатки, либо преднамеренные ошибки. Не всё работает, как написано. Пример связи через каналs Windows DDE c Excel лучше посмотреть в Help-ах Wincc 5 SP2

Re: WinCC и DDE
AllZ; 17.6.02

Использовали. WinCC5SP2HF7. Есть ограничение, не более 29 топиков. Ругались. Получили новый *DDE.chn. Гоняющий и не более 50 топиков.

Re: WinCC и DDE
Каменков Алексей; 10.2.03

Поддерживаю вопрос - хотелось бы доставлять данные в проект из Cogent Cascade Connect.

К сожалению, в мануалах достадочно подробно описано, как вставлять тэг из проекта в Эксел, но есть ли возможность записывать значения тэгов из сторонних приложений? И какие DDE Service/DDE Topic необходимо указывать?
К примеру - для InTouch это View/tagname. А что с WinCC?

Re: WinCC и DDE
Александр Туманов; 11.2.03

Успешно используем DDE-сервер фирмы "Взлёт" (опрашиваем их расходомеры). До этого стоял "родной" WinCC драйвер Modbus и те же датчики опрашивал крайне неудовлетворительно (очень медленно = далеко не в каждом цикле).

Re: WinCC и DDE
Gunter; 12.2.03

Успешно используем DDE-сервер разработанный на С++Builder 5 являющийся драйвером обмена с 7 контроллерами Ремиконт 110/130. 700 внешних тегов - опрос и управление.

Рекомендую WinCC -> 5.1.
Re: WinCC и DDE
Lambda; 8.4.03

Вопрос:

Необходимо передавать данные из MatLab в проект WinCC используя DDE канал, возможно ли это. Если возможно, то каким образом


text

копирование проекта
иван жуков; 7.4.03

Что-то никак не могу скопировать проект с машины на машину. Вернее, скопировать получается, но новая копия копия после этого не работает. Пробовал и папку копировать и задействовал утилиту project duplicator. Ничего не помогает: копию проекта не удается активировать. Выдается сообщение: The project can only be activated, if an available server has been entered in the computer startup tab [Проект может быть активирован если был осуществлен вход в доступный сервер в startup]? :-(

В чем тут дело?

Re: копирование проекта
Евгений; 7.4.03

Посмотри сетевое имя компьютера и в WinCC-Explorer измени старое имя на новое. Вот и все :)


text

MP 370 и CF card
Гусаков Константин; 7.4.03

Есть ли возможность сохранять реал-графики с панели на CF (compact flash)карту,для последующиго их переноса на ПК, с целью распечатки?

Заранее спасибо за ответ.


text

Когда происходит обмен с WinCC в цикле контроллера?
Иван Жуков; 26.3.03

Приветствую!

кто-нибудь знает, в какие моменты времени происходит запись данных в DB из WinCC? Ситуация такая: Есть блок DB1, к которому привязаны теги WinCC. Этот блок для обработки копируется в другой блок DB2, после того как обработка завершена, содержимое DB2 копируется обратно в DB1. Манипуляции с копированием и обработкой производятся в FC, вызываемой из OB1. Не спрашивайте, зачем это нужно - долго объяснять - говоря кратко, это делается для экономии памяти. Так вот: может ли оказаться так, что пока данные блока DB1 находятся в DB2, в этот момент вклинится обмен с WinCC, который обновит DB1, после чего DB2 будет скопировано обратно в DB1, при этом обновления сделанные WinCC в DB1 _БУДУТ_ЗАТЕРТЫ_?

Re: Когда происходит обмен с WinCC в цикле контроллера?
Чистяков Дмитрий "СеверСталь"; 26.3.03

WinCC использует прямой доступ коммуникационного процессора контроллера к памяти в CPU. Таким образом образуется свой цикл, который примерно равен циклу обмена по сети или (если мало данных) циклу, установленному на обновление тэгов.

Таким образом достигается асинхронная работа системы управления (контроллер) и системы визуализации. Что в свою очередь увеличивает надёжность этих систем по раздельности за счёт независимости одной подсистемы от другой.
Re: Когда происходит обмен с WinCC в цикле контроллера?
Иван Жуков; 28.3.03

Это плохо. И нет никакого способа ввести синхронизацию - т.е. программно со стороны контроллера регулировать доступ извне к его памяти? Хотелось бы, чтобы WinCC производила обмен не когда попало, а откладывала его до определенного момента (допустим пока не установлен какой-то бит). Такой возможности нет?

Второй вопрос: как работает процессор контроллера S7-300 - предположим я делаю операцию AND на каком-то байте в памяти, это будет операция атомарная? Т.е. может ли этот байт быть измененен внешним обменом с WinCC до окончания операции AND?

Re: Когда происходит обмен с WinCC в цикле контроллера?
Илья; 1.4.03

Есть разница в коммуникациях S7-300 (кроме 318 CPU)и S7-400. В 300 все коммуникации - по завершению цикла. В 400 коммуникации вклиниваются в выполнение программы. Бывает ситуация, когда народ пишет FB по обработке чего-либо и в параметр RESULT_VALUE пишет промежуточные значения. Этот параметр привязывается к тэгу WinCC. В результате у оператора периодически вылезают дебильные значения в этом тэге.

Re: Когда происходит обмен с WinCC в цикле контроллера?
Чистяков Дмитрий "СеверСталь"; 1.4.03

Ну, решается-то эта задача достаточно просто.

1. Создаём два DB.
2. Один DB используем в программе контроллера.
3. Другой для приёма данных из WinCC
4. А в конце (или начале) скана пересылаем один DB в другой при помощи SFC20.

Re: Когда происходит обмен с WinCC в цикле контроллера?
Илья; 7.4.03

Ну, наверное, лучше использовать SFC81 - она все-таки непрерываемая... А еще лучше читать книжечки, которые приходят с CPU - там написано КАКИЕ SFC-шки НУЖНО использовать в ДАННОМ цпу. Вот...


text

Визуализация
Александр; 4.4.03

Здраствуйте,у меня возник вопрос по поводу сообщений об ошибках и неисправностях линии управляемой двумя контроллерами <S7 400> одним <S7 300> + S7 200 c использованием порядка 30 станций децентролизованной периферии<ET200M> связб осуществляется по протоколу Profibus/dp и MPI

так вот...теперь по существу:)
на визуализации CARTA индицируются сообщения только от 2х S7400. Я сосвоей стороны могу создать блоки данных (DB)для записи в ячейки соответствующие сигналы от датчиков ЕТэшек и проч.но вот как мне потом эти сигналы читать с ячеек и... так сказать индицировать на мониторе рабочей станции?


text

выполнение скриптов при появлении сообщений в Alarm's
иван жуков; 3.4.03

Есть система алармов, собщения генерируются по фронту битовых тегов. Требуется выполнить некоторые операции (код Си) в момент возникновения сообщения, а также в момент его квитирования. Можно ли это организовать? Что-то по документации очень трудно понять. Подскажите также, есть ли где-нибудь более понятное описание работы с алармами в WinCC, чем имеющееся в документации.

Re: выполнение скриптов при появлении сообщений в Alarm's
Александр Родин, ООО "Нева Электрик"; 3.4.03

1. можно изменить код функции gmsgfunc.fct, лежащей в папке с библиотеками WinCC;

2. можно определить группы сообщений и назначить им статусные тэги, после чего вести отслеживание этих тэгов посредством GlobalScript-ов;
3. поищите информацию на http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&lang=en


text

преобразование типов
Игорь; 2.4.03

строку с числами надо перевести в тип

флоат
подскажите сишную функцию в WinCC
Re: преобразование типов
Iva; 3.4.03

sprintf

С целыми числами точно работает.
Насчёт float - не пробовал.

Re: преобразование типов
Александр Родин, ООО "Нева Электрик"; 3.4.03

double strtod (char* sourcestring, char** error);


text

связь с PLC
Игорь; 2.4.03

как сформировать и выдать сообщение оператору,

что нет связи с контроллером S7-300

Re: связь с PLC
Eugene; 2.4.03

Считываешь какой нибудь ТЭГ функцией GetTagStateWait('....') (или GetTagWaitState - не помню). Данная функция не только возвращает значение тэга, но и его состояние. Описание состояний в хэлпе есть. А сообщение вывести не составляет большого труда.


text

Господа, кто-нибудь использует SIMIT?
Александр Туманов; 1.4.03

SIMIT - это программно-аппаратные средства для имитации технологического процесса.

Re: Господа, кто-нибудь использует SIMIT?
Михайлин Сергей; 2.4.03

Это продукт департамента I&S. Насчет использования в России, скорее всего вряд-ли, хотя я тоже могу чего-то не знать. А что собсвенно хотелось? Кое какая информация есть у нас и кроме того есть официальный сайт.

См. Сайт SIMIT

Re: Господа, кто-нибудь использует SIMIT?
Любитель Симатика; 2.4.03

Ну посмотрел я; слишком сложно, накручено и наверняка дорого! По-моему, SIMBApro намного проше и эффективнее. У нас народ очень доволен ей. Всю периферию с сигналами ошибок и тд все можно с компа или программатора провести.

Re: Господа, кто-нибудь использует SIMIT?
Михайлин Сергей; 2.4.03

Забыл я про SIMBApro, точно. Тоже неплохой продукт, но он именно для имитации периферии, а не тех. процесса. Немного подробнее по имитации можно почерпнуть из каталога AddOns для PCS7 от 10/2002. Там кстати, оба продукта присутствуют.


text

WinCC & S5-115U
Dev; 28.3.03

Уважаемые участники форума! Помогите пожал-ста "теоретически" решить задачку.

Cуществует система автоматизации на базе контроллеров S5-115U (8 штук)объединенных в сеть на базе SINEC L2. Станции визуализации и оперативного управления морально и физически устарели и могут умереть в ближайшее время.
Вопрос: возможно ли применить станции WinCC для замены устаревших и какие коммуникационные процессоры (и программные драйверы каналов) для этого необходимы и достаточны.
Re: WinCC & S5-115U
Денис Дроздов; 1.4.03

А чего ж не можно - можно! Чем, например, я сейчас занимаюсь. А именно - замена некоего COROS LS-C на WinCC.

А Sinec L2 - это что? Просто Ethernet?
Re: WinCC & S5-115U
Чистяков Дмитрий "СеверСталь"; 1.4.03

Ответ уже мною был дан в другой ветке.

А для разъяснения и востановления истории скажу, что Sinec L2 - это родной папаша Profibus.
Многие устройства с этой сетью даже совместимы с современным Profibas`ом. Т.е. непосредственно подключаются к новым контроллерам.


text

Как прописать роутинг в WinCC ?
Руслан, ДМЗ; 28.3.03

Существует такая ситуация, есть компьютер с WinCC, который подключен к 400-сотому по ethernet, к которому подклбчен по profibus 300-сотый, можно ли сконфигурировать WinCC так чтобы он брал теги напрямую из 300-того без переброски их в 400-ый... спасибо...

Re: Как прописать роутинг в WinCC ?
Чистяков Дмитрий "СеверСталь"; 28.3.03

Так он такой роутинг у вас уже и имеется - т.е. путём пересылки данных из 300-ого в DB 400-ого.

А вот такого прямого, хитрого роутинга из одного вида подсети в другой нет.
Самый простой способ установить в машину с WinCC карту Profibus.
Re: Как прописать роутинг в WinCC ?
Любитель Симатика; 28.3.03

Напрямую, WinCC не увидит 300-ый.

Г-н Чистяков прав.
А вот если на этой машине стоит STEP7 то запрограммировать 300-ый через 400-ый с помощью роутинга можно. Очень здорово получается.
Re: Как прописать роутинг в WinCC ?
Александр Родин, ООО "Нева Электрик"; 31.3.03

Вообще-то подобный роутинг можно обеспечить посредством канала Named Connection, мне так кажется...

К сожалению, не помню адрес источника, где я подобное видел.

Как всегда - обращайтесь к разработчику. :)
По-моему, Михайлин Сергей из московского Сименса что-то подобное рассказывал на одном из семинаров.
Re: Как прописать роутинг в WinCC ?
Михайлин Сергей; 1.4.03

Нет. Мой рассказ к другому относился.

Такого рода роутинг в WinCC не пройдет.
Это только для программирования(PG функции). Но как уже сказал Дмитрий Чистяков, пересылка то из 300-ого в 400-ый должна быть, следовательно данные из 300-го попадут в WinCC через 400-ый.


text

Ошибочка в документации
Андрей; 28.3.03

Ошибка в документации http://www.automation-drives.ru/as/download/doc/simatic_hmi/protool/Appendix_r.pdf

стр. C-15 , кабель ОР-АТ РС.
пара RxD и TxD должна перекрещиваться, а не один к одному,а то соединяем передатчик с передатчиком, приемник с приемником, да и пара CTS и RTS тоже.


text

WinCC & S5-115U
Dev; 28.3.03

Уважаемые участники форума! Помогите пожал-ста "теоретически" решить задачку.

Cуществует система автоматизации на базе контроллеров S5-115U (8 штук)объединенных в сеть на базе SINEC L2. Станции визуализации и оперативного управления морально и физически устарели и могут умереть в ближайшее время.
Вопрос: возможно ли применить станции WinCC для замены устаревших и какие коммуникационные процессоры (и программные драйверы каналов) для этого необходимы и достаточны.
Re: WinCC & S5-115U
Чистяков Дмитрий "СеверСталь"; 28.3.03

В принципе достаточно приобресть в персоналку CP5613. А драйвера для неё имеются в комплекте с картой и в WinCC.

Как осуществить подключение можно прочитать в описании WinCC. В том числе и на русском языке.
Это описание имеется на этом сайте.


text

Как получить данные из dBase
LA; 17.3.03

Добрый день.

Нужно считать данные из БД dBase(*.dbf) в WinCC. Как это сделать?

Re: Как получить данные из dBase
Iva; 18.3.03

В ODK есть функции для работы с базами данных. Вызываешь их из скриптов - и все дела.

Re: Как получить данные из dBase
Lidiya_; 27.3.03

Создаю БД в MSAccess, прописываю DSN и пытаюсь открыть БД с помощью функций ODK DBExConnect и DBOpen. В результате к БД подключаюсь, а DBOpen выдает ошибку. При работе этих же функций с БД WinCC проекта все выполняется корректно. Подскажите в чем ошибка?

Re: Как получить данные из dBase
Alexis; 27.3.03

Ну наверное db.dll (до WinCC6) только под Sybase заточен...

Re: Как получить данные из dBase
Юрий Оганесян; 27.3.03

http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1041511877&year=

2003

И все более раннее на этом же форуме


text

Tag'и глючат
Олег; 27.3.03

Ситуация следующая:

WinCC5.1+Hotfix1,
Step7 V5.1+SP3
S7-PLCSIM 5.0+SP1+HF2
В WinCC есть внешний Тэг 32бита Unsigned, через него в контроллер (PLCSIM пока) передаются 32 дискретных сигнала управления. Причем часть из них обновляются в WinCC циклически в глобальной процедуре, а часть по событию (нажатие кнопок на экране).
Те переменные, которые обновляются циклически нормально доходят до контроллера, а "событийные" при нажатии кнопки либо передаются, либо не передаются, а очень часто начинают просто "мигать" с 0 на 1 и обратно с изменяющейся произвольно частотой и скважностью. Затем это может успокоиться, и установиться как в 0, так и в 1, независимо от состояния управляющего воздействия.
Ощущение такое, что значение внешнего тэга, обновленное по событию, отправляется в контроллер и одновременно считывается из него. Таким образом в разные моменты цикла обмена, измененное значение может затереться значением из контроллера, либо не затереться, либо произойдет многократный обмен значениями тэга между WinCC и контроллером, в результате - неопределенное поведение переменной, что недопустимо.
Останется ли этот зоопарк, когда я загружу проект в реальный контроллер S7-300 CPU316-2DP и свяжу его по Profibus с WinCC через CP5613?
Если да то как это лечится?


text

MicroComputing V1.0
Владимир; 27.3.03

Кто продаст ключевую дискету к MicroComputing V1.0. Или подскажите где можно найти крек. Заранее благодарен. Владимир.


text

td17 help pliz кто может.
zaz; 26.3.03

дело в том что я не могу залить в дисплей ничего, выдает 620-ю ошибку, а как исправить это .. темный лес, ничего в голову не приходит, заливаем Протулом, лайтом. если какому гуру не сложно, подскажите пожалуйста.

можно в асю 145559004

Re: td17 help pliz кто может.
Любитель Симатика; 26.3.03

Вот выдержка из доки по TD17.

Error 620
Cause
Illegal keyboard ID: too high module number or total number of keys differs from key-board ID.
Remedy
Enter configuration complying with hardware.

Вобщем несогласованность у тебя софта и железа.

Re: td17 help pliz кто может.
zaz; 26.3.03

спасибо конечно, но выдержку из доки я читал, а вот где согласовывать эту не согласованость не понятно..ProTool lite говорит что совместим с ТД17 да и в Siemense сказали что все ок будет когда брали, специально уточнили..


text

Где скачать ProTool 6?
angel; 21.3.03

Есть версия PROTOOL 5.2 + SP2 .....где скачать PROTOOL 6?

Re: Где скачать ProTool 6?
Чистяков Дмитрий "СеверСталь"; 21.3.03

Нигде не удастся.

Да и весит оно в сжатом виде 400 метров.

Re: Где скачать ProTool 6?
В. Сорокин.; 26.3.03

Есть у ООО СИМЕНС компакт про LOGO и S7-200 за 2002!!!! год (как всегда б. п. - тут они молодцы. В нём и сидит этот ProTool 6. Вроде рабочий (без авторизации конечно), сам поставил на днях и ещё не поковырялся. ProTool\Pro CS и RT там же. На пишите им, может пришлют.


text

Описание ошибок OP3, или структра программирования
Владимир; 25.3.03

Выявлена ошибка за № 531, без описания.

Надо определитьпричину ошибки.
Оборудование "новое"(старое, но для меня новое), надо запустить а описания нет.
Из-за этой ошибки стоит агрегат.
Может где естьт какая-тнибудь документация.
Буду бланодарен за содействие.


text

Лицензия ODK
Хлопин Денис; 21.3.03

Требуется ли для работы с ODK лицензионная дискета?

Re: Лицензия ODK
Iva; 21.3.03

Не требуется.

Подключай нужные библиотеки и вызывай функции - всё открыто.
Re: Лицензия ODK
Л. Шерешевский; 24.3.03

На самом деле для того, чтобы иметь право разрабатывать собственные приложения с использованием пакета ODK, его необходимо купить. Однако, так как покупается сам пакет, а не лицензия на его использование, ключевая дискета не требуется.

Заказной номер пакета ODK в каталоге 6AV6371-1CC05-0AX0, а стоимость (на границе Германии) - 2645 евро.


text

WinCC 5.1 и стандартные библиотеки С
Алексей Светличный; 20.3.03

Доброго времени суток!

Насколько я разбираюсь в медицине:) в WinCC все стандартные С функции обеспечивает заголовочный файл apdefap.h. Ни о каких stdio.h, stdlib.h, ctype.h, string.h и прочих он понятия не имеет.
Как быть в том случае если я использую стороннюю библиотеку в чьих заголовочных файлах прописаны stdio.h, stdlib.h и т. д? Вариантов я вижу два или попытаться подключить эти файлы или править библиотеку прописывая всюду apdefap.h.
Re: WinCC 5.1 и стандартные библиотеки С
Alexis; 24.3.03

Что-то я не понял, Вы .LIB-ы что ли подключить пытаетесь?

Если вы подключаете сторонюю .DLL, дык создайте хэдэр куда вставте только необходимые вам прототипы функций, либо не используйте заголовочный файл вообще - достаточно в скрипте стандартно #pragma с подключением длл-ки и необходимым описанием функций использовать.


text

Где скачать SP2 к ProTool 6
Ефременко Денис (НКМЗ); 23.3.03

Имеется Protool6 + SP1a

Неужели я не могу по Инету выкачать у немцев обновление sp2 бесплатно?
У них на сайте написано, что он не доступен для бесплатного download. Почему так?


text

Как на объект Siemens HMI Symbol Library прицепить всплывающую подсказку?
Роман Чуликов; 18.3.03

Входящие элементы в Siemens HMI Symbol Library не имеют свойства tooltiptext, вследствии чего нельзя выводить всплывающий текст.Что делать?

Re: Как на объект Siemens HMI Symbol Library прицепить всплывающую подсказку?
Маслов Дмитрий; 19.3.03

Разместите прямоугольник поверх этого объекта. Поставьте ему свойства

DynamicFilling = Yes;
FillLevel = 0.
В результате прямоугольник будет невидимым, но подсказка, которую Вы введете для него, будет отображаться.

Re: Как на объект Siemens HMI Symbol Library прицепить всплывающую подсказку?
Евгений; 19.3.03

Что влекет за собой приплод "лишних" объектов... :(

Re: Как на объект Siemens HMI Symbol Library прицепить всплывающую подсказку?
Роман Чуликов; 20.3.03

Спасибо за ответ, жаль немцы не додумали как без извращений выводить подсказку.


text

При запуске проекта, WinCC требует файл CSigRT
Ярослав; 19.3.03

CSigRT мы скопировали в каталог …\WinCC\bin\ все файлы, начинающиеся с CS…, но результата нет, т.к. проект загружается, но практически никакие графические кнопки не работают, и изображение не занимает рабочую область на экране, а дублируется кусками снизу и справа относительно основной картинки. Как же быть?

Re: При запуске проекта, WinCC требует файл CSigRT
Чистяков Дмитрий "СеверСталь"; 19.3.03

Не совсем понятно, а зачем эти файлы крпировать?

Они что при установке сами не появились?
Если просто сбой произошёл, то переустановите сверху ещё раз WinCC, да и всё.
Re: При запуске проекта, WinCC требует файл CSigRT
Ярослав; 20.3.03

Ок, попробую еще раз переустановить WinCC, может забыл какой-нибудь компонент. Правда не думаю что это поможет так как CSigRT не появлялся после установки. А на действующей системе он есть (вот поэтому я и копировал его вручную).

Re: При запуске проекта, WinCC требует файл CSigRT
Alexis; 20.3.03

А какая версия WinCC?

Не помню что было в четверке, но скоко проектов не делал (WinCC 5 и выше) всегда использовался CCCSigRTServer.exe


text

wincc
Виктор ; 18.3.03

Подскажите серийный номер для WinCC v5.0

Re: wincc
Чистяков Дмитрий "СеверСталь"; 19.3.03

А смысл?

Всё равно ещё и авторизация нужна.
Если она имеется, то в программе AuthorsW можно посмотреть Ваш номер.
А так вбивай любой 001010101

Либо demo для демо-режима.


text

WinCC сервер
Дроздов Д.Е.; 7.2.03

Нужно сделать сервер. Вопрос - на что ставить авторизацию серверную? Можно ли на рантайм? И сколько внешних тегов должно быть?

Re: WinCC сервер
Чистяков Дмитрий ОАО СеверСталь; 7.2.03

Авторизация сервера ставиться только на сервер.

На сервере же ставите авторизации на все пакеты, которые будете использовать в своём проекте. RT авторизация на столько тэгов сколько Вам надо в проекте.
На клиентах достаточно авторизации на 128 тэгов и более ничего.

Не забудьте, что WinCC-сервер работает, только в режиме файл сервера (ни каких контроллеров домена). При этом при работе под Windows NT Workstation и Windows 2000 Prof, поддерживается не более двух клиентов.
Для поддержки до 64-ёх (32 провереных) клиентов необходимы версии этих ОС Server.

Re: WinCC сервер
Юрий Оганесян; 8.2.03

Не знаю Вашу задачу, то настоятельно рекомендую рассмотреть вариант с использованием не "WinCC Server'а", а "Web Navigator Server'а". Мы его используем довольно успешно, чему и рады. Но, конечно, все зависит от задачи...

Re: WinCC сервер
Скиталец; 16.3.03

С контроллером домена тоже хорошо работает, WINNT4 Server в качестве контроллера домена проверено


text

modicon
Виктор ; 26.2.03

Можно ли связать WINCC и MODICON

Re: modicon
Юрий Оганесян; 26.2.03

Можно. Толстой веревкой и надежным узлом. :)

Можно через ихние OPC-сервера (предпочтительнее), а также у WinCC есть свои драйвера для Modbus'а и всего остального, что так любит Schneider. А вообще-то в доке по WinCC есть специально обученные таблицы возможных взаимосвязей. Ты бы вначале их посмотрел, а потом на форум писал.

Re: modicon
Скиталец; 16.3.03

OPC для шнейдера решает все проблемы, какие контроллеры модикон??


text

Скорость работы WinCC
Дроздов Д.Е.; 4.3.03

Проблема - на клиенте при смене картинок скрипты работают крайне медленно. Например, в зависимости от значения битового тега написать "да" или "нет", так вот срабатывание такого скрипта приходится ждать до минуты что неприемлимо. Везде скорость опроса поставлена на 500 мс и все равно тормозит.

Архитектура клиент-сервер, сервер только опрашивает контроллер.
Re: Скорость работы WinCC
Владимир; 4.3.03

Э-эх больное место.

Используйте Dinamic Dialog вместо
скриптов Cи
Re: Скорость работы WinCC
Дроздов Д.Е.; 5.3.03

Дык лицензию не купили...

Re: Скорость работы WinCC
Дроздов Д.Е.; 5.3.03

Ой... Гонюююю... Dinamic Dalog - суть те же скрипты генеряет, но тормозит так же.

Re: Скорость работы WinCC
Михайлин Сергей; 5.3.03

Опять я!!!

Минута это уже слишком!!!
Честно говоря мне уже кажется, что проблема не в WinCС, а в настройках сети и ее параметров. Даже на больших проектах клиент-сервер скрипты не работают так медленно.
А картинки кешированны на клиентах или нет? Их можно скопировать на клиентов для уменьшения трафика.(см. доку)
Re: Скорость работы WinCC
Денис Дроздов; 5.3.03

Да картинки и так на килентах...

Сетка на 10 Мбит и хрена ли там настраивать?
Кеширование картинок стоит стандартное - 30 штук, но теги-то онлайновые на сервере не кешируются никак!
Re: Скорость работы WinCC
Денис Дроздов; 12.3.03

Наконец-то вылезло! Здорово подтормаживает связь WinCC - Simatic S5. То ли контроллеры тормозные, то ли где затыки по сетке цеховой, короче тормоза. Что делать?

Re: Скорость работы WinCC
Aleks; 12.3.03

Причем здесь контроллеры S5 ?

Скорее всего нехватает "Ruki.dll" или "Mozgi.ocx"

Re: Скорость работы WinCC
Скиталец; 16.3.03

Если связь с S5 по AS511 то будет подтормаживать


text

Ошибка 8304
Linsky; 13.3.03

Реализована однопользовательская система управления с использованием MPI (сервер SIEMENS PC840 и CPU 315-2DP). Количество внешних тегов - 300. При работе WinCC врямя от времени пропадает связь с контроллером, в log'е отображается ошибка 8304. Что это за ошибка, как ее можно исправить и вообще, где можно найти раскодировки этих ошибок, т.к. в Help я не нашел ничего похожего.

Re: Ошибка 8304
Владимир; 16.3.03

На всякий случай проверьте соответствие размерностей запрашиваемых тегов и реальных адресов в контроллере (особенно тех, после введения которых начались сбои)


text

Русский язык в Win-CC
Евгений; 15.3.03

Здравствуйте, господа!

Случилась такая штука:
На объекте местные администраторы ставили свое ПО на рабочую станцию оператора (под Win2000). После этого в Win-CC пропал русский язык (все наименования полей в UserArchive, ToolTopText'ы и , свойства Configured Language в Graphic Designer и т.д.).
Подскажите, чего надо сделать, чтобы вернуть все на свое место?
С уважением, Евгений

Re: Русский язык в Win-CC
Евгений; 15.3.03

Извиняюсь, нашел в форуме ниже. :)

Re: Русский язык в Win-CC
Евгений; 15.3.03

Извиняюсь, нашел в форуме ниже. :)


text

Profibus DP & MPI & Profibus DP
Serih Andrey; 6.3.03

Такая возникла проблема, при объединении в сеть ProfibusDP трех ОР (ОР7, ОР7, ОР17), все панели видели сеть и нормально общались с контроллером. Поставили второй контроллер и соединили с первым по MPI, все осталось функционировать без проблем, как и должно быть. Возникла необходимость поставить еще одну ОР, при чем она должна была общаться с двумя контроллерами. Поэтому повесили ее на MPI, и начались проблемы, чтобы ни делали (перепробовали кучу вариантов которые как нить могли бы повлиять) сеть пропадала или на трех ОР, которые на ProfibusDP или на ОР27. Причем ОР27 переставала видеть только тот контроллер на котором висят ProfibusDP абоненты (там висели 6 Симорегов, микромастер, и три ОР). Решили эту проблему простым способом, просто посадили все ОР на MPI, но вопрос остался открытым, все таки непонятной осталась причина пропадания связи...

Кто встречался с аналогичной проблемой, что скажете? В чем собака порылась?

Заранее благодарю!!!
Profibus DP & MPI & Profibus DP
Serih Andrey; 6.3.03

Кстати пробовали повесить WinCC аналогичная ситуация, или WinCC видела контроллер, или три ОР...

Зато все остальные абоненты ProfibusDP сетей одного и второго контроллеров общались нормально(не выпадая из сети).

Re: Profibus DP & MPI & Profibus DP
Просто так; 7.3.03

Если у Вас контроллеры S7-300, то при добавлении 4-й ОР (или WinCC) превышается допустимое число статических соединений CPU. Всего допустимо подключать 1 PG и 3 OP/WinCC.

Profibus DP & MPI & Profibus DP
Serih Andrey; 15.3.03

Да серия 300, но почему тогда когда просто переключили на MPI и повесили два программатора WinCC и все четыре ОР все стало работать без проблем? То что написано гарантированное соединение с 1ой ОР и одной станцией WinCC, а работает реально больше станций на MPI.


text

теги для ОР7
Бакалдин; 15.3.03

При создании тегов можно задать его тип - Type:"Timer" и ранг - Range:"T" с соответствующим номером таймера. Если я использую этот тег в выходном поле, то какая информация будет выведена; если я использую его во входном поле, то смогу ли я задать уставку времени для таймера. Если нет, то как это сделать? Заранее спасибо.


text

Ограничения в PROTool/PRO RT DEMO
Янош; 13.3.03

Какие ограничения в демо версии PROTool/PRO RT 6.0 SP2 (если есть официальный документ по этому поводу)


text

"Выпадание" русской раскладки в ProTool 6.0
Сергей Валуев; 10.2.03

Господа! Кто-нибудь сталкивался с таким явлением - при закрытии интегрированного в Step 7 проекта на ProTool версии 6.0 (а также +SP 2.0) для MP370, установленного на Win2000 Pro SP2, из системы выпадает русская раскладка клавиатуры? Как с этим бороться, не залезая каждый раз после закрытия проекта в настройки системы?

Re:
Pol; 14.2.03

Можно установить русский язык по умолчанию.

Открой в меню System/language assigment
В Device language должны быть русский и английский языки, если нет - установи.
В toolbar выбери русский язык и сохрани проект. Клава перестанет появляться при запуске protool.
Re:
Сергей Валуев; 14.2.03

Спасибо, но проблема другая. Видимо, я не достаточно четко её сформулировал. После закрытия ProTool CS с компьютера, на котором редактируется проект, "слетает" русская раскладка клавиатуры, остается только английская. И, чтобы продолжить работу с русскими шрифтами в других приложениях, необходимо снова загружать русскую раскладку через "Мой компьютер - панель управления - клавиатура"

Re:
aim; 16.2.03

Присоединяюсь к автору вопроса.

Использую W2K+SP3 и PT6+SP1 с интеграцией в Step.
- Проект для панели MP270. При закрытии происходит аналогичная фигня.
- Проекты для панелей OP-xx. При закрытии - усё Ок.

Похоже вышеописанная ерунда происходит только на проектах для панелей OS-кой в которых является WinCE.

Отчего и почему - вот в чём вопрос!!!
Re:
Ефременко Денис; 19.2.03

При работе с графическими панелями OP то же самое, а также с PC. Единственное, с текстовыми панелями такого глюка нет.

У меня W2K+SP3 и PT6+SP1a.
Re:
Роман Абзаев; 20.2.03

У меня более забавная "проблема" русская раскладка не слетает, как я ни пробовал повторить "успехи" респондентов, но при выходе из ProTool 6.0+SP1 к четырем раскладкам Windows 2000 Pro SP3 (Британский+американская, Русский, Немецкий, Греческий) добавляется Английский(США). Архизабавно.

Re:
Бобков Александр; 13.3.03

Protool 6.0+SP1, Win98, панель OP7.

При выходе из Protool тоже теряется русская раскладка, но раскладки англ. при нормальной работе и при попытки переключиться на русскую не совпадают.


text

WinCC 5.1 vs Win2000
Алексей Светличный; 12.3.03

После установки WinCC 5.1 на компьютер под управлением Win2000(Server/Professional) на клавиатуре перестают работать клавиши "Пуск" и "Контекстное меню". Кто-нибудь знает как это побороть?

Re: WinCC 5.1 vs Win2000
Лев Шерешевский; 12.3.03

см. http://www.simatic.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1026818995&year=2002

Помогает удаление ключа реестра Scancode Map в ветке HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout


text

WinCC Configuration Tool
Александр Шестаков; 18.2.03

Проблема: C помощью выше названного инструмента создается проект и конфигурируется... Затем созданый проект переноситься в другое место.

При попытке продолжить конфигурирование созданного проекта инструмент не находит проект на старом месте и запрашивает пользователя указать новое местоположение. При указании нового местоположения инструмент не может установить с ним связь. Если кто сталкивался с данное проблемой пожалуйста ответьте. (OS Windows 2000, WinCC 5.1, Excel 2000)
Re: WinCC Configuration Tool
Л. Шерешевский; 27.2.03

А не проще ли после переноса проекта пересоздать книгу Excel, считав текущий вариант конфигурации из WinCC?

Re: WinCC Configuration Tool
Шестаков Александр; 6.3.03

Нет не проще, т.к., например, все теги у меня разбиты на группы, каждая группа на одельном листе книги. А как вы знаете, если создать новую книгу все теги будут созданы на одном листе книги. И группировать их заново как-то не очень хочеться, да и вообще это неудобно (это касается и сообщений для Alarm Loggin).

Re: WinCC Configuration Tool
Чистяков Дмитрий ОАО "СеверСталь"; 7.3.03

Если много данных, то лучше сразу задуматься о более серьёзной базе данных. Хотя бы о ACCESS

Re: WinCC Configuration Tool
Шестаков Александр; 8.3.03

Уважаемый Дмитрий Чистяков, я не совсем понял что значит серьезная база данных и при чем она здесь?

Re: WinCC Configuration Tool
Чистяков Дмитрий "СеверСталь"; 11.3.03

Серьёзная база данных это та в которой данных (полей в записях) более 10.

Если Вы используете большлое число процессных значений, передаваемых в базу данных, то управление этими значениями становится затруднительным.
ЧТо как раз и наблидается в вашем случае. Т.е. каждое изменение в системе влечёт большие трудозатраты по изменению системы сбора данных.
Excel же это хорошая электронная таблица, но как СУБД он не очень удобен.
Если требуется передача данных в БД, то более правильным и удобным было бы использовать передачу данных в базу данных (в файл), обработка которого производится СУБД. Таким образом вся система разделяется на две подзадачи.
1. Приём и запись данных в файл.
2. Обработка этих данных.

Что даёт такое разбиение?
В этом случае одна подзадача не зависит от другой. И если что-то изменилось в системе передачи данных (как в Вашем случае другой компьютер), то обработчику это по фене. Главное чтоб бы обработчику был доступ к БД.
Ну, и обратная ситуация так же действительна.

Re: WinCC Configuration Tool
Шестаков Александр; 11.3.03

Мне кажется что вы не совсем поняли о чем идет речь. WinCC Configuration Tool используется ТОЛЬКО КАК УДОБНОЕ СРЕДСТВО ДЛЯ КОНФИГУРИРОВАНИЯ ПРОЕКТА, а не как СУБД. И речь идет о программной ошибке в этом инструменте.

Которая заключается в том, что при изменении местоположения проекта, созданый перед этим конфигурационный файл уже нельзя подключить к проекту.
Я нашёл только один путь режения этой
проблеммы - вернуть проект на прежнее место. Вот и всё!


text

Redundancy, будь оно не ладно!
Дроздов Д.Е.; 26.2.03

Господа подскажите! Делаю серверный проект, настраиваю редунданси, вставляю клиента одного, дуплю проект дупликатором... А дальше то что? Отрываем серверный проект с клиента? Или что? Если открыть проект с клиента вроде все работает, но переключения свитчером не происходит! Что делать? Куда бежать?

Re: Redundancy, будь оно не ладно!
Михайлин Сергей; 27.2.03

Последовательность такова:

- сделать серверный проект с клиентом
- настроить Редунданси
- скопировать на другой сервер
- проверить настройки Редунданси на обоих серваках
- расшарить диски с проектами
- на клиенте подключить сетевые диски с проектами
- настроить на клиенте Свичер
- запустить клиента
- оторвать связь клиента от рабочего сервера
- наблюдать процесс переключения(1-5 минут в зависимости от проекта и протокола обмена)
- вернуть сервер
- наблюдать процесс синхронизации
- по желанию настроить переключение при потери сервером связи с контроллером.
Должно работать, проверялось неоднократно!
Удачи!
Re: Redundancy, будь оно не ладно!
Дроздов Д.Е.; 27.2.03

Чего-то не получается... Все равно на другой сервер не переключается.

Re: Redundancy, будь оно не ладно!
Чистяков Дмитрий ОАО "СеверСталь"; 27.2.03

Были глюки, пока не устанили все не точности в проекте.

1. имена серверов не должны быть более 8 символов.
2. Проверить путь на клиенте до свичера.
Re: Redundancy, будь оно не ладно!
Чистяков Дмитрий ОАО "СеверСталь"; 27.2.03

Да, забыл.

В именах серверов лучше не использовать символов подчёркивания "_".
Желательно заменить их минсами "-"

Re: Redundancy, будь оно не ладно!
Дроздов Д.Е.; 27.2.03

В общем сами серваки перключаются. Поглядел по изменению тегов в группе Redundancy, а вот рабочая станция на другой сервер не лезет ни в какую, хотя свичер запускается.

Да! Еще вопрос - я загружаю проект непосредственно с сервера, клиентская часть, как я понимаю, сама по себе активизируется. Так вот - это правильно?
Re: Redundancy, будь оно не ладно!
Михайлин Сергей; 27.2.03

То что ты проект запускаешь с сервера правильно. Но если свичер на клиенте запускается, то переход должен быть. Картинки появляются, на клиенте, что типа обрыв связи с сервером 1, переход на резервный? И что потом молчок??

Проверь те ли пути прописаны в свичере на клиенте.
Проверь доступ к сетевым дискам на клиенте, они должны быть свободно доступны с полным доступом. Да еще, иногда если пользователи разные то Винда при подсоединении требует пароль.
Re: Redundancy, будь оно не ладно!
Дроздов Д.Е.; 27.2.03

Да все это есть. Свичер в процессах висит и все. И не реагирует на отрыватие одного сервака.

Re: Redundancy, будь оно не ладно!
Любитель Симатика; 27.2.03

А ты скока ждешь-то результат?

Эта самая Редунданся, вместе с Виндой и протоколом ТЦП/ИП весчь тормознутая! Ето все не мнгновенно произойдет. Потеря связи обнаруживается через секунд 20-30, а проект переключится выше уже написали.
Re: Redundancy, будь оно не ладно!
Дроздов Д.Е.; 28.2.03

А вот совсем не переключается. Покурить где-то минут 10, так по возвращении ноль реакции.

Есть мысль взять свичер со старых версий - у меня 5.1, а взять с 4-й или 5.0
Re: Redundancy, будь оно не ладно!
Дроздов Д.Е.; 28.2.03

Ну помогите! Больше сил никаих нет! Ну не работает переключение клиента на другой сервак! Причем наглухо. Использовались версии WinCC - 5.0 и 5.1

Re: Redundancy, будь оно не ладно!
Михайлин Сергей; 28.2.03

Предлагаю связаться по телефону!

737-24-31
Re: Redundancy, будь оно не ладно!
shurik; 28.2.03

а что подразумевается под свичером

Re: Redundancy, будь оно не ладно!
Дроздов Д.Е.; 3.3.03

Свичер - программа, запускаемая на клиенте. Она переключает клиента с основного сервера на резервный в случае сбоев при связи. Вот так в общих чертах, но она почему-то этого у меня не делает.

Re: Redundancy, будь оно не ладно!
Дроздов Д.Е.; 4.3.03

Таки победили! Правда совершенно не так как написано в документации, шедшей в комплекте с WinCC. Если кому интересно пишите на filmsy@inbox.ru

Re: Redundancy, будь оно не ладно!
михайлин Сергей; 4.3.03

Ну уж нет!!! ;-))

Просим плиз подробности в студию. Интересно наверно будет для всех.
Для этого и нужен форум.
Re: Redundancy, будь оно не ладно!
Владимир; 4.3.03

Да-да

пдробности плиз!
Re: Redundancy, будь оно не ладно!
Денис Дроздов; 5.3.03

Ну тогда призы в студию...

Делаем Multi-User проект на сервере, прописываем клиентов всех каких есть там же, настраеваем Redundancy на сервере, дуплим проект на другой сервак.
На кленте делаем клиентский проект Multi-Client, загужаем Server-Data, проверяем кто будет мастером(из серваков), кто партнером.
Далее все автоматически - оказываетяся, клиент сам переключатся на другой сервер, но..! Переключение с нового мастера обратно на основной сервер происходит в течение минут эдак 3-4. Не годится!
Игрался с регистри - не помогло. Какие есть варианты?
Re: Redundancy, будь оно не ладно!
Михайлин Сергей; 5.3.03

Стоооп!

MultiClient -это не обычный клиент! И его не обязательно создавать для Редунданси!!! Все обязано, скока раз сам реализовывал, должно работать и на обычных клиентах. Так что баг не решен, а лишь обойден. Ищем дальше...
По поводу скорости я уже писал. Здесь ФИЗИЧЕСКИ ничего нельзя сделать. Учти
- скорость обнаружения ошибки по TCP/IP (с ретрейнами)
- деактивировать старый проект
- закрыть его
- открыть новый проект (сетевой)
- активировать его.
Иначе нельзя ибо это два проекта и две базы данных не идентичных (после ошибки сервера это так)между собой.
Мои собственные тесты таковы:
Переключение по сбою сервера или сети 2-4 минуты
Переключение в штатном режиме(кнопочкой) менее 1 минуты.
Re: Redundancy, будь оно не ладно!
Михайлин Сергей; 5.3.03

И опять я! ;-))))))

Посмотри вот в этой доке главу 11.13.4
См. Дока

Re: Redundancy, будь оно не ладно!
Денис Дроздов; 5.3.03

Вот как написал - так и работает. Redundancy настраевается и запускается только на серверах, к клиенту это не имеет никакого отношения.

Re: Redundancy, будь оно не ладно!
Михайлин Сергей; 5.3.03

Работать то работает, но это не совсем корректно в смысле решения. Для обычных клиентов это 100% тоже работает через настройку свичера на клиентах. Посмотри все же главу которую я указал выше.

Re: Redundancy, будь оно не ладно!
shurik; 5.3.03

я конечно извиняюсь,но где взять этот самый свичер,и как кешировать картинки на сервере,а может кто раскажет как разместить картинки на клиенте? доки конечно интересно но что заменит живую речь на форуме?

Re: Redundancy, будь оно не ладно!
Чистяков Дмитрий ОАО "СеверСталь"; 7.3.03

Свичер (switcher) это программа, которая подключается, как дополнительное приложение, которое запускается при старте проекта на клиенте. Она находится в папке Siemens\winn\bin\ . SwitcherRT устанавливается всегда при установке WinCC. Задача этого приложения – распознать ошибки работы сервера (нет связи, завис сервер и т.д.) и дать команду на пере подключение клиентского места к проекту на резервном сервере.

Типичная ошибка при работе со свичером – это неверный путь до файла программы.
Теперь про саму суть вопроса.
Не понятно, зачем использовать станции в режиме мульти-клиента. Или у вас имеется ещё один – третий сервер, с которого берутся какие-то данные?
А так, из личного опыта скажу, что со станциями мульти-клиентами проблем больше чем с простым клиентом. Это, прежде всего, связано с тем, что при каких либо изменениях проекта на сервере необходимо синхронизировать данные проекта и на мультиклиенте. Чего на простом клиенте не требуется. Не знаю, конечно, как у вас, а у нас так это обновление данных затруднено по чисто физическим проблемам – трудно доступностью до станций оператора, т.к. они встроены в пульт. Да и останавливать станции нельзя.
Ну, и напоследок хочется сказать, что тут сработал чисто российский подход – как-нибудь извратится и сделать чего-нибудь неповторимое, вместо того чтобы использовать как надо. ;-)

Re: Redundancy, будь оно не ладно!
shurik; 7.3.03

нет такого приложения по указанному пути (WinCC 5.1)SwitcherRT ????????

Re: Redundancy, будь оно не ладно!
Чистяков Дмитрий "СеверСталь"; 11.3.03

CCProjectSwitcherRt.exe


text

TextList в WinCC как считать текстовое значение которое присваивается в свойстве Assigments
Хоружевский Роман; 3.3.03

TextList в WinCC как считать текстовое значение которое присваивается в свойстве Assigments. Не могу найти команду которая бы могла считать данный текст. Пробовал SetPropChar напрямую через DirectConnection. А задача следующая, из данного TextList нужно то что я присвоил 0 - Горошек, 1- помидоры. Вытянуть в тестовый тег именно Горошек, помидоры.

Re: TextList в WinCC как считать текстовое значение которое присваивается в свойстве Assigments
Евгений; 3.3.03

Напиши функцию соответствия типа:

switch (i)
{
case 0:
{
SetTagChar("TextTag","Горошек");
break;
}
case 1:
{
SetTagChar("TextTag","помидоры");
break;
}

Или сделай себе нормальный ComboBox :)
}

Re: TextList в WinCC как считать текстовое значение которое присваивается в свойстве Assigments
Хоружевский Роман; 7.3.03

Спасибо Евгений, я уже сам докопался, можно просто на уровне Direct Connection из поля TextList писать в тег свойство InputValue, очень просто но нигде этого не написано, как всегда "тыком" и получается.


text

WinCC(Step7) и экспорт тегов
Сергей; 5.3.03

Есть вопрос-как можно было бы экспортировать все теги из проекта WinCC, который получает данные из Step7.

Спасибо

Re: WinCC(Step7) и экспорт тегов
Владимир; 5.3.03

Simatic-WinCC-Tools-Variablen Export-Import


text

No connection to data server!
Василий Терняков; 21.2.03

2 компьютера Windows NT Server и Windows NT Workstation, SP6a, IE6, WinCC v5.1 HF1. WinNT Server работает как WinCC Server, WinNT WS - WinCC клиент. Казалось бы стандартная конфигурация для клиент-серверной системы, но возникла небольшая проблема: проект активизируется, появляются окошки, мнемосхемки и выводятся текущие сообщения от контроллера в окне сообщений, но сообщения выводятся только на сервере. Клиент в статус баре окна сообщений пишет "NO CONNECTION TO DATA SERVER!" и никаких сообщений конечно не выводит.

Прошу, если у кого-нибудь были подобные проблемы поделитесь советом. Советующих перезагрузить компьютер и переустановить WinCC прошу не беспокоиться.
Re: No connection to data server!
shurik; 22.2.03

посмотри какие процессы запускаются на сервере (WinCC Explorer-Computer-Startup),что-то типа CCLBMRTSERVER,СССSIGRTSERVER и пропиши их в startup клиента, кроме того глянь чтоб у клиента стояла галочка напротив ALARM LOGGING RUNTIME - для сбора аварийных сообщений,TAG LOGGING для трендов

Re: No connection to data server!
Александр, СКТЦ; 23.2.03

Поставь HotFix2 на WinCC, а лучше самый последний.

Re: No connection to data server!
Дроздов Д.Е.; 26.2.03

Ну а где этот HotFix2 взять?

Re: No connection to data server!
Василий Терняков; 26.2.03

Спасибо за помощь!

Поставил HotFix4 и проблема исчезла.
Re: No connection to data server!
Дроздов Д.Е.; 27.2.03

Ну где этот Hotfix взять?! Все облазил - нет нигде!

Re: No connection to data server!
Василий Терняков; 28.2.03

Сообщите свой E-mail. Я вам вышлю ссылку.

Re: No connection to data server!
Дроздов Д.Е.; 28.2.03

Легко! filmsy@inbox.ru

Re: No connection to data server!
shurik; 28.2.03

и мне пожалуйста ссылочку

avkbnm@mail.ru
Re: No connection to data server!
Юрий Оганесян; 3.3.03

HotFix4? Хм...

Ты бы выложил URL на форум, а то я вот, например, тоже не знаю где такой хотфикс водится...?
Re: No connection to data server!
Александр Родин, ООО "Нева Электрик"; 3.3.03

Кстати, да.

Неплохо было бы ко всем заплаткам иметь более свободный доступ... Или Сименс перенимает опыт мелкомягкого братства брать деньги за _свои_ ошибки ?.. :)
Re: No connection to data server!
Василий Терняков; 3.3.03

Ну, положим, денег я ни с кого не беру за ошибки сименс.

И раздобыть ссылку мне стоило труда.
Вот пользуйтесь: http://www.sinetic.ru/download/
Re: No connection to data server!
Игорь К; 4.3.03

Привет!

Можно вопрос: А что Hotfix7 под WinCC5.1 более глючный? :-|

Re: No connection to data server!
Василий Терняков; 5.3.03

насколько я знаю существует hotfix7 для wincc5.0, а не для wincc5.1


text

Как сделать автозапуск сервера.
Александр Туманов; 3.3.03

Требуется автоматически включать сервер и запускать WinCC при восстановлении питания. Как это сделать?

Re: Как сделать автозапуск сервера.
Михайлин Сергей; 3.3.03

Надо:

- настроить BIOS на автовключение компа при подаче питания
- активировать в операционке функцию AutoLogon для автоматического входа в систему(найти как это сделать можно либо в И-нете, либо есть готовая прога)
- настроить опцию WinCC AutoStart на нужный проект и сказать чтобы он сразу активировался.


text

Проблема с Tag Logging (срочно)
Vitalgan; 27.2.03

Суть проблемы в следующем.

У меня WinСС принимает теги через OPC Server, 8 битовые беззнаковые.
Для графики я назначаю каждый бит из тега. Тут все ясно.
А вот с Tag Logging "непонятки".
Как мне выхватить из тега только один бит для архивации.

Хотел сделать внутренний бинарный тег, а ему присвоить значение того бита которого нужно. Не сообразил как это сделать.

А вообще мне нужено сделать архив расхода сырья с разными видами в разное время.

Работаю с WinCC недавно и не постоянно, может в этом проблема.
Но все равно помогите пожалуйста. Время меня "душит"
Re: Проблема с Tag Logging (срочно)
Л. Шерешевский; 27.2.03

Ну, если Вы решили самостоятельно разбирать байт на биты, то заведите циклический action в котором для каждого байта

1. считывается значение (GetTagByte)
2. раскладывается на биты:
bit0 = byte & 0x01;
bit1 = byte & 0x02;
bit2 = byte & 0x04;
...
3. записываются все битовые значения (SetTagBit)

Это решение красивым никак не назовешь, оно скорее может выступать для Вас в роли временной "заплатки", пока не найдете более приемлемый вариант.
Re: Проблема с Tag Logging (срочно)
Макс Прилепский, ОАО "ЗСМК"; 1.3.03

В WinCC для решения подобных задач можно написать функцию конвертации

значения.

В Global Script создаётся функция с определёнными параметрами:
(более подробная информация есть в Нelp'е WinCC (тема - Conversion Function))

double Convert (double doLmtValue;double doValue;int dwCount,DWORD Archiving);
{
if ( ((BYTE) (doValue))&0x1) //проверка наличия единицы в бите №0
return 1;//В архив записывается значение 1
else
return 0; //В архив записывается значение 0
}

После написания функции в окне Properties of Process Tag
подсистемы Tag Logging необходимо вместо Actual Value выбрать Аction и указать имя написанной ранее функции.
После этого при каждом изменении архивируемого тега WinCC самостоятельно будет вызывать вашу функцию и писать в архив соответствующее значение.

Я использую такие функции , в основном, для реализации циклограмм работы механизмов
Re: Проблема с Tag Logging (срочно)
Vitalgan; 3.3.03

Наверное не совсем то решение.

У меня бочка наполняется сырьем, потом освобождается. Причем надо задавать какое сырье туда наполнилось.


text

Как обойти префикс тега в C Actions?
иван жуков; 20.2.03

Я использую в Picture Window префикс для тегов. Это мне нужно, чтобы окно вызывалось с разными структурными тегами. Все было нормально до тех пор пока мне не понадобилось получить доступ к другим тегам вне структурного тега, созданного для данного экземпляра Picture Window. Оказывается, что в C Actions нет способа(?) избежать добавления префикса тега (если он определен) ко всем тегам, с которыми я работаю, и я не могу обратится к тегам, которые не являются полями структурного тега с данным префиксом. Кто-нибудь может посоветовать подходящее решение?

Re: Как обойти префикс тега в C Actions?
Iva; 21.2.03

Не используй никакие префиксы.......

Я делаю так - есть куча тегов Tag1, Tag2.......И есть такая же куча однотипных картинок. В зависимости от номера текущей картинки склеиваешь название тега "Tag" + "Номер" и обращаешся к нему.
Вот и всё.......
Re: Как обойти префикс тега в C Actions?
иван жуков; 21.2.03

То есть доступ к тегам у меня будет только из C Actions, поставить прямую ссылку на тег в каком-нибудь поле Properties я не смогу?

Re: Как обойти префикс тега в C Actions?
Колпащиков Сергей; 22.2.03

Читайте здесь:

http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1027057738&year=2002
Re: Как обойти префикс тега в C Actions?
Владимир; 28.2.03

Как оказалось, префикс не распространяется на теги, у которых стоит признак "Indirect".

Т.е. создаете промежуточный строковый тег, в который заносите имя нужного Вам тега, и указываете его с признаком indirect. Но это не всегда удобно.
Что же касается склеиваний вручную названий и потом обращений к этим тегам в С Action, то эта процедура довольно заметно начинает тормозить процесс визуализации. К примеру, у меня в открытом кадре находится более 50 тегов, которые мне нужно получать путем "вычисления". При использовании C Action процесс инициализации тегов занимал почти 30 секунд! (сеть Profibus) Пришлось перейти к префиксам. Теперь время инициализации составляет около 2 секунд.
Re: Как обойти префикс тега в C Actions?
Л. Шерешевский, Д. Маслов; 1.3.03

Можно также использовать функции dmGetValue, dmGetValueWait, dmSetValue, dmSetValueWait пакета ODK, на них действие префикса не распространяется.

См. Центр компетенции WinCC

Re: Как обойти префикс тега в C Actions?
Владимир; 2.3.03

Интересно, сколько времени займет инициализация запросов значений хотя бы 30 тегов таким способом ?

Re: Как обойти префикс тега в C Actions?
Л. Шерешевский; 2.3.03

Все зависит от типа и топологии используемой сети, от количества станций и даже от размещения тегов в контроллерах. Поэтому хоть как-то оценивать можно только время чтения/записи внутренних тегов, оно будет примерно одинаковым в любых конфигурациях.

К примеру, в пустом тестовом проекте для 512 внутренних тегов чтение заняло примерно 0.42 сек. при первом обращении и 0,16 сек. при последующих. Для записи тех же 512 тегов аналогичные времена составили 2.7 сек. и 2.4 сек.

Конфигурация тестовой станции: PIII-800, Win2k+SP3, WinCC5.1+HotFix2.


text

TagPrefix
Колпащиков Сергей. Аквтехнология; 19.7.02

Используется один PictureWindow для нескольких однотипных объектов. Естественно все ТЭГи объектов названы так, что бы испоьзовать TagPrefix. И все работает. Но теперь на этой же форме необходимо отобразить значения ТЭГа единого для всех объектов (время некоторой операци). Напрямую естественно подставляется TagPrefix.

Написали через CAction (GetTagWord), но и здесь подставляется TagPrefix.
Подскажите, если кто знает, можно ли получить в этом случае значние ТЭГа без префикса. (Дублировать ТЭГ с соответствующими префиксами как то не очень хочется)

Зарание спасибо.
Re: TagPrefix
Евгений Трунов; 19.7.02

Можно вставить в PictureWindow ещё один PictureWindow, с пустым TagPrefix'ом, в который уже и внести новую форму с необходимым объектом.

Re: TagPrefix
Колпащиков Сергей. Акватехнология; 12.9.02

Спасибо за совет.

Так и зделал, но вот беда
вложенный PictureWindow тоже воспринимает TagPrefix родительского.
Причем если вложенному установить свой TagPrefix, то ТЭГи формируются как Родетельскоий.TagPrefix + Вложенный.TagPrefix + Имя ТЭГа.

Может я что-то не так делаю.

Заранее спасибо.

Re: TagPrefix
Лев Шерешевский; 19.9.02

Прямой способ получения тега без префикса несмотря на все попытки выяснить не удалось. Можно использовать обходной путь: в picture window для однотипных объектов разместить поля отображения общих параметров и еще одно вложенное picture window, у которого уже задать нужный tag prefix. Работа с окнами становится менее удобной, но все же реальной.

Re: TagPrefix
Л. Шерешевский; 1.3.03

См. ссылку

См. http://www.simatic.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1045759473&year=2003


text

WinCC и S7-PLCSIM
Игорь; 27.2.03

Возможна ли связь WinCC и S7-PLCSIM?

Re: WinCC и S7-PLCSIM
VT; 28.2.03

Несомненно. Нужно настроить адрес MPI на тот который прописан в проекте WinCC для соединения.


text

AlwaysOnTop в WinCC
Сергей; 18.2.03

Как сделать, чтоб при переключении окон, окно вызываемой ранее программы была поверх всех окон,(чтоб N-количество раз не запускать)

Re: AlwaysOnTop в WinCC
Л. Шерешевский; 27.2.03

Сомневаюсь, что это вообще возможно. Мы для этих целей используем несколько другой подход:

1. Проверить, не запущено ли нужное приложение с помощью функции FindWindow()
2. Если не запущено, запустить.
3. Если запущено, то разрешить размещение окон на переднем плане функцией PDLRTAllowSetForegroundWindow() и послать главному окну приложения команду SC_RESTORE. (Альтернативный вариант - послать команду завершения и запустить приложение вновь).

См. Центр компетенции WinCC


text

Системные сообщения в WinCC
Кирилов Владимир; 4.2.03

Господа! Не удается добиться отображения и архивирования системных сообщений, например, "activated Runtime". В Alarm Logging сконфигурил, в контрол'е отображать группу добавил. (К тэгам не привязывал, но, если я правильно понимаю, то это и не нужно, среда сама должна "возбудить" сообщение...) И никакого эффекта: ни отбражения, ни записи в таблицы. Подскажите, где можно прочитать про то, как это сделать? И что за параметры эти сообщения принимают?

Re: Системные сообщения в WinCC
Евгений Трунов; 4.2.03

Смотря какие системные. У нас автоматически отображаются, и нормально, системные сообщения, связанные с WinCC-Redundancy, например, при обнаружении подсистемой резервирования относящихся к ней действий (остановка сервера-партнёра, запуск сервера-партнёра и т.п.). Для этого их понадобилось только лишь импортировать в подсистему Alarm Logging ("Tools->WinCC System Messages..."). Точно так же отображаются сообщения, связанные со сменой пользователя и другими подсистемами (TLGRT, PDLRT).

Re: Системные сообщения в WinCC
Кирилов Владимир; 8.2.03

Евгению спасибо, но у меня проблема так и не решилась, может еще кто-нить поможет?

Re: Системные сообщения в WinCC
Л. Шерешевский; 27.2.03

Действительно, системные сообщения WinCC недостаточно документированы и подчас крайне сложно понять какие из них в каких случаях должны генерироваться. Убедиться в том, что системные сообщения все-таки работают можно следующим образом.

1. Создайте новое приложение. Не забудьте активизировать подсистему AlarmLogging.
2. В AlarmLogging создайте системные сообщения. Для Long-Term архива в Selection отметьте классы сообщений System without acknowledgement и System requires acknowledgement.
3. На стартовой экранной форме сконфигурируйте окно вывода сообщений, настроив его на долговременный архив. Также добавьте picture window, указав для него заведомо несуществующую pdl-форму.
Запустив проект, Вы должны увидеть системное сообщение об ошибке экранной формы.

См. Центр компетенции WinCC


text

драйвер для укт38
Виктор ; 20.2.03

Нужно связать WINCC и прибор УКТ38 (8точек температуры) через RS232.

Сколько это займет времени и сколько
будет стоить? (протокол могу выслать )
Re: драйвер для укт38
Iva; 26.2.03

Делал подобную вещь для связи WinCC и расходомеров "Взлёт". Готов оформить программу в виде DLL или ActiveX элемента. Это займёт максимум неделю и будет стоить 150$.

Если нужен драйвер полностью встроенный в WinCC (разработка на CDK) - то тогда время и деньги обсуждаются (ясно что больше).


text

Операторские панели ОР270/370
DEE; 21.2.03

Hi,All!!!

Вот вопрос: нужен ли runtime ProTool для панелей OP270/370 ( у них вроде встроенные винды СЕ)? Или не нужен ?
Или только для PC подобных панелей 670/870, PC&

Re: Операторские панели ОР270/370
fog; 21.2.03

Не нужен.

Re: Операторские панели ОР270/370
Илья; 26.2.03

Достаточно ProTool/Pro CS

Re: Операторские панели ОР270/370
DEE; 26.2.03

Ага, понятно, спасибо...


text

Как написать программу архивирования
Елена; 18.2.03

Уважаемые участники форума. Подскажите, где найти шаблон программы на C для Global Wincc 5.1, чтобы сархивировать переменную с частотой выше, чем 500 мсек.

И еще. Как средствами WinCC 5.1 также через Global создать новую директорию (папку) в Windows.
Re: Как написать программу архивирования
Юрий Оганесян; 19.2.03

Больше всего мне нравится непринужденный стиль вопроса :).

Способы писать в базу из WinCC помимо Tag Logging на форуме обсуждались уже раз 10, но, думаю, никто не решиться гарантировать, что хоть один способ успеет на требуемое время. Не знаю полностью вашу задачу, но интуиция мне говорит, что ее надо решать (если вообще надо) как-то по-другому, а не «в лоб» и, возможно, с применением совсем других аппартно-программных средств.
По поводу создания папки, то WinAPI открыто, но все та же интуиция снова говорит мне, что вы «ломитесь не в ту дверь».

Re: Как написать программу архивирования
Elena; 20.2.03

Спасибо за ответ, за стиль - отдельно. Просмотрела Форум за 1998-2003, "по зубам" ничего не нашлось. Будем писать эту переменную в виде ряда переменных, которые будут приходить из контроллера с больщей частотой, их архивировать, а потом собирать в массив нужной нам переменной. Что про папку, так туда хотелось сбросить архив переменной несколько раз, допустим, за смену, но под разными именами. Библиотека Dos не подключилась (не признал) и mkdir не признал тоже.

Re: Как написать программу архивирования
Александр Родин, ООО "Нева Электрик"; 20.2.03

Оставте ваш адрес, или пишите на наш...

Поедлимся.
Re: Как написать программу архивирования
Константин; 20.2.03

Александр, просьба неприлично не выражаться :-))

Re: Как написать программу архивирования
Елена; 20.2.03

Заранее благодарны...

Адрес
vniimt_44@mail.net-burg.net
Re: Как написать программу архивирования
Alexis; 20.2.03

2 Александр Родин

Александр, Вы стандартным TagLogging-ом без использования различных прибамбасов типа AR_SEND архивируете с частотой менее 0.5 секунды?
Или Вы делитесь чем-то другим?
Re: Как написать программу архивирования
Александр Родин, ООО "Нева Электрик"; 20.2.03

2Alexis

Нет стандартным таглоггингом архивировать с циклом менее 500 мс не получится никогда.

Да и вабще, у нас таких задач пока не ставилось. Более того, даже если взяться за эту задачу средствами самой WinCC, то ни к чему хорошему это не приведет. Хотя в принципе это возможно, потому как есть возможность создания пользовательского цикла 100мс.

Теоретически, если сделать архивирующий глобал-скрипт с пользовательским циклом, то можно добиться желаемого результат... Только кому нужен этот гемор ?... %))))))))

А делюсь я просто функцией создания дерриктории... :)
Re: Как написать программу архивирования
Alexis; 21.2.03

Нда... медленный TagLogging...

Кстати, а с WinCC ver6 кто-нибудь разбирался?

А создание директории эт же просто:

BOOL CreateDirectory(
LPCTSTR lpPathName,
LPSECURITY_ATTRIBUTES lpSecurityAttributes
);

Parameters
lpPathName
[in] Pointer to a null-terminated string that specifies the path of the directory to be created.
There is a default string size limit for paths of 248 characters. This limit is related to how the CreateDirectory function parses paths.

Windows NT/2000/XP: To extend this limit to 32,767 wide characters, call the Unicode version of the function and prepend "\\?\" to the path. For more information, see Naming a File.

lpSecurityAttributes
Windows NT/2000/XP: [in] Pointer to a SECURITY_ATTRIBUTES structure. The lpSecurityDescriptor member of the structure specifies a security descriptor for the new directory. If lpSecurityAttributes is NULL, the directory gets a default security descriptor. The target file system must support security on files and directories for this parameter to have an effect.
Return Values
If the function succeeds, the return value is nonzero.

If the function fails, the return value is zero. To get extended error information, call GetLastError.

Requirements
Windows NT/2000/XP: Included in Windows NT 3.1 and later.
Windows 95/98/Me: Included in Windows 95 and later.
Unicode: Implemented as Unicode and ANSI versions on Windows NT/2000/XP. Also supported by Microsoft Layer for Unicode.
Header: Declared in Winbase.h; include Windows.h.
Library: Use Kernel32.lib.


text

WinCC и PROFIBUS-DP
Александр Родин, ООО "Нева Электрик"; 27.1.03

Имею соединение WinCC(PROFIBUS-DP)- CP5611(PROFIBUS-DP Master) - PROFIBUS-устройство как SLAVE.

В COM PROFIBUS создал .ldb-файл для устройства (GSD-файл прилагался), где настроил входы/выходы.

Теперь хочу эти входы/выходы зачитать в WinCC.
Как это можно сделать ? Делается ли это с помощью RawTag-ов или можно как-нибудь еще ?
Кто имел практический опыт, буду очень признателен за помощь...
Re: WinCC и PROFIBUS-DP
Юрченко Владимир; 28.1.03

WinCC имеет свой драйвер для случая, когда компьютер выступает как мастер Profibus DP только для платы CP5613 (старый аналог CP5412). Для платы 5611 можно работать на Profibus DP с контроллером по S7 протоколу (PC в этом случае не мастер DP) или поставить SoftnetDP пакет с OPC сервером и связывать WinCC со слэйвами через OPC канал.

Re: WinCC и PROFIBUS-DP
Александр Родин, ООО "Нева Электрик"; 29.1.03

Спасибо, по ОРС связался нормально... Хотя огорчает отсутсвие авторизации на SoftnetDP.. :) Окошко раздражает...

А вот еще такой вопрос: Где можно более подробно узнать о структуре GSD-файлов ? На profibus.com есть программка-генератор GSD, но ее за так раздают только партнерам.
Re: WinCC и PROFIBUS-DP
Чистяков Дмитрий ОАО "СеверСталь"; 29.1.03

А зачем Вам структура GSD файлов?

Вы хотите создать свё устройство для Profibus-DP?
Тогда Вам в тему PROFIBUS Technology Components
На немецком сайте поддержки. Там в описаниях на чипы ASIC можно кое чего выцепить по структуре файлов gsd.
Re: WinCC и PROFIBUS-DP
Александр Родин, ООО "Нева Электрик"; 31.1.03

2 Чистяков Дмитрий:

хотим не то чтобы свое создать, сколько подредактировать существующий, чтобы получить доступ к более чем 1 модулю устройства (оно предоставляет их 24, причем COM PROFIBUS почему-то дает настроить для исрользования только один).

На самом деле у меня теперь другая проблема... более неприятная...

Переставил SIMATIC-NET, поставил SOFTNET-OPC-Server... из настроек PG/PC пропали CP5611(PROFIBUS-DP Master и Slave), остался только CP5611 (PROFIBUS)... OPC-сервер к нему соединяться отказывается, даже если указать в настройках Profile -> DP... В результате неделя мучений коту под хвост... :(

Кто подскажет, как обратно установить PROFIBUS-DP Master ?
Re: WinCC и PROFIBUS-DP
Александр Родин, ООО "Нева Электрик"; 5.2.03

Возвращаюсь к старым баранам... :)

Восстановил точку подключения CP5611(PROFIBUS-DP Master)... Теперь осталась проблема как заставить COM PROFIBUS настроить более одного модуля устройства (напомню, устройство предоставляет их 24).
Причем, импортировал этот же GSD в STEP, в HW-config-е настраивается более одного модуля...

Никак не могу понять, что еще можно сделать...
Re: WinCC и PROFIBUS-DP
Александр Родин, ООО "Нева Электрик"; 7.2.03

Вижу что никто COM PROFIBUS-ом не пользовался никогда.. :) Ну да фиг с ним... Сам все настроил и без него.. (кому интересно как, могу рассказать ;)

Вылезла еще одна, ну просто глобальная проблема. Просто черное пятно на всей продукции Сименса !!!

В WinCC настроил подключение через OPC. Сконфигурил графику и т.д. При первом, может при втором запуске все работало замечательно, связь установилась, все что мне надо было я считал и даже передавал команды на устройство. Но потом, ни с того, ни с сего при запусках рантайма вдруг начала обрушиваться система. Вылезает ошибка STOP 0x44 (MULTIPLE_IRP_COMPLETE_REQUESTS).

Проверил другие проекты (там где OPC не используется), работают нормально.

И что это может быть ?

Wincc 5 SP2;
Windows 2000 Pro RUS;

PS: Про большое пятно - это так... для взыграния гордости.. ;)
Re: WinCC и PROFIBUS-DP
Александр Родин, ООО "Нева Электрик"; 20.2.03

Мда.. Зря грешил на OPC.

Оказалось, что при запуске рантайма в любом проекте, где используется PROFIBUS возникает такой же STOP (синий экран). :(
Уже 5 раз систему переставлял. Даже на абсолютно девственных виндах (речь идет об Win2K), т.е. ничего кроме виндов и WinCC рантайм валит систему при использовании PROFIBUS драйвера.

Win2K
WinCC 5.0 SP2
CP5611 (PROFIBUS)


text

Как получить SP3 для ProTool Pro v5.2 SP2
Владимир; 16.2.03

Как получить SP3 для ProTool Pro v5.2 SP2.ProTool Pro v5.2 SP2 - куплен официально (Runtime лицензия на 256 тэгов). Неужели за Service Pack нужно платить?

Что требуется для получения Service Pack ?
Просьба сообщить на
PLC_programmer@torba.com
Re: Как получить SP3 для ProTool Pro v5.2 SP2
Чистяков Дмитрий ОАО "СеверСталь"; 19.2.03

Раньше на сайте поддержки Siemens в Германии была возможность заказать диск такой. А сейчас этой ссылки более нет. Видимо, эта акция длилась какой-то период и он завершился.

Попробуйте обратиться к ближайшему представителю


text

ActiveX в WinCC...
Хлопин Денис; 17.2.03

При написании ActiveX компонент для WinCC на Visual C++ 6.0 сталкиваюсь со следующими проблемами:

1)Как реализовать прозрачный фон, корректно работающий в WinCC, если делаешь вот так:
cs.dwExStyle=WS_EX_TRANSPARENT;
то в других приложениях работает корректно, но в WinCC глючит по-страшному. Какой еще есть способ реализации прозрачности!
2)Как сделать, чтобы мой ActiveX подчинялся иерархии Graphics Designера WinCC, т.е. чтобы я мог переместить свой объект на задний план, относительно других(родных) объектов WinCC, таких как I/O Field и т.п. У меня получается, только так, что мой объект правильно работает лишь с такими же ActiveX-ами, и всегда находиться поверх всех "родных" WinCC-шных объектов!!!
Re: ActiveX в WinCC...
Alexis; 17.2.03

А ты MFC используешь?

Попробуй на ATL наваять...
Re: ActiveX в WinCC...
Iva; 17.2.03

Знакомая тема. Я сам немало парился чтобы добиться прозрачности контрола.

Я использую ATL естественно.
Короче в описании класса делаешь DECLARE_VIEW_STATUS(0) и переопределяешь функцию OnDrawAdvanced. Всё становится прозрачным как море в Крыму.......
А насчёт перемещения на задний план - проблем с этим не было.


text

На OP17 System Mes №368.Ошибка связи S7 модуля.Что такое класс ошибки и номер:где искать
Ефременко Денис; 14.2.03

При подключении через модуль Ethernet станции WinCC к сети Profibus (CPU3152DP+OP17) на панели выскакикает системное сообщение №368 "Communication error S7 module; error class and error number will be read out" (Это я на шел в руководстве по OP7,OP17). А вот где найти описание классов ошибок? Панель выдала: класс ошибки 131, номер ошибки 4.

Re: На OP17 System Mes №368.Ошибка связи S7 модуля.Что такое класс ошибки и номер:где искать
Кухаренко Сергей, SIEMENS; 14.2.03

Единственный вариант - направить запрос в Германию, т.к. только у них есть расшифровка дополнительных ошибок

(из уже существующего опыта).


text

System Mes №368.Ошибка связи S7 модуля.Что такое класс ошибки и номер:где искать
Ефременко Денис; 14.2.03

При подключении через модуль Ethernet станции WinCC к сети Profibus (CPU3152DP+OP17) на панели выскакикает системное сообщение №368 "Communication error S7 module; error class and error number will be read out" (Это я на шел в руководстве по OP7,OP17). А вот где найти описание классов ошибок? Панель выдала: класс ошибки 131, номер ошибки 4.


text

проблема с окнами faceplate
shurik; 13.2.03

При открытии на экране одновременно 5-6 окон стандартных фэйсплейтов системы PCS7 "слетает" PDLRT с сообщением unhandled exception...... в Log файл пишется дамп памяти но понять в чем ошибка я не могу.Подскажите пожалуйста о методе диагностики подобных проблем


text

Report Designer
Кирилов Владимир; 8.2.03

Что за убогие средства печати?

Как, например, распечатать график параметра ТОЛЬКО за ВЧЕРАШНИЕ (или позавчерашние) сутки? Совершенно непонятно…
И еще, если мне надо печатать графики 50 идентичных параметров, мне, что, придется создавать 50 одинаковых Layout’ов, которые будут отличаться только именем тэга? А динамически при вызове его никак нельзя менять?
Народ! Как вы выходите из такого интересного положения ? Используете внешние средства печати ????…
Re: Report Designer
Л.Шерешевский; 9.2.03

Да, действительно, Report Designer - не самая сильная сторона WinCC. При малейшей возможности мы пытаемся отказаться от его использования. При этом есть как минимум два подхода.

Первый: использовать внешние средства.
Второй: использовать более развитые и продуманные средства Graphics Designer - отобразить все что надо на экране (хотя бы на долю секунды) и сразу же вывести нужную область экрана на печать. Этот подход, естественно, не позволяет формировать многостраничные отчеты.
В Вашем случае данный метод малопригоден, т.к. оператору вряд ли понравится мельтешение 50 графиков на экране. Хотя, вероятно, эту проблему можно обойти установкой двухмониторной видеокарты...
Re: Report Designer
Кирилов Владимир; 10.2.03

-> отобразить все что надо на экране

->(хотя бы на долю секунды) и сразу же
->вывести нужную область экрана на
->печать

А как это сделать?? Это, в принципе, подошло бы...
Re: Report Designer
Л.Шерешевский; 10.2.03

Все элементы, которые необходимо печатать, но нежелательно отображать для оператора (логотип, время печати и т.п.) следует сконфигурировать заранее, но атрибут Display установить в FALSE. Затем при необходимости в скрипте сделать их все видимыми, вызвать функцию PrtScreenPart (int left, int top, int right, int bottom); и опять скрыть.

См. Центр компетенции WinCC

Re: Report Designer
Константин; 12.2.03

А где лежит эта PrtScreenPart?

Re: Report Designer
Евгений Трунов; 12.2.03

В \Siemens\WinCC\aplib\prtscrn.h.

Report Designer - да, "...эта штука посильнее "Фауста" Гёте" © :)).


text

WinCC Redundancy
Игорь; 6.2.03

Здравствуйте!

Два сервера работают в резерве. После включения опции Redundancy на сервере партнере в Event-ах все красно от ошибки связанной с работой DCOM (Redundancy не работает). Иногда все работает нормально (но ОЧЕНЬ редко) :-)
Если кто встречался с этой проблемой, поделитесь пожалуйста информацией о возможных причинах и мерах устранения.
PS: И вообще у кого-то это работает (стабильно)?

Re: WinCC Redundancy
Чистяков Дмитрий ОАО "СеверСталь"; 11.2.03

А как у вас дела с синхронизацией проектов? Т.е. проекты должны быть строго идентичны.

Ещё посмотрите имеют пользователи под которыми работаю сервера. Они должны иметь достеп нп запись в реестр.
Re: WinCC Redundancy
Игорь; 12.2.03

Доброе время суток!

Проекты сделаны дубликатором. А пользователи прописаны как Power User.


text

TP370 -> Ethernet -> S7-400
Sinbad; 11.2.03

Можно ли подключить панель ТР370 к симатику S7-400 через Ethernet?


text

PDLRTGetFocus
Вадим Печёрских; 11.2.03

Доброе время суток, All!

Для работы необходимо знать имя текущей картинки и объекта. Вызов PDLRTGetFocus из левого приложения проходит нормально, но если эта функция вызываеться из встроенного в картинку ActiveX (что хотелось бы и получить), то система на какой-то время виснет, а затем выдаёт сообщение о превышение таймаута. Что посоветуете делать?
Re: PDLRTGetFocus
Alexis; 11.2.03

Как советует ОДК:

One of the causes is that ODK requests data from WinCC programs via Window Message during runtime operation and waits for an answer. If the OCX happens to run in the context of such a WinCC program, the request cannot be processed by the OCX because it is deadlocked in the ODK call.

Remedy:
In such a case, the problem can often be solved by rerouting the ODK call to a different thread.

Так-что попробуй вынести вызовы PDLRT* в нитку - помогает :)


text

ODK
Iva; 6.2.03

Проблема на ровном месте - ни одна функция ODK не вызывается из скриптов WinCC. В файле apdefap.h подключены соответствующие h-файлы. Все скрипты компилируются - но ни одна ODK функция не вызывается. Как будто их там нет.

Не знаю что делать.
Помогите кто может!!!
Re: ODK
A; 7.2.03

Таким образом вызываешь?

BOOL _main(char* lpszPictureName, char* lpszObjectName, char* lpszPropertyName)
{
#pragma code ("dmclient.dll")
#include "dmclient.h"
#pragma code ()

char szProjectFile[_MAX_PATH] = "";
CMN_ERROR Error;

return DMGetRuntimeProjectA(
szProjectFile,
sizeof(szProjectFile),
&Error);
}

Re: ODK
fog; 7.2.03

А лицензию на ODK ты купил?

Re: ODK
Alexis; 7.2.03

А лицензия то зачем? :))


text

SP3 ProToolPro 5.2
Анатолий; 6.2.03

Здравствуйте Все!

Срочно нужен Service Pack 3 для ProToolPro 5.2.
Подскажите где взять.

Спасибо.


text

Static Text
Iva; 6.2.03

Возникла проблема написания текста на экране вертикально. Используя Static Text можно написать вертикально - но сверху вниз. Тупизна полная. Надо ведь чтобы текст шёл снизу вверх.

Кто нибудь сталкивался с такой проблемой?
А то остаётся картинки рисовать или свой Static Text написать - не такой тупой.


text

Максим Поджидаев
Очередь скриптов; 4.2.03

Здравствуйте!

На экране имеется несколько объектов к свойствам которых привязаны actions возвращающие значения (например цвет).
При переходе на другой экран периодически можно наблюдать ошибку "WinCC Runtime: PDL Run time: picture not selected". Причина возникновения ошибки ясна, неясно только как её избежать (заменить action на динамический диалог не предлагать):).
Re: Максим Поджидаев
Евгений; 4.2.03

Следует более аккуратно использовать такие action's. Самые очевидные пути решения следующие:

1. Передачу значений закрываемой картинке делать не SetProp'ом, а через внутренний тэг, привязав последний к нужному свойству.
2. Создать искусственные симафоры, например, те-же внутренние тэги, опрос которых будет происходить при входе в action, а выставление - в action'е закрытия окна.
3. Не закрывать, а "сворачивать" текущее окно, делая свойства длины и ширины, допустим, в ноль.

Если не справитесь, могу выслать кусок кода , в котором обходится данная проблема.

Re: Очередь сообщений
Максим Поджидаев; 5.2.03

Спасибо за идеи. К сожалению, решения не назовешь красивыми :( (Увеличение нагрузки, усложнение проекта ...). Что будет, если оставить проект таким, какой он есть? Кроме некоторой задержки при переключении, чревато ли это еще какими либо проблемами (утечки памяти из прерванных actions...)? За "кусок кода" буду благодарен.

Re: Очередь скриптов
Л.Шерешевский; 6.2.03

В WinCC 5.0 после некоторого критического числа ошибок типа "Picture not selected" (зависящего от интенсивности вызова соответствующих экранных форм) происходило выпадение проекта. Судя по результатам наших экспериментов, в WinCC 5.1 этот недочет исправили, хотя явно в документации это нигде не заявлено. В нескольких проектах мы рискнули оставить скрипты таких типов и сбоев в работе не наблюдалось.

См. Центр компетенции WinCC


text

Использование MSComm из VBA 6.0 в С++ WinCC для работы с COM портом
Roman; 1.11.02

Используя MSComm 6.0 из С++ я научился принимать данные которые поступают на порт, но никак не могу что нибудь туда записать (я на 2 порт программой HyperTerminal посылаю текстовый файл и свободно принимаю всю информацию) при попытке записи в порт у меня в выходном буфере пусто, я уже и задержки ставил и пробовал включать подтверждение связи, но ничего не происходит. В начале я указываю номер порта, затем открываю порт и пишу в свойство Output строку, сразу же не закрываю порт считываю его свойства Output, OutBufferCount все пустое. Генерируется код события CommEvent = 4, CommID =644, 304, CDHolding = -1. Все это я делаю во встроенном С++ исмользуя свойства MSComm. Использую команды SetPropChar и др. Реально порт открывается но передача не идет.

Re: Использование MSComm из VBA 6.0 в С++ WinCC для работы с COM портом
Л.Шерешевский; 5.2.03

Похожие задачи мы решали созданием отдельного приложения на VisualC++, общающегося с WinCC по ODK. Это позволяет отвязаться от возможного подтормаживания WinCC и гибко организовать требуемую обработку данных. Изначально также пытались использовать готовый компонент, но столкнулись с какими-то странностями его поведения и быстро отказались.

См. Центр компетенции WinCC

Re: Использование MSComm из VBA 6.0 в С++ WinCC для работы с COM портом
Хоружевский Роман; 6.2.03

Ну в общем я разобрался с данным объектом, оказывается для того чтобы в порт ушла посылка нужно не писать в свойство объекта данную посылку, а присоединить к этому свойству тег и вести передачу через него (подход конечно загадочный. Теперь передаю и принимаю через порт без проблем. Да кстати торможений особых не заметил. А вообще спасибо за внимание. Покуда ждал ответа сам разобрался (жало что приходится все делать методом научного тыка) т.к. документации не хватает.


text

Построение системы опроса CPU в WinCC
Евгений; 17.1.03

Уважаемые коллеги! Как бы Вы построили циклический опрос 2-х CPU по протоколу MPI в ситуации, когда необходим обмен большими по размерам данными (используя циклы графического дизайнера, Global Script)? Какой размер RawDataTag'ов (в байтах) Вы считаете наиболее целесообразным в данной ситуации? Заранее благодарен за совет.

Re: Построение системы опроса CPU в WinCC
Юрий Оганесян; 27.1.03

Вопрос очень непростой. Дело в том, как организован обмен данными в WinCC. Согласно документации, если разработчик где-нибудь в проекте использует функцию GetTagXXX, то данный тэг регистрируется и в дальнейшем опрашивается с частотой в 2 раза превышающей частоту вызова GetTagXXX с занесением образа тэга в специально обученную область памяти. Это делается для того, чтобы уменьшить время отклика для WinCC, которая возьмет данные из этой самой области. Если же использовать GetTagWaitXXX, то тэг нигде не регистрируется и опрашивается один раз. По логике такой подход должен быть более щадящим, чем регулярные опросы. Ан, нет – если, например, в GS поставить цикл на 50 GetTagWait’ов, то время его работы будет очень даже ощутимо из-за того, что на это время будут заблокированы функции GD, такие как переход между экранами!! Поэтому я для себя определился, что raw тэги можно делать до 100 байт и опрашивать их GetTag ом – в такой схеме вроде все работает, не замедляя навигацию. А число таких тэгов… ну, думаю, штук 50-100 MPI потянет пару раз в минуту.

Re: Построение системы опроса CPU в WinCC
siemargl; 2.2.03

Извините, Юрий, но лажа-с

Re: Построение системы опроса CPU в WinCC
Евгений; 2.2.03

siemargl, ваши предложения?

Re: Построение системы опроса CPU в WinCC
Юрий Оганесян; 4.2.03

siemargl: Аргументы ?

Re: Построение системы опроса CPU в WinCC
Маслов Дмитрий; 5.2.03

Вопрос в том, что Вы хотите с этими большими объемами данных делать. И насколько велики объемы.

Для большинства задач достаточно применять обычные теги простых типов и привязывать их стандартным образом к графических элементам, архивам и сообщениям. RawDataTag целессобразно применять для организации быстрой архивации данных с проставлением метки времени в контроллере и для генерации сообщений в контроллере (также с проставлением там метки времени).
Re: Построение системы опроса CPU в WinCC
Евгений; 5.2.03

Маслову Дмитрию:

Объем данных примерно 10 килобайт. В них содержится информация, которую нужно анализировать, выводить на экран, архивировать и т.д с максимально возможной скоростью считывания и обработки. Если применять тэги простых типов, то их наплодится немеряное количество, что недопустимо (ведь количество внешних тэгов ограничено авторизацией). Поэтому выгоднее использовать RawDataTag'и для считывания таких объемов, а затем производить распаковку полученных данных.
Кстати, мне не удалось считать одним пакетом RawDataTag длиной более 250 байт. С чем это может быть связано?


text

Web Navigator
Игорь; 29.1.03

Господа, подскажите как можно решить следующую проблему.

На web клиенте стоит более низкое разрешение экрана, следовательно картинка проекта отображается не полностью (скролинг). Возможно ли сделать адаптацию изображения?
Re: Web Navigator
Чистяков Дмитрий ОАО "СеверСталь"; 29.1.03

Нет. Это не возможно просто одной кнопкой или галкой.

Это связано с тем, что масштабирование картинки делается самим пакетом WinCC. А оно не очень корректно работает даже в стандартном режиме клиент-сервер.
Re: Web Navigator
Л.Шерешевский; 5.2.03

Для автоматического масштабирования формы на web-клиенте в строке браузера следует дописать ?FitToSize=True

Пример можно посмотреть на http://www.wincc.de, однако, как заметил автор предыдущего сообщения, корректность масштабирования никто не гарантирует.

См. Центр компетенции WinCC


text

RS-232
Олег; 21.1.03

Господа, подскажите, можно ли связать с WinCC устройство(нестандартное) по RS-232 (через COM-порт компьютера).

Если нельзя напрямую, то может как то, через что нибудь (например DDE, OPC). Делал ли кто нибудь подобное. Может есть какие то примеры, исходники.
Re: RS-232
Iva; 22.1.03

Делал подобную вещь для связи WinCC и расходомера "Взлёт" через COM-порт.

Я просто заляпал на экран ActiveX элемент который обращается к порту. Правда он должен постоянно висеть на экране - при смене все контролы выгружаются.
Можно ещё написать свой драйвер с помощью CDK.

Re: RS-232
Л.Шерешевский; 5.2.03

Подобную задачу решали дважды, связывая WinCC с доморощенными устройствами по RS-323. В обоих случаях писали на VisualC++ отдельное приложение, работающее с последовательным портом. Взаимодействие с WinCC реализовывали по ODK. Если нужны подробности - пишите.

См. Центр компетенции WinCC


text

Антивирус для WinCC
Александр Туманов; 3.2.03

Какой антивирус лучше подходит для WinCC (хотя бы для инжиниринговой странции)?

Re: Антивирус для WinCC
Игорь; 3.2.03

С AVP у нас проблем не было. Стоит и на серверах, и на клиентах. База обновляется каждый день автоматически.

Re: Антивирус для WinCC
Чистяков Дмитрий ОАО "СеверСталь"; 5.2.03

У нас тоже AVP стоит и пока всё работает. :-)


text

Не задается шаг ползунка в WinCC
Хоружевский Роман; 5.2.03

При сипользовании Slider Object есть возможность указать минимальный шаг на который будет увеличиваться значение ползунка при нажатии на него мышкой, например Step 10. Но он почемуто все увеличивает на 1. В чем причина.


text

Признак наличия аварийного сообщения
Кирилов Владимир; 27.1.03

Господа! Мне хочется выводить на экран какие-нить символы как признак наличия активного сообщения в одной из групп Alarm Logging - признак, а не сам текст сообщений в окне сообщений места не хватит! Как это сделать? Уж очень не хочется в Global Script отслеживать все подряд сообщения и устанавливать/снимать какой-нить тэг !

Re: Признак наличия аварийного сообщения
Чистяков Дмитрий ОАО "СеверСталь"; 29.1.03

А чем не нравиться вызов какого либо кадра при появлении аварийного или какого либо конкретного сообщения?

Кадрик можно сделать маленьким и определить ему место на большом кадре. При появлении сообщения будет вызываться этот кадрик. А там уж что захочется, то и делай. Или фон (цвет) меняй или символ какой отображай и т.д.

Re: Признак наличия аварийного сообщения
Маслов Дмитрий; 5.2.03

Надо создать Group Message в Alarm Logging. Каждому такому "групповому сообщению" назначется либо тип/класс сообщений, либо перечень номеров. Групповому сообщению назначается статусный тег и в этот тег система будет заносить информацию о том, имеется ли хоть одно активное сообщение в группе.


text

Login / Logout
Iva; 4.2.03

Подскажите как в WinCC сделать Login/Logout по кнопкам. Комбинации клавиш - хорошо, но хотелось бы ещё и по кнопкам. В библиотеке есть множество системных кнопок, но они не работают. В хелпах написано что нужно установить "SFC Visualization". Что это такое и где достать?

Re: Login / Logout
Евгений Трунов; 4.2.03

Можно использовать функции PWRTLogin/PWRTLogout из pwrt_api.h, если в данном конкретном случае допустимо применение скриптов.

Re: Login / Logout
Iva; 4.2.03

Спасибо за информацию.

Надо будет установить опцию ODK.
И можно будет набирать код........

Re: Login / Logout
Маслов Дмитрий; 5.2.03

Можно взять готовое окно, вызываемое по кнопке, из Demo-проекта WinCC (он есть на диске с WinCC). Нужно будет только перевести названия кнопок с английского на русский.


text

Как сформировать архив?
Lidiya; 4.2.03

Добрый день!

Необходимо формировать архив расхода сырья по видам дневной/месячный. Как это лучше реализовать в WinCC? Нужно ли использовать опцию User Archivers?
Заранее спасибо.

Re: Как сформировать архив?
Евгений; 4.2.03

Можно все! Смотря что Вы хотите делать с этим архивом. Если Вы хотите работать с другой СУБД, отличной от Sybase (если Вам так удобней), то создаите свой Active-X, или используйте ODBC, или ODK для соединения c БД и работы с ней. Если Вас устраивает Sybase и необходимы только простейшие операции с таблицами БД, то используйте UserArchive и функции UA

Re: Как сформировать архив?
Маслов Дмитрий; 5.2.03

Нужно уточнить, откуда берется значение расхода сырья? Если оператор должен его заносить вручную, то дело обстоит именно так, как описал Евгений. Если же это некий измеряемый/вычисляемый системой параметр, то можно обойтись более стандартными средствами.

Можно в Tag Logging создать свой таймер, который, к примеру, будет срабатывыть в 0:00 ежедневно. И создать архив требуемых вам параметров с опросом, к примеру, раз в минуту и архивацией по вновь созданному таймеру. При этом можно задать, как будут обрабатываться ежеминутные значения - усредняться, суммироваться -за сутки.


text

Соотношение толстых и тонких клиентов
Александр Туманов; 31.1.03

Как выбирается количественное соотношеение толстых и тонких WinCC-клиентов? Действительно ли допускаются только крайние варианты (для V5):

1. 16 толстых и 3 тонких.
2. 50 тонких и один толстый.

Re: Соотношение толстых и тонких клиентов
siemargl; 2.2.03

RTFM:: есть проверенные конфигурации, а есть остальные..


text

Связать S7-200 c WinCC
Андрей Таранов; 3.4.01

Нам необходимо связать компьютер с WinCC (менее 128 сигналов в системе) с сетью MPI или PPI - не знаю какая будет предпочтительней, с контроллером S7- 200, сначала с одним в перспективе еще с 10-20, на экране нужно иметь картинку с мнемосхемой, должна быть возможность оперативно перелючаться между котроллерами или иметь несколько наиболее важных сигналов с каждого контроллера одновременно на одной мнемосхеме.
Особенности - длина сегмента между компьютером и контроллером ~500м
какие нужны для такой системы аппаратные и программные средства
Заранее спасибо А.Таранов.
Re: Связать S7-200 c WinCC
Чистяков Дмитрий; 4.4.01

Если требуется подключить несколько контроллеров, то однозназно MPI.

В персоналку можно приобрести любой коммуникационный процессор из CP5611, CP5511, CP5613. Последний более предпочтителен, так как большую часть по работе с сетью берёт на себя, разгружая CPU компьютера.
Все Ваши PLC, Вы подключите без проблем к WinCC. В проекте вы создаёте тэги, и размещаете их по Вашему желанию - хоть все на одном кадре хоть по одному на каждый кадр. При этом нет ни какой разницы к какому PLC относиться тот или иной тэг.
Более подробно почитайте описание WinCC, благо оно имеется и на русском языке на этом же сайте.
Re: Связать S7-200 c WinCC
Никаноров В. - Сименс; 4.4.01

WinCC может связываться только с новой серией контроллеров S7-200: 220 серия.

Причем связь возможна только через MPI через S7-OPC сервер.
Более подробно см. CustomerSupport
См. http://www.ad.siemens.de/simatic-cse

Уточните пожалуйста
Андрей Таранов; 5.4.01

Про СР5613 понятно про MPI тоже понятно

у меня дальность между контроллерами и между компьютером и ближайшим контроллером 500-700м,
нужны-ли репитеры,если да,то какие?
нужны ли модули ЕМ277 в S7200 - CPU224, какую применить топологию сети?(объекты хаотично распределены по некоторой площади,на каждом объекте по контроллеру ,расстояние между объектами ~500-700м.) Скорость обмена данными не критична.
Заранее спасибо. А.Таранов.
Связь с S7-200
vzozulja; 17.4.01

Недавно написал DDE-сервер для связи S7-200 с WinCC по PPI.

Работает и с S7-21x и через PC/PPI-кабель.
Подключаться через CP5611/OPC мрачно.
- описание есть на сайте поддержки

Связь с S7-200
Кузьменко; 23.6.01

Спомощью каках именно драйверов необходимо связыватся с S7-22х, какая версия WinCC необходима

Re: Связать S7-200 c WinCC
Роман Абзаев; 23.1.03

http://www4.ad.siemens.de/csinfo/livelink.exe/11515829?func=cslib.csinfo&objId=11515829&objAction=csView&foldersopen0=-155-156-157-206-207-214-208-220-605-628-634-635-641-&nodeID0=10805590&lang=en&siteid=cs&aktprim=0

Re: Связать S7-200 c WinCC
siemargl; 2.2.03

Давно пора в FAQ.. зае#$%


text

Update ProTool CS/Pro V5.2 to V6.0
Гугучкин Юрий; 29.1.03

При обновлении большая часть файлов оказалась нулевой длины.

Это глюк моей версии или с этим борются?
Re: Update ProTool CS/Pro V5.2 to V6.0
Baby; 30.1.03

Привет, Юрий !

К сожалению, при переходе с ProTool CS/Pro V5.2 to V6.0, возникает ряд не очень приятных моментов, начиная от того, что (было у меня) грохаются сетевые адреса в ProTool и заканчивая "кривлением" присвоений имён переменных.

Не понял, у Вас "большая часть файлов оказалась нулевой длины".
Каких именно ?

Пока.....


text

MS SQL и WINCC
Игорь; 22.1.03

Есть проект на Wincc, в котором данные сохраняются в User Archive, а затем через каждые 15 минут SQLсервер сам по запросу забирает данные.

Есть ли возможность запускать процедуру экспорта данных на SQL сервере по событию на WINCC???
Очень нужно. СРОЧНО.
Re: MS SQL и WINCC
Юрченко Владимир; 24.1.03

В скриптах WinCC запускаете

Execute program ("...");
где в строке-параметре вызывете утилиту isql.exe (или osql.exe) MS SQL Servera с параметрами для выполнения нужной SQL транзакции. Параметры для утилиты смотрите в Help'ах SQL Server'а.


text

Открыть окно по ссылке
Иван Жуков; 23.1.03

Я бы хотел, чтобы при нажатии на изображение в документе, выводилось окно поверх текущего документа(меньше размером), в котором можно было отобразить другой документ и работать с ним, а потом закрыть и вернуться на предыдущий. В WinCC есть возможность делать что-то подобное, но документ полностью перекрывает предыдущий - это не совсем то, что мне надо.

Re: Открыть окно по ссылке
Евгений; 23.1.03

Попробуй Picture Window


text

Реализация выпадающего списка в WinCC
Руслан; 17.1.03

Люди !!! Поделитесь пожалуйста опытом создания выпадающего списка в WinCC, например с помошью элемента activeX Siemens HMI Combobox 1.0 .

В общем проблема возникает при занесении туда собственно списка как это стелать средсвами Си ?
Заранее благодарен.
Re: Реализация выпадающего списка в WinCC
Евгений; 17.1.03

Сколько я ни пробовал занести список в WinCC'евский Combobox(ActiveX Control), ничего так и не получилось. Проблема решилась созданием своего ActiveX'а выпадающего списка. Сделали его на плюсах, хотя можно хоть на Delphi, хоть на Basic'е :)

Re: Реализация выпадающего списка в WinCC
Алексей Понасенко; 20.1.03

В демопроекте Demo5 есть пример.

(Выбор распечатки сообщения)
Можешь скопировать с соответсвующими тэгами.Отредактировать и пользуися.


text

Как соедениться с OP5 черес компьютер
Зубарев; 17.1.03

Есть программа COM TEXT - дополнительный пакет к Step 5. Не получается связаться с панелью чтобы скачать программу с панели.


text

OP17 и утилита ProSave из ProTool 6.0
Рыков Андрей; 15.1.03

Здравствуйте !

Перешли не версию ProTool 6.0.

Как используя ProSave из ProTool 6.0, которая внешне по сравнению с 5.x сильно изменилась, делать бэкапы с панели OP 17, ведь ее нет в списке доступных панелей ?

С уважением,
Рыков Андрей, "Веда-Система"

Re: OP17 и утилита ProSave из ProTool 6.0
Юрченко Владимир; 15.1.03

Используйте утилиту ProTool\Utility\Prosave.exe, которая предназначена для панелей ***7 и имеет досовский интерфейс. Для новых панелей используется ProTool\Utility\ProSave\PTProsave.exe


text

Внимание! Предлогаю обмен
Павел; 14.1.03

У меня есть схемы электрические принципиальные на модуля контроллера S7 : SM331, SM332, ET200, CPU316, SM321, SM322. Есть схема Simocode. А также многое другое в формате Orcad (легко конвертируется в Autocad). Мне нужна копия дистрибутива WebNavigator Server. Ключ не надо. Если понравится - купим легально.

Re: Внимание! Предлогаю обмен
Юрченко Владимир; 14.1.03

Зачем усложнять - обратитесь в представительство Сименс, для пробы дадим дистрибутив.

Попробовать Web-Navigator можно только с соответсвующей версией WinCC.


text

Text Library
Константин; 10.1.03

Список в Text Library пухнет после изменений в таблице Alarm Control. Например, изменяю размер блоков и порядок их расположения, после чего в библитечке появляются штук 30 записей, которые существуют перед этим, правда в другом порядке.

Как с этим бороться? или диск большой, можно и потерпеть :-))?


text

Преобразование в тип DATE
Денис; 6.1.03

Помогите пожалуйста разобраться со следующей проблемой. Необходимо чтобы пользователи вводили временной интервал, а на основании его выставлять свойства для комопнента WinCC Online Table Control - BeginTime и EndTime. Эти свойства имеют тип DATE. Дату получаем из компонента ActiveX и записываем ее в тэг Float. Как на основании этого тега установить изменение временного интервала комопненте WinCC Online Table Control.

Re: Преобразование в тип DATE
Юрий Оганесян; 8.1.03

Тип DATE хранит дату в следующем формате: до запятой - дней с 1900 года, после запятой - время в секундах.

Если непонятно - давай мыло, скину пример.

Re: Преобразование в тип DATE
Евгений Трунов; 9.1.03

Вопрос уже обсуждался когда-то (тред "TlgOnlineTrendControl" от 13.08.2002). Можно прямо задавать вместо DATE в BeginTime и EndTime строки вида "09.01.2003 17:14:51".


text

Runtime error 201
Павел Власкин; 9.1.03

при активизации проекта вылетает runtime error 201

куда копать?
Ситуация возникла в процессе раскорячивания старого проекта на новый идентичный объект (резервуарный парк)
Я понимаю, что это не хорошо :) но деваться уже некуда, нужно до победного.

Re: Runtime error 201
Павел Власкин; 9.1.03

Вдогонку WinCC 5.0 sp1


text

web-multi-client
Александр Туманов; 4.1.03

Существует ли в принципе (не средствами WinCC) возможность на одной web-страничке отображать данные (из OPC и Sybase) с нескольких IIS серверов. Если - да, то какие?

Re: web-multi-client
Юрий Оганесян; 5.1.03

Чё-то я вопрос недопонял. Так данные нужно все-таки брать из SQL– server’ов ? Тогда, например с использованием технологии ASP (когда страничка формируется на стороне сервера), их можно брать с любых компьютеров в том числе и нескольких. А что ты имел ввиду когда говорил «брать данные с нескольких IIS серверов» ? Если не рассматривать технологии типа ASP, CGI, ActiveX и т.д., то на IIS серверах лежат html-ины, по сути – текстовые документы, и как оттудова можно какие-то данные получить для формирования «одной web-странички» ? В два фрейма, конечно, можно вывести, но это не то, что тебе нужно, наверное…

Re: web-multi-client
Александр Туманов; 5.1.03

Некие технологические переменные архивируются на разных серверах, а на одной web-страничке нужно получить консолидированную таблицу, в которой отображаются и суммируются переменные из заданного временного диапазона. В EXCEL я такое уже сделал, а вот на web только учусь. Суть вопроса - нужно ли для решения этой задачи создавать отдельный IIS-сервер, который будет как-то обращаться к другим WinCC-серверам (через OPC, ODBC?) по запросам от web-клиентов, причём так, чтобы на стороне web-клиентов кроме Internet Explorer никакого дополнительного софта не было (такого как Web Navigator Clien).

Re: web-multi-client
Юрий Оганесян; 8.1.03

Нет, страничку можно разместить на любом существующем IIS.


text

OPC XML
Александр Туманов; 5.1.03

В руководстве по SIMATIC NET MN_OPC_76.chm есть описание примеров, в том числе и OPC XML. Но самого исходника примера нет (другие есть). Скачал примеры

http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&siteid=cs&lang=en&objid=10805878&aktprim=0&objaction=csopen
там тоже нет. В каталоге \\Program Files\SIEMENS\SIMATIC.NET\OPC2\SAMLES тоже нет. Где есть?


text

op5
Яковлев Михаил АОММЗ; 28.12.02

Панель ОР5 была запарамметрированна в

ProTool. Необходимо заменить панель, но нет программы. Как можно это сделать? Может как-то выгрузить код с панели и затем загрузить в другую панель (тоже ОР5), но как, это сделать? Я слышал, что есть какая-то программа для этого.
Re: op5
Юрченко Владимир; 30.12.02

Для этих панелей был пакет COMText. Он и для редактирования проекта и для функций downoad/upload.

Re: op5
Яковлев Михаил; 3.1.03

Спасибо за ответ Владимир. Если возможно, тогда скинь на ящик этот пакет (место есть).


text

1 тег - 2 сообщения
Гость; 20.4.04

Когда привязываешь два сообщения к одному тегу (одно по нарастающему, др - по падающему фронту), в рантайме отображается только одно...

Напр., это нужно если один тег на сигнализацию работы задвижки (0 - закр, 1 - откр) и нужно отслеживать оба события...
Как быть?

Re: 1 тег - 2 сообщения
Маслов Дмитрий; 20.4.04

Да, действительно два сообщения по одному тегу не работают.

Можно поступить двумя способами:
1. Сделать одно сообщение по этому тегу с текстом "задвижка такая-то", а классу сообщений, к которому она относится задать статусные тексты "ОТКР" и "ЗАКР" вместо стандартных "+" и "-" (естественно, класс сообщений должен быть с двумя статусами - пришедшее и ушедшее).
В результате будут появляться сообщения вида:
ОТКР Задвижка такая-то
или
ЗАКР Задвижка такая-то

2. Если тег идет из контроллера, можно сделать в контроллере его инвертированный дубликат, и второе сообщение сделать по нему. У Вас тогда будет один тег на состояние "Открыта" и один тег на состояние "Закрыта".

P.S. А вообще, для задвижки "не открыта" не означает "закрыта", т.к. у нее есть промежуточное состояние.
Re: 1 тег - 2 сообщения
Гость; 20.4.04

спасибо за ответ

с 1-м способом непонятки, в message window отображается нормально только приходящее сообщение (ОТКР), уходящее отображается с пустым статусом (а должно быть ЗАКР),
НО в архиве при этом оба сохраняются в нормальном виде (со статусом ОТКР и ЗАКР)

короче решил что проще продублировать тег, и привязывать второе сообщение по ниспадающему фронту к второму тегу.
Re: 1 тег - 2 сообщения
Маслов Дмитрий; 20.4.04

Да, первый способ - это для архива. А в Message Window, когда сообщение ушло, у него используется не текст статуса "ушло", а текст статуса "пришло/ушло". Чтобы не было там пустой строки, поменяйте в настройках класса текст этого статуса (по умолчанию он "+/-").


text

100 тагов или 2 секунды???
Михаил; 1.9.04

Че лучше стаить на событие: обновление 100 внутренних тагов или стандартный 2-хсекундный цикл???

Re: 100 тагов или 2 секунды???
Маслов Дмитрий; 1.9.04

Честно говоря, мне ни то, ни другое не нравится... Наверняка можно обойтись без 100 внутренних тегов, например, завести глобальные переменные, или вынести реализуемую на WinCC логику в контроллер. Что Вы хотите в итоге получить?

См. http://www.wincc.ru

Re: 100 тагов или 2 секунды???
для Маслова Д.; 1.9.04

в итоге рисуется 4-е графика на одной картинке по 100 значениям. у меня уже сделано зеркало PLC только в WinCC. я сделал на внутренних тагах.

глобальные переменные??? у меня пока 3-и насоса. на каждый рисуется график в окне настроек насоса. т.е. получится много переменных. низнай че лучше. я то новичек в этом деле :(
Re: 100 тагов или 2 секунды???
Маслов Дмитрий; 2.9.04

1. Не понял, зачем нужно дублировать внешние теги внутренними.

2. По поводу графика по 100 значениям: Вы что, его вручную рисуете? А чем не устроил стандартный элемент Online Trend или Function Trend?
Re: 100 тагов или 2 секунды???
->Маслов Дмитрий; 2.9.04

Я использовал ActiveX сомпанент фирмы Nationl Instrument.

(рисует графики)

Дублировать - создаю зеркало (чтобы изменение не касалось PLC) т.е. данные в PLC попадают только когда пользователь нажмет кнопку ЗАПИСАТЬ
Re: 100 тагов или 2 секунды???
Богдан; 7.9.04

А какой ActiveX ?

Дайте ссылку или вышлите директом на
tandem@il.if.ua

Спасибо
Re: 100 тагов или 2 секунды???
Yrok; 13.9.04

Cлушай если утебя есть этот ocx и плюс лицензия то вышли пожалуйста на почту,

а то я долго искал на него лизенцию да так и бросил что в конце концов и сам ocx удалил.
А по поводу отображения графиков, что если тебе надо посмотреть состояние твоего насоса год назад? вот тут и нужен родной Online Trend или Function Trend.
minchenkov@BK.ru
заранее спасибо.
Re: 100 тагов или 2 секунды???
я; 16.9.04

всем пошлю :)

но только в понежельник! я в отпуске пока...<


text

1000 строк в AlarmLoggin?
Юрий; 6.1.04

Как сделать, чтобы в AlarmLoggin отображалось больше 1000 строк в LongTerm архивах, например 2000 строк?

Re: 1000 строк в AlarmLoggin?
Макс Прилепский, ОАО "ЗСМК"; 8.1.04

Ограничение на вывод последней тысячи строк архива существует в самом ActiveX - компоненте Alarm Logging. Используйте фильтрацию для отображения нужного диапазона сообщений.

Re: 1000 строк в AlarmLoggin?
Роман; 3.3.04

А можно подробнее, что других способов нет совсем? Получается нужно писать фильтр и там задавать ему диаппазон времени, ну а количество строк тоже там задается?

Re: 1000 строк в AlarmLoggin?
Макс Прилепский; 4.3.04

С фильтром или без, ограничение на 1000 строк заложено в сам компонент отображения сообщений.


text

16 -> 10
Михаил; 3.9.04

Люди! не подскажите как на VBS преобразовать из 16-ого числа в 10-ое?

В PLC формат DATE_AND_TIME числа в декодах, а когда считываешь то они становятся нереальными :-/

нужно обязательно на VBS...
на С то все просто: sprintf(buf,"%x",chislo);
Re: 16 -> 10
Ирина; 3.9.04

Function HexToDec(Byval dig)

Dim i
Dim str

str = 0
dec = 0

For i = 1 To Len(dig)
str = -1
If(Asc(UCase(Mid(dig, i, 1))) >= 48 And Asc(UCase(Mid(dig, i, 1))) <= 57) Then
str = Asc(UCase(Mid(dig, i, 1)))-48
End If
If(Asc(UCase(Mid(dig, i, 1))) >= 65 And Asc(UCase(Mid(dig, i, 1))) <= 70) Then
str = Asc(UCase(Mid(dig, i, 1)))-55
End If
If(str = -1) Then
MsgBox "!!!"
End If
str = str * (16^(Len(dig)-i))
dec = dec + str
Next

End Function
Re: 16 -> 10
-> Ирина; 3.9.04

Канечно большое спасибо что ответили, но мне немого другое нада...

число 31 отображается в PLC в декодах, т.е. есил его считать, то будет 49. Т.е. мне надо преобразовать число 49 в 31. как бы наоборот :)

мне канечно лень но придется наверное самому писать... (методом деления на 16) я думал что есть ченить уже написаное в VBS
Re: 16 -> 10
-> Ирина; 3.9.04

мне вот че нада было:

Function HexToInt(Byval dig)
Dim str,dec
dec=dig
str = ""
Do
dec = dec Mod 16
str = str + String(1,dec+48)
dec = (dig - dec) / 16
Loop While dec > 15
str = str + String(1,dec+48)
str = StrReverse(str)
HexToInt = str
End Function
Re: 16 -> 10
Л. Шерешевский; 3.9.04

Вот одно непонятно: неужели никак нельзя обойтись без сетевого сленга, характерного для малолеток, бравирующих своей безграмотностью и пренебрежением к русскому языку?

Теперь к существу дела.

1. Вопрос был поставлен некорректно. На самом деле требовалось найти способ преобразования числа из формата BCD (Binary-Coded Decimal) в формат обычного десятичного числа. Шестнадцатиричный формат здесь ни при чем.

2. В результате выполнения sprintf(buf, "%x", number); в buf будет помещена строка, содержащая шестнадцатиричное представление числа. К преобразованию из BCD это не имеет никакого отношения.

3. В WinCC все делается проще. Достаточно при описании внешних тегов, связанных с элементами DATE_AND_TIME, в поле 'Adapt format' диалога настройки тега выбрать соответствующее преобразование, например, WordToBCDWord.

4. Чтобы функция, предложенная Ириной, заработала, в нее в качестве последней операции надо добавить строку HexToDec = dec
-> Л. Шерешевский;
миша; 5.9.04

:-)

1. глубоко извиняюсь за свою безграмотность (ну привык я в icq так писать, тут уж не переделаешь меня наверное), а насчет некорректности вопроса - да это так.
А за совет огромное спасибо, так и сделаю.

2. Не будете ли Вы так любезны проконсультировать меня еще по одному вопросу:
а. почему когда у меня при вызове функции приведенной ниже русские буквы отображаются совсем не русскими :) (а закорючками разными)??? а если взять этот код и вставить непосредственно в текст обработки события то с русскими буквами все нормально становится. :-/
(английские буквы отображаются нормально)
Function GetErrorMessage(Byref j, Byref i)

Dim mess(100),buf
Dim m1(8),m2(4),m3(10), m4(7), m5(5)
m1(0) = "резерв"
m1(1) = "< LL"
m1(2) = "< L"
m1(3) = "> H"
m1(4) = "> HH"
m1(5) = "Нет сигнала"
m1(6) = "Ошибка сигнала"
m1(7) = "Нет связи"

.......

If i < 17 Then
buf = m1(j)
End If

If i > 20 And i < 27 Then
buf = m2(j)
End If

If i > 30 And i < 53 Then
buf = m3(j)
End If

If i > 60 And i < 82 Then
buf = m4(j)
End If

If i > 90 And i < 95 Then
buf = m5(j)
End If

GetErrorMessage = mess(i) + buf
If i < 17 Then
buf = m1(j)
End If

If i > 20 And i < 27 Then
buf = m2(j)
End If

If i > 30 And i < 53 Then
buf = m3(j)
End If

If i > 60 And i < 82 Then
buf = m4(j)
End If

If i > 90 And i < 95 Then
buf = m5(j)
End If
GetErrorMessage = mess(i) + buf
If i < 17 Then
buf = m1(j)
End If

If i > 20 And i < 27 Then
buf = m2(j)
End If

If i > 30 And i < 53 Then
buf = m3(j)
End If

If i > 60 And i < 82 Then
buf = m4(j)
End If

If i > 90 And i < 95 Then
buf = m5(j)
End If

GetErrorMessage = mess(i) + buf
If i < 17 Then
buf = m1(j)
End If

If i > 20 And i < 27 Then
buf = m2(j)
End If

If i > 30 And i < 53 Then
buf = m3(j)
End If

If i > 60 And i < 82 Then
buf = m4(j)
End If

If i > 90 And i < 95 Then
buf = m5(j)
End If

GetErrorMessage = mess(i) + bufIf i < 17 Then
buf = m1(j)
End If

If i > 20 And i < 27 Then
buf = m2(j)
End If

If i > 30 And i < 53 Then
buf = m3(j)
End If

If i > 60 And i < 82 Then
buf = m4(j)
End If

If i > 90 And i < 95 Then
buf = m5(j)
End If

GetErrorMessage = mess(i) + buf
End Function
-> Л. Шерешевский;
миша; 5.9.04

:-)

1. глубоко извиняюсь за свою безграмотность (ну привык я в icq так писать, тут уж не переделаешь меня наверное), а насчет некорректности вопроса - да это так.
А за совет огромное спасибо, так и сделаю.

2. Не будете ли Вы так любезны проконсультировать меня еще по одному вопросу:
а. почему когда у меня при вызове функции приведенной ниже русские буквы отображаются совсем не русскими :) (а закорючками разными)??? а если взять этот код и вставить непосредственно в текст обработки события то с русскими буквами все нормально становится. :-/
(английские буквы отображаются нормально)
Function GetErrorMessage(Byref j, Byref i)

Dim mess(100),buf
Dim m1(8),m2(4),m3(10), m4(7), m5(5)
m1(0) = "резерв"
m1(1) = "< LL"
m1(2) = "< L"
m1(3) = "> H"
m1(4) = "> HH"
m1(5) = "Нет сигнала"
m1(6) = "Ошибка сигнала"
m1(7) = "Нет связи"

.......

If i < 17 Then
buf = m1(j)
End If

If i > 20 And i < 27 Then
buf = m2(j)
End If

If i > 30 And i < 53 Then
buf = m3(j)
End If

If i > 60 And i < 82 Then
buf = m4(j)
End If

If i > 90 And i < 95 Then
buf = m5(j)
End If

GetErrorMessage = mess(i) + buf
End Function<


text

Alarm Log пишет в Text Library
Клейн Александр; 26.2.04

Здравствуйте!

Не поможет ли кто решить такую проблему: при первом запуске Alarm Logging пишет в текстовую библиотеку некоторые свои слова, типа Date, Time, Number и т.д. Но делает он это поверх уже существующих слов! И чем больше в Alarm Logging работаешь, тем больше он портит текстовую библиотеку. Может где-то можно указать, в какие строки он должен писать, как, например, сделано в User Archive? Или как-то по другому это можно все решить?<


text

Alarm Loggin
Миша; 2.10.04

Господа знатоки подскажите пожалуйста как быть.

Как в Аларм Логгине сделать так чтобы например в одной картинке отображались одни ошибки, а в другой - другие.
Т.е. нада класифицировать ошибки.
Re: Alarm Loggin
Миша; 2.10.04

Вопрос закрыт. я разобрался как это сделать.

Re: Alarm Loggin
Александр Родин, ООО "Нева Электрик"; 4.10.04

Ну вы сами может и разобрались, а вот для остальной публики может тоже было бы интересно.. ;)

Хотя и так понятно, что там надо прописать строчку с фильтром.
Re: Alarm Loggin
Миша; 5.10.04

RE Александр Родин.

Немного не так :)
Нужно просто создать свой MessageClass в AlarmLoggine и потом указать его в тренде, тогда будут выводится ошибки только этого класса<


text

Alarm Loggin
Мифка; 1.12.04

Подскажите пожалуйста вот я настроил ЛонгАларм на хранение архива за неделю (и ограничил его 1000 МБайт), так вот он по объему совсем маленький еще, а сообщений уже намного больше 1000...

Как мне посмотреть сообщения которые были например два дня назад? (так как в нем отображается 1000 сообщений, причем они уже были за этот день)

и где эта настройка (ограничение в 1000 сообщений)
Re: Alarm Loggin
Александр Родин, ООО "Нева Электрик"; 1.12.04

ну можно в настройках контрола указать в тулбаре кнопочку "Select", а потом в RT при нажати на нее настроить фильтр отображения, в том числе и по времени.

А можно через скрипт менять параметр этого же контрола MsgFilterSQL, прописывая в него требуемую строку запроса, точнее параметры запроса.
Re: Alarm Loggin
Мифка; 1.12.04

Спасибо :)

попробую.

а вот насчет этих 1000 сообщений чего? можно ли их изменить? сделать больше или меньше...
Re: Alarm Loggin
Александр Родин, ООО "Нева Электрик"; 1.12.04

Можно.

для этого нужно изменить какой-то ключик в реестре, но не помню какой.. :)
В принципе, эт вопрос уже обсуждался где-то года 2 назад, просто надо полапатить форум. :) А может кто знает, раньше откликнется.<


text

Alarm Logging в WinCC 6 .......
Игорь Одесса; 2.2.04

Уважаемые Господа!Подскажите, что происходит - при загрузке runtime,выбрасывается окно следующего содержания: заголовок - Microsoft Visual C++ Runtime Library.

Текст - Runtime Error!
c:\..path..\CCWriteArchiveServer.exe abnormal programm termination.
Какого оно мне вылазит??
Re: Alarm Logging в WinCC 6 .......
Маслов Дмитрий; 3.2.04

Для начала проверьте, в чем причина - в проекте, или в установке WinCC. Создайте пустой проект, включите в нем запуск Alarm Logging. Если на нем ошибка не проявится - ищите ее в Вашем проекте.

Если проявится - переустановите WinCC. Причем ставьте на чистую машину: сначала format c:; потом винда + сервис паки; потом SQL Server и wincc. Ничего лишнего не ставьте. Все будет работать.
Re: Alarm Logging в WinCC 6 .......
Игорь Одесса; 3.2.04

Я уже проверял - ошибка выскакивает даже в "чистом" проекте. А может как нибудь без format? ;) Я уже третий раз за неделю винду ставлю, наконец то все нормально стало, кроме WinCC. Может SP1 для WinCC 6.0 поможет ?Подскажите где его взять ?

Re: Alarm Logging в WinCC 6 .......
Маслов Дмитрий; 3.2.04

SP1 можно взять в ближайшем представительстве Siemens. Но учитывая, что в WinCC Service Pack - это не отдельный пакет, а полный инсталлятор WinCC, Вам все равно придется ее переустанавливать. Так что рекомендую делать это на чистой машине.

Re: Alarm Logging в WinCC 6 .......
Евгений, Ангарск; 7.4.04

Re: Alarm Logging в WinCC 6 .......
Горлов Евгений; 1.7.04

после внесения изменений в реестре HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage

"1250"="c_1251.nls"
"1252"="c_1251.nls"
и перезагрузки ошибка не вылезала<


text

Alarm Logging, Process value
Ирина; 19.7.04

Последовательно поступают два тега. Сначало тег значения процесса, участвующий в Process value, потом тег, по изменению бита которого приходит сообщение. Таким образом, сообщение приходит со старым значением в Process value.

Есть ли в Alarm Logging какая-либо опция, архивировать сообщение только после обновления тегов в Process value? Или придется ставить задержку между приходом первого и второго тега?
Заранее спасибо!
Re: Alarm Logging, Process value
Svetozar Yolov; 23.7.04

Dear Irina,

The problem is that the Alarm Logging has it own acquisition cycle. You have first to update the Process Value tag, then to put some delay about 2 sec and then to triger the message bit. For this you can use Sleep(value of milliseconds) function. Here is the example:
#pragma code("kernel32.dll")
void WINAPI Sleep(DWORD dwMilliseconds);
#pragma code()

Also there is an example relted to create message when logging on but it related exactly to your problem. Here is the link:

http://www4.ad.siemens.de/-snm-0135030360-1088511457-0000001108-0000000000-1090574343-enm-WW/skm/newSKM/frameset.asp?markerurl=%2FWW%2Fllisapi%2Edll%3Ffunc%3Dll%26objID%3D6232967%26objaction%3Dcsview%26lang%3Den%26siteid%3Dcseus&lang=en&aktprim=0&siteid=cseus&query=message%20user%20log&searchinprim=0&nodeid0=10805585&BID=6232967&cur_pos=0

I hope this will help.

Best regards,
smi<


text

Alarm Logging
Николай; 21.9.04

При создании сообщения, устанавливаю для него бит в каком-то таге квитирования. Если сообщения приходит, то я могу его заквитировать, установив этот бит. Но проблема в том что этот бит не сбрасывается а так и стоит. И когда сообщение возникает опять, я таким образом не могу его заквитировать. Что это глюк, или оно так и должно быть?

Re: Alarm Logging
Лёха; 21.9.04

Ну а сбрасывать тэг квитирования кто будет то? Дядя Вася что ли? Самому надо сбрасывать этот тэг или через контроллер, или ещё как.


text

Alarm Logging
Александр; 11.11.04

Как заставить в тревогах или сообщениях пришедшее сообщение или тревогу мигать с определенной частотой..

Re: Alarm Logging
Александр Родин, ООО "Нева Электрик"; 11.11.04

Дык при подготовке блоков для сообщений, в них есть свойство мигание при приходе сообщения.

RTFM<


text

alarm-8
Грегорий; 9.11.04

Просьба пояснить:

Имею 320 сообщений (битовые). Чтобы получить сообщение об их изменение в Wincc Я должен 40 раз вызвать функцию Alarm-8 с соответсвующими параметрами, или тут иной механизм. Метод Scan меня не интересует. И сколько времени выполняется один такой вызов напрмер для 416 CPU?

<


text

AlarmLogging выводит предыдущее значение тега в поле ProccessValue
Hied; 29.11.04

Здравствуйте, эксперты!

У меня следующая проблема: в Alarm Logging создал сообщение, в поле ProccessValue прописал тег. Так вот при появлении этого сообщения в поле ProccessValue появляется предыдущее значение этого тега. А мне нужно, чтобы в этом поле было текущее значение тега. Помогите, пожалуйста с этой траблой! Делаю все правильно: сначала меняю значение тега, а потом вызываю сообщение при помощи MessageTag. Неужели это так задумано в Alarm Logging? Или это баг? А как тогда вывести текущее значение?
WinCC 6.0 SP2

Заранее спасибо!<


text

AlarmLogging
Роман; 4.11.04

Допустим существует в Alarm Logging множество сообщений разных классов и типов, они регистрируются в длинном архиве...Оператор захотел посмотреть конкретные сообщения по конкретному объекту за конкретное число или числа...Есть ли какой-нибудь инструмент что-бы систематизировать сообщения выделяя нужные или надо рыться в данной куче сообщений и искать необходимые в данный момент...

Re: AlarmLogging
Alexis; 5.11.04

А нужный SQL-запрос в стандартном контроле прописать?


text

AlarmLoging
Роман ; 6.7.04

Возможно ли вызывать сообщение из скриптов, а не по изменению тагов.

Re: AlarmLoging
Александр Родин, ООО "Нева Электрик"; 6.7.04

А какая разница? Установите скриптом сигнальный бит и получите сообщение... :)


text

AlarmLoging
Роман ; 6.7.04

Возможно ли вызывать сообщение из скриптов, а не по изменению тагов.

Re: AlarmLoging
Лев Шерешевский; 6.7.04

Да, возможно. Если нужен пример, укажите Ваш электронный адрес.

Re: AlarmLoging
Роман ; 7.7.04

morra@stal.ru

Заранее спасибо.
Re: AlarmLoging
Ирина; 7.7.04

Очень интересная тема. А можно пример также прислать на sosnina@binar.ru.

Заранее спасибо.
Re: AlarmLoging
Alexis; 7.7.04

Дык в WinCC-шнем хелпе есть пример.

Re: AlarmLoging
marina; 9.7.04

rumarinaa@mail.ru

Спасибо.
Re: AlarmLoging
Л. Шерешевский; 9.7.04

Пример выслал всем заинтересованным.

Если понадобится кому-либо еще, пожалуйста, пишите напрямую, не засоряйте форум. <


text

Analog Display (extended)
Смирнов Дмитрий ; 3.6.04

Добрый день!

Может кто подскажет, как правильно управлять состоянием этого компонента.

<


text

Anton
Как распечатать DB-шки в STEP7???; 24.11.04

При распечатке в STEP7 DB-шки вместо русских букв абракадабра!

Кто знает что делать?
Re: Anton
Сидоров Артем; 24.11.04

Попробуйте опцию Print to File, а затем полученный файл послать на LPT порт(если принтер LPT-шный).

Re: Anton
Hied; 24.11.04

Мы делали так: открывали Word, переключались на STEP7, жали на PrintScreen, переключались в Word, жали Ctrl+V (или Shift+Ins). И так все DB-шки. Через одно место, конечно, но быстро и без проблем.

Re: Anton
Дмитрий; 25.11.04

Все на много проще!!!

В ладоре ставишь шрифт Courier при этом шрифты на экране будудт не особо, зато на принтак проблем не будет, да и в PDF файл печатоется.
Re:
Anton; 29.11.04

Что за "ладоре"?

Re: Anton
Сидоров Артем; 30.11.04

Думаю имеется в виду LAD.

Re:
Anton; 1.12.04

Когда ставлю Courier на экране нормально, а печатается всеравно абракадабра..


text

apdiag.exe Че это значит и как победить?
ОАО "Маяк" г.Пенза, Миша; 6.10.04

ActSteu: 1226.837002 msec ====================================OnErrorExecute====================================

ActSteu: 1226.882418 msec dwErrorCode1: (ThreadId 4332) 1007007
ActSteu: 1226.920899 msec dwErrorCode2: (ThreadId 4332) 2
ActSteu: 1226.961180 msec szErrorText: (ThreadId 4332) PDLRTAPI oder DMAPI
ActSteu: 1227.012033 msec szErrorTextInfo: (ThreadId 4332) Error in DMApi
ActSteu: 1227.051190 msec szApplicationName: (ThreadId 4332) GSC_RT
ActSteu: 1227.089149 msec bCycle: (ThreadId 4332) cycle
ActSteu: 1227.127493 msec szFunctionName: (ThreadId 4332) @2
ActSteu: 1227.167384 msec dwParamSize: (ThreadId 4332) 0
ActSteu: 1227.207731 msec szErrortext: (ThreadId 4332) WinCC Runtime: PDL Run time: Picture not selected

Re: apdiag.exe Че это значит и как победить?
ОАО "Маяк" г.Пенза, Миша; 6.10.04

больше интересует как определить конкретно че за функция выдает ошибку (@2 - неочень то понятно) и т.п.

т.е. че и как значят разные параметры
Re: apdiag.exe Че это значит и как победить?
ОАО "Маяк" г.Пенза, Миша; 6.10.04

а вот еще более интересная штука...

ActSteu: 1510.981631 msec dwErrorCode1: (ThreadId 4364) 1007007
ActSteu: 1511.028692 msec dwErrorCode2: (ThreadId 4364) 2
ActSteu: 1511.144433 msec szErrorText: (ThreadId 4364) PDLRTAPI oder DMAPI
ActSteu: 1511.216957 msec szErrorTextInfo: (ThreadId 4364) Error in DMApi
ActSteu: 1511.282678 msec szApplicationName: (ThreadId 4364) PDLRuntimeSystem
ActSteu: 1511.350541 msec bCycle: (ThreadId 4364) acycle
ActSteu: 1511.416493 msec szFunctionName: (ThreadId 4364) @7b
ActSteu: 1511.488929 msec lpszPictureName: (ThreadId 4364) MAIN
ActSteu: 1511.556838 msec lpszObjectName: (ThreadId 4364) fc21_
ActSteu: 1511.628934 msec lpszPropertyName: (ThreadId 4364) Visible
ActSteu: 1511.696401 msec dwParamSize: (ThreadId 4364) 16
ActSteu: 1511.769497 msec szErrortext: (ThreadId 4364) WinCC Runtime: PDL Run time: Object not found

<


text

AR_SEND - передача архивных данных в WinCC
Руденко Алексей "НЕВИСС-Комплекс"; 14.12.04

Господа!

Кто сталкивался с данным примером работы (а желательно воплощал в жизнь) отзовитесь.
Интересуют подводные камни и любая информация, за исключением той, которая находится в описании каналов связи в документах на WinCC.
Спасибо.
Re: AR_SEND - передача архивных данных в WinCC
Руденко Алексей "НЕВИСС-Комплекс"; 15.12.04

Все, господа!

Свершилось - я наконец-то его добил. Методом промышленного тыка было установленно, что все описания, которые мне приходилось видеть (включая те, что мне прислали из Сименс(Москва) безбожно врут).
Но данные я все-таки передал.
Те кому нужно могут прислать мне письмо с запросом и я вышлю пример проекта.
Re: AR_SEND - передача архивных данных в WinCC
Дмитрий; 16.12.04

А возможна ли передача RAW-тегов из PLC не имеющего AR_SEND, т.е. формировать в нём DB соот-щей структуры, а в WinCC писать в TagLoggin встоенными средствами (т.е быстроизменяющиеся данные для тренда). Если у кого нибудь есть пример, буду признателен.

Re: AR_SEND - передача архивных данных в WinCC
Руденко Алексей "НЕВИСС-Комплекс"; 16.12.04

Эти блоки раьотают только для 400-контроллеров или для 300-х с коммуникационным процессором.

Во всех остальных случаях, это к сожалению невозможно.
Re: AR_SEND - передача архивных данных в WinCC
Мифка; 16.12.04

Мне пожалуйста :)

(для общего развития)
mailevdo@mail.ru
Re: AR_SEND - передача архивных данных в WinCC
pasha; 17.12.04

Если не орудно, и мне, please...

pavelby@nm.ru<


text

AS 511 в WinCC под Windows 2000
Зубарев; 27.2.04

Неполучается связатся с контроллером через COM по AS 511 под Win2K.

Теже самые действия в WinNT - все получается.
Re: AS 511 в WinCC под Windows 2000
Дмитрий; 1.3.04

Была такая проблема. Решена в WinCC 5.1 если правильно помню.

Re: AS 511 в WinCC под Windows 2000
Зубарев; 1.3.04

А в WinCC 5.0 SP2?

Re: AS 511 в WinCC под Windows 2000
Дмитрий; 5.3.04

Есть такая проблема. надо использовать либо версию 4, либо 5.1

Re: AS 511 в WinCC под Windows 2000
Помогите найти решение инсталировать PCS5.0 под Windows2000; 31.8.04

Существует проблемма - на одном из объектов установлен Помогите PCS 5.0 под Windows NT, принято решение об расширении системы добавление контроллера добавление оператоской станции, к сожалению станция пришла с видеокарточкой (двухмониторной - требование заказчика), которая не поддерживается Windows NT. Были ли прецендеты усттановки PCS 5.0 под Win2000, если кто знает буду очень признателен.


text

Cannot open new picture
Соснина Ирина; 10.3.04

Помогите, пожалуйста. Установила 6ю версию WinCC. Никаких проблем при установке не возникло, но он упорно отказывается работать с GraficDesigner и GlobalScript. При попытке создать новый pdl файл выдает сообщение "Cannot open new picture". С чем это может быть связано?

Re: Cannot open new picture
Yrok; 10.3.04

В 5-й версии был один глюк если не установленна сетевая карта то нельзя было открыть GraficDesigner и GlobalScript.

Re: Cannot open new picture
Соснина Ирина; 12.3.04

Спасибо за ответ. Проблему решили переустановкой системы.


text

CCDeltaLoader
Коростелёв; 19.3.04

Возникла следующая проблема. При завершении работы WinCC (из RunTime, или после осатновки проекта, не важно) возникает системное сообщение "CCDeltaLoader.e.exe вызвало ошибко и будет закрыто". Ничего не могу поделать. Может кто-нибудь помочь?


text

CCUATableCtrl - помогите разобраться
Мифка; 9.12.04

Вобщем вот такая проблема:

есть некий архив рецептов, нужно чтобы для пользователя выводился не всесь архив а по запросу (SQL). У меня на ворме есть IoField где он вводит имя рецепта (некое текстовое поле в БД), и на основании этого имени я записываю в Filter запрос вида Name LIKE '%имя%'.
Выводится все хорошо, только вот как теперь мне считать SelectID у первой выведеной записи????

Функции изменения этого поля не срабатывают почемуто... :-/

хотя курсор встает на первую запись выбранных данных!!!

как мне быть?

Это нужно для того чтобы считать в теги связанные с БД значения выделеной записи:

SetTagWord("@UA_Reciepts_ID",ЗДЕСЬ НУЖНО SELECTEDID);
SetTagWord("@UA_Reciepts_Job",7);
Re: CCUATableCtrl - помогите разобраться
Мифка; 9.12.04

После выборки (изменения Filter) поле SelectedID становится равным 65535

:-(<


text

CCWriteArchiveServer
Константин; 12.10.04


text

Connectivity Pack
Human; 3.2.04

Приветствую!

Господа, может кто-нить уже пользовался пакетом "Connectivity Pack", если "ДА", то подскажите, плиз, где на дисках PCS7 v6 он находится и можно ли его "пощупать" без авторизации?
Заранее спасибо!
Re: Connectivity Pack
Юрченко Владимир; 4.2.04

Опция WinCC 6 "Connectivity Pack" не содержится на основных дисках WinCC и PCS7. Это отдельный CD. Без авторизации работать он не будет.

Re: Connectivity Pack
Human; 6.2.04

Тогда такой вопрос: а "WinCC OLE DB Provider" входит в "Connectivity Pack" или как пишут на сайте sms-samara.ru поставляется с базовым комплектом WinCC?

Re: Connectivity Pack
Маслов Дмитрий; 6.2.04

Выдержка из документации по WinCC 6.0:

"If you want to access the database from a WinCC computer, install WinCC or the WinCC file server on the computer. OLE DB is installed with default settings."

Т.е. если Вы используете OLE DB на том же компьетере, на котором установлена WinCC, то Вам ничего дополнительно ставить не надо.
Вот если Вы собираетесь соединяться с базой данных WinCC с другого компьютера, на котором нет WinCC, то тогда надо устанавливать на нем WinCC OLE DB Provider отдельно (купив Connectivity Pack). Кроме того, при доступе к архивам WinCC с компьютера, на котором WinCC не установлена, требуется "бумажная" лицензия на клиента MS SQL Server. Эту лицензию можно заказать у Siemens - она называется WinCC/CAL (Client Access License)
См. Центр технической поддержки по WinCC

Re: Connectivity Pack
Human; 6.2.04

Хорошо, Дмитрий, тогда получается, что если на компьютере установлена WinCC, то я имею доступ к базе данных WinCC, НО если мне нужно посмотреть, значения переменных архивируемых чаще чем раз в минуту, то мне всё равно ПРИДЁТСЯ покупать Connectivity Pack и авторизаци на него?!

Это так?
Re: Connectivity Pack
Юрченко Владимир; 6.2.04

Если Вы смотрите эти теги из WinCC, то в таблицах и трендах увидите все, что архивируется без разницы с какой периодичностью, но для внешних приложений доступ к данным, которые быстро изменяются и сжимаются в базе данных, затруднителен (формат архивации данных, я думаю описывать не будут). Вот для внешних приложений и предназначен Connectivity Pack.

Re: Connectivity Pack
Маслов Дмитрий; 6.2.04

Если Вы хотите посмотреть значения тегов, архивируемых чаще, чем раз в минуту, с той же машины, на которой установлена WinCC, то для этого все уже все есть в базовой установке.

У меня на машине установлена WinCC 6/SP1, нет лицензии на Connectivity Pack и сам пакет COnnectivity Pack не ставился. Так вот, WinCC OLE DB Provider на этой машине присутствует.
А вот Connectivity Pack Вам понадобится, если Вы захотите получить доступ к архивам с машины без WinCC.

Отвечаю теперь на Ваш вопрос: если Вы смотрите архивы WinCC с машины, на которой есть WinCC, то ничего не надо доустанавливать, а если с машины, где WinCC нет, то нужны WinCC/Connectivity Pack и WinCC/CAL

В завершение хочу сказать, что данная информация, к сожалению, не проверена на практике (за исключением проверки наличия WinCC OLE DB Provider на машине без Connectivity Pack), а взята из документации Siemens.
Re: Connectivity Pack
Human; 6.2.04

Благодарю за столь подробные ответы!

Удачи!
Re: Connectivity Pack
Nick Gashevsky; 11.3.04

Чтение архивных тегов через OLEDB работает прекрасно. Проверено. Если SQL запрос возвращает много значений (около 5000), то пауза ~5-10сек. (P4-2,5). Пример кода на С могу выслать.

Re: Connectivity Pack
Костенич Дмитрий; 25.3.04

To Nick Gashevsky> Вышли на мыло, если не трудно... Заранее спасибо.(kostenitch@systserv.spb.su)

Re: Connectivity Pack
Костенич Дмитрий; 25.3.04

To Nick Gashevsky> Вышли на мыло, если не трудно... Заранее спасибо.(kostenitch@systserv.spb.su)

Re: Connectivity Pack
Human; 26.3.04

To Nick Gashevsky "Пример кода на С могу выслать." Будет интересно взглянуть, вышлите пожалуйста на manhu@ngs.ru, заранее спасибо!

Re: Connectivity Pack
Akorostel; 26.3.04

Пришлите и мне, пожалуйста. Akorostel@hotmail.ru

Re: Connectivity Pack
Михаил; 18.4.04

Если не трудно и мне ivanov_m_v@bk.ru

Re: Connectivity Pack
Маслов Дмитрий; 19.4.04

Насколько я понимаю, Nick Gashevsky уже указал свой электронный адрес. Так что все просьбы выслать пример кода можно направлять ему лично по электронной почте, а не засорять форум, участникам которого Ваш электронный адрес может быть не интересен.

Re: Connectivity Pack
Dmitry; 28.4.04

Нельзя ли показать строку соединения

Re: Connectivity Pack
Nick Gashevsky; 6.5.04

_bstr_t strConn("Provider=WinCCOLEDBProvider.1;Catalog=CC_MyProject_04_03_11_17_32_12R;Data Source=.\\WinCC");

_bstr_t strSQL("TAG:R,'ProcessValueArchive\\SUM11','2004-02-16 00:00:01.000','2004-02-16 00:00:15.000'");

<


text

COROS - SVGA ?
Евгений; 18.2.04

Суть проблеммы в том, что программа написаная в COROS под FlexOS работает в режиме 256 цветов только с карточкой HI-GRAPH, а со всеми остальными карточками, включая встроенную в RackPC 840, только в 16 цветном режиме.

Карточка HI-GRAPH в данном системном блоке не работает. Подскажите, как заставить работать LSB с SVGA картой на 256 цветов или как заставить работать карту C79458-L2350 в данном системном блоке.<


text

CP5611 и WinCC
Владимир; 23.7.04

Можно ли использовать два CP5611 в одной машине с WinCC . Чтобы подключить две сети Профибас

Re: CP5611 и WinCC
Л. Шерешевский; 23.7.04

Нет, более одной карты CP5611 в рабочую станцию вставлять нельзя. Возьмите CP5613, их можно устанавливать до 4 штук одновременно.

См. Центр компетенции WinCC

Re: CP5611 и WinCC
Юрчик; 29.7.04

Где есть описание, как считывать данные с COM порта в DB блоки при использовании WinAC 3.0 ?

Нужен перечень функциональников и их описание.

Буду благодарен за ссылки.

Re: CP5611 и WinCC
Юрчик; 29.7.04

Ой! Ошибся :-(


text

CP5613 ???
Сергей; 14.9.04

Господа помогите информацией по CP5613. Поставил драйвера под NT, в Setting the PG-PC Interface, устройство появилось, но оно неактивно, то есть я немогу выбрать и настроить CP5613. Может другие драйвера нужны или какие либо операции необходимо сделать?

Re: CP5613 ???
Маслов Дмитрий; 14.9.04

Можно попробовать установить новое устройство в Windows. Делаете поиск новых устройств, и, если Simatic Net уже поставлен, то драйвер должен найтись на системном диске.

См. http://www.wincc.ru

Re: CP5613 ???
Panyov Konstantin; 15.9.04

Здравствуйте Сергей, во первых что за Windows у вас установлен, во-вторых какая версия Simatic Net установлена, так как версии 6.0 и 6.1 идут к различным Windows. Если все нормально, тогда попробуйте переустановить Simatic Net, так как именно во время его установки устанавливается и карточка (CP5613)


text

CP5613/CP5614
Кирилл; 27.8.04

Помогите найти драйвера на CP5613/CP5614

Re: CP5613/CP5614
Fanat; 27.8.04

По моему эти драйвера входят в поставку самой карточки, а также пакетов SimaticNet(точно), Step7 and WinCC.

Re: CP5613/CP5614
Роман; 27.8.04

Ставишь WinCC или Step, и после этого ставь карту, все должно работать.

Re: CP5613/CP5614
Маслов Дмитрий; 29.8.04

Работа с картами CP5613/CP5614 осуществляется с помощью пакета Simatic Net (это отдельный диск, который обычно прилагается к самой карте CP5613/CP5614). Так что предыдущие два ответы не верны - установки Step7 и WinCC не достаточно.

Если Вы хотите использовать эту карту с WinCC (через протокол S7), то Вам понадобится лицензия S7-5613 (6GK1713-5CB61-3AA0, 450 Евро), которая заказывается отдельно и не входит в поставку WinCC, Step7 или карты CP5613/CP5614.

А вообще читайте каталог IK PI - там все написано.
См. http://www.wincc.ru


text

CP5613
Сергей; 20.9.04

Господа помогите пожалуйста, стоит плата CP5613 на Windows NT 4.0, версия софта 2.1, WinCC 4.01, Step7 v5.1. В Step7 v5.1 сетка работает, то есть контроллер и сеть видно и данные читаются и передаются с PC в PLC. Но WinCC 4.01 отказывается видеть контроллер! Ничего не понимаю... посоветуйте, что нибудь.... С уважением, Сергей...


text

Cмена экранов из контроллера_NEW
Scout; 15.9.04

Решил продолжить тему,т.к не все понятно. В руководстве " Коммуникации. Руководство пользователя" вычитал, управление экранами осуществляется через задание контроллера и моя панель ОР07 это задание(номер 51) поддерживает. Не ясно куда записывать это задание, ведь job mailbox-cа у этой панели нет. Как быть?

Re: Cмена экранов из контроллера_NEW
Андрей; 15.9.04

Для смены экранов в ОР7 используют байты n+4 и n+6 интерфейсной области.

Сначала надо загрузить номер экрана
в n+6, а потом номер задания в n+4.
Эта область хорошо описана в руководстве по коммуникациям.
Собственно, байты с n+4 до n+11, это и есть Job MailBox.
Re: Cмена экранов из контроллера_NEW
Андрей; 15.9.04

Поправлюсь, грузить надо в слова

n+4 и n+6.
Re: Cмена экранов из контроллера_NEW
Scout; 15.9.04

Заработало! Спасибо!


text

Cмена экранов панели ОР-07 из контроллера
Scout; 13.9.04

Господа! Можно ли непосредственно из контроллера управлять экранами панели ОР07.


text

Cмена экранов панели ОР-07 из контроллера
Scout; 13.9.04

Господа! Как реализовать смену экранов

панели непосредственно из контроллера.
Скажем контроллер выполнил какие-либо действия и на основании результата переходит на один экран, либо на другой.
Re: Cмена экранов панели ОР-07 из контроллера
Юрченко Владимир; 13.9.04

В ProTool добавьте в Area Pointers Screen Number. Об использовании интерфейсных областей почитайте:

См. http://www.automation-drives.ru/as/download/doc/simatic_hmi/protool/07%20User%20data%20areas%20for%20SIMATIC%20S7_r.pdf

Re: Cмена экранов панели ОР-07 из контроллера
Scout; 13.9.04

Как я понял, осуществить смену экрана можно с помощью задания, загружая в его в почтовый ящик задач. Я загружаю параметры и номер задания,как указано в документации, но ровным счетом ничего не получается. Может есть какие -то особенности?

Re: Cмена экранов панели ОР-07 из контроллера
Юрченко Владимир; 13.9.04

Не совсем правильно я посоветовал вставить Sсreen Number - это передает текущий номер экрана в контроллер. А для работы с почтовым ящиком надо добавить в AreaPointers еще DataMailbox.

Re: Cмена экранов панели ОР-07 из контроллера
Scout; 13.9.04

Я понял, и DataMailbox тоже добавил, не пашет. Для смены экрана одним скрин нумбером не обойдешся.

Re: Cмена экранов панели ОР-07 из контроллера
Юрченко Владимир; 13.9.04

Извиняюсь, что не посмотрел сам документацию. Нужен Job Mailbox, а он присутсвует только в панелях c Windows CE. Так что с OP7 ничего не получится.

Re: Cмена экранов панели ОР-07 из контроллера
Scout; 14.9.04

Cпасибо вам Владимир за совет.

Cмена экранов панели ОР-07 из контроллера
Scout; 14.9.04

Решил продолжить тему,т.к не все понятно. В руководстве " Коммуникации. Руководство пользователя" вычитал, управление экранами осуществляется через задание контроллера и моя панель ОР07 это задание(номер 51) потдерживает. Не ясно куда записывать это задание, ведь job mailbox-cа у этой панели нет. Как быть?


text

Dat@Workbook
Bobby; 8.10.04

Создал Excel файл и с помощью Dat@Workbook Wizard вставил на страницу всяческие таги. Как теперь посмотреть их в онлайновом режиме? Дело в том, что в Екселе в меню Dat@Workbook нет ничего, кроме Dat@Workbook Wizard. Нет никакого окошка, с помощью которого конфигурится и коннектится WinCC сервер. (Хотя в документации написано, что такое окошко должно быть). Что делать? :(


text

Display Library
Александр; 5.3.04

Люди!

Помогите, не могу понять - WinCC мощная СКАДА, а объектов стандартных (бочки, вентили...) меньше не бывает, эт что рисовать самому, блин, чтоли!
Или это у меня только так, может где- нить есть дополнительные библиотеки?
Re: Display Library
Юрченко Владимир; 5.3.04

В Graphic Designer меню View\Library

Re: Display Library
Владимир; 6.3.04

Стандартные библиотеки есть, но они не функциональны. Их применение в проектах весьма затруднено из-за ряда причин. Несколько раз в форуме эти причины обсуждались.

Каждый раз приходится создавать свои библиотеки, и переделывать старые.
Display Library
Александр; 9.3.04

Спасибо всем кто откликнулся... ;))

Re: Display Library
MCMak; 11.3.04

Да уж сейчас сижу рисую элементики для визуализации... Кто найдет и скажет всем где взял, тому ничего не будет :-)

С уважением МСМак...
Display Library
Александр; 15.3.04

Для МСМак...

Я нашел очень много стандартных объектов... Надо просто установить после WinCC ProTool и в папке Common в корневике Siemens появится библиотека Symbol Library - там этих прелестей НЕМЕРЕННО!!! ;))). В свою очередь Symbol Library появится в стандартной библиотеке WinCC!<


text

DLL и WinCC 5.1
Алексей; 20.6.04

Народ! Может кто-то подскажет как надо скомпилировать Dll в BC++6.0 чтобы функции из неё увиделись в WinCC. А то у меня получается что функции из DLL в BC++ видны, а в WinCC пишет, что не может найти указаную функцию. Что не так?

Re: DLL и WinCC 5.1
eric; 20.6.04

А куда положил длл-ку.

Надо в siemens\wincc\bin.
Re: DLL и WinCC 5.1
Макс Прилепский; 21.6.04

Не знаю как в BC++ , но в MS Visual C++ функции dll, чтобы их "увидела" WinCC объявляются следующим образом:

extern "C" _declspec (dllexport) void MyFunction(int a,float b)
Re: DLL и WinCC 5.1
Алексей; 23.6.04

Спасибо за ответы. Всё получилось.


text

DMSuspendVarUpdate
Alexis; 2.9.04

Господа, кто-нибудь имеет положительный опыт использования функций DMSuspendVarUpdate и DMResumeVarUpdate?

Под положительным понимается то, что Suspend действительно прекращает передачу данных в приложение...<


text

DSR-51
Shpack; 25.11.04

Подскажите где можно скачать демо- проект для PCS7?

Re: DSR-51
Михайлин Сергей; 25.11.04

В Рунет я его не выкладывал. Он порядка 30 мегов весит. Получить Вы его можете в любом оффисе Сименс. Спросите диск PCS7 Demo.


text

Error 4116 - L4_CONN_REJECT
Baby; 20.12.04

Приветствую.

Ситуация.
Есть система, 400 и 300 связь по Industrial Ethernet, соответственно в связке CPU 414-3 DP firmware V1.1, CP 443-1 firmware V1.1 и CPU 315-2 DP firmware V1.2, CP 343-1 firmware V1.0.
300 посылает данные на 400.
WinCC v5.1 данные “берёт” из 400 .
Соединение по TCP/IP. Карта в рабочих станциях CP1613(RFC1006).
Рабочих станций 12 штук.
Решили немного переделать проект и напрямую брать данные из 300.
Всё прописали в WinCC как положено, заработало Ок , для начала взяли немного сигналов около 20.
Работало около недели , затем неожиданно обнаружилось, что сигналы не меняются.
Посмотрели, Channel Diagnosis ->
Counters Value

State disconnected
First Error Code 4116
Last Error Code 4116
Error Count 0
Unit TCP/IP
Device CP1613(RFC1006).

Error 4116 - L4_CONN_REJECT
Connection could not be established. PLC rejects connection initialization.

1. Rack/slot not correctly configured. For an external CP module, the slot number of the CPU module must be entered.
2. Maximum number of permissible connections in the PLC exceeded.

Первая причина отпадает (всё работало).
Вторая……????

Вопрос:

CP 343-1, что очень “слабый процессор” , что не может поддержать подсоединения 12 рабочих станций….. ?

Прошивка старая………. ?

В Properties - CPU 315-2 DP - (R0/S2)-> Communication->
Connection Resources Reserved for

PG Communication: 1
OP Communication: 1
S7 Standard Communication: 8

Maximum Number of Connection Resources:12

Может дело в этом ? Коллеги посоветовали в OP Communication до 12 ?
Кстати, Maximum Number of Connection Resources:12 .
Это суммарное число подключений,
или Maximum Number для каждого вида подключений?

Или, что то мы не так делаем……….?

Re: Error 4116 - L4_CONN_REJECT
Макс Прилепский; 21.12.04

Судя по коду ошибки количество подключений к PLC превысило установленный лимит или же в проекте WinCC в параметрах подключения неправильно указан слот CPU.

Максимально CPU 315-2 DP поддерживает 12 одновременных (конкурирующих) соединений , у вас сконфигурировано одно соединение для программатора (режим PG) , одно для операторской панели (OP) и 8 прочих соединений (например,серверы WinCC), т.е. 2 соединения ещё есть в резерве
Re: Error 4116 - L4_CONN_REJECT
Чистяков Дмитрий ОАО СеверСталь; 21.12.04

А я бы рекомендовал для начала перейти с TCP/IP на ISO.

Ну, и всё таки, если у Вас 12 станций WinCC подключаются (пытаются) к контроллеру, то Вам действительнно не хватает коннектов.
Дело в том, что поже 8 коннектов у вас уже заняты на передачу данных в 400-ый.
Посмотрите сколько каналов используется (в NetPro).
Выходы
1. Один из компьютеров преобразовать в сервер, а остальные определить, как клиентов. Потребуется лицензия WinCC Server.
2. Оставить всё как есть.<


text

Ethernet и WinCC
Костя; 5.10.04

Народ подскажите пожалуйста будет ли работать WinCC и Step 7 на компе с двумя сетивыми картами в разных сетях.

graduyshko@tut.by
Re: Ethernet и WinCC
Макс Прилепский; 5.10.04

Если станция WinCC и PLC находятся в разных Ethernet-подсетях, то связь будет возможна по каналу TCP/IP при наличии шлюза между подсетями и настройке IP-адреса этого шлюза в конфигурации коммуникаций PLC.


text

Event cycle
Владимир; 27.2.04

Возможно ли каким либо способом на кадре у всех объектов с привязками Dinamic Dialog сменить цикл обновления скажем с "upon change" на 250 ms кроме как лазая :-) в каждое свойство ?


text

EventState в PCS7
Vadim; 25.10.04

Где узнать за что отвечают

след. теги в WinCC?
xxx.EventState
xxx.EventRaw
xxx.EventTrans

Re: EventState в PCS7
Alexis; 25.10.04

Подробное описание EventState есть в хелпаке WinCC - показывает "суммарное" состояние всех сообщений (алармов).

Значение Start/Substitute value переменной EventRaw - это номер первого сообщения блока сообщений (ALARM_8 и тп), остальные семь номеров получаются увеличением первого на 0x400000 для WinCC5.
Значение Start/Substitute value переменной EventTrans - показывает типы всех восьми сообщений блока сообщений по 4 бита на сообщение (0 - сообщение не используется ... F - аварийное сообщение).
EventState один для структуры, а EventRaw и EventTrans - в зависимости от количества блоков ALARM_8.<


text

Faceplate в PCS7
Vadim; 25.10.04

Подскажите где найти

описание на фейсплейты в PCS7?

Re: Faceplate в PCS7
Михайлин Сергей; 26.10.04

Как обычно все в доке.

Описание на стандартные фейсплейты в документации на библиотеки(рус). см. ссылку
Описание как самому создать фейсплейт в доке на фейсплейт-дизайнер(англ). есть на Сгыещьук Support Герамания.
См. Тут


text

Group Display
Александр Цихоцкий; 7.5.04

Доброго времени суток.

Возник вопрос следующего плана. Как работает Group Display и какую роль он должен играть в проекте PCS7? Этот компонент предлагается на главном окне проекта и, по-видимому, он должен отображать аварию, произошедшую на окне, находящемся в ветке, которую я создаю в Picture Tree Manager'е. Но дело в том, что авария на Group Display отображается только, если она произошла на главном окне ветки. Как мне вынести в тот же компонент и аварии, произошедшие на окнах, которые находятся на той же ветке, но не являются главными?

Заранее спасибо.
Re: Group Display
Human; 11.5.04

Для этого можно сделать следующее: на главном окне ветки расположить объект Group Display обощённый по всему "вложенному" окну. В этом случае, когда сработает какая-нить сигнализация на "вложенном" окне, то сработает и обощённый индикатор по окну, а затем сработает индикатор по всей ветке.

Re: Group Display
Александр Цихоцкий; 11.5.04

Тогда сразу встречный вопрос.

А как тогда сделать, чтобы по нажатию на Group Display на стартовом окне открывалось не главное окно ветки, а сразу то окно, на котором и произошла ошибка? Конечно можно пользоваться окном дерева и там выбирать, но это, как мне кажется, не очень правильно, если Group Display изначально задумывался для быстрого перехода к окну с аварией.
Re: Group Display
Human; 12.5.04

Я не проверял, но разве автоматом всё это дело не работает (имеется ввиду переход на "вложенное" окно с аварией?

Re: Group Display
Александр Цихоцкий; 13.5.04

Благодарю, Human, всё заработало.


text

group display
shurik; 20.5.04

уже несколько раз обсуждался замечательный элемент - групповой дисплей,но где найти описание его структуры и примеры программирования,в частности что такое Significant Mask, UserValue 1-4.Какие биты отвечают за какие сообщения?

Подскажите пожалуйста.
Re: group display
Владимир; 3.6.04

Вообще примерами программирования как бы негусто... и не только с group display. Как всегда, приходится воевать в одиночку )))


text

HELP - Не работает VBA скрипт
Эдуард; 23.9.04

Пишу в событии OnClick HMI-объекта VBA скрипт, но при компиляции VBA Editor ругается

Option Explicit

Sub Click(ByVal Item)
Dim objPicWindow As HMIPictureWindow
Set objPicWindow = ActiveDocument.HMIObjects.AddHMIObject("PicWindow1","HMIPictureWindow")
With objPicWindow
.Top=90
.Left=40
.Width=332
.Height=290
.AdaptPicture=False
.AdaptSize=False
.Border=True
.Caption=True
.PictureName="ControlZD.pdl"
.CaptionText="Íîâîå îêíî óïðàâëåíèÿ"
.UpdateCycle=0
End With
End Sub

Ругание VBA-Editor:
Предполагается наличие окончания инструкции (5): Dim objPicWindow As HMIPictureWindow
Actions must be error-free to be saved!
Please comment out the faulty instructions.<


text

Help!!!!
Сергей Н.; 2.11.04

Специалисты! у кого есть доки по VBA, желательно руссифицированные??? Если есть скиньте на s_e_r_g_e_y83.mail.ru


text

Hotfix для WinCC 6.0 SP2
Макс Прилепский; 8.12.04

Может ли кто-нибудь подсказать, выходили ли для WinCC 6.0 SP2 заплатки после Hotfix 2 ?

Re: Hotfix для WinCC 6.0 SP2
Юрченко Владимир; 8.12.04

Да выходили, последний который есть у нас в представительстве Сименса в Москве и городах, где есть наши технические центры - Hotfix 6. Размером около 80 Мб и поэтому переслать по почте или разместить в интернете проблемы.


text

Indirect Tags
Максим Поджидаев; 21.9.04

Привет Всем!

Подскажите pls, существует ли способ работы с косвенными (indirect) тегами из Dinamic Dialog либо из скрипта?

Есть окно с TagPrefix (адресация к экземпляру структуры), 95% тегов укладываются, 5% тегов нужно отображать из других структур. Вышел из положения создав internal текстовые теги (члены структуры) с названиями других тегов(этих самых 5%) в качестве стартового значения. Теперь хотелось бы их полноценно использовать (например, через Dinamic dialog привязать цвет к значению такого тега)
Re: Indirect Tags
Макс Прилепский; 22.9.04

Можно в Dynamic Dialog написать в качетве выражения , например, функцию GetTagByte(GetTagChar("TextTag")), которая вернет значение как раз того тега, название которого содержится в текстовом.

Re: Indirect Tags
Максим Поджидаев; 22.9.04

Re: Indirect Tags
Макс Прилепский; 22.9.04

Можно попробовать такой вариант: у окна, которое имеет TagPrefix (далее - родительское)убери Prefix, создай в этом окне PictureWindow c TagPrefix (95% тегов твоей структуры) для 5% тегов из других структур сделай либо свой PictureWindow с другим TagPrefix, либо просто нарисуй вразнобой объекты и динамически, например, при открытии родительского окна или по какому-нибудь иному событию меняй TagPrefix у окна для 95%, для 5%, если они вразнобой, для Dynamic Dialog можешь использовать указанное выше выражение. Сейчас я тоже использую 6-ю версию WinCC (с TagPrefix я отличий от 5.х не нашёл) и какую-то общую или дополнительную информацию , не имеющую отношения к структуре, для которой используется TagPrefix, именно так и отображаю. Если для такой информации я использую тоже разные (не обязательно даже структурные) теги , динамически привязывая их с помощью SetLink, то для функциональности, которую реализует Dynamic Dialog я делаю невидимый объект, к свойству которого (например BackColor) с помощью SetLink привязываю нужный тег и далее на событие изменения этого свойства, которое вызвано изменением значения привязанного тега, создаю либо Action , либо Direct Connection, которые передают нужную информацию в свойства уже другого,видимого на экране, но явно не связанного с тегами объекта. Ежели что, пиши на мыло.


text

Insert Process Value
Ирина; 29.6.04

Проблема в Alarm Logging (WinCC v6). Кто-нибудь пробовал вставлять значения тегов в блоки текстовой информации? Подскажите, как это грамотно делается. Тоже самое и с Loop in Alarm.

Заранее спасибо.
Re: Insert Process Value
Александр Родин, ООО "Нева Электрик"; 29.6.04

Так а в чем собственно проблема ?

Там вроде особо и не на чем спотыкаться и вся система тянется с самых ранних версий.

Задаются Process Value блоки требуемой длины, далее в свойствах строки в закладке Tag/Action этим блокам ставятся в соответствие значения тэгов, далее в закладке Text формируете шаблон вывода значений для блоков и указываете, какие собссно блоки выводить в строке. Все. Основное - это не вылезти за длину строки.
Re: Insert Process Value
Ирина; 29.6.04

Да я вобщем-то так и делаю. В результате получается строка: @1%s@ - например так. Не выводится! Все как в хелпе описано. Может у кого были подобные проблемы?

Re: Insert Process Value
Александр Родин, ООО "Нева Электрик"; 30.6.04

А правильно ли указан размер Process Value блока ? И правильно ли настроен формат для его вывода ?

То что вы написали справедливо для подстановки строки, если же Tag для Process Value имеет числовой тип, то и формат необходимо настраивать для числа... например @%2d@ - соответсвует целому десятичному числу из двух знаков. При этом длина Process Value блока не должна быть меньше 2 символов.
Re: Insert Process Value
Ирина; 2.7.04

Уф,проблема решена. Оказалось, что такая фишка не работает для сообщений возникающих при аналоговой аварии - Analog Alarm. Жаль, придется решать вопрос другим способом. А в формате @2%d@ цифра 2 все же соответствует второму Process Value, а не количеству знаков.

Re: Insert Process Value
Alexis; 2.7.04

то что стоит после % - см например printf и используйте как вашей душе угодно

Re: Insert Process Value
Ирина; 2.7.04

спасибо за подсказку :-)

Re: Insert Process Value
Александр Родин, ООО "Нева Электрик"; 2.7.04

да... опечатался..

в примере должно было быть @1%2d@<


text

Logout
Yrok; 22.4.04

Подскажите? в WinCC появился такой глюк: после нажатия кнопки Logout не происходит смены кадра на стартовый, а раньше было.


text

MES решения фирмы Siemens
Юрий; 1.6.04

Добрый день.

У кого нибудь есть информация по программным продуктам для MES (SIMATIC IT Framework и другие) от Siemens ?

Re: MES решения фирмы Siemens
Шопин Андрей; 7.6.04

Добрый день, Юрий

С MES продуктами ситуация следующая. В России их нет вообще. Хотя в одном из списков референсов упомянался Магнитогорск, но проект 96 года скорее всего делался не в тех технологиях, которые сейчас продвигаются. Таким образом поработать с MES продуктами не удастся.
Если же Вас интересует общая концепция построрения данных систем, то я могу прислать Вам пару презентаций, которые на мой взгляд наиболее подробно описывает их сущность.
Re: MES решения фирмы Siemens
Чистяков Дмитрий ОАО СеверСталь; 7.6.04

Как говорил мне Сергей Михайлин, в России не закупают такие системы у Siemens`a. А не закупают по той причине, что российские компании не могут чётко описать, что хотят. А немцы не могут работать так, когда требования к системе меняются каждую неделю. Видимо Россия - это удел самопальных систем. :-)

Могу сразу сказать, что у нас на СеверСтали, всё тоже самое. :-(
<


text

MessageBox
Мифка; 10.12.04

как поиметь хэндл окна для которого мессага выводица???

MessageBox(NULL,"текст","заголовок",MB_OK);
NULL - неустраивает :-/
Re: MessageBox
Александр Родин, ООО "Нева Электрик"; 10.12.04

Если нужно получить HANDLE окна WinCC-RT, то можно воспользоваться например такой фнкцией:

HANDLE WinHandle;
WinHandle = FindWindow ("PDLRTisAliveAndWaitsForYou", "WinCC-Runtime - ");

Re: MessageBox
Мифка; 10.12.04

Огромное спасибо, попробую сейчас :-)


text

Microsoft ComboBox в WinCC5.1
Роман; 10.9.04

При попытке набора русскими буквами внутри него вижу Ðîìàí а если набирать английскими то все нормально, и работает свойство отфильтровки. Может кто нибудь знает как это поправить?Чтобы при наборе русскими буквами такого не происходило.


text

Microsoft Date and Time Picker Control, version 6.0
Vasilij; 26.5.04

Уважаемые, подскажите пожалуйста.

При переносе проекта на другую машину не отображаются объекты ActivеX MSComCT2.DTPicker.2 (Microsoft Date and Time Picker Control, version 6.0).
А в графическои дизайнере поле в свойстве "Server Name" пустое, хотя должно быть DTPicker.
Вроде бы и зарегистрировал mscomct2.ocx с помощью regsvr32, всё равно ничего...
Заранее благодарен.
Re: Microsoft Date and Time Picker Control, version 6.0
Александр Родин, ООО "Нева Электрик"; 26.5.04

зарегестрировать сервис не достаточно... его еще в Graphics Designer добавить надо.

Т.е. в WinCCExplorer-е правой кнопкой мыши щелкаем на Graphics Designer, выбираем Select ActiveX Control, в открывшемся окне ищем требуем сервис и смотрим, стоит ли рядом с ним галочка. Ставим, если не стоит... После чего можете в рисунках использовать соответсвующий контрол. Кстати, через этот же механизм можно и регестрировать контролы в сиситеме.. :)
Александру Родину.
Vasilij; 26.5.04

Уважаемый, Александр Родин.

Спасибо за ответ.
Но в том то и дело, что я и в Graphics Designer все галочки проставил, причём для всех объектов, работающих с этой mscomct2.ocx. Но всё равно при выборе этого объекта (Microsoft Date and Time Picker Control, version 6.0)и переноса его на картинку машина упорно требует лицензию. Дословно "Licence iformation not found. You do not possess a valid license for the design mode. (Animation)."
Я думаю, может быть стоит создать srg-файл.
Что посоветуете?

Re: Microsoft Date and Time Picker Control, version 6.0
Александр Родин, ООО "Нева Электрик"; 26.5.04

Скажу честно, имею всесьма смутное представление о механизме OCX. Но судя по надписи, этот контрол просит лицензии.. :) Возможно она есть на той машине, с которй вы переносите поект.

Александру Родину.
Vasilij; 26.5.04

Всё равно спасибо, что откликнулись.

Просто я думал, что вы подскажите каким способом формируется srg-файл и как в него перенести лицензии, поскольку этим мне заниматься ещё не приходилось.
Re: Microsoft Date and Time Picker Control, version 6.0
Евгений Трунов; 26.5.04

Этот ОСХ действительно требует лицензирования. Проще всего нарушить закон таким образом: посмотреть содержимое файла <имя компонента>.srg на той машине, где он нормально работает. Это фактически файл реестра. Перенести его на новую машину, переименовать в <имя компонента>.rеg и слить с реестром. Затем переименовать обратно.

Re: Microsoft Date and Time Picker Control, version 6.0
Олег; 27.5.04

Советую прочитать статью http://am.rusimport.ru/MsAccess/topic.aspx?id=127. Или подобные (задай в Яндексе поиск "mscomct2.ocx"). Подобные заморочки там описаны.

Re: Microsoft Date and Time Picker Control, version 6.0
Олег; 27.5.04

Советую прочитать статью http://am.rusimport.ru/MsAccess/topic.aspx?id=127. Или подобные (задай в Яндексе поиск "mscomct2.ocx"). Подобные заморочки там описаны.

Re: Microsoft Date and Time Picker Control, version 6.0
Vasilij; 27.5.04

Спасибо всем за ответы.

Оказывается есть самый простой способ.
В реестре для этого объекта вручную прописывается:
[HKEY_CLASSES_ROOT\Licenses\4F86BADF-9F77-11d1-B1B7-0000F8753F5D]
@ = "iplpwpnippopupiivjrioppisjsjlpiiokuj"
И не нужны никакие reg- и srg-файлы.
<


text

Migration from WinCC v5.1 to WinCC v6.0
Valera; 9.11.04

Стоит WinCC v6.0, при конвертации проекта, написанного на WinCC v5.1 при установке Sybase7 с диска с WinCC v6.0 требует диск WinCC v5.1. Возможно ли получить этот диск в Московском Siemense?

Re: Migration from WinCC v5.1 to WinCC v6.0
Лев Шерешевский; 9.11.04

Если у Вас WinCC 6.0 приобретена легально, Вам наверняка помогут, либо направят к кому-либо из официальных партнеров.

См. Центр компетенции WinCC

Re: Migration from WinCC v5.1 to WinCC v6.0
Чистяков Дмитрий ОАО СеверСталь; 10.11.04

А с какого диска устанавливали WinCC?

Не святым же духом он там появился. :-)
Думаю, надо прежде всего обратится к тому, кто установил WinCC 6.0. У него ведь этот диск имеется.
Re: Migration from WinCC v5.1 to WinCC v6.0
Valera; 10.11.04

Я и устанавливал....

Ставлю вопрос по другому: помогите пожайлуста получить диск с WinCC v5.1 для преобразования проекта. Я думаю, что подойдет диск и с демо/триал.. (если есть такой конечно)<


text

Models в PCS7 v6
Shpack; 25.11.04

Подскажите пожалуйста принцип работы с моделями! Насколько я понимаю они используются для создания типовых управляющих узлов. Например у нас есть типовой насос с 2 входами (работа и ручной режим) и 2 выходами (блокировка и запуск) кроме того он блокируется по нескольким доп. условиям (уровень залива, уровень в емкости и т.п.) мы конфигурим для него вх/вых, сообщения, привязываем его к таблице символов и создаем из него модель.

Далее, при копировании модели, автоматом генерятся сообщения с новыми объектами и автоматом идет привязка к таблице символов.
Так вот подскажите, как создать типовую модель скажем для такого насоса, из модели будут генериться насосы c названиями H101-1, H101-2 на основе модели H101 и привязываться к IO GSH-101-1,GSL-101-1,HS-101-1 для Н101-1. За пример по почте буду благодарен втройне!!!
Re: Models в PCS7 v6
Михайлин Сергей; 25.11.04

Ну пример прислать не могу так быстро, но пару рекомендаций дам.

Во-первых, скорее всего это будет не модель, а Procces Tag Type. Отличие в количестве чартов внутри. В модели их несколько. Конекции к периферии можно будет выполнить с помощью Textual Interconnection. Как все это создать описано в доке по ссылке.
См. Тут


text

MP370&NetworkServices
San; 27.1.04

Есть панель MP370 c Ethernet и OC Windows CE 3.0. Карточку настроил, пинги проходят, проекты грузятся. Но, сетку видеть отказывается и сама не видна. Выдает мол сетевая служба не запущена. Хочу настроить подключение к сети, а там только модем или ком. Если кто сталкивался, помогите pls вылечить.

Спасибо! Александр.<


text

mscomct2.ocx
Vasilij; 20.5.04

Уважаемые, подскажите пожалуйста.

При переносе проекта на другую машину не отображаются объекты ActivеX MSComCH2.DTPicker.2 (Microsoft Date and Time Picker Control, version 6.0).
А в графическои дизайнере поле в свойстве "Server Name" пустое, хотя должно быть DTPicker.
Вроде бы и зарегистрировал mscomct2.ocx с помощью regsvr32, всё равно ничего...
Заранее благодарен.<


text

MSRTStartMsgService
Alexis; 24.9.04

При переходе с WinCC5 на WinCC6, неожиданно (хотя вроде пора и привыкнуть) столкнулся со странным поведением функции MSRTStartMsgService. В процессе работы программы происходит подключение к AlarmLogging через MSRTStartMsgService - один раз отрабатывается нормально, а дальше как повезет... Зависание происходит при вызове функции, причем зависает весь AlarmLogging.

Кто-нибудь сталкивался с подобным? WinCC 6 SP1 HF3<


text

Multi-Client Project
Макс Прилепский; 24.2.04

Можно ли подключить функции нескольких проектов WinCC, используемых в проекте Multi-Client каким-нибудь другим способом, отличным от копирования функций из папки library серверов в аналогичную папку мультиклиента ?


text

No connection to data server! (архивные тренды)
Миша; 30.9.04

Подскажите пожалуйста в чем может быть дело?

Раньше работало и перестало (после добавления некоторых тагов в таглогин).

И ЭТО БУДЕТ ТАК РАБОТАТЬ НА ПРОИЗВОДСТВЕ???? это как то ненадежно :-/

Re: No connection to data server! (архивные тренды)
Руденко Алексей Невисс-комплекс; 30.9.04

Честно скажу - глюки такие бывают, но система, которую мы установили вот уже год работает без нареканий...

Так что все зависит от того, кто настраивает...

Re: No connection to data server! (архивные тренды)
Миша; 30.9.04

Re: No connection to data server! (архивные тренды)
Руденко Алексей Невисс-комплекс; 30.9.04

На всякий случай проверь галочку в старапе а то уж очень знакомые симптомы...

Заодно проверь значок SQL сервера - он мог стать похожим на красные буковки, тогда сноси винды...
Также если все что я написал не помогло - сноси и ставь заново и настараивая логинг будь аккуратен...
Удачи.
Re: No connection to data server! (архивные тренды)
Миша; 30.9.04

Все галочки есть.

SQL нормально.

В чем дело - ХЗ :-(

На новом проекте все нормально. Да и старая копия тоже работает.

Че то произошло с самим проектом...
Re: No connection to data server! (архивные тренды)
Руденко Алексей Невисс-комплекс; 30.9.04

Совет конечно идиотский но проверь еще раз в график дизайнере откуда ты берешь теги - вдруг все же слетели настройки...

А лучше создай трэнд контрол и настрой его из рантайма...
Re: No connection to data server! (архивные тренды)
Nick Gashevsky; 1.10.04

Попробуй вытереть содержимое архива (файлы из папки Taglogging) и перезапусти проект.

Re: No connection to data server! (архивные тренды)
Kiril; 1.10.04

1. Запусти от \Siemens\WinCC\WinCCScope\bin\CCDiagAgent.exe

2. Настрой HTTP - port 80 ili (8080)
3. Из InternetExplorer - http://localhost/ и там Читай
----------------------------
4. От \Siemens\WinCC\uTools\apdiag.exe
5. Из Diagnostics -> Level 5
6. Из Output windows -> Open и там сматри
7. WinCC Project нужно стартират

Re: No connection to data server! (архивные тренды)
Евгений Горлов, Северсталь; 5.10.04

у меня такое было во время старта , а перед ним я убрал русские настройки в реестре CodePage/NLS


text

odbc
Роман; 3.12.04

Как в Wincc через драйвер odbc получить доступ к архивам WinCC,тэгам например из Excel...


text

ODK_Rus
Yrok; 19.6.03

Подскажите где скачать документацию на русском языке по ODK

Re: ODK_Rus
Василенко; 19.6.03

I think there is not russian,but only english.

Re: ODK_Rus
Yrok; 19.6.03

OK!

Re: ODK_Rus
Akorostel; 24.11.03

а где скачать на английском?

Re: ODK_Rus
Василенко; 5.12.03

Не помню,наверно где WinCC.Могу намылить help -2Мб.

Re: ODK_Rus
Alexis; 5.12.03

Кстати, а для шестой WinCC ODK появился?

Re: ODK_Rus
Юрченко Владимир; 5.12.03

Появился и можно заказывать по заказному номеру 6AV6 371-1CC06-0AX0 (upgrade 6AV6 371-1CC06-0AX4).

Только поставки начнутся скорее всего в начале января 2004.
См. Ссылка на анонс

Re: ODK_Rus
Akorostel; 8.12.03

намыль, пожалуйста, Akorostel@hotmail.ru

Re: ODK_Rus
Александр Козлов; 3.2.04

Если не сложно пришлите документацию на ODK на kozlov@ste.ru

Re: ODK_Rus
Alexis; 4.2.04

А лучше выложите куда-нибудь :)

Re: ODK_Rus
SIS; 6.2.04

Вышлите, плиз, документацию на ODK на spyder000@mail.ru

Re: ODK_Rus
Dzmitry; 25.2.04

И мне намыльте, пожалуйста документацию на tylpan@mail.ru

Re: ODK_Rus
Jevgenij; 16.6.04

Вышлите, пожалуйста , документацию на ODK на rslabs@rs.lv

Re: ODK_Rus
ALEX; 17.6.04

И мне намыльте, пожалуйста документацию на ALEXRLS@RLSAUT.PT

Re: ODK_Rus
ALEX; 17.6.04

И мне намыльте, пожалуйста документацию на ALEXRLS@RLSAUT.PT

Re: ODK_Rus
Олег; 18.6.04

Вышлите, пожалуйста , документацию на ODK на ovp1@mail.ru

Re: ODK_Rus
Алексей; 20.6.04

И мне плиз намыльте документацию на Kaz_min@rambler.ru

Re: ODK_Rus
Людмила; 25.6.04

Вышлите, пожалуйста, мне тоже документацию на ODK на milatrona@rambler.ru

Re: ODK_Rus
Роман; 2.7.04

Если можно, мне тоже пришлите документацию по ODK на morra@stal.ru.

Заранее спасибо.
Re: ODK_Rus
Alexis; 2.7.04

А может соберемся, да отрусифицируем одк-у и наполним его красивыми и внятными примерами...

Re: ODK_Rus
Александр Родин, ООО "Нева Электрик"; 2.7.04

Вопрос тока в том, кто будет собираться и кто будет делать примеры. :)

Re: ODK_Rus
Alexis; 4.7.04

Главное найти спонсора :))

Re: ODK_Rus
Александр Родин, ООО "Нева Электрик"; 5.7.04

Спонсор тут может быть только один - хозяин ентого форума.. :)

Re: ODK_Rus
Alexis; 5.7.04

А хозяин скромно отмалчивается :)))

Re: ODK_Rus
Игорь Одесса; 5.7.04

А за идею? ;)Просто так примерчики выложить, народ халявкой побаловать слабо.

Re: ODK_Rus
Alexis; 7.7.04

Дык как таковых примеров нет, есть куча софта, при написании которого пришлось разобраться с большей частью открытого wincc-шного API (так называемого ODK). Таким образом имеется многолетний опыт использования subj-а. От "версии" к "версии" ODK-шного хелпа вижу, что по части примеров (да и описания) он как был убогий, так и остается убогим.

Re: ODK_Rus
Людмила; 7.7.04

Народ, так может кто может намылить help на ODK на milatrona@rambler.ru???

Поспособствуйте человеку.
Re: ODK_Rus
Viktoria; 24.7.04

Если не сложно пришлите документацию на ODK на vvz27@yahoo.de !!!! danke

Re: ODK_Rus
Viktoria; 24.7.04

Если не сложно пришлите документацию на ODK на vvz27@yahoo.de !!!! danke

Re: ODK_Rus
Semenchik; 6.8.04

Вышлите, пожалуйста, документацию на ODK на semenchik@bsu.by Ну очень нужно !

Re: ODK_Rus
Lucky; 8.8.04

Если не сложно пришлите документацию по ODK на man_of_luck@mail.ru!!!! Thanks in advance!


text

Online Trend Control
LostAngel; 8.12.04

Использую Online Trend Control в WinCC 6.

Чтобы выводить нужные тренды по запросу оператора пытаюсь в рантайме устанавливать свойство контрола TagName. Для этого использую функцию SetTagChar. Ничего не получается.

Если кому-то удалось успешно менять в рантайме выводимые тренды - буду очень признателен услышать как это можно сделать.

Re: Online Trend Control
Александр Родин, ООО "Нева Электрик"; 8.12.04

Свойство TagName зависит от свойства Index. Поэтому прежде чем устанавливать свойства кривой необходимо указать какую именно посредством Index.

И, кстати, устанавливается оно не SetTag-ом, а SetPropChar.

И более того, это не имя RT-Tagа, а имя тага из TagLogging-a. Так что прежде чем выводить Online Trend Control, необходимо настроить архивы в TagLogging.
Re: Online Trend Control
LostAngel; 8.12.04

Согласен - насчёт SetTagChar - бес попутал. Не тот скрипт посмотрел.

TagLogging настроен верно и всё работает.
Функцией SetPropChar легко подключается тэг - но не из архива к сожалению.
Имя тэга из архива задаётся в виде строчки - "Архив/Тэг".
При вызове функции SetPropChar она не видит символ "/". Не видит - и всё. И архивный тэг не подключается.
Тому кто смог обойти эту проблему - глубочайший респект и просьба поделиться ценнейшей информацией.

Re: Online Trend Control
Александр Родин, ООО "Нева Электрик"; 8.12.04

По поводу "/", попробуйте в строке его прописать как "\/".

Re: Online Trend Control
Андрей; 8.12.04

/ - замени на //

Re: Online Trend Control
LostAngel; 8.12.04

Опять я ошибся - в строке задания надо писать "Архив\\Тэг". Тогда в окне настройки тренда всё выглядит правильно.

Правда в строке состояния при этом имя тэга не меняется - остаётся прежним.
Реально будет ли это работать - проверю в ближайшее время.
Сомнения конечно есть.
Если кто-то знает другие способы менять тренды - поделитесь плиз......

Re: Online Trend Control
Руденко Алексей "НЕВИСС-Комплекс"; 9.12.04

Делал я следующим образом:

Делал Онлайн Трэнд, и несколько кнопок.
На действия кнопок привязывал Директ Коннекшн и засылал в соответствующее поле свойств графика имя тэга.
Надеюсь все понятно и не надо здесь никаких скриптов.
Удачи.
Re: Online Trend Control
Александр Родин, ООО "Нева Электрик"; 9.12.04

Оставте e-mail или скиньте на мой запросик..

Пришлю вам кусок проекта, в котором идет формирование картинки для вывода графиков.<


text

OP 17 Добавление русского интерфейса
Nikomed; 18.10.04

Помогите, пожалуйста: есть Simatic OP17, есть файлы с интерфейсом. Как их установить? Я этот аппарат первый раз вижу.

<


text

OP 17
Mitrich; 3.8.04

Возможна ли симуляция OP 17 c ProTool Pro RT или ProTool Pro Simulator ?

Re: OP 17
Юрченко Владимир; 3.8.04

Нет, симуляция возможна только для панелей с Windows CE.


text

OP 270 и USB bar-code scanner
Юрчик; 5.4.04

В каталоге CA-01 сказано, что USB порт можно использовать для подключения сканера штрих-кода.

Где можно найти более подробное описание по вводу данных с USB сканера в ProTool или WinCC? Желательно с примерами, а то на работу сканера штрих-кода через RS-232 в S7 есть документация, а на USB нет :-\<


text

OP17 (передача уровеня доступа в PLC)
Елена Протасова; 12.5.04

Возможно ли и как передать текущий уровень доступа пользователя панели OP17 в контроллер 315-2DP?


text

OP37. Несовместимость версий.
Новичок; 21.6.04

Доброго времени суток всем!

Подскажите, пожалуйста, новичку как...
Есть OP37 и ProTool v6 sd2. При попытке Upload данных по profibus

появилось сообщение о несовместимости операционки OP37 и ProTool.

(Да-да сообщение вверху я читал и всё же...)

Вопросы:
1) Как посмотреть версию операционки OP? (нет внешней клавиатуры

для OP37)
2) Сотрётся ли программа при обновлении операцинной системы OP?
3) Если ответ на предыдущий вопрос "Да", то как сохранить

программу до обновления?
(Кстати, имеется дисковод 3'5, но при попытке сохранить на него

выдается ошибка №32)
4) Ну и, как обновить операционку OP37? Может есть какие-то

тонкости? Рисковать нельзя...
Re: OP37. Несовместимость версий.
Bkmz; 23.6.04

Use ProSave! And no problem!

Re: OP37. Несовместимость версий.
Новичок; 1.7.04

Хорошо-то как.... :)

Версию посмотрел,
Backup сделал (действительно :Use ProSave! And no problem!),
а как всё-таки обновлять
операционку (сейчас v 5.2.2) и где брать firmare и зачем, извините за выражение, там дисковод 3'5 (может можно проекты с него запускать?)
<


text

OP37
Николай; 21.12.04

На OP появилось пятно в углу экрана.

После того как была произведена разборка и сборка OP, панель потухла.
На лампы подсветки ничего не выдается.
Все светодиоды на кнопках светятся.
Подскажите в чем может быть проблема. <


text

OP-393
error; 27.5.04

Кто-нибудь объяснит как с ней работать

Re: OP-393
Павел Иванов; 27.5.04

А Вы пытались прочесть русское руководство по ней?

См. ссылку.
См. http://www.automation-drives.ru/as/products/doc.php?l1=SIMATIC%20HMI&l2=Панели&l3=doc


text

OP396
Виктор Сахончик; 4.3.04

Где можно найти инструкцию от операторской панели OP396

Re: OP396
Роман Абзаев; 5.3.04

Известно где - на Customer Support. Вон она ссылочка, чуть правее, прямо под баннером A&D Mall. Конкретное руководство - ID 13896865.


text

OP7 и PLC и компании Beckhoff
Алексей; 10.12.03

У меня есть контроллер Beckhoff BC8100 c интерфейсом RS-232 и панель Simatic OP7 с тем же RS-232. В создаваемом Protool 6.0 SP2 проекте для OP7 контроллер этой марки не поддерживается. Как быть? Есть ли какие-то дополнительные библиотеки поддержки у SIEMENS? У Beckhoff я ничего не нашел.

Вместе эти два устройства точно работают, сам видел действующий шкаф.
Заранее спасибо.
Re: OP7 и PLC и компании Beckhoff
Роман Абзаев; 11.12.03

У меня есть подозрение что подобную поддержку можно осуществить только приобретя по запросу сответствующий софт. И скорее всего надо будет просить именно Beckhoff.

Re: OP7 и PLC и компании Beckhoff
amasht; 11.9.04

В 2004 Beckhoff открыла представительство в Москве, там два моих одноклассника работают. Я сам с августа работаю в ЗАО Эксет (фирма создана в июне 2004),(оффициальный дистрибьютер Beckhoof в России).

У мненя есть информация про панели, с примерами реализованных проектов. Если тема еще актуальна - пишите на support@ekset.ru - я отвечу.

Александр Маштаков, инженер по тех.поддержке, ЗАО Эксет.
<


text

OP7 синхрониэация времени
Тима; 12.5.04

Как "заставить" OP7 после включения

получить время от другого DP устройства. Или может ли она "держать"
время отключенной.
Re: OP7 синхрониэация времени
Eugeny; 29.7.04

OP7 может "держать" время отключенной.

Синхронизировать время ОР7 можно, например, с CPU PLC (см. библиотечную функцию SFC48).<


text

OPC & PROTOOL
александр ; 24.8.04

в PROTOOL в проекте для pc поставил галочку OPC server запустил

на другой машине в таком же проекте указал в соединениях OPC
запустил не работает , а на машине где собственно сервер выдаёт сообщение
NO OPCPROXY.DLL IS REGISTERED

на машине котороя по идее орс сервер стоит карточка cp5613a2 соединение с контроллером mpi
кто знает как заставить работать opc server

Re: OPC & PROTOOL
александр ; 26.8.04

дак что никто не знает что делать

Re: OPC & PROTOOL
Чистяков Дмитрий ОАО СеверСталь; 26.8.04

Настройки клиента в студию!

Re: OPC & PROTOOL
александр; 26.8.04

в проекте протула в controlltrs выбрал

OPC v6 в параметрах указал машину где запущен протул RT с включеной опцией OPC server
и выбрал OPC.SimaticHMI.PTPro

так как проэкты одинаковые то я так понимаю больше ничего прописывать не надо

если проделать с точность наоборот и на клиента поставить CP5511 и на нём включить opc server то OPC Scout видит все тэги и не ругается , но мне надо запустить это на стационаре с cp5613a2
а там даже в локале OPC Scout орёт NO OPCPROXY.DLL IS REGISTERED и ни фига не даёт делать .
(завтра на стационар step 5.1 поставлю сейчас 5.3 , т.к. на ноуте 5.1 может сдесь собака зарыта)

Re: OPC & PROTOOL
Vladimir S.; 26.8.04

Regsrv32.exe opccomn_ps.dll

Regsrv32.exe opcproxy.dll
OpcEnum.exe /reg server

Re: OPC & PROTOOL
александр; 27.8.04

проделал выше написаное не помагло

какие ещё есть мысли по данному вопросу
Re: OPC & PROTOOL
александр; 31.8.04

переустановка софта и установка степ 5.1 не помогла . может кто нибудь знает что в данной ситуации делать


text

opc
crazy; 18.10.04

люди подскажите что делать

запускаю протул с включеным орс сервером через opc scout все теги читаются , а с другого компьютера никак не подключится пишет что сервер не доступен . везде windows XP SP2 , pro tool 6.0 sp2 ,ip адрес получается автоматически , машины не в домене.

и второй вопрос есть ли у сименса курсы где обучают работе с орс серверами , а то я смотрю на всех форумах по орс практически нет ответов

Re: opc
Nick Gashevsky; 19.10.04

Попробкй отключить брандмауэр в Windows.

Re: opc
crazy; 19.10.04

отключен сразу после установки

Re: opc
Макс Прилепский; 20.10.04

Возможно, проблема в DCOM. В случае с WinCC 6, удалённый пользователь, под учётной записью которого производится подключение, должен находиться в группе SIMATIC HMI на OPC-сервере. В случае с WinCC 5 , в группе Опытные пользователи (Power Users)или Администраторы. Можно также запустить утилиту dcomcnfg и настроить права доступа вручную. Если проблема именно с правами доступа DCOM, то об этом обычно создаётся запись в журнале событий (event log)


text

OPC Server & MPI
Алексей; 5.9.04

Возможна ли связь OPC через MPI.

Если возможна, то какие особенности в настройках?<


text

OPC Server WinCC
Poll; 14.4.04

Передаю данные между двумя компами с помощью OPC Server WinCC. Все работает, но только под администратором. Под простым пользователем обмена не происходит. В чем загвоздка?

Пробовал менять разрешения в реестре-не помогает. Сам wincc стоит на FAT

Re: OPC Server WinCC
Маслов Дмитрий; 14.4.04

Для того, чтобы OPC сервер работал не под администратором, необходимо на машине, являющейся WinCC OPC-сервером, запустить dcomcnfg.exe и для OPCServer.WinCC настроить права доступа.

P.S.: Проверено для WinCC 5.1.<


text

OPC и домены
San; 23.4.04

Можно ли осуществить связь с ОРС-сервером, не находящемся в домене с клиентом (ОРС сервер - ProToolRT v6.0)

Re: OPC и домены
Маслов Дмитрий; 26.4.04

Если машины в одной локальной сети, то можно на них создать одинаковых локальных пользователей с одинаковыми паролями с администраторскими правами, и зайти на обеих машинах под этими пользователями. Все должно работать.


text

OPC, ProTool, работа двух проектов Протула
Darwin; 18.6.04

Я хочу реализовать следующее: 1-проект Протула создается для работы на PC станции, связанной с сетью MPI. В сети MPI 6 контроллеров, 3 операторские панели, теперь добавляется 4-я станция. Далее в проекте этой станции (1-PC), как я понял, есть возможность, чтобы он действовал как OPC сервер. Ставим это опцию. Дальше я хотел такой же проект (то есть дубль всех связей с контроллерами, тегов 1-PC) создать для другой PC станции, связанной с станцией 1-PC по локальной сети предприятия.

И мне не совсем понятен этот процесс. Я прочитал руководства и хэлпы, ясности не возникло.
Заранее благодарен за помощь.
<


text

OPC.SimaticNET и Delphi
Александр; 29.10.04

Пробую связаться с настроенным OPC.SimaticNET из DELPHI как написано в описании на OPC (там на С+). Не могу открыть интерфейс IOPSServer. Может кто подскажет в чем дело.

Re: OPC.SimaticNET и Delphi
Юрченко Владимир; 29.10.04

Не мучайся, зайди на www.opcconnect.com/delphi.php, там ссылки на примеры для Delphi и готовые компоненты для OPC клиента.

Re: OPC.SimaticNET и Delphi
Андрей; 29.10.04

Для работы OPC необходимо дополнительно установить на клиенте и сервере opccomn_ps.dll и opcproxy.dll и зарегестрировать их (REGSVR32 opccomn_ps.dll). В них прописаны все интерфейсы OPC, при регистрации они прописываются в реестре.

Может проблема в этом?
Re: OPC.SimaticNET и Delphi
Александр; 29.10.04

Спасибо за ссылки. Все аолучилось.


text

OPCCOMN_PS.DLL - старая версия
Dmitry; 5.5.04

У меня версия 1.1.0.0. При соединении к OPCServer'у из внешнего источника выдает что нужна новая версия. Кто-нибудь может выслать на мыло - dmitry_krivets@mail.ru.

Re: OPCCOMN_PS.DLL - старая версия
Маслов Дмитрий; 5.5.04

Re: OPCCOMN_PS.DLL - старая версия
Dmitry; 6.5.04

Проблему решил именно заменой dll. OPCClient был написан мной. И теперь вроде бы работает


text

OPCServer.WinCC
Олег; 1.7.04

Как можно ограничить список тэгов доступных по OPC или назначить права доступа к отдельным тегам? Нужно всего 50 из 1500, причем с разными правами на каждый- R, RW, W

Re: OPCServer.WinCC
Геннадий; 6.7.04

Такое можно сделать в KepServer.

"Родной" ОРС сделать такого не позволяет(на сколько я знаю)...
Re: OPCServer.WinCC
Александр Родин, ООО "Нева Электрик"; 6.7.04

Ищем \SIEMENS\SIMATIC.NET\opc2.nt\binDP\scoredp.txt

Открываем, правим как нам надо. Структура достаточно понятна.
Re: OPCServer.WinCC
Александр Родин, ООО "Нева Электрик"; 6.7.04

то же самое, если у вас не DP соединение, то смотрим

C:\SIEMENS\SIMATIC.NET\opc2.nt\binS7\scoredp.txt
C:\SIEMENS\SIMATIC.NET\opc2.nt\binFDL\scoredp.txt
C:\SIEMENS\SIMATIC.NET\opc2.nt\binFMS\scoredp.txt
C:\SIEMENS\SIMATIC.NET\opc2.nt\binSR\scoredp.txt<


text

OPCсервер WinCC
olzhan; 21.1.04

Не всегда срабатывает ВинСС как ОРС сервер. Выдает "ошибка при запуске программы". DCOM настроен правильно!!!

Re: OPCсервер WinCC
Владимир Ерохин; 19.2.04

Если проект, во время подключения находится не в RUNTIME - ошибка Класс не зарегистрирован. В WinCC 4.x при приостановленном RUNTIME сервер ОРС переходил в режим SUSPENDED. В WinCC 5.x сделали что вообще не запускается.

Еще может быть при использовании proxy библиотек, поставляемых с WinCC. Попробуйте поставить какой-нибудь ОРС сервер другого производителя (подменит, надеюсь proxy). Или взять отдельно proxy для OPC 2.0 (или поздние). Их можно с сайта www.opcfaundation.org поиметь.<


text

OS-ProjectEditor
Human; 8.1.04

Приветствую, уважаемые!

Столкнулся со следующей проблемкой надо сделать проектик для Simatic PC Panel размер 800x600, а OS-ProjectEditor такого разрешения не поодерживает, во всяком случае у меня он его не показвает. Проет создаётся в PCS7 v6.0 SP2, посему создавать картинки руками, нет резона, да и желания тоже. Подскажите, как научить OS-ProjectEditor показать 800x600?
Спасибо!<


text

PASSLoginDialog - регистрация с клиента WinCC 6 sp2
Gesha; 28.12.04

Есть сервер WinCC 6 sp2. Multi user project.

Есть клиент по локалке.
На сервере в User administrator прописаны пользователи.
Запускаем клиента - запускаем стандартную wincc регистрацию на нем, не удается зарегистрироваться. Ничего не пишет. В Currentuser тоже ничего не происывается ни на сервере, ни на клиенте.
хотя клиент живет - рантайм, тренды, аларм - все живое,
а вот с регистрацией с клиента проблемма. Как быть?<


text

PASSLoginDialog в WinCC 6.0.1.2
Human; 21.4.04

На компе установлен pcs7_v6.0SP2 плюс к WinCC доставлен WinCC_6SP1HF3. После создания проекта посредством OS-ProjectEditor для вызова окна регистрации предлагается использовать PASSLoginDialog, но в указанном "pdlrtint.h" её описания нет (проверил на 3х машинах). Можно конечно обойтись и без этой ф-ции, НО интересно, раз немцы ссылаются на "pdlrtint.h", может она там должна быть? Может какой-то компонент PCS7 переписывает файл? И как быть чайнику в этом случае?

Re: PASSLoginDialog в WinCC 6.0.1.2
Макс Прилепский; 21.4.04

В версии 5.1 объявление функции следующее:

#pragma code ("useadmin.dll")
#include "PWRT_api.h"
#pragma code()

void PASSLoginDialog(TCHAR ch)
{
PWRTLogin(ch);
}

думаю, в версии 6 это особым изменениям не подверглось, поэтому можно попробовать:

#pragma code ("useadmin.dll")
#include "PWRT_api.h"
#pragma code()

PWRTLogin('1');

в данном случае, '1' - это номер монитора, на который будет выводится диалог.

Можно также попытаться переопределить функцию PASSLoginDialog как функцию проекта, грохнув при этом passlogin.fct из папки ..\Aplib\Options - но это не очень правильный путь. А может есть проблемы с доступом к папке Aplib, она же расшаренная SCRIPTFCT
Re: PASSLoginDialog в WinCC 6.0.1.2
Human; 21.4.04

To Макс: всё, что Вы сказали, знакомо и понятно, вопрос не в том, КАК вызвать окно регистрации, (оно мне собственно и не нужно поскольку пользуюсь своим, написаным на Delphi), а в том - почему немцы ссылаются на "pdlrtint.h", в котором о данной ф-ции ни слова? Это косяк немцев или кто-то затирает этот самый файлик?

Re: PASSLoginDialog в WinCC 6.0.1.2
Макс Прилепский; 21.4.04

Здесь надо смотреть, какие заголовочные файлы (*.h) включены директивой #include в сам pdlrtint.h , далее искать концы (тоже #include)уже в этих заголовочниках. Так постепенно можно добраться и до заголовочника PWRT_api.h, в котором определяется функция PASSLoginDialog ;)А при интерпретации в P-Code транслятор WinCC проходит по всем используемым заголовочным файлам и ищет описание типов и функций в них (соответственно, проходя и по тем заголовочникам, которые указаны в #include используемых).


text

PASSLoginDialog('1');
Мифка; 16.12.04

PASSLoginDialog('1');

Че то не могу догнать одной штуки...
Вопщем в проекте я как то использовал эту функцию для вызова диалога ввода пароля (по клику на кнопке)
И это работало...

А в другом проекте делаю тоже самое, так при компиляции говорит что не знает такой функци... хм... а если блин скопировать кнопку (каторая работает) так нафиг она нормально работает....

Может кто че посоветует???
Впринципе нужно вывести диалог ввода пароля для аутонтификации пользователя (стандартный винсисёвый диалог нужен)
Re: PASSLoginDialog('1');
Андрей; 16.12.04

Для WinCC 6 SP1:

#include "apdefap.h"
void OnClick(char* lpszPictureName, char* lpszObjectName, char* lpszPropertyName)
{
// WINCC:TAGNAME_SECTION_START
// syntax: #define TagNameInAction "DMTagName"
// next TagID : 1
// WINCC:TAGNAME_SECTION_END

// WINCC:PICNAME_SECTION_START
// syntax: #define PicNameInAction "PictureName"
// next PicID : 1
// WINCC:PICNAME_SECTION_END

#pragma code ("UseAdmin.DLL")
#include "pwrt_api.h"
#pragma code ()

PWRTLogin('1');

}
Re: PASSLoginDialog('1');
Мифка; 17.12.04

Спасибо :)

я разобрался! у меня глюки с WinCC были. файл AP_GLOB.H был касяковый. скопировал нормальный и все заработало

Кстати, зачем #pragma code () ????
Re: PASSLoginDialog('1');
Андрей; 17.12.04

Я из какого-то демо проекта скопировал, особо не разбирался.

Re: PASSLoginDialog('1');
Макс Прилепский; 20.12.04

Конструкция

#pragma code ("имя используемой dll")

... здесь объявляются функции или директивой #include подключаются заголовочные файлы , в которых эти функции описаны ...

#pragma code ()

означает, что из action будут вызываться функции определённой dll.

#pragma code ("UseAdmin.DLL")
#include "pwrt_api.h"
#pragma code ()

PWRTLogin('1');

В этом случае из библиотеки UseAdmin.DLL выполняется функция
PWRTLogin(), описание которой находится в заголовочном файле pwrt_api.h.
<


text

PCS7 v6.0 SP3 и W2000rus
Дмитрий; 26.8.04

Можно ли заставить работать PCS7 v6.0 sp3 под русскими Виндами 2000?

Re: PCS7 v6.0 SP3 и W2000rus
Human; 26.8.04

И заставлять не надо - само работает :). Всегда используем русские Win2K - никаких проблем не наблюдалось ни с одной из версий PCS7, в том числе и с последней.

Re: PCS7 v6.0 SP3 и W2000rus
Diana; 26.8.04

Работой это не назовешь! Зы - попробуйте в русском наделать клиентов!

Re: PCS7 v6.0 SP3 и W2000rus
Михайлин Сергей; 26.8.04

Конкретика где? В чем проблема? Не ставиться, не запускается, что говорит, что не делает....

Re: PCS7 v6.0 SP3 и W2000rus
Human; 30.8.04

To Diana

В чём собственно проявляется "неработа"?
Re: PCS7 v6.0 SP3 и W2000rus
Сергей; 6.9.04

Дмитрий правильно ставит вопрос, если устанавливать PCS7 SP3 под Win2000 SP4, то для установки WinCC SP2 потребуется KB828748, а она есть только в нерусском варианте на диске и вообще в природе, поэтому или ставить под англоязычную версию, или Win2000SP3 и ниже, или обманывать ОС, что КВ828748 установлен.

Re: PCS7 v6.0 SP3 и W2000rus
Diana; 6.9.04

Сори! Просто накипело! Первое (только за последнее время) - Делаем трансфер, делается через раз, т.е. при меморирезете алярлогинх обновлять отказывается. Перезагружаемся - работает. Второе - в наглую перестает трансферить источник сообщений. Третье, четвертое, пятое... Песню про грязный реестр слышал. На машинках не установлено ничего! Только виндовз и симатик. Из-за русского, английского - не знаю. Дома английский - ничего подобного не было.

Re: PCS7 v6.0 SP3 и W2000rus
Diana; 6.9.04

ОФФ - а не заняться ли Сименсу сборкой автомобилей?! Уж что, а качество тормозов точно будет на высоте! :))

Re: PCS7 v6.0 SP3 и W2000rus
Михайлин Сергей; 6.9.04

2 Diana. Последним предложением вы сами ответили. Повсеместно стоит английский и проблем нет. И НИКТО не рекомендует ставить русский Windows, тем более для таких сложных ПТК как PCS7. А если хочется русскую оболочку ставьте MUI Language Pack.

PS. А Сименс собирал автомобили (Фаэтон назывались) и были неплохие. А сейчас 60% электрики в иномарках это Siemens-Bosch-Osram.
Re: PCS7 v6.0 SP3 и W2000rus
Штыка Игорь; 7.10.04

Для установки PCS7 v6.0 SP3 под Windows2000rus действительно необходим KB828748 (для установки WinCC для данного пакета). Необходимо следующее:

1. Должен быть установлен SP4 для Win2K

2. В реестре ищите КB828746 и затем 6 заменяете на 8. Все!
Re: PCS7 v6.0 SP3 и W2000rus
Jook; 23.11.04

У меня такая же проблема. Требует KB828748. Искал в реестре, как было предложено выше, ни чего ни нашёл. Что делать???

Re: PCS7 v6.0 SP3 и W2000rus
Jook; 23.11.04

У меня такая же проблема. Требует KB828748. Искал в реестре, как было предложено выше, ни чего ни нашёл. Что делать???

Re: PCS7 v6.0 SP3 и W2000rus
Чистяков Дмитрий ОАО СеверСталь; 23.11.04

смотрите сюда

См. http://dimton.narod.ru/re/pwcs7-wincc-kb.htm


text

PLC-OS Connection Data
Baby; 20.1.04

Привет !!!!

Ситуация.
Начал с помощью PLC-OS Connection Data, перегонять данные в WinCC,
и неожиданно ”выскочило” окошко с верхним подтекстом “SWW” -> сообщение
“No Licence for PLS1”. Лицензии на Step7 и WinCC есть.
Вопрос1. Что за окошко и сообщение.

И вдогонку вопрос2 , можно ли поставить атрибут для всего DB (и соответственно для всего , что внутри него находится).
Например S7_m_c . The parameter is to be operated or monitored from an operator interface system. Хотя там ясно сказано.....
S7_m_c Attribute
Parameter system attribute for:
IN/OUT/IN_OUT parameters for function blocks , system function blocks , shared data blocks, data blocks derived from a user-defined data type
,instance data blocks , global data blocks , charts .
Но может , не так.......
Re: PLC-OS Connection Data
Михайлин Сергей; 20.1.04

Ответ на вопрос 1 - отсутствует для WinCC v5 (а у вас наверно как раз она)лицензия на Basic Procces Control.

<


text

Project function в Global Script
Игорь Одесса; 23.7.04

Тривиальная задача - есть тег, хочу занести его значение в TagLogging разделенное на коэффицент . Написал Project Function которая в качестве параметров принимает имя тега и коэффицент деления, ну и выполняет соответсвующие действия (...return <значение/коэффицент>. В TagLogging->ProcessTagProperties->parametres выбираю Action, куда ставлю вызов ф-ции с соответствующими параметрами....ничего не работает. :( Подскажите в чем причина?

Re: Project function в Global Script
Александр Родин, ООО "Нева Электрик"; 23.7.04

Для того чтобы заносить нормализованные значения тагов в TagLogging в качестве Action должна использоваться специальная функция, написанная по следующему шаблону:

#include "apdefap.h"

double div10 (double doLmtValue, double doValue, int dwCount, BOOL dwFlag)
{
return doValue/10.0;
}

естественно, что выполняемые в функции операции по нормализации могут быть любыми, название функции так же может быть произвольным, главное - это сохранить набор параметров.
Подробнее читайте в Configuration Manual.
Re: Project function в Global Script
Александр Родин, ООО "Нева Электрик"; 23.7.04

Добавление:

более подробно надо читать даже не Configuration Manual, а описание к WinCC, в частности раздел 5 (кажется) Tag Logging.
Re: Project function в Global Script
Svetozar Yolov; 23.7.04

Dear Игорь,

I hope you ca deal with English because I understand russian but it is difficult to speek.
If you want to process tag values from the Tag Logging you have to use function which have special parameters:
for instance
double Norm_PDE(double doLmtValue, double doValue, int dwCount, int Archivierung)
{
return (doValue/10);
}
Please read the example in winCC information system, Release Notes, Notes on WinCC, WinCC CS, then select
Archiving converted process values under Tag Logging.
I hope this will help you.
Also pay attention to the following:
If you set the data to be archived to 1 min and acquisition and archiving cycle are equal to 1 min it is more likely to log the data which are 1 minute old! This because tag Logging make some performance optimisiations (i have contacted the Hot Line concerning this problem - they told me that this behavior is by design). To workround this make acquisition cycle less - 5 seconds for instance.
I hope this works for you.

Best regards,
smi

Re: Project function в Global Script
Александр Родин, ООО "Нева Электрик"; 23.7.04

Шкала времени в WinC Online Trend Control (WinCC 6 SP2)
Макс Прилепский; 23.7.04

Недавно перешёл на с WinCC версии 5.1 на версию 6.0 SP2. При работе со штатным компонентом для отображения трендов время на оси всегда обозначается в 12-часовом формате с указанием AM/PM. Манипуляции с Time Base проекта и компонента, ровно как и смена языка проекта с английского на русский ничего не изменила. Язык операционной системы - русский. Эта "фича" компонента вообще как нибудь лечится ?

P.S. В WinCC 5.1 время без проблем отображалось в 24-х часовом формате.
Re: Project function в Global Script
Игорь Одесса; 23.7.04

Спасибо, но имя тега я так и не могу в ф-ции передать, или имеет смысл следующее:

double div10 (char * TagName,double doLmtValue, double doValue, int dwCount, BOOL dwFlag)
{
value=GetTagDouble(TagName);
return value/10.0;
}
количество и тип передаваемых параметров видимо жестко зафиксировано, т.к. данная ф-ция у меня не отрабатывает ;(
Re: Project function в Global Script
Александр Родин, ООО "Нева Электрик"; 23.7.04

Да не надо никакого имени тега передавать !!!.. :)

Оно уже учитывается, когда вы подставляете Action в строке архивного тэга TagLogging-а. Значение тэга, который должен сохранятся - это doValue, а сама функция возвращает нормализованное значение, которое и _БУДЕТ СОХРАНЕНО_ в архив. Вся фишка-то как раз в том, что функция должна _ПОЛНОСТЬЮ_ соответсвовать представленному шаблону, т.е. никаких дополнительных параметров типа вашего "char* TagName" _НЕ ТРЕБУЕТСЯ_!
Re: Project function в Global Script
Александр Родин, ООО "Нева Электрик"; 23.7.04

Попробую все разложить по полкам.. :)

1. В архиве имеем тэг SomeTLGTag, который привязан к системному тэгу SomeCSTag.
2. Допустим нам надо сохранять в архиве значение SomeCSTag, но в 10 раз меньшее.
3. пишем в глобал-скрипте функцию div10, по уже известному нам шаблону.
4. В таглогинге у тэга SomeTLGTag в столбце Processing выбираем Action, в следующем столбцем (Action for processing) вставляем имя нашей нормализующей функции (div10) - и _ТОЛЬКО ИМЯ_, потому как список параметров системе уже известен (повторюсь - функция шаблонная).

Все, далее, с удовлетворением наблюдаем, как в архиве записываются нормализованные значения.
Re: Project function в Global Script
Игорь Одесса; 23.7.04

ОГРОМНОЕ СПАСИБО, а я мучался, совал этот TagName ;)

А в каком документе это все описано?
Re: Project function в Global Script
Александр Родин, ООО "Нева Электрик"; 23.7.04

Когда-то (для WinCC v.4.0) это входило в стандартное описание.

Сейчас это есть в хэлпах.

Help\Editors\Tag Logging\Apendix\Templates for Function Calls<


text

Project Migrator WinCC - сырой продукт.
Руденко Алексей "НЕВИСС-Комплекс"; 24.11.04

Я конечно умею читать, поэтому прочитал, что данный софт предназначен для конвертирования проектов для 5.0 и 5.1 SP2 в v. 6.0 , но пусть достопочтимые представители Сименса скажут каким образом можно определить в какой версии создан тот или иной проект и как более старые проекты перевести в WinCC 6.0 .

Наверное есть вариант установить 5.1 в ней открыть старый проект (а он открывается почти без проблем) потом сохранить его в версии 5.1 - ну а далее мигратор обязательно поможет (только сначала надо установить 6.0)
Также хотел отметить, что при установке 6.0 не важно с каким сервис-паком при использовании мигратора выдается сообщение, что не инсталирован драйвер SyBase SQL Anywhere-> после этого на диске выбирается меню Tools (или как то по другому - не важно) и выбирается искомый драйвер -> начинается установка...
И что вы думаете? После этого он запрашивает диск со старой (5.1 или 5.0) версией WinCC, так как этот драйвер находится именно там...
Ну и что тут сказать? Хорошо, у меня то старая версия есть, а у других, которые купили 6.0 она необязательно присутствует...
В общем, очень много "хороших" слов вырывается по поводу "великолепной" SCADA системы...
Re: Project Migrator WinCC - сырой продукт.
Чистяков Дмитрий ОАО СеверСталь; 24.11.04

Хм... А у нас не спрашивала старый сидюк.

Что же касается SyBase SQL Anywhere, то он находится на диске 6-ой версии в папке Option.
Кстати данная ситуация расписана в описаниях readme и руководстве по инсталяции.
Re: Project Migrator WinCC - сырой продукт.
Руденко Алексей "НЕВИСС-Комплекс"; 24.11.04

Директория Options содержит Microsoft Script Debuger, полезный для отладки скриптов VB и инсталлятор базы данных Sybase v.7, которы может понадобиться для трансляции проектов созданных в WinCC v.5.1 и v.5.0 SP2 в формат 6-ой версии.

- выдержка из файла ReadMe.
Но вот инсталятор и требует другой диск, так как на этом ничего не находит.
Но это второстепенная проблема, а волнует прежде всего вопрос №1 он же и тема обсуждения - Мигратор проектов, который уж слишком остро заточен.
Почему встала данная проблема:
- Есть диск старых выпусков с доками и примерами проектов на WinCC, захотелось кое что посмотреть, а никак.
Я конечно могу все сделать самостоятельно (уж секретов по WinCC для меня почти не осталось), но это же время.
Обидно просто.
Спасибо за коментарии
Re: Project Migrator WinCC - сырой продукт.
Чистяков Дмитрий ОАО СеверСталь; 24.11.04

Старыми примерами пользоваться не рекомендую. Там иногда попадались кадры, использующие не документированные функции, которые могут в новых версиях просто не работать или работать не совсем верно.

Так мы "накололись" на функции смены кадра в указанном окне. <


text

Project Migrator из Wincc 5 в WinCC 6
Vladimir; 21.10.04

Пытаюсь под WinCC SP1 запустить демонстрационные проекты из

COM.chm, CM.chm и KB_5_e.chm Для конвертации проектов запустил
CCMigrator.exe - отказался работать потребовал SyBase SQL сервер.
Установил SQL Anywhere Studio 7.0.2. Теперь CCMigrator.exe пишет
что не может сконвертировать проект так как он выполнен в WinCC
более старой чем WinCC5 SP2. Подскажите как решьть проблему,
т.е. как сконвертировать проекты WinCC5 в WinCC6

Re: Project Migrator из Wincc 5 в WinCC 6
Маслов Дмитрий; 21.10.04

1. Видимо проект создан в WinCC 5/SP1 или раньше, где использовался Sybase v.5. Поэтому его надо сначала сконвертировать в 5.1, а затем в 6.0. При этом не уверен, что после двойной конвертации все будет хорошо рабоать.

2. Учитывая то, что Вам нужны проекты из Configuration Manual, предполагаю, что наибольший интерес для Вас в этих проектах составляют картинки (*.pdl), функции проекта (*.fct) и скрипты Global Scripts (*.pas). Их Вы просто можете скопировать из старого проекта в пустой проект WinCC 6.
См. http://www.wincc.ru

Re: Project Migrator из Wincc 5 в WinCC 6
Макс Прилепский; 25.10.04

Я сконвертировал проект WinCC, созданный в версии WinCC 4.02, в версию 6 с помощью Project Migrator, до этого при инсталляции Sybase SQL Anywhere 7 указал для установки библиотеки совместимости с более ранними версиями этой СУБД, а именно Sybase 5.


text

PROSAVE
Евгений; 27.10.03

Проконсультируйте кто сможет.

Существуют ли декомпиляторы для
получения нормального проекта PROTOOL
из бинарной копии проекта(PROSAVE).
Заранее благодарен.
Re: PROSAVE
Костян; 15.9.04

Эх... хороший вопрос... Когда узнаете - как - расскажите пожалуйста!


text

ProSave
Alex; 21.9.04

Есть ProTool 6.0 SP2

Программой ProSave не могу вытащить проект из панелей ОР7 и ОР17.
Кабель и настройки для выкачивания сделал - в общем методов пробовал немеряно ....
Ничего не получается - пишет проверьте интерфейс,кабель,настройки...
Если кто реально эту процедуру делал - напишите как???
Есть подозрение что ProSave реально не работает......
У многих людей спрашивал - ни у кого не получилось....<


text

ProTool и мышиный курсор
Юрчик; 22.4.04

Как сделать так, чтобы при запуске ProTool/RT курсор не висел посередине экрана, загораживая его элементы?


text

ProTool & rs485
Bai; 4.7.04

Можно ли работать непосредственно с портом (физическим устройством).


text

ProTool & S5-135U
Юрчик; 2.2.04

Имеется станция диагностики Win Based PC на ProTool/RT v 6.0 + SP2 и

двухпроцессорный контроллер S5-135U на процессорах 928B и 922 работающих через 923C координатор.
Вопрос: как получить доступ из протула к обоим процессорам через 923C координатор?

В пакете Step-5 под DOS в конфигурации все просто - прописываешь маршруты и
при необходимости просто выбираешь нужный - все, кабель переключать не надо.
А может этот маршрут можно как-нибудь прописать в ProTool ?
<


text

Protool /pro CS не открывает проект OP17
Александр; 4.3.04

Пишет что " Error on converting OID4==OID_OP_DEVACE", и нагло посылает к дилеру :-(. При этом мои проекты на ОР37 открываются без проблем.

Protool /pro CS V5.2 +SP2
Step V5.1 + SP1
W2k pro
ожет кто чего-нить подскажет по данной проблеме, чего ей еще надо? Заранее благодарен. Александр
Re: Protool /pro CS не открывает проект OP17
kot; 4.3.04

скорее всего проект под ор17 написан на РТ версией повыше.

Re: Protool /pro CS не открывает проект OP17
alex-b3; 4.3.04

Была аналогичная проблема. Лечится только установкой более свежей версии ProTool (желательно самой последней)

Re: Protool /pro CS не открывает проект OP17
Александр; 12.3.04

Действительно: установил ProTool V6 + SP2 и все поехало :)))

Re: Protool /pro CS не открывает проект OP17
александр; 12.3.04

поставил ProTool V6 + SP2

и без изменений что делать может кто знает ?
Re: Protool /pro CS не открывает проект OP17
alex-b3; 17.3.04

Возможно проект написан в ProTool V6+SP2P (это, кажется, наиболее свежая). Еще можно связаться с производителем проекта и узнать версию ProTool у него.

Re: Protool /pro CS не открывает проект OP17
Наташа; 17.3.04

Версия ProTool v.6 SP2 более свежая чем ProTool v.6 SP2Р.

Re: Protool /pro CS не открывает проект OP17
александр; 19.3.04

сорри не обратил внимание у меня ProTool v.6 SP2Р я так понимаю надо найти без "P"

вопрос
fresco; 25.3.04

Что такое SP2P ?


text

ProTool ???
Сергей; 13.10.04

Господа в ProTool v6.0 в есть функция Upload (File/Upload/Start-Preferences). Я так понял можно выгрузить проект из панели? Попробовал на Simatic C7-633, не идёт, загрузка без проблем, а вот выгрузка пишет, что нет соединения... Хотя панель находиться в режиме "Ready for transfer". Помогите разобраться с проблемой, или выгрузка проекта из панели в принципе невозможна, а может не все панели поддерживают эту функцию? С уважением, Сергей...

Re: ProTool ???
sasha; 13.10.04

ВАША ВТОРАЯ ДОГАДКА ВЕРНА. НА ЛИЧНОМ ОПЫТЕ УСТАНОВИЛ, ЧТО ФУНКЦИЮ АПЛОАДА ПОДДЕРЖИВАЕТ ТД370. ДЛЯ ОР3,7,17 ЭТА ПРОЦЕДУРА НЕДОСТУПНА. ДРУГИХ ПАНЕЛЕЙ ДЛЯ УЗУЧЕНИЯ ЧЕРЕЗ МОИ РУКИ НА ПРОХОДИЛО. КСТАТИ НА АНАЛОГИЧНЫЙ ВОПРОС В ЭТОМ ЖЕ ФОРУМЕ В РАЗДЕЛЕ HMI НЕ ПРИШЛО НИ ОДНОГО ОТКЛИКА. НАВЕРНОЕ ТЕМА НЕ АКТУАЛЬНА

Re: ProTool ???
Дмитрий; 13.10.04

Функция доступна для панелей с операционной системой WinCE

Re: ProTool ???
Михаил; 14.10.04

Посмотрите мое сообщение от 11.10.04 Сохранение проекта панели МР270 в разделе SIMATIC HMI!!!

Re: ProTool ???
Сергей; 3.11.04

На ОР27 прекрасно заливается туда и обратно с ProSave V6.0 SP2, функциями "backup" и "restore".

См. http:/sivoukhin.narod.ru


text

Protool -> Непонятный Error.
Baby; 18.2.04

Hallo !

Ситуация.
Есть проект на Protool.
Открываю и появляются сообщения

Error on converting OID 5 == OID_POB_CTDRIVER_MANAGER
Please contact the manufacturer.
Unexpected file format
Opening of configuration unsuccessful

Проект не открывается.

Вопрос. Что это за ошибки и как их исправить , чтобы проект открывался.
Re: Protool -> Непонятный Error.
Юрченко Владимир; 24.2.04

Скорей всего проект создан более новой версией ProTool. Последняя версия на данный момент ProTool v.6 SP2 (не SP2P).

Обратитесь в ближайшее представительство Сименс чтобы обновить версию.<


text

ProTool Pro V6.0 +SP2
Дмитрий; 5.11.04

Кто-нить знает где можно скачать данную прогу? Говорят что SP2 отдельного нет...


text

ProTool Pro v6.0 SP2 под WinXP
Александр Родин, ООО "Нева Электрик"; 4.8.04

После установки ProToolPro 6.0 SP2 под WinXP PRO SP1a RUS, не могу открыть ранее созданный проект. А точнее конфигурацию для PC. Вылазит окно: "The required device type "PC" is not supported by the ProTool version installed. Check the entries in the D:\SIEMENS\ProTool\PROTOOL.INI"

Проект создавался в той же версии ProTool но под Win2000.

Заглянул в указанный файл, и обнаружил там строчку:
[Device List]
...
PC=LY_PC.DLL
...

Посмотрел версию указанной DLL-ки:
версия продукта: V6.0+SP2
версия файла : V6.0.2.22

При попытке создать новую конфигурацию, драйвер для PC отсутствует как класс (есть для РС670, РС870 и т.д., а просто РС нет).

Так и где я и в чем не прав? Или это очередной косяк?
поправка
Александр Родин, ООО "Нева Электрик"; 4.8.04

драйверы для PC670, PC870, FI45 и т.д. так же отсутствуют. Хотя в PROTOOL.INI они есть...

Re: ProTool Pro v6.0 SP2 под WinXP
Юрченко Владимир; 4.8.04

Не проверял ProTool под Windows XP, но есть 2 момента - таблица совместимостей ProTool Pro и Windows (http://www4.ad.siemens.de/WW/view/en/8795248) умалчивает о сервис паках XP.

Ну и второе это руссифицированные версии Windows, иногда нормально, но иногда что нибудь проявляется самым неожиданным образом...
Re: ProTool Pro v6.0 SP2 под WinXP
Александр Родин, ООО "Нева Электрик"; 4.8.04

Посмотрел таблицу совместимости версий...

Стоял у меня до этого ProTool Pro v6.0 SP1a под такой же виндой (Win XP PRO SP1a RUS) работал отлично, по крайней мере конфигуратор. Хотя вот по таблице не должен бы... :)

Может, конечно, и русская версия виновата, хотя все изменения в реестре, по поводу локализации, я внес.

А может проблема в том, что диск бесплатный с партнерского семинара (уже были подобные косяки но с WinCC), но в документации на диске о функциональных ограничениях ничего не сказано.

Какие еще будут предложения?<


text

ProTool SDK (ActivX + Protool)
Исаев Георгий; 15.4.04

Работал кто нибудь с данной программой? И можно ли ее приобрести в России. В каталоге СА только ссылка на другой сайт.

<


text

protool на ПК и S7-200
SVS; 10.9.04

Будет ли работать protool на ПК и S7-200 через кабель pc/ppi?

Если нет, то что для этого нужно
(для их совместной работы ?)
Ответьте пожалуйста
Re: protool на ПК и S7-200
Дмитрий; 13.9.04

Будет!

Re: protool на ПК и S7-200
Marat; 14.9.04

И у меня прекрасно все работает.

Re: protool на ПК и S7-200
Василий; 28.9.04

А у меня не работает. Все уже пробовал, связь с ПЛК не находит. А MicroWin работает нормально. Может кто-то подскажет в чем дело может быть?

P.S. У меня WinXP стоит, может в этом дело? <


text

ProTool сносит русский язык
Дмитрий; 23.9.03

При закрытии ProTool удаляет из системы русский язык. Кто нибудь знает как от этого избавиться. (Система Win2kRU языки - Eng/Ru)

Re: ProTool сносит русский язык
Юрченко Владимир; 24.9.03

Это бывает Когда ProTool запускается в интегрированном режиме и один из поддерживаемых языков не европейский -

все языки кроме 5-ки (en,germ,fr,it,esp) и выбрасываются из трея.
Единственно, что остается после этого, это добавить русский в Control Panel.
Обещали исправить это дело - но пока...
Re: ProTool сносит русский язык
Роман Абзаев; 26.9.03

У меня была более весёлая ситуация - при выходе из ProTool 6.0+SP1 к четырем раскладкам Windows 2000 Pro SP3 (Британский+американская, Русский, Немецкий, Греческий) добавлялся Английский(США). Забавно, хотя и не мешало.

Re: ProTool сносит русский язык
Eugene Segeev; 26.9.03

А кто-то ведь писал в asutp про аттттличную локализцию продуктов Сименс... Ж8-))))

Re: ProTool сносит русский язык
Dmitry; 3.10.03

Русскую раскладку клавиатуры Protool действительно сносит...

Мне помогала установка Русской раскладки по умолчанию.

О какой локализации может идти речь, если большинство программных продуктов Сименс имеют проблемы с элементарной поддержкой русского языка, а также c ОС в которых НАШ язык присутствует. Надеюсь, что проблемы не только с русским... :)
Re: ProTool сносит русский язык
Роман Абзаев; 3.10.03

Слово "отличная" этим кое-кем не упоминалась. И если уж на то пошло, то этот кое-кто писал в первую очередь про перевод документации. И какая, позвольте спросить, такая уж большая проблема с элементарной поддержкой русского языка, за исключением этой маленькой бажки в ProTool?

Re: ProTool сносит русский язык
Eugene Sergeev; 5.10.03

Я недавно чуть не поседел из за этой "маленькой бажки", когда в мнемосхеме на ПроТул РТ взяли и разом пропали все русские надписи. Кстати, они там до сих пор не появились, работают вторым языком - аглицким, бо танцы с бубном не помогли, а переставлять систему при работающем оборудовании я не решился.

И ведь русская раскладка пропадает не только в Протуле - она пропадает во всей системе. Ни комментариев к тексту программы написать, ни документации.
Анноит сильно.
А про локализацию - под локализацией я подразумеваю именно корректную работу с кирилмефодиевскими буквочками (в случае рублевой зоны), а не перевод документации, который нужен только двоечникам.

Re: ProTool сносит русский язык
Роман Абзаев; 6.10.03

Я не так часто использую ProTool, а то как работает WinCC с русскими буквами меня вполне устраивает.

Re: ProTool сносит русский язык
VVV; 14.10.03

Я вот програмку написал. После протула запускаешь ее и она восстанавливает язык в системе (кому интересно могу выслать).

vvitek@mail.ru
Re: ProTool сносит русский язык
Казанцев; 28.1.04

Вышлите, плз эту программку, VVV;

Re: ProTool сносит русский язык
Казанцев; 28.1.04

elmet@epn.ru

Re: ProTool сносит русский язык
asuchmz; 29.1.04

Товарищи (pardon - господа!) и нас не забудьте - asuchmz@chmz.umn.ru

Я тут уже писал по поводу слета комментариев в "Общих вопросах". У нас просто сбойнуло питание - и после этого в DB пропали комментарии. Ладно хоть распечатка была. Народ дико возмущен!
Re: ProTool сносит русский язык
Сидоров Артем; 8.2.04

>Я недавно чуть не поседел из за этой "маленькой бажки", когда в мнемосхеме на ПроТул РТ взяли и разом пропали все русские надписи.

По центру экрана в CS есть листбокс с языками. Если надпись была сделана когда там стоял русский язык, а потом его переставили на английский, то ее перестает быть видно. Но достаточно просто переставить обратно язык и все вернется в норму. Есть ощущение, что это оставлено специально - удобно на 2 языках писать.
Re: ProTool сносит русский язык
Сергей; 17.12.04

Для статистики:

W2K Eng; Англ/Рус, ProToolPro6.0SP2 (SP2 поставил только из-за панели. С SP1 не было ни в интегрированом, ни в неинтегрированом режимах).
Помог совет Dmitry от 03.10.03 (поменял языки с Англ/Рус на Рус/Англ), большое ему спасибо.
Господину Юрченко, на сообщение от 24.9.03 "... Обещали исправить это дело - но пока... ".
Получается, что пока ... добавили.
<


text

ProTool
Alex; 4.2.04

При попытке выкачать проект с панели выдается сообщение о том что версия протула и операционной системы не аналогичны.Как можно это победить?


text

ProTool
potor; 1.4.04

коллеги, помогите пожалуйста ссылочкой, или вышлите если можно по почте potor(собака)pisem.net ProTool с лекарством

за ранее сенкс:)
Re: ProTool
potor; 1.4.04

сам нашел, тема закрыта:)


text

PROTOOL6.0 Доступ к свойствам экранных объектов из VBS
KisA; 25.5.04

Как получить доступк свойствам экранных объектов из VBS, т.е. из собственных процедур (Scripts). Нужно поменять цвет у объекта 1 в экране 1.

Re: PROTOOL6.0 Доступ к свойствам экранных объектов из VBS
Александр Родин, ООО "Нева Электрик"; 25.5.04

только через теги...

напрямую не поменяете.

т.е. надо на требуемом вам объекте правой кнопкой мыши вызвать окно свойств, войти в закладку Attributes, нажать на кнопочку Multiplexing, выбрать тег и далее назначать цвет на различные значения тега.

по другому не получится.<


text

RawData - в чем косяк????
Михаил; 2.9.04

есть переменная Х (32 байта)

BYTE pb[100];
if(GetTagRaw("Х",(void*)pb,32)) MessageBox(NULL,"ok","",MB_OK);
else MessageBox(NULL,"fuck","",MB_OK);

выдает fuck :(
че не правильно? (массив пустой)
Re: RawData - в чем косяк????
Макс Прилепский; 2.9.04

Надо писать GetTagRaw("Х",pb,32)

Re: RawData - в чем косяк????
->Макс Прилепский; 2.9.04

да я и так вроде писал... один хрен не работает :-/

ну попробую еще разок<


text

RawTag in VBS
Алексей; 7.7.04

Кто нибудь ставил задачу передать в VBS содержимое некоего массива в RawTag

Пробую так:

MyRawTag.Value=MyArray
MyRawTag.Write

Пишет одни нули.
(Проверяю содержимое тега чтеним C-шных функций)
Re: RawTag in VBS
Григорий; 7.7.04

Насколько я помню, для работы с RAW -данными, необходимо поставить где-то галочку, может быть даже в опциях при установке WIncc


text

? Raw-тэги, вернее их длина
Дмитрий VAZ; 13.9.04

Привет!

В хелпе написано, что длина raw тэга зависит от PDU канала, который в свою очередь зависит от типа контроллера.
В моем случае, сеть ethernet tcp/ip, контроллер s7 - 400. тэг имеет длину 400 байт, по хелпу - ОК.
Один и тот же проект, один контроллер, но разные компьютеры где запускается проект. На одном - ОК, на другом ошибка, пишет что большая длина тэга.
Сабж еще от чего-то зависит?
TIA
<


text

Redundace и процессы в TaskManager,
Viktor; 18.10.04

WinCC 5.0 + sp2

Есть 2 Сервера. Синхронизируются.
Хронология.
1 день.
-------
На 1 сервере сделал изменения. Проджект дупликатором задублировал на второй сервер.
(файл имя_проектаRT.db ~1gb тоже благополучно перекочевал на второй
сервер)
Стартонул оба сервера - все ОК.
Есть 2 клиента, один прицепил к первому серверу, второй ко второму - все ОК.
2 день.
------
Проекты на первом сервере и на подключенным к нему клиенте - не реагируют на внешние раздражители.
Посмотрел на 1 сервере в TaskManager все время "сожрал" процесс redundancycontr. Поставил ему приоритет поменьше - все стало ОК.
На втором сервере такого процесса нет.
Прошло еще 3 дня.
--------
Процесс redundancycontr до сих пор висит в ситеме и отжирает максимум процессорного времени. Проект на первом сервере в Redundanсe является DefaultMaster.

Вопросы.
1. Что это за процесс?
2. Почему он сожрал все процессорное время?
Re: Redundace и процессы в TaskManager,
Чистяков Дмитрий ОАО СеверСталь; 18.10.04

Скорее всего этот процесс пытается синхронизировать огромное количество трендов и сообщений из архива на другом сервере.

Что за конфигурация сервера?
Винты IDE(SATA) или SCSI?
У нас проектная база весит около 800 МБ, сервера со сказёвыми винтами и загрузка CPU не превышает (в пике) 5%.
Re: Redundace и процессы в TaskManager,
Viktor; 18.10.04

PIII450, 512Mb, 9gb scsi, Lan10mb

Re: Redundace и процессы в TaskManager,
Viktor; 20.10.04

Народ, ну хоть идейку какую подбросте. А ту уже 7 день пошел.

Re: Redundace и процессы в TaskManager,
Михайлин Сергей; 20.10.04

Проверьте синхронизацию времени между серверами. Если оно разное, то процесс синхронизации может тянутся бесконечно.

Внимательно изучите лог файл \siemens\wincc\diagnose\CCRedCodi.log. Может там что-то полезное узнаете.
См. Тут еще рекомендации

Re: Redundace и процессы в TaskManager,
Viktor; 20.10.04

Синхронизация по времени есть.

------
Последние 2 строчки logа от 14.09.04 11:00:00
compare end
connetion to server 2 success
------
То есть получается, что синхронизация давно прошла.
Может грохнуть этот процес?

Re: Redundace и процессы в TaskManager,
Чистяков Дмитрий ОАО СеверСталь; 21.10.04

А посмотрите все процессы боле подробно не через TaskManager, а через Системный монитор.

Там обратите внимание, как на процессы, так и на загрузку сети. Что-то мне 10 Мбит как-то не очень нравятся.
К стати, а в качестве сетевого концентратора используется хаб или коммутатор? И нет ли там светода под название коллизии? И не активен ли он постоянно?
Re: Redundace и процессы в TaskManager,
Viktor; 25.10.04

Проблем с сетью нет. Эту версию я сразу отбросил.

Да и что там синхронизировать, если проект был задублирован вместе с РТ базой и стартанули они с периодом в 10 минут.

Re: Redundace и процессы в TaskManager,
Чистяков Дмитрий ОАО СеверСталь; 25.10.04


text

Report Dis.
Роман; 10.11.04

Как в WinCC распечатать архив тренда или таблицы нажав на созданную в рисунке кнопку,например,для того чтобы оператор смог увидеть данные за определенный момент времени и для нужного параметра...

Re: Report Dis.
Роман; 10.11.04

В Глобальных скриптах есть клманда, "Печать экрана", поискай.


text

RUNTIME ALARM LOGGING
ALEX; 11.6.04

Когда активизирую ALARM LOGING для RUNTIME,то при активизации проекта в RUNTIME не загружается Loading COM Objects... для ALARM LOGGING, потом переходит в дезактивизацию. Подскажите как решить проблему!!!!

См. RUNTIME ALARM LOGGING

Re: RUNTIME ALARM LOGGING
Юрченко Владимир; 16.6.04

Проверьте работу Message Queuing если он не стартует, то не запускается и система архивации алармов и тегов (см. на немецком FAQ, Entry ID:17846274)

Re: RUNTIME ALARM LOGGING
Александр ОАО"Северсталь"; 28.6.04

А у меня примерно происходит тоже самое но с ошибкой : CcAlgRtServer.e.exe has generated errors and will be closed by Windows. You will need to restart the programm.

An error log is bean created/

Re: RUNTIME ALARM LOGGING
Александр ОАО"Северсталь"; 7.7.04

Я решил данную проблему. Во первых стоит попробовать сделать новый проект с несколькими сообщениями, ест-но добавить их в Startup. Если при активизации этого проекта будет происходить тоже самое, что у меня собственно и было, значит дело не в проекте - дело в WinCC, я переустановил WinCC и все пошло. До этого я ставил на WinCC STEP 7 v5.2 и SIMATIC NET, я думаю WinCC нужно ставить посленей


text

s7-200 и WinCC 5
Alex; 6.9.04

Как связать S7-200 и WinCC

Re: s7-200 и WinCC 5
Anton; 6.9.04

Для связи служит PC Access OPC Server v1.0.


text

S7-200 и WinCC
Василий; 28.9.04

Есть S7-200, WinCC и какая-то PCI карта SIMATIC NET (на ней один выход- DP написано). Хотелось бы управлять из WinCC. Как все организовать, чтобы работало?


text

S7-PLCSIM & Alarm Logging
LostAngel; 9.7.04

Использую WinCC 6.0 на WindowsXP. Также использую S7-PLCSIM 5.2.

Сделал проект - отлаживаю программу контроллера S7-300 на PLCSIM, завязываю её с WinCC. Всё работает - кроме Alarm Logging. При выставлении бита сообщения само сообщение не появляется в окне WinCC Alarm Control. Бит сообщения выставляется железно - смотрел и в симуляторе и в WinCC. а сообщения всё нет и нет.
Если кто завязывал WinCC и симулятор контроллера откликнитесь. Хочу услышать - были у вас проблемы с выводом сообщений или нет?
Re: S7-PLCSIM & Alarm Logging
Елхов Максим; 11.7.04

В 6 версии вообще все, что связано с MS SQL работает криво, особенно под ХР. Служба сообщений, скорее всего, вообще не запускается. Под Win2kMUI работает лучше. Иногда помогает удаление и генерация заново Server data.

Re: S7-PLCSIM & Alarm Logging
LostAngel; 12.7.04

Разобрался в чём дело - действительно заново определил Server data - всё заработало.

Уродство блин. Столько времени и нервов из-за такой лажы.
<


text

S7-соединение с PG/PC с WinCC
Александр Клейн, ООО "ВК-Инжиниринг"; 29.9.04

Для работы SFB37 AR_SEND требуется создать S7-соединение к станции WinCC. В проекте это PG/PC. Руководство по HW предлагает в этом случае создавать соединение c неопределенным партнером, вручную вводя его адрес. Все это проделано, но не работает. SFB37 выдает ошибку "Проблемы связи". В чем тут может быть дело? Может быть необходимо также ввести номера Rack/slot для PG/PC? А как тогда их определить? Или что-то еще надо сделать? Пробовал делать определенное соединение с PG/PC. Тот же эффект.

Re: S7-соединение с PG/PC с WinCC
Чистяков Дмитрий ОАО СеверСталь; 30.9.04

Брр...

Как всё сложно. ;-)
А чем не устраивает стандартный драйвер связи?
Re: S7-соединение с PG/PC с WinCC
Александр Клейн, ООО "ВК-Инжиниринг"; 3.10.04

Можно и стандартный драйвер. Только в вызове блока все равно надо указать номер соединения ID, а значит его все равно надо создать.

Re: S7-соединение с PG/PC с WinCC
Чистяков Дмитрий ОАО СеверСталь; 4.10.04

Если честно, то я в принципе не пойму, зачем в S7 использовать SFB37 для передачи данных в WinCC.

Но делается это так.
В проекте устанавливается либо Other station, либо PG/PC. Там создаёте интерфейс, где и будет указан ID.
Re: S7-соединение с PG/PC с WinCC
Александр Клейн, ООО "ВК-Инжиниринг"; 4.10.04

В интерфейсе нет ID, там есть только адрес в сети ProfiBus.

А AR_SEND нужет для того, чтобы передать в WinCC архивные данные. Контроллер измеряет быстрый процесс - за 2 сек 50 измерений и с помощью SFB37 передает их в WinCC. А там это отображается в виде статичного тренда с помощью "On-line trend".
Re: S7-соединение с PG/PC с WinCC
Руденко Алексей "НЕВИСС-Комплекс"; 8.12.04

Тема конечно стара, но недавно задав такой же вопрос так и не получил ответа, поэтому по порядку:

Ситуация примерно такая же, но нужно передать большой объем данных (4kb).
1. Никаких Other Station, просто конфигурируем соединение с неизвестным партнером, не забыв указать его адресс (MPI or Profibus)
2. Указываем нужный нам ID (не путать с R_ID) и в NetPro все это дело компилим.
3. Сам я пользовался SFB12 BSEND, но наверное покатит и AR_Send - работает.
4. В WinCC создаем новое соединение через S7 Protocol Suite и т.д.
5. В настройках тэга (RAW-тэг) ставим галочку SEND/RESIVE.
6. В принципе и все, теперь можно использовать функцию GetTagRaw , а дальше его преобразовывать и т.д.
Естественно важно не забыть, что для нормальной работы SFB должна быть запущена WinCC иначе будет светиться ошибка соединения с кодом.
Если есть вопросы - пишите, отвечу, если надо пришлю пример проекта.
Всем удачи, Алексей
Re: S7-соединение с PG/PC с WinCC
Руденко Алексей "НЕВИСС-Комплекс"; 8.12.04

Ах да, забыл в настройках тэга нужно указать R_ID, так вот он должен совпадать с R_ID с которым вызывается BSEND, таким образом это означает что данные передаются для конкретного тэга.

Большая часть про конфигурацию этого соединения описывается в файле Configuration Manual-3_r.pdf, который выложен на этом сайте в разделе по архивам 5.1.8 стр. 5-83
Всем удачи.<


text

S7-Соединения
Руденко Алексей "НЕВИСС-Комплекс"; 30.11.04

Господа!

Такой вопросик! Работают ли эти соединения через MPI
Спасибо.
Re: S7-Соединения
Юрченко Владимир; 30.11.04

Не понятен вопрос. Если о S7 соединениях, то S7 протокол реализован на MPI, Profibus, Ethernet. Только для MPI лицензия не нужна, а для Profibus и Ethernet потребуется S7- лицензия в зависимости от соммуникационной платы:

См. http://www.automation-drives.ru/as/products/simatic_net/

Re: S7-Соединения
Руденко Алексей "НЕВИСС-Комплекс"; 30.11.04

Спасибо!

Вопрос в том, будут ли работать SFB12,13 на 400-контроллере через MPI при сконфигурированном S7-соединении.
Аналогично для 300 (но на сколько я знаю для 300-ки необходим коммуникационник и далее работа по профибасу или эзернету)
Поправьте если не прав.<


text

Service Pack №2 для Protool
Коротов Д.В.; 12.1.04

Коллеги! Где взять 20ой пак для Protool. Может есть ссылка!?

Re: Service Pack №2 для Protool
CCE; 12.1.04

http://216.43.206.89/Files/Siemens/protool%20V60%20SP2.zip

Re: Service Pack №2 для Protool
Александр; 12.1.04

проще в представителстве siemens`a


text

SetPropChar() с типом Variant
mike; 21.10.04

Подскажите пожалуйста как работать с типом Variant.

Есть событие на изменение значения (число с плаваящей точкой). В функцию это значение передается как Variant. Нужно это значение записать например ввиде строки куда-нибудь. Как получить это значение?
Re: SetPropChar() с типом Variant
Alexis; 21.10.04

дык HRESULT VariantChangeType(VARIANTARG *pvargDest, VARIANTARG *pvarSrc, unsigned short wFlags, VARTYPE vt);

Re: SetPropChar() с типом Variant
mike; 21.10.04


text

SFC "AR_SEND"
Александр Клейн; 23.8.04

В составе STEP7 есть функция SFC37 "AR_SEND" которая передает архивные данные в WinCC. В описании подробно описано как передаются данные из контроллера. А что нужно сделать в WinCC чтобы их принять? Это должен быть какой-то тег или что-то еще? И если тег, то на какие данные в контроллере он должен ссылаться?

Re: SFC
Харгелия Олег, ЗАО "Искра-Энергетика"; 24.8.04

Re: SFC
Александр Клейн; 24.8.04

Спасибо за подсказку.


text

Siemens HMI Symbol Library
LostAngel; 8.6.04

Re: Siemens HMI Symbol Library
Л. Шерешевский; 9.6.04

Специально проверил описанную Вами ситуацию - все работает. Левой кнопке соответствует 1, правой - 2, хотя нажатие на колесо мыши не ловится, к сожалению.

Ищите, что у Вас не так в макросе, в системе или в мыши.<


text

SP1 для WinCC6.0
Костя; 4.10.04

У меня XP и WinCC 6.0 скачал русификатор WinCC60SP1Rus.exe а он кричит что версия не подерживается надо SP1 для 6.0 где взять?

Re: SP1 для WinCC6.0
Pavel; 13.10.04

Идешь в Москве в представительство Сименс на Малой Калужской (м. Шабаловская)- там дадут кампарик с WinCC v6.0SP2. Проверено сам брал.

Re: SP1 для WinCC6.0
Pavel; 13.10.04

Идешь в Москве в представительство Сименс на Малой Калужской (м. Шабаловская)- там дадут компарик с WinCC v6.0SP2. Проверено сам брал.


text

Spartan ROC OPC Server
Людмила; 5.7.04

Работаю в WinCC 5.1. Для получения данных с ROC-407 ( производитель Siemens ) используем OPC-Server Spartan для ROC фирмы Matrikon. В описании этого OPC указывается, что он поддерживает до 256 портов. На практике оказалось, что только 9. При вводе COM10, в лог-файле генерируется ошибка. Производитель молчит. Кто-нибудь сталкивался с подобным? Помогите...

Re: Spartan ROC OPC Server
Diana; 5.7.04

Мне всегда казалось, что ПТИЦА-РУХ 407 делается Эмерсонами. А чего за порты Вы имеете ввиду, а то немного непонятно? И тот OPC разве уже разрешили?

Re: Spartan ROC OPC Server
Людмила; 5.7.04

Действительно, это расходомер фирмы "Fisher-Rosemount". А порты я имела последовательные коммуникационные порты. Физически их, конечно обычно 4, COM1, COM2..., а виртуальных может быть до 256.

Я живу не в России, поэтому не могу ответить на последний вопрос. А вообще он что запрещенный?
Re: Spartan ROC OPC Server
Diana; 6.7.04

Да вроде бы Газпром против коммерческого учета с этой программой. А насчет портов все равно не понятно. Т.е. если нужно подключить так дофига вычислителей, то нужно делать несколько подсетей - по 32 адреса на каждый COM.

Re: Spartan ROC OPC Server
Людмила; 6.7.04

У нас пока некоммерческий учет. А вообще, извените, я не так очевидно объясняю, что я хочу. Потому что я не поняла как это несколько подсетей по 32 адреса на каждый COM. Вычислители и так все в подсетях и каждому COM может соответствовать только один IP адрес и вроде бы по другому нельзя. Это задается при установке виртуального порта.

<


text

Sybase
Д.Веткин; 15.3.04

Привет коллеги!

При установке проекта на новом компьютере (ВИН 2000, ВИНСС 5.1) возникла проблема:
Не работает связь с базами данных (сабж), связь устанавливалась с помощью функций ОДК и через АДО объекты
при подключении Сервер сабжа кричит что превышен предел количества подключений, причем кричит правильно, если в проекте вырубить алярмлогин, текстлибрари, тэглогин все начинает работать, кстати алярм логин не работает вообще(если его включить рантайм не запускается)
может кто сталкивался с такой штукой?
TIA
Re: Sybase
Юрий Оганесян; 18.3.04

Уфффф.. Предел одновременого количества подключений существует, по-моему только для DSNов, использующих TCP/IP. (кстати, этот предел - 1:) ) На Shared Memory ничего такого не встречалось. Понятно, что работают такие DSN только если обращение идет с локального (того же) компьютера.

Не понял, откуда вы обращаетесь к базе тем же ADO - из Global Script или внешней прогой???
А Alarm Logging сам по себе работает? , т.е. без вашего доп. кода (ODK, ADO)?
Re: Sybase
Юрий Оганесян; 18.3.04

Уфффф.. Предел одновременого количества подключений существует, по-моему только для DSNов, использующих TCP/IP. (кстати, этот предел - 1:) ) На Shared Memory ничего такого не встречалось. Понятно, что работают такие DSN только если обращение идет с локального (того же) компьютера.

Не понял, откуда вы обращаетесь к базе тем же ADO - из Global Script или внешней прогой???
А Alarm Logging сам по себе работает? , т.е. без вашего доп. кода (ODK, ADO)?
Re: Sybase
Никаноров; 18.3.04

Если у Вас на той же машине установлен Step7 (Step7 Professional), то необходимо с диска Step7 установить HotFix к WinCC. Тогда и AlarmLogging будет запускаться, и соединение с базой будет.

Re: Sybase
Д. Веткин; 18.3.04

Спасибо всем, дело действительно в ХотФиксе,

а с базой работал и глобал скрипта, и без хотфикса работало только несколько подключений, неважно каких, ВИНССшный или моих, главное что на всех не хватало)))... прикольно<


text

Tag Loggin
Никитин; 24.7.04

Подскажите, где находится запис значения тегов в Tag Loggin.

Заранее спасибо!

Re: Tag Loggin
Никитин; 24.7.04

Re: Tag Loggin
Nick Gashevsky; 26.7.04

Если нужен к ним доступ, то через WinCC OLE DB

Посмотри в архиве конфы. Эта тема уже обсуждалась. Есть и примеры.<


text

Tag Logging WinCC 5.1
Владимир; 5.4.04

Подскажите где находится файл ( и как называется) в который пишется Tag Logging .И можно ли задать его размер чтобы запись шла по циклу?

Re: Tag Logging WinCC 5.1
Александр Родин, ООО "Нева Электрик"; 5.4.04

Файл называетс <Название вашего проекта>RT.db :)

Параметры, в частности для определения его окончательного размера и т.д., задаются при параметрировании архивов TagLogging. Там же задается писать архив с циклическим обновлением или по событию, там же указывается поведение самого архива, а точнее будет ли он перезаписываться при достижении определенного количества записей или будет тянуться вечно.

Читайте мануалы.. :)
Re: Tag Logging WinCC 5.1
Игорь; 23.8.04

А для WinCC 6.1 такой же файл? Я не могу найти его. Как будто, ничто никуда не пишется! И потом, когда вывожу трэнд на экран, на поле трэнда сообщение "No connection to data server". Где ошибка?


text

Tag Logging Runtime - при выборе её не работает runtime!
Serg; 19.1.04

Если не выбирать - runtime запускается, но виснет через некоторое время...


text

Tag Logging
Vit; 30.8.04

Здравствуйте.

Есть такая проблемка для начинающего.
1. В редакторе Таg Logging создаю архив для трех внутренних тегов.
2. Ставлю в проект элемент Online Trend Control (или Table Control, без разницы) - все как в мануале.
3. конфигурирую проект с запуском соответствующего приложения Tag Logging.
4. На этапе активации выскакивает окошко с надписью "tag logging runtime: startup error!"
c надписью:
"Error - cannot connect to database"
После чего проект деактивируется.
Не подскажете, в каком направлении искать ошибку? Заранее благодарен.
Re: Tag Logging
Юрченко Владимир; 30.8.04

Возможно Вы не установили Message Queuing.

См. http://www4.ad.siemens.de/WW/view/en/17845612

Re: Tag Logging
Vit; 30.8.04

Владимир, огромное спасибо. Сделал так, как Вы посоветовали - заработало.


text

TAG LOGGING-СВЯЗЬ С DATA BASE
ALEX; 21.6.04

Имею проблему с графиком. Иногда пропадает связь C базой данних. При параметрах графика "Load archive data" и сохранение на HDD-сначала все Ok! но сейчас график мигает постоянно с сообщением "No connection to data server". В остальних проекта при тех же параметрах Tag Logginga все нормально. Что может бить??? Братва подскажите...

Re: TAG LOGGING-СВЯЗЬ С DATA BASE
Nick Gashevsky; 22.6.04

Что-то похожее было при синхронизации времени с сервером. Излечилось установкой HotFixa на SP1.

Re: TAG LOGGING-СВЯЗЬ С DATA BASE
Игорь; 19.8.04

У меня такая же проблема. Установка HotFix`а не помогла (версия WinCC стала 6.0.1.2). А главное - я не могу найти файл, в который пишется TagLogging: <название_проекта>RT.db! Как будто ничто никуда не пишется. Может в MS SQL Server надо что-то настраивать? И еще. В проводнике WinCC, когда выделяю в левой части TagLogging, в правой написано "No objects Exist", хотя там есть архивные тэги. Так должно быть? Помогите!

Re: TAG LOGGING-СВЯЗЬ С DATA BASE
Human; 19.8.04

To Игорь:

В WinCC v6 архивы хранятся в каталогах:
ArchiveManager\TagLoggingFast
ArchiveManager\TagLoggingSlow
Относительно"No objects Exist" - так и должно быть, в смысле так немцы сделали.
С проблемой пропадания связи не сталкивались.<


text

Tag Login Export
Koltsov; 18.3.04

Заглючил проект WinCC 5.1.

Хочу создать новый проект и перенести в него всё из старого проекта. Возник вопрос как перенести Tag Login?
Создавать в новом проекте все тренды - трудоемко. Может есть способ как то экспортировать данные из одного проекта в другой?
Re: Tag Login Export
Alexis; 18.3.04

Дык может ручками сделать unload из scview таблицам TagLogging-а из cs-ной базы, а потом в новый проект через interactive sql вставить...

Re: Tag Login Export
Маслов Дмитрий; 18.3.04

В WinCC 5.1 есть замечательное средство - называется WinCC Configuration Tool (надо отметить галочку при установке WinCC, требуется Excel 2000/XP). После этого при открытом проекте WinCC запускаете Excel, там должны появиться новые кнопки в новой панели инструментов. Закачиваете проект в Excel, вносите требуемые изменения, потом все можно закачать обратно в WinCC

Re: Tag Login Export
Gaff; 19.3.04

Хотелось бы добавить по поводу Configuration Tool. Перенос проекта в Excel возможен только при установке WinCC 5.1 SP1. А на панели инструментов в Excel появляется кнопочка WinCC.

Re: Tag Login Export
Маслов Дмитрий; 22.3.04

Configuration Tool появился сразу с WinCC 5.1, и SP1 для него НЕ требуется. Хотя, конечно, сама по себе установка SP1 не помешает.


text

TagLog не поддерживает русский
Горлов Евгений; 5.7.04

Tag Logging WinCC 6.0 SP1 не даёт создать архивы с русским названием, а при добавлении тега с русским именем заменяет его на абракадабру. С именами тегов проблему решил: правлю их прямо в БД через Enterprise Manager. А вот после изменения имени архива теряются связи все теги для архивации пропадают.

Re: TagLog не поддерживает русский
Горлов Евгений; 7.7.04

Выход один: править ручками в таблицах SQL из Enterprise Manager

Re: TagLog не поддерживает русский
Елхов Максим; 11.7.04

Ну не любят американцы (MS SQL) русского языка. Вы еще попробуйте засунуть проект в папку с русским именем - повеселитесь всласть ;) Все, что касается непосредственно WinCC будет работать, а все, что подвязано к вытягиванию из MS SQL - даже не пускается.


text

TagLogging архив WinCC
валерий; 12.8.04

У нас есть лицензия SIK/SIMATIC WINCC-V6 RC 64K PTg 512 Atg, которая ограничивает количество тегов в архивах TagLogging до 512.

С чем связано это ограничение?
Существует ли лицензия на большее количество архивных тегов?
Нам необходимо хранить порядка 3000 тегов в архивах TagLogging.
Разумно ли создавать архив такого размера средствами TagLogging?
<


text

TagLogging архив для WinCC
Валерий; 16.8.04

У нас есть лицензия SIK/SIMATIC WINCC-V6 RC 64K PTg 512 Atg, которая ограничивает количество тегов в архивах TagLogging до 512.

С чем связано это ограничение?
Существует ли лицензия на большее количество архивных тегов?
Нам необходимо хранить порядка 3000 тегов в архивах TagLogging.
Разумно ли создавать архив такого размера средствами TagLogging?

Re: TagLogging архив для WinCC
Nick Gashevsky; 16.8.04

6AV6371-1DQ06-0EX0 SIMATIC WINCC V6.0 ARCHIVE POWERPACK: ПАКЕТ УВЕЛИЧЕНИЯ КОЛИЧЕСТВА АРХИВИРУЕМЫХ ПЕРЕМЕННЫХ С 512 ДО 30000, цена 18500,00 Евро

Насчет разумности решать Вам, хотя при наличии необходимых средств, наверное это самый простой путь для хранения большого объема данных.
Re: TagLogging архив для WinCC
Юрченко Владимир; 16.8.04

Для WinCC v.6 есть так называемые Archiv Powerpacks и если Вам нужно более архивировать более 512 тегов, то надо покупать их для установки лицензии на архивный сервер. Вам нужен PowerPack на 5000 тегов.

См. http://www.automation-drives.ru/as/download/ascat/simatic_hmi/wincc/11_WinCC_r.pdf


text

TD17
Александр; 28.9.04

Расскажите как программируется TD17. В ProToole новый Screen не добавляется. И вообще можно ли с помощью этой панели изменять значения в DB? Или она может только чего-то показывать?


text

TimeRange в Layot
Gaff; 20.4.04

Не подскажете с помощью какой функции можно изменять и сохранять в режиме RunTime значение при выборе времени в поле "namely the last" (0-999) для динамической таблицы значений в отчёте.

Заранее спасибо.
Re: TimeRange в Layot
Маслов Дмитрий; 22.4.04

Все зависит от версии WinCC. Если используется WinCC 6.0, то к этому полю можно привязать тег.

Если используется WinCC 5.1 (или более ранняя версия), то это поле динамически изменять не получится. В этом случае для динамического выбора диапазона времени в отчете надо использовать функции ODK. Если надо, могу выслать исходники функции, устанавливающей треубемый диапазон времени в отчете.<


text

TLGGetArchivDataEx
Pasha; 13.12.04

Функция TLGGetArchivDataEx возврщает мне количество записей за единицу времени, но не данные. В чем загвоздка - не пойму. Уже мозги заворачиваются.

Может кто пример сбросит?
Re: TLGGetArchivDataEx
Маслов Дмитрий; 13.12.04

У этой функции есть параметр PTLG_ARCHIVDATARAW* ppTlgData

В него необходимо передать адрес указателя, в который данной функцией будет записан адрес на запрашиваемые данные.

Обратите внимение на тип данного параметра - это указатель на указатель.
См. http://www.wincc.ru


text

TP170A и 20 полей на экран
sv; 29.4.04

так получилось, что при конфигурировании панельки TP170A на каждый экранчик было уложено несколько больше полей вывода, чем допустимые по документации 20. ProTool негромко ругается "W3535 Screen Генератор: permitted number of tags exceeded. Configured number: 28, 20 tags are permitted.", но в принципе компилирует, всё записывает и на панельке все данные отображает правильно.

Вопрос насколько можно превышать рекомендуемое значение полей и зависит ли это от типа переменных?
Re: TP170A и 20 полей на экран
Любитель Симатика; 29.4.04

Скажите, а насколько можно Вас заставлять и нагружать работой например с 8 утра до 10 часов вечера? Пожалуста в часах/неделю ответ дайте. Вы конечно будете немного ругаться, но будете делать. ;-) В вашем договоре о найме это не написано.

Так же как и в документации на панель не написано насколько можно превышать количесво полей.<


text

TP-170A
V12D; 30.7.04

Разбито стекло экрана. Меняетсят ли в Москве? На что, как, где и по чём?

Олег.
<


text

TP270 шрифт
Макисм; 8.9.04

Поддерживает ли TP270 кириллицу. И если да то как закачать шрифты?

Re: TP270 шрифт
Юрченко Владимир; 9.9.04

Конечно поддерживает, шрифтов правда только 2 (Tahoma и Courier New), и ничего закачивать не надо кроме проекта. Добавьте в ProTool поддержку русского языка (System\Language Assignment).

Re: TP270 шрифт
Максим; 9.9.04

Огромное спасибо


text

TP270-USB >>>PC нет обмена
Владимир; 28.10.04

Почему при правильных настройках Pro Tool и TP270 может не происходить upload/download проекта по USB ,хотя

по RS232 O.K.?
А драйвера TP270-USB >>>PC для обмена поставил
USB Bulk Transfer; 28.10.04


text

Transfer
антон; 27.7.04

Помогите!!!

Добавляю в проект новое устройство, загружаю в PLC, делаю трансфер. В результате из проекта пропадают 200-250 тагов, не могу понять в чем причина.<


text

Transfer
antonio; 3.11.04

Проблемма такая добавляем устройство делаем трансфер в итоге вместо генерации новых тегов получаем удаление 200 тегов. в чем причина?

Re: Transfer
Уточни; 3.11.04

О какой программе/оборудовании идет речь? Пересылка чего/куда ? Генерация/удаление тэгов где?

Re: Transfer
уточняю; 5.11.04

добавляю ASI устройство (например задвижку для подачи воды)после этого для ее контроля и управления в WINCC необходимы теги к которым можно привязаться, так вот делаю трансфер и вместо добавления тегов в программу тегов становится мешьше.


text

Triggers an action
Yess; 16.1.04

в Alarm Logging создал Analog Alarm на превышение уставок датчиков.

в одиночных сообщениях поставил triggers an action,
на них вызывается GmsgFunction.
эту функцию я переписал под необходимые действия.
Они все выполняются как нужно мне, но функция вызывается без конца
пока авария еще существует.
как сделать чтоб GmsgFunction выполнялась один раз ?

в принципе можно сделать чтоб функция вызывалась один раз,
создать переменную или тэг,
которая будет взводится при первом выполнение.
но как потом её сбросить когда аварию устранят?

я не силён в Си, подскажите какое-нибудь решение

можно ли получить через какую-либо функцию номер одиночного сообщения
которое вызвало GmsgFunction ?

Re: Triggers an action
Макс Прилепский, ОАО "ЗСМК"; 19.1.04

Можно в GMsgFunction анализировать сообщения только по состоянию "пришло"

функция GMsgFunction:

... разбор строки функцией sscanf и заполнение структуры mRT, имеющей тип MSG_RTDATA_STRUCT (код функции по умолчанию)...

if(mRT.dwMsgState==MSG_STATE_COME)
{
здесь выполняются необходимые действия
}

Тогда, при исчезновении сообщения из очереди сообщений никакие действия выполняться не будут. А номер сообщения, которое инициировало вызов функции находится в элементе dwMsgNr структуры mRT.

Например:

SetTagDWord("Current_Msg",mRT.dwMsgNr); //Номер сообщения записывается в тег<


text

Uncertain теги в WINCC
-=Stealth=-; 22.10.04

Почему при запуске проекта в wincc теги имеют качество uncertain (0x40)?

При записи туда значения качество становится good.
А как его сделать good сразу при инициализации проекта?
Re: Uncertain теги в WINCC
Андрей; 22.10.04

Если Вы подключаитесь ч/з OPC (да и через стандартные каналы), то качество тэгам выставляет сам OPC сервер, Вы изменить ничего не можите.

Похоже при записи Вами значения, данные записываются и устанавливает качество в Good.
Я не знаю, что за OPC сервер у Вас (или канал), но это скорее проблема его настройки...
Re: Uncertain теги в WINCC
Андрей; 22.10.04

или ошибка (проблема) чтения тэга, т.к. при запуске WinCC начинает опрашивать подключенные тэги, и изменять их значения, время получения и качество

Re: Uncertain теги в WINCC
-=Stealth=-; 22.10.04

Сервер OPCServer.WINCC

При запуске проекта в WINCC изначально качество uncertain
При записи туда нового значения (средствами wincc или клиента) качество меняется на good.
Но необходимо при инициализации проекта сразу получать нормальное качество. Я регистрирую тег. Устанавливаю ему initial value. Но, чтобы тег был нормальным, мне нужно его перезаписать или обновить. :(
Re: Uncertain теги в WINCC
Андрей; 22.10.04


text

Unicode и WinCC ODK
Виталий; 21.4.04

Есть ли версии ODK для WinCC6.0, поддерживающие Unicode? Необходимо из VC++ проекта в WinCC передавать текстовую информацию (кодовые страницы 1250 и 1251).

Re: Unicode и WinCC ODK
Макс Прилепский; 22.4.04

Каким образом планируется передавать информацию ? В C-Action WinCC можно использовать типы wchar_t, BSTR, VARIANT и др.

Re: Unicode и WinCC ODK
Виталий; 22.4.04

Информацию планируется передавать из внешней программы (не из WinCC), c помощью функции DMSetValue из dmclient.lib (WinCC ODK)


text

update WinCC v5.1
ppp; 27.5.04

Подскажите пожалуйста ПРЯМУЮ ссылку на SP1 for WinCC v5.1

А то сименсовский сервис по обновления совсем не работает. Ввел свой KHE с дискеты - обещали прислать ссылку на ящик в течение 7 дней, но прошло уже более 2 недель - а от сименса ни слуху не духу.

Re: update WinCC v5.1
Юрченко Владимир; 28.5.04

Вообще то WinCC 5.1 SP1 это целый CD около 700 МБ, а не отдельный файл небольшого размера. Если обратитесь в наши региональные представительства или в центральное в Москве, можем записать Вам этот софт на CD.

Re: update WinCC v5.1
ppp; 31.5.04

Для меня размер не так важен, т.к. имею выделенку и скачать могу за день эту компашку.

Живу в провинции, но в июне буду в Москве. Поскажите к кому конкретно можно обратиться.
А на сименсовском сайте сервис обновления действительно не работает, или только меня игнорируют?<


text

upload op17
саша; 23.2.04

утерян проект протула для ОП17.как можно скачать с ОП проект чтоб можно было делать изменения?есть кабель оригинальный но с протула при upload пишет нет соединения.а на другой ОП загружаю другой проект без проблем.а просейв-бекап не получается открыть:(.

Re: upload op17
q; 23.2.04

Ото оно такое типа как и OP7.

Мыкалися так же.
Upload поддерживается более взрослыми панелями типа 27 и т.д. Нам так присоветовали на нашем Сименсе. Позвоните на Ваш, может и будет счастье.
Re: upload op17
саша; 23.2.04

счастя нету.они ничего не насоветовали.да и с оп37 в качестве проверки не удалось скачать

Re: upload op17
Сидоров Артем; 25.2.04

Боюсь, что если утерян проект для 17-й панели, Вам никак не удасться достать из нее проект (речь идет не о Prosave).

Re: upload op17
alex-b3; 25.2.04

Если проект утерян, то изменений делать уже не получится (если не написать в ProTool все заново).

Единственное, что можно сделать - это скачать backup с помощью PROSAVE.EXE.
Загружаться нужно в DOS. Находится обычно эта утилита в C:\Siemens\PROTOOL\Utility\PROSAVE.EXE
(возможны варианты).
Все настройки связи с панелью там есть.
Re: upload op17
саша; 25.2.04

даа.спасибо утешили.я тоже склонялся к мысли что придёца писать заново. но думал "а вдруг?"

Re: upload op17
саша; 25.2.04

даа.спасибо утешили.я тоже склонялся к мысли что придёца писать заново. но думал "а вдруг?"

Re: upload op17
Илья; 27.2.04

ProSave есть как интегрированная в ProTool, так и автономная. Запускается из-под Windows (ProTool 6.x). Скачивается образ проекта - бинарный файл. Никакие изменения невозможны - это чисто бекап. Работает со всеми ОР. Лично я пробовал ОР7/17/27/270...

Re: upload op17
Леха; 29.4.04

А у меня такой вопрос, а в каком режиме должна находиться ОР и как в этот режим войти?


text

Vat в Wincc
Григорий; 20.10.04

Можно ли в Wincc организовать окно VAT-table и использовать его для мониторинга/изменения переменныых

Re: Vat в Wincc
Папировский Роман; 25.10.04

Попробуйте использовать WinCC Tag Simulator. Значение и статус тега отображаются в всплывающей подсказке при наведении на тег курсора мыши в WinCC Explorer.

См. http://www.wincc.ru

Re: Vat в Wincc
GorA; 26.10.04

Можно просто накидать смысловые текстовые поля и требуемые поля ввода-вывода в определенную pdl-картинку и вызывать когда нужно.

Re: Vat в Wincc
Григорий; 26.10.04

Интерес есть использования окна Vat напрямую. Эрзацы не интересны. Вроде в siemens даже OCX есть.


text

VBS - преобразование типов
Михаил; 26.8.04

Я считал из PLC блок данных. Они помещены в переменной которая интерпритируется как массив байтов.

Но реально в PLC числа формата FLOAT.
Как получить числа формата float из этого массива?

Заранее благодарен.<


text

VBS и WinCC
polk; 18.8.04

Помогите на пальцах: в VBS-editor создал форму, а как вызывать ее из RT ума не приложу?

Re: VBS и WinCC
Юрченко Владимир; 18.8.04

в VBS в принципе невозможно создать форму (если только под формой вы понимаете action...). Ну если создали скрипт, то он вызывается тригером, то есть по времени или по изменению переменной (правой мышкой по окну редактора скрипта и меню Info/Trigger).

Если же Вы какую то форму создавали в редакторе VB в Graphic Designer, то VBA предназначен не для RT, а для среды разработки.
Re: VBS и WinCC
polk; 18.8.04

Спасибо, тема закрыта :(


text

VBS!!!!!!!!!!!!!
миша; 25.8.04

Как в VBS узнать у Picture имя PictureWindow в катором она отображается?

Re: VBS!!!!!!!!!!!!!
Маслов Дмитрий; 25.8.04

RTFM:

WinCC Information System -> Working with WinCC -> VBS for Creating Procedures and Actions -> VBS Reference -> Objects and Lists -> Parent Object
для Маслова Дмитрия
я; 25.8.04

спасибо друг!


text

VBScript + SQL Server
Дмитрий; 26.6.04

Нужен пример (на VBScript) выборки данных из таблицы SQL Server с последующим засовыванием их

в ListBox.
Я имею ввиду данные которые я записал в таблицу
следующим скриптом :

Sub OnClick(Byval Item)
Dim objConnection
Dim strConnectionString
Dim lngValue
Dim lngValue2
Dim lngValue3
Dim Sdate
Sdate = Now

Dim strSQL
Dim objCommand
strConnectionString = "DRIVER={SQL server};SERVER=winccwincc;DATABASE=press;UID=;PWD=;"
lngValue = HMIRuntime.Tags("Breadth").Read
lngValue2 = HMIRuntime.Tags("Lenght").Read
lngValue3 = HMIRuntime.Tags("NomThickness").Read
strSQL = "INSERT INTO Table1 (data,breadth,lenght,thickness) VALUES (‘" & Sdate & "‘, " & lngValue & ", " & lngValue2 & ", " & lngValue3 & ")"
Set objConnection = CreateObject("ADODB.Connection")
objConnection.ConnectionString = strConnectionString
objConnection.Open
Set objCommand = CreateObject("ADODB.Command")
With objCommand
.ActiveConnection = objConnection
.CommandText = strSQL
End With
objCommand.Execute
Set objCommand = Nothing
objConnection.Close
Set objConnection = Nothing

End Sub

Заранее благодарен.<


text

VBScript и Web Navigator
Андрющенко Александр; 17.9.04

Не публикуются VB-скрипты в PDL.

Создаю VBS-action на нажатие кнопки в PDL. Публикую в Navigator.
Открываю PdlPad - пусто. Что не так делаю?<


text

Visual Basic и ProTool Runtime
Анатолий; 26.1.04

При создании ActiveX компонента возникает проблема. Подскажите, как в Visual Basic описать переменную как объект ProTool Runtime. Для связи с WinCC описываю строчкой Set mcp = CreateObject("WinCC-Runtime-Project") и все работает, а вот с ProTool RT никак связаться не могу.


text

WEB Navigator & Рапорта
Ринат; 20.8.04

1. Господа, кто нибудь реализовывал рапорта через WEB Navigator? Если есть информация поделитесь пожалуйста...

2. Можно ли подключиться к базе данных RT по сети, по протоколу ODBC, из Excel...
3. Ваше предложение чтения данных по сети из базы RT...
С уважением, Ринат...
Re: WEB Navigator & Рапорта
fog; 20.8.04

п. 2. Можно - я внедрял такое в своё время - потратил кучу времени (денег).

п. 1. пришлось параллельно организовывать ещё и чтение через EXCEL, т.к. в web - не получилось ничего путного.
Re: WEB Navigator & Рапорта
Ринат; 20.8.04

Можете ли Вы поделиться инфой? По данному вопросу...

С уважением, Ринат...
P.S.: можно на емайл...
Re: WEB Navigator & Рапорта
Л. Шерешевский; 20.8.04

Да, мы делали такие отчеты из-под WebNavigator. Не очень тривиально, но в итоге все заработало. Пример смотрите на нашем сайте в разделе "Материалы для скачивания".

См. Раздел downloads сайта sms-automation.ru


text

WebNavigator 6 - Ошибка у клиента.
Иван; 26.5.04

У клиента клиентская часть ставится, а после подключения появляется такая ерунда.

Îøèáêà âûïîëíåíèÿ Microsoft VBScript ошибка '800a01a8'

Òðåáóåòñÿ îáúåêò: 'lfd'

/Language.asp, line 61

Что бы это значило.

Re: WebNavigator 6 - Ошибка у клиента.
Вадим Печёрских; 27.5.04

Учётная запись пользователя WinCC WebNavigator (эта запись появляеться в списке локальных пользователей после конфигурирования Web Navigator Server) должна иметь полный доступ на папку проекта и права не ниже "Опытный пользователь".

Re: WebNavigator 6 - Ошибка у клиента.
Иван; 27.5.04

Не помогло.

Хотя может чего не так делаю.
Пользователю WNUSR_DC92D7179E29 с описанием WinCC WebNavigator User добавил членство в группе Опытные пользователи, дал полный доступ на папку проекта.
Может чего не так делаю при конфигурировании или публиковании или администрировании.
При опубликовании ошибок никаких.
Что означает вкладка "Веб страница по умолчанию" при конфигурировании?
Может есть тонкости при администрировании?
Re: WebNavigator 6 - Ошибка у клиента.
Горлов Евгений; 1.7.04

сделал стартовой страницу webclient.asp вместо maincontrol.asp, в 61 строке прописал полный путь

set f = WNStandart_fso.GetFile("C:\Program Files\Siemens\WinCC\WebNavigator\Server\Web\_languages\en\"+strFile).OpenAsTextStream()
создал своего webclient, добавил его в группу simatic hmi viewer, прописал в user administrator
- всё работает (при запущенном проекте)
Re: WebNavigator 6 - Ошибка у клиента.
Роман; 2.7.04

Спасибо, попробую.

Re: WebNavigator 6 - Ошибка у клиента.
smi; 15.7.04


text

WebNavigator HELPPPPPPPP
mike; 23.8.04

Народ! дайте пажалуйста докуметацию про webnavigator1.1. И кстати он могёт работать с winCC 6.0 ???

Re: WebNavigator HELPPPPPPPP
Юрченко Владимир; 23.8.04

Нет не "могёт". Для WinCC v.6.0 и SP1 идет WebNavigator v.6.0, для WinCC 6.0 SP2 - WebNavigator v.6.0 SP1. А документация у нас на сайте -

См. http://www.automation-drives.ru/as/download/doc/simatic_hmi/wincc/WebNavigator_r.pdf

Re: WebNavigator HELPPPPPPPP
Чистяков Дмитрий ОАО СеверСталь; 23.8.04

Он не будет работать c WinCC 6.0.

А описание его лежит вот здесь
http://www4.ad.siemens.de/WW/news/en/2053005
Re: Юрченко Владимир
mike; 23.8.04

а как мне его поиметь? =) (шестой веб навигатор то)

Re: WebNavigator HELPPPPPPPP
Чистяков Дмитрий ОАО СеверСталь; 23.8.04

О-опс! Почти одновременно! ;-)


text

WebNavigator Install
Евгений Горлов, Северсталь; 14.9.04

При инсталляции WebNavigator6 на WinCC6 SP2 и W2K_Server_Ru SP4 вылезает сообщение о невозможности зарегистрировать библиотеку PdlComponents.dll. Ручками через regsvr32 тоже не регистрирует.

Re: WebNavigator Install
Чистяков Дмитрий ОАО СеверСталь; 14.9.04

У нас всё без вопросов пролетает.

Re: WebNavigator Install
Маслов Дмитрий; 14.9.04

Это нормальная ситуация для версий WebNavigator 6 и WinCC6 SP2 - они несовместимы.

Используйте WinCC 6 SP2 Hotfix 3 и WebNavigator 6 SP1 Hotfix 2.
См. http://www.wincc.ru

Re: WebNavigator Install
Евгений Горлов, Северсталь; 21.9.04

Откуда можно скачать Hotfix3 для WinCC6 SP2 ?


text

WebNavigator
Aleks; 18.2.04

Если, можно дайте попробовать WebNavigator Server, чтобы знать что это и стоит ли его ставить вообще.

Re: WebNavigator
Чистяков Дмитрий ОАО СеверСталь; 19.2.04

Сам посебе Web Navigator не работает в демо режиме. Необходима ещё и лицензия, хотябы на 3 пользователя.

Re: WebNavigator
Diman; 26.2.04

В демо он работает. Попросите в предтавительстве Siemens, может дадут.


text

Webnavigator
Pavel; 20.5.04

Будет ли работать Webnavigator v1.2 sp1 c WinCC v6.0?

Re: Webnavigator
Л. Шерешевский; 20.5.04

Нет, для шестерки выпущена своя версия WebNavigator 6.0.


text

WebNavigator
B; 9.9.04

Web-клиентам нужно ставить какой-нибудь софт или достаточно Internet Explorer? Тот же вопрос для Dat@Monitor

Re: WebNavigator
Юрченко Владимир; 9.9.04

Надо поставить WebNavigator Client (для Dat@Monitor свой клиент). Но если эти пакеты не стоят на PC и идет обращение к серверу, то предлагается загрузка и установка клиентов с сервера.


text

WebNavigator
Владимир; 13.10.04

Стоит WinCC 6.0 sp2 и WebNavigator 6.0.1.0 . При публикации кадров по нажатию кнопки "Finish" выходит сообщение "Not all picture have been published successfully.Files which caused an error are marked". Пишет, что не все картинки - на самом деле ни одна не публикуется .Хотя я публикую демо-проект ,который шел вместе с WebNavigator'ом.

Re: WebNavigator
Маслов Дмитрий; 13.10.04

С WinCC 6.0/SP2 надо использовать Web Navigator 6.0 SP1.

Другой работать не будет.
См. http://www.wincc.ru

Re: WebNavigator
Владимир; 14.10.04

Так WebNavigator 6.0.1.0 я думаю и есть v6.0 sp1 hf0

Re: WebNavigator
Маслов Дмитрий; 14.10.04

У меня стоит Web Navigator 6 SP1, полноcтью его версия называется так: 6.0.1.12.

Откройте лучше Start->Simatic->WinCC->WebNavigator->ReleaseNotes, там на заглавной странице крупным шрифтом выделена версия. Должно быть:
WinCC / Web Navigator V6.0 SP1
Edition 04/2004
См. http://www.wincc.ru

Re: WebNavigator
Владимир; 14.10.04

Точно у меня 6.0 .


text

WinAC и RS-232
Юрчик; 29.7.04

Где есть описание, как считывать данные с COM порта в DB блоки при использовании WinAC 3.0 ?

Нужен перечень функциональников и их описание.

Буду благодарен за ссылки.
Re: WinAC и RS-232
Юрченко Владимир; 2.8.04

У WinAC не было и нет стандартных функций для работы с COM-портами. Но все поправимо с помощью WinAC ODK.

Документация по WinAC ODK лежит на http://www4.ad.siemens.de/WW/view/en/12840073/133300<


text

WinBDE
Михаил; 16.2.04

Кто работал с WinBDE? Поделитесь опытом. Что означает 32 machine/unite для WinBDE Workstation.

Re: WinBDE
Чистяков Дмитрий ОАО СеверСталь; 17.2.04

http://www.ad.siemens.de/hmi/html_76/pdf/doku/sb_winbde_e.pdf


text

WinCC - Omron , MP-270???
sova; 9.6.04

Здравствуйте Всем!

Подскажите где мне найти драйвер для связи WinCC с Omron (Hostlink/Multilink)??? А то получается в ProTool есть такое соединение, а в WinCC нет???
И еще такая тема как мне в рабочий проект на панели МР-270 догрузить дополнения (с помощью чего я знаю), исходника нет. И если не трудно поясните поподробнее если бы он (исходник) был.
Заранее Огромное.
Re: WinCC - Omron , MP-270???
Чистяков Дмитрий ОАО СеверСталь; 10.6.04

1. Необходимо приобрести у Omron`a или ещё кого OPC сервер.

2. Без исходного проекта ничего в рабочей программе не изменить. Если есть исходный проект, то делайте, что хотите.

Re: WinCC - Omron , MP-270???
Роман; 11.6.04

Омроновский ОРС вещь не очень удобная. Приходится ещё в нем создавать проект - все таги прописывать.

На своем опыте скажу, что с Омроном WinCC лучше связывать, используя омроновкую C-library для плат Controller Link, Sysmac Link. На сколько знаю, уже появилось и для Ethernet. Скорострельность на порядок больше, чем у ОРС.
То же самое можно делать и для ком-порта, благо протокол открытый.
Re: WinCC - Omron , MP-270???
Горлов Евгений; 1.7.04

расскажите по-подробнее как связать WinCC и OMRON через C-library

Re: WinCC - Omron , MP-270???
Роман ; 2.7.04


text

WinCC переход с версии 4 на 5 или 6
Сергей; 4.11.04

Подскажите нужно ли менять авторизацию или просто как апгрейт делать при переходе с версии старой на новую

Re: WinCC переход с версии 4 на 5 или 6
Назаров Дмитрий; 10.11.04

При переходе на 6 версию, менять авторизацию надо через апгрейд, плюс надо конвертировать проект под новую базу данных.

Re: WinCC переход с версии 4 на 5 или 6
Чистяков Дмитрий ОАО СеверСталь; 10.11.04

Меняются авторизации самого WinCC, WebNavigatora.

А такие опции как сервер, user archive остаются прежними.<


text

WinCC & ActiveX
Eugene; 1.12.04

Probuju polucit dostup k activeX, zapuskaju na vipolnenie kod :

#define GetObjectA GetObject

__object *obj = NULL;
__object *pic = NULL;
__object *ocx = NULL;

VARIANT v;
BSTR bstrText1;

printf("Get PDLRuntime \r\n");
obj = __object_create("PDLRuntime");

if (!obj)
{
printf("obj NULL!!!\r\n");
return;
}

pic = obj->GetPicture("NewPdl0");
if (!pic)
{
printf("pic NULL!!!\r\n");
return;
}

ocx = pic->GetObject("Control1");
if (ocx == NULL)
{
printf("ocx NULL!!!\r\n");
return;
}

bstrText1 = SysAllocString("Variant String");
VariantInit(&v);
v.vt = VT_BSTR;
v.u.bstrVal = bstrText1;

ocx->SetText(4,4,v);
ocx->SetFontSize(14);
ocx->SetFontBold(TRUE);

__object_delete(obj);
__object_delete(pic);
__object_delete(ocx);

}

i polucaju oshibku vo vrema vipolnenija, o nevozmoznosti polucit dostup k PDLRuntime. Podskazite pozalusta, cto mne sdelat ctobi eto rabotalo, v cem precina oshibki ?

Vivod WinCC vo vrema vipolnenija :

Get PDLRuntime
F6dc (49) : general protection fault..
====================================OnErrorExecute====================================
dwErrorCode1: (ThreadId 5396) 1007001
dwErrorCode2: (ThreadId 5396) 4100
szErrorText: (ThreadId 5396) Exception in Action
szErrorTextException: (ThreadId 5396) access violation
szApplicationName: (ThreadId 5396) PDLRuntimeSystem
bCycle: (ThreadId 5396) acycle
szFunctionName: (ThreadId 5396) @b
lpszPictureName: (ThreadId 5396) NEWPDL0
lpszObjectName: (ThreadId 5396) Button8
lpszPropertyName: (ThreadId 5396) (NULL)
dwParamSize: (ThreadId 5396) 12
====================================OnErrorExecute====================================
Re: WinCC & ActiveX
Маслов Дмитрий; 3.12.04

Есть у меня подозрение, что ошибка возникает при работе со строками. Попробуйте выкинуть из скрипта весь код, который работает с типом variant и со строками. Оставьте только установку целого и логического свойства. Если заработает - поймете в чем проблема...


text

WinCC + Festo
Игорь; 29.6.04

Кто-то решал уже задачу работы WinCC + Festo -вские контроллеры?


text

WinCC + Panel PC
Human; 1.4.04

Привет! Есть вопрос: как в проекте WinCC задействовать кнопки встроенной клавиатуры Panel PC, например, кнопки "Ack" и "S1 - S16"?

Re: WinCC + Panel PC
Александр Родин, ООО "Нева Электрик"; 1.4.04

Ваще-то с самим Panel PC должен был быть вложен диск с драйверами и в частности с образом диска для прошивки определения скан-кодов под WinCC. Когда эту прошивку устанавливаешь, то потом, при использовании хоткеев в проекте, нажимая на кнопки S1 - S16 получаешь комбинацию типа [Ctrl] + [[Alt]|[LShift]] + F#. И можешь уже писать скрипты для обработки нажатий.

По опыту работы могу сказать определенно, что такой диск был с Panel PC FI45. Так что ищите.. :)<


text

WinCC + Teleperm M не все работает.
Vikond; 26.3.04

WinCC 5.0 SP2 + Teleperm M.

Есть проект, использующий OLE объекты(OCX файлы).
Готовая, настроенная система рабоатет. Хочу повторить ее, установив все программное обкспечение с "нуля".
Устанавливаю ОС, WinCC, Драйвера, Teleperm M-Kanal, копирую проект, настраиваю его, устанавливаю OCXы. Запускаю. Алармы приходят. Визуально проект работает нормально. Кроме одного, если есть OCX объект, который изменяет значение какого-нибудь тэга, то он может работать в одном месте и точно такойже, с такимиже настройками и тэгами, в другом месте может не работать.

Не могу понять в чем дело.
Исходников OCX нет.
Re: WinCC + Teleperm M не все работает.
Михайлин Сергей; 29.3.04

Свяжитесь со мной для прояснения проблемы по телефону или мылом.

Re: WinCC + Teleperm M не все работает.
Vikond; 30.3.04

Доступа к почте к сожалению нет (так настроена политика безопасности нашего сервера).

Михайлин Сергей если не сложно оставьте свой телефон я позвоню.
Re: WinCC + Teleperm M не все работает.
Михайлин Сергей; 31.3.04

ОК Сорри, что в прошлом посте не оставил

(095)737-24-31<


text

WinCC 5.0 + jdbc
gRay; 18.11.04

Class.forName("com.sybase.jdbc2.jdbc.SybDriver");

Connection con = DriverManager.getConnection("jdbc:sybase:Tds:host:port","dba","sql");

При вызове executeQuery("select * from PDE#testArc#mode":
com.sybase.jdbc2.jdbc.SybSQLException: ASA Error -141: Table 'PDE#testArc#mode' not found

Почему не видны таблицы только из runtime базы?

Re: WinCC 5.0 + jdbc
Маслов Дмитрий; 19.11.04

А Вы соединяетесь с Runtime-базой или с базой проекта? Они разные.

Re: WinCC 5.0 + jdbc
gRay; 19.11.04

Соединяюсь как с той, так и с другой:

"jdbc:sybase:Tds:host:port/CC_database",
"jdbc:sybase:Tds:host:port/CC_database_R",
"jdbc:sybase:Tds:host:port" -

результат одинаковый.<


text

WinCC 5.0: Параметры ActiveX events
Дмитрий Лаушкин; 5.2.04

Задача такая: Самодельный объект ActiveX запрашивает данные, для этого вызывает событие и передает в него параметры, в надежде получить обратно соответствующие данные в одном из параметров типа in/out. Все попытки реализовать это простыми и очевидными способами закончились неудачей.

1. Событие с параметром типа VARIANT* просто не вызывается (без сообщения об ошибках, чтобы пользователя не огорчать).
2. Параметр типа long* в WinCC читается и изменяется, но в объект возвращается старое значение.
3. События, возвращающие результат, WinCC не признает, тип результата всегда void.

Может сталкивался кто с такой задачей? Другие способы передачи данных в объект (свойства/методы) не подходят, т.к. WinCC про объект ничего не знает.

Дмитрий Лаушкин
ICQ: 51367389
Re: WinCC 5.0: Параметры ActiveX events
Alexis; 6.2.04

ActiveX работает в PDLRT?

А почему тогда не передавать данные из event в property этого же объекта?
Re: WinCC 5.0: Параметры ActiveX events
Дмитрий Лаушкин; 6.2.04

И это я тоже пробовал, но получается так: некий метод объекта (UpdateData)скажем 10 раз вызывает событие, запрашивая различные данные, а в обработчике события устанавливается свойство объекта, но вызовы метода изменения свойства происходят уже после выполнения

Re: WinCC 5.0: Параметры ActiveX events
Дмитрий Лаушкин; 6.2.04

И это я тоже пробовал, но получается так: некий метод объекта (UpdateData) скажем 10 раз вызывает событие, запрашивая различные данные, а в обработчике события устанавливается свойство объекта, но фактически вызовы метода изменения свойства объекта происходят уже после завершения метода UpdateData, все 10 по очереди. То есть, этими данными я могу воспользоваться только после завершения UpdateData, "объяснив" получателям данных, что данных пока нет.

На самый крайний случай сгодится и такой вариант, но уж больно криво получается...
Re: WinCC 5.0: Параметры ActiveX events
Роман; 17.2.04

Поробуй свойства объекта подключить к тегам, а уже в эти теги писать и читать.

Re: WinCC 5.0: Параметры ActiveX events
Дмитрий Лаушкин; 20.2.04

Удивительно, но эффект тот же.

В обработчике события объекта OnGetData устанавливаю тэг с данными. Этот тэг жестко привязан к свойству объекта (можно в c-action возвращать свойство по изменению этого тэга - без разницы). Выполняется это в такой последовательности:
1. Вызывается OnGetData
2. Устанавливается тэг
3. Завершается OnGetData
4. Устанавливается свойство объекта
Причем, если OnGetData вызывается несколько раз подряд, то свойство объекта устанавливается только после завершения последнего вызова OnGetData. Может я что-то делаю не так?.. Но, вроде, уже все перепробовал.<


text

WinCC 5.1 Alarm Login
Koltsov; 18.3.04

В проекте WinCC5.1 добавляю новй класс и тип сообщений. Открываю Screen сообщений в Grafic Designer. Пытаюсь сделать selection - Созданные класс и тип имеют квадратик для выбора - там где имя пусто. В selection также отображаются не все поля которые созданы в User text block.

ну вобщем какие то глюки. Что делать?

Re: WinCC 5.1 Alarm Login
Alexis; 18.3.04

Глючный редактор у AlarmLogging...

Раз имя пустое - смотри и правь TextLibrary... Где-то имя пустует... Где-то уродливые перекрестные ссылки...
Re: WinCC 5.1 Alarm Login
Александр Родин, ООО "Нева Электрик"; 18.3.04

Вы наверняка имя класса и типа указали русскими буквами. Тогда он точно пустые поля отображает.

Попробуйте в TextLibrary подкорректировать имена ваших классов/типов в столбце для английского языка, если он такой есть.
И еще, как вариант, может помочь установка русского языка по умолчанию для всего проекта.<


text

WinCC 5.1 SP1
Eugene; 5.3.04

Разработал проект на WinCC 5.1 HF2. Затем появился SP1. Я тут же его установил. Позже выяснилоссь, что перестала нормально работать функция PWRTSilentLogin. Подменили UseAdmin.dll на старый, от WinCC 5.1 HF2. Вроде все снова заработало корректно.

Замечал ли кто-нибудь подобные вещи с SP1? И вообще, кому об этих глюках можно сообщить, чтобы Siemens принял меры по их устранению?<


text

WinCC 5.1 и Allen Bradley Micrologix ML1500
Александр; 23.4.04

Как подключить Allen Bradley Micrologix ML1500 к WinCC 5.1 ?

Re: WinCC 5.1 и Allen Bradley Micrologix ML1500
Маслов Дмитрий; 26.4.04

Попробуйте по OPC.


text

WinCC 6.0 - отображение трендов на клиенте
Алексей; 14.9.04

Есть клиент и сервер.

Версия 6.0
Настройки клиента и сервера абсолютно идентичны на закладке Startup

Но на клиенте не работают тренды
и таблицы - не читается БД.

Есть у кого какие соображения на этот счет?
Re: WinCC 6.0 - отображение трендов на клиенте
Маслов Дмитрий; 14.9.04

Если на клиенте используется своя картинка (а не картинка с сервера), то для трендов и таблиц может быть неправильно указан Server Prefix.

См. http://www.wincc.ru

Re: WinCC 6.0 - отображение трендов на клиенте
Алексей; 14.9.04

В том то и дело, что картинки идентичные, все с сервера

Re: WinCC 6.0 - отображение трендов на клиенте
Маслов Дмитрий; 15.9.04

Под "картинкой с сервера" подразумевается указание имени картинки с префиксом сервера, а не копирование картинок с проекта сервера в проект клиента. Вы это так сделали?

См. http://www.wincc.ru

Re: WinCC 6.0 - отображение трендов на клиенте
Алексей; 15.9.04

А где это указывается?

Я вижу название сервера только в настройке пакетов (ServerData).
Вы это имели в виду?
Re: WinCC 6.0 - отображение трендов на клиенте
Маслов Дмитрий; 16.9.04

Нет, не это.

Как Вы отображаете картинки с сервера?

Это можно сделать разными способами:
1. В настройках компьютера указать стартовую картинку, выбрав ее из списка картинок сервера.
2. Картинку, отображаемую в том или ином Picture Window, указывать с префиксом сервера.
....

Какой способ используете Вы?
См. http://www.wincc.ru

Re: WinCC 6.0 - отображение трендов на клиенте
Евгений Горлов, Северсталь; 17.9.04

У меня была аналогичная проблема: многопользовательский проект с 1 сервером. Клиент загружал проект из сетевой папки на стороне сервера. Проблему решил после того как создал пакет в ServerData. Теперь остался 1 недочёт: в диалоговом окне выбора архивов вместо 1 архива фигурируют 2, причём из обоих можно посмотреть графики тегов.

Re: WinCC 6.0 - отображение трендов на клиенте
Алексей; 21.9.04

Я использую первый вариант - указываю стартовую картинку в списке картинок на сервере.

<


text

WinCC 6.0 (путь до элемента)
Mike; 31.8.04

Если есть главная картинка <main>, в которой PictureWindow <fc21_> в каторой катринка <@ProminentScreenProba> в каторой PictureWindow <PictureWindow4> в каторой картинка <xy> в каторой IoField <hyst> то как до всего этого добраться??? :))))

Пробую
HMIRuntime.Screens.Item("main.fc21_:@ProminentScreenProba.PictureWindow4:xy")
а мне бана в ответ :(
Re: WinCC 6.0 (путь до элемента)
Маслов Дмитрий; 1.9.04

HMIRuntime.Screens("main.fc21_:@ProminentScreenProba.PictureWindow4:xy").ScreenItems("hyst")

См. http://www.wincc.ru

Re: WinCC 6.0 (путь до элемента)
->Маслов Дмитрий; 1.9.04

Огромное спасибо!!!

вот хотел еще узнать насчет преобразования типов в Вас: если я считал RawData то они в переменой по байтам (а у меня числа float в PLC) как их поиметь???
Re: WinCC 6.0 (путь до элемента)
Маслов Дмитрий; 1.9.04

В C - преобразование типов. В VBS - не знаю.

->Маслов Дмитрий;
mike; 1.9.04


text

WinCC 6.0 и Modbus
Александр; 7.5.04

Вследствие отсутствия (по малопонятным причинам) Modbus-драйвера в поставке WinCC 6.0, все же имеется возможность использовать Modbus-драйвер от WinCC V5.1.

Немного помучившись, разобрался, каких файлов нехватает. Вот список, может кому пригодится (Установка 6.0 поверх старой не подходит - удаляются нужные файлы):
binwrenu.lng
COMMB.dll
Modbenu.hlp
Modbus Protocol Suite.Chn
Modbus Serial.CHB
Modbus Serial.CHN
modenu.lng
ModMbpEnu.Lng
<


text

WinCC 6.0 не работают архивные тренды
Мылов Сергей; 12.1.04

Не работают архивные тренды, таблицы, даже ось времени не движется. Проект был сделан в версии 5.1 потом сконвертирован в 6.0.

В 5.1 все прекрасно работало.
Подскажите пожалуйста, как оживить архивы
Re: WinCC 6.0 не работают архивные тренды
Макс Прилепский, ОАО "ЗСМК"; 16.1.04

База данных RT тоже перекочевала из версии 5.1 ? Можно попробовать грохнуть старую RT-базу и создать новую. При этом все таблицы Tag Logging должны создаться заново на основе данных конфигурационной БД проекта.


text

WinCC 6.0 от скромности явно не умрёт
Евгений Трунов; 3.8.04

Ситуация. Работает WinCC 6.0 из пакета PCS7. Спустя некоторое время (от часов до дней) после запуска выдает сообщение о нехватке виртуальной памяти. Причем от количества памяти (физической 512 Мб, виртуальной обычно в два раза больше) это не зависит. Анализ списка процессов в Task Manager'e показывает следующее:

- WinCC запускает около 20(!) процессов, каждый из которых без особых колебаний запускает около 10-40 потоков;
- это не считая SIMATIC NET, который и так одних сервисов запускает около 10 штук;
- большинство из процессов WinCC съедает от 5 Мб и выше физической памяти, и раза в два больше виртуальной. Рекордсменом является CCProjectMgr.exe - до 67 Мб (!) физической и 328 Мб (!) виртуальной.

Теперь скажите мне:

- сталкивался ли кто-то с подобными проблемами?

Если да, то:
- КАК побороли? Что мне лучше бы купить 2 Гб RAM, я догадываюсь :-).
- ЧЕМ должно заниматься обычное Win32-приложение (не-.NET), чтобы сжирать СТОЛЬКО памяти?
- ЧЕМ думали программисты и инженеры Siemens, создавая такое чудовище?
- КАК можно со спокойной душой устанавливать такое на объекте?
- ПОЧЕМУ равные по классу системы конкурентов спокойно работают в 128 Мб RAM?
Re: WinCC 6.0 от скромности явно не умрёт
Юрий Оганесян; 4.8.04

Сразу скажу: с WinCC v6 я не работал.

Теперь: анализ используемого объема памяти лучше производить не Task Manager'ом, а Системным монитором ("Производительность" в ХР). Причем это оснастка позволяет вести журнал по каждому процессу, по которому очень удобно определить "ДИНАМИКУ" захвата памяти - если память хватается сразу и держится на данном уровне - это приемлемо. Если идет постоянное увеличение необходимого объема памяти для приложения, то на 90% - это грубейший косяк (т.к. понятно, что и 2Гб не спасет - только время увеличится). Косяк то ли у SCADА, то ли не хватает, какой-нить заплатки у ОС - надо смотреть, однако...,
Но вообще-то мы как раз хотели попробовать v6 и Вы меня озадачили...
Re: WinCC 6.0 от скромности явно не умрёт
Маслов Дмитрий; 4.8.04

WinCC 6 у нас стоит на реальном объекте и память не "течет".

Да, действительно, требования к памяти в WinCC 6 возросли. И для того, чтобы это понять, не нужен никакой Task Manager, надо просто почитать документацию, в которой говорится, что для WinCC 6 требуется 512Mb памяти, а рекомендуется - 1Gb. Отчасти это из-за использования MS SQL Server 2000 - все-таки это полновесный сервер баз данных, как никак.

С утечками памяти, тем не менее, мне в WinCC 6 сталкиваться не приходилось.
Re: WinCC 6.0 от скромности явно не умрёт
Чистяков Дмитрий ОАО СеверСталь; 4.8.04

У нас тоже проблемы с утечкой памяти не наблюдалось.

Надо смотреть, кто её кушает.
А не писали ли Вы что нибудь своё? Или может от третьих лиц какую-нибудь примочку используете.
А какой буфер у вас стоит на сообщения(количество сообщений в коротком архиве)? Может это они у вас весь воздух со временем высасывают?
Ну, и в требованиях сказано, что 512 метров - это для клиента, а для сервера требуется минимум 1Гиг.
Re: WinCC 6.0 от скромности явно не умрёт
fresco; 4.8.04

Видимо речь не об утечке. А о том что WinCC стало в два раза больше и в два раза лучше. А если занимаемый объем памяти увеличится в 10 раз - станет в 10 раз лучше. Это же очевидно :-)

Re: WinCC 6.0 от скромности явно не умрёт
Nick Gashevsky; 4.8.04

Две недели гонял WinCC6.0 на 256мб памяти. Своп постоянный, но не повис. Архивировалось ~250 параметров с периодом 1с. Больше всего памяти съедал SQL.

Re: WinCC 6.0 от скромности явно не умрёт
Кирил; 4.8.04

WinCC 6.0 SP2 and SQL-2K спокойно работает и на 128МB с CPU 500 MHz. Попроуй с ApDiag.exe от

...\Siemens\WinCC\uTools
Re: WinCC 6.0 от скромности явно не умрёт
Евгений Трунов; 4.8.04

Собственные приложения могут отъедать для своих нужд сколько угодно, но как они могут заставить CCProjectMgr забрать 400 Мб памяти? На SQL Server грешить не могу - он занимает столько же, сколько обычно и занимает :-). Память тем же CCProjectMgr хватается не сразу, а поджирается по мере работы. Второй по жадности компонент - pdlrt.exe, затем идет script.exe. Допустим, тут еще зажирания можно списать на наличие скриптов, хотя эти же самые скрипты в WinCC 5.0/5.1 вели себя куда более спокойно.

Почему больше в два раза? 5.1 вполне себе жила в 256 Мб, 6.0 распухла до 1 Гб при аналогичной функциональности. Это 4 раза, а не два :-).
Re: WinCC 6.0 от скромности явно не умрёт
Лёха; 5.8.04

Посмотри всё-таки, идёт у тебя накопление памяти или нет в том же script.exe. У меня по началу в WinCC 5.1 было такое же чудо. Сжираемая память потихоньку увеличивалась. В итоге проект вис. Дело было в скриптах. Забывал очищать память, выделенную под динамические переменные.

Просмотри свои скрипты и остальное.
Re: WinCC 6.0 от скромности явно не умрёт
shurik; 5.8.04

а как очищать память динамических переменных - приведите пример

Re: WinCC 6.0 от скромности явно не умрёт
Лёха; 6.8.04

Как, как. Как и раньше. Вы же выделяете под них память (например, SysMalloc), то её потом и освобождать надо (например, SysFree). Так же и созданные объекты надо удалять после того как они уже не нужны.


text

WinCC 6.0+ time synchronization
KAV; 23.6.04

Конфигурация: S7-400H с СР443-1, 2 персоналки c СР1613 и WinCC 6.0. Что нужно запараметрировать с той и другой стороны для синхронизации времени.

Re: WinCC 6.0+ time synchronization
ЗАО "Искра-Энергетика", Харгелия Олег; 23.6.04

на Customer Support посмотрите ID Entry: 16622902.

Может поможет.

Re: WinCC 6.0+ time synchronization
Геннадий; 6.7.04

Вывод времени и синхронизация часов компьютера с общими часами на сервере времени Microsoft Windows для рабочих групп,

Windows NT, Windows 2000 ...

NET TIME [\\компьютер /WORKGROUP:группа] [/SET] [/YES]

компьютер Имя компьютера (сервера времени), предназначенного для вывода или синхронизации времени.
/WORKGROUP Этот ключ указывает необходимость использования часов
компьютера из другой рабочей группы.
группа Имя рабочей группы, в которую входит нужный компьютер.
При наличии в группе нескольких серверов времени команда NET TIME использует первый найденный из них.
/SET Синхронизация часов компьютера с часами указанного компьютера или рабочей группы.
/YES Выполнение команды NET TIME без предварительного запроса данных или подтверждения.
<


text

WinCC 6
Yrok; 9.3.04

Люди подскажите такую вещь.

Создал в WinCC новый тег с именем NewTag, в TagLogging создал архив с именем Agdam, запустил на выполнение и далее пишу свою прогу на С++ пытаюсь соеденится с SQL Server но не могу найти таблицу в которой хронятся значения этого тега. Запустил SQL Manager но там гора таблиц и найти никак не могу нужную таблицу.
Re: WinCC 6
Human; 10.3.04

В зависисмости от того, как часто архивируются переменные, значения смотрите или в

Databases\..._TLG_F_....\Tables\TagCompressed
или в
Databases\..._TLG_S_....\Tables\TagUncompressed
Re: WinCC 6
Yrok; 10.3.04

Всё равно всё не ясно, создал ещё один тег unsigned 16 bit но в отличие от двоичного тега я его не вижу в этих таблицах. И ещё создаю проект в Visual С++, устанавливаю на диалоговое окно таблицу, далее устанавливаю осх компонент Microsoft ADO control и пытаюсь подключится к базе данных SQL Server. Но всплывает интересная вещь WinCC предоставляет только два источника данных это один DSN=CC_3T_04_03_09_11_30_50 а второй

DSN=CC_3T_04_03_09_11_30_50R а в них то тютю этих таблиц нету, и чё теперь делать?
Re: WinCC 6
Nick Gashevsky; 11.3.04

Тегов явно не видно, но доступ к ним вполне нормальный. Посмотри пример из доки к WinCC Connectivity Pack. Пример на VBA. Могу выслать свой пример (на VC++ чтения архивных тегов).

Re: WinCC 6
Костенич Дмитрий; 25.3.04

To York> А ты в RT базе посмотри в таблицу AMT - там валяются DSN для сегментов баз AlarmLogging, TagLoggingFast и TagLoggingSlow

Re: WinCC 6
Alexis; 26.3.04

А что, TLGGetArchivDataEx не работает?


text

WinCC Alarm Control
Николай; 17.11.04

Прошу всех срочно о помощи. Есть огромная проблема с выводом аварийных сообщений в Runtime с помощью Alarm Control. Почему-то выводится только последняя тысяча сообщений, хотя архивируется больше, причем и короткий и длинный архивы (а у меня тысяча сообщений набегает за полдня). Подключал таблицы к Access, там все Ok. Помогите, совсем голову поломал. Используется WinCC 5.1

Re: WinCC Alarm Control
Alexis; 17.11.04

Дык оно вроде токо 1000 и выводит... фильтруйте...

Re: WinCC Alarm Control
ООО Стальсеть; 18.11.04

Alarm Control выводит только 1000 сообщений макс. Для вывода более старых сообщений необходимо задавать фильтр, например, по времени.


text

WinCC Alarms
Sergei; 1.9.04

Privet.

Nikak ne mogu razobrat'sja, kak zastavit' rabotat' alarm? Kto mozhet v dvuh slovah objasnit'? Primer: AlarmTag (bit type). Pri ustanovke "1" dolzhen vivesti alarmu. Nichego ne ponimaju. V InTouch ponimaju, zdes'-ne ponimaju. POMOGITE. THANKS.
Re: WinCC Alarms
STOP, all is OK; 1.9.04


text

WinCC flexible options
Игорь Одесса; 23.9.04

Господа подскажите такую вещь:

есть панель MP 270 уже запрограммированная и участвующая в тех.процессе.Необходимо продублировать мониторинг с нее на PC. Внимание вопрос:
Можно ли это реализовать при помощи пакета WinCC flexible/Sm@rtService? Необходимо ли WinCC flexible RT для работы самой опции WinCC flexible/Sm@rtService? и совсем маленький ;) : Для описанной выше задачи,можно ли на PC создать архивы при помощи WinCC flexible/Sm@rtService?
Re: WinCC flexible options
Игорь Одесса; 24.9.04

Что, неужели никто не подскажет?


text

WinCC MultiClient Project
Koltsov; 15.3.04

Есть сервер WinCC 5.1 и клиенты, которые работают с этим сервером.

Необходимо знать кто, когда и откуда залогинился на сервер.@CurrentUser показывает только текущий логин(последнего залогиневшегося не важно откуда). Можно написать action на сервере для каждого клиента, но по какому признаку его запускать, как узнать с какой машины логиниться клиент.
Re: WinCC MultiClient Project
Human; 15.3.04

Если не ошибаюсь стандартный логинер WinCC пишет в сообщении, где произведена регистрация?!

Ну, а мы, как вариант написали свой логинер, который при регистрации пишет имя пользователя во внутреннюю переменную, читает имя компутера (клиента) и пишет его в другую переменную. И всё это в сообщение.
Re: WinCC MultiClient Project
koltsov; 15.3.04

как прочитать имя машины клиента?

Re: WinCC MultiClient Project
koltsov; 16.3.04

как прочитать имя машины клиента?

Re: WinCC MultiClient Project
Human; 16.3.04

Можно использовать GetComputerName.


text

WinCC ODK
Eugene; 15.11.04

В проект подключаются header файлы из ODK, проект компилируется без ошибок, но при запуске возкает ошибка 'unresolved external function' при вызове любой функции. Подскажите пожалуйста, что надо сделать ?


text

WINCC ODK
Eugene; 15.11.04

В проект подключаются header файлы из ODK, проект компилируется без ошибок, но при запуске возкает ошибка 'unresolved external function' при вызове любой функции. Подскажите пожалуйста, что надо сделать ?


text

WinCC OLEDB Provider for Archives
Малкон; 23.11.04

Приведите пожалуйста пример, как мне подключить в CBuilder или Delphi через ADO базу

(я так понял это можно сделать через WinCC OLEDB Provider for Archives объект).

У меня проблемма в том, что я не понял что за ИСТОЧНИК ДАННЫХ и РАЗМЕЩЕНИЕ, все что мог перепробовал, но подключиться не могу.
WinCC 6 SP1 с компашки по умолчанию все установлено.Все испытываю на одной машине.

Re: WinCC OLEDB Provider for Archives
Nick Gashevsky; 23.11.04

Скачай мой пример (на MS VC).

http://www.automation-drives.ru/as/download/doc/simatic_hmi/wincc/SamplesAdoWinCC6.zip
В CBuilder должно работать без проблем.
Re: WinCC OLEDB Provider for Archives
Руденко Алексей "НЕВИСС-Комплекс"; 23.11.04

Там все просто (Delphi) из палитры ADO компонент выкладываешь на форму АДОконнекшен и ищешь вкладку ConnectionString, далее выбираешь ODBC драйвер->и в следующем окне в выпадающем окошечке выбираешь твой проект WinCC - далее дело техники.

Удачи...
Re: WinCC OLEDB Provider for Archives
Малкон; 23.11.04

Provider=MSDASQL.1;Persist Security Info=False;User ID=z;Mode=ReadWrite;Extended Properties="DSN=CC_sux_04_11_04_08_47_20R;Description=WinCC 6.0;UID=z;APP=Enterprise Suite;WSID=COMPNAME;DATABASE=CC_sux_04_11_04_08_47_20R;AttachDBFileName=C:\Program Files\Siemens\WinCC\WinCCProjects\sux\suxRT.mdf";Initial Catalog=CC_sux_04_11_04_08_47_20R

С такой строкой работает, но меня берут сомнения, что это идет через OLE DB, и вот почему:
Поставщик данных->Microsoft OLE DB Provider for ODBCDrivers

т.е. я выбрал профайдера для ODBC,в то время как в поставщиках есть еще: WinCC OLEDB Provider for Archives.
У которого как я писал в первом сообщении совершенно необъяснимые вопросы. Далее делал:

ConnetionString->Использовать строку подключения->Сборка->Источник Данных компьютера->CC_sux_04_11_04_08_47_20R

т.е. таким образом я скорее всего подключил просто табличку без использования WinCC provider for archives, который собственно и НУЖЕН!

Быстрые Архивы в распакованном виде мне не увидеть таким образом.

Да конечно пример на C я посмотрел,там следующий стринг:
Provider=WinCCOLEDBProvider.1;Catalog=CC_MyProject_node_04_03_11_17_32_12R;Data Source=.\\WinCC

попытался написать руками строку - ничего не вышло, менял местами как мог все равно не выходит,
При этом я уж на всякий случай запустил сам WinCC, хотя вроде разницы быть не должно.
Возможно дело в опции ConnectivityPack, однако мне кто-то говорил, что полная установка с компакта 6 версии позволяет локально работать с архивами из других программ. Только ЛОКАЛЬНО.
Так это или не так ?
Re: WinCC OLEDB Provider for Archives
Малкон; 23.11.04

На оригинальном компакт диске WinCC 6 SP1 имеются слеующие опции:

UserArchives
Redundancy
Server
Basic Process Control
ChipCard

никакого ConnectivityPack там нет судя по всему.
Это значит пока я не купллю WinCC, я не смогу писать клиента на Delphi ???
Re: WinCC OLEDB Provider for Archives
Nick Gashevsky; 24.11.04

Да, только ЛОКАЛЬНО. WinCC Должен быть запущен для получения данных и в быстрых архивах должна лежать информация. Кроме того, имя архивного тега нужно вписать руками и вписать свое имя проекта CC_sux_04_11_04_08_47_20R. Попробуй запустить пример, изменив в нем параметры Connection string на свои собственные. Когда что-то заработает,будет легче.

<


text

WinCC OPC сервер и Simatic NET.
Владимир Ерохин; 19.2.04

Здравствуйте!

Установили WinCC 5.1 HF 4, сотвории проект, пытались подключиться OPC клиентом - все нормально (видит теги, читает, пишет и т.д.).
Устанавливаем далее Simatic NET V6.0 SP5 B2645. После этого OPC клиенту (при добавлении в группу) возвращается ошибка - OPC_E_UNKNOWNITEMID. То есть неправильно назвали тег, который надо добавить в группу (вольный перевод :-) ).

Пытаемся через OPC Scout - показывает список тегов и т.д., но при добавлении пишет:
The item definition does not exist in the server address space

Как со всем этим бороться? Кто нить сталкивался?

З.Ы. После деинсталляции Simatic NET - ситуация такая же хреновая как и до деинсталляции.
Re: WinCC OPC сервер и Simatic NET.
Чистяков Дмитрий ОАО СеверСталь; 20.2.04

Не стоит нарушать порядок установки ПО (сначала Simatic Net, затем WinCC).

Я бы переустановил WinCC.
Re: WinCC OPC сервер и Simatic NET.
Евгений Трунов; 20.2.04

Ну да. Не надо нарушать порядок инсталляции. А еще порядок деинсталляции, установки сервис-паков, их номеров, версий эксплорера, middle-tier ПО и пр., и пр., и пр. SIMATIC NET проверен в одной конфигурации, STEP в другой, WinCC в третьей - и все только так, и никак иначе. Вместо всех этих сложностей можно было просто написать в документации: "Мы, менеджеры и инженеры, общими усилиями загнали нашу линейку ПО в стадию неуправляемости. О том, как заставить всю связку нормально работать вместе, описано в печатной документации в 5 томах, заказной номер - 6ES7-..., цена - 1290 евро" :-)).

Re: WinCC OPC сервер и Simatic NET.
Владимир Ерохин; 25.2.04

Спасибо, помогла правильная последовательность установки. Хотя все это как-то неправильно...

Re: WinCC OPC сервер и Simatic NET.
Чистяков Дмитрий ОАО СеверСталь; 25.2.04

Да нет, всё правильно. WinCC не просто устанавливается, он ещё и OPC свои настраивает и регистрирует.

Re: WinCC OPC сервер и Simatic NET.
Владимир Ерохин; 25.2.04

Регистрация OPC сервера никак не должна зависеть от установки другого софта - этож обычный COM. Причем, другие ОРС сервера на этой машине нормально опрашивались.


text

WinCC RAW data tag
Руденко Алексей "НЕВИСС-Комплекс"; 25.11.04

Столкнулся с небольшой проблемой.

В WinCC создаю RAW-тэг и далее его разбиваю на части, но все это дело работает до той поры пока значение длины для него в районе 200 байт (240 уже не работает) - далее начинаются проблемы, а именно: он не хочет считываться функцией GetTagRaw - функция выдает ошибку.
Это происходит как при использовании эмулятора Степ-7 так и при использовании реального железа (IM151-7 CPU).
Кстати в процессе "разбора полетов" столкнулись с проблемой, что CPU отказывается работать на профибасе(мигает системная ошибка и ошибка шины) а позволяет считывать данные только по MPI. Непонятки какие-то.
Кто сталкивался с подобным поведением RAW тегов, помогите...

Re: WinCC RAW data tag
Кирилов Владимир; 26.11.04

Если не ошибаюсь, MPI устроена так, что пакеты в ней длиной 250 байт.

Re: WinCC RAW data tag
Руденко Алексей "НЕВИСС-Комплекс"; 26.11.04

Ну MPI то понятно, а что профибас?

К слову, в какой раз наблюдаю молчаливых сынове Сименса - ни ответа ни привета. Вчера с этим вопросом обращались к Питерскому представительству: ответ не удивил: "Не знаем!!!"
Re: WinCC RAW data tag
Кирилов Владимир; 26.11.04

DP - кажись то же самое, FMS не знаю, надо смотреть

Re: WinCC RAW data tag
Руденко Алексей "НЕВИСС-Комплекс"; 26.11.04

The maximum length of the raw data is limited to one of the data blocks that should be transferred. It must be possible to transfer the raw data completely with just one PDU (Protocol Data Unit). The maximum length of the data blocks that can be transmitted by the S7 communications driver depends on the PDU length negotiated during the connection setup minus the header and additional information. The following maximum PDU lengths are commonly used for SIMATIC S7:

S7-300: PDU length 240 bytes; data block length max. 208 bytes

S7-400: PDU length 480 bytes; data block length max. 448 bytes

Вот и ответ, всем спасибо!
Re: WinCC RAW data tag
Чистяков Дмитрий ОАО СеверСталь; 26.11.04

А такой вопрос - а зачем Вам такой большой блок RAW данных?

Вы пытаетесь записывать какие-то сигналы в файл, подменяя функцию трендов, только с меньшим временем цикла?
Или ещё какие-то мысли имеются?
Может просто пойти другим путём? Расскажите, так може чё подскажу.
Что же касается MPI, то этот интерфейс нельзя назвать особо предназначенным для быстрых и больших коммуникационных задач.

Что касается IM151-7 CPU. Profibus на борту этого модуля может работать только в режиме Slave. Т.е. только в режиме станции удалённой периферии.
Для работы в режиме мастера необходимо докупить модуль 6ES7138-4HA00-0AB0
Re: WinCC RAW data tag
jkeks; 26.11.04

новый пакет Genesis32 стоит около 8000$ новая 8 версия, полностью со всем барахлом. В Екатеринбурге самый известная кантора по автоматизации ProSoft по большей части придерживается именно продукта фирмы ICONICS, а тот просто основывается на WEB. Я чисто из энтузиазма наблюдаю за этой ситуацией.

См. http://ptm-energo.ru

Re: WinCC RAW data tag
Руденко Алексей "НЕВИСС-Комплекс"; 26.11.04

Суть состоит в следующем:

В контроллере будут храниться посекундные архивы за 10 минут до аварии (предполагаемой, т.е. постоянно данные будут обновляться) и за 10 минут после, далее архивация останавливается (Все это будут работать на 414_2DP).
Далее оператору нужно будет выгрузить это все в WinCC и просмотреть (найти причину и т.д.)
Блок данных получается равным 9620 байт - и это все в случае необходимости нужно вытянуть (архивация средствами WinCC не допускается, т.к. объект котельная - сами понимаете - все должно управляться на нижнем уровне).
Как я понял максимум что я выжму из S7-соединения 448 байт на тэг. Этого очень мало (таких блоков данных где-то около 50 :-)
Сейчас пошел по другому пути:
С помощью BSEND/BRESIVE можно пересылать до 16KB информации из контроллера напрямую, а WinCC способна это дело принять. Есть конечно недостатки, но это неважно, т.к. такие считывания будут происходить редко (хотелось бы чтобы вообще не происходили).
Так вот - симулятор это дело не поддерживает, как не поддерживают 200CPU и 313_2DP, которые имеются у нас в наличии, а работать надо!!!
Усли кто сталкивался с работой этих функций - буду очень признателен.
Спасибо всем за участие в дискуссии
Re: WinCC RAW data tag
Руденко Алексей "НЕВИСС-Комплекс"; 26.11.04

Сейчас докопался, что 300-ка поддерживает эти функции - пойду пробовать...

Жду комментариев (вот бы сименс услышать но боюсь это несбыточные мечты, это ж вам не Германия)<


text

WinCC Redandancy Что не так?...
Игорь Одесса; 25.8.04

Два проекта созданных дубликатором, в обоих поднял опцию Redandancy, проставил "галки" где только можно, и... тишина, от одного сервера к другому данные не передаются :(. Может еще что - то надо прошаманить, а то как-то подозрительно просто все по документации получается.Подскажите что делать.

Re: WinCC Redandancy Что не так?...
Чистяков Дмитрий ОАО СеверСталь; 25.8.04

Оно и действительно всё просто - главное выполнить все требования по параметрам проекта и настройке серверов.

1. Имя компьютеров должно быть не более 8 символов и желательно без спец символов.
2. Проверить пользователей на обоих серверах - они друг к другу должны иметь доступ
3. проверить путь у пользователей до дополнительной запускаемой программы в параметрах клиента.
Re: WinCC Redandancy Что не так?...
Игорь Одесса; 25.8.04

По пунктам 2-3:

А разве недостаточно просто расшарить с полным доступом соответствующие папки?
Re: WinCC Redandancy Что не так?...
Лёха; 26.8.04

Есть ещё один прикол в редундансе.

После первого включения обоих компов необходимо поочереди остановить проект и заново запустить на машинах. Да ещё, в настройках редунданс имена серверов-партнёров прописал?
Re: WinCC Redandancy Что не так?...
Игорь Одесса; 26.8.04

Да, все прописано.

Что я сделал:
1.Создал одинаковых пользователей на обоих машинах с одинаковыми правами
2.Поднял опцию Redandancy, и указал партнера
3. Запустил Project Migrator коим перебросил проект на 2-ю станцию.
По описанию - этого достаточно для работы Redandancy, однако значения тегов и архивов не синхронизируются :(
Господа, подскажите, я в мертвой точке - даже не знаю что еще сделать.
Re: WinCC Redandancy Что не так?...
Макс Прилепский; 1.9.04

Если проект имеет тип Multi-User, то SIEMENS в документации указывает для него в качестве ОС Windows Server 2000, также упоминается о том, что серверы должны быть синхронизированы по времени, например, с помощью Time Synchronization. Если у серверов с проектом нет клиентов, можно попробовать установить тип проекта в Single-User, если есть, то можно попробовать сгенерировать в проекте Server Data.

Re: WinCC Redandancy Что не так?...
Игорь Одесса; 2.9.04

Time synchronization поднял, теперь даже идет синхронизация данных :), но...синхронизация между серверами происходит как-то странно - ни о какаких 5 - 10 секундах(время синхронизации как указано в доках), речи не идет, сервера синхронизируются то ли раз в час, то ли еще позже. Проводил эксперимент также с отключенным одним сервером, затем поднимал второй, данные архивов синхронизировались где-то через часика полтора :((.

Re: WinCC Redandancy Что не так?...
Nick Gashevsky; 14.9.04

Архивы действительно синхронизируются долго (недостающие денные). Текущие сразу.


text

WinCC Server-Client по локалке
Людмила; 31.3.04

WinCC v5.1 Есть сервер-клиент. На сервер через ОРС-сервер поступают данные с приборов.

Визуализация и на сервере и на клиенте.
Все работает. На клиенте отключаю локалку. На клиенте все поля сереют. Локалку включаю.
Данные на клиент не поступают, пока не перезагрузишь машину-клиент.
Кто знает какие нужно сделать настройки, чтобы клиент обнаруживал сервер автоматически при обнаружении
локалки?
Re: WinCC Server-Client по локалке
Zolotoy; 2.4.04

А кто или что застовляет обрывать локалку во время процесса? :)

Re: WinCC Server-Client по локалке
Вадим Печёрских; 2.4.04

Привет, Людмила. Минут через 5 связь появляеться. Только что проверяли. Скорее всего выдерживаеться какой-то таймаут.

Re: WinCC Server-Client по локалке
Людмила; 2.4.04

Ждала час, связь не появилась. Локалку отключала специально для проверки. Дело в том, что иногда на клиенте поля "сереют", как при потере связи с сервером, хотя надписи "No connection to data server" не появляется. После этого ничего не остается делать как клиент перезагрузить. И я подумала что может барахлит локалка. Хотя при наглом отключении локалки выходит запись, что нет связи с сервером. Непонятки. А пользователь не доволен...

Re: WinCC Server-Client по локалке
Вадим Печерских; 2.4.04

Лучше взять проект и протестировать данную ситуацию на других машинах.

У нас были следующие условия
1.Windows 2000 Server
2.WinCC 5.1 Hotfix 4
3.OPC сервер OPC DataManager
4.Сеть 100 кб/с

Re: WinCC Server-Client по локалке
Макс Прилепский; 2.4.04

Как вариант, не исключается кривизна локалки, например, обжим коннекторов RJ-45 не по схемам T-568A или T-568B, а по схеме "лапша" :) Можно попробовать выполнить в командном процессоре (cmd.exe) команду ping -t -l 50000 <NetBIOS-имя сервера WinCC> и поглядеть, как доходят пакеты по 50000 байт, если часто будет request timed out, то пакеты ходят из рук вон плохо, что может быть также обусловлено наличием Hub 10 Мбит, к которому подключено несколько сетевых устройств. Далее, если пакеты по 50000 байт доходят далеко не все, можно снижать размер пакета с 50000 байт до меньших значений. И ещё: WinCC-клиент качает в том числе и картинки PDL с сервера, если эти картинки (с временем изменения файла не меньшим, чем файлы сервера) не находятся в каталоге ...\WinCC\Bin\PdlCache. Попробуйте скинуть в PdlCache все файлы Pdl из \GraCS проекта.

А на самом сервере WinCC при "серых" полях клиента всё нормально? Ибо есть такие OPC - серверы, например, UniOPC, которые, при потере связи с устройством, не возобновляют обновление OPC тегов даже при возобновлении связи с устройством.
Re: WinCC Server-Client по локалке
Людмила; 3.4.04

При "серых" полях клиента сервер работал нормально. Проверка сети дала хорошие результаты, обжим коннекторов не по схеме "лапша". Условия у нас другие: WinCC 5.1 без Hotfix-ов и SP. Windows 2000prof-rus. При повторных попытках отключения локалки, связь действительно иногда возобновляется, что меня обрадовало, но бывает, что не все теги подхватываются для обновления. Все картинки PDL клиента лежат на клиенте, поэтому я думаю они с сервера не качаются.

Спасибо всем, кто ответил. Буду пробовать дальше что-то делать.
Re: WinCC Server-Client по локалке
Макс Прилепский; 5.4.04

Проблема может объяснятся именно Windows 2000 Prof, у которой число сетевых подключений ограничено числом 10 (у Win2K Server ограничение настраиваемо и соответствует количеству лицензий на сервер), причём несколько из них занимает сам проект WinCC , поскольку работает с папкой проекта , как с сетевой папкой. При временном отключении клиента свободные подключения могут снова использоваться, но не клиентом, и может достигаться предел продключений, а может и не достигаться (ситуации когда связь возобновляется) Количество и список активных подключений можно посмотреть командой netstat. А вообще, SIEMENS в перечне требований при установке сервера на базе WinCC 5.х указывает в качестве ОС именно Windows NT Server или Windows 2000 Server.


text

WinCC SP1 падает на XP
jkeks; 2.11.04

У меня XP SP1, MSSQL 2000 WinCC SP1 (без хотфиксов)

И при добавлении в раздел Tag Management нового устройства, WinCC падает (добавляю S7) были ли такие проблеммы ?? и как ее решить ?
См. А это моя страничка

Re: WinCC SP1 падает на XP
Пердатору; 2.11.04

Для Пердатора и нет ничего странного, что у него все слетает. Убери свой пердатор со своего компа и все заработает.

А сюда такие ссылки постить не надо.
Re: WinCC SP1 падает на XP
jkeks; 3.11.04

При чем тут журнал наш - Sperdator ?.. ответа я не нашел, переустановил XP, и все заработало.. блин. Прямо как в старые добрые времена лечились баги переустановкой. Поставил XPSP2.

См. http://revda.biz


text

WinCC TM
Gennady; 16.2.04

Имеется ли возможность получить демо версию WinCC TM. Есть задача, хотелось бы прежде чем покупать, попробовать. Потому как нет уверенности что заработает.

Или PCS 7/TM OS.
Re: WinCC TM
Михайлин Сергей; 16.2.04

Демо версии TM нет. Но вопрос несколько не корректен. WinCC TM - это самая обычная WinCC и плюс к ней идет просто канал (chn) для связи в контроллерами Teleperm. Канал работает, проверено на многих проектах! А демо WinCC есть всегда. Суть такова: ставите WinCC, подключаете Teleperm канал, создаете соединение, объявляете переменные Teleperm процессора, далее как с обычной WinCC. Если есть реальная задача и желание сделать миграцию, обратитесь ко мне. У меня как раз сейчас в процессе такой же проект.


text

WinCC v6 SP1
Владимир; 14.4.04

Где можно взять SP1 для WinCC v6 и руссификатор для него. Он уже вышел.

Re: WinCC v6 SP1
Лев Шерешевский; 14.4.04

Как всегда, в представительствах Siemens A&D и в центрах компетенции WinCC. Перечень региональных офисов приведен на станице http://www.aud.ru/about/regions/index.php

См. www.wincc.ru


text

WinCC vs QNX
Andrey Sher; 29.3.02

Кто подскажет:

- собираемся запустить АСУТП установки печь-ковш. Имеется 2 генподрядчика. Оба лепят на Simatic S7. Но верхушка у одного выполняется на QNX & ISAGRAF, у другого - на Win NT & WinCC. Куда податься ?
Re: WinCC vs QNX
Alexis; 29.3.02

Я бы QNX посоветовал... WinCC уже достала... да и виндоза тоже...

Re: WinCC vs QNX
Александр Туманов; 29.3.02

Обратитесь на форум QNX & ISAGRAF!!!

Re: WinCC vs QNX
Александр Родин, ООО "Нева Электрик"; 29.3.02

2 Alexis:

Вот что достала, так достала - эт точно.. %) Токма чего так радикально сразу на куникс сажаться ?.. Под ним тож баги есть... А альтернатив WinCC хоть отбавляй - Wonderware тот же... или Intellution FIX / FIX Dynamix... наконец AdAstra со своим TraceMode.. Причем все божаться, что дрова под Симатики имеют...
А что Винды касается.. под ней тоже жить можно... иногда... :)

С уважением ко всем..
Re: WinCC vs QNX
Чистяков Дмитрий ОАО "СеверСталь"; 29.3.02

Лучше возьми родную WinCC, чем потом мучаться с проблемами связи с ISAGRAF.

Для Alexis
-----
WinCC уже достала... да и виндоза тоже...
-----

Достаёт всё чем приходиться заниматься серьёзно. :-)

Re: WinCC vs QNX
Михайлин Сергей; 29.3.02

Прошу не расценивать мой постинг как рекламу, я прекрасно понимаю, что есть SCADA системы лучше и хуже нашей, но я считаю, что волшебное слово "совместимость" не утратило своей актуальности.

Насчет дров, да, все говорят, но лично я убил 2 дня что бы подсоединить S7-300 к InTouch-у, который знал только сетевую карту 2-летней давности.
С ОРС проблем конечно поменьше. И часто это единственный вариант соединения. Но всегда надо предварительно тестировать.
В случае "зоопарка", посылать вас будут в случае проблем скорее всего с обоих концов.
Так что вот так вот.
Я уже не говорю о специфических вещах, типа поддержки дублированных контроллеров, и тд.
Но выбор за Вами. ;-)
Re: WinCC vs QNX
Alexis; 29.3.02

2 Чистяков Дмитрий

Дима, посуди сам, общаюсь с WinCC.ODK-Hotline@mhm6.siemens.de и говорю им, мэны, у Вас баг в функциии MSRTGetMsgText(...), а в ответ:
... it is a bug that is well known. It appeared with the WinCC version 5.0 SP2. The reason for the bug is probably
that parts of WinCC data are
rolled out from the operating system. By the call from the function
MSRTGetMsgText() this data are needed,
but it could not recall as fast as necessary. Therefore the exception.
It is planed the the problem will be fixed with a Hotfix in WinCC version
5.1.
ууупппссссс....

Cпрашивал на счет DMSendApplicationData(...) (в форуме уже задавал этот вопрос), пришел ответ:
It seems that the function DMSendApplicationData() does not work between two computers is a bug from the function. I made a problem report to the WinCC developers. As soon as I hear anything else from the guys i inform you. But in the moment the functions works only from applications that run on the same machine.

еще раз: ууупппссссс....

ну и как после этого нормальный софт писать? стандартными средствами WinCC классно и просто для юзверов не сделаешь... особенно для конечных...

вот...

а может много на грудь принял сегодня... :)
Re: WinCC vs QNX
Павел Берляков; 1.4.02

Александру Туманову:

А где этот форум - QNX + ISAGRAF ?
И, кстати, кто-нибудь пробовал какую-нибудь SCADA на неWindows платформе ?
Под QNX было даже что-то отечественное, RTWin называется.
А что по поводу простоты, так там (в QNX) тоже все не так просто, как бы хотелось. В основном все надо делать руками. Внешне все вроде бы нормально. В PhAB так же прописываются свойства элементов формы и обработчики событий. Но вот братья-словаки, что делали нам софт, почему-то не часто пользуются стандартными фотоновскими средствами(я имею в виду как раз написание обработчиков событий и т.д.). У них куча своих библиотек.
С Симатиком общаемся по UDP. Важно точно прописать структуры, через которые осуществляется обращение к соответствующему DB и учесть разницу форматов (перестановка байтов). Когда все прописано нормально, то работает без перерыва. Пока рабочая станция не сломается. С точки зрения надежности QNX конечно лучше и производительнее.
Непаханная земля!!!
Илья; 29.9.04

Народ, привет!

Есть город и даже целая страна, в которой промышленность интенсивно
развивается, а АСУТП за ней никак не поспевает, то есть резко отстает.
Причем, промышленность очень хочет эту самую АСУТП и громко заявляет о
своем большом спросе. Но нет предложения, которое бы удовлетворило этот
спрос.
Сименс как-то пытается удовлетворять потребность, но потребность растет
быстрее. Подалась сюда некая российская (немецкая) фирма со своим
контроллером на букву "Т" и сразу же столкнулась со спросом, который она не
может даже перевести в заказы, поскольку не хочет вкладываться в разработки
(хочет только торговать своим контроллером). Коллектив одного из филиалов
этой фирмы желает сменить хозяина, поскольку инвестиции были мизерными, а
деньги от выполняемых проектов ПОЛНОСТЬЮ уходят в метрополию, и на развитие
филиала не выделяются.
Так вот, есть слаженный коллектив обученных опытных специалистов (вместе с
руководством). Есть клиентура (благо, не всю ее отдали прежнему хозяину).
Есть хорошие (уже обсосаные) идеи по технологии, маркетингу, развитию. Нужен
инвестор (не спонсор), который позволит вспахать целину (извините за
алегорию).
Если в Украине и России надо еще побороться за клиентов, то тут пока
бороться не надо, конкуренции никакой. Тут хотя бы освоить имеющийся
спрос...
Предложения и вопросы жду на адрес vlasow@mail.kz

Re: WinCC vs QNX
Константин Власкин; 2.10.04

У нас стоит SCADA под QNX. Впечатления от работы-тяжёлые. Парни которые ставили нам эту систему в конце концов ушли на платформу Windows. Не буду говорить что шансы написать что либо путное на QNX нулевые, но уверен что вероятность наткнуться на подрядчика напишушего что либо путное под windows больше чем под qnx.


text

WinCC базовая комплектация
Михаил; 9.3.04

Была куплена WinCC v.6.0 Run-Time+проектирование на 1024 переменных.Входит ли в базовую комплектацию User Archives ? Он был установлен при установке WinCC, но лицензии на дискете на него не оказалось.

Re: WinCC базовая комплектация
Юрченко Владимир; 9.3.04

User Archives - это опция WinCC, которая находится на базовом CD, но лицензия на нее отдельная - см. www.automation-drives.ru/as/download/ascat/simatic_hmi/wincc/08_WinCC_r.pdf

На клиентах WinCC лицензия на User Archives не нужна.<


text

WinCC и Dynamic Wizard
Степанченко Сергей; 14.5.04

Установил WinCC v6.0 sp1 все работает нормально, только в Grafics Designer когда вызываеш на рабочий стол Dynamic Wizard он появляется но пустой.

Может я что то не понимаю,но в WinCC v5.0 я часто им пользовался.
Может кто-то сталкивался с таким или кто может обяснить в чем проблема.
Заранее благодарен
Re: WinCC и Dynamic Wizard
ion; 14.5.04

:-) У меня та же херня. иногда он сам появляется, потом опять исчезает.

В чем прикол пока не разобрались. :-(
Re: WinCC и Dynamic Wizard
Лев Шерешевский; 15.5.04

Похожих проблем не наблюдали ни разу. В общем случае проблемы Dynamic Wizard можно попробовать вылечить удалением (или переименованием расширения) файла \Siemens\WinCC\WScripts\Dynwiz.cwd и последующей "перекомпиляцией" этого файла в Dynamic Wizard Editor (кнопка 'Create CWD'). Есть один нюанс: если используется пакет русификации, то после этой операции русские названия wizard-ов и их разделов будут продублированы английскими.

Re: WinCC и Dynamic Wizard
ion; 18.5.04

а у меня еще и Dynamic Wizard Editor не вызывается: выдает ошибку

Microsoft Visual C++ Runtime Library

Runtime Error!
Program: ...\DynWizEdit.exe

abnormal program termination

так что даже перекомпилить ниче не получилось :-(((<


text

WinCC и Modbus-RTU
Александр; 13.8.04

Доброго времени суток.

Подскажите как мне подвязать к винсиси частотник LG.
Выбрал драйвер Modbus, все номано (вроде), но тут как это всегда бывает ввожу адрес в формате HEX, а он мне инвалид.... надо в интежере (!?!?)

Помогите плз

Заранее ОГРОМНОЕ!!!<


text

WinCC и Profibus других фирм
Владимир; 6.8.04

Кто знает Как подключить WinCC по profibus"у к контроллеру других фирм . Например Омрон ?

Re: WinCC и Profibus других фирм
Александр Родин, ООО "Нева Электрик"; 6.8.04

Самый простой способ через ОРС.

Делается следубщим образом:
1. Берется GSD-файл от устройства
2. Импортируется в HW-Configuration STEP7
3. Строится DP конфигурация, где мастером является коммуникационный процессор, установленный у вас на компе, а слейвами ваши устройства.
4. конфигурируете ОРС соединение в WinCC на SIMATIC.NET\DP\<ВАШ CP>, причем можно разными способами пойти: или передавать данные через RAW-таг, но при этом желательно создать структуру посылки, либо адресоваться к необходимым ячейкам напрямую.

Есть еще один способ с использованием в качестве мастера контроллера SIMATIC с DP интерфейсом.

Тогда все проще, т.к. можно использовать S7-Protocol в WinCC.

Если же ваше устройство не умеет быть слевом, то ищите ОРС сервер непосредственно от производителя.

В принципе, обращайтесь для консультаций. Конкретно Омрон мы не использовали, но устройства сторонних производителей на PROFIBUS вешали.
Re: WinCC и Profibus других фирм
Владимир; 9.8.04

Спасибо попробуем


text

WinCC и S7 PLCSim - возможна ли связь локально?
ASH; 23.2.04

Возможен ли коннект WinCC и PLCSim локально на одном компе? Вроде кто-то сказал, что это возможно, но мои исследования в этой области к сожалению ничего не дали:( Если кто-нибудь может что-нибудь сказать по этому поводу - плиз, откликнитесь!

Re: WinCC и S7 PLCSim - возможна ли связь локально?
Назаров Дмитрий; 23.2.04

Странно, что ваши исследования ничего не дали, эта возможность описана в документации. Попробуйте сделать теги в WinCC через MPI и проверьте одинаковый ли адрес MPI в PLCSIM. Первым запустите PLCSIM, вторым WINCC.

Re: WinCC и S7 PLCSim - возможна ли связь локально?
DRON; 24.2.04

А у меня и по PROFIBUS DP работает без проблем. Причем нет разницы, что первое запускать- PLCSIM или WinCC!!! Главное чтобы адреса совпадали.

Re: WinCC и S7 PLCSim - возможна ли связь локально?
ASH; 25.2.04

Всем спасибо, виноваты мои кривые руки - всего лишь второй день с WinCC ковыряюсь, хотел по-быстрому справиться с проблемой - :) В документации правда освещение данного аспекта так и не нашел (дока по версии 5.0) :(

Но уже все работает:)<


text

WinCC и Step7
Максим; 1.10.04

Подскажите, пожалуйста, как можно, если можно, "связать" проект в WinCC с проектом в Step7 в условиях офисной (домашней) сети или на одной машине? И как можно симулировать (проверить) работу проекта WinCC c Step7? Заранее благодарен!

Re: WinCC и Step7
Руденко Алексей Невисс-комплекс; 1.10.04

Для этого существует симулятор контроллера в Степе, а когда он запущен к нему можно подконнектится WinCC без всяких проблем, а как это сделать - читай доки...

Re: WinCC и Step7
Михаил; 2.10.04

PLCSim он называется. Установи его. Потом в Step7 нажмешь кнопочку каторая его запустит.

В WinCC добавишь соединение (S7 Protocol...) вроде так называется. И работай наздоровье
Re: WinCC и Step7
Максим; 14.10.04

PLCSim у меня установлен в Step7. Я хотел бы проверить работу WinCC на симуляторе Step7. Реального контроллера у меня нет. Как можно осущиствить это на простом примере?

Re: WinCC и Step7
Владимир; 15.10.04

В WinCC есть свой симулятор тегов

Re: WinCC и Step7 через PLCSim
PC adapter; 18.10.04

См. http://simatic.nm.ru/phorum.dhtml

Re: WinCC и Step7
Максим; 18.10.04

В WinCC есть свой симулятор тегов, но меня он не интересует. Я хотел бы через симулятор Step7 проверить работу проекта на одной рабочей машине без реального контроллера.

Программный адаптер "PC adapter (Auto)" я установил, но что дальше необходимо сделать? Подскажите, пожалуйста!!!
Re: WinCC и Step7
Маслов Дмитрий; 20.10.04

По поводу PC-Adapter - это заблуждение, к PLCSim он отношения не имеет (PC-Adapter - это преобразователь из COM или USB в Profibus DP/MPI).

PLCSim используется следующим образом:
1. В Step7 настраивается конфигурация контроллера (как обычно, HW Config). При этом обязательно должен быть включен MPI-интерфейс контроллера, а адрес должен быть 2 (PLCSim умеет эмулировать только MPI).
2. Запускаете PLCSim (кнопочка в Simatic Manager).
3. Грузите HW и программу как в обычный контроллер (при включенном PLCSim загрузка всегда будет происходить в него). Переводите PLCSim в режим RUN-P.
4. В WinCC настраиваете MPI соединение (адрес=2, слот CPU должен соответствовать указанному в конфигурации контроллера в Step7). Запускаете проект WinCC.
См. http://www.wincc.ru

Re: WinCC и Step7
PC-Adapter; 20.10.04

См.ссылку Operating S7-PLCSIM through WinCC RT (ну длинные они)

http://www4.ad.siemens.de/-snm-0135109872-1098201826-0000022358-0000000233-1098261247-enm-WW/llisapi.dll/11916587?func=ll&objId=11916587&objAction=csView&nodeid0=10805405&filter=PLCSIM&foldersopen0=-170-171-361-364-365-523-522-521-485-173-172-530-174-538-544-&lang=en&siteid=cseus&aktprim=0

Затем "show the entry list" наверху и найдешь
По поводу PC-Adapter - это "заблуждение" надо просто иметь:
Linking ProTool/Pro Runtime V6.0 with PLCSIM V5.0 SP1
If there is no MPI card installed in the configuration computer, then at least the PC adapter must be installed as interface for STEP 7 V5.1 SP4.
Человек вообще задал общий вопрос не описав конфигурации и задачи своей системы. Я думаю на домашнем компе у него нет никаких карт.

WinCC V5.1 and S7-PLCSIM V5.0 с картинками
PC-Adapter; 21.10.04

В ФАКе с картинками

Connection between SIMATIC WinCC V5.1 and S7-PLCSIM V5.0 SP1
http://www4.ad.siemens.de/-snm-0135109872-1098201826-0000018554-0000000029-1098372151-enm-WW/llisapi.dll/14226931?func=ll&objId=14226931&objAction=csView&nodeid0=10805590&foldersopen0=-172-753-785-786-787-789-790-791-802-803-809-&lang=en&siteid=cseus&aktprim=0

См. Ссылка на ФАК

Re: WinCC и Step7
Максим; 29.10.04

ОГРОМНОЕ ВСЕМ СПАСИБО!!!

ВСЕ ЗАРАБОТАЛО :))
WinCC & Step7
Hunter; 16.11.04

откуда можно слить сабжи или кто-нибудь готов обменяйться со мной есть Soft Allen-Bradley и ABB

отвечать лучше на личку...<


text

WinCC и права администратора
Victor; 27.9.04

Здравствуйте! Можно ли каким-то образом запускать WinCC c ограниченными доступом (user)? Дело в том, что имеется учебный класс, желательно бы не давать права админа тем, кто обучается. Либо запускать WinCC под правами доступа ТОЛЬКО к ней, например. Под ограниченными правами она просто не работает, либо выдает сообщение о невозможности обновления реестра. Это под FAT. А под NTFS вообще сплошные ошибки.

Это возможно? С уважением, Виктор.
Re: WinCC и права администратора
Чистяков Дмитрий ОАО СеверСталь; 27.9.04

Для работы WinCC вполне достаточно прав на уровне опытного пользователя.


text

WinCC и теги PIW
Vlad; 29.2.04

Зделали WinCC проект котрый берет информацию с двух контролеров S7 (315-2DP и 314). C 314 теги заадресированы напрямую с PIW когда запускаем runtime связь с 314 пропадает то появляется, когда делаем через DB все нормально. Информацию с PIW не можем перегнать в DB (запрет производителя).

Прошу помощи!,может кто-то имел с этим дело.
Заранее благодарен!
Владислав Белов
Re: WinCC и теги PIW
Макс; 15.3.04

Есть в памяти такое хорошее и всегда доступное место - меркеры ;)

Делаем OB35, где записываем
L PIW528
T MW112
L PIW530
T MW114
Закачиваем в контроллер, в программе не сохраняем - никто ни про что не знает, обнаруживается только при просмотре блоков в online или сравнении оффлайна с онлайном.
Re: WinCC и теги PIW
Alex G.S.; 17.3.04

А что, Владислав, поиграться с временем update не помогло?


text

WinCC клиент
ser; 7.4.04

Почему в папке "WinCC Projects" я нажимаю менюшку "Enable Remoute" и ничего не происходит. Может я забыл, что-нибедь включить в рпоекте. (клиент в список компьютеров добавлен)

<


text

WinCC клиент-сервер ?
Ser; 5.4.04

Парни помогите чайнику разобраться с конфигурацией клиент-сервер. Вот что я делал:

1. На сервере создал новый проект в режиме мультиклиент
2. В этот проект в раздел компьютеры добовил имя компьютера клиента.
3. Закрыл проект.
4. На компьютере клиенте пытаюсь открыть этот проект
5. Выскакивает сообщение: сервер не доступен, хотите вы использовать локальный компьютер в качестве сервера (что-то типа того)

ЧТО НЕ ТАК?
Зарание благодарен

Re: WinCC клиент-сервер ?
Дмитрий; 5.4.04

Попробуйте не закрывать проект.


text

WinCC клиент-сервер. Как конфигурить?
Ser; 5.4.04

Помогите чайнику разобраться с конфигурацией клиент-сервер. Вот что я делал:

1. На сервере создал новый проект в режиме мультиклиент
2. В этот проект в раздел компьютеры добовил имя компьютера клиента.
3. Закрыл проект.
4. На компьютере клиенте пытаюсь открыть этот проект
5. Выскакивает сообщение: сервер не доступен, хотите вы использовать локальный компьютер в качестве сервера (что-то типа того)

ЧТО НЕ ТАК?
Зарание благодарен

Re: WinCC клиент-сервер. Как конфигурить?
Zolotoy; 6.4.04

У меня такая хрень была, и есть в разных сегментах сети (пока не знаю как сделать чтобы всё работало) - в одном всё работает.

Попробуй добавить в свойствах сервера сдедующие приложения:
CCUsrAcv.exe (воткнуть галку в project directory)
CCCSigRTServer.exe
CCLBMRTServer.exe
(startup => Additional Tasks/Applications)
Диск:\Siemens\WinCC\bin
Re: WinCC клиент-сервер. Как конфигурить?
Макс Прилепский; 6.4.04

Дело, скорее всего, в настройках DCOM на клиенте и на сервере. В этом случае, запускается утилита dcomcnfg и настраивается безопасность по умолчанию на пользователей, под учетными записями которых осуществляется вход в систему.

Если обе машины не в домене, можно попробовать включить учётную запись Гость (Guest) и настроить безопасность по умолчанию на него, а в свойствах по умолчанию уровень проверки подлинности установить как "Нет" (None) , а уровень олицетворения "Аноним" (Anonymous).
Если же есть домен, то можно сделать и проще, но это не очень правильный путь: пользователя проекта прописать в группу Администраторы на клиент и на сервер, тогда можно обойтись без настройки DCOM. Проверить, именно ли ошибка DCOM имела место при подключении клиента к серверу, можно посмотреть в Журнале событий сервера(Event Log), запустив eventvwr.
Re: WinCC клиент-сервер. Как конфигурить?
Макс Прилепский; 6.4.04

Забыл добавить, папка проекта на сервере должна быть доступна пользователю клиента как на чтение, так и на запись

Re: WinCC клиент-сервер. Как конфигурить?
Ser; 6.4.04

Огромное спасибо всем, кто откликнулся.

Мне кажется проблема где-то в именах пользователей проекта. Вопрос - когда я открываю проект локально или удоленно, то какое имя пользователя используется по умолчанию.
Re: WinCC клиент-сервер. Как конфигурить?
Zolotoy; 6.4.04

непонел...

В ВинСС сервере добавляете имя клиента например disp, компьютер клиент должен иметь сетевое имя disp и вроде как всё... ну и добавить учётную запись disp и засунуть в группу опытные пользователи

Re: WinCC клиент-сервер. Как конфигурить?
Макс Прилепский; 6.4.04

Проект открывается от имени локальной или домЕнной текущей учётной записи пользователя. Имя текущего пользователя можно посмотреть, нажав alt+ctrl+del, а пользователи, созданные внутри проекта с помощью User Administrator к проблеме отношения не имеют.

Re: Макс Прилепский
Zolotoy; 6.4.04

А как можно зайти в папку проекта клиентом если на сервере недобавлена учётная запись клиента, ведь доступ происходит по мелкомягкой сетке?

(требует ввести имя и пароль чтобы увидеть разшаренные ресурсы которые предоставляются службой доступа к файлам и принтерам сетей Microsoft)

Например я делал так: на компьютере клиенте открывал моё сетевое окружение => вся сеть => Сеть Microsoft Windows => группа => WinCC_Server и с этого компьютера запускал файл имяпроекта.MCP
и всё работало, но только в одном сегменте сети :(
а вы как?
Re: Макс Прилепский
Zolotoy; 6.4.04

:)

пользователи, созданные внутри проекта с помощью User Administrator к проблеме отношения не имеют.-всё правильно :)
не внутри проекта а в панели управления => пользователи и пароли

Re: WinCC клиент-сервер. Как конфигурить?
Макс Прилепский; 6.4.04

У нас и клиенты и сервер принадлежат одному и тому же домену, ровно как и пользователи, учётные записи которых используются для входа в систему, существуют в этом домене. Если же станции не находятся в домене и вход в систему производится под локальным пользователем, например, с именем Администратор, то для того, чтобы другие пользователи в сети могли иметь доступ к расшаренным ресурсам станции, необходимо включить локальную учётную запись Гость (по умолчанию она отключена). Управлять локальными пользователями можно, запустив lusrmgr.msc

Re: WinCC клиент-сервер. Как конфигурить?
ser; 6.4.04

Я все делал читая "GettingStartedr.pdf" для версии 5.0 а у меня установлена V6.0, может быть сдесь собака зарыта. Ведь дпи создании проекта появилось 3 пункта "Single-User", "Multi-User" и "Client proect"(что это такое)

Re: WinCC клиент-сервер. Как конфигурить?
ser ; 6.4.04

Вопрос к

>Попробуй добавить в свойствах >сервера сдедующие приложения:
>CCUsrAcv.exe (воткнуть галку в >project directory)
>CCCSigRTServer.exe
>CCLBMRTServer.exe
>(startup => Additional >Tasks/Applications)
>Диск:\Siemens\WinCC\bin

не понял, как это сделать поподробнее, если можно

Re: WinCC клиент-сервер. Как конфигурить?
ser; 6.4.04

Ни как не могу победить:"The configured server is not available. Do you want to open project using the local computer as the server"

Re: ser
Zolotoy; 7.4.04

Это для версии 5.х, вроде как в 6.х тоже самое...

Открыть проект, он обязательно должен быть Multi-User! далее переходим на Computer, справа открывается список клиентов если таковые есть и сервер.
Жмём на сервере свойства и переходим во вкладку "Startup" далее Additional Tasks / Applications жмём add...
приложения находятся: Диск:\Siemens\WinCC\bin
<


text

WinCC клиент-сервер
Александр ОАО"Северсталь"; 7.7.04

Листал форум но внятного ответа не нашёл, возможна ли работа Сервера и клиента в разных рабочих группах, или даже доменах, где в полном имени компьютера есть точка, которая в WinCC ну не как не пишется. Если возможно то как. Заранее спасибо

Re: WinCC клиент-сервер
Горлов Евгений; 7.7.04

Уважаемый Александр, на АО Северсталь планируется только один домен severstal.severstalgroup.com ,куда сейчас загоняются уже существующие ПК из разных доменов. Возможно существование рабочих групп, но тогда именуйте их без точек.

Re: WinCC клиент-сервер
Александр ОАО"Северсталь"; 7.7.04

Уважаемый Евгений, по моей информации в домен severstal.severstalgroup.com загоняют все компьютеры кроме технологических. А за инфу спасибо, попробую.


text

WinCC пример
lomlom; 21.10.04

Начинаю работать с WinCC v5.Изучаю документацию.Но хотелось бы посмотреть реально работающий небольшой проект, как и что надо делать правельно .

За ранее благодарен.
Shiha2@yandex.ru
Re: WinCC пример
Маслов Дмитрий; 21.10.04

Для начала посмотрите Demo-проект, который присутствует на диске с WinCC.

Re: WinCC пример
lomlom; 22.10.04

Да я его просмотрел и изучил и много подчерпнул но там нет связи с тегами реального процесса.И демо пример это одно, а вот на реальном примере это другое.Есть практичная сторона вопроса.

За ранее благодарен.<


text

WinCC&VBS
Sergey; 4.8.04

Поставил у себя WINCC c SP1 нужно написать функцию на VBS реакцию на нажатие кнопки чтобы там я не писал даже вставляю просто комментарий при сохранении пишет что ошибок не найдено на тутже пишет закоментируйте

все не правельные операторы. В чем дело?
Re: WinCC&VBS
GorA; 4.8.04

Рекцию на нажатие кнопки в WinCC лучше делать в Graphics Designer, вызывая свойство кнопки и выбирая вкладку Events. И далее, например,MOUSE-Mouse Action и выбрать C-action.

Re: WinCC&VBS
Sergey; 4.8.04

Но мне надо именно VBS!!!

Re: WinCC&VBS
Маслов Дмитрий; 4.8.04

Все отлично работает в VBS-скриптах.

Либо Вы где-то делаете ошибку в синтаксисе, либо криво установлена WinCC. Чтобы определить точно, попробуйте написать какой-нибудь простой скрипт (лучше взять из примера в WinCC Information System), например состоящий из следующей одной строчки:

HMIRuntime.Tags("Tag1").Write 6

Если компилируется и работает, значит раньше Вы что-то делали неправильно. Если и скрипт из примера не работает, значит криво установлена WinCC. А вообще я проверял работу VBS-скриптов на WinCC 6.0, WinCC 6.0/SP1, WinCC 6.0/SP2 - нигде проблем не было.
См. http://www.wincc.ru

Re: WinCC&VBS
Sergey; 6.8.04

Спасибо вопрос снимается криво была поставлене WINCC после переустановки WINDOWS и WINCC все пошло нормально


text

WinCC, VC++ 6.0 и COM-объекты
Людмила; 4.5.04

В документации по WinCC 5.2, есть примеры как получить значения тегов и отправить измененные через таблицы Excel. Но мне надо все это сделать через VC++ 6.0. Нигде не могу найти описание библиотеки типов для WinCC-шных объектов OLE автоматизации, чтобы использовать в своей программе директиву #import. Может кто знает где или как????

Re: WinCC, VC++ 6.0 и COM-объекты
Маслов Дмитрий; 4.5.04

Вам в VC++ принципиально надо получать/записывать теги именно через OLE? Если нет, то это можно без проблем сделать, используя функции ODK. Просто подключаете нужную библиотеку и используете функции DMGetValue/DMSetValue. Если надо - пишите по мылу, вышлю пример.

P.S. WinCC версии 5.2 не бывает :)
Re: WinCC, VC++ 6.0 и COM-объекты
Людмила; 5.5.04

ODK-это дорого, пока таких денег не заработали. VC++ - это почти даром.

Если бы кто-то поделился... пакетом я не отказалась.
Re: WinCC, VC++ 6.0 и COM-объекты
Людмила; 5.5.04

На счет WinCC 5.2 я извеняюсь, не на ту кнопочку нажала ;((, прошу читать в первой строчке WinCC 5.1

Re: WinCC, VC++ 6.0 и COM-объекты
Маслов Дмитрий; 5.5.04

Использовать функции ODK в принципе можно, не устанавливая сам ODK. DLL-ки, в которых содержатся эти функции, вместе с WinCC ставятся...

Re: WinCC, VC++ 6.0 и COM-объекты
Людмила; 5.5.04

Почему в принципе? Есть какие-то проблемы? Дмитрий, скинула Вам на мыло просьбу на счет примера.

Re: WinCC, VC++ 6.0 и COM-объекты
Маслов Дмитрий; 5.5.04

Проблема в том, что описание этих функций поставляется только с ODK :)


text

WinCC. Рукотворный Process Controled Archiving
Дмитрий; 21.10.04

Господа. Возможно ли в WinCC 5 (да и 6) записать быстроменяющиеся значения (~200ms) воспользовавшись Process Controled Archiving TagLogin'a (PLC 315 и функции SFB37 в нем естественно нет). Значения пишутся периоически - раз в 15сек ~80 значений одного параметра. Если возможно то как это сделать? В документации структура такого DB расписана, но как инициировать запись непонятно. Возможно есть другой подходящий способ записи в архив быстро меняющихся значение. Поделитесь знаниями. Спасибо.


text

WinCC:Архивный сервер
B; 14.10.04

Есть три сервера, на которых запущены приложения, и один сервер с PowerPackArchive 512-1500. Как можно забирать тэги в архивный сервер с других серверов, помимо OPC?

Re: WinCC:Архивный сервер
Маслов Дмитрий; 17.10.04

Рекомендуемый Сименсом способ "server-to-server communication". Настраивается так же, как и клиент-сервер:

1. Создаете проект серверов 1-3, создаете на них пакет серверных данных.
2. Создаете проект сервера архивации, загружаете на нем серверные данные всех трех серверов. После этого добавляете теги этих серверов в архив.
См. http://www.wincc.ru


text

WinCC
Сергей Н.; 2.11.04

Кто знает есть ли WinCC Information System на русском языке??? Или придётся довольствоваться английской версией?

Re: WinCC
Андрей; 2.11.04

WinCC Information System - на русском вряд ли. Но есть документация по отдельным редакторам на русском

(WinCC_GettingStarted_V6_r.pdf,
WinCC_V6_r.pdf,
WinCC6_ArchivingSystem.pdf,
AlarmLogging_V502_r.pdf,
TagLoging_V502_r.pdf,
GraphicsDesigner_V502_r.pdf и т.д.)
Re: WinCC
Сергей Н.; 2.11.04

Это я видел.Просто мне нужна документация по VBA, желательно подробная...


text

WinCC
Костя; 27.12.04

Подскажите ответ

WinCC Server входит в стандартный пакет WinCC 6.0 Sp2 или это отдельная Софтина и где ее взять?
Спасибо.
Re: WinCC
Л. Шерешевский; 27.12.04

Вообще-то Server входит в состав WinCC, но для того, чтобы его использовать, Вам придется приобрести у Siemens соответствующую авторизацию. Заказной номер 6AV6371-1CA06-0AX0.

См. Центр компетенции WinCC

Re: WinCC
Юрченко Владимир; 27.12.04

Опция WinCC Server ставится с основного CD WinCC, а для работы необходима отдельная лицензия. Cмотрите в кратком описании, там есть заказные номера для большинства опций, в том числе и для WinCC Server:

См. http://www.automation-drives.ru/as/download/ascat/simatic_hmi/wincc/10_WinCC_r.pdf

Re: WinCC
костя; 28.12.04

Да все поставил и софт и лицензии создал проект как Сервер и Kлиент но клиент не может связаться с сервером

Re: WinCC
Чистяков Дмитрий ОАО СеверСталь; 28.12.04

А компьютер (его сетевое имя) в проекте написано правильно?

Пользователь со станции клиентской прописан на сервере?
А он входит в группу HMI?
Re: WinCC
костя; 28.12.04

О каком пользователи идет речь Windows или регистрация WinCC как пользователь Windows то я на сервере являюсь администратором и на машине клиента тоже администратор

Re: WinCC
Михаил; 29.12.04

Нужно, что бы в проекте была прописана клиентская мишина в списке компьютеров.

А так же, необходимо чтобы был прописан пользователь с необходимыми правами в User Administrator<


text

WInCC+ActiveX
KAV; 20.9.04

Люди!!! Если не жалко, вышлите к.-н. демку WInCC+ActiveX (если можно с Си и VBS). А то чего-то ничего не понятно. В частности интересует ListView.

Заранее благодарен.
См. http://kav_ua

Re: WInCC+ActiveX
USV; 1.10.04

А что, получается вставлять свои

ActiveX в WinCC?
Re: WInCC+ActiveX
KAV; 1.10.04

Для USV.

Да<


text

WinCC+Simatic-400H
KAV; 6.5.04

Что нужно для подсоединения WinСС-станции к контроллеру S7-400H со стороны компьютера? (soft, etc.)Где это можно прочитать? Если можно - поподробнее.

Re: WinCC+Simatic-400H
Alex G.S.; 7.5.04

Здесь и прочитать: http://automation-drives.ru/as/support/documentation/ Про WinCC ужас как много и подробно написано. Из дополнительного софта нужен Softnet. М.б. софт для сетевой карты, если она от Siemensa.

Re: WinCC+Simatic-400H
Маслов Дмитрий; 7.5.04

Совершенно не согласен с предыдущим ответом.

Для соединения с S7-400H Вам понадобится коммуникационный процессор фирмы Siemens (например, CP-1613), лицензия S7-REDCONNECT на каждый компьютер, который должен соединяться с H-контроллером, и лицензия на опциональный пакет к Step7 для конфигурирования H-контроллеров (6ES7833-2AC01-0YA0) на инженерную станцию. И уж что точно не понадобится - так это Softnet, т.к. сетевые карты сторонних производителей применяют только для обычных контроллеров, а не для резервированных!
Вообще процедура такая - ставите Step7+WinCC совместимых версий (например, Step7 5.1 и WinCC 5.1, или Step7 5.2/5.3 и WinCC 6). Сначала Step7, потом WinCC. При установке WinCC обязательно установите AS-OS engineering (по умолчанию не ставится).
Затем ставите опциональный пакет для H-контроллеров + все лицензии. В Step7 надо сконфигурировать H-контроллер (см. каталог S7-400H на диске с русской докуметацией Siemens, возьмите в ближайшем представительстве). Затем надо добавить PC-станцию, сконфигурировать соединение с ней и сделать перенос данных в WinCC (см. файл IntegrationS7.pdf на диске с английской документацией Siemens).

Честно говоря, я не знаю документа, в котором вся эта процедура расписывалась бы по шагам от начала до конца (но это не значит, что такого документа нет).
Re: WinCC+Simatic-400H
Nick Gashevsky; 11.5.04

Не согласен частично с предыдущим ответом. Обычная сетевая карта (у нас от Intel) работает прекрасно с Н-системой (и STEP и WinCC). Проверено.

Re: WinCC+Simatic-400H
Михайлин Сергей; 11.5.04

Уже давно на эту тему я ФАК написал. Вот здесь по ссылке. Там все написано, что нужно для такой коммуникации.

См. Тырк

Re: WinCC+Simatic-400H
Харгелия Олег, ЗАО "Искра-Энергетика"; 11.5.04

Вроде как в последних версиях Step7 конфигурирование H-контроллеров является стандартной функцией не требующей установки дополнительного пакета

Re: WinCC+Simatic-400H
Константин Власкин; 16.5.04

Как вы считаете на сколько целесообразно в подобной конфигурации дублировать ещё и серверы, которые будут принимать данные непосредственно от H-системы. Имеется ли программное обеспечение для реализации подобного "кластера", чтобы для рабочих мест оператора переключения master/slave как на уровне контроллеров, так и на уровне серверов происходили незаметно.

Re: WinCC+Simatic-400H
Маслов Дмитрий; 17.5.04

Если у Вас используется архитектура клиент-сервер (т.е. используется WinCC-сервер и WinCC-клиенты), то резервирование сервера является крайне желательным, поскольку ПК является значительно менее надежным по сравнению с контроллером, а при отказе сервера все клиенты потеряют возможность наблюдения и управления процессом. Для резервирования серверов WinCC используется опция WinCC/Redundancy. При ее использовании все клиенты автоматически переключаются на резервный сервер при отказе основного.


text

WinCC5 обнуление лог файла
Евгений; 20.5.04

WinCC5 как и WinCC4 построена на базе данных Sybase.

Средствами Sybase (Репликация) организовываем синхронизацию отдельных таблиц в разных проектах.
Репликация основана на анализе лог файла базы данных.
В WinCC4 эта схема абсолютно работоспособна. При попытке реализации ее в WinCC5 выяснилось, что примерно раз в час лог файл обнуляется, что в свою очередь вводит в ступор репликацию.

Есть ли возможность заставить WinCC5 не обнулять лог файл?
<


text

WinCC6 и Резервирование
Сергей; 26.7.04

Здравствйте!

Помогите п-та. Хочу использовать Резервирование. Какую лучше взять ОС-2000Server или 2003Server?
И как настроить резервирование (репликация) на SQL Server2000 при условии, что в базу пишу сам, без TagLogginga?

Re: WinCC6 и Резервирование
Nick Gashevsky; 27.7.04

ОС по-моему все равно какую для данного применения(работает и под 2000Prof)

Ручками наверно придется синхронизировать. (у меня при записи в User Archive запись синхронизируется по внешнему тегу, т.к. он общий для обеих станций WinCC.<


text

Wincc6.0 +CD-R/CD-RW = ???
Сергей; 1.2.04

Здравствуйте!

Подскажите, пожалуйста, как в версии 6.0 произвести копирование (запись) базы проекта из Run-Time на CD-R/CD-RW.
Что есть заменой ф-ции Storage?

Спасибо!
Re: Wincc6.0 +CD-R/CD-RW = ???
Маслов Дмитрий; 2.2.04

В WinCC 6.0 возможности опции Storage реализованы в базовом комплекте Tag Logging. Просто при настройке быстрых и медленных архивов надо установить флажок "Activate backup", и сегменты архива на уровне файлов будут копироваться по указанному Вами пути в указанное Вами время.

Можно, конечно, настроить копирование сразу на CD-R, однако я Вам рекомендую сначала настроить копирование на другой носитель (например, диск другого сервера), т.к. это более надежно (болванка может оказаться сбойной), а потом, вручную или с помощью командного файла, записывать скопированные сегменты архива на CD-R.
См. статью о подсистеме архивации WinCC 6.0


text

WinCC6.0 и OnlineTableControl
Сергей; 21.4.04

Подскажите, господа, как я могу менять ширину колонок в таблице.

Спасибо
Re: WinCC6.0 и OnlineTableControl
Юссссер; 21.4.04

Когда щелкаешь по таблице появляется окно где есть пункты типа "присоединить тэги к таблице" а ниже можно посмотреть список тэгов, так вот наведясь на тэг, справа внизу кнопка Свойства, там и ищи.

Re: WinCC6.0 и OnlineTableControl
Сергей; 21.4.04

Спасибо за ответ, но что-то я этой кнопки там не нашел...

Re: WinCC6.0 и OnlineTableControl
Маслов Дмитрий; 22.4.04

Предыдущий ответ, видимо, касался редактора отчетов. Там действительно можно поменять ширину колонок для таблицы тегов.

А вот в OnlineTableControl (который используется в графическом редакторе), похоже, ширину колонок поменять не получится. Вы можете задавать там только точность отображения даты/времени и значений тегов. В зависимости от этой точности ширина колонок подберется автоматически.

Если Вас что-либо не устраивает в стандартной таблице, Вы можете создать собственную. Описание того, как это сделать, с примером проекта, приводится в документации WinCC Configuration Manual.<


text

WinCC6.0SP1 Tag Logging
Михаил; 24.12.03

Друзья

Есть проблема почемуто Tag Logging
тоесть архивирование в WinCC6.0 SP1 не работает. А все тоже самое делаю в WinCC6.0 без SP1 все работает.
Может подскажет кто нибудь
в чем они отличаются
Re: WinCC6.0SP1 Tag Logging
Goodvin; 24.12.03

Чем отличаются не скажу, но у нас проект, сделанный в WinCC6.0 без SP1 работал под SP1 и сейчас работает под SP2. Есть конечно косячки, но в общем пашет.

Re: WinCC6.0SP1 Tag Logging
Nick; 12.1.04

Наблюдал похожую картину. Tag Logging остановился "сам по себе" и так же "сам по себе!" заработал (часов этак через десять шаманства с бубном)Что произошло - не знаю.

2Goodvin
Eugene; 15.1.04

А где уважаемый Гудвин раздобыл SP2 для WinCC 6.0? Его ведь еще нет в природе.

Re: WinCC6.0SP1 Tag Logging
Goodvin; 16.1.04

Имелось ввиду PCS7 v6.0 SP2 :)

а WinCC там новая, вернее дополненная (HF1).<


text

WinCC6.0SP1 и региональные настройки
Сергей; 29.6.04

Здравствуйте!

Подскажите как можно сделать так, чтобы при английском языке в RunTime в Wincc6.0 SP1 диалог ввода имени пользователя и пароля и т.п. системные экраны отображались по РУССКИ???
Также интересно как сделать так,чтобы элемент управления Календарь не зависил от регионального языка в системе, т.е. при англиском языке в настройках, месяцы отображались по русски.
Подскажите, пожалуйста...
Спасибо
Re: WinCC6.0SP1 и региональные настройки
Л. Шерешевский; 29.6.04

Ответ на первый вопрос: переименуйте соответствующие ресурсы ***rus.lng в ***enu.lng, заменив оригинальные. Хотя я не понимаю, зачем Вам при этом нужно оставлять в RT английский язык.

<


text

WinccOpc & SaabTankmaster OPC server
Ruslan; 8.10.04

Проблема необычная. Есть стандартное программное обеспечение "Saab tank Master" - собирает и конфигурирует информацию с уравнемеров. Мы читаем с него данные через OPC из WinСС. Недавно заменили РС на котором работал Saab. После этого не можем настроить связь Wincc и Saab-а по ОРС. Все установки сделаны. Другими клиентами мы видим SaabTankmaster OPC server, более того мы его видим и из WinСС (OPC item manager). Однако при запуске WinСС - статус ТЭГов -no conection. В чем может быть проблема? Дополнительно: все компьютеры находятся в домейне, имя нового компьютера такое же как и было до этого.


text

wincc-server на win2000pro....вопрос
Andrey; 23.6.04

Будет ли работать wincc-server (многопользовательская система (решение клиент-сервер)) под win2000pro(хотя в описании требуется win2000server)и только 1 wincc-client тоже под win2000pro??? весьма интересует, а если нет - то почему...

Re: wincc-server на win2000pro....вопрос
Сергей; 23.6.04

Все будет работать без проблем. Проверено!

Re: wincc-server на win2000pro....вопрос
Чистяков Дмитрий ОАО СеверСталь; 24.6.04

Только будет ограничение количества клиентов до двух.

Re: wincc-server на win2000pro....вопрос
Andrey; 24.6.04

а если чисто теоретически поставить 3 го клиента - он что работать не будет?

в смысле, чем обусловленно ограничение..
Re: wincc-server на win2000pro....вопрос
roma; 25.6.04

У нас подключаются 4 клиента, все работает, но периодически стали возникать проблемы. А именно, то станция не загружается, ссылаясь на неправильное указание пути до расположения проекта, то замедление при чтении данных с сервера. Данную проблему решили изменив скорость обмена данными на 100 Мбит/с + обеспечением чтения картинок локально с самих клиентов.

Re: wincc-server на win2000pro....вопрос
Andrey; 25.6.04

roma

хм...а если не секрет, как обеспечить чтение картинок локально с клиентов?
Re: wincc-server на win2000pro....вопрос
roma; 28.6.04

Файлы *.pdl из каталога GraCS твоего проекта на сервере скинь в папку Siemens\WinCC\Bin\PDLCache\ на клиенте.

Смысл при загрузке поекта с сервера и чтении файлов - картинок WinCC сначала проверяет наличие *.pdl файлов в указанном выше каталоге. Если они там отсутствуют, происходит обращение к серверу WinCC.
Re: wincc-server на win2000pro....вопрос
roma; 28.6.04

Забыл предупредить, при изменении *.pdl файлов в проекте, необходимо на клиенте сохранить изменнения, т.е. переписать снова редактированные картинки.


text

Windows 2003 Server
Эдуард; 9.9.04

Здравствуйте! Скажите, пожалуйста, встанет ли WinCC 6.0 SP2 и, соответственно Microsoft SQL Server 2000 SP3, на Windows 2003 Server? Кто нибудь ставил? Какие при этом были затруднения?

Re: Windows 2003 Server
Л. Шерешевский; 10.9.04

См. обсуждение этой темы в форуме и ссылку.

http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1082095706&year=2004
См. Compatibility list for WinCC and Windows

Re: Windows 2003 Server
Александр Андрющенко; 10.9.04

Вообще-то в SP2 обещали поддержку Windows 2003. Но у меня и без SP работает. Кстати, всего того, что уже писали насчет WINCC instance - недостаточно. Инсталлировать SQL "чистый" бесполезно (и WINCC instance здесь не при чём) - сименсовский setup производит дополнительные настройки SQL-сервера. Без них WinCC выдает ошибку при открытии/создании проекта. Кто-то здесь уже писал про это и даже предлагал список этих настроек. Я же сделал проще: Сименсовский setup SQL-сервера (..Components/SQLServerData/setup.exe) выдает при запуске, что, дескать, "Cluster Services is installed" и - на выход. Всё, что необходимо сделать - удалить (на время инсталляции SQL) "ClusterInstallationState" из ветки реестра HKLM/Software/Microsoft/Windows NT/CurrentVersion/Cluster Server.


text

А В VBS МОЖНО ЛИ ГЛОБАЛЬНЫЕ ПЕРЕМЕННЫЕ КАК В С????
Миша; 21.10.04

Можно ли объявить как нибудь глобальные переменные в VBS значение каторых будет сохранятся? (навроде глобальных переменных в С)

если да, то где и как их объявлять и потом декларировать?<


text

А КАК ДОБРАТЬСЯ ИЗ C-СКРИПТОВ ДО ACTIVE-X КОМПАНЕНТОВ???
Миша; 16.8.04

Вот например есть некий актив-Х компанент и я хачу использовать его свойства и методы в скрипте (не стандартные каторые есть в пропертях) а те каторые нуно вызывать. как поиметь указатель на объект акив-Х????

например в VBS это так:
dim s
set s = ScreenItems.Item("aaa")
<ну и делаем с aaa че хатим>

а как в С это выглядит???
Re: А КАК ДОБРАТЬСЯ ИЗ C-СКРИПТОВ ДО ACTIVE-X КОМПАНЕНТОВ???
Маслов Дмитрий; 16.8.04

Методы Active-X объектов, размещенных на PDL-картинках, можно вызывать из С-скриптов в WinCC, как в следующем примере:

#include "apdefap.h"
void OnClick(char* lpszPictureName, char* lpszObjectName, char* lpszPropertyName)
{
#define GetObjectA GetObject

__object *obj = NULL, *pic = NULL, *ocx = NULL;
obj= __object_create("PDLRuntime");
if(!obj)
{
printf("obj = NULL\r\n");
return;
}
pic = obj->GetPicture("NewPdl0");
if( pic == NULL){
__object_delete(obj);
printf("pic != NULL\r\n");
return;
}
ocx=pic->GetObject("OLE Control1");
if( ocx == NULL){
printf("ocx = NULL\r\n");
__object_delete(obj);
__object_delete(pic);
return;
}
ocx->AboutBox();
__object_delete(obj);
__object_delete(pic);
__object_delete(ocx);

}
См. http://www.wincc.ru


text

А как проверить корректность проекта?
Михаил; 5.9.04

Вот хотелось бы узнать как можно проверить корректную работоспособность проекта (ну там всякие ан всякие утечки памяти, и т.п.)

И какие критерии нужно проверять вообще
Re: А как проверить корректность проекта?
Дмитрий; 6.9.04

Утечка памяти это как утечка мозгов? Куда она стекает?

Re: А как проверить корректность проекта?
GorA; 6.9.04

С помощью симулятора

Re: А как проверить корректность проекта?
Павел Кобелев; 7.9.04

Оценить корректность и оптимальность использования памяти можно с помощью Reference Data


text

Аварийное сообщение
Прокопенко Вера; 14.4.04

Скажите, пожалуйста, как можно получить имя тега, вызвавшего аварию? В фунции gmsgfunc.fct нужно сделать обработку пришедшего сообщения. Просмотрела функции ODK, но нужной не нашла.

Re: Аварийное сообщение
Маслов Дмитрий; 14.4.04

В функцию gmsgfunc.fct передается номер сообщения. По номеру сообщения можно выбрать строчку из таблицы сообщений в базе данных проекта, там есть идентификатор тега, по которому срабатывает сообщение. По идентификатору тега можно определить его имя (например, через таблицу тегов в базе данных проекта).

Можно сделать проще - завеcти для сообщения служебный текстовый блок, который не будет отображаться в окне сообщений, и на этапе конфигурирования вписывать туда имя тега. А значение текстового блока сработавшего сообщения можно получить в функции gmsgfunc.fct с помощью функций ODK.<


text

Автозапуск проекта WinCC
Michon; 10.12.04

Не работает автозапуск проекта WinCC 5.1 Насколько я понял, это происходит из-за слишком долгой загрузки сетевого окружения. Проект начинает грузиться до того, как появится иконка сетевых подключений.

Если проект закрыть/открыть или просто подождать завершения загрузки сети, то все работает. Система Win2000
Что можно с этим сделать?
Re: Автозапуск проекта WinCC
Александр Родин, ООО "Нева Электрик"; 10.12.04

А вы чем автозапускаете проект ?

По идее, если пользоваться утилиткой из WinCC-шного набора Autostart, то все стартует как надо, потому что она запускается уже после загрузки всех драйверов и системных приложений. Да и не должно на нее влиять, если вдруг сеть позже загрузилась.
Re: Автозапуск проекта WinCC
Павел; 11.12.04

На форуме немецкого Сименса, лежит архивчик как раз для таких ситуаций. Он содержит бат файлик, и утилитку wait.exe. Смысл все этого в следующем: вы кидаете в автозапуск этот бат файл, который запускает утилитку, которая делает заданную вами задержечку в секундах, затем батничек запускает автостарт проекта, либо через стандратный либо по расширению файла. какой вы сами впишите. Смысл всего этого огорода - сначала вы имеете паузу во времени и даете системе полностью загрузиться, а потом уже и запуск WInCC. На законный вопрос, где это лежит - законный ответ не помню, но надо искать на ФОруме.


text

Автоматизация работы в WinCC RC
Эдуард; 18.7.04

Здравствуйте! Извините, пожалуйста, что обращаюсь к вам, просто больше не к кому обратиться. А ваше мыло я узнал из форума по WinCC.

Не подскажите, как в WinCC 5.1 (6.0) сделать так, чтобы в режиме разработки CS при нажатии мышкой на объекте появлялось мое окно? Мне это нужно для того, чтобы быстро конфигурировать мои объекты в режиме разработки. Поясню конкретнее на примере другого SCADA-пакета iFIX 3.0. Так вот в этом пакете можно было создавать «Динамо» следующим образом:
1) рисовался какой-нибудь объект, например задвижка.
2) У этого объекта, как и у любого были методы Edit (вызывался при клике на объекте в режиме разработки) и Click (вызывался при клике на объекте в режиме исполнения)
3) В метод Edit писалась строчка (Visual Basic) появления нашего окна
4) В этом окне отображалась информация из БД Access по всем объектам
5) В этом окне мы могли выбрать номер задвижки и все теги, привязанные к задвижке, заменялись автоматически тегами для нужной задвижки
6) Таким образом, мы указываем номер задвижки в окне и все теги автоматически меняются на нужные.
Мне нужно подобное сделать в WinCC. Т.е. мне нужно автоматизировать замену тегов (задвижка имеет 5-6 тегов) в объекте.

Заранее огромное спасибо!

Re: Автоматизация работы в WinCC RC
Л. Шерешевский; 19.7.04

Во-первых, в WinCC 6.0 появилась возможность создания собственных макросов VB для среды разработки. Во-вторых, в WinCC есть другие, более простые и элегантные способы быстрой привязки сложных объектов к тегам:

1. Использование префиксов тегов и структурных тегов.
2. Использование технологии модульных кадров.
3. Использование диалога группового редактирования связей с тегами.
Re: Автоматизация работы в WinCC RC
Svetozar Yolov; 23.7.04

Dear Эдуард,

In WinCC v5.X for that purpose you can use Dynamic Wizard. But it is diffult to test you scripts. It's diagnstic is VERY poor. The explanation for Dynamic Wizard you ca find in WinCC Information System - examples too.
As Mr. Шерешевский said in WinCC v6.0 VBA can be used. You can create form etc.

Best regards,
smi<


text

Авторизация WinCC
ppp; 7.5.04

Имею лицензию на WinCC v6.0 RC64K (A9WRC460), но требуется более чим 512 архивных тегов. Что для этого надо сделать?

Re: Авторизация WinCC
Юрченко Владимир; 7.5.04

Требуется авторизация WinCC V6.0 Archive Powerpack. Заказные номера приведены в http://www.automation-drives.ru/as/download/ascat/simatic_hmi/wincc/02_3-WinCC_r.pdf на стр.14 и в http://www.automation-drives.ru/as/download/ascat/simatic_hmi/wincc/11_WinCC_r.pdf на стр.4


text

Администрирование
beginner; 13.5.04

непонятки...Назначаем в User Administrator пользователей со своими правами..Как например запретить для определенных пользователей какие-либо возможности (например ENABLE для кнопки выхода из RT и т.д.)Заранее спасибо за советы

Re: Администрирование
Маслов Дмитрий; 13.5.04

1. В User Administrator создаем новое право доступа (Table/Insert Authorization) 'Выход из RT'. Создаем пользователя 'Вася'. Даем ему это право.

2. В Graphics Designer у кнопки выхода из RT устанавливаем свойство Authorization в 'Выход из RT'. В результате все пользователи, кроме Васи, не будут иметь возможности нажать эту кнопку.
RTFM!
Re: Администрирование
beginner; 14.5.04

for Маслов Дмитрий:

большой THANKS....<


text

Администрирование
Роман; 25.11.04

Как сделать так, чтобы при запуске режима RunTime запрашивались сконфигурированные в User Administration авторизации........

Re: Администрирование
Чистяков Дмитрий ОАО СеверСталь; 26.11.04

Что за авторизации?

Вернее что Вы под этим термином подразумеваете?
Если это авторизации (ключи) на программные продукты, то ни как.
А если Вы имеете в виду имя пользователя и пароль, то создайте в User Administrator пользователей и в перёд.<


text

Алексей
Пароль для OP7; 29.1.04

Утерян пароль для OP7PP, панель работает в режиме Online. Как его можно восстановить (пароль 100 не подходит)? Сохранность проекта в памяти OP не критична.


text

Анимация трубопровода
Сергей Н.; 12.11.04

Кто знает как лучше сделать анимацию трубопровода, т.е. анимация движения жидкости по трубопроводу???

Re: Анимация трубопровода
А. Ковальчук; 13.11.04

"Бегущие огни" на ёлке видел??? :-)

В PLC создаёшь программку, выводишь 3-5 тегов, подбираешь подходящую картинку, располагаешь в нужных местах и ... ну - дальше знаешь! :-)<


text

аплоад с панели
sasha; 23.8.04

какие панели поддерживают функцию аплоада OP->PG


text

Архив сообщений в WinCC 6.0.2.0
WinCCist; 7.7.04

Господа, вопрос к тем, кто юзает WinCC 6.0.2.0. Столкнулся с проблемами:

1) Не все сообщения пишутся в архив, хотя у всех стоит аттрибут архивирования. Т.е. сообщение приходит, а в архив не заносится (смотрел в SQL Server).
2) В Alarm Logging убрали разделение на кратковременный и долговременный архивы, вопрос к какому типу корректней привязывать элемент AlarmControl?
P.S. Пробовал на разных компьютерах. Проект сделан в PCS7.<


text

архивирование бинарных тегов
Максим Елхов; 24.6.04

Была такая фишка в пятой версии - при занесении бинарного тега в TagLogging можно было присвоить сообщение для каждого состояния ентого тега. В шестой версии про это написано только в хелпере, а на самом деле куда-то делося :( Это у меня одного так, или проблема глобальная?


text

Архивирование по расписанию
Юрий Оганесян; 1.10.04

WinCC v.6

Задача - проще некуда: Заархивировать значение тэга один раз ровно в 15-00 ежедневно.
Самому стыдно - не могу сделать..
Смотрел TagLogging - не нашел такой возможности.
В Global Script запускал TLGInsertArchivDataA - она возвращает 1, а в таблице ничего нет. Кстати, она 1 возвращает, даже если имя архива намеренно неправильно указано... Может кто-нибудь работающим кодом поделится?

Re: Архивирование по расписанию
Лёха; 1.10.04

В Global Script есть настройки для global Actions в закладке связи с тригером. Там можно настроить выполнение своей функции 1 раз в день в назначенное время.

Re: Архивирование по расписанию
Руденко Алексей Невисс-комплекс; 1.10.04

У каждого архивируемого тэга есть настройки и в них есть такие свойства как Start and Stop Evens, а для них можно задавать тэги управления...

Удачи...
Re: Архивирование по расписанию
Дмитрий; 4.10.04

Как сделать стандартными средствами ??? По Start and Stop Events пишит дважды. Хочется - выставил бит в PLC в WinCC заархивил значение и сбросил бит.

PS Скриптом пишет, это понятно. Но хотелось сделать столь тривиальную задачю стандартными средствами.
Re: Архивирование по расписанию
Nick Gashevsky; 4.10.04

Если можешь изменить программу в контроллере, я бы в 15-00 изменял значение тега в контроллере, а в ВинСС настроил архивирование по изменению тега.

Re: Архивирование по расписанию
Роман; 4.10.04

Обсуждалося уже

http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1095224651&year=2004<


text

Архивы WinCC
Системотехника; 11.10.04

В процессе архивирования в базу данных MS SQL WinCC записывает время с опозданием на 7 часов от системного времени сервера при часовом поясе Алматы. Эта же разница во времени проявляется при поиске тегов, когда выводится таблица с описанием найденных тегов (поле Last Change). При этом, настройка Computer Propertties/ Parameters/ Time base for the clock shown in RunTime = Local time zone.

Вопрос: Что нужно сделать, чтобы исправить это положение с искажением времени?
<


text

Архивы МР370
Юрий Оганесян; 27.4.04

Добрый день!

Довольно интересная особенность:
После аварийной перезагрузки (отключение питания) WinCE фиксирует ошибку в файле архива *.csv (размер неправильный) и предлагает исправить сама, или оставить как есть. Самое неприятное, что: 1) спрашивает это на англ. языке; 2) спрашивает это для каждого файла архива в отдельности, а главное 3) НЕ ЗАПУСКАЕТ ProtoolRT, ПОКА НЕ ОТВЕТИШЬ. Как с этим БОРОТЬСЯ ???? Как представлю состояние операторов, которые не могут посмотреть свою любимую мнемосхему получив вместо этого какое-то сообщение со словом "incorrect", плохо становится. Неужели вообще придется от архивов на панели отказываться ????

Re: Архивы МР370
Юрченко Владимир; 27.4.04

Попробуйте перегрузить образ операционной системы (в разделе ProTool\Utility\Prosave\Images лежат образы для панелей).


text

БД Access и WinCC
HiEd; 24.9.04

Re: БД Access и WinCC
Yrok; 27.9.04

Если ты хочешь иметь доступ к данным из WinCC к Accesss то как мне кажется лучше написать DLL, например на MS VC6++ с использованием DAO или ODBC и оформить всё это в функции которые возвращали тебе уже готовые данные.

Дело в том что оформлять всё это в WinCC гиморрой полный, поэтому как мне кажется лучше будет так.
Хотя может быть Я не прав
Re: БД Access и WinCC
LostAngel; 28.9.04

В библиотеке ODK есть функции для работы с базами данных. Вызываешь их из скриптов - и все дела.

Писать свою DLL - больше работы проделать придётся.
Re: БД Access и WinCC
Nick Gashevsky; 1.10.04

Можно воспользоваться встроенным VBS и получать данные через OLE DB провайдера или DAO или ODBC.


text

БД RunTime вылетает если размер превышает 4Гб
Роман; 23.9.04

Re: БД RunTime вылетает если размер превышает 4Гб
Юрий Оганесян; 28.9.04

v.5 OR v.6 ???

i.e. (Sybase OR MS_SQL)

Re: БД RunTime вылетает если размер превышает 4Гб
Владимир; 6.10.04

Нужно чтоб диски были NTFS обязательно. 4ГБ это ограничение FAT32


text

Безымянные сообщения в Alarm Logging
Евгений; 3.11.04

После компиляции операторской станции в Alarm Logging'e появляется очень много безымянных заготовок сообщений; неужели, чтобы их все сделать нормально читаемыми нужно искать все автоматически сгенерированные FB-блоки и в их свойствах писать HelpText, или есть другой способ??

Re: Безымянные сообщения в Alarm Logging
Маслов Дмитрий; 6.11.04

Скорее всего у Вас в SIMATIC Manager указан один язык проекта, а в WinCC - другой. В результате SIMATIC Manager при компиляции операторской станции создает тексты сообщений для того языка, который в нем указан, а Alarm Logging отображаются тексты для языка, указанного в WinCC (а эти тексты никто не создавал).

См. http://www.wincc.ru


text

бесполезности для wincc
Alexis; 7.10.04

См. http://www.density.newmail.ru


text

Библиотека WinCC ITagSet2Master Type Library (ITagSet2Master.dll)
SIS; 23.3.04

ПРограммирование для WinCC на VB.

После установки WInCC в системе регистрируется библиотека WinCC
ITagSet2Master Type Library (ITagSet2Master.dll), которая содержит классы MasterCtl, ITagSet2, ITagSet2DataProvider (доступны среди прочих компонентов)
Для чего она нужна?
Как работать с этой библиотекой?
Где можно найти информацию по этим классам?

Re: Библиотека WinCC ITagSet2Master Type Library (ITagSet2Master.dll)
Юрченко Владимир; 23.3.04

В Help'ах WinCC есть описание объектной модели для VBA (VBA.chm) и VBS (VBSscripts.chm). Вот там искать и надо.

Re: Библиотека WinCC ITagSet2Master Type Library (ITagSet2Master.dll)
SIS; 23.3.04

to Юрченко Владимир:

Где бы их достать? Может вышлите на мыло?
Re: Библиотека WinCC ITagSet2Master Type Library (ITagSet2Master.dll)
Юрченко Владимир; 23.3.04

Ну если Вы установили WinCC, то у Вас должен быть CD. Осталось найти папку Documents/English и найти там эти файлы (если помощь не ставили на HDD).

Re: Библиотека WinCC ITagSet2Master Type Library (ITagSet2Master.dll)
SIS; 23.3.04

to Юрченко Владимир:

В на моем СD в каталоге Documents/English этих файлов нет:(
Re: Библиотека WinCC ITagSet2Master Type Library (ITagSet2Master.dll)
SIS; 23.3.04

Может все-таки намылите, уважаемый Юрченко Владимир:)

Re: Библиотека WinCC ITagSet2Master Type Library (ITagSet2Master.dll)
SIS; 24.3.04

Может кто-нибудь вышлет эти файлы на мыло,а? плиззззз...


text

Блокировка работы в WinCC
Игорь Одесса; 30.6.04

Необходимо заблокировать работу пользователя в runtime WinCC,до тех пор пока пользователь не произведет авторизацию. Устанавливать св-во(authorization) для каждого объекта не хочется-объектов уж очень много, да и не все его(св-во) поддерживают. Может кто сталкивался

с подобной задачей?
Re: Блокировка работы в WinCC
Л. Шерешевский; 1.7.04

Один из вариантов следующий. Поверх всей рабочей области располагаете окно заставки (можно с красивыми картинками и надписями). Разрешение на его закрытие даете только нужным пользователям. Если нужно дать возможность просмотра, закрываете рабочую зону прозрачным прямоугольником, оставляя доступными только навигационные кнопки и кнопки регистрации и закрытия этой прозрачной прослойки.

Re: Блокировка работы в WinCC
Игорь Одесса; 1.7.04

В том то все и дело, что мне надо видеть что происходит на экране, но исключить возможность управления оператором, если закрыть окно rectangle и установить его прозрачным, управление "сквозь" него все равно доступно :(.

Неужели как в Windows нельзя реализовать - модальное окно с запросом пользователя и пароля для разрешения работы? (именно для всей системы)
Re: Блокировка работы в WinCC
Маслов Дмитрий; 2.7.04

Для того, чтобы нельзя было упралять, но можно было все видеть, разместите прямоугольник поверх изображения. Не надо делать его прозрачным. Вместо этого поставьте ему свойство Dynamic Filling = Yes и Dynamic Level = 0.

Re: Блокировка работы в WinCC
Игорь Одесса; 5.7.04

Ничего не изменилось - эффект как при Transparent. Может еще что-то надо ?

Re: Блокировка работы в WinCC
Игорь Одесса; 5.7.04

Извиняюсь, все работает, забыл поставить Rectangle на передний план.

Маслов Дмитрий, огромное спасибо !
Re: Блокировка работы в WinCC
Александр Родин, ООО "Нева Электрик"; 5.7.04

А что вам мешало на управляющих элементах просто вписать скрипт с проверкой логинов/паролей?

См. ODK->User Administrator.

Очень много полезных функций... Кстати, скрипт можно было написать один групповой, т.е. выделить все необходимые элементы, и в свойстве Display у группы написать необходимый скриптик. Можно, как вариант, сделать стартовый экран с логином, при правильном вводе которого перейти на другие экраны.
Re: Блокировка работы в WinCC
Игорь Одесса; 5.7.04

Написать скрипт, даже групповой ;) енто конечно можно было,и даже без ODK,но... в данном случае решение предложенное г-ном Масловым просто,быстро по времени реализации и очень эффективно.Cкриптик правда, все равно писать придется, так как блокировку привязываю к Login/Logout.


text

Большая панель
Anonimus; 11.8.04

Подскажите, пожалуйста, где можно найти информацию по большим панелям (например 1x1.5 метра) для отображения информации, с возможностью коммуникации по MPI или Profibus

Re: Большая панель
Чистяков Дмитрий ОАО СеверСталь; 11.8.04

А что имеешь в виду под большой панелью и с какой степенью защиты хочется? Отображать - графику или цифровые значения или псевдографику.

Как вариант, можно купить ЖК панель (или плазму) и подключить её к компьютеру (можно и к PC S7 Box для компактности).
А вот ссылка на фирму, производящую табло для промприменения и под любые параметры по заявке покупателя. Само собой и базовые варианты у них есть.
http://www.schauf-gmbh.de/

Re: Большая панель
GorA; 12.8.04

Еще есть фирма Siebert

http://www.siebert.de/english/displays/large/e_large.php
<


text

В Alarm Control в поле Status ничего нет
Evgen; 9.7.04

У меня такая проблема. Вдруг в Alarm Control при выводе сообщений перестали выводиться символы состояния сообщения в поле Status (по умолчанию для класса сообщений Error это +, -, *, +/-). Удаление/добавление системного блока Status не помагает. Что делать?

Re: В Alarm Control в поле Status ничего нет
Nick Gashevsky; 12.7.04

Попробуй удалить Alarm Control и создай его заново. Должно помочь.

Re: В Alarm Control в поле Status ничего нет
Evgen; 12.7.04

Не помагает: раньше пробовал, сейчас тоже. Более того, был такой глюк. После добавления аварийных сообщений для аналоговых тегов AlarmLogging упорно не хотел сохранять проект: пришлось нажать "No", чтобы WinCC нормально завершил работу. После открытия проекта добавленные сообщения остались, то настройка по каждому сообщению (теги и биты тегов статуса, квитирования, текст сообщения, место аварии - не сохранились. Думаю переустановить WinCC (v6.0). ОС - 2000Pro SP3


text

В Alarm Control в поле Status ничего нет
Evgen; 9.7.04

У меня такая проблема. Вдруг в Alarm Control при выводе сообщений перестали выводиться символы состояния сообщения в поле Status (по умолчанию для класса сообщений Error это +, -, *, +/-). Удаление/добавление системного блока Status не помагает. Что делать?


text

в Web Navigator 1.1 не работает GetTagDWord
Роман; 22.11.04

Кто-н. сталкивался с тем, что в Web Navigator v. 1.1 не срабатывает ф-ия GetTagDWord? С чем это м.б. связано?


text

В WinCC Projects - пусто
Александр; 24.6.04

Что есть:

Windows XP SP1 со всеми updates;
Microsoft local network;
WinCC 6.0;
Лицензии Server и NetCC Client;
Multiclient project;
CCAgent работает нормально (вроде).
Почему в My Computer / WinCC Projects
ничего нет ?
Re: В WinCC Projects - пусто
Назаров Дмитрий; 25.6.04

А что там должно появиться? Проект писать надо :-)

Re: В WinCC Projects - пусто
Александр; 25.6.04

Проект есть. И он виден в WinCC Projects. Но ни значков, ни заголовков таблицы, ни контекстных меню нет. Проблемы русификации?

Re: В WinCC Projects - пусто
VGenn; 26.7.04

При установке WinCC в поле "Name" укажите имя своего компа из сетевой идентификации


text

Вадим Печёрских
Медленное открытие экранов; 9.12.04

Привет, всем!

Возникла тут проблема. Есть проект, работающих на двух серверах. К каждому серверу подключено по одному клиенту. Данные поступают с 5 (пяти) PLS S300.
При открытии экранов очень долго обрабатываються значения тегов. Т.е., на экране есть порядка 30 графических объектов (клапана). К каждому объекту привязано от 5 до 7 тегов, используемые для отображения состояния объекта. Обработка выполняеться с помощью динамических диалогов. При открытии экрана, картинка появляеться быстро, а сама обработка происходит медленно занимая до 15 сек. После открытия экрана, при изменении тегов, обработка на экране происходит практически мгновенно.
Все обрабатываемые теги приведены к одному циклу. Связь с PLC осуществляеться через Industrial Ethernet. Сеть 100 Мб/сек. В качестве серверов и клиентов используються машины PIV 2400, 1 Gb ОЗУ. На экранах нет циклических скриптов.
Используеться WinCC 6. На клиентах включен PDL Cashe.
Отключали пару контролеров из пяти, скорость обновления заметно увеличилась.
Кто чего посоветует?
Re:
Вадим Печёрских; 9.12.04

Сорри, перепутал тему и автора :) Пора домой идти.

Re: Вадим Печёрских
Eugene; 16.12.04

а что мешает не привязывать ТЭГи, как это делают практически все, а написать свой Action, в котором будет считываться необходимая информация (например Raw-тэгами), а затем распаковываться и распределяться по необходимым графическим объектам (SetProp... и т.д.). При таком подходе Все прекрасно работает и не тормозит. Просто не надо лениться и немного попрограммить :)


text

Вкачать теги с Excell в WinCC
Игорь Одесса; 5.7.04

В Excell овской таблице расписаны все теги Системы, перебивать вручную более 500 тегов - облом, может кто знает как автоматически "загнать" теги с Excell в WinCC.

Re: Вкачать теги с Excell в WinCC
Nick Gashevsky; 5.7.04

Экспортируй файл Excel в формат CSV.

Запусти WinCC TAG Export Import.

PS. Для начала экспортируй из WinCC в Excel несколько тегов, чтобы посмотреть структуру файла, и подправь свой.

Re: Вкачать теги с Excell в WinCC
Игорь Одесса; 5.7.04

Честно говоря я уже разобрался как через configuration tool.Все равно спасибо.

WinCC Tag Export Import - утилита? Или как?
<


text

Внешние переменные в Global Scripts
Роман; 26.5.04

Подскажите, есть ли какие ограничения у WinCC в GlobalScripts на количество внешних переменных.

Просто надо оперделиться в какую сторону двигаться: или с использованием внутренних тагов или внешних переменных.

Re: Внешние переменные в Global Scripts
Александр Родин, ООО "Нева Электрик"; 26.5.04

А какие в глобал-скрипт внешние переменные ? Тригеры или используемые внутри скрипта тэги ?

Вообще было когда-то ограничение на объем самого текста скрипта - не более 5000 знаков (или строк ?... не помню точно). Насколько это ограничение действует в 6-й версии - эт наверное в описании есть... RTFM.. :)
Re: Внешние переменные в Global Scripts
Роман; 26.5.04

Re: Внешние переменные в Global Scripts
Александр Родин, ООО "Нева Электрик"; 26.5.04

Я так полагаю, что ограничений на их использование нет. Хотя еще для 4-й версии в описании стояла маленькая сносочка, что использовать объявление extern следует с большой осторожностью.. :) Лучше пользуйтесь внутренними тэгами. Или у вас какие-то безумные объемы передавать надо ?

Re: Внешние переменные в Global Scripts
Роман ; 26.5.04

Ну где то около тысячи

Re: Внешние переменные в Global Scripts
Александр Родин, ООО "Нева Электрик"; 26.5.04

М-да... не слабо... :)

В принципе можете попробовать внутренние структурные теги... я их использовал, когда делал сосбственную систему архивирования... но у меня общее количество переменных было чуть-чуть поменьше... штук 800 всего.. :)
Re: Внешние переменные в Global Scripts
Роман ; 26.5.04

Да мне в принципе не для архивирования. Данные я получаю не через внешние таги. И удобнее бы было передавать их из скрипта в скрипт через внешние переменные. И для отображения удобно.

Re: Внешние переменные в Global Scripts
Александр Родин, ООО "Нева Электрик"; 26.5.04

Да я так думаю, что ничего зазорного не будет, если вы попробуете сделать так, как задумываете... :) Тем более, что в описании строгого ограничения на это нет. А потом запостите сюда результат... всем будет интересно.. ;)

Re: Внешние переменные в Global Scripts
Владимир; 3.6.04

Я как то размахнулся и создал огромный массив переменных... так мне WinCC 5.1 сказала - размер памяти под глобальные переменные не больше 64К (сегмент, как я понял) и все, обломись.

пришлось поужаться )))
Re: Внешние переменные в Global Scripts
Роман; 7.6.04

С внешним массивом[600] на WinCC 6.0 все нормально работает.

Re: Внешние переменные в Global Scripts
Владимир; 12.6.04

Вот ошибка. Win CC 5.1

error (008c) : global variable space is restricted to 64K<


text

возможен ли автостарт с определнным акаунтом?
Viktor; 22.9.04

Есть:

2 сервера (дублируют друг друга)
2 клиента.
Задача:
Добавить еще один компьютер как клиентский, но на нем сделать так, чтобы можно было залогиниться в winCC только определенным пользователем.
Возможно ли это сделать не изменяя проекта.
Или возможно ли производить автозапуск проекта WinCC с определенный пользователем.
Re: возможен ли автостарт с определнным акаунтом?
Чистяков Дмитрий ОАО СеверСталь; 23.9.04

Да, возможно.

Для этого надо строчку с запуском автостарта перенести из раздела реестра
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
в раздел для пользователя
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run]
Re: возможен ли автостарт с определнным акаунтом?
Viktor; 24.9.04

Немного неправильно я описал вопрос.

Надо чтобы АВТОЛОГИН происходил в WinCC а не в Windows.
Выглядить должно так
пользователь запускает компьютер, логинится в Windows. И WinCC автоматически запускается и автоматически залогиневается в WINCC с определенным акаунтом.
Re: возможен ли автостарт с определнным акаунтом?
smi; 28.9.04

да ето вазможно използвай

PwSilentLogin("потребителко име", "пароль");

ето от ODK<


text

Возможно ли из OP37 сделать OP37Pro?
Eugene Sergeev; 7.5.04

Есть на неком объекте ОП37. При модернизации заказчик хочет ОП37Про.

Можно ли как-нибудь это сделать? (поставить винт, винду, протул - все это по кускам имеется)
<


text

ВОЗМОЖНО ЛИ ПЕЧАТЬ ОТЧЕТА ,,,,
ALEX; 5.11.04

ВОЗМОЖНО ЛИ ПЕЧАТЬ ОТЧЕТА ТОЛЬКО, КОГДА СТРАНИЦА А4 ПОЛНАЯ.

ИЛИ ПЕЧАТЬ ОПРЕДЕЛЕННОГО КОЛИЧЕСТВА СТРОК.
Re: ВОЗМОЖНО ЛИ ПЕЧАТЬ ОТЧЕТА ,,,,
Маслов Дмитрий; 6.11.04

Если речь идет о печати архива сообщений, то можно написать скрипт, который будет делать выборку количества тех сообщений из базы данных, которые планируется печатать. Если количество больше нужного, то запускать печать, иначе - нет.

См. http://www.wincc.ru


text

Возможность ведения архива в MSSQL
vv; 4.6.04

Можно ли вести архивы данных тегов в БД MSSQL или только в c-base???

Re: Возможность ведения архива в MSSQL
Nick Gashevsky; 4.6.04

В WinCC6.0 используется БД MSSQL для ведения архива данных тегов.

Re: Возможность ведения архива в MSSQL
vv; 4.6.04

Так я смотрел, что все архивы хранятся в файлах на дисках, но не в БД

Re: Возможность ведения архива в MSSQL
Nick Gashevsky; 4.6.04

А где ж им еще быть, как не на диске?

Re: Возможность ведения архива в MSSQL
vv; 4.6.04

Архивы храняться в БД?


text

Вопрос о выборке значений из TagLogging
Pasha; 10.12.04

Если кто-нибудь сталкивался с извлечением данных архивных тегов, подскажите.

Задача состоит в выборке СУММЫ значений за определенный промежуток времени. Оператор должен выбирать сумму по группе либо, по некоторым тегам из группы. Как это контролировать?
Re: Вопрос о выборке значений из TagLogging
Александр Родин, ООО "Нева Электрик"; 10.12.04

Тут наверное уже у старых участников форума в глазах рябит от подобного вопроса.. :)

Ищите в ODK описание функций TLGGetArchivData и TLGGetArchivDataEx.

буквально неделю назад писалось...
http://www.automation-drives.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1101886830&year=2004<


text

Выборка значений тегов из БД
Сергей; 28.12.04

Здравствуйте!

необходимо другим приложением забирать значения тэгов из архива TagLogging'a. На базу законнектился, читаю данные с таблицы TagUncompressed - никакого эффекта, чистая таблица. Подскажите в чем трабл? Может не ту таблицу читаю?
Re: Выборка значений тегов из БД
Маслов Дмитрий; 29.12.04

См. обсуждение данной темы в форуме:

http://www.automation-drives.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1096372537&year=2004

и пример:
http://www.automation-drives.ru/as/products/doc.php?l1=SIMATIC%20HMI&l2=WinCC&l3=doc
<


text

Где взять Demo WinCC
Александр; 6.4.04

Подскажите pls

Re: Где взять Demo WinCC
Роман Абзаев; 7.4.04

В любом ближайшем бюро.

Re: Где взять Demo WinCC
Александр; 7.4.04

Под словом бюро понимается региональный представитель Siemens ?

Re: Где взять Demo WinCC
Роман Абзаев; 8.4.04

И он тоже.


text

Где взять WinCC 6 SP2 ?
Малкон; 25.11.04

СУБж.. 8((.

См. http://revda.biz


text

Где взять информацию про Simatic OP3
Алексей; 21.6.04

У меня накрылась OP3, выдаёт "$551 AS addres 2 not possible" и дальше не на какие мои действия не реагирует.

Re: Алексей
Чистяков Дмитрий ОАО СеверСталь; 21.6.04

Если с кабелями всё в порядке и программа в в ней не сбилась, то сгорел приёмопередатчик.

А программку пробовал заново закачать в OPэху?
А описание смотри здесь
http://www4.ad.siemens.de/WW/news/en/1142799
Re: Чистяков Дмитрий
Алексей; 22.6.04

А нельзя ли ссылочку на сайт, где документация на русском языке? И подскажи каким образом заново закачать програмку? Вот скажем на Simatic 170, с названием могу попутать, т.к. было давно, там программу переустанавливал с помощью флешки, а как здесь пока непонятно.


text

Где взять примеры
Андрей; 13.10.04

Может кто подскажет, где взять примеры

к "WinCC Руководство по конфигурации"(тома 1-3)
Re: Где взять примеры
Маслов Дмитрий; 13.10.04

Надо найти это руководство не в pdf, а в chm формате - туда включены примеры. У меня такое есть только на английском языке для WinCC 5. Московский Siemens выпускал двойной диск SIMATIC HMI-SCADA и там на втором диске (WinCC V5 Options) было это руководство с примерами. Так что спросите у них, или, если сильно нужен какой-нибудь один пример, могу выслать.

См. http://www.wincc.ru

Re: Где взять примеры
~BurAn~; 14.10.04

Стучись сюда -> 253235


text

Где взять протокол MODBUS для WinCC???
Миша; 2.3.04

Подскажите где его взять? может он называется как то по другому??? но когда добавляю протокол в проек, то в списке его нет :-(

Re: Где взять протокол MODBUS для WinCC???
Назаров Дмитрий; 3.3.04

А какая версия WinCC?


text

Где купить OP15-C1?
Walter; 26.3.04

Где можно купить панель OP15-C1(Order code:6AV3515-1MA20-1AA0

)?
Re: Где купить OP15-C1?
Роман Абзаев; 29.3.04

Она поставляется "identified repair only"


text

Где найти SP2 для WinCC 5.0 ?
kip; 16.1.04

Есть лицензионный SP1, на сайте Сименса ничего не нашел

Re: Где найти SP2 для WinCC 5.0 ?
Чистяков Дмитрий ОАО СеверСталь; 19.1.04

SP для WinCC всегда идут не как дополнительный файлик, а полным пакетом. Обратитесь к ближайшему партнёру Siemens.

Re: Где найти SP2 для WinCC 5.0 ?
Чистяков Дмитрий ОАО СеверСталь; 19.1.04

SP для WinCC всегда идут не как дополнительный файлик, а полным пакетом. Обратитесь к ближайшему партнёру Siemens.

Re: Где найти SP2 для WinCC 5.0 ?
Роман Абзаев; 20.1.04

ID 10868418 на Customer Support. но проще обратиться в ближайшее бюро.

См. http://www4.ad.siemens.de/WW/view/en/10868418


text

Где найти стандартные FB
Egorka; 23.6.04

Подскажите! Плц! Где найти стандартный FB для соединения OP-7 в существующий Profibus-DP на S115 CPU 945 + IM 308 C.


text

Где птичку ставить?
Diana; 7.4.04

Насколько я знаю, в окне симатик менеджера перед трансфером можно поставить птичку и тогда при создании дерева в пустые картинки навтыкаются привязанные типикалы тех месмонов, дигмонов и т.д., которых есть в соответствующих папках (ну в смысле те, которые можно потом надергать из @Template). Так вот, где ставить эту птичку?

Re: Где птичку ставить?
Михайлин Сергей; 8.4.04

Эту галку надо ставить в свойствах технологической иерархии в Plant View.

Re: Где птичку ставить?
Diana; 9.4.04

Чего-то не находится...

Re: Где птичку ставить?
Михайлин Сергей; 9.4.04

В Plant View подсветить нужный контейнер или всю иерархию целиком и по правой кнопки мыши выбрать Plant hierachy\Create&Update picture object.

Re: Где птичку ставить?
Diana; 12.4.04

Мне аж прям стыдно!... Нету там этой возможности. Там есть такие строчки:

- Settings...
- Check Consistency
- Open Check Log
- Create Update Block/Icons...
- Open Block Icons Log
- Cancel Assigmet...
А вот той строчки почему-то нету. Может чего надо доставить? У меня PCS7 v6.0+sp2. И отдельно поставленный Step v5.3.
Re: Где птичку ставить?
Strannik; 13.4.04

Вот это круто.

Зачем же отдельно СТЕП то ставить :)
Re: Где птичку ставить?
Diana; 13.4.04

Страннику - если в степе 5.2 были глюки, на которые были многократные жалобы, то компания Сименс постаралась избавиться от них в версии 5.3. Так как я хочу, чтобы на моем компьютере стояла более работоспособная версия, чем та, которую ставили из комплекта PCS7, то я отдельно устанавливаю степ 5.3 версии. Такой подход к программному обеспечению характерен для большинства пользователей Windows. У меня сименовский софт появляется не сказать, чтоб поздно, поэтому я хочу спросить Вас: Вы уже видели установщик PCS с 5.3 версией степа?

А птичка, кстати, нашлась. Тока ставится она в Create Update Block/Icons... Перед этим, правда, надо воткнуть еще одну птичку в свойствах картинки. Функция совершенно беспонтовая.
Re: Где птичку ставить?
Михайлин Сергей; 15.4.04

PCS7 со STEP 5.3 появится в конце апреля. Это будет PCS7 v6.0+SP3

Ставить в состав PCS7 более новую версию софта можно, но иногда очень черевато. PCS7 это набор идеально стыкующихся между собой компонент, а привнесение чего-то другого, пусть даже нового, может притянуть проблемы. Не всегда, но может...
Функция очень полезна если использовать эти стандартные типикалсы для быстрого рисования и привязки тэгов.<


text

Где регистрироваться
KAV; 25.11.04

Кто знает, где нужно регистрироваться,

что бы получить доступ к
www.automation-drives.ru/as/download/
Подскажите пож-та.
Re: Где регистрироваться
Михайлин Сергей; 25.11.04

Это внутренний админский раздел. Доступа туда не предоставляется. Хакать не надо ;-) Софта там не нет.


text

Глюк Graphics Designer WinCC 6
Вадим Печёрских, ; 4.11.04

Привет, всем!

По непонятным причинам слетели теги в динамческих диалогах на объектах. При просмотре диалога в Graphics Designer тег в поле "Expression/Formaula" отсутсвует, однако диалоги отрабатывают в RunTime. В чём причина?
В WinCC 5 такого прикола не наблюдалось.
P.S. Используем WinCC V 6.0 / SP2 HOTFIX 2
Re: Глюк Graphics Designer WinCC 6
Mike; 5.11.04

Глюки усегда возникают в этом ибучим ВинЦЦ :))))

У меня тож постоянно какая то хрень проскальзывает.
Как бороца - НЕ ЗНАЮ (может переустановить все, включая систему)

За че и не лублу этот ВинЦЦ (лучше написать все например на VB или VC++ - там хоть сам сибе казяин)
Re: Глюк Graphics Designer WinCC 6
Макс Прилепский; 5.11.04

Вадик, подобная проблема и у меня была, выражалась в "замирании" отображения. Каким-то образом была нарушена целостность PDL-файла, теперь я после возникновения проблемы и её решения на всякий случай отключаю всякое антивируснуе ПО, осуществляющее проверку файлов "на лету" и по сети клиентом картинки тоже не редактирую, только локально, пока проблема (стучу по дереву :-) )не повторялась...


text

Глюк в WinCC (PCS7 V 6.0+SP1+HF1)
Сергей Никулин; 26.3.04

При работе в 2-хмониторной системе WinCC обнаружил странный глюк. Если открыть один и тот же faceplate на обоих мониторах, а потом при нажатии кнопку "Close" на faceplate'е второго (не основного монитора) монитора, то закрывается faceplate на основном мониторе. Faceplate на втором мониторе кнопкой "Close" никогда не закрывается! Только кнопкой "Х" в правом верхнем углу.

Кто-то уже сталкивался с подобным глюком и как вышел из этой ситуации? Или это ошибка WinCC и надо ждать нового сервиспака?
Заранее спасибо.
Re: Глюк в WinCC (PCS7 V 6.0+SP1+HF1)
Михайлин Сергей; 26.3.04

Прошу прощения, Сергей. А в faceplate'ах какой билиотеки есть кнопка Close. Что-то я не помню...

Или это ваша собственная разработка?
В принципе я не вижу смысла еще в одной кнопке закрытия.
Re: Глюк в WinCC (PCS7 V 6.0+SP1+HF1)
Сергей Никулин; 26.3.04

Пользуемся библиотекой CEMAT. Может это связано с этой библиотекой?

Re: Глюк в WinCC (PCS7 V 6.0+SP1+HF1)
Сергей Никулин; 5.4.04

Большое спасибо за советы и оказанную помощь.

Тему можно закрыть.
Re: Глюк в WinCC (PCS7 V 6.0+SP1+HF1)
Михайлин Сергей; 5.4.04

А что было-то все-таки???

Мини-отчет в студию.<


text

Глюки с GetTagXXX и SetTagXXX
Людмила; 1.10.04

Может ли кто объяснить или дать ссылку где подробно можно узнать про такие дела:

1. Внешний тег получил новое значение, в WinCCExplorer это вижу. В Global Script получаю это значение сначала через GetTagBitWait, значение новое. Затем получаю через GetTagBit - значение старое.
2. Иногда (не всегда) проскакивает такой фокус: в Global Script устанавливаю внутренний тег функцией SetTagFloatWait, тут же проверяю через GetTagFloat, все хорошо, тег установлен. Через примерно 50 сек вызывается другой Action, хочу опять получить тег GetTagFloat, а там старое значение. Ерунда какая-то.
3. Если я вызываю Action по изменению тега, то он вызывается через минуты 2, после изменения тега. Как уменьшить это время?
Заранее спасибо за ответы.
Re: Глюки с GetTagXXX и SetTagXXX
Роман; 4.10.04

Такое может быть если запускаешь несколько скриптов одновременно, проверь.

Re: Глюки с GetTagXXX и SetTagXXX
Людмила; 4.10.04

Да в этот может быть несколько скриптов, но нигде в литературе я не встречала, что количество скриптов должно быть ограничено. Но если присвоится тег не успел, то никакая GetXXX не должна возвратить новое значение. Или я сама должна следить, что бы не было вызвано несколько скриптов одновременно?


text

Господа корефеи WinCC, выручайте!!!
MMM; 10.12.04

Можно ли как нибудь выбрать из UserArchive записи чтобы некоторое поле не повторялось?

В чистом SQL это:
SELECT DISTINCT <поле> FROM <таблица>

а как в CCUATableCtrl это сделать??? там есть поле Filter, только чего-то там это не работает....
Re: Господа корефеи WinCC, выручайте!!!
Александр Родин, ООО "Нева Электрик"; 10.12.04

ну насколько я вообще понимаю работу с фильтрами в Control-ах WinCC, то в них вписываются только атрибуты команд SQL без непосредственно команды. Причем не могу точно утверждать как это в UserArchive реализовано, но вот в AlarmControl-е фильтр явно представляет собой атрибут связки SELECT WHERE.

Re: Господа корефеи WinCC, выручайте!!!
MMM; 10.12.04

ну очень нужно выбрать из UA записи с неповторяющимися именами рецепта... блин...

Re: Господа корефеи WinCC, выручайте!!!
Александр Родин, ООО "Нева Электрик"; 10.12.04

Ну в принципе есть вариант выборки напрямую из базы посредством SQL-запроса, например с помощью dbisql.exe, эт для WinCC 5.1 (к сожалению не в курсе что есть на ее замену в 6-й версии). Можно экспортировать результаты запроса во внешний файл или в какую-нибудь пользовательскую таблицу, а потом организовать вывод данных из файла в WinCC.

Возможно есть другие способы. :)
Вроде как в ОДК есть функции для обработки SQL-запросов.
Re: Господа корефеи WinCC, выручайте!!!
Мифка; 10.12.04

Ну блин всетаки наверное это очень глупо когда есть инструмент, и нельзя воспользоваться обычным SQL запросом для него, а только каким то слабеньким фильтром (поле Filter)

Re: Господа корефеи WinCC, выручайте!!!
Александр Родин, ООО "Нева Электрик"; 10.12.04

Дык фильтр сидит в контроле для обеспечения стандартных выборок. Видимо выборки по сложным критериям к стандартным не относятся и, следовательно, для таких задач существуют другие подходы.


text

Графики WinCC
Василий; 27.10.04

Есть ли такая возможность вывода группы графиков по запросу из RunTime? Например, выбираю какой-нибудь обьект процесса и выводятся все графики которые нужны для него. Как это реализовать?

Re: Графики WinCC
Маслов Дмитрий; 29.10.04

Сделайте по одной картинке PDL на каждый объект, создайте на них все нужные графики, а потом открывайте нужную картинку при необходимости.

См. http://www.wincc.ru

Re: Графики WinCC
Василий; 29.10.04

Дело в том что нужно еще сделать вывод графиков по изделиям. Т.е. изделие сделанное в процессе должно записываться в базу и при его выборе нужно вывести графики(нужные) в то время когда сделано изделие.

Re: Графики WinCC
GorA; 29.10.04

Тогда можно сделать типовую PDL картинку, какой-нибудь ТЭГ идентификатор изделия и по нему выводить данные (графики) в типовую PDL картинку, используя косвенную адресацию и смещение.


text

Групповые сообщения в Alarm Loggin
Шестаков Александр Анатольевич; 28.1.04

При работе с групповыми сообщениями в Alarm Loggin замечена ошибка. Проблема в следующем:

1. Создаем класс с квитированием в этом классе создаем тип.

2. Создаем N-ое количество сообщений подключаем каждое последовательно к битам тега сообщения.

3. Соответвующим образом конфигурируем для тега квитирования.

4. Идем в групповые сообщения. Находим созданный класс и устанавливаем для него в отдельном теге к примеру 0 бит квитирования.

5. Таким образом, при установке данного бита будут квитированы все сообщения принадлежащие данному классу.

А теперь самое ИНТЕРЕСНОЕ.

Генерируем сообщения во всех битах для тега сообщения. Происходит отображение всех сообщений соответственно, а теперь если мы захотим квитировать всех эти сообщения одним махом и установим бит квитирования сообщений данного класса, то по идее должны установиться все биты квитирования в теге квитирования для каждого сообщения. НО ЭТО НЕ ВСЕГДА ПРОИСХОДИТ!!!. Иногда некоторые биты так и не устанавливаются.

Кто-нибуть сталкивался с данной проблеммой, знает в чем причина или может быть это уже исправили в SP2.

Данный глюк проявляется у меня на WinCC 5.1

<


text

Дайте плиз последний каталог
Владимир; 22.7.04

Нужен прайс на рабочие станции и софт WIN CC 5.1 и WIN CC 6.0

Не тот который за октябрь 2003. Ибо прогресс то не стоит на месте и наверняка уже есть более мощные станции чем в каталоге за 2003 год.
Re: Дайте плиз последний каталог
Л. Шерешевский; 22.7.04

См. ссылку.

См. Siemens A&D Mall

Re: Дайте плиз последний каталог
Юрченко Владимир; 22.7.04

Наиболее актуальная информация по промышленным компьютерам находится в файле http://www.automation-drives.ru/as/download/ascat/pc_based/ipc/ipc-konfigurator_rus.zip.

По WinCC 6 смотрите http://www.automation-drives.ru/as/download/ascat/simatic_hmi/wincc/11_WinCC_r.pdf<


text

Дата изменения тега в С-фунции WinCC
Людмила; 8.11.04

Подскажите, пожалуйста, как достать дату изменения тега через С-функции.

И еще, если кто знает, как можно достать неспецефичные свойства внешнего тега.
Re: Дата изменения тега в С-фунции WinCC
Alexis; 9.11.04

Сдается мне в ОДКе нет функций, которые возвращают время последнего изменения тега в RT...

Или Вы имеете в виду дату модификации свойств тега в CS? И что подразумевается под неспецифичными свойсвами внешнего тега?
В принципе, все что касается свойств тега есть в DMCLIENT.H
Ну и всегда можно ручками из таблиц CS-ной базы поднять...
Re: Дата изменения тега в С-фунции WinCC
Людмила; 10.11.04

Да, мне надо именно время последнего изменения тега в RT. В ODK я не нашла. Но ведь в WinCCExplorer показывает дату. Вот я и подумала, может все-таки кто-нибудь сподобился как-то вытащить это время.

Неспецифичные свойства внешнего тега:
есть OPC-сервер и к нему есть свой explorer. Так вот у тега есть набор свойств. Каждое свойство имеет свой ID. Кроме limit High, limit Low еще много. Нужда заставляет попробовать изменять эти свойства не ручками, а программно. Такие свойства, которых нет в самой WinCC, я и назвала неспецифическими.
А что за "таблицы CS-ной базы"?

Re: Дата изменения тега в С-фунции WinCC
Alexis; 10.11.04

На то он и WinCC Explorer... :))

А так как WinCC-евый проект - это в большей своей части просто база данных (Sybase/MSSQL), то в ее табличках можно порыться...
А неспецифичные свойства наверное лежат в какой-то ОРС-шной базе - искать надо...
Re: Дата изменения тега в С-фунции WinCC
Людмила; 10.11.04

Да, мне надо именно время последнего изменения тега в RT. В ODK я не нашла. Но ведь в WinCCExplorer показывает дату. Вот я и подумала, может все-таки кто-нибудь сподобился как-то вытащить это время.

Неспецифичные свойства внешнего тега:
есть OPC-сервер и к нему есть свой explorer. Так вот у тега есть набор свойств. Каждое свойство имеет свой ID. Кроме limit High, limit Low еще много. Нужда заставляет попробовать изменять эти свойства не ручками, а программно. Такие свойства, которых нет в самой WinCC, я и назвала неспецифическими.
А что за "таблицы CS-ной базы"?
<


text

Два разных проекта Тэги одни и те же
Александр; 15.3.04

Господа!!!

Имеется два разных проекта WinCC, на двух машинах.
Вопрос: как мне сделать так чтобы тэги были на одной машине, а другая коннектилась бы к этим тегам по сети?
Re: Два разных проекта Тэги одни и те же
Юрченко Владимир; 15.3.04

Если не подходит конфигурация клиент-сервер WinCC, на второй машине используете OPC channel и связываетесь по OPC с первым проектом.

Два разных проекта Тэги одни и те же
Александр; 18.3.04

...Юрченко Владимир

Спасибо!<


text

Два символа в слово
ion; 15.7.04

Такая трабла.

Создаю внешний тег типа "Text tag 8-bit character set". Указываю адрес, например, DB1 DBW10, Length : 2.
Создаю на экране поле ввода/вывода (I/O Field) и подвязываю тег к этому полю. В поле Data Format: String.
Записываю в это поле два символа, например, 12 и! получаю в контролере
по адресу DB1 DBW10 лежит длина строки, в моем случае 2, а в DB1 DBW12 (!) лежат мои два символа в ASCII кодах.

Подскажите, плиззз, как мне положить два символа в ASCII кодах в тот адрес, который я указываю.
Re: Два символа в слово
sv; 15.7.04

строку надо класть не куда попало, а в тэг с типом данных STRING. в нем как раз эти 2 байта зарезервированы.

Re: Два символа в слово
ion; 15.7.04

э-э-э, а где ж этот тип взять?

при создании нового тега такого типа вроде нету, или я ошибаюсь?
Re: Два символа в слово
ion; 15.7.04

а тип "Text tag 8-bit character set" это разве не стринговый?

он как раз кладет строку из двух символов в два байта, но еще зачем то пишет размер строки в байт:(
Re: Два символа в слово
sv; 15.7.04

WinCC тэг "Text tag 8-bit character set" соответствует тэгу в контроллере "STRING".


text

Две версии WinCC на одной машине
Андрей; 29.3.04

Можно ли на одном компьютере установить две версии WinCC? Требуется поддерживать проекты написанные в версиях 5.0 и 5.2, очень неудобно иметь на одном винчестере две ОС и перезагружаться между ними если возникает небходимость загрузить тот или другой проект.

Re: Две версии WinCC на одной машине
Alexis; 29.3.04

Поставь VMware

Re: Две версии WinCC на одной машине
Nick Gashevsky; 30.3.04

А стоимость лицензии на VMware начальство поймет правильно?

Re: Две версии WinCC на одной машине
Андрей; 31.3.04

VMware использую для этого давно, и даже OPC-сервер почти работает, но мне жалко места на диске - система, Step7, WinCC всё это занимает больше полутора гигабайт, да скорость работы заметно ниже... Я надеялся, что есть способ поставить WinCC в разные каталоги и они бы при этом ещё и нормально работали.


text

Двухмониторный проект WinCC 6
Макс Прилепский; 10.9.04

Недавно перешёл на WinCC 6.0.2.0.

Сейчас разрабатываю проект для двух мониторов. Имею следущую ситуацию: в двух разных и отображаемых одновременно Picture Window отображаю один и тот же PDL с мнемосхемой. Периодически некоторые (но далеко не все ) значения (I/O Fields) и состояния механизмов (тоже стандартные объекты WinCC), привязанных к тегам PLC напрямую либо через Dynamic Dialog на одной из картинок (иногда на левой, иногда - на правой) как бы "замирают", тогда как во втором Picture Window продолжают обновляться. При движении "мышью" "замирание" прекращается, но после некоторого времени, если не двигать "мышь", ситуация повторяется. PLC S7-400 , канал связи TCP/IP. Ошибок связи нет никаких, в log-файлах тоже никаких ошибок работы не зафиксировано. Все теги имеют коды good. Может кто-нибудь уже сталкивался с подобным ? Раньше я работал в WinCC 5.1 , там я таких "фич" не наблюдал... И ещё, ситуация повторяется и при одном подключенном мониторе, на котором отображаются эти Picture Windows, видеокарта "двухголовая" ATI Radeon 9200, драйвера самые свежие. Пробовал отключать аппаратное ускорение и DirectDraw - результатов никаких...
Re: Двухмониторный проект WinCC 6
Маслов Дмитрий; 11.9.04

Сейчас ответить ничего не могу. Однако тоже создаю проект двухмониторный проект (перехожу с WinCC 5.1 на WinCC 6.0/SP2/HF3). Планирую запустить его в ноябре - может, что и выясню до этого времени.

Re: Двухмониторный проект WinCC 6
Макс Прилепский; 13.9.04

Отмечу ещё один момент: при "замирании" отображения некоторых объектов в одном из кадров, для возобновления в нём обновления отображения курсор "мыши" нужно не просто произвольно переместить , а перевести именно в область этого кадра.

Re: Двухмониторный проект WinCC 6
Макс Прилепский; 16.9.04

Двухмониторность оказалась ни при чем. Ошибка крылась в самом PDL-файле, который, по всей видимости, криво сохранился, хотя и открывался редактором нормально, но в RT, тем не менее работал странно. Нарисовал с нуля этот же экран, восстановил динамику объектов, всё пока работает без глюков. Тревожным сигналом о проблеме в картинке явилась информация из Cross Reference, исходя из которой к одному из объектов был привязан несуществующий тег (тег раньше действительно существовал и был привязан к свойству объекта через Dynamic Dialog, но потом удалён, ровно как и привязка). При открытии объекта, на который было указано в Cross Reference, Graphics Designer в Dynamic Dialog показывал другой, существующий, тег. После удаления объекта из картинки в Cross Reference перестал отображаться несуществующий тег, но проблема осталась, поэтому экран пришлось создавать заново.

Таких глюков я доселе не встречал, в версиях WinCC 5.х , в которых я разрабатывал проекты довольно долгое время, пару раз картинки сохранялись криво, но они потом и не открывались в Graphics Designer, он просто вис при их открытии, ровно как и RT.<


text

Демо проекты для ОР
Александр; 30.1.04

Недавно попадались демо проекты для панелей типа ОР170, ОР27, теперь найти не могу, подскажите где искать?

Александр<


text

Диагностический буфер в WinCC???
Anton; 11.11.04

Делал ли кто-нибудь реализацию диагностического буфера в WinCC??

В документации написано "WinCC может отображать сообщения от контроллера, автоматически генерируемые системой диагностики S7, в виде многострочных текстовых сообщений", а как это сделать не знаю, подскажите пожалйста!!!<


text

Диагностический буфер в WinCC???
Anton; 11.11.04

Делал ли кто-нибудь реализацию диагностического буфера в WinCC??

В документации написано "WinCC может отображать сообщения от контроллера, автоматически генерируемые системой диагностики S7, в виде многострочных текстовых сообщений", а как это сделать не знаю, подскажите пожалйста!!!
Re: Диагностический буфер в WinCC???
Михайлин Сергей; 15.11.04

При наличии CPU S7-400 и лишних 400 Евро можно вывести полную информацию о ЦПУ на WinCC с помощью Diagnose Tool CPU. Вплоть до распиновки памяти.

Re: Диагностический буфер в WinCC???
Anton; 15.11.04

Diagnose Tool CPU это отдельное приложение? или что ?

мне нужно только чтоб на WinCC в AlarmLogginge отображались сообщения, которые находятся в диагностическом буфере(с детальным описанием, временем возникновеня и т.д.).
Re: Диагностический буфер в WinCC???
Anton; 15.11.04

Добавлю...

у меня S7-400H
а лишних 400 евро это за что??
Re: Диагностический буфер в WinCC???
Дмитрий; 16.11.04

Если толькл сообщения в аларм , то в CFC когда вставляешь драйвера модуля автоматом вставляются диагностические блоки для модуля, река и CPU и генерируются все необходимые сообщения.

Если PCS то втягиваешь все это дело и банзай, ну а можно создать соответствующие теги и алармы ручками.
Re: Диагностический буфер в WinCC???
Anton; 17.11.04

Я и сделал ручками:

Получаю теги - вермя, код, доп. информацию, потом все это расшифровываю, формирую и вывожу как сообщение в ALarmLogging.
А где должны формироваться сообщения и в каком виде? В строковом или как у меня по каждой OB и по каждому параметру?
Re: Диагностический буфер в WinCC???
Дмитрий; 18.11.04

Если используешь стандартные драйвера канала (при опросе)и работаешь в CFC, то при компиляции будет запрос:

хотите скомпилировать драйвера? Подтверждаешь в результате имеешь дополнительные FB модулей, реков и CPU со своими DB, в которых и находится вся диагностическая информация. Все необходимые для станции данные имеют атрибут S7_m_c и при трасфере они уйдут в теги, а от туда в алармы со своими текстами и т.д.
Re: Диагностический буфер в WinCC???
Alexis; 18.11.04

2 Дмитрий:

А у Вас при RunTime эти сообщения нормально отображается? В смысле подстановка текстовок в поля сообщений вместо, например @4W%t#MOD_1_TXT@? По идее (естно Сименса) текстовки при трансфере должны попасть в WinCC в текстовую библиотеку, но они туда естно не попадают... Языки и в Step-е и в WinCC одинаковые. Может конечно в шестерке этот глюк и исправили, но в пятерке приходилось ручками текстовки и ссылки востанавливать.
Re: Диагностический буфер в WinCC???
Anton; 19.11.04

Дмитрий!!!

Можно по подробнее?
Где взять информацию что за теги формируются?
Re: Диагностический буфер в WinCC???
Дмитрий; 19.11.04

Так! По порядку.

Если забил в STEPе свою текстовку на русском, то чтобы было при трансфере все ОК необходимо в менеджере оставить один язык АНГЛИЙСКИЙ (по умалчанию в русской винде STEP имеет один язык РУССКИЙ), но будет проблема с лобанием мультиязычных проектов (STEPовских).
По поводу поподробнее: изучайте, а лучше пробуйте PCS7!!!Хотя можно обойтись и без него, но нужен необходимый софт (типа CFC)
Re: Диагностический буфер в WinCC???
Anton; 19.11.04

Что такое CFC??


text

Диагностический буфер в WinCC
Антон; 12.11.04

Делал ли кто-нибудь реализацию диагностического буфера в WinCC??

В документации написано "WinCC может отображать сообщения от контроллера, автоматически генерируемые системой диагностики S7, в виде многострочных текстовых сообщений", а как это сделать не знаю, подскажите пожалуйста!!!<


text

Диалоговое окно на Си
ion; 1.9.04

Подскажите, плиз, как из Си скрипта вызвать MessageBox виндовский.

Re: Диалоговое окно на Си
Макс Прилепский; 2.9.04

HWND Handle;

Handle = FindWindow("PDLRTisAliveAndWaitsForYou","WinCC-Runtime - ");
MessageBox (Handle, "Текст в окне", "Текст заголовка окна", MB_OK |MB_ICONEXCLAMATION | MB_SYSTEMMODAL);

В примере, приведенном выше, в родительском окне WinCC Runtime рисуется модальное окно с кнопкой ОК.

int a;
HWND Handle;

Handle = FindWindow("PDLRTisAliveAndWaitsForYou","WinCC-Runtime - ");

a=MessageBox (Handle, "Вы ДЕЙСТВИТЕЛЬНО желаете выйти из режима Runtime ?", "Выход из Runtime", MB_YESNO |MB_ICONEXCLAMATION | MB_SYSTEMMODAL);
if (a==6)
DeactivateRTProject ();

В этом примере рисуется окно с кнопками Yes/No и, если нажата кнопка Yes, выполняется действие.
Re: Диалоговое окно на Си
Михаил; 2.9.04

MessageBox(NULL,"текст","заголовок",MB_OK);

Re: Диалоговое окно на Си
Михаил; 2.9.04

на VBS

MsgBox("сообщение")
Re: Диалоговое окно на Си
ion; 2.9.04

Всем спасибо.


text

Динамическое привязывание свойств и событий
HiEd; 19.9.04

Здравствуйте, эксперты! Подскажите, пожалуйста, как лучше сделать общее окно управления для однотипных объектов в WinCC 6.0 SP2? Например, окно управления для задвижек. В этом окне отображается состояние задвижки и имеются кнопки «Закрыть», «Открыть», «Стоп». В руководстве пользователя приведены примеры для VBA. Можно ли по другому? И как лучше и производительнее?

В InTouch 8.0 это делается просто: свойство и событие можно подвязать к косвенному тегу (такой тип тега имеется - косвенный), а потом при запуске окна управления косвенным тегам присваиваются имена внешних тегов.
Заранее благодарю!
Re: Динамическое привязывание свойств и событий
Миша; 20.9.04

Есть несколько методов:

1. Через TagPrefix
2. Link
3. Через скрипты (в зависимости от имени PictureWindow)

Вобщем делай через TagPrefix!!!
1. Рисуй картинку управления насосом.
2. Связывай на имена тегов (наример stop, start, ...)
3. Втыкай PictureWindow на каждый свой насос, и устанавливай у них TagPrefix в соответствии с именем тага (например nasos1.)
4. Добавь StructureTag для насоса
5. Добавь таги своих насосв (nasos1, nasos2, ...)

че не понятно спрашивай
4. Сде
Re: Динамическое привязывание свойств и событий
Прокопенко Вера; 20.9.04

У нас подобная задача реализована так: при выборе задвижки и нажатии на ней кнопки мыши засылаем во внутренний тег типа Text имя нужной переменной, активизируем окно управления и задаем нужный заголовок этого окна, в котором действие кнопок привязаны к этому внутреннему тегу через Direct Connect используя indirect (косвенная адресация). И еще очень удобно использовать tag prefix, но для этого нужно заранее предусмотреть соответствующее именование всег тегов. Если нужно, можем прислать сами *.pdl.

Re: Динамическое привязывание свойств и событий
Прокопенко Вера; 20.9.04

По поводу предыдущего сообщения. А зачем на каждый насос свой PictureWindow? Ведь преимущество TagPrefix именно в том, что можно обойтись одним окном, а не плодить однотипные окна. И с косвенной адресацией мы тоже используем одно окно.


text

Динамическое создание объекта в Runtime
Hied; 21.10.04

Здравствуйте! Подскажите, пожалуйста, как в режиме Runtime WinCC 6.0 SP2 динамически создать объект (CheckBox) на рисунке PDL при открытии этого рисунка в объекте PictureWindow.

Заранее благодарю.
Re: Динамическое создание объекта в Runtime
Маслов Дмитрий; 21.10.04

В большинстве случаев можно заранее создать объект, а в режиме Runtime только управлять его видимостью (свойство Display).

Однако если Вам _действительно_ нужно динамически создавать объекты, то можно воспользоваться функцией ODK:
PDLCSNewObjectEx
См. http://www.wincc.ru


text

Для изучения проект WinCC кто-нибудь сбросьте
Chainic; 1.10.04

Для изучения кто-нибудь сбростьте, если не жалко, проект какой-нибудь не слишком навороченный.

Re: Для изучения проект WinCC кто-нибудь сбросьте
~BurAn~; 1.10.04

Можно через ICQ: UIN 253235

Мне не жалко... Но у меня обычный проэкт за 80 Мб... Как тебе его заслать? Может лучше инфы в pdf на русском (524 стр.)? Хватит для изучения...

Re: Для изучения проект WinCC кто-нибудь сбросьте
Роман; 4.10.04

На дисках с ВинСС есть демо проекты, там посмотри.

Re: Для изучения проект WinCC кто-нибудь сбросьте
Chainic; 5.10.04

На самом деле.Что-то в голову самому не пришло.Посмотрю.Спасибо


text

Документация на ODK (бесплатно)
Александр Козлов; 3.2.04

Помогите найти документацию на ODK

Re: Документация на ODK (бесплатно)
Зубарев; 27.2.04

Она идет вместе с пакетом ODK

только на английском<


text

документация на ODK v 6
KBI; 27.4.04

На китайском сайте Siemens есть английская документация по ODK v6.

http://www.ad.siemens.com.cn/download/manual/docu_pdf/as/hmi/Manual/ODK%20V6.zip
а также SDK и т.д.

Тяжело разобраться с иероглифами, но можно.
Линки на английском.
Попробуйте
http://www.ad.siemens.com.cn/download/manual/as.asp
http://www.ad.siemens.com.cn/download/manual/
<


text

Документация на русском языке по s7-200 opc server v 1.0
Евгений; 10.9.04

Здравствуйте!

Хочу разобраться в подключении SCADA WinCC с контроллером S7-200. На форуме уже поднимался данный вопрос и указывалось что для этого требуется opc server v 1.0. А для того чтобы разобраться в opc server`е v 1.0 нужна документация на русском языке. Подскажите пожалуйста. А если можно, то как связываtтся WinCC с S7-200 через opc server v 1.0. Спасибо.<


text

Документация по OPC на русском.
VaS; 14.1.01

Существует ли документация по созданию OPC серверов (и клиентов) на русском? Или, может быть, книга.

Документация на русском или английском на TD200?
АО мороз; 26.6.04

Нужна документация на русском или английском на TD200 для фризера frigus400(TetraPak).

Re: Документация по OPC на русском.
Nick Gashevsky; 30.6.04

Посмотрите на http://www.ipi.ac.ru/lab43/lopc-ru.html


text

Документация по PCS
Вадим Печёрских; 24.11.04

Привет, всем!

Где можно взять сабж. Особенно интересует в части разработки проекта в части WinCC. Описание стандартных фэйсплайтов, функций и т.д. А то это новое чудо Siemmens'a создаёт кучу экранов и функций, а копаться в каждой функции просто нет времени.
Re: Документация по PCS
Чистяков Дмитрий ОАО СеверСталь; 24.11.04

А слабо было выьрать в "Быстром переходе" "PCS7"?

:-)
См. http://www.automation-drives.ru/as/products/doc.php?l1=SIMATIC%20PCS7&l3=doc


text

Доступ к базе архива из C++Builder или Delphi
ion; 28.9.04

Подскажите, плиз, в какую базу и какую таблицу архивируются теги TagLogging'ом, чтоб можно было из C++Builder'а или Delphi (или VB) вытащить архивные теги.

Re: Доступ к базе архива из C++Builder или Delphi
Руденко Алексей Невисс-комплекс; 29.9.04

Попробуй через ODBC соединение - там все поймешь...

Re: Доступ к базе архива из C++Builder или Delphi
ion; 29.9.04

я знаю как подсоединяться.

Вопрос в том:

к чему подсоединяться?!
к какой базе и таблице базы?!

где лежат архивные теги?
Re: Доступ к базе архива из C++Builder или Delphi
Alexis; 30.9.04

Версия то WinCC какая интересует?

А самый простой вариант получения данных TLG - это использовать TLGGetArchivDataEx.
Re: Доступ к базе архива из C++Builder или Delphi
Nick Gashevsky; 30.9.04

Посмотри пример на http://www.automation-drives.ru/as/products/doc.php?l1=SIMATIC%20HMI&l2=WinCC&l3=doc правда на VC++6, но на C++Builder подправить нетрудно+почитай ODK

Re: Доступ к базе архива из C++Builder или Delphi
Руденко Алексей Невисс-комплекс; 30.9.04

При соединении через ODBC - на выбор в списке доступных баз предлагается выбор - и там есть строчка с названием твоего проекта WinCC и датой его создания с приписками RT еще что то.

Так вот выбрать надо RT, после этого нужно выбрать таблицу этой базы данных...
При использовании Delphi и её компонента ADOTable или ADOQuery есть вариант посмотреть все содержание базы - покопайся - найдешь...
Ежли уж совсем не в моготу, то открой эсель (MS Office который) и через вкладку "данные" -> "импорт внешних данных"-> "создать запрос" а там он тебе высветит что есть в этой базе и т.д.
Удачи
Re: Доступ к базе архива из C++Builder или Delphi
Руденко Алексей Невисс-комплекс; 30.9.04

Хотя в 6-ой версии там лежит лишь информация о названии тегов и т.д. - но я думаю если покопаться то, можно найти...

Метод научного тыка еще никто не отменял...
И не забудь запустить ВИНСИСЮ а то тебя не допустят к базе...
Re: Доступ к базе архива из C++Builder или Delphi
ion; 30.9.04

Re: Доступ к базе архива из C++Builder или Delphi
Alexis; 30.9.04

Открываешь RT-шную базу, в таблице AMT берешь нужный DSN (либо для Slow либо для Fast), открываешь базу с нужным DSN и копаешься в табличках Archive (имена переменных и их ID), TagCompressed (сжатые данные Fast-ов) и TagUncompressed (данные Slow архивов).

То что сжато - тебе прийдется ручками расжать :))
Re: Доступ к базе архива из C++Builder или Delphi
Павел Кобелев; 1.10.04

Для доступа к архивным тегам есть WinCC OLEDB Provider for Archives. Драйвер устанавливается вместе с WinCC

Re: Доступ к базе архива из C++Builder или Delphi
ion; 5.10.04

> Открываешь RT-шную базу, в таблице > > AMT берешь нужный DSN (либо для Slow > либо для Fast), открываешь базу с

> нужным DSN и копаешься в табличках
> Archive (имена переменных и их ID),
> TagCompressed (сжатые данные Fast-ов)
> и TagUncompressed (данные Slow
> архивов).
> То что сжато - тебе прийдется ручками > расжать :))

А вот в архивах в этих почему то пусто :(
Re: Доступ к базе архива из C++Builder или Delphi
ion; 5.10.04

> Открываешь RT-шную базу, в таблице > > AMT берешь нужный DSN (либо для Slow > либо для Fast), открываешь базу с

> нужным DSN и копаешься в табличках
> Archive (имена переменных и их ID),
> TagCompressed (сжатые данные Fast-ов)
> и TagUncompressed (данные Slow
> архивов).
> То что сжато - тебе прийдется ручками > расжать :))

А вот в архивах в этих почему то пусто :(
Re: Доступ к базе архива из C++Builder или Delphi
ASH; 5.10.04

А ведь действительно, эти таблицы пусты. В некоторых базах в TagCompressed лежит непонятно что (названия полей - ValueID, Timebegin, Timeend и BinValues мне ну ничего не говорят, также как и содержащаяся в этой таблице информация), ну да ладно, допустим там действительно надо, как сказали "ручками разжимать". Но таблица TagUncompressed, вроде бы действительно та самая необходимая таблица (поля Timestamp и Realvalue говорят именно об этом) всегда пуста!!! Хотя в рантайме я же с помощью ТрендКонтрола вижу, что теги нормально архивируются и где-то ведь они сохраняются! В Си-Билдере я без проблем получаю доступ с помощью ADO-компонент к любой винсисишной базе, но вот где хранятся архивированные теги и как получить к ним доступ - я так и не понял:( Кто может - помогите, плиз!

Re: Доступ к базе архива из C++Builder или Delphi
Alexis; 6.10.04

Дык в RT-шной базе в таблице AMT лежит как минимум три DSN-а на базу с алармами, на базу Fast-архивов и на базу с Slow-архивами.

Если хотим Slow, то берем нужный DSN, открываем базу и копаемся в табличке TagUncompressed - сопоставление ID и ИмяПеременной в табличке Archive.
Если хотим Fast, то ... и копаемся в табличке TagCompressed - но тут ситуация хуже - данные лежат в бинарном поле (max 2Kb) - с наскока расжать я не смог, но попытаться попробуйте - в шапке (размер не помню) точно есть время, а в теле лежат 32битные floatы и на них накручен сдвиг: 33 байтные отрезки - 8 float-ов + байт, первый флоат чистый, второй получается сдвигом оставшихся 29 байт на один бит (недастающий бит приходит из 33-ого байта) и тд... Но когда наткнулся на 25 байтный отрезок - сказал ООППСС...
Это то до чего я доковырялся когда захотелось данные самому выцарапывать, потом лень стало...
А чем Вас все таки ОДКшная TLGGetArchivDataEx не устраивает? Работает нормально...
Re: Доступ к базе архива из C++Builder или Delphi
ASH; 8.10.04

Да бог с ней, с TLGGetArchivDataEx... И И забудем про компрессирование... Объясните кто-нибудь почему таблица TagUncompressed пуста?? Ведь там же теги Slow-архивов должны храниться?

Re: Доступ к базе архива из C++Builder или Delphi
Alexis; 8.10.04

А ты в базе для Slow-архивов смотришь?

Re: Доступ к базе архива из C++Builder или Delphi
ion; 8.10.04

А можно примерчик на использование ф-ции TLGGetArchivDataEx.

Если конкретнее, то как в ней задавать параметр PTLG_ARCHIVDATARAW* ppTlgData?
Re: Доступ к базе архива из C++Builder или Delphi
ASH; 8.10.04

To Alexis

Да я везде смотрю! И в Фаст, и в Слоу базах, во всех базах ВинСиСи, которые видны в Enterprise Manager'e MS SQL Server'a либо через АДО из VB, таблицы TagUncompressed пусты:(
Re: Доступ к базе архива из C++Builder или Delphi
Alexis; 11.10.04

2 ASH:

Плохо смотришь :) А может у тебя нет переменных которые в Slow пишутся?

2 ion:
TLG_ARCHIVDATARAW *pDataRaw=NULL;
DWORD dwDataCount=10000;
DWORD dwFlag=0;
TLGGetArchivDataEx(lpszArcName, lpszVarName, &stFrom, &stTo, &pDataRaw, &dwDataCount, &dwFlag, &dmError);
...
if ( pDataRaw ) TLGFreeMemory(pDataRaw);
Re: Доступ к базе архива из C++Builder или Delphi
ASH; 11.10.04

To Alexis

Действительно, стормозил:) Эх ручки мои кривенькие - в настройках границу частоты архивирования для быстрых архивов выставил равной частоте архивирования тегов, потому все писалось в фаст, а не в слоу.
Спасибо:)
Re: Доступ к базе архива из C++Builder или Delphi
Маслов Дмитрий; 11.10.04

Предлагаю поставить точку в этой затянувшейся дискуссии.

1. В WinCC 6.0 имеются два типа архивов: быстрые и медленные.

2. Вплоть до версии 6.0 SP1 в быстрые попадали все теги с циклом архивации <= 1 мин., в медленные - остальные.

3. Начиная с версии 6.0 SP2 Вы сами можете сконфигурировать, что попадает в быстрый, а что - в медленный архив.

4. Содержимое медленных архивов пишется в базу данных в таблицу с полями "метка времени", "идентификатор тега", "значение". Вывод: прочитать содержимое медленного архива можно просто обратившись к нужной табличке БД, например, через ODBC.

5. Содержимое быстрых архивов пишется в БД в сжатом виде. Прочитать их можно через WinCC OLE DB Provider, который производит расжатие "на лету". Пример чтения тегов можно скачать с этого сайта, ПРИЧЕМ НИКОЛАЙ ГАШЕВСКИЙ УЖЕ ДАВАЛ ССЫЛКУ НА ЭТОТ ПРИМЕР НЕСКОЛЬКИМИ СООБЩЕНИЯМИ ВЫШЕ!

http://www.automation-drives.ru/as/products/doc.php?l1=SIMATIC%20HMI&l2=WinCC&l3=doc
См. http://www.wincc.ru

Re: Доступ к базе архива из C++Builder или Delphi
Евгений; 12.11.04

Прошу прощения за то что влезаю в разговор. Может кто-нибудь подсказать, как из с++ builder работать с файловым dsn? Компонент Query системные и пользовательские dsn видит, а файловые - нет. А нужен именно файловый.

Заранее спасибо за помощь!
Re: Доступ к базе архива из C++Builder или Delphi
Евгений; 12.11.04

Прошу прощения за то что влезаю в разговор. Может кто-нибудь подсказать, как из с++ builder работать с файловым dsn? Компонент Query системные и пользовательские dsn видит, а файловые - нет. А нужен именно файловый.

Заранее спасибо за помощь!
Re: Доступ к базе архива из C++Builder или Delphi
Евгений; 12.11.04

Прошу прощения за то что влезаю в разговор. Может кто-нибудь подсказать, как из с++ builder работать с файловым dsn? Компонент Query системные и пользовательские dsn видит, а файловые - нет. А нужен именно файловый.

Заранее спасибо за помощь!
Re: Доступ к базе архива из C++Builder или Delphi
Евгений; 12.11.04

Прошу прощения, на кнопку отправить я нажал только один раз - браузер сбоит похоже.


text

Доступ к базе архива из C++Builder или Delphi
ion; 28.9.04

Подскажите, плиз, в какую базу и какую таблицу архивируются теги TagLogging'ом, чтоб можно было из C++Builder'а или Delphi (или VB) вытащить архивные теги.

Re: Доступ к базе архива из C++Builder или Delphi
Михаил; 20.10.04

Для просмотра структуры базы данных

конфигурации можно использовать Excel. Внешние данные->Создать запрос и в отобразившемся окне в качестве источника нужно указать текущий проект WinCC состоящий из названия и даты без символа R в конце (связь с базами данных осуществляется через ODBC).
Таблица архивов начинается насколько помню с PDE#название архива#название тега.<


text

Доступ к базе архива из C++Builder или Delphi
ion; 28.9.04

Подскажите, плиз, в какую базу и какую таблицу архивируются теги TagLogging'ом, чтоб можно было из C++Builder'а или Delphi (или VB) вытащить архивные теги.


text

Доступ к базе
Константин; 22.12.04

Подскажите,пожалуйста,в Администраторе ODBC во вкладке пользавательский DSN WinCC создает свою базу типа CC_имя проекта_04-11-11_08:34:02R,например,для соединения с ней необходимо задать User ID и Password, КОТОРЫЕ WinCC устанавливает по умолчанию. Для доступа где эти поля пусты необходимо указывать эти параметры...так какой же пароль WinCC скрывает за звездочками?

Re: Доступ к базе
Eugene; 22.12.04

стандартный пароль для баз данных, создаваемых по умолчанию, в зависимости от СУБД. Если ты не настраивал сам пользователей и пароли, то по умолчанию User = DBA, Password = SQL.


text

Доступ к данным Tag Logging
Андрей; 5.1.04

Какие есть способы получения данных из архива Tag Logging на определённый момент времени. Время задаётся динамически. Нужно для использования в отчетах.

Re: Доступ к данным Tag Logging
Макс Прилепский, ОАО "ЗСМК"; 6.1.04

Если используется Report Designer, то с помощью функции ODK RPJSetProperty можно модифицировать свойства отчета "ABSOLUTESELECTIONFROM"

и "ABSOLUTESELECTIONTO", а в самом отчете должен быть сконфигурирован динамический метафайл, связанный с объектом Trend из категории Tag Logging Runtime.
<


text

Доступ клиента к WINCC OPC Server по сети
-=Stealth=-; 21.10.04

Опишу ситуацию:

Есть 2 машины. На обоих англ. 2000 винда. Подключены друг к другу через свич. На одной из машин стоит wincc 6.0, в котором я запускаю проект.
Со второй машины я подключаюсь к opc серверу wincc.
Пишет CO_E_SERVER_EXEC_FAILURE.
Ошибка 80080005.
Фишка вот в чем:
На первой машине я локально подключаюсь к opc серверу. И только после этого по сети можно подключаться к опс серверу wincc!!!
В чем проблема? Как инициализировать сервер при запуске проекта?<


text

Доступ клиента к WINCC OPC Server по сети
-=Stealth=-; 21.10.04

Опишу ситуацию:

Есть 2 машины. На обоих англ. 2000 винда. Подключены друг к другу через свич. На одной из машин стоит wincc 6.0, в котором я запускаю проект.
Со второй машины я подключаюсь к opc серверу wincc.
Пишет CO_E_SERVER_EXEC_FAILURE.
Ошибка 80080005.
Фишка вот в чем:
На первой машине я локально подключаюсь к opc серверу. И только после этого по сети можно подключаться к опс серверу wincc!!!
В чем проблема? Как инициализировать сервер при запуске проекта?
Re: Доступ клиента к WINCC OPC Server по сети
-=Stealth=-; 21.10.04

Вот еще:

Есть exe-шник SOPCSRVRWinCC.exe
Подключиться к opc серверу можно только, если он висит в памяти.
При закрытии клиента он выгружается из памяти.
На локальной машине клиенты сами его запускают. По сети не могут.
DCOM вроде настроен. В чем грабли?
Re: Доступ клиента к WINCC OPC Server по сети
Андрей; 21.10.04

Запуск/выгрузку SOPCSRVRWinCC.exe - OPC сервера WinCC и должны осуществять клиенты. Запуск инициализирует клиент,

ч/з вызов функции CoCreateInstanceEx, дальше начинает работать Microsoft COM/DCOM, как только клиент прекращает работать с сервером, он выгружается (опять по спецификации COM/DCOM).
Сервер будет висеть, пока к нему подключен, хоть один клиент (их может быть и несколько).

И посмотри
http://support.microsoft.com/?kbid=156223 (настройка DCOM и пользователей), чтобы не выскакивало
CO_E_SERVER_EXEC_FAILURE, там написано как этого избежать

Re: нужна-ли доп. защита по питанию(220В)
Продожающий; 22.10.04

Что за чушь? Серия D это многократное превышение по току (чтото такое). Ставится исключительно для защиты двигателей. Контроллеры надо защищать автоматами серии A или В. Надо только выбирать номинал исходя из параметра I "квадрат" T источника питания контроллера.

Re: Доступ клиента к WINCC OPC Server по сети
Владимир Ерохин; 25.10.04

При работе с сервером ОРС WinCC версий 4.x и 5.x тоже нельзя запускать сервер клиентом COM. Даже в доке (не подскажу - не помню) написано было, что работает только с запущенным уже instance. Я (не работал с WinCC версии 6.x) предполагаю, что такое-же сделано и в этой версии. Его нельзя запустить клиентом COM. Можно подключиться только когда проект WinCC запущен (даже если не в рантайме).

Re: Доступ клиента к WINCC OPC Server по сети
Владимир Ерохин; 25.10.04

При работе с сервером ОРС WinCC версий 4.x и 5.x тоже нельзя запускать сервер клиентом COM. Даже в доке (не подскажу - не помню) написано было, что работает только с запущенным уже instance. Я (не работал с WinCC версии 6.x) предполагаю, что такое-же сделано и в этой версии. Его нельзя запустить клиентом COM. Можно подключиться только когда проект WinCC запущен (даже если не в рантайме).

Re: Доступ клиента к WINCC OPC Server по сети
Андрей; 25.10.04

Все это правильно. Но SOPCSRVRWinCC.exe - это OPC сервер, который запускает/выгружает клиент, сервер должен предоставить для клиента свое адресное пространство (тэги, в данном случае), а если проект не запущен, откуда он знает, что предоставлять (тэги какого проекта), поэтому он и не запускается, а только при запущеном instance(даже без RT).


text

Еще о переходе на WinCC V6
Александр; 22.4.04

Такой вопрос: работают ли в WinCC V6 драйверы устройств от V5.1? Я где-то слышал, что в поставке V6 нет Modbus-драйвера, а у нас он активно используется (в слегка модифицированном виде) и заменить ни на что другое не можем (контроллеры знают только Modbus и необучаемы).

Re: Еще о переходе на WinCC V6
Дмитрий; 24.4.04

Правильно где-то слышали, теперь предлагают общаться с Modbus через ОРС сервер.


text

Ещё раз про Upload
Дертунов Борис; 7.9.04

Подключился к ТР170В по RS232-му и попробовал сделать загрузку проекта в РС: пишет не найден файл с расширением pzs. Откуда он берётся? И вообще как сделать аплоад? Возможен ли аплоад, как заявлено, по Profibusу?

Re: Ещё раз про Upload
fresco; 7.9.04

>не найден файл с расширением pzs.

.pdz наверно. Этот файл (архивированый проект) пишется на флеш-карточку. Нет карточки - нет файла.
Re: Ещё раз про Upload
Дертунов Борис; 8.9.04

да верно .pdz, а что с самой панели никак нельзя скачать проект?

Re: Ещё раз про Upload
fresco; 8.9.04

Нет. В панели нет проекта в том виде, в каком он есть на PC. Только .dll файлы (результат компиляции проекта).


text

Зависает Global Script
Лёха; 25.5.04

Есть проект на WinCC 5.1. Нормально работает при условии, что не обращаются к архивам. Отображение архивов построено на WinCC Online Trend Control. На одной картинке несколько трендов, которые появляются/исчезают в зависимости от оператора. На одном тренде можно отобразить несколько графиков. Их кол-во определяет оператор.

Так вот. Если несколько раз перейти с основной картинки на просмотр трендов и обратно, то зависают скрипты.
Отображения трендов построены на тэгах и Dinamik Dialog. Для оторбажения трендов и их управлением скрипты не используются.
Не пойму, почему тогда у меня скрипты виснут?
Re: Зависает Global Script
Л. Шерешевский; 25.5.04

Откройте временно Diagnostic Window и проверьте, не пишутся ли у вас туда какие-либо ошибки при переходах между кадрами. В свое время у нас была похожая проблема с зависанием макросов, вызванная накоплением какого-то критического числа ошибок, которые нас в общем-то не волновали, но систему, очевидно, беспокоили.

Re: Зависает Global Script
Лёха; 25.5.04

Что вы имеете в виду под Diagnostic Window? Это GSC DiagnosticS?

Re: Зависает Global Script
Александр Родин, ООО "Нева Электрик"; 27.5.04

\Siemens\WinCC\uTools\apdiag.exe -> меню Output Window

Re: Зависает Global Script
Лёха; 28.5.04

Александр, а вы можете рассказать, как это всё дело проанализировать, что бы узнать проблему.

У меня, пока проект работает нормально, можно смотреть всё из пунктов меню. Как только зависает, то из меню Info не могу ничего вызвать, хотя если ставить отображение по времени выполнения, то мои функции выполняются.
Re: Зависает Global Script
Александр Родин, ООО "Нева Электрик"; 28.5.04

в Output Window выкидываются все сообщения от системы рантайм. Если вы в своих скриптах проставите сигнальные строки типа printf ("<строка>"); в которых будете выводить критичную для вас информацию (например результат выполнения функций, значения тегов, входные параметры), то получите очень неплохую систему диагностики и сможете очень легко отыскать критичные места. Обычно скрипты у меня висли при частых выполнениях операций со строками.. в частности при не корректной их инициализации.

Re: Зависает Global Script
Лёха; 31.5.04

У меня стоят во всех скриптах какие-либо строки для отображения. Это мы проходили.

В то м то проблема, что когда у меня виснет проект, то никакие строки от скриптов в окно диагностики не выводятся, поэтому я и не могу отловить причину.
Может есть другой способ узнать причину ошибки?<


text

загрузка проекта в ProTool
Андрей ; 19.10.04

Получили проект, разработчик французская фирма. При попытке открыть проект в ProTool/pro CS v.6.0. SP2 получаем ошибку Error on converting OID 5 == OID_POB_CTDRIVER_MANAGER. Please contact the manufacturer. Unexpected file format. Связывались с разработчиками, версии совпадают. В чем может быть проблема? Заранее спасибо.

Re: загрузка косноязычного проекта в наш ProTool ?
Вариант; 19.10.04

Может там у них в именах тегов и файлов используются французские каракули, а у тебя не взведены флажки французского в региональной поддержке.

У меня финские проекты нормально открываются, но мы договорились не применять чухонские имена.
Проект в виде файла или проект в панели?
Re: загрузка проекта в ProTool
Андрей; 19.10.04

Проект в виде файла, интергированный в Step7. Какие там каракули неизвестно, т.к. не могу открыть.

Re: загрузка проекта в ProTool
Вариант; 20.10.04

А версии Степа + сервис паков + хот-фиксов совпадают и какие они у тебя и у них. Степовская программа тоже не открывается? Какой тип панели оператора.

Если ты питерский (судя по адресу) и у тебя нет других компьютеров и у меня такая версия Степа, то можем связаться - попробуешь на моих.
Re: загрузка проекта в ProTool
gregar; 20.10.04

Так бывает еще если в имени файла где-нибудь стоит ударение. Стоит поискать его и если оно есть, то удалить.

Re: загрузка проекта в ProTool
Андрей; 20.10.04

Нашел проблему. Нужен сервис пак SP2, а использовал SP2_P (оказывается не полнофункционален). Может у кого есть в Питере или на мыло (правда размер не малый). Заранее благодарен.

Re: загрузка проекта в ProTool
Вариант; 20.10.04

Смотри почту для связи

Ошибка старой версии Протула
Вариант; 21.10.04

В ФАКе - эта ошибка в случае более старой версии Протула

http://www4.ad.siemens.de/-snm-0135109872-1098201826-0000018554-0000000029-1098369636-enm-WW/llisapi.dll/13396711?func=ll&objId=19001028&objAction=csView&foldersopen0=-172-753-785-786-787-789-790-&nodeID0=10805581&lang=en&siteid=cseus&aktprim=0<


text

Заданная кривая в ProTool
Дмитрий; 11.10.04

Господа!

Кто-нибудь имеет опыт в выводе заданной кривой на график? Т.е. на графике отображается кривая, значения которой записаны в DB пользователем.
Подскажите порядок программирования. Панель - ОР270.
Заранее благодарю.<


text

Закраска объекта
Валера; 29.10.04

Например создан объект цвет которого необходимо изменять взависимости от состояния тэгов.Возможно ли к одному объекту привязывать несколько тэгов которые будут менять его цвет...

Re: Закраска объекта
Андрей; 29.10.04

Скорее всего только через С action, где

берутся значения необх. тэгов и по какому-то условию возвращается нужное значение цвета.

Re: Закраска объекта
Наталья; 29.10.04

Можно с помощью Dinamic Dialog. Там в Expression/Formula задается формула из необходимых тэгов, а в Result of the Expression/Formula значениям функции присваиваются нужные цвета.


text

Закраска объекта
Валера; 29.10.04

В Dinamic Dialog даже есть выбор цвета?

В Wcc 5.1 я этой функции почему-то не наблюдаю....И в списке операций нет логических....
Re: Закраска объекта
Наталья; 29.10.04

Если рассмотреть пример “закраски” окружности, то я делаю следующим образом:

Object Properties =>Properties =>Colors => Background Color щелкаю правой кнопкой мышки по «лампочке», выбираю Dynamic Dialog.

Далее в Expression/Formula забиваю формулу. Например мне надо, чтобы при Тэге1=1, Тэге2=0 кружок был серым, при Тэге1=0, Тэге2=1- зеленым, а при Тэге1=1, Тэге2=1 и Тэге1=0, Тэге2=0 - красным, то забиваю формулу типа:

Тэг1+2*Тэг2
Data Type ставлю Analog?
а в Result of the Expression/Formula
назначаю:
0-красный
1- серый
2- зеленый
3-красный

В Wcc 5.1 все это возможно

<


text

Заливка TP 070
JON; 24.12.04

Имея USB/PPI кабель могу ли я залить программу в панель TP070 с помощью программы TP Designer v.1.0, если в настройках соединения только COM1,COM2.

Re: Заливка TP 070
Павел Кобелев; 27.12.04

Насколько я знаю, TP Designer не поддерживает загрузку по USB/PPI кабелю


text

замена OP7
Сергей ; 31.10.04

Здравствуйте!!!

Хотелось бы узнать, возможна ли замена панели оператора OP7 на многофункциональную платформу MP270?
Re: замена OP7
Конкретней; 1.11.04

Возможно с переписыванием программы контроллера с учетом установленной новой панели и созданием в Протуле программы с экранами для панели.

Или ты просто хотел воткнуть абсолютно другое устройство и все должно заработать.
Re: замена OP7
Программа; 1.11.04

Программу контроллера переписывать не всегда обязательно, а вот для панели программу переписывать вероятно придётся. А так вобщем равноценная замена панелек.

Экран Сименса хх65 равноценен хх45?
Сравнение; 1.11.04

>А так вобщем равноценная замена панелек.

То есть я равноценно могу заменить MP270 на ОР7?
Не приравнивай цветную графическую панель на базе WindowsCE (с сенсорным вводом?) с текстовым экранчиком пейджера.
Это уже совершенно другой подход к управлению. И программу контроллера в соответсвии с этим подходом надо переделывать, не будет же он выводить на графический экран только 4 текстовых строки по 20 символов.
По своему опыту скажу, что заказчики просто балдеют от того цветных панелей.
Re: замена OP7
Пояснения с грустным лицом; 2.11.04

Если без авторских ремарок и "смеха за кадром" уже непонятно, в шутку или всерьёз говорится о равноценности ТАКОЙ пары панелей, становится грустно.

По поводу переписывания.
Программу контроллера по минимуму трогать не обязательно, только если есть желание и возможность (это, к сожалению, есть не у всех). Программу же панели переписывать придётся примерно на 99,(9)%.
С оценкой цвета согласен. С точки зрения разработчика (программиста) проще получить качественный продукт. С точки зрения заказчика упрощается эксплуатация, уменьшается количество ошибок персонала. <


text

Запароленные скрипты
Михаил; 18.12.04

Доброе время суток, уважаемые господа коллеги!

Подскажите пожалуйста, существует ли возможность просмотреть запароленные скрипты в WinCC?
Если есть такая возможность, то как это можно сделать?
Re: Запароленные скрипты
zolotoy; 20.12.04

я думаю тока сидеть и подбирать пароли :) программ таких наверника нет :( на скока я знаю енто специально делает разработчик чтобы никто туды свой нос несувал :( ибо енто есть евошний тяжёлый труд...


text

Запись в User Archive скриптом
ion; 27.4.04

В WinCC 6.0SP1HF3.

Подскажите как скриптом под какой-нибудь кнопкой записать в UserArchive значение.
Например значение 5 в архив с именем a_name.

Если можно коротенький пример того, как открыть, записать и закрыть базу.<


text

Запись в User Archive скриптом
ion; 27.4.04

В WinCC 6.0SP1HF3.

Подскажите как скриптом под какой-нибудь кнопкой записать в UserArchive значение.
Например значение 5 в архив с именем a_name.

Если можно коротенький пример того, как открыть, записать и закрыть базу.
Re: Запись в User Archive скриптом
Маслов Дмитрий; 28.4.04

Несколько сообщений назад в форуме была ссылка на ODK Help для WinCC 6 (тема: "документация на ODK v 6"). Скачиваете архив по указанной там ссылке. В архиве Вам нужен файл "ODKUserArchives.chm". Там все написано.

Re: Запись в User Archive скриптом
ion; 28.4.04

пасибки

Re: Запись в User Archive скриптом
ion; 28.4.04

И все таки там совсем не все описано.

Описаны функции, но это есть и в хелпе. А вот примера вставки новой записи таки нет:(
Есть кнопочки с ссылками на примеры, но ведь в архиве их нет.

Если можно примерчик. с последовательностью работы с юзерархивом: открытие, вставка записи, закрытие.

плизззз.:)
Re: Запись в User Archive скриптом
ion; 28.4.04

И все таки там совсем не все описано.

Описаны функции, но это есть и в хелпе. А вот примера вставки новой записи таки нет:(
Есть кнопочки с ссылками на примеры, но ведь в архиве их нет.

Если можно примерчик. с последовательностью работы с юзерархивом: открытие, вставка записи, закрытие.

плизззз.:)
Re: Запись в User Archive скриптом
Nick Gashevsky; 29.4.04

Найди winccoptions_v6_e.pdf - По моему, все понятно расписано, с примером (у меня заработало).

Re: Запись в User Archive скриптом
ion; 29.4.04

в winccoptions_v6_e есть пример того, как читать из архива и изменять запись, НО НЕТ ПРИМЕРА ВСТАВКИ НОВОЙ ЗАПИСИ. А мне именно это надо.

Re: Запись в User Archive скриптом
ion; 29.4.04

в winccoptions_v6_e есть пример того, как читать из архива и изменять запись, НО НЕТ ПРИМЕРА ВСТАВКИ НОВОЙ ЗАПИСИ. А мне именно это надо.

Re: Запись в User Archive скриптом
ion; 29.4.04

в winccoptions_v6_e есть пример того, как читать из архива и изменять запись, НО НЕТ ПРИМЕРА ВСТАВКИ НОВОЙ ЗАПИСИ. А мне именно это надо.

Re: Запись в User Archive скриптом
Nick Gashevsky; 6.5.04

ф-я uaArchiveInsert( hArchive )) добавляет запись.

Пример ушел по почте

Re: Запись в User Archive скриптом
ion; 7.5.04

спасибо. я уже разобрался.

Re: Запись в User Archive скриптом
Малкон; 21.12.04

Зато я не разобрался.. че за фигня, Пишу все отладил, все отладочные окошки выскакивают какие надо,а значит процесс идет так как надо,однако в базе значений нет !!!!!!!..

Хуже того что в официальной документации UserArchivesV502_r.pdf дан пример с таким ворохом ошибок, что хоть стой хоть падай.
Re: Запись в User Archive скриптом
jkeks; 23.12.04

Пример записи в базу данных:

Это пример из официального дока, однако в той документации целое море ошибок, я вообще не понимаю, как так можно было писать, исходник компилил часа 3, т.к. сам еще разбираюсь.
И еще в исходник прилепил простой пример записи в базу, в котором есть одна проблемма, я не знаю пока как работать с полями "счетчиками".
А если вам пока не до них, то следующий пример вам может помоч:

#include "apdefap.h"
void OnClick(char* lpszPictureName, char* lpszObjectName, char* lpszPropertyName)
{
UAHCONNECT hConnect;
UAHARCHIVE hArchive;
LONG IndexArchive;
LONG FieldLength;
LONG FieldType;
LONG NumberOfFields;
LONG Index;
long IntValue;
double DoubleValue;
char StringField[255];
char z[255];
SYSTEMTIME SysDate;
MessageBox(NULL,"Íà÷èíàåì àïèñûâàòü â áàçó","2",1);
//******* Ñîåäèíåíèå ñ êîìïîíåíòîì ïîëüçîâàòåëüñêèõ àðõèâîâ ***************
if ( uaConnect( &hConnect ) == FALSE )
{
MessageBox(NULL,"UAConnect error ","Ñîîáùåíèå",1);
//printf ( "uaConnect error: %d\n", "uaGetLastError()" );
return;
}
if ( hConnect == NULL )
{
MessageBox(NULL,"Handle UAH equal NULL","Ñîîáùåíèå",1);
//printf ( "Handle UAHCONNECT equals NULL\n" );
return;
}
//******* Ñîåäèíåíèå ñ àðõèâîì ïî èìåíè àðõèâà****************************
if ( uaQueryArchiveByName( hConnect, "jkeks", &hArchive ) == FALSE )
{
MessageBox(NULL,"UAQueryArchiveError ","Ñîîáùåíèå",1);
//printf( "uaQueryArchive Error: %d\n", "uaGetLastError()" );
return;
}
//******* Îòêðûòèå àðõèâà**********************************************
if ( uaArchiveOpen( hArchive ) == FALSE )
{
MessageBox(NULL,"Archiv open error ","Ñîîáùåíèå",1);
//printf( "uaArchive Open Error\n" );
return;
}
//******* Ïîëó÷åíèå êîëè÷åñòâà ïîëåé ************************************
NumberOfFields = uaArchiveGetFields( hArchive );
MessageBox(NULL,"Number of field is more ","Ñîîáùåíèå",1);
//printf( "Number of Fields = %u\n", NumberOfFields );
//******* ×òåíèå ïîñëåäíåé çàïèñè****************************************
if ( uaArchiveMoveLast( hArchive ) == TRUE ) // ïîñëåäíèé
MessageBox(NULL,"âñòàëè íà ïîñëåäíþþ çàïèñü ","Ñîîáùåíèå",1);
//printf( "Number of Fields = %u\n", NumberOfFields );
else
{
MessageBox(NULL,"ArcMoveLast error ","Ñîîáùåíèå",1);
//printf( "uaArchiveMoveLast Error: %d\n", "UAGetLastError()" );
return;
}
//******* Çàïèñü â ïîëÿ äàííûõ*****************************************
/* ----------------------------Çàïèñàòü ñòðîêó--------------------------------------*/
//uaArchiveSetFieldValueLong (hArchive, 0,-1);
uaArchiveSetFieldValueString (hArchive, 1, "malcon");
uaArchiveSetFieldValueLong (hArchive, 2, 999);
if (uaArchiveInsert (hArchive) == TRUE )
MessageBox(NULL,"Äîáàâèëîñü îòëè÷íî","Ñîîáùåíèå",1);
else
MessageBox(NULL,"Íå äîáàâèëîñü" ,"Ñîîáùåíèå",1);
/*----------------------êîíåö çàïèñè ñòðîêè-----------------------------*/
//******* Çàêðûòèå àðõèâà************************************************
if ( uaArchiveClose ( hArchive ) == FALSE )
{
MessageBox(NULL,"Õóåâî çàêðûâàåòüñÿ àðõèâ","Ñîîáùåíèå",1);
//printf( "error on closing archive\n" );
return;
}
//****** Îòñîåäèíåíèå îò àðõèâà****************************************
if ( uaReleaseArchive ( hArchive ) == FALSE )
{
MessageBox(NULL,"Áëÿäñêî õóåâî îòñîåäèíÿåòüñÿ îò àðõèâà!","Ñîîáùåíèå",1);
//printf( "error on releasing archive\n" );
return;
}
//******* Îòñîåäèíåíèå îò êîìïîíåíòà ïîëüçîâàòåëüñêèõ àðõèâîâ**************
if ( uaDisconnect ( hConnect ) == FALSE )
{
MessageBox(NULL,"Õóåâî îòñîåäèíÿåòüñÿ êàê-òî îò êîìïîíåíòà UserAerchive!","Ñîîáùåíèå",1);
//printf( "error on disconnecting\n" );
return;
}
MessageBox(NULL,"Âñå áëÿ!","Ñîîáùåíèå",1);
}

А то что русские буквы корявые - это очередной косяк WinCC. Впрочем там читать особо нечего.
http://revda.biz
http://revda.info

Удачи
См. http://revda.info


text

Запуск Global скрипта по времени суток
Роман; 15.9.04

Привет всем, как сделать запуск Global Action в моменты времени 6.00, 14.00 и 22.00, пробовал так

char *time;

time = GetTagChar ("Time");

if (time == "09:03")
{
SetTagBit("TIME_test", 1); //Return - Type :BOOL
}

естественно тишина, тэг Time взят из System Info, либо неправильно считываю либо не догоняю как правильно сделать, подскажите кто нибудь.
Re: Запуск Global скрипта по времени суток
Сам себе и отвечаю :))); 15.9.04

const char *time;

const char *time_limit_1;

time_limit_1 = ("09:15");

time = GetTagChar ("Time");

//SetTagChar ("Time_22", time);

if ( (time, time_limit_1 ))
{
SetTagBit("TIME_test", 1); //Return - Type :BOOL
}

Re: Запуск Global скрипта по времени суток
Маслов Дмитрий; 15.9.04

Вообще-то можно просто настроить триггер, явно указав требуемое время запуска скрипта.

См. http://www.wincc.ru

Re: Запуск Global скрипта по времени суток
Роман; 15.9.04

Эт понятно нужно что бы в определенное время суток, есть 3 смены на заводе, есть дозатор сыпучих мат., требуется полученный вес за смену т.е. за 8 часов. а так система будет срабатывать от того момента когда запустил рантайм.

Re: Запуск Global скрипта по времени суток
Павел Кобелев; 16.9.04

Устанавливаете тип триггера "Daily" и время запуска, с точностью до секунды. На 3 смены понадобится 3 триггера.

Re: Запуск Global скрипта по времени суток
Роман; 16.9.04

Мда, век живи...., спасибо.


text

Запуск RT WinCC
KAV; 28.10.04

А как можно запустить Runtime без "Автостарта" (кнопочка "Cancel" очень смущает) и без запуска WinCC Explorer. Вроде как это можно. Подскажите как.

Re: Запуск RT WinCC
Юрченко Владимир; 28.10.04

Ну так в "Autostart" галочки для запуска CS и диалогового окна с "Cancel" снять надо и все...

Re: Запуск RT WinCC
Вадим Печёрских; 1.11.04

То Юрченко - такой вариант работает в WinCC 6, в пятой версии таких возможностей нет.

То KAV поищии в по форуму, недавно подобное уже обсуждали. <


text

Запуск WinCC
Андрей; 26.10.04

Подскажите, пожалуйста,

есть разработанный проект в WinCC 6.0,
что надо для установки на компьютере пользователя для его запуска, можно ли не устанавливать WinCC Explorer. Что и где можно почитать по этому поводу
Re: Запуск WinCC
Alexis; 27.10.04

Установите WinCC RT (WinCCExplorer все равно установится) и сделайте автостарт проекта. А почитать - дык RTFM, RTFM и еще раз RTFM :))


text

Запуск приложения на клиенте
Александр Клейн, ООО "ВК-Инжиниринг"; 22.9.04

Господа, подскажите как в системе "1 сервер - 3 клиента" запустить обычный калькулятор из Windows? Дело в том, что на сервере от запускается, а на клиентах нет. Calc.exe лежит на сервере в расшаренной папке. Скопировал его даже в папку проекта на сервере - не помогло.

Re: Запуск приложения на клиенте
Руденко Алексей Невисс-комплекс; 22.9.04

В данном случае проще всего вызывать калькулятор через WinExec или ShellExecute, а на каждом клиентском компьютере сам калькулятор должен лежать в одной из системных папок (т.е. по системным путям) и тогда все заработает.

Либо можно в этой функции четко прописать путь (но точных гарантий что будет работать дать не могу) - в теории должно работать
Re: Запуск приложения на клиенте
Александр Клейн, ООО "ВК-Инжиниринг"; 22.9.04

А можно слегка поподробнее: WinExec и ShellExecute - это что и как с этим работать?

Re: Запуск приложения на клиенте
Павел Кобелев; 23.9.04

Это API-функции. Вызывать из скрипта.

Re: Запуск приложения на клиенте
Руденко Алексей Невисс-комплекс; 23.9.04

Re: Запуск приложения на клиенте
Александр Клейн, ООО "ВК-Инжиниринг"; 23.9.04

Все понятно. Спасибо за подсказку.


text

Заходи, кто хочет и твори чего вздумается
asuchmz; 19.2.04

Здравствуйте.

Вопрос к уважаемым мэтрам в WinCC.
Не бывало ли так, что когда WinCC в Runtime - самопроизвольно (иначе и не скажешь) открывается меню "Пуск" ?
Все сочетания клавиш блокированы, система - WinCC 5, WinNT4.
Или кто из добрых юзеров мне туда вирусов напихал ?
Доступ к Desktop у меня возможен во время Autostart, ибо выполняется он достаточно долго (время не засекал, но минутка там точно есть, можно и дискету прочитать и т.д и т.п).
Или мне специально блокировать Desctop ?
Re: Заходи, кто хочет и твори чего вздумается
Alexis; 19.2.04

Дык отключи десктоп совсем :)

Re: Заходи, кто хочет и твори чего вздумается
Чистяков Дмитрий ОАО СеверСталь; 19.2.04

Ниже следует содержимое файла "Запретить всё.reg", который я использую для защиты от операторов на операционке W2K.

Действия следующие:
1. СОздать пользователя.
2. Дать ему права администратора.
3. Настраиваем параметры для Autostart
4. Устанавливаем автоматический ввод имени пользователя и пароля при входе в Windows
5. Проверяем нормальный вход в Windows и загрузку WinCC проекта.
6. Запускаем файл "Запретить всё.reg".
7. Заходим администратором
8. Удалить из папки "C:\Documents and Settings\<имя пользователя>\Главное меню\" всё что там есть.
9. Переименовываем расширение файла "C:\Documents and Settings\<Имя пользователя>\NTUSER.DAT"
в NTUSER.MAN
10. Перезапускаемся и проверяем как оно всё работает.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
"NoDriveTypeAutoRun"=dword:00000001
"NoNetHood"=dword:00000001
"NoDesktop"=dword:00000001
"NoFind"=dword:00000001
"NoSetFolders"=dword:00000001
"NoRun"=dword:00000001
"NoFavoritesMenu"=dword:00000001
"NoSetTaskBar"=dword:00000001
"NoTrayContextMenu"=dword:00000001
"NoRecentDocsMenu"=dword:00000001
"NoCommonGroups"=dword:00000001
"NoSetActiveDesktop"=dword:00000001
"NoAddPrinter"=dword:00000001
"NoSMHelp"=dword:00000001
"NoChangeStartMenu"=dword:00000001
"NoViewContextMenu"=dword:00000001
"NoShellSearchButton"=dword:00000001
"NoFolderOptions"=dword:00000001
"NoClose"=dword:00000001

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Network]
"NoEntireNetwork"=dword:00000001
"NoNetSetup"=dword:00000001
"NoNetSetupIDPage"=dword:00000001
"NoNetSetupSecurityPage"=dword:00000001

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\System]
"NoVirtMemPage"=dword:00000001
"NoDevMgrPage"=dword:00000001
"NoConfigPage"=dword:00000001
"NoFileSysPage"=dword:00000001
"NoFileSysPage"=dword:00000001
"NoDispScrSavPage"=dword:00000001
"NoDispAppearancePage"=dword:00000001
"NoDispSettingsPage"=dword:00000001
"DisableTaskMgr"=dword:00000001
"NoDispScrSavPage"=dword:00000001

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Internet Explorer\Restrictions]
"NoBrowserOptions"=dword:00000001

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictRun]
"1"="C:\\Siemens\\WinCC\\bin\\AutoStartRT.exe \\\\Stasrv01\\WinCC50_Project_Ackp_5kl\\Ackp_5kl.MCP /Activ:yes /LANG=ENU"
"2"="AutoStartRT.exe"
"3"="\\\\Stasrv01\\WinCC50_Project_Ackp_5kl\\Ackp_5kl.MCP"

Re: Заходи, кто хочет и твори чего вздумается
Чистяков Дмитрий ОАО СеверСталь; 19.2.04

Да, забыл.

Надо ещё вставить 9.1. Это когда зашли администратором, надо пользователя перевести в группу "пользователи", если на диске с: стоит FAT32, или в группу "Опытные пользователи", если стоит NTFS.
Re: Заходи, кто хочет и твори чего вздумается
Human; 20.2.04

Ещё можно использовать утилиту Poledit

при помощи которой можно настраивать профиль конкретного пользователя, можно убрать всё из меню "ПУСК", оставив только нужные приложения, сделать невидимыми сеть и логические диски данного ПК. Вобщем обрезать всё по нехочу :). Многократно проверено под NT4.0. Единственный минус - не всегда можно откатится назад.
А ещё вариант использовать прогу WinBoost 4.64 - программа позволяет защитить станцию оператора
от самого оператора :)
сам правда ещё не пробовал.
Re: Заходи, кто хочет и твори чего вздумается
Чистяков Дмитрий ОАО СеверСталь; 20.2.04

Можно и через Poledit, как Вы и сказали отката нет там.

Ну, действия применяемые через Poledit приводят всё к тем же реестровым записям, что и файле. Потому я перешёл на него. К тому же отмена запретов делается очень просто. Достаточно в reg файле заменить все 1 на 0.
Re: Заходи, кто хочет и твори чего вздумается
Евгений Трунов; 20.2.04

С такой бетонной защитой, как у Дмитрия, так уж проще не запускать explorer вообще, а сразу оболочкой - проект WinCC. (Ну, и Task Manager запретить). Если не нужны никакие другие приложения, запуск из AutoRun и пр. - вполне годящееся решение.

Re: Заходи, кто хочет и твори чего вздумается
Владимир; 23.2.04

а есть еще утилита такая

Desktop Lock
от Rockwell Software.
Отличнейшая весчь.
Re: Заходи, кто хочет и твори чего вздумается
Чистяков Дмитрий ОАО СеверСталь; 24.2.04

Увы, но без Explorera мы не смогли запустить свой проект WinCC. ВОзможно наши разработчики кадров где-то что-то "накрутили".

А у Вас пошло?
Re: Заходи, кто хочет и твори чего вздумается
Евгений Трунов; 24.2.04

Да, у нас без эксплорера вполне нормально. WinCC 5.1+SP1, Win2000+SP2. Какие у Вас симптомы: просто не запускается, и все?

Re: Спасибо, сейчас попробую
asuchmz; 25.2.04

По поводу отката. Хорошая штука - PQ Drive Image Pro. Универсальная. Делаешь image диска где - нибудь. Потом всего пара дискет - и система в исходном состоянии.

Спасибо за отклики.

Re: Заходи, кто хочет и твори чего вздумается
Ч; 25.2.04

Евгений Трунов

Пробовали давно. Ещё под NT и WinCC 5.0 SP2. А потом создали выше указанный файлик и успокоились.
А проблема была в том, именно просто ничего не запускалось и всё тут. Т.е. я вместо explorer`а в реестре подпихивал autostart.
Но сейчас запланирована миграция на версию 6.0. Потому если и будем пробовать, то только на ней.
Re: Заходи, кто хочет и твори чего вздумается
Вадим Печёрских; 1.3.04

Ответ немного не в тему но тоже относиться к безопасности. У нас мы идёт тремя путями

1.Poledit
2.Консоль управления (mmc)
3.Групповые политики безопасности(если машина в домене и на ней работают разные пользователи)
После Poledit всё равно кое что приходиться править руками. Самое лучшее это групповые политики+проект оболочкой запускаеться.
Re: Очнь надо
Рома; 21.3.04

Люди помогите Изменить картинку в polytechnik (ProTool Pro RT v6.0)


text

Звуковая сигнализация в WinCC
Степащенко Игорь; 11.8.04

В проекте WinCC сделана светловая индикация аварий , подскажите как сделать чтобы персоналка издавала при этом звуки

Re: Звуковая сигнализация в WinCC
Маслов Дмитрий; 12.8.04

Смотря какая у Вас версия WinCC.

Если 6, то используйте редактор под названием Horn. Там Вы сможете каждому классу сообщений назначить свой wav-файл.

Если версия 5 или ранее, то надо реализовать проигрывание wav-файлов в стандартной функции GMsgFunction, которая вызывается автоматически всякий раз при появлении/исчезновении сообщения, для которого в Alarm Logging стоит галочка "Triggers an Action"
См. http://www.wincc.ru

Re: Звуковая сигнализация в WinCC
Александр Родин, ООО "Нева Электрик"; 12.8.04

Использование GMsgFunction (5-я версия) очень здорово грузит машину, особенно, когда есть очень много активных сообщений, да еще если при этом надо назначать разным классам/типам/группам разные звуки.

Я для подобных случаев использую статусные тэги. И потом, по изменению этих тэгов запускаю глобал-экшен, в котором проигирываю требуемый файл в зависимости от их значения.
Re: Звуковая сигнализация в WinCC
Маслов Дмитрий; 13.8.04

Спешу не согласиться по поводу GMsgFunction. Все зависит от того, как ее реализовать. Если непосредственно в ней вызывать функцию проигрывания wav-файла, то она действительно грузит машину.

А если в ней в зависимости от класса сработавшего сообщения выставлять соответствующие битовые теги, по которым запускать скрипт в Global Action, то все работает быстро.
См. http://www.wincc.ru

Re: Звуковая сигнализация в WinCC
Александр Родин, ООО "Нева Электрик"; 13.8.04

А собственно, какая разница ?.. :)

Что вам пришедшее сообщение выдаст свой тип/класс/статус через GMsgFunction и вы его в биты засунете, но при этом не увидите из какой группы оно пришло, что вы сразу назначите статусные теги по типу/классу/группе, а статус в этом тэге сам проставится... :)
Ваш случай более удобен, если надо выполнять единичные квитирования. Я же этого никогда не делаю. На мой взгляд более выгодно выполнять сразу групповое квитирование.
Re: Звуковая сигнализация в WinCC
Alexis; 13.8.04

Дык есть же HMRT.exe и @Signal1, @Signal2 и @Signal3... Правда я что то не помню работает это без BPC или нет...

Re: Звуковая сигнализация в WinCC
Fanat; 14.8.04

В этом случае можно использовать просто функции WinApi, они прекрасно работают, причем есть возможность использовать даже системный динамик!!!

Re: Звуковая сигнализация в WinCC
Маслов Дмитрий; 15.8.04

Александру Родину:

Разница только в гибкости. Статусные теги можно назначать лишь классам/типам и группам сообщений (опеределенным перечислением номеров), а GMsgFunction можно реализовать так, как Вам удобно - например, можно анализировать какой-нибудь из текстовых блоков сообщения.
Опять же можно сделать разную логику проигрывания wav-файлов. Мы, например, в одном из проектов пригрывали один раз wav-файл сигнализации при появлении каждого нового сообщения. Со статусным тегом это не пройдет - если уже есть пришедшее неквитированное сообщение, то приход нового сообщения этого же класса не изменит статусный тег, назначенный классу.
См. http://www.wincc.ru

Re: Звуковая сигнализация в WinCC
Panyov Konstantin; 14.9.04

Для вывода звуковой сигнализации в версии 5.1 (а может и в других версиях не знаю не пробовал) можно использовать стандартную функцию ProgramExecute (вызов программы) вот пример формата этой функции:

ProgramExecute("C:\\Program Files\\winamp\\winamp.exe C:\\1.m3u"
где 1.m3u - это плэй лист который тебе нужен
Re: Звуковая сигнализация в WinCC
Александр Родин, ООО "Нева Электрик"; 4.10.04

Ага, а потом при выпадении кучи сообщений сидите и смотрите как плодятся окна с винампом и играют ваш плей-лист... :)


text

Звуковые сигналы в WinCC
роман М; 29.10.04

Как прицепить звуковой сигнал к аварийному сообщению в AlarmLogging?

Re: Звуковые сигналы в WinCC
Андрей; 29.10.04

В Horn configuration на закладке "Message assigned" выбираешь класс сообщений для которых назначается звуковой сигнал, в "Tag", указываешь binary tag (например, "Alarm_signal"), далее на закладке "Signal assigment" для этого тэга задаешь *.wav файл.

При поступлении сообщения указанного класса, активиз. назначенный тэг и проигрывается звуковой файл.

Для сброса звукового сигнала используется тэг "@HornReset" с установкой значения в 0.
Re: Звуковые сигналы в WinCC
Александр Родин, ООО "Нева Электрик"; 29.10.04

Стандартная функция есть gmsgfunc.fct, которая вызывается при появлении нового сообщения, отыскивается она в Global Script-е. Прямо в ее теле прописывается функция проигрывания звуков, коих выбор достаточен для использования, начиная от API, заканчивая банальным пищанием.


text

Звуковые сигналы
роман; 29.10.04

А подскажите где же в версии 5.1 находится редактор Horn Config....

Re: Звуковые сигналы
Андрей; 29.10.04

У меня версия WinCC 6.0, как в 5.1 делать не подскажу

Re: Звуковые сигналы
Александр Родин, ООО "Нева Электрик"; 29.10.04

дык нету его в 5.1. %)


text

Значение IOField * 1000 в тег
ion; 21.7.04

Подскажите, плиз, как записать значение, умноженное на 1000, из IOField в тег.

Т.е. я пишу в IOField значение 5, а в тег записывается значение 5000.
Как сие реализовать?
Re: Значение IOField * 1000 в тег
Human; 22.7.04

По изменению поля считываешь OutputValue, умножаешь на 1000 и записываешь в тег.

Re: Значение IOField * 1000 в тег
Игорь Одесса; 22.7.04

double value =GetPropDouble(lpszPictureName,"имя I/O Field","InputValue");

value = value+1000;
SetTagDouble("имя тега",value);<


text

Зона в рисунке, свободная от TagPrefix
Евгений; 7.12.04

Как при использовании TagPrefix в рисунке подключить к-л элемент к тегу, для которого этот префикс не подходит: скажем, окно тренда к архивному тегу? Дело в том, что во всём остальном TagPrefix очень хорошо работает, и не хотелось бы от него отказываться. Возможно такое или нет?

Re: Зона в рисунке, свободная от TagPrefix
Л. Шерешевский; 7.12.04

см. ссылки

http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1027057738&year=2003
http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1045759473&year=2003
<


text

Изменение имени базы данных
Alex; 1.12.04

Может кто знает, почему WinCC регулярно изменяет имена баз данных (дату, время в конце имени базы). Есть ли какой-нибудь выход из этой ситуации. (Для внешней программы, которая достает данные из базы WinCC необходимо указывать конкретное имя.)

Re: Изменение имени базы данных
Л. Шерешевский; 1.12.04

WinCC изменяет DSN не регулярно, а только при открытии проекта. Чтобы избежать проблем, проект WinCC при запуске должен получать DSN базы и класть его куда-либо (тег, файл, область памяти и т.п.), откуда внешнее приложение будет его считывать. Как получить DSN написано на http://www4.ad.siemens.de/WW/news/en/9061684

См. Центр компетенции WinCC

Re: Изменение имени базы данных
Nick Gashevsky; 6.12.04

Еще можно увидеть и считать имя проекта в реестре в ветке HKEY_CURRENT_USER,Software\ODBC\ODBC.INI при запущенном Runtime.


text

Изменение пользователя
Андрей; 12.10.04

Кто может подсказать с переключением пользователей.

Есть кнопка с авторизацией, с помощью динамического мастера (Operationable if autorization) создается функция проверки прав пользователя, в качестве Event'а для нее тэг @CurrentUser Cycle = UponChange. Но когда переключаю пользователя, тэг @CurrentUser меняется сразу, а кнопка включается через некоторый интервал (порядка 5-10 секунд)

Re: Изменение пользователя
Макс Прилепский; 12.10.04

Можно попробовать у свойства Operator-Control Enable Вашей кнопки создать Dynamic Dialog , в качестве параметра которого установить функцию PASSCheckLevelPermission(x), где х - номер авторизации в таблице User Administrator, установить тип данных Direct , а в качестве события указать тег @CurrentUser . В случае смены пользователя функция сработает и , если уровень авторизации пользователя соответствует указанному в параметре функции, то кнопка будет моментально блокирована/разблокирована, такой способ я применял не один раз, реакция объектов на смену пользователя осуществлялась без каких-либо задержек

Re: Изменение пользователя
~BurAn~; 12.10.04

Re: Изменение пользователя
Андрей; 12.10.04

Вариант, что прислал Макс Прилепский работает, а вот от ~BurAn~, он не всегда срабатывает, в качестве триггера у меня стоит Tag @CurrentUser UponChange.


text

Изменение размеров объекта в ProTool_6SP2
Владимир; 14.9.04

Столкнулся с необходимостью в протуле изменения размера линии. Стандартными средствами можно только смещать объект. Как же изменять размеры объекта? Есть предположение, что через скрипты, но не могу разобраться как задавать класс. Заранее благодарю за любой совет.


text

Износ контактов клавиш на OP 37
С.Покровский; 16.4.04

От частого употребленя на операционной панели OP37 перестали работать несколько клавиш. В остальном панель исправна. Мы ее разобрали и считаем, что вся проблема в пленочной клавиатуре. Вопрос? Можно ли отдельно заказать только клавиатуру и какой у нее заказной номер? В каталоге присутствует некий сервисный пакет с клавиатурой. Не то ли это самое?

<


text

Имена тагов PCS7v5.1
marina; 9.7.04

Скажите возможно ли названиям тагов в системе PCS7 присвоить имя - псевдоним?

Допустим таг имеет имя viparka\station1\cfc_fsh_1\meas_mon.u,
необходимо, чтобы было F shelok 1
Re: Имена тагов PCS7v5.1
GorA; 9.7.04

Можно попробовать изменить имя функционального блока в CFC пакете,откуда берутся данные, на желаемое.

Re: Имена тагов PCS7v5.1
Маслов Дмитрий; 9.7.04

Про псевдоним не знаю - скорее нет, чем да.

Зато можно настроить формирование имен тегов. Для этого:
1. CFC-чартам давайте понятные имена (например, в Вашем случае - F shelok 1 вместо cfc_fsh_1);
2. в настройках иерархии Plant View в Simatic Manager отключите включение иерархии в имя тега.

В этом случае имя Вашего тега будет выглядеть следующим образом:
F shelok 1\meas_mon.u
Re: Имена тагов PCS7v5.1
Alexis; 9.7.04

Дык после того как имена тэгов появятся в WinCC, те после трансфера, берите и переименновывайте их как вашей душе угодно... токо сознавайте что творите :)


text

Имитация перемещения объекта
Dzmitry; 25.2.04

Подскажите плиззз!

Мне необходимо создать эффект перемещения допустим небольшого закрашенного кружка. Для этого можно (один из вариантов) сделать много-много кружков и visible их по очереди. Так вот в чем проблема, я хочу свезать с тегом скорость перемещения объекта, но тут возникает проблем с триггером: если делаешь минимальный триггер(250мкс), то это слишком медленно, а если по изменению -то слишком быстро, и приходится гимороем заниматься (загружать процессор работой чтобы он задерживал на некоторое время каждый из объектов видимым на некоторое время). Так вот есть ли какая нибудь функция Си, задержки (паузы выполнения программы). Но это нехороший способ, т.к. хотелосбы чтобы обработка остальных тегов не страдала из-зи этого объекта.
Может быть отслеживать время...Возможно ли точно (с точностью до нескольких мкс) оследить время visible. И если да, то какой функцией возвращается время для этого.

Заранее огромное спасибо откликнувшимся!!!
Re: Имитация перемещения объекта
Макс Прилепский; 26.2.04

А можно не париться, сделать Gif-файл с любой скоростью анимации и по тегу активировать/деактивировать его воспроизведение, используя, к примеру, ActiveX-компонент Animated Gif Control. У компонента есть свойство "Номер кадра", по изменению тега можно выводить нужный кадр анимации

Re: Имитация перемещения объекта
Dzmitry; 26.2.04

....по изменению тега можно выводить нужный кадр анимации....

А как сделать чтобы тег определял только скорость перехода от кадра к кадру (относительную конечно), а не являлся номером кадра?
Re: Имитация перемещения объекта
Маслов Дмитрий; 26.2.04

Я бы рекомендовал Вам написать свой ActiveX со свойством "скорость". Я думаю, что реализация более-менее быстрой анимации на скриптах WinCC будет безбожно сильно загружать процессор.

Re: Имитация перемещения объекта
Dzmitry; 26.2.04

В принципе я эту задачу уже решил.

Если я правильно понимаю Скада выполняет свою программу цеклически. Я сделал как бы счетчик циклов который инкрименируется (+1) с скаждым разом при выполнении блока программы относящейся к интиресующиму нас объекту, и когда счетчик доходит до заданной выличины (например 40) он обнуляется и в тоже время включает visible следующего кадрика, а этого выключает. При этом в качестве уровня до которогу будет считаться счетчик можно без труда определить как тег (фактически этот тег будет регулировать скорость смены кадров), а далее пожалуйста изменяйте скорость перемещения объекта.
А как вам идейка, проста и в тоже время не так уж плоха, вы не находите. :))
Этот принцит не наносит вред для обработки других объектов, т.к. нет никакой задержки выполнения программы, которая была бы если применять функции задержки Си.
Надеюсь эта идейка комунибудь пригодиться, буду только рад. :)
Если у кого нибудь есть какая нибудь лучшая идея напишите.

Спосибо!
Re: Имитация перемещения объекта
Макс Прилепский; 1.3.04

У Animated Gif Control есть свойсво "задержка между кадрами". Я этот копмонент использовал для анимированного отображения скорости вращения ротора, а также для отображения его реверсивного вращения (есть и такое свойство у компонента). Модель ротора я делал в 3DS Max, рендерил несколько кадров, потом создавал на их основе Gif-файл.

Re: Имитация перемещения объекта
Dzmitry; 1.3.04

Макс Прилепский, твой вариант мне очень понравился, спосибо за помощь.


text

Имя источника данных ODBC
Лёха; 18.3.04

Как в WinCC 5.1 узнать имя источника данных?

Re: Имя источника данных ODBC
Yrok; 18.3.04

Открываешь "Панель управления" находишь там "Администрирование" Тоже его открываешь и находишь там "Источники данных (ODBC)" , далее запускаешь эти источники в открывшеемся окне щёлкаешь мышкой по вкладке UserDSN. В окне будет список доступных источников данных, так вот WinCC имеет два источника данных

один это для конфигурации а другой для RunTime и они обозначаются где то так
CC_3T_04_03_09_11_30_50
CC_3T_04_03_09_11_30_50R
Учти чтобы их увидеть нужно чтобы был открыт проект в WinCC.
Re: Имя источника данных ODBC
Alexis; 18.3.04

Ну либо DMGetProjectInformation или DMEnumOpenedProjects...

Re: Имя источника данных ODBC
Александр Родин, ООО "Нева Электрик"; 18.3.04

Я под это дело функцию писал. Если надо могу намылить.

Re: Имя источника данных ODBC
Лёха; 18.3.04

Для Yrok: мне надо знать имя ODBC во время загрузки проекта.

Re: Имя источника данных ODBC
Лёха; 18.3.04

Re: Имя источника данных ODBC
Лёха; 18.3.04

Для Александра Родина: намыль. я к тебе по мылу обращусь.

Re: Имя источника данных ODBC
Alexis; 18.3.04

Функции в ОДКе

Попробуй так в скрипте:

#pragma code("dmclient.dll")
#include "dmclient.h"
#pragma code()

CMN_ERROR cmnError;
DM_PROJECT_INFO dmInfo;
if ( DMGetRuntimeProject(dmInfo.szProjectFile, _MAX_PATH, &cmnError) )
{
if ( DMGetProjectInformation(dmInfo.szProjectFile, &dmInfo, &cmnError) )
{
printf("DSN=%s\r\n",dmInfo.szDSNName);
}
}
Re: Имя источника данных ODBC
Yrok; 19.3.04

Так ты запусти один раз на выполнение WinCC и посмотри как он называется, я не думаю что он при следующем запуске поменяется.

Re: Имя источника данных ODBC
Лёха; 22.3.04

Спасибо всем за помощь.

Всё работает.<


text

интегрирование в WinCC
D.M.; 23.11.04

как в wincc можно реализовать интегрирование тегов по заданному диапазону времени? т.е. нужно например считать расход за час.

Правильно ли будет поступить так:
архивировать тег как среднее значение за час с циклом опроса напр. в минуту,
сохранять архивное значение во внутренний тег, который потом умножать на время (60 минут).
можно ли через C-Action это реализовать?

Re: интегрирование в WinCC
Чистяков Дмитрий ОАО СеверСталь; 23.11.04

Вообще-то проще всего это сделать в контроллере.

А в WinCC используй Global Script. Там можно сделать две акции
1. Собирает данные и суммирует их. Вызывается раз в час.
2. Вызывается раз в час и считает среднее значение сумму и вообще, всё что хочется. :-)<


text

Использование глобальных переменных
Миша; 19.10.04

Расскажите пожалуйста вкратце как использовать глобальные переменные (значение которых будет сохранятся независимо от кадра).

1. где их декларировать (в каком файле)
2. как их потом использовать

Буду признателен если приведете какой нибудь простенький примерчик
Re: Использование глобальных переменных
Макс Прилепский; 19.10.04

Объявлять глобальные переменные можно в любой функции проекта, перед её телом, например, создаёте функцию проекта:

int MyInt;
BOOL MyBOOL=FALSE;
char MyChar[10];
__object *MyObj,

void Global_Variables()
{
}

После этого, при запуске проекта, даже если функция нигде не вызывается, переменные будут созданы и обращаться к ним можно из любых actions, будь то action PDL-картинки или Global Script.

Затем эти переменные должны быть объявлены в использующем их action соответствующим образом:

extern int MyInt;
extern BOOL MyBOOL;
extern char MyChar[10];
extern __object *MyObj,
Re: Использование глобальных переменных
Миша; 19.10.04

RE: Макс Прилепский

Спасибо. поробую. <


text

Кабель
lis; 1.12.04

Подскажите пожалуйста серийный номер кабеля для последовательной передачи данных из программатора в OP. Есть ли какая-либо альтернатива?

Re: Кабель
Чистяков Дмитрий ОАО СеверСталь; 3.12.04

Альтернатива - спаять абель самому. Это будет дёшего и сердито. :-)

Распайка же кабеля прописана в описании панели.
А вообще, про какую панель Вы ведёте речь?
Re: Кабель
Чистяков Дмитрий ОАО СеверСталь; 3.12.04

Да, забыл написать про кабель. Он входит в комплект программных пакетов:

6AV6573-1FA06-0CX0SIMATIC TP170/OP170B, КОМПЛЕКТ КОНФИГУРИРОВАНИЯ: ПАКЕТ SIMATIC PROTOOL/LITE V6.0 SP2 С РУКОВОДСТВОМ; РУКОВОДСТВО ПО SIMATIC TP170/OP170B; РУКОВОДСТВО ПО ОРГАНИЗАЦИИ СВЯЗИ С СИСТЕМАМИ АВТОМАТИЗАЦИИ; КАБЕЛЬ RS232; MPI-КАБЕЛЬ; АНГ./ НЕМ./ ФР./ ИС./ ИТ. ЯЗЫК

и

6AV6621-0AA01-0AA0SIMATIC OP77B/ TP170 MICRO/ TP170A/ TP170B/ OP170B, КОМПЛЕКТ ПРОЕКТИРОВАНИЯ: ПАКЕТ SIMATIC WINCC FLEXIBLE COMPACT; CD С КОМПЛЕКТОМ ЭЛЕКТРОННОЙ ДОКУМЕНТАЦИИ ПО SIMATIC HMI; СОЕДИНИТЕЛЬНЫЙ КАБЕЛЬ RS232 ДЛИНОЙ 5 М; MPI-КАБЕЛЬ ДЛИНОЙ 5 М
Re: Кабель
Sergey; 3.12.04

Кабели поставляются вместе с панелями. Кабели RS232. MPI кабели несложно сделать. Через них не только связь, но и питание 24 V подается.Мы паяли двойник PC-PLC, PLC-OP,PC-OP. Все это вместе хорошо работает. Только при загрузке в OP с PC нужно выдергивать связь PC-PLC, а то в панель не грузится и выдает ошибку. Распайку точно сейчас не скажу, но в документации есть.


text

Как автоматизировать разработку проекта в WinCC 6.0 SP2?
Эдуард; 13.9.04

Здравствуйте! Подскажите, пожалуйста, как в WinCC 6.0 + SP2 автоматизировать работу по привязке однотипных объектов (аналоговые сигналы, задвижки, насосы)? Чтобы был понятен вопрос, объясню как это делаю я в SCADA-пакете iFIX 3.0. Создаю базу данных в MS Access с описанием всех имеющихся объектов, например в таблице ZD этой БД содержится описание задвижек: номер задвижки, описание, номер по технологии, имена тегов.

У любого объекта в этой СКАДЕ есть два главных события OnEdit() и OnClick(). Первое событие вызывается в среде конфигурации во время щелчка мышью на объекте, второе – в среде исполнения во время щелчка мышью на объекте. В VBA (Visual Basic Application) этой СКАДЫ в событии OnEdit вызываем наше сконструированное окно. При открытии это окно связывается с БД с нужной таблицей, например, если объект – задвижка, то с таблицей ZD. В этом окне мы выбираем нужную запись и жмем ОК. Дальше скрипт VBA прописывает все теги выбранной задвижки в нужные свойства, анимируя их. При большом количестве объектов такая штука очень удобна: меньше движений – экономия времени, мала вероятность ошибочной привязки, удобство перепривязывания при пуско-наладке.
Я читал руководство пользователя WinCC 6.0, раздел VBA. Что-то такого я там не увидел, хотя там все в общих чертах написано.
Возможно ли подобное в WinCC? А какие способы автоматизации в WinCC?

С уважением, Эдуард.

Re: Как автоматизировать разработку проекта в WinCC 6.0 SP2?
Макс Прилепский; 14.9.04

Можно использовать структурные теги, при этом название механизма делать названием структурного тега, например Valve1 - задвижка №1, Valve2 - задвижка №2. Затем сделать один объект/группу объектов с привязкой к свойствам/событиям элементов структуры

Valve1.
Если не использовать структуры, то создавать теги для однотипных объектов надо в таком ключе:
Valve1_State , Valve1_Regime, Valve1_Alarm - для задвижки №1;

Valve2_State , Valve2_Regime, Valve2_Alarm - для задвижки №2 и т.д.

В actions объекта теги определять следующим образом :

для C-Action добавлять секцию внутри которой директивой #define определять теги и далее в action к ним обращаться по переопределённым именам

// WINCC:TAGNAME_SECTION_START
#define Tag1 "Valve1.State"
#define Tag2 "Valve1.Regime"
// WINCC:TAGNAME_SECTION_END

Для VBS секция имеет такой вид:

' WINCC:TAGNAME_SECTION_START
Const Tag1 = "Valve1.State"
Const Tag2 = "Valve1.Regime"
' WINCC:TAGNAME_SECTION_END

После создания объекта в Graphics Designer этот объект или группа дублируются, выделяются и вызывается контекстное меню Linking->Tag Connections в котором в закладке Find And Replace в поле Search For вводится Valve1 , а в поле Replace With вводится Valve2, затем последовательно нажимаются кнопки Select All и Replace. В результате все привязанные к объекту теги, в т.ч. и в actions , если объявлены так, как указано выше, имеющие в названии текст Valve1 изменятcя на теги Valve2. Заменять тексты типа Static Text и ToolTip можно подобным образом с помощью контекстного меню Linking->Texts.

Все вышенаписанное, за исключением использования VBS, актуально и для WinCC 5.x
Re: Как автоматизировать разработку проекта в WinCC 6.0 SP2?
Дмитрий; 14.9.04

Как часть концепции TIA (Полная интегрированная автоматизация) WinCC в связке с STEP7 позволяет автоматизировать большинство задач проектирования комплексных систем. К сожалению в рамках форума описывать все возможности и варианты долго. Лучше один раз показать.


text

Как вытащить верхнюю и нижнюю границы шкалы аналогового тега ?
Evgen; 18.6.04

Задам вопрос по-другому: как узнать границы шкалы аналогового параметра (тега) в WinCC. Нужно для представления значения аналоговых параметров с различными шкалами в ОДНОМ элементе отображения Bar


text

Как грамотно задублировать проект?
Viktor.; 20.9.04

Имеем:

2 сервера с WinCC 5 (Дублируют друг-друга)
2 клиента.
На 1 серевере немного обновленный проект.
Надо:
Перенести проект на 2ой сервер не останавливая техпроцесс.
Я предполагаю сделать так:
1. Переключить клиентов на 1 сервер.
2. Остановить второй.
3. Запустить проджект дупликатор и закинуть проект на 2 ой сервер.
Получится?...
Просто я никогда не дублировал проекты не останавливая оба сервера.
Re: Как грамотно задублировать проект?
Чистяков Дмитрий ОАО СеверСталь; 20.9.04

Не получиться, т.к. проектдубликатор потребует остановить проект. А останавливать его он просто вынужден, т.к. иначе он не получит доступа к фалу базы данных проекта.

Re: Как грамотно задублировать проект?
Viktor; 20.9.04

Понял,... я так и думал, просто рассчитывал что я не прав ((((


text

Как добавить русский язык в WinCC?
Сергей Никулин; 9.4.04

По умолчанию в WinCC установлены только 3 языка (англ., нем. и фр.). Требуется добавить русский. В Text Library русские сообщения добавлены, но как сделать правильное переключение между языками в RunTime и в GraphicsDesigner (имеется ввиду, чтобы системы брала сообщения и надписи из Text Library)?

Re: Как добавить русский язык в WinCC?
Юрченко Владимир; 9.4.04

Самый простой способ использовать программу руссификации WinCC 6. Она будет доступна в ближайшее время на CD в региональных представительствах Сименс. Есть также описание скриптов для переключения языков в разделе PCS7 - http://www.automation-drives.ru/as/download/ascat/simatic_pcs7/readmev6.zip.

Re: Как добавить русский язык в WinCC?
Сергей Никулин; 9.4.04

Спасибо! Будем пробовать.


text

Как заставить ОР27 грузиться по MPI?
Eugene Sergeev; 23.10.04

Как заставить ОР27 грузиться по MPI?

повесил на кнопку функцию Mode, которая устанавливает Mode=5, требует еще какого-то тэга для смены режима.
Режим загрузки меняется при смене одного из этих параметров, или обоих вместе? То есть должен ли я по нажатию кнопки еще и выставлять в пятерку какой-то тэг, прикрученный к функции?
В стандартной панели смотрел - ничего не понял. Панели для экспериментов нет, она на объекте уже стоит. Надо железное решение, бо времени на объекте не будет совсем.

Re: Как заставить ОР27 грузиться по MPI?
Павел Кобелев; 28.10.04

Достаточно указать режим загрузки по MPI. Все дополнительные параметры задаются в окне загрузки.


text

Как избавиться от UserArchive?
Евгений; 2.1.03

Как работать с БД без использования функций UA и тегов. Может кто работал, используя возможности пакета ODK?

Re: Как избавиться от UserArchive?
Юрий Оганесян; 4.1.03

Да, было дело, попробовал в качестве эксперимента - заработало.

А вообще, ( хочу похвастаться :) ) мне больше всего понравилось работать с базами напрямую через ODBC (т.е., подключая, odbc32.dll) Можно из Global Script работать с любой базой - как своей, так и внешней, например, MS SQL. Еще пытался подключиться к базе данных через ActiveX компонент "ADO Control", но бросил сие занятие - лень стало...

Re: Как избавиться от UserArchive?
Евгений; 4.1.03

Спасибо, Юрий. Через ActiveX с использованием ADO - компонентов все работает. А вот через ODBC из скрипта - это интересно...

Re: Как избавиться от UserArchive?
Малкон; 3.12.04

Подскажите как это делаеться ? примерчик можно ??

Re: Как избавиться от UserArchive?
Малкон; 3.12.04

Разве UserArchive не дополняет ODK.. своими функциями ?

откуда тогда в ODK ua.. функции ?
Можно без UserArchive работать с архивом через ADO. И как это организовать ? Подключить библиотеку ado.dll ?
А для этого не нужно дополнительных опций покупать ?

См. http://revda.info


text

Как кнопку добавить
Diana; 14.4.04

Надо добавить на стандартный фэйсплейт, скажем мотора, дополнительную кнопку, которая, как минимум, будет управлять какой либо входной ногой FB, например LI_OP. Ну чтобы линк/нелинк делать. Ну и задачи вообще такого плана. Как это сделать, а то я в луже? Может кто подскажет хотя бы названия пары-тройки сплитскриновских функций, с которых раскручивать? Задача максимум управлять со стандартного фэйсплейта мотора другим FB.

Re: Как кнопку добавить
Маслов Дмитрий; 14.4.04

Какая версия PCS7? Если версия 6, то там каждая фейсплейтка - это просто картинка PDL, которую можно как угодно редактировать. Если версия 5, то там каждый фейсплейт - это ActiveX и все значительно сложнее.

Re: Как кнопку добавить
Diana; 15.4.04

Шестерочка. То, что с PDL'ками проще - это понятно, остается вопрос, как именно.

Re: Как кнопку добавить
Михайлин Сергей; 16.4.04

Значица так...

открываем нужную pdl-ку. Для мотора это будет что типа @PG_MOTOR_{тип вкладки} Например стандарт. освобождаем место под кнопку. Затем открывает картинку с готовыми заготовками для фейсплейтов, она называется @PCS7Elements.pdl Там есть готовые кнопки. Копи/Паст. Остается только в свойствах новой кнопки прописать имя входа или выхода блока, например LI_OP и настроить остальные свойства. Все остальные там скрипты уже там сделаны.
Удачи.
Re: Как кнопку добавить
Diana; 20.4.04

Спасиба! Все это очень здорово, но все равно надо решать задачу максимум. Т.е. на фейсплейт мотора добавить, например, какой-нибудь комбобокс, который будет управлять блочком OP_D, а тот, в свою очередь, врубать сигнал LOCK на самом моторе и делать еще всякие гадости далее по программе. Вообще есть ли толковая дока по поводу решения подобных задач?

Re: Как кнопку добавить
Михайлин Сергей; 23.4.04

Что-то я не допетрил... OP_D и так имеет свой фейсплат, а связка с нужной логикой "гадостей" рисуется в CFC чарте. Смешивать в одном фейсплейте данный с разных структур теоретически можно, но смысл этого ИМХО равен нулю. А дока по решению таких задач (как два блока связать) это книжка по инжинирингу.

Re: Как кнопку добавить
Diana; 23.4.04


text

Как купить ЗИП для OP35?
Владимир; 25.4.04

На OP35 со временем выходят из строя клавиши. Для OP45 есть заказной номер фронтальной панели с клавиатурой. Может кто знает для OP35. Что вообще делать в подобных ситуациях со старым оборудованием?


text

Как мне вызывать С скрипт каждую секунду ?
Малкон; 25.11.04

Необходимо в определенные моменты времени читать значения тэгов очень часто. Как мне вообще это организовать, может и С скрипты писать не надо ?

Re: Как мне вызывать С скрипт каждую секунду ?
Чистяков Дмитрий ОАО СеверСталь; 25.11.04

Вопервых. Необходимо прочитать или хотя бы просмотреть документацию по WinCC.

А вовторых, там Вы найдёте такое средство, как Global Script.
:-)))

Re: Как мне вызывать С скрипт каждую секунду ?
Панёв Константин; 26.11.04

Global Script\ Info/Trigger

:)<


text

Как настраивается OPC?
Hied; 21.10.04

Здравствуйте! На объекте будет два компа: сервер и клиент. На сервере будет стоять WinCC 6.0 SP2 64 K, на клиенте WinCC 6.0 RT 128. Для ввода уставок в контроллер я написал программу на Visual Basic, которая по OPC изменяет значения тегов. Я проверял прогу только на одном компьютере, на котором стоит WinCC 6.0 SP2 64 K – изменял значения внутренних тегов, так как нет соединения с ПЛК и нет другого компьютера-клиента. Я хотел бы узнать как должен настраиваться OPC сервер или что-то еще, чтобы моя прога с компьютера-клиента могла изменять значения тегов на компьютере-сервере? Какие трудности могут возникнуть? Я спрашиваю, потому что скоро ехать на объект и там не будет интернета и специалистов по WinCC, а сейчас нет второго компа для имитации клиента. Помогите мне, пожалуйста, дельными советами!

Заранее благодарю.
Re: Как настраивается OPC?
Андрей; 21.10.04

Основные проблемы с настройкой OPC сервера могут быть при конфигурировании DCOM для OPC серверов. Я сам не раз соединялся на машинах с разными системами (Win2000- Win98). У меня есть файл по настройке DCOM (Руководство по конфиг. DCOM для работы с удаленным OPC сервером), если надо мыльте.

Re: Как настраивается OPC?
Андрей; 21.10.04

Для изменения значений тегов, Вам скорее всего, ничего делать не надо будет, так как это берет на себя WinCC и сервер OPC.

Re: Как настраивается OPC?
-=Stealth=-; 21.10.04

Вышлите мне файл по настройке DCOM!

Заранее спасибо.
verbatium@ua.fm
Re: Как настраивается OPC?
-=Stealth=-; 21.10.04

А Вы не знаете как решить проблему с:

http://www.automation-drives.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1098348624&year=2004
Re: Как настраивается OPC?
А. Ковальчук; 5.11.04

Если не затруднит - и мне пожалста описание.

Заранее благодарен!
Re: Как настраивается OPC?
Людмила; 8.11.04

Re: Как настраивается OPC?
gregar; 8.11.04

И мне, если можно, тоже файл по настройке DCOM сборосьте, пожалуйста.

Re: Как настраивается OPC?
jkeks; 9.11.04

Кашмар, а человек владеющий информацией раз, и на plati.ru поставил свой товар... такой вот опыт. хоть 1 или 2$ а все равно уже SIEMENS - ассоциируется с тем что все технологии закрыты. Впрочем извиняюсь, не по теме.


text

Как настроить CCAgent на VPN
Александр; 7.7.04

Настроил VPN. Логически VPN - локальная сеть. Но подключение к VPN устанавливается после входа в систему и IP-адрес назначается динамически. Какими командами заставить CCAgent после установления подключения переключаться на новый (VPN) IP-адрес ?


text

как настроить OPC-сервер
Михаил; 2.12.04

Купил профибасовскую карточку CP5613,

как настроить OPC сервер, ктонибудь мож даст ссылку на инфу или на мыло вышлет.
Re: как настроить OPC-сервер
Л. Шерешевский; 2.12.04

К карте прилагается компакт-диск. Там есть все необходимое, в т.ч. и документация.

Re: как настроить OPC-сервер
Михаил; 2.12.04

Мне бы на русском я на по английски ни в зуб ногой

Re: как настроить OPC-сервер
александр; 3.12.04

на тему руского вопрос актуален

тоже хотелось бы
Re: как настроить OPC-сервер
Л. Шерешевский; 4.12.04

см.

http://www.automation-drives.ru/as/download/doc/simatic_net/profibus/05_ProjectEngineering_OPC-Server_r.pdf
и другие руководства раздела Промышленные сети SIMATIC NET / PROFIBUS / Документация
См. Центр компетенции WinCC


text

как организовать управление от панели оператора и ПК?
роман; 23.10.04

Уважаемые коллеги, поделитесь опытом, как грамотно организовать управление от ПК и панели? К ПЛК подключены ПК с WinCC и OP17, необходимо обеспечить мониторинг и управление от обеих точек. Управлять можно только с панели или только с ПК, в зависимости от установленного разрешения. Можно ли использовать одну область памяти для ОП и ПК или лучше разнести?

Re: как организовать управление от панели оператора и ПК?
2 DB; 24.10.04

использую два DB: OP1 и OP2, в которых размешаю тэги соответствующих управляющих кнопок источников управления.

В теле программы, в зависимости от состояния триггера выбора управления, работают тэги OP1 или OP2. Аварийные сигналы остановки разрешаю с обеих панелей.<


text

Как отключить функцию клика для touchpad, встроенного в клавиатуру 6GF6710-3BE
Ефременко Денис; 20.8.04

Имеется компьютер Simatic Box PC620 6ES7647-5HF30-0KX0 с подключенной клавиатурой 6GF6710-3BE со встроенным Touhpad. При ударе по touchpad срабатывает функция одинарного нажатия левой кнопки мыши. Как отключить эту функцию, чтоб кликать можно было только с помощью кнопок. Драйвера от Field PG не подходят. А то при управлении из WinCC это не совсем удобно


text

Как перекрыть ActiveX control в WinCC
Александр Андрющенко; 5.10.04

Как отобразить что-либо поверх ActiveX control в Graphics Designer?

Re: Как перекрыть ActiveX control в WinCC
Л. Шерешевский; 5.10.04

Используйте Picture Window.

Re: Как перекрыть ActiveX control в WinCC
г.Пенза, ОАО "Маяк", Миша; 6.10.04

RE: Лев Шерешевский

а вот у меня ActiveX фирмы NationalInstrument например CWVessel так вот он в любом случае отображается поверх всех окон :-(
не помогает даже свойство Foreground...
хнык хнык
че же делать???
Re: Как перекрыть ActiveX control в WinCC
Л. Шерешевский; 8.10.04

Если уж National Instrument захотел сделать свой ActiveX всегда отображаемым на переднем плане, то тут уж Siemens никак не поможет.

А может быть разработчики правы и поверх этого элемента управления действительно ничего не стоит отображать?
См. Центр компетенции WinCC


text

Как подключить TP270 к РС
макс; 1.9.04

Нужен ли при последовательном подключении нуль модем адаптер. В какой вход на TP270 их там два RS232.

И какую скорость устанавливать на PC
Re: Как подключить TP270 к РС
Дертунов Борис; 7.9.04

я подключился стандартным для RS-232 шнуром к разъёму, где написано Download

скорость выбрал 115200, но по-моему можно любую, которую позволяет устанавливать порт РС
Re: Как подключить TP270 к РС
Diana; 9.9.04

У меня там ничего не написано :( Опять надули! Разъем IF2 должен работать


text

Как подключиться к тегу
Андрющенко Александр; 16.9.04

Есть ли какая-нибудь возможность получить доступ к тегу из Java/JavaScript в HTML? Установлен WebNavigator Client 6 SP1.


text

Как поменять тип проекта
DM; 30.4.04

Как поменять тип проекта с single-user на client, если проект, теги уже созданы?

Re: Как поменять тип проекта
Маслов Дмитрий; 30.4.04

Очень просто - в WinCC Explorer'e щелкаете правой кнопкой мыши на имени проекта (левый верхний угол экрана), говорите "properties", в диалоговом окне выбираете тип проекта, говорите "OK", закрываете проект, открываете проект. Все.

Вот только, если не секрет, зачем Вам теги на клиенте? В большинстве случаев достаточно тегов сервера...<


text

Как поставить WinCC6 на неродной SQL
Александр; 30.4.04

Планирую переход с V5.1 на V6.

В качестве демо скачал WinCC V6 Disk1. Второго диска (с SQL Server) нет, но есть SQL 2000 Standard SP3. Вопрос - как его ставить? Пробовал ставить по умолчанию на instance WinCC и Windows autentification - WinCC вылетает при создании проекта с ошибкой 0x8004005.
Re: Как поставить WinCC6 на неродной SQL
Горлов Евгений; 7.7.04

Высылаю архив таблиц SQL, которыми WinCC заменяет оригинальные по пути C:\Program Files\Microsoft SQL Server\MSSQL$WINCC\Data


text

как проверить факт потери связи между PLC и ОП
bond; 21.1.04

как в Protool можно узнать о факте потери/появления связи между PLC (S7-300) и ОП (MP370), т.е. требуется запустить скрипт при потере/появлении звязи.

спасибо
Re: как проверить факт потери связи между PLC и ОП
Илья; 27.2.04

В интерфейсной области есть такая штука LifeBit, который меняется Ор-шкой с 0 на 1 и обратно 1 раз в секунду. Если его состояние не изменилось за определенный период времени - связь сдохла.

Re: как проверить факт потери связи между PLC и ОП
Astronom; 27.2.04

А что разве ОР-ка сама пез программного анализа не говорит что нет связи...

Илья, по моему лучше постоянно изменяющийся интегер
Re: как проверить факт потери связи между PLC и ОП
bond; 1.3.04

Astronom

говорить то она говорит, но что с того толку, если надо выполнить определенное действие когда это происходит

Илья
спасибо, уже таким образом и реализовал<


text

Как разместить поверх...
Владимир; 4.5.03

Picture Window другой объект, к примеру Static Text ???

В графическом дизайнере все это удается без проблем но в RunTime объекты Picture Window располагаются поверх всех остальных.
Re: Как разместить поверх...
Назаров Дмитрий; 6.5.03

Если я правильно Вас понял... Есть у Picture Window такое свойство Foreground (Поверх всех). Вероятно оно задано "Yes". Попробуйте установить его в "No".

Re: Как разместить поверх...
Владимир; 7.5.03

В том то и дело что независимо от этого свойства объект располагается поверх всех остальных.

Re: Как разместить поверх...
Максим Поджидаев; 7.5.03

Поверх Picture Window можно расположить только другой Picture Window. Если очень надо заталкивайте свой Static Text в PW2 и распологайте его поверх PW1.

Re: Как разместить поверх...
Владимир; 8.5.03

Да нет, в поставленной задаче таким образом проблему решить не удастся.

Всем спасибо, очень жаль :-(
Re: Как разместить поверх...
Владимир; 8.1.04

Хм...

Даже если один Picture Window расположить сверху другого, у обоих свойство Foreground "No", если ткнуть мышой, происходит смена порядка окон.
Динамически свойство Foreground изменять не удается. Что, управлять только свойством Visible ?
Re: Как разместить поверх...
Владимир; 9.1.04

Сверху выводится тот Picture Window, в котором находится фокус

Как разместить поверх...-2 :)
fresco; 25.3.04

Как разместить поверх Online trend contol какой-нибудь простой графический элемент? Например линию или прямоугольник. Независимо от значения свойства Layer наверху всегда оказывается тренд. Что делать?

Re: Как разместить поверх...
Alex; 25.3.04

А если попробовать разместить тренды и графические элементы в разных слоях?

Re: Как разместить поверх...
fresco; 25.3.04

>разместить тренды и графические

>элементы в разных слоях?

Свойство Layer и указывает в какой слой поместить объект.
А здесь получается так: линия в 15-м слое, тренд в нулевом, и линия все равно закрыта трендом.
Re: Как разместить поверх...
Alexis; 26.3.04

Поверх оконного контрола (ActiveX) можно разместить только другой оконный контрол, им слои по барабану..


text

Как расчитать размер архива в TagLoggin
Роман; 24.9.04

Как расчитать размер архива в TagLoggin, там пишеться цифира, а ниже указан размер в Кб/Tag, что под этим подразумевается, допустим в килобайтах 31250, делим на 1000, получается 31Мб? или егО еще надо разделить на количество тэгов?

Re: Как расчитать размер архива в TagLoggin
Чистяков Дмитрий ОАО СеверСталь; 24.9.04

Почитайте документацию - там даны все выкладки по расчётам. Я не думаю, что стоит выкладывать сюда всех их.


text

как сделать автоинкремент в архиве ?
Малкон; 29.12.04

Есть UA архив, куда пишу скриптом значения так:

uaArchiveSetFieldValueString (hArchive, 1, "malcon");
uaArchiveSetFieldValueLong (hArchive, 2, 999);
uaArchiveInsert (hArchive);

и при этом записи не добавляються.
вылазит какая-то сумашедшая ошибка:
14745680
абсолютно ни о чем не говорящая.
А запись я добавляю по хитрому, нулевое поле я не заполнил, потому что это поле ID в таблице. У этого поля я выставил параметр: Identity.
И предполагал, что после этого добавляя запись без ID, она будет создана автоматически, увеличина на 1.
Что я сделал не так ?
См. http://revda.biz


text

Как сделать связь между внутренними и внешними тегами?
Zolotoy; 6.4.04

Как реализуется связь между внешним (binary Tag) и внутренним (Unsigned 32-bit value) тегом, допустим внутренний тег один а в него поступают данные из 16 внешних тегов, соответсвенно в кадре исполнения в Static text свойства=>разное=>Display=>dynamic dialog присваевываем определённый бит определённому значению, т.е. Set енто yes, а not set ето No (Data Type = Bit)

хотелось бы это использовать для диагностики связи ...
(WinCC 5.1)

Заранее благодарен...

Re: Как сделать связь между внутренними и внешними тегами?
Макс Прилепский; 6.4.04

Для отображения 16 бинарных тегов как один 16-битный,можно в I/O field (установив его тип, как Binary)написать для свойства OutputValue Dynamic Dialog типа: 'Tag1'|('Tag2'<<1)|('Tag3'<<2)|... |('Tag16'<<15) , где Tag1...Tag16 - имена бинарных тегов PLC и поставить в Data Type окна динамического диалога тип Direct. А если значение этого поля нужно ещё и записать во внутренний тег, то на событие OutputValueChange создать DirectConnection значения OutputValue поля с внутренним тегом

Re: Как сделать связь между внутренними и внешними тегами?
Александр Родин, ООО "Нева Электрик"; 7.4.04

А почему бы просто и элементрано не адресоваться к каждому битному тагу отдельно, а поставить адресацию сразу на 16-бит слово или двойное слово ? Или у вас биты, которые вы читаете иду не по порядку ?

Re: Как сделать связь между внутренними и внешними тегами?
Zolotoy; 9.4.04

Спасибы за ответы, будем эксперементироать ;)

пока сделал по другому, вроде всё работает, время покажет ;)<


text

Как создать окно управления объектом?
Эдуард; 2.9.04

Здравствуйте, уважаемые эксперты по WinCC! Я начинаю изучать WinCC 6.0. У меня не получается сделать окно управления для какого-либо объекта (задвижки, насоса...). Например, после щелчка мышкой на задвижке должно появиться модальное окно управления задвижкой, которое имеет свой вид и свои кнопки. При этом главный экран с задвижкой не должен исчезать. И это окно управления можно было бы закрыть своей кнопкой. Как это сделать? Пробовал через NewPicture, через *.PDL - не получается.

Подскажите, пожалуйста!
Заранее спасибо!
Re: Как создать окно управления объектом?
Л. Шерешевский; 2.9.04

Уважаемый Эдуард, если Вы начинаете изучать WinCC, то очень рекомендую иногда заглядывать в online-справку. Еще лучше начать изучение с чтения документации. WinCC достаточно большой и сложный продукт. Изучив его возможности заранее, до начала практической работы, Вы сэкономите массу времени и сил.

В отношении Вашего конкретного вопроса. Почитайте в справочной системе WinCC или в прилагаемой документации о таких объектах, как Picture Window. Все Ваши вопросы отпадут сами собой.<


text

Как удалить экран в Protool?
Виктор; 6.10.03

Здравствуйте!

Помогите, пожалуйста, решить следующую проблему. Был написан проект для панели на протуле. Потом один экран оказался не нужным. Все содержимое экрана было удалено, но из списка экранов данный экран не удаляется. На запрос кросс-референса выыодит красную строку:
Screen1-(REF==QREFSCAN) REF0(1==0)/REF1(0==0)/REF2(0==0)
Кто нибудь знает в чем дело?
Re: Как удалить экран в Protool?
Игорь_К; 6.10.03

Привет!

В проекте остались ссылки на этот экран, их необходимо удалить.
Re: Как удалить экран в Protool?
Виктор; 6.10.03

Ну так и как их найти, если в кросс-референсе такая строка и ничего нет?

Re: Как удалить экран в Protool?
Виктор; 14.10.03

Так все таки, господа: как найти эти ссылки, если в кросс-референсе билиберда какая то?

Re: Как удалить экран в Protool?
Юрченко Владимир; 14.10.03

Поищите на других экранах кнопку по которой вызывется этот экран. В принципе этот экран может вызываться и из какого то скрипта, например при возникновении аларма.

Re: Как удалить экран в Protool?
Шимолин Сергей; 15.10.03

Помоему это просто глюк. У меня тоже в одном проекте нельзя было удалить Graphic Object. Сносил все - а ссылка в Cross-reference оставалась и не давала удалить картинку.. не помню что потом сделал - или в новый проект всё перетащил, или просто оставил в покое этот объект :)

Re: Как удалить экран в Protool?
Никаноров; 15.10.03

В окне кросс-референс нужно нажать Ctrl+правую кнопку мыши. Во всплывающем меню выбрать что-то вроде "Repair all errors" - не помню точно, как называется.

Вот и все.
Re: Как удалить экран в Protool?
Виктор; 16.10.03

--->>Никаноров

Спасибо, действительно все стало нормально!
Но ведь нигде про это не написано...
Re: Как удалить экран в Protool?
Казанцев; 28.1.04

Спасибо, та же беда была!!!


text

Как узнать реквизиты аналогового тега (шкала, значения уставок) во время исполнения
Evgen; 23.7.04

Здравствуйте. У меня такой вопрос.

Казалось бы простая задача - узнать шкалу аналогового тега и значения его уставок, сконфигурированных в AlarmLogging. Но как это делается в WinCC? Подскажите, пожалуйста, кто сталкивался с этим.
Re: Как узнать реквизиты аналогового тега (шкала, значения уставок) во время исполнения
Евгений Трунов; 26.7.04

Используя ODK. Например, так:

<pre>
char szProject[_MAX_PATH];
char* lpszTagName = "Tag1"; // имя нужного тега

DM_VARKEY varKey;
dword dwItems = 1;
DM_VARLIMIT varLimit;
CMN_ERROR Error;

// Узнаем точное расположение проекта WinCC
DMGetRuntimeProject(szProject, _MAX_PATH+1, &Error);

// Поиск тега по имени
varKey.dwKeyType = DM_VARKEY_NAME;
varKey.dwID = 0;
sprintf(varKey.szName, lpszTagName);
varKey.lpvUserData = NULL;

// Вызов функции ODK. После возврата структура varLimit заполняется значениями границ тега.
DMGetVarLimits(szProject, &varKey, dwItems, &varLimit, &Error );

</pre><


text

Как это реализовать в WinCC flexible
~BurAn~; 1.10.04

Многие вещи, которые были элементарными в WinCC 6.0 я не могу сделать в WinCC flexible.

У кого есть опыт работы с WinCC flexible?
Вопросы такие:
1. В WinCC 6.0 можно было создать объект, назначить всякую анимацию, а потом копировать этот объект и редактировать Тэги с помощью Link->Tag Connection. Можно ли так же делать в WinCC flexible? Если нет, то как лучше? Если у меня мотор, например, и к нему привязано 2 тега, но в различних местах (сам мотор состоит из нескольких Simple объектов)...
2. В WinCC 6.0 был объект Picture Window... Очень удобно было вызывать pop-up для управления тем же мотором... Как это красиво реализовать в WinCC flexible
3. (думаю не последний) В WinCC 6.0 был прекраный тул, позволящий редактировать весь проэкт в Excel... Я применял его постоянно для копирования Тегов... Если в проэкте тысячи Тегов, то я себе не представляю как же каждый тег в ручную добавлять... Как с этим дело обстоит в WinCC flexible?

Спасибо заранее за множество содержательных ответов :-)
Можно через ICQ: UIN 253235<


text

Каким образом создать оперативный отчет (двухчасовки)?
Hied; 24.11.04

Здравствуйте! Скажите, пожалуйста, как лучше создать оперативный отчет (каждые два часа)? Операторы должны видеть и распечатывать значения определенных аналоговых сигналов каждые два часа. Объясните, пожалуйста, как это реализуется в WinCC 6.0 SP2? Заранее спасибо!

Re: Каким образом создать оперативный отчет (двухчасовки)?
Nick Gashevsky; 24.11.04

Для формирования двухчасовок программно доставал данные из архивных тегов, заполнял форму отчета через внутренние теги и печатал ее.

Re: Каким образом создать оперативный отчет (двухчасовки)?
Маслов Дмитрий; 28.11.04

Можно сделать проще, обойдясь стандартными средствами WinCC.

Создайте архив, в который будут попадать данные по двухчасовкам. Для этого опишите в TagLogging свой таймер, который будет срабатывать на границе каждых двух часов. Добавьте в архив теги, которые должны присутствовать в отчете. Поставьте им требуемое время опроса, а в качестве цикла архивации укажите свой таймер. Задайте требуемую функцию обработки (минимум, максимум, среднее и др.). Затем данные этого архива отображаются в Report Designer с помощью стандартного элемента - таблички. Способ проверен на нескольких реальных проектах.
См. http://www.wincc.ru


text

Какой в PDL класс окон ?
Александр; 16.11.04

Есть ли метод добраться до HWND окон WinCC ? Через FindWindow нашел только основное окно - класс PDLRTisAliveAndWaitsForYou. Какой же, интересно знать, класс у дочерних окон ?

Re: Какой в PDL класс окон ?
Alexis; 16.11.04

Запустите Spy++ и посмотрите...


text

Какой комплект поставки WinCC flexible
Flex; 12.11.04

Подскажите, что идет на втором диске WinCC flexible, который запрашивается после установки с первого диска. Пробовал Компакт, Стандарт и Адвансед режимы установки, во всех вариантах запрашивает еще диск.

Re: Какой комплект поставки WinCC flexible
Лев Шерешевский; 12.11.04

Без второго диска поставить WinCC flexible Вам вряд ли удастся.

А что конкретно Siemens вынес во второй диск, сказать непросто. Вот некоторые названия каталогов, находящихся на диске №2:
Migration
MSDE
OPCXMLWrapper
Options
ProSave
Runtime
System
DeviceDriver
Images
Manuals
SmartClient
См. Центр компетенции WinCC


text

Какой тег вызвал action ?
Александр; 4.6.04

Подскажите самый простой способ узнать в action (WinCC6 C-Editor), какой именно тег вызвал action, если тегов-триггеров несколько?

Re: Какой тег вызвал action ?
Nick Gashevsky; 4.6.04

А если в action прочитать состояние тегов (сразу при вызове); можно попробовать дополнительно проанализировать что-то вроде

Set objTag = HMIRuntime.Tags("Result")
objTag.TimeStamp <


text

Квитирование Alarm message
Michon; 7.10.04

Как квитировать все активные на данный момент алармы, если окно сообщений расположено на другой картинке? Алармы не сгруппированы.

Т.е. Есть картинка, на котором показываются все нарушения и надо разместить в ДРУГИХ картинках кнопку, при нажатии на которую все нарушения квитировались бы. Это возможно?
Re: Квитирование Alarm message
Маслов Дмитрий; 11.10.04

Создайте групповое сообщение, в которое добавьте все Ваши сообщения. Назначьте ему тег квитирования. По кнопке квитируйте все сообщения с помощью бита квитирования группового сообщения.

См. http://www.wincc.ru

Re: Квитирование Alarm message
Прокопенко Вера; 13.10.04

Есть еще вариант (без создания групповых сообщений и дополнительных тегов). Создать кнопку к которой привязать скрипт:

for(i=1;i<=nn;i++)
AcknowledgeMessage(i);
//nn-номер последнего сообщения

Т.о. квитируются по очереди все аварийные сообщения

Re: Квитирование Alarm message
michon; 14.10.04

Большое спасибо.

Так и сделал (с помощью цикла)

Надеюсь, то, что я квитирую не активные на данный момент алармы ни на что не повлияет :)
Re: Квитирование Alarm message
ОАО "Маяк" г.Пенза, Миша; 14.10.04

А как получить количество алармов?

Re: Квитирование Alarm message
Прокопенко Вера; 19.10.04

Квитирование неактивных алармов ни на что не влияет. Количество nn задаем жестко по количеству алармов в AlarmLogging. Если задавать больше, могут быть ошибки. Динамически количество аварий пока не определяем, надо посмотреть ODK функции.


text

Кириллица в Alarm Logging
Роман; 21.10.04

Как сделать так, что бы в Alarm Logging

в RT текст сообщений отображался на русском языке....

За ранее благодарен.
Re: Кириллица в Alarm Logging
Чистяков Дмитрий ОАО СеверСталь; 21.10.04

Смотрите на этой же странице ниже.

См. http://www.automation-drives.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1045054658&year=2004

Re: Кириллица в Alarm Logging
Дмитрий; 21.10.04

1)NLS в реестре заменить ср_1250-ср_1254 на ср_1251;

2)Выбрать кирилический шрифт в Controle.<


text

клиент - сервер ВинСС 6.1
zolotoy; 15.12.04

нужен клиент чтобы немешать работе оператора, т.е когда кто-нибудь переключает кадры исполнения оператор этого не видит... например начальнику надо посмотреть тредны, а оператору в свою очередь включить насос (кнопка включения находится в другом кадре исполнения), и получается кто вперёд нажмёт тот и сделает задуманное... :(

пробовал клиента ВинСС и веб клиента ВинСС неполучается...
получается один выход: ставить второй полноценный сервер (с 5611 картой, соеденять с контроллером) для этих целей и больше никак ?

Re: клиент - сервер ВинСС 6.1
Alexis; 15.12.04

обычный клиент-серверный проект, ставится один винЦЦ-сервер и кучка клиентов... с клиентов операторы творят все что им позволено... ртфм и еще раз ртфм, там все есть...

Re: клиент - сервер ВинСС 6.1
zolotoy; 15.12.04

дык Сервак стоит у оператора на станции, а все клиенты работают удаленно с этой

тачкой. Все изменения на сервере отображаются на клиентах.
Re: клиент - сервер ВинСС 6.1
Alexis; 15.12.04

сервак отделить, оператора на клиента посадить...

Re: клиент - сервер ВинСС 6.1
zolotoy; 15.12.04

:) всё равно проблемы нерешает... :((

т.е. например есть пара кадров исполнения: "Тренды" и "Насосная"
дык опер жмёт на насосную кадр открываетца и на серве и на кленте синхронно... а надо чтоб на серве был кадр "Тренды" а на клиенте "Насосная"
Re: клиент - сервер ВинСС 6.1
Alexis; 15.12.04

раз синхронно открывается на разных компах - значит у вас проект криво написан...

Re: клиент - сервер ВинСС 6.1
zolotoy; 15.12.04

а где ента кривизна ?

Re: клиент - сервер ВинСС 6.1
Alexis; 15.12.04

хех... вот бы знать как у вас проект сделан :))

по какому принципу при нажатии на кнопку кадр меняете?
аська есть?
Re: клиент - сервер ВинСС 6.1
Руденко Алексей "НЕВИСС-Комплекс"; 15.12.04

Суть в следующем - для каждого тэга (во всяком случае локального) есть настройка (в его свойствах) обновлять данные только для локальной машины или для всего проекта - вот ее и надо поменять.

Удачи.
Re: клиент - сервер ВинСС 6.1
zolotoy; 16.12.04

для открытия кадра сделал общий для всех окон внутренний текстовый тег 8 -битной кодировки (PictureName), далее в свойствах кнопки: события => действие мыши => прямое соединение => константа - pumps.PDL => тег PictureName (напрямую)

поставил в свойствах тега "обновление на этом компьютере" ( у меня ВинСС русифицирован) и непомогло :(((
ICQ есть, номер 313917528
Re: клиент - сервер ВинСС 6.1
Макс Прилепский; 16.12.04

Сделайте навигацию без использования тегов, например, с помощью C-Action на событие Mouse Action кнопки переключения экрана: SetPictureName(lpszPictureName,"Имя кадра", "Pumps.PDL");

Re: клиент - сервер ВинСС 6.1
zolotoy; 17.12.04

а "Имя кадра" это где находится кнопка запуска pumps.PDL ? у меня проект в стадии начала... на машиене с windows 2000 ENG так вот стартует он у меня с кадра start.PDL который в свою очередь разбит на две области: в верхней кнопки запуска окон в нижней "PictureWindow"...

запускаю окна через c-action так:
SetVisible(lpszPictureName, "tanksWnd", 0);
SetVisible(lpszPictureName, "pumpsWnd", 1);
и ещё второе окно tanks.PDL
SetVisible(lpszPictureName, "pumpsWnd", 0);
SetVisible(lpszPictureName, "tanksWnd", 1);

и ещё кагда открываетца проект в браузере с другой машины по средствам вебклиента вместо русских букв стоят вопросы... :( смена кодировки в браузере непомогает :(

Re: клиент - сервер ВинСС 6.1
Чистяков Дмитрий ОАО СеверСталь; 17.12.04

У Вас не правильно выбран язык у пользователя в User Administrator.

Либо Вы все кадры сделали в Английском (он по умолчанию стоит), а в User Ad.. установили русский.
Re: клиент - сервер ВинСС 6.1
zolotoy; 20.12.04

так и есть с языками напутал... поставил рус и всё ок...


text

Клиент/Сервер
Sergey; 31.5.04

Необходимо настроить конфигурацию Клиент/Сервер. Т.е. необходимо сделать так, чтобы проект WinCC находящийся на одной машине можно было запустить на другой и параллельно наблюдать режим RinTime. Подскажите какие необходимо сделать настройки для этого. Заранее благодарен.

Re: Клиент/Сервер
Николай "НПФ РАКУРС"; 1.6.04

Я в основном занимаюсь нижним уровнем, поэтому прошу не судить строго если я вас неточно понял ))) Могу рассказать как мы делали распределенную систему, проект находился на сервере, а доступ к нему можно было получить с любой машины в сети. Использовали терминальный сервер входящий в состав Win2K Server - все очень быстро работало и трафик в сети при таком способе минимален. Единственное, что я не знаю будел ли WinCC работать с терминальным сервером, мы делали на Intouch. Теоретически должен

Re: Клиент/Сервер
Sergey; 1.6.04

Николай, если знаешь подскажи какие настройки необходимо сделать.

Я делал так:
1) Проект WinCC multi-client
2) Добавляю новый компьютер WinCC-клиент
3) Делаю доступ к папке и добавляю пользователя с правами администратора у себя на компьютере
4) На другом компьютере подключаю сетевой диск с этой папкой
5)Пытаюсь открыть проект WinCC нс другого компьютера и возникает ошибка
Может необходимо ее что настроить.
Подскажи если знаешь. Заранее благодарен

Re: Клиент/Сервер
Sergey; 1.6.04

Николай, если знаешь подскажи какие настройки необходимо сделать.

Я делал так:
1) Проект WinCC multi-client
2) Добавляю новый компьютер WinCC-клиент
3) Делаю доступ к папке и добавляю пользователя с правами администратора у себя на компьютере
4) На другом компьютере подключаю сетевой диск с этой папкой
5)Пытаюсь открыть проект WinCC нс другого компьютера и возникает ошибка
Может необходимо ее что настроить.
Подскажи если знаешь. Заранее благодарен

Re: Клиент/Сервер
Sergey; 1.6.04

Николай, если знаешь подскажи какие настройки необходимо сделать.

Я делал так:
1) Проект WinCC multi-client
2) Добавляю новый компьютер WinCC-клиент
3) Делаю доступ к папке и добавляю пользователя с правами администратора у себя на компьютере
4) На другом компьютере подключаю сетевой диск с этой папкой
5)Пытаюсь открыть проект WinCC нс другого компьютера и возникает ошибка
Может необходимо ее что настроить.
Подскажи если знаешь. Заранее благодарен

Re: Клиент/Сервер
Николай; 2.6.04

Я к сожалению, не очень знаком с WinCC multi-client. Но постараюсь что-нибудь узнать. А что он пишет при даной ошибке???

Re: Клиент/Сервер
Сергей Колпащиков; 2.6.04

Если у вас WinCC 5 вариант без входа в домен:

1. Паку расшаривать ненадо она автоматом шарится
2. Компьютеры должны быть в одной подсетке
3. Одной рабочей группе (не точно)
4. Клиентская машина должна быть под юзером/паролем заведенным на серверной машине с правами администратора. Лучше вообще Сервер и клиентов запускать по одним юзером с правами админа

<


text

Клиентские проекты
mlr; 20.12.04

В клиентских проектах WinCC v6 SP1 вызов администрирования пользователей и закладки 'параметры' в свойствах компьютера напрочь вешает проводник WinCC. Что за напасть такая? Или это только у меня так...

Re: Клиентские проекты
zolotoy; 20.12.04

дык енто рулитца токо с сервера ВинСС кажись... раньше работало ?

была подобная причина, непомню в деталях где, но помог только переинсталл... как вариант снести всё и заново поставить включая и виндавс...<


text

Кнопки с фиксацией
Авхадеев В.В.; 1.6.04

в готовом проекте надо добавить 6 кнопарей. причем первая кнопка шлет на 1 бит определенного байта. вторая шлет на 2-й бит , третья на 3-й. и так далее.

есть одно ограничение: сигнал (1) должен держаться постоянно, пока кнопка нажата. кнопки все "утапливаемые", т.е. с фиксацией. если нажимаем одну, т другая должна отжаться. что посоветуете?
Заранее благодарен.
Re: Кнопки с фиксацией
Л. Шерешевский; 1.6.04

В похожей ситуации мы по нажатию кнопки вызывали функцию проекта, в которую передавали имя нажатой кнопки. Данная функция производила необходимые действия со всеми кнопками группы. Имитация утопленного состояния кнопки производилась сменой цветов блика и тени (3D Border Color и 3D Shadow Color). Конечно, это решение красивым не назовешь, но оно работоспособное.


text

Когда "висит" Система.....
Игорь Одесса; 18.11.04

Дано:

Есть диспетчерский пульт на базе персонального компьютера c OS
Windows 2000 sp4, с запроектированной SCADA-ой WinCC v6.0. В WinCC скриптами реализованы технологические алгоритмы во многом определяющие функциональность Системы.

Вопрос:
При "зависании" програмного обеспечения, не важно - WinCC явилось источником проблемы или Windows,
как проинформировать оператора диспетчерского пульта о возникшей проблеме?
Re: Когда
Маслов Дмитрий; 19.11.04

Настройте watch dog timer в BIOS'e. Если все подвисло, машина перезагрузится.


text

Компиляция ProTool 6?
Den; 19.1.04

Возможно ли компилирование проекта в ПроТул для автономного использования без ПроТул (визуалзация и управление на PC контроллером S7-200)


text

Конвертация из tp070 в mp270
Den Tigarbo; 9.3.04

Как конвертить прогу MicroWin для 70 панели в ProTool для MP270 например?

Re: Конвертация из tp070 в mp270
Роман Абзаев; 9.3.04

Никак. Придётся переписывать руками. Дело в том, что ТР 070 стоит несколько особняком от обычных панелей - ведь она даже программируется без помощи ProTool.

Re: Конвертация из tp070 в mp270
Eleria; 23.4.04

программируется она и из ProTool но если загруженная прога написана на TP Dedigner то все придется переписывать руками :(


text

КОНВЕРТАЦИЯ ИЗ ТЕКСТОВОГО ТЕГА В ЧИСЛОВОЙ-DECIMAL
ALEX; 16.10.04

ЛЮДИ ПОДСКАЖИТЕ ВОЗМОЖНО ЛИ РЕШИТЬ СЛЕДУЮЩЕЕ-

КАК Я МОГУ КОНВЕРТИРОВАТЬ ИЛИ ПЕРЕВЕСТИ ПОЛУЧЕНЫЙ ТЕГ ТЕКСТОВОГО ФОРМАТА(TEXT 8-16 BIT FORMAT) В ТЕГ UNSIGNED DECIMAL FORMAT C ПОМОЩЬЮ C-ACTION.При условии что текстовый тег будет содержать только числовые значение.
Re: КОНВЕРТАЦИЯ ИЗ ТЕКСТОВОГО ТЕГА В ЧИСЛОВОЙ-DECIMAL
Маслов Дмитрий; 17.10.04

SetTagWord("Тег1", atoi(GetTagChar("Тег2")));

См. http://www.wincc.ru


text

конвертация программы OP 37 в МР 370
Игорь Одесса; 29.11.04

Г-да подскажите, возможна ли конвертация программы из OP 37 в МР 370?

Re: конвертация программы OP 37 в МР 370
Юрченко Владимир; 30.11.04

Конечно возможна (смотрите в ProTool File/Convert. Графику может прийдется подправить из-за разного разрешения дисплеев и в зависимости от типа панели MP370(если например Touch) и особенностей OP37 изменить чтото в функциях.

Re: конвертация программы OP 37 в МР 370
Игорь Одесса; 30.11.04

А как насчет символьной графики, все надо будет ручками перерисовывать, или есть варианты?

Re: конвертация программы OP 37 в МР 370
Сидоров Артем; 7.12.04

Лучше перерисовать. Графические картинки конвертируются, но не всегда хорошо. Учитывая то, что МР370 предоставляет намного больше возможностей (в т.ч. и графических) реализация с ноля будет выглядеть намного красивее:)


text

Контролируемый ввод текста в поле IOField
Павел; 25.6.04

Задача при вводе текста в поле ввода/вывода необходимо после каждого нового добавленного символа производить действие связанное с тем что вводится. Проблемы- цеплятса за изменение поля Инпут - бесполезно, т.к. оно меняется только по нажатию кнопы Интер, за поле Оутпут - вообще не то. Заявленное свойство - Немедленный ввод - не помогает и вообще с ним или без него разницы нет. Поле Инпут обновляется только после нажатия Интер или потери фокуса, т.е. когду уже все введено, а задча делать это во время исполльзуя то что введено. Путано немного, но пршу помочь....

Re: Контролируемый ввод текста в поле IOField
Павел Кобелев; 25.6.04

Вот так, навскидку, стандартными средствами WinCC не получится. Можно было бы обрабатывать события KeyUp и KeyDown, но нет средств определить текущее положение курсора в поле ввода.

Используя IndustrialX - легко.
Re: Контролируемый ввод текста в поле IOField
Nick Gashevsky; 25.6.04

Навскидку 2 варинта

1. Сваяй свой элемент управления (Ole object) какой тебе нужно, вставь в WinCC.
2. Перехватывай нажатия на клавиши
Re: Контролируемый ввод текста в поле IOField
Павел; 26.6.04

Для Павла Кобелева:

Возможно ли по входным параметрам этих событий определить какая кнопка нажата, т.к. например при русском активном языке определить что нажато довольно проблематично.
Re: Контролируемый ввод текста в поле IOField
Владимир; 27.6.04

Вставляешь объект Static Text/IO Field, на нем в Events - keyboard - press пишешь все что тебя волнует :-)

я так делал, когда потребовалось создать сой оригинальный обработчик ввода данных.
вобщем то никаких проблем.
Re: Контролируемый ввод текста в поле IOField
Павел; 28.6.04

Сразу вопрос, как использовать входные параметры этого события КейПресс, особенно на предмет активного русского языка?? И вообще есть где нить помощь по событиям всяких там элемнотов ГрафРедактора.

Re: Контролируемый ввод текста в поле IOField
Павел Кобелев; 28.6.04

В событие передается код клавиши без учета языка ввода. Проблемы могут возникнуть при редактировании уже существующего значения, так как в отличие от полноценных визуальных языков, нет возможности определить позицию в которой осуществляется ввод.

Re: Контролируемый ввод текста в поле IOField
Павел; 29.6.04

Похоже что интерес к этой теме угас, а жаль...

А то у меня еще пара вопросов:
1. Как WinCC вообще переключается на русский ввод? При вводе текста в ИОполе вывожу по фунции GetKeyboardLayout текущий язык. И блин!!, он всегда АНГЛИЦКИЙ!!! - 000409!!! Но текст, то вводится по РУССКИ, а это 000419!!! Просто ШАМАНЫ от Сименса.
2. Те параметры что передаются в события КейПресс(Даун) просто обман покупателя! Смысл имеет только nChar содержащий СканКод кноп, а остальное просто плосский немецкий юмор! Вот например по схожим событиям Американского ТекстБокса - имеем СканКод и ВиртуалКод кноп, плюс имеется реакция на переключения Языка.
А вы так просто взяли и забыли эту интересную тему....
Re: Контролируемый ввод текста в поле IOField
Кобелев Павел; 29.6.04

То что вам надо присутствует в стандартном элементе управления Microsoft Visual Basic, который называется TextBox. Воспользуйтесь им, или создайте свой. Используя IndustrialX в него можно включить работу с тегами вашего проекта. Если есть вопросы, могу ответить по E-mail.

Re: Контролируемый ввод текста в поле IOField
Павел; 29.6.04

IndustrialX это еще одна замануха от Сименса стоимость 1.500 евриков как минимум. Ведь есть же заявление что ВинСС полностью поддерживает АктивХ, но на деле то одно глючит, то другое вообще систему роняет.

А вообще имеется демо версия ИндстХ 1.0 и адпдейт на нее 1.1, но она чего то не хочет инсталится, пишет что надо ВинСС выше 4.1, ну а у меня 5.1. Вот таки дела...
Re: Контролируемый ввод текста в поле IOField
Nick Gashevsky; 29.6.04

Можно попробовать так:

Добавь Соntrol типа S7WCNumber (из Simatic Net) и на его Events KeyPress привязать функцию типа
SetPropDouble( lpszPictureName,"IOFieldTest","OutputValue",KeyID);
В поле IOFieldTest увидим код клавиши (с русским)
Правда позиция текста неизвестна
Re: Контролируемый ввод текста в поле IOField
Владимир; 29.6.04

В моем случае, действительно, требовался ввод только цифр.

Проблема раскладок меня не коснулась...
Re: Контролируемый ввод текста в поле IOField
Павел; 2.7.04

Для Nick - спасибо за помощь, к сожелению не смогу это проверить еще дней 15, ушел в отпуск.

А реальность оказалась еще суровей, по nChar не то что языки нельзя различать, но даже верхний/нижний регистры не получится.
Хотя, параметры этих событий (КейДоун и Пресс) очень похожи при обработке события WM_CHAR для ВизуалС. Вот только там, nChar - это символ с учетом и языка и регистра, nRepcnt - число повторений нажатия, nFlags - дополнительные флаги. В нашей ВинСС все гораздо скромней, или я не прав?
Re: Контролируемый ввод текста в поле IOField
Darwin; 2.7.04

А для какой ситуации то надо обрабатывать все это? Просто жутко любопытно стало для чего все это надо.

Re: Контролируемый ввод текста в поле IOField
Кобелев Павел; 2.7.04

Ну ежели очень сильно надо так глубоко лезть - пиши верхний уровень на том-же Visual Basic + OPC сервер.


text

Контроль наличия связи с PLC в ProTool RT
Darwin; 12.7.04

Такая задачи:

1.в случае если нет связи с одним из трех контроллеров то необходимо скрыть кнопку записи параметров в эти контроллеры.

При разрыве связи во время работы в ProTollRT выводится сообщение о потере связи. Я так думаю, что есть бит или слово которое выставляется после потери связи? Пробовал сделать так: в PLC установил бит всегда в 1, в ProToolRT читается этот бит (инициализуруещее значение 0 в Properities->Options) не проходит т.к. остается значение 1 и ProToolRT не дает никакой реакции во время потери связи.
(связь через TS adapter)<


text

Курс VBA для WinCC
Сергей Н.; 30.10.04

Господа инженеры,подскажите существует ли учебный курс VBA специально для WinCC? Если нет, то посоветуйте что лучше почитать начинающему специалисту.

С уважением, Сергей!
Re: Курс VBA для WinCC
Маслов Дмитрий; 1.11.04

Читайте WinCC Information System, раздел Working with WinCC -> VBA for Automated Configuration

См. http://www.wincc.ru

Re: Курс VBA для WinCC
Сергей Н.; 1.11.04

Что то я не могу найти WinCC Information System среди документации?

Re: Курс VBA для WinCC
Сергей Н.; 1.11.04

Что то я не могу найти WinCC Information System среди документации?


text

Лицензия к DiagnoseTool
Дмитрий; 15.11.04

Поставил сие тулсы, штука мне понравилась, но WinCC в рантайме при отображении этого ActiveX требует какую-то лицензию. Определить, что ей надо стандартными способами не удолось?

Re: Лицензия к DiagnoseTool
Михайлин Сергей; 15.11.04

DiagnoseTool лицензируется как и другие продукты Сименс. Нужна лицензия, которая ессно входит в поставку этого пакета, если он конечна куплен.


text

Логическое исключение объектов
Panyov Konstantin; 14.9.04

Здравствуйте господа! Подскажите пожайлуста существует ли возможность логического исключения неработающего КП с помощью WinCC 5.1. Существующая конфигурация: на КП - CPU314-2DP + TIM32; на ПУ TIM42 и PC. Заранее очень благодарен за ответ.

Re: Логическое исключение объектов
Л. Шерешевский; 14.9.04

Уважаемый Константин, что Вы понимаете под "логическим исключением неработающего КП"? Любую обработку состояний КП следует производить в ПУ на уровне контроллера, с помощью имеющихся в SINAUT ST7 функций диагностики. А уж отобразить все это в WinCC можно каким угодно образом.

Re: Логическое исключение объектов
Panyov Konstantin; 14.9.04

Под логическим исключением я понимаю прекращение опроса КП в случае отсутствия с ним связи. То есть возможна ли посылка какой-нибудь команды из РС в TIM-мастер для того что бы он (TIM-мастер) перестал пытаться установить соединение с удаленным КП.

Re: Логическое исключение объектов
Л. Шерешевский; 14.9.04

Да, можно. Только команда с PC фактически сводится к сбросу одного бита. А вся логика реализуется в CPU, управляющем TIM-модулем.

Re: Логическое исключение объектов
Panyov Konstantin; 14.9.04

В нашем случае TIM-модулем никто не управляет. Он Master то есть он инициирует обмен с остальными Slave устройствами переферии и связан он непосредственно с PC-станцией в которую к конечном счете и передается вся информация. То что команда в WinCC это всего лишь сброс или взвод тега это понятно. Существует ли тогда какой-нибудь внутренний (то есть генерируемый самой системой) тег в котором записываются Subscriber-ы всех КП с которыми связан TIM-master?


text

ЛЮДИ ДОБРЫЕ, ПОМОГИ СО СВЯЗЬЮ S7-200 и WINCC
Миша; 2.3.04

Я в инете не силен. скорость маленькая. искать нет возможности ответ. Будте добры...

Нужно связать WinCC 6.0 и S7-226. У меня стоит контрогллер подключеный к компьютеру по PPI кабелю. Как штобы в проекте WinCC было доступно S7-200??? йте =) (желательно по PPI)
Re: ЛЮДИ ДОБРЫЕ, ПОМОГИ СО СВЯЗЬЮ S7-200 и WINCC
Yrok; 2.3.04

напрямую в лоб никак, но есть OPC Server для S7-200 который связывается по ProfiBus, производитель Siemens.

Если интересует именно через PPI то используй KepServer
http://www.kepserver.com/ искать там дальше в лом но у меня где то ещё демо Server болтается.
Но через PPI это ещё не очень хорошо но если так хочешь то лучше используй преоразователь Ethernet в RS485, тогда можешь поставить контроллер где угодно, то есть растояние в отличие от PPI кабеля не так лимитировано и точно так же через KepServer связывайся.
Совет лечше используй ProfiBus.
Re: ЛЮДИ ДОБРЫЕ, ПОМОГИ СО СВЯЗЬЮ S7-200 и WINCC
Yrok; 2.3.04

Адрес преобразователя

http://www.advantech.com/products/Model_Detail.asp?model_id=1-D6FMP&bu=
Re: ЛЮДИ ДОБРЫЕ, ПОМОГИ СО СВЯЗЬЮ S7-200 и WINCC
MooR; 2.3.04

А протула нет у Вас? Того который Про? Он умеет двухсотки цеплять по PPI кабелю. В противном случае придется использовать ОРС сервер.

Re: ЛЮДИ ДОБРЫЕ, ПОМОГИ СО СВЯЗЬЮ S7-200 и WINCC
Юрченко Владимир; 2.3.04

OPC сервер для S7-200 (SIMATIC S7-200 OPC V1.0 + SP1) можно скачать по ссылке www4.ad.siemens.de/-snm-0135038936-1077799491-0000013415-0000000001-1078210867-enm-WW/csius/en/10834038.

Второй способ - использовать протокол Modbus. Для этого в Микровине с помощью визарда сделать S7-200 как Modbus slave и в WinCC задействовать драйвер для Modbus (правда в 6-ой версии WinCC его уже нет).
Re: ЛЮДИ ДОБРЫЕ, ПОМОГИ СО СВЯЗЬЮ S7-200 и WINCC
kot; 2.3.04

В tip&triks есть пример работы ModBus Slave для S7-200. В WinCC организуешь канал ModBus. Отлично вяжутся.

Re: ЛЮДИ ДОБРЫЕ, ПОМОГИ СО СВЯЗЬЮ S7-200 и WINCC
Вячеслав; 9.3.04

У меня, в общем-то, то же вопрос - соединить WinCC v5.1 с CPU224, только у меня есть Profibus DP модуль EM 277, а на компьютере CP5412A2. Вопрос - какое соединение выбирать в WinCC и какие параметры там писать (если соединение Profibus, то Rack=? Slot=?).

P.S. Нужные мне данные лежат в DB1 начиная с VB101.
Заранее благодарю.
Re: ЛЮДИ ДОБРЫЕ, ПОМОГИ СО СВЯЗЬЮ S7-200 и WINCC
Vladimir; 30.6.04

Самый класный варивнт это подключить S7-220 через Ethernet (CP243)

Подробнее могу скинуть инфо по mail.
Re: ЛЮДИ ДОБРЫЕ, ПОМОГИ СО СВЯЗЬЮ S7-200 и WINCC
В. Сорокин; 3.7.04

Здравствуйте, Миша!

Вы попали. С 200-м связаться по РРI - головныя боль. Но, если связался, то боль становится больше - скорость заедает (по пол минуты ждать приходится). Бросьте, слушайте тех, кто про езернет говорит.<


text

ЛЮДИ!!! никто не работал с MicrosoftFlexGrid 6.0 ???
Михал; 27.8.04

Есть компанент ActiveX MicrosoftFlexGrid 6.0. Как туда добавлять строчки и как ее заполнять?

Re: ЛЮДИ!!! никто не работал с MicrosoftFlexGrid 6.0 ???
Лёха; 27.8.04

Re: ЛЮДИ!!! никто не работал с MicrosoftFlexGrid 6.0 ???
----> Лёха; 27.8.04

Пришли VSFlexGrid мне на mailevdo@mail.ru

Re: ЛЮДИ!!! никто не работал с MicrosoftFlexGrid 6.0 ???
Павел Кобелев; 1.9.04

В MSFlexGrid для поячеечного заполнения есть свойство TextMatrix.

В синтаксисе VBS выглядит так:

Obj.TextMatrix(Row, Col) = "xxx"

Менять размер можно просто изменяя значения свойств Cols и Rows.

Re: ЛЮДИ!!! никто не работал с MicrosoftFlexGrid 6.0 ???
->Павел Кобелев; 1.9.04

Это то понятно :))

я имел ввиду методами самого объекта (причем на С).

т.е. например obj->Rows = 4 - типа делаем 4 строчки у него, а вот заполнять этими методами как?
SetPropWord("Row",3)
SetPropWord("Col",4)
SetPropChar("Text","sdfgsdfg") не подходит!!!!!!!
<


text

Масштаб времени в отчетах графиков
oleg; 17.12.04

При создании отчетов графиков ReportDesigner выводит на печать шкалу времени, которую делит на пять отрезков. Есть ли возможность разбить шкалу на большее количество интервалов.

ReportDesigner не предусматривает такой возможности. Если есть какое-нибудь решение, подскажите пожалуйста.
Re: Масштаб времени в отчетах графиков
Маслов Дмитрий; 27.12.04

Что-то мне подсказывает, что прямого решения нет. Но можно попробовать печатать отчеты не через Report Designer, а непосредственно из окна просмотра трендов, например, печатая копию соответствующей части экрана. Такое решение, конечно, не подойдет, если требуется печатать отчеты не в интерактивном, а в автоматическом режиме.


text

Масштабирование не подходит
Yrok; 25.5.04

Люди добрые подскажите как сделать?

Имется контроллер Siemens TI505 (6 штук)в WinCC создаю соединения "SIMATIC TI Serial.CHN" и качаю с каждого контроллера где теги, Но программа написана так что все значения там в целых числах например:
123 соответствует 12,3. Вывод значения для оператора посредством панели (Она то может сама делить на 10.0).
Не могу придумать как это сделать средствами WinCC без использования скриптов.
Пробовал использовать масштабирование в свойствах тега - работает не так как хотелось бы. При этом значение тега не делится на 10.0, а просто округляется и подводится под масштаб.

Поскажите как сделать?
Re: Масштабирование не подходит
Александр Родин, ООО "Нева Электрик"; 25.5.04

Это потому что тип тега установлен целочисленным.

Можно в свойстве OutputValue поля вывода выбрать Dinamic Dialog, установить Data Type -> Direct, а в поле Expression/Formula записать выражение типа '<Имя тега>'/10.0 (точка обязательна). Но лучше все-таки через скрипт. :)
А в таглоггинге для этого есть два волшебных столбика Processing и Action for processing. Собсственно, в Processing вместо Actual value ставится Action для тех переменных, которые требуется масштабировать, а в Action for processing указывается имя шаблонной функции которая создается по следущему шаблону:

#include "apdefap.h"

double div10 (double doLmtValue, double doValue, int dwCount, BOOL dwFlag)
{
return doValue/10.0;
}

Тогда в архивах будут сохраняться масштабированные значения.<


text

Мерцание экрана в WinCC
Василий Дорофеев; 13.1.04

При смене значений на экране, под числом, наблюдается мерцание. При этом

один и тот-же проект на разных компьютерах может мерцать,а может не мерцать.Подскажите как от мерцания избавиться.
Re: Мерцание экрана в WinCC
Макс Прлепский, ОАО "ЗСМК"; 13.1.04

Если мерцание не вызвано динамическим изменением свойств объекта (например,посредством Dynamic Dialog), то , возможно, проблема в драйверах видеокарты или работы WinCC с ними. Попробуйте в свойствах экрана -> Дополнительно -> Устранение неполадок -> Аппаратное ускорение изменить значение этого параметра

Re: Мерцание экрана в WinCC
Василий Дорофеев; 13.1.04

Аппаратное ускорение не помогает. Что-то очень простое, а ЧТО? Помогайте.

Re: Мерцание экрана в WinCC
Макс Прилепский, ОАО "ЗСМК"; 14.1.04

Можно в WinCC Explorer попробовать поставить/убрать флажок Optimized Drawing в свойствах компьютера в категории Turn Off во вкладке Graphics Runtime. Если этого флажка нет (установка по умолчанию), то картинка собирается в оперативной памяти, а потом целиком выводится на экран. А если флажок установлен, то вывод происходит поэлементно, что может привести к мерцанию, хотя, в этом случае вывод на экран полностью зависит от производительности видеокарты в 2D.

Re: Мерцание экрана в WinCC
Владимир; 14.1.04

Я тоже сталкивался с этой проблемой где то с полгода назад.

Так и не смог победить. На нескольких компьютерах отображение идет нормально, на некоторых - мерцает.
Пришлось отказаться от элементов анимации, вызывающих мерцание.
Re: Мерцание экрана в WinCC
Василий Дорофеев; 14.1.04

Макс ! Спасибо,операторы выразили нам свою благодарность, ну а мы Вам.

С уважением Василий Д.<


text

Миграция проекта WinCC5.1 to WinCC 6.0
Chainik; 5.11.04

Есть проект WinCC5.1. При попытке преобразовать его в WinCC 6.0 (стоит WinCC 6.0 без SP и HF) выдается сообщение:

"Ошибка ODBC, не удалось создать источник данных "WinCC_CS".Убедитесь,что Sybase 7 и драйвер ODBC "Adaptive Server Anywhere 7" были установлены корректно."
Прочитал что написано в хэлпе по миграции.... Есть ссылка на драйвер ODBC на microsoft сайте,но там его нет. Вопрос: как проверить есть ли драйвер (может я его не установил, в хэлпе написано что с диска устанавливать что-то там, а я устанавливал WinCC просто и прямо сетап запустил и нажимал нехт и по дефаулт) есть ли Sybase7 и если нет или они есть,но почему то не нравятся WinCC то как их переустановить.
Заранее благодарен за помощь
Re: Миграция проекта WinCC5.1 to WinCC 6.0
Григорий; 5.11.04

На диске с Wincc 6.0 есть довесок Sybase для выполнения функции миграции (точное название не помню). Нуужно при установке пройтись по всем опциям. Возжможно Вы не установили это компонент

Re: Миграция проекта WinCC5.1 to WinCC 6.0
Chainik; 5.11.04

Возможно, надо попробовать


text

Миграция проекта
Лариса; 21.1.04

После конвертации проекта WinCC 5.1 в WinCC 6.0 проект не запускается c AlarmLogging (без него все нормально). В чем причина?

Re: Миграция проекта
Вячеслав; 19.2.04

Возможно алармы не мигрировались нормально и следует просто отключить AlarmLogging

Re: Миграция проекта
Чистяков Дмитрий ОАО СеверСталь; 19.2.04

Для начала следует поискать проблемы в старой версии. Если всё в старой версии настроено нормально, то миграция проходит без проблем.

У нас всё проходит нормально на проекте с более 8000 файлов (объём проекта 1,7 Гб), за исключением русских шрифтов в AlarmLogging. Но это шлюк от версии WinCC 6.0 без SP.<


text

Многоязыковой проект в WinCC_v6_SP2
Human; 19.8.04

Приветствую! Господа, кто-нить реализовывал многоязыковой проект на WinCC? Если "ДА", то как? :)

В смысле интересует, Вы ручками забивали тескт в текстовую библиотеку или есть другие варианты? Благодарю за ответы!
Re: Многоязыковой проект в WinCC_v6_SP2
Чистяков Дмитрий ОАО СеверСталь; 19.8.04

В текстовой библиотеке есть возможность экспортировать всю библиотеку в файл *.CSV, который можно редактировать, например, в Excele.

Но и там и там придётся вбивать всё ручками. Тут уж ни куда не денешься. ;-)<


text

Могу ли я контроллировать таблицу
Малкон; 4.11.04

У меня интересный проект, необходимо нескольким опреаторам заводить данные в таблички (различные анализы), а затем эти данные должны появляться на операторских панельках в цехе.

--------
Дак вот умеет ли WinCC работать с такблицами следующим образом:
.Контроллировать каждую ячейку WinCC Online Table (менять цвета, вставлять картинки в определенные колонки, или по определенному значению, вообщем аналогично возможностям языков типа Delphi/C++Builder)

Может быть не стоит убиваться за недоделанность WinCC, и писать клиентов на других языках, просто записывая данные в SQL базу WinCC проекта ?

Или все же Можно попробовать реализовать эти возможности через VB скрипты, или С, встроенный в WinCC. Я к сожалению их возможностей пока не представляю.

Вот такой вопрос. Спасибо.
Re: Могу ли я контроллировать таблицу
Малкон; 4.11.04

Ах да.. забыл добавить, так же должна быть возможность вставлять ComboBox, чтобы оператор мог делать выбор, а может даже и вводить свое знаениче если значения нужного нет.

Re: Могу ли я контроллировать таблицу
Макс Прилепский; 4.11.04

То, что Вы описали, возможно реализовать в виде ActiveX-модуля, интегрировав его в кадр WinCC. WinCC Online Table Control для этого не подходит, однозначно, даже если этот компонент сконфигурировать в кадре в режиме формы

Re: Могу ли я контроллировать таблицу
Малкон; 4.11.04

А где я могу достать описание как мне подключить Active-X, я так понимаю создавать его нужно в Васике (VB) из VS. да ?

Re: Могу ли я контроллировать таблицу
GorA; 4.11.04

Все, что нужно Малкон_у в Win СС можно сделать. Нужно только немного отойти от стиля программирования на DELPHI и т.п. и конечно не зацикливаться стандартными приложениями того же Siemens.

Re: Могу ли я контроллировать таблицу
GorA; 4.11.04

А также для более менее устойчивой работы конечного продукта поменьше использовать внешних приложений.

Re: Могу ли я контроллировать таблицу
Вадим Печёрских; 5.11.04

Привет, GorA.

Подскажи как можно сделать нормальный ComboBox средствами WinCC с возможностью ввода новых значений, сортировки и поиска по первым символам?
Re: Могу ли я контроллировать таблицу
Малкон; 5.11.04

На Дельфях перехватывается ХИТРОЕ событие которое вызывается при создании ячейки, а дальше пишутся условия типа: ЕСЛИ ЯЧЕЙКА ТАКАЯ-ТО, то КРАСИМ ЕЕ В КРАСНЫЙ ЦВЕТ, ВСТАВЛЯЕМ КАРТИНКУ.

Какой принцип в WinCC тогда ?
А нормальными средствами В ДЕЛЬФИ ComboBox с возможностью ввода своего варианта в ячейке таблицы не создашь. Приходиться применять либо RxLib, либо EhLib.
Я поэтому когда с Дельфями ковырялся, подумал, что WinCC далеко не язык программирования по сути, то будут проблеммы.Поэтому я настроился на работу с Васиком или с чем-то еще.
Re: Могу ли я контроллировать таблицу
Mike; 5.11.04

Господа!!! Пишите на Visual C++ и не будет у вас всяких заморочек :)

Re: Могу ли я контроллировать таблицу
Nick ; 5.11.04

To Mike На С время выполнения проекта растет раза в 2.

Re: Могу ли я контроллировать таблицу
Alexis; 5.11.04

2 Nick:

Где и чего растет раза в два?
Re: Могу ли я контроллировать таблицу
jkeks; 5.11.04

дак не времы выполнения важно, а вообще принципиальная возможность средствами самого проекта WinCC. И каким образом если можно.

Re: Могу ли я контроллировать таблицу
GorA; 5.11.04

Вадиму Печёрских.

Каждое приложение должно заниматься своим делом и не забирать хлеб у других.
Вообще-то вопрос звучит так " .... менять цвета, вставлять картинки в определенные колонки, или по определенному значению ..."
А то, что предлагаете вы нужно делать использую каку-нибудь базу данных. В Win CC есть приложение User Archive.

Re: Могу ли я контроллировать таблицу
Малкон; 5.11.04

Ну как автор вопроса тогда немного поясню, что информация вводимая в таблицы, должна быть мгновенно оторажена на панелях в цехе, я считал, что лучшим вариантом будет организовать интерфейс на базе WinCC, чтобы МГНОВЕННО передавать информацию.

К тому же если делать на базе того же Дельфи, то откуда мне брать структуру в которой храняться данные, даже не представляю как это там храниться.

Получается что клиентские приложения прощще писать на специализированных языках. А как же Связка с VBA ? Или того круче - C Scripts (хотя там свой SDK, точнее ODK, скорее всего далеко не полноценный) ???
Re: Могу ли я контроллировать таблицу
Малкон; 5.11.04

Хотя лично я бы написал приложение на C++ Builder 6 + RxLib. Решилась бы проблемма со структурами.

И как правильнее ?
(казалось, что покупая самую навороченую скаду придется лишь изучить ее особенности)

А вообще если прибегать к вариантам типа WinCC+Delphi/C++, то не лучше ли воспользоваться аналогами типа AStudio. Тоже коряво, но уже дешевле.
Re: Могу ли я контроллировать таблицу
GorA; 5.11.04

А связь с каким-нибудь PLC есть?

Если нет, или объем маленький и эпизодический, то лучше сделать на каком-нибудь другом приложении. Например Visual FoxPro.
Re: Могу ли я контроллировать таблицу
Малкон; 9.11.04

Схема достаточно сложная: 13 операторских панелей, несколько S7-400, архивный сервер у ИВЦ, и простонародье: Лаборатория, ОТК, технологи, у каждого свой интерфейс, каждый видит что-то особенное из процесса работы.

Re: Могу ли я контроллировать таблицу
Павел Кобелев; 10.11.04

Я бы использовал стандартный Microsoft flex grid control. Это для табличек. И "родной" combobox от microsoft. Теперь к вопросу как. В WinCC в графическом дизайнере на палитре объектов есть страница "Controls". На нее добавляем требуемые элементы ActiveX и используем как родные. Обращаю ваше внимание, что для работы с проектом для MSFlexGrid нужна лицензия на режим разработки. Иными словами, у вас на машине должен стоять Visual Basic.


text

Может ли S7-300 реагировать на сигнал за 0.2 мс?
Михаил; 6.11.04

На стандартных модулях это точно не выйдет - там только время реакции модуля до 4.8 мс.

Есть ли у сименса процессоры/модули, позволяющие запускать нужный блок по прерыванию через примерно такое время?
Напр, на контроллерах митсубиси (очень похожи на сименс) есть спец плата прерываний, которая позволяет делать такое. Есть ли похожее у немцев?<


text

Можно ли в VBS использовать C-функцию?????
ЛАМЕР +); 25.8.04

Вобщем есть встроеная функция GetParentPictureWindow()

мне нужно ее использовать в VSB :-/

Вернее мне надо узнать имя родительского окна в VBS. HELP PLEEEEEEEAAASEEEEE
Re: Можно ли в VBS использовать C-функцию?????
Yrok; 26.8.04

Посмотри как реализована функция и переложи её на VSB.

А вообще в API есть функция которая возращает HANDLE окна.
HWND FindWindow(
LPCTSTR lpClassName, // pointer to class name
LPCTSTR lpWindowName // pointer to window name
);
Находится она в user32.DLL
Только учти в dll их две таких одна для Unicode а другая для Ansi
HWND FindWindowW
HWND FindWindowA
Re: Можно ли в VBS использовать C-функцию?????
Я; 27.8.04

Тут вбщето подсказали как это сделать более простым способом :))))

Нужно использовать Parent.
например ScreenItem("IoField1").Parent.Parent<


text

Можно ли заменить хранитель экрана для OP270 на свой?
Александр Куликов; 13.8.04

Если можно, то подскажите как или где почитать.

Александр
GTE
<


text

Накрылись панели TP27
Михаил; 5.11.04

Такая вот проблемка, у нас на предприятии стоят 2 панели TP27, не прошло и 3-х лет как их новенькие поставили с новой системой, и значит обе эти панели накрылись, ну точнее они работают, но ЖК экран стал показывать частями потемнел больше чем на половину, и потемнел както полосками, кароче ничего на ней не видно. И главное это произошло на обеих панелях. Мы заменили на новые, но боимся что опять произойдет тоже самое, как это предотвратить? В чем причина? Может кто подскажет?

Re: Накрылись панели TP27
GorA; 5.11.04

В каталоге на TP270(следующая после ТР27) указано среднее время эксплуатации при нормальной яркости около 40 000 часов - это примерно 4,5 года.

Re: Накрылись панели TP27
GorA; 5.11.04

А в описании на TP27-6 срок эксплуатации 25 000 часов - цветные, 22 000 - монохромные панели. А это меньше 3 лет.(~2.8).

Re: Накрылись панели TP27
Михаил; 5.11.04

GorA:

А какого хера она таких бешенных денег стоит? тоже мне промышленная вещь, обыкновенный бытовой телевизор дольше работает раза в 2 три.
Re: Накрылись панели TP27
Мифка; 5.11.04

Значит тому и быть :)))

лучше на компутере сделат и навека :)))
Re: Накрылись панели TP27
Мифка; 5.11.04

Привет Митус!!!! не парься насчет энтого :)))

сгорит опять - опять за бабки им вкачаем прогу в новую панель и все дела
Re: Накрылись панели TP27
Михаил; 5.11.04

Мифка:

Да согласен пускай каждый день лучше горят а мы с этих идиотов бабки стрич будем за установку.
All:
Кстати народ не подскажите что можно зделать чтоб панель быстрее накрылась (незаметно) Ну там может магнитик какойнибудь подложить и т.п.?
Re: Накрылись панели TP27
Ответ Мифке; 5.11.04

Лампы работают по закону Насредина, через 3 года либо установка, либо хозяин должны сдохнуть.

По своему опыту скажу, что даже после 2-х дневной выдержки в грязной подсоленной воде, последующей промывки и просушки не вывели несколько панелей и сейчас несут свою вахту.
Мифке: А чтобы все быстро накрылось, включая всю АСУ, подай по цепям питания вместо 24 220в. Работы и бабок будет еще больше.
Re: Накрылись панели TP27
Pavel; 9.11.04

У нас тоже экран помню сдох.

Сименс конечно таких "мелочей" в запчасти не дает. Пришлось долго рыться в инете, но нашли, купили, поставили.
Один совет. Матрицы как правило сам Сименс не делает, а покупает, но клеит свою наклейку поверх фирменной. Поробуйте сами заменить матрицу, особых сложностей там нет, и деньги съэкономите
Re: Накрылись панели TP27
Михаил; 10.11.04

to Pavel:

Спасибо канечно, только чьи мне деньги то экономить (предприятия? Хе-хе) упало оно мне, а геморрой с заменой этого экранчика мне достанется, нет уж лучше новую панель купить.
Re: Накрылись панели TP27
Darwin; 10.11.04

To Pavel; и в чем же заключалась процедура подбора матрицы?? Только по диаганали?? Или там марка есть определенная какая то. Разъемы там стандартные что-ли у всех??

Re: Накрылись панели TP27
Pavel; 10.11.04

To Darwin

Подбирали матрицу по размеру и разрешению.
У нас панель (не помню точно тип), но скорее всего ТР27, цветная. Размер 5,7", 320х240. Изготовитель ALPS(япошки) подбирал из их каталогов, там только один такого размера
FLUBL 605XA. Если кого интересует, где-то от нее завалялось несколько .pdf рисунков, там есть размеры.
Встала как родная, замена тоже несложная. Труднее с закупкой. Брали где-то в Европе. Стоит около 600
Re: Накрылись панели TP27
Чистяков Дмитрий ОАО СеверСталь; 14.11.04

Ну, что тут скажешь? :-)

Ну, видимо сам-то Siemens тут не совсем виноват. Кто ж виноват, что этот тип матриц столь не долговечен?
Re: Накрылись панели TP27
Михаил; 15.11.04

Чистяков Дмитрий: Хе-хе ну ты даешь, а кто же виноват то тогда, Пушкин? Кто выбирал для своей продукции эту матрицу Пушкин? Никто же не знает что матрица то не сименсовская, да и еслиб знали вот я теперь знаю и нисколько это плюсов в моих глазах сименсу не добавляет а даже наоборот. Так что сименс виноват так как панель его.

Re: Накрылись панели TP27
GorA; 15.11.04

Прежде чем устанавливать новое оборудование неплохо бы почитать ея возможности и срок службы - конкретно у Siemens для TPхх это все есть. И, поэтому нечего на зеркало пинять , коли ...

Re: Накрылись панели TP27
Михаил; 15.11.04

GorA:

Так оборудование ставила немецкая фирма а не мы :) Я вот понимаю когда есть гарантийный срок службы 3 года, но чтоб максимальный срок службы был 3 года у электроники где нет никаких механических частей - это полная задница. А если изначально эта панель является расходным материалом, то почему цены то такие заоблачные? Откуда они берутся то? Вот китайские товары все знают что они так сказать "одноразового использования" но и цены у них копеешные. А это у сименса херня какаето просто натуральный дибилизм фирмы.
Re: Накрылись панели TP27
Чистяков Дмитрий ОАО СеверСталь; 15.11.04

А Вы нашли бы (на тот момент покупки) дешевле панельку? :-)

На самом деле панель для применения в промышленности всегда стоят не мало. Это же не ширпотреб, их покупают не сравнимо меньше, а вот затрат на их разработку уходит больше. От того и стоят все промпанели дорого. И не только у Siemens`а. :-(
Что касается сроков эксплуатации, то даже современные панели LCD мониторов имеют в полне осязаемый срок гарантированной работы. Чаше всего это не более 50 - 60 тысяч часов.
Только тут стоит упомянуть, что использование такой панели в круглосуточном режиме работы, значительно сократит срок работы в годах. :-)
Это ведь компьютер и телевизор дома и наработе не работают круглые сутки. :-)
Re: Накрылись панели TP27
GorA; 15.11.04

Перед внедрением новых устройств идет масса технических согласований, где соответственно и предлагаются определенные образцы оборудования и каким образом решается та или иная задача. И последнее слово по согласованию технического решения идет как раз от покупателя, т.е. от ВАС.

Могли бы полистать каталог, или просто спросить технического представителя поставщика в момент согласования.
Re: Накрылись панели TP27
Михаил; 16.11.04

GorA:

Да чего там говорить то, панель то хреновенькая это факт, а на ней сименсовский лэйбел...
Re: Накрылись панели TP27
Pavel; 16.11.04

То что Сименс ставить изделия других

фирм-это обычная практика. Помню вскрываем промышленный монитор-а там устройство полнокомплектное с лейблом Грюндик, т.е. от Сименса только крышки пластиковые.
Другой момент-это нежелание фирмы предлагать матрицу в списке запчастей, это говорит уже о целенаправленной политике, если у вас накрылось изделие, то болшинство купит новое, только некоторые плюнут на Сименс, и переделают систему под другого производителя, хотя это и будет дороже. Но только эта категория пользователей будет обходить Сименс стороной по всем продуктам, несмотря на то что у них действительно есть неплохие изделия.
Re: Накрылись панели TP27
Чистяков Дмитрий ОАО СеверСталь; 16.11.04

Михаил;

На тот момент времени эти панели мало чем отличались от панелей других производителей.
А то что не нравиться Вам эта панель, так возьмите другую - и Вам будет не нравиться и другая. :-)
Подобные панели операторов имеют свои достоинства и недостатки (имею в виду класс операторских панелей, а не конкретно TP27). Если не нравятся такие панели, то может стоит перейти на панели на основе PC? Типа PC670.
Re: Накрылись панели TP27
Pavel; 16.11.04

Не знаю, работает рядом TP27 и OMRON,

(Омрон даже поболее), и на ТР матрицк меняли. Режим работы у обеих практически одинаковый. Может это от того что Сименс выбрал мелкого поставщика комплектующих (Я про эту фирмочку только и узнал когда железяку увидел).
А вообще-то мое мнение-что аппаратная часть систем визуализации никогда у Сименса не была сильным звеном. Работать начинал еще с КОРОС, и там даже немецкие фирмы предпочитали комплектовать установки японскими мониторами.
Re: Накрылись панели TP27
Чистяков Дмитрий ОАО СеверСталь; 16.11.04

Омроновскую-то какую панель используете?

Re: Накрылись панели TP27
Pavel; 16.11.04

А вот и не помню.

Буду в производстве, посмотрю. Поступило все в составе оборудования
в 2000 году. До сих пор с системами управления никаких проблем, поэтому туда и не лезешь и забылось даже что
установлено. Все проблемы как обычно-датчики,фильтры,пневмозолотники и
прочая обвязка. Справляются операторы.
Кстати и контроллер ОМРОН.
Re: Накрылись панели TP27
Чистяков Дмитрий ОАО СеверСталь; 17.11.04

Тогда не понятен выбор станций от Siemens для системы на Omrone.

Чем хороши панели от Siemensa, так это наличием порта Profibus. Что упрощает их использование в пультах управления (не надо тащить отдельный кабель для связи с панелью).
Что же касается проблем, так они у всех такие - с контроллерами проблем нет (разве что с отечественными), все проблемы с датчиками и устройствами отображения информации.
У нас в частности с маслянной грязью и пылью проблема (всё таки чёрная металлургия). И ещё не менее важная проблема - операторы, которые могут и уронить на них чего-нибудь, или замаслянной рукавицей замазать весь экран. :-)
Кстати в последнее время пользуем TP170. Впечатление весьма приятное.
Re: Накрылись панели TP27
Pavel; 17.11.04

Я наверное не совсем точно описал состав оборудования. Это разные линии.

Та что с ОРОНОМ получена в комплекте и запускалась фирмой. Мы же в своих проектах используем СИМЕНС, потому-что так сложилось исторически.Ведь выбирается поставщик технологического оборудования, и там уже имеешь что поставили. У нас есть и S5, S7 всякой твари по паре. Тем более когда есть уже специалисты, лицензионный софт то естественно что в своих проектах используешь знакомые изделия, по крайней мере предвидешь грабли на которые наступишь. По поводу операторов, то-же верно - жмут пятерней немытой, могут и постучать.
Мне нравиться здесь американский поход-у них изделия расчитаны на пользователя-обкурившегося негра, и сломать такои прибор проблематично, вес и габариты конечно те еще, но иногда это не самое главное. <


text

Накрылись панели TP27
Михаил; 5.11.04

Такая вот проблемка, у нас на предприятии стоят 2 панели TP27, не прошло и 3-х лет как их новенькие поставили с новой системой, и значит обе эти панели накрылись, ну точнее они работают, но ЖК экран стал показывать частями потемнел больше чем на половину, и потемнел както полосками, кароче ничего на ней не видно. И главное это произошло на обеих панелях. Мы заменили на новые, но боимся что опять произойдет тоже самое, как это предотвратить? В чем причина? Может кто подскажет?

Re: Накрылись панели TP27
Цепи подсветки или лампа ?; 5.11.04

Раз накрылись, значит можешь разобрать и посмотреть цепи подсветки, у меня на МР370 отдельная платка. Посмотри может сдохло на ней чего или коррозия. Я видел аппаратуру полностью засыпанную стиральным порошком - производство у них такое.

Ну и лампы через 3 года иногда тоже сдыхают. Поэтому на панелях и предусмотрен режим сбережения лампы.
Re: Накрылись панели TP27
Михаил; 5.11.04

Нет не лампа потому что часть экрана видно, походу эти самые жидкие кристалы чота толи растеклись толи незнай кароче вот так вот.

Re: Накрылись панели TP27
Цепи подсветки или лампа ; 5.11.04

другой ветке тебе тоже сказали о лампе. Да и срок ресурса они могут приводить с учетом, что лампа все время работает в экономичном режиме, а не в полный накал.

Спроси у сименса о возможности покупке новых ламп (трудно, но возможно).

Re: Накрылись панели TP27
Цепи подсветки или лампа ; 5.11.04

Когда кристаллы текут все становится черным и непрозрачным.

А люминисцентная лампа у тебя на потолке тоже только с одного конца может светиться и еще мигать при этом. Там тот же принцип.
Ты для начала сними корпус, аккуратно размести на столе и включи.
Я разбирал - ничего страшного.
Re: Накрылись панели TP27
Михаил; 5.11.04

Да да именно все стало черным и непрозрачным прямо. Вот только не все пиксели растеклись а с низу остались прямо такисе полососки видимые прямо по пикселям как бы, тоесть действительно потекли кристаллы.

Re: Накрылись панели TP27
Кто то злой и тупой просто продавил экран; 5.11.04

Один раз при мне оператор вместо управления двумя руками использовал одну козу - большим пальцем и мизинцем пытался нажать одновременно 2 кнопки, размещенные по краям сенсорного 12" экрана. Когда я увидел как прогибается защитное стекло под его казанками мне стало страшно. Там есть зазор, но и его можно выбрать. Просто так экраны течь не начинают, тем более одновременно. Где то нарушена герметичность.

Но не видя, точно определить не могу.<


text

Написание программ для панели под WinCE
Eugene Sergeev; 1.6.04

Тут вот такая идея в голову пришла - можно ли написать программу под ВинЦЕ, скомпилить ее и записать в панель, ну скажем, в ОР170В. Будет работать? IDE для WinCE существуют, процессор такой там есть (MIPS). Есть ли какой-нибудь API для панелей?

Re: Написание программ для панели под WinCE
Александр Родин, ООО ; 2.6.04

.

См. посмотрите здесь

Re: Написание программ для панели под WinCE
Eugene Sergeev; 3.6.04

Спасибо, посмотрел. Понял, что дело тухлое. SDK под процессоры серии R не раздают.


text

наработки разработки
Шимолин Сергей; 25.3.04

смотрим htt://wincc-shimolin.narod.ru

Re: наработки разработки
Олег; 25.3.04

Огромное тебе Thank You!

В самом деле очень полезные наработки.
Re: наработки разработки
Олег; 25.3.04

Только один вопрос:

почему решено базу MyGraphSetDB.db разместить отдельно от базы проекта WinCC? На мой взгляд гораздо рациональнее таблицы базы MyGraphSetDB.db разместить в конфигурационной базе проекта, так не будет возможности их случайно потерять.
Re: наработки разработки
Шимолин Сергей; 25.3.04

Когда начинал разработку - молодой был, не опытный :) Страшно было залазить и творить в базе проекта..

каюсь..
Re: наработки разработки
Маслов Дмитрий; 8.4.04

От нашего стола - Вашему столу:

http://www.sms-automation.ru/support/downloads/
Re: наработки разработки
shurik; 8.4.04

ну и как скачать пакет русификации Wincc 6.0 SP1. Пароль какой-то

Re: наработки разработки
Маслов Дмитрий; 8.4.04

Пакет русификации WinCC 6.0 SP1 можно скачать по согласованию с Siemens A&D, или получить диск в любом представительстве Siemens A&D.

Все остальное доступно для свободного скачивания.<


text

НАРОД!!! а где посматреть описание функций всяких???
Михаил; 16.8.04

Вот например натыкаюсь на этом форуме на функцию DMGetRuntimeProject и кучу других а в хелпе нету ниче про нее... где полный список фсяких функций поиметь? +)))) будьте доры подскажите ченить

Re: НАРОД!!! а где посматреть описание функций всяких???
Маслов Дмитрий; 16.8.04

Упомянутая Вами функция, и другие функции WinCC API, описываются в документации ODK (Open Developer's Kit).

См. Скачать документацию ODK

Re: НАРОД!!! а где посматреть описание функций всяких???
михаил; 16.8.04

сэнкью бразер =)


text

Настройка локальной сети WinCC 6.0
Hied; 14.11.04

Здравствуйте! Имеется комп-сервер с Windows 2000 Server и комп-клиент с Windows 2000 Professional. На сервере должна стоять WinCC 6.0 SP2 64K, на клиенте WinCC 6.0 RT 128. Подскажите как нужно правильно настроить Windows 2000 Server (DNS,DHCP,...), чтобы клиент мог общаться с сервером без проблем (не требуя ввода пароля и т.д.) и чтобы проект WinCC работал без проблем? Как правильно настроить проект WinCC на сервере и на клиенте, написанный на локальном компьютере? Может быть есть у кого-то описание настройки сервера и клиента? Скиньте, пожалуйста.

Сетка установлена, компы видят друг друга через рабочую группу.
Заранее благодарю.
Re: Настройка локальной сети WinCC 6.0
Маслов Дмитрий; 14.11.04

Насколько я понял, машины в домен не входят. Так что самый простой вариант - создать на обеих машинах локальных пользователей с правами администраторов с одинаковыми именами и паролями, и заходить под ними.

Описание настройки проекта WinCC на клиенте и на сервере имеется практически в любой документации по WinCC, в т.ч. в WinCC Information System.
См. http://www.wincc.ru


text

Не активны Alarm Logging, Tag logging Runtime
Роман; 15.4.04

WinCC V6.0 SP1 Win2000

При создание клиент серверноего проекта на клиентах в Computer Properties закладка Startup не активны Alarm Logging и Tag Logging Runtime с чем это связанно. Необходимо что то дополнительно ставить или необходимы дополнительные настройки.
Re: Не активны Alarm Logging, Tag logging Runtime
Михайлин Сергей; 16.4.04

Это нормально! Ведь клиент не ведет собственного архива тэгов и сообщений а подкачивает его с сервера. Так что запускать эти службы на клиенте не нужно. Просто подкачайте package файл с расширением pck с сервера и архивы будут видны.


text

Не вижу Status в Alarm Loggin
Андрей; 22.10.04

Подскажите пожалуйста, почему может не отображаться значение в колонке "Status" (сист. блок) компонента WinCC Alarm Control для моих сообщений (для сообщений WinCC, видны). Иногда в поле Status отображается: Квит-Сист.

Длина "Status" (сист. блок) в
свойствах = 5, значения для отображения статуса:
+
-
*
+/-
Re: Не вижу Status в Alarm Loggin
Маслов Дмитрий; 24.10.04

"Квит-Сист" в поле статуса означает, что сообщение появилось, ушло, а зетем снова появилось, при этом предыдущее его возникновение так и не было квитировано оператором. Поскольку любое сообщение, для класса которого включено квитирование, должно быть квитировано, оно квитируется системой, и одновременно с этим появляется вновь.

Пустые поля статуса у меня возникали для сообщений, класс которых помечен как "без статуса "Ушедшее"".
См. http://www.wincc.ru

Re: Не вижу Status в Alarm Loggin
Alexis; 25.10.04

Как вариант может не отображатся если в текстовой библиотеке для нужного языка отсутствуют текстовки...

Кстати, а кто-нибудь может сказать как поменять текстовку для Ack-System? Откуда она у вас Квит-Сист?
Re: Не вижу Status в Alarm Loggin
Маслов Дмитрий; 29.10.04

Текст "Ack-System" прошит в ресурсах WinCC, поменять его можно любым редактором ресурсов, например, Restorator. На "Квит-Сист" он меняется, если установить русификатор для WinCC.

См. http://www.wincc.ru

Re: Не вижу Status в Alarm Loggin
Alexis; 29.10.04

2 Маслов Дмитрий:

Спасибо. Очередная WinCC-шная фишка. Сдается мне у Siemens давно уже глобальная нехватка программеров во всех департаментах (один только S65 чего стоит). Просто вроде как в структуре MSG_CLASS_STRUCT уже давно зарезервированно место под этот статус, но и по сей день оно игнорируется, да и в базе описание этого статуса так и не появилось...
Re: Не вижу Status в Alarm Loggin
Андрей; 29.10.04

Ничего не помагало увидеть Status, наконец влез в базу данных моего проекта, нашел таблицу с описанием классов Alarm Loggin, а там ссылки на текст CameIn, CameOut и т.д. = 0, а должны быть = ID в текстовой библиотеке, после ручного ввода все вдруг заработало, почему не сохраняло, не понятно. Я и удалял из Text Library, заходил в AlarmLoggin и сохранял, тексты появлялись под новыми ID, но в базе данных все равно не обновлялись.


text

Не запускается WIN CC
VVV; 28.10.04

Здравствуйте!

Может у кого то такое было...
Была WinCC 5.0 SP2. И жила она вполне нормально на моем компьютере. Недели 2 я ее не запускал, а сегодня она понадобилась, а не запускается...
Появляется логотип, потом открывается сам Эксплорер, в строке статуса начинает перечислять чего он делает, и закрывается!
И все...
Пробовал переустанавливать WinCC и Sybase- не помогает...
Re: Не запускается WIN CC
VVV; 28.10.04

Видимо это изза того, что я возился с DCOM. Но как это исправить не переустанавливая винду?


text

не идет резервирование CP 1613 в WinCC
Hied; 29.12.04

Здравствуйте, эксперты!

Нахожусь в командировке на объекте и у меня возникла проблема. Никак не могу настроить резервирование модуля CP 1613 в WinCC. Объясню поподробнее: имеется компьютер-сервер, в который вставлены два коммуникационных процессора CP 1613, также установлена Windows 2000 Server и WinCC 6.0 SP2. Каждый CP 1613 соединяется с каждым CP 443-1 контроллера S7-400 (контроллера два – один резервный). В проекте WinCC с помощью Wizard’a Redundancy настроил резервирование. Логическое соединение в WinCC одно, настройки прописаны для одного модуля CP 1613. Все теги принадлежат этому соединению. При отключении одного контроллера или одного CP 1613, теги должны брать значения с другого резервного соединения, но этого не происходит. Может нужно создать другое логическое соединение в WinCC и там создать те же теги, что и в первом, но теги будут иметь разные имена и придется перепривязывать всю анимацию на мнемосхемах. Может я что-то не правильно сделал, упустил? Подскажите, пожалуйста, как мне решить данную проблему? Выручайте, коллеги!
Re: не идет резервирование CP 1613 в WinCC
Юрченко Владимир; 30.12.04

Не совсем понятна ситуация. Если используются S7-400H контроллеры, то нужен пакет S7-REDCONNECT и в WinCC уже не надо использовать Wizard Redundancy - все делается через Named Connection. Wizard нужен если используется SoftRedundancy, то есть если контроллеры не аппаратно резервируемые, и тогда имеется два набора тегов и скриптами (генерируемыми Wizard'ом ) они переключаются для отображения.


text

Не меняются значения тегов
Эдуард; 19.9.04

Здравствуйте! Никак не могу изменить значение внешнего тега в режиме Runtime WinCC 6.0 SP2. Пробовал через кнопку, в событии Mouse->Press Left которой написал скрипт SetTagBit (“ZD12.stOpen”,1); также пытался в симуляторе WinCC менять тег. Но теги не меняются. Помогите, пожалуйста, мне это очень нужно для тестирования проекта.

С уважением, Эдуард.
Re: Не меняются значения тегов
Миша; 20.9.04

1. Может он у тебя пишется в PLC (т.е. кантроллер его сбрасывает)

2. Есть ли у тебя связь с PLC???
3. Нет ли у тебя TagPrefix???
Re: Не меняются значения тегов
Эдуард; 20.9.04

Связи с ПЛК и TagPrefix нет

Re: Не меняются значения тегов
Лёха; 21.9.04

Тэг читается по S7 или как?

Если с ProfiBus, то какой тип указан: для чтения или записи?
Re: Не меняются значения тегов
Эдуард; 21.9.04

Уточню: у меня нет соединения с ПЛК, не установлен STEP, только WinCC 6.0 SP2. Создаю внешние теги в менеджере тегов. Привязываю анимацию к этим тегам. На событие Left Click кнопки Button1 вешаю скрипт SetTagBit("ZD_Close",1). Запускаю Runtime, жму кнопку, никаких изменений, т.е. значение тега не изменилось.

Re: Не меняются значения тегов
Михаил; 23.9.04

Так если нет связи с LPC то какая может быть речь о внешних тегах???

чтобы внешние теги работали нужно чтобы:
1. была связь с PLC
2. Чтобы тег реально существовал в PLC (т.е. существовал DB к каторому он привязан)<


text

НЕ МОГО ЗАКАЧАТЬ ПРОГРАММУ В ОР 27
FuzzMan; 11.2.04

Имеется Simatic OP27+ProTool/Pro+Программа. Программа компилируется нормально начинаю закачивать в панель, ProTool начинает ругаться, что не возможно соединиться. Может что с кабелем. Я использую самопайный RS 232(как описан в спецификации на ОП), подключаю к ОР27 (IF2) Или есть нормальный кабель? или необходим переходник RS232/TTY.

Re: НЕ МОГО ЗАКАЧАТЬ ПРОГРАММУ В ОР 27
Baby; 11.2.04

Привет !!!

Только проблемы с "железом" ->
кабели, разъёмы и т.д. Никакой переходник не нужен. Если всё нормально спаяли всё должно быть ок.
Re: НЕ МОГО ЗАКАЧАТЬ ПРОГРАММУ В ОР 27
Юрчик; 11.2.04

1. Панель в режим загрузки переводите перед передачей программы?

2. Подключаете кабель к тому же COM-порту, что и в настройках ProTool указан?
Re: НЕ МОГО ЗАКАЧАТЬ ПРОГРАММУ В ОР 27
FuzzMan; 12.2.04

Проверил кабель, подключил заново, панели ProTool не видит, но сама панель начала выдавать - Init Transfer 0. Наверное не так спаял.

Спасибо.

Re: НЕ МОГО ЗАКАЧАТЬ ПРОГРАММУ В ОР 27
FuzzMan; 12.2.04

Ха. Все нормально. Закачалось.Но...Проект я писал на английском языке, а на панели на итальянском отображается.

Re: НЕ МОГО ЗАКАЧАТЬ ПРОГРАММУ В ОР 27
VVV; 12.2.04

Так значит у вас по умолчанию в проекте задан итальянский.

Re: НЕ МОГО ЗАКАЧАТЬ ПРОГРАММУ В ОР 27
Павел Кобелев; 1.3.04

Грузил по MPI, проблем не было

Re: НЕ МОГО ЗАКАЧАТЬ ПРОГРАММУ В ОР 27
Павел; 2.3.04

Если можешь кинь на мыло распайку кабеля.


text

НЕ МОГУ ПОДКЛЮЧИТЬСЯ К ПАНЕЛЯМ OP15C И OP27
ЛЕНАР; 25.10.04

НЕ ПОДСКАЖИТЕ ПО КАКОМУ РАЗЪЕМУ СОЕДИНЯТЬ ПК И ПАНЕЛЬ. НУЖНА БЫЛА ЕЩЕ РАСПАЙКА ПРОВОДОВ ПО КОТОРЫМ МОЖНО БЫЛО БЫ ПОДКЛЮЧИТЬСЯ.

Re: НЕ МОГУ ПОДКЛЮЧИТЬСЯ К ПАНЕЛЯМ OP15C И OP27
Чистяков Дмитрий ОАО СеверСталь; 25.10.04

Распайка разъёмов на OP15 смотрите в описании панели страница D-1

OP27 страница руководства B-1<


text

не открывается проект WinCC
роман; 25.10.04

WinCC 5.1. WinCC Explorer зависает при открытии проекта сервера. Если подменить RT базу пустой (сгенерированной через WUnload), открывается и пускается нормально. Что может быть не так?

Re: не открывается проект WinCC
Юрченко Владимир; 28.10.04

Скорей всего из-за временных файлов, которые неправильно были закрыты и которые надо удалить.

Посмотри ссылки:
http://www4.ad.siemens.de/WW/view/en/492977
http://www4.ad.siemens.de/WW/view/en/11082699
<


text

Не открывается проект
Michon; 29.9.04

При попытке открыть готовый проект на другой машине выдается ошибка "0х80030005 Отказано в доступе". Соответственноо проект не открывается.

Может ли это быть связано с тем, что проект разрабатывался в WinCC 5.0 SP2, а пытаемся открыть в WinCC 5.1 SP2?
И что посоветуете делать?
Re: Не открывается проект
Michon; 30.9.04

Все, вопрос снят.

Причина была на редкость дурацкой :) Перенос проекта осуществлялся путем записи CD. При этом все файлы стали read only :))))<


text

Не пашет
Макс; 2.9.04

Подключаюсь через Com порт PC к TP270.

Все скорости перепробовал. Кабель в норме. Все равно при выгрузке проекта выдает сообщение проверить подключения и настройки что не так.
Re: Не пашет
Diana; 3.9.04

Значица, вот эта ТЭПЭ должна быть еще и готова к взамоотношаться! Воключаем-включаем и усиленно топчем сериальную загрузку даунов

Re: Не пашет
Миша; 5.9.04

Может кабель не тот? у меня было однажды что кабель вродебы тот а не тот :)

Посмотрел документацию, прозванил, не тот! пришлось вручную паять его<


text

Не получается взаимодействие между картинками
Эдик; 28.9.04

Имеются три картинки: Main.pdl, ControlZD.pdl и Verify.pdl. На Main.pdl находятся объекты PictureWindow1 для ControlZD.pdl и PictureWindow2 для Verify.pdl. Имеются внутренние теги типа Text-8. В Runtime режиме при нажатии кнопкой на объекте, находящемся в Main.pdl, вызывается окно управления объектом PictureWindow1 с ControlZD.pdl. В этом окне отображаются значения внутренних тегов. При нажатии кнопки в окне управления должно вызываться окно подтверждения PictureWindow2 с Verify.pdl. В этом окне также должны отображаться значения внутренних тегов. У меня никак не получается запустить окно подтверждения из окна управления. Пробовал так:

Dim Verify_Window
Set Verify_Window=Screens("Main.PictureWindow2")
Verify_Window.Visible = True
Один раз как-то получилось (??), но значения текстовых внутренних тегов не отображались.
Подскажите, пожалуйста, как решить данную проблему?<


text

Не получается запись в теги из PictureWindow
Эдик; 28.9.04

Здравствуйте! Мне нужно в окно подтверждения передать данные из окна управления. Выглядит это так: щелкаем на задвижке (имя объекта задвижки ZD_12_1), появляется окно управления задвижкой, в которое я из имени объекта формирую номер задвижки, т.е. в окне управления у меня написано, что это окно управления задвижкой № 12.1. В этом окне управления есть кнопки управления: Открыть, Стоп и Закрыть. При нажатии на эти кнопки должно появляться окно подтверждения, типа «Вы действительно хотите открыть/остановить/закрыть задвижку № 12.1». Чтобы в окне подтверждения появилась надпись определенного действия (открыть/закрыть/остановить) я при нажатии на кнопку, например «Открыть», хочу записать во внутренний тег TEXT8 Verify_action строку «открыть электрозадвижку №». Но проблема в том, что не получается записать значение в тег из окна управления ControlZD.pdl. А значения записываются только из главного окна Main.pdl. Я даже не знаю как обойти эту проблему? Пробовал и через VBS-скрипты и через C-скрипты – ну не хочет WinCC записывать значения в теги, если пытаешься писать их из окна PictureWindow. А вы мне что подскажете?

PS. В других SCADA (iFIX 3.0, InTouch 8.0) таких проблем не было и разрабатывалось все легко, не то что в WinCC.
<


text

Не получается перечислить пользователей
Hied; 1.12.04

Здравствуйте! Подскажите, пожалуйста, что в моем коде не так? Мне нужно получить всех пользователей в системе WinCC 6.0 SP2 и вывести их. Подскажите, как нужно делать правильно.

#include "apdefap.h"
void OnLButtonDown(char* lpszPictureName, char* lpszObjectName, char* lpszPropertyName, UINT nFlags, int x, int y)
{
#pragma code("usegen.dll")
#include "usegenap.h"
#pragma code()
#pragma code("dmclient.dll")
#include "dmclient.h"
#pragma code()
BOOL fRet;
char ProjectName[_MAX_PATH];
char DSNName[MAX_DM_DSN_NAME + 1];
DM_PROJECT_INFO ProjectInfo;
LPDWORD UserCount;
fRet=DMGetRuntimeProject(ProjectName,_MAX_PATH+1,NULL);
if (fRet==FALSE)
{
MessageBox(NULL,"Невозможно определить имя проекта","Ошибка",MB_ICONQUESTION | MB_OK | MB_SYSTEMMODAL);
return;
}
fRet=DMGetProjectInformation(ProjectName,&ProjectInfo,NULL);
if (fRet==FALSE)
{
MessageBox(NULL,"Невозможно получить информацию о проекте","Ошибка",MB_ICONQUESTION | MB_OK | MB_SYSTEMMODAL);
return;
}
fRet=PWGENConnect (ProjectInfo.szDSNName,NULL);
if (fRet==FALSE)
{
MessageBox(NULL,"Невозможно соединиться с базой данных проекта","Ошибка",MB_ICONQUESTION | MB_OK | MB_SYSTEMMODAL);
return;
}
fRet=PWGENEnumUsers(UserCount,UserCallback,NULL,NULL);
if (fRet==FALSE)
{
MessageBox(NULL,"Невозможно перечислить юзеров","Ошибка",MB_ICONQUESTION | MB_OK | MB_SYSTEMMODAL);
return;
}
PWGENDisconnect(NULL);

Callback-функцию я пишу в Project functions:
#include "usegenap.h"
BOOL UserCallback(void* lpData, void* lpUser)
{
LPWGEN_USERINFO lpUserInfo=NULL;
lpUserInfo=(LPWGEN_USERINFO) lpData;
if (lpUserInfo==NULL)
{
printf(“error”);
return FALSE;
}
printf("%s",lpUserInfo->login);
return TRUE;
}
У меня из Callback-функции вообще ничего не печатается.
Re: Не получается перечислить пользователей
Alexis; 1.12.04

А ты уверен что винЦЦ умеет из скриптовых callback-ов printf делать? :)

Попробуй в своей UserCallback копировать куда-нибудь приходящие данные:
в Global Script\Project Functions
BOOL myUserCallback(PVOID lpUserInfo, PVOID lpUser)
{
#include "usegenap.h"
if ( lpUserInfo && lpUser ) memcpy(lpUser,lpUserInfo,sizeof(PWGEN_USERINFO));
return TRUE;
}

в обработчике кнопки:
void OnLButtonDown(char* lpszPictureName, char* lpszObjectName, char* lpszPropertyName, UINT nFlags, int x, int y)
{
#pragma code("usegen.dll")
#include "usegenap.h"
#pragma code()
#pragma code("dmclient.dll")
#include "dmclient.h"
#pragma code()

CMN_ERROR dmError;
DM_PROJECT_INFO dmPrj;
DWORD UserCount=0;
PWGEN_USERINFO ua;

if ( FALSE==DMGetRuntimeProject(dmPrj.szProjectFile,_MAX_PATH,&dmError) )
{
printf("Невозможно определить имя проекта\r\n");
return;
}

if ( FALSE==DMGetProjectInformation(dmPrj.szProjectFile,&dmPrj,&dmError) )
{
printf("Невозможно получить информацию о проекте\r\n");
return;
}

if ( FALSE==PWGENConnect(dmPrj.szDSNName,&dmError) )
{
printf("Невозможно соединиться с базой данных проекта\r\n");
return;
}

if ( FALSE==PWGENEnumUsers(&UserCount,myUserCallback,&ua,&dmError) ) printf("Невозможно перечислить юзеров\r\n");
else
{
printf("ok %d\r\n",UserCount);
printf("last user %s\r\n",ua.login);
}
PWGENDisconnect(&dmError);
}

но это только одного пользователя получишь, а как получить всех - сам догадайся :))
Re: Не получается перечислить пользователей
Hied; 1.12.04

2Alexis:Я пытался в Callback-функции получить всех пользователей и не вышло. Подскажите, как это у вас реализовано.

Re: Не получается перечислить пользователей
Alexis; 2.12.04

Callback вызывается для каждого существующего пользователя - таким образом, необходимо извратится и как-то где-то сохранять пользователей в процессе вызовов callback-а...


text

Не производится визуализация графиков тренда.
Sergey Piskovets; 4.6.04

SOS! Помогите разобраться.

В системе WinCC не производится визуализация графиков. В таблице имеется имя тега и путь к этому тегу. Но нет графиков и показаний значений этих точек.
Имеем два вида графиков:
1. "Короткий" - график реального времени в течении 1 - 2 часов.
2. "Длинный" - График истории
Первый тип графиков начинает выдавать показания только после открытия этого кадра, а после его смены и возврата к нему всё начинается с начала.
Второй тип графиков обсалютно ничего не показывает.

См. Sergey Piskovets

Re: Не производится визуализация графиков тренда.
Роман Папировский; 4.6.04

Первый тип графиков настроен как online. Поэтому при закритии экрана и открытии его вновь история не сохнаняется. Эту настройку можно поменять на закладке Gneneral окна трендов.

Со вторым типом графиков надо разбираться более подробно см. e-mail<


text

Не работает OS Project Editor
Андрей; 15.1.04

Устаноил WinCC V6.0 на Windows 2000 Advanced Server. При попытке использования компонента OS Project Editor выдается следующее сообщение при конфигурировании Runtime system: "An error occured while configuring runtime system". Кто сталкивался с такой проблемой помогите. Причем на другой машине все было ОК.


text

Не работает Tag Loggin
Юрий; 14.1.04

WinCC6.0 SP1 . Создаю архив в Tag Loggin, все настройки по умолчанию.

Есди задаю цикл UponChange, то данные архивируются как и положено по изменению. Если устанавливаю CiclicContinue, то ничего в архив не пишется. В чем проблема ?
Re: Не работает Tag Loggin
Юрченко Владимир; 15.1.04

Есть такая проблема в WinCC 6.0 SP1. Для устранения можно скачать HotFix - www.automation-drives.ru/as/db/zwqjvl/WinCC_6SP1HF3.zip

Re: Не работает Tag Loggin
Юрий; 18.1.04

Почему при установке Hotfix3 сразу появляется ошибка:

Severe
V06.00.00.01_11.17.00.27: This is not the correct BuildNumber, please check your configuration, the seup will cancel now.
Re: Не работает Tag Loggin
Юрченко Владимир; 20.1.04

Судя по номеру версии у Вас просто 6-ая версия, а HotFix для WinCC 6.0 SP1.


text

Не работает компиляция OS
Евгений; 2.12.04

Здравствуйте, господа эксперты. Вопрос по компиляции станции WinCC из Simatic Manager'a: эта команда просто перестала работать; учитывая что я с этим встречаюсь уже 2-й раз за полгода, я подумал, может кто уже сталкивался с этим и придумал лучший выход, чем переустанока всей системы вместе с операционкой?

Re: Не работает компиляция OS
Штыка Игорь; 2.12.04

Какой версии Вы используете Step7

Re: Не работает компиляция OS
Любитель Симатика; 2.12.04

Прямо таки и не работает? Ну хотя бы что-то она говорит? Сообщение об ошибке выдает какое-нить?

Re: Не работает компиляция OS
Евгений; 3.12.04

Step7 использую v5.3 HF2 и он ничего не говорит, только песочные часы показывает на долю сек. Проблему решил "как обычно", похоже это универсальный метод, радует только что сам проект так непонятно(тьфу,тьфу..) никогда не падает.


text

Не работают методы Move элемента msadodc
cias; 29.8.04

Проблема такая: в SCADA системе WinCC использую элемент управления adodc.

ADODC подключается к mysql через odbc драйвер (для UserArchive ситуация аналогична).
После выполнения sql-запроса, пытаюсь просмотреть результат, последовательно в цикле проходя по набору записей. При этом adodc.recordset.fields(2).value возвращает результат первой строки в наборе, хотя после него стоит метод adodc.recordset.movenext().
Метод RecordCount выдает результат в 31 запись (и это верно).
Может чего нехватает в настройках элемента управления, но при использовании в приложении на VB все тоже самое работает(все настройки контрола).
Заранее благодарен за помощь.
а код вот такой
cias; 30.8.04

#include "apdefap.h"

void OnClick(char* lpszPictureName, char* lpszObjectName, char* lpszPropertyName)
{
#define GetObjectA GetObject

long i=0;
long j=0;

__object *obj = NULL, *pic = NULL, *ado=NULL;
obj= __object_create("PDLRuntime");
if(!obj)
{
printf("obj = NULL\r\n");
return;
}
pic = obj->GetPicture("Test");
if( pic == NULL){
__object_delete(obj);
printf("pic != NULL\r\n");
return;
}
ado=pic->GetObject("Control1");

if( ado == NULL){
printf("ado = NULL\r\n");
__object_delete(obj);
__object_delete(pic);
return;
}
ado->ConnectionString="DSN=my_office";
ado->RecordSource="Select * from avto";
ado->Refresh();
if(ado->Recordset->BOF)
{
printf("\r\n Òàáëèöà ïóñòà");
}
else
{

printf("\r\n%d",ado->Recordset->RecordCount());//все путем 31
i=ado->Recordset->RecordCount();//i=31
while(j<i)
{
printf("\r\n%s",(char*)ado->Recordset->Fields(2)->Value);//Всегда первая запись
printf(" %u",(long)ado->Recordset->Fields(0)->Value);
ado->Recordset->MoveNext();

j++;
}

}
__object_delete(obj);
__object_delete(pic);
__object_delete(ado);

}<


text

не сохраняются данные в базе SQL
Малкон; 26.11.04

Добрый день.

Никак не могу отобразить разобраться с архивами.
Точнее не вижу что данные сохраняются в SQL базе.

Я хочу чтобы данные поступающие якобы от контроллера (на самом деле от
программы Simulation) сохранялись в SQL базе дынных.

Как я это делаю ?
Я основываюсь на документации:
UserArchivesV502_r.pdf

1. Создаю один тэг у интерфейса MPI (называл его MPI_tag)получилась
цепочка: MPI -> NewConnection_1 -> MPI_tag
2. Создаю архив в UserArchive. Указываю что данные буду брать из тэгов
(Communication via a WinCC Tag)
3. Непонятно для чего , но все же создал контрольные переменные типа @UA_aName_ID
4. Права: <No access-protection>
5. Дальше добавил поле: где указал минимум 0, максимум 200, начальное
значение 34
6. У поля параметр WinCC Tag назначил тэгу MPI_tag
7. Права у поля <No access-protection>
8. Дальше как мне показалось очень странным, что я нигде не написал
время опроса тэга, а запустив проект, данные конечно же не сохранялись
в SQL.
9. Ладно, пошел в Graphics Designer, там повешал объект какую-то
печку, которой назначил тэг MPI_tag.
10. Запустил проект, запустил Симулятор, в симуляторе поставил
случайные значения, Все отлично на рисунке видно случайные скачки. Ну
думаю значит и в архив пишеться, захожу в Microsoft Enterprise
Manager, база есть, но в ней ничего нет. Почему не сохраняеться ?
11. Ладно думаю, создам я WinCC User Archive - Table Element, он то уж
точно покажет. Повешал табличку, прикрутил к ней таблицу архива, а тот
в свою очередь показал ее два поля (одно которое я создал и ID).
Запустил, включил симулятор, индикатор прыгает, табличка как
замороженая, как ничего небыло так и нет, кроме заголовков полей.

и вот я и приехал, что я делаю неправильно ?
Re: не сохраняются данные в базе SQL
Alexis; 26.11.04

Может надо было через TagLogging сохранять?

Re: не сохраняются данные в базе SQL
Малкон; 26.11.04

Задача будет намного сложнее, чем простое сохранение, поэтому был выбрана опция UserArchives.

А вот выдержка из описания опции:
При помощи пользовательских архивов WinCC осуществляется непрерывное
сохранение данных технологического процесса на сервере. Для отображения
оперативной информации в графическом дизайнере (Graphics Designer) в режиме
исполнения существует специальный элемент управления – Таблица
пользовательского архива (User Archive Table Control) WinCC.
Re: не сохраняются данные в базе SQL
Alexis; 26.11.04

А что за такая сложная задача?

Re: не сохраняются данные в базе SQL
Малкон; 26.11.04

Там много лишнего храниться, а в UserArchive, я могу контроллировать что хранить а что не хранить.

Аналогично поступаю с TagLoggin, архив не создаеться. В табличке пусто.
Re: не сохраняются данные в базе SQL
Alexis; 26.11.04

А у тебя TagLogging запускается при RT проекта?

Re: не сохраняются данные в базе SQL
Руденко Алексей "НЕВИСС-Комплекс"; 26.11.04

Во первых, если работать с ТагЛогингом, то средствами SQL данные можно и не увидеть. так как они могут храниться в сжатых архивах (6.0 ВинСС, в 5.1 все видно и работает великолепно)

Во вторых, при работе с юзерархивом, запись в архив производится только с помощью функций, которые нужно писать ручками.
А запись производится с помощью управляющих тегов (там их 4 штуки - используются первые 2)
Говорю на память, поэтому с названиями могу ошибиться.
1-ый тэг UA_Job... - в него заносится какое то значение (5,6 или 7) в зависимости от него в архив пишутся тэги или считываются 2-ой отвечает вроде за колонку и т.д. ТОчно не помню, в любом случае в доках все написано.
ИТОГ: запись в архив можно производить управляя этими 2 тэгами, иначе только через функции актив-х элемента, но это уже другой разговор.
Удачи...
Re: не сохраняются данные в базе SQL
Юрченко Владимир; 26.11.04

Насчет использования User Archiv для архивирования выше почти все написано, добавлю, что для этого нужна будет лицензия на эту опцию.

Если же используется WinCC 6SP1, то для того чтобы нормально работал стандартный TagLogging, надо поставить еще HotFix2 или HotFix3 (последний есть на CD с DEMO WinCC6).
Re: не сохраняются данные в базе SQL
Юрий Оганесян; 26.11.04

Не забудь првести тестирование быстродействия User Archive, а то у тебя там какая-то задача сложная - боюсь не потянет. Быстродействие, указанное в документации смело дели на 2.


text

Не удается загрузка в OP77B
Бобков Александр; 24.8.04

Добрый день!

Проблема с OP77B.

При попытке загрузить проект выдается сообщение Created configuration is intended for a different device than the currently connected и загрузка прекращается.

Версия WinCC Flexible Compact V1.00 Hotfix2
В проекте OP77B конфигурируется как V1.0.0.0
Версия ОР77B (как первоначально было установлено на панели) WinCE 3.0, image B7.0.0.52.

Как рекомендовано в руководстве, сделал Project-Transfer-OS Update. Происходит вызов Prosafe7.0 и передача на OP файла …\WinCC flexible Images\OP77B\OP77B_V7_0.img. Версия ПО панели после этого опять WinCE 3.0, image B7.0.0.52. Проект снова не грузиться.

Помогите, кто может...<


text

Неизвестная ошибка в DBGHELP.dll
Эдуард; 22.9.04

Re: Неизвестная ошибка в DBGHELP.dll
Павел Кобелев; 23.9.04

Попробуйте символьные указатели проинициализировать перед использованием. Типа Nomer=new char[128];

Очищать ничего не надо, память освобождается автоматом.
Re: Неизвестная ошибка в DBGHELP.dll
Эдуард; 23.9.04

2Павел: Оператор new WinCC не понимает.


text

Непонятки с трендами
Денис Дроздов; 4.8.04

Тренды как то странно отображаются - с запаздыванием на 5 минут относительно системного времени. Люди волнуются. Это так задумано или мой глюк?

Re: Непонятки с трендами
Маслов Дмитрий; 4.8.04

Ничего такого вроде бы не задумано. Если период архивации 1 секунда, то и обновляется все раз в секунду... Проверьте цикл опроса/архивации, и не включена ли у Вас опция архивации по изменению.

Re: Непонятки с трендами
Дроздов Денис; 6.8.04

В таг логгинге он раз в секунду и обновляется, а все тренды длинее часа на визуализации на 5 минут отстают.


text

несовместимость ОС MP270 и ProTool 6 SP2
Юрий С.; 13.1.04

При подключении к MP270 через ProTool v6 SP2, выдает ошибку о несовместимости операциооной системы панели и версии ProTool. Конечно, нужно обновить операционку, однако, у меня нет исходника программы из панели, поэтому я ъочу считать программу из мультипанели. Самый простой способ в этой ситуации - это найти патч для ProTool v6 SP2, чтобы обеспечивалась совестимость с операционкой мультипанели v5.2.x.x - точно не помню.

Помогите пожалуйста найти такой патч и существует ли он?
См. http://www.omsktyre.ru

Re: несовместимость ОС MP270 и ProTool 6 SP2
Vladimir Matveev; 30.1.04

Для обновления нужно

- запустить ...\Siemens\Protool\Images\<MP270>\PTUpdate.exe,
- включить ОР-панель (СОМ-шнурок, RS232),
- После появления "Please, reboot device", соответственно, передёрнуть питание.
В дальнейшем download выполняется обычным образом.
Удачи!
Владимир.<


text

Нет связи WinCC
Владимир; 10.8.04

Есть ли в WinCC готовая функция определяющая , что нет связи с контроллером ?

Re: Нет связи WinCC
Юрченко Владимир; 10.8.04

В С-скриптах есть набор функций для определения статуса переменной. А в слове статуса есть бит определяющий потерю связи с контроллером. Подробности смотрите в Help (файл GlobalScriptFunctions.chm).

Re: Нет связи WinCC
Маслов Дмитрий; 10.8.04

Сделайте такой скриптик в Global Scripts с вызовом, к примеру, раз в секунду. Здесь "State" - тег, привязанный к адресу M0.0 контроллера, "ControllerState" - внутренний тег, в котором будет содержаться информация о состоянии связи с контроллером: 1 - OK, 0 - все плохо.

int gscAction( void )
{
DWORD ControllerState;
GetTagBitState("State", &ControllerState);
SetTagBit("ControllerState", (short)(ControllerState == 0));

return 0;
}
См. http://www.wincc.ru


text

Неужели это НЕВОЗМОЖНО??????
Миша; 25.9.04

Есть проект WinCC 6.0. Я хочу его сделать заново. Как мне экспортировать теги из одного проекта в другой (НЕ НАБИРАТЬ ЖЕ ИХ ЗАНОВО)

Заранее благодарен.
Re: Неужели это НЕВОЗМОЖНО??????
Л. Шерешевский; 26.9.04

Нет ничего невозможного. Вот 2 наиболее простых варианта переноса тегов:

1. Copy-Paste. Открываете старый проект, копируете теги, открываете новый проект, вставляете теги. Недостатком этого способа является необходимость нескольких итераций, особенно при наличии множества соединений.
2. WinCC Configuration Tool. Экспортируете в Excel старый проект, а затем все что нужно копируете в новый. Этот вариант наиболее правильный, он рекомендован Сименсом. Однако, при этом Вам придется узнать из документации, что такое WinCC Configuration Tool и как с ним работать.
См. Центр компетенции WinCC

Re: Неужели это НЕВОЗМОЖНО??????
GorA; 27.9.04

Есть програмка в SmartTools - Variablen Export-Import.

Должна быть на установочном диске WinCC.

Re: Неужели это НЕВОЗМОЖНО??????
Миша; 27.9.04

всем большое спасбо!!! попробую


text

Нужен ProTool
Sergey; 26.1.04

Необходимо дополнить в панелях OP7 сообщения и тех.параметры.

Re: Нужен ProTool
Magik; 28.1.04

Если нет самого проекта лучше даже не ищите... такой гемор будет :(


text

Нужна OP7
Андрей; 8.10.04

Нужна ОР7 либо плата от нее

750-1003 05А.фОРМА ОПЛАТЫ ЛЮБАЯ
Re: Нужна OP7
СВР; 11.10.04

Продадим вам панель ОР7 со склада.


text

Нужна информация по WinCC Channel Development Kit
Александр Савченко; 20.10.00

Где КОНРКТНО в Интернет найти более-менее Подробную информацию по WinCC Channel Development Kit на русском, но можно и на английском.

Поверхносный поиск ничего конкретного не дал...
Или пришлите пожалуйста что-нибудь мне на е-майл
Re: Нужна информация по WinCC Channel Development Kit
siemargl; 22.10.00

Если у тебя проблемы с английским, за CDK лучше и не берись. Там требуется _глубокое_ понимание и опыт работы с написанием OLE серверов с использованием MFC....

Господа, Да дайте же ссылок в коце концов! English - OK (-)
Александр Савченко; 23.10.00

Господа, Да дайте же ссылок в коце концов! (-)

Re: Господа, Да дайте же ссылок в коце концов! English - OK (-)
Чистяков Дмитрий; 27.10.00

Если не ошибаюсь, то коечто есть из описаний есть на бесплатном CD WinCC

Re: Господа, Да дайте же ссылок в коце концов! English - OK (-)
Никаноров (Сименс-Москва); 27.10.00

На бесплатном диске WinCC почти ничего нет по CDK.

В очередной версии этих дисков (которые будут распространяться в ближайшее время) эта документация будет включена.
Поэтому, для тех, кто уже имеет диски WinCC без документации на CDK, я могу выслать ее по e-mail.
Re: Нужна информация по WinCC Channel Development Kit
Суюндуков Дмитрий; 23.11.04

Хотелось бы написать драйвер для MS SQLServer.

Если такой уже имеется то я был бы рад.
Re: Нужна информация по WinCC Channel Development Kit
Чистяков Дмитрий ОАО СеверСталь; 24.11.04

Хм... Какой драйвер?

Если необходимо просто сделать обращения к базе WinCC из другого сервера (клиента) MS SQL или наоборот работать с другим сервером MS SQL, то всё это описано в KnowledgeBase, который имеется на диске с WinCC.<


text

Обмен файлами картинок, скриптами и тд
Darwin; 27.5.04

Предложение, обмениваться файлами для ProTool, WinCC. Целыми проектами

Re: Обмен файлами картинок, скриптами и тд
shurik; 27.5.04

Ну давай выкладывай,это интересно

Re: Обмен файлами картинок, скриптами и тд
ALEX; 6.8.04

ДАВАЙ ПОПРОБУЕМ

Re: Обмен файлами картинок, скриптами и тд
Darwin; 9.8.04

ToAlex, послал проект розливочной машины.

Мне кажется такой обмен интересен не в плане сдирания готовых решений, а в плане самообразования, т.е. интересно каким образом решаются задачи.

Re: Обмен файлами картинок, скриптами и тд
GorA; 9.8.04

To Darwin

А разве это не одно и тоже?
Re: Обмен файлами картинок, скриптами и тд
Владимир; 10.8.04

Хы

пойдите найдите 2 одинаковых задачи, которые решены средствами WinCC
Предложение к модераторам по "Обмен файлами картинок, скриптами и тд"
Роман; 10.8.04

А не лучьше ли на сайте открыть раздел типа "Проекты реализованные на WinCC или S7" краткое описание задачи (железо, способы связи)картинки и т.д. Предложение к модераторам

Re: Обмен файлами картинок, скриптами и тд
Nick; 11.8.04

А кто будет следить за соблюдением авторские прав?

Re: Обмен файлами картинок, скриптами и тд
Роман; 11.8.04

А никто и не принуждает выкладывать скрипты и т.д., предлагается подробное описание проектов, а вот кому нужно тот пускай с разработчиками связывается и разговаривает на более конкретные темы, это своеобразная реклама как продукта так и разработчиков. Как на это смотрят модераторы форума, дайте однозначный ответ, тема актуальна.

Re: Обмен файлами картинок, скриптами и тд
Юрченко Владимр; 11.8.04

Есть такое предложение - присылайте ваши примеры на мой адрес, а я буду их загружать на недавно открытую папку Downloads в Документации WinCC. Просьба присылать в zip файле с указанием названия, под которым будет это в папке, и кратким описанием (Readme) в отдельном файле.

P.S. Описание проектов есть в разделе Решения и можно отдельно описания WinCC проектов публиковать в http://www.automation-drives.ru/as/solutions/solutions.php?l1=WinCC-проекты, которая сейчас пустая.
См. http://www.automation-drives.ru/as/products/doc.php?l1=SIMATIC%20HMI&l2=WinCC&l3=doc


text

ОБНОВЛЕНИЕ PCS7 V5.2 НА PCS7 V6.0
ЕФИМОВ; 5.7.04

ВХОДИТ ЛИ WIN CC V6 В UPGRADE-ПАКЕТ

(6ES7658-2DB05-0YE0) ИЛИ ЕГО НАДО ЗАКАЗЫВАТЬ ОТДЕЛЬНО<


text

Обновление информации в ВинЦЦ
KAV; 13.9.04

Добрый день.

Кратко о проекте: 2 станции WinCC v6.0 (сконфигурированы как отдельно стоящие сервера) с помощью CР1613(в каждом по 1-й) и S7-redconnect связаны с
CPU 414-4H. На компьютере оперативной памяти 1 Гб, скорость процессора 3MГц. Связъ по Ethernet-100Mb через HUB.
Переменных I/O-2000, аварий – 2300, запись трендов – 25 параметров.
Один из экранов (основной) очень сложный: tag connection - 650,Direct connections - 680,Dynamic dialogs-250,Tags in dynamic dialogs-600,Dynamic dialogs Inproc-1245. И при переходе на него время обновления информации колеблется от 3 до 20 секунд.
Но кроме этого, и это просто ужасно, периодически компьютер “замирает” (не зависит от открытого окна), т.е. не видно информации из контроллера (или видна устаревшая), а нажатие на клавиши (установка/сброс значений) ни к чему не приводят, хотя запоминаются в буфере и затем принимаются к исполнению.
При этом диагностируемая связь с контроллерами не обрывается (использован стандартный Wizard WinCC).
Почти все привязки стоят “по изменению”.
Изменение на 250 ms или 500 ms ни к чему не привели.
Подскажите, пожалуйста, ЧТО ДЕЛАТЬ?
Заранее благодарен

Re: Обновление информации в ВинЦЦ
Макс Прилепский; 13.9.04

В WinCC Explorer в настройке канала связи в контекстном меню System Parameter можно попробовать сбросить флажок "By PLC" в категории Cycle Management, в своё время в WinCC 5.1 это помогало снизить нагрузку на коммуникации.


text

Обновление кадра в ВинЦЦ
KAV; 27.8.04

Проект на S7-400H, 2 шт ВинЦЦ. Один из экранов (основной) очень сложный - tag connection - 650,Direct connections - 680,Dynamic dialogs-250,Tags in dynamic dialogs-600,Dynamic dialogs Inproc-1245. И при переходе на него время обновления информации колеблется от 3 до 20 секунд. Может кто сталкивался? Что делать? Все привязки стоят "По обновлению"

Re: Обновление кадра в ВинЦЦ
Чистяков Дмитрий ОАО СеверСталь; 27.8.04

Поставь всем им 500мс.

Re: Обновление кадра в ВинЦЦ
Л. Шерешевский; 27.8.04

Режим "по обновлению" использовать однозначно не стоит. Не зная, какая у вас реализация сетевого взаимодействия, 500мс я бы не рискнул рекомендовать. Ну нет смысла медленно изменяющие параметры передавать с высоской частотой. Кроме того, частота обновления параметров различных типов должна быть оговорена в ТЗ.

А нет ли у Вас макросов, срабатывающих при открытии кадра и использующих GetTag...?<


text

Обновление кадра в ВинЦЦ
KAV; 27.8.04

Проект на S7-400H, 2 шт ВинЦЦ. Один из экранов (основной) очень сложный - tag connection - 650,Direct connections - 680,Dynamic dialogs-250,Tags in dynamic dialogs-600,Dynamic dialogs Inproc-1245. И при переходе на него время обновления информации колеблется от 3 до 20 секунд. Может кто сталкивался? Что делать? Все привязки стоят "По обновлению"


text

Обработка битов в AlarmLoggin
Андрей; 19.10.04

Возникла ситуация обработки сообщения в Alarm Loggin не по одному биту, а трем:

MessageTag = 00000xxx, где xxx =
000 - измерение влажности
001 - прогрев
010 - забит датчик
011 - и т.д.

Как обработать такую ситуацию. Ведь для каждой комбинации необх. создавать message с указанием класса, типа, source, text, Message Tag и т.д.
Какой бит выставить в качестве сигнального (для срабатывания).

Re: Обработка битов в AlarmLoggin
Руденко Алексей Невисс-комплекс; 19.10.04

Скорее всего их надо сначала обработать в степе, а лишь потом по результатам их обработки выставлять какой либо бит и его оценивать в аларме...

Либо на каждый из тегов делать свое сообщение - тоже вариант...<


text

Ограничение на число объектов PIcture Window
Владимир; 29.12.03

Столкнулся с этим ограничением !

Никто не решал эту проблему ?
Напомню - есть ограничение в 32 объекта типа Picture Window на кадре.
Re: Ограничение на число объектов PIcture Window
Макс Прилепский, ОАО "ЗСМК"; 5.1.04

Ограничение существует только на 32 экземпляра Picture Window,привязанных к одному и тому же экрану, например Picture1.PDL, если скопировать этот экран в файл с другим именем, например, Picture2.PDL - то получится уже 64 экземпляра :) Но всё - таки, в задачах, связанных со множеством однотипных окон для каких либо объектов, лучше использовать одно или несколько Picture Window с Tag Prefix, если, конечно, не предполагается отображать сразу все окна объектов.

Re: Ограничение на число объектов PIcture Window
Владимир; 8.1.04

Именно и требуется отобразить 36 объектов Picture Window.

Каждая Pdl в Picture Window имеет еще по 2 Picture Window, для каждого установлен свой Tag Prefix. :-)
Такова задача.
Пока перенес все на прямые ссылки, но хочется найти решение.
Разбить на кусочки по PDL не получилось, действует общее ограничение.<


text

Описание OPC?
Виктор; 21.10.04

Здравствуйте!

Подскажите, пожалуйста, где можно найти описание на OPC стандарт в целом и на OPC фирмы СИМЕНС?
И есть ли такое на русском языке?
Спасибо.
Re: Описание OPC?
Андрей; 21.10.04

По поводу первого вопроса (описание стандарта OPC):

http://www.opcfoundation.org/ - основной
http://www.ipi.ac.ru/lab43/lopc-ru.html
http://www.opceurope.org/
http://www.opcconnect.com/index.php
http://www.opcfoundation.org/
http://www.opctest.com/

На этих сайтах докум. можно скачать.
Я сам OPC занимался очень долго (разработка сервера и клиента), писал на Delphi. На русском языке вряд ли где найдешь.

А OPC фирмы СИМЕНС, если знаешь спецификацию, наверное уже и не надо будет, только если какая-то конкретная настройка чего-то.
Re: Описание OPC?
Виктор; 21.10.04

Спасибо Андрей. Почитаю. Вот сейчас я как раз и пытаюсь написать клиент на Делфи. Попробовал написать свой сервер-клиент с примитивными функциями- все получилось.

Теперь нужно написать клиента к СИМЕНовскому серверу.<


text

Описание функций PCS7
Vadim; 28.9.04

Где найти описание стандартных

функций ( написаных на C ) PCS7?
Re: Описание функций PCS7
Чистяков Дмитрий ОАО СеверСталь; 29.9.04

Хм... А где Вы в PCS7 видели функции, написанные на С?

А описания всех функциональных блоков можно взять здесь
См. http://www.automation-drives.ru/as/products/doc.php?l1=SIMATIC%20PCS7&l3=doc

Re: Описание функций PCS7
Павел Кобелев; 1.10.04

Может имелись в виду стандартные функции для макросов на ANSI-C в WinCC?

Re: Описание функций PCS7
Вадим (ЗАО Инкомсистем); 1.10.04

Да имел в виду функции WinCC


text

Описание функций ProTool
Дмитрий; 25.12.03

Создаю проект в ProTool Pro на основе ПК, но требуется описание функций, где его можно найти

Re: Описание функций ProTool
Игорь; 25.12.03

Вообще-то вопросы надо поконкретнее формулировать...

Скачай доку на русском языке с этого сайта, и изучай на здоровье...

( http://automation-drives.ru/as/products/doc.php?l1=SIMATIC%20HMI&l2=ProTool&l3=doc )
Re: Описание функций ProTool
Дмитрий; 26.12.03

В тех документах нет описания функций. Может я плохо объясняю, но я имею в виду те функции, которые можно присваивать, например, кнопка и т.д.

Re: Описание функций ProTool
Сидоров Артем; 25.2.04

А чем Вас не устраивает стандартный хелп?


text

Описание функций ProTool
Дмитрий; 12.1.04

Создаю проект в ProTool Pro на основе ПК, но требуется описание функций, где его можно найти.

Я имею в виду те функции, которые можно присваивать, например, кнопкам и т.д.

Re: Описание функций ProTool
Юрченко Владимир; 12.1.04

Отдельного руководства или справочника по функциям нет, но в help'ах все хорошо описано. Смотрите Configuring Windows-based systems/Reference/Functions. Кроме этого есть описание VB функций, но в виде html файлов, ссылка на них есть в Help ProTool - Configuring Windows-based systems/Configuration techniques/Creating VB scripts.


text

Определение ID action
Людмила; 27.10.04

Кто-нибудь знает как получить ID Global action? А как программно отключить выполнение или стартовать например test.pas?

Заранее спасибо!
Re: Определение ID action
GorA; 27.10.04

Как системно получить не знаю, но можно создать внутренний ТЭГ, например, integer. И в глобальноых акциях записывать какое либо индивидуальное для каждой акции число и, соответственно, по необходимости считывать данный ТЭГ для получения данных о выполняемой акции.

Re: Определение ID action
Людмила; 27.10.04

Этот вариант хорош, когда просто надо знать, что за функция выполняется. А так как мне необходимо отключить action или подключить системно, или прицепить триггер в скрипте, то мне нужен указатель на функцию. В форуме я когда-то встречала как это делать через какую-то системную таблицу, а сейчас не могу найти, где я это читала. Просто я знаю, что это как-то делать возможно.


text

Оптимальные алгоритмы в WinCC
Maksim; 27.11.04

Мож посоветуете. Есть 16 одинаковых агрегатов - по 60 тегов на каждый. Можно ли использовать один экран для всех? Сам пробовал создавать группу из 60 внутренних тегов, и в зависимости от требуемого агрегата копировал в группу нужные значения - GetTag -> SetTag. Но при цикле в 1сек. это приводит к загрузке рабочей станции дополнительно на 20-25%. Грустно. Раскопировать на 16 экранов? Или есть варианты?

Re: Оптимальные алгоритмы в WinCC
Маслов Дмитрий; 28.11.04

Опишите структурный тег с 60 полями. Создайте по одному такому тегу на каждый агрегат (16 штук). Создайте одну картинку, и привяжите все объекты на ней к полям созданного структурного тега. Например, если в структуру входит поле "Value", то к полю вывода на каринке привязывайте не тег (например, "Aggregate1.Value"), а только поле структуры: ".Value". Полученную картинку отображайте через PictureWindow, в котором в свойство TagPrefix записывайте имя структуры, например, "Aggregate1".

См. http://www.wincc.ru

Re: Оптимальные алгоритмы в WinCC
Anton; 29.11.04

Еще можно образовывать не структуру а имя тэга, в котором присутствует номер агрегата, а собирать соброс нужно строкой и потом вызывать тэг, имя которого сформированная строка.

Re: Оптимальные алгоритмы в WinCC
Nick Gashevsky; 29.11.04

Попробуй привязять косвенными (indirect) тегами. Работать в похожем случае со структурным тегом мне не понравилась - когда прищлось несколько раз менять состав структурного тега (проект железа и софт разрабатывался параллельно), делать это не удобно.

Re: Оптимальные алгоритмы в WinCC
Маслов Дмитрий; 29.11.04

По поводу изменения состава структурного тега: если действительно планируется его менять, то структурный тег неудобен. Однако с TagPrefix можно работать и без него. Для этого надо создавать на каждый агрегат теги с именами вида

"Aggregate1_Value1",
"Aggregate1_Value2",
...
"Aggregate1_ValueN",
а к полям вывода на картинке привязывать
"_Value1",
"_Value2",
...
"_ValueN".
В качестве префикса, как и в случае структурного тега, указывать "Aggregate1". Такую "структуру" дополнить новыми "полями" не составит труда.
<


text

Опция Storage
rustam; 18.9.04

Что надо сделать, чтобы в опции storage (WinCC 5.1) был доступ к архиву аварийных сообщений (Alarm logging)? Там почемуто оображаются только данные из tag logginga.


text

ОПЯТЬ ВСТРЕЧНЫЙ ВОПРОС ПО АНИМАЦИИ
ALEX; 28.7.04

Анимация появление и исчезание Цикл проходит объектов. В програмном логичном контролере а я получаю только сигналы,например от 1 до 5 и так по кругу.Почему же всё-таки пропадает курсор для ввода других полей при этом.


text

ОПЯТЬ по поводу ФИЛЬТРА в AlarmLogging
ALEX; 13.7.04

И всё таки подскажите как подсоеденить текстовый Тег к MsgFilterSQL как выглядит макрос в С-ACTION. Или как выглядит в С-ACTION фильтрование сообщений по промежутку времени через теги. Если можно скинуть на alexrls@rlsaut.pt

Re: ОПЯТЬ по поводу ФИЛЬТРА в AlarmLogging
Маслов Дмитрий; 14.7.04

В C есть такая функция, sprintf называется. Ну так вот с помощью нее можно сформировать любую текстовую строку. В текст строки можно включить произвольные значения, в том числе считываемые из тегов с помощью функций GetTagXXX.

Описание sprintf и других фукнций C читайте, например, в MSDN. Или в любой книжке по С.

Пример ушел по мылу.<


text

ОР3 и число с плаваюйщей запятой
Сергей; 3.3.04

Здравствуйте!

Подскажите, как на панели ОР3 вывести число с плавающей запятой, типа 100,5 .
Для этой панели в Протуле не нашел нужного типа тега.
Спасибо!
Re: ОР3 и число с плаваюйщей запятой
Юрченко Владимир; 5.3.04

OP3 не поддерживает чисел с плавающей запятой. Единственный способ вывести число с плавающей запятой - в контроллере посчитать целую часть и после запятой, представив их в int и word, а в панели выводить эти два числа поставив между ними точку.


text

Организация связи WinCC v6 с SIMADYN D
Борис; 10.3.04

Подскажите источник, где можно узнать, как организовать работу индексных архивов COROS при переводе системы визуализации с COROS на WinCC v6, какой канальный драйвер можно использовать? Возможно кто-то сталкивался с такой проблемой. Ответьте.

Re: Организация связи WinCC v6 с SIMADYN D
Чистяков Дмитрий ОАО СеверСталь; 10.3.04

Мы для версии 5 использовали WinCC ADD-OS

WinCC Channel Dll
http://www.ad.siemens.de/hmi/html_76/products/software/wincc_addons/wcc_addon_directory_6.htm
<


text

Организация сообщений в PCS7v6.0
Лисагоров С.Н.; 18.10.04

Какой механизм посылки сообщения из FB контроллера в окно "alarm" соответствующего FB "faceplates"?

Re: Организация сообщений в PCS7v6.0
Михайлин Сергей; 19.10.04

Посылка сообщений в системе PCS7 происходит через блок в контроллере Alarm_8P, который как правило встроен в каждый блок технологической библиотеки.


text

Отловить нажатие ESC
Дроздов Денис; 1.4.04

Как отловить нажатие любой клавиши с клавиатуры?

Re: Отловить нажатие ESC
Zolotoy; 1.4.04

Cтавишь прогу 007 Spy Software http://www.e-spy-software.com/

у меня стои тверсия 3.17, ловит всё подряд :) даже скиншоты снимает с указанным промежутком времени
Re: Отловить нажатие ESC
Дроздов Денис; 5.4.04

Да не то... Надо типа как нажали кнопу, а пикчуре виндов закрылось. Короче, нужны коды кнопок и функция их отлова.

Re: Отловить нажатие ESC
Кирилов Владимир; 5.4.04

А если у невидимой кнопки поставить HotKey - ESC ?

А на Mouse Action этой кнопки -то , что ты хочешь...
Re: Отловить нажатие ESC
Прокопенко В.; 5.4.04

Для объекта главной картинки в свойствах -> Events-> Keyboard ->Press пишется скрипт, например:

#define ESC 27

printf("Key =%d \r\n",nChar);
if (nChar==ESC )
...нужное действие...;

но это будет работать только при условии, если объект этот в фокусе

Re: Отловить нажатие ESC
Дроздов Денис; 6.4.04

Вот в том то и все дело - в фокусе. Как это сделать глобально?

Re: Отловить нажатие ESC
Макс Прилепский; 6.4.04

Написать какую-нить hook.dll,или найти готовую, которая перехватывает все сообщения окна WinCC-Runtime, и из обилия собщений этого окна отлавливать сканкоды нажатых клавиш... А что касается клавиш, то можно, как было сказано ранее, сделать одну или несколько невидимых кнопок (свойство Display=FALSE или размер 0х0) в той области экрана, которая не изменяется, например, на стартовой картинке, привязать к этим клавишам нужный Hotkey, например Esc. После нажатия Esc в данном случае выполнится код, привязанный к событию Mouse Action этой невидимой кнопки, в котором можно закрыть Picture Window или выполнить иное действие. Таким образом, при нажатии Esc, всегда будет выполняться заданное этой кнопке действие, независимо от того, есть ли фокус на этой кнопке. Если надо отлавливать несколько клавиш, то, соответственно , делаются несколько невидимых кнопок. Есть, правда, ограничения на горячие клавиши: например, пробел нельзя привязать, а Alt и Ctrl можно только совместно с другими клавишами...


text

Отображение Event Message. Как?
Scout; 7.10.04

Как сделать так, чтобы сообщения о событиях появлялись на экране, а не складировались в буфере. Тоесть мне надо, чтобы как только установился соответствующий бит, появлялось соответствующее ему сообщение, чего сейчас не происходит, оно просто оседает в буфере.

Re: Отображение Event Message. Как?
Маслов Дмитрий; 11.10.04

Не совсем понятно, что Вы подразумеваете под буфером, и чего хотите добиться.

Текущие сообщения в WinCC отображаются в специальном окне сообщений (если оно настроено на отображение текущих сообщений, а не архива). Туда не попадают лишь те сообщения, класс которых помечен как "Без статуса "Ушедшее"".
См. http://www.wincc.ru

Re: Отображение Event Message. Как?
Scout; 12.10.04

Прощу прощения, забыл уточнить. Я имел

ввиду отображение сообщений на панели оператора(OP07). Так вот, в буфере Еvent сообщения появляются, а на экране не отображаются. С Alarm сообщениями подобной проблемы нет, а вот с Event сообщениями никак. А добится я хочу того, чтобы оператор видел сообщения сразу, а не лез их смотреть в буфере.
<


text

Отображение массива данных в виде тренда
Александр Клейн; 11.5.04

Как можно отобразить массив чисел в виде тренда, который бы появлялся на экране сразу, а не полз справа налево? Задача усложняется тем, что количество отображаемых тегов может меняться, например, от 200 до 800. Такое количество данных - это результат обработки быстрого процесса. Конроллер пишет их по прерыванию у себя в блок данных и только потом разрешает забрать в WinCC.

Re: Отображение массива данных в виде тренда
Маслов Дмитрий; 12.5.04

Не совсем понял Вашу задачу, поэтому предлагаю три варианта решения.

1. Если данные хранить в User Archive, можно отображать их график с помощью элемента Function Trend.
2. Можно делать свой собственный тренд на базе обычной ломаной линии (динамически перемещая и добавляя/удаляя ее узлы). См. пример в демо-проекте WinCC.
3. Если цель - это просто быстрая архивация значений некоторого параметра с последующим отображением тренда, то можно пользоваться полностью стнадартными средствами. Т.е. использовать SFC "AR_SEND" для накопления буфера данных в контроллере и передачи его в WinCC Tag Logging. Полученный архив можно отображать с помощью обычного элемента Online Trend.
Re: Отображение массива данных в виде тренда
Александр Клейн; 16.5.04

Спасибо за подсказку, проблема решена!


text

Отображение трендов с помощью VBScript
Алексей; 21.9.04

Подскажите, плиз, код скрипта, который может вывести на форму TlgOnlineTrend

график архивного тега "Arch_tag" со "start_time" в определенном "interval".
В хелпе я ничего путнего не нашел.
<


text

отчет за определенный период времени
D.M.; 16.11.04

Как в версии 5.1 Report Designer создать таблицу сообщений за текущие сутки?

Re: отчет за определенный период времени
Маслов Дмитрий; 19.11.04

В WinCC Configuration Manual описан способ выбора диапазона времени для таблиц и трендов в отчетах, и даже приводится пример скрипта.

Re: отчет за определенный период времени
Руденко Алексей "НЕВИСС-Комплекс"; 19.11.04

По своему опыту скажу, что это достаточно проблематично...

Мы пытались сделать это на основе функций ODK и это даже получалось, но в случае когда есть сервер винСС и несколько клиентов - система начинает глючить и отчеты просто не распечатываются с самих клиентов, хотя с сервера все работает...
В итоге написал внешнее приложение на дельфи, которое вытягивало из архива таг.логинг данные...
Re: отчет за определенный период времени
D.M.; 22.11.04

а пример скрипта,который делает выборку по времени для отчета, можно сюда скинуть?

Re: отчет за определенный период времени
Руденко Алексей "НЕВИСС-Комплекс"; 22.11.04

Пример проеккта для винсс есть на диске...

А так же можно посмотреть ОДК - там есть описание нужных функций...
А если делать внешнее приложение, то там все через SQL...
Удачи...<


text

Отчет
Валера; 9.11.04

Отчет
Валера; 9.11.04

Как в WinCC распечатать архив тренда или таблицы нажав на созданную в рисунке кнопку,например,для того чтобы оператор смог увидеть данные за определенный момент времени и для нужного параметра...

Отчет
Валера; 9.11.04

Как в WinCC распечатать архив тренда или таблицы нажав на созданную в рисунке кнопку,например,для того чтобы оператор смог увидеть данные за определенный момент времени и для нужного параметра...

Re: Отчет
Кирилов Владимир; 10.11.04

http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1044712660&year=2003


text

Отчеты
Валера; 9.11.04

Как в WinCC распечатать архив тренда или таблицы нажав на созданную в рисунке кнопку,например,для того чтобы оператор смог увидеть данные за определенный момент времени и для нужного параметра...


text

Отчеты
Николай; 10.12.04

Как в WinCC создавать динамические отчеты,т.е. с выбором нужного тэга и нужного диапазона времени,например...

Спасибо...

Re: Отчеты
Руденко Алексей "НЕВИСС-Комплекс"; 10.12.04

Вариант 1: Через функции ОДК, которые позволяют изменять параметры выборки по времени и т.д., но должны быть эти отчеты все равно спроектированы в репорт дизайнере. Это черевато очень многими глюками, я их победить так до конца и не смог, поэтому см. вариант 2.

вариант 2: Создать внешнее приложение, которое будет вытягивать из WinCC нужные данные (либо наоборот) а дальше уже стандартными средствами. К сторонним приложениям относятся программы написанные на различных языках с доступом через OLE, ODBC и т.д. либо Excell Access - тоже можно.
Re: Отчеты
Николай; 10.12.04

Я сделал по второму варианту: Использовал программу отчетов Crystal Reports, через которую по ODBC связался с архивом WinCC и вытянул оттуда нужные тэги, но как эти внешние программы будут работать в режиме RunTime WinCC.. т.е. вызываться оттуда.

С помощью функции ProgramExecute, но тогда оператору придется изучать дополнительно программу Cr. Reports для работы в ней.Если использовать программирование в Visual C++, то тэги то выцепить можно, но как заставить по ним формировать отчет значений или трендов.... <


text

очень долго обновляются теги
роман; 12.10.04

После перезапуска проекта на сервере первое обращение клиента (multi-client) ко внешнему тегу с помощью ф-ии GetTagxxx происходит очень долго. Затем все работает нормально.

Уважаемые коллеги, кто сталкивался с этой проблемой? Если кто-то смог решить или обойти каким-то образом, просветите
Re: очень долго обновляются теги
Владимир; 13.10.04

Одно из самых больных мест в WIN CC.

Когда идет первый запрос GetTagxxx, сначала идет его регистрация в Tag Manager, и этот процесс идет очень долго. Обычно так бывает когда имя тега формируется в скрипте WIN CC и потом функцией GetTagxxx считывается из контроллера. Обойти это можно несколькими путями : Использовать Tag Prefix на Объектах Picture Window; использовать косвенную адресацию с перезаписью во внутренние теги, или еще можно использовать RAW теги.
В любом случае использование внутри скриптов Си функций чтения внешних тегов недопустимо, поскольку приводит либо к увеличению нагрузки канала тег менеджером или вот к таким "тормозам" при обновлении тегов.
Re: очень долго обновляются теги
роман; 13.10.04

спасибо за совет!

не очень понятно, что вы имеете в виду под косвенной адресацией и перезаписью во внутренние теги? если не сложно, поясните, пжлста.
Re: очень долго обновляются теги
Владимир; 13.10.04

Re: очень долго обновляются теги
роман; 14.10.04

Спасибо за пояснения.

В WinCC Knowledge Base 5.1 предлагается разместить на кадре невидимые объекты и привязать их свойства к нужным тегам через дин. диалог. Тогда при открытии кадра data manager сразу зарегистрирует теги и первое обращение ф-иями Get/SetTag пройдет быстро. Только что обнаружил. Попробую, сообщу, что получилось.
Re: очень долго обновляются теги
Владимир; 14.10.04

Это не совсем удобно, потому как Вы заранее не знаете, какие именно теги будут нужны для отображения ( для этого и был написан скрипт с "вычислением" имени тега).

Забыл упомянуть, эти поля, созданные для перезаписи, делаются невидимыми, их даже можно вытащить за пределы кадра, и все будет работать :-)<


text

Очистка архивов в WinCC_6
Начинающий пользователь; 18.8.04

Подскажите пожалуйста, как в WinCC_6 чистить архивы. Я создал проект в которм веду архив ошибок в AlarmLogging и архив значений в TagLogging. Ивот в процессе отладки проект благодаря этим архивам уже вырос до 500 Мв. Можно конечно сократить частоту запись в архив, но меня интересует, можноли архив полностью обнулить. К сожалению в имеющейся у меня литературе ответ я так и не нашёл

Re: Очистка архивов в WinCC_6
fog; 20.8.04

Я чистил средствами интегрированной базы данных (см. SQL).


text

ошибка Protool
ppp; 28.4.04

Возникла проблема с открытием проекта на панель OP270, появляется ошибка :

Error on converting OID 5==OID_POB_CTDRIVER_MANAGER

Какое происходит только в одном проекте, написаном буржуями в Protool v5.2 SP3

Проекты написаные в Protool v5.1 открываются нормально.
Я открываю Protool v6.0 SP1а

В чем загвоздка и что надо делать для решения проблемы?
Re: ошибка Protool
Роман Абзаев; 29.4.04

Решение проблемы - ProTool v6.0 SP2.


text

Ошибка в трендах
Константин Власкин; 29.7.04


text

ошибка загрузки проекта WINCC
Ирина; 8.9.04

При загрузке проекта WINCC (v6.0 sp2) проект не загружается и выдает ошибку 0 Х 80046127 (null). При предыдущем запуске все было нормально. Подскажите пожалуйста что это за ошибка и как с ней бороться! Спасибо!

Re: ошибка загрузки проекта WINCC
Human; 8.9.04

Сталкивался с такой ошибкой, возникла в ситуации когда почему-то у данного пользователя не было прав доступа к папке проекта. Вылечил просто - добавил в разрешения папки проекта

конкретно данного пользователя (в плюс к SIMATIC HMI). Удачи!<


text

Ошибка с типами :-(
mike; 21.10.04

void ValueChanged(char* lpszPictureName, char* lpszObjectName , VARIANT * Value, VARIANT * PreviousValue, BOOL OutOfRange)

{
char t[20];
float f;
Value->vt = VT_R4;
f = Value->fltVal; //ТУТ ОШИБКА
sprintf(t,"%s",f);
MessageBox(NULL,t,"",MB_OK);
}

Как мне поиметь значение float из variant???
Re: Ошибка с типами :-(
Alexis; 21.10.04

а может VT_R8 и dblVal?

Re: Ошибка с типами :-(
mike; 21.10.04

RE: Alexis

тоже самое:
error 004a: unknown struct/union members
Re: Ошибка с типами :-(
Alexis; 21.10.04

то есть что такое VARIANT она знает, а то что в варианте есть поля FLOAT fltVal и DOUBLE dblVal она не в курсе?

а ты в чем компилишь?
Re: Ошибка с типами :-(
Alexis; 21.10.04

кстати, в хелпаке wincc есть такая штука:

When accessing the value of the VARIANT, a ".u." must be inserted between the name of the VARIANT and the name of the member.

Example:
// Supply Variant
myVariant.vt = VT_I4;
myVariant.u.lVal = 233;

A description of the data type VARIANT can be found in the appropriate technical literature. The VARIANT dmValue needs to be initialized with VariantInit() before the first use and be released again with VariantClear(&dmValue) after use.

Re: Ошибка с типами :-(
Александр Родин, ООО "Нева Электрик"; 21.10.04

-> sprintf(t,"%s",f);

кажися должна быть не %s, а %f или %d, потому как f у вас типа float.
я так думаю, что из-за этого у вас и лезет ошибка.
Re: Ошибка с типами :-(
mike; 22.10.04

re: Александр Родин: это я знаю. но это не актуально.

re: Alexis: в WinCC 6.0

пробовал и float и double и т.п.
дело в том что первая трочка (где тип указывается) нормально, а вот когда к значию обащаешся - error

может WinCC криво стоит... ХЗ карчое :-(
Re: Ошибка с типами :-(
Alexis; 22.10.04

Что-то ты где-то темнишь...

Вот, попробовал такой скриптик, компилится и работает нормально:

void vtFunction(float fltValue)
{
VARIANT vt;
VARIANT *pvt = &vt;
vt.vt = VT_R4;
vt.u.fltVal = fltValue;
printf("%f\r\n", vt.u.fltVal );
pvt->u.fltVal += fltValue;
printf("%f\r\n", pvt->u.fltVal );
(*pvt).u.fltVal += fltValue;
printf("%f\r\n", (*pvt).u.fltVal );
}
Re: Ошибка с типами :-(
mike; 22.10.04

#include "apdefap.h"

void ValueChanged(char* lpszPictureName, char* lpszObjectName , VARIANT * Value, VARIANT * PreviousValue, BOOL OutOfRange)
{
Value->vt = VT_R4;
Value->fltVal = 12.7;
}

Тоже самое... ошибка на строчке Value->fltVal = 12.7;
Наверное WinCC стоит криво :-/
Re: Ошибка с типами :-(
Alexis; 22.10.04

mike, ты бы мой пример то посмотрел повнимательнее... :))

напиши так:
Value->u.fltVal=12.7;

или так:
(*Value).u.fltVal=12.7;

Re: Ошибка с типами :-(
mike; 22.10.04

Вау! заработало :-)

спасибо!!!

а где можно посматреть про структуру VARIANT и как ей пользоваться?
Re: Ошибка с типами :-(
mike; 22.10.04

Просто в обычном С++ пишется же просто

Value->vt = VT_R4;
Value->fltVal = 12.7;
а не
Value->vt = VT_R4;
Value->u.fltVal = 12.7;

Re: Ошибка с типами :-(
Alexis; 22.10.04

Дык это ж в обычном с/с++ :))

А описание VARIANT и функций работы с ним смотри в MSDN или в каком-нибудь "учебнике" по виндозе.<


text

Панели для WinCC 6
Малкон; 9.11.04

Вообще вопрос некорректный, однако, как мне подобрать панели, если у меня WinCC6 ?

Насколько я понял визуализация на панелях происходит посредством WinCC Client, а не ProTool. Дак вот апанели все заточены на protool (Win CE, пойдет ли на Win CE , WinCC Client ?)
Re: Панели для WinCC 6
Лев Шерешевский; 9.11.04

WinCC 6 на панелях работать не будет. Для панелей Вам надо использовать WinCC flexible или ProTool. Если очень хочется использовать WinCC, поставьте Panel PC. Еще можно попробовать использовать WebNavigator.

А вообще, прежде чем что-либо приобретать, Вам лучше проконсультироваться со специалистами.
См. Центр компетенции WinCC

Re: Панели для WinCC 6
Павел Кобелев; 10.11.04

Возможно вы имели в виду Panel PC? Например, SIMATIC Panel PC IL70 или SIMATIC Panel PC 670/870. Они могут поставляться с WinCC Runtime.

Re: Панели для WinCC 6
Чистяков Дмитрий ОАО СеверСталь; 10.11.04

Да, тут пожалуй Малкон, должен уточнить, что он имел в виду под панелями.

А вообще, как-то много вопросов он задаёт. Может Вам стоит обратится к каким либо специалистам, ранее занимавшимися построением систем. Это дало бы более быстрое решение вопросов, да и количество проблем потом было бы меньше. :-)
Re: Панели для WinCC 6
Малкон; 10.11.04

Панели выбрали PC 670. Вы даже не представляете сколько приходиться налаживать связей. Консультации идут с официальными представительствами и такими крупными канторами как ProSoft, но на некоторые вопросы не могут ответить никто. Один из вопросов: как вставить в ячейку таблицы - выпадающий список.

Re: Панели для WinCC 6
GorA; 10.11.04

Самый простой и быстрый способ - это сделать другое малеьнкое окно, в котором запехнуть текстовые тэги требуемой (введенной)информации. Данному маленькому окну определить свойство Display=no. В текстовом поле главного окна определить изменение свойства маленького окна Display on/off.


text

Панель оператора МР270
Михаил; 8.7.03

Здравствуйте,уважаемые коллеги.

Я намереваюсь сделать BackUp программы
панели оператора МР270 с помощью
оболочки ProSave V6.0.Как я предполагаю
для зтого еще надо перевести панель в
режим Transfer.
Необходимо ли переводить панель в режим Transfer при BackUp-e?
Как перевести панель в режим Transfer и не испортить программу?
Заранее благодарен.
Михаил.
Re: Панель оператора МР270
Костя; 15.9.04

Когда узнаешь - поведаешь?!


text

Пароль в WinCC
Богдан; 24.5.04

Есть проект на WinCC, который пришел с б/у-установкой.

В нем для выхода из системы, печати, конфигурированя графиков и т.д.
небходимо ввести пользователя и пароль.

Заказчик логинов не знает, немецкая фирма которая делала установку уже не существует.

Как их узнать ?
Или как их изменить ?
Или как их уничтожыть и ввести новые ?
Re: Пароль в WinCC
Л. Шерешевский; 24.5.04

Проще всего в User Administration создать новых пользователей по образу и подобию существующих, и дать им новые пароли. Сложностей с этим никаких нет.


text

Пароль для OP7
Алексей; 2.2.04

Утерян пароль для OP7PP, панель работает в режиме Online. Как его можно восстановить (пароль 100 не подходит)? Сохранность проекта в памяти OP не критична, нужно просто иметь возможность перепрограммировать панель.

Re: Пароль для OP7
DRON; 4.2.04

Выключаешь питаник. Нажимаешь однлвременно кнопки "вверх" и "Esc". Удерживаешь их, и в таком состояние подаешь питание. Секунд через 5 отпускай кнопки. ОР после этого находиться в режиме Ready for Transfer. Т.е. можете в нее грузить что угодно. если грузить ничего не хотите, нажмите "Esc". Проект в ОР сохранится.

Re: Пароль для OP7
Алексей; 4.2.04

Спасибо. Попробую. А если не секрет, откуда такая информация?

Re: Пароль для OP7
DRON; 5.2.04

Читайте мат. часть!:)


text

Первод времени на S7 300 ?
Zolotoy; 1.4.04

Сушествует ли проблема в связке WinCC + S7 300 по MPI при переводе стрелок с зимнего времени на летнее ?

Компьютер то пререшёл на 1 час вперёд, а вот в контроллере надо время то менять или нет, (глюки с трендами)

заранее благодарен ...
Re: Первод времени на S7 300 ?
Макс Прилепский; 1.4.04

Не знаю, как в версии 6, а WinCC 5.х сама штампует архивируемые мгновенные значения локальным временем станции, и в таблицах Tag Logging (тренды) записи, если был перевод часов, помечаются флагом "Time Jump" и на тренде отображаются "своеобразно" :) Так что это не баг , а фича , и время PLC тут не причём, если, конечно, Вы не используете AR_SEND, где время штампует сам PLC.

Re: Первод времени на S7 300 ?
Zolotoy; 1.4.04

спасибо за ответ :), "своеобразно" не то слово ;) тренды были горизонтальные, ступенчатые, интервал в линейке где-то 5см = 2 часам... а с переводом времени стали вертикальные!:)

обрывистые!:) и интервал возрос до часов 10 в тех же 5 см.
так же глюк наблюдался в таблице отчёта...(по 31.03 данных небыло, ставишь 01.04 данные есть :))
сечас всё стало ОК, вроде как прошла синхронизация времени (почему-то она длилась около суток, или более)

а AR_SEND енто что такое ?
флаги "Time Jump" я на трендах невидел
Re: Первод времени на S7 300 ?
Макс Прилепский; 1.4.04

Time Jump это флаг, хранящийся вместе с другими флагами в таблицах Tag Logging в поле F. Для каждого графика можно задать цвет состояния Time Jump в закладке Limit Values компонента WinCC Online Trend Control (который и отображает тренды). Тогда графики, имеющие флаг Time Jump в поле F таблиц со значениями в RT-базе WinCC(в этом поле может быть значение, содержащее несколько флагов)при отображении на экране будут отображаться этим самым цветом, и пользователь системы может по цвету определить, что графики за определенный промежуток времени не несут достоверной информации.

Что касается AR_SEND - то это функциональный блок S7, позволяющий передавать в WinCC архив измеренных значений с контроллера. Например, в случае, если надо раз в час измерять какой-то параметр в течении трёх секунд с частотой 20мс, какую подсистема Tag Logging WinCC обеспечить не может, то применяется AR_SEND, который формирует телеграмму, содержащую штамп времени первого измеренного значения, шаг измерения, и массив значений. После получения телеграммы, WinCC записывает полученные значения в свою Runtime БД.
Re: Первод времени на S7 300 ?
Макс Прилепский; 1.4.04

Time Jump это флаг, хранящийся вместе с другими флагами в таблицах Tag Logging в поле F. Для каждого графика можно задать цвет состояния Time Jump в закладке Limit Values компонента WinCC Online Trend Control (который и отображает тренды). Тогда графики, имеющие флаг Time Jump в поле F таблиц со значениями в RT-базе WinCC(в этом поле может быть значение, содержащее несколько флагов)при отображении на экране будут отображаться этим самым цветом, и пользователь системы может по цвету определить, что графики за определенный промежуток времени не несут достоверной информации.

Что касается AR_SEND - то это функциональный блок S7, позволяющий передавать в WinCC архив измеренных значений с контроллера. Например, в случае, если надо раз в час измерять какой-то параметр в течении трёх секунд с частотой 20мс, какую подсистема Tag Logging WinCC обеспечить не может, то применяется AR_SEND, который формирует телеграмму, содержащую штамп времени первого измеренного значения, шаг измерения, и массив значений. После получения телеграммы, WinCC записывает полученные значения в свою Runtime БД.
Re: Первод времени на S7 300 ?
Zolotoy; 1.4.04

По Time Jump - да они рисуются разными цветами, нашёл вкладку Limit values(properties of WinCC Online Trend Control) - там нет поля F

Re: Первод времени на S7 300 ?
Александр Родин, ООО "Нева Электрик"; 1.4.04

Поля F нет ни в редакторе Trend Control ни в Tag Logginge. Это поле есть в самой RT Базе в таблицах сохраненных трендов. Его можно посмотреть например с помощью утилиты SCVIEW.

Re: Первод времени на S7 300 ?
Zolotoy; 2.4.04

...properties of WinCC Online Trend Control далее Limit values - ни одной установленной галочки (в Check Box),

а разрывы, например после перезагрузки компьютера с WinCC помечаются вроде как серым цветом (сначала ступенчатый график - потом прямая, равная времени перезагрузки компьютера и опять идёт обновление тренда ступеньками)как енто возможно если галочка в Time Jump неустановлена ?<


text

Передача S7-"Error Mess" в WinCC
Дмитрий; 31.5.04

Имеется интегрированный проект:

Step7 v5.2, ProtoolPro v6, WinCC v6.
После конфигурирования и компеляции дигностических сообщений в Step7 формируются соообщения в Protool и WinCC. Но если с Protool-ом почти "нормально", то в WinCC от сообщений остаётся только "Help(Info) text", все "Message text"=RSE_DB. Вопрос. Как нормально стелать передачу "Message text", и в чём собственно косяк.<


text

Перенос авторизаций по сети
Human; 8.9.04

Есть ноутбук без FDD, нужно перенести на него авторизацию на STEP7 v5.3, хочу сделать это по локалке, создал одинаковых пользователей, открыл доступ к диску, в проводнике захожу на него нормально, пытаюсь перенести авторизацию и ALM говорит "Access denied". В чёи может быть дело? И вообще кто-нить переносил авторизацию по сети посредством ALM?

Благодарю за ответы!
Re: Перенос авторизаций по сети
GorA; 8.9.04

Нужно работать с правами администратора на обоих компах. И подключить сетевой диск на который(с которого) хочется перенести авторизацию

Re: Перенос авторизаций по сети
Human; 9.9.04

to GorA

Спасибо за подсказку, всё получилось. Правда я диск подключать не стал, сделал пользователей админами и убрал в ALM галочку "Protect local license keys" и всё пучком.<


text

Перенос проекта Wincc
Виктор; 29.8.04

Здравствуйте, подскажите пожалуйста, как грамотно перенести проект WinCC на другой компьютер? На исходном стоит ProTool, в проекте использована его библиотека картинок разных обьектов. При переносе папки с проектом и смене имени компьютера эти изображения не показываются. Может есть какая-то компиляция проекта?

Re: Перенос проекта Wincc
Маслов Дмитрий; 29.8.04

Я не понял насчет использования библиотеки Protool - имеется в виду Simatic HMI Symbol Library, или что-то другое?

Если идет речь о Simatic HMI Symbol Library, то это не библиотека Protool, а общая библиотека WinCC/Protool. В этом случае на компьютере, куда переносится проект, она должна быть установлена (выбирается при установке WinCC).

При переносе проекта на другой компьютер никаких действий, кроме смены имени компьютера в проекте, делать не нужно. Главное, чтобы были установлены все опции WinCC, используемые в проекте, и лицензии на них.

См. http://www.wincc.ru

Re: Перенос проекта Wincc
Виктор; 29.8.04

Спасибо, Дмитрий. Да, речь идет об этой библиотеке (в значке символ воздушного компрессора). Попробую, может в самом деле что-то не установил, может и совпадение такое просто.

Re: Перенос проекта Wincc
Юрченко Владимир; 30.8.04

Дело в том, что у ProTool версия этой библиотеки выше, чем у WinCC. Отсюда и проблемы.


text

перенос проекта с PCS7
Vertal; 28.1.04

Есть машина с установленным пакетом PCS7 6.0. Необходимо создать

проект для станции на которой не установлен PCS7, а установлен только
WinCC. Возникнут ли проблемы при запуске проекта на машине без PCS7?
Кто имеет опыт поделитесь соображениями. Достаточно ли просто не
использовать PCS7 компоненты, возможны ли специальные настройки?
Re: перенос проекта с PCS7
Маслов Дмитрий; 29.1.04

Проблем возникнуть не должно, если на машине с WinCC установлены все WinCC-опции, которые Вы использовали при разработке Вашего проекта PCS7:

Basic Process Control,
SFC-Visualization (если используется) и др.

Что Вы подразумевали под фразой "Достаточно ли просто не использовать PCS7 компоненты?"
Re: перенос проекта с PCS7
Vertal; 29.1.04

>Что Вы подразумевали под фразой "Достаточно ли просто не использовать PCS7 компоненты?"

Например не пользоваться CFC, SFC. Не пишется ли куда-нибудь информация о том, что проект разрабатывался на машине с PCS7, даже если никакие компоненты кроме "чистых" Step7 и WinCC не использовались.
Re: перенос проекта с PCS7
Маслов Дмитрий; 29.1.04

Re: перенос проекта с PCS7
Михайлин Сергей; 29.1.04

Вношу полную ясность. При прочих равных условиях, т.е. не используются дополнительные опции PCS7 со своими лицензиями, то 100% соответствия все равно нет. Дело вот в чем, в состав софта PCS7 OS штатно входит лицензия на Advance Procces Control, которую вы не сможете приобрести отдельно. Посему если в проекте используются функции этой опции то просто на WinCC вы будете иметь сообщение об отсутсвии авторизации и демо режим. Кроме того если посчитать WinCCRT64K и PCS7 OS Single station на 64К имеют ОДИНАКОВУЮ ЦЕНУ. И в PCS7 еще входять лицензии BCE и Advance Procces Control. Так что проще и выгоднее купить PCS7, если уж изначально проект был в нем.

Re: перенос проекта с PCS7
Vertal; 29.1.04

Всем спасибо за ответы!

А вопрос появился из-за того, что на одной и той же машине разрабатывается несколько проектов (с использованием PCS7 и без оного) и не хотелось каждый раз сносить всё и ставить с нуля. А еще может что доделывать потом потребуется...<


text

Перенос списка тегов WinCC в другой проект
Роман; 21.4.04

В старый проект решил интегрировать новый, сделал несколько окон обявязал их, а еще создал пару сотен внешних тегов по MPI, и вдруг возникает необходиость на другой машине создать новый проект, с новым именем, а вот каким образом перенести эту "кучу" тегов не представляю. Не хочеться заново набивать имена и самое главное адресацию. Кто знает как победить проблему?

Re: Перенос списка тегов WinCC в другой проект
Human; 22.4.04

Элементарно, Ватсон! Выделяете нужные переменные, делаете COPY, открываете другой проект - делаете PASTE и всё!

Re: Перенос списка тегов WinCC в другой проект
Роман; 22.4.04

Спасибо за ответ, уже сам "догнал" :), так и бывает самое простое нужно сделать и тут, что то глючит в голове:))


text

Переход на WinCC 6.0
Василий Д; 15.1.04

Коллеги, поделитесь пожалуйста своим мнением по поводу:"ОБОСНОВАН ЛИ ПЕРЕХОД НА 6-Ю ВЕРСИЮ?".В наличие 1-н сервер, 8-м станций, 10-ть клиентов и система сейчас в целом динамично развивается,выходя на диспетчерский уровень предприятия.

Re: Переход на WinCC 6.0
Eugene; 15.1.04

Мнение 1. Недавно разарабатываемый в версии 5.1 проект "мигрировал" (такой вот термин Сименс предлагает) под версию 6.0. Сразу перестал работать скрипт, меняющий свойство "имя экрана" компонента PictureWindow в зависимости от выбранного режима (изменяется переменная, по ее изменению и работает скрипт). Под 5.1 все работало замечательно. Скрипт заканчивается return retVal; (retVal объявлен как char retVal[30]). Перед этим retVal выводится с помощью printf на консоль. И вот что получается: скрипт возвращает абсолютно корректное имя экрана, но до свойства объекта эта строка доходит с добавленными "левыми" символами и, естественно, PictureWindow ничего не отображает. Пришлось писать глобальный скрипт, передающий значение свойству через SetPropChar. Пока не нашел, что же еще работает некорректно, но осадок на душе остался. Я то ведь следовал рекомендациям Сименса возвращать значение свойств через return, а не устанавливать их с помощью SetPropChar (что должно быть медленнее).

Мнение 2. Основное отличие версий 5.х и 6.0 - переход с Sybase SQL AnyWhere на MicroSoft SQL Server. Все базы данных вроде бы должны быть сконвертированы корректно, но кто его знает :-)

Замечание по "миграции": При переходе на версию 6.0 не надо "убивать" Sybase SQL AnyWhere, он пригодится для "миграции".
Re: Переход на WinCC 6.0
Human; 16.1.04

Если есть свободное время, лишние деньги и нервы, то наверное стоит перейти на WinCC v6. Объясню что зачем нужно: 1)ВРЕМЯ - чтобы преобразовать существующий проект(ы) под новую версию, (имеется ввиду не просто запуск ProjectMigrator, а неизбежные исправления в системах архивирования, протоколирования, запросов данных из сторонних приложений и т.д. потом обкатать всё это; попутно придётся (если АСУ более менее серьёзная) изучить новшества WinCC v6, Microsoft SQL Server, систему SQL запросов и может быть XML.

2)ДЕНЬГИ - для покупки нового софта Siemens (авторизации), для модернизации компьютерного парка, для выплаты зарплаты людям, которые всем этим будут зниматься.
3)НЕРВЫ - понадобятся при реализации всего выше перечисленного :).
Что в итоге поимеете: проекты на более современном софте; новые возможности организации обмена данными (SQL); более быстрое архивирование данных; дополнительные возможности по использованию WEB Navigatora 6.0; и ещё куча мелочей, иногда полезных, иногда не очень :).
P.S. Это моё личное мнение, полученное в процессе переделки проекта из 5.1 в 6.0 и создании пары проектов непосредственно в v6.0.<


text

Переходна зимнее время, синхронизация контроллеров и РС
Viktor; 1.11.04

Есть два контроллера и две компьютера. Все обединено по профибас. Компьютеры по времени синхронизируются нормально.

А вот как проверить синхронизируются ли контроллеры (скорее всего если и синхронизируются, то только между собой). Хотябы направьте в нужное русло. Контроллеры S400, на них "крутится" Teleperm M.

Спасибо.
Re: Переходна зимнее время, синхронизация контроллеров и РС
Viktor; 1.11.04

всем спасибо проблема решена


text

Перечеркнутое время
Mlr; 15.9.04

в alarm logging

что значит?
Еще вопросик :)
Mlr; 15.9.04

В alarm control'е вроде как-то можно было принудительно задать ширину колонки. Не могу найти как...

Re: Перечеркнутое время
Маслов Дмитрий; 15.9.04

Если сообщения передаются из контроллера (через Raw Data Tag), и сообщения возникли до запуска проекта WinCC, то после запуска проекта они появляются с перечеркнутым временем.

Ширина колонок регулируется заданием ширины соответствующего текстового или системного блока сообщений (количество символов) в Alarm Lagging.
См. http://www.wincc.ru


text

Печать Alarm Loggina
Владимир; 27.10.04

Как можно задать на печать только те сообщения ,которые отфильтрованы по времени.Используется print job. В нем конечно есть выбор по времени ,но как передать в него время начала и конца печати ?

Re: Печать Alarm Loggina
Андрей; 27.10.04

В Alarm Loggin RT.Archive Report есть

Filter criteria for alarm output, где можно задать - Variable (Text tag).
По кнопке пишем след. код для печати:

...
sprintf(SQLcmd,"DATETIME >='%04d-%02d-%02d %02d:%02d:00.000000' AND DATETIME <= '%04d-%02d-%02d %02d:%02d:00.000000'", year_b, month_b, day_b, hour_b, minute_b, year_e, month_e, day_e, hour_e, minute_e);

SetTagChar("MsgFilterSQL", SQLcmd);

RPTJobPreview("Alarms");
Re: Печать Alarm Loggina
Прокопенко Вера; 29.10.04

Андрей, я не поняла: "В Alarm Loggin RT.Archive Report есть Filter criteria for alarm output, где можно задать - Variable (Text tag)" -это где? Просмотрела все Help и ODK функции и не нашла. Как все же динамически можно задавать диапазон времени для вывода архива на печать (или просмотр)? Пожалуйста, объясните подробнее. Как можно менять свойства print job и можно ли?

Re: Печать Alarm Loggina
Андрей; 29.10.04

Тут возникают проблемы с версиями WinCC. Предлагаю указывать изначально, какая версия стоит. Я пользуюсь WinCC 6.0.

А насчет вопроса: вызываите свойства "Alarm Loggin RT.Archive Report" (правый щелчек мыши) на закладке Connect открываите Selection, открывается окно "Alarm Loggin Runtime: Report - Table Column Selection" и в этом окне внизу эта Variable и есть.
Re: Печать Alarm Loggina
Прокопенко Вера; 29.10.04

У нас WinCC v5.1, поэтому я даже не знаю, что это за объект "Alarm Loggin RT.Archive Report". В ODK нашла функции чтения и установки свойств print job, но пока еще не добилась их работы без ошибок.

Re: Печать Alarm Loggina
Андрей; 29.10.04

По WinCC 5.1 ничего сказать не могу


text

печать в WinCC
Александр; 23.4.04

Re: печать в WinCC
Маслов Дмитрий; 23.4.04

Ну если получилось от кнопки, то скопируйте тот скрипт, с которым получилось, в новый C-Action в Global Scripts. Там задайте триггер - либо по времени (например, каждый день в 12-00), либо по тегу. И не забудьте включить запуск Global Scripts в свойствах компьютера. В общем, RTFM.

печать в WinCC
Александр; 26.4.04

Ну не силен я в этих скриптах, ну хоть кто -нибудь сжалится надо мной и даст скриптик, пример:

Если бит в 1, то печатать то чего надо,
любой пример, я по готовому сам постараюсь допетрить куда чего вставить... :-)<


text

Печать журнала сообщений в WinCC 6
Коростелёв; 19.7.04

Печатаю журнал сообщений (алармов) стандартным способом, по кнопке печать в AlarmControl (используется @ССTableControlContents). Некоторые столбцы на распечатке получается слишком узкие, из-за чего невозможно определить например время и дату возникновения сообщения, имя пользователя, статус сообщения, да и само сообщение получается обрезанным. Настройки шрифтов не помогают.

Кто-нибудь сталкивался с этим? Какие есть пути борьбы с этим недостатком?
Re: Печать журнала сообщений в WinCC 6
Svetozar Yolov; 23.7.04

Hi,

Please open the layout in Report designer. Select CSV-Provider.Table. right click and select properties. Then go to Geometry and double click Columns. In the menu you can add columns and change the width.
Also you can use Alarm Logging RT controls (in Report Designer) Runtime documntation tab. Here is the same as CSV-Provider.Table but the width of columns is relative!

Best regards,
smi <


text

Печать из OP77
Scout; 18.11.04

Возможна ли печать из ОР77 через RS232?

Ни в самой панели, ни в WinCCfleible
я не нашел настроек RS - са(скорость, кол - во бит данных и тд).
Пробовал печатать и через USB, панель выдает следующее: "I can't identify the printer language".
Кто печатал из этой панели, подскажите в чем дело.
Re: Печать из OP77
Юрченко Владимир; 18.11.04

Печать в OP77В возможна только через USB и поддерживаются не все принтеры. Список протестированных принтеров можно найти на:

См. http://www4.ad.siemens.de/WW/view/en/11376409

Re: Печать из OP77
Scout; 18.11.04

Владимир я вижу вы хорошо осведомлены.

Хочу еще вас спросить. Можно ли через
usb порт ОР77 принимать данные, скажем от сканера штрих - кода?
Cпасибо за помощь.

Re: Печать из OP77
Юрченко Владимир; 18.11.04

Смотрите по этому поводу:

См. http://www4.ad.siemens.de/WW/view/en/19188460

Re: Печать из OP77. Первые опыты и неясности...
Scout; 18.11.04

Cпасибо вам Владимир за ссылочки.

Может вы знаете, почему невозможна печать по RS-су? В документации на пенель не сказано, что можно печатать по RS - cу, но так же не сказано, что нельзя.

На USB прицепил сканер штрих - кода, вроде работает, правда пришлось вешать внешнее питание. Насколько я понял, панель "выплевывает" данные от сканера штрих - кода в любое доступное поле ввода активного в данный момент экрана, вот только не пойму как привязать сканер к конкретному полю ввода на конкретном экране панели. Тоесть чтоб считанный штрих - код отображался только на одном, нужном мне экране, и не отображался на других экранах, содержащих поля ввода, активных в данный момент. Может вы что сможете сказать....?<


text

Печать отчетов и отлогинивание в заданное время
Guest; 9.1.04

Уважаемые!

Как лучше реализовать автоматический вывод на печать отчетов и отлогинивание в заданное время? Есть ли для этого стандартные средства или нужно писать скрипт?
Re: Печать отчетов и отлогинивание в заданное время
Александр Родин, ООО "Нева Электрик"; 12.1.04

А про что собственно речь ?

Если про WinCC, то стандартные средства есть, но, по-моему, ими никто не пользуется, по крайней мере что касается репорта графиков.
Настраиваются стандартные средства в редакторе ReportDesigner\PrintJobs.

Лучше все-таки использовать API. Как, читайте хелпы к ODK.<


text

Печать отчетов из VBS WinCC 6.0
Nick Gashevsky; 3.3.04

Как вывести на печать отчет из Report Designer. На С есь RPTJobPrint(), а на Бейсике?

Re: Печать отчетов из VBS WinCC 6.0
Юрченко Владимир; 5.3.04

В текущей версии WinCC нет объектов для работы с отчетами. Если очень надо запускать отчеты из VBS, сделать это можно косвенно изменив переменную - тригер, а связанный С-скрипт уже вызовет RPTJobPrint().

Re: Печать отчетов из VBS WinCC 6.0
Nick Gashevsky; 11.3.04

Так и делаю. Изменяю несущественное св-во обьекта, а по его изменению вызываю печать. (Лень переписывать код из VBS в С). Но как-то криво через пень...

Re: Печать отчетов из VBS WinCC 6.0
ALEX; 21.6.04

Имею проблему с графиком. Иногда пропадает связь C базой данних. При параметрах графика "Load archive data" и сохранение на HDD-сначала все Ok! но сейчас график мигает постоянно с сообщением "No connection to data server". В остальних проекта при тех же параметрах Tag Logginga все нормально. Что может бить??? Братва подскажите...


text

Печать отчетов
Алексей; 12.11.04

Как в Runtime,например,в окне печати отчетов можно вытянуть конкретный параметр(тэг) и распечатать его тренд или таблицу за определенное время?

Спасибо...<


text

Печать содержимого User Archive
Владимир; 22.1.04

Собственно, сабж.

Одна особенность - установлен фильтр, и распечатать нужно именно отфильтрованные сообщения. Стандартных функций, как на Alarm Logging , я не нашел :-(
Re: Печать содержимого User Archive
Маслов Дмитрий; 26.1.04

Косвенный спосб решить Вашу проблему - это распечатать копию части экрана. Т.е. надо распечатать ту часть экрана, которая содержит окно User Archive с отфильтрованными строками.

Делается это так:

#pragma code ("prtscrn.dll")
#include "prtscrn.h"
#pragma code()

PrtScreenPart(Left,Top,Width,Height);

Здесь Left,Top,Width,Height - координаты и размеры части экрана для печати.

Re: Печать содержимого User Archive
Human; 26.1.04

Я решаю эту задачу следующим образом: по нажатию на кнопку "Печать" производиться фильтрация данных из исходной таблицы, затем отфильтрованные данные заносятся в другую таблицу, а уже она распечатывается. Просто и быстро, рекоммендую!

Re: Печать содержимого User Archive
Владимир; 26.1.04

Спасибо, однако...

Печать содержимого экрана намного не то решение...
нужна печать по стандарту, с заголовками, колонтитулами и пр.
Поподробней бы, как можно привязаться к Report Designer и распечатать все что нужно? Количество строк больше, чем вмещается на одном листе.
Все советы приветствуется.
Re: Печать содержимого User Archive
Владимир; 26.1.04

Сорри за ошибки, тороплюсь на совещание :-)

Re: Печать содержимого User Archive
Human; 27.1.04

В продолжение моего предыдущего поста:

полученную после фильтрации таблицу печатаю естественно посредством Report Designer, там просто вставляешь нужный элемент и привязываешь его к таблице из UA, и все дела, он будет печатать столько страниц, на сколько разместиться таблица. Там будет всё путём, заголовки, колонтитулы и др.
Re: Печать содержимого User Archive
Владимир; 28.1.04

Спасибо !


text

Печать трендов в WinCC 6.0
Константин Власкин; 11.3.04

Подскажите в шестой версии всё так же плохо как и в пятой, или, наконец, ситуация с печатью трендов изменилась?

Re: Печать трендов в WinCC 6.0
Human; 12.3.04

Практически ничего не изменилось, всё тот же элемент, добавили только возможность отправки на печать указанного PrintJob, да ещё можно выбрать Time base (project, server, local).

Re: Печать трендов в WinCC 6.0
mlr; 15.7.04

А как вы печатаете тренды? Что-то я не смог настроить не шрифт, не кол-во знаков после запятой на осях. График совсем нечитаемый вид имеет...

Re: Печать трендов в WinCC 6.0
Nick Gashevsky; 19.7.04

В ВинСС Никак, использую внешнюю программу.

Re: Печать трендов в WinCC 6.0
Коростелёв; 19.7.04

Я печатаю так:

Layers(15).Visible = vbTrue
Dim objWshShell
Set objWshShell = CreateObject("Wscript.Shell")
objWshShell.Run "PrtScr.exe -C= 0;50;1280;800 -l", 1, True
Layers(15).Visible = vbFalse
Set objWshShell = Nothing

Просто вывожу на печать область экрана, на которой расположен объект с трендом. Для этого есть специальная программулька в WinCC - PrtScr.exe. Предварительно убираю все элементы экрана, которые не нужны на печати (Заслоняю их белым прямоугольником, находящимся в 15-ом слое, который по умолчанию невидим). Качество получается не идеальное, но при разрешении 1280х1024 вполне допустимое.
Re: Печать трендов в WinCC 6.0
mlr; 26.7.04

Простите за дурацкий вопрос, но куда это прикручивать? К кнопке какой-нибудь или куда?

Re: Печать трендов в WinCC 6.0
Коростелёв; 26.7.04

Да, создаёте свою кнопку, и в ней пишите этот скрипт. Цифры 0,50, 1280, 800 означают координаты распечатываемого прямоугольника на экране (в пикселях). Если что не понятно - пишите на мыло.


text

По моему это баг...
DEE; 27.7.04

Hi!

Не знаю, поднимался ли этот вопрос на форуме, но хочу спросить, может кто сталкивался с проблемой. При установке WinCC v5.1 изменил путь установки, который предлагался (отказался от С:\Siemens\WinCC, а прописал свой С:\Program Files\Siemens\WinCC - ну у меня там всё остальное от сименса стоит и степ и протул и др.), при этом дальнейшая установка WinCC зависает на моменте - пишется что ищется компонент для установки S7 Base, и всё процесс замирает навечно. При повторной установке согласился с предложенным путём установки и всё замечательно встало! Только, правда, всё ПО по сименсу у меня теперь в програм файлс, а винсс в гордом одиночестве в корне на С:. Ну так что - это баг от сименса или у меня руки кривые?
P.S. Ранее неоднократно ставил более ранние версии винсс - таких проблем не припомню...
Re: По моему это баг...
Евгений Трунов; 27.7.04

Как раз раньше такие проблемы и были :-). Я года четыре назад долго продолбался с неработающей WinCC 5.0, установив ее в папку Program Files. Не хотела работать, и всё. Вылечилось установкой в папку без пробелов. Только в последних версиях продукты SIMATIC (NET, WinCC 6.0) стали нормально ставиться в папку Program Files, раньше - напрямую в C:\SIEMENS.


text

Подвисают фэйсплейты
Diana; 9.4.04

Наметился глюк на 5.2 версии PCS - если открыть в Runtime более одного фэйсплейта, то через раз это Runtime либо просто подвисает (на три кнопки не пошлешь), либо деактивируется. Все самое стандартное, вызовы фэйсплейтов тоже самые стандартные. Проект нормально тестировался с этим оборудованием и на этом же компьютере. Потом пролежал месяц дожидаясь объекта и тихо сдох. Вот это вообще лечится, или просто Сименс - маздай?...

Re: Подвисают фэйсплейты
Николай; 13.4.04

Что-то подобное наблюдал. При запуске Runtime полностью завешивал машину. Причину подвисания не нашли, т.к. на другом компьютере с "чистой" Windows проект заработал нормально. Попробуйте переустановить систему.

Re: Подвисают фэйсплейты
Diana; 13.4.04

К сожалению приходится принимать подобные меры. Однако, я считаю, что это не должно быть панацеей. У этих Сименсов, похоже, какой-то свой механизм многооконности, а следовательно, они могут ошибочно использовать виндусячью функции. Может из-за этого?


text

Подвязка тегов
Игорь; 7.6.04

Господа,подскажите, как можно динамически(в скрипте) подвязать тег WinCC к объекту -I/O Field;

Properties - Output/Input,Attribute - Output Value?

Re: Подвязка тегов
Игорь; 7.6.04

Спасибо, уже разобрался


text

Поделитесь DCOM98 & XP
А. Ковальчук; 13.11.04

Нигде не могу найти....

Скачал один архивчик, там две папки - вроде как 95-й и 98-й...
А на самом деле - два одинаковых набора...<


text

Подключение к БД WinCC6
Макс Прилепский; 24.8.04

Помнится, в WinCC5 в БД был интегрированный пользователь dba с известным паролем, с правами которого можно было подключаться к БД из других приложений. В случае с WinCC 6 помимо пользователей группы "Администраторы" операционной системы в БД есть интегрированные пользователи WinCСAdmin и WinCCConnect. Если кто-то знает пароли этих пользователей, то буду очень признателен сообщившему.

Re: Подключение к БД WinCC6
Conmbinator; 3.9.04

База все равно закодированная


text

Подключение к очереди сообщений окна
Макс Прилепский, ОАО ; 2.2.04

Кто-нибудь пробовал получать сообщения из очереди сообщений окна WinCC-Runtime c помощью WIN API, используя actions WinCC, например, регистрируя свою callback - функцию, которая будет вызываться при появлении в очереди нового сообщения?

Re: Макс Прилепский, ОАО
Маслов Дмитрий; 3.2.04

Я думаю, из скрипта WinCC сделать callback-функцию WinAPI точно не получится. Хотя бы потому, что скрипты WinCC даже не компилируются в исполняемый код (они компилируются в P-код, который интерпретируется системой исполнения WinCC).

А для чего такие ухищрения? Что Вы хотите сделать в конечном итоге?
Re: Маслов Дмитрий; 3.2.04
Макс Прилепский, ОАО "ЗСМК"; 3.2.04

Адреса callback-функций WinCC без проблем передаются из скрипта API- функциям и вызов этих функций из API происходит без проблем, если функции объявлены в соответствующем вызываемой функции API контексте, ну и директива #pragma pack (4) используется при работе со структурами, т.к. структуры в WinCC по умолчанию выравниваются по границе байта, а в API по границе DWORD. А из очереди сообщений окна я хотел получать, например, сообщения о координатах курсора "мыши" и т.п. Хотя и WINAPI GetCursorPos работает, но циклически не хочется эту функцию использовать.


text

Подключение к панели МР370
Елена; 22.9.04

Пожалуйста вышлите информацию на русском языке о подключении панели оператора МР370 к контроллеру Modicon

Re: Подключение к панели МР370
Назаров Дмитрий; 23.9.04

Документацию по панели можно скачать здесь.

См. Панели SIMATIC

Re: Подключение к панели МР370
Pahan; 24.9.04

Более конкретный вопрос. Где взять описание работы панели MP370 по протоколу ModBus. И вообще в каком режиме работает в данном случае панель Master или Slave. Описание регистров, исключений и т.п.


text

подскажите как передать данные
micha; 14.12.04

нужно передать данные с машины WinCC через SQL другой машине вернее

как подключить sybase SQL server к Б.Д. wincc
Re: подскажите как передать данные
Маслов Дмитрий; 14.12.04

Чтобы получить доступ к БД с архивами WinCC 6.0 используется WinCC OLE DB Provider. Пример его использования есть на данном сайте в разделе с документацией.


text

Подскажите по панелям оператора
DEE; 26.11.04

Hi!

Народ, подскажите что делать. На ОР37/27 по истечении некоторого времени бледнеет экран, изображение на них становится не яркое. Если отключить/включить питание то становится всё ОК, а потом через некоторое время опять повторяется. Типа работает какой то энергосберегающий режим на панелях, а как его блокировать? Помню, что где то про это читал, но не помню где.
Re: Подскажите по панелям оператора
Юрченко Владимир; 26.11.04

Смотрите руководство по OP27/37 на стр. 201. Скачать файл можно по ссылке:

См. http://www4.ad.siemens.de/WW/view/en/1142800

Re: Подскажите по панелям оператора
DEE; 26.11.04

Спасибо большое...

<


text

Подскажите пожайлуста
Анастасия; 24.11.04

Здравствуйте господа инженеры. Возникла такая проблемма: После переустановки ОС (Win2000_AS на WinXP_Eng + SP2) произошли странные изменения в алармах уже разработанного ранее проекта. Вместо сообщение на русском языке он пишет какие то крякозябры. Подскажите пожайлуста как подключить кирилицу чтобы сообщения вновь стали русскими.

Заранее благодарю

Re: Подскажите пожайлуста
Чистяков Дмитрий ОАО СеверСталь; 24.11.04

Пожалуй, надо в FAQ этот вопрос наносить. И на первой строке форума жирными большими буквами нарисовать ссылку. :-))

См. http://www.automation-drives.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1045054658&year=2004

Re: Подскажите пожайлуста
Анастасия; 25.11.04

Большое спасибо Дмитрий, все получилось!


text

Получить конфигурацию User Archive
Владимир; 20.1.04

Нужно получить число - максимальный возможный размер архива

Делаю примерно вот так :
UAHCONNECT hConnect;
UAHARCHIVE hArchive;
UAHCONFIG hConfig;
UACONFIGARCHIVE hArchiveConf;
Long IDArchive;

uaConnect(&hConnect);
uaQueryArchiveByName( hConnect,"Имя_архива",&hArchive);
IDArchive=uaArchiveGetID(hArchive);
uaQueryConfiguration(&hConfig);
uaGetArchive(hConfig,IDArchive,&hArchiveConf);

Далее получаем hArchiveConf.lNumRecs

Получается так, что IDArchive содержит величину на 1 больше чем требуется для uaGetArchive.

Верно ли это ?

<


text

Помогите WinCC
Александр; 10.3.04

Здравствуйте все, кто откликнулся.

Люди! Кого не затруднит помочь начинающему? Дело в том, что дня три "ковыряюсь" с WinCC что-то получается, что-то непонятно... В основном непонятны функции, они пишутся на языке С+ (?), а в нем я не рыба в воде ;0), поэтому если не трудно свяжитесь со мной по Mail aleks_ostrov@inbox.ru, или через этот форум, или через аську 288861965.
Всем огромное заранее...
Re: Помогите WinCC
Павел; 10.3.04

Кроме С++ там есть еще и VBS. В хелпе очень подробно объектная модель WinCC расписана. Так что без проблем, если C++ не устраивает.


text

Помогите лоху
Николай; 17.8.04

Как связать CPU 314C-2DP с WinCC через CP 342-5? В компьютере установлена карта CP 5613.

Re: Помогите лоху
Yrok; 18.8.04

Через PG/PC и канал соединения в WINCC

Юрок
Николай; 19.8.04

Ага, ты ещё про кабель забыл сказать с разъёмами...

Re: Помогите лоху
Чистяков Дмитрий ОАО СеверСталь; 19.8.04

Почитайте описание на WinCC, там же всё в картинках. А здесь перепечатывать его не охота, да и бессмысленно. :-)


text

Помогите с документацией
Eleria; 2.4.04

Адрес для документации на русском языке не подскажите?

Re: Помогите с документацией
Чистяков Дмитрий ОАО СеверСталь; 2.4.04

http://www.automation-drives.ru/as/products/simatic_hmi/wincc/index.php

Re: Помогите с документацией
Eleria; 5.4.04

Спасибо. Дмитрий


text

Помогите с панелью OP27
Макс Авершин; 13.3.04

Подключаю панель к компу чтобы скинуть программу, а панель выдает :

Init Transfer 0. Раньше такого не было. Программа перекачивалась без проблем. <


text

Помогите с привязкой анимации объектов
Hied; 5.9.04

Здравствуйте, уважаемые эксперты! Я собираюсь писать проект на WinCC 6.0. Программа для ПЛК пишется на STEP 7. Подскажите, пожалуйста, как мне привязывать анимацию объектов и др. параметров: к Symbol Table или к каким-нибудь тегам WinCC? Я думаю так: привязываю все во время разработки к тегам, созданным в WinCC, а потом во время пуско-наладки либо заменяю эти теги на теги из Symbol Table, либо меняю адреса тегов WinCC на реальные адреса в ПЛК. Прав ли я? Может можно по другому? Как легче всего? Как лучше?

Сразу не привязываюсь к Symbol Table, так как нужно устанавливать помимо WinCC и STEP 7, что нагружает сильно систему (слишком много запущенных процессов в Windows XP от STEP7 и соответственно тормоза).
Заранее извините, если задаю Вам глупые вопросы, так как я начинаю только программировать в WinCC. А эта SCADA отличается от известных мне: iFIX 3.0 и InTouch 8.0, которые я знаю хорошо. Например, в вышеперечисленных SCADA открытие окна управления объектом производится с помощью одной функции ShowPicture (название точно не помню), т.е. очень просто и понятно, а на то же самое в WinCC я потратил кучу времени, чтобы врубиться как это сделать через PictureWindow.
Ответьте, пожалуйста, на вопросы. С удовольствием помогу с вопросами по другим SCADA-пакетам.
Заранее благодарю всех ответивших!
Re: Помогите с привязкой анимации объектов
Diana; 6.9.04

А, не! - не прав! Если проект большой, то вы замучаетесь менять. Начинать, по-любому лучше с железа. Сразу иметь набор адресов. Смиритесь с тормозами.

Re: Помогите с привязкой анимации объектов
Роман; 6.9.04

На диске с WinCC обязательно идут демо проекты, вот там и посмотри подходы к анимации, но могу сразу сказать, анимация в WinCC ГЕММОРОЙ, ничего стандартного нет, пишишь скрипт на С++, потом привязываешь объекты, или управляешь их свойствами, типа команды SetProp, SetVisable. заменять тэги, одни на другие глупо, если только это не настроечные параметры типа FLOAT. Делай привязку напрямую, если лицензия позволяет, если нет, тогда вытягивай побитно с наложением маски. Будут вопросы пиши на мыло.


text

Почему WinCC не соединяется с БД?
Эдик; 13.10.04

Re: Почему WinCC не соединяется с БД?
Маслов Дмитрий; 13.10.04

Вот примерчик скрипта WinCC для соединения с RT-базой данных через ODBC. Подставляете нужный Вам DSN и будет работать с Вашей базой.

#pragma code ("odbc32.dll")
#include "sql.h"
#pragma code ()

int ConnectDB()
{
SQLHENV henv;
SQLHDBC hdbc;
SQLHSTMT hstmt;

RETCODE retcode;
SQLCHAR SQLState[50],SQLMsg[100];
SDWORD FAR* SQLErrorCode;

SQLCHAR DataSourceName[MAX_DM_DSN_NAME+2];
char PrPath[MAX_PATH+1];
CMN_ERROR cmnError;
DM_PROJECT_INFO ProjectInfo;

//------get project information
memset(&cmnError, 0, sizeof(CMN_ERROR));
memset(&ProjectInfo, 0, sizeof(DM_PROJECT_INFO));

if (!DMGetRuntimeProject(PrPath,MAX_PATH, &cmnError)) printf("!!!Error - DMGetRuntimeProject(...)\r\n");
if (!DMGetProjectInformation(PrPath, &ProjectInfo, &cmnError))
{
printf("!!!Error - DMGetProjectInformation(...)\r\n");
return 0;
}
else
{
strcpy((char*)DataSourceName,ProjectInfo.szDSNName);
strcat((char*)DataSourceName,"R");
}

retcode = SQLAllocEnv(&henv); /* Environment handle */
if (retcode == SQL_SUCCESS)
{
retcode = SQLAllocConnect(henv, &hdbc); /* Connection handle */
if (retcode == SQL_SUCCESS)
{
retcode = SQLConnect(hdbc, DataSourceName, SQL_NTS,(SQLCHAR*) "dba", SQL_NTS,(SQLCHAR*) "sql", SQL_NTS);
if (retcode == SQL_SUCCESS || retcode == SQL_SUCCESS_WITH_INFO)
{
retcode = SQLAllocStmt(hdbc, &hstmt); /* Statement handle */
if (retcode == SQL_SUCCESS || retcode == SQL_SUCCESS_WITH_INFO) return 4;
else
{
printf("!!! ERROR !!! SQLAllocStmt\r\n");
return 3;
}
}
else
{
printf("!!! ERROR !!! SQLConnect \r\n");
return 2;
}
}
else
{
printf("!!! ERROR !!! SQLAllocConnect \r\n");
return 1;
}
}
else
{
printf("!!! ERROR !!! SQLAllocEnv \r\n");
return 0;
}
}
См. http://www.wincc.ru

Re: Почему WinCC не соединяется с БД?
Владимир; 13.10.04

Дмитрий, подскажите пожалуйста, не могу никак разобрать, WIN CC 5.1, необходимо передавать на другую машину оперативные данные (около 150 байт) информации о состоянии системы управления. В проекте есть внешние теги, в которых хранятся эти данные. Где, в какой таблице базы данных RT я могу отыскать значения этих тегов ? Или их вообще в принципе нет ? Как я могу передать эти данные на другую машину ?

Re: Почему WinCC не соединяется с БД?
Маслов Дмитрий; 14.10.04

1. В RT-базе данных хранятся только архивные значения тегов. Текущие значения, естественно, там не хранятся.

2. Передавать на другую машину - расплывчатая формулировка. В каком виде Вам нужны эти данные: в файле, в БД, получение какой-либо самописной программой, просто отображание и т.д.?
Варантов множество, но надо сначала понять, что Вам нужно.
См. http://www.wincc.ru


text

Почему вентиляторы? И как быть?
Viktor; 5.10.04

Господа!

Ответьте пожалуйста на такой вопрос. Вот решил нарисовать мнемосхему в WinCC 5.0 SP2 элементами из библиотеки. Все нормально, но если перенести проект на другой компьютер, то все элементы из библиотеки заменяются вентилаторами...
Как быть?
Спасибо.
Re: Почему вентиляторы? И как быть?
Лёха; 6.10.04

У меня такие же глюки. Выход: по каждому объекту мышой щёлкни пару раз, выскочит окно с выбором. Ничего не выбирай, а сразу нажимай ОК. Помогало.

Если найдёшь другой способ, скажи.
Re: Почему вентиляторы? И как быть?
Viktor; 6.10.04

Так то оно так, но попробуй 560 объектов отщелкай...Как то не очень.

Я думал, что кто то знает способ попроще.
Re: Почему вентиляторы? И как быть?
Дмитрий; 19.10.04

Видимо ещё поставили ProTool v6, а там версия граф.библиотеки 1.3 (в WinCC v5 v1.2 ). А как по быстому вернуть картинки в норму тема интересная. Может откликнитесь.... cпециалисты?


text

Почему нельзя протестировать проект в ProTool RT?
TD-17; 15.11.04

Кто-нибудь работал с панелями TD17?

Почему для нее недоступна возможность тестирования проекта в ProTool RT?
Re: Почему нельзя протестировать проект в ProTool RT?
Юрченко Владимир; 15.11.04

Потому что в ProTool предусмотрена тестирование только для панелей работающих под Windows CE (xPx70).

Re: Почему нельзя протестировать проект в ProTool RT?
Dmit; 16.11.04

Спасибо! Будем ждать когда отгрузят железо.


text

При замене проекта не читаются старые алармы
Anton; 22.11.04

Отлаживаю проект на одной машине, потом ставлю на другую, (бызы по алармам и архивам со старого проекта копирую в новый проект).

Новый проект архивы не видит...
Подскажите, пожалуйста, что сделать???
Re: При замене проекта не читаются старые алармы
Дмитрий; 22.11.04

Что значить ставлю на другую и копирую базы?

Всю жизнь зиповал весь проект и сливал на другую машину, раззиповывал и все ОК!!!
Ни каких проблем.
Re: При замене проекта не читаются старые алармы
Anton; 22.11.04

То есть прям поверх старого проекта?

Но тогда же заменятся архивы (папка ArchiveManager)! и файлы имя_проектаAlg.mdf и ldf!

Имя то на машине на которой разрабатываю отличное от имени машины на которой крутится проект!

Именно по этому я пробывал оставлят выше написанные файлы и подставлять их в новый проект, но ничего не получается...
Re: При замене проекта не читаются старые алармы
Дмитрий; 22.11.04

Насчет имени машины: в новом проекте в свойствах компа ставишь имя текущей машины и все.

А вообще непонятно, что тебе нужно.
Если мне необходимо, что либо изменить,
забираю рабочий проект, меняю его у себя на компе, заменяю потом картинки новыми. Если добавил теги, экспортирую их в ехель и на рабочей тачке втягиваю(без перезаписи). В итоге имеем новые картинки и новые теги. Если надо изменить еще что нибудь, то имеются другие варианты.
Re: При замене проекта не читаются старые алармы
Anton; 23.11.04

Проект постоянно крутится на рабочей тачке (круглосуточно), и архивируется различная информация.

Когда я копирую проект для изменения и изменяю, то информация не архивируется!!! (т.к. не всегда проект в он-лайне и не всегда есть связь с контроллером).

После изменения проекта (картинки, теги, глобальные скрипты и т.д.) нужно записать на рабочую машину, а архивы сообщений и тэгов подставить со старого проекта (т.к. старый проект полностью писал архивы)
А на рабочей тачке импортировать тэги не когда! потомучто только три минуты есть для замены проекта!

Вот такая вот проблема!!!
Re: При замене проекта не читаются старые алармы
Anton; 1.12.04

Неужели никто не встречался с такой проблемой?


text

Привязка тегов только вручную?
Shpack; 11.10.04

Добрый день!

Интересует вопрос - привязка тегов и реакция на события в wincc осуществляется только вручную? а если у меня не одна сотня объектов - это же просто не производительный труд!!! Может кто создавал свои методы управления объектами в wincc?
Также если необходимо на мнемосхеме например 100 одинаковых насосов - каждый раз их надо рисовать, писать для каждого скрипты (например подтверждение на включение и останов) и вучную привязывать к тегам?

Пожалуйста, поделитесь современными методами проектирования в wincc 6!!!
Re: Привязка тегов только вручную?
~BurAn~; 11.10.04

Как делаю это я.

Создаешь 1 объект (насос, например). Анимируешь этот объект с привязкой тэгов для насоса номер 1 (Nasos01.Status, Nasos01.Alarm, Nasos01.SetPoint, Nasos01.Actuel, и т.д.). В качестве тэгов, естественно лучше использовать Структурный тэг.
А потом копируем этот готовый объект 100 раз. После чего кликаем на объекте правой кнопкой мыши -> Linking -> Tag Connections... А там используя "Найти и заменить" легко изменяутся тэги в объекте.
Но вот в скрипте тэги не меняются. Т.е. надо стараться создавать объекты без скриптов.

Андрей
Re: Привязка тегов только вручную?
Nick Gashevsky; 11.10.04

Я делал так: писал скрипт обработки, используя именя объекта (напр. Насос1, Насос2), который при старте экрана подвязывает теги (типа стартНасос1, АварияНасос1 и т.д.) к объектам. Потом копировал объект. ВинСС при этом добавляет номер к названию, поэтому скрипт работает корректно, т.е. привязывает к тегам стартНасос2, АварияНасос2.Таким образом, имена тегов привязываются автоматически.

Re: Привязка тегов только вручную?
Маслов Дмитрий; 11.10.04

По поводу первого ответа: в C-скриптах теги тоже заменяются, если их имена объявлять с помощью #define в специальной секции в начале скрипта (она автоматически создается при создании нового скрипта).

По поводу второго ответа: привязывать теги на этапе проектирования все же лучше, т.к. не тратятся лишние ресурсы в Runtime.

Ну и наконец самый простой и быстрый способ решения поставленной проблемы - использовать PCS7. И теги сами создадутся, и насосы на мнемосхеме с готовыми привязками к нужным тегам.
См. http://www.wincc.ru

Re: Привязка тегов только вручную?
Eugene; 28.10.04

Re>>Ну и наконец самый простой и RE>>быстрый способ решения RE>>поставленной проблемы - RE>>использовать PCS7. И теги сами RE>>создадутся, и насосы на мнемосхеме RE>>с готовыми привязками к нужным RE>>тегам.

Называется это иконками блоков, создается при компиляции ОС функцией "create/update blocks icon". В свойствах мнемосхемы, до компиляции, указываешь "derive the block symbols from the technological hierarchy". Иконки берутся из @@PCS7Typicals.PDL при компиляции, из @Template.PDL при обновлении из WinCC через Визард "Update of The picture objects".
Иконки мастеришь по своему усмотрению.
<


text

Пример для WinCC OLE DB Provider
Dmiriy; 28.4.04

Может кто покажет пример connection-string для связи с fast-архивами WinCC через её OLE DB Provider for Fast archiv (всё на одной машине)


text

Пример доступа к Active-X элементам
Малкон; 12.11.04

Пожалуйста, может кто-нибудь написать пример доступа к Ячейке таблицы например DataGrid или DBGriв (Active-X) ?

По нажатию Кнопки Button1
И как это сделать на встроенном C, и на VB ?

(как странно, из всей документации - нет ни одного примера, это надо было так умудриться написать такую плешивую документацию)
Re: Пример доступа к Active-X элементам
Д Веткин АвтоВАЗ; 12.11.04

а где сам элемент то, если на картинке то вот пример, на аналогичный вопрос мне здесь уже отвечали, если в другом приложении, то в демо проекте к ОДК рассматривается доступ к екселу

#include "apdefap.h"
void OnClick(char* lpszPictureName, char* lpszObjectName, char*
lpszPropertyName)
{
#define GetObjectA GetObject

__object *obj = NULL, *pic = NULL, *ocx = NULL;
obj= __object_create("PDLRuntime");
if(!obj)
{
printf("obj = NULL\r\n");
return;
}
pic = obj->GetPicture("NewPdl0");
if( pic == NULL){
__object_delete(obj);
printf("pic != NULL\r\n");
return;
}
ocx=pic->GetObject("OLE Control1");
if( ocx == NULL){
printf("ocx = NULL\r\n");
__object_delete(obj);
__object_delete(pic);
return;
}
ocx->AboutBox();
__object_delete(obj);
__object_delete(pic);
__object_delete(ocx);

}

Re: Пример доступа к Active-X элементам
Малкон; 15.11.04

Re: Пример доступа к Active-X элементам
Михаил; 15.11.04

Малкон: дофига вопросов задаешь. Расслабся сдался тебе этот WinCC.

Re: Пример доступа к Active-X элементам
Малкон; 15.11.04

Политика предприятия - WinCC, кое с чем я разобрался, но вопросов все равно еще больше, чем ответов. Есть альтернатива WinCC - Genesis32, ее иногда смотрю, последняя 7 версия кривоватая еще, падает ни с того ни с сего.

Восьмая по цене чуть ли с WinCC не сравнялась. Я бы не задавал вопросы, если бы знал где искать, а то политика SIEMENS - раздавать инфу только на оф.обучении. - это маразм. Так же нельзя. А обучение вылевается не в цену книжки, 500 евро один курс, а по WinCC их штуки 4.
Re: Пример доступа к Active-X элементам
Вадим Печёрских; 24.11.04

Доступ к ячейкам таблицы должен обеспечивать ActiveX. То есть он сам должен предоставлять свойства и методы.


text

Пример
Константин; 15.12.04

Если возможно,вышлите, пожалуйста, (кто когда-нибудь делал)отрезок проекта, где используется динамическая система создания отчетов по времени и по параметру....а то параметров много,а стандартно из Report Des. корректно получается только для ограниченного числа тэгов, да и время забивается жестко...

Адрес: mri4@yandex.ru <


text

Примеры к ODK (WinCC)
SIS; 16.2.04

Поделитесь кто-нибудь,плиз, примерами использования ОДК на VC++ (вроде бы есть на диске с ОДК)

А то буржуи не хотят делиться...
Re: Примеры к ODK (WinCC)
Alexis; 16.2.04

Дык в хелпах одкашных полно примеров...

Re: Примеры к ODK (WinCC)
SIS; 17.2.04

Мне бы реальный проект на VC++ или VB... По одкашным примерам трудновато разобраться.:)

Re: Примеры к ODK (WinCC)
Маслов Дмитрий; 17.2.04

Вообще говоря проект, в котором используются все возможности ODK трудно найти - слишком их много. Есть проект, в котором записываются теги в WinCC. Доступ к WinCC-тегам реализован в виде классов: CTag, CBitTag, CFloatTag и др. В общем, посылаю по мылу.


text

Принтер с ECMA раскладкой...
Olga; 18.5.04

Для печати кириллицей с OP17 нужен принтер с ECMA раскладкой (DR 2040 + ECMA 9014 карта):

6GF6520-1LD :24 ИГЛ В ГОЛОВКЕ МАТРИЧНЫЙ ПРИНТЕР 80 ЗНАКОВ В ЛИНИЮ 400 CPS (10 CPI) РАЗРЕШЕНИЕ 360X360 DPI, ПАРАЛЛЕЛЬНЫЙ ИНТЕРФЕЙС/ ПОСЛЕДОВАТЕЛЬНЫЙ RS232C
6GF6520-4LF :ECMA 9014 ЭМУЛЯЦИЯ ДЛЯ DR 2155/2170 ID: 048 050
Подскажите, пжлста, верен ли мой выбор?

Re: Принтер с ECMA раскладкой...
Юрченко Владимир; 18.5.04

Для принтера T2150 (6GF6520-1LD ) заказывать ECMA модуль не надо. Он был нужен для старых принтеров DR2155. В новых принтерах встроена эмуляция ECMA модуля. Ну а дополнительную информацию можно найти на www.tally.ru - в принципе это их принтер.


text

Принцип обмена сообщениями
Shpack; 13.10.04

Добрый день!

Поясните, пожалуйста, на примере насоса, управляемого как по месту, так и дистанционно, с блокировками по превышению давления на всасе (аналоговый) и разрыву шланга (дискретный) принцип обмена сообщениями (Alarm logging).

Насколько я себе это понимаю, wincc может отслеживать состояние аналоговых и дискретных тегов и в соответствии с ними генерировать аварийные сообщения.
Но ведь это должен делать и контроллер тоже, для отработки блокировок (например перекрытие клапанов, включение резервного насоса и т.п.)
То есть двойной контроль одного и того-же?
Подскажите, как правильно заполнить все компоненты alarm loggin для примера, приведенного выше!
Также, указывается что для PCS7 и контроллеров s7-400 это вообще не проблема - расскажите в чем для этих контроллеров такое существенное отличие!
Заранее огромная благодарность!
PS: Может кто из профессионалов есть в Волгограде или Волжском?
Приветствуется пример проекта для wincc6 по почте! sektoris@yandex.ru
Re: Принцип обмена сообщениями
Nick Gashevsky; 13.10.04

Конечно двойной контроль, а толку например с контроля ТОЛЬКО от WinCC, если шнурок связи отвалится или коммуникационник выйдет из строя. Контроллер сам Должен все обработать.

Re: Принцип обмена сообщениями
Маслов Дмитрий; 13.10.04

По поводу двойного контроля - не обязательно. В WinCC хотя и есть возможность контроля аналогового параметра по уставкам с выдачей сообщений, лучше это делать только в контроллере, а в WinCC считывать только биты-результаты контроля. На каждый аналоговый тег получается 4 бита: признаки нарушения нижней и верхней аварийной и предупредительной уставок, по каждому создаете тег (поле структуры), который будет являться тегом соответствующего сообщения (Message Tag). А контроллер выставляет эти биты, контролируя параметр по уставкам с учетом всех задержек, гистерезисов и прочей логики.

По поводу PCS7 и S7-400 - там используется другой механизм сообщений. Они передаются с помощью системной функции контроллера (ALARM_8P), метка времени фиксируется не станцией, а контроллером (более точно). А главное, конфигурирование сообщений сводится к тому, что в программе контроллера Вы задаете логику появления этого сообщения и текст, а в WinCC все создается автоматически.
См. http://www.wincc.ru


text

Проблема коннекта S7 315 2DP & MP370 (код ошибки 140010)
Alexander; 27.10.04

Уважаемые, помогите с таким траблом:

панель MP370 соединена с 315 2DP по PROFIBUS DP. Но прект загруженый в нее никак неможет связаться с 315 2DP. Изменение настроек связи панель- CPU (DP-адрес, master\slave) ситуацию не изменило. Пробывали связывать по MPI - эффект тот же.
По совету умных людей перепрошили ОС в панели ситуация таже.
Ситуация осложнена тем, что программа в контроллере закрыта паролем( ее нельзя скачать). Мне были открыты только блоки данных с помощью которых ведется обмен с панелью.
Пробовал "проэмитировать" обмен данных с помощью Step 7(функцией Compare Blocks) через порт DP не получилось.
Аналогичный тест обмена данных через порт MPI привел к запросу пароля.
Грешу на пароли. Прав ли я?
Может кто сталкивался с таким, подскажите.
Панель выдает следующий код ошибки 140010.
Заранее спасибо.

Re: Проблема коннекта S7 315 2DP & MP370 (код ошибки 140010)
Юрченко Владимир; 27.10.04

Данная ошибка описана в документации по панели и означает, что неправильно настроен DP порт контроллера. И пароли тут не причем. Как и упомянутые блоки данных для ведения связи с панелью - (может Вы имеете ввиду интерфейсные области ProTool?) тоже не причем. Еще часто добавляют панель как slave в Hardware Configure, что не нужно делать - она в интегрированном проекте должна быть в NetPro окне подсоединена к нужной сети.

Re: Проблема коннекта S7 315 2DP & MP370 (код ошибки 140010)
Alexander; 27.10.04

Спасибо за ответ.

Где можно найти документацию,в которой есть эти самые коды?
Вообщем то, если верить Вам, то я не в состоянии поправить ситуацию. Иностранцы слишком ценят интелектуальную собственность.
Или может кто подскажет как ломается пароль на аплоуд? :-)
Re: Проблема коннекта S7 315 2DP & MP370 (код ошибки 140010)
Уточни; 27.10.04

Из этого сумбура я не понял - в самой панели программа от этих "скрытных" горе-программистов есть? Если нет - то чего ты хочешь - из Виндовса связаться?

Программа контроллера знает, что она должна работать с панелью?
В конфигурации контроллера жестко прописаны параметры подсоединения панели и ее адрес - стандартно через MPI. Адрес должен соответсвовать конфигурации.
Тип процессора какой - с MMC картой или с батарейкой?
И зачем ты один вопрос в разные разделы кидаешь - я уж подумал у меня башка к концу дня едет.

См. http://simatic.nm.ru/phorum.dhtml


text

ПРОБЛЕМА ПРИ АНИМАЦИИ ОБЪЕКТОВ.
ALEX; 26.7.04

Очень важный вопрос по-поводу анимации объектов. Когда я привязую любой таг формата UNSIGNED16,32 для отображеня и скрытия объэкта в цикле 1сек. или 500милисек, вопрос- когда этот цикл в действии я не могу ввести данные в любое поле "i/o field"- пропадает курсор для введения. Може я что-то творю не так?

Re: ПРОБЛЕМА ПРИ АНИМАЦИИ ОБЪЕКТОВ.
smi; 27.7.04

Try to show/hide the IO field by event, not in cycle!

Re: ПРОБЛЕМА ПРИ АНИМАЦИИ ОБЪЕКТОВ.
ОПЯТЬ ВСТРЕЧНЫЙ ВОПРОС-ALEX; 27.7.04

Цикл проходит в програмном логичном контролере а я получаю только сигналы,например от 1 до 5 и так по кругу.Почему же всё-таки пропадает курсор для ввода других полей при этом.


text

Проблема с Alarm Logging
Эдуард; 30.11.04

Здравствуйте, эксперты!

У меня следующая проблема: в Alarm Logging создал сообщение, в поле ProccessValue прописал тег. Так вот при появлении этого сообщения в поле ProccessValue появляется предыдущее значение этого тега. А мне нужно, чтобы в этом поле было текущее значение тега. Помогите, пожалуйста с этой траблой! Делаю все правильно: сначала меняю значение тега, а потом вызываю сообщение при помощи MessageTag. Неужели это так задумано в Alarm Logging? Или это баг? А как тогда вывести текущее значение?
WinCC 6.0 SP2

Заранее спасибо
Re: Проблема с Alarm Logging
Л. Шерешевский; 1.12.04

Уважаемый Эдуард, эта проблема уже неоднократно рассматривалась в форуме.

См. Одно из обсуждений данной темы (были и другие!)

Re: Проблема с Alarm Logging
Эдуард; 1.12.04

Спасибо Вам, Л. Шерешевский!


text

Проблема с панелью TP170B
Павел; 19.8.04

Господа, подскажите пожалуйста:

После включения панели отображается окно загрузчика, однако кнопки в нем на нажатия не реагируют. При попытке загрузить что-либо из WinCC Flexible, на панели появляется сообщение "Bus address configured alredy assigned"
Что делать? (с панелью работаю впервые)
Re: Проблема с панелью TP170B
Юрченко Владимир; 20.8.04

Может быть в панели операционка Windows CE совместимая с ProTool и надо перегрузить ее образ.Для этого надо выбрать меню Project\Transfer\OSupdate (соединяться с панелью по RS232) и после выбора образа нужно включить-выключить панель для начала перегрузки.


text

Проблема с сообщениями
Федор; 21.9.04

Не знаю, сюда ли. Может быть кто подскажет.

Блок CTRLDRV генерит сообщения о действиях над ним производимых (авт/дист, откр/закр и т.д.). Если производить эти операции с сервера, то все сообщения нормально приходят и записываются в архив. Но если с клиента, то сообщения не приходят вообще.
WinCC 6 SP1, Мультиклинеты

Также интересно было бы знать где формируется текст этих сообщений. Потому как в CTRLDRV в messages их нет. Они как-то в WinCC формируются? Там в текстовой библиотеке такой текст: @7%s@ / @6%s@ стало = @3%g@ @8%s@ было = @2%g@ @8%s@. Можно как-нибудь к этой строке добавить BlockComment из CTRLDRV и запретить некоторые из сообщений (напр. сообщение о подачи импульса на откр или закр)?
<


text

Проблема связи WinCC 5.1 и SIMATIC S5
Макс Прилепский; 27.4.04

Есть следующая проблема: существуют две станции WinCC 5.1 HF4 под Win2K с одним и тем же проектом и SIMATIC NET 2001 SP5. Станции подключена по Industrial Ethernet (ISO) к контроллеру S5 (у контроллера в конфигурации СР имена TSAP уникальные и MAC-адреса станций разные). Первая станция связывается с контроллером без проблем, вторая же , при подключении , тоже отображает информацию, ошибок никаких ни в log-файлах, ни в файлах трассировки нет. Утилита Channel Diagnosis тоже показывает отсутствие ошибок. Но при запуске проекта на второй станции в PLC начинает самопроизвольно меняться один из меркерных битов. При создании на этой станции нового проекта, в котором создаётся пустое, без тегов, соединение, настроенное на PLC, при запуске нового проекта проблема остаётся. В сети существуют несколько станций и PLC других подсистем, в т.ч. и контроллер S7, но адреса и настройки связи у всех разные. Сеть построена на оптическом кольце, т.е. все участники сети видят пакеты друг друга. Смущает то, что вторая станция даже при отключении первой инициирует самопроизвольное изменение переменной PLC. Вместо второй станции ставили другую с такой же аппаратной конфигурацией, меняли сетевую карту на другую, меняли настройки SIMATIC NET - всё безрезультатно. Может кто-нибудь с такими граблями сталкивался ?

Re: Проблема связи WinCC 5.1 и SIMATIC S5
Макс Прилепский; 27.4.04

Всё, проблема решилась. Глюк был в PLC, но при наличии сзязи с первой станцией почему-то не проявлялся


text

Проблема старта в Tag Logging
Людмила; 22.9.04

В Tag Logging создаю архив. Параметр архивируется так: в Acquisition Type выбираю Acyclic, на вкладке Parameters ставлю галочку Archive only upon change. Все прекрасно архивируется. Но мне не нравиться, что первые значения при запуске проекта архивируется нулевые, когда данные еще не пришли. Тогда в archiving at system start ставлю галочку в Disable, а в Start Event записываю action, как в примере. Архивирование не работает. В отладочном окне запускаю сообщение о возвращаемом значении стартовой функции – все правильно работает. Еще мне не понравилось, что функция вызывается каждую секунду, а может и чаще.А если у меню около сотни таких архивов? А не подскажет ли кто-нибудь, как включить архивирование программным путем? И почему не архивируется?

Еще такой вопрос: что нужно указывать при создании сообщения в поле Link и Link Title?
Re: Проблема старта в Tag Logging
Прокопенко Вера; 22.9.04

На архивирование по событию, если оно сконфигурировано в TagLogging через Evevt start / Even stop есть ограничения: не рекомендуется более чем для 10 тегов. Если отследить работу этих событийных функций, то видно, что они запускаются по 4 и более раз в секунду для каждого тега, видимо, это и нагружает систему. Мы работаем только с циклическими архивами.Для записи аналоговых тегов используем гистерезис. Запускать и останавливать архивирование можно принудительно.

#pragma code("kernel32.dll");
void GetLocalTime(SYSTEMTIME* lpst);
#pragma code ();

SYSTEMTIME time;
CMN_ERROR pError;
TLG_ARCHIVDATARAW pTlgData;
//char *szArchivName="arch_sec_k4";
DWORD dwNumberOfData=1;
DWORD dwFlags=0;

GetLocalTime(&time);

pTlgData.dwFlags=0;
pTlgData.stTime=time;

TLGConnect(NULL,NULL);
//TLGLockArchiv (NULL,имя архива,0-разрешение записи или 1-запрет,&pError ).
TLGLockArchiv (NULL,"arch_sec_k4",1, &pError );
TLGDisconnect(NULL);
Re: Проблема старта в Tag Logging
Людмила; 22.9.04

Вера, большое спасибо за подсказку, сейчас пробую.

Re: Проблема старта в Tag Logging
Людмила; 22.9.04

Вера, большое спасибо за подсказку, сейчас пробую.


text

Проблема установки MS SQL Server
Денис; 19.3.04

При установки MS SQL Server программа вылетает

Re: Проблема установки MS SQL Server
Павел Кобелев; 26.3.04

Проблема скорее асего заключается в следующем:

У вас имя пользователя введено на русском языке, например, "Администратор" и путь ко временной папке по умолчанию лежит в Documents and Settings в профиле соответствующего пользователя - т.е. временная папка содержит русские символы. Переназначте временную папку на C:\TEMP, например, и все будет замечательно.
<


text

Проблема. Что дальше ставить? WinCC v6 или v5
Дмитрий Л.; 21.6.04

Предприятие. Есть N-проектов (по одному в цехе) на WinCC v5 с WebNavigator-ами. Организован Web-сервер с сылками на на эти WinCC Web-сервера. В целом картина нормальная. Но сейчас встаёт вопрос о использовании 6-ой версии для новых проектов. Но Web-клиенты у них свои и друг с другом не дружат. Как быть? Продолжать использовать v5 или платить кучу денег и переводить всё на v6.


text

Проблемма с Handle в консольном проекте Delphi
Coroner; 11.9.04

Привет всем !!! У меня проблеммы с использованием Handle в консольном проекте. По определённой комманде у меня должен вылетать список присутствующех окон в системе однако Delphi на отрез отказывает компилить любые функции где присутствует Handle.

Напиример : Wnd := GetWindow(Handle, gw_HWndFirst); говорит, что вот этот самый Handle незадикларированная переменная. Проверял в обычном проекте всё работает !!! В чём косяк подскажите !!! Весь нет и доки перерыл но ничего не нашёл !!! Всем заранее спасибо.
Re: Проблемма с Handle в консольном проекте Delphi
Юрченко Владимир; 13.9.04

Ну во первых Delphi не продукт Сименса. Во вторых немного почитать бы о Delphi начиная с документации. Например, что наличие файлов после uses, (аналог include в С) полностью объясняет Ваши проблемы. Вообще посмотрите сайты посвещенные Delphi, например можно начать с www.torry.net


text

Проблемы с OP17
Vladimir; 10.2.04

Уважаемые коллеги.

На одном из станков с интервалом в полгода вышли из строя две панели оператора OP17 (6AV 3617-1JC20-0AX1). Проявление неисправности: не действуют верхние 2 ряда кнопок панели.
Детальный анализ показал что неисправность абсолютно одинакова: вышла из строя микросхема Am186 ES-25KS (отсутствуют импульсы на 52-й ножке). Явных причин поломки нет. Механические повреждения отсутствуют.
Поделитесь, пожалуйста, мнениями о возможных причинах поломки. Был ли подобный случай в практике? Есть ли где возможность ремонта (схемы, оборудование для пайки), можно ли приобрести компоненты.

Re: Проблемы с OP17
Чистяков Дмитрий ОАО СеверСталь; 12.2.04

Хм...

В эксплуатации с 2000-ого года и ни каких проблем не было.
Я бы прежде всего проверил питание, отсутствие встречных токов и напряжений по профибасному кабелю. Линия то по Profibus длинная?
Re: Проблемы с OP17
Vladimir; 12.2.04

C OP7,27,37 - аналогично никаких проблем. Да и с 17 до этого проблем не было, а тут сразу 2 шт. подряд да еще неисправность одинаковая.

Питание проверяли ессно.
Насчет Profibus не понял. Вылетел проц. Порт с остальной схемой развязан вроде (или я путаю что то). Если есть информация, поделитесь плз. если не трудно (без схем тяжко).
Линия, метров 15 в общей сложности, от коммуникационного процессора. На ней висят OP7 и OP17.<


text

Проблемы с ProTool
malefik; 22.12.04

ОС WINXP SP2. Остался проект от ProTool 5. Установил 6 ProTool. Проект соответственно конвертировался. Периодически ProTool вылетает пишет различные ошибки а то и вообще молча закрывается....Снёс 6 поставил 5. 5 при запуске ругается на COMRes.dll. Может такие ошибки уже описывали..сильно не пинайте...

Re: Проблемы с ProTool
Юрченко Владимир; 22.12.04

ProTool не поддерживает WinXP SP2.

Смотрите таблицу совместимости версий ProTool и Windows:
См. http://support.automation.siemens.com/WW/view/en/8795248


text

Проблемы с С7-613
Korotov; 9.6.04

Господа!

Кто-нибудь сталкаивался с панелью С7-613. Не можем добиться поддержки русского языка.<


text

Проблемы связи двух PC c S7 300
Константин; 2.6.04

Две WinCC станции связаны с контроллером Simatic S7 300 по протоколу TCP/IP через OLM. На одной из них используется СP1613, на другой встроенная сетевая плата. При этом на втором РС наблюдаются нерегулярные случаи потери связи с контроллером около 1 сек. Первый при этом работает нормально. Общий объём обмена – примерно 200 тегов в 250ms цикле. В проекте на контроллер в NCM станции не прописывались, соответственно и connections тоже, все настройки соединения с контроллером (кстати 315-2DP) проводились на стороне станций WinCC.

Подскажите, в чём может быть проблема?
Re: Проблемы связи двух PC c S7 300
DEE; 2.6.04

И вообще, не подскажите ли какие действия (настройки) нужно произвести в контролллере и станциях WinCC для выше приведённого случая...Поточнее обрисую ситуацию : есть один Simatic S7 300 (CPU 315 2-DP + CP 343-1) к нему нужно подцепить(по IE) 2 WinCC сервера (без клиентских станций). Горячего резервирования серверов не требуется. Нужно, что бы WinCC на обоих тачках обращался к одним и тем же областям памяти в контроллере и всё это работало без задержек/зависаний. Заранее благодарен.

Re: Проблемы связи двух PC c S7 300
Лёха; 3.6.04

Какого рода проблемы со связью?

У нас были проблемы между РС и S7 400 по протоколу TCP/IP - связь пропадала сама по себе, потом появлялась, но могла и не восстановиться.
Помог переход с ТСР/IP на Siemens Industial Ethernet (ISO). Связь работает стабильно.
Re: Проблемы связи двух PC c S7 300
DEE; 4.6.04

Проблемы такого рода, что на одной станции всё нормально ( и данные на экране обновляются быстро, коннект с контроллером не обрывается), а с другой всё наоборот. Но, повторяю на стороне контроллера мы ничего не делали (т.е. в NCM никаких станций не добавляли и сетевой конфигурации не прорисовывали), а настройку вели только на стороне WinCC, т.е. Tag Management- SIMATIC S7 PROTOCOL SUITE-TCP/IP-Connection в пропертисах задавали IP адрес контроллера (ну там ещё № корзины, слота и др.) и в случае одной станции всё великолепно работало. Но стоило подцепить ещё одну станцию (абсолютный аналог первой в плане проекта на ней, ну только ес-но IP другой и карта памяти встроенная а не IP1613) и вот на ней начались глюки...

Re: Проблемы связи двух PC c S7 300
Харгелия Олег, ЗАО "Искра-Энергетика"; 4.6.04

А если станцию с СР1613 отключить от сети, то проблемы со связью на второй станции остаются?

Re: Проблемы связи двух PC c S7 300
Nick; 4.6.04

Посмотрите, не забивает ли вторая станция сеть "левыми" пакетами.

Re: Проблемы связи двух PC c S7 300
Константин; 7.6.04

В том то и дело, что если выключаешь одну станцию, то вторая работает без проблем. Влияют друг на друга, почему непонятно. Причём, если использовать СР 1613 на оба компа, то они начинают терять связь поочереди.

Re: Проблемы связи двух PC c S7 300
Константин; 7.6.04

А как проверить насчёт "левых" пакетов, и вообще непонятно что это такое.


text

Проблемы со связью одной станции визуализации WinCC и контроллера SIMATIC 318-DP
Поташов Александр "Северсталь"; 22.4.04

Операторская станция представляет собой компьютер Р3 промышленного исполнения с WinCC. Связь с контроллером SIMATIC 318-DP осуществляется через плату CP5613. Связь периодически пропадает, сама не восстанавливается, при перезагрузке Runtime как правило восстанавливается.

Вылезает ошибка.
CP_STATE_EXCP_CLOSE_0!
DW_Para1: 0x0 DW_Para2: 0x101
Интересует, если это аппаратная ошибка, то неисправна плата CP5613 или материнская плата. При перезагрузке копьютера иногда проскакивают один длинный и восемь коротких сигналов.
При установке данной платы CP5613 на другой компьютер, загрузка идёт в нормальном режиме.<


text

Программирование ОР, ТР
Дертунов Борис; 20.1.04

Кто знает как запрограммировать панели оператора если в РС нет СОМ-порта? Есть ли какой адаптер под USB или PCMCIA?

Re: Программирование ОР, ТР
Кулаков Г.К.; 20.1.04

Есть преобразователи USB в COM.

Мы пробовали, все работает.
Re: Программирование ОР, ТР
Дертунов Борис; 20.1.04

Что за преобразователи?

К ним стандартный кабель подходит?
Re: Программирование ОР, ТР
Чистяков Дмитрий ОАО СеверСталь; 21.1.04

Подойдут стандартные переходники

см. здесь
http://www.price.ru/bin/price/prodlist?base=1&fair=1&cid=0908&where=00&sort=1&plan=5&curr=2&vcid=010307&pnam=usb%20com
Re: Программирование ОР, ТР
Дертунов Борис; 23.1.04

Большое спасибо. Буду заказывать

Re: Программирование ОР, ТР
Yrok; 24.1.04

Фирмы Advantech

USB -> RS485/RS422/RS232 = ADAM4056
Ethernet -> RS485/RS422/RS232 = ADAM4570
Если Ethernet то вообще удобно модуль может находится чёрт знает где а PC связыватся с ним по сетке
http://www.advantech.com/products/Model_Detail.asp?model_id=1-D6FMP

http://www.advantech.com/products/Model.asp?Category_ID=1-D6H6Z&bu=
Заказать можно в фирме ProSoft.ru
Re: Программирование ОР, ТР
Darwin; 11.5.04

Насчет ADAM4510, кто нибудь использовал его как адаптер COM->MPI/DP?

Особенно про питание ADAM4510, как его подавали?<


text

ПРОГРАММНЫЙ ЗАПУСК TAGLOGIN
Михаил; 1.12.04

Цель по изменению какого либо определенного тега taglogin начинал орхивирование данных но только один раз и снова вставал. в стоп

Re: ПРОГРАММНЫЙ ЗАПУСК TAGLOGIN
Alexis; 1.12.04

Попробуйте TLGLockArchiv\TLGLockVariable, а если одно значение запихнуть, то TLGInsertArchivData.

Re: ПРОГРАММНЫЙ ЗАПУСК TAGLOGIN
Макс Прилепский; 2.12.04

Можно сконфигурировать в Tag Logging события начала/окончания архивирования с помощью функций или значений служебных тегов (Закладка Events в свойствах архивируемого параметра в Tag Logging)


text

Продам OP27
Automation; 5.2.04

В связи с модернизацией оборудования продается панель оператора ф.Siemens OP27 Mono 6AV3627-1JK00-0AX0.

Панель новая, в упаковке.

Цена 1200 Евро (более, чем на 20 % ниже каталожной цены Siemens).
Возможен торг.
Рассмотрятся возможность доставки, а так же программирование и установка на оборудовании.

Re: Продам OP27
куплю; 2.9.04

условия продажи?

См. http://bilalov

Re: Продам OP27
Юрчик; 2.9.04

Продано в мае еще.


text

Продам неспешно панель OP-27
Automation; 1.3.04

В связи с модернизацией продам по сходной цене из ЗИПа панель OP27 Mono 6AV3627-1JK00-0AX0.

Панель новая, в упаковке.

Рассмотрятся возможность доставки, а так же программирование и установка на оборудовании.

Re: Продам неспешно панель OP-27
Осинцев Сергей; 28.7.04

ПАНЕЛЬ ЕЩЕ ПРОДАЕТСЯ С УСТАНОВКОЙ И ПРОГРАМИРОВАНИЕМ PROTOOL V6.0?


text

Прозрачная PDL
Shpack; 18.10.04

Подскажите, как сделать прозрачную PDL скажем с рисунком насоса. При установке свойства transparent оно сразу же сбрасывается в solid.

И вообще если не нравятся simatic HMI кто как из положения выходит?
Ну кроме ActiveX

Re: Прозрачная PDL
Nick Gashevsky; 19.10.04

Рисовал свои картинки и вставлял в ВинСС, еще группировка со встроенными объектами с созданием Customized Object и "вытягиванием" нужных св-в. Получается вроде ничего.

Re: Прозрачная PDL
Евгений; 10.11.04

Я делаю рисунки насосов и кранов в CorelDraw в wmf формате, отображаю их в WinCC c помощью элемента Graphic Object

Re: Прозрачная PDL
Александр Родин, ООО "Нева Электрик"; 11.11.04

Можно вставлять BMP графику с равномерным цветом фона, а потом в свойствах вставленного рисунка объявлять цвет фона прозрачным.


text

Пропадает отображение трендов в WinCC
Писковец Сергей; 4.6.04

Мы сталкнулись с проблемой отображения графиков в WinCC.

При выборе окна Selekt Time renge ничего не выбрано не "in RC", не "in RC and CS"
В окне Selekt Time renge при выборе "in RC" происходит визуализация трендов в реальном времени, однако после смены кадра начинается всё с начала.
В окне Selekt Time renge при выборе "in RC and CS" ничего не происходит.
Подскажите пожайлуста что произходит и что делать.

См. Писковец Сергей

Re: Пропадает отображение трендов в WinCC
Cnhtkznmcz; 13.7.04

Из большого пистолета!

Re: Пропадает отображение трендов в WinCC
Л. Шерешевский; 13.7.04

RTFM, как говорят иностранные коллеги!

Судя по Вашему описанию, Вы используйте online-теги, а не архивные, отсюда все проблемы. А "in RT" и "in RT & CS" - это совсем из другой оперы.
P.S. Select пишется с "с", а range - с "a".<


text

Пропадание связи S5 Siemens - profibus - WinCC
Vladimir; 24.12.04

Помогите почему может пропадать связь S5 Siemens - profibus - WinCC,с очерёдностью 1-4 дня.WinCC работает через плату CP1413.Контроллер CPU945, работает - пропадает только связь со SDADA.После restart PLC - ok.В чём может быть проблема?

Re: Пропадание связи S5 Siemens - profibus - WinCC
Чистяков Дмитрий ОАО СеверСталь; 24.12.04

Ещё раз скажу, что CP1413 - это Ethernet, а не Profibus и как это оно у вас там работаит? :-)

По какому протоколу работаете?
Какой канал в WinCC используете?
Какой CP стоит в S5-том?
Как он настроен?
Re: Пропадание связи S5 Siemens - profibus - WinCC
Vladimir; 27.12.04

Добрый день - Дмитрий!

Спасибо за ответ.
Дело в том,что у нас этот проект выполняли англичане,мы сами такие работы не выполняем.Я только работаю,частично обслуживаю систему,поэтому большого опыта в прораммировании нет.Если есть возможность Вы немогли скинуть мне Ваш e-mail или телефон. За раннее спасибо.
Я постараюсь собрать информацию на заданые Вами вопросы.
Re: Пропадание связи S5 Siemens - profibus - WinCC
vllv; 27.12.04

Плата,на станции стоит CP1613,но она сконфигурирована под CP1413. Связь PLC-модем-SCADA.В PLC коммуникационный процессор стоит 6GK1143-OTA02. Модем установлен на коммуникационном - CentreCOM 210TS.

Где можно посмотреть протокол и канал связи WinCC,для того чтобы я мог Вам передать информацию.
Re: Пропадание связи S5 Siemens - profibus - WinCC
Vladimir; 27.12.04

Плата,на станции стоит CP1613,но она сконфигурирована под CP1413. Связь PLC-модем-SCADA.В PLC коммуникационный процессор стоит 6GK1143-OTA02. Модем установлен на коммуникационном - CentreCOM 210TS.

Где можно посмотреть протокол и канал связи WinCC,для того чтобы я мог Вам передать информацию.
Re: Пропадание связи S5 Siemens - profibus - WinCC
Чистяков Дмитрий ОАО СеверСталь; 28.12.04

Во первых, Вам необходимо посмотреть настройки коммуникационного процессора CP1430 TF (именно так он называется) при помощи программы COM 1430TF (заказной номер 6GK1743-0TA01-0EA0). Там же можно узнать код ошибки, от которого в последствии и необходимо плясать после очередного зависания.

В программе STEP 5 необходимо просмотреть участок программы с передачей данных в WinCC.
В WinCC тип канала можно посмотреть в ветке Tag Management.
CentreCOM 210TS - Конвертор из интерфейса AUI в RJ-45 (витая пара). Т.е. стандартный Ethernet.

Ну, и ещё, в любом случае Вам придётся хотя бы просмотреть все описания на CP1430 и WinCC. В противном случае Вам будет тяжело в устранении проблемы, а нам рассказать Вам где и что ещё посмотреть. :-)<


text

Просмотр трендов из архива
Владимир; 6.10.04

При просмотре тренда из архива выбираю EndTime больше текущего времени и на графике вижу после текущего времени прямую горизонтальную линию(типа данные есть)Мне ясно что это неправильно.Но операторы не поймут.Как от этого избавиться?

Re: Просмотр трендов из архива
Маслов Дмитрий; 11.10.04

По-моему, никак. Объясните операторам, как отличить настоящие данные от результата интерполяции/экстраполяции: включаете бегунок на тренде, в окне отображения выбранных значений смотрите, есть буква i (interpolated) после значения, или нет.

См. http://www.wincc.ru


text

Простая визуализация
Alex Legornev; 16.11.04

Добрый день! У меня совсем простой вопрос:

Как показать вращение детали на операторской панели? В свойствах рисунка есть управление по горизонтали и вертикали, но нет поворота на градусы.
Может в сети сборники подобных решений?
Re: Простая визуализация
Павел Кобелев; 17.11.04

2-3 разных картинки. Показывать по очереди. А панель-то какая?

Re: Простая визуализация
Alex Legornev; 17.11.04

Спасибо за совет, панель MP 370.

И вот еще идею подсказали, что можно использовать полярные координаты, где- нибудь это было реализовано?<


text

простой вопрос
Alex Legornev; 16.11.04

Добрый день! У меня совсем простой вопрос:
Как показать на ProTool вращение детали на операторской панели? В свойствах рисунка есть управление по горизонтали и вертикали, но нет поворота на градусы.
Может в сети сборники подобных решений?

Re: простой вопрос
Игорь; 17.11.04

Способ решения проблемы следующий.

1. Создаёшь внутренний тэг типа INTEGER
2. Открываешь Properties того Screen'а, на котором твоя картинка, и вставляешь туда функцию Animate для этого тэга (с нужными параметрами, например - мин. величина=1, макс.=5)
3. Либо создаёшь пять (для данного примера) картинок, при смене которых будет возникать иллюзия вращения, либо пять дополнительных граф. элементов для этой же цели
4. Их свойство Visible связываешь с нужным (по порядку) значением тэга.

Результат:
При открытии Screen'а функция Animate начинает автоматически изменять значение тэга в указанных пределах и с заданной частотой. Если картинки геометрически совмещены, то будет возникать иллюзия вращения объекта.

Надеюсь, что доступно изложил...

Успехов!
Re: простой вопрос
Alex Legornev; 17.11.04

Спасибо большое, сейчас поробую.

<


text

Просьба к администраторам сайта
Игорь; 17.2.04

Выложите, пожалуйста, в раздел "HMI/Документация" руководство по кнопочным панелям PP17-II (на русском или английском).

Заранее благодарен...
Re: Просьба к администраторам сайта
Михайлин Сергей; 17.2.04

На наш сайт мы стараемся выкладывать только русскую документацию, а по кнопочным панелям, увы, переводов пока нет. Поэтому, Вы можете скачать английскую доку по указанной ссылке с немецкого сайта поддержки.

См. Ссылка на доку

Re: Просьба к администраторам сайта
Игорь; 17.2.04

Спасибо за совет, Сергей.

Я знал, что могу скачать интересующую иеня документацию с немецкого сайта, но... Из-за наших сисадминов я не могу зайти на этот сайт (что-то они сотворили, и сами не могут понять - что).
Поэтому я и обратился к вам. Если не трудно - сбросьте мне, пожалуйста, на "мыло" это руководство (частями не более 1,2Мб - опять же ограничение наших системщиков). Или выложите у себя на сайте.

Best regards,
Игорь.<


text

Процесс CCRtsLoader - утечка памяти
Ruslan; 30.8.04

При запуске проекта (WinCC 6.0) процесс CCRtsLoader.exe все время увеличивает потребление памяти. Подскажите в чем причина и где искать утечку.


text

Прошу дать рекомендации по проекту
Малкон; 9.11.04

Добрый день.

Прошу вас дать нам рекомендации по программному обеспечению в
следующем проекте.

Существует 13 литейных установок.

С каждой установки снимаются около 10 сигналов, которые затем попадают
на S7-400 контроллеры.
Контроллеры по PROFIBUS подключены к серверу.

На этой же линии PROFIBUS находяться 13 панелей (промышленные
компьютеры)

<ПК> <ПК> <ПК> <ИВЦ Архивный сервер>
| | | |
+-----+-----+----------+
|
|Ethernet TCP
|
{Сервер}
|
|profibus
|
+--------+-------+
| | |
+<П.к.> +<П.к.> +<Пром.комп.>
| | |
0 0 0 S7-400
S7-400 S7-400

1 2 3 4 ... 13

На сервере {Сервер} установлен WinCC 6 Server
На <Пром.комп.> - установлены соответственно WinCC Client

Могут ли WinCC Client - читать информацию из контроллеров либо это
может делать лишь WinCC 6 Server ?

Схема работы следующая:
Сервер получает данные от S7-400, хранит их, дополнительно пишет эти
данные в <ИВЦ Архивный сервер>, и отображает часть их на
<Пром.комп.>.

Паралельно этому <ПК> из обычной Ethernet сети (например экспресс
лаборатория) делая различные анализы должна писать данные в туже базу
к {Серверу}, который эти данные тоже хранит у себя, пишет в
<ИВЦ Архивный сервер>, и выводит часть данных на экраны <Пром.комп.>.

Вопрос1:
На чем должен быть выполнен интерфейс <ПК>, если требуется:
1. видеть данные в табличном виде
2. Иметь возможность выделять отдельные ячейки/столбцы/строки цветами,
вставлять картинки, делать так, чтобы ячейчки столбца являлись выпадающим
списком, с возможностью вводить значение не из списка, а новое.

Вопрос2:
Нужно ли покупать дополнительные компоненты для WinCC, чтобы хранить
данные в специфичной структуре. (несколько связанных таблиц) причем
некоторые данные хранить не в своей базе а на отдельном сервере.
Re: Прошу дать рекомендации по проекту
Лев Шерешевский; 9.11.04

Очень рекомендую Вам обсудить работоспособность нарисованной Вами структуры с опытными специалистами. Даже если в этом форуме Вам дадут абсолютно верные ответы на поставленные вопросы, останется множество нюансов, не обратив внимания на которые заранее, Вы получите множество проблем в дальнейшем.

Re: Прошу дать рекомендации по проекту
Малкон; 10.11.04

Тут шрифт не моноширный, ..

а картинку не вставить...<


text

ПРОШУ СРОЧНО-СВЯЗЬ WINCC6.0 С МОДЕМОМ GSM,WAP
ALEX; 20.8.04

Люди добрые помогите срочно как возможно установить связь с WINCC6.0 и модемом GSM, для отправки сообщений с WINCC6.0 на мобильный телефон. Или способ через Internet на мобилку. Пожалуйста подскажите какой-то способ.

Re: ПРОШУ СРОЧНО-СВЯЗЬ WINCC6.0 С МОДЕМОМ GSM,WAP
Михайлин Сергей; 20.8.04

Есть такой Addon к PCS7 правда, но я думаю что и к WinCC его можно заточить, называется FunkServer Pro. Он эо все может. Инфу смотрите в каталоге AddOns для PCS7.

Re: ПРОШУ СРОЧНО-СВЯЗЬ WINCC6.0 С МОДЕМОМ GSM,WAP
Л. Шерешевский; 20.8.04

На сайте Siemens (см. ссылку) заявлено, что этот addon работает с чистой WinCC, вовсе без PCS7.

См. FunkServerPro

Re: ПРОШУ СРОЧНО-СВЯЗЬ WINCC6.0 С МОДЕМОМ GSM,WAP
Nick Gashevsky; 21.8.04

С помощью скриптов на С можно вызвать функции API, которыми открыть COM порт и подключиться к модему. Для простых сообщений должно сработать (по кр. мере SMS передать можно) Посмотрите пример TTY из MSDN.


text

Пунктирная линия в WinCC 6 SP2
shurik; 28.6.04

Установлена WinCC 6 SP2.Проблема в том,что не получается нарисовать простую линию пунктиром при толщине 1.А еще цвет линии учитывается,а вот изменить цвет фона линии не получается.Одно исправляют -другое портят!!!!!

Re: Пунктирная линия в WinCC 6 SP2
Игорь Одесса; 29.6.04

В WinCC 6.0 Sp2,у меня на линии св-во FlashingLineActive, что в Yes, что в No абсалютно без разницы, так что подозреваю, что линию таки, немчики обгадили в SP2.(Не было патча SP2 все работало)

Re: Пунктирная линия в WinCC 6 SP2
shurik; 30.6.04

а как этот факт донести до разработчиков ? Может г-н Юрченко поможет

Re: Пунктирная линия в WinCC 6 SP2
Юрченко Владимир; 30.6.04

Получил сегодня HotFix2 для WinCC 6SP2,

где эта проблема решена. Я его выложил в виде 3 файлов:
http://www.automation-drives.ru/as/db/zwqjvl/cd_v6sp2HF2.part1.rar
http://www.automation-drives.ru/as/db/zwqjvl/cd_v6sp2HF2.part2.rar
http://www.automation-drives.ru/as/db/zwqjvl/cd_v6sp2HF2.part3.rar
Re: Пунктирная линия в WinCC 6 SP2
shurik; 1.7.04

Спасибо,очень оперативно помогли!!!!


text

Работа под ХР?
Alex; 16.3.04

У меня ХР , что нужно сделать что бы

WinCC 5.1 SP1 можно было установить .
Может какая заплатка есть?
Re: Работа под ХР?
Роман Абзаев; 16.3.04

Можете поступить двумя путями:

1.Снести Windows XP и вместо неё поставить Windows 2000 Pro SP4
2.Приобрести апгрейд 6AV63811A-x-060AX4 вместо х поставьте А для RT или В для CS.

посмотрите так же ID 1139080 на A&D CSS<


text

Работа с WinCC SQL
Роман ; 15.6.04

Подскажите, где можно найти информацию о работе с WinCC SQL сервером.

Re: Работа с WinCC SQL
Nick Gashevsky; 16.6.04

В WinCC6.0 MS SQL стандартный, доступ через WinCC OleDB Provider. Полная документация есть в WinCC ODK.


text

Работа с контроллером через Profibus из Windows
Fanat; 14.8.04

Недавно наткнулся в хелпах для СиматикНет на описание функций и библиотек для считывания данных по Профибасу с контроллера средствами Виндовс, т.е. на одном из ЯВУ (C++) пишешь программу и спокойно считываешь данные. Необходимо лишь установить СиматикНет.

Но столкнулся с многими проблемами, например, функции никак не хотели работать, а выдавали неведомые ошибки. В итоге мне удалось лишь вызывать функцию, которая определяла доступные подключения, создавала нужные, но сам процесс считывания так и остался глючным.
Если у кого есть информация по этому поводу, поделитесь пожалуйста!!!
Спасибо, что выслушали.
Алексей, "Невисс-комплекс" г. Санкт-Петербург
Re: Работа с контроллером через Profibus из Windows
Макс Прилепский; 16.8.04

Гораздо проще было бы с помощью Simatic Net получать данные из канала PROFIBUS в Simatic OPC Server, находящийся на той же станции, что и PROFIBUS CP, к которому затем подключаться в качестве OPC-клиента для доступа к тегам.

Re: Работа с контроллером через Profibus из Windows
Fanat; 16.8.04

Этот вариант работает и неплохо, но хотелось бы знать и подобный вариант работы с симатиком...

Re: Работа с контроллером через Profibus из Windows
Чистяков Дмитрий ОАО СеверСталь; 16.8.04

А для этой цели можно воспользоваться SAPI-S7. Это API интерфейс Windows`а для вызова функций связи и управления оной. Но для работы это интерфейса необходимо установить SIMATIC NET.

Описание
http://www4.ad.siemens.de/WW/news/en/1652760
И пример
http://www4.ad.siemens.de/WW/news/en/7887913
Re: Работа с контроллером через Profibus из Windows
Fanat; 16.8.04

Вот я с и работал с этими SAPI, но почему-то связь не пошла...

Если есть у кого опыт общения с набором данных функций, то буду очень признателен за помощь...
Сам помогу если чем смогу...
Если есть русская документация, то буду рад :-)
Спасибо всем кто откликнулся
Re: Работа с контроллером через Profibus из Windows
Чистяков Дмитрий ОАО СеверСталь; 16.8.04

Дык пример то скачай. ;-)


text

Работа с модемом под WINCC
Константин; 19.5.04

Доброе время суток!

Кто из вас имел опыт с subj'ем?
Есть ли какие-нибудь подводные камни и тонкости настройки/программирования?
Какие протоколы/модемы лучше использовать для связи удаленного контроллера с компьютером, который будет отображать полученные от контроллера данные?<


text

Размер шрифта для 1280х1024
Евгений Трунов; 2.6.04

А такой вот эстетический вопрос. Кто какой шрифт использует для разрешения 1280х1024? В меньших разрешениях вопрос не стоял - был чудесный Tahoma 8 pt, который хорошо смотрелся, был удобочитаем и красив, имел четкие буквы и цифры, был привычен пользователю Windows. Увы, для разрешения 1280х1024 он слишком мал. А его старшие братья (9 pt, 10 pt) выглядят гораздо хуже. Поделитесь опытом, кто какой шрифт использует в таком разрешении?

Re: Размер шрифта для 1280х1024
Владимир; 3.6.04

мы о таких разрешениях на рабочих станциях и не помышляем.

1024х768 пока стандарт.
Давно ли Вы на 1280х1024 ?
Re: Размер шрифта для 1280х1024
Евгений Трунов; 3.6.04

Нет, недавно. К сожалению, с пришествием ЖК-мониторов выбирать не приходится - они могут нормально показывать только в одном разрешении, и для моделей 17" и выше - 1280х1024 являются стандартом. Меня самого вполне устраивало 1024х768.


text

Разные языки в WinCC
Богдан; 20.5.04

Переключатся на разные языки в WinCC

я могу с помощью функции
SetLanguage(0x0409)- англ
SetLanguage(0x0407)- нем
SetLanguage(0x0422)- укр и т.д.

Есть ли какая-то глобальная переменная
для чтения текущего значения установленного языка ?
Re: Разные языки в WinCC
Маслов Дмитрий; 20.5.04

DWORD GetLanguage();


text

Разные языки в WinCC
Богдан; 20.5.04

Переключатся на разные языки в WinCC

я могу с помощью функции
SetLanguage(0x0409)- англ
SetLanguage(0x0407)- нем
SetLanguage(0x0422)- укр и т.д.

Есть ли какая-то глобальная переменная
для чтения текущего значения установленного языка ?
Re: Разные языки в WinCC
Михайлин Сергей; 21.5.04

Конечно есть! Так и называется @CurrentLanguage Она системная и внутренняя.


text

Распиновка кабеля для программирования OP17
Павел; 3.3.04

Собираю кабель для программирования панели. В описании к OP17 нашел распиновку 15-ти пиновой части. В описании ОП-3 нашел 9-ти пиновую часть. Спаял. Не работает. Где косяк?

Получилось:
OP(15)-PC(9)

RxD 3-2
TxD 4-3
CTS 5-8
RTS 10-7
GND 12-5
GND 15-5
4=6 (DTR замкнут на DSR на стороне PC).

Буду весьма признателен. Пол-дня бьюсь.
Re: Распиновка кабеля для программирования OP17
Юрченко Владимир; 3.3.04

9Pin 15Pin

2 - 4
3 - 3
5 - 12
7=8
1=4=6
Re: Распиновка кабеля для программирования OP17
Павел; 4.3.04

Спасибо, все работает.


text

Редактирование Password, ProTool/Pro для PC
Darwin; 1.7.04

Как осуществить логинизацию юзера перед доступом к кнопке под паролем?


text

Режим разработки в WinCC
Эдуард; 19.7.04

Здравствуйте!

Скажите, пожалуйста, как в WinCC (5.1/6.0) сделать так, чтобы в режиме разработки CS при щелчке мышью на объекте появлялось мое первое окно, а в режиме исполнения RT при щелчке мышью на объекте появлялось уже другое окно. При двойном клике мышкой на объекте в режиме разработки появляется окно свойств. Так вот мне нужно, чтобы в режиме разработки при двойном клике левой кнопкой мышки появлялось окно свойств, при двойном клике, допустим, правой кнопкой мыши появлялось мое окно, а в режиме исполнения при двойном клике левой кнопкой мыши появлялось уже другое мое окно
Re: Режим разработки в WinCC
Владимир; 19.7.04

Летели два кродила. Один на юг, а другой зеленый ...

Re: Режим разработки в WinCC
VGenn; 21.7.04

Следует использовать редактор VBA. Читайте основную документацию по V6.0


text

Резервирование двух рабочих станций
Дима; 28.2.04

Здравствуйте.

Вопрос такой. Кто нибудь делал резервирование двух рабочих станций, для синхронизации архивав? Каким способом лучше воспользоваться?
Спосибо!<


text

Русификатор WinCC 6 SP1
Андрей; 18.11.04

Может кто подскажет, при деинсталяции пакета руссификации произошла ошибка, WinCC был удален раньше, и теперь не могу переустановить руссификатор, говорит, что он у меня уже стоит. Чистил реестр утилитами, но не помогло.

Re: Русификатор WinCC 6 SP1
Л. Шерешевский; 19.11.04

Удалите ключ реестра

HKEY_LOCAL_MACHINE\SOFTWARE\SMS\SIMATIC WinCC Russian UI и переустановите русификатор.

Деинсталляцию русификатора следует производить перед удалением WinCC.
См. Центр компетенции WinCC


text

Русификация WebNavigator6
Евгений Горлов, Северсталь; 31.8.04

Где бы её взять ?

Re: Русификация WebNavigator6
Л. Шерешевский; 1.9.04

Ресурсы, русифицирующие основные компоненты WebNavigator6, содержатся в русификаторе WinCC 6. Если что-то русифицировано неправильно или не переведены какие-то принципиально важные фрагменты, направьте запрос в московское представительство Siemens или непосредственно нам в центр компетенции WinCC.

См. www.wincc.ru


text

Русификация WinCC6 SP2
shurik; 5.7.04

А когда выйдет и как скачать русификатор для SP2?

Re: Русификация WinCC6 SP2
Маслов Дмитрий; 6.7.04

В настоящее время ведутся руботы по русификации WinCC6/SP2. Когда они будут завершены, русификатор можно будет получить в любом представительстве Siemens в России.

См. http://www.wincc.ru

Re: Русификация WinCC6 SP2
shurik; 2.8.04

ну скиньте таки на мыло пакет русификации !!!!! ,ну негде мне его взять поблизости

Re: Русификация WinCC6 SP2
Маслов Дмитрий; 3.8.04

Русификатор для WinCC6/SP2 завершен и передан в Московский Siemens. Звоните им и договаривайтесь, как получить - по мылу или еще каким-нибудь способом.

Re: Русификация WinCC6 SP2
Юрченко Владимир; 3.8.04

В ближайшее время руссификатор будет доступен с нашего сайта после заполнения регистрационной формы. Выход на форму будет на странице WinCC:

http://www.automation-drives.ru/as/products/simatic_hmi/wincc/index.php
Re: Русификация WinCC6 SP2
Вадим Печёрских; 6.8.04

А зачем она нужна? Руссификация эта?

Re: Русификация WinCC6 SP2
Л. Шерешевский; 6.8.04

Возможно, на Ваш вопрос частично ответит вводная часть статьи о локализации ПО (см. ссылку). Она немного устарела, но в целом все еще актуальна.

См. Статья о локализации ПО

Re: Русификация WinCC6 SP2
Вадим Печёрских; 9.8.04

WinCC является иструментом для создания подсистем визуализаци АСУ. Если система АСУ используется в России, то она должна быть локализована. Но это не говорит о необходимости локализации WinCC.

Re: Русификация WinCC6 SP2
Л. Шерешевский; 9.8.04

Не забывайте, что WinCC - это СS+RT. Не локализовав RT получить полностью русифицированный проект в подавляющем большинстве случаев нельзя.

Кроме того, если следовать Вашей логике, то MS Office - это инструмент для создания документов, а русские документы можно создавать и в английской версии пакета, дополненной специализированными языковыми модулями. Тем не менее, большинство использует русскую версию пакета, вне зависимости от уровня знания английского языка.

В действительности я сам и мои коллеги в большинстве случаев используем оригинальные англоязычные версии продуктов, но при этом мы не экстраполируем собственные предпочтения и привычки на конечных пользователей. А конечными пользователями WinCC могут быть не только ИТ-специалисты, но и технологи, не всегда владеющие иностранными языками.

Кстати, если бы WinCC штатно поддерживала только японский и китайский языки, Вы бы столь же свободно работали с ней, как и сейчас?
Re: Русификация WinCC6 SP2
Чистяков Дмитрий ОАО СеверСталь; 11.8.04

Ни японский, ни китайский языки не имеют статуса международного. ;-)

Эту нишу пока занимает английский.
MS Office это не удачный пример, т.к. это пользовательский продукт, который ориентирован на _пользователя_.
WinCC же это продукт разработчика, а не пользователя. Т.е. здесь уместнее сравнивать WinCC и среду программирования, например, MS Visual C++, Borland и т.д. Много ли этих продуктов локализовано? Сейчас вот MS решилась локализовать на локализацию Visual Basic`а, так и то в качестве эксперимента.
Моё мнение такого: богу-богово, кесарю-кесарево. Т.е. технологу в проектировании WinCC делать не чего - его задача следить за параметрами системы и выполнять свои обязанности по технологии, а не картинки дорисовывать, те что в процессе проектирования были не доведены до ума.
Re: Русификация WinCC6 SP2
shurik; 11.8.04

мое мнение-русификация менюшек вообще лишнее,нужны только диалоги с оператором в RT и системные сообщения. И ,кстати,попутно вопрос-почему в график дизайнере при вставке объекта его имя отображается по русски но криво (вместо ЛИНИЯ - ИНИ1,ОКРУЖНОСТЬ-ОКУНОЬ)

Re: Русификация WinCC6 SP2
Л. Шерешевский; 11.8.04

С Дмитрием Чистяковым согласен по всем пунктам. Однако все равно до конца не могу понять почему наличие _опционального_ пакета русификации воспринимается так неоднозначно участниками форума. Никто же никого насильно не заставляет работать в русской среде.

Shurik-у:
1. Вы вполне можете в среде разработки оставить английский язык, используя русский только в среде исполнения. Тогда поведение системы будет в точности такое, как Вы хотите.
2. Это "особенность" графического дизайнера. Он вырезает все спецсимволы из названий объектов. Проблема заключается в том, что с русской кодовой страницей многие обычные символы кириллицы попадают на те места, где у европейцев располагаются спецсимволы. Немецкие коллеги знают об этой беде, но делать исправления не спешат.
Re: Установка WinCC6 SP2
Смирнов Дмитрий ; 12.8.04

Как установить SP2 на русский Win2000?

Он просит fix, который нужно получить каким то окольным способом на сайте microsoft... Описано в " Microsoft Knowledge Base Article - 828748".
Может у кого уже есть такой?
Re: Русификация WinCC6 SP2
Л. Шерешевский; 12.8.04

См. ссылку на обсуждение этой темы.

От себя добавлю, что это не лучший вариант решения проблемы. Маловероятно, что Siemens чисто из спортивного интереса требует установить данный hotfix. Наверное, он все же для чего-то нужен. В идеале WinCC надо ставить на оригинальную версию Windows, чтобы потом не терзаться сомнениями.
См. WinCC 6.0 SP2 с Win2k rus

Re: Русификация WinCC6 SP2
Nick Gashevsky; 12.8.04

Windows c MUI подойдет лучше всего.


text

Руссификация WinCC
Дмитрий; 24.8.04

Прошу консультации.

Неудается установить руссификатор для
WinCC SP2. Просит установить Hotfix 2.
Где его взять.
Установлено WinXP SP1 ENG, WinCC 6.0 SP2.
Re: Руссификация WinCC
Юрченко Владимир; 24.8.04

Вы можете скачать HotFix2 для WinCC v.6.0SP2 с нашего сайта по ссылкам (3 файла rar) - http://www.automation-drives.ru/as/db/zwqjvl/cd_v6sp2HF2.part1.rar ;

http://www.automation-drives.ru/as/db/zwqjvl/cd_v6sp2HF2.part2.rar ;
http://www.automation-drives.ru/as/db/zwqjvl/cd_v6sp2HF2.part3.rar<


text

Русский шрифт (WinCC)
Bairon; 12.2.03

Дело в следущем: Упала ОСь. Поднял. востановил все настройки. Запускаю старый проект. Надписи на русском по абракадбрски. Перерыл все что мог. Недоумеваю!!!

Re: Русский шрифт (WinCC)
Константин; 13.2.03

в проекте: Свойства компьютера> Parameters> Language Setting at Run Time> РУССКИЙ

Re: Русский шрифт (WinCC)
Bairon; 13.2.03

>в проекте: Свойства компьютера> >Parameters> Language Setting at Run >Time> РУССКИЙ

пробовал, но тогда выдет вместо абракадбркого текста знаки вопроса(((
Re: Русский шрифт (WinCC)
Иван Данилушкин; 13.2.03

У нас знаки вопроса появлялись при открытии русскоязычного проекта под английской версией Windows, может, с установкой Винды перемудрили?

Re: Русский шрифт (WinCC)
Игорь К'; 14.2.03

А может попробовать открыть библиотеку текстов (дословный перевод ;-)), и посмотреть на каком языке сделаны надписи, по умолчанию вдруг аглицкий и все тексты в нем по русски (встречалось сие).

Re: Русский шрифт (WinCC)
Bairon; 14.2.03

>У нас знаки вопроса появлялись при >открытии русскоязычного проекта под >английской версией Windows

как это?...русский проект под русским винсиси? и
в проекте: Свойства компьютера> >Parameters> Language Setting at Run >Time> Russian - знаки вопроса
Свойства компьютера> >Parameters> Language Setting at Run >Time> English - "чушь"...
>может, с установкой Винды перемудрили?
а где мудрить?... ставили как ставилось))) эт ща копать начали.

Re: Русский шрифт (WinCC)
Чистяков Дмитрий ОАО "СеверСталь"; 16.2.03

Если определился с языком в проекте. А он у вас английский. Это видно из того, что на русском у вас появились знаки вопроса.

То выполните стандартное решение по замене кодировки в реестре с 1250 и 1252 на 1251.
Сделать можно это, например, при помощи файла __.reg содержимое которого выглядит вот так

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontMapper]
"DEFAULT"=dword:000000cc

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Nls\CodePage]
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Nls\CodePage]
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Control\Nls\CodePage]
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"

Re: Русский шрифт (WinCC)
Iva; 17.2.03

Насчёт замены кодировки в реестре - не слабо...........

А я парился как дурак - делал замену шрифтов надписей с Arial на Arial Cyr
Re: Русский шрифт (WinCC)
Bairon; 18.2.03

Замена кодировки в реестре - оно кому как. По мне результата - ноль. Сдается мне надо сажать человека и пусть правит все 250 картинок с переключением.((( Грустно, долго и люди так не работают.

Re: Русский шрифт (WinCC)
Чистяков Дмитрий ОАО "СеверСталь"; 18.2.03

Bairon

Проверьте какой шрифт использовался у вас в проекте. Как вариант, возможно, типа pragmatika. Это шрифты, которые используют специалисты Siemens`а в своих проектах. Но вот кодировка там хитрая и потому на стандартных русских шрифтах показывает крякозяблики.
Re: Русский шрифт (WinCC)
Bairon; 18.2.03

шрифт нормальный - arial называется...

Re: Русский шрифт (WinCC)
Чистяков Дмитрий ОАО "СеверСталь"; 19.2.03

Да, забыл Вас спросить - какая у Вас ОСь?

Указанный мною файл подойдёт только для ветки NT/2k/XP. Для 9x файл немного другой.

И ещё. Посмотрите в редакторе реестра сколько наборов параметров на Вашем компьютере.
ControlSet00x
В представленном мною файле их всего три. Если у Вас их больше, то необходимо войти в каждый (4,5 и т.д.) и справить те же параметры.

Вообще же, с этой проблемой часто сталкиваются все пользователи буржуйских программ. Подвержен этому даже MS Office. ;-)
А вся проблема в том, что в России имеется 14 стандартных раскладок кодовых страниц. И буржуи просто понять не могут - какой же кодировкой воспользоваться. :-)

Re: Русский шрифт (WinCC)
kip; 12.1.04

Подскажите, что нужно поменять в реестре для Win98:

В реестре нашел ветку
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]
Замнил 1250,1251,1252 на 1251 - не помогло
Re: Русский шрифт (WinCC)
Lexus; 18.6.04

У меня тоже прикол такой: на одной машине алармы русские не выводятся! На дву других машинах всё отлично!!! Кодировку в реестре везде менял! Язык стоит английский, текст русский...

См. http://www.infocom.com

Re: Русский шрифт (WinCC)
Александр ОАО"Северсталь"; 28.6.04

И у меня точно такая же проблема на одном компе русский шрифт в алармах а на другом непонятно какой страны

Re: Русский шрифт (WinCC)
Кобелев Павел; 29.6.04

Пользуюсь следующим файлом для правки реестра:

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontMapper]
"DEFAULT"=dword:000000cc

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Nls\CodePage]
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Nls\CodePage]
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Control\Nls\CodePage]
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage]
"1250"="c_1251.nls"
"1251"="c_1251.nls"
"1252"="c_1251.nls"

Re: Русский шрифт (WinCC)
Кобелев Павел; 29.6.04

Прошу прощения за повтор. Только сейчас рассмотрел

Re: Русский шрифт (WinCC)
Борис; 24.8.04

У меня проблема. После того, как изменил 1250 и т.д. на 1251 - WinXP глюкнул. После перезагрузки винда не грузится. Пишет что не можен найти файл А_1251.nls

Кто нибудь сталкивался с чем либо подобным?<


text

Русский язык в MS SQL SERVER 2000 (WinCC v.6)
Project_CS; 29.3.04

КОЛЛЕГИ! Подскажите, в чем проблема?

При записи в БД информации на РУССКОМ языке и последующем просмотре данных компонент UserArchive, а также менеджер MS SQL Server'а выдают информацию в некорректной кодировке (??????). Настройки региональных опций Windows в порядке, реестр(NLS\Languages\...) тоже. ЧТО ДЕЛАТЬ?

Система: Win2000 English, WinCC v.6 (PCS7 V 6.0+SP1+HF1).
Re: Русский язык в MS SQL SERVER 2000 (WinCC v.6)
Л. Шерешевский; 30.3.04

Проблем с отображением русских текстов в пользовательских архивах при правильных региональных настройках Windows быть не должно.

А как Вы производите запись данных? Может быть стоит проверить, корректно ли они заносятся в базу?
Вдогонку
Л. Шерешевский; 31.3.04

Проверьте также, что в ветке реестра

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage ключ "1252" = "c_1251.nls"<


text

Самое начало
Andrey; 2.10.04

Добрый день! Подскажите, как начинать проект для связки step7+wincc6.Где настроить базу даннных хранения проекта (а то step7 хранит ее в dbf, а wincc на MSSQL).Имеется ли возможность отладки программы (самий блоков и верхнего уровня - wincc) без контроллеров?

Если я правильно понимаю процесс должет представлять следующую последовательность действий:
1.Набираем аппаратуру в проекте step7
2.создаем таблицу символов проекта в step7
3.кодируем блоки, т.е.пишем программу управления процессом
4.Переносим тэги в wincc (кстати как?)
5.рисуем экраны мнемосхем
6.привязываем компоненты мнемосхемы к тегам
7.пишем обработчики (скрипты) для управления объектами и модификации выходных тегов
8.Эмуляция процесса (какими средствами?)

Ну и еще один вопросик - если не сложно - предположим возникает предаварийная ситуация - низкий уровень в емкости, необходимо из контроллера в wincc передать это сообщение.Как правильно это сделать?Учитывая,наверное,необходимость создания очереди таких сообщений?
Может за этим будет следить сам wincc, а контроллер будет только отрабатывать блокировки для данной ситуации?
Заранее ОГРОМНАЯ блгодарность за ответы!
Re: Самое начало
Миша; 2.10.04

Ну для симуляции процесса существует ропграмма PLCSim (она позволяет работать ваабще без контроллера)

передача аварийных сообщений может быть организована по инициативе контроллера или битовым способом.

Во втором случае есть биты ошибок в PLC а в WinCC используется Alarm Loggin
Re: Самое начало
Nick Gashevsky; 4.10.04

Возможно Вам может подойти Simatic PCS6 как более интегрированная среда (Step+WinCC).

Re: Самое начало
~BurAn~; 4.10.04

>>4.Переносим тэги в wincc (кстати как?)

Я испoльзую для этого Excel. В Addition software на диске с WinCC есть Configuration Tools. После установки в меню Excel появляется новый пункт (WinCC). Очень удобно!!! Хотя можно и напрямую из WinCC читать тэги в Step7.
>>8.Эмуляция процесса (какими средствами?)

Я вообще не симулирую весь процесс. А делау так: создал, например 1 мотор. Привязал к нему 3 тэга (1 для статуса, 2-й для аларма, 3-й для "Мануал/Ауто"). Проверил анимацию спомощью внутренних тэгов и, если все ок, то копирую этот мотор по всему проэкту, не забывая применять Link -> Tag connection для привязки правильного тэга...<


text

Сбои при отображении кривых
Human; 27.1.04

Приветсвую!

Есть проблемка в проекте под WinCC v6.0 SP1 + HF3, замечен следующий глюк: по открытии окна с трендом аналогового параметра (данные из архива TagLogging Fast) на оси времени устанавливается дата 06.29.00, при этом графика нет, при повторном открытии всё нормально. Может кто знает, в чём тут дело и откуда берётся эта дата?
P.S. Проект создан месяц назад.
Re: Сбои при отображении кривых
Roman; 27.1.04

Попробуй убить старую базу RT и создай новую, как это сделать было описано в форуме 2003 года. Удачи.


text

Свойтсва объектов
Соснина Ирина; 12.3.04

Подскажите, пожалуйста. Можно ли, находясь в одном PDL файле, читать значения свойств объектов других PDL файлов общего проекта? У меня не получается, может я чтото не так делаю?

Re: Свойства объектов
Лев Шерешевский; 14.3.04

Можно, если кадр, значения объектов которого Вы считываете, в данный момент активен, т.е. отображается на экране. Иначе Вам будет выдаваться ошибка "picture not selected"


text

Связь PC с 6ю контроллерами по MPI. ProTool
Darwin; 27.7.04

Во время запуска проекта, написанного на ProTool для PC (CP5511 комм.проц) все время не устанавливается связь с одним из 6и PLC S7-3XX. При этом не устанавливается чаще с одним из них, но иногда не устанавливается с другим.

При подключении этого же проекта к сети через TSadapter все нормально.
1. Было: PLC не сконф. MPI, связь не устанавливалась с одним из 6 PLC.
2. Сделал: объединил все PLC и PC в одном проекте, сконфигурировал сеть MPI (но мне кажется это не влияет, т.к. SDB не изменился у одного из PLC, обладающего только MPI интерфейсом). Результата не дало. По прежнему связь не устанавливается с одним из PLC.

Есть подсказки? <


text

Связь WinCC c контроллером
Николай; 19.8.04

Связь WinCC c контроллером S7 CPU 314C-2DP через СР342-5.Протокол связи S7 Profibus,подключение по CP_L2_1.Карта на WinCC станции СР5613 сконфигурирована при диаг.ОК. При диаг. свизи между WinCC станцией и контроллером ошибка "Диагнозтика не может обработать модуль с № 6ES7 314-6CF01-0AB0 NCM S7-Diagnose 1425:4115". Указанный № это № СPU.

Re: Связь WinCC c контроллером
Чистяков Дмитрий ОАО СеверСталь; 19.8.04

1. A в WinCC указал, что связь будешь осуществлять через CP_L2_1?

Tag Management -> Profibus -> правая мышка, "System Parameter" -> закладка "Unit"
2. В параметрах связи с контроллером какой слот указал (Slot Number)?
Он должен быть таким же номером в котором стоит CPU в конфигурации. Для серии контроллеров S7-300 это значение обычно 2.

Re: Связь WinCC c контроллером
Николай; 19.8.04

Дмитрий,спасибо за отклик!Сделал именно так ! Но пока ошибка.


text

Связь WinCC и Oracle
Роман; 18.11.04

Подскажите, где достать описание по программному обеспечению для WinCC - пакет Индастриал Дельта Бридж для связи WinCC и Oracle....


text

Связь WinCC и Oracle
Николай; 18.11.04

Подскажите, как связать тэги wincc и данные в базе Oracle...

Re: Связь WinCC и Oracle
Юрченко Владимир; 18.11.04

Это можно с помощью опции WinCC IndustrialDataBridge. Смотрите краткое описание на русском в http://www.automation-drives.ru/as/download/ascat/simatic_hmi/wincc/10_WinCC_r.pdf и на английском:

См. http://www.ad.siemens.de/hmi/html_76/products/software/wincc_optionen/industrial-data-bridge.htm


text

Связь WinCC и СР343-5
Василий; 26.4.04

Не могу установить связь между WinCC c CP-5613 и CPU315-2DP с СР343-5.

Для СР343-5 установлено: Profibus, 1.5Mbps, Standart.
В NetPro вставил станцию PG/PC с соответствующим адресом и объединил в сеть с Ср343-5.
На РС в set PG/PC установил точку входа CP_L2_1 на CP-5613(PROFIBUS) и соответствующие параметры сети.
При тестировании видит и себя и СР343-5.
В WinCC установил драйвер SIMATIC S7 Protocol Suite.
Во вкладке Profibus установил новое подключение, где указал адрес СР343-5 в сети и слот.
После запуска RT соединение отсутствует.
В чем подвох? Или нужно еще что-то настроить?
Хотя на встроенный в CPU DP интерфейс при подключении к той же сети соединение происходит нормально.

Re: Связь WinCC и СР343-5
Маслов Дмитрий; 26.4.04

В свойствах соединения в WinCC номер слота какой указали? Там надо указывать номер слота CPU, а не CP. Т.е. в Вашем случае это должна быть двойка, вне зависимости от того, к какому интерфейсу контроллера Вы подключаетесь.

И, кстати, в Net Pro не обязательно вставлять станцию PG/PC. Достаточно сконфигурить CP345-5 в Step'e (и загрузить в контроллер), затем те же параметры поставить для CP5613 в Setting PG/PC interface, настроить точку входа CP_L2_1 и настроить соединение Profibus в WinCC. И еще. Щелкните правой кнопкой мыши на вкладке Profibus в WinCC, выберете System Parameter. Перейдите во вкладку Unit. Убедитесь, что в поле выбора Logical device name стоит CP_L2_1.
Re: Связь WinCC и СР343-5
Василий; 26.4.04

Все получилось.Спасибо, Дмитрий.

Ошибка была в номере слота.
Re: Связь WinCC и СР343-5
Василий; 26.4.04

Все получилось.Спасибо, Дмитрий.

Ошибка была в номере слота.<


text

Связь WinCC с DP-Slave через CP5611
Кустов К.Н.; 14.9.04

Уважаемые господа!

Есть задача связать WinCC 5.1 с DP-Slave устройством. Вопросы:
1. Подойдет ли для этих целей CP5611 или его будет мало?
2. Попытался сконфигурировать подобную связь в WinCC и обнаружил, что она дает сделать это только для CP5412(A2) (добавил новый PB DP Channel, а там четыре карты CP5412). Что делать, так и не понял.

Подскажите, кто может, пожалуйста. Заранее благодарю.<


text

Связь WinCC с спектроанализатором
Михаил; 20.4.04

Подскажите, как можно средствами WinCC 6.0 организовать чтение данных по TCP/IP (необходимо читать данные прямо с порта)

Re: Связь WinCC с спектроанализатором
Diana; 20.4.04

А никак! Это ВинСиСи читает данные через тэги, доступ к которым определяется в PG/PC. А вот если к этому спиртоанализатору есть OPC, тогда можно побаловаться...

Re: Связь WinCC с спектроанализатором
Маслов Дмитрий; 20.4.04

Ну почему же никак?

Можно написать программу, которая будет читать данные из любого внешнего источника (порт, файл и др.) и через ODK записывать эти данные во внутренние теги WinCC. У нас имеется такой опыт.
Re: Связь WinCC с спектроанализатором
Роман; 21.4.04

Можно попробовать по другому. Есть ActivX в VBA 6.0 MSComm 6.0 для работы с СОМ портом, поищите в этом форуме, я уже эту тему поднимал. Нужно установить приблуду от VBA, вставить ее в экранную форму и посредством С++ управляя свойствами данного объекта, можно делать запрос/ответ через порт.


text

СВЯЗЬ WINCC6.0 С МОДЕМОМ...
ALEX; 5.11.04

Есть ли какой нибудь способ установить связь с модемом ,подключеный в порт СОМ1. Модем может принимать сигналы в ASCII формате. Т.е. необходимо отправлять SMS сообщения на модем.

Пожалуйста подайте информацию или вариант.
Re: СВЯЗЬ WINCC6.0 С МОДЕМОМ...
Маслов Дмитрий; 6.11.04

Лучше всего написать библиотеку DLL, которая будет работать с модемом, а из WinCC вызывать ее функции.

См. http://www.wincc.ru


text

Связь двух WinCC серверов
Коростелёв; 24.11.03

Здравствуйте!

Необходимо передавать данные из одного WinCC сервера в другой. Каким способом это можно организовать (например OPC, ODBC? Сервера возможно будут находиться в разных подсетях, есть ли какие-нибудь ограничения, связанные с этим?

Заранее спасибо за ответ.
Re: Связь двух WinCC серверов
Юрченко Владимир; 26.11.03

Проще всего через OPC (можно и в 5 и в 6 версиях). Ограничения для OPC - клиент и сервер должны быть в одном домене. Слышал о утилитах которые позволяют связать по OPC два компьютера в разных сетях, но подробностей не знаю.

В 6-ой версии стал возможен обмен между серверами WinCC по своим протоколам, но ограничения те же - оба сервера должны быть в одном домене.
Re: Связь двух WinCC серверов
Коростелёв; 26.11.03

Спасибо Вам за подробный ответ.

Re: Связь двух WinCC серверов
Лёха; 19.2.04

А можно настроить репликацию между машинами.

Re: Связь двух WinCC серверов
Коростелёв; 19.2.04

А что вы имеете ввиду? Резирвированную пару серверов? Вопрос был о двух разных серверах с разными проектами.

Re: Связь двух WinCC серверов
Вадим Печёрских; 1.3.04

Если данные - это просто значений тегов, то лучше всего ОРС. Для этого необходимо настроить DCOM. Пробовал - работает.


text

СВЯЗЬ МЕЖДУ PLC-200 И WINCC6.0
ALEX; 19.8.04

СРОЧНО ПРОШУ ПОМОГИТЕ КАК УСТАНОВИТЬ СВЯЗЬ МЕЖДУ КОНТРОЛЕРОМ PLC-222(или другим) И WINCC6.0.

Возможно ли через кабель PC/PPI и COM1?
Re: СВЯЗЬ МЕЖДУ PLC-200 И WINCC6.0
MooR; 20.8.04

Через ОРС сервер

Re: СВЯЗЬ МЕЖДУ PLC-200 И WINCC6.0
Юрченко Владимир; 20.8.04

У WinCC нет драйверов для связи с S7-200. Выход использовать OPC для S7-200.

Недавно вышел новый пакет для связи с S7-200 по OPC (по Ethernet, PPI и MPI) под названием PC Access, прочитать о нем можно по ссылке. Лучше использовать его, так как предыдущий OPC сервер работал через PPI не очень хорошо. Но еще лучше организовать связь через Ethernet с использованием CP243-1.
См. http://www4.ad.siemens.de/WW/view/en/19298708


text

Сервер-сервер
ex; 9.9.04

как передать тэг от одного сервера другому?

Re: Сервер-сервер
GorA; 9.9.04

Подключайтесь клиентом к серверу.

Re: Сервер-сервер
ex; 9.9.04

т.е. стандартными средствами никак?

Re: Сервер-сервер
Л. Шерешевский; 10.9.04

А чем не устраивает OPC?

Re: Сервер-сервер
Маслов Дмитрий; 11.9.04

Если тегов не много, то OPC подойдет идеально. Если же надо передавать много тегов и часто, то OPC может не подойти по производительности. В этом случае можно использовать server-to-server comunication. Настраивается примерно так же, как и client-server: на одном сервере создаете пакет серверных данных, на другом загружаете и используете теги сервера, на котором создан пакет серверных данных.

См. http://www.wincc.ru

Re: Сервер-сервер
ex; 15.9.04

Спасибо.

Второй вариант предпочтительнее, но на сервере нет меню загрузки серверных данных, только создание. Хотя, вручную не пробовал, может и получится...
Re: Сервер-сервер
Маслов Дмитрий; 16.9.04

Есть такое меню. Щелкаете правой кнопкой на Server Data и выбираете Loading.

См. http://www.wincc.ru


text

Синхронизация в Reduntancy
Евгений К.; 18.12.03

Привет !

Есть ли способы синхронизации внутренних переменных м\у двумя серверами в Reduntancy. Например, ввожу в ручную значение во внутр. переменную ,а на другом в таком же окне появилось ?
Re: Синхронизация в Redundancy
Маслов Дмитрий; 19.12.03

Попробуйте передавать их по OPC. Правда, в этом случае проекты будут немного отличаться.

А самый простой способ (хотя не совсем экономичный) - сделайте эти теги внешними. Вы будете так же вводить значение вручную на одной станции, а оно через контроллер будет передаваться во вторую станцию.
См. Центр технической поддержки по WinCC

Re: Синхронизация в Reduntancy
Евгений К.; 14.1.04

Спасибо!

Второй совет оказался удачней !
А Reduntancy мы вообще убрали !<


text

Синхронизация серверов вручную.
Viktor; 6.12.04

2 сервера синхронизируются.

Тот, который в redudance master, завис. Проект перестал стартовать. Удалось запустить только после того как заменил файл в проекте ИмяпроектаRT.db на WinCC.db из каталога wincc/bin.
Но похоже базы не стали синхронизироваться.
Как заставить, не останавливая проект на втором сервере, принудительно синхронизировать базы, либо просто перенести базу со второго сервера на первый?<


text

Синхронизация сереверов.
Vikond; 16.4.04

Есть 2 WinCC сервера. Работают нормально, синхронизируются. Если я возьму один, сервер перенесу проект на другой компьютер (без РТ базы данных), настрою IP и имя компьютера такоеже как и было. То после включения нового компьютера надо ли что еще дополнительно настраивать, чтобы заработала синхронизаия?

Re: Синхронизация сереверов.
Любитель Симатика; 16.4.04

В принципе ничего, но еще раз для верности я бы проверил и подтвердил настройки Redundancy. На всякий случай...


text

Сколько стоит переделать HMI c панели TP27 на PC
Михаил; 10.11.04

Господа подскажите пожалуйста сколько можно содрать с предприятия денег за переделку визуализации с панели TP27 на Компьютер (например на ProTool PC RunTime) Прога на панель есть.

Да и еще
Михаил; 10.11.04

Я имею ввиду какие цены на данные виды работ в москве или в других регионах, так чтобы ну заломить немного ниже. Патаму что наверняка они (заказчики) будут обзванивать различные фирмежки на предмет выяснения так сказать "мировых цен". они сами в этом деле лапухи цен не знают. Да и я тоже незнаю. минимально канечно взялся бы за 300$, но ведь хочеться срубить побольше. Да и еще цена должна как бы быть такой чтоб оправдался отказ от замены панелей на новые. :)

Памагите пажалуйста никак не могу определиться с этим. Я новичок в этом деле (я имею ввиду подобные шабашки) работаю сибе инженером по автоматизации у нас на заводе и делал всегда все за зарплату.
Re: Сколько стоит переделать HMI c панели TP27 на PC
Владимир; 11.11.04

Существуют "Сметные нормы на пусконаладочные работы АСУТП" . Я сам не видел их. Но и в них говорят цены старые ,поэтому вводятся различные коэффициенты повышающие.


text

Скорость работы с User Archive WIN CC 5.1
Владимир; 11.10.04

Необходимо организовать архивирование данных, порядка 120000 записей в неделю, данные типа string.

Архив No Communication, записи добавляем скриптом, скорость доходит временами до 5-6 записей в секунду.
Проблема в том, что запись иедт очень медленно. Но если открыть User Archive из дерева проекта, или в проекте вызвать User Archive Table Control, скорость записи увеличивается в несколько раз. В свойствах проекта на вкладке StartUp приложение CCUsrAcv.exe указано как загружаемое до старта проекта.
Подскажите, кто сталкивался с такой же ситуацией, что можно сделать ? или вообще отказаться от User Archive м вести запись какими-то другими способами ?
Re: Скорость работы с User Archive WIN CC 5.1
Макс Прилепский; 11.10.04

User Archive в версии 5.х работает весьма криво. Например, у нас для версии 5.х существовует практика хранения архивируемых данных различного характера (в основном, протоколы различных стадий и операций технологического процесса)в конфигурационной БД проекта. Запись и чтение данных организованы в проекте WinCC средствами ODK, штамп времени записи формирует PLC в формате UTC. Далее эти архивы, необходимые для верхнего уровня, со станций с помощью специально написанной службы, установленной на верхнем уровне периодически перекачиваются на верхний уровень и там уже публикуются в виде web-форм, которые можно отображать на станциях WinCC. Эта же служба удаляет устаревшие данные из БД станций. БД между станциями не синхронизируются. Надёжность обеспечивается двумя параллельно работающими станциями. Если же связи с верхним уровнем не предусматривается, то следить за количеством записей в архиве и удалять лишние можно также либо средствами ODK, либо использовать в С-action объекты, например, ADO. Ниже приведу небольшой пример использования ADO для чтения данных из таблицы конфигурационной БД проекта:

BOOL ADOReadTable()

/* объекты объявляются как глобальные переменные вне тела функции */
__object *ADO_Conn,*ADO_RSet;
{

char Field1 [100];
char Field2 [100];

if(ADO_RSet!=NULL)
{
__object_delete(ADO_RSet);
ADO_RSet=NULL;
}

if(ADO_Conn!=NULL)
{
__object_delete(ADO_Conn);
ADO_Conn=NULL;
}

ADO_Conn=__object_create("ADODB.Connection");

if(ADO_Conn==NULL)
return FALSE;

ADO_Conn->Open(<Сюда передаётся DSN-имя , полученное , например с помощью функции DMGetProjectInformation>);

/* Выполняем запрос из таблицы Glossary конфигурационной БД проекта */
ADO_RSet=ADO_Conn->Execute("select * from dba.Glossary order by M_Code asc",NULL,0x1);

if(ADO_RSet==NULL)
{
ADO_Conn->Close();
__object_delete(ADO_Conn);
return FALSE;
}

ADO_RSet->MoveFirst();

/* Здесь идёт получение строковых полей записей */
while ((!ADO_RSet->eof))
{
strcpy(Field1,ADO_RSet->Fields->Item("DB_Field_1")->value);

strcpy(Field2,ADO_RSet->Fields->Item("DB_Field_2")->value);
и т.п.

ADO_RSet->MoveNext();
}

ADO_RSet->Close();
__object_delete(ADO_RSet);
ADO_RSet=NULL;

ADO_Conn->Close();
__object_delete(ADO_Conn);
ADO_Conn=NULL;

return TRUE;
}<


text

СЛИТЬ ТЕКСТОВЫЙ ТЕГ И ЧИСЛОВОЙ
ALEX; 8.11.04

Как слить текстовый тег1(text tag16-bit)

и тeг2 числовой(decimal) в единый другой текстовый тег3(text tag16-bit)
с помощью С-ACTION.
Подскажите PLEASE!!!
Re: СЛИТЬ ТЕКСТОВЫЙ ТЕГ И ЧИСЛОВОЙ
Мифка; 9.11.04

char buf[255],temp[25];

strcpy(buf,GetTagChar("Name1"));
sprintf(temp,"%d",GetTagWord("Name2"));
strcat(buf,temp);
Re: СЛИТЬ ТЕКСТОВЫЙ ТЕГ И ЧИСЛОВОЙ
Александр Родин, ООО "Нева Электрик"; 9.11.04

Или еще проще:

{

char* buf1;

buf1 = (char*) SysMaloc(255);

sprintf (buf1, "%s%d\0", GetTagChar ("Tag1"), GetTagWord ("Tag2"));

SetTagChar ("Tag3", buf1);
}

где Tag1 и Tag3 - 16-bit Text, Tag2 - Word.
Re: СЛИТЬ ТЕКСТОВЫЙ ТЕГ И ЧИСЛОВОЙ
Мифка; 10.11.04

Re: Флександр Родин

Век живи, век учись :-D<


text

Службы CCAgent и WinCC SQL Server
Роман ; 26.8.04

Подскажите, для чего нужны эти службы и в каком состоянии они должны быть - запущены или остановлены.

Или дайте ссылочку, где можно почитать про это.
Заранее спасибо.
Re: Службы CCAgent и WinCC SQL Server
Юрченко Владимир; 26.8.04

WinCC SQL Server основа WinCC и без него не редактировать проект, не тем более RT запустить не возможно. Ну

CCAgent нужен для диагностики и для настройки соединений Client-Server (если на PC более одной платы Ethernet).
Re: Службы CCAgent и WinCC SQL Server
Шестаков Александр; 3.9.04

CCAgent - необходим не только при наличии двух сетевых плат. Но и для пинания WinCC при переходе из одной подсети в другую:-).


text

СОЕДИНЕНИЕ С ПАНЕЛЬЮ OP15
LION; 26.10.04

ПОМОГИТЕ ПАЖАЛУЙСТА!!!!

НЕ МОГУ СОЕДЕНИТЬСЯ С ПАНЕЛЬЮ. С ПОМОЩЬЮ КАКОГО КАБЕЛЯ И К КАКОМУ РАЗЪЕМУ НА ПАНЕЛИ НАДО ПОДКЛЮЧАТЬСЯ.
У МЕНЯ С ПРОГРАММАТОРОМ ПРИШЛО ДВА КАБЕЛЯ НО НИ ОДИН НЕ ПОДХОДИТ*(6ES7 901-0BF00-0AA0,6ES5 734-2BF00)

СПАСИБО ЗАРАНЕЕ!
Re: СОЕДИНЕНИЕ С ПАНЕЛЬЮ OP15
Юрченко Владимир; 28.10.04

Для соединения по RS232 нужен кабель 6XV1 440-2KH32. Со стороны OP он 15 пин, со стороны PC 9 пин.


text

Создание Alarm Message
Прокопенко В.; 8.4.04

В Alarm Logging в System Message в строке сообщения используется запись “:@100%s@:” как параметр, которая в рабочем режиме заменяется нужной подстрокой. Можно ли что-нибудь аналогичное применить для создания своих сообщений и как? Дело в том, что функция MSRTCreateMsg() записывает в архив аварийное сообщение по номеру существующего в Alarm Logging, а мы не можем в редакторе сразу предусмотреть все возможные сообщения, нужно чтобы в архив записывалось сформированное сообщение. Очень нужно...

Re: Создание Alarm Message
Макс Прилепский; 9.4.04

Формировать такое сообщение можно, используя стандартные средства Alarm Logging. Для этого необходимо в Message Blocks->Process value blocks создать необходимое число блоков, помещаемых в сообщение. Затем, при конфигурации нужного сообщения,в закладке Tag/Action в категории Process Values конфигурируется до 10 используемых в тексте сообщения тегов - Process Value 1 ... 10(в т.ч. и текстовых), значения которых динамически вставляются в строку сообщения при его генерации. Затем в тексте сообщения формируются ссылки на нужные блоки (например, строка "Колодец К3 - уровень воды превысил @1%4.0f@ мм" содержит в себе ссылку на Process Value 1 в формате float с четырьмя знаками до запятой).

Re: Создание Alarm Message
Прокопенко В.; 9.4.04

Огромное спасибо, Макс. Действительно, все получается просто и красиво.


text

создание объектов в WinCC
Игорь Одесса; 7.6.04

Подскажите, как в Си скрипте WinCC можно создать Static Text и I/O Field?

Re: создание объектов в WinCC
Л. Шерешевский; 8.6.04

Для этого необходимо использовать функции среды разработки для работы с кадрами PDL, входящие в пакет ODK.

Re: создание объектов в WinCC
Игорь Одесса; 8.6.04

Можно чуть подробнее, за неимением ODK?

Re: создание объектов в WinCC
Л. Шерешевский; 8.6.04

Во-первых, не имея ODK Вам будет сложно добиться поставленной цели. Во-вторых, все подробности зависят от используемой версии WinCC.

Re: создание объектов в WinCC
Игорь Одесса; 8.6.04

WinCC6


text

Сообщения Alarm_S
Юрий Оганесян; 11.5.04

Protool V6.0 SP2 MP370

Step7 V5.2 SP1
Использую подтверждаемые сообщения Alarm_S (SFC17), в текст которых внедрен (ассоциирован) текст из пользовательской текстовой библиотеки (текст русский). На панели сообщения отображаются корректно, но просмотре истории (Message Events) или архива обнаружилась интересная особенность: записи о возникновении и снятии сообщений корректны, а в записи о подтверждении вместо ассоциированного текста ###. В чем дело? Работал ли кто-нибудь с SFC17 и наблюдалась ли такая же картина?
Re: Сообщения Alarm_S
Юрий Оганесян; 1.6.04

Немцы ответили:

"The ACK-event of an Alarm-message or an Alarm-S message displays
### at the place were a value is in the message.
This is a systemattribute of all panels which are programed with ProTool."
То есть так и будет.
С программной точки зрения обосновано. Можно было и самому догадаться, что так и будет.
Но как объяснить надпись "###" обслуживающему персоналу и руководству???
Все равно косяк тут у Siemens...недодумали...

2 Владимир Юрченко: Спасибо.<


text

Сообщения WinCC
Василий; 26.10.04

В окне сообщений из длинного архива выводятся все три типа Alarm‘ов: пришедшие, ушедшие и квитированные(красные, черные, синие). Как сделать так чтобы выводился только один тип?

(только черные) Может SQL фильтр какой-то поставить?

Re: Сообщения WinCC
Alexis; 27.10.04

Сделайте выборку по статусу сообщения - в хелпаках и ртфмах это подробно описанно.


text

Сообщения в PCS7v6.0
Лисагоров С.Н.; 22.10.04

Нет отображения сообщения в дисплее аварийных сообщений faceplates, хотя в групповом дисплее faceplates аварийное сообщение отражается.

Re: Сообщения в PCS7v6.0
Eugene; 28.10.04

В фасплате осуществяется фильтрация сообщений по полю ТЕХТ1. Фильтр устанавливается в скрипте OnOpenPicture

PCS7_Alarm.pdl<


text

Сообщения в WinCC v6.0.2
Human; 8.7.04

Уже на трёх проектах сделаных в pcs7_v6.0SP3 наблюдаем косяк: был сделан перенос сообщений в WinCС из Step7, всё работало замечательно, затем были внесены исправления в программе Step7 и заново перенесены сообщения в WinCC, номера сообщений сдвинулись. Наблюдаем следующее: в окне сообщений отображается новый текст сообщения (который в AlrmLogging), а в архив пишется старый текст, т.е. текст который соответствовал данному номеру сообщения до того, как сдвинулись номера. Вопрос к тех. поддержке WinCC: ОТКУДА БЕРЁТСЯ СТАРЫЙ ТЕКСТ СООБЩЕНИЙ? И как решается данная проблема? И ещё, люди, кто-нить ещё наступил уже на эти грабли? Спасибо за ответы.

Re: Сообщения в WinCC v6.0.2
Маслов Дмитрий; 9.7.04

К сожалению, есть такой глюк в PCS7 6. Я столкнулся с ним на реальном проекте... Можно вылечить следующим образом:

1. из каталога проекта удалить файлы OS1Alg.ldf и OS1Alg.mdf;
2. на всякий случае еще перенести все данные из Step (скомпилировать OS), но не изменения, а целиком проект, с очисткой памяти.

См. www.wincc.ru

Re: Сообщения в WinCC v6.0.2
Маслов Дмитрий; 9.7.04

Пардон, имена файлов, которые надо удалить из каталога проекта WinCC, формируются так: имя_проектаAlg.ldf и имя_проектаAlg.mdf.

Re: Сообщения в WinCC v6.0.2
Л. Шерешевский; 9.7.04

Это не глюк, так задумано. Текст сообщений сохраняется в каждом сегменте архива. С началом нового сегмента тексты обновятся. Если нужно срочно произвести обновление, придумайте, как начать новый сегмент принудительно. Немцы говорят, что это было сделано для того, чтобы архив сообщений более точно соответствовал тому, что реально появлялось на экране перед операторами.

В Alarm Control в поле Status ничего нет
Evgen; 9.7.04

У меня такая проблема. Вдруг в Alarm Control при выводе сообщений перестали выводиться символы состояния сообщения в поле Status (по умолчанию для класса сообщений Error это +, -, *, +/-). Удаление/добавление системного блока Status не помагает. Что делать?

В Alarm Control в поле Status ничего нет
Evgen; 9.7.04

У меня такая проблема. Вдруг в Alarm Control при выводе сообщений перестали выводиться символы состояния сообщения в поле Status (по умолчанию для класса сообщений Error это +, -, *, +/-). Удаление/добавление системного блока Status не помагает. Что делать?

Re: Сообщения в WinCC v6.0.2
Human; 12.7.04

To Л. Шерешевский, а как тогда быть с тем, что я удаляю все сегменты, при запуске RunTime создаётся новый, но сообщения-то в него пишутся со старым текстом!?

Спасибо!
Re: Сообщения в WinCC v6.0.2
Л. Шерешевский; 16.7.04

Действительно, непонятно почему так происходит. Описанная Вами проблема указана в списке исправленных в PCS7 6.0 SP3. Видимо, немецкие коллеги были слишком оптимистичны.

Вот соответствующий абзац из списка иправлений:
The message texts in the message list differ from those in the long-term archive.
After alarm texts were edited in the text library, these are output correctly to the alarm overview according to their current status when new alarms are generated. However, the long-term archive still shows the old texts.<


text

Сортировка в AlarmLoggin
Андрей; 5.11.04

Есть элемент WinCC Alarm Control высотой в одну строку, без toolbar'a. Хотелось бы отображать сообщения, отсортированные по приоритету, т.е. если есть сообщение с высоким приоритетом, то оно висит, даже если приходят сообщения с меньшим приоритетом.

В help'e написано как это сделать ч/з диалог Sort(
Sorting by priority makes it possible for the most important message (highest priority) to appear in the display area in the case of a single-line message. A low-priority message will not be displayed even if it has a more recent date.), как раз то, что надо, а можно ли это сделать как-то программно.
<


text

Сохранение проекта панели МР270
Михаил; 11.10.04

Пытался сохранить проект панели МР270 на программатор с помощью программы ProSave V 6.0 по MPI-связи.Программа выдала сообщение о том,что версия операционной системы панели(2.12)не совпадает с версией операциионной системы в программе(3.0) и рекомендует обновить панель.Сохранять проект отказывается.Может в панели есть какие-нибудь хитрые опции,которые позволяют делать копии проекта?)) Можно ли в такой ситуации сохранить прект панели каким-либо другим способом,не используя Flash?

Спасибо.
Re: Сохранение проекта панели МР270
TVO; 14.10.04

Скачать можно старой версией Prosave v.5.2.


text

Список пользователей в User Administrator
HiEd; 24.9.04

Здравствуйте! Подскажите, пожалуйста, каким образом считать список пользователей, имеющихся в User Administrator и заполнить этим списком Microsoft ComboBox, чтобы не вводить имя пользователя, а выбирать его из списка.

Заранее благодарю.<


text

СРАВНЕНИЯ В "C-ACTION"
ALEX; 21.6.04

ПОДСКАЖИТЕ КТО МОЖЕТ, КАК С ПОМОЩЬЮ "C-ACTION" ПРОИЗВЕСТИ СРАВНЕНИЕ ТЕКУЩЕГО ВРЕМЕНИ С ВРЕМЕНЕМ КОТОРОЕ ЗАДАЕТСЯ,Т.Е. В ТЕКСТОВОМ ФОРМАТЕ. И ВРЕЗУЛЬТАТЕ ЧЕГО ПРОИСХОДИТ ДЕЙСТВИЕ. СПАСИБО!!

Re: СРАВНЕНИЯ В
Александр Родин, ООО "Нева Электрик"; 22.6.04

Пишем функцию...

SYSTEMTIME GetCurrentSysTime ()
{
#pragma code ("kernel32.dll")
void GetLocalTime(LPSYSTEMTIME lpSystemTime);
#pragma code ()

SYSTEMTIME TmpTime;

TmpTime = (SYSTEMTIME) SysMalloc (sizeof (SYSTEMTIME));

GetLocalTime (&TmpTime);

return TmpTime;

}

далее где-нить в нужном месте пишем

{
SYSTEMTIME LocTime;
char* LocTimeStr;

LocTime = GetCurrentSysTime ();
LocTimeStr = (char*) SysMalloc (MAX_PAH);

sprintf ("%d-%02d-%02d %02d:%02d:%02d.000\0", LocTime->wYear, LocTime->wMonth, LocTime->wDay, LocTime->wHour, LocTime->wMinute, LocTime->wSecond);

// А далее сравниваем полученную строку LocTimeStr с другой строкой и делаем все что нам надо.
}
Re: СРАВНЕНИЯ В
Александр Родин, ООО "Нева Электрик"; 22.6.04

Добавка:

преобразование в строку можно так же сделать в функцию... и тогда у вас сразу получится функция получения текущего времени в виде строки...
<


text

Срочно! Связь WinCC с Excel
roma; 23.6.04

Необходимо сформировать Excel документ со значениями процессорных тегов.

Для внутренних тегов через драйвер Windows DDE все работает, а вот для внешних тегов не подходит.
Подскажите, пожайлуста.
Может воспользоваться другим методом.
Re: Срочно! Связь WinCC с Excel
Nick Gashevsky; 23.6.04

На VisualBasik для своей программы исчпользовал компоненту OPC сервера SimaticNet. Дока и примеры есть справке по SimaticNet.

Re: Срочно! Связь WinCC с Excel
roma; 23.6.04

извени, можно подробнее

Re: Срочно! Связь WinCC с Excel
Nick Gashevsky; 23.6.04

Кусок хелпа WinCC 6.0

1
Open Microsoft Excel with a new workbook.

2
In the "Tools" menu, select "Macro" "Visual Basic Editor". This will launch the Visual Basic Editor for Microsoft Excel.

3
In the "Tools" menu of the Visual Basic Editor select "References...". A dialog titled "References - VBAProject" appears. Locate the entry "Siemens OPC DAAutomation 2.0" in the list of references available. Mark the corresponding checkbox. Click "OK" .

4
Click here. Copy the script. This script is only available in the online help.

Option Explicit

Option Base 1

Const ServerName = "OPCServer.WinCC"

Dim WithEvents MyOPCServer As OpcServer

Dim WithEvents MyOPCGroup As OPCGroup

Dim MyOPCGroupColl As OPCGroups

Dim MyOPCItemColl As OPCItems

Dim MyOPCItems As OPCItems

Dim MyOPCItem As OPCItem

Dim ClientHandles(1) As Long

Dim ServerHandles() As Long

Dim Values(1) As Variant

Dim Errors() As Long

Dim ItemIDs(1) As String

Dim GroupName As String

Dim NodeName As String

'---------------------------------------------------------------------

' Sub StartClient()

' Purpose: Connect to OPC_server, create group and add item

'---------------------------------------------------------------------

Sub StartClient()

' On Error GoTo ErrorHandler

'----------- We freely can choose a ClientHandle and GroupName

ClientHandles(1) = 1

GroupName = "MyGroup"

'----------- Get the ItemID from cell "A1"

NodeName = Range("A1").Value

ItemIDs(1) = Range("A2").Value

'----------- Get an instance of the OPC-Server

Set MyOPCServer = New OpcServer

MyOPCServer.Connect ServerName, NodeName

Set MyOPCGroupColl = MyOPCServer.OPCGroups

'----------- Set the default active state for adding groups

MyOPCGroupColl.DefaultGroupIsActive = True

'----------- Add our group to the Collection

Set MyOPCGroup = MyOPCGroupColl.Add(GroupName)

Set MyOPCItemColl = MyOPCGroup.OPCItems

'----------- Add one item, ServerHandles are returned

MyOPCItemColl.AddItems 1, ItemIDs, ClientHandles, ServerHandles, Errors

'----------- A group that is subscribed receives asynchronous notifications

MyOPCGroup.IsSubscribed = True

Exit Sub

ErrorHandler:

MsgBox "Error: " & Err.Description, vbCritical, "ERROR"

End Sub

'---------------------------------------------------------------------

' Sub StopClient()

' Purpose: Release the objects and disconnect from the server

'---------------------------------------------------------------------

Sub StopClient()

'----------- Release the Group and Server objects

MyOPCGroupColl.RemoveAll

'----------- Disconnect from the server and clean up

MyOPCServer.Disconnect

Set MyOPCItemColl = Nothing

Set MyOPCGroup = Nothing

Set MyOPCGroupColl = Nothing

Set MyOPCServer = Nothing

End Sub

'---------------------------------------------------------------------

' Sub MyOPCGroup_DataChange()

' Purpose: This event is fired when a value, quality or timestamp in our Group has changed

'---------------------------------------------------------------------

'----------- If OPC-DA Automation 2.1 is installed, use:

Private Sub MyOPCGroup_DataChange(ByVal TransactionID As Long, ByVal NumItems As Long, ClientHandles() As Long, ItemValues() As Variant, Qualities() As Long, TimeStamps() As Date)

'----------- Set the spreadsheet cell values to the values read

Range("B2").Value = CStr(ItemValues(1))

Range("C2").Value = Hex(Qualities(1))

Range("D2").Value = CStr(TimeStamps(1))

End Sub

'---------------------------------------------------------------------

' Sub worksheet_change()

' Purpose: This event is fired when our worksheet changes, so we can write a new value

'---------------------------------------------------------------------

Private Sub worksheet_change(ByVal Selection As Range)

'----------- Only if cell "B3" chang10770983531013056416982307180 d:1037014088106325821410437455441093331638 10370140881063258214104374554410933316388648841020061471102464164810331299649692640919809328791077011985 ґ€9787100229493115521097065213995613702 ”
1020061471102464164810331299649692640919809328791077011985 њ#1020061471102464164810331299649692640919809328791077011985 d:10438255101000047111983181381  "1044017511102852248510777016801096170638 d:1037014088106325821410437455441093331638 д» 1046699983 Х#981107907 њ# Ё%10101347641018431611970118952ґ€930083434109809754794515565095858009410620551841034554952107580692010298288721026822958108269720894459826810825468381097040897103122367298551462010379742171094453735%Ѕ%9653682431013525035107511490221383510358780761075382586109801101610264607271081161809Advisories and threaded discussions. The threaded discussions allow you to ask questions, or look for solutions, on a subject that you may need help with where other PCS Users or Siemens staff may be able to assist you.
In closing let me assure you that we are firmly committed to providing you with regular up-to date information in order to make the integration of our Products and Systems, as well as the transition to new technologies, easier for you.
Yours sincerely!

Re: Срочно! Связь WinCC с Excel
Геннадий; 6.7.04

Попробуй так:

Dim MCP As Object
Dim WinCCValue As Variant

Set MCP=CreateObject("WinCC-Runtime-Project")
WinCCValue=MCP.GetValue("Имя_тэга_в_WinCC")

Читаются любые тэги (VisualBasic 6.0)
<


text

Срочно!!! wincc и internet explorer 6.0
pav; 13.1.04

При установке WinCC v5.0 sp2 на компе с internet explorer 6.0 инсталятор выдает сообщение, что не найден internet explorer и надо установить версию не нниже 4. Так повторилось на двух компах. Что делать?

Re: Срочно!!! wincc и internet explorer 6.0
Роман Абзаев; 13.1.04

А у Вас какая ОС? посмотрите для начал ID 1139080.

Re: Срочно!!! wincc и internet explorer 6.0
Human; 14.1.04

Надо ставить IE 5.0 или IE 5.5, лучше последний, проверено на личном опыте, он лучше всего работает с WinCC v5.0, v5.1.

Re: Срочно!!! wincc и internet explorer 6.0
pav; 14.1.04

Нашел сам с помощью regmonitor.

Оказывается в разделе реестра
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\IEXPLORE.EXE

нужен строковый параметр Path с путем где лежит iexplore:
C:\Program Files\Internet Explorer
Просто IE6.0 его удалил, а новое значение не поставил.
Прописал ключ и все поставилось<


text

СРОЧНО!!!-ПЕЧАТЬ ОТЧЕТА ПО ПРОМЕЖУТКУ ВРЕМЕНИ
ALEX; 8.7.04

ОБЯСНИТЕ КАК ОТПЕЧАТАТЬ ОТЧЕТ АРХИВ СООБЩЕНИЙ(ALARM LOGGING) ТОЛЬКО ОТ ДАТЫ КОТОРАЯ ЗАПРАШИВАЕТСЯ ИЛИ ЛУЧШЕ ОТ ДАТЫ НАЖАТИЯ КНОПКИ.ИЛИ ВОЗМОЖНО ЧЕРЕЗ ФИЛЬТР ПО ДАТЕ,ТЕГУ-ФИЛЬТР ЗАДАЕТСЯ GRAPHICS DESIGNER. В РЕЗУЛЬТАТЕ НУЖНЫ ТОЛЬКО СООБЩЕНИЯ НА ПРОМЕЖУТКЕ ЭТОЙ ДАТЫ. ПОМОГИТЕ ПОЖАЛУЙСТА.

Re: СРОЧНО!!!-ПЕЧАТЬ ОТЧЕТА ПО ПРОМЕЖУТКУ ВРЕМЕНИ
GorA; 9.7.04

Если отчет распечатывается вручную, то нужно вывести на экран сообщений кнопку SELECTION. Нажатие на данную кнопку в Run-time выведет окно активации фильтра, где можно ввести свои условия вывода сообщений и затем распечатать.

Re: СРОЧНО!!!-ПЕЧАТЬ ОТЧЕТА ПО ПРОМЕЖУТКУ ВРЕМЕНИ
Маслов Дмитрий; 9.7.04

Вариант 1.

----------
1. Создаете LayOut с окном сообщений
2. Создаете Print Job и задаете в его настроках диапазон времени относительно момента печати.

Вариант 2.
----------
1. В Graphics Designer рисуете поля ввода даты-времени.
2. Заданный оператором диапазон времени можно записывать в PrintJob с помощью функций ODK (см. пример проекта в WinCC Configuration Manual) или в LayOut через теги (если используется WinCC 6).

Вариант 3.
----------
1. Задавайте фильтр сообщений для окна отображения сообщений (Alarm Control), свойство MsgFilterSQL
2. Печатайте выбранные в окне сообщений с помощью стандартной кнопки в панели инструментов окна сообщений.
См. www.wincc.ru


text

СРОЧНО-ПРОБЛЕМА ОТКРЫТИЯ AlarmLogging
ALEX; 20.10.04

В чем проблема, в WINCC v.6.0 в Windows 2000 немогу открыть AlarmLogging. Компьютер зависает постоянно ,уже пробовал создать новый проект-тоже самое.Раньше мог открыть -через раз. Подскажите PLEASE как исправить это, нужно ли переустанавливать WINCC.

Re: СРОЧНО-ПРОБЛЕМА ОТКРЫТИЯ AlarmLogging
Маслов Дмитрий; 20.10.04

Ну раз на пустом проекте глючит, значит надо переустанавливать. Причем лучше вместе с виндой. Поставьте все строго в соответствии с рекомендациями Siemens, не ставьте никаких программ, кроме WinCC. И не забудьте все последние Hotfix'ы (Hotfix 1-3 для WinCC 6/SP2).


text

Стандартный FB53 для связи OP7 c S5 CPU
Валерий; 15.7.04

Уважаемые Господа!

Задача связать OP7 с 2-х портовым CPU944 через 2-ой порт SI2. В документации сказано что для связи необходим стандартный блок FB53 (имя TDOP:FAP) который должен вызываться в циклической части программы CPU. Не знаю где взять этот блок. Возможно ли его скачать бесплатно откуда либо или подскажите заказной номер продукта в котором он находится. В документации "Coros OP30 A/B/C Equipment Manual" сказано что FB53 находится в файле S5TD50ST.S5d, который в свою очередь находится на дискете "COROS S5 Standard FBs for TD10 to OP30". Я думаю что он может быть также в составе программного обеспечения к каким-нибудь другим панелям операторов.
Помогите пожалуйста. Спасибо.
Re: Стандартный FB53 для связи OP7 c S5 CPU
Никаноров Владимир; 16.7.04

FB действительно необходим.

В принципе, продукт "COROS S5 Standard FBs for TD10 to OP30" раньше продавался отдельно. Теперь он возможно снят с производства (поставки), но точно я не знаю. Рекомендую обратиться в московский Сименс, думаю что там сохранились эти FB. <


text

Стандартный проект для ОР270
Дмитрий; 6.2.04

Привет всем!

Я генерирую новый проект для ОР270 при помощи мастера. В одной из закладок должна быть вкладка с флажком что-то вроде "use standard project" ("Standardprojekt verwenden"-нем.). На самом деле ее нет, хотя в хелпе она описана именно для этой панели (windows based panels). Это очередной облож Сименса?
Что интересно, для ОР27 все ОК. У меня идея - сгенерировать сначала ОР27 с использованием стандартного проекта, а потом переконвертировать ОР27 в ОР270. Должно работать, вроде бы.
Использую ProTool/Pro CS V6.0 RC1
Please help!
Re: Стандартный проект для ОР270
Дмитрий; 6.2.04

Пишу вдогонку. Проинсталил SP1a, переконвертировал проект из ОР27 в ОР270. Стандартный проект в ОР270 исчез.

Для чего это нужно?
Первый трансфер для ОР идет через нульмодемный кабель. Все последующие можно через сетку MPI или Profibus.
Только как выбрать этот режим для ОР270?
Согласитесь, это удобнее, нежели бегать по заводским колдобинам с программатором и кабелем.
Re: Стандартный проект для ОР270
Сидоров Артем; 8.2.04

Сделайте системную кнопку на выход из проекта. Выглядит это примерно так Functions->Other functions->exit_runtime->exit_RT_only. После этого загружаете панель через нульмодемный кабель и выходите из своего проекта. Появляется меню из 4-х пунктов: Transfer/Start/Control Panel/Taskbar. Заходим в Control Panel и выбираем пункт Transfer. Там есть 2-й канал для загрузки. По умолчанию он выключен. Tab-ом на него наводимся и ставим обе галочки.

PS. Нажав на Advanced можно посмотреть свойства MPI/Profibus.<


text

Статус тега 4с
Прокопенко Вера; 23.8.04

Имеется проект WinCC v5.1 в котором опрашиваются теги контроллеров Allen Bradley SLC-500. Есть теги, которые используются только на вложенных картинках. При открытии картинок теги опрашиваются и значения тегов отображаются. После закрытия этих картинок значения данных тегов в Tag Management равны нулю и статус 4с? Это ошибка или так и должно быть? Разве база не должна хранить последние опрошенные значения? Для внутренних тегов в подобных ситуациях значения сохраняются.

Re: Статус тега 4с
Маслов Дмитрий; 24.8.04

Tag Manager опрашивает значения тегов только если они где-нибудь используются. Т.е. если они у Вас не архивируются, и картинка, на которой они отображаются, закрыта, то теги не опрашиваются. Это нормально. Таким образом уменьшается траффик сети.

Если Вы эти теги добавите в архив, то они будут опрашиваться постоянно, независимо от того, открыта картинка, или нет.
См. http://www.wincc.ru

Re: Статус тега 4с
Харгелия Олег ЗАО "Искра-Энергетика"; 24.8.04

Насколько я понял вопрос был несколько в ином. А именно, почему теги когда их перестаешь использовать обнуляются, а не сохраняют последнее значение?

Re: Статус тега 4с
Прокопенко Вера; 25.8.04

Вопрос именно в том, почему база не хранит однажды опрошенные значения внешних тегов. Вопрос этот возник по следующей причине: в проекте написан скрипт, отрабатывающей по нажатию на горячую клавишу и присваивающий значение внешнего тега внутреннему. И получалось, что внутреннему тегу присваивался ноль вместо реального значения. Использовалась функция GetTagWord. возможно, если бы использовалась функция GetTagWordWait удалось бы получить значение тега (не пробовала), но стараюсь не использовать эту функцию,т.к. скрипт не будет выполнен, пока от контроллера не дождетя ответа, поэтому боюсь, что проект будет подтормаживать (или я не права?).Тогда мы занесли эти внешние теги в архивные, но, по-моему, это не очень хорошо.

Re: Статус тега 4с
Alexis; 25.8.04

Используйте DMGetValueWait, точно считает с контроллера...

Re: Статус тега 4с
Маслов Дмитрий; 25.8.04

Давайте разберемся по порядку.

1. Отвечаю на вопрос "почему база не хранит однажды опрошенные значения внешних тегов?". База данных здесь вообще не при чем. В базе данных хранятся только архивные значения тегов (для которых сконфигурирована архивация в Tag Logging). Текущие значения тегов в базу данных не заносятся.

2. По поводу функций GetTagXXX и GetTagWaitXXX (где XXX - тип тега). Функции GetTagXXX, вызываемые из скрипта WinCC, выполняют следующие действия: постановка запрашиваемого тега в очередь менеджером данных WinCC для циклического опроса с периодом 2 секунды, а если тег уже циклически опрашивается, то получение его значения из менеджера данных. Функции GetTagWaitXXX циклический опрос тега не инициируют, а запрашивают его значение непосредственно из контроллера. Плюсы и минусы каждой функции: GetTagXXX очень медленно (по сравнению с GetTagWaitXXX) отрабатывает в первый раз (когда тег ставится в очередь на опрос), но зато быстрее работает в следующие вызовы. Поэтому ее лучше использовать в скриптах, срабатывающих циклически. Функцию GetTagWaitXXX лучше использовать в скриптах по нажатию кнопок, открытию картинок и т.д. Т.е. в Вашем случае нужна именно GetTagWaitXXX. Подтормаживать ничего не будет - проверено (если Вы не 100 тегов сразу запрашиваете).

3. Alexis'у. А вот ODK'шная функция DMGetValueWait здесь точно не нужна. Это есть аналог GetTagWaitXXX, предназначенный для вызова из внешних приложений и DLL.

См. http://www.wincc.ru

Re: Статус тега 4с
Прокопенко Вера; 30.8.04

Конечно же, я неправильно выразилась. Имелась в виду не Runtime база, а Data Manager, где должны храниться мгновенные значения опрошенных тегов. У меня есть подозрение, что это все таки ошибка WinCC (или ошибка работы канала ввода /вывода для DH+). Надо будет проверить подобную ситуация для тегов котроллеров Simatic. Спасибо за отклики.


text

Стоимость работ по разработке программ???
Мифка; 9.11.04

Подскажите сколько стоит написаине программ на панель ТР-27???

Вообще сколько стоит написание программ в PLC, панели и т.п.

Как это все увязять например на ее сложность (количество экранов, количество тегов, ...)<


text

Считать значение из архива TagLog
Клейн Александр; 1.12.04

Господа, а можно ли считать значение из архива TagLogging, например, 20-минутной давности и записать его в тег и как это сделать?

Re: Считать значение из архива TagLog
Александр Родин, ООО "Нева Электрик"; 1.12.04

Поищите в ОДК рписание функции TLGGetArchivData, или TLGGetArchivDataEx.

Re: Считать значение из архива TagLog
Александр Родин, ООО "Нева Электрик"; 1.12.04

Еще тут один способ вспомнил, можно же данные через SQL-запросы доставать.

:)
Re: Считать значение из архива TagLog
Александр Клейн; 2.12.04

Спасибо за совет.


text

Считать из PLC сразу большой блок?
миша; 25.8.04

Можно ли как нибудь считать из контроллера большой блок данных (например сразу байт 500) программным способом (VBS или C-скрипт)

Re: Считать из PLC сразу большой блок?
Чистяков Дмитрий ОАО СеверСталь; 25.8.04

Создать в WinCC тэг типа Raw Data Type

Re: Считать из PLC сразу большой блок?
Григорий; 25.8.04

А как будет учитываться такой блок в счетчике лицензий? Как одна переменная или как сумма всех переменных в DB

Re: Считать из PLC сразу большой блок?
VGenn; 26.8.04

Как один тэг.

Re: Считать из PLC сразу большой блок?
я; 26.8.04

В PLC ДАННЫЕ ТИПА FLOAT!!! ПОСЛЕ СЧИТЫВАНИЯ ИМЕЮ МАССИВ БАЙТОВ :((((

КАК ПРЕОБРАЗОВАТЬ ВО FLOAT (НА VBS)<


text

Теги не коннектятся
Денис Дроздов; 4.2.04

Архитектура клиент-сервер, контроллер S5 с CP-1430TCP. На сервере расписаны внешние теги из контроллера, на клиенте, соответственно, картинки. Проблема такова - на некоторых картинках с большим объемом отображаемой информации некоторые значения(теги) не отображаются вообще - элемент вывода серенький, адреса прописаны правильно. Вопрос - откуда растут ноги?


text

Теги статуса после загрузки WinCC Runtime
Evgen; 9.8.04

Здраствуйте.

У меня такая проблема. После загрузки WinCC runtime есть нарушения по аналоговым и дискретным параметрам, то есть имеются единичные биты в тегах сообщения (Message Tag), но теги статуса имеют нулевые значения. Иными словами после запуска состояние нарушения в тегах статуса (Status Tag) не отслеживается. Если значения бита сообщения сбросить в "0", а затем снова установить в "1" - все ОК: соответствующим образом изменяются биты тега статуса.
Причем при первом запуске WinCC runtime после удаления архивов сообщений такой ситуации нет.
Re: Теги статуса после загрузки WinCC Runtime
Evgen; 9.8.04

Вопрос частично снят: убрал флажок "Reload message list after power failure"


text

Типовой клапан и насос
Shpack; 25.11.04

Подскажите как написан стандартный компонент VALVE, что при копировании его, PDL сама копируется в соответствующую мнемосхему plant hierarhy после компиляции. Как то же самое сделать для своих собственных компонент.

PCS7 V6
Re: Типовой клапан и насос
Михайлин Сергей; 25.11.04

Как самому написать блок в стандарте PCS7 описано в доке по ссылке.

Почаше надо в доки смотреть и страничку PCS7 посещать. ;-)
См. Вся дока на русском по PCS7


text

Точка входа в процедуру Сс...... не найдена в библиотеке DLL ACE60.dll
Herman; 5.8.04

Сообщение возникает при запуске WinCC6 SP1, а т.ж. при удалении и установке WinCC.

Как с этим бороться?

<


text

ТР170 micro и s7-200
Дмитрий; 6.11.04

не получается скоммутировать эти две вещи. Тэги не обновляются в панели - хоть ты убейся.

Кто знает? Буду благодарен.
ICQ UIN: 137823035<


text

трансфер
григорий; 16.6.04

имею Wincc5.1 и step7 5.2 servispak1. не могу передать теги в wincc: сообщение типа Саn not open wincc project. Hotfix из Step 7.2 установлен. Чего в супе не хватает?

Re: трансфер
Юрченко Владимир; 17.6.04

Смотрите таблицу совместимостей WinCC и Step7. Для Step7 v.5.2SP1 нужен WinCC v.5.1 SP1 или SP2.

См. http://www4.ad.siemens.de/WW/view/en/14604845


text

Требование дискеты от AlmxpMgr.exe & CCActivateDeactivate.exe
Андрей Поздняков; 25.12.03

Добрый день!

При установке WinCC 5.1, когда на экране возникает надпись: "Setup is updating your registry database. Component RT."
Приложение CCActivateDeactivate.exe вдруг выводит всплывающий экран: "There is no disk in the drive. Please insert disk into drive A:."
Вырианты ответов: Cancel/Try Again/Continue при ЛЮБОМ ответе установка продолжается дальше. Причём проверял и с чистой дискетой, и с дискетой с лицензиями.... чего-то шуршит-шуршит дисководом потом установка продолжается.

Ладно бы это.... НО!
При запуске компьютера сразу после ввода пароля вылезает уже приложение AlmxpMgr.exe и тоже выводит предложение вставить дискету или продолжить работу. Пока не погасишь это сообщение загрузка Windows останавливается. При работе RT WinCC время от времени так же обращается к дисководу....

Это описание самой проблемы, хоть и длинное, зато подробное.

Параметры системы:
Win2000 SP2 ENG, WinCC 5.1
потом поставил HotFix0, Step7 v5.2, SimaticNet DP.

Лицензии установленны через AutorsW 2.5.1

Уже всё сносил и ставил Win2K+WinCC заново, ничего не помогает. Чего делать-то????

P.S. На e-mail'ы пока ответить не смогу. Пишите сюда...

С Уважением
Андрей Поздняков.
СПбЭК
Re: Требование дискеты от AlmxpMgr.exe & CCActivateDeactivate.exe
Анрей Поздняков; 29.1.04

Нашёл выход из данной ситуации такой - отключил в BIOS дисковод.

Re: Требование дискеты от AlmxpMgr.exe & CCActivateDeactivate.exe
Лёха; 6.2.04

а попробуй авторизацию поставить через AutorsW 1.3


text

Тренды +WinCC 6
Oleg; 21.12.04

Доброго времени суток :) !

Есть проблема с трендами, а именно

Большая амплитуда показаний, поэтому тренды кажутся "лохматыми". На тех же самых каналах с тем же оборудованием, но на другой системе визуализации (RSView) такой проблемы не было.
Где копать??? В официальной документации ничего не нашел...

Спасибо.
Re: Тренды +WinCC 6
Лев Шерешевский; 21.12.04

Есть подозрение, что "лохматость" трендов обусловлена либо большей частотой опроса тегов, чем в RSView (менее вероятно), либо отсутствием фильтрации (более вероятно). Чтобы избавиться от следов "дребезга" выводите на трендах архивные теги, а при архивации используйте усреднение.

См. http://www.wincc.ru

Re: Тренды +WinCC 6
Oleg; 22.12.04

Спасибо за ответ.

В том то и дело,что именно так и поступаю :( - архивные теги и усредняю при архивации....
не помогает :(.<


text

Тренды в Protool/Win 6.0 РС
григорий; 28.6.04

Вопрос:

1. Можно ли динамически менять переменные в трендах оператору в среде RunTime, а также назначать им цвета;
2. Можно ли на одном тренде - одновременно выводить более 9 графиков;
3. Можно ли в RUN-Time растягивать панель тренда? осуществлять его прокрутку. Включение визирок только через функции или еще каким либо образом?
4.Не могу получить доступ к переменным STEP 7 5.2 SP1 - ОКно пусто. Чего в супе не хватает?
Re: Тренды в Protool/Win 6.0 РС
Л. Шерешевский; 29.6.04

1. Можно, но штатных средств нет. Посмотрите на www.wincc.ru в разделе downloads, там приведен пример соответствующей программы. Либо сами напишите нечто подобное.

2. Можно.
3. Можно, в т.ч. с помощью ODK.
<


text

Тренды в заданном диапазоне времени
Polk; 15.9.04

Вечер добрый! Подскажите как вывести тренды в заданном диапазоне времени?

Заранее спасибо.
Re: Тренды в заданном диапазоне времени
Прокопенко Вера; 16.9.04

У объекта Online Trend Control есть свойства BeginTime, EndTime, которые и нужно задавать для каждого пера (Index). При этом свойство TimeRange должно иметь значение равное нулю.

Re: Тренды в заданном диапазоне времени
Polk; 17.9.04

Спасибо, но может еще подскажете почему так коряво дата отображается: месяц\дата\год ? И как это в нормальный человеческий вид привести...

Re: Тренды в заданном диапазоне времени
Прокопенко Вера; 17.9.04

В Help написано: «The entry format of the date and time is dependent on the runtime language used.»

Если выбрать в настройках проекта француский вместо английского, то, действительно, время выводится в формате день:месяц:год. Иного способа мы не нашли. Но и этим не пользуемся, операторы уже привыкли к формату месяц:день:год.

Re: Тренды в заданном диапазоне времени
Прокопенко Вера; 17.9.04

Есть еще вариант: в свойстве Time объекта для трендов задать формат dd:mm:yy hh:mm. В таком случае дата и время выводятся на рисках по всей шкале

Re: Тренды в заданном диапазоне времени
Прокопенко Вера; 20.9.04

И еще :-). Если в насройках операционки Regional Options -> Your locale выбирать English (United States) и дату в формате dd.mm.yy (в качестве разделителя точка), время и дата отображается нормально

Re: Тренды в заданном диапазоне времени
Polk; 20.9.04

Спасибо, тема закрыта.


text

Тренды и таблицы
Роман; 21.10.04

Имеется куча параметров для которых необходимо создать тренды и таблицы.

Если это делать в разных окнах то окон получается слишком много - это неудобно.Есть ли возможность вызывать необходимый тренд или таблицу в одном созданном окне выбирая лишь тег или архив?
Re: Тренды и таблицы
Маслов Дмитрий; 21.10.04

Можно динамически изменять свойство TagName у окна тренда.

См. http://www.wincc.ru

Re: Тренды и таблицы
роман; 22.10.04

можно..., вот только при изменении TagName данные из нужного архива подгружаться не будут. не знаю как в v. 6.0, а в 5.1 работает так :-(

Re: Тренды и таблицы
Ирина; 23.10.04

У меня все работает как в 6.0, так и в 5.1. Только помимо TagName еще приходится менять: NumItems, Index, Name, ItemVisible.

Может быть так заработает.
Re: Тренды и таблицы
Маслов Дмитрий; 24.10.04

Динамическое изменение свойства TagName прекрасно работает во всех версиях WinCC. На что меняете, то из архива и читается. Вы только изменяйте это свойство у окна тренда, когда оно невидимо. А после изменения делайте видимым.

По поводу свойств NumItems, Index, Name, ItemVisible: это, конечно, нужные и полезные свойства, но в данном случае не обязательно нужны. Если в окне один тренд, то свойством TagName для выбора тега вполне можно обойтись.
См. http://www.wincc.ru

Re: Тренды и таблицы
Alexis; 25.10.04

Чтобы подгружались значения надо то ли свойство Actualize, то ли свойство Activate у тренд-контрола в TRUE перебросить - это где-то в хелпах описано...


text

Три динамичных уровня на одной шкале
Алексей; 26.7.04

Не могу обуздать 3-d Bar (WinCC 5.1 + hotfix2). Есть ли еще способы отображения уровней жидкостей, разных по плотности, в одной емкости?


text

тэги в WinCC flexible
~BurAn~; 12.10.04

Как же все таки быстрее ввести большое количество тэгов в WinCC flexible? Работая в WinCC 6, я применял Excel. А тут такой вариант, видимо, не срабатывает... Как быть? Не руками же вбивать 2000 тэгов?

Помогите!!!<


text

Удаление аварийных сообщений
Александр; 15.5.04

Подскажите пожалуйста, с помощью вызова какой процедуры можно полностью очистить архив аварийных сообщений Alarm Log ?

(используется WinCC 4)
Re: Удаление аварийных сообщений
Маслов Дмитрий; 15.5.04

Если базу надо очистить при остановленном проекте, то проще всего заменить весь файл RT-базы данных проекта на пустой (взять из WinCC\Bin).

Если это надо сделать при запущенном проекте, то можно из скрипта WinCC обратиться к RT-базе данных посредством вызова функций библиотеки odbc32.dll (описание функций читайте в MSDN) и выполнить SQL-запрос на удаление сообщений: "delete from MSArcLong". Тонкость заключается в том, что если сообщений в архиве очень много, то запрос будет выполняться непомерно долго (поскольку сильно вырастет сегмент отката Sybase). В этом случае полезно выполнять удаление в несколько приемов, удаляя каждый раз порцию сообщений запросом типа "delete from MSArcLong where t between <начальное время> and <конечное время>", с последующим выполнением "commit".<


text

Управление Led's для PC870
Игорь; 7.10.04


text

Ускорение времени выборки из User Archives
Андрей Поздняков; 26.3.04

Доброго времени суток!

Как ускорить время выборки данных из User Archives?

Я поступаю следующим образом:
"uaConnect"

потом, в зависимости от требуемого архива:
"uaQueryArchiveByName"
"uaArchiveSetSort" по ID
"uaArchiveOpen"

потом в цикле
"uaArchiveMoveNext" и
"uaArchiveGetFieldValueLong"
пока не найду требуемую строчку

Читаю данные из строки.
"uaArchiveGetFieldValueLong"

Закрываю, на всякий случай данный архив:
"uaArchiveClose"
"uaReleaseArchive"

И если, по ходу выполнения процедуры, необходимо открываю другие архивы.
начиная с "uaQueryArchiveByName"

Завершается всё это
"uaDisconnect"

Просто хотелось бы узнать у народа правильно ли я поступаю, или есть более быстрый и простой способ работы с UA и особенно с методом выборки из архива.

С уважением.
Андрей Поздняков.
Re: Ускорение времени выборки из User Archives
Nick Gashevsky; 29.3.04

Использую Control Tags для доступа к архиву из WinCC, т.к. несколько раз наблюдалось зависание компоненты Uarchive при интенсивном чтении базы вышеуказанным методом (с активной ф-ей Redundancy). Кроме того, можно простым методом выбрать в архиве запись по номеру записи (например из Table element с настроенными фильтрами)

По сортировке и выборке - Функция uaArchiveSetSort( UAHARCHIVE hArchive, LPCTSTR pszSort )<


text

Установка PCS7 V6.0 с сетевого диска
Евгений Трунов; 3.6.04

Собственно вопрос. Как указать программе установке PCS7 путь к дискам 2 и 3? В руководстве "PCS7 - PC Configuration and Authorization", в главе "Installing the PCS7 Packages in a Network" написано, что такая возможность есть. Однако setup.exe с СД1 упорно просит вставить диски 2 и 3. Настройка в файлах setups.cfg каждого диска секций DRIVE и PATH ничего на дает. Как его убедить ставиться не с СД?

Re: Установка PCS7 V6.0 с сетевого диска
Чистяков Дмитрий ОАО СеверСталь; 3.6.04

Очень просто – надо слить все диски в одну папку.

Re: Установка PCS7 V6.0 с сетевого диска
Евгений Трунов; 4.6.04

Это как? Там что, все файлы в корневых каталогах всех трех дисков полностью идентичны и просто дублируют друг друга?

Re: Установка PCS7 V6.0 с сетевого диска
Евгений Трунов; 4.6.04

Хм. Оказывается, да, как ни странно :-). Спасибо Дмитрию за совет.


text

Установка WinCC 6.0 под Win2003.
Vikond; 16.4.04

Пытаюсь поставить WinCC 6 на Win2003. Не ставиться, SQL сервер. Выдается ошибка

Instaling software failed.

Cluster Services found on this computer.
You must call the original SQL Server 200Setup from your CD-ROM.

Дальше описаны 2 шага установки сервера и его сервис пака.

Все делаю как написано, сервер встает, но WinCC не инсталируется, говорит о том, что SQL сервера не найдено.

Как лечить?
Re: Установка WinCC 6.0 под Win2003.
Лев Шерешевский; 16.4.04

А почему Вы считаете, что WinCC 6 должна работать под Windows 2003?

Почитайте список совместимости WinCC и Windows на
http://www4.ad.siemens.de/WW/news/en/1139080 там о Windows 2003 даже не упоминается.
См. www.wincc.ru

Re: Установка WinCC 6.0 под Win2003.
Vikond; 16.4.04

Там много чего не упоминается. Например то что WinCC 5.0 без проблем на томже самом 2003 работает :).

Re: Установка WinCC 6.0 под Win2003.
Виталий; 21.4.04

WinCC 6.0 под Windows 2003 ставится. Для этого SQL сервер необходимо установить c WinCC Instance (Читайте внимательнее: не SQL сервер не найден, а SQL сервер WinCC Instance).

Re: Установка WinCC 6.0 под Win2003.
Vikond; 22.4.04

2 Виталий.

Если не сложно, можно немного поподробнее.
Re: Установка WinCC 6.0 под Win2003.
Виталий; 22.4.04

SQL Server можно инсталировать с Siemens диска (\SQL2000\Products\MSSQLServer2000\autorun.exe). При инсталяции необходимо ввести Instance Name: WINCC. По умолчанию включена опция Default (нет Instance Name). В заключении следует установить SP3.

Re: Установка WinCC 6.0 под Win2003.
Vikond; 23.4.04

2 Виталий.

Пробовал. На что мне инсталяция ответила "такое имя уже есть" (((.
Re: Установка WinCC 6.0 под Win2003.
Виталий; 23.4.04

Я попробывал при существующем WINCC Instance запускать инсталяцию еще раз. Проблем не возникло. После правильной инсталяции имя сервера должно быть [имя компьютера]\WINCC (можно посмотреть в SQL Server Interprise Manager). После default инсталяции имя сервера - [имя компьютера].

Других препятствий для инталяции WinCC я не заметил.
Instance name - это вопрос, относящийся к SQL серверу. Посмотрите соответствующую документацию или www.sql.ru. Попробуйте отинсталировать SQL сервер, почистите реестр, и попробуйте еще раз.
Re: Установка WinCC 6.0 под Win2003.
Дмитрий; 24.4.04

А вообще нормальную поддержку Win2003 обещают с WinCC 6 SP2


text

Установка WinCC 6.0. Требует MS Message Queuing v 5.0
Chainic; 28.9.04

При установке WinCC 6.0 программа требует microsoft message queuing 5.0. Где взять, сисадмины не смогли помочь. В VB.net должно быть говорят. Кто подскажет?

Re: Установка WinCC 6.0. Требует MS Message Queuing v 5.0
Владимир; 28.9.04

Панель управления->Установка и удаление программ->Установка компонентов Windows-> Очереди сообщений (какой из 4-х компонентов точно нужен не знаю, но если установить все - не ошибешься)

Re: Установка WinCC 6.0. Требует MS Message Queuing v 5.0
Chainic; 1.10.04

И было ему счастье........


text

Установка WinCC6.0 Client
Алексей; 18.11.04

Неужели для этого надо ставить MSSQL server или я где глючу?...

Re: Установка WinCC6.0 Client
Чистяков Дмитрий ОАО СеверСталь; 18.11.04

А то как же. :-)

Это же основа на которой строится сам WinCC. Вас же не удивит установка дельфийский библиотек на компьютер, если программа создана на базе Дельфи. :-)
Re: Установка WinCC6.0 Client
Алексей; 19.11.04

Тогда получается, что в системе с двумя серверами и тремя клиентами будет 5 MSSQL серверов? Или на клиентах MSSQL должен быть запущен в каких-то других режимах?


text

Установка WinCC-проблема
Дмитрий; 7.9.04

При попытке установить WinCC v6 в составе PCS7 v6 вылазит сообщение "Instance WinCC of SQL Server 2000 ServicePack 3 not found on this computer" и установка прерывается. Операционка W2k

Re: Установка WinCC-проблема
Л. Шерешевский; 7.9.04

Так и должно быть. SQL Server 2000 ServicePack 3 следует устанавливать заранее. Инсталлятор прилагается на одном из дисков, входящих в комплект поставки PCS7.

Как говорится, RTFM!
Re: Установка WinCC-проблема
Дмитрий; 7.9.04

На каком же диске он находится, в каком каталоге? Не могу что-то найти

Re: Установка WinCC-проблема
Л. Шерешевский; 7.9.04

Посмотрите внимательно, должен быть диск со специальной версией MS SQL Server для WinCC. Если у вас его нет, обратитесь в Сименс, либо в центры компетенции PCS7 и WinСС, либо к официальным партнерам.

См. www.wincc.ru

Re: Установка WinCC-проблема
Дмитрий; 7.9.04

Можно ли его скачать и откуда

Re: Установка WinCC-проблема
Павел Кобелев; 8.9.04

Проще получить диск в техническом центре Сименс A&D. Этот диск также входит в комплект демонстрационной версии WinCC.


text

установка времени в OP77
SASA; 3.12.04

Как установить время в ОР77. Ставишь просто i/o поле - из него не принимает, в Flexible Compact и в документации ничего ни нашел. Спасибо

Re: установка времени в OP77
Макаров Ю.; 4.12.04

У меня получилось так как написано в:

http://www4.ad.siemens.de/-snm-0135109872-1098201826-0000007885-0000000513-1102141646-enm-WW/llisapi.dll/19322242?func=ll&objId=19322242&objAction=csView&nodeid0=10805558&lang=en&siteid=cseus&aktprim=0<


text

Установка триггеров программно
Людмила; 26.10.04

Проблема такая: есть gscAction, при определенных условиях он не должен вызываться, а при других условиях должен отрабатывать каждые 10 секунд.

Сейчас проверка условия идет внутри gscAction, но таких функций много и это по моему грузит проект. У кого-нибудь есть опыт установки триггера программно, через кнопку на рисунке?
Re: Установка триггеров программно
Alexis; 27.10.04

Вопрос интересный - непонятно только наличие большого множества таких Actions, неужели нельзя уменьшить их количество? Непонятна задача и требования к этим Action, поэтому сразу трудно предложить путь изврата.

Как вариант:
есть одна циклическая action (ваши 10 секунд) которая смотрит на тэг взводимый с картинки и в случае взвода начинает изменять фронт второго тэга - а на изменение второго тэга и подвешаны ваши actions. Подойдет?
Re: Установка триггеров программно
Людмила; 27.10.04

Мысль очень интересная, как вариант это лучше, чем было, спасибо. Попробую. Просто проект не мой, поэтому больших переделок делать не хотелось бы.

В ODK я раскопала очень интересную функцию. Ее использование, по-моему, более эффективно:

LPACTION GSCGenDeleteTrigger (
LPGSC_TRIGGER pGenGT,
AllocAppMem lpfnAllocAppMem,
LPCMN_ERROR lpdmError)

Но у меня она не работает. Примера нет, и я не понимаю, второй параметр.
WinCC ругается: 'GSCGenDeleteTrigger': unresolved external function
====================================OnErrorExecute====================================
dwErrorCode1: (ThreadId 3100) 1007001
dwErrorCode2: (ThreadId 3100) 4099
szErrorText: (ThreadId 3100) Exception in Action
szErrorTextException: (ThreadId 3100) unresolved external function or variable
szApplicationName: (ThreadId 3100) PDLRuntimeSystem
bCycle: (ThreadId 3100) acycle

Может надо как-то объявить ее, может дополнительно какие-то действия нужны. Очень хотелось бы узнать.
Re: Установка триггеров программно
Alexis; 27.10.04

А таким образом объявлять не пробовали:

#pragma code("gscgen.dll")
#include "capigsc.h"
#pragma code()

Второй параметр - это
typedef LPVOID (* OUTSIDE AllocAppMem)(size_t nSize);
те Вам надо передать указатель на функцию, которая заведует захватом памяти, что-то типа стандартного:
void* malloc(size_t size);
это для того чтобы выбитая память в GSCGenDeleteTrigger (и другими подобными фунцайками) была освобождена Вами по заданным Вами же законам, например стандартная связка malloc/free.

Скажу сразу, я с этим семейством функций не работал, и работать не собираюсь, так как предпочитаю использовать вместо недоразвитых скриптов внешний код.
Re: Установка триггеров программно
Людмила; 27.10.04

Объявляла я именно так как Вы пишете.

А вот второй параметр я указала неверно. А "внешний код" вы имеете ввиду собственные dll или даже exe написанные на VB, VC++, Builder, Delphi? Все равно вы, наверное, при этом используете функции ODK?
А задача у меня такая: куча контроллеров опрашивается в цикле. Иногда необходимо установить с одним из них связь и опрашивать каждые 10 сек. Соответствующий action этого контроллера обновляет теги,
делает кое-какие расчеты и т.д. На данный момент каждый такой action вызывается каждые 10 сек и в теле проверяется отрабатывать или закончить работу. Мысль такая: триггеры не ставлю, пока нет постоянной связи. Как только появилась необходимость поддержать постоянную связь с контроллером, устанавливаю на соответствующий action триггер с циклом опроса 10 сек.
Re: Установка триггеров программно
Людмила; 27.10.04

Если есть возможность, не приведете ли пример по фразе: Второй параметр - это

typedef LPVOID (* OUTSIDE AllocAppMem)(size_t nSize); Не могу понять суть: а сколько памяти надо отвалить? Размер передаваемой структуры?

Re: Установка триггеров программно
Alexis; 27.10.04

Внешний - это естественно свои exe, dll, ocx; и естественно все взаимодействие с WinCC через ODK.

На счет второго параметра:
стандартная ситуация, когда кто-то хочет вернуть Вам кусок памяти неизвестной длины, он либо требует от Вас механизм захвата/освобождения памяти (как раз обсуждаемые функции), либо сам предоставляет механизм освобождения (например TLGGetArchivDataEx/TLGFreeMemory).

В случае GlobalScript необходимо предоставить функции для работы с памятью, например у WinCC есть внутренние стандартные (см Internal\allocate) функции:
void* SysMalloc(unsigned long int size);
void SysFree(void* lpFree);
то есть Вы можете передавать SysMalloc в качестве второго параметра, и очищать возвращаемый Вам указатель используя SysFree.

А как в WinCC связь с контроллерами то организована?
Re: Установка триггеров программно
Людмила; 27.10.04

Если есть возможность, не приведете ли пример по фразе: Второй параметр - это

typedef LPVOID (* OUTSIDE AllocAppMem)(size_t nSize); Не могу понять суть: а сколько памяти надо отвалить? Размер передаваемой структуры?

Re: Установка триггеров программно
Людмила; 27.10.04

Спасибо, ситуация проясняется. Только пока все равно не могу понять сколько памяти я должна захватить, ведь void* SysMalloc(unsigned long int size);в качестве параметра требует указать размер.

А в WinCC связь с контроллерами через ОРС сторонних организаций. Сами конроллеры подключены в локалку.

Re: Установка триггеров программно
Alexis; 27.10.04

Вам ничего захватывать не надо! Вы передаете указатель на функцию захвата памяти в GSCGenDeleteTrigger, а она сама, используя переданную Вами функцию, захватит памяти столько, сколько ей нужно и вернет Вам указатель.

Заглянул в ОДКу, там есть какие-то функции типа APActive/APInactive, APStart и APTransAct - может они вам нужны? Правда неразжеваны они нифига, надо методом научного тыка их изучать :))
Re: Установка триггеров программно
Людмила; 27.10.04

Про эти функции я тоже думала, но они еще более непонятны. Примера нет. А так может быть их даже более удобно было бы использовать.Вот, например, второй параметр "Number of actions". Я например незнаю, как получить этот номер. Такую тему я подняла в форуме, но пока никто не ответил. Хоть бы малюсенький примерчик.

Alexis, большое вам спасибо, теперь я хоть знаю ( или кажется, что знаю ) направление куда двигаться. Сейчас буду пробовать применить полученные знания.
Re: Установка триггеров программно
Людмила; 27.10.04

Спасибо, ситуация проясняется. Только пока все равно не могу понять сколько памяти я должна захватить, ведь void* SysMalloc(unsigned long int size);в качестве параметра требует указать размер.

А в WinCC связь с контроллерами через ОРС сторонних организаций. Сами конроллеры подключены в локалку.

Re: Установка триггеров программно
Alexis; 27.10.04

Заинтересовали Вы меня этими стартами-остановами...

Попробовал такую штуку - крутится циклический action и мне удалось усыпить и востановить его циклическую работу с помощью связки функций ApInactive/ApInactive. Единственное, это удалось через ID, через имя пока не получается... Либо надо где-то взять ID :), либо заставить его проглотить имя...
Re: Установка триггеров программно
Людмила; 27.10.04

А где Вы взяли ID для ApInactive/ApInactive? Примерчик скиньте, хоть по e-mail. А я функцию GSCGenDeleteTrigger вставила в Global Action ( до этого я ее пихала в project function), теперь WINCC не ругается, но выскакивает ошибка глобальная Script.exe out memory

int gscAction( void )
{
#pragma code("gscgen.dll")
#include "capigsc.h"
#pragma code()

GSC_TRIGGER GenGT;
CMN_ERROR pError;
LPACTION pvAction;

SYSTEMTIME date;
memset( &GenGT, 0, sizeof(GenGT) );
memset( &date, 0, sizeof(date) );

GenGT.ptGSCDateTime = &date;
GenGT.pAction = "Test.pas";
GenGT.pszTriggerName = "10 s";
GenGT.dwGSCTriggerType = AP_TT_USER_DEF;

pvAction = GSCGenDeleteTrigger( &GenGT, malloc, &pError);

return 0;
}
Re: Установка триггеров программно
Alexis; 28.10.04

Насчет ID - их можно посмотреть в стандартном элементике GSC Run Time.

Насчет ApActive/ApInactive - я еще покопаюсь, потом сюда примерчик закину.

А насчет Вашего примерчика:
LPACTION pvAction=NULL;
...
pvAction = GSCGenDeleteTrigger( &GenGT, malloc, &pError);
if ( pvAction!=NULL )
{
// я думаю это надо зачищать
free(pvAction);
}
Re: Установка триггеров программно
Людмила; 28.10.04

Я поставила отладочные сообщения до и после вызова этой функции:

printf("111111 \r\n");
pvAction = GSCGenDeleteTrigger( &GenGT, malloc, &pError);
printf("222222 \r\n");
так сообщение "out of memory" выходит между ними. Значит ошибка где-то в параметрах.
А ID Вы впихиваете вручную, уже после запуска, когда можно их увидеть?
Re: Установка триггеров программно
Alexis; 28.10.04

ID-шники присваиваются при старте проекта, так как я их пока не могу получить программно, то естественно приходится загонять их ручками.

Кстати, может попробуете вместо malloc передать SysMalloc...

Вот вам примерчик с ApActive/ApInactive, надо передать ID и FALSE - остановка, TRUE - запуск
//-----------------------------------
BOOL actionMgr(DWORD dwID, BOOL bActive)
{
#pragma code("apclient.dll")
#include "ap_def.h"
#pragma code()

CMN_ERROR dmError;
AP_ACT_KEY apk;
BOOL bRet=FALSE;

printf("ap-connecting...\r\n");
memset(&dmError,0,sizeof(CMN_ERROR));
if ( APConnect("AktSteu",NULL,NULL,NULL,&dmError)==FALSE )
{
printf("ap-connect failed:\r\n");
printf("E1=0x%X E2=0x%X E3=0x%X E4=0x%X E5=0x%X\r\n",dmError.dwError1,dmError.dwError2,dmError.dwError3,dmError.dwError4,dmError.dwError5);
printf("Text: %s\r\n",dmError.szErrorText);
return bRet;
}
else printf("ap-connect OK\r\n");

memset(&apk,0,sizeof(AP_ACT_KEY));
apk.dwKeyType=AP_ID_TYPE;
apk.dwID=dwID;

if ( bActive )
{
printf("ap-activing...\r\n");
memset(&dmError,0,sizeof(CMN_ERROR));
if ( ApActive(&apk,1,NULL,NULL,NULL,&dmError)==FALSE )
{
printf("ap-active failed:\r\n");
printf("E1=0x%X E2=0x%X E3=0x%X E4=0x%X E5=0x%X\r\n",dmError.dwError1,dmError.dwError2,dmError.dwError3,dmError.dwError4,dmError.dwError5);
printf("Text: %s\r\n",dmError.szErrorText);
}
else { printf("ap-active OK\r\n"); bRet=TRUE; }
}
else
{
printf("ap-inactiving...\r\n");
memset(&dmError,0,sizeof(CMN_ERROR));
if ( ApInactive(&apk,1,NULL,NULL,NULL,&dmError)==FALSE )
{
printf("ap-inactive failed:\r\n");
printf("E1=0x%X E2=0x%X E3=0x%X E4=0x%X E5=0x%X\r\n",dmError.dwError1,dmError.dwError2,dmError.dwError3,dmError.dwError4,dmError.dwError5);
printf("Text: %s\r\n",dmError.szErrorText);
}
else { printf("ap-inactive OK\r\n"); bRet=TRUE; }
}

printf("ap-disconnecting...\r\n");
memset(&dmError,0,sizeof(CMN_ERROR));
if ( APDisconnect(NULL,NULL,NULL,&dmError)==FALSE )
{
printf("ap-disconnect failed:\r\n");
printf("E1=0x%X E2=0x%X E3=0x%X E4=0x%X E5=0x%X\r\n",dmError.dwError1,dmError.dwError2,dmError.dwError3,dmError.dwError4,dmError.dwError5);
printf("Text: %s\r\n",dmError.szErrorText);
}
else printf("ap-disconnect OK\r\n");

return bRet;
}
//-----------------------------------

осталось только ID определить, либо заставить ApActive/ApInactive через имя работать :))
Кстати, я пиво люблю...
Re: Установка триггеров программно
Людмила; 28.10.04

SysMalloc я тоже вставляла, та же петрушка. Здесь надо, видимо, идти другим путем. Может структуру триггера определяю неправильно. В этом направлении повозиться.

А как любой программер, не люблю ничего вводить ручками. Это не есть хорошо. Программа должна сама все делать после одного щелчка мышки.
А пиво - это хорошо, только Вы ж не до конца программу доделали :((. Правда, идеи Вы подкидывали интересные, спасибо. Так мне как через интернет-магазин бежать за пивом или по телефону можно?
Re: Установка триггеров программно
Alexis; 28.10.04

Виртуальное пиво - это не серьезно :))

На счет моей фунцайки:
вместо -
memset(&apk,0,sizeof(AP_ACT_KEY));
apk.dwKeyType=AP_ID_TYPE;
apk.dwID=dwID;
можно определять так -
memset(&apk,0,sizeof(AP_ACT_KEY));
apk.dwKeyType=AP_NAME_TYPE;
strcpy(apk.szActionName,"имя!");
НО ТРАБЛ! Непонятно как правильно задать имя, типа actionname.pas или actionname не прокатывает.
Надо в wincc-hotline писать, вдруг да они знают :))
Re: Установка триггеров программно
Alexis; 29.10.04

Как это не печально, но я временно прекращаю ковырятся в данном направлении:

- во первых, на мой вопрос в hotline, как для Action-Name получить Action-ID и почему ApActive/ApInactive не работают с AP_ACT_KEY.dwKeyType=AP_NAME_TYPE, пришел как всегда исчерпывающий ответ "It seems it is a bug. I contact the WinCC development an give you a feedback as soon as possible." - подождем...
- а во вторых - я в отпуск ухожу...

На счет моей - BOOL actionMgr(DWORD dwID, BOOL bActive) - будем считать ее доделанной, естественно только для Action-ID :))
Кстати, из той же серии функций, есть хорошая функция APStart - которая просто позволяет запускать скрипты, и что самое важное, откуда угодно (в смысле как изнутри WinCC, так и из внешних приложений) - в общем хорошо, что Вы развели меня на изучение данного раздела ОДКи :))
Re: Установка триггеров программно
Людмила; 29.10.04

Это очень печально, что Вы уходите в отпуск, в такое напряженное для моего проекта время, тем более, что дождь за окном не прибавляет радости. Тем не менее желаю хорошо отдохнуть, набраться сил и как можно быстрее приступить к своим прямым обязанностям. И жаль, что кроме виртуального пива предложить ничего не смогу, я так думаю, что мы живем даже в разных странах. Правда еще есть почта... :)).

А если Вам пришлют оттуда (hotline) ответ, все равно мы узнаем об этом только после Вашего отпуска? Очень надеюсь, что Вы нас не забудете, и если Вам пришлют информацию даже после отпуска, Вы ею поделитесь с нами на страницах этого замечательного форума.
А вообще я удивлена, что никого не заинтересовала эта тема. Ведь можно получить очень гибкий проект. Я сейчас копаюсь над этими функциями в VC++ 6.0. Раскопала ихний пример на VC++5. Он очень огромный и выдает ошибки с самого начала. Ошибка вылезает в wingdi.cpp. А по исходникам читаю, что параметры предлагают загонять ручками. А как раз затык-то в параметрах. Пока успехов нет. Желаю всего хорошего. Еще раз спасибо за участие в моей судьбе.
Re: Установка триггеров программно
Людмила; 29.10.04

В догонку:

Alexis, не могли бы вы дать ссылку на hotline ( быстро не смогла найти где это, а интернета мало чтобы долго искать ). Хочу спросить все-таки про GSCGenDeleteTrigger. А им нужно писать на каком языке вопрос?
Re: Установка триггеров программно
Alexis; 29.10.04

Принимая во внимание Ваше время появления в форуме и дождь за окном, я начинаю подозревать, что мы находимся чуть ли не в одном городе :) а это вселяет надежду на невиртуальное пиво :)

Так как интернет в домашних условиях не редкость, то в случае получения какой-либо информации, Вы узнаете об этом.
На счет того, что никого не заинтересовала эта тема, действительно странно. Правда когда я недавно выложив свой проектик (бесполезности от 7.10.04 - правда там текстовка куда-то делась! ссылка только осталась) на всеобщее обозрение тоже думал, что оно будет хоть кому-то интересно, хотя бы чисто на уровне идеи - ан нет, тишина... То ли все довольны возможностями WinCC, то ли просто лень, то ли не осталось программеров... Все довольны ублюдочными фейсплейтами, переходящими от версии к версии багами, постоянно увеличивающейся монстроидальностью скады и тд и тп... что-то накипело перед отпуском :))

А что за примерчик раскопали?
Re: Установка триггеров программно
Alexis; 29.10.04

Ну я обычно пишу на wincc.odk-hotline@siemens.com и естно на английском.

Re: Установка триггеров программно
GorA; 29.10.04

Возвращаясь к начальному вопросу

"...У кого-нибудь есть опыт установки триггера программно, через кнопку на рисунке?"
Можно сделать проще - создать локальный ТЭГ (или сколько нужно ТЭГов) и по кнопке записывать туда "1", "0", что хотите, а затем использовать в других программах и скриптах.
Re: Установка триггеров программно
Людмила; 29.10.04

GorA: Вы потеряли идею, предлагая такой вариант. Да, я могу запустить action по изменению тега, определяя это в триггере. Но мне не это нужно. У меня есть action, который иногда должен вызываться каждые 10 секунд (ставлю триггер Timer->Cyclic->10 s), а некоторое время вообще не вызываться. Я, наверное, не правильно поставила вопрос о кнопке. Скорее так: установка триггера через функции ODK.

Re: Установка триггеров программно
Людмила; 29.10.04

Re: Установка триггеров программно
Alexis; 29.10.04

Ха! они признались "...it is a bug in ODK..." дык значит этот баг уже лет пять кочует от версии к версии...

2 Людмила: То что версия у Вас 5.1 - это не страшно, должно работать. Мне же интересны идеи и предложения - стоит ли вообще проект продолжать... Кстати, запуск/останов actions я уже намерен туда вставить, вещь иногда полезная...
А примерчика я такого что-то не видел...
Re: Установка триггеров программно
Людмила; 29.10.04

А может с функцией GSCGenDeleteTrigger тоже баг. Может никто этим вообще не занимался. Все выкручивались как могли подручными средствами. А когда они исправят? А не могут ли они подсказать тогда как найти через функции этот самый ID для AP_ID_TYPE?

Re: Установка триггеров программно
Alexis; 29.10.04

Скорее всего никто и не занимался - Вы первая :)

А вот как найти ID - это вопрос... Ихний GSC Run Time откуда-то их берет... Но этим я уже только через пару недель займусь... А может Вы уже найдете... Рекоммендую с хотлайном пообщаться.
Re: Установка триггеров программно
Людмила; 29.10.04

В догонку: Кстати с Вашим, Alexis, примерчиком ApActive/ApInactive, Вы заметили, что в стандартном элементике GSC Run Time при отключении action, ее статус не меняется. Это конечно не страшно, но неправильно.

Re: Установка триггеров программно
Людмила; 29.10.04

с хотлайном пообщаться хорошо, но я понимать-понимаю по-англицки, а вот сказать плохо могу. Правописание у меня хорошее, но почему-то хромает. Не знаете, как это они воспримут?

Re: Установка триггеров программно
Alexis; 29.10.04

Ну у меня тоже не ахти, однако ж как-то приходим к взаимопониманию. Главное программного кода побольше - интернациональный язык :))

А Вы попробуйте в GSC Run Time застопорить акцию, ее статус изменится на deactivated и в конткстной менюшке будет разрешенно только стартовать данную акцию. Теперь если закрыть GSC Run Time, а потом снова открыть, то оно будет в наглую считать, что акция работает и будет предлагать только останов. Эт я к чему, они похоже сами точно не знают в каком состоянии их actions... В их APCLIENT.DLL есть две неописанные функции APGetNotify/APSetNotify причем насколько я понял GSC Run Time работает именно через них, посколько GSCRTCLI.DLL (а это и есть GSC Run Time) явно использует APSetNotify.
Re: Установка триггеров программно
GorA; 29.10.04

Как раз все и нормально.

Пишется первый скрипт, который вызывается раз в 10 секунд.
В нем анализируется ТЭГ включения требуемой акции, и если он, например, =TRUE - , то и вызывать нужную акцию, а если =FALSE - не вызывать.

Re: Установка триггеров программно
Людмила; 1.11.04

Если ничего так и не получиться узнать, почему правильно не работают ODK-шные функции, то так и придется сделать, как Вы, GorA, предлагаете. Это оптимальное решение. Но здесь есть но... Как вызывать нужную акцию. Если по изменению тега, то не всегда нужная Global action вызывается моментально при изменении тега, иногда доходит до минуты и более. Если только нужные функции в project functions затолкать. А самое главное - это нерационально, и не оптимально, что функция будет вызываться каждые 10 сек чаще всего в холостую. И может ей придется работать в холостую неделями. А так я бы ее отключила а когда надо включила. И если она мне в данный момент не нужна, лишние ресурсы бы не тратились, а использовались на другие задачи более рационально. Согласитесь, что это решение намного красивее.

Re: Установка триггеров программно
GorA; 1.11.04

Самое лучшее, на мой взгляд, всю логику управления перенести в PLC. И работа будет устойчевее и логику переключений, включений, вызовов реализовывать проще.

Re: Установка триггеров программно
Alexis; 2.11.04

2 GorA:

Дык логика в PLC - эт одно, а задача то изначально ставилась по осознаному циклическому опросу выбраного контроллера с WinCC-шной станции... типа, хочу - спрашиваю (настойчиво :), не хочу - свободен...

2 Людмила:
Как предлагает GorA - вызов функций по TRUE/FALSE - вроде как неопределенность получается, если основной "10-секундный распределитель задач" не успеет отработать за 10 секунд (типа на все сто контроллеров надо сделать запрос данных) - к чему это приведет? Я так до конца и не понял как работает ApActive/ApInactive - в смысле дожидается ли ДеАктивация остановки акции или происходит замораживание на полпути - тоже кстати интересный вопрос...
А так-то дело за малым - как из имени идешник получить - и тему можно закрывать...
Re: Установка триггеров программно
Людмила; 3.11.04

Для добавления триггера я использовала функцию GSCGenAddTrigger из "API functions of the Global Scripts editor", а есть функция AP_GEN_AddTrigger из раздела "Functions of the Script Programming CS", она тоже добавляет триггер. Может кто знает в каких случаях, какие функции надо использовать?

А ошибку в параметрах я нашла. Теперь функция GSCGenAddTrigger отрабатывает без ошибок, но триггер не появляется,т.е. action по триггеру не отрабатывает.

Re: Установка триггеров программно
Alexis; 3.11.04

Похоже функции вида GSCGen* только для CS предназначены и в RT бесполезны...

Re: Установка триггеров программно
Людмила; 3.11.04

для CS, т.е. при старте системы отрабатывают? Или когда они должны работать?

Re: Установка триггеров программно
Людмила; 3.11.04

Пусть отработает при старте. Мне интересно они вообще на что годны?

Re: Установка триггеров программно
Alexis; 3.11.04

Те по большей части они нужны для автоматизации разработки проекта.

Вы лучше узнавайте как из имени идешник сделать :)
Re: Установка триггеров программно
Людмила; 3.11.04

Да где же узнать. Я написала в "Центр технической поддержки по WinCC" wincc@industrialauto.ru. Но пока молчание. То ли вообще не получили почту, то ли не знают.

Re: Установка триггеров программно
Alexis; 3.11.04

Буржуи то не ведают что кодируют, а нашим то и подавно лень в этом разбираться...

Похоже все идет к тому, что спасение утопающих - дело рук самих утопающих...
Re: Установка триггеров программно
Людмила; 4.11.04

А если они ( wincc.odk-hotline@siemens.com )признались, что через имя у них глюк, то не могут ли они сообщить, как найти ID action. Такой вопрос Вы не задали?

Re: Установка триггеров программно
Alexis; 4.11.04

Задавал, не ответили...

Запросили мои персональные данные, я их послал, сказал что я анонимный тестер :) - наверное в черный список занесли...
Так что теперь Ваша очередь :) а я типа в отпуске...<


text

Филтьрация в Alarm Logging
Алексей; 14.12.03

Народ! Кто-нить подскажите как фильтровать в Alarm Logging по текстовому полю. Я пишу следующую вещь:

Filter.dwTB=8;
strcpy(Filter.szTB[0],"Котёл №1");
Ну и далее вызов фильтра.
Ни фига не работает. Причём нужная колонка устанавливается, а текст не применяется к ней. Стандартными средствами пробовал - получается. Может кто-нить знает где можно информацию поподробнее раздобыть. Заранее благодарен.
Re: Филтьрация в Alarm Logging
Alexis; 15.12.03

Вы используете MSG_FILTER_STRUCT, dwFilter|=MSG_FILTER_TEXT и соответствующие ОДК-шные функции?

А почему у Вас dwTB=8, а szTB[0]?
Вроде если dwTB=8, то szTB[3]...
Помню по фильтрации по классам траблы были в версии ниже 5.1 (в том году обсуждали).
А что за стандартные средства вы пробовали?
Re: Филтьрация в Alarm Logging
Алексей; 15.12.03

Стандартные - это когда в RUN TIME в окошке Alarm Logging нажимаем кнопочку (не помню как называется, но она там есть) в результате появляется окошечко в котором мона выбрать поле для фильтрации и условие фильтрации.

Re: Филтьрация в Alarm Logging
Alexis; 16.12.03

Кнопочка SELECTION? :)

Плохая она, в RT, да через скрипты, imho лучше через sql фильтровать. Гнусный Selection дает фильтровать только по установленным колонкам, а через MsqFilterSQL можно фильтровать по чему угодно... Я во всех стандартно сгенеренных SSM-ом алармовых pdl-ках навставлял свой ALG-Filter Helper - все работает и фильтруется как душе (моей :) угодно...
Re: Филтьрация в Alarm Logging
Алексей; 18.12.03

Научите меня плиз как это делать:-(

Re: Филтьрация в Alarm Logging
Alexis; 18.12.03

Дык опиши проблему поконкретнее...

Если надо в AlarmControl отфильтровать по первому текстовому полю, то можно из скрипта вызвать SetPropChar(...,"Control","MsqFilterSQL","TEXT1 LIKE 'Котёл №1'") - естественно если там есть такой текст :)
Re: Филтьрация в Alarm Logging
Алексей; 18.12.03

Огромный СПАСИБА!

Re: Филтьрация в Alarm Logging
Владимир; 8.1.04

Все это хорошо НО

если задать фильтр скажем DRIVE
то отфильтруются и DRIVE C и DRIVE AB и все похожее.
Как задать ТОЧНОЕ соответствие ???
Re: Филтьрация в Alarm Logging
Макс Прилепский ,ОАО "ЗСМК"; 9.1.04

Точное соответствие достигается строкой TEXT1 = 'DRIVE C' - если в БД WinCC есть сообщение с ТОЧНО таким же текстом (все символы до одного идентичны), то оно отобразится в WinCC Alarm Control. В случае с TEXT1 LIKE 'DRIVE'- будут отображены все строки, содержащие подстроку DRIVE.

В случае с TEXT1 LIKE 'DRIVE С'- будут отображены все строки, содержащие подстроку DRIVE С. <


text

ФИЛЬТР AlarmLogging
ALEX; 12.7.04

ПОДСКАЖИТЕ КАК ПРИСОЕДЕНИТЬ ТАГ ВМЕСТО ПОЛЯ '12-07-2004'-т.е. в С-ACTION:

SetPropChar("имя_окна","имя_окна сообщений","MsgFilterSQL",
"DATETIME >='12-07-2004'AND DATETIME <='12-07-2004'");

Re: ФИЛЬТР AlarmLogging
Л. Шерешевский; 13.7.04

А в чем проблема-то? Формируйте в макросе сколь угодно сложную строку фильтра с использованием любых нужных тегов, а потом записывайте ее в MsgFilterSQL, как Вы собственно и написали.


text

ФИЛЬТР в PRINTER JOB PROPERTIES
ALEX; 13.7.04

Re: ФИЛЬТР в PRINTER JOB PROPERTIES
Маслов Дмитрий; 14.7.04

Описание того, как это сделать, читайте в WinCC Configuration Manual (см. http://www.automation-drives.ru/as/products/doc.php?l1=SIMATIC%20HMI&l2=WinCC&l3=doc).

Функция для изменения диапазона времени ушла по мылу.<


text

Фильтр на AlarmLogin
Дмитрий; 19.5.04

Как выглядит скрипт для фильтрации вывода Аварийных сообщений по встречаемому тексту

PS/ по номерам усё Ok.
Re: Фильтр на AlarmLogin
Маслов Дмитрий; 19.5.04

Вот так, например, выглядит фильтр по первому текстовому блоку сообщения с условием вхождения в текст этого блока заданной подстроки:

TEXT1 LIKE 'искомая подстрока'

А так можно найти все сообщения, у которых первый текстовый блок принимает одно их перечисленных значений:
TEXT1 IN ('искомая строка 1', 'искомая строка 2')

Замечание: поиск подстроки (LIKE) работает весьма медленно, не рекомендую его использовать, если размер архива сообщений большой (для окна текущих сообщений - можно).
Re: Фильтр на AlarmLogin
Дмитрий; 19.5.04

Это понятно. Но как повесить это на кнопку.

Re: Фильтр на AlarmLogin
Маслов Дмитрий; 19.5.04

#include "apdefap.h"

void OnLButtonDown(char* lpszPictureName, char* lpszObjectName, char* lpszPropertyName, UINT nFlags, int x, int y)
{
SetPropChar(lpszPictureName, "имя окна сообщений", "MsgFilterSQL", "TEXT1 LIKE 'искомая подстрока'");
}<


text

Фильтр по времени в Trend"ах
Владимир; 6.10.04

Делаю вручную выбор трендов по времени через BeginTime и EndTime в итоге какая-то глюки. У кого есть скрипт как правильно их использовать?

Вышлите плиз.
Re: Фильтр по времени в Trend
Маслов Дмитрий; 11.10.04

Вот примерчик того, как устанавливать диапазон времени на тренде через функции ODK:

TCHAR szTemplateName[20];
TCHAR szTemplateItemName[20];
SYSTEMTIME stBegintime;
SYSTEMTIME stEndtime;
TLG_CURVESCALEX csx;
DWORD dwAction;

strcpy(szTemplateName, "Заголовок окна трендов (свойство Caption)");
SetIndex("Имя картинки","Имя объекта - окна трендов", 0);
strcpy(szTemplateItemName, GetPropChar("Имя картинки","Имя объекта - окна трендов", "Name"));
dwAction = TLG_TI_ACTION_RANGE_X;

stBegintime.wYear = GetTagWord("Year_from");
stBegintime.wMonth = GetTagWord("Month_from");
stBegintime.wDay = GetTagWord("Day_from");
stBegintime.wHour = GetTagWord("Hour_from");
stBegintime.wMinute = GetTagWord("Minute_from");
stBegintime.wSecond = GetTagWord("Second_from");

stEndtime.wYear = GetTagWord("Year_to");
stEndtime.wMonth = GetTagWord("Month_to");
stEndtime.wDay = GetTagWord("Day_to");
stEndtime.wHour = GetTagWord("Hour_to");
stEndtime.wMinute = GetTagWord("Minute_to");
stEndtime.wSecond = GetTagWord("Second_to");

csx.stFrom = stBegintime;
csx.stTo = stEndtime;

TLGConnect(NULL, NULL);
TLGModifyTemplateItem(szTemplateName, szTemplateItemName, dwAction, &csx, NULL);
TLGDisconnect(NULL);
См. http://www.wincc.ru


text

функция GMSGFUNC.FCT и скрипт
Прокопенко Вера; 28.12.04

В проекте проговор аварийных сообщений реализован следующим образом: при возникновении аварии отрабатывает функция GMSGFUNC.FCT, в которой взводится внутренний битовый тег; по нему отрабатывает глобальный скрипт с функцией PlayWave (char* lpszSound) .

Все работает как-будто корректно, только в файле диагностики периодически появляются записи:
«255,20.12.2004,10:03:26:895,1003015,4,HES,SERVER1_HES,Alarm Logging,AlarmLogging is being overloaded with 2938 messages / 10 min.»
В самом аварийном архиве на это время может быть всего одно аварийное сообщение, а может и вообще не быть.
Чем вызвано появление такой записи? И насколько оптимальна подобная реализация озвучания аварийных ситуаций. Не нравится, что скрипты с проговором нагружают ситему, но операторы привыкли. Используем и функцию PlaySoundA с прерыванием предыдущей фразы.

Re: функция GMSGFUNC.FCT и скрипт
Маслов Дмитрий; 29.12.04

Если используете WinCC версии 6, можно использовать стандартный редактор Horn.

А по поводу сообщения "AlarmLogging is being overloaded with 2938 messages" - мне кажется, оно не связано с проигрыванием звука. Попробуйте в качестве эксперимента вообще отключить проигрывание звука, и посмотрите, сохранится ли проблема. <


text

Функция для изменения архивов TagLogging'a
Кулагин Андрей; 30.1.04

Подскажите пожалуйста каким образом можно _изменить_ одну запись в каком-либо архиве TagLogging'a ?

Например мне надо по по какой-то дате- времени записать в архив ноль. Как прочитать с помощью функций Odk - понятно, но как записать - не нашел.
Re: Функция для изменения архивов TagLogging'a
Маслов Дмитрий; 30.1.04

Можно из скриптов WinCC работать с RT-базой данных с помощью вызова функций библиотеки odbc32.dll.

Если надо - могу выслать по электронной почте пример подключения к базе данных и выполнения SQL-запроса в ней.

А дальше Вам надо будет только сформулировать SQL запрос вида

UPDATE <Table_name>
SET V = 0
WHERE T BETWEEN <Time_min> и <Time_max>
Re: Функция для изменения архивов TagLogging'a
Кулагин Андрей; 2.2.04

Пришлите пожалуйста.

Re: Функция для изменения архивов TagLogging'a
Alexis; 2.2.04

А не пробовал использовать

BOOL TLGInsertArchivData(LPCTSTR lpszArchivName,LPCTSTR lpszVarName,PTLG_ARCHIVDATARAW pTlgData,DWORD dwNumberOfData,DWORD dwFlags,PCMN_ERROR lpError);
и запихивать нужное значение на нужное время?<


text

Хотите WinCC бесплатно?
Никаноров (Сименс-Москва); 30.7.99

Смотрите ссылку

См. http://www.siemens.ru/ad/as/ru/news/index.html

Re: Хотите WinCC бесплатно?
Василенко П Л; 30.7.99

Хочу получить

Особенно ODK и Ock которые на этом диске

НПО Дельфин-Информатика
АСУ-ТП Энергетических объектов

Программист Василенко Петр
Re: Хотите WinCC бесплатно?
ugcma@osetia.ru; 21.2.00

Хочу, если можно

См. http://www.osetia.ru/~ugcma

Re: Хотите WinCC бесплатно?
Алексей; 26.7.04

WinCC 5.1

Re: Хотите WinCC бесплатно?
Авхадеев; 29.7.04

Ссылка не работает.

но хочу:
Vadim8@bk.ru
Re: Хотите WinCC бесплатно?
Владимир; 30.7.04

Ошибка 404: документ не найден

Re: Хотите WinCC бесплатно?
Sergey Shestakov; 1.8.04

Ссылка не работает!

Хочу не столько WinCC 6.0, сколько опциональные пакеты к ней.
Re: Хотите WinCC бесплатно?
Николай; 2.8.04

Бесплатного сыра не будет, будет только мышеловка.

Re: Хотите WinCC бесплатно?
Юрченко Владимир; 2.8.04

Хочу поставить точку в этом вопросе. Ссылка была новостью 5 лет назад и естественно за давностью лет перестала быть таковой. Бесплатный WinCC CS 128 тегов раздавался и раздается для пробы в одном экземпляре на фирму (не конечного потребителя, а разработчика) для ознакомления с возможностями WinCC. За 5 лет было роздана не одна сотня таких комплектов, не говоря о дисках с WinCC без авторизаций. Если у кого то есть желание получить этот комплект, обращайтесь ко мне и если фирма в которой Вы работаете еще не получала обещанное, я готов дать CD и дискету с авторизацией на 128 RC.

Re: Хотите WinCC бесплатно?
Sergey G. Shestakov; 18.8.04

Поставлена точка - это хорошо. Однако хочу спросить у народа: кто-нибудь видел на дисках с WCC все доступные опциональные пакеты к ней, по крайней мере заявленные в каталогах и имеющие весьма значительные цены. Я не могу предлагать заказчику какое-либо дополнение к WCC, если не знаю что это и как это работает. Бог с ними с авторизациями, посмотреть бы... А в WCC 6.0 появились ещё какие-то опции...

Re: Хотите WinCC бесплатно?
Чистяков Дмитрий ОАО СеверСталь; 19.8.04

Все доступные доплнительные пакеты, на диск с WinCC просто не поместятся. :-)

Здесь стоит спросить, какие опции Вы конкретно хотите?
Так в частности такие опции, как "WinCC Server", "WinCC Redundancy" и т.д. имеются в базовом пакете. И Вы можете их установить и без авторизации (при этом они могут работать в демо режиме).
Более подробнее о том, что входит в пакет можно найти в каталоге, описаниях и в краткой информации о продуктах.
http://www.automation-drives.ru/as/products/cat.php?l1=SIMATIC%20HMI&l2=WinCC&l3=cat

Из новых опций идут следующие

WinCC/Dat@Monitor WebEdition (Historian Tools)
WinCC/Connectivity Pack (OPC HDA, OPC A&E, Database Access via WinCC OLE-DB Provider)
WinCC/ Industrial DataBridge (exchange of WinCC data via standard interfaces)
WinCC/ SIMATIC Logon, WinCC/ Audit and WinCC/ Electronic Signature (support when implementing FDA CFR21 Part 11 compliant solutions)

<


text

Хочу ОР к S5-115U
А. Ковальчук; 19.10.04

Доброго Вам!

Така проблема - есть S5-115U, 942-е CPU. Для мониторинга ~50 входов требуется панель - желательно цветная, небольшая, недорогая...
Большую часть времени она будет использоваться только для наблюдения (возможно - это единственная функция!)
Посоветуйте - как и какую панельку можно бы использовать??? И нужны ли ещё модули для подключения???
Да - расстояние от контроллера до 40 метров.
Заранее благодарен всем откликнувшимся!
Re: Хочу ОР к S5-115U
Pavel; 20.10.04

Попробуй UniOP (http://www.emicon.ru/

Re: Хочу ОР к S5-115U
GorA; 21.10.04

Если немного параметров можно попробовать PC670(или просто PC) с WinCC и подключиться к PG интерфейсу CPU.


text

Хочу ОР к S5-115U
А. Ковальчук; 22.10.04

Доброго Вам!

Така проблема - есть S5-115U, 942-е CPU. Для мониторинга ~50 входов требуется панель - желательно цветная, небольшая, недорогая...
Большую часть времени она будет использоваться только для наблюдения (возможно - это единственная функция!)
Посоветуйте - как и какую панельку можно бы использовать??? И нужны ли ещё модули для подключения???
Да - расстояние от контроллера до 40 метров.
Заранее благодарен всем откликнувшимся!<


text

Цвет сетки на тренде
Роман; 20.10.04

Возможно ли установить цвет сетки на тренде не такой, как у графика?

Re: Цвет сетки на тренде
Маслов Дмитрий; 20.10.04

Можно. Установите Low Limit Value равным максимуму шкалы (чтобы параметр всегда был меньше Low Limit Value), включите для него выделение цветом и установите нужный цвет для графика.

См. http://www.wincc.ru


text

че купить RT и/или RC+WinCC Server ?
Малкон; 23.11.04

у нас по идее 12 операторских панелей и 1 сервер. Каждая панель должна отображать какие-то данные технологического процесса.

А вот сервер их все получает.

Дак вот в прайсах совершенно запутанно написано:

"В архитектуре клиент/сервер для клиента достаточно лицензии RT128, на сервере необходима лицензия на нужное число тэгов (например RT64К) плюс опция Server..."

Вопрос, если у меня 12 клиентов к одному серверу, то мне что, все 12 лицензий RT128 покупать ???
А минимальная стоит по 2115 ЕВРО на "границе Германии".

Помогите пожалуйста!!!..
См. http://revda.biz

Re: че купить RT и/или RC+WinCC Server ?
Юрченко Владимир; 23.11.04

Естественно лицензия RT 128 нужна на каждый клиент и выше обо этом и написано. Только настораживает упоминание об операторских панелях, надеюсь что это все таки PC.

Re: че купить RT и/или RC+WinCC Server ?
Roman; 23.11.04

Могу предложить очень хорошую цену за 12 лицензий, если интересно пиши на мыло.

Re: че купить RT и/или RC+WinCC Server ?
Сидоров Артем; 23.11.04

RT лицензии ставятся, как справедливо заметил Владимир, на PC. Для панелей она не нужна. Уточните какая у вас все-таки архитектура : если 12 панелей, то с чем они соединены.

Re: че купить RT и/или RC+WinCC Server ?
Малкон; 23.11.04

да конечно это PC. Однако я не собираюсь ничем управлять с этих 12-ти PC, они нужны лишь чтобы наблюдать.

Мне подсказали, что одной лицензии RT128+server будет достаточно, чтобы повешать на серваке WinCC с опцией Server, и раздавать 12 компам изображения.
Так можно ?
См. http://revda.info

Re: че купить RT и/или RC+WinCC Server ?
Юрченко Владимир; 23.11.04

Если на сервер поставить 128 RT, то только 128 внешних тегов и будут доступны в системе.

Если использовать технологию WinCC Client-Server, то на каждом клиенте должна стоять лицензия RT128. Другой вариант - WebNavigator, там ограничения на одновременно работающие PC. Но в обоих вариантах для работы на клиентах только на просмотр надо завести соответсвующих пользователей.
Третий вариант - использование технологий тонкого клиента (от Microsoft или VNC), но для этого варианта не реализовать только просмотр без управления, так как будет действительно переноситься копия экрана. Да и 12 клиентов такой вариант не потянет, производительность будет очень низкой.
Re: че купить RT и/или RC+WinCC Server ?
Малкон; 24.11.04

Юрченко Владимир; 23.11.04

>> Если на сервер поставить 128 RT, то только 128 внешних тегов и будут доступны в системе.

непонял.. какой системе будут доступны-то ?
Если у меня на сервере одна лицензия RT 128+Server, могу ли я на 12 других компьютеров повесить ВСЕГО ОДНУ копию WinCC с одной купленной лицензией RT 128.
Re: че купить RT и/или RC+WinCC Server ?
Чистяков Дмитрий ОАО СеверСталь; 24.11.04

Если на сервере стоит авторизация на 128 тэгов, то в проекте Вы сможете использовать, только 128 тэгов, в не зависимости от количества станций.

Т.е. если Вам необходимо 1024 тэга, то Вы закупаете на сервер именно такую авторизацию.
При этом всем клиентским станциям достаточно будет иметь авторизации на 128 тэгов для отображения всех 1024 серверных тэгов.
Этим самым достигается
1. Экономия, т.к. не надо закупать полную (в нашем примере 1024 тэга) лицензию на каждую станцию).
2. Удобство разработки и сопровождение проекта, т.к. можно вносить изменения в проект с одной станции прямо на работающем проекте. И все они будут тут же доступны всем другим клиентским станциям.

И не забудьте, что для работы в режиме клиент-сервер, Вам необходима авторизация WinCC Server!
Re: че купить RT и/или RC+WinCC Server ?
Панёв Константин; 24.11.04

Зачем мучаться, ведь если у тебя есть одна дискета с авторизацией 128 RT для сервера, с нее можно сделать 12 копий для клиентов, путем снятия ее образа (под Досом) и установить на все машины

Re: че купить RT и/или RC+WinCC Server ?
Маслов Дмитрий; 28.11.04

Панёву Константину: Вы бы еще посоветовали напасть на сотрудника Siemens и отнять у него коробку с лицензиями.

Администраторам форума: если это возможно, предлагаю удалять из форума сообщения с призывами к нарушению Уголовного кодекса РФ.
Re: че купить RT и/или RC+WinCC Server ?
Панёв Константин; 29.11.04

Маслову Дмитрию: Хорошо Дмитрий, я вас понял, буду иметь в виду :)

Re: че купить RT и/или RC+WinCC Server ?
Малкон; 29.11.04

8)).. мы уже думали над чтобы напасть на сотрудников SIEMENS 8))).

Там очень маленькая вероятность, что у них с собой будет лицензия.

А вот скажите, стоит ли включать в состав покупок лицензию CAL ?
По идее у нас несколько мест, (штук 20) откуда будут работать пользователи из обычных C++ программ, которые подключаються к SQL серверу.

Re: че купить RT и/или RC+WinCC Server ?
Маслов Дмитрий; 29.11.04

Насколько я понимаю, CAL - это немецкое название для лицензии Microsoft на клиента MS SQL Server. Значит, она Вам понадобится на каждое рабочее место, откуда планируется производить доступ к MS SQL Server.

Re: че купить RT и/или RC+WinCC Server ?
Alexis; 30.11.04

Вообще то CAL - это Client Access License. И они необходимы фактически для всех серверных продуктов Мелкософта.

Re: че купить RT и/или RC+WinCC Server ?
Малкон; 30.11.04

Вообщем с мой стороны было бы предложено. Это я как понял одна лицензия покупаеться на одно рабочее место ? если 2 компьютера подключаются к SQL серверу, то нужно уже покупать две лицензии, да ?

Re: че купить RT и/или RC+WinCC Server ?
Панев Константин; 30.11.04

:)


text

ЧЕ ПОЧЕМ???
mike; 25.10.04

Вобщем очень охота узнать сколько будет стоить работа по программированию панели ТР27?

Есть программа, есть панель, нужно только закачать туда программу.

Сколько будет стоть выезд специалиста (например из москвы в пензу (билет 1000р. в один конец)).

И как ваабще калькулируется стоимость таких работ?
Re: ЧЕ ПОЧЕМ???
Владимир; 25.10.04

Существуют так называемые "Сметные нормы на пусконаладочные работы АСУ"

Re: ЧЕ ПОЧЕМ???
mike; 25.10.04

RE: Владимир

Ну а где их посматреть?
Re: ЧЕ ПОЧЕМ???
VGenn; 28.10.04

Могу выслать.

Re: ЧЕ ПОЧЕМ???
mike; 28.10.04

давай на mailevdo@mail.ru


text

Чтение из поля "Date/time" User Archive средствами VBScript
Смирнов Дмитрий; 15.11.04

Как прочитать данные отображаемые в таблице User Archive, в которой присутствуют поля типа "Дата/время", на которые нельзя создать процессые теги, с помощью VBScipt? Эти поля нужны для следующей фильтрации данных архива!


text

Чтение свойств тега в С-фунции WinCC
Evgen; 17.6.04

Подскажите, пожалуйста, как достать нижнее, верхнее значение тега в С-функции. И вообще механизм извлечения свойств тега (Process value range, Tag value range, Upper limit, Lower limit, ...)

Re: Чтение свойств тега в С-фунции WinCC
Alexis; 18.6.04

смотри DMGetVarLimits

Re: Чтение свойств тега в С-фунции WinCC
Evgen; 18.6.04

а можно привести хоть какой-нибудь простенький пример ?

Re: Чтение свойств тега в С-фунции WinCC
Evgen; 18.6.04

... а если не в С-функции ?

Re: Чтение свойств тега в С-фунции WinCC
Alexis; 18.6.04

Пример есть в ОДКе.

Простенький пример:
TCHAR szPrj[_MAX_PATH+1];
if ( DMGetRuntimeProject(szPrj,_MAX_PATH,...) )
{
DM_VARKEY dmvk;
dmvk.dwKeyType=DM_VARKEY_NAME;
lstrcpy(dmvk.szName,"имя тэга");
DM_VARLIMIT dmvl;
ZeroMemory(&dmvl,sizeof(dmvl));
if ( DMGetVarLimits(szPrj,&dmvk,1,&dmvl,...) )
{
// ну и разбираемся чего получили
}
// variant-ы DM_VARLIMIT еще чистим до кучи
}
вроде должно работать :))
Re: Чтение свойств тега в С-фунции WinCC
Evgen; 18.6.04

Спасибо, Alexis.

Вы, конечно меня простите, но хоть что-нибудь о преобразовании VARIANT к Int, char* , ... Описания ODK у меня нет вообще. Искал в Сети - впустую. На всякий случай мой e-mail: evgen@diya.alicetele.com
Re: Чтение свойств тега в С-фунции WinCC
Alexis; 21.6.04

HRESULT VariantChangeType(

VARIANTARG * pvargDest,
VARIANTARG * pvarSrc,
unsigned short wFlags,
VARTYPE vt
);

Parameters:

pvargDest
A pointer to the coerced argument. If this is the same as pvarSrc, the variant will be converted in place.

pvarSrc
A pointer to the argument to be coerced.

wFlags
Flags that control the coercion. Acceptable values are:
VARIANT_NOVALUEPROP. Prevents the function from attempting to coerce an object to a fundamental type by getting the Value property. Applications should set this flag only if necessary, because it makes their behavior inconsistent with other applications.
VARIANT_ALPHABOOL. Converts a VT_BOOL value to a string containing either "True" or "False".
VARIANT_NOUSEROVERRIDE. For conversions to or from VT_BSTR, passes LOCALE_NOUSEROVERRIDE to the core coercion routines.
VARIANT_LOCALBOOL. For conversions from VT_BOOL to VT_BSTR and back, uses the language specified by the locale in use on the local computer.

vt
The type to coerce to. If the return code is S_OK, the vt field of the *pvargDest is always the same as this value.<


text

Что изменяет Split Screen Wizard
Viktor; 1.10.04

Есть одномониторный проект. Работает.

Split Screen Wizardом хочу сделать его двухмониторным.
Что поменяет этот Wizard?
Хочу проверить что было и что стало чтобы потом не возникли проблемы.
Re: Что изменяет Split Screen Wizard
Миша; 1.10.04

А ты сохрани проект (сделай резервную копию), потом попробуй и посмати че произойдет :)

Re: Что изменяет Split Screen Wizard
Viktor; 1.10.04

Я так и сделал. Но может оно поменяло то что сходу не видно.


text

Что такое "Устр-во центральной сигнализации"
Андрей; 15.10.04

Может кто подскажет, что это такое и как с ним бороться. И зачем кнопка на WinCC Alarm Control "Квитирование центрального сигнального устройства" (Horn acknowledgment)


text

Что такое "Устр-во центральной сигнализации"
Андрей; 15.10.04

Может кто подскажет, что это такое и как с ним бороться. И зачем кнопка на WinCC Alarm Control "Квитирование центрального сигнального устройства" (Horn acknowledgment)

Re: Что такое
Маслов Дмитрий; 17.10.04

Насколько я понимаю, это устройство производства Siemens, предназначенное для световой сигнализации (лампочками). Светофор напоминает...

Re: Что такое
Михайлин Сергей; 18.10.04

Это карта в компьютер/станцию с дискретными входами/выходами на борту, кторый можно завязать на определенные классы сообщений в системе. Отчет о испытании сигнального модуля Вы можете прочесть здесь (по ссылке).

См. Отчет


text

Что такое ORPA?
Viktor; 6.9.04

Этот термин встречается в Teleperm-M.

Что таоке не знаю. Кто может помочь с документацией на любом языке.
Re: Что такое ORPA?
Михайлин Сергей; 6.9.04

ORPA это нечто похожее на функциональный блок. Адрес напишите я вышлю документацию на английском.

Только скажите точно на что..у меня 45 файлов с доками по Teleperm
Re: Что такое ORPA?
Viktor; 9.9.04

Спасибо Сергей. Но я не могу использовать почту, могу только скачивать (так настроена политика безопасности). Так что если получится выложить все это куда нибудь, буду благодарен.

Точно скащать что надо не могу, только начал с телепермом заниматься.

Re: Что такое ORPA?
Михайлин Сергей; 9.9.04

Сходите по ссылке, там все доки выложены в разделе Support/Documentation.

Если что еще надо будет - пишите.
См. Страничка системы Teleperm


text

что такое WinCC
Николай; 12.3.04

Пожалйста об'ясните популярно, что такое WinCC? Зачем он нужен для программиста Simatic.

Re: что такое WinCC
Лев Шерешевский; 14.3.04

RTFM:

http://www.automation-drives.ru/as/download/ascat/simatic_hmi/wincc/08_WinCC_r.pdf<


text

Ширина колонок в Report Designer
Юрий; 9.12.04

Как управлять шириной колонок динамических таблиц в Report Designer, особенно колонок, где прописывается время и дата? При печати получается ширина колонки уже чем выводимый текст.

Re: Ширина колонок в Report Designer
Anton; 10.12.04

Нужно в AlarmLogginge указать ширину столбца в символах (это значение глобальное, как для отчетов так и для таблиц в проекте)


text

Шкала времени в WinC Online Trend Control (WinCC 6 SP2)
Макс Прилепский; 26.7.04

Недавно перешёл с WinCC версии 5.1 на версию 6.0 SP2. При работе со штатным компонентом для отображения трендов время на оси всегда обозначается в 12-часовом формате с указанием AM/PM. Манипуляции с Time Base проекта и компонента, ровно как и смена языка проекта с английского на русский ничего не изменила. Язык операционной системы - русский. Эта "фича" компонента вообще как нибудь лечится ?

P.S. В WinCC 5.1 время без проблем отображалось в 24-х часовом формате.
Re: Шкала времени в WinC Online Trend Control (WinCC 6 SP2)
Л. Шерешевский; 26.7.04

В какой-то из версий мы сталкивались с похожей проблемой. Ее удалось обойти, поставив в операционной системе английский locale, но настроив его по принятым в России стандартам. Может быть, в Вашей ситуации этот трюк тоже сработает.

Re: Шкала времени в WinC Online Trend Control (WinCC 6 SP2)
Макс Прилепский; 26.7.04

Спасибо! Способ с изменением параметров английского locale решил проблему,компонент,по всей видимости жёстко "заточен" под locale ID 1033...


text

Шрифты в WinCC
Лёха; 19.2.04

В WinCC были группы тэгов, обозванные по-русски. В один прекрасный момент вместо русских букв появились каракули, хотя когда вызываю свойства группы, то всё нормально, написано по-русски. Может кто расскажет причину?

Re: Шрифты в WinCC
Чистяков Дмитрий ОАО СеверСталь; 19.2.04

В низу этой страницы есть подобный вопрос и ответы

Русский шрифт (WinCC)
http://www.automation-drives.ru/cgi-bin/forum/forum.cgi?dir=1008101956&root=1045054658&year=2004<


text

Экспорт из WinCCUA-TableElement
Human; 23.11.04

Привет! Есть вопросец относительно экспорта данных из архива пользователя:

при использовании кнопки экспорта из тулбара "WinCCUA-TableElement" файлик с данными создаётся в системной дирректории System32, что неудобно, раньше файл создавался в дирректории проекта\ua\. Может кто знает, как это лечится? Делать свою кнопку экспорта не предлагать :).<


text

Экспорт тэгов в cvs-файл
~BurAn~; 7.10.04

Как в WinCC flexible экспортировать таги в текстовый фаил?

Re: Экспорт тэгов в cvs-файл
Л. Шерешевский; 8.10.04

В "cvs-файл" WinCC flexible экспортировать теги не умеет. Может быть Вы, имели в виду CSV-файл?

Экспортировать настройки проекта (в т.ч. и теги) можно в форматы pdf, rtf, htm, tif, а также в текстовый. Для этого надо выбрать пункт меню Project -> Print Project Documentation..., затем настроить параметры документирования и нажать кнопку экспорта.
См. Центр компетенции WinCC

Re: Экспорт тэгов в cvs-файл
~BurAn~; 8.10.04

Да, конечно в csv файл. К тому же я имел ввиду экспортировать значение тэгов в run time (кнопку нажали и значения определенных тэгов записались в csv файл с именем dd_mm_yyyy.csv, например) Это как сделать?

Можно ли использовать в VB скрипте операторы типа Open file_name For Output As #1 ?

Спасибо за ответ
Re: Экспорт тэгов в cvs-файл
~BurAn~; 11.10.04

Нашел сам. Если кому надо то:

Dim fso, MyFile
Dim strTest
Set fso = CreateObject("Scripting.FileSystemObject")
Set MyFile = fso.CreateTextFile("c:\testfile.csv", True)
strTest = Тэг1 & ";" & Тэг2 & ";" & Тэг3
MyFile.WriteLine(strTest)
MyFile.Close<


text

Я хочу писать таблицы в архив ПО СВОЕМУ
Малкон; 15.11.04

Суть с том, что я хочу писать данные в архив не так как мне это предлагает WinCC, а так как я хочу, допустим одни данные в одну табличку, другие в другую, их связать идентификаторами, а что-то может вынести во внешнюю базу. Это делается стандартными средствами WinCC, либо это делается путем программирования функций на C или VB ?

Re: Я хочу писать таблицы в архив ПО СВОЕМУ
Малкон; 15.11.04

Один из вариантов: Решить проблему средствами SQL сервера, путем написания соответствующих триггеров.

Re: Я хочу писать таблицы в архив ПО СВОЕМУ
GorA; 15.11.04

Используй User Archive.


text

odk документация
Кулагин Андрей; 27.1.04

Подскажите пожалуйста где можно скачать документацию по odk ?

Re: odk документация
Маслов Дмитрий; 28.1.04

Скачать вряд ли получится. ODK - это отдельная опция WinCC и собственно состоит из библиотек для работы c WinCC API и документации к ним. Поэтому для получения ODK надо его заказать.

Тем не менее, пакет ODK присутствовал на втором диске двойного CD c WinCC v.5.x, выпускаемом Московским Siemens.
Re: odk документация
Кулагин Андрей; 28.1.04

Эти два диска у нас есть, но документации на odk я там не нахожу. :(

Там только библиотеки и .h файлы. И по ним понять что делает та или иная функция затруднительно.
Диски от 04/2003.
Re: odk документация
Маслов Дмитрий; 29.1.04

Необходимо установить ODK. К сожалению, у меня нет диска от 04/2003. У меня есть диск от 03/2001 (ODK с тех пор не менялся). На этом диске имеется каталог ODK с двумя подкаталогами - Odk_v4 и Odk_v5_update. Сначала надо установить Odk_v4, затем Odk_v5_update.

В результате у Вас появится в меню Пуск/Simatic/WinCC новый раздел: ODK. Оттуда будет возможен вызов справки по функциям ODK на английском языке.
Re: odk документация
Eugene; 29.1.04

Документацию по ODK скачать невозможно, так как она продается за деньги (и очень немаленькие). Собственно, основное, что продается как ODK - это и есть документация. Функции WinCC API и так доступны для использования.

Кстати, во всевозможных примерах функции WinCC API активно используются, но нормально их применять их в своих проектах страшно из-за возможных неясностей в назначении параметров. Так что если есть необходимость серьезного программирования под WinCC, ODK надо покупать по-любому.

Re: odk документация
Кулагин Андрей; 30.1.04

Всем спасибо. Проблема решена.

Книга
Евгений; 17.1.05

Скажите как и где я могу заказать книгу по программированию на WinCC Step7


text

WinCC v6.0 SP2
Human; 7.5.04

Приветствую! Господа, кто-нибудь уже поимел опыт установки WinCC v.6.0 SP2 на русскую Win2000? Если "ДА", то подскажите, как решили проблему отсутствия MS_Hotfix_Q828748 для русской Win2000? Без него WinCC не ставится, а на Microsoft его не выкладывали ещё :(.

Re: WinCC v6.0 SP2
Human; 11.5.04

Вопрос снимается, сам его решил.

Re: WinCC v6.0 SP2
Dmitry; 8.6.04

уважаемый Human,

и же разрешили сий казус?
Re: WinCC v6.0 SP2
Dmitry; 8.6.04

тьфу, и как же разрешили сий казус?

Re: WinCC v6.0 SP2
Human; 9.6.04

Сделал файлик для реестра, он "говорит" установщику WinCC, что данная заплатка установлена :). Ждать выхода SP5 для Win2K нет времени.

Re: WinCC v6.0 SP2
Dmitry; 9.6.04

а можно файлик обнародовать или скинуть на smart-ufa@yandex.ru

Re: WinCC v6.0 SP2
Diana; 9.6.04

И мне!

Re: WinCC v6.0 SP2
luxoft; 10.6.04

Если не трудно, прошу скинуть и на luxoft@rambler.ru

Спасибо!

Re: WinCC v6.0 SP2
MVI; 10.6.04

Если не трудно, прошу скинуть этот файлик и на mvi@iskra-energy.ru :)

Заране, Спасибо!
См. http://MVI

Re: WinCC v6.0 SP2
Sosnina Irina; 11.6.04

А можно еще сюда, пожалуйста sosnina@binar.ru

Заранее спасибо!
Re: WinCC v6.0 SP2
Dmitry; 15.6.04

ну что, кто-нибудь из страждущих получил заветный файлик, а?

Re: WinCC v6.0 SP2
luxoft; 16.6.04

УВЫ!

Re: WinCC v6.0 SP2
Nick; 18.6.04

Добавьте ключ

HKEY_LOCAL_MACHINE\Software\Microsoft\Updates\Windows 2000\SP5\KB828748
Он добавляется при установке на английскую винду
Re: WinCC v6.0 SP2
Human; 7.7.04

Люди, сорри, что не помог - был в коммандировке, а там инета нет.

Re: WinCC v6.0 SP2
Serg; 13.1.05

Чего-то я не понимаю как эта проблема решается? Поставил win2000 sp4 на русском, так как этот ms hotfix тоже установить?

Спасибо

Re: WinCC v6.0 SP2
Сергей; 18.1.05

Ручками добавить в реестр ветку с нужным апдейтом.

Re: WinCC v6.0 SP2
Evgeniy; 28.1.05

Да, бывают же извращения... Спасибо за ключик. Счастья вам :)


text

WinCC и OLE Automation
Кирилл Калишев; 3.12.98

В "WinCC system description" есть упоминание о том, что WinCC в рамках своей открытости является automation сервером. В configuring manual есть пример, в котором портируется через ole значения тегов, но не приведена номенклатура verbs (глаголов) )для WinCC, а есть только конкретный пример. Где эту информацию можно получить?

Re: WinCC и OLE Automation
A&D AS Никаноров; 29.12.98

Я вышлю Вам примеры напрямую.

Re: WinCC и OLE Automation
Mabroolo; 7.7.99

Хотелось бы также получить примеры.

Заранее спасибо!

Re: WinCC и OLE Automation
Игорь П.; 25.10.01

Я тоже не отказался бы от примеров.


text

Битовые тренды WinCC 5.1
Константин; 14.12.04

Не работают Битовые тренды WinCC 5.1. На комп. кроме этого стоит STEP 5.2. Ставил Hotfiх 0, но это не помогло. В конфигурации со STEP 5.1 вроде всё нормально. Помогите!

Re: Битовые тренды WinCC 5.1
Ilja; 19.1.05

Слету могу посоветовать либо поставить WinCC 5.1 SP2, либо STEP 5.3

У меня глючило ВСЕ, когда стояли несовместные версии. Таблица совместимости, кстати, есть в инете.


text

Схема распайки MPI-кабеля
Кушников Олег; 24.9.99

Интересует распайка стандартного MPI-кабеля 6ES7901-0BF00-0AA0

Re: Схема распайки MPI-кабеля
Чистяков Дмитрий; 13.10.99

Распайка кабеля MPI ничем не отличается от кабеля PROFIBUS. Подключаются контакты 3 и 8.

Но вообще стандартный кабель не распаивается, а имеет клеммы под винт.
Re: Схема распайки MPI-кабеля
Иванов Павел (Сименс-Москва); 13.10.99

Распайка MPI-кабеля приведена в руководствах по программаторам (PG 720/740/760).

Pin
3 - Line B
4 - PG Active
5 - Ground (5V)
6 - Power +5V
8 - Line A
9 - PLC Active

WinCC V5.0
Жилинков В.А.; 10.4.01

Что дополнительно включено в новую версию Wincc?

В чем ее отличие от v4.02?
Какой дополнительный графический редактор можно использовать для создания 3-D обьектов?
Можно ли проект, созданный с помощью 4-ой версии открыть в 5-ой?
Можно ли использовать WinCC V5.0 в PCS7?


text

Работа с EPROM, ресурсы SIMADYN D
Андрей Усенко; 16.11.99

Здраствуйте ! Господа, я хотел бы получить ответы на несколько своих вопросов:

- В своей работе использую PG730, Srtuc L Ver. 3.2.3(с хардлоком), модули памяти MS41(MS43). Мне необходимо считать информацию с модулей памяти MS41(MS43), что бы получить исходные файлы функциональных пакетов (*.cfp) и мастер программы (*.cmp). Возможно ли выполнение такой задачи на имеющихся у меня средствах? Если выполнение задачи не возможно, то какие программные и аппаратные средства необходимы для выполнения этой задачи.

- Необходима информация о ресурсах последних версий систем Simadyn D и Simoreg.
Процессорный модуль(производитель CPU, частота), объем модуля памяти(EPROM,флэш), возможности языка программирования (плотформа под которой он работет, "графический интерфейс"). Наличие графических пакетов позволяющих оссцилографировать например прокатную клеть (10 параметров) или прокатный стан с дискретностью 1mS в течении 5-ти суток. Возможность диагности оборудования через коммутируемые линии.

С уважением господин Андрей Усенко uaw@alba.dp.ua .

Re: Работа с EPROM, ресурсы SIMADYN D
Чистяков Дмитрий ОАО "СеверСталь"; 17.11.99

Здравствуйте!

Скачнуть программу из субмодулей памяти не получиться (по крайней мере пакеты не получишь).Это связанно с тем, что программа SIMADYN D (в отличии SIMATIC) компилируется, как EXE-файл и вытащить обратно пакеты практически не возможно.

Подробности об устройствах можно найти в каталоге CA01.

Последней новинкой из этой области у Siemens`а является модуль FM458 - это SIMADYN D выполненый в формате S7-400. Прообразом этого модуля (или копией)является самый мощный на сегодняшний день процессор PM6 - 64 разрядный RISC процессор.
Ограничения по памяти программы формируются только производством flash-карт. На данный момент это 8 Мбайт (мои данные могли устареть). Но по сути дела программа для SIMADYN D 8 Мб - это нечто сверхестественное.
В качестве программных продуктов, возможно использование "старого" доброго STRUC G ver 4.2.5. или CFC в комплекте со STEP7. Сейчас STRUC G практически не обновляется и видимо со временем умрёт, отдав лавры победителя CFC. STRUC G работает под SCO Unix, а CFC под Windows 9x/NT.
В качестве системы осцилографирования Siemens`овский ANL обычно предлагает продукцию фирмы IBA (www.iba-germany.com). Она позволяет записывать 512 аналоговых и 512 дискретных сигналов с дискретностью 1 мс. И имеет прямое подключение своей системы с SIMADYN D через модули CS12/13/14 по оптоволоконному кабелю. В добавок ко всему фирма разработала несколько пакетов целенапраленных на работу с прокатными станами.

Если что, то лучше обратиться по почте, а то имею ограниченный доступ в on-line.
sta5@stal.ru

Re: Работа с EPROM, ресурсы SIMADYN D
Андрея Усенко; 24.11.99

Спасибо!

Re: Работа с EPROM, ресурсы SIMADYN D
Тарасов Всеволод; 23.3.01

Подскажите, где можно скачнуть библиотеки Siemens`а для автоматезированного проектирования? Или где есть информация о них?


text

SM331
АО ; 10.3.99

Мы купили у Вас модуль SM331

(6ES7 331-7KB01-0AB0)
Как мы можем получить его описание и схемы подключения к нему датчиков (более подробные чем рисунок на фронтальном штекере)?
Re: SM331
Техническая группа A&D S; 12.3.99

У нас имеется полное описание всех модулей для

S7-300 на русском языке.
Заказной номер: 6ES7 398-8AA02-8AA0-RUS.
Конкретно по данному модулю, мы можем выслать
информацию по факсу или E-Mail(по запросу).

Габариты SIWAREX R
Eugene; 30.7.00

Где взять габаритные и присоединительные размеры весоизмерительных датчиков SIWAREX R различных исполнений?

Re: Габариты SIWAREX R
Павел Иванов (Сименс-Москва); 11.8.00

В каталоге KT30 по SIWAREX или в руководстве по SIWAREX R, которое можно скачать с центрального немецкого сайта или переписать в наших центрах.


text

О неисправности модуля SE20.2(система SIMADYN D)
Андрей Усенко; 17.12.99

Здраствуйте, необходима информация о микросхеме, которая установлена в модуле SE20.2. На корпусе микросхемы надписи:

PMI
OP400HP
T9542
D29786A
С уважением Андрей.

Re: О неисправности модуля SE20.2(система SIMADYN D)
Чистяков Дмитрий ОАО "СеверСталь"; 29.12.99

Re: О неисправности модуля SE20.2(система SIMADYN D)
Андрей Усенко; 26.6.00

Устранили эту неисправность программно.


text

Запись в EPROM S5-110
Владимир (ВАЗ); 29.11.99

Возникла проблема записи программы в EPROM(RAM)

в контроллере S5-110 при отсутствии PG670.
Если другие решения?
Re: Запись в EPROM S5-110
В. Ковин. (ВАЗ ); 29.11.99

Рабочий вариант.

Пишите программу в OB1 с учетом команд S5-110.
Первая команда NOP 1.(FFFFН). Записываете в EPROM предварительно забив первые байты FFН до первой комбинации FFFF(NOP 1). Если сделаете все првильно
будет работать.

SIMATIC S5-110
Khaled Alaghil; 6.4.00

I used SIMATIC S5-110 in the packing machine in my diaper machine - manufacturer FAMMECCANICA - in Italy. I need to buy a simatic S5-110 as a spare part to replace the one that is presently in the packing machine.

Kindly advise where can I buy a new one ?????

Re: SIMATIC S5-110
Никаноров В. - Сименс, Москва; 6.4.00

You can find contact person's with help of this URL

См. http://www3.ad.siemens.de/partner/index.asp?language=en&searchmode=technology&techid=1


text

Железо PG730
АО Элем; 21.10.99

На PG730 вышли из строя обе лампы подсветки дисплея. Можно ли их у Вас заказать?

Или подскажите, где можно их найти или чем заменить.
Re: Железо PG730
Виктор; 21.10.99

Может это не лампы вышли из строя, а то что их питает? Сразу две детали обычно не выходят из строя.

Если Вы в Москве, то советую поискать на митинском радиорынке.
Re: Железо PG730
АО Элем; 21.10.99

Прошу прощения, но лампы умирали постепенно и по очереди. Дисплей - Toshiba, лампы FC2EXN/250T8/H/G

Re: Железо PG730
Иванов Павел (Сименс-Москва); 21.10.99

Лампы подсветки для PG730 конечно можно заказать как запчасть

для PG 730 SX/DX:
Backlight- Box
C79451-Z1133-K2

для PG 730C:
Backlight - Unit (2 Röhren)
C79451-Z1502-K1

Re: Железо PG730
Алексей Даньшин; 5.11.99

Подскажите пожалуйста каталог, откуда взят этот заказной номер. Хотелось бы выяснить это одна лампа или блок подсветки всборе.

Re: Железо PG730
Павел Иванов (Сименс-Москва); 27.3.00

Каталога на запасные части по программаторам нет.

Для PG730C это две лампы подсветки.


text

обмен модулями
Papik; 7.12.99

обменяю следующие модули :

6ES5310-3HB11 НА МОДУЛИ : 6ES5924-3SA11
6ES5304-3UA11 6ES5925-3SA11
6ES5512-5BC21 6ES5926-35A11
6ES5301-3AB13 6ES5927-3SA11
6ES5324-3UA11
6ES5445-3AA12
6ES5476-3AA11 ВОЗМОЖЕН НЕ РАВНОЦЕННЫЙ ОБМЕН
6ES5420-3BA11 Т.Е. НЕСКОЛЬКО МОИХ И ОДНА ВАША
6ES5465-3AA13
6ES5512-5BC12
Re: обмен модулями
dimidrol; 12.3.00

Повсему видимому у тебя 150 симатик

у меня такойже очень интересно пообщаться
пиши


text

LOGO!230
Олег Бакиров; 22.12.99

Ваше сообщение...

Купил на Митино контроллер LOGO!230 RLB11. Сказали что может все. Так и
есть но большинство нужных функций привязано к часам реального времени,
которых как раз таки и нет в этом аппарате. Подскажите что нужно
докупить (какой модуль) чтобы эти часы появились или заработали, ну или
какие-то варианты есть?
Re: LOGO!230
Никаноров - Сименс; 22.12.99

Надо просто купить другой Logo, в котором есть часы (с буковкой С в обозначении, что означает Clock).

Re: LOGO!230
ПАВЛЯК К.С.; 27.2.00

ПОЧЕМ такие контроллеры на МИТИНО ????????

Свой не продаешь ?????
Если есть предложения - звони, звони....


text

вопрос по ZBE
Papik; 7.12.99

подскажите пожалуйста где можно найти

хоть какую небуть доку по терминалу ZBE это древний Cименовский терминал
на процесоре Z80 подключен он у меня к контроллеру 150S

Re: вопрос по ZBE
Никаноров (Сименс - Москва); 1.2.00

Надо более подробную информацию.

Возможно, есть заказной номер и т.п.


text

Как обратится к памяти CPU SIMATIC S7
Шишков Сергей; 22.12.99

Ваше сообщение...Можно ли узнать кодировку МС7 и есть ли возможность в SIMATIC S7 каким-либо образом считывать содержимое произвольной области памяти CPU, например, области, где распологается рабочая программа.

Re: Как обратится к памяти CPU SIMATIC S7
Никаноров (Сименс - Москва); 23.12.99

В S7 нет прямой адресации в память. Считать память другими средствами также невозможно.

Поэтому кодировка MC7 не приводится.


text

115u -- аналог.модульи
Papik; 17.11.99

подскажите сколько стоят аналоговые модули к 115u и есть ли вообще таковые

сколко имеют "инпутов" входные и сколько "аутпутов" выходные ( имеется в
виду каково количество в одном модуле )
Re: 115u -- аналог.модульи
Михайлин Сергей; 6.12.99

Вся эта информация находится в катологе ST50 со всеми характеристиками.

Я вышлю Вам кусок каталога по электронной почте.
Re: 115u -- аналог.модульи
Дедовец Павел; 6.12.99

Информация о модулях отправлена Вам на E-mail.

Два rtf файла и один mdb(Access).

Желаю удачи.


text

Программирование S5
Николай Тарасов; 20.7.99

Каким образом можно работать с четырьмя

(и более) контроллерами Simatic S5 через
порт программирования на IBM PC?
Есть ли какой-нибудь мультиплексор,
программно поддерживаемый STEP5 ?
Еще огромная просьба сообщить стоимость
программно-аппаратных средств для
реализации программирования четырех
контроллеров Simatic S5 с одного IBM PC.

Николай.
Re: Программирование S5
siemargl; 20.7.99

А перетыкать кабель слабо?

Не пойму смысла затеи.
Re: Программирование S5
Чистяков Дмитрий; 21.7.99

Проще всего установить CP1413(CP5412) в PC и программировать через него №-ое количество S5.

Естественно необходимо в S5 установить соответствующие модули.
Re: Программирование S5
Никаноров (Siemens-Moskau); 26.7.99

Если контроллеры в сети (Profibus или Ind.Ethernet), то их можно программировать с одного РС, подключившись к порту программирования одного из контроллеров.

Если же возможности построить сеть нет, то стандартного решения не существует.
Re: Программирование S5
max; 5.8.99

На АвтоВАЗе выпускается плата коммутатора с интерфейсом

"токовая петля" на 8 портов стоимостью около 2000 рублей.
К ней прилагается описание и драйвер написанный на Borland C.
Зделано "по-русски", коряво, но работает стабильно и без сбоев.
С продавцом можно связаться по avers@infopac.ru

Re: Программирование S5
Иванов Павел (Сименс-Москва); 26.8.99

Такой вариант скорее всего не будет работать, т.к в STEP 5 нет поддержки этой платы.

Есть стандартное решение: устройство называется 757 programming device multiplexer. И этот вариант поддерживает пакет STEP 5.
Возможно одновременно работать с 8 контроллерами SIMATIC S5.
Номер для заказа 6ES5 757-0AA11.
Информация про него есть в бумажном каталоге ST50 и в электронном CA01.
Re: Программирование S5
В. Ковин.; 26.11.99

Устанавливается блок связи 64.33.016.00.00.000 ПС

ПТО ВАЗ в PC на 8 каналов. Кналы - TTY. Просто и сердито. Орентировочная цена 1500р.


text

Catalog ST57
Ilya; 18.11.99

Где в инете можно найти (и скачать) каталог ST57 (Standart function blocks description)?

Thanks in advance.
Re: Catalog ST57
Иванов Павел (Сименс-Москва); 19.11.99

На нашем центральном сайте есть интерактивный электронный каталог CA01, в котором находится информация по всем продуктам, выпускаемым нашим департаментом. В том числе в соответствующем разделе есть описание и функциональных блоков для S5.

Или Вы можете посмотреть в бумажном каталоге ST50.
Все каталоге по S5 сведены теперь в общий каталог.


text

Релейные защиты
Эдуард Сафронов; 12.11.99

Встретил в тендерной документации на АСУ ТП

ОАО "Волжская ГЭС" ссылку на микропроцессорные релейные защиты SIEMENS типа 7UT511, 7UT512
7UT515 и т.д. Где по ним найти тех. описание.
Re: Релейные защиты
Иванов Павел (Сименс-Москва); 19.11.99

Это оборудование выпускает другой департамент фирмы Siemens, называется EV (передача и распределение электроэнергии).

Свяжитесь с ними сами по телефону.


text

обучение
Dmitriy Seredin; 15.11.99

Вот назрел вопрос на нашем предприятии об обучении работе с оборудованием Siemens

Simatic и программированию контроллеров на
Step 5. Есть предложение от представителей Siemens в нашем городе(Рязань),но они не
обещают сертификат от Siemens.
Каково качество и уроверь обучения на курсах
в Москве и других городах? Какую литературу и какие документы об обучении предоставляют после
прохождения подобных курсов?
Хотелось бы услышать мнение знающих людей по
вопросу обучения.
Заранее спасибо.

Re: обучение
Альтерман И.З; 18.11.99

В Москве курсы по SIMATIC S5 (ST-SYS1,ST-SERV,ST-PRG) проводят специалисты, имеющие сертификат от фирмы SIEMENS.

О качестве обучения можно судить по положительным отзывам от участников, прошедших обучение (а их более 300 !). В учебном процессе используются современные технические средства обучения (проекторы, современные программаторы, имитаторы технологического оборудования и т.д. Каждый участник получает учебное пособие по учебному курсу (более 100 стр.)с изложением основных вопросов.
После успешного окончания курса участник получает сертификат единого образца, выдаваемого по всему миру во всех лицензионных центрах обучения SIEMENS.
Для участия в курсе вначале нужно прислать заявку
по факсу 737-24-83. Желаем успехов!


text

FM 353: ввод технологической программы
Рябов Андрей; 17.11.99

На оборудовании установлено: OP7 + CPU313 + FM353 + DI/DO и соответственно шаговый привод. Требуется часто менять технологическую программу позиционирования в FM353.Запись новой техн. программы в FM353 возможна при использовании ПО STEP7+конфигурационный пакет FM353 или с ОР7, используя специальные функции. НО, первый вариант на оборудование не поставишь, второй - довольно медленный и не наглядный способ.

Существуют ли ещё какие-либо способы ввода техн. программы в FM353? Можно ли для этой цели использовать, например, PRODAVE?


text

Доступ к меркерам с панели оператора
Юрий О.; 5.11.99

У меня ситуация следующая: К контроллеру S7-300 подключена панель оператора OP7. При конфигурации этой панели созданы тэги, указывающие на область меркеров контроллера. Программа в S7-300 написана так, что по ходу выполнения ее цепей меркер принимает различные значения, а значение меркера, отражающее истинное положение вещей формируется при обработке последних цепей программы.

Мой вопрос: Может ли создаться ситуация, когда панель оператора считает значение меркера в середине цикла выполнения программы и, таким образом, получит неверное представление о процессе?
Еще один вопрос: Что подразумевает системный атрибут "S7_m_c" (параметр будет модифицироватся с панели оператора) и чем грозит его неустановка?
Заранее благодарю за ответ и поздравляю всех, кто дочитал до этого места.
Re: Коммуникации S7-300
Никаноров Владимир (Сименс, Москва); 5.11.99

Контроллер S7-300 устроен таким образом, что коммуникационные задачи он выполняет между циклами выполнения пользовательской программы (в отличие от S7-400, который имеет дополнительный коммуникационный процессор).

Поэтому, ситуация, которой Вы опасаетесь, возникать не должна.
Однако, обычно программа так не пишется. Т.е. если Вам надо выводить какую-то переменную на ОР, то сохраните ее значение в нужный момент времени либо в другом меркере, либо в блоке данных.

Установка (или не установка) атрибута "S7_m_c" в описанной Вами конфигурации на работу контроллера с панелью оператора никак не влияет. Он может быть использован при работе с WinCC для автоматического переноса переменных STEP7 в WinCC.


text

Надежность реле и модулей Simatic S5
АО ЭЛЕМ; 26.10.99

Уважаемые господа!

Можете ли вы предоставить среднестатистическую количественную оценку надежности аппаратуры коммутации (реле), используемой в промышленности , модулей с дискретными выходами ~220В Simatic S5 и модулей с релейными выходами Simatic S5, для проведения анализа о целесообразности замены контакторно-релейных систем управления на системы управления на базе ПЛК Simatic S5?
Понятен ли Вам такой вопрос?
С уважением,
инженер АО Уралэлектромедь
Трушин М.Ю.
Re: Надежность реле и модулей Simatic S5
Андрей Гуленок; 28.10.99

Не совсем понятно, что подразумевается под среднестатистической количественной оценкой. Если речь идёт о ресурсе релейных модулей SIMATICа, то этот параметр приводится в каталогах. Если это наработка на отказ, то EXСEL-таблица занимает более мегабайта. Её можно получить у нас в бюро или у наших представителей в регионах.

В целом могу заметить, что использовать SIMATIC S5 на сегодняшний день нецелесообразно, так как семейство S7 ощутимо дешевле. А выводы о приемуществах контроллеров перед релейно-контактными схемами сделаны лет двадцать назад.
Надежность модулей Simatic S5 и реле.
Уралэлектромедь; 28.10.99

Уважаемые господа!

Уточню свой вопрос. Под среднестатистической оценкой я подразумевал оценку, полученную в результате усреднения данных о надежности продукции разных производителей (Вы разумеется согласитесь, что реле или электронная техника, произведенные к примеру в г. Москва, отличаются от аналогичных, произведенных в г. Мюнхене).
Перечислю интересующие показатели надежности:
MTBF,MTTR, ресурс.
Кроме того, мне известно, что преимущества контроллеров перед релейно-контакторными схемами имеют место. И что выводы об этом уже сделаны (как Вы сообщаете лет 20 лет назад). Однако, мне бы хотелось иметь об этом конкретную информацию с цифрами (другими словами количественные показатели) и при этом желательна ссылка на источник (так как источников разумеется много).
Вопрос возник только из-за отсутсвия этих самых источников в ближайшей технической библиотеке.
Соотношение цен на S5-S7 я, разумеется, учту. Интерес именно к модулям S5 вызван наличием "основной корзины" и модулей ЦПУ семейства S5 135, поэтому неочевидно, что будет дешевле в нашей ситуации - докупка модулей S5 или приобретение ПЛК на базе S7 в полном объеме (анализ соотношения цен я еще не производил).

Спасибо за проявленное к вопросу внимание.
С уважением, инженер АО Уралэлектромедь
Трушин М.Ю.

Re: Я же Вам выслал данные по SIMATIC
Никаноров (Сименс); 29.10.99

...

Благодарю за помощь и внимание.
Уралэлектромедь; 2.11.99

Уважаемый господин Никаноров, данные по Simatic я от Вас получил. Благодарю Вас за помощь и внимание.

С искренним уважением, инженер АО Уралэлектромедь
Трушин М.Ю.


text

AS функция блокирована. Функция недоступна.
Андура Виктор; 20.10.99

Re: AS функция блокирована. Функция недоступна.
А.Степанов; 22.10.99

В данном CPU возможно случайное изменение состояния системного байта BS120.

Можно попробовать дописать в OB1 и OB21 строку:

RU BS120.0

Это сброс software protection, которая могла установиться произвольно.


text

описание step5 на русском
Papik; 26.9.99

Ребята кому надо полное описание с фотографиями и примерами

по step5 полностью на русском причем все описанно до мельчайших
подробностей ( разжеванно и в рот положенно )
формат WORD A4 обший объем около 800 стр. 25мегов
пишите ___ о цене договоримся. fops@inbox.ru

Мылом отправил месагу, жду ответа (-)
Виктор; 22.10.99


text

Тип CP в PC R145
АО ЭЛЕМ; 18.10.99

Прошу указать, какой тип коммуникационного процессора используется в PC R145.

Спасибо.
Re: Тип CP в PC R145
Иванов Павел (Сименс-Москва); 18.10.99

Если у Вас RI45 PII, то на материнской плате интегрирован CP5611. Он поддерживает работу по сетям MPI, PROFIBUS с поддержкой протоколов S7, DP.

А на RI 45 PIII в дополнение к нему интегрирована сетевая плата Fast Ethernet (10/100 Mbit).


text

step5-декодер
Дима; 20.6.99

Где взять декодер который втыкается в порт для запуска STEP5 на PC или

как собрать самому или купить?????
А зачем декодер, просто пакет STEP5 для PC.(subj)
Андура В.; 21.6.99

subj

Re: step5-декодер
Иванов Павел ; 5.7.99

Есть стандартный продукт, который называется STEP 5 for PC, и его можно приобрести обычным способом у нас или у наших партнеров.

Этот пакет до версии 6.5 включительно защищался с помощью так называемого донгла, который подсоединялся на LPT-порт. Начиная с версии 6.6 пакет защищается с помощью специальной дискеты авторизации.

Не забудьте только, что для связи с контроллером, Вам будет необходим также кабель с конвертором (RS232 в TTY- токовая петля 20 мА).

Re: step5-декодер
Virus Resident; 9.7.99

Все это фигня

Step 5 давно уже сломан как новые так и старые версии
работает без проблем
Re: step5-декодер
R.A.E.L.; 12.10.99

Пакет для PG прекрасно работает на PC

Защита там примитивная, он просто смотрит в ПЗУ марку машины. Короче, подправить - на 5 минут дела


text

Глюки STEP 5 6.65 / R
Сергей В. Филиппов; 12.10.99

Имеется следующая проблема:

при работе во втроенном редакторе символики при попытке сохранить исправления (по кнопке "Сохранить") иногда происходит потеря данных. Пакет матерится, что файл *.tm0 не существует, при этом намертво затирается сам оригинальный файл символики *z0.seq . Проблема возникает как под Windows 95, 98, так и под DOS. От выбранного языка интерфейса не зависит. Иногда (на маленьких файлах и значительно реже) выпадает сообщение, что не существует сам *z0.seq (;-)!), правда, при этом данные выживают. Сохранение через "ВВОД" (с выходом из редактора и компиляцией в *z0.ini) глючит значительно реже.
Если кто сталкивался с такой проблемой - подскажите решение.


text

TTY кабель
Papik; 9.9.99

сколько стоит ваш кабель TTY для соединения CPU-100 с PC

только пишите конкретно сумму пожалуйста а не номер заказа
а лучше схему кто может пришлите как можно самопальный
собрать
Re: TTY кабель
Чистяков Дмитрий ОАО "СеверСталь"; 29.9.99

Подключение к порту TTY на прямую с COM-овским портом не возможно. Необходим преобразователь в интерфейс "токовая петля", по нашему советскому это ИРПС. Это гальванически развязаный канал в котором логическим "0" считается ток > 10ма, а "0" <5ма.

Более побробно описано подключение в описании программаторов PG740, PG760 глава 7 стр. 17


text

tty кабель s5-100u---->PC
Papik; 11.9.99

сколько стоит ваш кабель TTY для соединения CPU-100 с PC

только пишите конкретно сумму пожалуйста а не номер заказа
,,,,,а лучше схему кто может пришлите как можно самопальный
собрать

Re: tty кабель s5-100u---->PC
Гуленок Андрей; 11.9.99

А стоит он пока 325DM по курсу центробанка со склада в Москве. Но он пассивный. Активный (правда не от Сименса и мы ими не торгуем) стоит раза в полтора дороже. Схема у конвертора достаточно типовая, максимовская микросхема-преобразователь и горстка опртронов. С помощью справочника её можно составить самому. Причём питание лучше брать не из разъёма контроллера, а завести отдельно.


text

Связь с Simatic S5 через порт PG
Nick Tarasov; 11.7.99

Знает ли кто-нибудь, каким образом можно получить данные с PLC Simatic S5 (CPU928) на персоналку через порт программирования в какую-нибудь SCADA через DDE или OPC, какое для этого необходимо железо и программное обеспечение.

Говорят, есть такой пакет PRODAVE, который
может работать как DDE сервер для связи с S5
через порт программирования. Может знает
кто-нибудь, какое железо нужно для этого пакета
и какая ориентировочная стоимость PRODAVE и железа ?

C уважением, Николай.
См. http://www.raid.ru

Re: Связь с Simatic S5 через порт PG
Павел Иванов (Сименс-Москва); 12.7.99

Для IBM PC есть пакет PRODAVE AS511, предназначенный для работы ПК

по протоколу AS511 (протокол порта на CPU).
Он представляет из себя набор функций, которые можно вызывать в программе
пользователя на языке С или Pascal. Реализованы функции чтения/записи
всех областей пользователя контроллера, опрос состояния ПЛК и т.д.
Существует также мини версия данного пакета, которая позволяет
читать/писать только блоки данных.
В качестве железа в этом случае нужен только кабель с конвертором.
Но этот пакет не работает по DDE механизму.

Есть другие пакеты OLE/DDE-Manager или OPC-Server, но они работают
только по какой-нибудь сети (PROFIBUS или Industrial Ethernet). Для этого
в контроллер надо будет вставить соответствующий коммуникационный
процессор, а в компьютер сетевую плату. Информация об этом находиться
в разделе продуктов нашего сайта.
Re: Связь с Simatic S5 через порт PG
max; 5.8.99

Пакетов полно, стоят бешеные бабки по нашим понятиям (в среднем 1000$ за

пакет). Попробуй зайти http://www.novotek.com/products/fix/drivers/ss5.htm или
объяви поиск на YAHOO.COM по теме RK512. Описание протокола 3964R
попробую накопать, пишите.
Re: Связь с Simatic S5 через порт PG: решение - WinCC
Никаноров Владимир (Siemens-Москва); 5.8.99

Если в качестве какой-нибудь SCADA будет WInCC, то WinCC имеет прямой драйвер AS511 (порт программирования контроллеров Simatic S5), что, конечно же, гораздо лучше, чем любой DDE сервер. Этот драйвер включен в базовую поставку (также, как и 3964R).

Re: Связь с Simatic S5 через порт PG
Иванов Павел (Сименс-Москва); 26.8.99

Описание протоколов 3964R и RK512 "копать" не нужно. Они полностью описаны в руководстве по коммуникационным процессорам точка-к-точке (СР 525, СР 340, СР441). Руководства на английском языке в электронном виде мы даем бесплатно.

P.S. Что касается WinCC, то полную версию на 128 переменных мы даем бесплатно. Информацию об этом можно посмотреть на нашем сайте в разделе "Новости".
Re: Связь с Simatic S5 через порт PG
Цедровский Кирилл; 30.8.99

Если возможно, перешлите такое описание нам, пожалуйста.


text

Связь с CPU314IFM через коммутируемые линии связи
ЗАО ; 4.6.99

В настоящее время перед нами стоит задача по организации двусторонней передачи данных между микроконтроллером S-300 CPU314IFM и персональным компьютером через телефонную сеть.

Просим Вас сообщить, каким образом программируется CPU314IFM для работы с модемом и какие дополнительные модули необходимы для организации такой линии связи, а также их стоимость и возможность их покупки.

Благодарим Вас.

Re: Связь с CPU314IFM через коммутируемые линии связи
Гуленок А.; 23.6.99

Для этих целей используется специальный пакет - телесервис. Его описание можно найти в наших каталогах, а так же посмотреть у нас в офисе "в живую"

Re: Связь с CPU314IFM через коммутируемые линии связи
siemargl; 6.8.99

Модули серии CP340, CP341 - выход на стандартный модем (rs232); CP341 позволяет свободный драйвер.


text

Подключение ТСМ к SIMATIC S7-300
Александр Степанов; 23.7.99

Коллеги,

Многие заказчики контроллеров SIMATIC предпочитают устанавливать на своих объектах медные термосопротивления (платину - воруют!). Нет ли у кого-либо из партнеров примера программы на STEP7 для пересчета градуировочной таблицы ТСМ при подключении датчика к аналоговому модулю SIMATIC S7? Можно было бы предлагать как одно из стандартных решений.

Re: Подключение ТСМ к SIMATIC S7-300
Никаноров (Siemens-Moskau); 26.7.99

К сожалению, мне неизвестно сандартное законченное решение для подключения медных терморезисторов. Видимо, каждый пишет для себя (в данном случае, наверное, быстрее написать, чем найти готовое решение и в нем разобраться).

Re: Подключение ТСМ к SIMATIC S7-300
siemargl; 6.8.99

Можно использовать FB NONLIN из комплекта Modular PID. Это функция линейной интерполяции по n точкам.


text

Драйвера к платке аналогового вывода
Alexander Lifanov; 26.7.99

Никто не имел дела с платами Analog Out 4*16 bit?

Это которая 332-7ND00-0AB0. Нужны драйвера (GSD).

Или хотя бы ответьте на вопрос: пойдет ли эта плата с драйверами от 4*12 bit из стандартного комплекта S7 4.02?
Re: Драйвера к платке аналогового вывода
Alexander Lifanov; 26.7.99

Всем сорри, драйвера найдены.

Кому надо - http://www4.ad.siemens.de/csinfo/livelink/872382/v402-SM33x.exe


text

cpu 100
Papik; 10.7.99

кто может рассказать как подключать к COM порту CPU 100(s5-100u)

у него разъем 15 штырей
Re: cpu 100
Павел Иванов (Сименс-Москва); 12.7.99

Для связи контроллеров серии SIMATIC S5 с IBM PC (COM port) существует

стандартный кабель с конвертором, который преобразует интерфейс
TTY токовая петля 20мА в RS232.
Закакзной номер 6ES5 734-2BD20.


text

FLASH память
Юрис Гекиш; 18.5.99

Как использовать FLASH память для сохранения данных в контроллерах серии S7-300?

Пожалуйста, пришлите пример программ или ссылки на информацию по данному вопросу.
См. http://www.olimps.lv

Re: FLASH память
Siemens-Москва Никаноров; 26.5.99

В контроллерах S7-300 FLASH память используется для хранения резервной копии программы пользователя, которая может загружаться в ОЗУ после стирания памяти контроллера и нового старта или при отсутствии буферной батареи.

Дополнительно, FLASH может быть использована для хранения так называемых нелинкуемых блоков данных (Unlinked DB), которые могут подгружаться в ОЗУ динамически во время выполнения пользовательской программы (см.стандартную документацию Step7).


text

CPU 417
Овчинниковой Елены; 11.5.99

Где можно посмотреть технические характеристики CPU 417?

Или к кому можно обратиться, чтобы их получить в электронном
виде по e-mail?
Re: CPU 417
A&D S Nikanorov; 17.5.99

6ES7417-4XL00-0AB0 CPU 417-4, 4 MB

6ES7952-1AM00-0AA0 MC 952, RAM- 4 MByte, lang
6ES7952-1AP00-0AA0 MC 952, RAM- 8 MByte, lang
6ES7952-1AS00-0AA0 MC 952, RAM 16 MByte
6ES7952-1KT00-0AA0 MC 952,32 MByte,S7-400,5V F|ash
6ES7952-1KY00-0AA0 MC 952,32 MByte,S7-400,5V F|ash
6ES7955-2AL00-0AA0 Arbeitsspeichererw. (2+2 MB)
6ES7955-2AM00-0AA0 Arbeitsspeichererw. (4+4 MB)

SHORT VERSION:

The CPU 417-4, the associated user memory expansion and the documentation
(new edition) are now available from LZN. The range of S7-400 CPUs has been
be supplemented at the upper performance level by the high-performance CPU
417-4 with large, expandable user memory and integrated PROFIBUS-DP master
interfaces.

Features of the CPU 417-4:
--------------------------
- User memory: 4 Mbytes integrated, expandable to 20 Mbytes
* for programs: 2 Mbytes, expandable to 10 Mbytes
* for data: 2 Mbytes, expandable to 10 Mbytes
- Loading memory: 256 Kbytes integrated, expandable to 64 Mbytes (MC)
-I/O address area: 16 Kbytes
* i.e. DI/DO max. : 131 384
* and AI/AO max. : 8 192
- Backup of the data via a battery in the power supply or external battery
- Max. number of blocks: 6144 FC, 6144 FB, 8192 DB
- Execution times:
* binary operations: 100 ns
* word operations: 100 ns
* fixed-point addition: 100 ns
* floating-point addition: 480 ns
- Flags 16384 (can be set retentive)
- Counters 512 (can be set retentive)
- Timers 512 (can be set retentive)
The no. of IEC1131 timers and counters is unlimited (10 bytes per timer/
counter).
- MPI port (12 Mbit/s, 187.5 kbit/s or 19.6 kbit/s) supported
* PG/OP communication
* Global data communication
* S7 basic communication
* S7 communication
- PROFIBUS DP port (up to 12 Mbaud)
* Stations: up to 125 ET 200 stations
* PG/OP communication
* Max. 244 bytes of process data per ET 200 station
- 2 free ports to connect the DP submodule IF964-DP
(6ES7964-2AA01-0AB0, planned for 5/99)
- The MPI can be configured as PROFIBUS DP and used as DP master. If the
MPI is used for PROFIBUS DP, the integrated communications functions -
except for the PG/OP communication - can no longer be used.
The max. number of ET stations is 32.
- The MPI/DP port can be operated at 19.8 kBaud, 187.5 kBaud or 12 MBaud.
- Certain quantity frameworks (e.g. process I/O image, local data, diag-
nostic buffer) can be enlarged at the expense of the user memory. The
process I/O image can be increased to the size of the max I/O address
area.
- Up to 8 sub-process I/O images can be defined
- Logic module addresses can be assigned in byte steps
- The system function runtimes (SFB, SFC) have been significantly improved
- Communication performance has been improved once again.
- Routing for PG connection permits engineering across the whole plant,
as well as testing and diagnostics over the whole network hirarchy.
- Support of lateral communication between DP slaves. Receivers can be
intelligent slaves (CPUs), e.g. CPU 316-2DP, 318-2), that listen in
when process data are sent to the DP master.
- Synchronous operation and equidistance on PROFIBUS DP (e.g. for motion
control applications)
- In addition to the integrated DP interfaces, up to 10 additional DP
strings can be implemented via CP (or 4 via IM)

Different memory distribution:
The user memory has been sudivided into a memory for code and a memory
for data, so that in total more working memory is now available. This
concept will be generally introduced for S7-400 as of 6/99.

- STEP 7 V5.0 or higher is required for programming.

Documentation
--------------------------------------------
S7-400 manual (G) 6ES7 498-8AA02-8AA0
S7-400 manual (E) 6ES7 498-8AA02-8BA0
S7-400 manual (F) 6ES7 498-8AA02-8CA0
S7-400 manual (S) 6ES7 498-8AA02-8DA0
S7-400 manual (I) 6ES7 498-8AA02-8EA0

List of Operations (G) 6ES7 498-8AA02-8AN0
List of Operations (E) 6ES7 498-8AA02-8BN0
List of Operations (F) 6ES7 498-8AA02-8CN0
List of Operations (S) 6ES7 498-8AA02-8DN0
List of Operations (I) 6ES7 498-8AA02-8EN0


text

SIMATIC C7-633
Фирма 2С; 18.3.99

Можно ли полключать термопары РТ100 к аналоговым входам С7-633/Р

Re: SIMATIC C7-633
Техническая группа A&D S ; 18.3.99

Возможные дипазоны аналоговых входов С7-633/Р

таковы:
-10...+10V / 50KOм
-20...+20mA / 105,5Oм
4...20mA / 105,5Oм
Исходя из этого и следует выбирать датчик.


text

Работа S7-200 c "чужими датчиками"
Cергей Рыбаков; 16.2.99

Была информация о возможности работы S7-200 с датчиками угла поворота фирмы HOHNER (Tuttlingen, Deutschland) посредством PPI. Каким образом это можно сделать и можно ли одновременно с OP-3? Можно ли таким же образом работать с S7-300?

Re: Работа S7-200 c "чужими датчиками"
A&D S Гуленок; 19.2.99

Полная информация по этому вопросу содержится в статье "Подключение датчика RS485 к PPI интерфейсу S7-200" Совместная ребота датчика и ОР вряд ли возможна, так как эти устройства используют разные протоколы. В этом случае целесообразно использовать двухпортовый CPU-216. Порт программирования у S7-300 работает в других режимах и прямое подключение датчика не предусмотрено, однако можно воспользоваться модулем CP340 с RS484 интерфейсом для такого подключения.

См. Подключение датчика RS485 к PPI интерфейсу S7-200


text

Какой драйвер для последовательного кабеля?
Алик Минкин; 8.3.00

Какой драйвер надо использовать в PG/PC Interface на компьютере, соединённым с S400 по последовательному интерфейсу/модему с адаптером MPI на стороне S400? Нужен ли дополнительный софт?

Заранее благодарен.

Алик Минкин
Пивзавод ВЕНА

См. Vena Brewery

Re: Какой драйвер для последовательного кабеля?
Никаноров В. - Сименс, Москва; 9.3.00

Для связи через COM-порт и MPI адаптер (из STEP7 или WinCC) никаких дополительных драйверов не нужно.

В PG/PC интерфейсе надо выбрать PC Adapter.
Re: Какой драйвер для последовательного кабеля?
Алик Минкин; 10.3.00

Я включил два модема между компьютером со STEP7 и адаптером MPI на стороне контроллера и ожидал, что они не будут помехой. В PG/PC интерфейсе был выбран и настроен PC Adapter, связь между модемами установлена. Но как только STEP7 обращается к S400, связь между модемами рвётся! Причём вырубается именно тот модем, который подключён к компьютеру.

Я не отрицаю кривизну такого включения, мне всего-то хотелось проверить адаптер на стороне S400, а заодно воможность связи из дома.
Правильно ли я понимаю, что без телесервиса здесь не обойтись? Или можно какнибудь вывернуться?

Заранее благодарен.

Алик Минкин

См. Vena Brewery

Re: Какой драйвер для последовательного кабеля?
Никаноров В. - Сименс, Москва; 10.3.00

Без телесервиса никак.

Sinumerik System 8
Маркин Егор; 14.4.00

Ваше сообщение...

Нет информации о подключении ЧПУ Sinumerik System 8 к IBM PC через СОМ порты. Буду благодарен за информацию.
Re: Sinumerik System 8
Михаил; 7.5.01

Схемы подключения для обмена программами и машинными данными есть в руководстве на ЧПУ и в руководстве по интерфейсам SINUMERIK.

Re: Sinumerik System 8
Воронин Александр (SIEMENS-Москва); 7.5.01

Уважаемый г. Маркин,

Обмен программами осуществляется через стандартный COM -порт IBM PC и интерфейс 1 системы ЧПУ(RS232C;V.24 по DIN66020) с помощью программы PCIN. Данная информация содержится в руководстве оператора SINUMERIK System 8 выпуска 06.88 (номер 6ZB5410-3AA01-0BA0)на стр.2-62 раздел 2.10 Ввод/вывод данных через последовательный интерфейс.

См. A&D MC

Re: Где взять драйвер для принтера SIEMENS PT 89 S?
Николаев Василий; 25.9.01

Где взять драйвер для принтера SIEMENS PT 89 S?


text

Схема преобразователя RS232-->TTY
Костюк В.; 27.8.00

У кого имеется схема преобразователя RS232-->TTY

для соединения PC c SIMATIC S5?
Каким образом можно её получить?

Re: Схема преобразователя RS232-->TTY
Dima; 28.8.00

чиркни мне

и я тебе схему пришлю
придумал практически сам работает на 9600
железно
Re: Схема преобразователя RS232-->TTY
Adam Donocik; 10.8.01

If You have, please send me this diagram

Regards
Adam

Ваше сообщение...


text

Нужен разработчик !!!!!
Зайцев Евгений ; 21.8.00

Просим направить в наш адрес технико-коммерческое предложение на создание автоматизированной системы управления экстракционным цехом (объект под надзорен ГОСГОРТЕХНАДЗОРУ) на основе компонентов фирмы SIEMENS (SIMATIC S7-300, ET-200M). Количество точек ввода/вывода 176DI, 80DO, 17AI.

В качестве SCADA-системы используется пакет GENESIS32 v6.0 300 точек I/O. Для связи с оборудованием SIEMENS используется PCI-карта SIMATIC NET, CP 5613 и DP-OPC-сервер v2.0 для WINDOWS NT v4.0.
В качестве рабочей станции используется SIMATIC PC RI45 PIII, 19” с WINDOWS NT v4.0 SP5, английский вариант.
Для создания данной системы имеются проектные решения выполненные проектной организацией, имеющей лицензию на проектирование химических и других взрывоопасных и вредных производств, ОАО «СЕВКАВПИЩЕПРОМПРОЕКТ».

Re: Нужен разработчик !!!!!
а; 5.3.01

Ваше сообщавпение...

Re: Нужен разработчик !!!!!!
йdddd; 30.3.01

Ваше сообщение...sd

См. www.skpp.ru


text

Доки по Simadyn D
Оганесян Юрий; 22.11.00

Подскажите, где можно достать информацию по Simadyn D на русском языке?

Re: Доки по Simadyn D
Ташлицкий Максим; 22.11.00

Уважаемые господин Оганесян,

этот раздел форума посвящен стандартным приводам
переменного тока:
преобразователям частоты типов
MICROMASTER
MICRO/MIDIMASTER Vector для постоянного момента 120 Вт - 75 кВт
MICRO/MIDIMASTER Eco для насосов и вентиляторов 750Вт - 315 кВт
MICROMASTER Integrated 120Вт - 7.5 кВт
COMBIMASTER 120Вт - 7.5 кВт
и асинхронным двигателям

По вопросам приводов постоянного тока и SIMADYN обращайтесь, пожалуйста,
к господину Иванову Андрею Гелиевичу, тел. 737 23 91
e-mail: Andrej.Iwanow@mow.siemens.ru
или к Зиновьеву Алексею Юрьевичу, тел. 737 23 90,
e-mail: Alexej.Sinowjew@mow.siemens.ru

Также приглашаем Вас на страницу в Интернет:
http://www.siemens.ru/ad/ld/

С уважением
Ташлицкий Максим

Simadyn D
Tarasov Vsevolod; 22.3.01

Подскажите, где можно найти библиотеки с модулями Simadyn`а для програам САПР? Или информацию о этих библиотеках.


text

Проблема с модулем SM 331 (AI 8 xTCx24 bit)
Штепа С.А.; 16.11.00

Проблема: Модуль SM 331 (новый термопарный - 6ES7 331-7PF10-0AB0, только достали), STEP7 v5.1. Подключен вход CH0 к термопаре типа K, на остальных - перемычки.

Параметры: группа 0-1 - тип K, тип измерения TC-IL, остальные деактивированы. Режим "8 channels, hardware filter".
--> После старта контроллера модуль измеряет температуру отлично, но примерно через минуту показания "застывают" (чего нет при "4 channels, hardware filter").

Может, это связано с подключением незанятых входов? Помогите, пожалуйса.
Сам себе отвечаю
Штепа С.А.; 15.2.01

Через неделю, после публикации своего письма, я написал про свою проблему на Siemens Customer Support. Через день мне отетили, что этот глюк - ошибка АЦП, которую обещали исправить в следущих версиях этих модулей.

P.S. А я думал, что у меня глюки...


text

RAM модуль для CPU922
Цёмик Сергей; 27.12.00

Здравствуйте!

А не подскажет ли кто что из себя представляет сие изделие(может даже схема есть или хотя бы примерное аппаратное обеспечение). Необходимо отладить программу, а в распоряжении имеются только EPROM модули с УФ стиранием - не очень удобно вести отладку. Имеющийся модуль имеет организацию 32kWord(2x27256)

Буду очень признателен за любую информацию.

Re: RAM модуль для CPU922
Андрей Гуленок; 22.1.01

Сие изделие представляет из себя модуль 6ES5 377 0AA11 (0AA21 или 0AA32) соответственно 16, 32, или 64 кб.


text

Подключение S7-200 к PC
Алексей Карзыков; 22.11.00

Извините за вопрос чайника, как и каким шнуром подключить S7-200 к компьютеру для использования программы STEP7, если в поставке не было шнура?

С Уважением, Алексей
alexeyk@rikt.ru

Re: Подключение S7-200 к PC
Оганесян Юрий; 23.11.00

Это может быть сделано через COM порт с использованием переходника PC/PPI (6ES7901-3BF00-0XA0 - 72 EUR ) или в комп надо вставить специально обученную плату, например CP5611 (6GK1561-1AA00 - 389 EUR ).

PS. Для программирования S7-200 используется не "STEP7", а "Step7-Microwin".
Best regards.
Re: Подключение S7-200 к PC
Алексей Карзыков; 23.11.00

Вопрос несколько более сложный... Поставкой оборудования к нам занималась Германская фирма, S7-200 программировать приезжал немец какой- то, и теперь возникла острая необходимость переделать программу, а шнура нету...

Можно- ли как- нибудь его спаять в кустарных условиях?
Re: Подключение S7-200 к PC
Eugene; 24.11.00

В кустарных условиях не удастся.

Дело в том, что вышеуказанный "шнур" - не просто несколько проводов между разъемами, но электронный блок.

Re: Подключение S7-200 к PC
aim; 27.11.00

Стоит попробовать карты для PC работающие с RS-485. Ведь Siemens для связи со своими контроллерами использует физику интерфейса RS-485.

Re: Подключение S7-200 к PC
Чистяков Дмитрий ОАО "СеверСталь"; 27.11.00

RS-485 и PROFIBUS, MPI это разные вещи.

RS-485 это аппаратный протокол.
MPI и Profibus это программные протоколы.
Поэтому то что плата работает по RS-485 вовсе не значит, что она сможет работать с PROFIBUS (MPI). Для это необходимо ей добавить "мозгов" в виде драйвера. Но как праволо всё это вызывает больше проблем, чем простая закупка переходника или карты от Siemens.

А вообще надо было бы не много побеспокоиться об этом чуть раньше, когда контракт подписывали и заказать всё что надо для обслуживания своими руками. А то теперь придётся снова буржуя вызывать.

Re: Подключение S7-200 к CIMPLICITY(HMI)
spirichin margarita; 16.1.01

kak Подключить S7-200 CPU226 k CIMPLICITY (HMI)?

Re: драйвер ОРС ?
Spirichin Margarita; 16.1.01

Где можно взять драйвер ОРС для связи между НМΙ СІМРLICITY и РLС S7-200?

Возможны ли другие способы связи?

Re: драйвер ОРС ?
Никаноров В. - Сименс; 16.1.01

Вы можете установить карту PROFIBUS от Siemens + драйвер, в объем поставки которого входит ОРС сервер.


text

AS511
Serge_D; 1.12.00

24 Aug 2000 Sergei писал, что общается с S5 по протоколу AS511 напрямую и имеет описание "S5 AS511 (Programming port) protocol description".

Sergei, или кто-нибудь у кого есть какое-либо описание на AS511 вышлите пожалуйста мне сюда home_serge@themail.com .
Поделитесь опытом чтения контроллера не фирменными средствами.

Спасибо.

Re: AS511
Max; 4.1.01

http://www.runmode.com/


text

Схема преобразователя RS232-->TTY
Костюк В.; 18.7.00

У кого имеется схема преобразователя RS232-->TTY

для соединения PC c SIMATIC S5?
Каким образом можно её получить?

Re: Схема преобразователя RS232-->TTY
Андрей Гуленок; 18.7.00

Это уже обсуждалось здесь. Например http://http://www.http://www.siemens.ru/ad/as/ru/forum/sw/forum.cgi?message=36siemens.ru/ad/as/ru/forum/sw/forum.cgi?message=36

Re: Схема преобразователя RS232-->TTY
aim; 11.11.00

Ну чё тут сказать.

Зажрался Siemens (цены просто заоблачные).
А проблемма решается элементарно - просто надо с одной стороны использовать источник токовой петли встроенный CPU, а с другой, через оптронную развязку, подавать сигнал на RS. Так мы работаем уже больше года. Кому нужна схема - пишите :-)))

Re: Схема преобразователя RS232-->TTY
Dimm; 2.12.00

Будь другом, нужна такая схема.

ЗДЕСЬ ЛЕЖИТ ПРЕОБРАЗОВАТЕЛЬ RS232->TTY
Max; 4.1.01

http://www.runmode.com/


text

Документация на FM 352 - ?
Владимир; 23.11.00

Если есть переведенная дока или описание

вышлите пожалуйста.

Re: Документация FM 350 - 2
Масенко А,В.; 28.12.00

Есть ли у вас документация на модули FM350 - 2?


text

Аналог IP241 в S7-400
Oльштейн Эдуард; 26.12.00

Необходим модуль обрабатывающий сигналы датчика абсолютного положения.Видел как в S5 эту функцию выполняет модуль IP421, обрабатывающий сигналы с датчика BRZ. По каталогу нашел, что похожие функции выполняет модуль декодера позиционирова-

ния WF705.
1.Где найти более подробную информацию по этому модулю, желательно на русском языке?
2.Может быть есть более простые модули для обработки сигнала датчика абсолютного положения, где найти по ним информацию?
3.Есть ли у кого-нибудь опыт работы S7-400 и датчика абсолютного положения?
4.Какие датчики абсолютного положения работают совместно с S7-400?
Заранее благодарен.
Re: Аналог IP241 в S7-400
Никаноров В. - Сименс; 26.12.00

Сименс в основном применяет абсолютные датчики с SSI интерфейсом. Имеются также датчики с выходом на Profibus-DP.

Для подключения SSI датчиков к S7-400 могут служить модули FM451, FM452.
В S7-400 можно также устанавливать некоторые IP модули от S5 через специальный адаптер.
Модули WF являются достаточно старыми, и вскоре снимаются с производства.
Более подробно см. в каталоге ST70-2000.
См. http://

ПОЯСНИТЕ ПОЖАЛУЙСТА ЕЩЕ.
Ольштейн Эдуард; 27.12.00

1.Модули FW451 и FW452 работают с абсолютными датчиками положения с SSI-протоколом, параметрируются от CPU и выполняют различные функции в АВТОНОМНОМ режиме.

Имеется ли при этом возможность иметь в CPU текущие показания абсолютного датчика?

2.Поясните, если можно коротко, что такое SSI-
протокол, или где можно найти о нем информацию?
По линии `данные` видимо идет код датчика в последовательном виде, а что идет по линии `такт`?

3.В каталоге в таблице параметров модулей FW есть фраза `типы дешифраторов ..... одиночные и многоточечные SSI`. Т.е. датчики с SSI-протоколом можно обьединять в `сеть`?

4.В каком месте смотреть информацию по абсолютным датчикам положения(SSI и Profibus)?

5.Вопрос по другой теме.
Модули для S7-400 типа IP240,IP241 и т.д. усаревшие? Или их можно применять в новых разработках?

Спасибо


text

Глюки S5-115
Станислав Хмельницкий, СП "ТИГИ-Рихтер"; 20.12.00

Добрый день!

В ходе эксплуатации контроллера S5-115 CPU-944 обнаружилась вот какая
фигня: при каких-либо катаклизмах питания (220V) процессор иногда не
запускается, а зависает в совершенно непонятном режиме - активно светит
всеми индикаторами и не реагирует на все манипуляции типа Overall Reset,
Stop, Start и так далее. А бывает, что просто стоит в стопе и выдает в Online
ошибку или отсутствие OB-34 и прочих блоков. Может неожиданно ожить, а
может так стоять до одури. Радует то, что всегда оживает, но т.к.
базируемся мы в Колпино, катаклизмы с питанием дело систематическое,
соответственно потери времени неимоверные. Может кто сталкивался с
подобным и чего присоветует?
Заранее признателен.

Stah Chmelnicki

Re: Глюки S5-115
Максим; 21.12.00

Бывает у нас такое при иголках в сети. После установки RC-фильтров с варисторами дело улучшилось, но не везде. Там где не смогли победить пришлось питать контроллеры через SmartUPSRM - как бабки отшептали. Еще могут быть проблемы из-за отсутствия гальванической развязки при разводке линий связи по принципу точка-точка (из-за неправильного подключения).


text

Ограничение доступа к CPU через CP443-1 TCP
Маруськевич Сергей; 7.12.00

Что необходимо предпринять для ограничения доступа к CPU при условии, что контроллер подключен к общецеховой сети с большим количеством станций. Кроме как держать под большим секретом IP-адрес CP, есть ли еще дополнительные меры по безопасности?

Re: Ограничение доступа к CPU через CP443-1 TCP
Чистяков Дмитрий; 7.12.00

Установить пароль на доступ программам, если конечно у Вас пакет Step7 ver5.0 и выше.


text

Термопара типа L на SM331
Василий; 4.12.00

При установке на модуле SM331 диапазона измерения температуры термопарой типа L характеристика преобразования не соответствует характеристике, которая указана в ГОСТ Р 50431-92 на термопару типа L.Что делать? Может есть НСХ, заложенная в модуле.

Re: Термопара типа L на SM331
Никаноров В. - Сименс; 4.12.00

Характеристику, используемую для термопар типа L, можно посмотреть в документации на аналоговые модули (можно скачать с этого сайта).

Re: Термопара типа L на SM331
Василий; 5.12.00

В конфигурации модуля указан материал термопары типа L как Fe-CuNi, что более соответствует термопаре типа J, как и указано в конфигурации. Термопара типа L - это хромель-копель(NiCr-CuNi).

Тип термопары указан или в конфигурации неправильно или это двойной стандарт?
Re: Термопара типа L на SM331
Никаноров В. - Сименс; 5.12.00

Материал термопар:

L - Fe-CuNi - DIN 43 710
J - Fe/CuNi - DIN IEC 584
K - Ni/CrNi - DIN IEC 584
Re: Термопара типа L на SM331
Василий; 6.12.00

Да, все правильно. Тип L по ГОСТ Р50431-92 -это хромель/копель,а тип L по DIN 43710 -это железо/медь-никель. Соответственно их НСХ разные.

В модуле используется тип L по DIN 43710.
Спасибо.

Re: Термопара типа L на SM331
Никаноров В. - Сименс; 6.12.00

В модуле можно использовать термопару типа E с материалом NiCr-CuNi. Но у меня нет характеристики на этот тип.


text

CPU 315-2DP
Булгакова В.В.; 1.12.00

Сколько удаленных станций ET200M можно подсоединить к встроенному в процессор интерфейсу DP,и может ли CPU, используя станции ET200M, обслуживать дискретные входы-выходы общим количеством свыше 1024 каналов, например, до 1500 каналов, и как это обеспечивается?

Re: CPU 315-2DP
Никаноров В. - Сименс; 1.12.00

В современных процессорах CPU 315-2DP (6ES7 315 2AF03-0AB0) допустимо подключение до 64 станций-slave на порт DP.

Адресное пространство входов\выходов составляет
1024\1024 байт.
Необходимо только помнить, что каждый DP-Slave занимает дополнительно 1 байт во входном буфере (диагностический адрес).
Таким образом, максимальная конфигурация с дискретными входами выходами при применении 32 канальных модулей:
7944 DI {(1024-31)*8} / 8182 DO {1024*8}


text

Цена
Марат Гарифуллин ; 27.11.00

Subj OP 393

6ES5393-0UA (12, 13, 14)
можно современные аналоги, пуля в пулю
Re: Цена
Никаноров В. - Сименс; 30.11.00

Панель ОР393 6ES5 393-0UA15 пока поставляется.

Стоимость 375 EURO на границе Германии.


text

Временная диаграма S7-400
Соловьев А.П.; 25.11.00

Возможно ли получить временную диаграму выполнения OB на процессоре S7-400 CPU416-3DP

Re: Временная диаграма S7-400
Никаноров В. - Сименс; 27.11.00

А что такое временная диаграмма выполнения ОВ?

Re: Временная диаграма S7-400
Соловьев А.П.; 27.11.00

Фактическое время выполнения циклических OB в контроллере с учетом прерывания их более приоритетными. Проблема такая: идет ошибка превышения времени выполнения. Хотелось бы на этапе разработки выделить OB, время выполнения которых близко к критическому.

Re: Временная диаграма S7-400
Никаноров В. - Сименс; 27.11.00

Вы можете считать фактическое время выполнения ОВ1 с помощью системных функций.

Re: Временная диаграма S7-400
Соловьев А.П. ; 27.11.00

Это нас не спасет. Нам бы хотелось тоже самое но для пользовательских циклических OB (н-р OB34 и другие). В примерно таком виде: 0ms начало OB30,

0.0001 ms ОВ30 прервано началом выполнения OB35,
0.0101 OB35 закончил свою работу, управление передано OB30 и т.д.


text

команда DIV на S5-95
Минеев Алексей; 24.11.00

Как мжно реализовать операцию деления на S5-95 (При выполнении команды DIV

контроллер входит в стоп ,в ISTACK появляется бит NNN- comand cannot be interpreted in this PLC)

Re: команда DIV на S5-95
Дедовец Павел; 27.11.00

Для этого существуют базовые функциональные блоки для S5-95U ... S5-155U. заказной номер 6ES5848-7AA02 за 739 Euro. Есть так же математика с плавающей запятой, заказной номер 4ES5845-7GP01 за 308 Euro. Можно попробовать написать эти блоки (FB) самостоятельно.


text

куплю регулятор РТИ-012. Рассмотрю все варианты
Олег Иванович; 22.11.00

Куплю регулятор РТИ-012. Рассмотрю все варианты

См. Куплю запчасти


text

подкачивающие станции 3-го подъема
Знаменщиков Вячеслав; 15.11.00

Ваше сообщение...

Как организовать работу параллельно 2-х,3-х
насосов используя один преобразователь
с максим. экономией в стоимости оборудования.
Re: подкачивающие станции 3-го подъема
Ташлицкий Максим; 20.11.00

Уважаемый Вячеслав,

Отвечаем на ваш вопрос относительно использования одного
преобразователя с несколькими приводами.
Отметим, что в любой момент времени естественно может работать пара
преобразователь - привод, параметры которого(P80-89) в данный момент
загружены в частотник. Поэтому принцип следующий : выход частотника
распараллеливается через контакторы приводов, которые включаются при
необходимости подключения нужного привода (блокировки и контроль не
описываем).
Работа следующая: перед включением нужного двигателя его параметры
прошиваем в частотник и включаем нужный контактор, затем пускаем
преобразователь.
Таким образом, если двигатель нужно пускать только через частотник, то
необходим 1 контактор(К) на привод(Привод2 на схеме), если же
предусматривать возможность пускать привод напрямую от ИП, то - 2
контактора (Привод1 и Привод3 на схеме).
______________________________
ИП Преобразователь ИП |
| | | | | |
K1 K1-1 K2 K3 K3-1 |
| | | | | | Cхема
Привод1 Привод2 Привод3 |
______________________________|
Вот вкратце и все.
---------------------------------------------------
Северо - Кавказский Технический Центр
Технический директор Колесников А.В.
инженер по ИТ Зозуля В.С.


text

Прием нестандартных протоколов по RS485
Харгелия Олег; 17.11.00

Для приема протоколов по RS-485 существует коммуникационный процессор CP-441. Вся беда в том, что он умеет принимать только стандартные протоколы (ASCII, printer и еще какой-то один).

Существует ли принципиальная возможность принять нестандартный протокол.

Может есть какой-нибудь программируемый коммуникационный процессор, тогда дело сведется к написанию драйвера для этого CP?


text

Подскажите пожалуйста по 0-5 мА и по градуировкам...
Павел; 25.9.00

Подскажите пожалуйста :

1) Существует ли возможность с Siemens использовать датчики 0-5 мА ?

2) Возможно ли использовать термометры со следующими градуировками:
а) старые: 23, 21
б) новые: 50М, 100М, 50Р, 100Р

Заранее благодарен за ответ.

Re: Подскажите пожалуйста по 0-5 мА и по градуировкам...
Оганесян Юрий; 27.9.00

Что касается S7-200, то диапазон аналогового входа не конфигуряется и составляет 0-20 мА, у

S7-300 есть возможность сконфигурять такой же диапазон, таким образом при подключении датчиков 0-5 мА никаих проблем не предвидется, если, конечно Вас устраивает получающаяся точность.
По поводу термометров, то сконфигурять отечественные термометры и термосопротивления со своими нестандартными градуировками встроенными в STEP7 средствами разумеется не удается. В ближайшем будущем мне предстоит решать аналогичную проблему. Думаю, что градуировка термометров будет сделана программно по какому-нибудь калибратору, хотя от минимальной нелинейности характеристики, которая присутствует в градуировках моих термометров уйти не удастся.

Re: Подскажите пожалуйста по 0-5 мА и по градуировкам...
Никаноров В. - Сименс, Москва; 27.9.00

1.В S7-400 можно сконфигурировать вход +-5мА

2. Для отечественных терморезисторов встроенной линеаризации нет. Нужно делать программную линеаризацию. Градуировка 100П в определенном диапазоне практически совпадает с Pt100.

Re: Подскажите пожалуйста по 0-5 мА и по градуировкам...
Харгелия Олег; 17.11.00

Можно сконфигурировать в S7-400 вход -5...+5 мА. При этом точность младшего разряда в четыре раза лучше чем при конфигурировании 0...20мА.


text

converter AG/TTY
Александр; 17.11.00

Я прошу прощения может быть за некоторую наглость сообщения - вдруг кому-нибудь нужен конвертер для Step5 - Siemens AG/TTY PC/RS232(6ES5 734-1BD20) совершенно новый в коробке.


text

S7-216 & 5412A2 Card
Каверин Олег; 5.9.00

Каким образом можно связать РС и контроллер серии S7-200 через плату 5412А2?

Re: S7-216 & 5412A2 Card
Чистяков Дмитрий ОАО "СеверСталь"; 5.9.00

Связь устанавливается в режиме MPI .

Для этого в Set PG/PC Interface привязываете канал CP_L2_1 к CP5412 (MPI).

В WinCC используется канал SIMATIC S7 PROTOCOL SUITE - MPI.

Вырезка из каталога CA01
==================================================
Программирование
Для программирования CPU 216 и PPI интерфейса могут быть использованы STEP 7 Micro/DOS V1.3, STEP 7 Micro/WIN16 V2.6 или STEP 7 Micro/WIN32 V3.0. Эти пакеты позволяют программировать все функции центрального процессора. Если программное обеспечение установлено на компьютере, то для подключения контроллера необходим PC/PPI кабель. STEP 7 Micro/WIN32 V3.0 позволяет использовать для связи с контроллером коммуникационные процессоры CP5511 или CP5611. В этом случае скорость передачи данных может достигать 187 Кбит/с

=================================================
Re: S7-216 & 5412A2 Card
Каверин Олег; 6.9.00

на самом деле я плохо сформулировал вопрос - нужно связать InTouch 7.0 и контроллер

Re: S7-216 & 5412A2 Card
Каверин Олег ; 7.9.00

Извиняюсь за неправильно сформулированный вопрос. Надо связать InTouch 7.0 и S7-216 именно через 5412А2. Какой протокол лучше использовать?

Re: S7-216 & 5412A2 Card
Чистяков Дмитрий ОАО "СеверСталь"; 7.9.00

Вообще то, не понятно почему именно InTouch.

Мы с ним долго тра-сь. Очень уж он плохо работает с DDE серверами, поставляемыми с InTouch.
Все эти сервера разрабатываются третьими фирмаими и видимо тестируются не достаточно хорошо. Возможно в какой то конфигурации (конфигурации автора) всё работает, а вот у других не всегда.

Наиболее качественная работа связки InTouch - Simatic (при чём как S5, так и S7) оказалась при использовании DDE Manager от Siemens.
Связь работала надёжно, без зависаний и проблем.
При этом значительно меньше проблем при отладке связи.
Вам лучше всего подойдёт Simatic Net S7-OLE/DDE Manager 6GK1705-0AW15-3AA0.
Он имеется на бесплатном CD Simatic NET, но для его работы требуется авторизация. Её Вам придётся купить.

А так проще взять WinCC благо он бесплатный на 128 тэгов. Там связь с Simatic S7 одно удовольствие. А вам 128 тегов для S7-200 за глаза хватит. К тому же WinCC считает тэгами только переменные, связанные с контроллером. И Вам ни кто не запрещает описвать тег двойным словом (32 бита), а затем использовать из него биты. Таким образом Вы получаете 128 X 32 = 4096 дискретных тэгов. И это на халяву!
Этого вполне достаточно для среднего проекта

InTouch
vit; 13.11.00

Господа, подскажите пожалуйста, при стыке InTouch 7.0 с контроллером у нас возникла следующая проблема, не идет побитная запись данных, запись через целый регистр проходит нормально. Есть ли в InTouch операции с битами?

Как разрешить проблему? Спасибо.


text

Джойстик и регулируемый источник тока
Vereshko; 7.11.00

Вышлите, пожалуйста, заказные номера и

детальное описание следующих двух устройств, выпускаемых SIEMENS:

1) Регулируемый источник постоянного тока с диапазоном выходного напряжения 0-24В и
с диапазоном выходного тока 0-2,5А.
Управляющий сигнал
либо 0-10 В,
либо 0-20 мA.

2) Резистивный джойстик для пропорционального управления,
либо на два направления
либо на четыре направления
для подключения ко входу аналогового модуля SIMATIC S7 300.

Отрицательный ответ!
Михайлин Сергей; 13.11.00

Насколько я знаю и насколько мне сказали мои коллеги, SIEMENS не производит данные устройства.


text

источник бесперебойного питания
Знаменщикова Вячеслава; 10.11.00

Ваше сообщение...

необходим источник бесперебойного питания 3-х
фазный,6кВА,время удержания 5 минут, для питания
автоматики на котельной.


text

PC-MPI кабель
Богдан Кудлак; 9.11.00

Что такое PC-MPI кабель (6ES7 972-0CA20-0XA0)?

Только ли преобразователь RS232 в RS485,
или это интеллектуальное устройство
со своим процессором, ПЗУ и т.д.?

Вышлите, если есть, блок-схему или схему PC-MPI кабеля.

Re: PC-MPI кабель
Никаноров В. - Сименс; 9.11.00

Это уже обсуждалось в этом разделе


text

Многопроцессорный режим работы – почти мистический случай.
Александр; 7.11.00

Здравствуйте !!!

Может кто сможет помочь в обьяснении почти мистического случая . Итак…

Ситуация

На производстве применяются 3 контроллера с многопроцессорным режимом работы.
Комплектация корзин :

1. Координатор, CPU 948, CPU 928, СP 143, входные\выходные модули.
2. Координатор, CPU 948, CPU 928, СP 143, входные\выходные модули.
3. Координатор, CPU 928, CPU 928, СP 143, входные\выходные модули.

Питание контроллеров осуществляется через источник бесперебойного питания.
Из-за аварии отключился основной ввод рабочего питания контроллеров, затем в
течении 30 мин. питание осуществлялось от источника бесперебойного питания.
После разряда аккумуляторов источника бесперебойного питания контроллеры в
течении 40 мин. находились без питания. При восстановлении питания выяснилось,
что контроллеры с CPU 948 - CPU 928 находятся в состоянии “ STOP “, а CPU 928 -
CPU 928 находятся в состоянии “ RUN “.
При выяснении причин останова контроллеров обнаружилось, что в CPU 948 - CPU
928 “разрушилась” ( стёрлась ) программа, а в СP 143 программа сохранилась , хотя
буферные батареи были нормальны. Ток буферных батарей около 1,5 А. После
загрузки программы в CPU один из контроллеров сразу запустился, а в другом после
подтверждения задания на запуск с PG , на PG появлялось сообщение (дословно точно не
помню) “ Запуск невозможен – системная ошибка ” . В USTACK и BSTACK не было
информации об ошибках или меток причин останова – всё показывало ОК. Были
предприняты различные способы запуска все окончились безрезультатно - ни один
из CPU, ни оба сразу не хотели запускаться. Вдруг в очередной раз старта с PG
контроллер запустился. Программа заново не загружалась. Контроллер проверялся
– в смысле хорошо ли CPU,модули вставлены в корзину и т.д. Температура в
машзале и внутри шкафов с контроллерами +17-20 С. Вибраций в шкафах, машзале нет.
Программы контроллеров
почти одинаковы, различие только в номерах DB для обмена по Н1-BUS.

Вопросы

1. Почему “разрушилась” (стёрлась) программа, если буферная батарея – ОК ?
2. Возможные причины - почему не запускался один из контроллеров ?
3. “ Запуск невозможен – системная ошибка ” в каких случаях возникает данное
сообщение ?

Спасибо всем, кто смог дочитать моё послание до конца.

С уважением Александр.


text

S7-400 Многопроцессорный режим
Александр Башкиров; 25.10.00

Доброго времени суток!

Имеется в UR1 два 414-DP и один CP443-1.
Подскажите ,пожалуйста, как лучше реализовать
обмен данными между 414-ими учитывая, что оба
проца через 443-1 обмениваются достаточно интенсивно с WinCC 5.0, причем один из них
каждые 500 мс посылает "наверх" блок порядка 12 кбайт.

Заранее благодарен.
Re: S7-400 Многопроцессорный режим
Никаноров В. - Сименс, Москва; 30.10.00

А что, есть много вариантов?

По К-шине через SFB.
Re: S7-400 Многопроцессорный режим
Александр Башкиров; 30.10.00

S7-connection или GD?

И какие SFB лучше использовать если по S7-connection?

Re: S7-400 Многопроцессорный режим
Никаноров В. - Сименс, Москва; 31.10.00

Смотря какой объем данных Вам требуется.

Если небольшой, то проще через глобальные данные.
А также важно, нужно ли Вам подтверждение доставки сообщения на уровне программы пользователя, и коды ошибки, если не доставлено.
Исходя из этого выбираются SFB для S7-connection.


text

модуль на 8 термосопротивлений
Eugene; 24.10.00

Помогите найти информацию (характеристики, подключение) по модулю аналоговых входов на 8 термосопротивлений (заказной номер

6ES7331-7PF00-0AB0).
Re: модуль на 8 термосопротивлений
vereshko; 25.10.00

Пожалуйста, вышлите информацию по подключению (ПОДКЛЮЧЕНИЮ ПИТАНИЯ!) модуля на 8 термосопротивлений с заказным номером 6ES7 331-7PF00-0AB0

Re: модуль на 8 термосопротивлений
Чистяков Дмитрий ОАО "СеверСталь"; 25.10.00

Схемы и описания доступны на русском языке по адресам :

http://www.siemens.ru/ad/as/ru/info/s7400_man.htm

http://www.siemens.ru/ad/as/ru/info/manuals/S7-400/Modul/06_Analog_r.pdf

Чистякову Дмитрию
Eugene; 26.10.00

Интересующий нас модуль появился совсем недавно.

Он принадлежит к модулям взрывобезопасного исполнения.
По указанному адресу лежат устаревшие описания, а описания взрывобезопасных модулей там вообще нет, так что ответ не принимается :-).

Re: Чистякову Дмитрию
Чистяков Дмитрий ОАО "СеверСталь"; 26.10.00

Тогда прийдётся с лазить на немецкий сервер поддержки пользователей

http://www4.ad.siemens.de/csinfo/livelink.exe/2263976?func=ll&objId=2263976&objAction=csView&lang=en&aktprim=0&siteid=cs

файлик 82 кБайта.
Выслал по почте

Спасибо за информацию
Eugene; 29.10.00

Спасибо за информацию


text

О реальном ИСПОЛЬЗОВАНИИ LOGO!
ПАВЛЯК К.С.; 27.2.00

Кто уже РЕАЛЬНО использовал ЛОГО! "с нуля" ?

Пишите .... плиз

Re: О реальном ИСПОЛЬЗОВАНИИ LOGO!
vzozulja; 28.2.00

Ну и?

Re: О реальном ИСПОЛЬЗОВАНИИ LOGO!
Сорокин В. Н.; 14.3.00

Задавайте Ваши конкретные вопросы?

Штука неплохая. Жаль мало допустимое число операторов между входом и выходом. Память позволяет "накрутить" больше, чем получаеся.
P.S. Применен на балансировочном станке СБ-30ВК в качестве логического устройства. Станок в эксплуатации на заводе "Омскшина".

Re: О реальном ИСПОЛЬЗОВАНИИ LOGO!
Сазонов С.О. BCC St.Petersburg; 23.3.00

Классная штука!!!

Сделана система сигнализации заполнения бака жидких
отходов производства. Состоит из:
- световой сигнализации уровней заполнения бака;
- звуковой сигнализации (два режима - сигнализация
срабатывания датчика верхнего уровня; сигнализация
неисправности одного из датчиков уровней) с
различными временными параметрами;
- кнопка сброса звуковой сигнализации при осуществлении
режима откачки отходов (но, если откачка не
производится (защита от "дурака") звуковая сигнализация
восстанавливается через некоторое время);
- дискретные выходы срабатывания датчиков
в систему верхнего уровня.
Все это на одном LOGO!24RCL!!!

Re: О реальном ИСПОЛЬЗОВАНИИ LOGO!
Александр В. Ковтун.; 4.8.00

Здравствуй, Павел.

Контроллеры ЛОГО используем уже 1,5 года, стоят в трех системах управления гидрогенератором: охлаждение генератора (управление 2 насосами), управление 2 насосами высокого давления и в системе управления пробковыми кранами. Есть небольшой, но уже опыт их эксплуатации, так как проекты на ЛОГО разрабатывали, монтировали и пускали сами.
Если у тебя есть вопросы, пиши на мой E-mail, буду рад поделится опытом.
С Уважением Александр В. Ковтун.

Re: Не трогай ты этот лого!
Андрей Таранов; 27.10.00

Не трогай ты этот лого!

за такие деньги можно купить говорящего слона!
берешь контроллер PIC16F84.
Софт описание бесплатно на microchip.ru
делает все то-же самое и много чего еще.
Стоит 5$.
Пиши,помогу.


text

FM455
Александр Калашников; 20.3.00

Если кто работал с FM455 - просьба отозваться!

В частности, вопрос такой. Конфигурация:
Error signal: Fixed Setpoint или Cascade Controller;
Control Algoritm: PID
Controller Output: Step Controller without Position Feedback Mode)
Проводим тест: устанавливаем задание SP,
подаем входную величину - Actual Value,
получаем какую-то ошибку Error Signal
и наблюдаем за выходом Control algoritm.
В выходном воздействии можно четко выделить P компоненту - пропорционально ошибке,
D компоненту (при изменении ошибки наблюдаем скачок). А вот I-компоненты НЕТ, увеличения значения со временем не происходит(при наличии ошибки). В чем наша ошибка?
Re: FM455
Никаноров В. - Сименс, Москва; 24.3.00

Если у Вас Step Controller, то он работает по алгоритму PD(или PDD2). Соответственно увеличения значения регулятора не происходит при постоянной ошибке, это нормально.

Если есть возможность пронаблюдать I-компоненту в отдельности, то она должна изменяться как обычно, если конечно она не в насыщении.
PD или PDD2?
Eugene; 23.10.00

Так все-таки PD или PDD2

(в смысле "PD D квадрат")?


text

реализация генератора импульсов
Смирнов Владимир; 12.10.00

Кто нибудь подскажите, как реализовать генератор используя функции таймера (нутром чую - можно используя On-Delay Timer и Off-Delay Timer).

изучайте матчасть
Eugene; 18.10.00

Вот STL-текст функции генератора импульсов

(проверял - работает):

timerNo : TIMER
period : S5TIME
clock : BYTE

AN #timerNo
L #period
SE #timerNo
NOT
BEC
L #clock
INC 1
T #clock

А ваще - читайте почаще доку - иногда помогает ;-)


text

нужна прошивка для модуля 6ES5525-3UA11
Кайхер Сергей; 15.10.00

Прошу помочь в поиске (приобретении) программы прошивки EPROM (32К), для модуля связи 6ES5525-3UA11 с мультиплексором 9600,Е,8,1.

В распоряжении имеется PG635 c ОС CPM/86.
Буду безумно благодарен всем откликнувшимся.


text

Как воскресить PG-795?
Шаклеин Вадим; 5.10.00

Привет, народ!

У нас такая проблема. Села батарея в PG-795
(АТ-шка 286 на 8 МГц) -> пропали все настройки
компьютера -> не видит жёсткий диск, перестал
загружаться -> перестал работать -> стоит без
работы. А там ещё кое-что из программ осталось.
Была у нас когда-то программка "atsetup", с
помощью которой можно было установить настройки
в BIOSе компа, но она осталась на этом PG.
Может у кого-нибудь она (или ей подобная) зава-лялась?
Или есть другие варианты?

Всё. Пока!
Re: Как воскресить PG-795?
Андрей Гуленок; 5.10.00

А что зто за программатор такой, PG 795? Мы всем отделом гадали, но ни кто не видел такого. Была распостранена линейка 670-675-685-635, но из них только 685 в поздней модификации был 286-ым, и биоса в теперешнем понимании там не было. Настройки он хранил "в душе", а при сбросе его можно было запустить со специальной дискеты. Остальные были ХТями. В природе существовал двухтумбовый стол, PG690, но это было совсем ни на что не похоже.

Из 286-ых был ещё 710 и его клоны, но это уже вполне себе лаптоп с биосом и прочими причиндалами нормальной РС. Остальные представители семисотого семейства строились на 386-ых и выше.

Sorry - это PG 695
Шаклеин Вадим; 6.10.00

Привет!

Прошу прощения - это не PG 795, а PG 695.
Он же - РС 16-20. У нас с 1990 г.
По виду обычный компьютер - комп. блок (с раз-
мерами PG 685), дисплей, клавиатура. Видеокарта
Hercules. Но имеет внутренние отличия от нормаль-
ного компьютера, которые не позволяют переставить
жесткий диск.
Спасибо за участие!
Пока!


text

Подключение клавиатуры IBM-совместимого компьютера к модулю CP526.
Ольштейн Эдуард , оАСУТП ОАО"Мечел".; 5.10.00

В системе используется контроллеры S5-115 с модулями CP526, к которым подключенны клавиатуры РВТ 982(6ES5982-2BA11 ,1989 года выпуска). Начала "сыпаться" пленочная структура. Через 2-3 года система будет менятся и брать новую дорогую клавиатуру (современная клавиатура аналогичная РВТ 982 СТОИТ 60 000 р.) не хочется.

Хочется подключить клавиатуру от обычного компьютера.
Прошу сообщить,есть ли у кого-нибудь такой опыт(положительный или отрицательный)?
Где можно взять протоколы обмена РВТ982 и СР526?


text

Как избавиться от помех?
Андрей Таранов; 28.8.00

Контроллер S7-224 сбоит при работе с частотником

пробовали частотники на 0.7кВт и на 1.8кВт.
Частотник и контроллер заземлены, сигнальные
провода экранированные. Ситуация несколько улучшилась, когда запитали частотник и контроллер
от разных вводов, но проблема не снята.
Как быть?

Re: Как избавиться от помех?
Oльштейн Эдуард; 5.10.00

Обычно принято заземлять кабель связи со стороны приемника. По крайней мере только с одной стороны. При заземлении кабеля с двух сторон образуется контур экран кабеля-земля, что только ухудшает ситуацию с помехами. Может быть вам поэксперементировать в этом направлении.


text

5v в UR1
gregory; 20.9.00

Мне нужно взять напряжение +5В из UR1 (SM400). как это можно сделать (на каких ножках)?

Можно ли это напряжение взять непосредственно из PS407 (405)?

Григорий

Re: 5v в UR1
Михайлин Сергей(SIEMENS-Москва); 28.9.00

Информация о разводке задней шины корзины не предлагается. Кроме того, такие вещи не рекомендуем делать в силу хрупкости этих ножек!

Из блоков питания, не разбирая их, нельзя снять это напряжение. Только подвести извне!


text

S5-150U, OB43
Dmitriy D.; 22.9.00

При горячем рестарте CPU уходит в стоп. В стеке

выдает обращение к OB43. В программе пользователя
данный блок не используется.
В справочнике 6ES5998-0AL01-1C информации по ОВ43
нет.
Для чего предназначен ОВ43 и когда вызывается?

При холодном рестарте CPU уходит в стоп, стек не
выводится, программа не стирается.
В чем может быть дело?


text

Simatic S5 & Sinec L1
Турчанинов Владимир; 12.9.00

Имеется контроллер Simatic S5, датчики шлют ему инфу, а он по шине Sinec L1 пытается передавать эту инфу на ПК. В ПК стоит плата от фирмы Comsoft GmbH - DF30ix. Комп старинный - 386-ой. Всё вроде бы работает.

Однако, при попытке воткнуть эту плату в современный ПК, работающий под Windows NT/2000 плата не видна и как с ней работать непонятно.
Comsoft не поддерживает этот тип плат уже 6 лет и предлагает купить у них более современную модификацию - DF32.
Вопросы: 1. Можно ли совсем отказаться от шины Sinec L1, поставить в комп какую-нибудь более-менее обычную :-) плату RS-485 и работать с ней?
Если да, то как это сделать и чем в этом может помочь Ваша фирма?
2. Если всё-таки оставить Sinec L1, то нет ли у Сименса своих решений для такого типа задач (я имею в виду интерфейсные платы для связи с ПК, нет ли сименсовских аналогов плат от Comsoft)?
Возможно, я что-то непонятно здесь изложил, если необходимы уточнения - сообщите. Надеюсь на быстрый и квалифицированный ответ. Заранее благодарен.
Re: Simatic S5 & Sinec L1
Дедовец Павел; 14.9.00

А сколько контроллеров подключены через SINEC L1 к SICOMPу ? Один или бльше? Для соединения к SINEC L1 используется порт программатора (PG), дополнителиный интерфейс на ЦПУ или специальный модуль CP.

Re: Simatic S5 & Sinec L1
Турчанинов Владимир; 19.9.00

5 контроллеров Simatic S5 115U, используется процессор связи CP530.

Re: Simatic S5 & Sinec L1
Дедовец Павел; 22.9.00

Наиболее приемлемое решение это - поставить в один из контроллеров PC для PROFIBUS или Ethernet и уже его соединить с ПК.

Можно так же подключить этот контроллер к ПК и по AS511 протоколу (PG порт) к RS232 (ПК). Этот вариант дешев, но увеличивает нагрузку на ЦПУ контроллера.


text

Лог работы программы для S7-300
Михаил; 15.9.00

Возникла необходимость узнать как изменяются переменные в Step7-программе за несколько суток работы. Наиболее приемлемый вариант - подключить програматор чтобы он формировал какой-либо лог-файл. Как это возможно осуществить? Существует ли какое-либо програмное обеспечение?

Система:CPU 315, PG 720
Re: Лог работы программы для S7-300
Чистяков Дмитрий ОАО "СеверСталь"; 19.9.00

Если сигналов не много и они изменяются не часто, то можно производить запись в буфер диагностики процессора, а затем читать их в Step 7.

Если сигналов много, то необходим дополнительный софт, например WinCC.
А ещё лучше S7 - PDiag.


text

Simatic S-400
Владимир; 12.9.00

Позволяет ли система Simatic S-400 производить

изменения в управляющих программах контроллера в
интерактивном режиме с инженерной станции.

Re: Simatic S-400
Никаноров В. - Сименс, Москва; 18.9.00

Конечно, если на инженерной станции установлен Step7.


text

Prosave
Шапиро Марк; 12.9.00

Если кто-то имеет успешный опыт по использованию программы Prosave для записи из ОР и ТР в файл, прошу поделиться знаниями.

Re: Prosave
Дедовец Павел; 14.9.00

Утилита досаточно простая. Зная несколько слов по английски или имея словарик можно понять. Особенностью можно назвать то, что она заработала у меня нормально только после перегрузки из Windows в режим DOS. Видимо проблемы с портом.


text

приобретение Simatic S5
Константин Демидович; 14.9.00

сообщите пожалуйста можно ли приобрести Simatic S5

для установки на собственый компьютер,и сколько это может стоить.


text

drivers
spaseman; 25.2.00

СРОЧНО НЕОБХОДИМЫ ДРАЙВЕРА ДЛЯ SIEMENS

SIMATIC PG740 PROGRAMMING DEVICE CD
ПОМОГИТЕ ИХ НАЙТИ !!!
РОМАН тел 349-51-26

Вышлю по E-Mail, только сообщите ....
Михайлин Сергей (SIEMENS-Москва); 1.3.00

какие именно драйвера нужны. Для CD-ROM drive, для видео карты или иные?

Re: Вышлю по E-Mail, только сообщите ....
demidovich konstantina; 12.9.00

как перенести simetic S5 c программатора на персональный компьютер.Достаточно ли простого копированияю


text

CPU 948
Logunov Ivan; 6.9.00

Уважаемые господа! Как при работе с CPU 948, возможно произвести обращение

к ячейке памяти в области маркеров связи по абсолютному адресу этой ячейки?
В случае с CPU 928B, это делалось просто, например:

L KH F220
LIR 1
T FY32

Для CPU 948 аналогичный адрес для FY32 - F F220H.
В имеющейся у меня документации коротко указано, что непосредственное
обращение даёт "FF H" в старшем байте и данные в младшем?


text

Продается Simatic S5-135, Simatic S5-115
Иванов Андрей; 5.9.00

Предлагается на продажу недорого Simatic S5-135, Simatic S5-115 с разными блоками, корзинами,и софтом.Новые и Б/У. Подробности по E-mail: Andrey.Ivanov@Unilever.com.


text

CPU 948
Logunov Ivan; 1.9.00

Уважаемые господа! Как при работе с CPU 948, возможно произвести обращение

к ячейке памяти в области маркеров связи по абсолютному адресу этой ячейки?
В случае с CPU 928B, это делалось просто, например:

L KH F220
LIR 1
T FY32

Для CPU 948 аналогичный адрес для FY32 - F F220H.
В имеющейся у меня документации коротко указано, что непосредственное
обращение даёт "FF H" в старшем байте и данные в младшем?


text

Схема на Simatic S5-115U
ОАО "НИЗ"; 1.9.00

Просьба откликнуться у кого есть схемы блока питания и выходного блока 64/24 Simatic S5-115U.


text

PG740 (контроллер HDD)
AndrewB; 29.8.00

Уважаемые господа!

А не подскажет ли кто как в программаторе PG740 (487DX-100MHz) отключить встроенный в материнку контроллер жесткого диска.

Благодарю за помощь.


text

Point to point link between CP and CPU
EvroImex DSP; 29.8.00

Подскажите пожалуйста где можно найти распайку соединительного шнура точка-точка между CP и CPU (PG интерфейс AS 511)


text

заказ
Шилов, Армавир; 28.8.00

Занимается ли SIEMENS выпуском и продажей шаговых

двигателей средней мощности?

Re: заказ
Воронин Александр (SIEMENS A&D MC Москва техническая поддержка ); 28.8.00

Да! SIEMENS занимается выпуском и продажей шаговых двигателей мощностью от 2Нм до 15Нм. Кратко можно посмотреть в Интернет по адресу:

http://www.siemens.ru/ad/mc/ru/products/motor/1fl3.html

См. Сайт отдела SIEMENS A&D MC


text

AS511
Sergei; 24.8.00

Разбирая AS511 протокол разобрался как получить адрес DB-шки. Для этого в функции B_INFO в заголовке используется ID=01h. S5 находит начальный адрес в своей системной памяти SR34 и прибавляя необходимый номер DB сообщает о адресе первого элемента искомого DB в области памяти узера. Какие ID ещё используются, например для доступа к флагам, таймерам и блокам?

Заранее спасибо.
Re: AS511
Никаноров В. - Сименс, Москва; 24.8.00

Распределение памяти (меркеры, таймеры, периферия) описано в руководстве на соответствующий процессор.

По поводу IDs не совсем понятно, откуда (из какого пакета) Вы хотите получить доступ к памяти контроллера. Если это Prodave-AS511, то из него возможен доступ только к блокам данных.
Напишите более подробно.
Re: AS511
Sergei; 24.8.00

Никакой пакет я не использую, всё по той-же причине скудности нашего бюджета. :)

Всё приходится делать ручками...
Нашёл в инете небольшое описание в текст формате "S5 AS511 (Programming port) protocol description" на 3 странички. Ничего лучшего я не нашёл. Описано три функции протокола обмена с S5-м. Получение адреса блока, чтение по адресу блока и запись по адресу. Для каждого случая свой function code. Для функции получения адреса B_INFO описан только один ID=01h для блоков DB. Это первый байт в разделе header info этой функции в протоколе AS511. Дальше идёт байт-номер соответствующего DB. Логично рассуждая, что здесь можно организовать доступ и к другим типам блоков как FB,PB,OB,таймерам,счётчикам и наконец флагам, можно предположить, что для каждого типа определён свой ID. Этот ID "понимает" сам PLC. Хотелось бы их того... Знать. :)
Я хорошо знаком с протоколом 3964R для связи с CP525.
А может я нахожусь в плену своих заблуждений?
Заранее спасибо.
Re: AS511
Никаноров В. - Сименс, Москва; 25.8.00

Опять не совсем понятно.

Куда Вы подставляете ID?
Если в какую-то функцию (на С, Pascal), то откуда Вы взяли эту функцию. А также не понятно, что за описание AS511 у Вас (возможно, это всего лишь кусок описания какого-то более полного пакета).
Или, может быть, я совсем не понимаю, о чем идет речь?
Re: AS511
Чистяков Дмитрий ОАО "СеверСталь"; 28.8.00

Видимо господа хотят написать свою SCADA систему или написать свой драйвер связи для какой-то готовой SCADA.

Но, непонятно зачем им это нужно.
Разве они не имеют право на получение бесплатного пакета WinCC?
А там уже встроена поддержка AS511

С уважением, Чистяков Дмитрий


text

S5-135 Basp
Сергей; 23.8.00

135U 928 процессор.

Входные-выходные блоки соединены аккуратно.
В любом режиме Start,Stop горит Basp индикатор.
Входа работают, CP 525 работает, блок цифровых выходов не работает. Судя по всему Safe state
режим. Никакими комбинациями switch-ей на передней панели избавиться от этого не удаётся. С другим 135-м в этом-же rack-е без проблем. Это смертельно? Я к тому, что он уже безнадёжен окончательно ?
Re: S5-135 Basp
Дедовец Павел; 24.8.00

Можно поподробнее, что Вы делали?

Само по себе - "Никакими комбинациями switch-ей на передней панели" моло о чем говорит. Есть ли у Вас документация на 135U, и какая?

Писать можно на E-mail.


text

Полярность напряжения питания входов CPU 216 имеет значение?
Андрей Таранов; 8.8.00

Смотрю в каталог, вижу схему запитки входов s7-216. К 1М подключен "+", а к 2М - "-".

Почему так, можно-ли к обоим подключить минус, и имеет-ли вообще значение полярность, ведь входы вроде гальв.-развязаны?
спасибо.

Re: Полярность напряжения питания входов CPU 216 имеет значение?
Андрей Гуленок; 15.8.00

Огрехи перевода. В руководстве пользователя стоит сноска, что возможна обоюдная полярность.


text

Проблема с EM235
Павел Орешко; 31.7.00

После подключения аналогового модуля ЕМ235

(3 AI / 1 AQ) к CPU216-2, несмотря на то , что
напряжение на аналоговый вход подаю достаточно стабильное , в программаторе диапозон значений прыгает +/- 75% от подаваемого напряжения

Может кто-нибудь знает в чем дело ?
Павел

Re: Проблема с EM235
Василий ; 15.8.00

Заземли вход и питание и все будет нормально.В MicroWin есть встроенный мастер, который фильтрует вход.


text

Резервирование S7-300
Богдан Кудлак; 1.4.00

В документе

"Software Redundancy for SIMATIC S7-300 and S7-400
Help topics from S7_SWR_B.HLP of 12/99"
сказано, что для резервирования S7-300 можно использовать
следующие процессоры (стр.47)

CPU 315-2DP 6ES7 315-2AFxx-0AB0
CPU 316-2DP 6ES7 316-2AGxx-0AB0
CPU 318-2DP 6ES7 316-2AJxx-0AB0

На стр. 40 (см.ниже) дано время переключения между
процессорами только для CPU 315-2DP.

Какое время переключения для более быстрых
процессоров CPU 316-2DP и CPU 318-2DP?

==================================================================
Requirement for Call Interval of OB 1/OB 35
The call interval between two OB 1 calls or two timer-controlled
OB calls must always be greater than
the switch-over time for 4 or 8 DP slaves.
Only if you are using fewer than 4 or 8 DP slaves, may the
call interval be smaller (see table for times).
CPU 315-2DP with Integrated DP Master
==================================================================
Number of CPU consisting of S7-300 with integrated DP Master...
DP Slaves

12 MBaud 1,5 MBaud 500 kBaud 187,5 kBaud
==================================================================
1 6 ms 6 ms 7 ms 12 ms
2 12 ms 12 ms 14 ms 24 ms
4 25 ms 25 ms 30 ms 50 ms
8 2 x 25 ms 2 x 25 ms 2 x 30 ms 2 x 50 ms
16 4 x 25 ms 4 x 25 ms 4 x 30 ms 4 x 50 ms
32 8 x 25 ms 8 x 25 ms 8 x 30 ms 8 x 50 ms
64 16 x 25 ms 16 x 25 ms 16 x 30 ms 16 x 50 ms
==================================================================

Re: Резервирование S7-300
Павел Иванов (Сименс-Москва); 7.8.00

Время переключения зависит в основном от объема данных и скорости объединяющей сети, а не от операционной системы ЦПУ.


text

связь PPI
shurik; 17.5.00

Как штатными средствами передать данные с S7-212 в EXCEL

Спасибо
Re: связь PPI
Гуленок Андрей; 17.5.00

Есть такой софтвер - Prodawe. Это набор Си библиотек. С его помощью можно наладить связь S7-200 и РС. Ещё эту задачу решала фирма Инфорум (Александр Лифанов [ALifanov@INFORUM.RU]). Но они писали собственный софт для этого.

Re: связь PPI
shurik; 17.5.00

Добрый пакет Вы упомянули ,но не содержит он драйвера PPI для NT/Win98,либо есть новая версия этих библиотек (тода будьте любезны заказной номер его)- или есть у меня задумка использовать коммуникационную DLL от MicroWin32 (правда по хакерски это как-то получается)

Re: Prodave MPI v.5
Павел Иванов (Сименс-Москва); 7.8.00

Prodave MPI v.5 поддерживает работу и с S7-200, но только через карты CP5611/CP5511, а не через кабель с конвертором PC/PPI.

Prodave MPI Mini v.5: 6ES7 807-3BA00-0YA0
Prodave MPI v.5: 6ES7 807-4BA00-0YA0


text

SM431....
Кочин Алексей; 26.7.00

Ваше сообщение...В модуле аналогового ввода sm431-1kf10-0ab0(AI 8x14bit)вышел из строя чип со следующей маркировкой:AD634

0P07C
N24621.
Помогите опознать или хоть аналог назовите.


text

SIMATIC S5-150
Туманов А. В.; 3.7.00

Нужны схемы подключения модулей входов 6ES5420-4UA11 и модулей выходов 6ES5441-4UA11.

Адреса для таких модулей задаются только с помощью микропереключателей на самих модулях или требуется еще какая-нибудь процедура?

Задаю адрес на модуле входов 0 (все переключатели в положении off), модуль устанавливаю в слот следующий за тем, в котором стоит интерфейсный модуль 6ES5310-3AB11 в корзине расширения 6ES5183-3UA12. В режиме ТЕСТ ПЕРЕМЕННЫХ по адресу IW0 читаем FFFF, в чем может быть дело?

Re: SIMATIC S5-150
Павел Иванов (Сименс-Москва); 17.7.00

Эти модули описаны так же в руководствах по:

S5-135/-155, U-Peripherie, ...
Эти руководства есть как на русском так и на английском языках.
На английском языке можно загрузить с немецкого сайта, а на русском получить у наших региональных представителей.


text

поддержка CPU 314 программного ПИД-регулятора
Святкин Владимир ОАО РММЗ; 12.7.00

Поддерживает ли CPU 314 программный ПИД-регулятор.

Re: поддержка CPU 314 программного ПИД-регулятора
Никаноров В. - Сименс, Москва; 12.7.00

Все CPU поддерживают.

Для реализации программного ПИД регулятора служат библиотечные блоки Step7: FB41,42,43. Вы должны добавить их в свою программу.
Кроме того, если у Вас CPU314IFM, то эти блоки уже встроены в его операционную систему под номерами SFB41, SFB42, SFB43. При этом Вы существенно экономите память пользователя, т.к. эти блоки не занимают ее.
Помимо этих простейших блоков Вы можете использовать комплексные пакеты регулирования:
Standart PID Control
Modular PID Control


text

Не хватает памяти CPU-314
Конышев Алексей; 1.7.00

При загрузке в процессор CPU-314 дополнительного

FC блока возникла ошибка, что не хватает рабочей
или загружаемой памяти.Проверка загрузки памяти
показала: рабочая память загружена на 65%, а загружаемая 51%. Загружаемый блок не более 5% от всей программы. Так что же такое загружаемая память? В чем здесь проблема?
Re: Не хватает памяти CPU-314
Никаноров В. - Сименс, Москва; 10.7.00

Попробуйте сделать дефрагментацию памяти

(или очистку памяти с последующей загрузкой всей программы).Других проблем быть не должно.


text

Имеется контроллер S5-135U/155U
Nukri Basharuli; 27.6.00

Имеется контроллер S5-135U/155U

Каким образом можно разобраться в его
програмировании ? Есть ли в Москве центры
обучения работы с ними ?
Заранне благодарю.

Re: Обучение
Никаноров В. - Сименс, Москва; 10.7.00

...

См. http://www.siemens.ru/ad/as/ru/training/index.html


text

Преобразование RS232/MPI
Сорокин Владимир; 20.6.00

Ответьте, пожалуйста, кто пробовал или знает точно.

На компьютере имеется порт RS485. Можно ли его рассматривать как преобразователь РС/MPI-кабель (6ES7901-2FB00-0AA0).

Владимир Сорокин.

Re: Преобразование RS232/MPI
Никаноров В. - Сименс, Москва; 20.6.00

Нет, нельзя.

Re: Re: Преобразование RS232/MPI
Сорокин В.; 21.6.00

Если можно, немного поясните: в чем разница?

Сорокин Владимир.

Re: Преобразование RS232/MPI
Павел Иванов (Сименс-Москва); 21.6.00

Если это компьютер, производства фирмы Siemens, то скорее всего да. Надо уточнить, что это за компьютер.

Иначе, скорее всего, нет, т.к. несмотря на то, что сеть MPI/Profibus использует в качестве физики RS485, но работает на больших скоростях и выполняет много функций, которые реализованы в чипе интерфейса. И также есть проблема с драйвером для программных пакетов - они реализованы к стандартным интерфейсным платам/преобразователям, производства фирмы Siemens.


text

FM455C
Борцов В.; 15.6.00

1.Можно ли использовать дискретные входа FM455C как обычные (независимо от петель регулирования).

2.Сколько контуров регулирования можно реализовать используя один FM455C.


text

FM458
Григорий; 26.5.00

Здравствуйте!

Какие средства нужны для программирования сего модуля, а также его субмодулей? Есть ли какие-то текстовые языки?

Где в сети можно посмотреть дополнительные материалы? У меня есть только несколько PDF-ов примерно на 1М.

Re: FM458
Чистяков Дмитрий ОАО "СеверСталь"; 26.5.00

Для написания программ для этого контроллера необходим STEP7 + CFC + D7-SYS. Последние версии всех пакетов 5.0. Выгоднее купить пакет программ в одном флаконе - D7-ES - Complete STEP 7/CFC and D7-SYS package (6DD1801-4DA2). При этом необходимо помнить, что нельзя использовать пакеты разных версий. У нас даже была проблема, когда вместо Step7 SP2 мы поставили Step7 SP3 + Hotfix3.

Для параметрирования DP-периферии на субмодуле SS4 необходимо докупить пакет COM Profibus ver 3.3 и выше.
Ну, а так надо конкретно про каждый модуль разговаривать отдельно.

Фирма Siemens выпускает CD-ROM с полной документацией по Simadyn D и FM458. Этот CD-ROM входит в комплект D7-ES.
А в общем FM458 практически мало отличается от Simadyn D CPU PM6.
Вы можете так же заказать бесплатный бумажный каталог DA99 с описанием этих систем.
Либо просмотреть краткую информацию в онлайновом CA01.

Re: FM458
Никаноров В. - Сименс, Москва; 29.5.00

Могу добавить следующее.

Документация на FM458 имеет следующую структуру.
1. Документация на сам FM458, его аппаратную часть и программное сопряжение с SIMATIC S7-400.
Две основные главы из этого руководства недавно переведены на русский.
2. Документация по программированию этого модуля и системным функциям. Это руководство общее для FM458 и Simadyn. В настоящее время переведены руководства "CFC для Simadyn" и "Системное программное обеспечение".

Эти руководства включены в новый CD_Manual. Также могу выслать по email.
Re: FM458
Григорий; 30.5.00

Здравствуйте!

Спасибо за информацию. Готов принять имеющуюся у Вас документацию по e-mail. У меня есть только несколько PDF-ов, содержащуие выжимку из каталогов, некоторое описание модуля и его субмодулей ЕХМ и некоторые сведения о программировании (взяты с СD-ROM c документацией по контроллерам S7 из раздела FM).

Хотелось бы также получить информацию о возможности использования текстовых языков программирования. Применительно к D7 мне попадалась ссылка на язык STRUC (о нем мои понятия также минимальны), который вытесняется CFC. Это связано с необходимостью переноса имеющихся программ на языке С для I486 на FM458. Опыт работы с CFC минимален + большая логика в программах (много ветвлений), поэтому было бы проще использовать текстовый язык.

Кстати, входит ли в комплект программы (блоки)ввода с субмодулей EXM?

С уважением, Григорий
Re: FM458
Никаноров В. - Сименс, Москва; 30.5.00

Документацию отправил.

FM458 программируется только с помощью CFC (как и все новые модули).
Имеется также User function block generator, который позволяет сгенерировать библиотечный функциональный блок, написанный пользователем.
Re: FM458
Чистяков Дмитрий ОАО "СеверСталь"; 30.5.00

Тут хотелось бы спросить - "А что за программа то такая?".

Что значит много логики? Это чисто битовая логика, т.е. конечники кнопки и т.д.
Если это так, то всю логику можно сделать в CPU S7-400. Там это будет значительно проще. Тем более что он всё равно должен присутствовать. Да и УСО у него более развито и дешевле.
А на сам FM458 можно возложить задачи регулирования, требующие сложных и быстрых расчётов.
Так построение регулятов в CFC значительно проще чем их написание на языке типа C. Здесь всё очень похоже на рисование квадратиков на лекции по ТАУ.
Вообще же системы типа Simadyn D (новое название Simatic TDC) можно назвать "Смерть программистам". И кстати так оно и есть. Например, у нас Simadyn`ы используются с 1995 года, и большая часть программистов так и не приняла этой системы. Так как здесь нельзя (и нет необходимости) писать какие то сложные прогаммки, которые должны обмануть систему. При работе с этими контроллерами достаточно быть специалистом в своём деле, а не программистом.
Так эту систему очень полюбили наши приводчики и проектанты. Господа с Уралмаша заявили, что неконец-то появилась система в которой не надо знать, как расположены старший и младший байт - об этом можно просто забыть.
Re: FM458 для сведения
uhbujhbq; 2.6.00

Программа содержит много логики означает, что в ней много ветвлений (типовая структура большинства алгоритмов "если ... то ... иначе ..." или "если ... то идти"). В данном случае программа должна управлять газотурбинным двигателем с реализацией алгоритмов запуска, диагностики, самоконтроля и прочее.

Поэтому уж если разговор зашел об этом, то хотелось бы узнать об опыте написания подобных программ на CFC.

На тему старший/младший байты, битовые операции это в "С" реализуется через #define. Об этом мы вспоминаем только, если нужно нарисовать что-то машинно-зависимое, например обмен с со своим пультом.

По s7. а)Требуется обеспечить малое время цикла (~20mc);
б) в номенклатуре S7 нет подходящих преобразователей для ввода оборотов за этот интервал времени
в)дискретный вывод в S7 имеет частоту 100гц, а для программного формирования управляющего сигнала надо чаще, т.е для дискретного вывода по ряду параметров должно быть еще меньшее время цикла ~1мс, а возможно и меньше. Так что вроде альтернативы FM в данной ситуации нет.

Re: FM458 для сведения
Чистяков Дмитрий ОАО "СеверСталь"; 15.6.00

Ну что ж немного из опыта.

Правда, опыт у нас по работе с прокатными станами в чёрной металлургии. Но требования к быстродействию системы тоже весьма жёсткие. Так сейчас в системах регулирования толщины и натяжения установлено время скана 2 мс (Т1).

По поводу логики. Как правило в системах регулирования прошлых лет применялись алгоритмы программ, которых строились по принципу применения вычислений цифровых систем методами приближённых к реальномым. Т.е. те алгоритмы решения различных математических функций, которые не поддавались простым вычислениям. Например, вычисление интеграла.
Если вспомнить простейшую систему регулирования, то она всегда содержит (как минимум) одно входное значение для управления системой, одно-два звена управления и обратную связь. Так вот чтобы описать подобную систему раньше приходилось решать кучу уравнений и производить ещё больше вычислений, для того чтобы реализовать регулятор какой то величины. И вот тут то и появлялась та "логика", которая не имела ни какого отношения непосредственно к регулятору, так как она была необходима лишь для математических вычислений.
Теперь написание программы в CFC сводиться в составлении структурной схемы, которая в квадратиках реализует тот же регулятор. А все вычисления уже спрятаны в этих квадратиках. Так что "логика" из программ на CFC выпадает за ненадобностью.

Теперь про само написание программы на CFC.
Здесь Вы не встретите анахранизмов, тянущихся с языками программырования типа C, Pascal, Basic и т.д., которые требуют описания переменных. Здесь нет такого понятия. Написание программы подобно рисованию электрической схемы, где входы/выходы квадратиков (микросхем) соединяются линиями (проводами). При этом набор функциональных блоков (квадратиков) вполне достаточен, так что у нас за пять лет даже мысли не возникло написать свой блок. Здесь главное - это проштудировать описание блоков и выбрать требующийся.

Вообще CFC это объектно ориентированный язык прграммирования, доведённый до той степени, когда уже программирования как такового остаётся всё меньше и меньше. И имено поэтому требуется прежде всего специалист по регуляторам, а не программист в чистом виде.

Если Вы вышлете мне свй e-mail, то я могу выслать Вам примеры программ на CFC.
Так же у Siemensa есть CD с демо версиями программирования на всех языках (CFC, Graph, HiGraph и т.д.) он высылается бесплатно.

О быстродействии.
Минимальное время скана в Simadyn D 0,1 мс. Всё УСО работает с половинным временем минимального цикла - 50 мкс. При чём как аналоговое, так и дискретное.
Про ваш сигнал.
Тут необходимо узнать, что же это за сигнал. Если это просто регулируемый генератор импульсов, то может даже нет необходимости реализовывать его программно. А можно купить Simatic и какой нибудь FM 45x, который формирует на своих выходах требующуюся последовательность внутренним программно-аппаратным способом, не занимая ресурсов CPU.


text

CPU315 & CPU315-2 DP
УМиА "Северсталь"; 8.6.00

Может кто-то сравнивал быстродействие сабжиков, а то у меня CPU315 быстрее работает, чем CPU315-2 DP.

Re: CPU315 & CPU315-2 DP
Чистяков Дмитрий ОАО "СеверСталь"; 8.6.00

Согласно документации время выполнения инструкций (команд) идентично. Но здесь следует учитывать, что во время скана 315-го происходит считывание входов-выходов, находящихся непосредственно на корзине. А в 315-2 DP ещё добавляется время приёма данных с УСО, подключенного по PROFIBUS, и здесь всё зависит от скорости обмена и количества периферии.

Да, ещё есть галочка в настройках , которая выравнивает скан по времени до 10 мс у S7-300 и 1 мс у S7-400.

Источник документации о времени выполнения инструкций:
S7- 300 Instruction List
Edition: 2
CPU 312 IFM, 314 IFM,313, 314, 315, 315- 2 DP, 316- 2 DP,318- 2
Order number: 6ES7 398- 8AA03-8BN0
ZN: EWA4NEB7106087-02 01
(761 Kbytes, 0 Units)
http://www4.ad.siemens.de/virlib/doc_76/s7/opli_e.pdf

Там же дан принцип расчёта времени скана.

Re: CPU315 & CPU315-2 DP
Никаноров В. - Сименс, Москва; 13.6.00

Надо также смотреть, какие версии CPU Вы сравниваете.


text

SIMATIC S5-115U
ASD; 7.6.00

БЛОК ПИТАНИЯ.

Re: SIMATIC S5-115U
Чистяков Дмитрий ОАО ; 7.6.00

Да блок питания! А что конкретно?!


text

Найти модули цифрового вывода
Дрокин Александр; 5.6.00

Срочно нужно два модуля цифрового вывода

6ES5 441-7LA11, кто и в какие минимальные сроки мог бы их поставить или предоставить на время?


text

Приобретение ноутбука (программатора)
Кириллова Люба; 25.5.00

Можно ли у "Siemens" приобрести ноутбук или программатор без программного обеспечения STEP 7 и STEP 5. Если "да" вышлите прайс-лист на Alex@mspm.ru

Re: Приобретение ноутбука (программатора)
Sergeev Roman; 2.6.00

Продается PG740 (intelPentium133 10.4")

а ,также НОУТБУК SCENIC MOBILE 500 (intelPentium100 32Mb 1Gb...)
+dockStation

Пишите по адресам: roman_sergeev@mailru.com
roman_sergeev@pisem.net
PG740@mail.ru
PG740@aport.ru


text

SIMATIC S5-150 Что это такое?
Москалев Михаил; 24.5.00

Будет важна любая информация по контроллеру SIMATIC S5-150.Модули:925,926,927,511.Заранее благодарен.

Re: SIMATIC S5-150 Что это такое?
Чистяков Дмитрий ОАО "СеверСталь"; 30.5.00

Order numbers of the instruction manuals for the AG 150

Entry ID: 188212 - Date: 12/17/1997
deutsch francais italiano

QUESTION:
What are the order numbers for the AG 150 instruction manuals?

ANSWER:
The following table lists the instruction manuals and their order numbers: Instruction manual Order number
Instruction Manual AG 150A (German) 6ES5 998-0AE15
Instruction Manual AG 150A (English) 6ES5 998-0AE24
Instruction Manual AG 150A (French) 6ES5 998-0AE31
Instruction Manual AG 150K (German) 6ES5 998-0AG16
Instruction Manual AG 150K (English) 6ES5 998-0AG22
Instruction Manual AG 150K (French) 6ES5 998-0AG31
Software Manual AG 150A/K (German) 6ES5 998-0SW11
Software Manual AG 150A/K (English) 6ES5 998-0SW21
Software Manual AG 150A/K (French) 6ES5 998-0SW31
Instruction Manual AG 150S (German) 6ES5 998-0AK13
Instruction Manual AG 150S (English) 6ES5 998-0AK21
Instruction Manual AG 150S (French) 6ES5 998-0AK31
Instruction Manual AG 150U (German) 6ES5 998-0AL11
Instruction Manual AG 150U (English) 6ES5 998-0AL21
Instruction Manual AG 150U (French) 6ES5 998-0AL31
Instruction Manual AG 150U (Russian) 6ES5 998-0AL01-1C
Software Manual for AG 150U/S (German) 6ES5 998-1SW11
Software Manual for AG 150U/S (English) 6ES5 998-1SW21
Software Manual for AG 150U/S (French) 6ES5 998-1SW31
Instruction Manual for Robust I/O (German) 6ES5 998-0PA11
Instruction Manual for Robust I/O (English) 6ES5 998-0PA21
Instruction Manual for Robust I/O (French) 6ES5 998-0PA31
Instruction Manual for Compact I/O (German) 6ES5 998-0PB11
Instruction Manual for Compact I/O (English) 6ES5 998-0PB21
Instruction Manual for Compact I/O (French) 6ES5 998-0PB31
Instruction Manual for U-I/O (German) 6ES5 998-0PC12
Instruction Manual for U-I/O (English) 6ES5 998-0PC22
Instruction Manual for U-I/O (French) 6ES5 998-0PC32
Instruction Manual for U-I/O (Spanish) 6ES5 998-0PC42
Instruction Manual for U-I/O (Russian) 6ES5 998-0PC01-1C

These manuals are no longer standard; some are included in the spare parts catalog. If you need an old manual, then please get in touch with your Siemens contact who will be able to tell you whether or not the manual you require is still available.


text

EPROM
Дрокин Александр; 24.5.00

Сколько времени храняться данные в модулях памяти

375 для CPU 943?
Re: EPROM
Никаноров В. - Сименс, Москва; 24.5.00

В модулях EPROM 6ES5 375-.... используются стандартные микросхемы EPROM (не обязательно Siemens).

Общепринято, что такие микросхемы должны сохранять данные более 10 лет.


text

SM431
Григорий; 17.5.00

Добрый день!

Обязателен ли для модуля SM431 (в частности 16-ти входовый 7QH00) модуль выбора пределов измерения или можно ограничиться Step7?

Какой терморезистор нужно подключать на вход 0 для компенсации термопары или он встроен внутрь?

Уменьшается ли при этом число входных каналов на 2?

Григорий
Re: SM431-подключение термопар
Никаноров В. - Сименс, Москва; 17.5.00

1. Модули выбора диапазона измерений (резистивные делители) поставляются вместе с модулем аналогового ввода. В частности, для модуля 6ES7431-7QH00-0AB0 (16 каналов) поставляется 8 модулей диапазонов измерений (один модуль на 2 канала).

Для выбора конкретного диапазона необходимо установить модуль выбора диапазона в соответствующее положение, при этом выбирается группа диапазонов, а в Step7 дополнительно установить конкретный диапазон. Более подробно см.в руководстве.

2. Для компенсации температуры холодных спаев термопар для модуля 6ES7431-7QH00-0AB0 используется терморезистор Pt100 (климатический диапазон: до 130 град.С, разрешение 0,01 град.).
При этом количество каналов уменьшается на 2.
Для некоторых других модулей имеется внутренняя компенсация холодных спаев.

3. Дополнительно можно использовать так называемую динамическую компенсацию.
Если у Вас имеется несколько модулей с подключенными термопарами с одинаковой температурой холодных спаев, то достаточно в одном модуле считать эту температуру. А в другие модули занести ее с помощью SFC55.

Re: SM431-подключение термопар
Григорий; 18.5.00

Эти модули нужно заказывать отдельно или они входят в комплект модуля?

Если их надо заказывать, то применительно к указанному модулю, это 4 позиции по каталогу (1позиция - два модуля)?

Также по терморезистору - заказная позиция или нет? Если да, то где ее найти в каталоге (компакт-диск)?

SFC55 - это язык SFC версии 5.5 или функциональный блок или ...?

В руководстве (я использую переводной вариант) написано, что настройки можно выполнить посредством электрического монтажа и Step7. Я хочу ввести посредством упомянутого модуля 12термопар и два сигнала 4-20мА + возможно терморезистор на канал0. Возможно ли в данном случае обойтись электрическим монтажом?

Григорий
Re: SM431-подключение термопар
Никаноров В. - Сименс, Москва; 18.5.00

1. модули входят в комплект модуля аналогового ввода

2. Используется стандартный терморезистор Pt100. Его можно заказать где угодно;
если хотите у Сименса, то позвоните по тел. 737-2478.
3. SFC55 - это системная функция, входящая в операционную систему Simatic процессоров.
4. Для выбора конкретного диапазона необходимо установить модуль выбора диапазона в соответствующее положение, при этом выбирается группа диапазонов, а в Step7 дополнительно установить конкретный диапазон.


text

Сертификация
Evstropov Sergey; 17.5.00

Господа прошу сообщить методику поверки аналоговых плат семейства S5, требуют по ISO-9000.

Буду крайне признателен всем откликнувшимся.


text

simatic s5-150u
Divna Simeunovic; 17.5.00

Have you any documentation about s5-150U?

Thank you.

Re: simatic s5-150u
Никаноров В. - Сименс, Москва; 17.5.00

Unfortunately, there is no S5-150U documentation in electronic form.


text

Обмен данными между двумя СР 414-2 по К шине
Занчевского Юрия; 13.4.00

Как орканизовать обмен данными между двумя процессорами в одном каркассе (мультипроцессорный режим ) по внутренней (к) шине. Процессоры СР 414-2 с временами циклов 2 и 20 мсек и обьемом данных обмена 1 квайт


text

Модуль ан-го входа 6ES765-7LA13
Dmitriy Seredin; 28.3.00

Как установить DIP переключатели для того чтобы работали 16 каналов?

Re: Модуль ан-го входа 6ES765-7LA13
Дедовец Павел; 4.4.00

Дмитрий!

Вы уверены, что указали номер правильно?
Может это 6ES5 465-7LA13.

Re: Модуль ан-го входа 6ES765-7LA13
з-д Технофлекс; 11.4.00

Re: Модуль ан-го входа 6ES765-7LA13
Дедовец Павел; 12.4.00

Ваш модуль имеет 16 входов напряжение/ ток или 8 входов для Pt 100 или термопар. Поэтому в данном случае важно, что Вы к модулю подключаете.


text

Проблеммы с модулем 6ES165-7LA13
з-д Технофлекс; 11.4.00

Модуль 6ES165-7LA13 имеет 16 каналов, но работают только 8 (стандартные варианты не проходят). Как установить DIP переключатели для того чтобы работали 16 каналов?


text

SIMATIC Memory Card
Туманов Александр, ООО "БАЛТИК"; 6.4.00

Существует ли возможность записать программу

на EEPROM Memory Card через CPU (без программатора,как в SIMATIC S5 CPU 95U)?
Re: SIMATIC Memory Card
Никаноров В. - Сименс, Москва; 7.4.00

Записать программу на FEEPROM Memory Card через CPU можно, но только с помощью программатора.

В некоторых процессорах можно загружать программу с программатора непосредственно во FEEPROM 5V.
Или есть команда в STEP7: Copy RAM to ROM.


text

S5 135U, EPROM в IM 308-3
Дмитрий; 7.4.00

Используется система на базе 135 контроллера с использованием децентрализованной периферией ET100.

Необходимо заменить EPROM IM 308-3UA12, достаточно ли для этого выключить его, или необходимо останавливать ЦПУ, снимать полностью питание. (Отключение ЕТ100,в нашей системе возможно)

Заранее СПАСИБО.


text

FM455S
Pavel Shvetsov ; 4.4.00

Вопрос по модулю FM455S

При использовании модуля FM455S,,был выбран
тип выхода Step Controller without position feedback mode (шаговый контроллер без ОС);
PID алгоритм регулирования.
Звено P и D наблюдались в управляющем воздействии(Manipulated value)
Звено I отсутствовало
Однако, при отключении P и D звеньев, управляющее воздействие было равно 0, тем не менее модуль производил регулирование(при наличии ошибки), т.е. на выход поступали импульсы (Up, Down), и при изменении времени интегрирования (TI) частота выходных импульсов изменялась
Мною был написан имитатор представляющий из себя простой RC фильтр первого порядка, с выхода FM считывались импульсы, и изменяли величину подаваемую на вход FM Actual Value, получился замкнутый контур(с помощью Sim_455). Результат был подтверждающий работу I звена, модуль отслеживал изменение задания и выдавал на вход имитатора воздействия изменяющие входную величину.
Но получить численное значение управляющего воздействия мне не удалось, как это сделать или получить алгоритм работы выходного блока Step Controller?
Если I звена все же нет, и я ошибаюсь, то каким образом можно регулировать соотношение только на PD звеньях?
Если можно,то ответ также E-mail'om

Re: FM455S
Никаноров В. - Сименс, Москва; 5.4.00

См.ссылку

См. http://www.siemens.ru/ad/as/ru/forum/forum.cgi?message=148


text

FM456AB
Седельников Николай; 28.3.00

Нужно из RSView32 по DH+ связаться с S7-300


text

Проблема с Simatic S5 100U CPU102
ОАО "Стройфарфор"; 24.2.00

Предприятие купило конвейрную линию... Соответственно документации на оборудование

нет... Проработав некоторое время вышеописанный контроллер перестал нормально
функционировать... При нормальной комбинации сигналов на входе (проверили) часть
функций перестала работать... Вероятнее всего какой-то сбой в программе... Контроллер
перезапускали, что не дало эффекта...Хотелось бы получить общие рекомендации для
этой ситуации... Где можно взять документацию на контроллер, какое ПО можно
использовать для работы с этим контроллером (дешифрации программы)...
Re: Проблема с Simatic S5 100U CPU102
Никаноров (Сименс - Москва); 24.2.00

1. Что касается документации, то она доступна совершенно бесплатно с сайта Customer Support, см.ссылку.

2. Для работы с контроллером и программой необходим пакет Step5 (и кабель-конвертер RS232\TTY для РС).

3. Сбой в программе крайне маловероятен.
Наиболее часто встречается ситуация, когда версия программы в EPROM и RAM не совпадает. При этом, если батарейка села, а Вы перезапускаете контроллер из EPROM, то получаете описанную Вами ситуацию.
Возможно также, что вышел из строя один из модулей ввода-вывода.
См. http://www4.ad.siemens.de/infocs/livelink.exe?func=cslib.csinfo&startNode=2526&table=ProductNodes&lang=en&nodeID0=2806&aktprim=0&open0=-33-3-&siteid=cs)

Re: Проблема с Simatic S5 100U CPU102
ОАО "Стройфарфор"; 24.2.00

Спасибо за ссылку и консультации... Попробуем разобраться... :)

Re: Проблема с Simatic S5 100U CPU102
Petro; 6.3.00

Ваше сообщение...

Чтобы решить проблему обязательно надо провести диагностику с помощью пакета step 5 или Step 5 for Windows. И обязательно списать программу с контроллера,сохранить на магнитном носителе, перевести в текст и изучать, дорабатывать!!! А то EEPROM сглючит, батарейка сядет и Пи....
P.S. Проходил обучение по программированию на Step5 в нем. фирме HEBEL.
Модуль аналогового входа 6ES765-7LA13
Технофлекс; 27.3.00

Как установить DIP переключатели для того чтобы работали 16 каналов?


text

Нужна Ваша помощь
Игорь Кореневский; 15.3.00

Ко мне попал контроллёр,изготовленный в Финляндии фирмой "Арласон" (Arlacon).Имеется бирка с надписью "Mehatronic model E205 MS 400 Control System".Состоит из БП, 4плат для управления двигателями по 3 координатам (двигатели "Electro-Craft Limited,England, model M540SA).Имеется 2 порта RS-232. На плате процессора стоит м/с HD63B03RP + 4 м/с KM62256BLP-10. На запрос в поисковике попадаю на сайты с финским языком с ссылкой на SIEMENS.Возможно кто-то из Вас имел дело с такой машиной.Хочется попробовать её запустить. Документов нет и программы на вход тоже. Буду рад любой информации.Если звонить по телефону, то в будни после 17.00

Re: нужна помощь по SIWAREX для S5-135U
Андрей Оборин; 24.3.00

Как задать в программе контроллера вес досыпки для модуля дозирования SIWAREX?

Re: Нужна Ваша помощь
Оборин Андрей; 24.3.00

Приношу свои извинения за некорректное размещение запроса.

Re: нужна помощь по SIWAREX для S5-135U
Гуленок Андрей; 24.3.00

Согласно документации.....

Для каждого SIWAREXса способ связи с CPU свой собственный. Обычно все значения ложатся в специальный DB, хотя для старых версий возможен был обмен через DPR.


text

Настройка системы дозирования на S5-135U
Андрей; 24.3.00

Как задать вес досыпки для весового модуля SIWAREX в программе контроллера S5-135U?


text

Документация по Simatic S5-135U
ГРП-Сервис; 27.1.00

Можно ли где-нибудь достать документацию по Simatic S5-135U (с CPU 928B).

Проблема в загрузке программы с ПЗУ
Re: Документация по Simatic S5-135U
Гуленок Андрей; 27.1.00

Её можно заказать на Сименсе. К сожалению в цифровом виде её нет и в бесплатный диск она не входит.

Re: Документация по Simatic S5-135U
Никаноров - Сименс; 1.2.00

Маленькая поправка:

в электронном виде нет документации на русском, ее надо заказывать;
на английском и др.языках документация доступна для свободного скачивания на сайте Customer Support, Германия.
Re: Документация по Simatic S5-135U
Оборин Андрей; 24.3.00

Где можно достать информацию по контроллеру взвешивания SIWAREX для SIMATIC S5-135U?

Код на схеме:7MH3.30501AB

Re: Документация по Simatic S5-135U
Оборин Андрей; 24.3.00

Приношу свои извинения за некорректное размещение сообщения.


text

Процессор CPU414-2 DP
Сергей Максимов ; 23.3.00

Функция Upload в пакете STEP7 v.4.02 не способна опознать процессор CPU414-2 DP(6ES7414-2XG03-0AB0) .В стандартной библиотеке этот процессор также отсутствует.

Что делать?
Re: Процессор CPU414-2 DP
Никаноров В. - Сименс, Москва; 24.3.00

Для работы с процессором 6ES7414-2XG03-0AB0 необходим STEP7 V5.0 service pack 2.

В более старых версиях Step также можно работать с этим модулем, но выбирать из каталога предыдущую версию этого модуля (6ES7414-2XG02).
Сообщение о некорректном заказном номере можно проигнорировать.


text

Соединение PG7XX ---- PG685
ОАО ''Восточный порт'' , Герасимов Иван; 20.3.00

Ваше сообщение..

Господа,
Необходимо перекачать софт с винчестера PG685(PCP/M) на PG7XX. В документации по PG7хх есть только соеденительные кабели. Сообщите пожалуйста с каким програмным обеспечением это возможно.
Re: Соединение PG7XX ---- PG685
Иванов; 20.3.00

Насколько я сейчас помню, для этого достаточно только пакета STEP 5

Re: Соединение PG7XX ---- PG685
Petro; 22.3.00

Ваше сообщение...

Господа какой софт?
Эсли просто файловую систему то програмка FX
вяжется по любому порту и любому интерфейсу.
А если STEP 5 то его надо переставить с помощью ключевой дискеты (TOKEN).


text

pg740
SERGEEV ROMAN; 16.3.00

ПРОШУ ВАС ВЫСЛАТЬ МНЕ ДОКУМЕНТАЦИЮ

НА МАТЕРИНСКУЮ ПЛАТУ SIMATIC PG 740
intelPENTIUM 133Mhz

ЗАРАНИЕ БЛАГОДАРЕН
РОМАН.

Re: pg740
Чистяков Дмитрий "СеверСталь"; 17.3.00

Вся документация на PG7xx находиться по адресу
http://www4.ad.siemens.de/infocs/livelink.exe?func=cslib.csinfo&startNode=2401&table=ProductNodes&lang=en&nodeID0=792341&open0=-1-115-118-&aktprim=0&siteid=cs

Ваш вариант PG740 и PG740P


text

Как проверить MPI адартер TS?
Минкин Алик; 8.3.00

Имеется TS адаптер с портом MPI и портом RS232 (6ES7 972-OCA30-OXA0). На одной стороне S400, на другом конце - модем.

Мне нужно проверить его (адаптер) на неисправность. Как проверить его "на месте"? или какой может быть простейший стенд?

Заранее благодарен.

Алик Минкин
Пивзавод ВЕНА
См. Vena Brewery

Re: Как проверить MPI адартер TS?
Андрей Гуленок; 9.3.00

TS адаптер может работать как обычный РС кабель без всякого модема. Только надо в "Setting PG\PC interfase" выставить его именно как TS адаптер, а для этого надо инсталировать телесервис. Если связь при прямом подключении есть, то адаптер исправен и должен работать и с модемом.

Кроме того, об исправности адаптера можно судить по поведению светодиода "power". В описании на адаптер приведены коды миганий при самодиагностике.
Re: Как проверить MPI адартер TS?
Алик Минкин; 10.3.00

Спасибо. Всё ясно.

А где можно взять телесервис для этих целей?

Алик Минкин

См. Vena Brewery

Re: Как проверить MPI адартер TS?
Гуленок Андрей; 10.3.00

Купить. Поставочный номер 6ES78420CC010YE0. Без этого пакета TS адаптер как бы бесполезен. Звонить он никуда не будет.


text

Как осуществить удалённый доступ к S400?
Минкин Алик; 8.3.00

Как осуществить удалённый доступ к S400 по протоколу MPI? Подразумевается, что расстояние больщое.

Заранее спасибо за подробности.

Алик Минкин
Пивзавод ВЕНА
См. Vena Brewery

Re: Как осуществить удалённый доступ к S400?
Никаноров В. - Сименс, Москва; 9.3.00

Насколько большое расстояние???

Можно применять репитеры для электрической сети, оптические компоненты или связь через TS Adapter/Modem.
Соответственно, получаются разные допустимые расстояния.
Пишите подробнее..
Re: Как осуществить удалённый доступ к S400?
Алик Минкин; 10.3.00

Мой вопрос именно о доступе по модему (последний вариант - TS Adapter/Modem) или сетям TCP/IP.

Под большим рассоянием можно понимать, например, связь из другого города. Вопрос именно об _удалённом_ доступе.

Заранее благодарен.

Алик Минкин
Пивзавод ВЕНА
См. Vena Brewery

Re: Как осуществить удалённый доступ к S400?
Никаноров В. - Сименс, Москва; 10.3.00

Вопрос только в том, что с чем связывать.

Если программатор со STEP7, то через TS адаптер.
WinCC по такой схеме тоже работает (через MPI канал).
Prodave MPI теперь также поддерживает TS адаптер, так что можно писать свои программы для удаленного доступа.
По TCP/IP также можно, так как CP Industrial Ethernet для S7 контроллеров поддерживают TCP/IP протокол.


text

Выбор средств автоматизации
Сергей Алексеев; 9.3.00

Re: Выбор средств автоматизации
Дедовец Павел; 10.3.00

Могу дать пару советов.

Подробности по E-mail
dedovetc@online.ru


text

Требуется помощь
Михаил; 29.2.00

Нужна плата бит-процессора для контроллера S32 - модуль А-6435-А1. Готовы купить данную плату. Если кто-то может помочь в поиске или ремонте данной платы, просьба связаться со мной по e-mail: Ves@aep.mpei.ac.ru

Заранее благодарен всем откликнувшимся. Михаил.


text

Модуль RCM-1P
Александр; 24.2.00

Подскажите, где можно получить описание по

модулю RCM-1P?В электронном каталоге информации
нет.


text

Как выбрать контроллер ???
ПАВЛЯК К.С.; 24.2.00

Подскажите, пожалуйста, мне нужно собрать управляющий контроллер ( до 10 входов, 2- аналоговых, и до 6 выходов на реле). Какой чип выбрать ??? Нужно также, чтобы был эмулятор с ПАСКАЛЯ или хотя-бы БЭЙСИКА. Также желательно наличие конструктора-набора со свободным полем для ДОмакетирования.

С уважением, ПАВЛЯК К.С.
Re: Как выбрать контроллер ???
Дедовец Павел; 24.2.00

Если я Вас правильно понял, Вы самостоятельно хотите создать Промышленный контроллер. Для этих целей обычно используются однокристальные микро-ЭВМ I8259 и подобные, например отечественные аналоги серии К1816...

Но я бы посоветовал использовать готовый контроллер S7-200 с CPU214 (6ES7214-1BC01-0XB0) PS-AC, 14 входов DC, 10 выходных реле, EEPROM 4К. А если Вам нужен компилятор с Паскаля то Вам нужно использовать контроллер S7-300.
Если есть желание использовать стандартный PLC, могу помочь правильно его выбрать. Мой E-mail dedovetc@online.ru

С уважением,
Дедовец Павел

См. http://www.simatic-center.scn.ru


text

s5-100u продам
Papik; 24.2.00

продам контроллер Simatic s5-100u cpu100

2_а модуля входных и 1 выходной (цыфр)
с блоком питания (срочно )


text

SFC20 - BLKMOV
vzozulja; 7.2.00

И как эту гадость заставить работать?

Она определенно не хочет вызываться ни из SCL, ни из STL.
Re: SFC20 - BLKMOV
shurik; 7.2.00

Да нууууу

А ну-ка посмотри как у добрых людей сделано (например в библиотечных блоках PCS7)
Re: SFC20 - BLKMOV
Чистяков Дмитрий "СеверСталь"; 9.2.00

Не взываются - это как?

Не вводится в программе - красне символы?
Или, при запуске программы CPU вываливается в STOP?
Если последнее, то прежде всего посмотри, имеется ли SFC20 в CPU. Это делается крайне просто, делаешь очистку памяти в контроллере и подключаешься в S7 менеджере в режиме on-line. И получишь список стандартных SFC и SFB зашитых в твой CPU.

Re: SFC20 - BLKMOV
vzozulja; 12.2.00

Именно не вводится. Точнее, но хотят нормально задаваться адреса SRC_BLK, DST_BLK. Вплоть до того, что примеры из online-help не катят. А SFC20 в CPU есть всегда - на то и SFC.

Re: SFC20 - BLKMOV - shuriku
vzozulja; 12.2.00

Точнее, например #. См.также мой второй ответ, да и сам бы попробовал. Для сверки - STEP7 v5+SP2.

Re: SFC20 - BLKMOV - shuriku
shurik; 12.2.00

Прежде чем писать само сабой сам проверил - все очень хорошо вставляется - если конечно ты берешь SFC20 из раздела Standart Function (или что-то в этом роде),а не BUILT-IN function

(позжее уточню названия разделов библиотек)

Re: SFC20 - BLKMOV
Чистяков Дмитрий "СеверСталь"; 14.2.00

Ну во первых, далеко не в каждом CPU есть все SFC.

CPU с одним наименованием, но разными заказными номерами имеют различный набор системных блоков "зашитых" в ПЗУ CPU.

Так, например, наиболее часто встречается отсутствие блоков SFC17,18,19. Эти блоки генерируют сообщения для системы визуализации. И используются таким пакетом, как PDiag.
Так имеется три варианта CPU 413-2DP
6ES7413-2XG00-0AB0 CPU 413-2 DP, 72 kB, 0.2 ms/kAW
6ES7413-2XG01-0AB0 CPU 413-2 DP, 72 kB, 0.2 ms/kAW
6ES7413-2XG02-0AB0 CPU 413-2 DP, 72 kB, 0.2 ms/kAW
Казалось бы все одинаковые, ан нет.
Более подробно смотри -
http://www.siemens.ru/ad/as/ru/forum/sw/forum.cgi?message=33

Теперь, что касается ввода параметров блока.
Всё вводится без проблем, включая пример из справки.
Возможно у Вас стоит режим ввода в стиле Germany
меню OPTION --> CUSTOMIZE --> Language.
Или просто допускаются очепятки при вводе данных.

Если необходимо, то напишите мне по почте и вышлю маленький примерчик с данным блоком.
Re: SFC20 - BLKMOV - shuriku
vzozulja; 15.2.00

Вставляться то вставляется, но параметры не задаются.

Например, передать 40 байт, начиная с DB40.DBX44.0, в область MW20...
Re: SFC20 - BLKMOV
Чистяков Дмитрий "СеверСталь"; 16.2.00

Пример применения SFC20.

Пример1.
Переносит все данные из DB40 до окончания DB40, начиная с 40-вого байта в область MW20.
SRCBLK - DB40.DBB40
DSTBLK - MW20
RET_VAL - MW200

Пример2.
Переносит 10 байт из DB40, начиная с 40-вого байта в область MW20.
SRCBLK - P#DB40.DBX 40.0 BYTE 10
DSTBLK - MW20
RET_VAL - MW200

Re: SFC20 - BLKMOV - shuriku
vzozulja; 17.2.00

Вопрос оказался пустым. В тот вечер то ли я был сильно пьян, то ли STEP7...

Re: SFC20 - BLKMOV - shuriku
shurik; 18.2.00

Братан - да ты наш человек - заходи как нить на огонек...


text

Связь SIMATIC S5 150U с PC
Герасимов Иван; 26.1.00

Господа,

Необходима информация, какой процессор связи необходимо установить в персональный компьютер для соединение программируемого контроллера SIMATIC S5-150U по протоколу AS511 c компьютером(РС)WinCC станцией или ProTool.

Заранее благодарен за ответ.
Re: Связь SIMATIC S5 150U с PC
vzozulja; 26.1.00

На 150У 2-интерфейса 1 стандарный TTY (PG) и один свободный (зависит от интерф.модуля)- RS232, TTY, 422|485.

С WinCC станцией достаточно, например COM-порт (RS232) и преобразователь PG|PC либо вариант с интерфейсным модулем 232 в PLC. Что удобнее, зависит от кол-ва контроллеров 150U, подключаемых к PC (в принципе, учитывая разнообразие CP как для PLC, так и для PC возможен чуть ли не любой вариант связи).
Для связи с панелью тоже, но возможен вариант и TTY и RS232 и 485.

У меня сейчас такой проект в ходу, так что готов к переписке e-mail.


text

Диагностика модуля SM 331 8AI
Штепа С.А.; 25.1.00

Как можно анализировать диагностическое сообщение модуля SM 331 (обрыв провода, синфазная ошибка...)? Описание OB 82, имеющееся у меня, не включает описание обработки такой ситуации.

Re: Диагностика модуля SM 331 8AI
Никаноров (Сименс - Москва); 26.1.00

ПОсмотрите здесь

См. http://www4.ad.siemens.de/infocs/livelink.exe?func=cslib.csinfo&startNode=2526&table=ProductNodes&lang=en&nodeID0=684058&open0=-19-&aktprim=0&siteid=cs


text

16 модулей CP441-2(RS-232C) на одном CPU?
Виталий Диденко; 24.1.00

Возможно ли подключить к одному CPU S7-400 (Если ДА, то к какому?) 16 коммуникационных модулей CP441-2(RS-232C) для организации концентратора на 32 линии RS-232C? С концентратора данные будут подаваться на WinCC по MPI или PROFIBUS.

Re: 16 модулей CP441-2(RS-232C) на одном CPU?
Иванов Павел (Сименс-Москва); 25.1.00

Соединения с 32 участниками точка к точке можно реализовать, если использовать CPU416 и выше.


text

обработка данных аналоговых модулей
шурик; 19.1.00

Какие существуют стандартные библиотеки для обработки аналоговых данных контроллером S7-300(например от модулей расположенных в ET200М),кроме самарской библиотеки SCSIGN

Re: обработка данных аналоговых модулей
Alex; 21.1.00

Для обработки и масштабирования аналоговых значений можно применить блок FC105 (SCALE) из стандартной библиотеки STEP 7 TI-S7 Converting Blocks.

Re: обработка данных аналоговых модулей
Никаноров - Сименс; 21.1.00

Специальной библиотеки для обработки аналоговых данных нет.

Можно использовать библиотеку Modular PID Control, которая содержит большой набор блоков для обработки аналогового канала.


text

Математические функции в S5
Шишков Сергей; 19.1.00

Какие есть программы, вычисляющие мат. функции (например тригонометрические), для CPU948 S5-155U

Re: Математические функции в S5
Никаноров - Сименс; 19.1.00

Существует библиотека "Математические функции" для S5-135\155U.

Она содержит функциональные блоки для вычисления тригонометрических функций, логарифмов, экспонент и т.п.
Заказной номер: 6ES5 848-7MT01


text

Связь S7-300 с РС
Андрей; 19.1.00

Где можно найти пример организации связи между контроллером S7-300 (CPU315-2 DP)(СР343-5) и РС (СР5412(А2)) по FMS протоколу.

Re: Связь S7-300 с РС
Никаноров (Сименс - Москва); 19.1.00

Например, по приведенной ссылке.

Entry ID 04/27/1999 765171

См. http://www4.ad.siemens.de/infocs/livelink.exe?func=cslib.csinfo&startNode=2526&table=ProductNodes&lang=en&nodeID0=723492&nodeID1=h0001&nodeID2=h0001&open0=-140-160-&aktprim=0&siteid=cs.


text

Документация на русском.
Андрей Дяченко; 27.12.01

Расскажите ,пожалуста,соществует ли таковая и как ее заполучить.

Re: Документация на русском.
Чистяков Дмитрий ОАО "СеверСталь"; 27.12.01

Смотря на что требуется документация.

А для подробностей обратитесь вот сюда
http://www.aud.ru/as/support/doc.shtml


text

everything@secure.f2g.net
John Extensi0n; 11.12.01

Можно ли достать описание на Step5 в Инете? (На Русском языке)

См. :: John Extensi0n Secure Site ::

Re: everything@secure.f2g.net
Никаноров, Сименс; 27.12.01

Смотрите раздел "Продукты" на этом сайте.


text

Необходимо описание протокола AS511!!!
Сергей; 7.12.01

Необходимо описание протокола AS511!!!

СПАСИБО!!!
Re: Необходимо описание протокола AS511!!!
Чистяков Дмитрий ОАО "СеверСталь"; 10.12.01

Взгляните чуть ниже на этой странице

http://195.146.64.23/ad/as/ru/forum/s5/forum.cgi?message=133


text

Продаю Б.У. модули и тд. и тп. - дешево -!
Olkomovsky; 6.12.01

Предлогаю всевозможные Б.У. модули и контроллеры - S5-

по очень низким ценам ( тут один товарищ на форуме я смотрю интересуеся )
так вот вам пожалуйста ПРЕДРОЖДЕСТВЕНСКИЕ СКИДКИ
ТОЛЬКО ЗА НАЛИЧКУ И ТОЛЬКО В С-Петербурге.
запрос отсылайте на i-mail
в запросе указывайте количество

кат. номера
6ES5308-3UC11 + ЕВРО ПЕРЕХОДНИК 6ES5491-0LB11 + FLASH CARD 256kb/16bit 6ES5374-1FH21 400$
6ES5306-7LA11 90$
6ES5420-7LA11 100$
6ES5430-7LA11 100$
6ES5470-7LC12 150$
6ES5441-8MA11 70$
6ES5421-8MA12 70$
6ES5100-8MA01 300$
6EW1380-1AB 90$
6ES5470-8MB11 90$
6ES5700-8MA11 90$
6ES5422-8MA11 90$
6ES5928-3UA12 + МОДУЛЬ RAM 64kb 6ES5377-0AA32 500$
6ES5524-3UA13 + МОДУЛЬ EPROM 32kb 6ES5373-0AA41 300$
6ES5530-3LA12 + МОДУЛЬ RAM 6ES5375-0LD11 300$
6ES5420-4UA12 50$
6ES5301-3AB13 70$
6ES5324-3UA11 150$
6ES5512-5BC12 150$
6ES5465-3AA13 150$
6ES5445-3AA12 90$
6ES5308-3UA12 + МОДУЛЬ EPROM 16kb 6ES5376-0AA11 200$
6ES5420-3BA11 70$
6ES5310-3HB11 100$
6ES5304-3UA11 100$
6ES5512-5BC21 100$
6ES5340-3KB31 150$


text

срочно куплю модули от 150
Papik; 28.11.01

Срочно куплю модули от 150 контроллера

только за наличку и только в Питере
потому как ехать куда либо нехочу.
Естественно по разумной цене
предложения о продаже за немеренное количество
ЕВРО или подобной несуразицы даже рассматривать
не буду , потому что такого (г...) как подобные
платы можно найти на любой помойке какого небуть
обонкротившегося завода
если интересно то вот каталожные номера:
6ES5255-3AA11
6ES5315-3LB11
6ES5924-3SA12
6ES5926-3SA12
Re: срочно куплю модули от 150
Verner von Siemens; 28.11.01

ПРодам честно, по прайслисту.

Re: срочно куплю модули от 150
Papik; 30.11.01

а сколько денег то по прайс листу ??

Хе-хе!
Любитель Симатика; 30.11.01

Хе-хе! Именно такую кучу в Евро и будет стоить, если по Прайсу.

Похоже Verner von Siemens действительно von (от) SIEMENS!
Но этого г... можно не найти на помойке! Хотя ....ВПЕРЕД ...если одежки не жалко!
Re: Хе-хе!
Papik; 30.11.01

вот спасибо утешил

ну и ладно
пойду робу напялю

ps / ну не верю я что нет не у кого
такого добра точнее (дерьма)прошу прощения.
ведь воляется где нибуть под столом
просто заглянуть лень
Re: Хе-хе!
Чистяков Дмитрий ОАО "СеверСталь"; 6.12.01

У кого и есть так не продадут. И я бы не продал.

Контроллер снят с производства и разбазаривать ЗИП нормальный хозяин не будет.
А раз снято с производства, то модули будут эксклизивный вариант и стоить будут немеряно


text

как для операции SEG перейти на следующий разряд индикатора ?
Сергей; 6.12.01

Подскажите пожалуйста неопытному:

Как в Step7-MicroWin 32 для операции образование битовой комбинации для семисегментного индикатора для входящего аналогового сигнала на CPU 212-214 получить переход на следующий разряд индикатора? (для тех же выходов)

D I0.1
MOVB 16#21, VB48
SEG VB48, QB0
????


text

Схема преобразователя RS232/MPI
Спол Ате; 4.12.01

Имеет кто-нибудь схема преобразователя RS232/MPI?

(печатный монтаж и компоненты)
Спосибо...
Re: Схема преобразователя RS232/MPI
Чистяков Дмитрий ОАО "СеверСталь"; 5.12.01

Такой схемы нет, но Siemens производит специальный адаптер:

6ES7972-0CA23-0AX0
SIMATIC S7, PC ADAPTER V5.1 ZUM ANSCHLUSS AN S7-300/-400 C7, M7; ZUR UMSETZUNG RS232 AUF RS485; OHNE RS232-KABEL

Но следует помнить, что этот адаптер не просто конвертирует один электрический сигнал в другой. Адаптер имеет специализированную БИС, которая выступает станцией MPI, которая управляется по RS-232.
Т.е. эта БИС берёт на себя все функции по поддержке протоколов MPI.


text

EPROM
Nick; 4.12.01

Нужен субмодуль памяти 6ES5-375-0LA61 64kB


text

Предлагаю б/у S5-110S, модули для S5-115U
Игорь; 30.11.01

Имеются для продажи или обмена блоки от S5-110S,

S5-110A
(БП,ЦПУ,входные выходные блоки, корзина),блоки выходов для 115U (на 110 вольт).
Продадим или обменяем на блоки для S7.

Re: Предлагаю б/у S5-110S, модули для S5-115U
Viktor; 2.12.01

Прошу Ваши цены на 110 на мой e-mail .Виктор.


text

Особенности программного PID-регулятора на S7-300
Оганесян Юрий; 20.7.01

У нас возник вопрос при работе с блоком программного PID-регулирования S7-300 SFB41 (“CONT_C”). Используется PI - регулятор

Наблюдается следующая картина:
Если при включении регулятора пропорциональная составляющая составляет более 100%, то интегральная составляющая «ЗАМОРАЖИВАЕТСЯ» и НЕ ВОЗРАСТАЕТ. Точнее ее возрастание происходит только тогда, когда пропорциональная составляющая становится меньше 100% (т.е. происходит приближение реальной температуры к заданной). И как бы «позволяет» расти интегральной составляющей.
Мы не можем понять, является ли описанный эффект недокументированной особенностью Siemens’овского регулятора “CONT_C” или дело в чем-то другом.
В классическую теорию PID-регулирования описанный эффект вроде как не укладывается: пропорциональная и интегральная составляющие являются независимыми и несмотря на то, что воздействие больше чем 100% процентов выдать все равно невозможно, интегральная составляющая должна все равно плавно увеличиваться «на будущее».

Re: Особенности программного PID-регулятора на S7-300
Никаноров, Сименс; 20.7.01

Описанная Вами ситуация является совершенно нормальной.

Интегральная составляющая входит в насыщение и не возрастает, чтобы избежать излишнего перерегулирования.
Такая особенность характерна для всех регуляторов ф.Сименс. В более мощных пакетах регулирования - Standart PID Control и Modular PID Control, ограничение интегральной составляющей, насколько я помню, можно отключить.

PID Control
Владимир Изюмский; 30.11.01

Подскажите где взять пакеты

Standart PID Control и Modular PID Control.
Сколько это будет стоить и есть ли демо-версии.


text

Вопрос
Савин А.В.; 17.1.01

Сколько стоит датчик

SimoDrive sensor
6FX2001-4B500

Re: Вопрос
Воронин А.Ю. (SIEMENS A&D MC Москва); 17.1.01

По вопросам цен Вам необходимо обратиться к менеджерам отдела A&D MC (если данный датчик покупается для станка или производящего оборудования) по тел. 737-24-75 или к менеджерам отдела A&D PS (если это другое оборудование) по тел. 737-24-19

Re: Вопрос
Недай Игоря; 23.11.01

Где можно посмотреть прайс-лист промышленных контролеров SIMATIC фирмы SIEMENS?


text

Ошибка квитирования
Францев Д.Н.; 22.11.01

Вышел из строя Step5 u-135. Во время работы программы периодически возникает ошибка квитирования QVZ. Была предпринята попытка установить причину. Были запрограммированы блоки OB23 и OB24 на останов контроллера. Анализ стека после останова показал, что причиной является комманда SEF 30. Вопрос. Причем здесь комманда SEF, которая согласно описанию выставляет некий симафор, тогда как в диагностичеком сообщении на QVZ стоит: "Ошибка квитирования ввода/вывода при обращении к байту 60"?

См. http://www.ezan.ac.ru

Re: Ошибка квитирования
Никаноров, Сименс; 22.11.01

Скорее всего, у Вас проблема с модулем ввода-вывода по адресу 60. Либо модуль неисправен, либо неплотно установлен в разъем и т.п.

Что касается стека прерываний, то в некоторых случаях он указывает на команду, которая стоит после (или до) команды, вызвавшей ошибку. Посмотрите инструкции в районе вызова команды SEF.

Re: Ошибка квитирования
Францев Д.Н.; 22.11.01

Поначалу мы тоже так решили. Произвели замену платы ввода/вывода, переставили её в другой разъём корзины, сменили интерфейсную плату - эффект тотже. Самое главное, если "забить" комманду SEF коммандой NOP, то ошибки квитирования не возникает.


text

Simatic S7-200 +OP7 связь с удалённым компьютером
Кулагин Павел ; 14.11.01

Есть несколько станков, для упрвавления каждым используется Simatic S7-216 на один порт подключена OP7 на другой - регуляторы напряжения с управлением через RS485 300baud с собственным протоколом обмена.

Подскажите как проще подключить удаленный компьютер для сбора информации от
каждого из станков.

Re: Simatic S7-200 +OP7 связь с удалённым компьютером
Михаил Скотников; 16.11.01

Первый вариант наиболее очевидный, но и наиболее дорогостоящий:

Если есть свободное место на рейке к каждому S-200 подключить модуль Profibus DP Slave СP 242-8.
В компьютер вставить сетевой адаптер Profibus. Купить, или написать самим необходимое программное обеспечение.
Примерная стоимость на три станка:
215x3+675+337=1657 Euro на границе Германии. В общую стоимость необходимо включить какую-либо программу для сбора данных.

Второй вариант основан на использовании одного порта для связи с двумя абонентами.(регулятор и ли компьютер)Вариантов дальнейшего построения существует несколько.

Re: Simatic S7-200 +OP7 связь с удалённым компьютером
Юрий Оганесян; 16.11.01

А у чем проблема?

Ежли есть деньги, то на фирменном оборудовании: карта связи (напр. СР5611) и ПО ( напр. ProTool/Pro) строится классическая промышленная сеть. При этом используется именно тот порт, где стоит ОР7 и получается такая довольнго симпатичная сеточка из 1 компутера, 4 ПЛС и 4 ОР7

Re: Simatic S7-200 +OP7 связь с удалённым компьютером
Юрий Оганесян; 16.11.01

А у чем проблема?

Ежли есть деньги, то на фирменном оборудовании: карта связи (напр. СР5611) и ПО ( напр. ProTool/Pro) строится классическая промышленная сеть. При этом используется именно тот порт, где стоит ОР7 и получается такая довольнго симпатичная сеточка из 1 компутера, 4 ПЛС и 4 ОР7

Re: Simatic S7-200 +OP7 связь с удалённым компьютером
Кулагин Павел; 19.11.01

Проблема в том что OP7 не поддерживает мультимастерную сеть (по тем данным которые удалось найти) если есть другие возможности можно более подробно, пожалуйста.


text

Загружаемый драйвер для СР525-2
Павел; 6.11.01

Господа!!! Пожалуйста отзовитесь счастливые обладатели загружаемого драйвера для СР525-2 (6ES5 897-1AB11). Он как я понял необходим для организации канала связи между СР525-2 и СР521. Помогите советом как организовать связь между СР525-2 и СР521.

Заранее благодарен,
Павел

Re: Загружаемый драйвер для СР525-2
Павел; 16.11.01

Вопрос снимается. Все уже сделали.


text

6ES7 331-7FSF00-0AB0 и Pt100 по трехпроводной линии
Куракин Александр Николаевич <rz6hpt@rbcmail.ru>; 15.11.01

Добрый день /утро, вечер/.

Simatic S7-300, модуль AI8xTC/4xRTD,Ex 6ES7 331-7FSF00-0AB0. Подключил к данному модулю Pt100 по трехпроводной линии, соответствующую перемычку установил. В писании писано, что можно, но увеличится погрешность (вопрос - на сколько). При поверке выяснилось следующее:
- если Pt100 находится в непосредстренной близости от модуля, сходимость результата 100%.
- если подключаю реальный Pt100, установленный на об"екте (удаление nx100 м, соответственно увеличивается сопротивление линии до 2-3 Ом), то получаю результат с погрешностью на величину сопротивления одной линии. Результат складывается из сопротивления Pt100 плюс сопротивление одной линии. Как с этим бороться? Может ли данный модуль "правильно" работать с Pt100, подключенным по трехпроводной схеме? Если кто решал такую проблему, прошу поделиться. Заранее благодарен.

Re: 6ES7 331-7FSF00-0AB0 и Pt100 по трехпроводной линии
Юрий Оганесян; 16.11.01

Если добавочное сопротивление постоянно, то может ввести программную коррекцию?


text

40-контактный SM331 + пассивный датчик
Андрей Петров СЦА; 12.11.01

Как запитывается пассивный датчик, например Sitrans TK, в токовой петле с модулем SM331 ...7NF(40-контактный).

Последовательное включение в цепь 24Вольт - го источника питания позволит ли решить данную проблему?

Re: 40-контактный SM331 + пассивный датчик
Юрий Оганесян; 16.11.01

Угу.. Для ентого модуля именно так и придется, а вот ежели был бы специально обученный модуль такой как ..7KF02.., то можно было бы серьезно сэкономить на блоках питания


text

Куплю CP525
Ovel; 17.9.01

Здравствуйте!

Куплю недорого СОМ процессор СР525.
Откликнитесь, у кого есть 6ES5 525-3UA21.
Заранее благодарю.

Re: Куплю CP525
ipsp; 11.11.01

Можно поискать. Вам только сами модули нужны или

требуется все "под ключ"?


text

Интересуют БУ модули серий 100 или 115
Dmitry; 8.10.01

Интересуют БУ-шные модули CPU серий 100 или 115, а также блоки входов/выходов к ним.

Re: Интересуют БУ модули серий 100 или 115
Ilshat; 3.11.01

Имеется блок Simatic S5 6ES5 485-8MA13.

Если кому нужна позвоните или мылом.
107-67-03. Ильшат.
Re: Интересуют БУ модули серий 100 или 115
ipsp; 11.11.01

С какими суммами Вы готовы расстаться, скажем за

S5-100U, S5-115 (CPU944), Есть и другие модули.


text

cp441-2
Alex_SeverStal; 9.11.01

Не получается работа в режиме full-дуплекс связи для CP441-2 ( пробуем на связке IF1 с IF2). Видимо ошибка в параметризации SFB12, SFB13.

Может кто - то сталкивался с такой проблемой ?


text

EM277
Сергей; 8.11.01

Пытался составить DP сеть из CP5613 и 2 модулей EM277. Ранее мне сообщили что нужен для этого COM Profibus. Слил GSD файл под EM 277. Ни в одном описании не нашел как это безобразие соединить. Может подскажите где посмотреть?

Re: EM277
Чистяков Дмитрий ОАО "СеверСталь"; 9.11.01

Найти папку со всеми GSD файлами и переписать туда файл для EM277. Вот и всё

Re: EM277
Сергей; 9.11.01

Я конечно ламер, но не настолько же :) Это я давно сделал. Возникает ошибка при создании ldb файла.


text

Конфигурирование и настройка PID регулятора в S5-135
Николай Терещенко; 9.11.01

Подскажите, пожалуйста, как и чем делается настройка или пошлите куда-нибудь если вопрос не по теме или с бородой(FB176 SIMATIC S5-135 CPU 928B)


text

конфигурирование ПЛК
Сарычев Л.; 8.11.01

Работаю в STEP7 V5.1 + Service Pack 1, Revision Level K5.1.1.0

Выполняю UpLoad HW-конфигурации PLC в проект.

Пытаюсь задать заказные номера для модулей прочитанной HW-конфигурации на основе списка появляющегося в окне Specify Module. Это удается сделать для всех сигнальных модулей, кроме DO8*REL AC230V (заказной номер 6ES7 322-1HF80-0AA0), поскольку спецификация этого модуля отсутствует в списке упомянутого окна Specify Module.

Почему его нет в списке и что делать????

Re: конфигурирование ПЛК
Чистяков Дмитрий ОАО "СеверСталь"; 9.11.01

ВОт здесь лежит решение Вашей проблемы

http://www4.ad.siemens.de/news/cs/en/1415670


text

LOGO! -> RS232 -> PC - возможно такое?
Дмитрий; 8.11.01

... подбираем оборудование для системы автоматической заправки тепловозов.

Re: LOGO! -> RS232 -> PC - возможно такое?
Худяков А.Н.; 8.11.01

Для LOGO! есть специальный кабель-переходник LOGO!-PC который коннектится к COM порту (9 пин) и программирование происходит с помощью пакета LogoSoft.

Кабель - 6ED1 057-1AA00-0BA0
Софт - 6ED1 058-0BA00-0YC1 (или более поздняя версия).
Можно запрограммировать модуль, считать из него программу, эмулировать работу на ПК. Очень удобная и простая программа.
Нельзя только управлять LOGO! c PC (как у S7-200). более подробно можно поговорить по телефону (8462) 41-99-11


text

Программатор для EPROM
Viktor; 2.11.01

Куплю программатор для PC на параллельный порт.


text

Настройка PID регулятора
Николай Терещенко; 31.10.01

Что нужно для Step5 для сабжа построенного на базе FB176 и множества других FB которые не открываотся на PG?

Слышал о COM REG. Годится ли он в этом случае?
Благодарен за любую информацию на эту тему.
PS: SIMATIC S5-135
CPU 928B


text

s5-100 cpu100 связь с op15
Ушаков Андрей; 31.10.01

Помогите решить проблему связи s5-100 cpu100 с op15. Я имею в виду стандартный программный блок FB51. Если у кого-то есть программа *.s5d с этим блоком вышлите на ush_akov@mail.ru. Заранее благодарен.


text

контроллеры серии SIMATIC S5
Гладышев В.; 25.10.01

ИЩУ 8Т31N ДЛЯ S5-110S.Торг!


text

Подключение PG270P через MPI к S7-200
Чистилин Андрей; 17.10.01

Возможно ли подключить программатор SIEMENS PG720P к CPU216 через MPI порт программатора и какие установки PG/PC интерфейса должны быть установлены в Windous и STEP7-Micro/WIN V2.1?

Re: Подключение PG270P через MPI к S7-200
Чистилин Андрей; 22.10.01

Отвечаю сам себе. Да можно, просто надо читать внимательно документацию. В нашем программаторе установлена карта MPI-ISA on board, которая такую связь предусматривает через МPI-кабель с портом 0 CPU 216. В STEP7-Micro/WIN 32 V2.1 заходите в меню Setup/Communications и щелкаете кнопочку [PG/PC_Interface], выбираете из списка "MPI-ISA on board(PPI)", щелкаете на кнопку [Properties] и ставите следующие установки:

Address 2,
time out 1s,
transmitions rate 9.6,
highest node address 31.
Именно так уменя получилось связаться. В моем случае к CPU подключена еще операторская панель, навеное поэтому адрес равен 2, так как, по моему CPU в такой сети выступает как подчиненный, и адрес 1 будет у операторской панели.
Вот такие вот дилетантские выкладки.


text

Нужна помощь по S5-135 928B CPU
Svetlana; 17.10.01

При попытке очистить все блоки в CPU выдает сообщение,что часть выделенных блоков недоступна.

При этом контроллер переходит в режим Offline.
Кто сталкивался с подобной проблемой?

Re: Нужна помощь по S5-135 928B CPU
Никаноров, Сименс; 19.10.01

Возможно, на эти блоки установлена защита от изменений.

Re: Нужна помощь по S5-135 928B CPU
Svetlana; 19.10.01

Нет, раньше (месяца 2 назад) это все получалось.

Может ли что-либо произойти с RAM?
У нас стоит
RAM 6ES5377 -0AA32 64 kB
KM622256 BLP-10 74НС365D
Пожалуйста, скажите, где их можно достать, или чем можно заменить?


text

Распайка соединительного кабеля PC-MPIconv
Максим Елхов; 15.10.01

Кто-нибудь может кинуть распайку соединительного кабеля между портом RS232 и MPI конвертером?

Re: Распайка соединительного кабеля PC-MPIconv
Чистяков Дмитрий ОАО "СеверСталь"; 15.10.01

Обычный нуль-модемный кабель.

Это либо перкрещёные сигналы CTS-RTS, либо они должны быть просто закорочены на обеих сторонах
Re: Распайка соединительного кабеля PC-MPIconv
Юрий Оганесян; 17.10.01

Не уловил..

Если речь идет о конверторе RS232-MPI , то никакого дополнительного кабеля не надо. Если о каком-то другом конверторе , то какой у этого кабеля второй интерфейс?


text

S7-200
Сухоручкин Сергей; 16.10.01

Имееется контроллер S7-200, и криво написанная программа. Необходимо реализовать задержку выключения, в имеющейся документации ничего не нашёл. Существует ли такой таймер, а если нет то как это выглядит в AWL.

Заранее благодарен за любую информацию.
Re: S7-200
Andrej Gulenok; 16.10.01

LD E0.0

TOF T33,3

Системное руководство. Стр 9-22
Re: S7-200
Сухоручкин Сергей ; 17.10.01

Спасибо за ответ!

Просто когда я спрашивал по телефону (отвечал кто то другой), мне ответили, что такого таймера не существует, и требуется решать это програмно на остове таймера TON.


text

PG740
Autogubitel; 15.10.01

Кому-нибудь нужен программатор , а то у меня без дела стоит почти год :0(

P133/128Mb/40Gb/CD-ROM/1Mb Video/ну и т.д.
PS:Естественно не бесплатно :)


text

проблемы с AS511 при большом кол-ве СОМпортов
Сергей; 12.10.01

Здравствуйте.

Скажите пожалуйста, есть ли возможность соединения контроллера SIMATIS S5 с WinCC через драйвер AS511 (Win98/NT4.0) при следующих условиях:
1. В ПК есть 1 стандартный (физический) СОМ -порт. - СОМ1
2. С помощью мультипортовой карты МОХА (ISA/PCI) кол-во СОМ-портов было увеличено максимум до 9 (1 стандартный+8 добавленных).
3. Каждый добавленный СОМ-порт имеет свою область ввода-вывода, но все они имеют одно прерывание, равное номеру прерывания карты МОХА в Windows.
4. Неизвестно мне, возможно ли при помощи AS511-Admin настроиться на эти СОМ-порты, используя СОМх. Попытки сделать это привели к аппаратным конфликтам по прерываниям и областям ввода/вывода.
5. В AS511-Admin НЕ ПОЯВИЛИСЬ добавленные СОМ-порты (присутствовал СОМ1 и СОМх), хотя в программах STEP7/STEP7MicroWin и WinCC (другие драйвера), а также в среде Windows. Возможность связи через добавленные порты была успешно проверена при связи с S7-200,300.
6. ЧТО ДАСТ ИСПОЛЬЗОВАНИЕ ДРАЙВЕРА WSENDCOM.DLL ПРИ УСЛОВИИ ЕГО ПРИОБРЕТЕНИЯ?

Заранее благодарен.


text

Подключение S5-150 к PC через COM525
Александр Гофман; 10.10.01

Не могу найти функциональные блоки для организации связи PLC S5-150 через COM525 (FB180-181). Может помочь любая информация, заранее благодарен.

См. http://www.agofman@mail.ru


text

SIMATIC S5 - 150 Function blocks for CP525
Александр Гофман; 8.8.01

Не могу найти функциональные блоки для организации связи PLC S5-150 через COM525 (FB180-181). Может помочь любая информация, заранее благодарен.

Re: SIMATIC S5 - 150 Function blocks for CP525
Baby; 13.9.01

Привет,Александр!

Это случайно не эти блоки
FB 180 S5>PCIM
FB 181 PCIM<>S5
Не уверен, что они подойдут,
но если надо могу помочь.

Re: SIMATIC S5 - 150 Function blocks for CP525
Леонид Окунь,Сашин друг и коллега; 9.10.01

Уважаемый Baby ! Пожалуйста, сбрось FB180 и FB181

на адрес cetl@yandex.ru и на leonid_okun@mail.ru.
Благодарю . Леонид.


text

Simatic S5 Step 5/St ver.7.13 центр.модуль 6ES5 944-7UB21
Самойлин Виктор; 12.9.01

Ваше сообщение...Какой программатор подойдет для этой системы.Интересует прайс-лист и ссылки где посмотреть возможности.

Re: Simatic S5 Step 5/St ver.7.13 центр.модуль 6ES5 944-7UB21
Самойлина; 5.10.01

Ваше сообщение...Прошу сообщить параметры PG-720?,где его можно приобрести и за сколько, где взять документацию по Step 5/St.


text

LOGO! Contact
НТМК, ЛСПУ; 28.9.01

1. Возможно ли использовать контактор LOGO!Contact для коммутации цепи постоянного тока. Имеет ли значение полярность подключения коммутируемой линии.

2. Серию устройств LOGO!230... как запитывать: 230 VAC, или можно 230 VDC ?

Re: LOGO! Contact
Andrej Gulenok; 2.10.01

1 Это обычное реле. Оно может коммутировать что угодно. Но! Параметры нормированы только для переменного тока.

2 Только переменным током. Этио связано с особенностями устройства её блока питания.
Re: LOGO! Contact
НТМК, ЛСПУ; 3.10.01

Спасибо за справку.

Однако в спецификации на устройство LOGO!230RC (6ED1052-1FB00-0BA3), например, указано напряжение питания AC/DC 230V. Если это касается только устройств LOGO!230 (...OAB3), тогда хотелось бы узнать, возможно ли на цифровые входы LOGO подавать 230 VDC в качестве цифрового сигнала ?

Re: LOGO! Contact
Andrej Gulenok; 4.10.01

Написано что можно АС. Про постоянный ток ничего не сказано. Хотя питать можно. Получим новое LOGO проверю.

Re: LOGO! Contact
НТМК, ЛСПУ; 5.10.01

Информацию о модельном ряде LOGO (...0BA3)я получил с www..ad.siemens.de/logo/html_76/new_products.htm

И еще вопрос. Возможно ли питать LOGO!Contact 230V постоянным током 230V DC ?


text

Необходимо расширить S5-95U
Белобаева Александра; 10.9.01

Нам необходимо подключить от 4 до 8 аналоговых выходов. Подскажите, пож-а какой интерфейсный модуль нам выбрать, и самое главное, где его купить? В чем принципиальное отличие м/у

6ES5 316-8МА12 и 6ES5 316-8МА12?

Спасибо
Санкт-Петербург
Александр
Re: Необходимо расширить S5-95U
Андрей Гуленок; 4.10.01

А зачем вам интерфейсный модуль? 95-ый прекрасно расширяется шинными модулями и блоками ввода-вывода от 100-го контроллера.

а разници между 6ES5 316-8МА12 и 6ES5 316-8МА12 я не вижу.


text

S7_400
Aleks ; 27.9.01

Можно ли связать Simbol Name из таблицы символов

с FB создаваемой на SCL ?

Re: S7_400
Aleks; 28.9.01

Уже разобрался - все связывается.


text

Ищу схемы блоков ввода вывода дискретных сигналов Simatic5 для ознакомительных целей
Alexandr Kulikov; 5.8.01

Ищу схемы блоков ввода вывода дискретных сигналов Simatic5 для ознакомительных целей.

С уважением,
Alexandr

Re: Ищу схемы блоков ввода вывода дискретных сигналов Simatic5 для ознакомительных целей
Чистяков Дмитрий ОАО "СеверСталь"; 8.8.01

Для ознакомление может достаточно тех схем расключения, которые имеются в описаниях на модули? Или Вам принципиальные схемы нужны?

Re: Ищу схемы блоков ввода вывода дискретных сигналов Simatic5 для ознакомительных целей
Alexandr Kulikov; 11.8.01

Именно принципиальные схемы. С остальным ознакомился.

С уважением,
Alexandr Kulikov

Re: Ищу схемы блоков ввода вывода дискретных сигналов Simatic5 для ознакомительных целей
Alexandr Kulikov; 11.8.01

Именно принципиальные схемы.

С уважением,
Alexandr Kulikov

Re: Ищу схемы блоков ввода вывода дискретных сигналов Simatic5 для ознакомительных целей
aim; 28.9.01

На какие конкретно модули тебе нужны схемы.

Желательно заказной номер ;-).


text

Переходник RS232/MPI
Papik; 27.9.01

Подскажите кто небуть пожалуйста

Можно ли сконектить S5-тый контроллер
с помощью переходника RS232/MPI
или он только для S7-х

Re: Переходник RS232/MPI
Чистяков Дмитрий ОАО "СеверСталь"; 27.9.01

А что с чем хочется с коннектить-то?

S5-ый с S7-мым?
S5-ый c персоналкой?


text

IP 241для S5-155U
Алексей; 23.9.01

Где найти FB для модуля IP241 6ES5 241-1AA11

для контроллера S5-155U CPU948.


text

Simatic S5 Step 5/St ver.7.13 центр.модуль 6ES5 944-7UB21
Самойлин Виктор; 12.9.01

1.Прошу сказать к какому Simatic-у S5-??? сабж относится.

2.Нужны технические характеристики PG-620 - укажите ссылку в Интернете.
Re: Simatic S5 Step 5/St ver.7.13 центр.модуль 6ES5 944-7UB21
Дедовец Павел; 14.9.01

Ваш сабж относится к Simatic-S5 115U.

Можно посмотреть в русской документации: http://195.146.64.23/ad/as/ru/support/doc.htm
В каталоге: https://mall.ad.siemens.com/WW/guest/index.asp?aktPrim=0&lang=en&nodeID=5000374&foldersopen=-508-509-510-538-579-585-586-&jumpto=586
Так же см. ниже.

См. http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&startNode=4000024&table=ProductNodes&lang=en&open0=-1-45-47-50-&aktprim=0&nodeID0=4000116&siteid=cs&jumpto=50


text

Защита PS407
Eugene; 9.9.01

Где найти рекомендации по выбору защитных устройств для входных цепей блоков питания PS407?

Для PS307 даны прямые рекомендации, для PS407 таковых найти не удалось.


text

Документация на CD
Алексадр Карандашев ; 2.9.01

Как в г. Ульяновске можно получить диск с документацией на русском языке?


text

СР 441-2 (S7-400) - информация к размышлению
Шаклеин ВВ; 8.8.01

Привет!

Сейчас вожусь со связью S7-400 с ПЭВМ. В контроллере стоит СР 441-2 с одним портом, про-
токол свободный (ASCII), скорость 115200, блок
для передачи - SFB 12 (BSEND). Время задержки
символа 2 мс. Передача фиксированной длины.
Интересно то, что, несмотря на такую немалую
скорость, каждая новая посылка начинается не
ранее, чем через 20 мс от начала предыдущей посылки, что иногда может породить некоторые про-
блемы.
Например, я посылаю 4 байта, на передачу которых уходит не более 2 мс, но следующие 4 байта я смогу послать не через 2 мс, а только через 20 мс (примерно).
Как я понял, в это время СР решает какие-то свои внутренние проблемы. Ворос к авторам - не слишком ли долго он их решает?
Может кто знает, как с этим бороться?
Спасибо за внимание.
Re: СР 441-2 (S7-400) - информация к размышлению
Чистяков Дмитрий ОАО "СеверСталь"; 10.8.01

А время скана контроллера какое? Не 20 мс?.

SFB 12 с какой периодичностью вызываешь - в каждом скане по таймеру или ещё как?

Re: СР 441-2 (S7-400) - информация к размышлению
Шаклеин ВВ; 10.8.01

Время скана (ОВ1) - 1...3 мс.

SFB12 вызывается в каждом скане.
Re: СР 441-2 (S7-400) - информация к размышлению
siemargl; 23.8.01

Строго говоря, весьма череззадый способ подключения.. Но вообще-то я наблюдал похожую картину (20мс) при работе с Com-портом из WinNT. Возможно, это тайминги квантования NT (W32).

Re: СР 441-2 (S7-400) - информация к размышлению
Шаклеин ВВ; 27.8.01

>Строго говоря, весьма череззадый способ >подключения..

??

>Но вообще-то я наблюдал похожую картину (20мс) >при работе с Com-портом из WinNT. Возможно, это >тайминги квантования NT (W32).

Здесь работает (посылает информацию) не Win-
dows, а Simatic, конкретнее - СР 441-2.


text

upgrade 115-го контроллера.....
Михаил; 9.8.01

У нас имеется S5 115U c CPU 942B и IM 306

Имеющийся в CPU 942B единственный порт SI1 занят под пульт ОР-37.

Подскажите пожалуйста как наиболее рационально
модернизировать контроллер чтобы иметь возмлжность
- программировать контроллер, не отключая пульт,
- организовать в котроллере PROFIBUS DP интерфейс.

Re: upgrade 115-го контроллера.....
Никаноров, Сименс; 13.8.01

Можно установить CP5431 FMS/DP.

При этом можно подключить панель и программировать через Profibus.
Правда, потребуется модификация программы в CPU.

Re: upgrade 115-го контроллера.....
siemargl; 23.8.01

А можно воткнуть модуль в SI2. Без профибаса, но в 10раз дешевле (и медленнее).


text

Память CPU
shurik; 17.8.01

Для чего нужна обьемная загрузочная память процессора(например внешний RAM модуль),если все упирается в ограниченную рабочую память процессора

Например S7-414 CPU имеет рабочую память 384 Кб - загрузочная память RAM 2Мб,программа занимает чуть больше 40% RAM, программа загружается,но не работает (код ошибки - нет свободной рабочей памяти).Подскажите в чем дело? Можно ли увеличить рабочую память не меняя процессор
Re: Память CPU
Оганесян Юрий; 20.8.01

Сам я упирался в ограничение по памяти только на CPU 214 и, если честно, подозреваю, что возможно соптимизировать Вашу программу, чтобы она стала гораздо меньше. А по поводу загрузочной памяти, то, как я понимаю, есть функции, которые позволяют временно выгрузить блок из рабочей памяти и на его место записать блок из загрузочной. Насколько я помню, есть даже функция - аналог дефрагментации жесткого диска ПК, которая сжимает рабочую память.

Re: Память CPU
Никаноров, Сименс; 20.8.01

Вы можете посмотреть в свойствах контейнера блоков в Simatic Manager, сколько рабочей и загрузочной памяти занимает Ваша программа.

Если рабочей памяти требуется больше, чем позволяет данный процессор, то необходимо менять процессор. Если же рабочей памяти хватает, а программа не лезет, сделайте дефрагментацию (сжатие) памяти.
А загрузочная память нужна для того, чтобы в нее, помимо программы, загрузить системные данные (Hardware Configuration), а также комментарии к программе и символические обозначения операндов (начиная со Step7 V5).
Для экономии рабочей памяти возможна динамическая подгрузка блоков данных (нелинкуемых) из загрузочной в рабочую память.


text

связь между РС и S7-212
Светлана; 15.8.01

При использовании РС в качестве устройства отображения и управления (ProTool) каким образом можно осуществить связь между РС и S7-212


text

MultiControl 200
Кукушкин Михаил; 8.8.01

Господа, помогите разобраться с блоком MultiControl 200.


text

Куплю Б.У. модули от 115го
Papik; 4.8.01

Кто небуть !! продайте Б.У.-шные модули от 115

контроллера.
А то тновые покупать жаба душит.
Если кто заинтересовался пишите и я вышлю вам
коталожные номера.


text

Куплю Б.У. модули от 115го
Papik; 3.8.01

Продайте кто небуть б.у.-шные модули от 115 контроллера.

Новые покупать жаба душит.
Если кого заинтересовало мое предложение то:
чиркните мне и я вышлю коталожные номера
того чего мне надо.


text

срочно нужен модуль позициониров. IP266
Резчиков Валерий; 26.7.01

Ваше сообщение...ОАО "ЗМЗ" срочно купит модуль позиционирования IP266 каталожный номер 6ES5 266-8MA11 одну штуку.


text

FM 357-2
Зайчиков В А; 18.7.01

Здраствуйте. У меня ряд глуппых вопросов по FM357-2. Форум системы контроля перемещений похоже не работает

1. Может - ли FM 357-2 дополняться модулями ввода вывода?
2. Что за memory card у FM 357-2? Это вещь без которой он не может работать или это место для длительного хранения фирменных микропрограмм которые в принципе можно загружатиь в FM357-2 с персонального компьютера.
Re: FM 357-2
Воронин А.Ю. LFG SIEMENS A&D MC; 19.7.01

1.FM 357-2 это 4-х осевой позиционер. Дополняться модулями ввода/вывода самостоятельно не может, без процессора контроллера S7-300 (CPU 314 или выше) не работает, если с процессором, то расширении ввод/вывод стандартное.

2.memory card предназначена для установки фирменного ПО. FM357-2 продается без фирменного ПО, а покупаемое ПО превращает этот модуль в позиционер L(экспортный) или LX(стандартный). Надо учитывать, что для получения стандартного ПО необходимо получение экспортного разрешения.
Re: FM 357-2
Зайчиков В А; 19.7.01

Спасибо

А что такое экспортное разрешение? Сколько времени и денег оно стоит? Кстати, в каталоге есть позиция 6ES7357-4AH03-7BG0 "SIMATIC S7-300, ПАКЕТ КОНФИГУРИРОВАНИЯ МОДУЛЯ FM357-2 С МИКРОПРОГРАММАМИ FM357/LX/H: РУКОВОДСТВО, СТАНДАРТНЫЕ ФУНКЦИОНАЛЬНЫЕ БЛОКИ, МАСКИ ДЛЯ ПАНЕЛЕЙ ОПЕРАТОРА, ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ КОНФИГУРИРОВАНИЯ." Это что? Непонятно всетаки memory card - это носитель на который пользователь записывает фирменные и свои микропрограммы? Тогда какое устройство для этого нужно? И можно ли обойтись без memory card?

Re: FM 357-2
Воронин А.Ю. LFG SIEMENS A&D; 20.7.01

Экспортное разрешение - это межгосударственный документ КОКОМ (если коротко то это комитет, который не разрешает поставку в Россию и другие страны технологий двойного применения и современных технологий для производства различных вооружений. Оформление этого разрешения занимает около 3-х месяцев и если не нарушены условия экспортных ограничений, то выдают разрешение на поставку.Разрешение оформляется бесплатно. Что касается 6ES7357-4AH03-7BG0 - эта вещь не поставляется и за исключением руководства 6ES7357-4AH00-8BG0 входит в состав FM357-2. memory card - это носитель (!) и имеет свой собственный заказной номер см. каталог ST70 или NC60, или СА01. Обойтись нельзя, там находится фирменное ПО.

См. A&D MC


text

Электронная документация на CP526 и COM 536 - где?
Михаил; 7.5.01

Электронная документация на CP526 и COM 536 - где скачать или номер для заказа?

Re: Электронная документация на CP526 и COM 536 - где?
Павел Иванов; 20.7.01

К сожалению на эти продукты, снятые с производства более 6 лет назад, документации в электронном виде нет.

Поэтому надо искать у кого поближе можно скопировать бумажную версию.


text

Развязка токовых сигналов
Дмитрий Пасурин; 5.7.01

Имеются токовые выходы с датчиков положения (4-20мА), которые поступают на плату аналогового ввода Data Translation DT-2812 в системе управления литейной машиной Hazelett.

Необходимо не влезая в SCADA-систему вывести эти сигналы на систему визуализации, сохранив на приемлемом уровне точность и задержки передачи сигнала.

Re: Развязка токовых сигналов
Дедовец Павел; 10.7.01

Для визуализации можно использовать цифровые индикаторы например PROLUX G 96x48 с номером 7NJ3016-1AA14-1AC1. Вход и выход 4..20мА, разрядов пять. Есть в каталоге СА01.

Re: Развязка токовых сигналов
Дмитрий Пасурин; 17.7.01

Сигналы нужно также подать на плату сбора данных,то есть система визуализации должна быть построена на базе ПК.

Re: Развязка токовых сигналов
Дедовец Павел; 18.7.01

Если мы работаем с токовым сигналом то можно включить дополнительный вторичный преобразователь последовательно с уже имеющимся т.к. ток в последовательной цепи один =I. Есть только одно но. Датчик (источник токового сигнала) имеет стабилизатор тока имеющий ограничения по сопротивлению нагрузки. Сложите входные сопротивления вторичных преобразователей и сравните с допустимым сопротивлением нагрузки. А точность при этом пострадать не должна.


text

документация на CD
Шестаков Сергей; 10.7.01

Подскажите как мне получить документацию на CD на

русском языке рекламируемый у Вас на сайте.
Моё место жительства:
Архангельская область
г.Новодвинск


text

Информация о модуле 6ES5 453-4UA12 24В, 2А
Ольштейн Эдуард ,"Мечел"; 5.7.01

В модуле 453-4UA12 имеются выходы сигнализации о коротком замыкании Н+ и Н-.

Подскажите как ими пользоваться, как подключать, какая логика работы этогих выходов.
Или подскажите где найти документацию по этому модулю.

Re: Информация о модуле 6ES5 453-4UA12 24В, 2А
Гуленок Андрей; 6.7.01

Этот модуль описан в "SIMATIC S5-135U/155U System Manual 6ES5998-0SH21" 11/99 Edition 07. Его можно скачать через интернет или получить в представительствах Сименса.


text

Связь с S7-200 и др.
Кузьменко; 23.6.01

Сообщите пожалуйто через какае драйвера WinCC связывается с S7-200 и гле их взять\(купить).

Где можно посмотреть описание Pradave MPI.
Ипомогите пожалуйсто с подключением Siwarex R схема потерялась при транстортировке, а метод научного тыка не помогает.
Спасибо
Re: Связь с S7-200 и др.
Чистяков Дмитрий ОАО "СеверСталь"; 25.6.01

Этот вопрос здесь уже обсудили

http://195.146.64.23/ad/as/ru/forum/forum.cgi?message=545

Найти его можно ниже - сообщение №543.
Или Вы его уже читали? И у Вас есть новые вопросы?

Re: Связь с S7-200 и др.
Андрей Гуленок; 29.6.01

Способ связи с WinCC неоднократно обсуждался где только можно. Вкрадце, есть ОРС сервер, есть пакет микрокомпьютинг. Детали идут в описаниях к пакетам (в том числе и выложенных на этом сервере) и ФАКах. Полезно заглянуть на siemens.de.

По сиварексу, надо смотреть конкретный тип ячейки и по цветам можно определить что к чему. А вообще тензодатчик это банальный резистивный мост о шести хвостах. Элементарно звонится тестером.


text

Помогите с S5-95U
Михаил Симанович; 26.6.01

Здравствуйте Сименс.

Не могли бы вы подсказать как реализовать в контроллере S5 95U в программном блоке следующий алгоритм. Проверяется бит , например дигитальный вход I 3.0 и если он равен 1 то записать число ,скажем 10 в DW 20.
Не уж-то такое не возможно?
Заранее спасибо Михаил

Re: Помогите с S5-95U
Никаноров, Сименс; 27.6.01

В функциональном блоке можно:

UN E 3.0
SPB =M001
A DB X
L KF 10
T Dw20
M001:

А если нужно все-таки в PB, тогда:
U E 3.0
SPB PB xx
где в PB xx след. команды:
A DB X
L KF 10
T Dw20


text

Siemens and Allen Bradley
Богдан Кудлак; 26.6.01

Как осуществить передачу данных между процессорами

S7-300 (Siemens) и PLC5 (AllenBradley) напрямую через Ethernet?

Какое программное обеспечение нужно для этого?
Re: Siemens and Allen Bradley
;'l;'l,k;'; 26.6.01

hkjhjkhjkhj

Re: Siemens and Allen Bradley
Никаноров, Сименс; 26.6.01

Через Ethernet не получится.

А через CP341 по DF1 можно.
Для этого помимо CP341 нужны загружаемые драйверы.
Re: Siemens and Allen Bradley
Чистяков Дмитрий ОАО "СеверСталь"; 27.6.01

Здравствуйте, Владимир!

А может автору вопроса посоветовать использовать Profibus. Ведь AB его поддерживает, ну а Siemens само-собой.
По крайней мере AB заявляет, что поддерживает.


text

Датчики для модулей DI S7300
Васильев; 3.6.01

Господа!

Исходя из пратики, посоветуйте пожайлуста какой тип индуктивных датчиков приближения желательно применять в модулях DI SM321 и SM323.
Также подскажите тип относительного энкодера для модуля FM350-2 (желательно 600 имп/оборот). Зарнее благодарю.
Re: Датчики для модулей DI S7300
Никаноров, Сименс; 7.6.01

Используйте индуктивные датчики BERO

См.ссылку
См. http://195.146.64.23/ad/cd/index.html

Re: Датчики для модулей DI S7300
Васильев; 20.6.01

Спасибо, выбор остановлен на датчиках

BERO for PLC.


text

Vодуль дискретного ввода SM321 с поддержкой прерываний
Васильева В. И.; 22.5.01

Можно ли на удаленной станции ET200M с интерфейсным модулем IM153-1

применить модуль дискретного ввода SM321 (6ES7321-7BH00-0AB0) с поддержкой прерываний, для подсчета импульсов или для измерения частоты. Параметры сигнала:
длительность 2 мс. - частота до 100 Гц.
Применяется контроллер S7-315 2DP. Допустимо ли для этой цели использовать все 16 каналов.

Re: Vодуль дискретного ввода SM321 с поддержкой прерываний
Илья; 29.5.01

Я не стал бы. Смотрите, из чего складывается время обновления состояния входа: T(ob1)+T(sys)+T(dp)+T(sm321). Уложитесь в 2мс ? Лучше использовать специализированные модули счета типа FM 350-X. Либо советую обратить внимание на C7 - процессор от 314 до 315 + AI, AO, DI, DO да еще универсальных 4 входа (счетчики Up/Down, частотомеры и тд)

См. http://www.industrialauto.ru

Re: Vодуль дискретного ввода SM321 с поддержкой прерываний
Васильев; 30.5.01

Согласен с Вашим предложением Илья по использованию для этой цели FM350-2. Собственно я с него и начал. Но согласитесь со мной, что для таких параметров это несколько дороговато.

Что касается С7 то это скорее всего S7-200, но процессоры CPU214 ...CPU226 (или я не прав ?). Да и мне нужен удаленный доступ (100 м), что скорее всего с S7-200, будет сложновато.
И тем не менее благодарю Вас за проявленное внимание. Буду рад услышать комментарии на мои замечания.

Re: Vодуль дискретного ввода SM321 с поддержкой прерываний
Андрей Гуленок; 6.6.01

Вся С7 серия базируется на S7-314 - 315ых CPU


text

Неполадки с СР525
Шаклеин Вадим; 31.5.01

Здравствуйте!

У нас есть контроллер S5-115U с CPU 942, в нем
СР525 для связи с ПЭВМ, интерфейс - токовая петля.

Проблема - иногда пропадает связь с ПЭВМ. То есть, СР525 крепко затыкается - помогает только холодный (->OFF->ON) рестарт. Теплый рестарт
(->STOP->RUN), тем более - программный сброс
связи (RESET) не помогают.

Кто что посоветует?
Пока.


text

Продлема с FC 100-FC111
Ярослав; 31.5.01

Пришлите пожалуйста примеры использования функций обработки аналоговых сигналов или сообщите где можно почерпнуть информацию. В частности FC107 и FC109.


text

еще раз отладка
AlexanDer; 29.5.01

Если подробнее,то...

Я скачал сначала все(All)блоки в xxxxxx.s5d ,
затем в скачанном блоке PB14 изменил существующий вход на существующий маркер , а назад в ОЗУ PLC не могу его переслать ни в режиме FILE-BLOCKS-TRANSFER ,ни в режимах TEST,PLC соответственно EDIT-везде Выдает :"Block list does not exist in PLC" .
Можно ли это сделать в режиме RUN PLC ?


text

Нужна помощь! S5-100U CPU102
Alex Kamko; 25.5.01

Hi all !

кто подскажет - влияет ли произвольная установка
внешних модулей I/O для S5-100U CPU 102 (напр.: CPU_I0_I1_I2_Q3_Q4_I5 )на выполнение программы, если да то как ?

Re: Нужна помощь! S5-100U CPU102
Виктор; 25.5.01

Влияет на скорость выполнения, но обычно CPU-102

применяется там, где это не очень важно.


text

запись программы в S5 100U/CPU102
AlexanDer; 25.5.01

Есть STEP5 v7.11 и программа xxxxxxST.S5D на PC ,кабель PC/TTY .Как программу засунуть в

S5 100U/CPU102.

Re: запись программы в S5 100U/CPU102
Виктор; 25.5.01

Transfer FILE - CPU


text

Панель С7-624, не нашел код ошибки
Алексей Поликаркин, Самара; 17.5.01

В наличии панель С7-624, заказной номер

6ES7 624 1AE00 0AE3 (на задней крышке, проверял)
При попытке загрузить в контроллер стандартную конфигурацию, которую STEP7 сам выставляет появляется сообщение, что конфигурация offline не соответствует текущей и выдает номер
6ES7 624 1XE00 0AE3 текущей конфигурации. Что это за номер я так и не нашел ни в одном каталоге.
Дальше при запуске вылетает ошибка программирования 668 #3 и панель постоянно рестартуется. Код ошибки в руководствах не нашел,
там только 667 ошибка конфы. Посоветуйте что делать.


text

Использование имен параметров в DB
Шаклеин Вадим; 29.1.01

Привет всем!

Я программирую S7-400. Есть у меня DB, в ко-
торых я описываю переменные и даю им имена. А
как использовать эти имена в программе (т.е.,
обращаться к переменным из DB по имени) не знаю.
Кто знает?
Re: Использование имен параметров в DB
aim; 30.1.01

Пришло время читать Help. Там всё расписано по пунктам. Только не забудь твой DB прописать в символьной таблице.

Re: Использование имен параметров в DB
Шаклеин Вадим; 30.1.01

Благодарю за "исчерпывающий" ответ.

Стоило ли себя так утруждать?

Пояснение. Имелось в виду автономное использо-
вание DB.

Re: Использование имен параметров в DB
Love; 16.5.01

Как ни странно, aim дал вам вполне исчерпывающий ответ. Чтобы доступиться к символам переменных DB, ему самому (блоку данных) необходимо присвоить имя в символьной таблице.


text

модуль 6ES5-375-1LA15
AlexanDer; 11.5.01

У меня несколько вопросов НОВИЧКА.

Почему на ярлыке модуля 6ES5-375-1LA15 написано
« memory 8k*8bit »,а микросхема стоит в несколько раз больше (EPROM 27A512)?
Очевидно , что помимо управляющей программы в модуле хранится еще что-то.
Что храниться в модуле EPROM 6ES5-375-1LA15 и
в каком формате ?
Возможно ли заменить модуль EPROM 6ES5-375-1LA15 на модуль EEPROM 6ES5-375-OLC31 ?

Re: модуль 6ES5-375-1LA15
Никаноров, Сименс; 11.5.01

Там больше ничего нет, кроме программы.

Просто микросхема стоит такая.
А заменить на аналогичный по объему EEPROM можно.
Re: модуль 6ES5-375-1LA15
AlexanDer; 14.5.01

Как показала эксплуатация , нам прийдется несколько раз изменять программу .

Если мы возьмем модуль EEPROM 6ES5-375-OLC31 ,не
нужен ли будет программатор PGXX для того чтобы перебросить программу из модуля 6ES5-375-1LA15 ?
Или достаточно PC со STEP5 v.7.11, кабеля PC/TTY и
самого PLC S5 102 ?

Re: модуль 6ES5-375-1LA15
Никаноров, Сименс; 14.5.01

Для сохранения программы на EEPROM из CPU102 достаточно удерживать клавишу Copy в теч.3 сек.

Т.е. Вам для этого даже не понадобится РС со STEP5 .
отладка оборудования
AlexanDer; 14.5.01

Раз в 12 часов происходит сбой в алгоритме работы оборудования .Чем можно отслеживать ситуацию кроме OP393 ? Позволяет ли STEP5 c PC вести регистрацию состояний таймеров , счетчиков и входных/выходных сигналов ? Или какие другие программы ?

Re: отладка оборудования
Шкенев Виктор; 14.5.01

Если Вы в Москве,позвоните, попробую помочь.

Re: отладка оборудования
AlexanDer ; 15.5.01

К сожалению не в Москве .

Re: отладка оборудования
Шкенев Виктор; 15.5.01

У Вас все получиться, изменяйте программу сколько хотите, потом скопируйте на EEPROM.


text

Работа
Шкенев Виктор; 14.4.01

Ищу постоянную работу. Работаю с S5 и S7 в сфере

переработки пластмасс. Отличаюсь вредным характером и большими амбициями.
Re: Работа
Stah Chmelnicki; 24.4.01

Сообщите в каком вы городе?

Может быть что-нибудь смогу вам предложить.

Re: Работа
Шкенев Виктор; 13.5.01

Уважаемый by Stah Chmelnicki, я живу в Москве

Re: Работа
Михаил Ефремов; 13.5.01

Нужно запустить машину по производству преформ.

Машина б.у. Симатик С5-115.


text

Нужна программа для предприятия под S5 (115V CPU 943 B))
Nukri; 1.5.01

У нас на предприятии итальянской фирмой ORU, установлен завод по производству бетонной смеси. Контроллеры -

Simatic S5. (115V CPU 943B)
Недавно в одной операторской произошел сбой в работе.
Перестала работать система компьютерного управления автоматами.

Наше предположение, что произошел сбой в работе программного обеспечения (не загружается фирменная база данных). Тип файловой системы, неизвестный, и поэтому нет возможности даже посмотреть, что там зарыто.

Вопрос заключается вот в чем.

Может ли кто, поставить другое (более гибкое) программное обеспечение для нашего предприятия.

С Уважение Нукри Башарули.

Re: Нужна программа для предприятия под S5 (115V CPU 943 B))
Шкенев Виктор; 13.5.01

Могу помоч запустить Ваш завод.


text

IP 241
Гуцол Николай; 7.5.01

Господа, скажите- требуется ли для модуля пози-ционирования IP241 пакет конфигурирования или специальные FB?


text

Помогите найти документацию на ОС, установленную на контроллерах
Дмитрий; 11.4.01

Мне необходимо сделать доклад на эту тему(в учебных целях) помогите... Please

Re: Помогите найти документацию на ОС, установленную на контроллерах
Михайлин Сергей; 13.4.01

Такая информация не разглашается и является закрытой.

:) Закрыта от кого? Не SIEMENS же ее разработал.
Дмитрий; 14.4.01

Как можно закрыть чужое?

Re: :) Закрыта от кого? Не SIEMENS же ее разработал.
Андрей Гуленок; 17.4.01

На сколько я понимаю, это собственное творение Сименса.


text

SIMATIC S5-95U ????? что-да-как?
Дмитрий Поединок; 5.4.01

Правда если постараться то можно самому найти

что такое SIMATIC S5-95U Но если кто сможет
подскажите кто сможет где найти подробное описание
этого устройства.
адрес: poedinokd@mail.kz

Re: SIMATIC S5-95U ????? что-да-как?
Виктор Шкенев; 8.4.01

S5-95U - програмируемый контроллер.

Програмируется пакетом STEP-5.
Пишите, звоните, помогу.

Re: SIMATIC S5-95U ????? что-да-как?
Виктор Шкенев; 8.4.01

S5-95U - програмируемый контроллер.

Програмируется пакетом STEP-5.
Пишите, звоните, помогу.

Re: SIMATIC S5-95U ????? что-да-как?11
1; 17.4.01

Ваше сообщение...1


text

npn sensor
Гуцол Николай; 5.4.01

Имеется ли в арсенале оборудования Siemens какая-нибудь примочка для подключения датчиков c npn

выходом к модулям ввода дискретных сигналов S7-300?
Re: npn sensor
Ольштейн Э. "Мечел"; 11.4.01

Разве нельзя запитать эммитер 24В, а коллектор подключить к входу контроллера? Или я не понял вопрос?

Re: npn sensor
Max; 12.4.01

Нельзя. У npn транзистора напряжение на коллекторе должно быть больше, чем на эммитере. Примочка простая - сопротивление 1кОм 1 Вт между выходом BERO и +24В - при подгрузке одним входом напряжение логической единицы - около 17 вольт. Не совсем гуд, конечно, но вполне достаточно.

Re: npn sensor
Ольштейн Э. "Мечел"; 13.4.01

Извините,пора в отпуск.Читаю NPN - думаю PNP.

А с ответом Маха согласен.

Re: npn sensor
Гуцол Николай; 16.4.01

Спасибо за совет, но я спрашивал про что-нибудь готовое, перевертыши уже проходили.


text

S5-95U нужна информация!!!!! Помагите!!!!
Дмитрий Поединок; 7.4.01

Подскажите пожалуйста где скачать информацию

об S5-95U хотябы разводку всех раземов,
так-же протоколы и как программировать?
Ходил 4 часа по сайту Siemens скачал два фала,
какойто имулятор и step5 но некакого толку.
А если кто сможе прислать CD-ROM почтой с такой
информацией напишите на мыло poedinokd@mail.kz
Хотябы какую-нибуть захудалу сылку в нете,
где это можно скачать.
Заране благодарен.

Re: S5-95U нужна информация!!!!! Помагите!!!!
Шкенев Виктор; 9.4.01

Помогу по Simatic S5


text

прогромирование S5-100U
Сергей; 18.3.01

Контролер S5-100U потерял программу. Установлен на Keg washing\filling machine 1T.

Как восстановить программу на контроллере и что для этого необходимо.
Re: прогромирование S5-100U
Дедовец Павел; 20.3.01

Что значит потерял? По хорошему в контроллере обычно имеется модуль ПЗУ (такой оранжевый). Если батарейка подсела то программа восстановится из ПЗУ. Правда бывает, что программа в ПЗУ не верна т.е. не соответствует программе в ОЗУ. В этом случае обращайтесь к поставщику, или к документации (если она у Вас есть).

Re: прогромирование S5-100U
Шкенев Виктор; 9.4.01

Если нужно, востановлю.

GSM 89021638664


text

S7 это хорошо но у нас куча S5 а программаторы сдохли
Голубев Е.Ю. (Красноярский ЦБК); 22.3.01

IBM---------как?----------S5

Подскажите можно ли использовать в место программатора обыкновенный IBM и если да то какое программное обеспечение нужно (я подозреваю, что это любая из промышленных SCADA, но как правило они все навороченные и дорогие, а кроме, ведь нужно то всего выполнять задачи PG) и где и за сколько его приобрести (есть ли в инете какие либо демонстрашки или даже может быть что-нибудь бесплатно). Ну а если нет то сколько будет стоить PG для контроллеров серии S5-100U, S5-115U, S5-135U и где его можно приобрести в районе Красноярска.

Re: S7 это хорошо но у нас куча S5 а программаторы сдохли
Никаноров В. - Сименс; 22.3.01

Обратитесь в наш технический центр в Красноярске

(см. ссылку)
См. http://www.simatic-center.scn.ru/

Re: S7 это хорошо но у нас куча S5 а программаторы сдохли
Дедовец Павел; 22.3.01

Давно ждем. Урицкого, 61. оф. 323А

Красноярское Бюро SIEMENS A&D
Re: S7 это хорошо но у нас куча S5 а программаторы сдохли
Viktor Shkenev; 8.4.01

Имею старенький PG 710 .

Отдам недорого. Пишите на E-mail.
Привет Столбам.


text

S7-300 и USS-протокол
Рябов Андрей; 2.4.01


text

SFC 51 чтение диагностического буфера
Веткин Д В ВАЗ; 31.3.01

Привет!!!

Может кто сталкивался с такой проблемой:
сабж читает диагностический буфер, причем только 21 последних записей, хотя контроллер хранит больше (400 - ый), дак вот, если очень хочется прочитать все - никак нельзя, или можно как-то вывернуться?

Сразу спасибо
Дима


text

Периодичность измерений FM350-2
Шаклеин ВВ; 29.3.01

Привет всем!

Я использую режим измерения длительности пери-
ода этого модуля. Задается для него и временнОе
окно. Судя по документации, должно измеряться
время между двумя смежными импульсами, при
условии, что они попадают во временное окно. Од-
нако, как бы я не менял частоту импульсов, время
обновления результата не меняется и остается ра-
вным длительности временного окна.
Что надо сделать, чтобы измерялся интервал меж-
ду любыми двумя смежными импульсами?

Пока.


text

Cломался монитор фирмы "Siemens",чем заменить?
Oльштейн Эдуард , "Мечел"; 27.3.01

Cломался монитор 6AV1472-0AA00,перекошен экран.

Он был подключен к модулю WF470 6FM1470-3AA21.
Модуль стоит в корзине 135-ого "SIMATICа".

1.Можете ли подсказать, что за интерфейс у монитора? Похож на RGB-TTL,но при подключении к стандартному RGB-TTL устройству монитор не включается, а на обьекте ремонт затруднен.

2.Возможен ли ремонт этого монитора в фирме "SIEMENS"?

3.Можно ли преобрести в ЗИП такой монитор, или какой монитор сейчас идет на замену?

Re: Cломался монитор фирмы
Никаноров В. - Сименс; 27.3.01

Обращайтесь в ближайший офис Сименс.


text

Проблема внутренним EEPROM у IFM контроллеров (312,314)
Ярослав Бойков; 25.3.01

При перезагрузке программы в ремоненнтную память загорается "SF"

- контроллер переходит в стоп, программа в память не попадает.
Спасибо


text

провода
Андрей; 23.3.01

Ваше сообщение...нужно найти маркировку проводов по внешнему виду, производитель сименс,на одном проводе есть надпись "cs 4-1128-013-50".Где и как это можно зделать ??


text

Доступ к FM350-1 без использования библ. FC (очень нужно!)
Любимов А. (ОАО "Электропривод"); 13.3.01

Для увеличения быстродействия и предотвращения запаздывания при считывании информации от FM350-1 хотелось бы иметь возможность обратиться к нему "напрямую" _без_ использования библиотечных FC CNT_CTRL и DIAG_INF.

Если кто-нибудь сталкивался с подобной проблемой -- помогите, пожалуйста.

Спасибо.


text

Где можно взять описание OB251 ???
Serge Dovgopolyuk ; 7.3.01

Subj plaese?

Re: Где можно взять описание OB251 ???
Дедовец Павел; 12.3.01

Описание Subj есть в мануалах на конкретный контроллер и в книжке по STEP5 (например Бергер в 2х томах) Все это имеется на нескольких языках, и на русском тоже. Получить можно в ближайшем техническом центре SIEMENS. см.-> http://www.siemens.ru/ad/region/center.htm

или по ссылкам:
поискать на http://www.ad.siemens.de/simatic/html_76/support/index.htm
или посмотреть на

См. http://www.siemens.ru/ad/as/ru/info/03_s5/04_man/


text

Время обработки FM350-2
Александр Башкиров "АСК"; 28.2.01

Имеется 3 счетчика FM350-2 на ET200M, работающие в режиме измерения длительности периода, для измерения скорости вращения двигателей.У каждого

счетчика работают все 8 каналов.
Результат подсчета длительности периода удается получить лишь каждые 20 мс, а хотелось бы каждые
5 мс.
Подскажите как, если это возможно?


text

PG702
НТМК, ЛСПУ; 28.2.01

В комплекте с S7-200 был приобретен программатор PG702. К сожалению,практически без описания. Поиски в сети не дали результата. В данном форуме на этот вопрос мне дали ссылку,но по данному адресу кроме тех.данных прибора и его изображения ничего не было найдено. Срочно нужно руководство пользователя, помогите, пожалуйста. Работа стоит !!!!

Re: PG702
Никаноров В. - Сименс; 28.2.01

Так здесь же лежит руководство.

150 страниц.
Что нужно-то?

См. http://www.siemens.ru/ad/as/ru/info/08_pcpg/04_man/pg702_e.pdf


text

ПИД-регулятор S7200
Романа; 23.2.01

Имеется исполнительный механизм МЭО-63,с аналоговым датчиком положения,который осуществляет открытие или закрытие дроссельной заслонки на всасе компрессора. Сигнал на открытие или закрытие заслонки является дискретной величиной.

Вопрос заключается в том, что каким образом можно с помощью програмного ПИД регулятора контроллера S7215 у которого регулирующее воздействие представляется аналоговой величиной заставить регулировать положение дроссельной заслонки.(Как в 300-ой серии SFB42)Может быть есть какие нибудь TIPсы на эту тему?

Re: ПИД-регулятор S7200
Павел; 23.2.01

Зайдите на сайт WWW.owen.ru там найдете всё необходимое.Вопросы по почте.

Re: ПИД-регулятор S7200
Eugene; 26.2.01

Попробуйте выход регулятора в пределах 0-100%.

Положение МЭО также преобразуйте в % от 0 до 100.
А выгонять МЭО на заданное положение - задача не такая уж и сложная. Правда с сигналом положения придется повозиться - он не слишком уж стабильный, придется усреднять.

Re: Спасибо
Романа; 26.2.01

А как насчет того, чтобы преобразовать аналоговое регулирующее воздействие в дискретную величину? Возможно ли это?


text

Re: PG 720
Alex; 22.2.01

Уважаемые господа бподскажите бвозможно ли в PG 720 установить новый (больший) RAM чтобы перевести PG с windows 95 на windows 98 , и какова ориентировочная цена такого изменения.

С уважением!


text

S5
Dmitry; 20.2.01

Какой коммуникационый процессор необходимо

использовать для связи S5-95 или S5-115 c компьютером. Или можно обойтись без комм.процессора ?
Re: S5
Дедовец Павел; 21.2.01

Можно обойтись и без комм.процессора. S5-95 и S5-115 имеют PG порт для подключения программатора (через COMх порт). Используемый протокол AS511 поддерживается SCADA системой WinCC.

Более простого решения не бывает.

Re: S5
dmitry; 21.2.01

А если необходимо подключить S5 к MPI, а уже потом

к какому-то участку MPI подключать компьютер.

Re: S5
Alexei; 21.2.01

Можно применить также CP525 (точка - точка). Если есть интерес, можем помочь...


text

модуль SM 322 Ex
SCA , Петрова Андрея; 21.2.01

В каталоге на модуль SM322 6ES7322-5RD01-0AB0 указывается напряжение питания нагрузки 15В. Какое напряжение подается на контакты 1 и 20 его передней панели (24В ?). Если 15В, то от дополнительного источника питания?

Re: модуль SM 322 Ex
Чистяков Дмитрий ОАО "СеверСталь"; 21.2.01

Питание внешней цепи 24В. Вы можете, конечно, использовать один источник питания, но в таком случае может появиться проблема с развязкой питания внешних цепей. Поэтому желательно иметь отдельный источник для всех внешних цепей.

15В формируются внутри модуля из 24В.


text

SDB для CPU 414-3DP
Храмцов В.В.; 20.2.01

При сравнении программ в CPU и на программаторе, кроме всего прочего выдал : SDB Differences.

В Details: Comparison for SDB type 2000 is not supported.
Что бы это значило?
SDB2000 присутствует и в процессоре, и на программаторе (Type 2000). Контрольные суммы System data тоже совпадают.
Есть подозрение, что из-за этого падает связь по Profibus со второго интерфейса.
Re: SDB для CPU 414-3DP
Чистякова Дмитрий ОАО "СеверСталь"; 21.2.01

Ничего страшного.

Данное сообщение говорит лишь о том, что имеются различия в датах и времени создания системного блока. Присходит это потому, что Закачав в контроллер программу, Вы вероятно уже после этого открывали проект и сохраняли его, при этом, не важно изменяли его или нет - дата и время фиксируются новые.
Вообще же это сообщение предупреждающее и оно просто заставляет Вас проверить - не было ли каких либо несанкционированных (ложных) загрузок новой программы.


text

СP 340
Игошев В.Ю.; 20.2.01

Как можно организовать обмен с внешним прибором и блоком СР340 используя протокол (АSCI, RS485),но для увеличения скорости обмена использовать прерывания от блока СР340. Возможноли вообще использовать прерывания от блока СР340.

Re: СP 340
Никаноров В. - Сименс; 20.2.01

Для увеличения скорости обмена использовать прерывания не получится.

СР340 умеет генерировать только диагностические прерывания (если Вы установите Interrupt==Yes).
При этом вызывается OB82, в который СР340 передает 4 байта диагностической информации. Структуру этой информации см. в руководстве в разделе диагностика.
Эту же самую диагностику СР340 записывает в диагностический буфер CPU, который может быть просмотрен средствами STEP7 в online.
Учтите, что если Вы активизировали диагностику, а OB82 не запрограммирован, то при возникновении диагностического прерывания CPU перейдет в STOP.
Помимо вышесказанного, FB для СР340 нельзя вызывать в блоках обработки прерываний (от процесса и диагностических).


text

CP340 - глюк
Шипилов ЮВ; 13.2.01

Имеем мастер и до 20 слейвов.

Один слейв и мастер работают бесконечно долго.
Мастер и несколько слейвов длительность связи обратно пропорциональна количеству слейвов.
Настройки слейва и мастера одинаковы.
Пробовал баловаться с настройками CP340 более меннее устойчивый результат дает при следующих настройках.
Protokol=ascii
2400 bps 8/e/1
cdt=18 ms
dfc=none
prevent overwriting=true
beffered receive message frame = 1
Но через месяц работы мастер загибается! И восстанавливается только после операции stop - run. CP340 -RS232C 6ES7 340-1AH01-0AE0 V3

Re: CP340 - глюк
Любимов А.; 19.2.01

Какие могут быть master'а и slave'ы для 340-го???

Поясните, в каком смысле Вы употребляете указанные термины.
Re: CP340 - глюк
Шипилов; 20.2.01

Имеются N контроллеров S7 300 и обмениваются они

данными посредством радиомодема отсюда соответственно и логическая структура выкорячивается.


text

Конфигурирование для S5-контроллеров
Ярослав; 16.2.01

Есть ли необходимость конфигурировать непосредственное соединение контроллера и присоединенных к нему модулей расширения или программа COM... необходима только для удаленных станций? Спасибо

Re: Конфигурирование для S5-контроллеров
Дедовец Павел; 16.2.01

COMы нужны для параметрирования "умных" модулей (CP, IP, IM ...) Если у вас однопроцессорная система то обычные модули ввода вывода достаточно просто установить в корзину контроллера. Есть правда у некоторых особенности - DIP переключатели и субмодули диапазонов. (но это ведь не СОМ)


text

PG 720 PII
Паршин Геннадий; 14.2.01

При работе от аккумулятора программатор

PG 720 PII был выключен и затем не хочет
включаться. Как вывести его из этого состояния.
Может быть отключить аккумуляторы?

Re: PG 720 PII
Никаноров В. - Сименс; 14.2.01

Совершенно верно.

Нужно отсоединить аккумуляторы.


text

вопрос для Никанорова (третично)
Шипилов ; 14.2.01

Имеем мастер и до 20 слейвов.

Один слейв и мастер работают бесконечно долго.
Мастер и несколько слейвов длительность связи обратно пропорциональна количеству слейвов.
Настройки слейва и мастера одинаковы.
Пробовал баловаться с настройками CP340 более меннее устойчивый результат дает при следующих настройках.
Protokol=ascii
2400 bps 8/e/1
cdt=18 ms
dfc=none
prevent overwriting=true
beffered receive message frame = 1
Но через месяц работы мастер загибается! И восстанавливается только после операции stop - run. CP340 -RS232C 6ES7 340-1AH01-0AE0 V3

Re: вопрос для Никанорова (третично)
Никаноров В. - Сименс; 14.2.01

Устойчивое впечатление, что у Вас переполняется буфер приема. Если Вы вызываете блок приема в CPU в OB1 (а Вы это обязаны делать именно здесь), то при параметре beffered receive message frame = 1 Вы должны задать параметр

"prevent overwriting" ==0. Иначе будет переполнение буфера.
Кроме того, переполнение возможно также, если CPU переходит в "стоп", а при передаче через ASCII не контролируются управляющие сигналы RS232.
Помимо этого, для более детального разговора необходимо описание Вашей конфигурации, версии Firmware (Z0x), версии пакета проектирования, результатов диагностики (через Status и буфер диагностики) и пр.
P.S. Если Вы хотите общаться непосредственно со мной, то у меня есть телефон: 737-2426.
Но по CP340 лучше разговаривать с моим коллегой Гуленком Андреем: 737-2477.


text

Глюки CP 340
Шипилов; 12.2.01

Имеется мастер и 20 слейвов.

Настройки связи одинаковы.
Protocol
------------
transmission rate=2400
8/1/even
----------
DFC=none
---------
Prevent overwriting=true
buffer receive message frame=1
Проблема.
Если число слейвов > 1 то через 1 месяц получаем 0-ой буфер


text

Документация на PG702
НТМК , ЛСПУ; 2.2.01

Подскажите,пожалуйста, где можно найти руководство пользователя на программатор PG702.

Re: Документация на PG702
Никаноров В. - Сименс; 2.2.01

Помещен в раздел Продукты\руководства PC\PG.


text

задание адреса входа в DB в S7-400
Шаклеин Вадим; 29.1.01

Привет всем!

Не могу понять, как в DB можно задавать адреса
входов/выходов для косвенной адресации в S7-400.
В S5 было так. Адрес входа задавался в слове,
где старший байт - номер бита (если нужен), мла-
дший - номер байта или слова. Слово с таким со-
держимым в формате "KY" можно было вписывать в
DB и затем использовать для косвенной адресации
в программе.
А в S7 как делать?
Поделитесь опытом, кто делал.

Re: задание адреса входа в DB в S7-400
aim; 30.1.01

А Help читать не пробовал?

Re: задание адреса входа в DB в S7-400
Шаклеин Вадим; 30.1.01

Привет, aim!

Если б не пробовал, не писал бы.


text

PG 740 наращивание RAM
Олейник Сергей; 23.1.01

Имеется PG 740 P-MMX-233

в оригинале стояло 2*16Мб SIMM 60 ns.
Пытались нарастить память до 128 Мб
4*32Мб (модули SIMM EDO 60ns.
При любых комбинациях (64, 98, 128)
PG 740 сбоит либо при загрузке, либо при запуске любого приложения, появляется "синий экран".
Вопрос: кто-нибудь сталкивался с подобной ситуацией и как можно её решить?

Re: PG 740 наращивание RAM
НТМК , ЛСПУ; 30.1.01

Такой случай имел место в моей практике, правда был обыкновенный PC. Тогда проблема возникала, как выяснилось, только потому, что две новые "линейки" имели чипы другого производителя, чем на уже установленных. Остальные параметры "линеек" (время,объем памяти, и т.д.) полностью совпадали. Пришлось поменять на другие. Сразу все заработало...


text

Гальваническая изоляция в модулях аналогово ввода S7
Занчевский Ю.В.; 26.1.01

Какого типа станцию распределенного ввода (ЕТ) и какие модули оптимально использовать для ввода аналоговых сигналов с изолированным входом от выхода на 1000 В ? В каталоге ST 70 такой информации не нашел. Написано толькоБ что изоляция от шины ПЛК - оптоэлектронная


text

Симулятор S7-200
НТМК , ЛСПУ; 17.1.01

Имеется ли в природе программное средство для IBM PC , реализующее программную симуляцию ПЛК S7-200 ?

Re: Симулятор S7-200
Гуленок Андрей; 22.1.01

В номенклатуре Сименса такой программы нет.


text

микросим
Байков Денис; 22.1.01

Прошу отозваться тех кто программировал связь

индикаторов веса Микросим (ф.Метра г.Обнинск)
Проблема в отсутствии ответа от прибора .
Связь идёт по RS232,SFB12.
И что же в SFB12 означает R_ID ?


text

Срочно нужна помощь !!!
aim; 18.1.01

Кто слышал про модуль SSM-BG42.

Это комбинированный модуль: 4*AInp(разъём 25p) + 4*AOutp(разъём 25p) + порт для инфракрасного датчика (разъём как PS/2, только без фишки).
СРОЧНО нужна информация !!!


text

Мониторы Siemens
НТ; 18.1.01

Подскажите, где можно найти тех.документацию на мониторы 6AV8011-1JE22-0DA0 и PM54/C2 6AV8011-1LE62-0KA0. Возможно ли получить так же и принципиальные электрические схемы этих устройств ?


text

Подключение PG702 к PC
НТМК , ЛСПУ; 16.1.01

Возможно ли передавать программный проект из STEP 7 - MicroWIN 32 непосредственно в программатор PG 702 и наоборот ? Если возможно, то что для этого необходимо ?

Re: Подключение PG702 к PC
Гуленок Андрей; 16.1.01

Если вы имеете в виду передачу программы из компьютера в PG702 то это возможно только через контроллер.


text

Позиционирование с помощью CPU 314C-2 PtP
Штепа С.А.; 5.11.02

Возможно ли для позиционирования с помощью CPU 314C-2 PtP использовать попеременно разные каналы счета (два инкрементальных датчика)? И что за параметр CHANNEL в SFB44? Понятно, что это номер канала, но какого такого канала?

Re: Позиционирование с помощью CPU 314C-2 PtP
Кухаренко Сергей, SIEMENS; 31.12.02

Возможно, если Вы сумеете так организовать программу. Номер канала - это фактически номер оси позиционирования. На самом деле я Вам рекомендую обратить внимание на пакет Easy Motion Control, для параметрирования задач простого позиционирования в том числе и на CPU 314C-2PtP. Этот пакет очень сильно облекчит Вашу работу.


text

OP5
Зубарев; 27.12.02

Панель ОР5 была запарамметрированна в

ProTool. Необходимо заменить панель, но нет программы. Как можно это сделать? Может как-то выгрузить код с панели и затем загрузить в другую панель (тоже ОР5), но как, это сделать? Я слышал, что есть какая-то программа для этого.
Re: OP5
Кухаренко Сергей, SIEMENS; 31.12.02

Если Ваша панель ОР5 была запараметрирована в ProTool, то выгрузить проект можно с помощью утилиты, которая называется Prosave(она входит в состав ProTool).

Но в этом случае есть один маленький нюанс - этот файл бинарный и его нельзя редактировать.


text

S7-400H и Ind.Ethernet
Иванов П.П.; 26.12.02

Как организовать связь по Ethernet между S7-400H и PC c одним коммуникационным процессором CP1613?

Re: S7-400H и Ind.Ethernet
APS; 28.12.02

Не совсем понятен вопрос, но может чем помогу....

В проекте добавляется OS генерится xdb файл, на PC ставится REDCONNECT и вперед. REDCONNECT нужен, чтобы видеть H - систему как единое целое. У нас по крайней мере работает.


text

Siemens MCM1503
Tanya; 26.12.02

Подскажите, пожалуйста, нужен ли к МСМ1503 драйвер и вообще, что представляет из себя этот монитор(основные характеристики)?

Спасибо.


text

Как сделать Upload?
Дертунов Борис; 24.12.02

Подключился к S7-414 программатором, а Upload пишет не возможен:....not valid PG format. Что значит данное сообщение? Программу удалось скачать только из онлайна ессно без ситемных данных. Что будет если произойдет какой-либо сбой и нужно будет сделать обратную загрузку(download)? На стенде организовать данное сообщение не удалось

Re: Как сделать Upload?
Baby; 24.12.02

Привет, Борис !!!!

А куда вы делали Upload.....
В просто имя, проект, серию Simatic ???

Пока.....


text

модернизация ZG S5-150U на S7-400
Герасимов Иван; 11.12.02

Всем здравствуйте,

Возможно ли заменить только центральную корзину S5-150U, имеющую связь с EG-185и EG-187 на S7-400.

С уважением,

Герасимов И.

Re: модернизация ZG S5-150U на S7-400
Михайлин Сергей; 18.12.02

На 99.9% НЕТ! Принципиально разные семейства. На 0.1% можно скажать, что есть адаптер модулей S5, чтобы вставлять из в S7-400, но он поставляется только вместе с модулем S5 и не для всех модулей годится. Да и контрукция получится не дай Бог! ;-) Проще заменить все сразу.

Re: модернизация ZG S5-150U на S7-400
Андрей Гуленок; 18.12.02

Я бы не стал утверждать так категорично. Есть же IM463-2 к которому можно подоткнуть IM314, воткнутый в соответствующую корзину расширения 115-го или 135-го. И есть список модулей, с которыми всё это протестировано. Но само собой, всякие раритеты от 150-го туда не входят. Это не значит, что такая конструкция невозможна, но Сименс заявляет, что это не тестировалось, а посему на свой страх и риск. Если это экономически оправдано, можно прикупить этот модуль и провести нировские работы, но как правило живые 150-ки уже физически изношены и логичнее вывести их в ЗИП, чем пытаться выжимать последние капли.


text

Документация на Step 7
MCMak...; 9.12.02

Подскажите где добыть документацию по Step 7 на русском языке...

С уважением МСМак...
См. Step 7

Re: Документация на Step 7
Любитель Симатика; 10.12.02

Ё-мое! Неужели народ вообще по сайту не ходит! Даже ФАКу написали по этому поводу и на открытое место положили, видно создателей тоже достали!

Re: Документация на Step 7
NC-1@mail.ru; 17.12.02

А можно ответить на вопрос без комментариев?

Re: Документация на Step 7
Михайлин Сергей; 17.12.02

В чем то любитель прав. Но все-таки...

Вся документация на русском языке лежит в соответсвующем разделе продуктов, что и написано в FAQ, ссылка на который дана с права, а еще описние этого лежит в Поддержке
См. Вот здесь

Re: Документация на Step 7
MCMak...; 18.12.02

Большое спасибо за советы, по сайту действительно лазил плохо (Re: любитель Симатика), но непосредственно доков на программирование по Степ 7 я не нашел как не крути... На англицком есть например Programming with Step 7 все просто как в танке, а ежели на русском также??? Так нет же. А в ближайшем представительстве Сименса, ненавящево развели руками: "Мол сами страдаем", и показали многотысячные труды на немецком языке...

С уважением МСМак...
Re: Документация на Step 7
Михайлин Сергей; 18.12.02

Стоп, а что же лежит по сцылке?! По-моему, как раз программирование на STEP7. А в каком центре центре это было? По идее, туда можно прийти с болванкой и Вам прожгут нужную доку, если нет готовой коллекции.

См. Вот тут

Re: Документация на Step 7
MCMak...; 18.12.02

Пока не могу объяснить каким образом я не наткнулся на эту документацию. :-(

Когда я не очень преуспел в своих поисках я начал закачивать все подряд. Скачал 77 Mb, на этом мой ИНет умер. Такого как Вы показали я все же не нашел признаю свою беспомощность и кланяюсь перед Вами Сергей за помощь. Вроде все!
С уважением МСМак...


text

GSD файл
CM35; 10.12.02

Подскажите где можно достать файл GSD для этого модуля.

Re: GSD файл
Aleksey; 10.12.02

Посмотри тут http://www.profibus.com/

Re: GSD файл
Михайлин Сергей; 10.12.02

Profibus здесь ни при чем и GSD файл здесь не поможет! СМ35 это не Profibus устройство, а полноценный модуль счета S7-300, и чтобы он появился в HW Config надо поставить его родной софт для его параметрирования.


text

требуется специалист по Simatic S7
МПНУ; 22.10.02

Для программирования и настроийки котроллера S 7 ищем специалиста, имеющего опыт подобной работы.

Re: требуется специалист по Simatic S7
t55@rbcmail.ru; 23.10.02

Можно подробнее и конкретно какой срок?

Re: требуется специалист по Simatic S7
МПНУ; 23.10.02

Автоматизация теплоэнергетического оборудования (водоподогревателей, насосов, резервуаров)с программированием котроллера.

Сбор данных о работе котлов, горелок.
Обрудование в работе. Комплектиация Siemens - полная. Небольшие недолки по монтажу щита Siemens.
Работа на 2-х ангалогичных объектах по очереди. Ориентировочный срок на оба объекта - 3 мес. Объекты в разных регионах.
Важно: опыт подобной работы.
Re: требуется специалист по Simatic S7
t55@rbcmail.ru; 24.10.02

Господа! S7 бывает S7-200, S7-300, S7-400 и далее. Мониторин через ProTool Lite или Pro, WinCC или другой SCADA системой. Отображения через компьютер или ОР панели оператора. Количество сигналов аналоговых и дискретных(входа и выхода). Наличие программного обеспечения и адаптеров, программаторов. Документация на разработанное ПО или Спецификации для ПО. Если всё в работе то неясна задача. Пульт доделают КИПовцы. Может Вам нужна оптимизация работы оборудования? Стадия работ - переделка или эксплуатация, сопровождение? Одному можно сопровождать, а переделовать нужна кантора. Похоже Вы пытались экономить по мелочи, а это не допустимо!

Re: требуется специалист по Simatic S7
Технополюс; 24.10.02

Вопросы те же, но переделать или допроектировать - вопросов нет.

www.technopolus.ru
Re: требуется специалист по Simatic S7
МПНУ; 24.10.02

S-7-300, WinCC, и копьютер и панель. Остальное в проекте.

Стадия - ввод системы автоматизации иа уже работающем технологическом оборудовании.
ПО разрабатывается. Имеются некоторые сомнения как в работоспособности ПО, так и в сроках его сдачи.
Возможен вариант заключения контракта для осуществления функций технадзора и пусконаладки.

Re: требуется специалист по Simatic S7
Виталий ; 7.12.02

Какая конкретно работа


text

Измерение частоты в SIMATIC C7-626
Денисов Сергей; 26.11.02

Люди помогите, кто пользовался универсальными входами в SIMATIC C7-626 в частности для измерения частоты-можно ли измерять частоту переменного напряжения? или только частоту импульсов; если есть пришлите примеры измерения частоты по адресу: psv@energomash.ru

Re: Измерение частоты в SIMATIC C7-626
Чистяков Дмитрий ОАО "СеверСталь"; 29.11.02

Начнём с того, чтобы измерить частоту переменного напряжения, в полне достаточно двух диодов и двух резисторов. Которые срежут отрицательную полуволну переменного напряжения, а резисторы ограничат входное напряжение на входы, до требуемого уровня.

Теперь вопрос. А частоту какого напряжения предполагаете измерять?
Это не 220 В?

Для того, чтобы достичь точночти измерения 10%, частота опроса входа должна быть больше измереямой частоты как минимум в 10 раз. Т.е. для 50Гц это будет 500 Гц. Или скан контроллера должен быть равен 2мс.
Само собой такого быстродействия от C7 ждать не стоит. Для таких целей используются специальные модули счётчиков (например, FM350-1,FM350-3, FM351). Такой модуль можно, например, установить во внешнюю станцию ET200.

Re: Измерение частоты в SIMATIC C7-626
Илья; 5.12.02

Абсолютно не согласен с Дмитрием! Универсальные входа замечательно используются и отлично работают. Кстати, частоту можно мерить через период. А С7 берет 100Гц сигнал с Тимп=100мкС с точностью 1%


text

виснут Simatic'и 300 и 400 серий
Mike Lourier; 27.9.02

Периодически зависают PLC разных моделей S7. Есть, возможно, проблемы с питанием, но стоят БП серии Sitop, через которые помехи, я считаю, проходить не должны. Что может быть? Как отследить? Что предпринять? Помогает только перезагрузка зашитой программы.

Re: виснут Simatic'и 300 и 400 серий
siemargl; 28.9.02

посмотреть диагност.буфер

Re: виснут Simatic'и 300 и 400 серий
t55@rbcmail.ru; 23.10.02

Хорошо помогают блоки непрерывного питания UPS. А относительно помех которые на пром предприятии то вещь гадостная. Судя по реакции, если много оборудования нужен мотор генератор или независимый фидер.

Re: виснут Simatic'и 300 и 400 серий
A.Gorski; 29.11.02

Используете ли вы передачу сообщений через PDIAG. Если да, то причина может быть в частоте и количестве передаваемых сообщений.

Re: виснут Simatic'и 300 и 400 серий
Mike Lourier; 29.11.02

Нет, не используем.

Re: виснут Simatic'и 300 и 400 серий
Чистяков Дмитрий ОАО СеверСталь; 29.11.02

Дык а что пишет пишет буфер сообщений CPU?

Re: виснут Simatic'и 300 и 400 серий
Mike Lourier; 29.11.02

Да ничего не говорит. Системные сообщения иногда бывают.

Но, кажется, мы избавились от этой проблемы запуском новой электроподстанции и соответственно прокладкой новой ветки электропитания из городской сети. Видимо, проблемы были из-за электропитания.


text

куплю адаптер
Papik; 28.11.02

куплю адаптер

HMI ADAPTER 6ES7 972-0CA10-0XA0
или
HMI ADAPTER 6ES7 972-0CA11-0XA0


text

отличие адаптеров
Papik; 25.11.02

Подскажите в чем отличие

адаптеров
6ES7 972-0CA23-0XA0
от 6ES7 972-0CA32-0XA0 , 6ES7 972-0CA11-0XA0


text

S5 <-> FieldPg
Sinbad; 25.11.02

А какой кабель нужен для программирования S5 c помощью программатора FieldPG.

Заранее спасибо.
Сергей.


text

Помогите перепрошить флэшку
Денис; 11.11.02

Знатоки S5, помогите! Возникла следующая проблема: не могу перепрошить флэшку сименсовским софтом. Нужно для переконфигурирования существующей сети PROFIBUS.

Имеется:
- софт: COM-PROFIBUS V3.3 и V5.1;
- железо: программатор Siemens Field PG, модуль IM-308C с FLASH-картой 6ES5-374-1KH21 в составе корзины контроллера S5-115 CPU-944B;

При попытке считать информацию с флэшки
COM-PROFIBUS версии 3.3 выдает "не установлен драйвер EPROM TSR",
а версия 5.1 - "неизвестный формат файла".

В STEP V5.1 флэшки читаются, а в COM-PROFIBUS нет - т.е. программатор рабочий. В чем проблема? М.б. нужны какие-нибудь Hot fix'ы для COM-PROFIBUS к данному типу программатора?

Ответы слать директом на мыло: kdv@fromru.com

Заранее благодарен. Денис.
Re: Помогите перепрошить флэшку
Чистяков Дмитрий ОАО "СеверСталь"; 11.11.02

Скорее всего, модуль был за параметрирован при помощи программы ET200. Это старая DOS-программа. Все форматы там другие и потому нет ничего удивительного в том, что она не читается. ;-)

Re: Помогите перепрошить флэшку
Денис; 12.11.02

2 Чистяков Дмитрий ОАО "СеверСталь"

Вечный вопрос: Что делать?
Судя по нижеописанному СОМ ЕТ WIN переименован в COM PROFIBUS, а СОМ ЕТ WIN понимает формат СОМ ЕТ DOS?

Compatibility: COM PROFIBUS, version 3.0, is fully upward compatible with versions 1.0 and
2.x of COM ET 200 Windows. IM 308-C or S5-95U DP Master program files and
memory cards generated with version 1.0 or 2.x can be read with COM PROFI-
BUS, version 3.0. Files or memory cards programmed with COM PROFIBUS will execute on an IM 308-C with version 1 to 5, provided the function expansions of version 3.0 are not used. If the function expansions of version 3.0 are to be used on the IM 308-C, revision level 6 is required.

Денис
Re: Помогите перепрошить флэшку
Грузевич Олег, Екатеринбург; 14.11.02

Вот что ответила на этот вопрос техническая поддержка:

На Field PG под Windows 2000 Pro вы можете использовать только COM PROFIBUS V5.1. Eprom драйвер V3.3 не работает с EPROM-устройством на Field PG.
Работа V5.1 под DOS подобна работе V3.3.
Flash-карты, запрограммированные на V3.3, могут быть прочитаны V5.1.
В Вашем случае, если Вы получаете сообщение "Unkown format", значит, модуль был запрограммирован очень старой версией называющейся COM ET200. В этом случае, пожалуйста, используйте другой PG /PC с EPROM программатором и работайте с V3.3 для импорта из этого старого модуля.
V5.1 не способна прочитать файлы/модули созданные с COM ET200.

On Field PG under Windows 2000 Pro you may only run COM PROFIBUS V5.1. The
Eprom driver of V3.3 is not working with the EPROM-AS of the Field PG. If you run the V5.1 under DOS it is like running V3.3.
Flash-cards programmed on V3.3 may be read by V5.1. So if you get the
message "Unkown format" the modul was made by a very old version called COM
ET200. In this case please use an other PG /PC with Prommer and run V3.3 to
Import this old Modul. The V5.1 is not able to read files/moduls created by
COM ET200.

Your Technical Support for Automation & Drives
Petra Braun
Re: Помогите перепрошить флэшку
Грузевич Олег, Екатеринбург; 25.11.02

Исходная программа считана из IM 308-C через сеть с помощью COM PROFIBUS V5.1 (File-Import-DP Master).

Flash-карта памяти "прошита" с помощью Field PG и COM PROFIBUS V5.1.


text

Соединение контроллера по Modbus
Хлопин Денис; 23.9.02

Имеется контроллер S7-400 (Redconnect) , два модуля CP 411-2, и коннекторы RS232-C, нужно соединить контроллер с поточным компьютером OMNI, который поддерживает протокол MODBUS RTU(больше никакой не поддерживает), приобрел пакет MODBUS MASTER. Посмотрел пример, разобрался.

Проблема в том, что CP-411 не может обнаружить связь(это мне функция сообщает), а на CP мигает лампочка fault1! Кабель подключен правильно!!!
Если кто имел дело с MODBUS RTU, будьте добры, помогите!

Re: Соединение контроллера по Modbus
siemargl; 24.9.02

Подключить "подслушку"-терминал и посмотреть запрос-ответ. Вообще, сочувствую-проблема неприятная.

Re: Соединение контроллера по Modbus
Assa; 9.10.02

1. Проверте распайку соединительного кабеля.

2. Возьмите пример стандартной программы Modbus, настройте его для вашей конфигурации (задав аппаратный адрес СР) организовать связь. После этого используйте его в качестве скелета Вашей программы.

Re: Соединение контроллера по Modbus
Modbus симулятор; 20.11.02

Сабж запускается на РС и общается на RS232 по модбасу. Возможны различные установки модбаса (мастер\слейв, етс). Могу выслать директом.


text

Сброс SIMATIC S5. Останется программа?
Владимир; 1.11.02

Не включается

Выдает ошибку
$613 DB-Fehler
Nr.11 (0;63)
Я так понял нужен общий сброс.
будет ли контроллер после этого работать без перепрограммирования
Re: Сброс SIMATIC S5. Останется программа?
Ольштейн Эдуард ОАО "Мечел"; 1.11.02

Уточните следуюшие вещи, тогда возможно получите от кого-нибудь ответ.

1. Какой контроллер не включается (семейство контроллеров 115U, 100U и т.д и какой тип CPU используется CPU 944,CPU943,CPU102....)
2.На каком устройстве Вы смотрите ошибку $613.
3.Стоит ли процессоре или блоке питания батарейка и не горит ли светодиод "BATT LOW" ("BATTERY OFF/LOW)
Re: Сброс SIMATIC S5. Останется программа?
Владимир; 1.11.02

Контроллер 95U

CPU Главный процессор 80С537
Связной процессор V25+ c SPS
Код $613 смотрю на консоли оператора
Батарейка стоит

Раньше он не переходил в режим RUN (горел красный светодиод STOP).Cделали полный сброс RUN светится но ошибки остались и постоянно запрашивает LOAD DATA и затем выдает ошибки
Re: Сброс SIMATIC S5. Останется программа?
Alex; 1.11.02

Конечно после общего сброса

программы в контроллере не осталось
и его нужно заново перепрограммировать.
Re: Сброс SIMATIC S5. Останется программа?
Рябов Андрей; 1.11.02

Установлен ли в CPU субмодуль EPROM'а (оранжевый такой); каким образом проделали общий сброс и что делали после него? Посмотрите есть ли программа в PLC вообще.

А ошибка сообщает, что (цитирую) "блок данных отсутствует или слишком короткий" - DB11.
Re: Сброс SIMATIC S5. Останется программа?
Владимир; 1.11.02

Тогда почему не происходит сброса ошибок?

Re: Сброс SIMATIC S5. Останется программа?
Владимир; 1.11.02

CPU субмодуль EPROM'а не установлен

Общий сброс без программатора:
> Установить переключатель выбора режима в положение "STOP"
> Изъять батарею
> Установить переключатель ON/OFF в положение "О"
> Установить переключатель ON/OFF в положение "1"
> Вставить батарею
Re: Сброс SIMATIC S5. Останется программа?
Владимир; 1.11.02

А посмотреть программу некак

есть только пульт оператора
Re: Сброс SIMATIC S5. Останется программа?
Рябов Андрей; 4.11.02

После общего сброса программа из PLC удалена. И поскольку EPROM'а нет, то ей(программе) неоткуда взяться. Соответственно в PLC нет нужных блоков данных и соответственно на OP будет указанная ошибка поскольку OP пытается прочитать данные, а их, сами понимаете, там нет. Вам необходимо восстановить программу в PLC. Для этого нужно иметь либо субмодуль EPROM с актуальной программой, либо иметь эту программу на дискете и STEP5, чтобы загрузить её с компьютера.

Re: Сброс SIMATIC S5. Останется программа?
eprst; 4.11.02

похоже кирдык, исходники не сохранились

Re: Сброс SIMATIC S5. Останется программа?
Дмитрий; 20.11.02

Владимир,

Рекомендую Вам для решения проблемы узнать у своих коллег, что такое система DeltaV


text

Данные из COROS LS-B
Эрнест; 31.10.02

Всем добрый день!

Ситуация такая:
на нашем заводе внедряется общезаводская система на базе PI System, в связи с чем необходимо достовать данные из системы COROS LS-B. Согласно описанию данная система может выкладывать архивы в виде *.dbf файлов на подключенный диск Novell. но как это делается никто не знает.

Если кто сталкивался с подобной проблемой, и/или знает ее решение буду признателен за любой ответ.
Re: Данные из COROS LS-B
Чистяков Дмитрий ОАО "СеверСталь"; 10.11.02

Какие архивы вам нужны?

1. Архивы сообщений (ALARM)
2. Архивы данных (измеряемых значений)
Re: Данные из COROS LS-B
Дмитрий; 20.11.02

Здравтвуйте, Эрнест.

Мануал по пресловутой COROS доступен на русском языке, как говорится на http://www.automation-drives.ru/as/support/Manual_Rus_0501.xls. Поэтому рекомендую обратиться к Павлу Иванову (pawel.iwanow@siemens.com) за подробными рекомендациями.
Надо воспитывать заказчика. чтобы он не пытался затевать "Автоматизацию по кускам".


text

Как лучше организовать обмен м/у 313С и 215-2
Алексей; 20.11.02

Подскажите кто знает, как лучше организовать обмен м/у 313С и 215-2, если максимальное расстояние м/у ними 300 метров и один из них находится на подвижной установке. Есть возможность укладывать кабель в лоток, но тогда это будет не слабая катушка.

Re: Как лучше организовать обмен м/у 313С и 215-2
Андрей Гуленок; 20.11.02

Лучше через профибус. Оснащаете 313 профибус СР и прокладываете гибкий кабель для подвижных механизмов.


text

С7-621
Сергей; 16.11.02

Подскажите, где можно найти документацию на С7-621.

Заранее благодарю.
Re: С7-621
Чистяков Дмитрий ОАО "СеверСталь"; 19.11.02

http://www4.ad.siemens.de/news/cs/en/6968371

http://www4.ad.siemens.de/news/cs/en/6968921

http://www4.ad.siemens.de/news/cs/en/1140726

http://www4.ad.siemens.de/news/cs/en/11407264328169


text

Редукторы Bauer, Lenze, Noma, Eisenbeiss, Siemens, Flender, Tandler, Pfaff, Albert
Андрей; 13.11.02

Помогите, пожалуйста, найти информацию о производителях редукторов: Bauer, Lenze, Noma, Eisenbeiss, Siemens, Flender, Tandler, Pfaff, Albert, Alpine.

Re: Редукторы Bauer, Lenze, Noma, Eisenbeiss, Siemens, Flender, Tandler, Pfaff, Albert
Baby; 14.11.02

Привет, Андрей !

Набираете в своём любимом поисковом сервере эти фирмы, потом переходите по найденным ссылкам на сайты вышеупомянутых фирм и там находите ответы на все волнующие, Вас вопросы......
Пока.......


text

PID регулятор
Рукин Дмитрий ОАО "Северсталь"; 11.11.02

Господа, подскажите, где бы найти рекомендации фирмы Siemens по настройке и применению оных регуляторов

при условии что время скана должно не превышать определенную величину. Дело в том, что когда подгружаю блок ПИД регулятора и его обработку время скана возрастает до невероятных размеров
Re: PID регулятор
Baby; 11.11.02

Привет, Дмитрий !!!!

Про какие именно регуляторы Вы спрашиваете ???
Фирменные Siemens или .....
Дока на сайте http://www.aud.ru/ по ПИД есть.....
И кстати для каких процессов Вам нужен регулятор ??????

Пока.....
Re: PID регулятор
Чистяков Дмитрий ОАО "СеверСталь"; 11.11.02

Вообще для этих целей используется специальный софт. Например:

Standard PID Control
Modular PID Control
PID Self-Tuner

http://www.automation-drives.ru/as/products/07_is/04_man/index.shtml

По подтекстному вопросу (выснилось при личном общении) нужна была таблица быстродействия для различных CPU.


text

СМ35
Андрей; 1.11.02

Подскажите есть ли пример программы для того чтобы получить на выходе этого модуля сигнал "п" образной формы с какой-то частотой от изменяющегося параметра. И также пример описывающий его подключение к С7633DP.

Re: СМ35
Чистяков Дмитрий ОАО "СеверСталь"; 10.11.02

Для подключения этого модуля Вам придётся установить станцию ET200M.

Но чем мучаться таким образом, вам будет проще использовать модуль 2 PULSE из серии ET200S.
6ES7138-4DD00-0AB0
SIMATIC DP, ЭЛЕКТРОННЫЙ МОДУЛЬ ДЛЯ ET 200S; 2-КАНАЛЬНЫЙ МОДУЛЬ ГЕНЕРАТОРА ИМПУЛЬСОВ И ТАЙМЕРА, ШИРИНА 15MM


text

Куплю...
Рябов Андрей; 16.10.02

Доброго времени суток!

Нужен модуль счёта для S5-115/135/155:
6ES5281-4Uxxx

Есть ли кого?
Re: Куплю...
AmstronTech Ltd; 8.11.02

1) 6ES5281-4UA12 - $1400.00

2) 6ES5281-4UP12 - $1640.00

Delivery: 2-3 weeks


text

Старые CPU S5. Где искать информацию?
AndySher; 1.11.02

В старом станке Kieserling стоит контроллер S5-155U. В нем имеются стоящие рядом модули

6es5946 3ua23
6es5947 3ua22
6es5355 3ua11
В каталоге 2002 года этого хозяйства уже нет. Нет даже упоминания, что это. Понятно, что один из них - CPU. А дальше ?
Вопрос такой. Где можно по заказному номеру взять и найти файл с информацией хотя бы на английском языке?

Re: Старые CPU S5. Где искать информацию?
Baby; 2.11.02

Привет, AndySher !!!

Как настроение ?????
Постараюсь несколько философски ответить на Ваш вопрос.....
Как следует из названия станка 'Kieserling' фирма германская (а может и нет, но не суть важно), это значит, что во время монтажа и пуско-наладочных работ со стороны фирмы была оставлена Полная (!!!) документация по данной теме... Благо у иностранных фирм есть негласный закон оставлять Заказчику максимум информации (кроме ноу-хау),что бы в дальнейшем их не беспокоили ( к тому же бесплатно)...

А вот и более дельная информация с моей стороны, покопайте здесь:

http://www.sps-reparatur.de
http://www.juneusa.com/

Удачи............

Re: Старые CPU S5. Где искать информацию?
Худяков Александр; 4.11.02

А может быть не стоит так сильно мучаться а просто посмотреть по быстрому переходу (см. меню правее)всю информацию по S5, в т.ч. и каталог за 98 год на русском языке.

Re: Старые CPU S5. Где искать информацию?
Гуленок Андрей; 4.11.02

Справа есть ссылка, частозадаваемыевопросы. Там подробно расписано, где и как искать документацию. А указанные позиции это две половинки CPU 946/947 от S5-155 и плата контролера памяти. Все платы уже безнадёжно устарели и сняты с производства. Из каталогов они исчезли году так в 94.


text

СМ35
Андрей; 1.11.02

Подскажите есть ли пример программы для того чтобы получить на выходе этого модуля сигнал "п" образной формы с какой-то частотой от изменяющегося параметра. И также пример описывающий его подключение к С7633DP.


text

Про LOGO!
Павел; 31.10.02

Кто-нибудь подскажите, как в LOGO!SoftComfort Задействовать модуль расширения LOGO!ASi вместе с ...-0ВА3

(24/16 вх/вых все нужны).
КАК задействовать ASi выходы...???


text

Параметрирование блока DB1
Валерий; 30.10.02

Требуется информация по программированию блока DB1 для процессора CPU 928B (DB screen).


text

Ремонт блока питания.
Ольштейн Эдуард ОАО "Мечел"; 30.10.02

Блок питания 6ES5 951-7LD12 (220B, 7A/15A S5-115) достаточно часто приводит к переходу СРU в сотояние STOP.

Предпологаю, что неисправность PS типична, буду благодарен за совет.
P.S. Проблема именно в блоке питания, а не в сети, модулях и т.п.
P.P.S. Услуг по ремонту не предлогать, пока.


text

S5
Sinbad; 30.10.02

В исходнке Step 5 есть следущий сегмент:

A F 100.6
A I 28.4
A Q 47.5
= F 200.1

AN F 200.1
NOP 1

C DB 29
L DW 139
T DW 137
NOP 1

AN I 28.5
NOP 1

C DB 29
L DW 138
T DW 137
NOP 0

После конвертирования программы mc5 -> seq получается файл с расширение ****А0.SEQ , и в этом файле сегмент выглядит так:

U M 100.6
U E 28.4
U A 47.5
= M 200.1

UN M 200.1
SPB = 7

A DB 29
L DW 139
T DW 137
SPB = 8

UN E 28.5
SPB = 5

A DB 29
L DW 138
T DW 137
NOP 0

Т.е. "NOP 1" заменяется на "SPB= " и выдается ошибка. Но программа рабочая (работает в данный момент) и по работы условные переходы SPB= стоят правильно, но в исходнике вместо них NOP 1.

Может быть кто-нибудь встречался с подобным. Буду признателен за любую подсказку.


text

Создание Help'а для блока
Николай Федун, АО АНХК; 1.10.02

Уважаемые участники форума,

Поделитесь информацией, если кто знает, можно ли создать Help для собственного блока, написанного на SCL, STL и т.п.? Чтобы он вызывался нажатием F1.

С уважением,
Николай.
Re: Создание Help'а для блока
Михайлин Сергей; 1.10.02

Описание процедуры создания on-line help описана в документе по ссылке ниже в главе 3. Это правда документ относится к PCS7, но это все равно дейтсвует и на обычные блоки.

См. Файл

Re: Создание Help'а для блока
Николай Федун, АО АНХК; 29.10.02

Уважаемый Сергей!

Спасибо огромное за ссылочку! Извините за долгое молчание, нет времени попробовать, занят на других объектах. А PDF почитал, должно получиться.

С уважением,
Николай.


text

S5 -> S7
Sinbad; 25.10.02

Добрый день.

Занимаюсь сейчас конвертацией программы из S5 в S7. Некоторые FB в S5 зашиты в ПЗУ SIMATICа 5. В Step 7 есть специальная библиотечка для замены этих блоков. Мне встретились блоки FB250 и FB251, для преобразования значений сигналов для ввода-вывода. Для FB251 замена FB108, а для FB250 я замены в библиотеке Step 7 не обнаружил. Может быть кто-нибудь из вас встречался с такой ситуацией. Буду презнателен за любую помошь.

См. http://Sin-bad.narod.ru


text

Измерение температуры (6ES7 431-7QH00-0AB0)
Маруськевич Сергей; 18.2.02

Объект измерения - жидкий металл в пром. ковше МНЛЗ (машина непрерывного литья заготовок). Температуру измеряют термопарой (погружают ее в металл), которая "живет" всего 4-7 секунд. Можно ли с помощью стандартного сигнального модуля, например 6ES7 431-7QH00-0AB0, ПРАВИЛЬНО найти "площадку" измеряемой температуры? Дело в том, что мы какое-то время уже измеряем таким способом (со своим алгоритмом нахождения площадки). И только недавно решили набрать статистику и построили график по точкам измерения (время цикла программы 12мс). В результате график получился какой-то «гладкий», т.е. время преобразования (время интегрирования) слишком большое для данной задачи. На самом деле колебания температуры на графике должны быть значительными. Что можете посоветовать. Спасибо.

Маруськевич Сергей
АО «СеверСталь»
PS и можно ли вообще измерять температуру так с помощью стандартного сигнального модуля?

Re: Измерение температуры (6ES7 431-7QH00-0AB0)
Чистяков Дмитрий ОАО СеверСталь; 19.2.02

С Андреем Маношиным мы уже пообщались на эту тему по телефону. Но и сюда ещё отвечу.

Указанный Вами модуль слишком медленный для Вашего применения. А именно, этот модуль при измерении термопары имеет время преобразования 47мс. Преобразование за 20мс происходит при измерении напряжения и тока
Re: Измерение температуры (6ES7 431-7QH00-0AB0)
Маруськевич Сергей; 19.2.02

К сожалению, я в курсе технических возможностях данного модуля. Хочу еще добавить, что 47мс - это время преобразования сигнала только для одного канала, а т.к. преобразование сигналов в данной плате происходит последовательно, то это время можно еще умножить N ( N - кол-во каналов, задействованных в данном модуле). Просто хотелось услашать про альтернативные способы измерения температуры, используя стандартные сигнальные модули. Спасибо за поддержку.

Re: Измерение температуры (6ES7 431-7QH00-0AB0)
aim; 21.2.02

А может лучше использовать стандартные решения для данной области. Например прибор MultiLab фирмы Heraues. Забирать данные с этого прибора можно с помошью DP/RSLink или CP441.

Re: Измерение температуры (6ES7 431-7QH00-0AB0)
Рукин Дмитрий ОАО "Северсталь"; 16.10.02

Наверное, дороговато через Heraues. Но можно зато посмотреть как и что сделано у коллег в соседнем цехе. Так что если что - звони. Андрею привет

Re: Измерение температуры (6ES7 431-7QH00-0AB0)
Baby; 17.10.02

Приветствую !!!!

У нас на УНРС (установка непрерывной разливки стали)сделано так.........
Следующая связка.......
Ferrotron->CP441 и дальше по адресатам....

http://www.ferrotron.de/

Желаю всего...

Re: Измерение температуры (6ES7 431-7QH00-0AB0)
Baby; 17.10.02

Да, чуть не забыл ......

Если, интересно могу подробно рассказать.....
Проект работает и все (имеется ввиду наши любимые технологи {разливщики, операторы и т.д.})дОвОльны........


text

Где найти User manual about Simatic S5
Миклин Глеб; 14.10.02

Уважаемые господа!

Пожалуста подскажите где можноно скачать руководство эксплуатации и техническое описание контроллера Simatic S5, а также о проге Step5?
Заранее благодарен.
Миклин Глеб
Re: Где найти User manual about Simatic S5
Чистяков Дмитрий ОАО "СеверСталь"; 15.10.02

На этом сайте. ;-)

С права от этого сообщения есть "Быстрый переход".

http://www.automation-drives.ru/as/products/05_s5/04_man/index.shtml


text

Помогите переписать EPROM
Илья; 11.10.02

На нашем предприятии две одинаковые упаковочные машины с Simatik S5.

С одной из машин украли плату ПЗУ. Новую плату мы купили, подскажите, пожалуйста, где можно в Москве переписать программу с одной платы на другую.


text

DB1 для CPU928
Валерий; 10.10.02

Скажите как параметрируется блок DB1 для CPU 928 (однопроцессорный режим) Можно ли удалить этот блок и к чему это приведет? Спасибо!


text

SISI 90 - statec
Alexandr; 16.9.02

Доброй сети!

Помогите распознать плату SISI90-statec, похожа на аналог(вх. или вых.), если можно, то инфу по применению.
Спасибо.
Re: SISI 90 - statec
Павел Иванов; 9.10.02

А Вы уверены, что это плата производства фирмы Siemens?

Такое название мне не знакомо.
Все продукты фирмы Сименс имеют стандартные заказные номера, например:
- 6ES5 095... (цифра, две буквы, цифра)
или запчасти C951....
Re: SISI 90 - statec
Alexandr; 9.10.02

Ув. Павел Иванович

спасибо за проявленный интерес.
Эта плата была вставлена в адаптерный модуль Симатика S-115, и имеет маркировку - SISI 90, а на шилдике надпись:
STATEC technologie
Deutschland Gmbh.
Вот и вся маркировка.
Плата похожа на аналог. вх. или вых. 4 канала.


text

Адаптер к S5
Венский М; 12.9.02

Где можно официально можно купить адаптер к S5 в Украину. Рассмотрим все варианты.

Re: Адаптер к S5
Alexandr; 16.9.02

Если не официально,то у нас

Re: Адаптер к S5
Павел Иванов; 9.10.02

Обратитесь в представительство фирмы Сименс в Киеве:

Бекетов Александр Александрович
(044) 201-2374
(044) 201-2466
oleksandr.beketov@iev.siemens.com.ua


text

слетели установки контроллера PCS-36 недоступные userу.
U2; 23.9.02

После снятия аккумулятора слетели установки контроллера PCS-36 на пайке волной SEHO недоступные userу. Может кто подскажет как их коректировать?

Re: слетели установки контроллера PCS-36 недоступные userу.
Павел Иванов; 9.10.02

А что это за контроллер?

Это контроллер производства фирмы Сименс?
Есть его заказной номер?


text

Соединение SIMATIC S5 <->PC (RS232)
Стас Степанов ; 19.8.02

Добрый день!

Помогите соеденить контролер с ноутом.
Интерисует есть ли стандартный кабель для этого соединения? Может у кого есть схема распайки?!
Re: Соединение SIMATIC S5 <->PC (RS232)
aim; 19.8.02

Знакомая проблема. Сходите на сайт www.runmode.com, так есть схема конвертора RS->TTY

Re: Соединение SIMATIC S5 <->PC (RS232)
Eleria; 5.10.02

А www.runmode.com когда бывает доступен

(похожая проблема)
Помогите ПЛЗ
Re: Соединение SIMATIC S5 <->PC (RS232)
Alex; 8.10.02

посмотри здесь:

http://simatic.nm.ru/


text

Протокол RS-232
Хлопин Денис; 27.9.02

Есть модуль CP 441-2 и подмодуль к нему RS-232C, необходимо настроить связь с внешним устройством(например с принтером), все настройки перепробовал, результат один и тот же - на модуле мигает лампочка fault, что в хелпе означает либо конфигурация не загружена, либо неверно кабельное соединение! Если кто сталкивался, помогите пожалуйста!

Re: Протокол RS-232
Михайлин Сергей; 27.9.02

Как минимум надо загрузить аппаратную конфигурацию из HWConfig, создать и загрузить из NetPro соединение с другим устройством и также надо физически их соединить. А дальше уже писать программу. Удачи.

Re: Протокол RS-232
Anatoliy; 27.9.02

Привет ! Желаю тебе успехов в этом

нелегком деле!
Re: Протокол RS-232
Eleria; 5.10.02

Есть прибор с RS-232S выдает данные на СОМ порт и программа их читает.

Не подскажите нет ли просто драйвера для СОМ порта что бы с обычного ПК через СОМ порт можно был бы прочитать данные с RS-232S или др похожего интерфейса ?
Re: Протокол RS-232
Чистяков Дмитрий ОАО "СеверСталь"; 7.10.02

Так а Вы описание на CP441-ый читали?

Главу 9. Там все протоколы описываются.

Re: Протокол RS-232
Хлопин Денис; 7.10.02

Кому интересно, я разобрался в своей проблеме. Просто в NetPro надо было в таблицу (connection table) добавить соединение, ее(таблицу) можно найти нажав на CPU! Дальше уже можно читать описание на CP-441.


text

EPROM_Help
Eleria; 24.9.02

подскажите можно ли использовать

EPROM с одного контролера для хранения
программы и использования в другом
Мой начальник утверждает что нельзя
другого варианта нет т.к. EPROM вышел из строя но есть резервная копия программы.....
Подскажите кто прав и почему ??? PLZ
Re: EPROM_Help
Валерий; 25.9.02

Привет! Если контроллеры идентичны, то конечно же можно. Надо лишь прошить EPROM, предполагаемый к использованию в другом процессоре

Re: EPROM_Help
Eleria (slayer); 29.9.02

Что значит "Контролеры идентичны" т.е.

Вы хотите сказать что на определенные типы процессоров необходима определенного типа память ????

Нельзя ли по подробней осветить этот вопрос и/или дать ссылки на информационные сайты по этому вопросу.

С благодарностью Eleria
Re: EPROM_Help
Рыбаков Михаил; 1.10.02

Если контроллеры имеют одинаковые области , к которым обращается программа (входы, выходы, периферия), то этот "Епром" может спокойно использоваться на любых типах контроллеров, если они поддерживают все используемые командыюТ.Е. С 90-го на 135- нет проблем, а со 135 -на 90 могут быть, т.к. у 135 много команд, функции которых в 90-м реализованы через FB или вообще отсутствуют!!!

Кроме того, например, в 95-м одним модулем можно как дискетой запрограммировать несколько ЦПУ!
Re: EPROM_Help
Eleria; 5.10.02

Спасибо :))

Кстати есть ли возможность програмирования встроиеных FB и OB ???
Спасибо за помощь....


text

Термометр 100П и Pt100
Константин; 18.9.02

У SIEMENSа есть входы градуировки Pt100 по DIN EN 60 751 (IEC 751), причем имеется два диапазона стандартный (-200 ... +850 град. С) и климатический (-120 ... +130 град. С). Входные сигналы по DIN линеаризуются и масштабируются в соответствии с выбранным диапазоном. Все бы хорошо, но градуировки по ГОСТ(градуировки 100П по ГОСТ 6651-94) и DIN не совпадают из-за различных марок платины, из которых изготавливаются термометры у нас и в Германии. Т.е. получается, что выбрав на модуле тип входа Pt100, мы получаем в контроллере значение температуры соответствующее сопротивлению "их" термометра и нужно сначала проделать "делинеаризацию" и определить сопротивление, а затем кусочно-линейной функцией произвести линеаризацию для градуировки 100П. Есть ли другие предложения и кто-либо сталкивался с этой проблемой?

Re: Термометр 100П и Pt100
Чистяков Дмитрий ОАО "СеверСталь"; 18.9.02

В скором времени Siemens вводит в свой софт и хард поддержку российских термопар.

Эта информация у меня от г-на Гуленка.
К стати он активно интересовался текущими ГОСТами, действующими в России и статистикой - какие коэфициенты чаще используются на российских просторах.
Re: Термометр 100П и Pt100
Илья; 2.10.02

Подключайте как резистор. Таблицы градуировки есть. Х-ка обычно линейная.

См. http://www.industrialauto.ru

Re: Термометр 100П и Pt100
Андрей Гуленок; 3.10.02

Вопрос конечно интересный. В ГОСТ 6651-94 (это действующий на сей момент) фигурируют 2 коэффициента наклона для ПТ100 1,3910 и 1,3850 причём коэффициенты совершенно равноправны. Первый, это так называемая градуировка 22, а второй - DIN. Соответственно при выборе термосопротивлений лучше ориентироваться на наклон 1,3850. А если датчик старый, то он скорее всего будет иметь наклон 1,3910. Тогда только пересчитывать. Или не обращать внимание, благо расхождение кривых на 200-ах градусах не превышает градуса.

Вообще, действующие госты приведены в соответствие с международными и при выборе новых датчиков имеет смысл ориентироваться на DIN-совместимые части стандартов, а для ретрофита использовать SITRANS который можно настроить на любые параметры.
А на счёт внедрения градуировок в Симатик, то в первую очередь будем стараться расширить диапазон отсутствыющими градуировками, такими как Cu100, хромель-алюмель и т д, а уж во вторую вводить дублирующие градуировки национальных стандартов.


text

SOS!!! Как замасштабировать Pt100?
Сычёв А.; 26.7.02

Имею в наличии AI 6ES7 331-7KF01-0AB0

и датчик PT100 -50..500 C.
Стандартная функция FC105 неподходит.

Re: SOS!!! Как замасштабировать Pt100?
aim; 29.7.02

Какой диапазон измерения и тип подключения?

на E-mail плииз
Re: SOS!!! Как замасштабировать Pt100?
Сорокин В.; 29.7.02

У меня правда 6ES7 331-7KВ01-0AB0, но может похоже будет.

В HW config открыл Properties, выбрал модуль, адрес выбран, галку в System Selection, в Inputs: Hardware Interrupt галку, Measuring Type - RT, Measuring Range - Pt 100Std. Потом читаю градусы - получаю с точностью до 0.1 без преобразования.
Может я что-то неионял в вопросе?
Re: SOS!!! Как замасштабировать Pt100?
Ефременко Денис; 24.9.02

Модуль 6ES7 331-7KF01-0AB0 тоже аппаратно содержит таблицу перевода PT100. Так что действия такие же, как описал Сорокин В.

Re: SOS!!! Как замасштабировать Pt100?
Ефременко Денис; 24.9.02

..да, и еще: выходное значение получается на порядок завышенным, так что для получения реальных градусов раздели входное значение на 10.

Re: SOS!!! Как замасштабировать Pt100?
Сорокин В.; 24.9.02

Точно, в 10 раз больше, ну и пусть.

Re: SOS!!! Как замасштабировать Pt100?
Сычёв А.; 26.9.02

Большое Всем спасибо!

Всё получилось!


text

Upgrade процессора
Наивный Вопрос; 25.9.02

Кто-нибудь знает, существует ли готовое решение в виде IM или ET, позволяюшее подключить периферию старых Симатиков - S3, S5-110, S5-150A/K к S7?

Re: Upgrade процессора
Андрей Гуленок; 25.9.02

Нет, такого решения нет. К S7-400 можно подключить только модули от S5-100/115/135.


text

help,please!
женя; 25.9.02

повторно

очень нужна схема источника питания
6ES5951-7ND12.
подскажите хоть где искать,
уже весь интернет облазил


text

EPROM_Help
Eleria; 24.9.02

подскажите можно ли использовать

EPROM с одного контролера для хранения
программы и использования в другом
Мой начальник утверждает что нельзя
другого варианта нет т.к. EPROM вышел из строя но есть резервная копия программы.....
Подскажите кто прав и почему ??? PLZ


text

Программирование SIEMENS
Панов Сергей; 24.9.02

Помогите !

Нужно запрограммировать S7-400.
Перепрошился с помощью адаптера 6ES7972-0ca21-0xa0 раза три, потом перестал. Пишет ошибку "Online: No other partner can be found." Поменял адаптер на 6ES7901-2BF00-0AA0 (подумал что в адаптере проблема). Та же самая ошибка. Под рукой нашёлся S7-300 номер ошибки не изменился. Я думаю, что оборудование исправно. Если кто знает в чём причина, принимаю любую помощь, советы...


text

Соединение контроллера по Modbus
Хлопин Денис; 23.9.02

Имеется контроллер S7-400 (Redconnect) , два модуля CP 411-2, и коннекторы RS232-C, нужно соединить контроллер с поточным компьютером OMNI, который поддерживает протокол MODBUS RTU(больше никакой не поддерживает), приобрел пакет MODBUS MASTER. Посмотрел пример, разобрался.

Проблема в том, что CP-411 не может обнаружить связь(это мне функция сообщает), а на CP мигает лампочка fault1! Кабель подключен правильно!!!
Если кто имел дело с MODBUS RTU, будьте добры, помогите!


text

CPU315-DP и FM354
Сорокин В.; 22.7.02

Имею FM354 4 штуки. Параметризирую их все. Создаются все SDB. Создаю системные данные, юзер-DB, загружаю всё в CPU. Пока работаю с одним FM354 все хорошо, но как приписываю второй, то на этом конец. Инициализация в OB100 проходит без сбоев, а обращение в OB1 к FC1 для чтения юзер-DB приводит к останову CPU. Пишет, что ошибка адресации I\O. В параметризации модули работают все, управляют приводами, все двигается настраивается. Подскажите, пожалуйста, куда двинуться.

Сорокин В.
Re: CPU315-DP и FM354
Кухаренко Сергей; 13.9.02

Эсли Вы разрешили свои проблемы, то скажите как, если нет, то пришлите Ваш проект для анализа.

Re: CPU315-DP и FM354
Сорокин В.; 23.9.02

Проблемы я решил, спасибо. Как - не помню - давно это было, но постараюсь вспомнить и сообщить. Оборудование уже работает.

Кое-что всё-таки осталось, хотелось бы посоветоваться. Поэтому проект вышлю с вопросами.
Благодарю за отклик.
Владимир Сорокин.


text

FM354
Беликов Алексей; 18.9.02

Каким образом заносятся в модуль координаты исходной точки и точки позиционирования?

Нужна ли коррекция координаты исходной точки при смене датчика?
Можно ли обрабатывать модулем восемь точек позиционирования последовательно от точки к точке без возвращения в исходную точку?
Re: FM354
Кухаренко Сергей ; 18.9.02

Как и многие устройства позиционирования фирмы SIEMENS, FM354 имеет возможность позиционироваться на заданные координаты двумя способами: в режиме AUTO программа или программы находятся внутри самого блока и FM отрабатывает их кадр за кадром; в режиме MDI координаты точки позиционирования вводятся каждый раз через блоки данных и выдаётся команда START.

Т.к. первой операцией перед началом любой операции с FM модулем после выключения питания или перезапуска CPU в автоматическом режиме или MDI необходимо вывести устройство в начало отсчёта (режим REFPOINT), а местоположение этой точки отсчёта привязано к нулевому импульсу ROD-датчика, то любая смена ROD-датчика приводит к нарушению положения нулевого импульса и ,как следствие, к смещению точки начала отсчёта.
Из всеговышеизложенного можно сделать заключение, что модуль может обрабатывать сколько угодно (максимальное значение ограничено только объёмом памяти CPU) точек позиционирования в режиме MDI и ограниченное (ограничено объёмом памяти FM модуля), но достаточно большое, в режиме AUTO.
Re: FM354
Сорокин В.; 23.9.02

Следует только учесть, что имеет место соверненно не объяснимое ограничение:

при 16 кб памяти можно написать только 20 кадров программы.
Чтобы "выкрутиться" приходитсся разбивать на несколько и вызывать их по нисходящей друг из друга. Хотя и этих вызовов неможет быть более 20-ти.
Ну очень не удобно! Да и с функциями что-то не ладно - с нарушением требований стандартов ISO.
Координата нуля оси определяется сигналом концевика и ноль-меткой датчика, а затем можно внести смещение с помощтю MD-SDB. Но можно и определить, что ноль - там, где включили FM.
Пишите. Я сейчас как раз работаю с этим модулем (аж 4 штуки в одном станке).
Успехов.


text

S5 EPROM модуль
Александр; 18.7.02

1. Кто-нибудь знает можно-ли испортить EPROM модуль памяти для S5 если указать при его прошивке неправильный PROG Nr.

2. Есть-ли способ восстановить работоспособность такого модуля
(при попытке записи STEP говорит invalid submodul content)
Re: S5 EPROM модуль
Андрей Рябов; 18.7.02

1. Испортить т.е. "сжечь" ...?)

2. У Вас видимо что-то записано на этот модуль, а Вы еще пытаетесь записать. Нодо стереть EPROM сначала, а потом записывать программу.
Re: S5 EPROM модуль
Александр; 18.7.02

1. Испортить - значит каким-то образом неправильно записать данные. Для чего-то же STEP спрашивает тип модуля перед выполнением каких-либо операций с ним.

2.модуль EPROM стерт (стирали несколько раз) при чтении содержимого
STEP сообщает
Start adress: 0000000
но не говорит submodul empty, как в случае с рабочим модулем.

Re: S5 EPROM модуль
Рябов Андрей; 19.7.02

Если микросхемы EPROM'а действительно пусты, то никаких проблем с записью быть не должно. Может быть какая-либо микросхема вышла из строя или не до конца стерта. А какова контрольная сумма на микросхемах?

Re: S5 EPROM модуль
Александр; 20.7.02

Что есть контрольная сумма? Вернее что это такое понятно, вопрос где в STEP'e5 её можно посмотреть?

Re: S5 EPROM модуль
Рябов Андрей; 25.7.02

В STEP'e5 - нигде. Только читая микросхемы на проммере.

А вообще, если программа пишется на казалось бы стертый EPROM, но на самом деле на нем не все стерто, то в STEP5 (программа естественно не записывается) выдается адрес и значение недотертого байта и процесс записи останавливается.
Re: S5 EPROM модуль
Eleria; 22.9.02

Вообще в документации написано

что неправильный номер PR№
действительно может испортить EPROM
НО сам не проверял :)
Re: S5 EPROM модуль
Eleria; 23.9.02

У меня нет литературы по записи EPROM

Мое Руководство утверждает что менять
EPROM из одного контролера в другой нельзя, но другой пока возможности нет подскажите что можно, а что нельзя
и если можно техническую сторону вопроса.


text

COM 525 ищу soft HELP!!!!
Ахат; 10.9.02

Помогите найти soft на COM524.Нужно записать программу на EPROM 6ES5 373-1AA61. Заранее благодарен. Ахат.

Re: COM 525 ищу soft HELP!!!!
Павел Иванов (Сименс-Москва); 23.9.02

Вы можете его официально приобрести у всех партнеров фирмы Сименс.

Заказной номер 6ES5 895-4SA21


text

Simatic S7-400 код ТН ВЭД
AndySher; 17.9.02

Инофирма в составе своего оборудования поставляет S7-400. Надо срочно растаможить. Какой правильный код ТН ВЭД указывать ?

Понимаю, что может не совсем в тему форума, но очень надо.
Re: Simatic S7-400 код ТН ВЭД
Михайлин Сергей; 20.9.02

Ну на сколько я понимаю в колбасных обрезках, S7-400 нельза подогнать под один код ТН ВЭД. Он же состоит из корзины, блока питания, ЦПУ и др, а каждый из этих модулей имеет свой код и относится к своей группе товаров. Так что это будет бааальшой или не очень список кодов для соответствующих модулей.

Re: Simatic S7-400 код ТН ВЭД
Павел Иванов (Сименс-Москва); 23.9.02

Можете посмотреть коды в сертификате соответствия на SIMATIC.

См. http://www.automation-drives.ru/as/support/certif/01_sootv/3867716.pdf


text

OB 105
Николай Федун, АО АНХК; 6.8.02

Здравствуйте!

Подскажите, пожалуйста, где можно найти информацию по блоку ОВ105 (standby startup)?
Re: OB 105
Кухаренко Сергей; 13.9.02

Вообще описание всех ОВ есть в HELP STEP 7, но там такого ОВ нет. Список ОВ, которые могут использоваться в конкретном CPU можно посмотреть в On-line информации CPU. Я сомневаюсь, что такой ОВ там присутствует.

Re: OB 105
Николай Федун, АО АНХК; 17.9.02

Уважаемый Сергей,

Всё, что вы посоветовали, я уже сделал в первую очередь. Этого блока нет ни в Help'e, ни в CPU Online Properties - у нас CPU413-2DP. Он есть только в Run Sequence для CFC. Ставишь в него 2 блока - SET_TINT и ACT_TINT - всё успешно компилируется, грузится в контроллер. При этом CPU не "ругается" и вся программа работает. Только вот непонятно, когда же OB105 выполняется. Поиск в INET'e тоже ничего не дал.

Николай.
Re: OB 105
Кухаренко Сергей; 20.9.02

После долгих розысков удалось выяснить следующее, что я всётаки прав в отношении моего первого ответа. Что касается конкретно этого блока, то он планировался для S7-400H систем, но до сих пор незадействован. Германия сообщила, что в CFC он включён на данный момент по ошибке.

Re: OB 105
Николай Федун, АО АНХК; 23.9.02

Уважаемый Сергей,

Большое спасибо за информацию! Теперь всё ясно.

Николай.


text

Где взять новые драйвера для FM 350-2 ???
AVR; 20.9.02

Уважаемые коллеги!

Где взять новые драйвера для FM 350-2 ???

Re: Где взять новые драйвера для FM 350-2 ???
Кухаренко Сергей; 20.9.02

С Германского сайта SIEMENS поддержка пользователей.


text

Simatic AG 150K, AG 110A
Сергей; 20.9.02

Где в России за сколько можно приобрести модули для старых контроллеров Simatic S5-150K и 110А.

6ES5925-3KA12,926,927, 6ES5340-3KA12, 6ES5511-3KA21, 6ES5710-0AA11
Re: Simatic AG 150K, AG 110A
ЗИП для 150К и 110А; 20.9.02

Уважаемый Сергей! Кое какой ЗИП на вышеперечисленные контроллеры. Есть б/у , есть новые. Скидывайте заказные номера в мэйл - ответим.


text

Ищется б/у программатор PG 740
Игорь Вяткин; 24.4.02

Срочно

Игорь Вяткин
тел. (0732) 77-24-44, 77-74-83

Re: Ищется б/у программатор PG 740
AmstronTech Ltd ; 30.5.02

What is the max price you are prepeared to go to ?

Re: Ищется б/у программатор PG 740
Максим Елхов; 11.7.02

Есть PG720 (386)

Re: Ищется б/у программатор PG 740
kip@slavutich.com; 19.9.02

Есть PG720P (Pentium 233)


text

источник питания
женя; 18.9.02

помогите найти схему источника питания

типа 6ES5 951-7ND12.
Заранее благодарен.


text

информация по модулю 6ES5465-3AA13
Дима; 6.8.02

Прошу помогите найти инфу по модулю

6ES5 465-3AA13
предположительно думаю что это анал.
входная плата 16 каналов
нужно разобратся как выставлять в ней джампера и можно ли вставить в модуленоситель с 115 контроллером
шлите прямо на почту или здесь оставте ссылку . за ранее благодарю.
Re: информация по модулю 6ES5465-3AA13
Кухаренко Сергей; 13.9.02

16 входов +-50MV/+-500MV

8 входов PT 100
В 115 контроллере должен работать, при этом адрес модуля выставляется перемычками на самом модуле и не зависит от местоположения в корзине (корзина должна быть соответствующая).


text

Подсчет импульсов без сигнального модуля с возможностью прерывания.
Руслан; 13.9.02

Подскажите, есть CPU 315-2DP и нужно считать импульсы до 50 гц, а программа получается больше 20 мс можно ли это сделать не используя сигнальный модуль без обработки прерываний и не используя аппаратнаго счетчика ?


text

S5 - 103 не хочет RUN
Щербаков А.И.; 6.3.02

Не мог ли кто прояснить ситуацию.

Имеется 103 процессор. Стоял на складе 6 лет. Взяли на испытание.
Сo STEP 5 v66 связывается, идентифицируется, блоки загружаются-выгружаются. Но в режим RUN не переходит. Что делать ? В морг ?
Re: S5 - 103 не хочет RUN
Baby; 6.3.02

А BSTACK и USTACK, что говорят ?

Re: S5 - 103 не хочет RUN (STACK)
Щербаков А.И.; 11.3.02

STACK говорят :

ISTACK - (STOANZ и NEUSTA) - помечены
BSTACK - незаконченный или пустой стек.

Re: S5 - 103 не хочет RUN
Александр Туманов; 22.3.02

Если процессор без периферии после процедуры общего сброса (без модуля памяти EPROM или EEPROM) не выходит в режим RUN - он неисправен!

Re: S5 - 103 не хочет RUN
Кухаренко Сергей OOO SIEMENS; 25.6.02

S5-103 не будет переходить в режим RUN, если к нему не подключен хотя бы один блок входов либо выходов через BUS-модуль.

Re: S5 - 103 не хочет RUN
Щербаков А.И.; 25.6.02

Спасибо, Так оно и есть !

Re: S5 - 103 не хочет RUN
Рыбаков М.; 12.9.02

Кроме всего прочего- может быть проблема в замене буферной батарейки - если неправильно заменена, то не запустить без повторной корректной замены!!!

Re: S5 - 103 не хочет RUN
Рыбаков М.; 12.9.02

Кроме всего прочего- может быть проблема в замене буферной батарейки - если неправильно заменена, то не запустить без повторной корректной замены!!!


text

типы карт памяти
Александр Туманов; 11.9.02

Меня интересуют типы (не заказные номера, а такие, если бы их покупать не как карты памяти для SIMATIC, а как просто карты памяти для чего-то своего) карточек памяти Memory Card и Micro Memory Card, если они стандартные.


text

Серж
Прроблемы профилактики; 10.9.02

Здравствуйте.

Собираемся останавливать контроллер, в т.ч - отключать питание и UPS... Возможно надолго. Батарейки на 3.6V за давностью лет сели. Память - RAM. Есть разъем для внешней запитки от блочка. Но вставить туда что-либо из китая не просто - типоразмер не подходит.
Подскажите безопасный вариант.
Re: Серж
fog; 10.9.02

1. Литиевые батарейки подходящего размера можно купить (например, в магазине "Источник" в Питере).

2. Программу можно и нужно скачать с помощью программатора и копию хранить у себя в сейфе (в случае потери программы оживить ваш контроллер будет стоить на три порядка больше или невозможно вообще). Такую услугу можно купить у ближайшего партнёра.


text

Нет токового сигнала !!!
Григорьев Анатолий; 9.9.02

При подключении двух активных независимых датчиков тока(4-20мА) с разным потенциалом напряжения и установки модуля SM-331 AI 8*12bit №6ES7 331-7KF02-0AB0 в диапазон С (четырех проводный преобразователь), не обрабатывается входной сигнал (на выходе датчика он есть) ни с одного из каналов. Подскажите как быть?


text

соеденить MPI/DP с PC
Дима; 25.7.02

Помогите соеденить переходник

( 6es7 972-0ca32-0xa0 MPI/DP )
с PC .
на одном конце MPI/DP а другой
RS232 (папа, что очень странно)
как не распаивал (тот что RS232)
нет конекта хоть умри!с com портом
что за хренотень блин зла не хватает
с этими НЕМЕЧИКАМИ нафига надо было
папу делать .
ведь в PC тоже папа
что за распайка подскажите пожалуйста
кто знает (если можно каждый проводок)
а то я уже все варианты испробовал
(или не все??????)

Re: соеденить MPI/DP с PC
Рябов Андрей; 25.7.02

Папа-мама... главное хвост! :)

А хвост по RS-232 такой (из прилагаемого описания к адаптеру 6ES7972-0CA23-0XA0):

9-pin PC 9-pin Adapter
RXD 2------------3 TXD
TXD 3------------2 RXD
DTR 4------------6 DSR
GND 5------------5 GND
DSR 6------------4 DTR
RTS 7------------8 CTS
CTS 8------------7 RTS

Shield----------------Shield

Re: соеденить MPI/DP с PC
Александр; 4.9.02

Используйте обыкновенный кабель для соединения двух компьютеров через СОМ - порт


text

Отмена программы в LOGO
Мамасолиев Зиед; 23.8.02

Нажимая комбинацию клавиш "ESC" и "OK" на передней панели LOGO попадаем в режим параметризации. После нажатия "ESC" и "OK" у меня появляется индикация, имеющая следующий вид:

> Set Param
Set Clock
Но в руководстве по LOGO (Программирование LOGO- A5E00119092-01)меню режима пераметризации имеет следующий вид:
> Stop
Set Param
Set Clock
Prg Name
Что мне делать, мне нужно отменить старую программу но модуль LOGO не выходит в меню параметрирования
> Edit Prg
Prg Name
Clear Prg
Password
и главное меню, где я могу удалить старую программу командой "Clear Prg"
Помогите советом

Re: Отмена программы в LOGO
Андрей Гуленок; 3.9.02

Подозреваю, что имеет место быть путаница с версиями. Модули версии 0,1 и 2 в режим программирования вводились тремя пальцами <- , -> и ОК одновременно. А одновременное нажатие esc и ОК вводил в режим коррекции параметров. В третей версии в меню попадают нажатием esc.


text

драйвер для CPU 417-4H !!!
Denver; 2.9.02

Где мне можно взять драйвер для CPU 417-4H (s/n 417-4HL0-0AB0)?!

Re: драйвер для CPU 417-4H !!!
Михайлин Сергей; 2.9.02

Вопрос либо не полный, либо не корректный. Драйвера подо что? Под Win2K? ;-) Что Вы подрузамеваете под драйвером?


text

FM458&EXM438
Диденко Евгений ; 29.8.02

Подскажите,пожалуйста,ответ на вопрос: как подаётся питание на модуль расширения EXM438?

В электронном каталоге СА 01 01/2002 RUS на этот счёт наблюдается противоречие. В закладке "Обзор" на EXM438 написано, что питание осуществляется через P-шину, а в закладке "Технические данные" указывается что необходимо питание +5V +24V(внешний подвод)! Что бы это значило? Что, нужно для работы ёщё внешние источники на 5 и 24V?
Заранее благодарен кто ответит!
Re: FM458&EXM438
Чистяков Дмитрий ОАО "СеверСталь"; 30.8.02

Через P-шину запитывается сам модуль.

Напряжение +5V и +24V используются для запитки инкрементных датчиков.
Так же следует помнить, что модули EXM не имеют гальванической развязки по входам выходам. Её необходимо предусмотреть в виде блоков SB60, SB61.


text

Параметрирование DB1
Зиед; 23.8.02

Как мне параметрировать DB1 в STEP 5/ ST Version 6.5 (02.05.95). Можно через пакет COM DB1, но его у меня нет.

Re: Параметрирование DB1
Виктор; 26.8.02

Можно просто просмотреть его как ASCII и тогда все будет понятно


text

Документация по пакету STEP 5/ ST
Зиед; 23.8.02

Где можно взять документацию по пакету STEP 5/ST (6ES5 998-0MA13) c описанием на немецком языке.

Re: Документация по пакету STEP 5/ ST
Чистяков Дмитрий ОАО "СеверСталь"; 23.8.02

http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&changelang=true&aktprim=0&siteid=cs&lang=de


text

Размещение модулей в корзине.
Ольштейн Эдуард ОАО "Мечел"; 21.8.02

В документации по S5 были таблицы, поясняющие какие модули где могут быть установленны.

В описании "Программируемый контроллер S7-400. Руководство пользователя" дано только текстовое описание. Боюсь, что мог что-то недопонять, поэтому задаю вопрос.
Верно ли, что при использованни корзины UR1 в качестве CR1, в нее могут быть установленны любые модули серии S7-400 в любые позиции, любое колличество?
Re: Размещение модулей в корзине.
Ольштейн Эдуард; 21.8.02

Поправка. ... кроме принимающих IM.

Меня интересует размещение модулей AI,AO,CP,FM. С SM и так все ясно.
Re: Размещение модулей в корзине.
Андрей Гуленок; 22.8.02

Меня интересует размещение модулей AI,AO,CP,FM.

В общем случае местонезависимое размещение. Главное, чтоб по питанию перегрузки не было. Хотя некоторые FM могут иметь собственную периферию. Это особый случай, который специально оговаривается в описании FM.


text

FB 164,FB165 для IP247
Сычёв Андрей; 22.8.02

Где можно достать FB164 и FB165 для

IP247?
Очень нужно!!!
Заранее благодарен за любую информацию


text

Работоспособна ли такая конфигурация?
Александр Туманов; 20.8.02

Есть 5 идентичных станций SIMATIC S7-300 дозирования гипохлорита: CPU313-2DP + CP342-5 + OP3 (по MPI к CPU313-2DP), одна станция SIMATIC S7-300 приёма гипохлорита: CPU314 + 2хCP342-5, одна станция сервера: CPU315 + CP342-5 и одна операторская панель OP170B. Коммуникации между ними следующие:

1. станция приёма является мастером по отношению к станциям дозирования по первому CP342-5 и ведомой по отношению к станции сервера по своему второму CP342-5.
2. станции дозирования являются ведущими по отношению к четырём DP-устройствам по своему встроенному DP-порту и ведомой по отношению к станции приёма по CP342-5
3. OP3 являются мастерами по MPI для своих станций дозирования.
4. ОР170В является мастером для всех станций дозирования и станции приёма по PROFIBUS.
5. Станция сервера является мастером для станции приёма по CP342-5 и ведомой для WinCC по MPI.
ВОПРОС: работоспособна ли такая схема,не будет ли конфликтов между OP3 и ОР170В?

Re: Работоспособна ли такая конфигурация?
Рябов Андрей; 21.8.02

Ну и наворотил ты, Шурик! Зачем такой геморой с таким количеством СР342-5 и сложными связями мастер-слэйв? И почему бы ОР и WinCC на PROFIBUS не подключить? Говоря о станциях думай мастером какого класса она является и какие службы будут задействованы на PROFIBUS. На вопрос могу ответить, что к одной ОР170В можно подключить до 4-х CPU S7. :(


text

Ввод новой программы в LOGO
Maмасолиев Зиед; 20.8.02

У меня Логичекий контроллер серии LOGO 230RC Input 6XAC, Output 4 Relay. Дело в том, у меня возникла небольшая проблема с вводом программы.

Модуль LOGO уже подключен к объекту и работает нормально. Я хотел ввести в модуль новую программу, но не могу отменить старую программу, которая повторяется циклически без останова, не реагируя на нажатие клавиш на передней панели. Руководство по эксплуатации логического модуля LOGO я прочитал, но нужной мне информации там не оказалось.
Посоветуйте мне пожалуйста, что мне делать для ввода новой программы.

Re: Ввод новой программы в LOGO
Андрей Гуленок; 20.8.02

Нажать <- -> и ОК одновременно. Попадаем в системное меню. Далее по инструкции.


text

Как состыковать 270 цифровых выходов Simatic S-300 со входами TTL?
Петр Сологубов; 2.8.02

Как наиболее просто состыковать 270 цифровых выходов Simatic S-300 со входами TTL?

Re: Как состыковать 270 цифровых выходов Simatic S-300 со входами TTL?
Виктор; 6.8.02

А Вы пробовали питание на выхода подавать не 24В а 5В ? Теоретически должно получиться...

Re: Как состыковать 270 цифровых выходов Simatic S-300 со входами TTL?
Чистяков Дмитрий ОАО "СеверСталь"; 7.8.02

Ну может быть с 5В и прокатит.

Но можно установить делители напряжения на выходах S7.

---+
|
---
| |
| |
| |
---
|
+-------------->
|
---
| |
| |
| |
---
|
|
---+----------------->

Re: Как состыковать 270 цифровых выходов Simatic S-300 со входами TTL?
Ольштейн Эдуард ОАО "Мечел"; 8.8.02

Выходные транзисторные модули SIMATICa имеют выход с открытым эммитером. Нагрузка подключается между эммитером транзистора и нулем питания. Когда на выходе 0В - это значит транзистор закрыт, нагрузка "оборвана". При включении выхода транзистор открывается - на нагрузку попадает питание, подключенное к коллектору транзистора.

Теперь вспомним типовой TTL-вход - это многоэммитерный транзистор. Идея здесь такая. Садим вход на 0В, из него течет ток несколько мА - это воспринимается как логический ноль.
Подаем на вход 5В, в него втекают доли мкА( или вообще обрываем вход) - это воспринимается как логическая единица.

Поэтому подача на TTL-вход выхода SIMATICa (даже через делитель) будет восприниматься либо как подача питания(1 на выходе) либо как обрыв (0 на выходе), т,е. всегда как логическая 1.

Первое что приходит в голову, здесь придется ставить промежуточные транзисторные ключи управляемые по базе от SIMATICa, с эммитером подключенным к 0В TTL-схемы, коллектором к TTL-входу и резистору, второй конец которого подключен к питанию. Питание либо 5В TTL-схемы, тогда на базе придется сделать делитель. Можно запитаться и от 24В, а паралельно транзистору поставить стабилитрон на 4-4,5В. Еще лучше использовать опторазвязку, тогда управление ее подключается к питанию, а выход запитывается от TTL-схемы.

Если я в чем-то ошибаюсь, готов обсудить.

Re: Как состыковать 270 цифровых выходов Simatic S-300 со входами TTL?
В.Румянцев ООО ALCOA CSI; 8.8.02

С резисторным делителем все будет работать,просто нижний резистор должен быть в пределах 800-400 Ом, это посадит вход TTL до "0" при отсутствии напряжения на выходе S7-300.

Re: Как состыковать 270 цифровых выходов Simatic S-300 со входами TTL?
Ольштейн Эдуард ОАО "Мечел"; 9.8.02

Видимо так оно и есть. Мне 400.0м больше нравится. Разместить то их лучше со стороны контроллера?

Re: Как состыковать 270 цифровых выходов Simatic S-300 со входами TTL?
Илья; 13.8.02

А какие выходные модули? Если транзисторные типа 321-1BL00 то ребята ответили, а если релейные - то тоже проблем нет!

Re: Как состыковать 270 цифровых выходов Simatic S-300 со входами TTL?
Петр Сологубов; 19.8.02

В общем тема закрыта...

С питанием 5В вместо 24 не работает...
Нормальная работа с резисторным делителем:
На 0 - 1кОм и парралельно ему стабилитрон 4.7в
На S7-300 - 3.9кОм


text

OP 393 - III
Александров Константин; 16.8.02

Подскажите, где можно найти любую информацию по панели OP 393 - III.

Re: OP 393 - III
Павел Иванов (Сименс-Москва); 16.8.02

На этом же сайте в разделе продуктов по приведенной ссылке лежит руководство на русском языке по ОР393

См. руководство на русском языке по ОР393


text

примеры программ S7 - 300
beck; 13.8.02

Добрый день

У вас в руководстве
http://www.aud.ru/as/products/02_s7/04_man/GS_Controlling_r.pdf

приведен пример программы. Там же сказано, что данный пример можно выложен в интернете. Можно узнать адрес?
Спасибо.

Re: примеры программ S7 - 300
Чистяков Дмитрий ОАО "СеверСталь"; 14.8.02

Все примеры и документация лежат вот здесь http://www4.ad.siemens.de/

А там уже по выбираете по Вашей теме.
Структура дерева такая же как и в CA01
Чистякову Дмитрию
Alexander B.; 16.8.02

Ссылка оказалась действительно очень полезной.

Спасибо.


text

Micro Memory Card для CPU313C-2DP
Александр Туманов; 13.8.02

У CPU313C-2DP объём рабочей памяти - 32 кБ, в СА01 сказано, что требуется микро-карта памяти - 32 кБ, а для заказа предлагаются только карты памяти от 64 кБ. годятся ли они для CPU313C-2DP? Может ли этот CPU быть одновременно мастером по своему встроенному DP и ведомым по CP342-5DP?

Re: Micro Memory Card для CPU313C-2DP
Виктор; 13.8.02

Здравствуйте!

Могу доку на русском языке по этому типу контроллеров выслать.
Нужно?
Re: Micro Memory Card для CPU313C-2DP
Илья; 13.8.02

Дело в том, что объем ЗАГРУЗОЧНОЙ памяти должна быть в 2-3 раза больше, чем объем РАБОЧЕЙ памяти (а точнее, чем вашв программа в рабочей памяти). На счет DP не уверен, да и зачем DP-шину нагружать еще и коммуникациями?

См. http://www.industrialauto.ru

Re: Micro Memory Card для CPU313C-2DP
Чистяков Дмитрий ОАО "СеверСталь"; 13.8.02

>Может ли этот CPU быть одновременно

>мастером по своему встроенному DP и
>ведомым по CP342-5DP?

Нет уж - либо мастер, либо раб.

Re: Micro Memory Card для CPU313C-2DP
Рябов Андрей; 15.8.02

>Может ли этот CPU быть одновременно

>мастером по своему встроенному DP и
>ведомым по CP342-5DP?

А почему бы и нет?
Ведь CPU с DP это один узел в сети, а CP342-5 это другой узел. CPU всего лишь читает/пишет данные из/в буфер СР342-5.
Re: Micro Memory Card для CPU313C-2DP
Павел Иванов (Сименс-Москва); 15.8.02

1. Для CPU313C можно использовать любые карты MMC, хоть на 4МБ, т.к. у Вас есть возможность сохранять на этой карте весь проект со всеми комментариями и таблицей символов.

2. Контроллер S7-300 конечно же может быть по одному порту PB мастером, а по другому порту - подчиненным. Это стандартная конфигурация.


text

Сопряжение PC и S7-200
Тарасов Сергей,Сочи,МУП "Водоканал"; 2.8.02

Пишу программу работы контроллерами типа SIEMENS S7-200 226 из диспетчерской в супервизорном режиме

Хотелось бы достать типы данных для сопряжения контроллеров и компьютера по протоколу (класс ,методы)через СОМ-порт компьютера по кабелю RS-232-485 и через модемное соединение
Re: Сопряжение PC и S7-200
Александр Туманов; 14.8.02

Самый лучший способ - это использовать фирменный SIMATIC NET OPC-сервер в паре с фирменной же сетевой картой (для MPI, например, CP5611). А в комплект к ОРС входит и библиотека функций на Си.

PS. Питерский водоканал работает на WinCC.

Re: Сопряжение PC и S7-200
vzozulja; 15.8.02

Удачи переписать c нуля и сделать лучше нашу программу+WinCC. СКТЦ/Зозуля


text

FM или не FM?
Сергей; 8.8.02

Помогите оценить.

CPU 416-2DP, -1BL00-0AB0, длительность импульса 15мс, порядка 2 импульсов в секунду... Или все-таки FM?
Re: FM или не FM?
Виктор; 13.8.02

У нас стоит S7-414, на нем работает основательная программа и время его скана 11 мсек.

Короче вряд-ли пропустишь...Но...
Re: FM или не FM?
Виктор; 13.8.02

У нас стоит S7-414, на нем работает основательная программа и время его скана 11 мсек.

Короче вряд-ли пропустишь...
Но лучше поставить Alarm'овые входа. И по OB40 обрабатывать. Тогда уж с гарантией.
Re: FM или не FM?
Сергей; 13.8.02

Спасибо, спасибо!

Я за это время прочел соответствующие азы и тоже докумекал до ОВ40, нахожу это дело весьма привлекательным.
Но вот беда, в нашей консервативной практике процессные прерывания аккуратно и чуть ли не с суеверным страхом избегались (со ссылкой на первого миссионера Siemens в нашей деревне). Пока не придет поставка - оттестировать не удастся, будьте так добры :-), опровергните авторитет немца и развейте сомнения.

Re: FM или не FM?
Илья; 13.8.02

Вообще-то, все зависит от задачи, которую вы решаете. Но, в любом случае, если поставите счетный модуль (а их немеряно, на все случаи жизни!), то не ошибетесь! Особенно, если импульсы идут не по одному, а по нескольким каналам. В противном случае есть риск пропустить импульсы! ОВ40 вещь полезная, но имеет некоторые особенности при использовании.

См. http://www.industrialauto.ru

Re: FM или не FM?
Виктор; 13.8.02

Да, развею :)

На самом деле у Siemens все просто (кто со мной не согласен я не виноват). Просто втыкаете ваш модуль алармовых входов, в хардвере определяете какие входа дают прерывание. Далее читаете доку на ваш модуль, на предмет того, какие входа модуля устанавливают какие биты локальной переменной ОВ40. И уже в программе (в ОВ40) вы проверяете кто вам вызвал прерывание по этим битам. Все очень просто! Если хотите, то я могу выслать вам по почте скриншоты хардверовских настроек- сами убедитесь.
И боятся не следует!

Re: FM или не FM?
Чистяков Дмитрий ОАО "СеверСталь"; 13.8.02

Такой импульс мы умудрялись ловить даже на S5-155U с дискретного входа модуля с прерываниями, а в S7-416 это должно работать без проблем. Единственное, что как уже здесь отмечали - это количество таких сигналов.


text

Часы в CPU 412-1
Игорь; 20.7.02

Не могу запрограммировать часы в CPU 412-1. Подскажите.

Re: Часы в CPU 412-1
Viktor; 13.8.02

Мы делаем так:

Настраиваем ОВ33 на прерывания в 1сек. Далее в локальном стеке ОВ33 есть переменная типа DateAndTime. Берем ее значения (мин,сек,...) и выводим куда надо...

Re: Часы в CPU 412-1
Илья; 13.8.02

Если с программатора - то PLC->Set Time of day. Если же вы вводите время с операторской панели, то через Interface Area.

Re: Часы в CPU 412-1
Чистяков Дмитрий ОАО "СеверСталь"; 13.8.02

Не понял, а чем SFC 0 и SFC1 не устраивают?


text

FM355
Дертунов Борис; 30.1.02

Хотелось бы обучиться правильной настройке ПИД-регуляторов

Есть проблема: исполнительные механизмы очень греются, т.к. невозможно точно настроить dead band, аналоговый входной сигнал очень нестабилен. Жду совета
Re: FM355
Юрий Оганесян; 4.2.02

Обучайтесь :)

По поводу нестабильности аналогового сигнала то да, есть такая проблема. Нам даже однажды пришлось отключить дифф. составляющую из-за каких-то скачков, которые нам не удалось подавить.. :(
Re: FM355
Дертунов Борис; 7.2.02

Легко сказать : обучайтесь.

Где курсы по ПИД-регуляторам?
А диф.составляющая и не нужна в регулировке расхода воды, лучше ПИ-регулирование, но точно настроить не получается.
Re: FM355
Михайлин С.; 15.2.02

Учится, учитсья и учиться... (с)СамиЗнаетеКто

Играться, играться и играться[настройками] (с) ОпытныйАвтоматчик
Меня этому в институте 5 лет учили и то сам иногда удивляюсь. Это наука, которая называется ТАУ, есть толстенные книги. Дело даже не в том, чтобы настроить регулято, это не сложно(по эмпирическим фрмулам), а вот настроить его оптимально(а именно такая задача у вас) это высший пилотаж. Потому как объект управления штука темная и его реакции на управляющее воздействие точно предсказать очень сложно. Но я не сказал - НЕТ. Попробуйте прогнать контур напрмер через PID Self Tuner или нечто похожее по автоматической адаптации контура к объекту.
Re: FM355
Лозовский Е.; 23.7.02

Из собственного опыта могу посоветовать следующее: 1. Для регулирования расхода воды действительно достаточно ПИ - регулятора. Методика настройки регулятора "не по науке" известна: настраиваем пропорциональную составляющую при нулевых остальных параметрах, добиваемся нужной скорости реакции, потом настраиваем интегральную сосотавляющую (уменьшая колебательность).

2. Иногда подобного рода проблемы удается решить настройкой параметра TV_LAG. Этот параметр действует даже при отключенной Д - составляющей регулятора.

Re: FM355
Илья; 13.8.02

А вот мы как раз и ведем обучение! По ПИД-регуляторам в том числе. ;)

См. http://www.industrialauto.ru


text

Transfer error
Николай Федун, АО АНХК; 8.8.02

Имеется проблема.

Мы пользуемся PCS7 v5.0 SP2. При transfer'e из Step 7 в WinCC происходит ошибка передачи сообщения от PLC. Transfer прерывается с сообщением "The text for a PLC process control message could not be read from the STEP7 text library". В отчёте о transfer'e показан номер сообщения, где произошла ошибка - "PLCSysMsg 1107492865". Последние 6 цифр могут меняться при смене CPU. У нас CPU-416-2DP. На 300-м CPU transfer проходит нормально, там в отчёте "No messages to transfer".

Ошибка возникает даже на пустом проекте с пустой OS. STEP7 никакую text library в папке проекта найти не может.

При открытии Alarm Logging после transfer'а в конце списка присутствует PLCSysMsg с громадным номером.

Если имеются какие-либо соображения, пожалуйста, поделитесь. Будем очень благодарны.

С уважением, Николай.
Re: Transfer error
Михайлин Сергей; 8.8.02

Скорее всего проблема связана с наличием в проекте единственного и неизвестного языка. Если операционка русифицирована, она автоматом добавляет русский язык в пустой проект при этом другие стандартные языки уходят. А так как стандартно сообщений на русском языке нет, то и колонка не заполняется, и переносить в WinCC нечего. Проверьте сразу по созданию проекта какие языки в него включены и если стоит один русский, то добавьте например еще английский и сделайте его стандартным. А в 300-м просто в принципе нечего передавать как сообщения! Там нет поддержки ALARM-8 блоков.

Re: Transfer error
Николай Федун, АО АНХК; 12.8.02

Уважаемый Сергей,

Ваше предположение оправдалось. Интересно, что английский необходимо добавлять именно до первого transfer'а, иначе проект становится безнадёжно "испорченным". А вот удаление английского языка после первого transfer'а ни к чему страшному не приводит.

Спасибо огромное за помошь!

С уважением, Николай.


text

Проблемы с сигналом BASP PLC-135
ОАО "ММК", ЦЭТЛ; 9.8.02

Было подозрение что вышли из строя ячейки выходов типа 6ES5441- UA11(Сразу 8 штук). На контроллере горел сингнал BASP. При принудительном отключении этого сигнала (на ножку модуля 6ES5441- подали "0")модули начали работать, но сигнал BASP не пропадает.Как формируется и в функции чего возникает этот сигнал?

Re: Проблемы с сигналом BASP PLC-135
aim; 11.8.02

Чего, чего - с железом сначало подружись и мануалы почитай


text

Step 5, Data and time
Виктор; 6.8.02

Здравствуйте!

Проконсультируйте, пожалуйста.
Есть ли в Step 5 системные дата и время, и если есть, то как их оттуда достать?
Заранее спасибо.
Re: Step 5, Data and time
Рябов Андрей; 7.8.02

См. руководства:

- S5-90/95 - глава 13,
- S5-100 - глава 12,
- S5-115 - глава 13.


text

Обращение к периферийной области I/O
Иван Данилушкин; 17.7.02

Уважаемые дамы и господа!

Поделитесь, пожалуйста, информацией...

1. Для контроллеров серий S7-300, S7-400, что именно происходит при обращении к периферийной области I/O? Например, при обращении к PIW, который определён входу аналогового модуля, происходит считывание значения из модуля или из таблицы образа процесса?

2. Есть ли разница, если модуль подключен непосредственно к контроллеру или доступен через станцию расширения по PROFIBUS?

3. Если считывание происходит несколько раз за время исполнения цикла OB1, могут ли получаемые значения отличаться друг от друга в силу изменения аналогового сигнала на входе модуля?

Заранее большое спасибо.
Re: Обращение к периферийной области I/O
Baby; 17.7.02

Привет,Иван !

Вопрос №3.
А где организовано обработка аналогового сигнала...?
Re: Обращение к периферийной области I/O
aim; 17.7.02

Мда...

Плохо, ПЛОХО знаете матчасть.
1. Ком-да PIW читает непосредственно из периферии.
2. Разница иногда огромная (зависит от количества станций и размера передаваемых данных). Описание задержек см. документации по системам децентрализованной периферии.
3. Всё зависит от подаваемого сигнала. Если подать стабилизированные 5В - ...;-)
Re: Обращение к периферийной области I/O
Иван Данилушкин; 5.8.02

Просомтрел весь форум, и не смог найти где, но помню, что обсуждалась ситуация, когда при вызове функции на контроллере значение переменной одно, а затем, во время исполнения функции значение переменной изменяется извне (из WinCC по PROFIBUS) и как, мол, обойти такую проблему.

Кто-то из МЭТРОВ ответил, что контроллеры серии S7-300 выполняют коммуникационные функции только по окончанию выполнения цикла OB1. Тогда каким образом ВО ВРЕМЯ выполнения OB1 считывается значение из периферии с помощью команды PIW?

С уважением, Иван


text

Кому MOBY?
Dido; 4.8.02

Имеются порядка 60-ти штук носителей данных DAT422(DAT423) фирмы "SIEMENS" заказной номер 6AW5453-8FC (6AW5453-8FF).

Данные носители, по достоверной информации, сняты с производства и теперь как-то эксклюзивно продаются фирмой-изготовителем по цене 300 евро/шт (весной 2002) там в Германии.
Имеющиеся у меня модули в своё время были установлены в механосборочном производстве АвтоВАЗА на автоматических линиях фирмы "KRAUSE" по сборке двигателя и КПП ВАЗ 2110, год их выпуска в районе 90-го, от этого и вся с ними проблема, поскольку 3,6В литиевая батарея внутри за этот срок села, а эти модули официально не подлежат ремонту, т.к. залиты компаундом и полностью герметичны. До сих пор "краузе" на ВАЗе работают на доживающих последние месяцы носителях данных, да на тех, что бригады электронщиков отремонтировали заменив в этой маленькой коробочке литиевую батарейку за 200 рублей.
Пусть эта плачевная перспектива со сборкой останется на совести начальства, не уделившего вовремя должного внимания закупке запасных MOBY пока они ещё выпускались. В то время пока ситуация назревала, у меня скопились те самые 60 штучек, в которых, как показывает опыт, в 90% случаев замена батарейки восстанавливает полностью работоспособность всего модулька видимо до времени пока не сядет и эта батарея.
А что насчёт неремонтопригодности, то если уж докопаться до компаунда, то можно его сравнить с загрубевшим клеем "Момент", который без проблем расковыривается, что и проделали электронщики за простое спасибо, а иногда за стандартную премию рублей в 400 раз в три месяца. Уверяю в вышеизложенном на 100%, потому как поработал и среди ремонтников и в службе запчастей. АвтоВАЗ будет платить любые деньги за устаревшие носители пока не осуществит план модернизации линий 613.726/727.32-3 и 613.726.32-6, где общее количество носителей порядка 360 шт. Итак, кого заинтересовали эта проблема или предложение просьба отвечать на е-mail: chuvak@visit.ru


text

Информация о модуле
Дмитрий Лапин; 25.7.02

Подскажите кто знает, где можно найти информацию по модулю 6ES5 491-OLB11 для SIMATIC S5.

Re: Информация о модуле
Павел Иванов (Сименс-Москва); 29.7.02

В руководстве по S5-115U на русском языке Глава 13, страница 73.

Это адаптационная капсула, в которую вставляются модули формата S5-135U.


text

Контур заземления
Константин; 25.7.02

Какие требования предъявляются

к контуру заземления для микропроцессорной техники и промышленных компьютеров фирмы "SIEMENS"
Re: Контур заземления
Чистяков Дмитрий ОАО СеверСталь; 26.7.02

Для контроллеров S7-300

http://www.automation-drives.ru/as/products/02_s7/04_man/04_Configuring_r.pdf

страница 4-17

Для S7-400
http://www.automation-drives.ru/as/products/02_s7/04_man/04_ElectricConfig_r_400.pdf
страница 4-22


text

CPU315-DP и PG720P.
Сорокин В.; 17.7.02

Уважаемые господа!

Подскажите, пожалуйста, если я "сяду" на DP-порт CPU с MPI кабелем от программатора, то будет-ли работать STEP 7 v. 5.1 или ProTool RT?
Re: CPU315-DP и PG720P.
Чистяков Дмитрий ОАО "СеверСталь"; 17.7.02

Да работать будет.

Только не забудьте протокол в PG установить такой же или S7.
Ну и скорость, естественно.

Кабель лучше для начала проверить.
Т.е. Выключите CPU и подключите кабель от PG. Если на CPU ни какие светоды не подсвечиваются, то значит всё окей.
У нас тут была маленькая проблемка с кабелем от BT-200. Этот кабель спалил в PG субмодуль (вернее транзистор в нём).
Re: CPU315-DP и PG720P.
Чистяков Дмитрий ОАО "СеверСталь"; 17.7.02

Да причина была в том, что при таком подключении PG питал весь CPU.

При постоянно включенном CPU никаких проблем до этого не было.

Re: CPU315-DP и PG720P.
Сорокин В.; 18.7.02

Извините, а если с PPI\РС - кабелем?

Re: CPU315-DP и PG720P.
Андрей Гуленок; 18.7.02

А он с 300-ым не работает. И вообще ДП не поддерживает. Это просто конвертор интерфейса, без "мозгов"

Re: CPU315-DP и PG720P.
Сорокин В.; 22.7.02

А как распаять DP-кабель в полевых условиях из подручного материала. Покупать времени уже нет.

Re: CPU315-DP и PG720P.
Андрей Гуленок; 22.7.02

Полная схема есть в описании S7-200. В крадце ножки 3 и 8.

Re: CPU315-DP и PG720P.
Сорокин В.; 25.7.02

Спасибо, вам всем.


text

соединить MPI/DP с PC не робить
Дима; 25.7.02

пробовал так как вы посоветовали не пошло может сгорел адаптер

как еще можно его поковырять
при подключении горит (сперва 3 раза моргает)
лампочка POWER
а ACTIVE нет
вот и все

Re: соединить MPI/DP с PC не робить
Михайлин С.; 25.7.02

А там еще сбоку на переходнике есть такой маааааленький переключатель скоростей 19200/38400. Его надо выставить соответсвенно настройкам с контрольной панели. Если они разные то ничего не пойдет. А кабель надо было вместе с адаптером заказывать ;-). Он кстати стандартный нуль-модемный без каких либо наворотов.


text

Фильтр на входах s7-200
dimm; 19.7.02

Необходимо схватывать импульсы порядка 1 мкс и обрабатывать эти события по прерыванию в ПЛК s7-200 cpu226. Возможно ли вообще отключить задержку распостранения сигнала (фильтр) на входах s7-200? Насколько я понимаю, благодаря входному фильтру (0,2-12 мс) ПЛК этот сигнал просто не увидит.

Re: Фильтр на входах s7-200
Игорь; 22.7.02

Вы совершенно правы. Мы с такой праблемой тоже сталкивались.

Re: Фильтр на входах s7-200
Андрей Гуленок; 22.7.02

У двухсотого есть "быстрые входы" до 30 КГц. Ими и надо ловить импульсы. Но 1 мкс это мегагерц. Слишком короткий импульс, контролер его не потянет.

Re: Фильтр на входах s7-200
aim; 22.7.02

К сожалению ни один Simatic с такими сигналами не справиться.

Слышал, что подобные сигналя можно обрабатывать на PLC Advantech, но это уже совсем другая песня.
Re: Фильтр на входах s7-200
dimm; 23.7.02

Спасибо за проявленное внимание к моей проблеме и прошу прощения за допущенную мною неточность. В данном случае длительность импульса 1 мкс, а период-1 мс. Такие вот события и надо обрабатывать по прерыванию. Кстати, вопрос-вызов п/п обр.прерывания каждую миллисекунду не помешает времени цикла?

Re: Фильтр на входах s7-200
aim; 23.7.02

Вот как раз от длительности импульса в данном случае и надо отталкиваться.

Импульс длительностью 1 мкс будет просто отфильтровываться (это сделано для исключения срабатывания от "дребезга" контакта) и соответственно не будет вызываться соответствующий OB.

По поводу влияния блоков вызывающихся по прерыванию - тут необходимо считать время выполнения каждой команды и смотреть как это соотноситься с временем цикла. Из опыта: если по прерыванию идёт работа со счётчиками, управление вспомогательными маркерами или опрос и фиксирование аналоговых сигналов - ничего сташного не будет, если начинаем использовать математику - начинаются траблы :-(
Re: Фильтр на входах s7-200
dimm; 24.7.02

В таком случае есть ли у двухсотки возможность отключить контроль времени цикла? Или задрать его повыше? в мануале такой инф. не нашел...

Re: Фильтр на входах s7-200
Чистяков Дмитрий ОАО "СеверСталь"; 24.7.02

По моему, Вы просто не правильно выбрали серию контроллеров. ;-)

Вам больше подошёл бы, например, S7-300 с FM 350 (или ему подобных).
Re: Фильтр на входах s7-200
dimm; 24.7.02

Понимаю, мои вопросы могут вызвать недоумение и раздражение, но стоит задача сделать такое на 200-м. В случае с 300-м у меня и вопросов бы подобных не возникло.

В любом случае спасибо за живое участие.
Re: Фильтр на входах s7-200
В.Румянцев OOO ALCOA CSI; 24.7.02

Как вариант, можно сделать следующее-предварительно обработать сигнал перед вводом его в контроллер,например пропустить его через ждущий мультивибратор,который увеличит длительность импульса или через триггер, который поделит частоту вдвое.Выход триггера будет менять свое состояние с приходом каждого импульса и держать его в течение 1мс, этот сигнал уже можно подать на быстрые входы контроллера.Но Ваша подпрограмма должна быть достаточно короткой иначе не будет времени для работы основной программы.Но я считаю,что вашу задачу лучше реализовать на жесткой логике.

Re: Фильтр на входах s7-200
Чистяков Дмитрий ОАО "СеверСталь"; 25.7.02

А Вы случайно, не импульсный датчик к S7-200 подключаете?

А то очень уж похоже на репер от датчика.

А так В.Румянцев правильный совет дал. Сделайте простейшую схему на базе К155АГ1 или К155АГ3. ;-)

Или как вариант возможно использование преобразователя импульсов в аналоговый сигнал. У нас тут робятки с Omron`ом такого зверя использовали. Извращение конечно, но что делать.

Или у Вас какая то другая задача стоит?

Так у нас 4-ёх клетевом стане стояла проблема - подключить репер с датчика (частота до 50 Гц) на S5-ом Simatic`е. Так мы там применили модуль дискретных входов с прерыванием. И то, как правильно сказал В.Румянцев, пришлось очень долго и упорно вылизывать программу на оптимизацию работы подпрограммы (FB) на быстродействие.


text

FM 351
Андрей; 24.7.02

Где можно скачать информацию по FM 351 (пакет параметрирования)

Если у кого есть, скиньте на E-mail.

Re: FM 351
Чистяков Дмитрий ОАО "СеверСталь"; 24.7.02

Программу можно скачать вот здесь

http://www4.ad.siemens.de/news/cs/en/6461271
Это 15 c половиной метров.

Доки на русском пока нет, а на английском можно взять вот здесь
http://www4.ad.siemens.de/news/cs/en/2029985
Для вникания в принцип работы с FM-модулями можно почитать, например, про FM350-1, FM350-2 вот здесь
http://www.automation-drives.ru/as/products/02_s7/04_man/index.shtml
Re: FM 351
Чистяков Дмитрий ОАО "СеверСталь"; 24.7.02

А вот ещё дополнения по документации для FM351.

FM 351 Positioning Module V5.x
http://www4.ad.siemens.de/news/cs/en/2103043

FM 351 Positioning Function Module Installation and Parameter Assignment V4.1
http://www4.ad.siemens.de/news/cs/en/1108705


text

Резервный ПЛК
НТМК ЛСПУ; 12.7.02

Есть ли возможность построения систем на базе s7-200 с резервным "горячим" контроллером? Хотелось бы узнать принципы, если такое построение возможно.

Re: Резервный ПЛК
Чистяков Дмитрий ОАО "СеверСталь"; 15.7.02

Ну, Вы даёте!

S7-200 - это минимальные затраты. Какие уж тут системы с резервированием?

В принципе, конечно, можно сделать всё.
Вопрос, только в какие затраты это всё выльется. А затраты выльются в стоимость S7-300F. ;-)


text

Установка s7-200
НТМК ЛСПУ; 11.7.02

Допускается ли вертикальная установка s7-200 и соединенных с ним модулей расширения и источника питания SITOP POWER 24V 3.5A ?

Re: Установка s7-200
Андрей Гуленок; 11.7.02

Да, допускается, но со снижением максимальной температуры окружающей среды до +40 градусов.

Re: Установка s7-200
aim; 11.7.02

По идее вертикальная установка PLC возможна (при наращивании системы вверх - PS,CPU,SM), только при этом температура в шкафу не должна превышать 45гр.


text

Совместимость с другими контролерами
Сергей; 21.6.02

У меня есть программатор SIMATIC PG720P||c установленым STEP 5,7.Вопрос: могу ли я подключить к нему контролер фирмы MITSIBISHI и работать с ним.

Re: Совместимость с другими контролерами
Чистяков Дмитрий ОАО "СеверСталь"; 21.6.02

Ну я так понимаю у контроллера MITSUBISHI имеется свой пакет проектирования. Его видимо установить можно на PG - это ведь почти обычная персоналка. А вот связь в PLC там по моеме идёт через COM порт, так что проблем нет, нужно только купить этот пакет.

Re: Совместимость с другими контролерами
Максим Елхов; 11.7.02

Только про кабель связи не забыть :)


text

6ES7 421-7BH00-0AB0. Проблемы!!!
Харгелия Олег Резович, ЗАО "Искра-Энергетика""; 15.2.02

Наша САУ используется на опасном производстве (газотурбинная электростанция)и мы приняли решение использовать дорогие модули дискретного ввода с диагностикой. И сильно жалеем об этом.

Проблема в следующем. Модуль изредка замораживает свое состояние и перестает передавать информацию об изменении каналов в контроллер. При изменении любого сигнала этого модуля с "0" на "1" или наоборот, меняет свое состояние только светодиод. Области I и PI остаются без изменений (просматриваем с помощью Monitor/Modify Vraiables). При этом Diagnostic Buffer ни о чем не говорит. А открытый в онлайне модуль говорит что у него все окей.
И что мы только не делали: в настройках Hardware убирали диагностику модуля совсем, выставляли чтобы при ошибке канала выставлялся 0 (или 1). Но модуль ведет себя всегда одинаково и по свинский.
И еще, так ведет себя не какой-то конкретный модуль, а разные (у нас их по 11 модулей на каждый энергоблок, а энергоблоков 6).
Буду очень признателен за любой дельный совет, который поможет решить эту проблему (только не надо советовать измерить вибрацию или температуру в шкафах, как это делают московские консультанты).
И еще хочется всех предостеречь от покупки этих модулей ;-)
Re: 6ES7 421-7BH00-0AB0. Проблемы!!!
Чистяков Дмитрий ОАО СеверСталь; 19.2.02

На 90% можно сказать, что проблема заключается в неправильной организации питающих цепей. В том числе проблема может заключаться и с заземлением (занулением).

Поэтому, пересмотрите всю схему всех источников питания.
Первое, что необходимо сделать, так это попробовать объединить минусовые провода всех источников питания:
1. Источник питания станции (контроллера)
2. Все источники питания входных сигналов и выходов, управляющих исполнительными механизмами.

Второе – это попробовать объединить эти все минусы с «землёй».

Re: 6ES7 421-7BH00-0AB0. Проблемы!!!
Харгелия Олег Резович; 22.2.02

А как тогда объяснить тот факт, что при перезагрузке контроллера (ключик в положение STOP а затем в RUN-P)работоспособность модуля востанавливается. Ведь в этом случае никаких изменений по питанию не происходит.

Re: 6ES7 421-7BH00-0AB0. Проблемы!!!
Маруськевич Сергей; 26.2.02

Была похожая "проблема". Просто забыли подключить питание к сигнальному входному дискретному модулю. Лампочки при этом моргали,а состояние входов (через монитор смотрел) ВСЕГДА были в "0".

Re: 6ES7 421-7BH00-0AB0. Проблемы!!!
Чистяков Дмитрий ОАО СеверСталь; 26.2.02

Объясняется это тем, что всё будет работать нормально, до тех пор, пока не появиться, так назаваемое, "встречное напряжение", которое приходит через линиии связи с УСО. И это напряжение запирает цепь диагностики.

Маруськевич Сергею
Харгелия Олег , ЗАО "Искра-Энергетика"; 26.2.02

Проблема не в том что модуль совсем не работает, а в том что он может проработать достаточно долгий срок нормально, а затем "зависнуть". После перезагрузки контроллера он опять востанавливает свою работоспособность.

Re: 6ES7 421-7BH00-0AB0. Проблемы!!!
Харгелия Олег , ЗАО "Искра-Энергетика"; 26.2.02

Посмотрел я как у нас запитаны модули.

+ на 3 и 26 ноге
- на 23 и 48 ноге

2 блока питания на 24V включены параллельно, "-" блоков питания гальванически не связан с землей.

Re: 6ES7 421-7BH00-0AB0. Проблемы!!!
Горновский Валентин, Могилев, Беларусь; 18.4.02

Я слаб в STEP7,но имея опыт работы с STEP5, осмелюсь высказать свое пребположение.

Вам следует обратить внимание на линию связи контроллера с модулем. Большие помехи в линии связи могут привенсти к нарушению обмена между контроллером и модулем. Если программно определяется количество повторных вызовов в случае приема пакета данных с ошибками, увеличьте их количество. Возможно,нужно организовать автоматический перезапуск связи.

Re: 6ES7 421-7BH00-0AB0. Проблемы!!!
Горновский Валентин, Могилев, Беларусь; 18.4.02

Я слаб в STEP7,но имея опыт работы с STEP5, осмелюсь высказать свое пребположение.

Вам следует обратить внимание на линию связи контроллера с модулем. Большие помехи в линии связи могут привенсти к нарушению обмена между контроллером и модулем. Если программно определяется количество повторных вызовов в случае приема пакета данных с ошибками, увеличьте их количество. Возможно,нужно организовать автоматический перезапуск связи.

Re: 6ES7 421-7BH00-0AB0. Проблемы!!!
Илья; 23.5.02

А 15кОм параллельно датчику вы повесили? Просто мы используем эти модули уже 3 года и все ОК!

Re: 6ES7 421-7BH00-0AB0. Проблемы!!!
Харгелия О.Р.; 31.5.02

У нас модули с датчиками не имеют непосредственной связи. Сигнал с датчика коммутирует реле, через контакты которого и проходит сигнал на модуль

Re: 6ES7 421-7BH00-0AB0. Проблемы!!!
Илья; 9.7.02

Ребята!!! Я же уже говорил про 15к! Как по вашему модуль определяет обрыв канала?!! По разрыву электрической цепи!!!!


text

Know-How Protection
Сергей; 8.7.02

Подскажите пожалуйста.

Как защитить свои FC(FB) от ненавязчивого вмешательства. Известная галочка в свойствах функций при обычном обращении к ним, увы, неактивна :-(
Re: Know-How Protection
Рябов Андрей; 8.7.02

Это уже обсуждалось. См.:

http://www.aud.ru/cgi-bin/forum/forum.cgi?dir=1008101985&root=1017838001&year=2002


text

Wacthdog-таймер
Victoria; 8.7.02

Есть у CPU-315-DP wachtdog? Если нет, как можно бороться с зависанием ПО?

Re: Wacthdog-таймер
aim; 8.7.02

1. В чём, интересно, выражено это "зависание".

2. А Вам недостаточно контроля времени цикла ?


text

Куплю
ЗАО"Поликом"; 25.6.02

Кто может продать

Адаптер 6ES79720CA230XA0
Кабель 6ES79011BF000XA0
Очень хочется

Re: Куплю
Есть ; 8.7.02

Данный комплект есть в Москве.


text

Модуль 6FX1120-...
RASHID; 5.7.02

Модуль связи 6FX1120-... установлен в AG-150S. На передней панели имеются 2-25pin разъёма. Нужна информация(схема) по подключению модуля к PG675,685 а также к другим модулям связи(СР), а если возможно схему(таблицу) назначения выводов разъёмов модуля.

Re: Модуль 6FX1120-...
Чистяков Дмитрий ОАО "СеверСталь"; 5.7.02

Только вот с документацией в электронном виде сложно.

Она существует, только в бумажном виде.
Её можно заказать по следующим заказным номерам.
http://www4.ad.siemens.de/news/cs/en/188194

Вот ссылки на схемы кабеля для подключения PG-6xx
http://www4.ad.siemens.de/news/cs/en/217827
Вот ссылки на схемы кабеля для подключения PG-7xx
http://www4.ad.siemens.de/news/cs/en/217845

Re: Модуль 6FX1120-...
Дубинин Сергей; 8.7.02

Наверное не S5-150S, а все-таки S5-150U. А потом в контроллере для программирования имеется плата AS511. Через нее программируется контроллер - но не как не ЧПУ.В нашем случае было именно так. А плата 6FX1120-....- это связь контроллера и ЧПУ SIN 850(880)

Все вышесказанное IMHO.


text

модули FM 355
Рылов Михаил; 4.7.02

Re: модули FM 355
Рябов Андрей; 4.7.02

Можно тут скачать:

http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&startNode=4000024&table=CS&lang=en&aktprim=0&wttree=cs&nodeID0=10805177&siteid=cs&foldersopen0=-166-167-168-220-232-239-&jumpto=239


text

Не могу найти описание (pdf) на SITOP power flexi
Александ Куликов; 27.6.02

Привет Всем!

Помогите найти более подробное описание чем просто о том что это блок питания стаким то входом и выходом :-(.

Re: Не могу найти описание (pdf) на SITOP power flexi
Чистяков Дмитрий ОАО "СеверСталь"; 28.6.02

http://www4.ad.siemens.de/csinfo/livelink.exe/fetch/7753030/BA_1353_2BA00-3.pdf?func=doc.Fetch&nodeid=7752375

Re: Не могу найти описание (pdf) на SITOP power flexi
Чистяков Дмитрий ОАО "СеверСталь"; 28.6.02

http://www4.ad.siemens.de/news/cs/en/7753030

Это оно же, только адрес по проще. ;-)

Re: Не могу найти описание (pdf) на SITOP power flexi
Александр Куликов; 30.6.02

Здравствуйте Дмитрий!

Спасибо за ссылку.
С уважением,
Александр


text

Simatic S5 95U-DP
Мильчук Виталий; 15.5.02

Ищу информацию по параметрированию DB1 контроллера S5-95U-DP (6ES5 095-8ME03) с интерфейсом PROFIBUS-DP. В стандартном описании, в том числе на данном сайте, описание заканчивается на серии 6ES5 095-8MD... с интерфейсом SINEC-L2. Может быть есть программа для этой цели типа COM DB1?

Re: Simatic S5 95U-DP
Кухаренко Сергей OOO SIEMENS; 25.6.02

описание для S5-95U с PROFIBUS-DP master необходимо искать в описании ET200 распределённая система ввода- вывода 6ES5998-3ES22.


text

AG 150U
RASHID; 4.6.02

При пуске AG 150U(CPU 150S)блоки пользовательской программы которые хранятся в EPROM установленных в блоках памяти 350 не читаются процессором. В ISTACK выдаётся сообщение ADRBAU:ADR.list strukture.

Как закачать адресный блок лист программы в PLC
Re: AG 150U
Кухаренко Сергей; 4.6.02

На самом деле я не понял Вашего вопроса.Если 150S не находит модулей EPROM, которые вставлены в модуль памяти 350, то скорее всего это говорит либо о неправильном выставлении перемычек на самом модуле 350,либо о его выходе из строя. Необходимо посмотреть структуру памяти контроллера и проверить, обнаруживается ли плата 350.

Re: AG 150U
RASHID; 5.6.02

Спасибо Сергей за ответ.

Перемычки на платах установлены правильно.Конфигурация памяти PLC пока-
зывает:PC RAM-C000,PC memory DBB2.
Раньше я с PG очистил RAM PLC(удалил все блоки в PLCе). После этого PLC перестала читать EPROM и в USTACK выдаётся сообщение ADRBAU.Наверно отсутствует ,блок DB который содержит структуру(список адресов блоков, которые есть в программе пользо-вателя). Если это так , то в каком блоке DB он создаётся и как.
Re: AG 150U
Кухаренко Сергей; 5.6.02

Этот блок DB0 создаётся самостоятельно при стирании CPU и не может быть создан вручную. Судя по конфигурации адресов, CPU не находит этой платы расширения памяти. Или один из блоков CPU вышел из строя.

Re: AG 150U
RASHID; 5.6.02

Сергей в листинге программы пользователя есть блоки DB которые должны храниться в RAM PLC. После очистки RAM я их не загрузил в PLC. Может поэтому и не создаётся список адресов блоков программы пользователя в

DB0. Блоки DB которые храниться в RAM PLC вызываются в пусковых блоках OB.

Re: AG 150U
RASHID; 7.6.02

Сергей прочитанная конфигурация CPU следующая:PC SOFTWARE Z5,CPU S5 150S,

PGAS SOFTWARE A02, далее идёт распределение областей I/Q, PI/PQ,T,C,RS, пользовательской и системной памяти, указывается длина DB,SB,PB,FB,OB,TB,DB0,LIST и т.д.
Я не могу не прочитаь,создать,загрузить
в PLC информацию.Выдаётся сообщение 0343:блок лист отсутсвует в PLC.
Читаю информацию в памяти PLC в области
распределения программы пользователя, то в ней находится программа пользователя т.е.платы 350 читаются.
Может мне надо создать блок DB0 с нулевой информацией и загрузить в РС и
при запуске РС в DB0 сформируеться адресный блок лист?
С УВАЖЕНИЕМ RASHID.
Re: AG 150U
Кухаренко Сергей; 7.6.02

Уважаемый RASHID,система контроллеров S5 (в которую входит и достаточно старый контроллер S5-150S) работает следующим образом: для первичной инициализации системы необходимо провести первичную очистку, которая проводится для 150S системы только с PG или PC - "стереть всё". При этом система автоматически определяет полный объём установленной памяти RAM и EPROM и создаёт библиотеку находящихся в EPROMе блоков. Эта библиотека создаётся в блоке DB0, который (как я уже говорил) создаётся автоматически и Вы не можите создать его вручную. Только после того, как система создала этот блок, вы можите дописывать в контроллер другие блоки через PG или РС.Адреса дописываемых блоков система автоматически допишет в DB0. Система 150S устроена таким образом, что для нормального функционирования ей необходима дополнительная память RAМ, которая в Вашем случае должна находиться на блоке 350. В Вашем случае (насколько я могу судить из текста) система по какой то причине не может создать этот блок DB0. Сказать по какой причине, к сожалению не видя системы, достаточно трудно. Причины могут быть самые разнообразные : начиная с неисправности какой то части RAM, кончая неисправностью одного из четырёх процессорных модулей.

Re: AG 150U
RASHID; 7.6.02

Сергей,спасибо за ответы на мои вопросы. ВЫ убедили меня в аппаратной неисправности PLC.

С уважением RASHID

Re: AG 150U
Сергей Дубинин; 13.6.02

Уважаемый RASHID если имеете желание приобрести ЗИП по данному PLC(процессорные платы и т.д.) , а также отремонтировать - пишите в мэйл.

Re: AG 150U
Кухаренко Сергей; 25.6.02

Вы можите прислать,либо привести, полный комплект блоков на тестирование и, если необходимо, то ремонт. К сожалению определить какой именно модуль вышел из строя невозможно без тестирования. Комплект блоков новых стоит очень дорого.


text

s7-300 и s7-200
dimm; 7.6.02

Планируется система: один S7-300 и несколько S7-200 (MPI). Для подключения PC к такой сетке необходим кабель PC/MPI. Тогда PC будет видеть S7-300. Будет ли PC по этому кабелю видеть и все S7-200? (последние ведь программируются по PPI)

Re: s7-300 и s7-200
Чистяков Дмитрий ОАО "СеверСталь"; 10.6.02

Вообще лучше для такой цели использовать Profibus на основе EMM277.

А в Вашем случае будет проще в PC установить коммуникационный процессор типа CP5611, CP5613 и т.д. И подкличить PC сразу в сеть MPI.

А вообще не понятно - на кой чёрт Вам несколько S7-200.
Проще ведь будет поставить станции ET200 и связать S7-300 с PC.
Плюсы:
1. Весь проект в одном месте.
2. Количество коммуникаций меньше, соответственно всё проще и надёжнее.
3. Обмен данными между подзадачами (бывшие S7-200) упрощается до минимума.
4. По цене одно и тоже, а то и дешевле.

Re: s7-300 и s7-200
Павел Иванов (Сименс-Москва); 24.6.02

Да! S7-200 тоже будет доступен.

Протокол PPI - это подмножество MPI.


text

Процедура 3964(R)
VAM; 27.12.01

Подскажите, пжлст, где можно взять описание процедуры 3964(R).

Необходима для организации связи CP441 с промышленным оборудованием.
Re: Процедура 3964(R)
Чистяков Дмитрий ОАО "СеверСталь"; 17.6.02

А что значит описание процедуры?

Если под этим имелся в виду протокол обмена, так он описан в руководстве по CP441 в главе
2.2.2 Data Transmission with the 3964(R) Procedure

Там же дан алгоритм протокола, который необходимо повторить в "промышленном оборудование"


text

Кабель PC/PPI
Поликом; 13.6.02

Можно ли использовать в качестве кабеля РС/PPI аналогичный кабель(RS232 - RS485), используемый для программирования контроллеров VersaMax ( GE Fanuc)

Re: Кабель PC/PPI
Андрей Гуленок; 14.6.02

Попробуйте. Ничего экстраординарного в этом кабеле нет. Тривиальный RS232-RS485 реверсивный конвертор. А вообще, спросите фанук, как работает их кабель. Если алгоритм работы совпадает с сименсовским (он описан в руководстве на S7-200) то проблем быть не должно.


text

S7 200 + радиомодем
Dr. Kren; 13.6.02

Здравствуйте уважаемые!

Где найти информацию как организовать связь между компьютером (WinCC 5.1) и тремя S7-22x посредством радиомодемов (расстояние от компьютера до контроллеров 11, 15 и 17 км)


text

6ES5 511
Ruslan; 1.6.02

У кого есть хоть какая-нибудь информация по этому делу , очень нужно

Re: 6ES5 511
Чистяков Дмитрий ОАО "СеверСталь"; 4.6.02

Вы уверены, что правильно написали заказной номер.

Может быть Вас интересует информация по интерфейсу AS511?

Re: 6ES5 511
Ruslan; 5.6.02

Я правильно написал заказной номер , меня интересует такая плата , если у вас есть информация и по интерфейсу AS511 , она также необходима ....

Re: 6ES5 511
Ruslan; 5.6.02

С какими платами можно работать по интерфейсу AS511 ?????

Re: 6ES5 511
Чистяков Дмитрий ОАО "СеверСталь"; 5.6.02

Это последовательный интерфейс со своим протоколом.

Вот несколько ссылок
Распайка кабеля для PG и S5-130, S5-150
http://www4.ad.siemens.de/news/cs/en/35676
http://www4.ad.siemens.de/news/cs/en/217845

Драйверы для связи
http://www4.ad.siemens.de/news/cs/en/40009
http://www4.ad.siemens.de/news/cs/en/9715828
---------------------------------------
С какими платами можно работать по интерфейсу AS511 ?????
--------------------------------------
Ну, например, CP525
Re: 6ES5 511
Ruslan; 6.6.02

Такой вопрос по распайке если смотреть ,то получается к PC конец папа ,а к контроллеру мама ... А на плате 525 вход мама или нужен какой-нибудь переходник ????

У меня есть шнур 6ES55731-OBF00
на нем написано AS511 не в курсе подойдет ли он , вкрыл его он не соответствует распайке по ссылкам ...
Re: 6ES5 511
Чистяков Дмитрий ОАО "СеверСталь"; 7.6.02

Так, для начала давайте договоримся, что к чему подключать по конкретнее.

Напишите, пожалуйста, об этом.
Все распайки для модуля CP525 имеются в руководстве на этот модуль в первом томе. Оно у Вас имеется ?
Если нет, то руководство имеется на CD-ROM с манулами на английском языке. Я бы Вам его выслал по почте, но вот первый том 40Мб, да ещё и второй около 8-ми.
Что касается подключения CP525 по интерфейсу AS511, то там имеется упоминание о подключении старых PG 600-сотой серии. Ведь AS511 довольно таки старая связь.
Хотя что там старого - ведь токовая петля - она и в Африке токовая петля.

Re: 6ES5 511
Ruslan; 9.6.02

Подключать SimaticS5 135U есть CP525 к РС имеется программатор PG750 , но он старый и визуализацию на нем не сделаешь и имеется PG 720 P2 новый , к нему собираемся подключать. Руководства на модуль 525не имеется ...

А не могли бы вы выложить на сайт , если имеется ,я бы забрал от туда документацию.. Спасибо за содействие и помощь.
Re: 6ES5 511
Чистяков Дмитрий ОАО "СеверСталь"; 10.6.02

Всё руководство выложить не смогу (40 Мб файлы ни кто не впускает к себе на сайт), а вот один рисунок пожалуйста.

http://dhs.boom.ru/temp/525.jpg

Re: 6ES5 511
Чистяков Дмитрий ОАО "СеверСталь"; 11.6.02

А вот подумал тут над темой и пришёл к выводу- а зачем так мудрить. На фига Вам именно AS511. Ведь для визуализации без разницы какой протокол использовать.

В полне реально и проще будет использовать ASCII или 3496R.

Тут вот только интересно - визуализацию-то на чём делать будете на WinCC, какой либо другой SCAD`е или самопал будет?

С WinCC так вообще проблем нет.
Хотя использовать PG в качестве терминала визуализации не очень-то удобно. Но это моё личное мнение.

Re: 6ES5 511
Ruslan; 13.6.02

Если бы у меня была информация по всем этим протоколам было бы из чего выбирать , а так пока в этом не силен и не обладаю информацией .... На счет визуализации пока ищу , что использовать ,а на счет PG это не проблема если получится под это дело буду пробивать машину .....


text

CPU 417-4 H.
Alex; 7.6.02

Господа! Работаем с H системой на 417-4HL01-0AB0. Все прекрасно. но заметили интересную вещь. Если один из контроллеров умер, а по PROFIBUS связи с ET 200M оставшегося проходит обрыв связи, то на CH_DI и CH_DO модулях висит ошибка на входе MODE 16#40ХХХХХХ и после восстановления связи, и они соответственно не пропускают и не выдают истинные значения с/на сигнальные модули. Ошибка приходит с MOD_2. Самое интересное в том, что проинициализировав вход ACC_MODE на MOD_2 ошибка сбрасывается. Не хотелось бы вручную накидывать связи на этот вход, т.к. модули генерятся автоматически. Как можно это обойти или исправить???


text

Выбор автоматического выключатея для Sitop
Ольштейн Эдуард ОАО "Мечел"; 3.6.02

Необходимо выбрать вводной автомат для

блока питания Sitop 230В - 24Вх5А.
Согласно данным на блок входной ток 1А,
логично выбрать вводной автомат на 2А с хорошим коэффициентом мгновенного расцепителя, чтобы не выбивался при включении блока питания.
Но в технических данных (входные величины) на блок питания есть параметр:
рекомендуемый LS-переключатель харак. С - 10А.
Не об вводном автомате ли речь?

И еще, если кто знает, о чем параметр -ограничение подключаемого тока - 45А,1.2 ААс?
Re: Выбор автоматического выключатея для Sitop
Павел Брындин; 3.6.02

Речь идёт именно о вводном автомате.

Но на наш взгляд он очень завышен.
Тем более, что для новых SITOPов 24В/5А рекомендуются уже автоматы на 6 А/хар. С. Буквально на днях провели эксперемент - "нагрузили" SITOP на номинал, на вводе поставили автомат на 1 А. После многократного включения автомат не сработал.
SIEMENS явно престраховывается.

Re: Выбор автоматического выключатея для Sitop
Юрий Оганесян; 6.6.02

Даже если 10А - эти и завышено, то чем это для Вас грозит? При КЗ SITOP и сам отключится, так что я думаю не стоит брать на себя риск и занижать рекомендуемый ток входного автомата.


text

s7-200 и RS485
dimm; 30.5.02

Будет ли функционировать нормально сеть s7-200 и несколько OP(TD) по RS485 если один или несколько OP(TD) отключены от питания?

Re: s7-200 и RS485
Андрей Гуленок; 30.5.02

По идее должна, если не очень длинная. Пробовать надо, есть ньюансы с терминаторами. И числом коннекшенов у двухсотки.

Re: s7-200 и RS485
dimm; 31.5.02

Планируется сеть RS485 в составе CPU216+ 2 TD200 + 2 OP7. Протяженность сети - 200м. Максимальное расстояние между узлами - 50м. Имеет ли такая система право на жизнь?

Re: s7-200 и RS485
Андрей Гуленок; 31.5.02

Имеет право не работать. Максимальная протяжённость PPI - 50 метров. Эту дистанцию можно увеличить при помощи репитеров, но это накладно и имеет ряд особенностей описаных в руководстве по S7-200. Кроме того, контролер имеет 4 свободных связи, одна из которых резервируется под программатор. Так что 4 ОР это много для S7-200

Re: s7-200 и RS485
dimm; 3.6.02

Я в затруднении.

Необходима система с 1ПЛК(S7-200), двумя устройствами текстовой визуализации и двумя устройствами визуализации/задания. Можете что-либо посоветовать?

Re: s7-200 и RS485
Рябов Андрей; 5.6.02

Есть такие панельки UniOP. Что в них особенного, так это возможность объединить эти ОР между собой в сеть (до 31). И подключив PLC к одной из ОР, иметь доступ к PLC из любой другой ОР в сети. Есть там драйверы и SIMATIC.


text

CPU 150S
RASHID; 3.6.02

При пуске программы блоки пользова-

тельской программы не закачиваются.
В ISTACK собщение:отсутствие адресного
блок листа.Где он создаётся и хранится?
Думаю он создаётся в блоках запуска ОВ и хранится в DB1. Правильно ли я думаю?

Re: CPU 150S
RASHID; 4.6.02

Уточняю вопрос. При пуске AG 150U(CPU 150S)блоки пользовательской программы которые хранятся в EPROM установленных в блоках памяти 350 не читаются процессором. В ISTACK выдаётся сообщение ADRBAU:ADR.list strukture.

Как закачать адресный блок лист программы в PLC


text

Дока по FM450-1
Baby; 4.6.02

Привет !

А по FM-450-1 вообще никакой документации, что ли нет.
Даже на немецком Siemens ?!?!
Re: Дока по FM450-1
Чистяков Дмитрий ОАО "СеверСталь"; 4.6.02

Ну уж так вот и нет. :-)

http://www4.ad.siemens.de/news/cs/en/5574978
http://www4.ad.siemens.de/news/cs/en/1118412


text

Входной аналоговый модуль.
Дмитрий; 31.5.02

Здравствуйте, господа!

Для проведения профилактических работ отключили питание с прибора расширения S5-185U, где установлены входные, выходные аналоговые модули (6ES5460-4UA..,6ES5470-4UA..).
По окончании работ, подали питание, но тут же обнаружилась неисправность одного из входных модулей -
6ES5 460-4UA12 (цифро-аналоговое представление измеряемых величин в диапазоне тока 4...20 мА). По всем каналам значения измеряемых величин
превышали максимум, хотя реально на входе было ~4мА.
Заменили модуль на резервный, а неисправный проверили на стенде - модуль оказался рабочим (все каналы исправны).
В связи с этим вопрос, в чём причина такого "зависания" платы ?

С уважением, Дмитрий.
Re: Входной аналоговый модуль.
Aleks; 31.5.02

У меня было такое

после перезапуска Simatic работа востановилась.
Возможно нужна синхронизация.

Re: Входной аналоговый модуль.
О.М.; 3.6.02

Входные аналоговые модули имеют гальваническую связь между каналами по питанию (если не имеют, это отдельно оговаривается в документации). Проследить все взаимосвязи контуров измерения обычно трудно, особенно если есть общая земля. Попробуйте запитать каждую измерительную схему (канал) от отдельного отвязанного от земли источника. Или бывают модули гальванической развязки.


text

Ошибка интерфейса (ID 16#6881 и ID 16#6981)
Харгелия Олег Резович, "Искра-Энергетика"; 15.2.02

Постоянно возникает ошибка сявзи. В диагностическом буфере контроллера следующая информация:

Event ID 16#6981
Interface error entering state
Interface ID: MPI (или DP bus)
OB number : 8
External error, Incoming event

или

Event ID 16#6881
Interface error living state
Interface ID: MPI (или DP bus)
OB number : 8
External error, Outgoing event

конфигурация сети следующая:
Два дублированных оптических кольца,
Оптические модули OLM G12
Контроллеры 416-3(9 шт.)
Операторские станции с CP5613 (3шт).
Кольца подсоединены через OLM к встроенным в контроллер интерфейсам MPI и PB DP, и коммуникационным процессорам операторских станций.
Интерфейсы: MPI (12 Mbit) и PB DP (12 Mbit). Для подсоединения используется PB-кабель и PB-коннекторы. MPI- кольцо используется для обмена информацией между контроллерами, и передачи информации на одну из операторских станции. PB - кольцо используется для передачи информации на две операторские станции.

Если кто-то сталкивался с подобной ошибкой, разъясните пожалуйста из-за чего может возникать подобная ошибка и как ее можно побороть.

Re: Ошибка интерфейса (ID 16#6881 и ID 16#6981)
Чистяков Дмитрий ОАО СеверСталь; 19.2.02

А на модулях OLM/G12 выставлен режим кольца?

Re: Ошибка интерфейса (ID 16#6881 и ID 16#6981)
Харгелия Олег Резович; 22.2.02

Естественно!!!

Только режим дублированного кольца.
Re: Ошибка интерфейса (ID 16#6881 и ID 16#6981)
Харгелия Олег ЗАО "Искра-Энергетика"; 23.4.02

Конфигурация сети изменилась

А проблема осталась :-(

Теперь конфигурация следующая:
Два дублированных оптических кольца,
Оптические модули OLM G12
Контроллеры 416-3(9 шт.)
Серверы с CP5613 (2шт).
Кольца подсоединены через OLM к встроенным в контроллер интерфейсам MPI и PB DP, и коммуникационным процессорам серверов.
Интерфейсы: MPI (12 Mbit) и PB DP (12 Mbit). Для подсоединения используется PB-кабель и PB-коннекторы. MPI- кольцо используется для обмена информацией между контроллерами. PB - кольцо используется для передачи информации на два сервера.

Помогите кто может!!!!

Re: Ошибка интерфейса (ID 16#6881 и ID 16#6981)
Харгелия Олег; 31.5.02

Тут прочитал в документации, что если убрана перемычка на корзине, то подключение к коммуникационным портам процессора нужно осужествлять через репитер. Не уж то это правда. Может все проблемы из-за этого?


text

Русификатор для STEP7-MicroWin
Андрей; 30.5.02

Где можно найти русскую редакцию STEP7-MicroWin, либо русификатор к ней.

Re: Русификатор для STEP7-MicroWin
Андрей Гуленок; 31.5.02

Официально нигде. Были попытки перевести V2 но они окончились ничем ввиду выхода новой версии. Больше он не переводился.


text

Кабель для соединения контроллеров в сеть
Мудрак Николай КГГМК "Криворожсталь"; 9.5.02

Каким должен быть кабель сети MPI для соединения контроллеров в сеть и подключения к ним программатора. Контроллеры CPU 313.

Re: Кабель для соединения контроллеров в сеть
Юрий Оганесян; 13.5.02

Для этого подойдет любой кабель стандарта Profibus от Siemens. Использовать аналоги не рекомендую - кабели Profibus других фирм имеют другое волновое сопротивление. Парадоксально, но факт!

Re: Кабель для соединения контроллеров в сеть
Илья; 31.5.02

Можешь посмотреть отечественные - есть подходящие по параметрам


text

PG 720
Иван Герасимов; 16.6.00

Ваше сообщение...

Господа,
Буду весьма признателен за помощь.
PG-720(Step5/ST ver7.0,Win95,DOS) в ON-LINE с SIMATIC 150U работает отлично за исключением функции TEST->Block Status.
PG-720 открывает выбраный PBn и виснет без всяких сообщений. PG720, S79220-A2476-F088-01.

Первоначальная версия пакета на PG-730 V6.3 в ней создавалась программа и загружалась в SIMATIC 150U.

С уважением,
Герасимов И.

Re: PG 720
Alex; 30.5.02

Перейди на Step5/ST ver6.6 получше работает


text

Почему CPU 224 не работает на положенных 187,2kbps
Дмитрий; 29.5.02

Почему CPU 224 не работает в сети ( только 1CPU - 1PC по MPI)на 187.2kbps, хотя по документаций должен (на 19.2kbps всё Ok).

Re: Почему CPU 224 не работает на положенных 187,2kbps
Ольштейн Эдуард ОАО "Мечел"; 30.5.02

Стоит проверить соответствие заказного номера 6ES7... имеющегося модуля и номера модуля описанного в документации.

Siemens часто выпускает модули ограниченными возможностями, а затем, меняя в заказном номере одну цифру, наращивают их.
Так например первые двухпортовые процессоры CPU944 поддерживают на SI2 только ASCII протокол, а первые CPU943 не позволяли менять программе (в процессе выполнения ) слова в блоках данных DB при загрузке программы с EPROM.

Re: Почему CPU 224 не работает на положенных 187,2kbps
Андрей Гуленок; 30.5.02

Потому что и не должен. Режим 187К заявлен только для коммуникаций MPI с функциями X-Get и X-Put. И в этом режиме он работает. При связи с себе подобными скорость ограничена 19,2К. Программироваться на 187 умеют только версии старше 1,0. Кстати, замечание на счёт разных релизов под одним поставочным номером имеет место быть. Например версия 1.0 не поддерживает профибас. В релизе 1,21 появилась масса новых команд. Подобного рода информация публикуется в "Anwendinfo" и FAQ, только её там мало кто читает.


text

про LOGO!
Андрей; 30.5.02

Можно ли увеличить колическтво входов/выходов в ЛОГО серии 0ВА3.Мне не хватает 24/16.Надо 24/22.Если нет тогда мне надо использовать S7-200?

Re: про LOGO!
Андрей Гуленок; 30.5.02

Можно ли увеличить колическтво входов/выходов в ЛОГО серии 0ВА3.

В руководстве написано что нельзя. У меня нет оснований этому не верить.

Мне не хватает 24/16.Надо 24/22.Если нет тогда мне надо использовать S7-200?

Ну почему именно S7-200? Есть же ещё серии S7-300 и 400.


text

S7-300 PLC, SIMATIC HMI
AmstronTech Ltd.; 29.5.02

We are currently looking for new SIMATIC S7-300

series PLC(315DP,318DP),Analog I/O modules,SIMATIC touch
panels(TP27,TP37),MP270,MP370
Min discount 50% of the retail price.


text

Ошибка при открытии проекта для S7-314CPU
KIP; 29.5.02

При открытии проекта выдается следующее сообщение:

Open Project (257:8)
One or more objects of a type (14154E) cannot be represented. Make sure that the required optional packages are installed.
Комментарии: открывается программа в STEP 7 v.5.1 с CPU 314 + абсолютно стандартые ячейки DI, DO, AI, которые есть в библиотеке Hardware. При открытии не отображает CPU и отсутствует программа. Ни с каким другим проектом при открытии подобных проблем не возникает. Какие опциональные пакеты необходимы????


text

FM357. Кто работал - откликнитесь.
Сорокин В.; 23.5.02

Пожалуйста помогите.

FB4, взят из ToolBox-а FM357. При обращении к нему вызывает останов CPU без сообщения о сбоях. Обращение построено классически, по документации.
Программа PLC написана в Simatic Manager версии 5.1. Восстановление работы только через выключение.
Дополнительно: при первых попытках генерации instans DB и встраивании его с FB4, Simatic Manager заявлял, что он не соответствует "голове" FB. И действительно, в нём переменных было больше, чем в FB4. Однако, через несколько дней, всё "сработало", хотя разница в числе переменных осталась, и теперь имеет место проблема, о которой сказано в начале. Очень прошу всех, кто может помочь, подсказать выход из данной ситуации или прислать работающую копию FB4 и его DB для FM357. FM357 - простой, не DP.
Прошу откликнуться все, кто работал с FM357, т. к. эта проблема у меня самая "горячая", но не единственная.
Заранее благодарен, В. Сорокин.
seima@mnogo.ru, seima@mail.ru.
Re: FM357. Кто работал - откликнитесь.
Александр Лифанов; 28.5.02

DB-шку сам писал? Или через OB100/FC1 делал?

Самым правильным будет взять DB-шники (ВСЕ!!!) из сэмплов и его править.

Плюс напоминаю, DB-шник там далеко не один: по одному на каждый модуль, плюс по одному на каждую ось, плюс по одному экземплярному на каждый FB, плюс DB121 для variables.

У меня 357-2, но там я так понимаю, что практически то же самое. Пиши на е-мейл - будет оперативнее.
Re: FM357. Кто работал - откликнитесь.
Сорокин В.; 28.5.02

Спасибо, Александр!

Послал вопросы по E-mail.


text

Может ли ПИД в SFB42 это ...
Александр Туманов; 6.5.02

В шаговом ПИД-алгоритме (SFB42) есть возможность задавать раздельно длительность паузы и длительность импульса. Объект управления - труба с сырой водой, в которую дозируется коагулянт. Дозирующий клапан открывается и закрывается от SFB42 по сигналу обратной связи (проводимость воды). Так вот - в канале обратной связи есть элемент задержки - 30 секунд, т.е. измерение проводимости происходит с существенной задержкой во времени. Вопрос - правильно ли я сделаю, если время паузы задам равным времени задержки, а время импульса выберу как 1/10 (или какую другую?) от полного времени хода клапана? Или лучше вообще отказаться от стандартного алгоритма и написать что-то своё?

Re: Может ли ПИД в SFB42 это ...
Маруськевич Сергей; 9.5.02

По большому счету, ПИД-регуляторы (и им подобные) предназначены для выполнения некого задания (расхода, температуры, скорости и т.д. и т.п). Для выполнения вышеуказанной задачи я бы написал что-нибудь свое

Сергей

Лучше не надо
Александр Лифанов; 28.5.02

Из своего опыта - с шаговым ПИД лучше дела не иметь. При непонятных условиях уходит в windup, откуда, по причине отсутствия ограничения на внутреннее аналоговое значение скважности, его возвращать в нормальное состояние приходится руками, заглядывая в служебный уголок DB-шки... Мораль: аналоговый ПИД с самодельной навеской работает гораздо предсказуемее.


text

Григорий
Возможности S7; 1.4.02

Использую CPU416. При построении ПО возник ряд вопросов:

1. Как программно определить - в каком режиме находится процессор -stop|Run|Run=P
2. Можно ли из программы динамически изменять доступ к DB (только чтение разрешать/запрещать). Аналогично если доступ к ПЛК запароллирован.
3.Можно ли как-то (кроме программатора) изменить содержимое DB в загрузочной памяти - во флэш-карте
а) с помощью системных функций
б) с помощью Prodave или иным способом
4. Возможно ли частичное закрытие модулей паролем в ПЛК?

5. Хотелось бы получить более подробную информацию по аттрибуту Unlinked для DB. Для чего используются подобные DB и т.д.

С уважением, Григорий

Re: Григорий
Александр Туманов; 24.4.02

1. UNLINKED - используется для тех DB, которые после пуска ПЛК не перезаписываются в RAM, а остаются во Flash. Потом с помощью SFC можно загружать их в RAM и наоборот.

2. Частичное закрытие паролем модулей?
если речь идёт о том, чтобы закрыть только одну половину FC, например, то нельзя (я так думаю).
3. Программно определить в каком режиме находится CPU? Если PLC-slave и он не отвечает (это определить программно в Мастере не трудно), то, возможно, он находится в состоянии STOP (если он не отвечает, то какая разница в конце-концов - в каком он состоянии).
Re: Григорий
Илья; 23.5.02

1) Есть SFC, которая позволяет получить статус удаленного ЦПУ

2)Из программы (если пишешь сам) можно ВСЕ
3)Siemens вроде-бы говорит что можно, но я не видел никого, кто это сделал. Может с Micro Memory Card получится?
4) Только программный блок целиком (всю FC/FB/DB)
5)Ex: есть много рецептов большого объема, которые периодически используются. Чтобы их не держать в рабочей памяти их делают UNLINCKED и хранят в загрузочной памяти. Через SFC их можно скопировать в рабочую память


text

передача данных с помощью 6ES5-525
Руслан; 12.5.02

Как сделать вывод данных из S5-135 посредством 6ES5525???

какое программное обеспечение можно и нужно для этого использовать ???
И возможно ли при этом визуализация или только архивация данных ???
Re: передача данных с помощью 6ES5-525
Павел Иванов (Сименс-Москва); 17.5.02

Для этого нужен дополнительный пакет параметрирования COM525.

СР525 - это коммуникационный процессор, поэтому от того с чем вы будете его связывать зависит какие функции будут реализованы (архивирование, визуализация и т.д.)

Re: передача данных с помощью 6ES5-525
Руслан ; 20.5.02

А где этот пакет параметрирования взять ????

Re: передача данных с помощью 6ES5-525
Павел Иванов (Сименс-Москва); 23.5.02

Купить.


text

Как программно определить сетевые адреса узлов в сети Profibus
Алексей; 21.5.02

Здравствуйте,

каким образом на программном уровне в CPU 414-3 продиагностировать наличие активных узлов в сети Profibus + их сетевые адреса (безотносительно, что является узлом - ET, привода,OP, CP и т.д.)
Re: Как программно определить сетевые адреса узлов в сети Profibus
Baby; 22.5.02

Привет, Алексей !

А куда должна выводиться информация
о состоянии Profibus клиентов ?

Re: Как программно определить сетевые адреса узлов в сети Profibus
Aлексей; 22.5.02

Я формирую протокол и через станцию связи (ОРС) передаю его на SQL-сервер

Re: Как программно определить сетевые адреса узлов в сети Profibus
aim; 22.5.02

см. FC3 DP_DIAG из библиотеки - Laibraries/ Standsrt Libraries/ Cimmunication Blocks/FC3

Re: Как программно определить сетевые адреса узлов в сети Profibus
Алексей; 23.5.02

На сколько я понимаю FC3 предназначена для диагностики PLC, ЕТ, исполнительных устройств и датчиков, сидящих на Profibus. OP, MP и ТD не имеют стартового диагностического адреса (первый формальный параметр FC3). Или я не прав?


text

s7-200+4TD
НТМК ЛСПУ; 21.5.02

Имеется s7-200 cpu215. Порт RS485 занят под свободно программируемую связь. Возможно ли организовать подключение ко второму порту (profibus) 4 TD (OP) ?


text

Неисправность C7-633/P
Andrey; 16.5.02

Непонятно по какой причине перестали работать дискретные входа

контроллера С7-633/P (6ES7633-1DF02-OAE3(V1.2)).
Выхода и универсальные входа - работают нормально.
Контроллер эксплуатировался в чистом, теплом помещении.

Re: Неисправность C7-633/P
fog; 16.5.02

А в чём, собственно, вопрос?


text

ЛОГО
НТМК ЛСПУ; 16.5.02

Имеется ли подсветка экрана (backlite) у модулей ЛОГО?

Re: ЛОГО
Александр Туманов; 16.5.02

Нет!


text

Помогите студенту с CPU 314IFM
Аркадий Каминский; 13.5.02

Уважаемые господа !!!

При выполнении дипломной работы возникла проблема. Не могу найти в документации тот диапазон адресов который можно использовать как переменные. Подскажите где копать или сам диапазон для контроллера 314IFM.
А также интересует более простое описание языка LAD, а не справочник по нему(справочник есть в PDF).

Заранее спасибо.

Re: Помогите студенту с CPU 314IFM
Лонин Виктор; 15.5.02

Если у тебя есть степ, то открываешь его, делаешь оффлайн проект на основе нужного CPU и выбираешь "module information" закладка "perfomance data". Там все расписано: сколько меркеров может быть, сколько блоков данных, если я правильно тебя понял.

На счет LADа: есть учебник на диске, если интересуешься могу выслать.

Re: Помогите студенту с CPU 314IFM
Аркадий Каминский; 15.5.02

уже разобрался ... А по поводу LAD - если это pdf со справочником - то он у меня есть. Просто мне данные языки не преподавали, приходится разбираться самому.

Re: Помогите студенту с CPU 314IFM
Лонин Виктор; 16.5.02

Нет, у меня брындовая литература...


text

Неисправность FM352
Лонин Виктор; 15.5.02

Здравствуйте!

Может быть кто сталкивался. Работал у нас модуль FM352 и вдруг перестал работать. Выяснилось, что все функции работоспособны кроме аппаратных прерываний и системы 10е-2 градусов. Как раз тех вещей на которых он работал.
Не знаете ли что в нем могло случиться?(Дефектов платы "на глаз" нет)
Re: Неисправность FM352
z; 15.5.02

Здравствуйте!

Вы программу контроллера меняли?

Re: Неисправность FM352
Виктор Лонин; 15.5.02

Нет, конечно. Более того новый модуль работает нормально на этом месте. Эти неисправности я вычислил на стенде.


text

Стандартный пароль на симатик
Виктор; 7.5.02

Азотная установка на контролере симатик с7 633 для входа в параметры промит пароль.

Пароль никто не менял , но документацию потеряли и теперь стандартный пароль никто не знает и не помнит может кто поможет

Re: Стандартный пароль на симатик
Андрей Гуленок; 7.5.02

Обычно три или четыре нуля.

Re: Стандартный пароль на симатик
Ольштейн Эдуард ОАО "Мечел"; 8.5.02

Не знаю что такое С7 633, но в панелях оператора ОР стандартный пароль - 100.


text

ASi & LOGO!
НТМК ЛСПУ; 6.5.02

Где взять информацию по работе LOGO!CM и CP243-2.

Re: ASi & LOGO!
Андрей Гуленок; 7.5.02

Как параметрировать LOGO сказано в его руководстве, а как работать с СР243-2 и раздавать адреса, так это есть отдельная книжка к СР243-2.


text

Длина кабеля при подключении термопар
Ольштейн Эдуард ОАО "Мечел"; 23.4.02

В параметрах на модули аналогового ввода указана длина кабеля экранированного 50 метров.

Это длина только подводящего медного провода (от эталонного спая до точки фиксации термосопротивления). Или суммарная длина подводящего медного провода и компенсационного провода ( от точки подключения до точки фиксации термосопротивления).

Re: Длина кабеля при подключении термопар
Гуленок Андрей; 29.4.02

Это суммарная длинна, при которой гарантируется соответствие заданным параметрам. При большей длинне работать естественно будет, но этот вариант не тестировался и никаких гарантий фирма не даёт.

Re: Длина кабеля при подключении термопар
Ольштейн Эдуард ОАО "Мечел"; 30.4.02

Спасибо. А может быть есть стандартное недорогое решение этой проблемы, кроме варианта установкм вторичного прибора с токовым выходом на каждый канал, где длина превышает 50м.

В данном случае ситуация описывается фразой -"горе от ума". В том смысле, что большинство производителей вторичных приборов и контроллеров совсем не указывают этот параметр.
Или если у кого-нибудь есть опыт подключения термопар кабелем 100м, и все нормально работает, то пожалуйста напишите здесь об этом.

Re: Длина кабеля при подключении термопар
Чистяков Дмитрий ОАО "СеверСталь"; 30.4.02

А что Вам мешает установить станцию децентрализованной периферии непосредственно рядом с датчиками?

Например, ET200M, ET200S, а для суровых условий ET200X.


text

Операционка для S7-400
Alex; 22.4.02

Тут узнали, что в контроллере S7-400 можно сменить операционку. Не подскажет ли кто ссылку по этому вопросу. Интересует как это сделать и где взять обновление.

Re: Операционка для S7-400
Андрей Гуленок; 22.4.02

Смена операционки это штатная операция описанная в руководстве. Нужен модуль памяти на 2 МБ и файл-образ, который можно скачать с www.ad.siemens.de, ну и программатор, чтобы запрограмировать модуль.

Re: Операционка для S7-400
Alex; 22.4.02

Несочтите за наглость, но нельзя ли поподробней? Какого руководства и где именно на сайте. Перед тем как задать вопрос я долго искал. Может просто не там и не то, но на www.ad.siemens.de я точно заглядывал.

Re: Операционка для S7-400
Гуленок Андрей; 29.4.02

Тогда найдите в разделе "поддержка пользователей" FAQ за номером ID 2928405. Там это как раз описано.

См. http://www.ad.siemens.de/support


text

Кабель 6ES7901-4BD00-0XA0 и выход на РС 232С
Попов Виталий ЗАО Белгородский цемент; 25.4.02

Подскажите кто знает возможно ли прямое подключение Кабель 6ES7901-4BD00-0XA0 на СОМ порт обыкновенного ноутбука. Спасибо.

Re: Кабель 6ES7901-4BD00-0XA0 и выход на РС 232С
Гуленок Андрей; 29.4.02

Невозможно


text

Converter 6ES5734-1BD20 доработать по MPI S7-313
Попов Виталий ЗАО Белгородский цемент; 25.4.02

Возможно ли кабель Converter 6ES5734-1BD20 доработать под 9-pin MPI разъём на S7-313 центральный блок

Re: Converter 6ES5734-1BD20 доработать по MPI S7-313
Михайлин Сергей; 27.4.02

Нет, нельзя.


text

Аналоговый ввод
Ольштейн Эдуард ОАО "Мечел"; 19.4.02

Не могу понять модуль аналогового ввода SM 431 AI 8*14Вit (6ES7431-1KF10-0AB0) имеет развязанные друг от друга входы или нет?

Если верить техническим параметрам: "испытательное напряжение между входами 120В перем. тока" - то это развязанные входы. Но судя по рекомендациям по подключению двухпроводных токовых преобразователейони имеют связь между собой(одно питание 24В на все каналы).
Буду благодарен за ответ.

Re: Аналоговый ввод
Александр Туманов; 24.4.02

Могу сообщить об аналоговых модулях S7-300 (уверен, что принципиальной разницы нет): аналоговые каналы разбиты по парам и в каждой паре есть общая точка; аналоговые модули гальванически развязаны от внутренней цифровой шины CPU, но не между собой; при подключении токовых входов по 4-х проводной схеме возможно придётся объединять их на клемме аналоговой земли. Вывод - вероятнее всего каналы окажутся не развязаны между собой и для некоторых схем датчиков (если заземлять датчики) вообще не работоспособны, поэтому, если нет уверенности нужно ставить модули гальванической развязки на каждый канал (40-130USD на канал).


text

совместное использование нескольких контроллеров
Данилушки Иван; 4.4.02

Здравствуйте!

Для реализации системы управления был выбран контроллер CPU 316-2DP, и несколько станций расширения ET200M. Контроллер и станции объединены по PROFIBUS. Теперь выясняется, что быстродействия контроллера недостаточно.
Вопросы:
1) имеет ли смысл докупить вместо одной из станций расширения докупить ещё один контроллер, CPU 318-2DP, и переложить на него решение части задач так, чтобы один контроллер являлся "супервизором" для другого?
2) Возможен ли вообще доступ к DB одного контроллера с другого? Если да, то нужно ли докупать какие-нибудь дополнительные модули?
3) Где про это можно почитать?

Заранее большое спасибо.
Re: совместное использование нескольких контроллеров
Чистяков Дмитрий ОАО "СеверСталь"; 5.4.02

1. Естествено, так и придётся сделать (раз уж его производительности не хватает, то тут уж ничего не поделаешь). Только вот смотря какой CPU приобрести. Может быть имеет смысл задуматься о четырехсотом?

С супервизором тут не получиться. Будет просто паралельная работа процессоров. В связи с чем необходимо будет просто разделить (распределить) задачи. Но тогда желательно и УСО (станции ET) подключить непосредственно к новому CPU. Т.к. это увеличит скорость обновления вх/вых сигналов. В противном случае, Вам придётся перекачивать все необходимые сигналы по сети, что соответственно и будет "тормозить" систему в целом.

Ещё один вариант - это приобрести удалённые станции типа IM151 CPU (ET200S). Эти станции имеют функции и параметры как CPU314. При этом Вы просто сможете перенести часть вычислений в УСО, делая предварительную обработку сигналов.

2. Данные DB одного контроллера можно пересылать в DB другого при помощи сетевого обмена. Для этого используются стандартные FC5,FC6 из NCM.

Другой способ обмена данными - это использование глобальной таблицы данных. Там Вы просто составляете таблицу, где указываете источник данных и адрес назначения. Т.е., например, слово 110 из DB 3 CPU такой-то в слово 2 DB 5 CPU такой-то. И после этого данные будут циклически обновляться (пересылаться) сами, за счёт системных действий CPU - CP.

Для всего выше описанного ничего пкупать не надо - всё уже имеется в базовом комплекте.

3. Для более полного понимания и простоты решения Вашей задачи, я бы посоветовал заказать бесплатный CD-ROM Quick Start Simatic NET. Там даны примеры и их описания для связи различных систем с различными CPU и CP. http://www4.ad.siemens.de/news/cs/en/574211
Re: совместное использование нескольких контроллеров
Логинов Павел; 10.4.02

Вопрос, насколько быстродействующие процессы вы собираетесь контролировать?

Возможно прийдется отказаться от SIEMENSа вообще.
Re: совместное использование нескольких контроллеров
Чистяков Дмитрий ОАО "СеверСталь"; 10.4.02

Ну уж прям вот сразу и отказываться от Siemens`a. ;-)

Можно ведь взять и Simatic TDC. Всё зависит от задачи.
Re: совместное использование нескольких контроллеров
aim; 10.4.02

Интересно, это для каких-же процессов не хватает производительности Simatic`a

совместное использование нескольких контроллеров
Данилушкин Иван; 10.4.02

Речь не идёт обо всём модельном ряде Сименса.

В рамках построения системы управления реализуется сначала первая очередь: AI=80, DI=330, DO=200, а затем вторая AI=80, DI=150, DO=100. Контроллер S7 316-2DP и станции расширения ET200M (10 штук). Скорость работы по PROFIBUS - 1.5 МБит/с.
Всё бы ничего, но на контроллере помимо всего прочего реализовано несколько локальных регуляторов, которые критичны даже не ко времени дискретизации, а к частоте обновления информации о состоянии процесса. Уже сейчас, когда снимается только 60 аналоговых сигналов, время обновления - 60*2.5мс=150 мс (AI: 331-7NF01-0AB0). Плюс время выполнения OB и обмен по шине ... вот и задумываемся.

С уважением ко всем.
Re: совместное использование нескольких контроллеров
siemargl; 10.4.02

Если переписать несколько участков в STL, часто можно удвоить производительность

Re: совместное использование нескольких контроллеров
Ваня; 11.4.02

Регуляторы то нужно вставлять в OB прерываний от таймера (OB35 и т.п.)

Там же и читать соответствующие аналоговые входы.
Re: Ваня
Иван Данилушкин; 11.4.02

Считывать аналоговые входы в OB35 не имеет смысла: контроллер опрашивает их по очереди и на каждый тратит 2.5 мс - время АЦ-преобразования.

Или можно как-нибуль добиться того, чтобы некоторые модули аналогового ввода опрашивались чаще, чем другие?
Re: совместное использование нескольких контроллеров
Чистяков Дмитрий ОАО "СеверСталь"; 11.4.02

Ну тут пожалуй типичный пример неправильного выбора контроллера для решения поставленной задачи. Это ктож 316-ый Simatic для регуляторов?

А вообще, что регулируете-то?
А то трудно предложить более менее оптимальный вариант для Вас.

Теперь о сети. А что мешает поднять скорость обема до 12 Мбит?

Re: совместное использование нескольких контроллеров
Логинов Павел; 11.4.02

Господа! Извините!

Никто не собирался бросать тень на замечательный Simatic. Просто времена надо считать (плюс минус лапоть) до покупки железа.
А в данной ситации, как мне кажется, стоит подумать о локальной реализации
локальных регуляторов,например на FM 355 или как предлагал Господин Чистяков
на IM 151.
Re: совместное использование нескольких контроллеров
Ваня; 11.4.02

Вы неправильно считаете времена обновления аналоговых каналов. Модуль обновляет каналы через 2.5мс*8=20мс(8-число каналов модуля). Соответственно читать входы имеет смысл в OB35 перед обработкой регулятора.

Re: Ваня
Иван Данилушкин; 11.4.02

Свои расчёты я строил на результатах эксперимента, а Вы уверены что правильно считаете? Где можно про это прочитать?

С уважением.
Большое спасибо
Иван Данилушкин; 12.4.02

Спасибо большое, за живое участие.

Впредь будем внимательнее при выборе контроллеров и способов организации распределенного управления.

С уважением ко всем.

Re: совместное использование нескольких контроллеров
Максим Елхов; 22.4.02

Тут проскочила не совсем верная трактовка. Ну снимаете Вы 60 сигналов - но быстродействие то не 60*3.0=180мс. Каждый АЦП работает самостоятельно (читай независимо от скана программы). Так что при заданной дискрете точности 9 разрядов + знак на АЦП вы получите максимальный цикл опроса на каждом модулк в 8*3=24мс. Это практически и будет временем обновления состояния процесса (надо добавить около 5-7 мс для DP при 10 слейвах). Итого 30 мс на все про все. Если влезете программой в 30 мс - то отклик на воздействие будет колебаться от 60 до 90 мс. Вам этого мало - смотрите где затык - уменьшите число каналов на АЦП - уменьшится время обновления информации о процессе. Примените модули с двумя входами - там при 10 разрядном преобразовании Вы за 6 мс ни за что не вылезете ;)

Re: совместное использование нескольких контроллеров
Ваня; 23.4.02

Это точно:)


text

cpu315-2af03
nick; 17.4.02

Help!!!

У меня Step7 v4.2 и станция на базе
cpu315-2af03, которого в HW каталоге нет. Программа и конфигурация рабочие, но для cpu315-2af01.
Сейчас cpu315-2af03 не видит ET200m.
Что делать?
Re: cpu315-2af03
Павел Иванов (Сименс-Москва); 22.4.02

Вы можете в конфигурировании HW использовать более старые версии ЦПУ.

Все будет работать, только Вам не будут доступны новые фукции, реализованные в новой версии ЦПУ.


text

Модемный модуль EM-241
Бузмаков Петр; 17.4.02

В выступлении на пресс-конференции Гельмута Гирзе был упомянут новый модемный модуль ЕМ 241 для микроконтроллера SIMATIC S7-200. Можно ли получить более подробную информацию об этом модули?

Re: Модемный модуль EM-241
Павел Иванов (Сименс-Москва); 22.4.02

В разделе "Продукты" в новостях для микросистем выложена более подробная информация об этом модуле.

См. http://www.aud.ru/as/products/01_micro/01_news/


text

связь PLC`s Siemens и Omron
Маруськевич Сергей; 18.4.02

Как связать контроллер фирмы Simemens (CPU 300 или 400) с контроллером фирмы Omron? Какое "железо" и soft для этого потребуется?

P.S. Желательно по Profibus.

Re: связь PLC`s Siemens и Omron
Михайлин Сергей; 18.4.02

Ну если желательно Profibus, то как минимум надо что бы Omron поддерживал Profibus. Дальше вопрос о протоколе: DP или FMS. DP очень прост в обращении, но надо что бы Omron мог быть либо DP-master либо DP-slave. FMS сложнее в настройке зато более универсальный, так как более низкоуровневый. Чаще всего для связи двух сторонних систем по Profibus используется именно он. Со стороны Siemens нет никаких проблем: покупается коммуникационный процессор СР343-5 или СР443-5 и все. Profibus родная сеть Siemens, а вот что может Omron - вопрос...

Re: связь PLC`s Siemens и Omron
Логинов Павел; 19.4.02

Единственный вариант - Profibus DP (Ethernet не в счет). Комуникационник для OMRON выберете из каталога (в зависимости от контроллера).Soft - Profibus DP system configurator.


text

связь между РС и S7-212
Светлана; 15.8.01

При использовании РС в качестве устройства отображения и управления (ProTool) каким образом можно осуществить связь между РС и S7-212

Re: связь между РС и S7-212
Claus; 24.8.01

Очевидно необходим PPI преобразователь.

Re: связь между РС и S7-212
alym33; 17.4.02

Sucshestvuut karty "Aplycom",Kotorye

poddergivaet MPI,DP bussystemy.
Ochen udobny v ispolzovanii,schitaet
kak Merker: M0.1,tak i "Datenbausteine":DB1.dbw1 oder db1.dbxo.1


text

Тензодатчики+SM331
Парамонов Александр; 4.2.02

Подскажите пожалуйста, можно ли подключать отечественные тензорезистивные датчики типа 9035ДСТ прямо к модулю ввода аналоговых сигналов, как датчик сопротивления. К=1,5мВ/В, Rвх=380ом, Rвых=400ом

Парамонов Александр
Re: Тензодатчики+SM331
Чистяков Дмитрий ОАО СеверСталь; 7.2.02

Ну, подключить, то можно - будет ли работать :-)

В принципе можно попробовать подключить датчик, как термопару. Но тут вопрос - надо знать схему включения Ваших тензодатчиков. Возьмите схему подключения термодатчиков к модулям SM и сравните её с Вашей схемой.

Вероятно работать будет - только вот встанет вопрос о сертификате метрологии.
Re: Тензодатчики+SM331
Sim; 17.4.02

Можно подключить.

Настраиваете канал на измерение 80мВ.
А датчик запитываете от отдельного источника питания. Далее в программе накладываете шкалу.


text

Карта диапазона для S5 модуля аналогового ввода
Зорин Николай ОАО"СПбКПК"; 12.3.02

Ребята, где можно приобрести карты выбора диапазона для модулей аналогового ввода 6ES5 460-7LA13 следующих типов:

- 6ES5 498-1AA11
- 6ES5 498-1AA21
- 6ES5 498-1AA31
- 6ES5 498-1AA41
- 6ES5 498-1AA51
- 6ES5 498-1AA61
Спасибо.

Re: Карта диапазона для S5 модуля аналогового ввода
nik; 12.4.02

hello!


text

встроенный интерфейс 316-2DP
Сергей; 1.4.02

стоит ли использовать встроенный интерфейс для связи с WinCC из соображений нагрузки на систему (около 300 сигналов, критичные ко времени алгоритмы) или лучше сразу заложить СР342-5

Re: встроенный интерфейс 316-2DP
Андрей Гуленок; 2.4.02

А это вам решать, стоит или не стоит. Другое дело, что он поддерживает только ДП протокол, а СР даст возможность использовать S7 функции.

Re: встроенный интерфейс 316-2DP
сережа; 2.4.02

спасибо, видимо не стоит...

Re: встроенный интерфейс 316-2DP
siemargl; 10.4.02

300 сигналов для S7-316 - чепуха. Обмен практически не влияет на время цикла.


text

Токовая защита LOGO! POWER
Худяков Александр; 22.2.02

Кто сможет подсказать время срабатывания защиты от токовой перегрузки на выходе LOGO! POWER 2,5.

Re: Токовая защита LOGO! POWER
Андрей Гуленок; 2.4.02

150 мсек.


text

CPU216 и CPU226 DC/DC/DC подключение входов
Кулагин Павел; 28.3.02

Для подключения входов I0.0..I1.4 к CPU216 DC/DC/DC используются датчики NPN на клемму 1M этой группы входов подаётся +24В в новой установке применён CPU226 DC/DC/DC но в описании требование поключать на эти входы датчики PNP на клемму 1M подаётся -24В и есть некое примечание "любая полярность принимается" можно ли в данном случае использовать подключение датчиков NPN с активным выходным сигналом -24В к этой группе входов подавая на клемму 1М +24В


text

S5D file format
Evgeny; 4.2.02

Hi, everyone !

I have a problem with reading files
in S5D format.

If anyone have its desc. please respond.

Thanks in advance
Re: S5D file format
Александр Туманов; 22.3.02

Уточни свой вопрос:

1. На каком носителе данных файл
2. В каком формате (DOS, CPM, PCPM)
3. Какая версия STEP5
4. Есть ли опыт работы с STEP5


text

про LOGO!
CGS; 15.3.02

когда же, наконец, будет расширена память модуля, количество выходов и входов увеличилось, а памяти мало... грустно это

Re: про LOGO!
Alex; 20.3.02

Может быть, более целесообразно оптимизировать программу? В LOGO! и так можно использовать 56 блоков в программе.

Подробную информацию об областях памяти LOGO! и ресурсах памяти Вы можете найти в Руководстве по LOGO! на русском языке п. 3.7 стр. 77 "Область памяти и размер схемы"
Re: про LOGO!
CGS; 21.3.02

:^)

К сожелению, есть множество задач, для решения которых не хватает 56 блоков в программе, те более, что на самом то деле их можно ставить значительно меньше (из-за того, что таймеры используют не по одной ячейки памяти). И это только для 8 входов и 4 выходов, а у новых модулей 24 входа и 16 выходов! Почему же тогда не увеличили память?


text

ЕТ100
Валерий Кожухов; 15.2.02

Имеется конфигурация: IM308A (на S5-135U) + "линейки" IM318 с входными цифровыми/аналоговыми модулями.

Задача: оставив периферию без изменения, убрать 135-ый Simatic, заменив его PC, а функции IM308A возложить на программу используя для связи с периферией ET100 COM порт PC.
Вопрос: сущесвуют ли библиотеки функций (для языков программирования) для связи (как например для AS511 Prodave DOS/WIn) или спецификация/описание протокола ET100?
Re: ЕТ100
Павел Иванов (Сименс-Москва); 20.3.02

Я о таких библиотеках не слышал.

Еще в 1991 году была плата ET 100-PC, которая вставлялась в ПК и была библиотека функций для нее под MS-DOS, C-DOS и FlexOS.
Но эта карта была снята с продажи лет 5 назад.

Может что-нибудь подобное осталось в другой немецкой фирме, которая делала разные коммуникационные платы - COMSOFT.

Насколько я знаю протокол ET100 был изменен, доработан и лег в основу Profibus.

Я бы поступил по другому:
- заменил головные модули ET100 на ET200. При этом у вас остануться все модули ввода-вывода, вся обвязка.
- Некоторые кабели шины ET100 можно было тоже использовать и для шины Profibus.
- и использовал стандартный модуль мастера шины Profibus - для S5-135 это IM308C

См. http://www.comsoft.de


text

Пользовательский Драйвер CP441-2
Григорий; 28.2.02

В каталоге написано, что CP441-2 может работать под управлением протокола, написанного пользователем. Где найти руководство по написанию драйвера для этого модуля и какие нужны дополнительные средства? Можно скинуть на e-mail.

Re: Пользовательский Драйвер CP441-2
Павел Иванов (Сименс-Москва); 12.3.02

Это написанов руководстве по самому CP441.

Документацию можно скачать с центрального сайта поддержки.
См. Customer Support

Re: Пользовательский Драйвер CP441-2
Григорий; 12.3.02

Если речь идет о файлах типа CP341.pdf,CP441.pdf, То там этого нет.

Re: Пользовательский Драйвер CP441-2
Павел Иванов (Сименс-Москва); 20.3.02

В руководстве по CP441 есть такая глава:

2.3.3 Parameterization Data of the ASCII Driver
В ней описана настройка пользовательского драйвера.


text

Программатор SIMATIC PG 631
Николай; 12.3.02

Уважаемые коллеги! Подскажите, пожалуйста, где можно найти описание и руководство пользователя программатора SIMATIK S5 PG 631.

Заранее благодарю.
Николай Степанов.

Re: Программатор SIMATIC PG 631
Александр; 18.3.02

Что конкретно ты хочешь? Отправь мне запрос я тебе отсканирую.


text

Документация по встроен. фун-м
Константин; 28.2.02

Кто знает где можно найти документацию

S7-300 Programmable Controller, Integrated Functions
[Программируемый контроллер S7-300, встроенные функции].
Заранее спасибо.

Re: Документация по встроен. фун-м
Павел Иванов (Сименс-Москва); 12.3.02

Если речь идет о следующем руководстве:

S7-300 Programmable Controller
Integrated Functions
CPU 312 IFM/314 IFM
то на русский язык мы его не переводили, т.к. эти ЦПУ применяются довольно редко.
Английскую документацию Вы можете скачать с центрального сайта поддержки.

В январе 2002 года вышли новые ЦПУ с интегрированными входами-выходами и технологическими функциями - для них перевели всю документация.
Она есть на нашем сайте.

См. Customer Support

Re: Документация по встроен. фун-м
Чистяков Дмитрий ОАО СеверСталь; 12.3.02

В дополнение.

А если Вас интересуют стандартные функции, то это здесь.

Справочное руководство по системным и стандартным функциям для S7-300 и S7-400 (2745.1 K, посл. обн. 22.1.02)

http://www.aud.ru/as/products/07_is/04_man/05_SFC_r.pdf


text

Связь с PG
Александров Костя; 10.1.02

Какие настройки должны быть для порта MPI в программаторе PG 720? Не получается установить режим Online с S300. Выдается сообщение "Hardware not found". И как протестировать порт ? Возможно ли это?

Re: Связь с PG
Рябов Андрей; 10.1.02

А в списке оборудования компьютера коммуникационная плата присутствует? Вообще оборудование и связь можно протестировать в "Панель управления" -> "Set PG/PC Interface" кнопка "Diagnostics...".

Re: Связь с PG
Владимир Петров, АО АВТОВАЗ; 10.3.02

Такие проблемы были. В Setup'е программатора посмотрите адрес порта MPI. Какой нужно, виноват, - не помню. Просто поставьте другой из предлагаемых.

V.Petrov@vaz.ru
Re: Связь с PG
Владимир Петров, АО АВТОВАЗ; 10.3.02

Такие проблемы были. В Setup'е программатора посмотрите адрес порта MPI. Какой нужно, виноват, - не помню. Просто поставьте другой из предлагаемых.

V.Petrov@vaz.ru


text

Simatic S5 PLC135-155
Смирнову Александру Геннадьевичу; 4.3.02

1.Быстро садится батарея поддержания памяти (при постоянно включенном контроллере за год бывае и быстрее).

2. По зипу получил процессорную плату 6ES5 948-3UA13,а в контроллере стоит 6ES5 948-3UA11.Документации по13 нет. Прошу дать рекомендации.

Re: Simatic S5 PLC135-155
aim; 5.3.02

Ничего страшного в этом нет т.к. они (с т.з. программирования) абсолютно одинаковые. Различие только в железе.

Re: Simatic S5 PLC135-155
aim; 5.3.02

Относительно батареи - скорее всего вышла из строя схема контроля разряда батареи.


text

Скоростная обработка аналоговых сигналов
Дмитрий Короткий; 21.2.02

Господа, подскажите пожалуйста, можно ли стандартными модулями аналогового ввода контроллеров S7-300 или S7-400 обрабатывать быстроменяющиеся аналоговые сигналы? Быстрота выливается в необходимость производить выборки сигнала с периодом не более 0,5ms. Приемлим вариант оцифровки аналогового сигнала с указанным периодом в течении 10-15 секунд, запись в память контроллера и, в дальнейшем, сравнительно медленная его обработка.

Ответы можно присылать по адресу kodim@fromru.com
С уважением, Дмитрий.
Re: Скоростная обработка аналоговых сигналов
Чистяков Дмитрий ОАО СеверСталь; 21.2.02

Ну в принципе это возможно.

Для этого лучше купить CPU S7-416 и аналоговые входные модули 6ES7431–1KF20–0AB0. У этих модулей время преобразования 420 мкс. Разрешение 14 бит.
Но может быть лучше подумать и применить для Ваших целей специализированные решения для записи сигналов, так называемые "чёрные ящики". У Siemens`а они называются Siemeas.
А так же обратите внимание на продукцию фирмы IBA www.iba-germany.com .
Эта фирма является партнёром Siemens.
Её устройства способны записывать до 1024 аналоговых + 1024 дискретных значений. При этом частота дискретизации достигает 25кГц.
Правда при такой частоте снижается количество возможных значений измерения. Тут всё упирается в быстродействие винчестера. Хотя фирма предлагает и RAID массивы для увеличения скорости работы (записи)


text

ЗИП для S5-150U
Сергей; 18.2.02

Уважаемые господа!

Может быть есть желание приобрести новый S5-150U с набором процессорных плат и связной 511 ,а также вся остальная начинка. Также имеются новые и б.у. на 115U.Если имеется заинтересованность - пишите на мэйл.


text

Продам CPU928 и др.
Леонид; 19.1.02

Уважаемые господа !

Продается плата PC 6ES5928-3UA12,
модуль памяти 32К.Всё новое.

Re: Продам CPU928 и др.
Vitiya; 15.2.02

Хочу ознакомиться с ценами


text

Как все-таки измеряет период модуль FM-350
Тулупова Виктория; 6.2.02

Как модуль FM 350 измеряет период? Для чего используется параметр TIME WINDOW,

задаваемый в программе конфигурации? Почему при измерении низких частот (менее 1 Гц)
в качестве измеряемого значения проскакивает ноль?

Re: Как все-таки измеряет период модуль FM-350
Чистяков Дмитрий ОАО СеверСталь; 7.2.02

В описании этого модуля глава "8.8 Period Duration Measurement" всё рассказано и имеются даже картинки.

Так вот TIME WINDOW это окно времени, в течении которого проиходит измерение. Если оно меньше чем длительность двух фронтов измеряемого сигнала, то сигнал будет установлен в "0"

Вот вырезка из описания, только картинка сюда не вставляется.
If the minimum of two rising edges were not present in the set time window, 0 is measured as the period duration (see Figure 8-12):

Возьмите описание этого модуля на сайте техподдержки на английском языке.
Re: Как все-таки измеряет период модуль FM-350
Тулупова Виктория; 7.2.02

Этот текст мы читали..

Однако при задании в программе конфигурации
TIME WINDOW равным 10 секунд и последующей загрузке
конфигурации низкие частоты измеряются
с нулями. Так при частоте 0.5 Гц каждое второе измерение
показывает 0 (как будто окно все-таки 1 секунда).
Может мы чего-нибудь не знаем про используемый процессорный
модуль (CP-315DP)?
Re: Как все-таки измеряет период модуль FM-350
Чистяков Дмитрий ОАО СеверСталь; 8.2.02

Во первых, про TIME WINDOW.

Этот параметр ограничен по нижней частоте, т.к. он "пляшет" от внутреннего генератора (1МГц). А делитель не умеет делить на ноль целых немного десятых. ;-)

Вообще, мне не совсем понятно, на кой чёрт Вам для измерения таких длительных интервалов использовать модуль FM. Ведь он разработан для того, чтобы измерять интервалы (частоту, считать импульсы и т.д.) в тех случаях, когда с этим не справляется CPU Simatic`а. Потому в FM-ке и не поддерживаются такие "медленные" вещи.

Вам можно поступить намного проще и дешевле.
Подключить сигнал к стандартному дискретному входу и измерять интервал средствами Step7.
Re: Как все-таки измеряет период модуль FM-350
Тулупова Виктория; 8.2.02

Как может повлиять внутренний генератор с частотой 1 МГц на

TIME WINDOW, задаваемое как 1000 по 100 ms?
Период измеряется с точностью до нескольких микросекунд (правда только в те
моменты, когда он измеряется). В технических характеристиках FM указано, что он может
измерять 0.008 Гц.
Насчет дискретных входов понятно, но в своей задаче мы параллельно с измерением периода и импульсы считаем,
поэтому хотелось бы использовать все-таки FM.
Кроме того, есть подозрения на CPU-315 (как будто каким-либо образом конфигурация не сохраняется).
В этом же форуме был мой вопрос про циклические прерывания (они тоже не устанавливаются).

Re: Как все-таки измеряет период модуль FM-350
Чистяков Дмитрий ОАО СеверСталь; 14.2.02

Извиняйте за задержку в ответе, но начальники ещё и работать заставляют.

Ну, во-первых, что значит «модуль» не воспринимает инициализационные данные?
Разрешили ли Вы диагностические прерывания? Если да, то на что модуль жалуется? Об этом можно посмотреть в описании в разделе 11

Во во-вторых, в пункте 6.1 описания указаны CPU с которыми работает FM. Так про 315-ый сказано, что он должен быть с заказным номером CPU 315 6ES7315-1AF01-0AB0. Проверьте, может быть Ваш CPU имеет более раннюю версию.

В третьих, проверьте правильность адресации модуля, как сказано в разделе 3.1
You can also calculate this fixed start address using the following formula:
Address = 256 + (mounting rack no. * 128) + (slot no. – 4) * 16

Вообще, 315-ый имеет не так много ресурсов по входам/выходам и памяти, и потому возможно, стоит рассмотреть «забитость» системы в целом.

Re: Как все-таки измеряет период модуль FM-350
Тулупова Виктория; 14.2.02

Конфигурация не сохраняется: изменяем период прерываний по OB35, а он реально остается 100 ms-ным (по чтению служебной переменной этого блока или внешним проявлениям типа вкл./выкл. дискретных выходов)

или изменяем злосчастное TIME_WINDOW, а оно реально остается 1-секундным (по появлению нулей при 0.5 Гц).
Возникли подозрения на CPU, потому что при загрузке новой конфигурации в диагностике появляется сообщение о каком-то конфликте конфигурационных параметров (не могу пока точно сообщить конкретный текст из-за короткого отсутствия контроллера)
Мы, как и все чайники, просто вкл. и выкл. питание контроллера и сообщение пропадает, контроллер почти работает нормально (за исключением этих временных параметров).

Спасибо за возможность получить ответ на наши вопросы.


text

ИЗМЕРЕНИЕ ПЕРИОДА FM 352
Игорь; 2.2.02

НА ЧТО ВЛИЯЕТ ПАРАМЕТР TIME_WINDOW

ПРИ ИЗМЕРЕНИИ ПЕРИОДА В ПРОГРАММЕ КОНФИГУРАЦИИ
(почему измерение периода на низких частотах (менее 1 гц) получается с провалами в измерении, то есть периодически выдается 0 а периодически измеренный период)
Как считает модуль FM-350(2)?
Тулупова Виктория; 6.2.02

Как модуль FM 350 измеряет период? Для чего используется параметр

TIME WINDOW, задаваемый в программе конфигурации? Почему при измерении
низких частот (менее 1 Гц) в качестве измеряемого значения проскакивает ноль?

Как считает модуль FM-350(2)?
Тулупова Виктория; 6.2.02

Как модуль FM 350 измеряет период? Для чего используется параметр

TIME WINDOW, задаваемый в программе конфигурации? Почему при измерении
низких частот (менее 1 Гц) в качестве измеряемого значения проскакивает ноль?


text

Использование FM4XX в H-системах
Дмитрий Д.; 30.1.02

Возможно ли использование функ. модулей серии 400 в H-системах, и если да то какие именно.

Re: Использование FM4XX в H-системах
Чистяков Дмитрий ОАО СеверСталь; 31.1.02

В описании S7-400H в приложении E-1 представлен полный перечень модулей CP и FM, работающих с системами резервиования.

Описания системы можно взять вот тут
http://www4.ad.siemens.de/news/cs/en/1186523
и
http://www4.ad.siemens.de/news/cs/en/2201072


text

Синхронизация времени
Сергей; 30.1.02

Синхронизация системного времени S7-400 - сервер WinCC. Как настроить?

Re: Синхронизация времени
Чистяков Дмитрий ОАО СеверСталь; 30.1.02

Мы так делаем очень просто - из WinCC в GlobalScript написана акция, которая циклически (каждые 30 минут)задаёт время на Simatic`и и Simadyn D.

Пришлось так делать, потому что Simadyn D не хочет синхронизироваться с Simatic`ом.


text

Надо оцифровать импульс 500 мкс
Таранов Андрей; 30.1.02

Есть задача оцифровать импульс длительностью 500 мкс, с периодом следования 5 мс, отследить его вершинку, померить амплитуду (каждого импульса), оценить крутизну фронта.

Вопрос: можно ли это сделать симатиком, если нет, то чем?
Re: Надо оцифровать импульс 500 мкс
Чистяков Дмитрий ОАО СеверСталь; 30.1.02

Ну тут можно присоветовать SIMADYN D. На Simatic`е функциональный модуль FM458.

Там можно задать время скана программы 100мкс. АЦП-эхи там тоже шустрые - 50мкс.


text

Циклические прерывания в CPU-315-2DP
Тулупова Виктория; 29.1.02

Не получается установить период прерывания для OB35, отличным от 100 миллисекунд. Значение в Hardware устанавливается, а прерывания все равно осуществляются каждые 100 миллисекунд

Re: Циклические прерывания в CPU-315-2DP
Юрий Оганесян ; 30.1.02

Убедитесь, что при Download'е Вы загрузили системные даные, а еще лучше их грузить прямо из окна Hardware Configurator. ВНИМАНИЕ: при сохранении новой конфигурации надо жать на кнопку "Сохранить и скомпилировать" а НЕ на кнопку "Сохранить"!!


text

CPU948 и IP240
Колесников Д.Ю.; 28.1.02

Стандартные функциональные блоки в связи со сменой процессора 928B на 948 не работают. В чем дело? Как наладить систему?


text

ЛОГО?
НТМК ЛСПУ; 24.1.02

Возможно ли в программно получить текущее значение реверсивного счетчика у модуля лого?

Re: ЛОГО?
Алексей Филимонов; 25.1.02

Есть две возможности: режим параметрирования - на 0ВА2 esc+ok, далее set param, далее клавишами вверх-вниз или c помощью параметрирования блока текстовых сообщений. Нужна ли более подробная информация?

Или кокое применение?

Re: ЛОГО?
НТМК, ЛСПУ; 25.1.02

Проблема немного в другом: по ходу выполнения программного цикла необходимо (в самой программе) считывать текущее значение счетчика. Или программе доступен только цифровой выход счетчика?

Re: ЛОГО?
Алексей Филимонов; 25.1.02

Вы не сможете в самой программе считывать текущее значение. LOGO! не имеет таких функций. S7-200 подходит для таких задач.


text

FM-450-1 Counter
Маруськевич Сергей; 22.1.02

Имею следующую проблему. Почему-то не сбрасывается счетчик в ноль (ACT_CNTV) при установки на входе SW_GATE из 0 в 1. Причем, на стенде (минимальная конфигурация) сброс происходит, а на действующей системе АСУТП нет. На действующей системе 2 месяца произошла авария (сгорели кабели, идущие на плату FM-450-1). После восстановления трассы, плата счетчиков сразу не заработала, ее пришлось удалить из корзины HardWare, загрузить конфигурацию (без нее) в CPU, затем снова вставить в корзину HardWare, загрузил снова в CPU, и только после этого плата счетчика заработала (глюк наверно у Siemens-а). А вот сброс счетчика в ноль так и не работает. Небольшое примечание: сброс счетчика, а если говорить точнее "запись из значения LOAD_VAL в ACT_CNTV", происходит при использовании входа L_DIRECT (0->1) происходит. А как сделать это (сброс) при использовании входа SW_GATE? Спасибо.

Маруськевич Сергей
АО "СеверСталь"

Re: FM-450-1 Counter
Чистяков Дмитрий ОАО СеверСталь; 23.1.02

Вы можете обратиться к нам в ПХЛ. Например к Анфиногенову Генадию или Кудряшову тел. 56-58-86


text

Кабель PC/PPI
Игорь Кореневский; 18.1.02

Возможно ли применение вместо кабеля PC/PPI ( связь RS232-RS485) преобразователя на микросхемах от Maxim

Re: Кабель PC/PPI
Юрий Оганесян; 21.1.02

Вы, очевидно, имеете ввиду Octagon'овские платы - тут есть тонкости:

Manual к Siemens'овскому кабелю: Кабель PC/PPI находится в режиме передачи , когда данные передаются из порта RS–232 в порт RS–485. Кабель находится в режиме приема ,
когда он не занят или передает данные из порта RS–485 в порт RS–232.
Кабель переходит из режима приема в режим передачи немедленно при
обнаружении символов в линии передачи RS–232. Кабель переключается
в режим приема , когда линия передачи RS–232 бездействует в течение
интервала времени , определенного как время реверсирования направления передачи . Это время зависит от выборанной скорости передачи
(на двухпозиционных переключателях кабеля)
А у Octagon'а направление передачи определяется не временными задержками, а наличием какого-то сигнала из ассортимента дополнительных сигналов RS-232 - какого точно не помню - врать не буду. (Хотя так и не у всех Octagon'ов - там тоже есть нормальные)

Таким образом, мое видение проблемы заключается в следующем: если Вам надо организовать программную связь, то написать программу для работы с преобразователем Octagon'a в режиме свободно программруемого порта возможно.
А Siemens'овское ПО (например Download Microwin'a) работать через другой преобразователь скоре всего не будет.

Re: Кабель PC/PPI
Юрий Оганесян; 21.1.02

Вы, очевидно, имеете ввиду Octagon'овские платы - тут есть тонкости:

Manual к Siemens'овскому кабелю: Кабель PC/PPI находится в режиме передачи , когда данные передаются из порта RS–232 в порт RS–485. Кабель находится в режиме приема ,
когда он не занят или передает данные из порта RS–485 в порт RS–232.
Кабель переходит из режима приема в режим передачи немедленно при
обнаружении символов в линии передачи RS–232. Кабель переключается
в режим приема , когда линия передачи RS–232 бездействует в течение
интервала времени , определенного как время реверсирования направления передачи . Это время зависит от выборанной скорости передачи
(на двухпозиционных переключателях кабеля)
А у Octagon'а направление передачи определяется не временными задержками, а наличием какого-то сигнала из ассортимента дополнительных сигналов RS-232 - какого точно не помню - врать не буду. (Хотя так и не у всех Octagon'ов - там тоже есть нормальные)

Таким образом, мое видение проблемы заключается в следующем: если Вам надо организовать программную связь, то написать программу для работы с преобразователем Octagon'a в режиме свободно программруемого порта возможно.
А Siemens'овское ПО (например Download Microwin'a) работать через другой преобразователь скоре всего не будет.


text

Point-to-Point Interface (PPI)
Vden; 29.12.03

Господа, подскажите пожалуйста, где найти описание PPI на русском.


text

Блок питания для CPU 224
Sergey; 25.12.03

Подскажите пожалуйста, где можно найти техническую документацию для блока питания CPU 224

Re: Блок питания для CPU 224
Симахин Александр; 26.12.03

Посмотрите ссылку выбирите там Manual-Search и сделайте поиск по номеру 6EP1332-1SH31.

Для S7-224 с релейными выходами блок питания не нужен выход 24 вольта у него свой.

См. http://www4.ad.siemens.de


text

EM235 и подобные
Виктор; 19.12.03

Хотелось бы прояснить такой вопрос.

При обращении к аналоговому входу этого модуля, подключенного к S7-200, наблюдается шум младших четырех разрядов АЦП, причем он наблюдается всегда, даже в режиме токового входа (резистор RLOOP подключен параллельно входу АЦП).Контроль осуществлялся по выводу на индикаторы контроллера.В чем тут причина? ведь для 12 разрядов это достаточно много. Все требования к качеству питания соблюдены.

Re: EM235 и подобные
fresco; 25.12.03

Причина в том что аналоговые входы для S7-200 не очень хороши. Более резкий человек мог бы назвать их отстоем...

Re: EM235 и подобные
kot; 25.12.03

Земли источника питания S7-200 и датчика объединил???


text

SIMATIC PC RI45
Alexei; 24.12.03

PC RI45. Не подскажете, какой драйвер сетевой карты идет в стандартной поставке (карта на борту). А то снесли систему, а инсталяшку потеряли.

Заранее благодарен.

Re: SIMATIC PC RI45
Евгений Трунов; 24.12.03

Там интеловская, на чипсете 82557. Intel PROSet тебя спасет. Качай из Инета и ставь.


text

S7200/300/400 и CAN
Сергей; 19.12.03

Имеется электронный блок управления, который хотелось бы включить в систему автоматизации, основанную на контроллере SIMATIC. В блоке реализован сетевой CAN-интерфейс (стандарт CAN 2.0 CiA-301). Хотелось бы узнать, есть ли коммуникационный модули у SIEMENS для подключения SIMATIC к сетям CAN. Или, может быть, кто-то посоветует какой-либо конвертор интерфейсов.

Спасибо.
Re: S7200/300/400 и CAN
Юрий; 19.12.03

У нас установлен S7400 несущий на себе коммуникационный модуль CAN-CSC515-C2, производитель ESD electronics system design gmbh (http://www.esd-electronics.com), заказной номер С.2904.xx. Кроме того даннй модуль выполнен в типоразмере для S5-115/135/155, и к нему дополнительно нужен адаптор siemens S5 ADAPTOR (6ES7-470-0AA00-0AA0)

Re: S7200/300/400 и CAN
Сергей; 22.12.03

Спасибо за ссылку. У того же производителя нашел модуль CAN-CMB-DP (Profibus-DP/CAN Gateway) со следующими свойствами:

1)fast and reliable linking ROFIBUS-DP and CAN;
2)application examples: SIMATIC-S7 to CAN layer 2 or CANopen
3)DP-slave with up to 300 bytes data (partitioning from up to 244 bytes input and 56 bytes output to 244 bytes output and 56 bytes input)

Возникает новый вопрос можно ли и как этот модуль конфигурировать в Step 7?

Re: S7200/300/400 и CAN
В. Сорокин.; 22.12.03

А к модулю GSD-файлы прилагаются. Подцепляешь их к Степу и он видит модуль.


text

Подключение сельсинов к S7
DEE; 7.8.03

Народ! Не подскажет ли кто, как завести сигнал с сельсина в контроллер серии S7. Есть ли какая-нибудь специализированная плата? Или нужен какой нибудь преобразователь?

Re: Подключение сельсинов к S7
Андрей Гуленок; 8.8.03

Самое дешовое решение - выкинуть сельсин и поставить ROD датчик. Уж больно сельсин ни в какие ворота не лезет.

Re: Подключение сельсинов к S7
В. Сорокин.; 8.8.03

Вопрос в том, какую задачу сельсин выполнял. В некоторых случаях на ФИД заменить нельзя, требуется другое решение.

Re: Подключение сельсинов к S7
DEE; 8.8.03

Да нехочет эксплуатация от сельсинов отказываться! Приходится проектировщикам под них подстраиваться и искать решения....

Re: Подключение сельсинов к S7
Виктор; 14.8.03

Ну а вчем проблема?

Он ведь вроде напряжение выдает в зависимости от положения?
Если так, то аналоговый вход. Нет?
Re: Подключение сельсинов к S7
В. Сорокин.; 14.8.03

Фазовый он, фазовый. Да ещё, поди, на 110 или 220 В. Надо строить фазовый дискриминатор ( наполовину), согласование по напряжению, выделенный сигнал превращать во что-то подходящее, чтобы засунуть в контроллер. А так как весь продвинутый мир про сельсины забыл году в 1980, то клеить придётся на резисторах, транзисторах, ОУ и 155 серии. Проще и надёжнее взять энкодер у Сименса или СКБ ИС и воткнуть взамен. Только выбрать: абсолютный или инкремент. Сельсин ведь абсолютная вещь внутри оборота. Потому и спрашивал уже: какая задача у него.

Re: Подключение сельсинов к S7
В. Сорокин.; 15.8.03

Хорошая мысля приходит опосля.

А может поставить сельсин-приёмник. На него посадить абсолютный енкодер с интерфейсом SSI, а с него взять на модуль SM338-4BC или аналогичный.

Re: Подключение сельсинов к S7
DEE; 18.8.03

Сельсины 110В 50Гц...Да, ладно, спасибо всем. Нашли тут по инету преобразователь, преобразует сигнал СД, на выходе - токовый сигнал (0-20), напряженческий, даже COM есть...Может подключаться в линию СД-СП. Возможно на нём остановимся...

Re: Подключение сельсинов к S7
В. Сорокин.; 18.8.03

Время преобразования не ограничит возможности?

Re: Подключение сельсинов к S7
DEE; 19.8.03

Всё может быть...Будем консультироваться с фирмой, которая эти преобразователи производит на предмет более подробных ТХ.

Re: Подключение сельсинов к S7
Alex; 20.12.03

А чё оьезательно подключать 110 В???:-)

10 12 Вольт тебе хватит.
Re: Подключение сельсинов к S7
Astronom; 22.12.03

А вам скорострельности аналога(цикла контроллера) хватит?

Я делал позиционирование и синхронизацию сельсиновых нажимных на РС контроллерах. Выбор на них пал не только из за дешевизны, но и за скорости считывания аналога...


text

Interface Submodule 6ES5752-0AA23
ClausMDauel; 11.11.03

Помогите разобраться. Имею см. выше, а в нем 25-пиновый разьем. Какой нужен кабель, для связи PLC S5 и PC через эту штуковину?

Re: Interface Submodule 6ES5752-0AA23
Олег; 19.12.03

ПК должен иметь последовательный порт V.24 (RS232C).

Кабель можно приобрести стандартный 726-8 (с обоих сторон 25-pin sub D male),например, 6ES5726-8CB00 длиной 10м.
Или сделать самому
см. здесь

См. см. здесь

Re: Interface Submodule 6ES5752-0AA23
ClausMauel; 20.12.03

Спасибо


text

Имитационный модуль SM374
Виктор; 19.12.03

Имеется модуль SM374 c выключателями и светодиодами. В библиотеке STEP7 его нет, в документации на него сказано, что он вставляется на место сигнального модуля для имитации его входов и выходов, но не указано на место какого именно модуля. Может кто-нибудь использовал? Сложность в том, что на SM374 задается ключом его конфигурация (кол-во входов и выходов, либо одновременно группами), и это не подходит ни под один существующий модуль. Заранее благодарен.

Re: Имитационный модуль SM374
oleg; 19.12.03

SM 321-1BH01-0AA0 16 inputs

SM 322-1BH01-0AA0 16 outputs
SM 323-1BH01-0AA0 8 inputs/ 8 outputs


text

аналоговый выход
Al-dr; 18.12.03

Re: аналоговый выход
astronom; 18.12.03

пневпораспределитель с электромагнитами

подробней можно...
у вас аналоговое управление или как)
Re: аналоговый выход
Назаров Дмитрий; 19.12.03

А не проще использовать два дискретных выхода и реле. Реле перекидывает полюса, а второе коммутирует 24В. Однозначно дешевле.

Re: аналоговый выход
В. Сорокин.; 19.12.03

А Вы сделайте повторитель на паре операционников и получите столько сколько надо.

Re: аналоговый выход
Alexander; 19.12.03

Аналоговое управление используют при пропорциональных клапанах и если не хватает выхода то нужен повторитель, а если простой двухпозиционный - то дискретные выходы, аналоговый на магнитах и выгореть может.

Re: аналоговый выход
v; 19.12.03

Al-dr, а Вы ничего не напутали?


text

Аналоговый модуль SM431 6ES7 431-7KF00-0AB0
Маруськевич Сергей; 19.12.03

Всем добрый день

Вопросы
1. Кто-нибудь использовал данный модуль?
2. Хочу подключть к нему термопару типа В. На модуле 6ES7 431-7QH00-0AB0 никаких проблем. А с этим скоростным модулем цирк какой-то: не хочет показывать(задавал mv с калибратора) то, что надо.
3. Даже простейшее подлючение источника напряжения (1..5V, +-2,5V и др) не дает нужного результата. При задании максимальных нижних и верхних пределов значения (смотрю через VAT таблицу) не дотягивает до нужных значений: я ожидаю увидеть 27648, а вижу 4000-7000.
4. Пытался откалибровать программой, входящей в состав платы - результат отрицательный

Вывод: либо я что-то не так делаю, либо Siemens в очередной раз "перестарался".
Спасибо за советы


text

LOGO --> LON
Сергей.; 18.12.03

Re: LOGO --> LON
Симахин Александр; 18.12.03

Программа LONMARK загружается в модуль CM LON при производстве.

См. http://aud.ru/as/products/doc.php?l1=Микросистемы%20LOGO!%20и%20S7-200&l2=LOGO!&l3=doc

Re: LOGO --> LON
Сергей; 18.12.03

CM LON транслирует виртуальные входы, выходы LOGO в сетевые переменные стандарта Lon works. Это я понимаю.

Из тех. Документации.
CM LON LOGO! Модуль расширения
8. Для регистрации CM LON в сети LON Works вы можете либо нажать кнопку “Service” или ввести Neuron-ID напрямую в сеть LON используя установочную программу или прочитав метку при помощи бар-код сканера.
9. После того как CM LON зарегистрирован в базе данных сети LON, он готов к работе.

Для проектирования сети Lon в режиме off-line, производители Lon устройств выпускают файлы в формате *.xif, что позволят проектировать сеть Lon, физически не подключаясь к сети. Вопрос, если ли такие файлы, для Logo, c модулем CM LON

Пример, Ваши коллеги из SBT.
http://www.lonmark.org/products/prod_search.cfm?CategoryID=-1&DeviceClassID=-1&ManufacturerID=25&UsageID=-1&TransceiverID=-1&Guideline_Version=-1&Submit=Search


text

Не грузится программа Step7 в С7-635
Андр; 15.12.03

Уважаемые коллеги!

Ни в какую не грузится программа для ПЛК, написанная в Step 7 в модную опэшку C7-635.
А программка, "написанная" в ProTool
грузится нормально.
Может кто-нибудь знает как загрузить-таки прогу из Step7 ??
Re: Не грузится программа Step7 в С7-635
VVV; 15.12.03

Попробуйте полностью сбросить память контроллера.

Re: Не грузится программа Step7 в С7-635
Андр; 15.12.03

Пробовал сбрасывать (т.е. Mres) -

ничего все равно не грузится.
Может быть нужно CPU в run переводить?
Все дело в настройках MPI наверное?
У меня сейчас у контроллера =2, а у ОР =3 адрес, может тут чего поменять??
Re: Не грузится программа Step7 в С7-635
Андр; 15.12.03

Возможно следует зайти в Control panel - S7 transfer settings и сделать backup to memory card ??

Кстати, почему нигде нет описания подробного по работе с С7-635 ??
Дайте кто-нибудь, пожалуйста.
У меня есть только с7-635e.pdf
Re: Не грузится программа Step7 в С7-635
vvv; 15.12.03

А вы пробовали при подключенном контроллере нажимать "Доступные узлы" в Степе?

Re: Не грузится программа Step7 в С7-635
ANDY; 16.12.03

Извини, с С7-635 не воевал, а с С7-633 помогало следующее:

1. Вынуть батарейку и покурить.
2. Вставить хорошую батарейку.
3. Сбросить с помощью клавиатуры ОР память контроллера и установить его в режим RUN-P.
4. Подключить PG(PC), спросить доступные узлы.
5. Появятся два узла. На узле контроллера с помощью PG(PC) сделать STOP потом RUN убеждаясь что контроллер взаимодействует с PG(PC).
6. Загрузить программу в контроллер.
Re: Не грузится программа Step7 в С7-635
Baby; 16.12.03

Привет !!!

Вдогонку ANDY....
ANDY очень подробно и правильно расписал. От себя добавлю -> желательно сначала загрузить проект Hardware, а уже потом весь проект и можно и SDB(System Data).
Re: Не грузится программа Step7 в С7-635
Андр; 16.12.03

Спасибо за участие! Вот только батарейки в 635-й нет и режима RUN-P

тоже нет.
Похоже разобрался я с 635-й так:
переключил проводок (MPI) на другой комп и сразу заработала связь, т.е. Step увидел ПЛК (display access. nodes). Так что Step надо переставлять.


text

S7-200 и стандартные сигналы
Николай Егоров; 16.12.03

Помогите чайнику. Я только начинаю работать с контроллером S7-200 и системами автоматизации.

Есть электроклапан фирмы Genebre с электронным актуатором модели
DPS 2000 http://www.diteico.com/j+j/cas-dps.htm. В системе есть PLC S7-200, который программно
должен управлять этим актуатором и читать его состояние. Взаимодействие с актуатором
и чтение его состояния производится с помощью сигнала 4-20мА или 0-10V. Все контакты
актуатора с названиями сигналов приведены в ссылке выше. Моя задача связать S7-200 с
актуатором, т.е. сделать схему электрическую принципиальную.
Мне никогда не доводилось применять стандартные сигналы 4-20мА или 0-10V и я не знаю
интерфейсы этого типа. В Интернете много сообщений об этих "стандартных сигналах", но
конкретной информации о физической реализации цепей, формирующих и принимающих эти
сигналы мне найти не удалось. А теперь вопросы.
1. Как произвести стыковку S7-200 с актуатором на физическом и программном уровне в пределах
стоящей передо мной задачей? Как это делается? Достаточно ли только аппаратных возможностей
S7-200 или нужны еще какие-либо дополнительные аппаратные компоненты?
2. Известный интерфейс "токовая петля 20мА" имеет какое-либо отношение к
"стандартному сигналу 4-20мА" или это только частичное совпадение названий?
3. Где можно найти в Инернете и прочитать конкретную информацию о физической, логической
и программной реализациях и о свойствах интерфейсов 4-20мА и 0-10V, чтобы больше не осталось вопросов на
эту тему?
4. Какой сигнал проще сформировать и обработать с помощью S7-200 4-20мА или 0-10V?
С благодарностью
Николай Егоров
Re: S7-200 и стандартные сигналы
Назаров Дмитрий; 16.12.03

Уважаемый "чайник" (можно вас так называть?)! В вашем случае может помочь простое внимательное прочтение системного руководства на контроллер S7-200. (См. ссылку) которое выложено на этом сайте. В этом руководстве подробно написано о "стандартном сигнале 4-20мА", 0-10В, способах, схемах его подключения и представлении этих сигналов в контроллере. Там же вы можете зайти в раздел "S7-200 примеры применения" и найти пример обработки аналогового сигнала в контроллере (пример №34).

Если скачивать для вас долго вы можете обратиться к ближайшему представителю СИМЕНС в регионе (см. раздел "О нас" http://www.automation-drives.ru/about/index.php) и получить или записать необходимые Вам руководства. По аппаратной части вам необходим контроллер и модуль аналогового ввода с достаточным количеством входных выходных сигналов для реализации вашей задачи.

Желаю удачи.

См. http://www.automation-drives.ru/as/products/doc.php?l1=Микросистемы%20LOGO!%20и%20S7-200&l2=S7-200&l3=doc


text

PID Self tune?
VVV; 11.12.03

Доброго времени суток!

Господа, кто нибудь знает как работать с пакетом PID Self Tune?
Доку на Сименовском диске прочитал- ничего не понятно...
Re: PID Self tune?
astronom; 11.12.03

А по моему в доке написано довольно подробно и ясно.

Прочтите ещё 2 раза)))
Но, могу сказать, что сей пакет не панацея, а ещё одна головная боль:)
Удачи

Re: PID Self tune?
VVV; 15.12.03

Может тогда Вы подскажете где что нибудь вразумительное лежит? Вот пример из документации "Загрузите пример в контроллер и наблюдайте за его работой". Ну если хотя бы проект оживить...Что за FC1, почему ее нет в примере и где ее тогда взять?

Re: PID Self tune?
Astronom; 16.12.03

Fc1 нет в примере потому что это пакет PID Self Tune, а не PID_Standard или MOD PID. Если у вас есть эти пакеты вставляйте все заработает)

Или сами стыкуйте к системным ПИДам
Удачи


text

S7400 и ET 200M
Игорь Одесса; 11.12.03

Господа подскажите,

хочу подключить Simatic ET200M к контроллеру серии S7 400 возможно ли это? В документации сказано что возможно использование ET200M в составе S7400H, а как обстоит дело с "обычными" S7400?
Re: S7400 и ET 200M
Дмитрий; 12.12.03

А какие вы видете в этом проблемы? Никаких, подключаете, работаете.

Re: S7400 и ET 200M
Игорь Одесса; 12.12.03

А можно более подробно, что использовать для подключения?

Re: S7400 и ET 200M
Baby; 14.12.03

Привет !!!!

Кабель фиолетовый .....
И разъёмы.....
Re: S7400 и ET 200M
Дмитрий; 15.12.03

Игорь Одесса! Я конечно понимаю, что хочеться все и сразу, но литературку (документацию) надо внимательней читать, потому что заниматься ы форуме пересказыванием неблагодарное дел. Кратко могу пояснить по вашему вопросу. Возьмите стойку с S7-400, соберите необходимое количество стоек с ET200M, соедините все это кабелем (фиолетовым) и разъемами RS485 не забыв включить оконечные резисторы и подключите питание по схеме. Сконфигурируйте вашу систему в STEP7 и загрузите ее в контроллер. И не забудьте написать программу!

Re: S7400 и ET 200M
Игорь Одесса; 15.12.03

Господа, что кабель фиолетовый и разъем необходим, я и сам знаю.

Но построить конфигурацию вышеописанной системы, как я уже выяснил, можно тремя способами (не считая извращений). Я рассчитывал, что кто-то предложит уже «обкатанный» вариант, а вы цирк устроили.

Re: S7400 и ET 200M
V; 15.12.03

Игорь, а что это за 3 способа? Мы всегда используем 400 контроллер с 300 периферией и именно тем способом, что описал Дмитрий...

Re: S7400 и ET 200M
м; 15.12.03

А кабель не всегда фиолетовый! :))

У нас он один раз зеленый был.
Re: S7400 и ET 200M
Чистяков Дмитрий ОАО СеверСталь; 15.12.03

Это старый Sinec L2 обзывался. Он был расчитан на работу на скороста до 1,5 мбит/c.

Насчёт подключения.
Step7 имеется?
Всё делается мышкой.
Ставь корзину.
Ставь туда источник питания и CPU.
Если у CPU имеется DP мастер, то появиться жирная полоса. Вот к ней и подноси мышкой свю станцию. Она приклеиться. :-)

Что касается примеров.
Попробуйте открыть пример, поставляемый на установочном диске. Называется он PROJECT-PROFIBUS
Re: S7400 и ET 200M
Игорь Одесса; 15.12.03

Уважаемый Чистяков Дмитрий ОАО СеверСталь, в вас однозначно пропал талант пидагога.

Всем Спасибо за дельные советы.

Re: S7400 и ET 200M
Андрей; 16.12.03

И все таки мне интересно, что это за 3 способа, и какие бывают извращения на эту тему!!!


text

Где можно найти M7-SYS
Сергей; 11.12.03

Умер модуль FM 356, нашли новый, но нужна программа M7-SYS, а SIEMENS её уже не поставляет. Не подскажете, где можно её найти?

Re: Где можно найти M7-SYS
Григорий; 11.12.03

Если речь идет о довеске к Step7, предназначенному для работы с железом типа М7, то оно у Вас должно быть на программаторе.

Если речь идет об операционной системе, то ее можно скачать с сайта Siemens в германии. Ссылку пока сказать не могу, но если идти с российского сайта -> поддержка -> customer support -> далее в дереве найти m7 -> downloads.

если что,пиши, поищу на винте.


text

ОЧЕНЬ НУЖНА ПОДРОБНАЯ ИНФОРМАЦИЯ О EM235
Sergey; 9.12.03

Простите за то, что отвлекаю, но мне действительно очень нужна информация по EM235. Если кто знает, где ее можно найти - пожалуста напишите.

Зараннее благодарен )

Re: ОЧЕНЬ НУЖНА ПОДРОБНАЯ ИНФОРМАЦИЯ О EM235
Роман Абзаев; 9.12.03

Сергей, так возьмите пакет документации по S7-200?! Там все есть.

См. Ссылка на дкументацию.

Re: ОЧЕНЬ НУЖНА ПОДРОБНАЯ ИНФОРМАЦИЯ О EM235
Спасибо, Роман.; 9.12.03

Спасибо, Роман, но у меня есть такая документация. А сейчас я по Вашей ссылке ( и не по Вашей тоже) войти туда не могу

Re: ОЧЕНЬ НУЖНА ПОДРОБНАЯ ИНФОРМАЦИЯ О EM235
MooR; 9.12.03

В вашей двухсоточной документации в папке CPU220 файл A_Specifications_r.pdf информация там


text

Считывание данных с Modbus Slave с помощью CP341
Askar; 8.12.03

Здравствуйте!

Пытаюсь считать данные с помощью
CP341-1CH01-0AE0 от сериальной платы DeltaV по Modbus:CP341-Master,плата DeltaV-Slave.RS485,полудуплекс.
Все настроечные параметры протокола одинаковые.Физическое соединение по инструкциям.Драйвер Modbus Master RTU загружен в CP341.
За основу посылки запроса и считывания данных взят example_Modbus_Master Siemens.
Slave address b#16#2
Код запроса b#16#3
Начальный адрес регистра W#16#9c41(40001 в DEC)
Количество регистров INT: 2

Программный блок SEND сообщает, что
ошибка 830-запрос послан, время ответа истекло.А RCV вообще бездействует.

В чем здесь может быть проблема?
Re: Считывание данных с Modbus Slave с помощью CP341
Алексей Родионов, ЗАО "Искра-Энергетика"; 8.12.03

Поставьте начальный адрес регистра

W#16#0000. Это и будет для данной функции адресом 40001.

Re: Считывание данных с Modbus Slave с помощью CP341
Askar; 9.12.03

Я уже пытался, результата нет.


text

Как вытянуть уже готовую прогу с PLC
Игорь; 7.12.03

Как достать программу с контролера PLC в компьютер. CP-1155 и STEP7.

Re: Как вытянуть уже готовую прогу с PLC
мимо проходил; 7.12.03

upload station

Сначала manualы почитай

Re: Как вытянуть уже готовую прогу с PLC
Игорь; 7.12.03

Почитал конечно, но боязно, вдруг машина работать перестанет.

Re: Как вытянуть уже готовую прогу с PLC
VVV; 8.12.03

Не перестанет. Главное не пишите ничего в контроллер...


text

S7-200 и siwarex M
D.M.; 28.11.03

S7-200 и siwarex M

можно каким-либо образом их связать?
Re: S7-200 и siwarex M
Дмитрий; 8.12.03

Не совсем понятно, зачем это надо, что за задача? Купите самый дешевый ЦПУ трехсотого семейства - 312 или 312С и связывайте по внутренней шине.


text

Сp441
Григорий; 2.12.03

Добрый день!

1.Имею CP441-2 с RS232. Хочу связать его с контроллером по AScii протоколу.

Как нужно сконфигурировать соединения?
В примере с СР конфигурируются два соединения. Одно на прием, одно на передачу. Или это только для связи Сименс-Сименс.

2. В форуме проскакивало сообщение, что кто-то нашел ссылку на средства создания своего протокола. Просьба сообщить ее, поскольку Сименс это только декларирует

3. если у кого есть напримеры, вышлите, если не жалко.

Re: Сp441
Дмитрий; 8.12.03

В комплекте поставки с СР441-2 идут примеры и стандартные блоки для организации связи. Насколько я видел и знаю все достаточно просто когда разберешься, а вот примеров у меня нет.


text

Доступ к S7-300 через OPC. СРОЧНО!
Дмитрий; 24.11.03

Здравствуйте. Тематика АСУ ТП для меня новая, так что простите за глупый вопрос. Необходимо получить доступ по Ethernet к контроллеру (модуль связи есть). Не подскажите название (а лучше линк)на родной OPC simens сервер. И будет ли он работать ч/з маршрутизатор (какие порты нужны). Спасибо

Re: Доступ к S7-300 через OPC. СРОЧНО!
соловьев владимир; 4.12.03

Softnet IE -- 6GK1704-1CW60-3AA0

SIMATIC NET, IND. ETHERNET SOFTNET-S7/WINDOWS V6.0 ПРОГРАММНОЕ ОБЕСПЕЧЕНИЕ ДЛЯ S7- И S5-КОММУНИКАЦИЙ ВКЛЮЧАЯ OPC, PG/OP-КОММУНИКАЦИЙ NCM PC; ДО 64 СОЕДИНЕНИЙ ПОД NT4.0 WS,SERVER; 2000PRO,SERVER
стоит 956 евро в германии (CA01 2003 rus), многие проблемы и способы их решения обсуждались на этом форуме в других ветках, и на форуме asutp@yahoogroups.com совсем недавно


text

С-613
Даутов Асет; 2.12.03

Можно ли вывести на экран сообщения на русском языке. Если возможно, то как?

Re: С-613
Юрченко Владимир; 3.12.03

В C-613 стоит панель OP3 и русский язык в ней не поддерживается


text

Сбои при программировании CP526 с FieldPGP4
Nec; 2.12.03

Столкнулся с проблемой:

При программировании или закачке программ в СР526 с программатора FieldPGP4 на плате моргает LED ошибки при обращении к плате. Не замечал ничего подобного при использовании FielgPGP3, но там связь через порт программатора, а в Р4 через дополнительный модуль I-Box (6ES7798-1AA000XA0). Кстати, какие-то проблемы при подключении к S7-300 через Profibus-FMS. Подключение к S7 пока больше нигде не проверял, а с CP526 проверил на еще одном PGP4 - то же самое.
Кто-нибудь встречался с подобным?
С уважением, Алексей.

Re: Сбои при программировании CP526 с FieldPGP4
Nec; 3.12.03

Могу добавить, что в документации по модулю СP526 написано: "загорание светодиода FAULT сигнализирует о прерывании связи с клавиатурой/программатором. Например он всегда загорается когда при рабочей плате отрываешь кабель от платы. Но он не тухнет пока не подключишь, а при связи через PGP4 моргает при каждой команде...


text

Переход на зимнее/летнее время
Дмитрий В.; 23.10.03

Добрый день!

Имеется CPU 315-2DP (6ES7315-2AG10-0AB0). Вопросы:
1. Переключение на зимнее/летнее время происходит автоматически или это нужно программировать? В каталоге ST70 (немецкая версия) я не нашел информации по этому поводу.
2. Если нужно программировать, то какие стандартные блоки имеются для этого?
3. Как обстоит дело с переключением времени для остальных CPU S7-300 и S7-400 (в общих словах)?
Вопрос важный, поскольку в программе веду архив, где фиксирую дату и время наступления события.
Заранее благодарю за ответы.
Re: Переход на зимнее/летнее время
Viktor; 23.10.03

Мы то же ведем архив на разных контроллерах, и автоматически не переходил только один- S7-314.

Re: Переход на зимнее/летнее время
Viktor; 23.10.03

Мы то же ведем архив на разных контроллерах, и автоматически не переходил только один- S7-314.

Re: Переход на зимнее/летнее время
Zorg; 24.10.03

Нужно настроить синхронизацию времени с компьютером, а компьютер переходит на зимнее/летнее время автоматически.

Re: Переход на зимнее/летнее время
Дмитрий В.; 24.10.03

Я эту проблему в общем-то уже решил. Отправив письмо, посетил A&D Support (Германия) и нашел решение подобной проблемы. Решение - платное, а вот идея этого решения бесплатная. На программном уровне необходимо использовать SFC0 (SET_CLOCK)и SFC1 (READ_CLOCK).

ZORG: компьютера нет, есть ОР270. Так что лучше реализовать в контроллере.
Re: Переход на зимнее/летнее время
marat; 3.12.03

Тоже стояла такая проблема.

В документации нашел такое решение: для контроллеров с определенной версией firmware в online режиме в HWConfig->Set Time Of Day... становится доступной кнопка "extended". (Help: You can only activate this button if the CPU supports evaluation and processing of the time-of-day status.) В новом окне можно указать когда начинается зимнее/летнее время.
Сам не проверял, у меня кнопка была заблокирована.
Если контроллеров несколько, то можно корректировать время только на одном, а другие синхронизировать с ним. Это делается просто. Время в панели тоже можно синхонизировать.


text

Проектирование сообщений alarm_sq, alarm_s (SFC17,18)
Михаил; 2.12.03

Помогите пожалуйста разобраться с системными функциями sfc17,sfc18

для генерации аварийных сообщений
может у кого нить есть документация по подробнеее об их использовании
Лучше конечно рабочий пример.
Сообщения хочу посылать в WinCC


text

Прием сигнала с интерфейсом RS-485 в контроллер
Grigoriy; 26.11.03

Господа, есть такая проблема. Датчик расхода с выходными интерфейсами RS-485 и RS-232 имеют нестандартный протокол,правда открытый для пользователя. Как завести выходной сигнал в контроллер Simatic? Понятно, что если бы датчик был один, то можно было бы поставить модуль с вышеописанными интерфейсами, но датчиков 5 и модулей ставить дорого. Может кто-нибудь подскажет решение?

Re: Прием сигнала с интерфейсом RS-485 в контроллер
Владимир, Минск; 26.11.03

Имеется в серии I7000 (ICP DAS)адресуемый преобразователь (или повторитель)RS232/RS485

(< ~70$). Для каждого модуля свой адрес и проблема решена. Так мне кажется. Надёжность в эксплуатации высокая. Имеется опыт в течении 5 лет в некомфортных условиях никаких отказов.
Re: Прием сигнала с интерфейсом RS-485 в контроллер
Владимир, Минск; 27.11.03

Дополнение и исправление.

Интерфейс RS-485 предусматривает задавать адрес для каждого устройства. Наверно в инструкции (на упомянутый расходомер)по протоколу обмена информацией с ведомым устройством (PC или PLC)это описано. А насчёт стоимости адресуемых преобразователей I752x >130$.

Re: Прием сигнала с интерфейсом RS-485 в контроллер
Дмитрий; 28.11.03

Не совсем понял какой модуль для SIMATIC имеет в виду Владимир из Минска. У СИМЕНСа два решения. Если применяется S7-200, то можно запрограммировать его RS-485 для опроса расходомера. Если S7-300 или S7-400, то приобрести свободно программируемый коммуникационный процессор СР341 или СР441 соответственно.

Re: Прием сигнала с интерфейсом RS-485 в контроллер
Grigoriy; 28.11.03

Я вас понял Владимир того что касается адресуемого преобразователя, то есть в этом случае есть возможность объединить преобразователи в сеть например Profibus DP. А насчет расходомера СПТ-961 могу сказать, что в инструкции сказано, что его можно подключить к PC через специальный адаптер по RS 485, так что адрес похоже там задать нельзя

Re: Прием сигнала с интерфейсом RS-485 в контроллер
Владимир, Минск; 28.11.03

Для Дмитрия. Модуль I7521...I7527 не Siemens!. Для каждого расходомера свой адресуемый I752x. Адрес выставляется на преобразователе (0..32 если не ошибаюсь). Информация по подобным модулям на сайте www.plcsystems.ru


text

Как защитить вход от перенапряжения?
PAV; 27.11.03

Поделитесь пожалуйсто опытом кто и как защищает входные модули от перенапряжения (в том числе и от пикового). Имеется в виду использование спец клемников и тому подобное.

Re: Как защитить вход от перенапряжения?
В. Сорокин.; 27.11.03

Должны быть такие диоды, из породы стабилитронов, с лавинным эфектом. Их сначала прошивает, а потом они восстанавливаются. Если источник лишнего напряжения не очень мощный, то его росадить можно через них на молое сопротивление.

Re: Как защитить вход от перенапряжения?
PAV; 27.11.03

Вопрос в другом, есть или нет стандартные клемники с такими диодами, если есть то поделитесь пожалуйсто кто какие клемники использует (каких фирм производителей)

Re: Как защитить вход от перенапряжения?
В. Сорокин.; 27.11.03

На счет клеммников с такими диодами - не знаю, воспоминания с советских времён.

А клеммники с встроенными предохранителями есть ф. Klemsan. Мы покупаем в Инпреде (www.inpred.ru).

Re: Как защитить вход от перенапряжения?
В.Румянцев; 27.11.03

Есть такая фирма Weidmuller, очень известный производитель клемм в том числе интересующих Вас. У нее много дистрибъютеров. Посмотреть каталог можно по этой ссылке:

http://www.weidmueller.ru/?10

Re: Как защитить вход от перенапряжения?
Дмитрий; 28.11.03

А если заглянуть в каталог СИМЕНС NSK то найдете клеммы 8WA с диодами, варисторами и т.п.


text

Как в найти максимум в массиве?
Андр; 20.11.03

Уважаемые коллеги!

Что-то не могу я найти способ определения максимума в массиве чисел типа real. Может кто подскажет что-нибудь? Неужели нет в Step7 какой стандартной функции?

Re: Как в найти максимум в массиве?
Ольга; 21.11.03

Стандартной функции в Step7 не видно. Писала FC на SCL.

Re: Как в найти максимум в массиве?
Андр; 21.11.03

Спасибо за участие. Умею писать только на STL.

Re: Как в найти максимум в массиве?
Андр; 21.11.03

Спасибо за участие. Умею писать только на STL.

Re: Как в найти максимум в массиве?
VVV; 24.11.03

Существует, же куча математических методов определения максимума. Например, пузырьковый метод...

Re: Как в найти максимум в массиве?
Евгений; 26.11.03

Вообще-то пузырьковый метод и "куча" других методов это для упорядочивания массива. А нахождение максимума во много раз элементарнее. И математикой тут не особо пахнет.

Re: Как в найти максимум в массиве?
VVV; 26.11.03

Ну да, не правильно прочитал...Ну тогда еще проще. Самый первый урок программирования в любой школе :))

Re: Как в найти максимум в массиве?
GorA; 26.11.03

В стандартной библиотеки IEC Function Blocks есть функция FC25 (MAX),которая находит максимум из трех переменных.


text

Модем для выделенной линии
Роман Абзаев; 10.7.03

Коллеги кто может подсказать модем с интерфейсом RS 485 для использования на выделенке для связи CP 340 и S7 313C-PtP?

Re: Модем для выделенной линии
kot; 11.7.03

А не проще СР340 настроить в RS232-> любой модем->выделенка->любой модем->

преобразователь RS232/MPI->S7313

Re: Модем для выделенной линии
Политов Игорь; 25.11.03

модем SATEL SATELLINE-3AS(d) подойдет


text

Измерение интервала времени больше 2ч 46м 30с
Андрей; 19.11.03

Уважаемые коллеги!

Необходимо измерить интервал времени между 2-мя битовыми фронтами.
Интервал времени больше чем 2ч 46м 30с.
Для измерения времени хочу использовать системную функцию SFC64.
Т.е. по 1-му фронту сохраняю системное время t1, по 2-му фронту сохраняю системное время t2 и нахожу разницу t2-t1, далее умножаю на 10 мс и соответственно получаю время в мс между 2-мя фронтами.
Только вот "меня терзают смутные сомнения" насчет того, что по достижении SFC64 величины 2 в 31 степени счет начинается снова с нуля. Видимо следует ловить этот переход через ноль и продолжать счет с 2 в 31 степени до "бесконечности".

Возможно существуют другие варианты??

Re: Измерение интервала времени больше 2ч 46м 30с
Игорь К; 20.11.03

Здравствуйте!

Если вы используете S7 400, можно сделатьследущее:
В ОВ36 (Прерывание 50msec)выставляется меркер
AN M 8.0
= M 8.0
В принципе если в других блоках прерываний по времени делать тоже самое (М 8.1, М8.2 и т.д) можно получить ряд импульсов заданной длительности. Затем в FC1 (к примеру)проделаем следующее:
L MB 8
L DB31.DBB 72
XOW
TAK
T DB31.DBB 72
AW
T MB 9
В db31.dbb 72 хранится старое значение генератора импульсов времени (МВ 8). В байте МВ9 получаем короткие импульсы, которые появляются через определенные промежутки времени (например М9.0 в нашем примере каждые 100 мс).
Далее организуем ряд счетчиков
A M 9.5 //импульс 1 с
JNB _006
L DB31.DBW 86 //счетчик для 1 мин. импульса
L 1
-I
T DB31.DBW 86
_006: NOP 0

в следующем Networke
A(
L DB31.DBW 86 //счетчик для 1 мин. импульса
L 0
<=I
)
= M 10.3 // 1 мин. импульс
A M 10.3
JNB _033
L 60
T DB31.DBW 86
_033: NOP 0
В конечном итоге можно получить:
M8.0 - 100ms симметричный импульс
M8.1 - 200ms симметричный импульс
M8.2 - 400ms симметричный импульс
M8.3 - 500ms симметричный импульс
M8.4 - 800ms симметричный импульс
M8.5 - 1 s симметричный импульс
M8.6 - 1.6 s симметричный импульс
M8.7 - 2 s симметричный импульс
M9.0 - 10 Гц импульс
M9.1 - 5 Гц импульс
M9.2 - 2.5 Гц импульс
M9.3 - 2 Гц импульс
M9.4 - 1.5 Гц импульс
M9.5 - 1 Гц импульс
M9.6 - 0.625 Гц импульс
M9.7 - 0.5 Гц импульс
M10.0 - 5 s импульс
M10.1 - 10 s puls
M10.2 - 30 s импульс
M10.3 - 1 min импульс
M10.4 - 5 min импульс
M10.5 - 10 min импульс
M10.6 - 30 min импульс
M10.7 - 60 min импульс
Что-то типа кварцевых часов :-)))
Меркеры можно использовать в программе как для подсчета прошедшего времени, так и для задания интервалов определенной длительности.
Re: Измерение интервала времени больше 2ч 46м 30с
Андр; 20.11.03

Я использую контроллер S7-314 (в котором есть только OB35),

на мой взгляд, как-то все непросто c вариантом "кварцевых часов".
А все-таки если использовать SFC64 ??

Что вы думаете по этому варианту ??
Re: Измерение интервала времени больше 2ч 46м 30с
Иван Данилушкин; 20.11.03

Уважаемый Андрей!

Мне кажется, вы не очень хорошо понимаете как работает функция SFC64.
1. Результат не нужно умножать на 10, чтобы получить ms.
2. 2^31 ms = 24d20h31m23s648ms
3. В трёхсотой серии счётчик не сбрасывается не на ноль, а на -2^31.
Это увеличивает временной интервал в двое.
Такие вот дела ...
Re: Измерение интервала времени больше 2ч 46м 30с
Андр; 20.11.03

Тогда получается, что после 24d20h31m23s648ms не будет 0 ms?

И 0 ms всё-таки будет после двойного интервала (24d20h31m23s648ms * 2) ??

Re: Измерение интервала времени больше 2ч 46м 30с
Андр; 20.11.03

Резюме: Что же удобнее для измерения больших интервалов времени - вариант "кварцевых часов" или вариант "SFC64" ??

Re: Измерение интервала времени больше 2ч 46м 30с
Иван Данилукшин; 20.11.03

Мы используем SFC64. При этом нужно следить за двумя вещами:

1. Чтобы засекаемый интервал времени не был больше чем 24d20h31m23s648ms * 2
2. В случае если t2<t1 рассчитывать временной интервал как 2^31-t1 + t2-(-2^31)

С уважением.

P.S. Да, что-то я заосмневался насчёт того куда сбрасывается счётчик на 0 или на -2^31. Нужно провести разведку боем :)

Re: Измерение интервала времени больше 2ч 46м 30с
Garri; 22.11.03

А я советую использовать системную функцию SFB4 (или SFB5..). Принцип использования такой же как и таймерных функций с системными ячейками-таймерами, а время измерения достигает до 24D_20H_31M_23S_647MS.

См. http://aiz@wline.ru


text

Связь PC и S5
Alex; 21.11.03

Для связи РС с S5 через модуль AS511 и для связи РС с S5-100U мне предлагают использовать кабель 6ES5734-1BD20. Плата AS511 имеет разъем 25pin, процессорный модуль 100U - 15pin.

Какой разъем на 734 кабеле?
Требуется еще какой-то адаптер?
Какой кабель надо для AS511?
Какой кабель надо для 100U?

Спасибо!


text

Ограничение функций STEP 7
Григорий; 12.11.03

Интереесует возможность блокировки функций STEP7: блокировка изменения конфигурации проекта, даже залезания в нее, просмотра проекта - доступ только к VAT, ограничение загрузкой ПО, без возможности выгрузки и т.п. Корочче говоря, определенные возможности администрирования.

Re: Ограничение функций STEP 7
Дертунов Борис; 14.11.03

А пароль не пробовали ставить на контроллер?

Re: Ограничение функций STEP 7
Григорий; 14.11.03

Пароль на контроллер вещь известная. Речь идет о передаче проекта с программатором и возможности его загрузки, при этом хочется, чтобы ручки шаловливые не лазили куда не надо.

Re: Ограничение функций STEP 7
Андрей Гуленок; 20.11.03

Ну так в STEPе три уровня паролирования. Можно как раз залочить программу, без ограничения загрузки.

Re: Ограничение функций STEP 7
SVEN; 21.11.03

А нельзя ли для начинающего юзера про три уровня по-подробнее?? Про пароль на загрузку - знаю (только если есть программатор со слотом для мемори карт и мемори карт используется для хранения программы то защита от загрузки в контроллер - пустой звук), хау-нау протекшен блоков знаю, а еще что? Очччень хочется защитить CFS, SFC и хардваре от изменений....


text

PID-регулятор
Ольштейн Эдуард "Мечел"; 29.10.03

Описание "Примеры программ для технологических функций" A5E00130042-01 4-1 по S7-300 выложенно здесь в разделе документация. В главе "Регулирование" п.4.1 Введение

сказано:
Примеры находятся на прилагаемом к вашей документации компакт-диске.
Если у вас нет этого компакт-диска, то вы можете также получить эти
примеры через Интернет.
Где бы я мог скачать эти примеры через интернет, и есть ли подобные примеры для S7-400.
Хочется отталкнутся от какого-нибудь примера. К примеру неясно зачем вызывать SFB-регулятора в OB100 и OB35,почему нельзя в циклически в OB1. Как часто вызывать OB35.К чему привязать время вызова.

Возможно в другой документации есть тексты программ поясняющих использование SFB-регуляторов. Я не нашел. Буду благодарен за подсказку.

Re: PID-регулятор
Baby; 1.11.03

Привет !!!

OB35 у нас всё делается через него.
Время вызова не к чему не привязывать.
Пусть OB35 работает сам по себе.
Если можно подробней , что Вам надо регулировать, сколко обратных связей.

Re: PID-регулятор
Ольштейн Эдуард "Мечел"; 18.11.03

Спасибо за сочувствие, Вaby. Занимаюсь контурами регулирования параметров на доменной печи.

Контура следующие
-контур регулирования давления колошникового газа;
-контур регулирования давления доменного газа на нагрев воздухонагревателе;
-контур регулирования температуры горячего дутья;
-контур регулирования соотношения природный газ – холодное дутье;
-контур регулирования подачи пара на увлажнение.

В принципе все контура с одной обратной связью.

Очень надеюсь, что наши киповцы посодействуют в наладке контуров регулировввания.
А вот для себя ставлю задачу правильно их вызвать в программе и разобраться в назначении параметров SFB.

Так же, говорят, контура могут плохо отрабатывать моменты переключения технологического оборудования, можент потребоваться дополнительное программное упреждение этих событий.

Буду благодарен, за любую информацию на эту тему.

Re: PID-регулятор
Михайлин Сергей; 18.11.03

Постараюсь объяснить зачем вызывать ПИД регулятор в ОВ35.

Не мне вам говорить, что ПИД регулятор содержит интегральную и дифференциальную настройки и уж конечно эти настройки работают не по математичекому интегралу и математической производной от исходной функции(модель объекта), все равно она "темный лес". Следовательно используется численный метод вычисления этих величин. Если Вы его вспомните, то там фигурирует, что... Правильно deltaT(элементарный промежуток времени за который вычисляется приозводная или интеграл. А посему чтобы регулятор работал действительно в режиме реального времени необходимо чтобы эта deltaT была равна действительной разнице во времени между двумя вызовами регулятора. Иначе он будет отставать или убегать от реального течения процесса(или давать погрешность регулирования). А теперь... Какой цикл ОВ1? А кто его точно знает!....
А какой цикл ОВ35? Именно тот, который Вы зададите и ни милисекундой больше или меньше. Посему по правильному, например в FB41 параметр Cycle должен быть равен времени вызова OB. Как часто вызывать регулятор, это уже по вашим требованиям к точности регулирования, а точнее к чувствительности регулирования(чтобы как раз контур чувствовал переключение оборудования например), 1 раз в секунду или чаще или реже.
Надеюсь я понятно объяснил. Добавления приветсвуются.
Остальная инфа в двухтомнике по теории управления.
ОВ100 это просто инициализационный вызов.
Re: PID-регулятор
Михайлин Сергей; 18.11.03

Кстати, в догонку...

Описанное правило действует не только для регуляторов, но и для других блоков, кторые работают с величиной deltaT для вычисления каких либо величин. Очень часто этот парметр называется Cycle или SamplT (Sampling Time)

Re: PID-регулятор
Александр Козлов; 20.11.03

Я думаю для медленных процессов использование ПИД-а в ОВ1 приемлимо


text

Преобразование REAL в INTEGER
Андрей; 4.11.03

Уважаемые коллеги!

Может быть кто-нибудь знает простой путь преобразования типа данных
REAL в INTEGER ??

Re: Преобразование REAL в INTEGER
oleg; 5.11.03

RND

Re: Преобразование REAL в INTEGER
VVS; 6.11.03

Ну, возможно ещё и RND+, RND-.

Re: Преобразование REAL в INTEGER
Андрей; 6.11.03

Уважаемые коллеги!

Хочу уточнить: преобразование REAL в Integer, состоящий из двух байт, а не двойного целого. Я тут накопал одну программку могу выслать желающим на обсуждение.

Re: Преобразование REAL в INTEGER
Bkmz; 6.11.03

Интересно, как она преобразует число типа 36000.66 :))))

Re: Преобразование REAL в INTEGER
Андрей; 17.11.03

Любопитно взглянуть на програмку, жду письма с исходниками.

Re: Преобразование REAL в INTEGER
Андрей; 17.11.03

Любопытно взглянуть на програмку, жду письма с исходниками.


text

Синхронизация времени
Олег; 4.5.03

Как синхронизировать время WinCC (то есть PC) и время слот контроллера CPU412-2 PCI. Надо чтобы PC был мастером, а CPU - слэйвом.

Других CP в компьютере нет. По этому стандартная программа синхронизации не хочет работать.

Re: Синхронизация времени
Андрей; 17.11.03

Я у себя реализовал синхронизацию, но у меня контроллер синхронизируется по WinCC. Если интересует - отвечу по e-mail.


text

Onboard счетчики на CPU314C-2
And; 30.5.03

Кто знает, как прочитать значения встроеных счетчиков CPU314C-2 напрямую через перефирийную область без использования SFB?

Re: Onboard счетчики на CPU314C-2
Андрей; 17.11.03

Интересно, а чем способ с SFB неподходит?


text

Хранение данных в S7-200
Александр; 17.11.03

Не могу понять, почему не храняться настройки передаваемые с панельки TD-200 в S7-200(CPU 222,224,226). Блок данных создаётся помощником, в системном блоке по умолчанию настроено сохранение всей области V-переменных. А они реально храняться только несколько дней. Как хоть какую-то их часть заставить храниться в энергонезависимой памяти?

Re: Хранение данных в S7-200
Александр; 17.11.03

А ты читал 5-ю главу мануала S7-22Х?

Там довольно подробно все описано.


text

S7-222 потеря функц-ти после длит. откл. пит-я
Влад Коваленко; 30.10.03

В чем могут быть причины следующей ситуации:

Есть программа работающая (CPU 222) со свободно программируемым портом (modbus, tips&triks №41 с адаптированным для 222 адресным пространством).
Все нормально работает пока с момента отключения питания контроллера не проходит большое количество времени (думаю около 8 - 12 часов, но никак не менее 3-4 часов).
После такого длительного отключения контроллер перестает откликаться на сетевые запросы в режиме freeport. При этом в этом режиме я не могу использовать пошаговую отладку. Но точно, что общий цикл контроллера работает. При этом все программы не использующие сетевой обмен так же работают.
Данный эффект сразу исчезает если я хоть как-то обращаюсь к контроллеру из Step7 (например, скачал с контроллера конфигурацию, перевел его в режим run из Step7).

Проверено на нескольких экземплярах, но все из одной партии.
Re: S7-222 потеря функц-ти после длит. откл. пит-я
Андрей Гуленок; 30.10.03

Что то я ничего не понял. Режим фреепорт исключает коммуникацию программатора по PPI. Если вы переводите контролер в фп, и то он не будет отвечать программатору, пока его не загнать в стоп. Порт то один, и как включить пошаговую отладку без связи я себе не представляю.

Re: S7-222 потеря функц-ти после длит. откл. пит-я
kot; 30.10.03

А переключатель стоит не в termе?

Re: S7-222 потеря функц-ти после длит. откл. пит-я
Влад Коваленко; 31.10.03

1. Вчера: Режим freeport работает. Выключил питание контроллера на ночь.

2. Сегодня включил питание: (положение переключателя остается в положении RUN) - нет отклика контроллера на мой запрос. Но контроллер отрабатывает дискретные входы, и даже отрабатывает обращение к порту (я проверял, вставляя в функции обработки запросов вкл. дискр. выходов)
3. a) Перевожу переключаетль в Stop. Запускаю Step7 и , например, загружаю в Step7 из контроллера конфигурацию.
Перевожу перекл. в режим RUN - мой протокол работает.
Контроллер отвечает на запросы, т.е. все работает. Выключаю контроллер (на 1-3 часа), включаю - все работает.

b) Перевожу переключаетль в Stop, потом Term. перевожу контроллер в режим RUN программно (из Step7). Контроллер отвечает на запросы, т.е. все работает. Выключаю контроллер (на 1-3 часа), включаю - все работает.

Но при этом программный цикл работает.

Вся непонятность ситуации заключается в том, что все начинает работать при хоть каком-то обращении к контроллеру из Step 7.
Если бы это была ошибка в моей программе, то как на эту ошибку может повлиять, напрмер, перевод контроллера в режим RUN из Step7 (программа не перезаписывается, ничего вообще не изменяется).

Может быть я не провоже все операции по инициализации порта, но тогда он у меня и не должен работать вообще.

Это больше похоже на защиту от использования не лецензионных программных средств. (Если бы я сам разработал программу типа Step7).

Re: S7-222 потеря функц-ти после длит. откл. пит-я
Влад Коваленко; 31.10.03

ще некоторое уточнение:

Под работой контроллера в данном контексте я понимаю работу в режиме freeport, а не возможность его программирования из Step7 (с этим проблем нет).

Под запросом здесь я понимаю modbus запрос от ЭВМ (с моим программным обеспечением) к контроллеру.

Под ответом контроллера я понимаю modbus ответ контроллера.

Re: S7-222 потеря функц-ти после длит. откл. пит-я
Влад Коваленко; 17.11.03

Проблема заключалась в неполной инициализации моей программой последовательного порта ПК.

Не была проинициализирована схема контроля четности.
При загрузки Step7 выполнял такую инициализацию, поэтому все работало.


text

Что такое "drum step number" в S5?
Л. Шерешевский; 17.11.03

Уважаемые коллеги, подскажите, пожалуйста, что означают словосочетания "drum step number" и "drum number" по отношению к S5. Они используются в WinCC при настройке соединения с S5 по TCP/IP. Несмотря на все поиски, русских аналогов этих терминов мне обнаружить не удалось, как и не удалось найти кого-либо, кто способен объяснить что эти слова означают.

Буду крайне признателен за любую информацию.


text

Eprom 6ES5-374-1KG11
Sergey; 14.11.03

Есть Eprom 6ES5-374-1KG11 нужно его перепрограмировать , а в програматоре нету такого Eprom с таким заказным номером.

Какой номер можно поставить?


text

Кабель к S5-95
walet; 12.11.03

Где можно приобрести кабель конвертор RS232/TTY для программирования S5-95?

Или подскажите его схему, распиновку разъемов.
Re: Кабель к S5-95
Ольштейн Эдуард "Мечел"; 13.11.03

Внимательно пролистайте форум за прошлые годы, там есть несколько вариантов, можно выбрать наилучший.

Re: Кабель к S5-95
San; 13.11.03

http://www.runmode.com

http://simatic.nm.ru/rs_main.htm

Re: Кабель к S5-95
walet; 14.11.03

Всем спасибо.


text

S7-200 и OP170B
Олег; 23.9.03

Можно запрограммировать S7-200 через PC/PPI адаптер, затем вытащить адаптер и воткнуть в S7-200 по MPI панельку OP170B?

Или в этом случае обязательно нужна карточка в комп для связи по MPI, как написано в инструкции на S7-200?

Re: S7-200 и OP170B
Сергей.; 30.9.03

Можно. Только неудобно отладку делать.

Re: S7-200 и OP170B
Bkmz; 13.11.03

Ну, по МПИ ничего перетыкать не надо...


text

Программная коррекция времени в CPU???
OLGA; 17.10.03

Подскажите, пжлста, как программно корректировать системное время в CPU S7-300...

Заранее благодарна...
Re: Программная коррекция времени в CPU???
Олег ; 17.10.03

Используйте системные функции SFC0 и SFC1.

Описание стандартных функций смотрите в документации на Step7

Re: Программная коррекция времени в CPU???
Илья; 13.11.03

А можно через Step7...


text

Синхрон. времени TP27 -> PLC
marat; 3.11.03

Как проще всего сделать синхронизацию времени и даты, вводимых с панели TP27, с CPU 316?

Re: Синхрон. времени TP27 -> PLC
Bkmz; 6.11.03

Через Interface Area - там есть все необходимое. Проверяли - работает :)

Да, не забудьте про соотв. SFC
Re: Синхрон. времени TP27 -> PLC
marat; 10.11.03

А в DB, соответствующем interface area, дата и время хранятся постоянно или только в момент изменения? У меня все по нулям в online. В ProTool все нормально настроено (для interface area указаны PLC и DB). Еще какие-то настройки нужны?

Re: Синхрон. времени TP27 -> PLC
marat; 12.11.03

Сам разобрался. Нужно было в этой Interface Area указать Job No. 41. Через 2-3 секунды в соответствующих байтах появляются дата и время.

Для установки даты из PLC в TP нужно указать Job No. 15. Установка времени - Job 14.

Re: Синхрон. времени TP27 -> PLC
Blmz; 13.11.03

Приятно общаться с грамотными товарищами!


text

Управление HART устройствами
Игорь Одесса; 13.11.03

Уважаемые господа,в вариантах подключения hart устройств к системе автоматики,как альтернатива подключению с ET200 Siemens указывает мультиплексор(http://www.siemens.com.ua/industry/ad/?PI/FieldSimaticPDM).

Внимание вопрос: Что это?(тех.документация) есть ли у Siemens?
Подскажите, может кто - то уже разбирался с данным вопросм.


text

BSEND SFB12 CP441-2
Ольштейн Эдуард "Мечел"; 16.10.03

Кому-нибудь приходилось использовать параметр R - Reset в SFB12. У меня SFB на него не реагирует.

Проводил такой эксперимент.

Раз в 18 секунд положительным фронтом REQ запускаю SFB12. Принимающее устройство не запущено.

На выходе CP441 семь раз с интервалом в 2 секунды мигает светодиод (как я понял из документации 6 раз STX и один раз NAK).

Мои попытки прервать передачу положительным фронтом параметра R
результата не дали. Светодиод моргает все 7 раз.

Подскажите, что же значит параметр R и как им управлять?

Re: BSEND SFB12 CP441-2
VVS; 6.11.03

R прерывает передачу (поток данных) во время обмена. Если СР молчит - нет обмена, то и смысла в этом сигнале никакого.

См. http://VVS

Re: BSEND SFB12 CP441-2
Григорий; 10.11.03

А нельзя ли ссылочку на средства разработки

Re: BSEND SFB12 CP441-2
Григорий; 10.11.03

Прошу прощения, промахнулся с окном в вопросе


text

Свой протокол для СР341
Eugen Sergeev; 25.10.03

Добрый день!

Есть ряд неких дивайсов, объединенных в сеть RS485, к ним можно обращаться своим протоколом, что-то типа <начало пакета><адрес><данные><команды><bcc><конец пакета>. Как реализовать такой протокол для модуля CP341 и загрузить его, аналогично тому, как туда загружается модбас и еще что-то, уже не помню что.

Re: Свой протокол для СР341
Дмитрий; 28.10.03

Судя по информации каталогов СИМЕНС с СР341 на диске идущем в комплекте, прилагаются средства для разработки собственного загружаемого драйвера.

Re: Свой протокол для СР341
Eugen Sergeev; 29.10.03

Да я вроде тоже эту информацию нарыл, хочется пообщаться с человеком, который это практически делал. Эти средства есть на сайте Сименса, но тянуть 25 мегабайт несколько напрягает.

Re: Свой протокол для СР341
Григорий; 10.11.03

А нельзя ли ссылочку на указанные средства


text

SM338 в центральной стойке
Олег; 10.11.03

SM338 бывают двух видов 4BC00 и 4BC01.

4BC01 может работать в так-называемом Isochrone mode. Чтобы его включить, написано что DP-мастер должен работать в режиме equidistant bus cycle, и slave должен быть синхронизирован.
А что, если у меня этот модуль не в слейве стоит, а в центральной стойке контроллера? Как включить Isochrone mode?


text

похожая история
Lego; 1.11.03

Похожая история с C7 626

Вышел из строя модуль аналоговых входов. Это что-брак производителя?
Re: похожая история
Чистяков Дмитрий ОАО СеверСталь; 3.11.03

А незадумывались над тем, что могли быть ошибки в схемотехнике подключения или землёй? :-)

Re: похожая история
Lego; 8.11.03

Машины поставлялись, монтировались и запускались в эксплуатацию немецкой фирмой. Все подключения соответствуют схемам, оставленными специалистами той-же фирмы. Если допустить, что ошибка при составлении схемы, то может подскажете что именно стоит проверить?

Re: похожая история
Чистяков Дмитрий ОАО СеверСталь; 10.11.03

Пржде всего - это землю.

Датчик и модуль (контроллер) должны быть подключены к единой земле. При этом не стоит забывать, что земля для систем автоматики (в отличии от сетей электроснабжения) должна иметь сопротивление не более 1 ома.
Попробуйте, отклюить датчик от модуля и измерьте напряжение между датчиком и контроллером.
Это для начала.


text

Игорь Одесса
Резервирование; 6.11.03

Уважаемые Господа, необходимо реализовать систему резервирования с использованием двух рабочих станций (АРМ1 - основная станция,АРМ2 - резервная)оператора(обычные ПК)с WinCC, пакета redundancy для PLC S7 300 и redundancy для WinCC. Каким образом наиболее правильно можно подключить АРМ1,АРМ2 к системе с PLC 300. Каждый PLC имеет коммуникационный процессор для синхронизации с другим PLC,к встроенному порту каждого PLC(2DP)подключены ET 200м по profibus,поддерживающие конфигурацию Redundancy.


text

Как задать адрес DP из программы
Юрий; 29.10.03

У меня есть сеть DP из 3 контроллеров S7-315-2DP (используются встроенные DP-порты) один из них мастер и два соответственно его слэйва.

Два слэйва выполняют одну и туже задачу, только на разных участках, например управляют двумя одинаковыми укладчиками.

Следовательно, программа загруженная в этих контроллерах одинаковая и отличается всего адресом сети DP.

Вопрос: Возможно, ли загрузить один и тот же проект в эти контроллеры, но при запуске контроллера по состоянию, например какого-нибудь дискретного входа, задавать им соответствующие адреса DP. Какие SFC, SFB, FC или FB надо при этом использовать?

Re: Как задать адрес DP из программы
Юрий; 29.10.03

Ответы отправляйте сюда пожалуйста

Re: Как задать адрес DP из программы
Илья; 6.11.03

Ну, вообще-то, не факт, что они работают MASTER-SLAVE. Это раз. А, во-вторых, судя по вопросу, вы не работали с Simatic S7 & PROFIBUS. Да, а зачем надо менять адрес слейва? Что-то странное с постановкой задачи. Нельзя ли подробнее?


text

Загрузка программ в S7-400
Григорий; 4.11.03

Можно ли каким-либо образом загружать программные блоки в S7-400, не используя Step7, чтобы не давать последний на объект.

Prodave позволяет грузить DB. Может есть что-либо аналогичное и для FC и FB?
Re: Загрузка программ в S7-400
Дмитрий; 5.11.03

TS адаптер и модем на объекте, у вас телесервис и вы загружаете контроллер через модем.

Загрузка программ в S7-400
Григорий; 5.11.03

Речь идет о том, чтобы не давать заказчику инструмент для модификации программ и аппаратной настройки, но оставить ему возможность восстановить систему по MPI или Profibus

Re: Загрузка программ в S7-400
Дмитрий; 6.11.03

Запишите программу на карту памяти.

Re: Загрузка программ в S7-400
VVS; 6.11.03

В процессорах 416 и выше возможно закрыть досту в PLC паролем - тоже вариант.

Re: Загрузка программ в S7-400
Bkmz; 6.11.03

Парольный доступ работает так же ина контроллерах 414 и ниже, типа S7-300 :)


text

Нужна консульатация по S5-CPU135 & video CP527
Петров Андрей; 5.11.03

Старенький CPU135 & CP527 спустя 15 лет дал сбой. Проходит сигнализация QVZ. Нам удалось определить адрес устройства, который не успевает сквитировать передачу данных. Это один модуль AI & AO. Они имеют одинаковый адрес. Но тестирование каналов показывает, что они исправны. Большую проблему вызывает видеоконтроллер CP527. Загружается стартовая картинка и все. Если кто-нибудь имел дело с этими устройствами, откликнитесь пожалуйста.

Re: Нужна консульатация по S5-CPU135 & video CP527
Nec; 6.11.03

Имел дело с СР526, что значит "стартовая картинка" (типа как BIOS компьютера или ваша исходная картинка) и "все" (не реагирует на клавиши, не показывает исходную картинку)?

С уважением, Алексей

Re: Нужна консульатация по S5-CPU135 & video CP527
Петров Андрей; 6.11.03

Загружается из EPROM первая пользовательская картинка, но дальше ничего не меняется. Не загружаются другие экраны и не реагирует на нажатие клавиатуры. Не могли бы Вы дать свои координаты.


text

Simatic PDM
Евгений; 28.10.03

Существует проблема подключения преобразователей с HART протоколом к аналоговым HART модулям в ЕТ200М. Контроллер видит первичную аналоговую величину, а другие параметры и диагностику не видит. Simatic PDM позволяет увидить эти параметры только в своем интерфейсе. Как вытащить их на верхний уровень (WinCC). Кто сталкивался с подобными задачами, поделитесь опытом.

Re: Simatic PDM
Михайлин Сергей; 3.11.03

Я подробно изучал сей вопрос. Контроллер может видет все величины из HART устройства посредством HART команд, а через адреса ввода-вывода он видит дейтсвительно только первичку. Зная формат посылки и приема и зная назначение и содержание HART комманды (их около 50) можно взять что угодно. Я сейчас пишу блок для законченой обработки HART комманд. Есть небольшое кол-во инфы. Таким образом их можно перенести в WinCC.

Теперь что касается PDM...
Объект PDM-а НЕЛЬЗЯ инкорпорировать в другую систему (WinCC или др) и использовать для on-line доступа(off-line можно через XML). Надо ставить stand alone PDM на машину, копировать урезанный проект и работать через него.
Итого два пути:
1. писать прогу в Симатике для HART обмена и выдавать инфу на WinCC (возможно если изменения не часты и не разнобразны, хотя исхитрится можно как угодно)
2. ставить в паралель или на другую машину PDM и работать с усеченным проектом, где присутсвуют только PDM объекты(не давать же доступ КИП инженеру с полному проекту)
Re: Simatic PDM
Евгений; 4.11.03

Спасибо Сергей, но это не решение проблемы. Как я понял есть возможность в процессе работы переключать первичный сигнал на отображении посредством HART команд, а полную информацию иметь только в PDM. Можно ли получить более полную информацию или где ее найти? Проект на грани провала. Заранее благодарен.

Re: Simatic PDM
Дмитрий; 4.11.03

Помнится в поставке Simatic PDM шел HART ОРС сервер. Не смотрели, может ли он получать данные с модулей ET200M?

Re: Simatic PDM
Евгений; 4.11.03

Спасибо Дмитрий за напоминание, но есть одно НО. HART OPC SERVER может помочь только в том случае, если имеется сеть HART в которой с разными адресами находится некоторое количество устройств. В данном же случае мы имеем дело с PtP соединением и каждый прибор может иметь один и тот же HART адрес, т.к. не находится в общей сети.

Re: Simatic PDM
Михайлин Сергей; 4.11.03

2 Евгений

В процесе работы через HART команды можно получить что угодно и изменить тоже что угодно. Т. е. возможно работать с HART устройвом через Симатик как через PDM. Подробности мылом отослал.

Re: Simatic PDM
Евгений; 4.11.03

Спасибо, буду разбираться.


text

как превратить ноутбук в программатор?
Мясоедов В.; 31.10.03

Имеем ноутбук без com-порта. Есть слот PC-card, USB, LPT, ИК порты, модем. Есть желание использовать его как программатор контроллеров S5.

Есть ли варианты?
Re: как превратить ноутбук в программатор?
san; 31.10.03

Можно приобрести переходник USB-Com или PCMCIA карту для Ком портов

Re: как превратить ноутбук в программатор?
Роман Абзаев; 2.11.03

Плюс USB-prommer для программирования карт памяти и софт.

Re: как превратить ноутбук в программатор?
Мясоедов В.; 3.11.03

По поводу приобретения переходника USB-Com или PCMCIA карты для Ком портов хотелось бы узнать будут ли эти устройства восприниматься Step`ом 5 как сом-порт.

Т.е. soft Siemens`а и драйвера этих устройств должны состыковаться.
Хотелось бы узнать о подобном опыте.

Re: как превратить ноутбук в программатор?
VVV; 3.11.03

По крайней мере с PG-95 все работает...

Re: как превратить ноутбук в программатор?
San; 4.11.03

Со step5 тоже работает, Надо обратить внимание, чтобы карта становилась на порты сом1 или сом2 (Для Step5 это не важно, а Step7 и ProTool могут работать только с этими портами)


text

Помогите найти руководства по C7-635
Андрей; 3.11.03

Уважаемые коллеги!

Помогите найти руководства по операторской панели C7-635.
Может есть у кого-нибудь?
Перекопал весь интернет, нашел только
С7-635 Control System

Re: Помогите найти руководства по C7-635
Роман Абзаев; 3.11.03

Пардон, какая операторская панель??? С7-635 это совмещенная система S7-314C + TP/OP170B. Если вамнжно руководство по ней то и смотрите соответствующее.

Re: Помогите найти руководства по C7-635
Дмитрий; 4.11.03

Интересно то, что нашли вы руководство в интернете правильно. По ссылке вы найдете руководство на английском

См. http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.csinfo2&siteid=cseus&aktprim=99&content=skm%2Fsearch%2Easp&lang=en&search=manuals


text

Хранение данных в S7-200
Александр; 3.11.03

Не могу понять, почему не храняться настройки передаваемые с панельки TD-200 в S7-200(CPU 222,224,226). Блок данных создаётся помощником, в системном блоке по умолчанию настроено сохранение всей области V-переменных. А они реально храняться только несколько дней. Как хоть какую-то их часть заставить храниться в энергонезависимой памяти?


text

SM431 AI8xRTDx16
GAV; 31.10.03

Имеется обозначение входов SE+, SE-, SO,AGND. В случае трехпроводного включения терморезистора где находятся токовые выходы, а где измерительные. Какие два можно объединить при трехпроводном включении.


text

S7-222 потеря функц-ти после длит. откл. пит-я
Влад Коваленко; 30.10.03

В чем могут быть причины следующей ситуации:

Есть программа работающая (CPU 222) со свободно программируемым портом (modbus, tips&triks №41 с адаптированным для 222 адресным пространством).
Все нормально работает пока с момента отключения питания контроллера не проходит большое количество времени (думаю около 8 - 12 часов, но никак не менее 3-4 часов).
После такого длительного отключения контроллер перестает откликаться на сетевые запросы в режиме freeport. При этом в этом режиме я не могу использовать пошаговую отладку. Но точно, что общий цикл контроллера работает. При этом все программы не использующие сетевой обмен так же работают.
Данный эффект сразу исчезает если я хоть как-то обращаюсь к контроллеру из Step7 (например, скачал с контроллера конфигурацию, перевел его в режим run из Step7).

Проверено на нескольких экземплярах, но все из одной партии.


text

ООчень Старая Вещь - ЧТО ЭТО???
Oleg; 28.10.03

Описание:

TI 305-01T
5 – 265 V AC 50-60Hz
5 – 30 V DC 4A RES
* 305-01T * LR 91179
Может кто знает: ЧТО ЭТО ТАКОЕ???

По процессору, кроме того, что написано в заявке, данных в инструкции больше нет.

Re: ООчень Старая Вещь - ЧТО ЭТО???
Aga; 29.10.03

OUTPUT MODULE 5A/POINT DC

http://www.kim-controls.com/PLC/DL305/dl305_relayio.htm


text

ПРОГРАМИРОВАНЬЕ 7S-300
RAJA; 2.10.03

Ми имейм в

> наличии машину, которая в себе имеет компьютер tipa Siemens
> Simatic S7-300 PCU 314, имеющий определенную программу. Но нет
> возможности ее использования, требуется проектирование и
> восстановление новой программы в S7-300.
> Просим Вас ответить о возможности восстановления программы
> или порекомендовать другие решения этого вопроса. Также просим
> направить в наш адрес номер Вашего контактного телефона.
>
>
> С уважением,
> Александр Райкович
Re: ПРОГРАМИРОВАНЬЕ 7S-300
Илья; 3.10.03

Фирма СМС-автоматизация (095)264-55-12

или обращайтесь ко мне, если вы в Поволжском регионе. (8462) 92-73-50
Илья Осовский
Re: ПРОГРАМИРОВАНЬЕ 7S-300
Роман Абзаев; 3.10.03

Или к нам, если Вы в Башкирии или Оренбурге. (3472)648243

Re: ПРОГРАМИРОВАНЬЕ 7S-300
Андрей; 3.10.03

Или ООО Балтик, если Северо-Запад. (812)113-04-66.

Re: ПРОГРАМИРОВАНЬЕ 7S-300
Андрей Данилин; 3.10.03

Или ООО ПромАвтоматика, Владивосток

(4232)28-10-34
Re: ПРОГРАМИРОВАНЬЕ 7S-300
Олег ; 17.10.03

Или ООО "Промтехмонтаж" если Вы на Урале или в Прикамье.

Re: ПРОГРАМИРОВАНЬЕ 7S-300
Astronom; 20.10.03

Инженерная фирма АО "Элакс":

Украина, г.Харьков
www.elaks.kharkov.com
Re: ПРОГРАМИРОВАНЬЕ 7S-300
Евгений; 26.10.03

ООО ПромАвтоматика г. Челябинск aeg74@mail.ru

Re: ПРОГРАМИРОВАНЬЕ 7S-300
Владимир; 27.10.03

ЗАО "ТПК Технополюс".

Москва или Словакия.
www.technopolus.ru


text

Как в программе S5 узнать номер активного DB?
Nec; 20.10.03

Здравствуйте!

Ситуация следующая:
-> Есть FB c формальным операндом типа BLOK и заданным как DB XX
-? Нужно в вызываемом в нем FB узнать номер XX блока данных заведенного формальным операндом.
-! Если вызвать его в первом DB и содержание какого-то регистра сохранить в метках, а потом косвенно обратиться? Подскажите что за регистр или область памяти?

С уважением, Алексей.
Re: Как в программе S5 узнать номер активного DB?
Валерий; 23.10.03

Номер активного блока данных это последний вызванный (открытый) командой

А DB XХ (немецк. вариант)
Или в программе в блоке FB реализована косвенная адресация?

Re: Как в программе S5 узнать номер активного DB?
Nec; 26.10.03

Спасибо, я уже нашел. Стартовый адрес активного блока данных хранится в регистре FFD0. Я просто существующий DB меняю, в нем нужно еще FB вызвать и знать какой запараметрирован в первом FB.


text

Как установить бит в S7-300
Олег; 17.10.03

Нужно из циклического прерывания OB35 устанавливать и сбрасывать один дискретный выход напрямую (не через область отображения потому как медленно), но, при этом нельзя нарушать состояние других битов этого байта.

Команды типа (T PQX13.7) не бывает в природе.
Пытался считать сначала состояние выходного байта (L PQB13), но такая команда тоже невозможна.
Остается одно, читать байт из области отображения, затем установить один из его байтов, а затем (T PQB13), но к моменту исполнения циклического прерывания информация в области отображения(QB13) может уже быть устаревшей и не отображать реальное состояние выходов (если например байт PQB13 был переписан предыдущим прерыванием, а цикл OB1 еще не закончился).
Какие выходы из данной ситуации?
Re: Как установить бит в S7-300
DRON; 22.10.03

А об такой последовательности не думали?

SET
S A13.7
Re: Как установить бит в S7-300
Oz; 24.10.03

Точнее

SET
=PQ13.7
Re: Как установить бит в S7-300
VVV; 24.10.03

Можно, например, "синхронизировать" ОВ1 и ОВ35, т.е. в начале ОВ35 устанавливать какой нибудь меркер, а в конце его сбрасывать, и в программе запретить изменение нужного байта, пока установлен этот меркер.

А какая задача стоит? Может есть другое решение?
Re: Как установить бит в S7-300
KIR; 25.10.03

Для установки (сброса) бита (напр. A0.2) можно предложить след. команды:

L AB 0
OW W#16#4
T PAB 0
S A 0.4

либо используйте SFC79 (SFC80):
CALL SFC 79
N :=1
RET_VAL:=MW222
SA :=P#0.2.


text

Просветите про S5.
Николай; 23.10.03

Какая конкретно модель не скажу. Что в них может быть? Есть ли дискретные входы/выходы? Аналоговые? Profibusы? Modbusы? Ч


text

ET200S modbus
Ушаков Николай; 23.10.03

Кто имел дело с модулем ModbusMaster(Slave)(6ES7 138-4DF10-0AB0) для ет200s. Пытался ради эксперимента связать два модуля, не проходит даже инициализация слэйва(FB не дает никаких результатов). В ссылках "S_SEND" видно что работает он через SFC14,SFC15, но при попытке отправить через них говорят что подходящего модуля нет.Поделитесь информацией или примером.


text

При включении питания загорается светодиод SF на модуле SM 331
Андрей; 23.10.03

Датчики модуля в порядке и КЗ тоже нет.

Нормальная работа модуля возможна при интенсивном прямом воздушном охлаждении.
Модуль вышел из строя и ремонту не подлежит?

Re: При включении питания загорается светодиод SF на модуле SM 331
Андрей; 23.10.03

Если при интенсивном прямом воздушном охлаждении возможна нормальная работа, то попробуй найти, что греется. Собрав стенд только с этой платой. Потом думать о причинах перегрева. Может она просто грязью заросла внутри.

Re: При включении питания загорается светодиод SF на модуле SM 331
Viktor; 23.10.03

Скорее всего ничего не греется. У нас подобная вещь была. Просто был непропай в плате, а при охлаждении контакт улучшался.


text

CPU 226+EM277
egor; 23.10.03

Имеется следующая конфигурация:

MicroWinV31SP1->CP5611->EM 277(PROFIBUS-DP)->CPU 226 AC/DC/RLY
При проведении диагностики в Set PG/PC Interface выдается сообщение о следующей ошибке: Error 0x031b: Synchronization error (problems with the PROFIBUS network)
С чем это может быть связано?


text

cpu22X, freeport mode
agg; 22.10.03

Помогите, Уважаемые.

Организовываю обмен на 38400 бод. CPU224 посылает запросы в циклическом прерывании.
1). Не могу выключить приём сбросом SM87.7, и следующая передача на него наползает. Приходится снимать режим freeport и потом криво (не в прерывании) его назначать.
2). Несвоевременные байты от slave'а вызывают останов контроллера; выход из этого состояния - только через выключение питания. А режим PPI работает стабильно - передача приостанавливается лишь при большой интенсивности "встречного движения".
Может быть, подскажете букварь с примерами?
Re: cpu22X, freeport mode
agg; 23.10.03

Вопрос снят после ознакомления с документацией по CPU22X 2003 г.

Нет проблем.


text

Redundancy на основе 400-ых
Astronom; 22.10.03

Работал ли кто-то с топологией Redundancy на основе 400-ых, но чтобы использовать встроенный интерфейс PROFIBUS, т.е. конфигурим два профибаса один Dp а другой для резервирования. При этом не использовать СР.


text

При включении питания загорается светодиод SF на модуле SM 331
Андрей; 22.10.03

При включении питания загорается светодиод SF на модуле SM 331. Отключение датчиков от входов ничего не дает. Исправен ли модуль и как это проверить?

Re: При включении питания загорается светодиод SF на модуле SM 331
DRON; 22.10.03

Где то у вас, скорее всего либо обрыв датчика, либо КЗ. А для проверки достаточно открыть конфигурацию в онлайне, и посмотреть.


text

CPU S7-315 2DP + encoder
User; 9.10.03

Гуру, помогите разобраться.

К CPU S7-315 2DP подключили инкодер TR CE65M DP v 3.0 PNO Class 2 32bits, настроили адреса (CPU - 10, encoder - 11), включили терминальные резисторы (encoder последний) и при включении на encoder мигает красный светодиод - bus fault, в диагностике пишет, что устройство не доступно. В чем грабли?
Re: CPU S7-315 2DP + encoder
Дмитрий; 10.10.03

Может скорость обмена установленная в CPU неподдерживается энкодером?

Re: CPU S7-315 2DP + encoder
User; 10.10.03

Да нет, вроде поддерживает. Такой же работает с другим контроллером S7-416 2 DP на скорости 1.5 Мб и все нормально, а с этим работать не хочет.

Re: CPU S7-315 2DP + encoder
Олег; 17.10.03

А в Step'ке энкодер прописали?

Грабли могут быть в настройках энкодера или Profibus'а


text

Процессор в Simatic S7-400
Слава; 17.10.03

Кто-нибудь знает в процессорных модулях Simatic S7-400 кроме спец. процессоров Siemens какие ещё процессоры используются - Pentium, AMD, Motorolla ...?


text

Нужен IM308 C
Михаил; 17.10.03

Срочно нужен IM308C с флэшкой, могу поменяться на что-нибудь из S5 серии:

S5-115,95,100,CP5431,CP5412 или куплю.
Предложение действительно для Москвы.


text

Переход с SIMATIC S5 на SIMATIC S7
Сергей Н.; 16.10.03

Здравствуйте господа!

Кто может что-нибудь сказать по поводу перехода с S5 155 на S7 400? Имеет ли кто такой опыт. Очень интересует переброс программы (она очень здоровая). Контроллер управляет макаронной линией. Интересует насколько сложно это все технически и программно.
Re: Переход с SIMATIC S5 на SIMATIC S7
Nec; 17.10.03

Есть только по переходу на S7-300, но наверное особенной разницы нет. Конвертировать нужно выборочно - логику конвертирует нормально, а вместо передачи данных (между DB, метками и т.д.) вставляет свои SFC. Иногда наворачивает много сохранений регистров перед простыми операциями. Сам не конвертировал, но смотрел что у других получалось - если много простой логики, то мусора будет немного.

Пиши, если что поможем.


text

Автоматика теплового узла
Сергей Александров; 16.10.03

Где взять инструкцию на RVD 235. Хэлп, мужики!


text

Переход с SIMATIC S5 на SIMATIC S7
Насибуллин Сергей; 16.10.03

Кто-нибудь имеет опыт по переходу с S5 155 на S7 400. Насколько сложно это технически и программно. Очень интересует, как сложно перебросить программку (она очень здоровая). Контроллер управляет макаронной линией. Блоки ввода-вывода, вроде-бы, должны подойти?


text

ПИД-регуляторы SFB41-43
Алексей; 10.10.03

Как известно, только CPU 314 IFM имеет встроенные SFB PID-регуляторы (SFB41,42,43).

Такой вопрос, если кто знает, какое количество PID-регуляторов этот процессор потянет?
Если более конкретно, то необходимо иметь около 30 ШИМ-регуляторов для управлением температурой нагрева:
снимаем показания термопар, нагреваем/охлаждаем тэны. Из описания ШИМ-регулятор составляется из SFB41 и SBF43. Или лучше использовать что-то другое?
Спасибо.
Re: ПИД-регуляторы SFB41-43
Дмитрий; 10.10.03

А почему бы Вам не использовать PID Temperature Control, в основе которого лежит FB58? В нем тоже есть встроенная ШИМ, встроенная оптимизация параметров ПИД-регулятора, самописец кривых в режиме online. Я использую FB58 в качестве задающего регулятора температуры для регулированя процесса нагрева на основе CPU 315-2DP (новая серия компакт). Результаты вполне приемлимые.

Re: ПИД-регуляторы SFB41-43
Алексей; 11.10.03

Да,спасибо. FB58 - то, что надо. Но вопрос такой: CPU 315-2DP имеет 64 кб рабочей памяти, а только один FB58 - 8156 байт. Т.е. я смогу сделать только порядка 5-6 регуляторов? Чтобы получить больше (20, например),то придется приобретать другой CPU c большей памятью? Или можно использовать один FB58 для разных регуляторов по принципу функций, вызывать в OB c разными параметрами? Сможете прояснить этот момент?

Re: ПИД-регуляторы SFB41-43
Astronom; 14.10.03

копируй FB58

создавай разные db которые весят 424 байт
дале считай
удачи

Re: ПИД-регуляторы SFB41-43
Сапельников Артем; 15.10.03

Если я не ошибаюсь у нового 315 128 кБ памяти. 64 было у предыдущей серии.


text

Step5 для Windows не ставится
Евгений; 14.10.03

Проблемма такая - есть Step5 версии 7.2. Так же есть даскета скопированная Анадиском по Step7 но с нужным файлом лицензии по Step5. При установки Step5 для Windows все идет ОК, прога спрашивает серийник я его ввожу, ок, далее вся инсталяция ОК.

Перезапускаю машину, запуская Step5 а он пишет что нет лицензии(с окошком дискеты разумеется все было ОК), директория почемуто не создается.
В чем трабл, помогите плиз.
В принципе пробовал так- ставлю Step7 с этой дискетой, потом ставлю Step5 и аутораном переношу лицензию по Step5, только после этого все работает,но это не выход.

Re: Step5 для Windows не ставится
ezanegin@rambler.ru; 15.10.03

После установки S-5 запустите Autors.exe (прог.для переноса авторизации) в ней выбираете какую лицензию(авторизацию)хотите перенести на Нard.Всё!

Если что-то нетак -пишите Удачи!


text

Проблемы с SM431- 7kf0-0ab0
Григорий; 14.10.03

Поставил указанный модуль, приобретенный в этом году, в корзину. Конфигурация - 7 термопар+измерение тока (4-20ма). Термопары работают без вопросов. По измерению тока проблемы:

1. На 20 ма код ~4200, вместо 26000, но меняется линейно в соответствии с изменением тока
2. При смене полярности входного тока аналогично меняется знак входного кода, словно предел симметричен +/- 20ма.

3. Также ведет себя и другой модуль из этой поставки.

4.При замене сего модуля на модуль, купленный два года назад - проблем нет. Модуль ведет себя согласно описанию.

Коды просматриваются мониторингом переменных Step 7 5.1 SP3/

Сталкивался ли кто с подобной проблемой, и является ли это дефектом?

В последнем каталоге указан диапазон +/-25 ма, однако в мануале написано, что 4-20ма также конфигурируемы. Есть ли какие-то изменения в версии программного обеспечения сего модуля (и собственно его)? И требуется ли Step7 5.2 для корректной параметризации новых модулей?

Re: Проблемы с SM431- 7kf0-0ab0
Андрей Гуленок; 15.10.03

А юзеровская рекалибровка в модули не зашивалась случайно?

Re: Проблемы с SM431- 7kf0-0ab0
Григорий; 15.10.03

1. НЕТ

2. Как это сделать? Поставляемые с модулем дискеты, как я понимаю, предназначены для калибровки термопар. Речь идет о токовом входе.

3. И почему модуль формирует отрицательный код? А не сигнал отказа.
Кстати, при диагностике модуля из STEP7, диагностика говорит, что все ОК.


text

Проблема с PS307;10A
Олег; 14.10.03

В блоке питания PS 307 потекли электролиты те которые 200В 1000мф Явной причины нет, это что брак или что ?

Re: Проблема с PS307;10A
Чистяков Дмитрий ОАО СеверСталь; 15.10.03

Всё что угодно может быть. Например:

1. Повышенная температура окружающей среды.
2. Повышенное напряжения питания подавали (не 380, а скажем 250-260 В)
3. Брак


text

длина линии измерения для аналоговых плат
Павел; 14.10.03

Для входных аналоговых плат Simatic S7-300/400 (например 331 7KF02-0AB0) указана максимальная длина кабеля 200 м.

Вопрос: при сигнале 4-20 мА насколько можно увеличить длину кабеля (разрешенная нагрузка линии при питании от платы <=820 Ом ), при какой напряженности эл.маг. поля данная длина, почему она(длина линии) одинаковая для потенциальных и токовых сигналов)?


text

Программирование S5
За Родину!; 13.10.03

Каков порядок физических действиЙ для изменения программы S5-135? Проще говоря, какой девайс куда и когда совать?

Re: Программирование S5
VVV; 14.10.03

Вопрос маленько не понятный, но обычно достаточно Step5 как софт и TTY адаптер как хард :))

Берешь в левую руку адаптер, втыкаешь его в контроллер...:))
Re: Программирование S5
VVV; 14.10.03

Вопрос маленько не понятный, но обычно достаточно Step5 как софт и TTY адаптер как хард :))

Берешь в левую руку адаптер, втыкаешь его в контроллер...:))


text

FuzzyControl++ 4.0
Astronom; 9.10.03

Не желает соединяться, стоит NT,

Вроде с помощью COML S7 сконфигурил...
все нормально Intouch-ий S7 видит VFD!!!,
а Fuffy не желает видеть и все тут пишет:
-There are no projected connectin in the online interfece
- S732.dll has error
-Invalid authorisation

путь к dll указал
в чем загвоздка?????
Help me

Re: FuzzyControl++ 4.0
Astronom; 14.10.03

Всё нормально под НТ-кой работает

загаженная ОС была, нашел другой программатор с НТ, все ОК.
Когда же немцы под 2000 сделают, а то не реально использование пакета.


text

Терминатор для IM 461-1
Shade; 14.10.03

Уважаемые господа!

Нужен ли терминатор для интерфейсного модуля IM 461-1 для неиспользуемого разъема, если "да" - то почему, его нет в СА 01? Вопрос больше к представителям Siemens, но может быть кто-нибудь опытом использования (или не использования ;-)) поделится.


text

Ошибки резервирования CPU-315-2DP
Петров Андрей; 14.10.03

При реализации резервирования на СPU 315-2DP пакетом SWRed-сy возникает ошибка в контроллере "Area length error when reading (writing)". Что это за ошибка. Вроде бы все аккуратно сконфигурил. Что интересно, пока один контроллер в стопе, у второго этих ошибок после теплого рестарта нет. Пускаю резервный и все валится. Заранее благодарен.


text

S7-200 CPU224 +OP17/PP
lyontik356; 11.10.03

Как,если это возможно, подключить эти два девайса?

Re: S7-200 CPU224 +OP17/PP
Андрей Гуленок; 13.10.03

Это не возможно. OP17/PP имел TTY интерфейс и предназначен для работы с S5 контролерами. Для связи с S7-200 нужна OP17 или OP17/DP версия панели.


text

CPU S7-315 2DP + encoder
User; 9.10.03

Гуру, помогите разобраться.

К CPU S7-315 2DP подключили инкодер TR CE65M DP v 3.0 PNO Class 2 32bits, настроили адреса (CPU - 10, encoder - 11), включили терминальные резисторы (encoder последний) и при включении на encoder мигает красный светодиод - bus fault, в диагностике пишет, что устройство не доступно. В чем грабли?


text

Не удаётся скчать программу.
Мильчук Виталий; 9.10.03

У меня ПО SIMATIC S& V 5.1.

Контроллер S7 313-2DP.
Не удаётся скачать программу с контроллера. Связь есть, при скачивании в новый проект выдаётся сообщение об ошибке.

Re: Не удаётся скчать программу.
VVV; 9.10.03

А какое сообщение?


text

S7-22X, свбд. прг. порт в срав. PPI 187.5 КБод/c
Влад Коваленко; 21.8.03

1. Почему для S7-22X есть ограничение на сокрость обмена для свободно программируемого порта 38.4 КБод/c, в то время как для PPI 187.5 КБод/с?

Или PPI обслуживает свой процессор?

2. Будет ли влиять интенсивность сетевого обмена на управляющий процесс (иными словами, подвисать) контроллера в случае PPI? (Непрерывный опрос каналов ввода-вывода).
3. В случае свободнопрограммируемго порта такая связь должна быть, т.к. ресурсы процессора используются явно, а приоритете прерываний порта выше приоритета прерываний по входам.

Из-за этого ли указано ограничение в примере 41 (Modbus) до 19.2 КБод/c?
Или я не прав?
Re: S7-22X, свбд. прг. порт в срав. PPI 187.5 КБод/c
Юрий Оганесян; 22.8.03

1. На 187.5 работатет не PPI, а MPI. Вопрос в целом очень интересный, но, думаю, ответ на него ты сам уже и написал.

2. Не замечено. Кстати, а какой софт для этой задачи подразуемавается на компьютере?
3. Логично. Только он не будет "подвисать", а будет увеличивать длительность цикла отработки программы. Вообще-то S7-200 применятеся для задач, в которых быстродействие не очень важно. Если у тебя задача серьезная, то может и не использовать S7-200, а взять что-нибудь по-мощнее?
Вообще у S7-200 есть встроенное ограничение длительности цикла что-то около 300 мс, если не ошибаюсь, но там с этим есть какие-то очень интересные особенности в отличие от S7-300, точно не помню, посмотри инструкции.
Re: S7-22X, свбд. прг. порт в срав. PPI 187.5 КБод/c
Влад Коваленко; 7.10.03

Спасибо Игорь за ответ.

Но основная проблема разрешилась путем случайного чтения английского варианта документации, в которой указаны корректные для CPU 22X данные возможности установки скорости обмена вплоть до 115200 кбод/с в режиме freeport.
Попробовал вплоть до 56700 - протокол работает.
В русском варианте указаны ошибочные данные для скоростей обмена выше 19200 кбод/с (видимо совсем древний перевод доки для 21Х серии)

1. Но тогда значит 222 поддерживает протокол MPI? (Или PPI=MPI для CPU 22X)
2. Но компе пока подразумеваться свой софт протокола modbus. На счет подвисания еще не проверял (но думуаю в пределах 2 -х месяцев результаты будут)и частота опроса скорее всего не будет чаще 100 мс. Или по крайней мере буду пачки запросов (2-3 запроса по 1-2 байта) между которыми достаточный перерыв (100-500 мс). Поэтому, предполаю, что все получиться.
3. По-мощнее - по-дороже. Да и по возможностям управлениям со слишком большим избытком будет.
Вообще-то нет жестких требований по времени (в основном моральные). Но отключиться клапан с задержкой 500 мс - ничего не произойдет за это время. Ограничение длительности цикла можно варьировать WatchDog таймером.

Re: S7-22X, свбд. прг. порт в срав. PPI 187.5 КБод/c
Андрей Гуленок; 7.10.03

1. Но тогда значит 222 поддерживает протокол MPI? (Или PPI=MPI для CPU 22X)

Все 22-ые поддерживают MPI в режиме слейва. Т е 300-ый может обмениваться с ними по Xget Xput. Надо только различать физику интерфейса и протокол обмена.
Но основная проблема разрешилась путем случайного чтения английского варианта документации, в которой указаны корректные для CPU 22X данные возможности установки скорости обмена вплоть до 115200 кбод/с в режиме freeport.
Так это и в русской доке есть. Описание SMB 30. Книга выложена на сервере.
Re: S7-22X, свбд. прг. порт в срав. PPI 187.5 КБод/c
Влад Коваленко; 8.10.03

>Так это и в русской доке есть. >Описание SMB 30. Книга выложена на >сервере.

Смотрим сайт: www.aud.ru
далее идем следующим путем
1.Продукты и решения
2. Системы автоматизации SIMATIC
3. Микросистемы
LOGO! и S7-200
4. ->S7-200
5. ->Документация
6. Системное руководство CPU 22x
7. Приложение 2 (742 Кб, обновлен 24/04/03)
Скачиваем данное приложение
(http://www.aud.ru/as/download/doc/microsystems/s7_200/B_Appendix_r.pdf)
Открываем документ и ищем описание
SMB30
На стр. 12 находим:
Таблица D−11Специальные меркеры SMB30 и SMB130
где указано следующее:
с SM30.2
по
SM30.4

bbb Скорость передачи данных
000 = 38.400 бод (в CPU 212: 19.200 бод)
001 = 19.200 бод
010 = 9.600 бод
011 = 4.800 бод
100 = 2.400 бод
101 = 1.200 бод
110 = 600 бод
111 = 300 бод

Где же тут 115200?

А какую русскую доку имели ввиду Вы?
Может быть я ни там смотрел?
Хотя на поставляем компакт диске по системам автоматизации описание аналогично.

http://www.aud.ru/as/download/doc/microsystems/s7_200/B_Appendix_r.pdf


text

горячее резервирование модулей
Александр; 25.6.03

Согласно описанию контроллеры S7-300 как ведущий DP не поддерживают горячую замену модулей в станциях ET-200M, поддерживает ли горячую замену модулей новинка CPU-315-2DP?

Re: горячее резервирование модулей
Павел Иванов (Сименс-Москва); 18.8.03

Нет не поддерживают, т.к. в них отсутствуют OB, отвечающие за горячую замену модулей (они есть только в S7-400).

Re: горячее резервирование модулей
Илья; 21.8.03

А так же в CPU318-2DP v3.0 есть ОВ83

Re: горячее резервирование модулей
Astronom; 7.10.03

ставим SP6 на 5.1 или step5.2

там почти все с гор. резервом от 315
ну или качаем из инета у немцев GSD файлы


text

Аналоговый вход
Аслан; 29.9.03

Всем привет.

Скажите пожалуйста как можно заставить вход начинать отсчет с конкретной цифры, или с сигнала (мА)
Спасибо.
С уважением Аслан
Re: Аналоговый вход
Василий; 29.9.03

Написать соответствующую программу в контроллере по обработке аналогового входа.

Re: Аналоговый вход
Аслан; 29.9.03

Спасибо за ответ, а как это сделать?

Подскажите пожалуйста.
Искал примеры в интернете, не нашел.
С уважением Аслан
Re: Аналоговый вход
Аслан; 29.9.03

Спасибо за ответ, а как это сделать?

Подскажите пожалуйста.
Искал примеры в интернете, не нашел.
С уважением Аслан
Re: Аналоговый вход
Аслан; 29.9.03

Спасибо за ответ, а как это сделать?

Подскажите пожалуйста.
Искал примеры в интернете, не нашел.
С уважением Аслан
Re: Аналоговый вход
Centurion; 7.10.03

Если речь идет о значении, получаемом от AI после старта контроллера, но до инициализации модуля AI (некоторое время после запуска OB100) то вам просто надо отслеживать появление цифры )0x7FFF насколько я помню из описания и подменять ее требуемым значением (обратите внимание это значение может появляться и после инициализации AI).

Если вам необходимо просто сдвинуть сигнал на некоторое значение, то просто добавляйте сдвиг к результату, полученому с переферийного входа


text

Программа в LOGO.Пароль.
Юрий; 2.10.03

Программа в LOGO 24 защищена паролем. Можно ли как-то пробиться в нее?

Заранее благодарен.
Re: Программа в LOGO.Пароль.
Дмитрий; 6.10.03

Не знаю точно, а скачать в LOGO!SoftComfort не пробовали?

Re: Программа в LOGO.Пароль.
Юрий; 6.10.03

К сожалению у меня нет PC кабеля...

А реально ее выкачать?

Re: Программа в LOGO.Пароль.
Дмитрий; 6.10.03

Да вот точно не помню, но кажеться можно. Тоже попробовать не на чем :-)


text

помогите считать программу S7 314
potor; 5.10.03

есть step 7 sp1, адаптер pc/mpi, при попытке считывания пишет, что неверно задан тип адаптера, надо ли указывать адрес MPI?? и откуда его взять???

Re: помогите считать программу S7 314
potor; 5.10.03

обязательно ли иметь дополнительно TeleService если адаптер TS, а программировать через модем я не собираюсь???

Re: помогите считать программу S7 314
Дмитрий; 6.10.03

Для настройки соединения с контроллером (тип адптера, адрес MPI) воспользуйтесь меню Option -> Set PG/PC Interface. Телесервис - если у вас TS адаптер иметь обязательно, т.к. драйвера для него идут вместе с этой программой. По крайней мере дистрибутив без авторизации и даже если программировать через модем необязательно.


text

счетчик импульсов
Аслан; 2.10.03

Спасибо за помощь, наконец разобрался (трудно быть по пояс деревянным, и дубовым ниже).

Всем привет.
помогите пожалуйста кто чем может, необходимо импульсы полученные с счетчика сумировать и сохранять в контролере, может у кого есть примеры для STEP7.
С уважением Чайник
Трудно быть по пояс деревянным, и дубовым ниже
Re: счетчик импульсов
Eugene Sergeev; 2.10.03

Уточните, о каком счетчике идет речь.

350-2? Или о чем-то другом?

Re: счетчик импульсов
Аслан; 2.10.03

Спасибо за ответ.

Есть счетчик газа марка СГ, у него есть импульсный выход, я хотел этот импульсный выход завести на дискретный вход контроллера CPU226, и что бы контроллер сохранял в себе количество импульсов на другом выходе,
С уважением Чайник
Re: счетчик импульсов
Аслан; 2.10.03

Спасибо за ответ.

Есть счетчик газа марка СГ, у него есть импульсный выход, я хотел этот импульсный выход завести на дискретный вход контроллера CPU226, и что бы контроллер сохранял в себе количество импульсов на другом выходе,
С уважением Чайник
Re: счетчик импульсов
Eugene Sergeev; 2.10.03

Честно говоря, не понимаю, в чем может быть проблема? В частоте импульсов?

Приходит фронт на вход - прибавляем единичку к MW. Все. А вот про "чтобы контроллер сохранял в себе количество импульсов на другом ВЫХОДЕ" эт я совсем не понял... Передавать импульсы что ли надо?
Re: счетчик импульсов
Аслан; 2.10.03

прошу прощения ,я неправильно задал вопрос, надо что бы в контроллере импульсы считывались и хранились, а сохраненное будет забирать компьютер раз в месяц и отображать накрутившийся расход.

С уважением Чайник
Re: счетчик импульсов
Dron; 3.10.03

Действительно, не понятно в чем проблема-то! Если частота импульсов приемлемая, то я проблем не вижу!

Re: счетчик импульсов
Bkmz; 3.10.03

Ну, проблема в частоте импульсов и глубине архива. А так же в стабильности электропитания.

Re: счетчик импульсов
kot; 3.10.03

Подаеш сигнал на 0(0-3)вход CPU226.

Под прерыванием от этого входа пишеш:
ld sm0.0
+r 1(а можно 0,0001),md0
ldr> 10000000,md0
movd 0.0,md0
creti
а чтобы данные хранились либо ИБП
либо в систем блоке поставь сохранить
mv0-mv20


text

Модуль 6ES7 331-7KF02-0AB0
Дмитрий; 29.9.03

Добрый день!

Имеется в стойке с CPU 315-2 DP модуль 6ES7 331-7KF02-0AB0, подключенный согласно схемы. При включении системы загорается красный светодиод SF. Читаю в HWKonfig в режиме ONLINE: отсутствует внешнее вспомогательное напряжение питания. При этом внешнее питание 24V DC имеется, поданное на ноги 1(L +24V) и 20 (M 0V). Остальные ноги не подключены.
Подскажите, пожалуйста, в чем проблема.
Спасибо.
Re: Модуль 6ES7 331-7KF02-0AB0
Илья; 3.10.03

А с модуль сигнал идет? А как стоят заглушки на модуле - в соответствии с конфигурацией? А дата сообщения текущая?

Re: Модуль 6ES7 331-7KF02-0AB0
Игорь_К; 3.10.03

Добрый день!

Скорее всего заглушки (и следовательно не совпадение конфигурации), если с внешним питанием всё нормально.
Попробуйте ОВ 85 - диагностические прерывания.


text

ET200S + S7-300
Павел; 25.9.03

Здравствуйте.

Пожайлуста поделитесь информацией о совместном использовании ET200S и S7-300.

Спасибо.

Re: ET200S + S7-300
Дмитрий; 26.9.03

Пожалуйста 315-2DP + 2 станции ЕТ200S. Скорость 12 МБ, входов-выходов дискретных 176, аналоговых 30. Все работает.

Re: ET200S + S7-300
Павел; 26.9.03

Дмитрий, насколько я понимаю в этом случае 315-2DP работает как master и вся логика сосредоточена на нем а ET200S работают в качестве slave?

Re: ET200S + S7-300
Павел; 26.9.03

Дмитрий, насколько я понимаю в этом случае 315-2DP работает как master и вся логика сосредоточена на нем а ET200S работают в качестве slave?

Re: ET200S + S7-300
Дмитрий; 27.9.03

Правильно понимаете. Лучше напишите какая проблема вас в данном случае волнует.

Re: ET200S + S7-300
Павел; 29.9.03

Дмитрий меня волнуют общие вопросы построения систем на базе ET200S и S7-300. Насколько я понял у Вас есть определенный опыт в этом. Если не сложно, то пожайлуста поделитесь информацией

Re: ET200S + S7-300
Дмитрий; 1.10.03

Павел! Что тут вам посоветовать? Изучать матчасть. В каталогах и руководствах на русском настолько все подробно расписано, что и добавить нечего. Строите систему согласно этим руководствам и все будет работать.

См. http://www.aud.ru/as/

Re: ET200S + S7-300
Павел; 1.10.03

Спасибо. А если мне необходимо подключить к S7-300 3 станции ET200S мне насколько я понимаю понадобится только 315-2DP?

Re: ET200S + S7-300
Дмитрий; 2.10.03

Правильно. Но можно поставить 313C-2DP или CPU 314 (CPU312) и СР 342-5 если эти варианты будут более выгодны с точки зрения цены и техники.

Re: ET200S + S7-300
Илья; 3.10.03

А еще есть ЕТ200S с модулем CPU - очень забавная вещица...

Re: ET200S + S7-300
Дмитрий; 3.10.03

А еще есть мастер сети PROFIBUS-DP для ET200S CPU - еще забавней!


text

CPU 315-2DP--2AG10 и метод научного тыка
Петров Андрей; 1.10.03

Не знаю почему, но рекомендуемый (www4.ad.siemens.de)софт для CPU 315-2DP-2AG10 - Step7 v5.1 sp4 и выше не работает. Метод научного тыка показал, что конфигурится контроллер только начиная с Step7 v5.2. Кто-нибудь с этим сталкивался. Это не упрек, а просто кому-нибудь на заметку.

Re: CPU 315-2DP--2AG10 и метод научного тыка
Дмитрий; 1.10.03

Мы SP4 и не ставили... Сразу SP6. Проект написанный в STEP7 v5.1 SP6 с указанным выше контроллером прекрасно работает.

Как бы с Вами связаться
Петров Андрей; 2.10.03

Дмитрий, не могли бы Вы дать свой email или телефон.

Re: CPU 315-2DP--2AG10 и метод научного тыка
Дмитрий; 2.10.03

Выслал на мейл.

Re: CPU 315-2DP--2AG10 и метод научного тыка
Роман Абзаев; 3.10.03

Вообще-то рекомндуется иметь последние версии Service Pack-ов. Почему бы Вам не обратиться в ближайшее бюро, если у вас нет возможности его скачать.


text

где скачать прогу s7microwin
sasha; 3.10.03

где скачать прогу s7microwin


text

счетчик импульсов
Аслан; 2.10.03

Спасибо за помощь, наконец разобрался (трудно быть по пояс деревянным, и дубовым ниже).

Всем привет.
помогите пожалуйста кто чем может, необходимо импульсы полученные с счетчика сумировать и сохранять в контролере, может у кого есть примеры для STEP7.
С уважением Чайник
Трудно быть по пояс деревянным, и дубовым ниже


text

Параметры
Валера; 2.10.03

Подскажите,пожалуйста,для S7-300

1.Как своей пользовательской программой
считать установленный адрес MPI?
2.Как своей пользовательской программой
можно проконтроллировать изменение положения флажка RUN/RUNP.

Заранее благодарен.


text

WinCC+S5
Sergey; 1.10.03

Не могу связать WinCC с S5-95U Sinec L2 интерфейс не DP .WinCC стоит на програматаре связной процессор СР5611

Вобще это возможно?
если возможно то как?


text

Настройка ПИД регуляторов
Михаил; 7.8.03

Расскажите кто нибудь как быстро настроить ПИД регулятор.

Re: Настройка ПИД регуляторов
Любитель Симатика; 8.8.03

Хе-хе. Быстро прочитать двухтомник теории управления. Это к вопросу КАК.

Насчет быстроты, некоторые контура несколько дней на режим выходят, а настраивают их неделями.
А по поводу настроек, то тут либо опытный технолог, либо богатый опыт, либо известный факт, либо пакеты-оптимизаторы типа PID Self Tuner.

Re: Настройка ПИД регуляторов
Михаил; 8.8.03

Помогите пожалуйста кто нибудь добыть

функциональные блоки Стандартных ПИД регуляторов (дистрибутив)
Re: Настройка ПИД регуляторов
Михаил; 8.8.03

Мне бы хотелось узнать есть ли какие либо имперические методы настройки коэффициэнтов и вообще как на практике определить возможность построения регулятора с заданной точностью регулирования. Посовейтуйте какую нибудь стоющую литературу.

Re: Настройка ПИД регуляторов
Михайлин Сергей; 8.8.03

Импирические методы конечно есть, но они основаны на параметрах объекта, т. е. надо строить модель. И точность модели, ессно, будет отражаться на настройках. Но это применяется только для первого шага. А уж оценить точность регулирования импирически вообще невозможно. Литературу можно посоветовать только, действительно, теорию управления, раздел ПИД регулирования.

Библиотеку Standart PID Control можно приобрести у нас.
Re: Настройка ПИД регуляторов
Александр; 8.8.03

Известен также ряд методов настройки ПИД регуляторов в первом приближении на основе анализа отклика системы на возмущения (Например метод Зиггер-Николсона и др.). Поищите в Интернете, спросите в любом техническом ВУЗе на кафедре электротехники, автоматики, телемеханики. На этих методах основаны куча лабораторных работ для студентов.

Re: Настройка ПИД регуляторов
Михаил; 8.8.03

Библиотеку Standart PID Control мы уже приобретали тоесть авторизация у меня есть а затерялся кудато сам дистрибутив Standart PID Control версии 5. Может можно его откуда нибудь скачать?

Re: Настройка ПИД регуляторов
Илья; 21.8.03

В стандартной библиотеке есть ПИД-регуляторы - ФБ41/42 и ФБ58/59. Софт встроен в Степ 7. 58/59 - температурные с возможностью САМОНАСТРОЙКИ. Удачи! Она понадобится...

Re: Настройка ПИД регуляторов
Михаил; 23.8.03

Илья, Извини пожалуйста, но об этих ПИД регуляторах я знаю мне же нужны другие, тоесть нужны функц. блоки которые входять в опциональную поставку а именно в Standart PID Controls V5, они имеют более расширенные возможности в частности в теме автоматизации настройки их параметров. Вот они то мне и нужны. Неужели никто небогат ими. Я бы очень сильно отблагодарил, у меня много чего есть сименского включая авторизации

Re: Настройка ПИД регуляторов
Сергей; 1.10.03

Если есть возможность напиши на аську 202732759

Какие именно нужны или просто готовые сэлплы.


text

Service Pack для CPU 315-2DP-2AG10
Петров Андрей; 30.9.03

Какой нужен SP (стоит S7 v5.1 sp4), чтобы наконец-то можно было сконфигурить резервирование в Hardware у 315-2DP-2AG10 (совсем новенького). У всех других контроллеров этой серии все получается. И вообще, где-нибудь написано, что для такого-то контроллера необходимо и достаточно sp... Заранее благодарен.

Re: Service Pack для CPU 315-2DP-2AG10
Роман Абзаев; 30.9.03

Есть такое место. Называется оно Siemens Automation & Drives Support & Services. Вот только к сожалению его мало кто смотрит. В соответствии с Siemens Automation & Drives Support & Services Entry ID: 13406642 Date: 10/25/2002

...The new CPUs can be configured with STEP 7 Version 5.1 SP4 and higher. Older STEP7 versions cannot be used for the new CPUs. The current Service Pack (SP6) can be downloaded from the Internet under the entry ID: 12642848. STEP 7 Lite will support the new CPUs from V2.0 SP1 and higher. It is expected to be available in the first quarter of 2003...
В добавлении к этому рекомендую обратить пристальное внимание на ID 12642848, а также ознакомиться с ID 13337010, 13008499 и 12643072.

См. Siemens Automation & Drives Support & Services


text

Управление МЭО
Андрей; 26.9.03

Необходимо управлять исполнительными механизмами МЭО через бесконтактный пускатель ПБР-3А на основе контроллера Simatic.

Управление:ПБР-3А - импульсами постоянного тока напряжением 24В:минус берется от источника питания =24В, встроенного в пускатель, и через контакты контроллера подается обратно на пускатель на входы больше/меньше. Частота подачи управляющих импульсов до 600 в час.
Коммутируемая нагрузка небольшая и можно применить и модуль транзисторных выходов и модуль релейных выходов.
1. При использовании модуля транзисторных выходов.
У всех данных модулей гальваническая развязка выполнена только группами по 8 каналов, а нам нужно отдельно запитывать каждую пару каналов от своего пускателя.
2. При использовании модуля релейных выходов.
Существуют модули с гальванической развязкой группами по 2 канала. Однако срок службы реле до 4 млн. срабатываний реле. Т.е. в нашем случае, при допущении о наиболее интенсивном режиме работы – срок службы около 1 года.

Что можно сделать:
1. Можно ли объединить минус всех внутренних источников питания ПБР-3А?
2. Использовать промежуточные реле?
……
Подскажите, пожалуйста, наиболее оптимальный вариант решения?
Re: Управление МЭО
Astronom; 26.9.03

а что обязательно нужно дергать МЭО 600 в час. Был проект с МЭО регулирование расходов -> температура. Просто настроил регулятор и сделал лимиты на дерганье МЭО. Уже 4 года пашет и нормально.

Удачи
Re: Управление МЭО
Валерий; 29.9.03

ставьте промежуточное реле и используйте 8 транзисторных выходов для управления 4-мя МЭО...у нас именно так работает.

Re: Управление МЭО
Василий; 29.9.03

Если у вас нагрузки небольшие и используются МЭО на 220в, то предлагаю вообще отказаться от ПБР (уж больно велики для двух симисторов и маленькой схемки управления, и управление -24в). Вместо них поставить два модуля Grayhill (70G-OAC24A)на оптодоску и управлять непосредсвенно с модуля дискретных выходов.Всё получается довольно компактно.

Проверено, работает на регуляторах несколько лет.


text

сглаживание помех (~4-7%)
Roy; 9.9.03

при работе с сигналом (4..20мА), поступающим с IQ_Radar на модуль AI8x12 bit возникли сложности по сглаживанию помех (~4-7%), шкалирую ч/з Scale,попытался изменить в хардваре,ч/з integration time.Нужно волнообразно и усредненно,посоветуте КАК.

Re: сглаживание помех (~4-7%)
В. Сорокин.; 11.9.03

Если частота стабильная или полоса не шибко широкая, то лучше поставить на входе фильтр.

Re: сглаживание помех (~4-7%)
Roy; 12.9.03

помехи не стабильные; бывают некоторые скачки до 7-10 %, но обычно ~2-4 %,если ставить фильтр, то какой?

Re: сглаживание помех (~4-7%)
В. Сорокин.; 12.9.03

Готовые редко встречаются. Надо свой сделать. Лучше активный, на операционнике, полосовой. Чтобы сигнал не давил, а помеху отсекал. Обратитесь к кому-нибудь из знакомых радиолюбителей.

Re: сглаживание помех (~4-7%)
Иван Данилушкин; 18.9.03

Есть вариант реализовать программмно фильтр скользящего среднего с ограничением на максимальную скорость изменения сигнала. Если нужен алгоритм - обращайтесь

Re: сглаживание помех (~4-7%)
Артем; 19.9.03

Вопрос конечно интересный. Первый совсем гллупый ответ, может посмотреть саму линию связи, возможно использовать двойной экран? Второй, можно попытаться отбросить младший бит, при этом точность упадет незначительно, тут, конечно, вопрос какая точность требуется.

Re: сглаживание помех (~4-7%)
Astronom; 26.9.03

попробуй взять в ModPid-у есть там фильтры 1 -го и второго порядка.

Но это действительно, зависит от хорактера помех и задачи....
Удачи


text

Подключение через RS-485
Рящиков Вячеслав; 25.9.03

Люди! Помогите!!!

Есть 50 температурных датчиков, которые соединяются в сеть по протоколу RS-485. Интерфейс известен. Надо как-то подключить эти дятчики к кнтроллеру S7-300 и написать программу для опроса этих датчиков. Подскажите, как подключить эти датчики, и какой софт надо для написания программы?
Спасибо!

Re: Подключение через RS-485
Оганесян Юрий; 25.9.03

Порты CPU S7-300 (в отличие от S7-200) не поддерживают режим свободно программируемой связи. Нужен дополнительный коммуникационный модуль СР 340(1). К ним идет софт, который представляет собой дополнение к HW Config и функциональные блоки для работы с коммуникационным процессором из программы CPU.


text

SIMADYN D STRUC L Вопрос о версиях
Богнат Владимир; 17.9.03

Можно ли используя пакет STRUC L V 4.2.7a и программатор SIMADYN D PP1X записать на модули MS41 проект созданый на STRUC L V 3.2.3.

Проект создан и оставлен на дискетах фирмой SIEMENS для системы электропривода в 1994г. Проект читается под V 4.2.7a, соответствует листингу, но при компиляции выдает ошибку: PN-COP: aborted P1-12 System and version error.
В чем здесь дело? Помогите!

Re: SIMADYN D STRUC L Вопрос о версиях
GorA; 23.9.03

Попробуйте обновить версию мастер программы и используемых функциональных пакетов, используя сервис STRUC L. Далее попробовать опять откомпилировать. Затем, возможно, придется откорректировать листинг, т.к. в более поздних версиях изменяется основная библиотека функциональных блоков.


text

Выбать "программатор"
noname; 20.9.03

Помогите выбрать систему программирования. Имеются S7-300, S5-115U, S5-100, S5-90, S5-135 и все требуют "заботы". А чем их юзать определиться трудно. За notebook' проблемы не станут.

Re: Выбать
Дмитрий; 22.9.03

Надо купить STEP5 и STEP7, плюс кабели связи.

Re: Выбать
Роман Абзаев; 22.9.03

Плюс USB-проммер для карт/модулей памяти.

Re: Выбать
Дмитрий; 23.9.03

Ага! И ультафиолетовый стиратель памяти для модулей S5. Дешевле купить Field PG - если из стоимости вычесть стоимсть ПО и USB проммер то 500 - 600 Евро за компьютер просто даром!

Re: Выбрать программатор
Роман Абзаев; 23.9.03

Ну там будет далеко не 500-600 евро. Хотя программатор действительно удобнее.


text

Запуск проекта
Александр; 11.9.03

Привет!

Помогите плииз в моей беде...
Как сделать так, чтобы проект на Step7
открывался и грузился в контроллер (S7-400) из приложения написанного например в Delphi по нажатию одной - двух кнопок?
Пользователя в Simatic Manager допускать нельзя!

Заранее премного благодарен!

мыльце: aleks_ostrov@inbox.ru
Re: Запуск проекта
Игорь К; 11.9.03

Привет!

А нельзя ли поподробнее?
Главным образом интересует СМЫСЛ?
Может просто записать проект на флешку, а затем пользователь вставит её в контроллер?
Запуск проекта
Александр; 11.9.03

Re: Игорь К; 11.9.03...

Привет Игорь!
Подробнее можно...
Четыре проекта для контроллера и четыре проекта для скады надо соответственно загружать в контроллер и запускать на РС. Со скадой мы разобрались. А вот с "сименсом" проблема!
Боже упаси, Игорь, допускать пользователей к Simatic Manager тем более к контроллеру :0 ...!
Такие вот пироги!

Re: Запуск проекта
Борис Дертунов; 12.9.03

А пароль поставить не пробовали на проект?

Re: Запуск проекта
Dron; 12.9.03

не понятно почему пользователь-то должен загружать контроллер!

Обычно на рабочей системе контроллер вообще в RUN ставится, чтобы не дай Бог туда ничего никто не загрузил.
Re: Запуск проекта
Андрей; 12.9.03

Предложение такое (при условиях, что не меняется аппаратная конфигурация и в CPU достаточно памяти для всех четырех программ): сделать один проект, в котором объеденены четыре программы, но с признаком работы одной из них. Этот признак устанавливается от скады.

Запуск проекта
Александр; 12.9.03

Привет всем!

Дело в том что это учебный проект, для тестирования персонала и отработки аварийных и нестандартных ситуаций, который состоит из четырех частей...
Вообще всем процессом управляет 3 контроллера, но с добавлением своих блоков для иммитации работы исполнительных механизмов, наполнения емкостей, динамики температуры, давления... и т.д. и т.п. размеры проектов выросли. Поэтому пришлось даже один из них располовинить. Разные проекты могут подгружаться в контроллер по несколько раз в день. Увеличивая память для обработки программы мы ничего не добиваемся, не влазит проект в загружаемую... Равно как и наоборот!
Приобретать S7-417 не предлагать !!! ;))

С уважением, Александр!

P.S. Спасибо всем кто откликнулся, быстрее бы решить проблемку, а то ведь ой-ёй... больно ;)))

Запуск проекта
Александр; 22.9.03

Ну что же Вы.....

Ну где же Вы... Головы.....


text

Modbus slave и REAL?
Елена Протасова; 17.9.03

Есть ли более простое средство передать переменную типа REAL через Modbus slave, чем делить ее на 2 x (2 байта - WORD) и потом на клиенте собирать опять в REAL?

Re: Modbus slave и REAL?
Алексей Родионов, ЗАО "Искра-Энергетика"; 18.9.03

Обычно вводят такое понятие как масштаб. Значение типа REAL умножают на масштаб, получают целочисленное значение, пересылают как WORD, ну а на клиенте, соответственно, делят.


text

Вопрос по PCS. HELP!!!
Андрей; 15.9.03

При конвертировании и компиляции в PCS7v5 проекта, написанного на PCS7v4 появились ошибки и предупреждения:

W: The S7 program contains neither the MSG_CSF (FB44) block nor the OB_BEGIN (FB100) block. Please place one of these blocks in a chart (if you select OB_BEGIN, you also require the OB_END (FC280) block).
E: Incorrect version of the SFC run-time system. Please copy the SFC run-time system (FB300) from the SFCLIB into the offline block folder.

Что они означают и как с этим "бороться"? Почему проект работает в 4-й версии и чего не хватает, чтобы перейти на 5-ю?
С уважением, Андрей.
Re: Вопрос по PCS. HELP!!!
APS; 15.9.03

Дык вроде все написано... Брось FB44 на CFC пропадет предупреждение. Хотя мы его не кидали и все работает..

А по ошибке она просит заменить старую FB300 на новую. Открой CFC и в библиотеке найди FB300 и кинь на лист. Она заменит старую. Потом можешь удалить ее с листа. Правда внимательно почитай что она скажет при замене. Может пару связей удалить.
Re: Вопрос по PCS. HELP!!!
Андрей; 16.9.03

За ответ спасибо.

Воспользовавшись Вашим советом ошибки убрал, но появилась новая ошибка(единственная) -
E:The block (DB0) referenced by CFC_R1.2.CHAIN is not a user block.
CHAIN - это вход @SFC_INTP(FB300). Где можно почитать об @SFC_INTP. Или если Вы сталкивались с этим - подскажите, что сделать?
Заранее благодарен. Андрей.
PS А скорее всего СHAIN - это намек, что я CHAINIK ;0)
Re: Вопрос по PCS. HELP!!!
Михайлин Сергей; 16.9.03

Блок SFC_CTRL(FB300) описан в документации на SFC редактор.

Скорее всего у вас вход этого блока соединен с переменной из DB0, номер которого выходит за диапазон номеров блоков данных для собственных нужд. Данный диапазон устанавливается в CFC редакторе Option/Customize/Compile. По умолчанию 1... 60 Ваши собственные блоки данных должны быть внутри этого диапазона. Смените номер блока, например на 5, должно быть нормально.
Re: Вопрос по PCS. HELP!!!
Андрей; 17.9.03

Нет, не помогло. Когда открываю Properties SFC_CTRL(FB300), то во вкладке General читаю: Instance DB69, т.е. за пределами пользовательских по умолчанию. Если увеличить диапазон, то автоматически увеличивается номер DB и он оказывается вне пользовательского диапазона. Похоже так и должно быть. Вопрос у меня такой: там же в Properties, только во вкладке Inputs/Outputs. Нахожу CHAIN-> Type-BLOCK_DB -> Value - 0. И этот ноль "серенький", не могу я его поменять на другое значение. Вот такие пироги.

А если удалить блок с листа то нет ошибок, а получается вот что:
W: Cannot calculate the local data requirements / the nesting depth of organization block OB100 because some of the installed blocks do not have a reference list. То же самое для ОВ35,80,81....
W: The PBC requirement check cannot be made because the information regarding the maximum possible value for the CPU is not available.
Может это легче "обороть".

В любом случае - спасибо. Даже если просто дочитали до конца.


text

Распиновка кабеля для программирования OP17
Дмитрий; 12.9.03

Подскажите, кто знает, какая распиновка у кабеля для программирования панели оператора OP17(заказной номер 6XV1440-1KH32) со стороны 15-контактного разъема.

Заранее благодарен.
Re: Распиновка кабеля для программирования OP17
Александр; 12.9.03

Привет!

Я тебе на мыло выслал...

...Незачто! ;)))


text

UART и S7-200
PAL; 12.9.03

Подскажите, если знаете, возможно ли в CPU226/224 при работе с внешним портом в режиме свободно программируемой связи использовать аппаратное выделение адреса устройства в однобайтном сообщении(аппаратное выделение адресного бита)как в полноценном UART. В Сименсовском описании нет про это никаких упоминаний. Спасибо!


text

Схема PPI
Аслан; 22.8.03

Re: Схема PPI
MooR; 29.8.03

На диске "Микросистемы" путь:

s7-200\cpu220\07_Communications_r.pdf
начиная со страницы 7-36
Re: Схема PPI
Александр Ковальчук; 5.9.03

Привет!

У меня была такая же нужда… Помогли ребята, вот совет:
Делаешь кабель на разъемах 9пин между
3 и 8 ногами, «землю» не забудь – между корпусами разъёмов… Назначаешь разные адреса контроллерам. Подсоединяешь к ПГ. В окне доступа их лицезреешь!
У меня около десятка метров между, работает!
А если «по-серьёзному", то - лучше все-таки:
6es7 972-0ba40-0xa0 - 1
6es7 972-0bb40-0xa0 - 1 (с разъемом под PG)


text

Пфвел Шранк
SIMATIC S7-200 -> GSM -> PC; 30.8.03

Проект дольжень быть SIMATIC S7-200 -> GSM -> PC. На одной стороне будет SIMATIC и около нет телефонной ризетки. Поетому дольжна быть связ через GSM. На другой стороне будет компьютер и интернет через телефон.

Как это сделать и какое оборудование нужно?

Re: Пфвел Шранк
Виктор; 1.9.03

Ну, как я это вижу- это Teleservice, ТС-адаптер и телефон, поддерживающий функции модема...

GSM
Андрей Гуленок; 3.9.03

Всё зависит от того, что надо иметь на компьютере. В МикроВин встроены функции телесервиса и через GSM терминал М20 можно спокойненько программировать двухсотку. Если нужны HMI-функции то можно использовать кеповский OPC сервер, он поддерживает модемные связи. Можно так же организовать обмен SMS сообщениями с помощью того же М20.

Re: Пфвел Шранк
Юрий; 5.9.03

А у кого реально получилась связь через модем с S7-200 с помощью KEPServerEx?


text

ремонт C7-626
kip; 4.9.03

В контроллере С7-626(6ES7626-2DG04-0AE3)вышел из строя модуль аналоговых входов/выходов возможна ли замена только этого модуля?

Re: ремонт C7-626
Кухаренко Сергей, SIEMENS; 4.9.03

Отдельные модули для систем С7 не поставляются. Если Вас интересует вопрос ремонта системы целиком, то его можно рассмотреть.

Re: ремонт C7-626
kip; 4.9.03

а можно ли его отключить из конфигурации (цифровые входа/выхода , расположенные на этой же плате работают), и для чего нужны дип переключатели на его плате

Re: ремонт C7-626
Кухаренко Сергей, SIEMENS; 4.9.03

Встроенные входа/выхода отключить из конфигурации невозможно.

Внешних дип переключателей на этой системе быть не должно.

Re: ремонт C7-626
kip; 4.9.03

Спасибо


text

CP441 прием с Receive Mailbox.
Ольштейн Эдуард "Мечел"; 4.9.03

При приеме с Receive Mailbox возникли проблемы.

Вопрос.
СР441 ложит данные в выдыленный под Receive Mailbox блок данных ассинхронно с циклом программы или нет.
Т.е. могут ли данные в Receive Mailbox в течении одного цикла программы в разных точках OB1 отличатся.
Или все-таки запись в Receive Mailbox привязана к моменте обновления области отображения.
Re: CP441 прием с Receive Mailbox.
Кухаренко Сергей, SIEMENS; 4.9.03

Receive Mailbox не привязан к циклу ОВ1. Момент перезаписи определяется только самим СР441. Обновились данные или нет также определить невозможно.

Решение этих проблем возможно только с использованием SFB.


text

Контроль состояния нагрузки
Дмитрий; 4.9.03

Имеется ли в выходных дискретных модулях S7-300 (AC 220V) возможность контролировать нагрузку на предмет обрыва? Скажем, выходной модуль управляет сигнальными лампами с номинальным напряжением 220 В. Как можно узнать о перегорании ламп? Спасибо.


text

Связь по RS-485
Константин; 28.8.03

Каие CP позволяют связать S-400(или S-300) с оборудованием по интерфейсу RS-485

Re: Связь по RS-485
Чистяков Дмитрий ОАО СеверСталь; 28.8.03

CP440,CP441-1,CP441-2

CP340,CP341
Модули CPx41 имеют возможность загрузки пользовательских протоколов и набор готовых протоколов.
Re: Связь по RS-485
Харгелия Олег, ЗАО "Искра-Энергетика"; 4.9.03

Привет Дмитрий.

Может подскажешь как в CPx41 загрузить пользовательский протокол. Если это действительно возможно, то было бы очень интересно узнать как.
Дело в том, что готовые протоколы от Siemens имеют формат обычного EXE файла и при наличии аппаратного ключа грузятся и исполняются в CP (там стоит похоже процессор х386). Т.е. вся работа по разбору пакета, проверке его целостности, проверке контрольных сумм выполняется в CP, а в CPU выдаются только данные.
Если же писать свой протокол (на основе ASCII), то в CPU передается полный пакет и вся его обработка ведется уже в CPU.


text

simatic s3 - helh!!!
Андрей; 26.6.03

Друзья - помогите.

Кто знает где можно посмотреть (а лучше скачать) доку по симатику S3 - включая железо и софт...
Заранее благодарен - очень надо

Re: simatic s3 - helh!!!
Рябов Андрей; 26.6.03

Думаю, что скачать негде. Были у нас работы по модернизации с S3. С тех пор ценная книжка имеется "Steuerungen programmieren mit STEP3".

Re: simatic s3 - helh!!!
SPC1; 2.9.03

Имеется самодельный пакет для работы с S3 для PC под DOS. Могу поделиться


text

PROFIBUS EM277-S5
Влад; 28.8.03

Как передать данные по PROFIBUS между S7-200 (CPU224)+EM277 и S5-135 (IM308)

Re: PROFIBUS EM277-S5
Чистяков Дмитрий ОАО СеверСталь; 28.8.03

Необходимо

1. взять GSD файл для EMM277,
2. переписать его в папку с программой COM ET200
3. В программе COM ET200 ввести станцию - Slave EMM277.
4. Закачать сгенерированную базу в IM308-C.

Да! Надеюсь IM308 имеет приписку "-C"


text

Учебное пособие по S5-S7
Nadir; 21.8.03

Я начал изучение PLC и прошу помочь найта учебное пособие на русском языке.Мой адрес turaevnadir@hotmail.com

Re: Учебное пособие по S5-S7
Павел Иванов (Сименс-Москва); 28.8.03

Ечсли Вы начали изучение ПЛК Simatic фирмы Сименс, то Вы можете скачать руководства для выбранного Вами типа контроллера с этого сайта.

Также Вам подойдет совсем свежий перевод книги Бергера "STEP7: STL+SCL"

См. http://www.automation-drives.ru/as/products/doc.php?l1=Программное%20обеспечение&l2=Базовое%20ПО&l3=doc


text

Ошибка FC275 / CH_AI
О.Сафронов; 25.8.03

Проблема такая:

Проект записан на флеш, в онлайне один драйвер аналогового входа не работает, причем на входе шестнадцатиричные значения меняются, на выходе - нули, остальные аналоги в данном контроллере работают. Пробовал перекомпилировать проект и заново записать - результат тот-же. Режим от диагностического модуля установлен корректно (аналогично другим).
Кто-нибудь встречал что-то подобное и что это может быть???
Re: Ошибка FC275 / CH_AI
Автор 2В; 26.8.03

Привет Олег!

Напиши шифр параметра - проверю
Re: Ошибка FC275 / CH_AI
Михайлин Сергей; 26.8.03

Рекомендации таковы:

- проверить наличие или отсутствие 1 на выходе QBAD. Если есть, то это и причина, надо рыть почему она выскакивает. Можно посмотреть код качества.
- проверить состояние режимов симуляции и подстановки. Выключить при наличии
- проверить установленные диапазоны шкалы, может они от 0 до 0. Причем если входная величина уже в физических единицах(например от термопары) то границы должны быть 0..1.
- просто попоробовать рестартовать модуль. Вытащить и опять вставить на ходу.
Re: Ошибка FC275 / CH_AI
О.Сафронов; 26.8.03

QBad=0,Симуляция не работает, т.е абсолютно не реагирует, диапазон в норме, в работе 2 аналогичных агрегата с одинаковыми параметрами - один работает, второй ...

И еще - выходые параметры мняются вручную в онлайне, хотя не должны.
При перезаписи во флеш контроллер был перезапущен.
Сейчас хочу попробовать удалить этот модуль и обратно вставить.
Re: Ошибка FC275 / CH_AI
Михайлин Сергей; 26.8.03

>И еще - выходые параметры мняются вручную в онлайне, хотя не должны.

Обана! Такого быть не должно. Перекомпилить и перезалить надобно прогу во флеш полностью и заново!С нуля!

2 2B
О.Сафронов; 26.8.03

Адрес AS2/PG1/AT2/PV_IN

2 2B
О.Сафронов; 26.8.03

Адрес AS2/PG1/AT2/PV_IN


text

RS-485 - Modbus для S7 200
NIK; 23.8.03

В "типичных вещях" для S7 200 есть пример связи контролера с мастером Modbus. Все хорошо и не сложно, однако не указываются разводка подключаемых к S7 200 кабелей. Пожалуйста, кто пробовал подскажите.

Re: RS-485 - Modbus для S7 200
kot; 25.8.03

Если для связи с компьютером, то стандартный PC-PPI кабель. Если с

другим контроллером то два провода от
3 и 8 ноги.


text

Визуализация-дубль
Михаил Подгор.МЗ; 19.8.03

Re: Визуализация-дубль
Оганесян Юрий; 20.8.03

Если и вправду хочешь получить ответ - пиши вопрос подробнее: что уже есть и что нужно сделать и с какими функциональными возможностями, а так можно предложить что-то около 20 способов решения твоей задачи: от видеозахвата до PCS7.

Re: Визуализация-дубль
Михаил Подгор.МЗ; 21.8.03

Установлено:

CPU, CP-414(или 416),б.р
На MPI - компьютер в 5 метрах. Есть гнездо свободное
По PROFIBUS кабель на входа-выхода.
Надо: на удаленном компьютере на 200-250 м отобразить состояние процесса без возможности управления, но с выбором картинки.
Re: Визуализация-дубль
Оганесян Юрий; 22.8.03

"на MPI - компьютер " - это понятно, а что за soft на этом компьютере? От этого и будут зависить его возможности по сетевой работеи передаче данных на еще один компьютер.

Или бери каку-нить типа Scada (ProTool/WinCC) и создвай еще один полноценный проект.
Re: Визуализация-дубль
Baby; 25.8.03

Приветствую !!!

Юрий,спасибо за ответы.
Но можно немного уточнить...

1. Возможно, без каких либо репиторов,
на 200-250 м, бросить кабель, и соединиться на свободном разъёме (о чём было рассказано выше).

2. Проект на WinCC уже есть,возможно ли с помощью паролей сделать запрет на управление(я так подозреваю,что можно).
Re: Визуализация-дубль
Юрий Оганесян; 25.8.03

1. Profibus - можно. А вообще-то длина участка зависит от скорости. А вот MPI не рекомендуется - этот порт не имеет гальванической изоляции от минуса. Кстати, не забудь про провод выравнивания потенциалов - у нас была ситуация, когда на дистации 300м порт 2 раза вышибало на панельке ОР7.

2. В смысле со стороны PLC? Хм... вопрос очень интересный - честно говоря - не знаю, не занимался. DB могут быть Write-protected, а вот меркеры.... Может и правда, кто-нить знает, как это сделать?


text

Помогите идиоту...Симатик S7-400
Максим; 19.8.03

В эксплуатации находится автом.линия под управлением S7-400.Программатор и тестовое оборудование отсутствует.Что необходимо приобрести чтобы на базе ноутбука сделать программатор?Не дайте пропасть человеку!Спасибо

Re: Помогите идиоту...Симатик S7-400
Михайлин Сергей; 19.8.03

По минимуму для нотебука и S7-400 Вам необходимо:

- пакет STEP7
6ES7 810-4CC06-0YX0
- карта PCMCI CP5512
6GK1 551-2AA00
По максимуму там может быть еще много опций.
Приобрести это все можно в любом представительстве Сименс в России.
Re: Помогите идиоту...Симатик S7-400
Максим; 19.8.03

Спасибо!К карте не нужен соединительный кабель?

А если вариант внешнего подключения через СОМ порт,что нужно тогда?
Re: Помогите идиоту...Симатик S7-400
Михайлин Сергей; 19.8.03

Да, кабель нужен, если его нет. Можно купить готовый кабель MPI/PROFIBUS или сдлеать его самому из разъемов и кабеля.

В случае использования COM-порта, необходим PC адаптер. Сейчас есть адаптер на USB.
Re: Помогите идиоту...Симатик S7-400
Олег; 19.8.03

Поподробнее, пожалуйста про PC-адаптер с USB (какой у него Bestelnumber)

Re: Помогите идиоту...Симатик S7-400
Михайлин Сергей; 19.8.03

PC adapter USB

6ES7 972-0CB20-0XA0
298 Euro на границе Германии
Re: Помогите идиоту...Симатик S7-400
Максим; 20.8.03

Еще один вопрос,если можно!

Для работы с S5-115 возможно применение этого же оборудования?Есть ли какое то универсальное оборудование?
И возможно ли поставить на один лаптоп степы пятый и седьмой?
Re: Помогите идиоту...Симатик S7-400
Михайлин Сергей; 20.8.03

Поставить 5-ый и 7-ой на один комп можно, но кабели связи будут другие. Для S5 нужет СОМ-кабель 6ES5 734-1BD20.

Универсальное оборудование - это программатор. Там весь софт, спец. порты и кабели уже сразу в комплекте.
Re: Помогите идиоту...Симатик S7-400
Олег ; 22.8.03

Странно, а CA01 такого PC-адаптера нету.

P.S. CA01 01/2003

Re: Помогите идиоту...Симатик S7-400
Михайлин Сергей; 22.8.03

Ну дык....

Новый! :-)


text

Подбор Simatic
Андрей; 28.7.03

Требуется подобрать ПЛК “Simatic”для контроля аналоговых сигналов.

1.Смотрю датчики “Метран”(токовый выход 4-20мА, питание 36В):
сопротивление нагрузки Rmin = 1кОм, Rmax = 1.05кОм
Входное сопротивление для аналоговых модулей “Simatic” Rвх = 50 Ом
Вопросы:
- Что значит Rmin и Rmax для “Метрана” ?
- Требуется ли согласующее сопротивление при подключении данных датчиков к ПЛК ?

2.По документации длина линии при подключении аналоговых сигналов
к “Simatic” ограничена 200 метрами
Вопросы:
- действительно ли это так, учитывая изложенное выше ?
- как, кроме использования ET200, (т.к. удаленные сигналы разбросаны по 1-2 сигнала)можно их контролировать
Re: Подбор Simatic
Павел Иванов (Сименс-Москва); 18.8.03

Вопрос про длину аналогового кабеля стандартный.

В руководстве на модули приводятся стандартные гарантируемые характеристики модуля для стандартных условий эксплуатации.
Длина кабеля может быть и больше, только в этом случае ухудшаются точностные характеристики модуля, т.к. увеличиваются наводки, снижается уровень сиганла и т.д.

Re: Подбор Simatic
Илья; 21.8.03

Подключали Метран к модулям 6ES7 331-7NF00. Без дополнительных шунтов и прочей дребедени. Схема подключения токового датчика по 2-х проводной схеме есть в описании на модуль и ФАКах на немецком сайте. А на метране есть зона, определяемая сопротивлением нагрузки и напряжением питания датчика - внимательно почитайте описание на Метран. Удачи!


text

Simatic-S5 IP 241, IP245
новичок; 27.1.03

Добрый день,

В проекте на S5-150U работают платы
IP 241, IP245.
При замене S5 на S7 чем их можно заменить?

Re: Simatic-S5 IP 241, IP245
Кухаренко Сергей, SIEMENS; 21.8.03

Для блока управления гидравликой IP245 не существует замены в серии S7.

Для модуля позиционирования IP241 может быть несколько вариантов замены в зависимости от режима его работы - либо FM350-1/FM450-1 в режиме счётчика, либо FM351/FM451 в режиме позиционирования.


text

WinAC
GAV; 18.8.03

Прошу откликнуться людей работавших с системой WinAC. Какое программное обеспечение необходимо для PCI карты CPU 412-2. В каталоге ничего нет

Re: WinAC
Михайлин Сергей; 18.8.03

Специального - никакого! STEP7 сам знает об этом типе процессора, только лежит он в другой ветке каталога аппаратного обеспечения в HW Config, а именно в PC-based. Работайте с ним как с обычным S7-400.

Re: WinAC
Назаров Дмитрий; 21.8.03

Все ПО необходимое для настройки Windows включено в комплект поставки.


text

СР581 - Монитор
Андрей; 4.5.03

Re: СР581 - Монитор
Кухаренко Сергей, SIEMENS; 19.8.03

Для замены необходим монитор с частотой от 15 kHz. Таковыми у SIEMENS являются SCD1815-E, SCD1515-E, SCD1215-E.

Re: СР581 - Монитор
Андрей; 20.8.03

Подойдет ли SCD 1597-ET, 6AV8101-1BB00-0AA0 ?

Re: СР581 - Монитор
Кухаренко Сергей, SIEMENS; 20.8.03

В своём предыдущем ответе я написал, что монитор должен поддерживать синхронизацию от 15kHz. Монитор, указанный Вами, работает от 30kHz.

Соответственно он не подходит для СР581
Re: СР581 - Монитор
Андрей; 20.8.03

У SCD1515-E предусмотрена ли установка сенсорного экрана? Есть ли место под стекло в корпусе?

Теперь про цифру 15 кГц. Частота зависит от ПО, установленного в CP581? В технической документации на СР 581 (номер док. 6ES5998-2AT22) в технических параметрах (раздел 4) при стандартном BIOS указаны частоты на различных режимах не ниже 31,5 кГц.


text

Процедура для управления ММ4..
Сапельников Артем; 20.8.03

Добрый день! Скажите, кто-нибудь знает есть ли готовая FC для управления Микромастером 4.. по Profibus по PPO1 протоколу? И если да, то где ее можно скачать? Что бы самому не писать.

Спасибо.


text

the address entered is not permitted here
Ламер; 20.8.03

Помогите!!!

при попытке соединения со входом блока СH_AI(value) выводится сообщение:
the address entered is not permitted here

Re: the address entered is not permitted here
Павел Иванов; 20.8.03

Посмотрите во встроенной справке по данному блоку, какие адресные области можно использовать для данного параметра.

Re: the address entered is not permitted here
Ламер; 20.8.03

Увязать со входом получилось, наблюдаю показания АЦП(на входе), но на выходе блока ничего нет - 0. Что бы это могло значить?


text

Модули счета СМ35
Евгений; 13.8.03

Есть проблема с установкой софта для конфигурирования. Сам софт ставится, его (модуль) видно в каталоге "HW config", но при попытке установки его на рейку выдает ошибку на 'p7hk8k4x.dll'. Такой библиотеки нет в STEP. Может кто сталкивался с чем либо подобным.

Re: Модули счета СМ35
Чистяков Дмитрий ОАО СеверСталь; 13.8.03

А там, где нибудь в readme не указано с какими версиями STEPа Ваша версия совместима?

И соответствует ли Ваша версия тем указаниям?
Re: Модули счета СМ35
Евгений; 14.8.03

В том то все и дело, что указана версия STEPа 5.1 и 5.2, даже при установке это видно. Пытались ставить и на ту и на другую версию - результат одинаков. В readme только желают успешной работы.

Re: Модули счета СМ35
Салихов Джамиль; 19.8.03

Обойти можно так:

1. Установить софт CM35: версия для Step 7 5.0. (нужна 98-я Винда, в 2000-м эта версия не ставится).

2. Взять из каталога ..\step7\s7bin\ файлы p7hk8k4x.dll, p7hk8k3x.dll.

3. Скопировать эти файлы в каталог ..\step7\s7bin\ после установки
софта CM35 версии для Step 7 5.1.

Re: Модули счета СМ35
Салихов Джамиль; 19.8.03

Обойти можно так:

1. Установить софт CM35: версия для Step 7 5.0. (нужна 98-я Винда, в 2000-м эта версия не ставится).

2. Взять из каталога ..\step7\s7bin\ файлы p7hk8k4x.dll, p7hk8k3x.dll.

3. Скопировать эти файлы в каталог ..\step7\s7bin\ после установки
софта CM35 версии для Step 7 5.1.

Re: Модули счета СМ35
Евгений; 20.8.03

Спасибо. Сама софтина заработала. Но теперь появилась еще одна проблема.

Данный модуль должен стоять на ET200M, который подключен к S7-417, но вставить его в HWconfig не получается, появляется надпись, что данный модуль не имеет ZS свойств. Подобная операция но на процессоре S7-315 проходит без проблем. Что бы это могло быть и есть ли способ решить проблему.


text

Вопрос по Flash Memory Card
DEE; 8.8.03

Hi all!

Вопрос:
1. Когда делаем из Step 7 функцию "Save Project on Memory Card" сохраняется проект весь полностью вместе с исходниками (на SCL, например), сетевыми настройками и др.? Так? Только проект нужно заархивировать, да?
2. А вот если выполняешь действие "Down user program to memory card", что записывается на Flash Card? Только блоки - т.е. программа пользователя? Или ещё сетевые конфигурации, созданные в NCM? А если эта конфигурация при этом не записывается, то как она должна сохраняться на флэшке?
3.И последнее... Системные блоки SFB записаны жёстко в ПЗУ контроллера вместе с операционкой? Или нет? Вроде бы нет, т.к. при загрузке пользовательских блоков в контроллер он спрашивает - типа не хотители перезаписать SFB.
Re: Вопрос по Flash Memory Card
Shade; 15.8.03

Хотелось бы все таки еще раз поднять вопросы заданные DEE. И вдогонку еще вопрос: можно ли сказать, что кроме всего прочего, Flash Card в чистом виде расширяет ОЗУ? Если да, то в чем отличие модулей памяти FEprom от RAM? Кроме того, что в RAM-модулях программа не сохраняется при сбросе питания.

Re: Вопрос по Flash Memory Card
Кухаренко Сергей, SIEMENS; 18.8.03

1."Save Project on Memory Card" полностью сохраняет Ваш проект, также, как если бы Вы сделали архив и сохранили его на диске (или дискете).

2."Down user program to memory card" полностью сохраняет выбранную папку Programm на Flash модуле, удаляя при этом всё предыдущее содержание.
3. SFB и SFC блоки являются частью операционной системы и не могут быть перезагружены. Их перезагрузка происходит только при перезагрузке операционной системы.
4. Любой вставляемый модуль расширяет загружаемую память, но не трогает рабочую память. Естественно Flash Card даёт возможность перезагрузки системы без применения компьютера.
Re: Вопрос по Flash Memory Card
DEE; 19.8.03

Понятно...

Но вот когда делаем "Down user program to memory card" сохраняются ли при этом сетевые конфигурации, сделанные в NCM? Если нет, то как их на флешку писать?
Хм...И ещё, а вот когда делаешь Download в контроллер папки Blocks проекта, после загрузки спрашивается "Do you want to load system data?"(кажись правильно написал?). Какие системные данные он предлагает сохранить?


text

Расчет времени ввода данных с ET-200M
Сергей; 12.5.03

К ET-200M подключены 8 модулей 6ES7-3317PF10-0AB0. Производится опрос 64-х каналов термопар. Как подсчитать минимальное время опроса всех модулей?

Т.е. складываются ли времена обработки каждого модуля, либо их опрос происходит параллельно.
Re: Расчет времени ввода данных с ET-200M
Илья; 13.5.03

Обычно говорят, что время реакции будет "не хуже чем". А. вообще, учите матчасть! Надо посмотреть доку на модуль - там будет время опроса каналов. К нему прибавит время на шине IM<-->SM + DP-cycle. Это если грубо. На самом деле есть еще времена. А время DP можно посмотреть при конфигурировании в HW.

Re: Расчет времени ввода данных с ET-200M
Сергей; 13.5.03

Вопрос не про работу ОДНОГО модуля (его характеристики известны из документации), а про работу ВОСЬМИ модулей одновременно, а именно: происходит ли опрос всех модулей поочереди(времена обработки каждого модуля складываются) или "одновременно".

Re: Расчет времени ввода данных с ET-200M
В.Румянцев; 13.5.03

Поскольку все модули подключены к одной шине то обратиться к ним одновременно просто невозможно. Тем более, если я не ошибаюсь, они общаются с ЕТ по последовательному интерфейсу.

Re: Расчет времени ввода данных с ET-200M
Кухаренко Сергей, SIEMENS; 19.8.03

Уважаемые Господа, не надо путать две разные вещи: Опрос станции ET зависит от скорости шины РВ и от колличества байт информации, которая скачивается со станции, и не зависит от типа модулей, которые стоят в ЕТ. Другое дело, что эта информация не будет обновляться. Обновляться она будет в зависимости от времени интегрирования (параметр модуля). В любом случае опрос по шине РВ при частоте 1,5 Мбод будет быстрее, чем само преобразование одним модулем всех каналов. Передача полной информации с разных модулей естественно идёт последовательно, но эта передача настолько быстра, что её нельзя сравнивать со временем преобразования в самом модуле.


text

Тип батареи в SIMATIC C7?
Королев Игорь; 16.5.03

Подскажите, пожалуйста, тип и размеры буферной батареи SISMATIC C7.

Re: Тип батареи в SIMATIC C7?
Кухаренко Сергей, SIEMENS; 19.8.03

Литиевая 3.6 V, 1.5 Ah

Заказной номер SIEMENS 6ES7 623-1AE01-5AA0.

Re: Тип батареи в SIMATIC C7?
Виктор; 19.8.03

Тип 1/2А. Фирма Lithium Sonnenshine(что то типа так). Ее представительство есть в России. И у них в 2 раза дешевле, чем у СИМЕНС.(они же производители:))


text

Время выполнения функции
Несчатный; 23.6.03

Как узнать время выполнения функции.

Или где об этом можно почитать (желательно с примерами). Нужно не время OB1 , а время именно определённой функции (напр. FB2). !!! Включая время на считывание со входов , выходов !!! Очень прошу помочь . Спасибо.

Re: Время выполнения функции
Кухаренко Сергей, SIEMENS; 18.8.03

Я вижу такую возможность - Перед вызовом и после вызова Вашего блока поставить вызов считывания часов реального времени. Выполнить блок FB2 несколько раз (для увеличения точности)и поделить разницу во времени на число вызовов вашего блока.


text

Срок безотказной службы модулей S7-300
Владислав; 8.5.03

Где можно узнать срок службы контроллеров SIMATIC S7-300?

Re: Срок безотказной службы модулей S7-300
Павел Иванов (Сименс-Москва); 18.8.03

Контроллеры SIMATIC S7-300 предназначены для работы в течении 10-20 лет. Реально может и больше.


text

Modem ==> S7
Vents; 28.5.03

Kакие есть возможности для coeдинeниe PC c STEP7 и PLC Siemens S7-400 чeрeз модем? Нeужeли только при помощи TeleService и TS-adapter?

Re: Modem ==> S7
Павел Иванов (Сименс-Москва); 18.8.03

Еще можно использовать другой вариант подключения:

ПК - Модем - Линия - Модем - CP441 - S7-400


text

S7-300 & SERCOS
Владимир Гусельщиков; 7.6.03

Как состыковать 315-2DP с сервоприводом, который понимает только SERCOS?

Какие устройства, какой софт и т.д. и т.п.?

Re: S7-300 & SERCOS
Павел Иванов (Сименс-Москва); 18.8.03

Сименс стандартно поддерживает подключение приводов к контроллерам по сети Profibus DP.

ЦПУ 315-2DP уже содержит в себе интерфейс Profibus DP, который используется для связи с приводами.
Поэтому более оптимально использовать привод с выходом на Profibus DP.
По поводу Sercos, то м.б. какие-нибудь фирмы выпускают мост Profibus-Sercos.
посмотрите на сайте пользователей Profibus.

См. http://www.profibus.com


text

EM241
Aslan; 4.7.03

Всем привет.

В июне обещали выпустить русскую документацию на EM241.
Скажите пожалуйста где можно ее найти.
С уважением Аслан
Re: EM241
Павел Иванов (Сименс-Москва); 18.8.03

Новая документация, включающая EM241, выложена в разделе по S7-200

См. http://www.automation-drives.ru/as/products/doc.php?l1=Микросистемы%20LOGO!%20и%20S7-200&l2=S7-200&l3=doc

Re: EM241
ASLAN; 18.8.03

Спасибо за ответ.

Что то я там не нашел
С уважением Аслан


text

Температурный диапазон -40+85 и S7-200?
Alexander Kulikov; 1.5.03

Октагон далеко не первопроходец в применении обычных компонентов(точнее, не отсортированных производителем ИС для работы в инд-м диапазоне) для создания изделий для -40+85. То же самое, например, делают Planar и IEE в своих дисплеях, Сименс в дисплеях ISFT и S7-200.

Можно получить коментарии к данному заявлению?
Re: Температурный диапазон -40+85 и S7-200?
Alex Kulikov; 13.5.03

Коментарий не будет?

С уважением,
Alex

Re: Температурный диапазон -40+85 и S7-200?
Чистяков Дмитрий ОАО СеверСталь; 14.5.03

Дело не только в самих микросхемах.

А самое главное, что для таких диапазонов температур проще и дешевле использовать серийный шкав с кондиционером, например, от Rittal.
Re: Температурный диапазон -40+85 и S7-200?
Роман Абзаев; 15.5.03

Минуточку, а причем тут S7-200 и -40 С? Если Вы имеете в виду SIPLUS, то у него, вообще-то, рабочая температура от -20.

Re: Температурный диапазон -40+85 и S7-200?
Alex Kulikov; 10.6.03

Прощу прощения, что долго не заглядывал.

Речь шла об утверждении одного из подписчиков конференции по АСУТП о том, что в изделиях Сименс с расширенным диапазоном температур используются микросхемы в исполнении Commercial. Вот я и попросил прокоментировать.
С уважением, Александр

Re: Температурный диапазон -40+85 и S7-200?
Роман Абзаев; 11.6.03

Не надо верить всему что говориться...

Re: Температурный диапазон -40+85 и S7-200?
Alexander Kulikov; 12.6.03

Да, конечно, весьма невероятно, но Октагон же ставит.

Во время обсуждения этого факта (Вы и сами, наверняка, читали первоисточник) и прозвучало утверждение, приведенное мною в первом письме. Вот и хотелось услышать комментарии от представителей Сименса, они же здесь обитают, наверное? Приведенная мною цитата была прочитана большим кругом подписчиков.
С уважением,
Александр Куликов
Re: Температурный диапазон -40+85 и S7-200?
Назаров Дмитрий; 16.6.03

Прочитал все вышеперечисленное. Открыл LOGO Siplus из первох серии. Похоже микросхемы обычные, единственное вся плата дополнительно залита лаком.

Re: Температурный диапазон -40+85 и S7-200?
Ян; 15.8.03

Если в ТУ на изделие написано -40+85, то оно работает в этом диапазоне температур.

И не надо ни чего вскрывать.

Иначе, рекламация.


text

Адаптер ОСА33-0ХА0?
Виктор; 14.8.03

Доброго времени суток!

Подскажите пожалуйста: вот есть адаптер, внешне похож на PC Adapter, его номер 972-0СА33-0ХА0.
Что это за фрукт и можно ли его использовать для коннекта РС и контроллера, и что для этого нужно?
Спасибо.
Виктор.

Re: Адаптер ОСА33-0ХА0?
Виктор; 15.8.03


text

Коммуникационный протокол на CP-340
Алексей Андреев; 8.8.03

Если у кого есть описание протокола связи через CP-340 - бросайте на мыло

(как мне сказали там используется 3964(R) - протокол)
Re: Коммуникационный протокол на CP-340
Чистяков Дмитрий ОАО СеверСталь; 13.8.03

Базовое описание протокола 3964(R), включая форматы кадров (блоков) данных и форматы описания типов переменных, описаны в главе 2 руководства по CP340.

В описании CP341-ого имеется и алгоритм работы программы.


text

Модули HART
Сергей; 7.8.03

Чем можно конфигурировать эти модули кроме SIMATIC PDM.Возможно ли их конфигурировать ресурсами контроллера и как,а также подерживают ли они многоточечный режим работы и если да то как его реализовать

Re: Модули HART
Михайлин Сергей; 8.8.03

Simatic PDM конфигурирует не модули, а сами датчики с HART протоколом. Вы можете вставить HW модули с поддержкой HART и работать и не имея PDM. Вопрос в том как Вы будете конфигурировать устройства. Для этого и служит PDM или другое ПО которое поддерживает язык EDDL. Кроме того можно конфигурировать датчик и из программы пользователя с помощью HART комманд, для этого у меня есть заготовки.

ВАЖНО! Модули НЕ поддерживают multi-drop режим. Строго один канал - один датчик. Но... Лазейка проверяется! ;-)
Re: Модули HART
Сергей; 8.8.03

Спасибо за ответ! У нас был SIMATIC PDM версии 5.1 но к сожелению диск испортился. Правда установочный каталог сохранили на диске все сохранилось кроме файла data1.cab

если возможно выслать его на мой почтовый ящик ASergey_@rambler.ru хотябы по кускам. Заранее блогадарен Сергей!
Re: Модули HART
Михайлин Сергей; 8.8.03

Советую скачать PDM 5.2 SP1 по ссылке. Он полностью рабочий в течении 60 дней.

Авторизация отличается. Но Вы можете скачать и предыдущие версии там же.

См. Качать PDM 5.2 SP1

Вопрос к Михайлину Сергею
Сергей; 12.8.03

Сергей Вы упомянули что есть лазейка для реализации режима multi-drop если возможно не могли бы описать подробнее ее!

Re: Модули HART
Михайлин Сергей; 12.8.03

Лазейка, как всегда ... низкий уровень общения. Но пока, как я написал, проверяется, без положительных результатов, но и без отрицательных. В процессе...


text

Режимы работы FM354
Black; 12.8.03

Из всех режимов работ существующих у FM354 работает только reference, а в отстальных например JOG даже не запускается двигатель

пробовали управлять через параметризацию (кнопка start не активна)или
изменением сигналов в блоке данных(скорость и др
сигналы для jog mode установлены)не стартует.
в чем грабли?

Re: Режимы работы FM354
В. Сорокин.; 12.8.03

Пиши на майл. Вышлю рабочий проект. Сравнишь - разберёшся.


text

Описание CP 341
Eugene Sergeev; 9.8.03

Что-то нигде не могу найти описание коммуникационного модуля CP341, это тот, что с RS485. Прерывания у него есть? Можно ли на нем реализовать произвольный самописный протокол?

Re: Описание CP 341
Marakuca; 11.8.03

Это здесь!

http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.csinfo&lang=en&objid=1117397


text

Вопросы по S7-200
walet; 6.5.03

Подскажите, пожалуйста, что представляет блок переключателей для имитации входных сигналов. Это просто переключатели или программируемый блок?

Re: Вопросы по S7-200
Роман Абзаев; 6.5.03

Просто переключатели.

Re: Вопросы по S7-200
walet; 6.5.03

Что за регуляторы выведены под шлиц на центральном блоке CPU 216-2?

Re: Вопросы по S7-200
CGS; 6.5.03

Аналоговые потенциометры :)

Re: Вопросы по S7-200
walet; 6.5.03

"Ясно лошадь, раз рога" - это к слову.

И всЁ таки кто-нибудь может пояснить их назначение?

Re: Вопросы по S7-200
В. Сорокин; 6.5.03

Крутишь, читаешь в своей программе цифру, делаешь всё, что хочешь. Орган задания без ОР. Ну минимум ...

Re: Вопросы по S7-200
walet; 7.5.03

Есть ли какие-то особые требования по питанию DC24V S7-200?

Дело в том, что микроконтроллер начинает сбоить при работе станочного оборудования, находящегося рядом с ним.
Re: Вопросы по S7-200
В.Румянцев; 7.5.03

Особых требований нет, работает великолепно даже с импульсными источниками.Питающие провода должны поводиться от источника непосредственно в контроллер, а не шлейфом через всю схему, если на массе есть наводки то ее можно попробывать отсоединить от земляной клеммы PLC.

Наводки также могут приходить по входным цепям если ипользуются удаленные датчики. Короче воспользуйтесь осциллографом он все покажет.
Re: Вопросы по S7-200
walet; 13.5.03

Как реально определить обьем управляющей программы, записанной в S7-200 в Кбайтах?

Re: Вопросы по S7-200
kot; 13.5.03

сделать ему upload MicroWinом

Re: Вопросы по S7-200
walet; 14.5.03

IMHO это не так, потому что при Upload и Download идет преобразование. Тем более размер программы, выведенный на компьютер в несколько раз превышает возможности CPU 216 (user profram size 4Kwords)

Re: Вопросы по S7-200
В.Румянцев; 14.5.03

1.Откройте MicroWin.

2.Загрузите проект из контроллера.
3.На панели инструментов нажмите кнопку compile, в нижней части экрана появится сообщение о результате компиляции и о размере загрузочного модуля в байтах.Как правило он много меньше чем 4К.

Re: Вопросы по S7-200
В. Сотролкин; 14.5.03

Увы, я был не дома. Ждите и вопросов не будет.

Re: Вопросы по S7-200
walet; 15.5.03

Какая разрядность шины по которой CPU216 обменивается с памятью EEPROM?

Re: Вопросы по S7-200
walet; 19.5.03

Где больше набор операций, функций? В Simatic S7-200 или SLC500 Allen Bradley?

Re: Вопросы по S7-200
walet; 5.6.03

Хотелось бы услышать ответы на последние 2 вопроса....

Re: Вопросы по S7-200
Marakuca; 11.8.03

А это зачем?


text

Требуется специалист по микроконтроллерам
Ирина; 23.12.02

Крупной западной производственной компании требуется инженер-электронщик, специалист по эксплуатации PLC Simatic S7-200, 300,400, S5. Работа в Санкт-Петербурге. Компания предлагает хороший компенсационный пакет. просьба резюме присылать по адресу ki@kellycis.spb.ru с пометкой PLC

Re: Требуется специалист по микроконтроллерам
инженер-электронщик, специалист по эксплуатации PLC Simatic S7-200, 300,400, S5. ; 3.1.03

как то страно.то ли фирма секретная,то ли

в её отделе кадров про фамили уже забыли
или "Ирина" просто с кем-нибудь
познокомиться хочет.
Re: Требуется специалист по микроконтроллерам
Сергей Чернышев; 2.3.03

Я программист PLC/SCADA систем фирмы Сименс.

Re: Требуется специалист по микроконтроллерам
Виктор; 17.3.03

>to Сергей Чернышев

А у Вас там местечка нет, в Siemens :))
Re: Требуется специалист по микроконтроллерам
Cтрельников; 21.3.03

Хе-хе S7400 это что микро??? :)

Re: Требуется специалист по микроконтроллерам
Александр; 9.4.03

Короче был я там на собеседовании, это питерская рекрутинговая контора Келли сервисес, ищут человека для работы на ФИллип МОррис Ижора.

Там все классно за исключением того что девочка которая проводит собеседование не отличает контроллер от микроконтроллера.

>to Сергей Чернышев
Сергей, Вы не могли бы раскрыть секрет, вообще в СИменс приходят программисты со стороны? Каким образом происходит набор персонала и какой нибудь контакт? Опыт и желание есть.

Re: Требуется специалист по микроконтроллерам
Михаил; 7.8.03

То же бы ни прочь найти работу


text

Визуализировать входные порты
Sergey Tkachenko; 1.8.03

Возможно ли самому, без участия Step 5 получить состояние входных портов. Программа в SIMATIC S5 написана не очень корректно и изменять ее пока нельзя. Переходник RS232\TTY (штатный для STEP5) есть. Куча документаций (что почитать?)

Или протокол обмена - это страшная военная тайна?
Мне нужно получить состояние входных портов E0-E38 - остальное я бы написал сам. Вроде краем уха когда-то слышал, что есть программа визуализации процесса... Но что это и к чему - не запомнил.
Re: Визуализировать входные порты
Sergey Tkachenko; 1.8.03

Сорри, забыл тип контроллера указать.

115U
CPU 943B
6E55 943-70B21

Re: Визуализировать входные порты
kot; 1.8.03

Програма называется WinCC. В ней стандартный протокол обмена с S-5 через СОМ-порт и переходник TTY.


text

Диагностика LED у CPU S7-300
Петров Андрей; 30.7.03

Подскажите, пожалуйста, каков порядок светодиодов в ответе при чтении диагностической информации функцией SFC51 c SZL-ID 0019h у контроллеров 300 серии. Заранее благодарю.

Re: Диагностика LED у CPU S7-300
Андрей Гуленок; 31.7.03

А по порядку. SF,RUN,STOP,FRCE,BATF. Будет структура из 5 блоков по два поля. LED_ON и LED_BLINK


text

Нужны коды ошибок для процессора 315DP
Black; 29.7.03

Где скачать коды ошибок для процессора 315DP ,а также на ет200.

на 315dp горит SF и мигает BUSF,
а на ет200 горит BF
В чём грабли?
Заранее спасибо всем ответившим.

Re: Нужны коды ошибок для процессора 315DP
Андрей Гуленок; 29.7.03

Вас спасёт книжка "Системные стандартные функции STEP7". Там описана процедура чтения соответсвующих регистров системной диагностики.

Re: Нужны коды ошибок для процессора 315DP
Петров Андрей; 30.7.03

Проблема в кабеле у отвалившейся ET200. Переберите разъем. Может где-нибудь на кабеле мышка повисла с жилой в зубах.Т.е. контроллер не видит одну из запрограммированных ET200.


text

Step 7 , контроллер s7-400 и рабочий проект
Fidel; 30.7.03

Имеем ПЛК s7-400 с загруженной в него программой, СР-5412 и упавший проект на рабочей станции (посыпался HDD). Проект в WinCC еще кое-как подняли, но вот под STEP7 - большой трабл...

Внимание вопрос. Вернее два. Переустановили STEP 7.
1.Как связаться с контроллером?
2. Могу ли я выкачать программу(проект) из контроллера без ущерба для его работы.
Re: Step 7 , контроллер s7-400 и рабочий проект
Петров Андрей; 30.7.03

1. Используя Set PG-PC interface, необходимо настроить СР и там же можно увидеть адрес работающего контроллера. После перейти к п.2.

2. В STEP 7 после вставки соответствующего типа сети (MPI, Profibus)и STATION S400 PLC->Upload Station и вперед. Если максимальная длительность сканцикла (время выполнения программы)находится неподалеку от текущей длительности, то сами понимаете время на служебные дела маловато. Собственный опыт показал, что при разрыве больше 100мсек можно делать выгрузку. Если меньше контроллер может перейти в стоп, что и случилось.


text

Как прочитать или обойти пароль?
Magic; 4.3.03

Можло ли прочитать или обойти парольную защиту контроллера Simatec s7 200 (CPU 216)+ op 7-dp? Кто нибудь знает как это сделать?

Re: Как прочитать или обойти пароль?
saa; 26.3.03

Могу сказать, но только через мыло :))

Re: Как прочитать или обойти пароль?
Андрей Гуленок; 31.3.03

Да ладно, можно и в слух. Самому интересно.

Re: Как прочитать или обойти пароль?
Crazy; 21.7.03

мне тоже скинь если не влом

Re: Как прочитать или обойти пароль?
Сергей; 21.7.03

И мне пожалуйста.

Re: Как прочитать или обойти пароль?
Beginner; 23.7.03

плиз, мне тоже

Re: Как прочитать или обойти пароль?
Александр; 27.7.03

...давно пытаюсь...

Буду признателен!
Re: Как прочитать или обойти пароль?
Jonny; 29.7.03

и мне тоже ПаЖаЛуЙсТа!!!

Re: Как прочитать или обойти пароль?
В. Сорокин.; 29.7.03

Все просят, просят. А может, как Андрей Гуленок сказал: вслух.

Время сэкономим.


text

Запуск программы в S7-300
Алексей; 28.7.03

Привет, подскажите пожалуйста, как запустить программу контроллера после её новой перезаписи, старая безвозвратно была утеряна после разряда батареи...,а новая никак не хочет работать!

Re: Запуск программы в S7-300
Андрей Гуленок; 29.7.03

Перевести переключатель в RUN. Если не помогло, смотреть в диагностическом буфере причину.


text

OB1
Gluhov Yury; 2.1.03

Зауплоадиный (UpLoad) проект с контроллера С7 626/P DP при открытии блока OB1 выдает сообщение:

Compiler information: type coflict,
после чего отказывается открыть этот блок. Пробовал скачать в другой проект (другая hardware configuration) - бесполезно. Онлайном этот блок также не открывается. В чем дело? Очень нужно внести изменения.
Re: OB1
Валентин; 3.1.03

А нет ли у вас в OB1 вызова несуществующего в программе блока ?

Re: OB1
Gluhov Yury; 6.1.03

Я не знаю, есть ли вызов несуществующего блока, т.к. ОВ1 не могу открыть. Но в целом программа работает без ошибок (диагностический буфер пуст).

Re: OB1
Валентин; 8.1.03

А Вы в программе не стирали какие-либо блоки до появления данного эффекта ?

Re: OB1
Gluhov Yury; 11.1.03

Исходники этого проекта хранились на дискетах - дискетам пришел каюк. Когда возникла необходимость добавить одну функцию в проект, его я решил сначала скачать - но вот проблема. Кстати, все остальные FC, FB, DB, OB - открываются, кроме ОВ1.

Re: OB1
Viktor; 15.1.03

А вы пробовали так: открыть СТЕП7 и нажать "Accessible nodes" (третья слева кнопка) и там уже посмотреть OB1?

Re: OB1
Gluhov Yury; 18.1.03

To Victor:

Пробовал - тоже самое.
Re: OB1
Aleks_odessa; 25.2.03

а если просто удалить OB1 и написать свой, а (ведь не самый озадаченый блок-то!)???

Re: OB1
Миша; 11.7.03

Что-то слышал похожее от знакомых.

Предполагают, что программа в контроллере написана более высокой версией, чем та,которой Вы открываете.

Re: OB1
Илья; 25.7.03

А какой версией Степа вы пользуетесь? Лучше всего 5.2 Или. на край, 5.1+SP6


text

Искробезопасная цепь на SM 331
Константин; 8.7.03

Вопрос в том нужно ли подключать барьеры искробезопасности при соединении сигнальных модулей с датчиками, которые находятся во взрывоопасной зоне и имеют степень защиты "искробезопасная электрическая цепь"

Re: Искробезопасная цепь на SM 331
Илья; 25.7.03

А как же! Если только модуль не имеет Ех-исполнения. А кроме того, необходимо разделять цепи и ставить перегородки между Ех- и обычными цепями.


text

вышла из строя схема контроля разряда батареи
Светлана; 22.7.03

S5 135 928B. Источник питания 6ES5 955-3LC41.Загораются светодиоды МБlow и RBlow даже при наличии требуемого питания.

Если разомкнуть перемычку NN-MM (перемычка контроля батареи), то контроллер переходит в RUN, но программа RAM тогда не сохраняется.
Посоветуйте, пожалуйста, что можно сделать? Где можно найти принципиальные схемы на источник питания?
Re: вышла из строя схема контроля разряда батареи
Shade; 22.7.03

Откуда такая уверенность, что батарея и аккумулятор исправны, а схема их контроля неисправна, была какая-то авария?

Re: вышла из строя схема контроля разряда батареи
Светлана; 24.7.03

Уверенность такая есть. Все проверено и замерено. Сначала очень быстро садилась батарея поддержания памяти (при постоянно включенном контроллере)-раз в месяц. А теперь даже при новой батарейке (3,4В) свтодиоды горят...

Re: вышла из строя схема контроля разряда батареи
Shade; 24.7.03

Единственное, что могу посоветовать, попробовать использовать внешний источник поддержки ОЗУ или аккумулятор (кстати он был? есть?) Электрической принципиальной схемы на блок питания 135U - никогда не видел, боюсь что кроме как у производителей ее ни у кого нет!!!


text

Продам Flash S7
Юрий; 21.7.03

Продам флешку 6ES7 951-0KE00-0AA0 5V 32kB


text

Модули HARD протокола для S7-300
Хоружевский Роман; 18.7.03

Есть множество датчиков с HARD протоколом, какие есть модули для S7-300 что бы завязать данные датчики на контроллер?

Re: Модули HARD протокола для S7-300
Назаров Дмитрий; 18.7.03

Для S7-300 есть два Ex - модуля с поддержкой HART протокола: 6ES7331-7TB00-0AB0 и 6ES7332-5TB00-0AB0. Тех.данные см. ссылку

См. http://www.aud.ru/as/products/cat.php?l1=Программируемые%20контроллеры%20SIMATIC%20S7&l2=S7-300&l3=cat

Re: Модули HARD протокола для S7-300
Хоружевский Роман; 18.7.03

Дмитрий, спасибо за подсказку, но я к сожалению в указанной документации не нашел описания указанных модулей есть все что угодно но не то что Вы указали. Где еще можно поискать?

Re: Модули HARD протокола для S7-300
Михайлин Сергей; 18.7.03

Инскать описание HART модулей надо в докуметации посвященной Ех модулям.

Учтите что модули HART в формате S7-300 работают только в станции ЕТ 200М. В центральную корзину S7-300 оне не встают. Кроме того есть модули с поддержкой HART в составе станции ET 200iS.

Re: Модули HARD протокола для S7-300
Дмитрий; 21.7.03

Я уточню свой ответ. В русском каталоге надо смотреть раздел "Распределенная периферия SIMATIC ЕТ200".

См. http://www.aud.ru/as/products/cat.php?l1=Распределенная%20периферия&l2=ET%20200M&l3=cat

Re: Модули HARD протокола для S7-300
Хоружевский Роман; 21.7.03

Спасибо всем уже все нашел.


text

Нужен блок питания на к S5-135 CPU928B
Андрей; 18.7.03

Нужен блок питания на 5..15..24 к S5-135 CPU928B. Где можно найти?

Re: Нужен блок питания на к S5-135 CPU928B
Дмитрий; 18.7.03

В разделе "О нас" приведено множество телефонов офисов СИМЕНС по всей стране и партеров. Выбирайте ближайший и звоните.


text

Срочно нужен S7 412-1
Sinbad; 17.7.03

Срочно нужен S7 412-1

Либо 6ES7412-1XF02-0AB0
либо 6ES7412-1XF03-0AB0
Версия прошивки роли не играет.


text

Тип монитора в PG730C
Александр; 11.7.03

Имеется PG730C 97г.р.

Каков тип монитора выставляется??
Автоматически не определяется, а документация не даёт ответа...
Re: Тип монитора в PG730C
Кухаренко Сергей, SIEMENS; 16.7.03

На сколько я помню, на этом PG стоял изначально WIN3.11. Соответственно, о каком автоматическом определении идёт речь. Соответственно были драйвера для этого Winda.


text

Помогите разобраться с SFC
Болдырев М. (студент); 11.7.03

Здравствуйте, помогите пожалуйста разобраться с SFC, конкретнее меня интересуют способы задачи диапазона измерения аналогового модуля SM 334. Буду благодарен за любую информацию.


text

CP 340 и CPU-315-2DP
Петров Андрей; 4.7.03

При попытке прогрузить программу с FB от коммуникационника CP340 возникает ошибка: - не могу копировать. Использую все тотже новенький 315-2DP, SP4 под STEP 7 v5.1 стоит, конфигурационный пакет для СР 340 v5.1 sp4 тоже установлен. Не могли бы подсказать, чего не хватает. Заранее благодарю.

Re: CP 340 и CPU-315-2DP
Илья; 11.7.03

Переведите ЦПУ в режим Stop или Run-P


text

Искробезопасная цепь на SM 331
Константин; 8.7.03

Вопрос в том нужно ли подключать барьеры искробезопасности при соединении сигнальных модулей с датчиками, которые находятся во взрывоопасной зоне и имеют степень защиты "искробезопасная электрическая цепь"

Re: Искробезопасная цепь на SM 331
Илья; 11.7.03

Если вы используете обычный модуль, то, согласно правилам, необходимо не только ставить барьеры искробезопасности, но и отделять перегородкой (у нее свой заказной номер) модуль с Ех-каналами от обычного. Ну, и разумеется, нельзя на одном модуле держать Ех- и обычные каналы. А то Госгортехнадзор засандалит по самые гланды... У Сименса есть специальные модули для подключения Ех-датчиков (подключать без барьера)


text

Расскажите о Sinaut ST7
Shade; 3.7.03

Уважаемые господа!

Кто-нибудь использовал Sinaut ST7?
В каком температурном диапазоне он работает, также как контроллер 0-40 град.С или шире? Требует обогрев-вентиляцию или это для него не принципиально? Заранее благодарен.
Re: Расскажите о Sinaut ST7
Shade; 9.7.03

Я правильно понял, из посетителей форума пользователей телемеханики Siemens - нет. Тогда другой вопрос, какую технику вы предпочитаете использовать для передачи информации на несколько десятков километров (автоматизация нефтепровода).

Re: Расскажите о Sinaut ST7
Роман Абзаев; 9.7.03

Дело в том, что Sinaut ST7 в России пока мало кто применял. Я думаю надо начинать смотреть с документации на Синаут... Кое что есть в инф. по продуктам, но этого не вполне достаточно. Можете посмотреть еще вот здесь...

См. SINAUT ST7

Re: Расскажите о Sinaut ST7
Shade; 9.7.03

Большое спасибо за отклик, но все выше перечисленное я уже "проштудировал".

Re: Расскажите о Sinaut ST7
Александр; 9.7.03

В России систему Sinaut ST7 применяла фирма партнёр "СМС" www.sms-samara.ru. Попробуйте с ними связаться

Re: Расскажите о Sinaut ST7
Lucky; 9.7.03

попробуйте OTN от Сименс АТЕА, Бельгия. Ethernet 100MBit, FOC.

Если есть конкретные вопросы насчет Sinaut ST7,задавайте.

Re: Расскажите о Sinaut ST7
Shade; 9.7.03

Куда как конкретнее (см. первое сообщение). А насчет OTN, неплохо бы ссылку, желательно на русскоязычную страничку. Спасибо.

Re: Расскажите о Sinaut ST7
Lucky; 9.7.03

http://www.ic.siemens.be/icn/otn/eng/default.shtm - инфа на англ., не знаю, есть ли вообще на русском.

По Sinaut ST7 вся инфа на http://www.ad.siemens.de/sinaut/html_00/support/handbuch.htm
А насчет вопроса: рассматривайте модули TIM и MD как модули S7300.
При вертикальном положении модуля рабочий диапазон температуры 0-60°C, при горизонтальном 0-40°C.

См. Инфа по модулям Sinaut

Re: Расскажите о Sinaut ST7
Илья; 11.7.03

Да, только CPU надо брать с объемом рабочей памяти не ниже 32к, а то может программа и не влезть...


text

Ошибка при загрузке программы в контроллер Symadin DSimadyn
Григорий ; 23.6.03

Здравствуйте! Хочу описать ситуацию, которая произошла при загрузке программы в контроллер Simadin D, может кто-то что-то подскажет.

У нас в 12-ти слотовой корзине 3 процессорных модуля. Мы изменили программу в 1 модуле, причем изменения не касались коммуникаций, вставили всего несколько блоков, ну и дали комментарии к ним. После загрузки программы в этот модуль на всех 3 модулях загорелась буква H, причем на 1 она мигала. Когда вошли в Online, то
в пакете SIMD, ошибки Н не было, таким образом сложилось впечатление, что программа не работала. Причем ошибка на модуле загоралась не сразу, непосредственно после RESTARTA было все нормально. После того, как загоралась ошибка пробовали сделать аппаратный RESTART, но через некоторое время ошибка опять появилась. Мы загрузили предыдущую версию программы и все стало OK.
наше предположение об ошибке связано с тем, что мы случайно изменили комментарий в программе 2 модуля(на входе одного из блоков. Но эту программу мы в контроллер не грузили.
В описании на счет такого случая никаких пояснений, может мы сделали что-то некорректное?

Re: Ошибка при загрузке программы в контроллер Symadin DSimadyn
GorA; 7.7.03

После загрузки новой программы и появления "Н" нужно открыть какой-либо функциональный пакет из первого процессора и посмотреть PLC->Module Information. Кабель on-line желательно подключить непосредственно к процессору 1.


text

Как работать с программой параметризации блока FM354
ALX; 7.7.03

Доброго времени суток!

Как работать с программой параметризации блока FM354
Были выполнены следующие действия:
1.Созданны блоки MD и инкрементальная таблица ,блоки износа инструментов
и блок NC не заполнялись
2.В результате создалось несколько DB блоков с адресами выше 1000
которые невозможно просмотреть редактором
3.При передаче созданных блоков DB в модуль FM 354 выводятся предупреждения
но блоки записываются.
4.При попытке включить ручное управление оно включается но
все кнопки start ,stop и т.п остаются не активными

Отсюда вопрос какая последовательность действий работы с программой
параметриризации для модуля FM 354? где ошыбка в действиях перечисленных выше

Re: Как работать с программой параметризации блока FM354
В. Сорокин.; 7.7.03

Ошибок, кажется, нет, но их можно увидеть только стоя рядом.

Блоки и не могут читаться, т. е. они читаются как раз в параметризации. См. Ваш п. 1.
Предупреждения бывают, надо переводить и решать: важно-не очень.
О каких кнопках идёт речь? В параметризации или Ваших?
Все действия описаны в док. на FM. Она на CD диске.


text

Связь PLC S-300 и лэп-топ
МО; 4.7.03

Глупый, конечно, вопрос. Но с обыкновенным РС всё понятно - СР 5611. А вот в случае, если я хочу программировать с лэп топа? Какое адаптер или переходник мне для этого нужен?

Re: Связь PLC S-300 и лэп-топ
Роман Абзаев; 4.7.03

Либо 5512 либо адаптер 6ES7972-0CA23-0XA0 Посмотрите хотя бы каталог SIMATIC NET или CA 01

Re: Связь PLC S-300 и лэп-топ
Назаров Дмитрий; 7.7.03

Появилась новинка! MPI - USB адаптер 6ES7972-0CB20-0XA0 - 298 Евро в Германии.

Re: Связь PLC S-300 и лэп-топ
Назаров Дмитрий; 7.7.03

Дополню Романа. Есть новый MPI-USB адаптер - 6ES7972-0CB20-0XA0. В каталогах еще не встречается.

Re: Связь PLC S-300 и лэп-топ
Роман Абзаев; 7.7.03

Тоже верно... Будем ждать когда встретится в каталогах :)

Re: Связь PLC S-300 и лэп-топ
МО; 7.7.03

Спасибо огромное. Обязательно приму во внимание.


text

Новинка CPU-315-2DP
Петров Андрей; 23.6.03

При попытке конфигурировании hardware на новом CPU315-2DP-2AG10-0AB0, а именно установке резервируемой ET200M во второй контроллер возникает ошибка - Не могу вставить. Хотя на контроллерах ранней серии все получается. Вроде STEP 7 v5.1 SP4 стоят, Redudance SW v1.1 стоит, но чего не хватает. Не мог бы кто-нибудь подсказать, что именно. Заранее благодарю.

Re: Новинка CPU-315-2DP
Роман Абзаев; 23.6.03

Посотрите ветку ниже - я уже давал ответ на этот вопрос

Re: Новинка CPU-315-2DP
Пастухов Андрей; 25.6.03

Скорее всего у вас в свойствах DP, у CPU315-2DP, установлен DP mode = DPV1. Он устанавливается по умолчанию. Я сталкивался с такой проблемой, правда на 318 контроллере. Установите там S7-compatible. И проблема должна исчезнуть.

Re: Новинка CPU-315-2DP
Роман Абзаев; 4.7.03

Не хватает SW Redundancy v 1.2 6ES7 862-0AC01-0YA0 Посмотрите Entry ID: 15222081 на Service&Support


text

упраление FM354
Alex; 27.6.03

Можно ли осуществлять управление

FM354 с модулей входов или обязательна
панель OP
Re: упраление FM354
Сорокин В.; 1.7.03

Модуль управляется с помощью ЦПУ. Если Вам нужно запараметрировать его один раз в жизни, то ОР может и не нужна. По вх\вых можно командоват( кнопки, т. п.). Но я не представляю, как может работать оборудование без контроля и вмешательсва оператора.


text

Специалисты SIEMENS Ау-у
Андрей; 28.6.03

Ну неужели и на SIEMENSе уже никто не знает где достать документацию по SIMATIC S3 - куда вообще обратиться... ???

Re: Специалисты SIEMENS Ау-у
Павел Иванов (Сименс-Москва); 1.7.03

Система Simatic S3 была снята с производства более 20 лет назад.

В Московском бюро у нас есть каталоги по данной системе 25 летней давности.


text

Кабель IM360/IM361
Eugene Sergeev; 30.6.03

Кто-нибудь знает распайку кабеля между IM360/IM361? Коммерсанты, туды их в качель, не тот кабель притащили, а время поджимает...


text

Где скачать пример программирования FM 354
ALX; 30.6.03

Re: Где скачать пример программирования FM 354
Дмитрий; 30.6.03

Можно поробовать здесь

http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&objId=10902346&objAction=csBrowse&nodeID0=10805177&lang=en&siteid=cs&aktprim=0


text

TD200 problem
Mack; 28.6.03

Добрый вечер господа!

Дело в следующем. Юзер через TD200 вводит данные в контроллер S7-200. Программа узнает о вводе "опрашивая" Notification Bit, что-то вроде Vxx.2 который устанавливает TD. Я эти данные читаю и сбрасываю этот битик. После чего мое сообщение почему-то исчезает и на экране TD появляется SIMATIC TD 200. Может кто знает как корректно обработать такую ситуацию?
С уважением Mack.
Re: TD200 problem
Александр,СКТЦ; 29.6.03

Значит вместе с Notification Bit ты сбрасываеш еше и бит который отвечает за то какой Message отображать. SIMATIC TD 200 появляется когда все такие биты сброшены.

Re: TD200 problem
Mack; 29.6.03

Прошу прощения, но Вы не правы. Если набрать простейший код вроде

LD SM0.1
MOVB 16#80, VB14
и поместить в блок данных что-то вроде этого
//
//DATA BLOCK COMMENTS
//
//Press F1 for help and example data block
//
//BEGIN TD200_BLOCK ----------------------------
VB0 'TD'
VB2 16#10 //Set Language to English, set Update to as fast as possible
VB3 16#80 //Set the display to 20 character mode; Up key V3.2; Down key V3.3;
VB4 1 //Set the number of messages
VB5 0 //Set the Function Keys notification bits to M0.0 - M0.7
VW6 40 //Set the starting address for messages to VW40
VW8 14 //Set the starting address for message enable bits to VW14
VW10 0 //Global Password (if enabled)
VW12 2 //Character Set = Latin 1 (Bold)
//MESSAGE 1
//Message Enable Bit V14.7
VB40 'Message'
VB47 16#10 //Edit Notification V47.2; No Acknowledgement;No Password;
VB48 16#30 //Unsigned Word; 0 Digits to the right of the decimal;
VW49 16#0000 //Embedded Data Value: Move data for display here.
VB51 ' '
//END TD200_BLOCK ------------------------------
то на моем железе после ввода данных появляется SIMATIC TD 200. Вчем дело?

С уважением Mack.

Re: TD200 problem
В.Румянцев; 30.6.03

Ваша ошибка в следующем:

когда используется ввод данных с подтверждением то после нажатия кнопки enter, TD сбасывает message enable bit, а он у Вас в программе поднимается однократно во время первого скана (SMO.1) поэтому Вам надо позаботиться что бы он деержался столько сколько надо.
Re: TD200 problem
Алексей; 30.6.03

У меня возникли схожие проблемы на проекте, который проработал без сбоев уже 6 месяцев. После получения сообщения "введите пароль" и после его ввода появляется сообщение "неправильный пароль", далее (до выключения/включения)доступно только меню настройки - связи с контроллером нет. Причем на следующий день, когда я появился на объекте, вооруженный ноутбуком - все было нормально и пока это не проявляется, хотя накануне эта неисправность появлялась после каждой попытки ввода пароля ...

С уважением, Алексей


text

"сеть" по MPI - два CPU 312 и PG730
Александр Ковальчук; 6.6.03

Можно ли собрать в "сеть" два CPU 312 и программатор??

Хотелось бы - по MPI-портам...
Соответственно нужна схема разводки или № заказной на соответствующие шнуры...
Благодарю откликнувшихся.
Александр.

Re:
kot; 9.6.03

Делаешь кабель на разъемах 9пин между

3 и 8 ногами. Назначаешь разные адреса контроллерам.Подсоединяешь к ПГ. В окне доступа их лицезреешь.
Re:
Александр Ковальчук; 9.6.03

Два в параллель и всё?!!

Не маловато ли ?!!
Re:
Илья; 10.6.03

Ну, если все это делать самопалом, я бы еще и землю добавил (соединил корпуса разъемов). Да еще на крайние припаял по терминатору 50 ом. А лучше все-таки:

6es7 972-0ba40-0xa0 - 1
6es7 972-0bb40-0xa0 - 1 (с разъемом под PG)
6xv1 830-0eh10 -PROFIBUS cable (20m min)
А подсоединять PG стандартным кабелем.
Re:
kot; 10.6.03

если расстояния не большие, то вполне

достаточно
Re:
Александр Ковальчук; 29.6.03

Всем спасибо!!!

Работает!


text

LOGO
Андрей Сычёв; 27.6.03

Есть в наличии 5 штук LOGO, новые , в упаковке. Предлагаем к продаже все.

Тип 6ED1052-1MD00-0BA3.
Цена 112 ЕВРО за штуку(без НДС).
e-mail: privod@infopac.ru


text

Прога защищена паролем...
Александр; 26.6.03

В CPU стоит пароль...

А как-то обойти пароль-то можно???
Хотя бы прочитать...


text

FM455S+ПБР+ФЦ
Никита; 23.6.03

Есть ли готовые пром. модулю опторазвязки

для работы FM c ПБР или ФЦ.


text

Новинка CPU-315-2DP
Петров Андрей; 23.6.03

При попытке конфигурировании hardware на новом CPU315-2DP-2AG10-0AB0, а именно установке резервируемой ET200M во второй контроллер возникает ошибка - Не могу вставить. Хотя на контроллерах ранней серии все получается. Вроде STEP 7 v5.1 SP4 стоят, Redudance SW v1.1 стоит, но чего не хватает. Не мог бы кто-нибудь подсказать, что именно. Заранее благодарю.

Re: Новинка CPU-315-2DP
Роман Абзаев; 23.6.03

Не хватает SW Redundancy v 1.2 6ES7 862-0AC01-0YA0 Посмотрите Entry ID: 15222081 на Service&Support

См. Service & Support


text

Документация LOGO! модуль ASi
Дмитрий; 22.6.03

Господа, подскажите, где можно найти документацию на функциональный модуль LOGO! ASi (система шин AS Interface)? Этот модуль описан в отдельной документации, так сказано в руководстве.

Спасибо.

Re: Документация LOGO! модуль ASi
Роман Абзаев; 23.6.03

Естественно на Support & Service по ID 13151372!!!

См. Support & Service


text

Где можно приобрести CPU-115U 943 / блок питания к нему на 3А/
Попов ; 19.6.03

Где можно приобрести

СPU-115U
Блок питания к нему на 3А
Блоки дискретного ввода

Re: Где можно приобрести CPU-115U 943 / блок питания к нему на 3А/
Роман Абзаев; 19.6.03

Указываете точный заказной номер и звоните в ближайшее представительство.

См. http://www.aud.ru/about/regions/index.php

Re: Где можно приобрести CPU-115U 943 / блок питания к нему на 3А/
Иванов С.; 19.6.03

Пишите в мэйл. Место - Москва.

Re: Где можно приобрести CPU-115U 943 / блок питания к нему на 3А/
Андрей; 19.6.03

т.(812)113-04-66

Re: Где можно приобрести CPU-115U 943 / блок питания к нему на 3А/
San; 20.6.03

Пишите


text

Вызов OB2 по прерыванию от процесса
Алексей; 19.6.03

Непонятно, как вызывается OB2.

В документации сказано, что он вызывается по фронту(уровню) на I0.0
Но во входном модуле этот сигнал не задействован.(Входы начинаются с номера I4.0)
Однако программный блок, который прописан в OB2 (и больше нигде) работает.
Есть у кого какие варианты?
Re: Вызов OB2 по прерыванию от процесса
Чистяков Дмитрий ОАО СеверСталь; 19.6.03

А модуль-то не имеет прерываний?

Какой тип модуля у вас?

Re: Вызов OB2 по прерыванию от процесса
Илья; 20.6.03

Смотрите структуру программы. Там есть взаимосвязи блоков


text

Проблемы с EPROM'ом...
Даниил; 17.6.03

Есть у меня EPROM (6ES5 375-1LA41), есть программатор (PG 720 PII), STEP 5 v. 7.12, пытаюсь прочитать содержимое EPROM'а на что мне step пишет сначала "-REQUESTED MODE NOT POSSIBLE !-" (это в окне информации о епроме), жму insert, пишет "Wrong mode". Может он просто пустой? А если неисправный, как проверить? Спасибо.

Re: Проблемы с EPROM'ом...
Андрей; 18.6.03

Должно быть режим доступа не тот установлен, попробуй изменить:

-> word;
-> word/byte;
-> byte.


text

S7 & TS Adapter
Ceргей Федеров; 15.6.03

Как соединить WinCC c S7 через TS Adapter? Адаптер у меня работает по DP настроен в ТeleService. Мне нужно описать PC станцию Нardware S7 но в каталоге я его не нахожу. Чем его можно заменить или где он находится.


text

Simatic MMC (Micro Memory Card)
KIP; 13.6.03

Подскажите, что собой представляют эти карты памяти, и каким образом они программируются? Можно ли их запрограмировать с ноутбука (не PG), и нужен ли для этого адаптер (если нужен, то какой)?

Re: Simatic MMC (Micro Memory Card)
Роман Абзаев; 15.6.03

Возьмите любой свежий каталог SIMATIC 2002-2003 г. и новую документацию на s7-300, или скачайте с этого же сайта, и просто посмотрите. Для программирования с обычного ноутбука нужен тот же внешний USB-адаптер, что и для других видов памяти SIMATIC.


text

S7-300,защищенные блоки
Александр; 12.6.03

Есть программа S7-300. В ней блоки защищены.Можно ли их открыть?

Если можно то как?


text

Связь через USB
Юрий; 9.6.03

Необходимо связаться с S7-224 используя USB-COM converter USC-1000 или ADAM 4561. Драйверы поставились нормально, связь отсутствует.

Что делать?
Re: Связь через USB
kot; 10.6.03

а с чем вяжется 224 и по какому

протоколу


text

Серийный номер RS232 <-> TTY адаптера для S5
Sinbad; 25.11.02

Не подскажете серийный номер RS232 <-> TTY адаптера для программирования S5.

Re: Серийный номер RS232 <-> TTY адаптера для S5
KIP; 25.11.02

6ES5 734-1BD20

Re: Серийный номер RS232 <-> TTY адаптера для S5
Sinbad; 25.11.02

А это просто кабель, или там есть конвертер RS232 <-> TTY ?

Re: Серийный номер RS232 <-> TTY адаптера для S5
Виктор; 7.12.02

Продам недорого

Re: Серийный номер RS232 <-> TTY адаптера для S5
Alex; 13.3.03

Продам недорого converter Siemens PC/RS232 6ES5 734-1BD20 AG/TTY

Re: Серийный номер RS232 <-> TTY адаптера для S5
Виктор(другой); 17.3.03

Там есть конвертер, маленький такой, черненький...

Re: Серийный номер RS232 <-> TTY адаптера для S5
Big Bo; 5.6.03

Преобразователь уровня MAX202E и четыре

транзистора. Работы на пять минут.
Но вот кто бы дал список ЦПУ, с которыми можно коннектиться таким кабелем?
Re: Серийный номер RS232 <-> TTY адаптера для S5
Роман Абзаев; 5.6.03

На Support & Services список.

См. Support & Service

Re: Серийный номер RS232 <-> TTY адаптера для S5
Виктор; 5.6.03

2*4N35(оптрон)

3*1N4148(диод)или другие
и резисторы 270 Ом,68K Ом,4K7

См. посмотри


text

Модемный модуль EM241
Чайник; 21.5.03

Доброе время суток.

Подскажите пожалуйста как по выделенной линии соединить два CPU226 используя модемные модули EM241.
С уважением Чайник
Re: Модемный модуль EM241
Роман Абзаев; 21.5.03

Берешь и соединяешь. Просто внимательно поитать инструкцию для 241-го и использовать мастер в MicroWin. Плюс на Support&Services есть примеры программы...

Re: Модемный модуль EM241
Чайник; 21.5.03

Спасибо за ответ, на EM241 документацию не дали, доли вкладыш там есть как выбрать страну, описание RJ11,

на мыло скинули документацию на английском языке, перепробовал варианты ничего не получилось, со Simens S7 опыт работы митнимальный, только, начал работать, около месяца
Можно ли поподробнее объяснить как настроитиь модемы на выделенку
С уважением Чайник
Спасибо за помощь
Re: Модемный модуль EM241
Чайник; 21.5.03

скачал документацию с тех.поддержки, там помоему только для внешних модемом которые стоят на компьютере, или может я невнимательно читал.

С уважением Чайник
Спасибо за помощь
Re: Модемный модуль EM241
Андрей Гуленок; 21.5.03

На этот вопрос наши немецкие коллеги ответили, что ЕМ241 предназначен для коммутируемых телефонных линий. Режима выделенной линии в явном виде нет, но можно заставить модем думать, что выделенка это коммутируемая линия. По большому счёту нужно обеспечить сигнал вызова для того, чтобы модем снял трубку.

Re: Модемный модуль EM241
Роман Абзаев; 21.5.03

Конечно невнимательно. How to Connect an S7-200 (Head Station) to multiple S7-200 (Substation)

by Means of Analog or GSM Modems (Tip 64)
This example shows how to exchange data between an S7-200 head station and multiple S7-200 substations (expandable to up to 32 substations, depending on memory) by means of the ELSA MicroLink 56k FUN fixed line modem or a Siemens TC35 GSM modem.

Re: Модемный модуль EM241
Роман Абзаев; 21.5.03

Это в новых Tips&Tricks - вообще штука очень полезная.

Re: Модемный модуль EM241
Чайник ; 21.5.03

Дело в том что контроллер№1 соединяется с компьютером по кабелю PPI, контроллер №2 соединяется с контроллером №1 по модемам (EM241), когда делали спецификацию оборудования на запрос ответили что эта схема работать будет.

На сайте http://www.prosoft.ru/news/arch2002/news_86.htm сказано что EM241 может работать по выделенной линии, в ответ на вопросы, переадресовали в представительство в Казахстане, они молчат
С уважением Чайник
Спасибо за помощь
Re: Модемный модуль EM241
Чайник ; 22.5.03

Не могу никак настроить EM241 на работу по выделенным и коммутируемым каналам, Помогите пожалуйста,

С уважением Чайник
Re: Модемный модуль EM241
Роман Абзаев; 23.5.03

А смотрели Типс-унд-Трикс? Там достаточно четко расписано, да и пример программы имется?

Re: Модемный модуль EM241
Чайник ; 23.5.03

А где это находиться

Спасибо за помощь,
С уважением Чайник
Re: Модемный модуль EM241
Роман Абзаев; 23.5.03

Ну, батенька... Естественно на сайте Сименс. Надеюсь с английским у Вас хорошо? Вот Вам ссылочка, а остальное по топику найдете...

См. Support & Services

Re: Модемный модуль EM241
Роман Абзаев; 23.5.03

Ищите по ID 1232912.

См. Можете скачать по этой ссылке - 3,2 МБ

Re: Модемный модуль EM241
Роман Абзаев; 23.5.03

Tip 64...

Re: Модемный модуль EM241
Чайник ; 23.5.03

На английском у меня описание есть, но с английском к сожалению плохо, совсем никуда,

У нас русский это иностранный язык
С уважением Чаиник.
Спасибо за помощь
Re: Модемный модуль EM241
Чайник; 23.5.03

А нет ли у кого на русском,

У меня задача соединить только 2 контроллера между собой, SMS пока не нужен.
С уважением Чайник,
Re: Модемный модуль EM241
Роман Абзаев; 23.5.03

Да боюсь что нет... Неужели так плохо с английским??? Та же в роде в пределах школьной программы? И там кстати не только веь СМС.

Re: Модемный модуль EM241
Чайник; 23.5.03

У нас в школе ин-язом был русский.

Если кто знает как настроить этот EM241, ПОМОГИТЕ ПОЖАЛУЙСТА,НОРМАЛЬНЫМ РУССКИМ ЯЗЫКОМ.
С уважением Чайник
Re: Модемный модуль EM241
Роман Абзаев; 2.6.03

Не будет он по выделенке работать...

Re: Модемный модуль EM241
Чайник; 3.6.03

На сайте http://www.prosoft.ru/news/arch2002/news_86.htm написано что на выделенке работает, но к сожалению там не помогли, отправили в представительство в Казахстане, а они молчат.

Спасибо за помощь.
С уважением Чайник
Re: Модемный модуль EM241
Роман Абзаев; 4.6.03

Батенька, я (и не только я), на последнем Siemens Partners Meeting спрашивали у г-на Хельмута Шиндлера из Siemens - он спец по "духсоткам" - так вот он сказал что 241 не будет работать на выделенке.

Re: Модемный модуль EM241
Чайник; 4.6.03

Спасибо, одна проблема решилась.

С уважением Чайник

Re: Модемный модуль EM241
Роман Абзаев; 4.6.03

Да как сказать... Ведь у Вас, батенька, осталась проблема со связью. И осталась проблема, что не только вы поверите ссылке.


text

Пароль CPU 315-2DP
Alex; 28.5.03

Установлена парольная защита, а прогу слить ну просто необходимо. Подскажите кто сталкивался как обойти пароль или сломать. Заранее благодарен.

Re: Пароль CPU 315-2DP
Viktor; 29.5.03

Не совсем понятна ситуация...Опишите, пожалуйста.

Re: Пароль CPU 315-2DP
Alex; 30.5.03

Ситуация проста. Step7... PLC... UPLOAD STATION... и the end "enter password"... так что если кто сталкивался, черкните.

Re: Пароль CPU 315-2DP
aim; 31.5.03

Забудь, не мучайся :)

Siemens не зря ест свой хлеб . . .


text

Протокол с БМРЗ
Сергей; 31.5.03

Нужно все что есть для звязи по RS485 блоков БМРЗ-ВВ,БМРЗ-АВ,БМПА,БМЦС Механотроники с контроллером AS416

ОВ,SFC..., блоков визуализации WinCC
Может у кого есть проект?
Нужно СРОЧНО, горим

См. СПКБ Промавтоматика, Краснодар (8612)240562


text

Место размещения ЦПУ
dimm; 27.5.03

Уважаемые коллеги! Вот какая ситуация. Недавно у нас не буду говорить какая фирма выполнила поставку и наладку АСУТП на базе ПЛК. Но вот что интересно. Имеется шкаф (Rittal), в котором и размещен ПЛК+расширение вместе с остальной начинкой (блоки питания, кросс-реле, трансформаторы и т.д.) Причем ЦПУ вместе с модулями расширения находится под самым потолком шкафа, т.е. вместо естественного охлаждения ему уготовано не менее естественный нагрев от поступающего ниже уже нагретого воздуха от других вышеперечисленных устройств. Пользуясь своей отдаленностью, фирма-изготовитель отмалчивается на такие вопросы. Так вот, может быть такое размещение ПЛК приследовало более важные цели, чем его охлаждение? Кто что скажет??

Re: Место размещения ЦПУ
Чистяков Дмитрий ОАО СеверСталь; 27.5.03

Все вопросы по монтажу, включая растояния сверху, снизу и т.д. имеются в документе

http://www.automation-drives.ru/as/download/doc/simatic_s7/s7_400/02_MechanConfig_r_400.pdf

А так же смотрите все остальные документы вот здесь

http://www.automation-drives.ru/as/products/doc.php?l1=Программируемые%20контроллеры%20SIMATIC%20S7&l2=S7-400&l3=doc
Re: Место размещения ЦПУ
DEE; 28.5.03

Конечно, если в шкафу приточно -вытяжная вентиляция, то в верхней части шкафа располагаются, естественно, элементы такие как блоки питания, тр-ры. Обычно там же располагают и автоматы (но это уже не из соображений нагрева). Далее можно располагать корзину с ЦПУ, своим PS, модулями и т.д. Ещё ниже располагают кроссовые клеммники, аналоговые развязки и др.

Однако, если используется полностью герметичный шкаф с кондиционированием и контролем температуры, то ,возможно, нарушение вышеуказанного порядка расположения аппаратных средств. Здесь может играть роль фактор удобства монтажа и обслуживания оборудования.


text

6ES5 482-8MA13
Ilshat; 15.10.01

Абсолютно новый блок 6ES5 482-8MA13.

Продам по сходной цене.

Re: 6ES5 482-8MA13
Kulakov Andrey; 27.5.03

Куплю


text

S7-200 как мастер?
Дертунов Борис; 22.5.03

Подскажите, пожалуйста, может ли контроллер 200-й серии быть мастером? В сети 4 ОР и 2 энкодера на профибасе?

Re: S7-200 как мастер?
Андрей Гуленок; 22.5.03

Нет.


text

Общий сброс S7-300 новой серии "компакт"
Дмитрий; 21.5.03

Здравствуйте!

Подскажите, как происходит общий сброс для Simatic S7-300 новой серии "компакт". Если использовать старую процедуру для обычных S7-300, то не все области памяти стираются. Каковы области памяти стираются? Что происходит с ММС (Micro Memory Card)?
Спасибо.

Re: Общий сброс S7-300 новой серии
Андрей Гуленок; 21.5.03

Как обычно. Ключ вниз, до полного проморгания. Но стерается только RAM. MMC можно стереть только программатором, причём конкретно указав, что хочешь стереть. Это слегка шокирует по началу, так как все привыкли, что загрузочная память тоже RAM и стирается при полной очистке. В компактах загрузочной RAM нет вообще, а епром стирается только если выделить конкретный объект и стереть его.


text

модуль 6ES7322-5HF0-0AB0
Сергей ; 14.5.03

Не найти документацию на модуль релейных выходов 6ES7322-5HF0-0AB0, в частности схема подключения. Помогите, пожалуйста.

Re: модуль 6ES7322-5HF0-0AB0
Чистяков Дмитрий ОАО СеверСталь; 14.5.03

http://www4.ad.siemens.de/csinfo/livelink.exe/fetch/12479348/S73225HF000AB0_76.pdf

Re: модуль 6ES7322-5HF0-0AB0
Илья; 15.5.03

А еще проще - открыть дверцу на модуле и с обратной стороны дверцы посмотреть, как надо подключать. Там все нарисовано!


text

FM458
Илья; 16.7.02

Народ! Кто работал с FM458 ? Отзовитесь! Пожалуйста!!! По поводу его использования для регулирования частоты вращения (40-80 Гц))механизма очень большой массы

Re: FM458
Капустин Виталий, АСК, Екатеринбург; 16.7.02

Мы использовали модуль FM458 в составе контроллера Simatic S7-400 шкафа базовой автоматизации мелкосортного стана "250" Нижне-Сергинского метзавода. Модуль решает задачи формирования задания скоростей для шести клетей стана (если коротко). Никаких проблем по поводу использования FM458 для задач регулирования частоты вращения! Уточните, пожалуйста, что конкретно Вас интересует, какие есть сомнения. Можно задать вопрос или мне, или на форум нашего предприятия (www.asc-ural.ru).

См. http://www.asc-ural.ru

Re: FM458
Чистяков Дмитрий ОАО "СеверСталь"; 17.7.02

Так же используем FM458-ой в системе СУРС головной части 5-ти кл. стана холодной прокатки. СУРС - это система управления режимами скоростей.

В качестве базы используются Simadyn D.


text

S7-200 и PG
Дертунов Борис; 6.5.03

Есть контроллер S7-224: нужно сделать upload.Подключаюсь с помощью СР5511 по PPI-протоколу 9.6 кбод связь есть, но при аплоаде дает ошибку передачи данных. Что нужно : контроллер в стоп? спец.кабель(у меня профибас - с 300-400 контроллерами как часы, а здесь мож другое надо? Очень нужна помощь!

Re: S7-200 и PG
Чистяков Дмитрий "СеверСталь"; 6.5.03

Через CP5511 связаться по PPI нельзя.

Для связи необходим действительно спец кабель.
6ES7901-3BF21-0XA0
SIMATIC S7-200, PC/PPI-КАБЕЛЬ ДЛЯ ПОДКЛЮЧЕНИЯ КОНТРОЛЛЕРА S7-200 К ПОСЛЕДОВАТЕЛЬНОМУ ИНТЕРФЕЙСУ КОМПЬЮТЕРА, ОТВОД КАБЕЛЯ ПОД УГЛОМ 90 ГРАДУСОВ, RTS ПЕРЕКЛЮЧАТЕЛЬ, ДЛИНА 5 M
цена 89 евро на границе Германии
Re: S7-200 и PG
fresco; 6.5.03

>Через CP5511 связаться по PPI нельзя

Много раз связывался, дело не в кабеле.

>9.6 кбод связь есть, но при аплоаде дает ошибку передачи данных

Какую ошибку дает, то есть что пишет?
Re: S7-200 и PG
Дертунов Борис; 7.5.03

Тo FRESCO

Я так и пишу:ошибка передачи(transfering..) данных - хотя полное сообщение добуквенно не помню
И почему нельзя связаться по PPI,если он (СР5511) определяет и скорость обмена и в установках интерфейса есть возможность связи по этому протоколу?
Что это - липа?
Re: S7-200 и PG
fresco; 7.5.03

>И почему нельзя связаться по PPI

Это Дмитрий пишет что нельзя, я же говорю что связывался много раз, все нормально было.

>полное сообщение добуквенно не помню

Сейчас глянул в хелпы - вроде не надо ставить в стоп перед upload. Наверное нетривиальная какая-то ошибка. Поэтому всегда хорошо иметь точный текст сообщения.

Re: S7-200 и PG
kot; 8.5.03

При uploade ставить в стоп обязательно

И проверь все установки в PG\PC interfese. Кабель с 5511 можно сделать самому , там 2 провода между 3 и 8 ногами на 9 pin разъеме. Если не получиться то поставь на 5511 MPI и попробуй по нему. В принципе тоже всегда работает.
Re: S7-200 и PG
Чистяков Дмитрий ОАО СеверСталь; 8.5.03

В том-то и дело, что скорее всего Вы fresco, связыветесь не по PPI, а по MPI.

Re: S7-200 и PG
fresco; 8.5.03

{Чистяков Дмитрий}

>скорее всего Вы fresco, связыветесь не по PPI, а по MPI.

Я так переключался:
Control Panel > Set PG/PC interface > выбрать CP5511(PPI) > OK > активировать PPI в открывшемся окне.
Вроде так всегда было.

{kot}
>поставь на 5511 MPI и попробуй по нему. В принципе тоже всегда работает.

Интересный вариант. При случае попробую. :-)

Re: S7-200 и PG
Дертунов Борис; 14.5.03

Всё попробовал - вроде работает, но оказалось проблема была не в этом: немцы запаролили контроллер и ничего неполучается узнать. Мож кто подскажет как обойти? Пишет:incorrect password. А немцев приглашать на сервисное обслуживание накладно однако..


text

Соответсвие S7 22x и версии Step7 MicroWin
Кулагин Павел; 8.5.03

Используем Step7-Micro/Win version(3.02.020) однотипное оборудование с одинаковой программой на CPU216,CPU226 216-2AD21-0XB0 и CPU226 216-2AD22-0XB0

последнее иногда ведёт себя "неадекватно" может быть из за версии Micro/Win? Другое оборудование с CPU226 --2AD22-- тоже иногда "глючит"
+ к CPU226 везде стоит OP7 DP. Спасибо.


text

CPU 216->22X
walet; 16.4.03

Имеется Simatic S7-200 c CPU 216 и программа STEP7-MicroWIN Ver2.0. В каталоге Siemens Simatic S7-200 только с CPU 22x. Хотели бы заменить свой микроконтроллер на другой, оставив модули входов\выходов старые, что делать? Нужно ли будет покупать новую программу STEP7 для CPU 22x?

Re: CPU 216->22X
CGS; 16.4.03

можно заказать 216, если есть заказной номер, у любого интегратора/дистрибьютера. Пока это поставляется.

Re: CPU 216->22X
walet; 17.4.03

Но в каталоге его уже нет... А нужно ли обновлять STEP7\MicroWin2.0 ???

Re: CPU 216->22X
В.Румянцев; 17.4.03

MicroWin2.0 обновлять нужно. Кроме того, использовать CPU22x с модулями от CPU21x не получится, у них разные разъемы межблочного интерфейса.

Re: CPU 216->22X
walet; 28.4.03

Реально ли самостоятельно разобраться с конфигурированнием и программированием Simatic S7-200?

Re: CPU 216->22X
walet; 29.4.03

Если у кого-то это получилось, поделитесь опытом, и что для этого надо по минимуму?

Re: CPU 216->22X
Александр; 29.4.03

Как минимум необходимо ЦПУ S7-200, пакет Step7 Micro/Win и документация (можно скачать с этого сайта). Разобраться вполне можно.

Re: CPU 216->22X
CGS; 6.5.03

Спишите заказной номер с вашего модуля и передайте в бюро, там подберут замену. :)

Разобраться реально. Это оч.просто.


text

Нужно узнать заказной номер для коммуникационного процессора
Виталий; 2.5.03

Нужно узнать заказной номер для коммуникацинного процессора для организации связи по DP , для установки в PC c PCI слотом .

Re: Нужно узнать заказной номер для коммуникационного процессора
Чистяков Дмитрий "СеверСталь"; 5.5.03

Имеются три варианта

CP5611 - 6GK1561-1AM00 - цена 394
CP5613 - 6GK1561-3AA00 - цена 726
CP5614 - 6GK1561-4AA00 - цена 1120

Все цены в евро на границе Германии (т.е. без растаможки)
подробнее смотри здесь
http://www.automation-drives.ru/as/products/cat.php?l1=SIMATIC%20NET&l2=PROFIBUS&l3=cat


text

СР581 - Документация
Андрей; 30.4.03

Интересует документация на СР581 на русском языке. Если есть откликнитесь.


text

CPU315-2DP:как организовать переход на летнее время самым простым способом
Денис Ефременко; 30.4.03

CPU315-2DP:как организовать переход на летнее время самым простым способом. Я так понял в самом контроллере этой возможности не предусмотрено.Я подозреваю,надо использовать SFC100. Когда ее надо вызывать и объясните смысл параметра Summer/Winter Time ID

Re: CPU315-2DP:как организовать переход на летнее время самым простым способом
Viktor; 30.4.03

Re: CPU315-2DP:как организовать переход на летнее время самым простым способом
Viktor; 30.4.03

У нас такие контроллеры сами переходят на летнее/зимнее время

Re: CPU315-2DP:как организовать переход на летнее время самым простым способом
Виктор; 30.4.03

У нас такие контроллеры сами переходят на летнее\зимнее время


text

Резервирование ЦПУ 315-2DP 6ES7315-2AG10-0AB0
Бородинов Юрий; 3.3.03

Добрый день.

Поддерживается ли программное резервирование для новых ЦПУ 315-2DP 6ES7315-2AG10-0AB0. Есть ли такая поддержка для ЦПУ 316-2DP, 318-2DP.
Re: Резервирование ЦПУ 315-2DP 6ES7315-2AG10-0AB0
Назаров Дмитрий; 27.3.03

Возможность программного резервирования нового процессора 315-2DP появиться с выходом нового ПО. 316 и 318 CPU согласно тех.описания резервировать невозможно.

Re: Резервирование ЦПУ 315-2DP 6ES7315-2AG10-0AB0
LeXXII; 1.4.03

А Software Redunduncy? Оно для любух ПЛК

Re: Резервирование ЦПУ 315-2DP 6ES7315-2AG10-0AB0
Назаров Дмитрий; 8.4.03

Нет, только для 315-2DP

Re: Резервирование ЦПУ 315-2DP 6ES7315-2AG10-0AB0
Роман Абзаев; 16.4.03

Дмитрий, а разве 316 и 318 не поддерживаются? Если верить документу Entry ID: 4356939 Date: 03/01/2000 SIMATIC S7 Software Redundancy - New Revision Level 1.1 , то версия 1.1 поддерживает CPU 316-2DP и 318-2DP.

Re: Резервирование ЦПУ 315-2DP 6ES7315-2AG10-0AB0
Назаров Дмитрий; 17.4.03

Рома, спасибо за инфоромцию! А вот в документации которую нам всем любезно предоставляют про это нигде не написано. Везде пишут только 315-2DP и 400. Надо подсказать чтобы исправили.

Re: Резервирование ЦПУ 315-2DP 6ES7315-2AG10-0AB0
Роман Абзаев; 18.4.03

Дмитрий не за что. Интересно, а как SR работает с новыми S7-315 и 317?

Re: Резервирование ЦПУ 315-2DP 6ES7315-2AG10-0AB0
Роман Абзаев; 28.4.03

Оказывается хорошо работает.

CPUs Suitable for Use
Description Order Number
CPU 315-2DP
6ES7 315-2AFxx-0AB0
6ES7 315-2AG10-0AB0

CPU 316-2DP
6ES7 316-2AGxx-0AB0

CPU 318-2DP
6ES7 316-2AJxx-0AB0

CPU 412-1
6ES7 412-1XFxx-0AB0
6ES7 412-1FK03-0AB0

CPU 412-2
6ES7 412-2XGxx-0AB0

CPU 413-1
6ES7 413-1XGxx-0AB0

CPU 413-2DP
6ES7 413-2XGxx-0AB0

CPU 414-1
6ES7 414-1XGxx-0AB0

CPU 414-2DP
6ES7 414-2XGxx-0AB0
6ES7 414-2XJxx-0AB0

CPU 414-3DP
6ES7 414-3XJxx-0AB0

CPU 416-1
6ES7 416-1XJxx-0AB0

CPU 416-2DP
6ES7 416-2XKxx-0AB0
6ES7 416-2XLxx-0AB0

CPU 416-3DP
6ES7 416-3XLxx-0AB0

CPU 417-4
6ES7 417-4XLxx-0AB0


text

Модуль аналогового ввода EM231 для S7 22x ?
Кулагин Павел; 18.4.03

При подключении к EM 231 токового сигнала 0-20мА постоянной величины значения в AIW0 изменяется в широких пределах случайным образом. Включение/отключение (изменение параметров) программного фильтра в System Blok на поведение AIW0 никак не влияют. Используется EM231 0C22-0XA0 CPU 226 24/24/24 216-2AD22-0XB0 STEP7-Micro/Win32 v 3.02.020 Что не так? Спаибо.

Re: Модуль аналогового ввода EM231 для S7 22x ?
Юрий; 21.4.03

Попробуйте соединить земли источников питания контроллера и первичного прибора. Проблема должна исчезнуть.


text

PROFIBUS: как передать 1000 байт за раз?
Александр Туманов; 21.4.03

Имеются два S7-300 с новыми CP342. Требуется принимать 1000 байт и передавать 1000 байт между ними. Как это сделать? Известно, что slave может передать не более 240 байт, но мастер может принять более 1000 байт, поэтому, наверное, существует способ передавать 1000 байт между двумя контроллерами.

Re: PROFIBUS: как передать 1000 байт за раз?
Чистяков Дмитрий "СеверСталь"; 21.4.03

Нет по сети PROFIBUS это не возможно.

В составе функциональных блоко SEND-RECIVE под протоколом FDL имеются функции FC50 (AG_LSEND) и FC60 (AG_LRECV). Они способны пересылать до 8кбайт, но только по Ethernet`у.
Выход - сделать механизм (прогаммный)по передаче пакетов данных поочерёдно.

Re: PROFIBUS: как передать 1000 байт за раз?
Илья; 21.4.03

По-моему, все гораздо проще - надо использовать BSEND/BRECEIVE в связке по S7-протоколу. СР это поддерживают. Ограничение - 64к максимум. А вот если необходима консистентность данных - этот механизм ручками, ручками!

Re: PROFIBUS: как передать 1000 байт за раз?
DEE; 21.4.03

Хм...Я не хочу ничего утверждать, но разве нельзя по PB организовать связь type S7 Connection и использовать функциональные блоки SFB12/FB12 и SFB13/FB13? В этом случае можно передавать информацию до 64KB. Данные будут автоматически сегментированы, а сама передача будет происходить асинхронно по отношению к User Programm.


text

Simatic S5-95
walet; 18.4.03

Имеется работающая установка лазерной маркировки на конроллере Simatic S5-95.

В настоящее время необходимо изменить программу. При покупке установки не было учтено, что когда-то возникнет такая проблема. Что нужно иметь для этого из аппаратных и программных средств и где это приобрести?

Re: Simatic S5-95
В.Румянцев; 18.4.03

Программа STEP5, кабель конвертор RS232/TTY и компьютер. Приобрести можно у любого дистрибьютера SIEMENS.


text

Кабель РС/PPI
Павел; 8.4.03

У кого есть старая версия кабеля РС/PPI

вышлите на pchebano@yandex.ru
Re: Кабель РС/PPI
Serg; 10.4.03

А что выслать-то? Кабель?

Re: Кабель РС/PPI
Кабель РС/PPI; 11.4.03

Кроме чисто кабеля есть схема. Вот она мне и нужна.

Re: Кабель РС/PPI
Serg; 11.4.03

Выслал!

Правда на испанском, но думаю, идея будет понятна

Удачи!
Re: Кабель РС/PPI
Viktor; 13.4.03

Пожалуйыста пошлите мне тоже схему

Спасибо!


text

5v в S7-300
Евгений; 9.4.03

Помогите, пож-ста, почему может мигать светодиод "DC5V" на CPU 315-2DP.

Re: 5v в S7-300
Андрей Гуленок; 9.4.03

Плохо ему. Сломалось что то.

Re: 5v в S7-300
Евгений; 9.4.03

Сломалось в самом процессоре на железяном уровне или как?

Re: 5v в S7-300
Nec; 10.4.03

Этот светодиод показывает наличие питания CPU и шины. Если он моргает - скорее всего питание прерывается. Проверь блок питания или напряжение на входе блока питания.


text

FM351
Aлександр; 4.4.03

Гдеможно достать летиратуру по FM351?

Re: FM351
Baby; 8.4.03

Привет,Aлександр !!

"летиратуру по FM351" "можнодостать" на этом сайте.....

Пока.....


text

кабель PC/PPI
beginner; 5.4.03

Можно ли самостоятельно спаять кабель PC/PPI ?

или это адаптер, значит его надо покупать?

Re: кабель PC/PPI
Андрей Гуленок; 8.4.03

Теоретиески да. В старой версии кабеля был только преобразователь интерфейса и опторазвязка. Его можно было спаять самому. Новый кабель содержит микропроцессор и копировать его без микропрограммы дело безнадёжное.


text

fuzzy logic
Керамика; 5.4.03

имеются ли в линейке S7-200 модули

fuzzy logic

Re: fuzzy logic
Андрей Гуленок; 8.4.03

Нет.


text

драйвер для монитора Siemens MCM1701
Вадим; 26.3.01

Помогите найти драйвер для монитора Siemens MCM1701

Re: драйвер для монитора Siemens MCM1701
NEO; 7.4.03

http://www.nix.ru/support/drivers.html?group=30&vendor=197

Пользуйтесь на здоровье!


text

Closed Loop Controller S5-нужен мануал
Михаил; 4.4.03

Где можно найти описание работы с ним.

Если это просто модуль для аналоговых сигналов, то для чего у него MPI-порт?
Re: Closed Loop Controller S5-нужен мануал
Михаил; 4.4.03

Его номер: 6ES5 262-8MA12

Re: Closed Loop Controller S5-нужен мануал
Любитель Симатика; 4.4.03

А уважаемый Михаил ничего не путает?

MPI интерфейс на Симатике 5??????!!!!!!! 8-( )
С каких пор?
Если судить по номеру то это IP262, который может быть использован для построения замкнутых систем автоматического регулирования. Он оснащен собственным источником питания и способен работать в автономном режиме.
Доку посмотри по сцылке.

См. Сцылка

Re: Closed Loop Controller S5-нужен мануал
Михаил; 5.4.03

Спасибо Любителю Симатика за ссылку.

Нашёл всё что нужно и более того.
А с MPI я конечно ,извеняюсь погорячился, имея ввиду порт для пэгэшника. Сказалось, видимо, долгое общение с S7.


text

Документация на рограммирование СР340-341
ALEXANDER; 4.4.03

Кто подскажет где посмотреть документацию по программированию канала связи через СР340-341

Спасибо

Re: Документация на рограммирование СР340-341
Любитель Симатика; 4.4.03

А не Ваш ли тред с точно таким же вопросом висит ниже? Там даже ответы есть. ;-) А в принципе ответ один: в FAQ или тщательнее лазить по www.aud.ru/as


text

Перевод контроллера на летнее время
DEE; 1.4.03

Hi!

Подобные вопросы, в принципе уже поднимались, но хочу ещё раз спросить...
1. Чтобы время в контроллере переходило автоматически на летнее/зимнее что нужно сделать?
У меня в конфигурации есть CP443-1 ( связаны между собой два S7 400), там есть "Use corrected time" - это оно ? Ставить галку в обоих контроллерах? В принципе синхронизация по времени обоих контроллеров настроена, значит достаточно поставить галку в одном контроллере?
2. А если в системе нет CP443, а контроллеры связаны по Profibus (там нет такой фичи)? Или вообще контроллер не связан по сетке никакой, а время должно переводиться ( например для передачи его на OP)?
3. А панели своё собственное время переводят на зимнее/летнее? например OP37 ?
Re: Перевод контроллера на летнее время
DEE; 1.4.03

По п.2 я имел ввиду, если контроллер работает локально, а связь с панелью, например, через встроенный порт Profibus/MPI. Ведь в настройках самого CPU нет установки перевода времени автоматически...

Re: Перевод контроллера на летнее время
Харгелия Олег, ЗАО "Искра-Энергетика"; 2.4.03

В системах реального времени перевод времени зимнее/летнее НИКОГДА не производится. Время обычно переводится только на операторских станциях.

Re: Перевод контроллера на летнее время
DEE; 2.4.03

Ну, хорошо, я повторюсь..

Если панель ОР37 (например) получает время от контроллера для синхронизации времён (настроена связь с помощью Interface Area в панели), то как время будет переводиться на летнее/зимнее в ОР, если в контроллере, как Вы утверждаете, оно не переводится?


text

FAQ по S7-400H
Михайлин Сергей; 1.4.03

В связи в увеличением количества вопросов по построению, настройки и работе с дублированным контроллером S7-400H, мной был написан FAQ по данной теме. Я постарался охватить все аспекты построения, настройки и работы с ним. FAQ состоит из двух частей: непосредственно текста и фотографий к нему. Если канал связи слабый, можно качать только текст. Качать либо по ссылке, либо со страницы продуктов, раздел SIMATIC S7/H/F системы. Пожелания, дополнения и претензии принимаются на мыло или в форуме всегда. ;-)

См. Ссылка на FAQ


text

Перегрузка компьютера ...
Хлопин Денис; 5.2.03

Есть контроллер S7-300(CPU315-2DP), соединение с компьютером MPI, (На компе проект WinCC, CP5611). Проблема в том, что, постоянно, через неопределенное время, при активном соединении с контроллером компьютер перезагружается! Если связи нет(отрублен кабель или CPU в стопе), то перезагрузки прекращаются! В чем может быть проблема? CP5611 менял на 5613 не помогло...

Re: Перегрузка компьютера ...
Чистяков Дмитрий ОАО "СеверСталь"; 5.2.03

Сколько ОЗУ на компе?

Какая ОС, какая версия WinCC?
Проверьте общее заземление между контроллером и персоналкой.
Re: Перегрузка компьютера ...
Хлопин Денис; 5.2.03

ОЗУ 128, но пробовал 256.

ОС Windows 2000.
Заземление не смотрел (посмотрю).

Re: Перегрузка компьютера ...
Хлопин Денис; 1.4.03

Вся проблема была в драйвере звуковой карты(звуковуха Genius SM Live с чипом FM-801), поменял драйвер все нормализировалось.


text

S5-135U 6AV1242-0AB10
Сергей; 26.2.03

В контроллере S5-135U стоит модуль 6AV1242-0AB10. К нему подключен монитор. Не подскажете, что это за модуль и где можно достать какую нибудь документацию.

Спасибо!
Re: S5-135U 6AV1242-0AB10
Кухаренко Сергей, SIEMENS; 28.3.03

Модуль называется СР527. Предназначен для вывода графической информации на монитор. Возможно также подключение клавиатуры и принтера. пакет параметрирования COM GRAPH. Модуль снят с производства в 1999 г.

Документация есть на немецком языке (может быть есть и на английском, но нужно искать)только в бумажном виде.


text

СИМАТИК
НОВЫЙ ЭДЕМ; 25.3.03

НЕОБХОДИМО ОПИСАНИЕ СИСТЕМЫ СИМАТИКА

Re: СИМАТИК
Любитель Симатика; 25.3.03

Ё-моё!!! А не судьба хоть немного по сайту полазить, сходить в FAQ, вообщем хоть немного пальцами понажимать! ;-)

См. Вот тут!

Re: СИМАТИК
Михайлин Сергей; 25.3.03

Вся документаци по Simatic находится на соответсвующем сайте департамента A&D. Зайдите в верхнем меню в Продукты и Решения и выбирете Системы автоматизации Simatic. Далее по списку.


text

Сколько макс. входов/выходов у LOGO?
Сергей; 24.3.03

Ребята, подскажите, сколько максимально

можно наращивать входа/выхода у LOGO?
Я имею ввиду сколько модулей 4DI/4DO
можно подцепить к стандартному модулю?
Спасибо
Re: Сколько макс. входов/выходов у LOGO?
Чистяков Дмитрий "СеверСталь"; 24.3.03

CA01 гласит:

Максимальная конфигурация: 24 дискретных входа, 16 дискретных выходов, 8 аналоговых входов.

Это и для LOGO! Basis, и для LOGO! Pure


text

Simatic S7-400H
Иванов П.; 20.3.03

Не получается создать симметричную конфигурацию контроллера с одинаковыми адресами модулей в разных корзинах в H-системе. Модули, устанавливаемые в одни и те же места в разных корзинах, почему-то всегда принудительно разводятся на разные адреса. Подскажите в чём ошибка.

Re: Simatic S7-400H
Михайлин Сергей; 20.3.03

Если речь идет сетевых МАС адресах в коммуникационных процессорах, то они и должны быть разные. Все правильно.

Re: Simatic S7-400H
Иванов П.; 21.3.03

Речь идёт не о сетевых адресах, а о базовых адресах ввода-вывода модулей ввода аналоговых и дискретных сигналов.

Re: Simatic S7-400H
SSP; 21.3.03

А Вы уверены, что это возможно в принципе? В таких системах возможно использование н-р специальных ЕТ200М с двумя IM. Но сигнальные модули все равно не дублируются на одно адрессное пространство. Это очень даже сложно с точки зрения обработки сигналов или диагностики.

Re: Simatic S7-400H
Михайлин Сергей; 24.3.03

Модули I/O ВСЕГДА имеют разные адреса. Как я понимаю Вы хотите дублировать эти модули. Тогда учтите, что для поддержки этой функции средствами операционной системы ЦПУ требуется FW 3.1, STEP7 v5.2 и модули определенного типа. Если чего-то из этого нет, то все операции надо программировать ручками.


text

Тип Conter(C) и Timer(T)?
Andrey; 22.3.03

Добрый день.Скажите, пожалуйста, какою тип имеет Counter(Integer(2) or WORD) and Timer(TIME(4),S5TIME(2),DATE(2)).

Re: Тип Conter(C) и Timer(T)?
Виктор; 24.3.03

На входе таймера тип данных S5TIME(WORD)с особым значением битов. На выходе- по желанию либо BCD формат либо интежер (оба WORD).

У счетчика вход предустановки WORD, два выхода по WORD(BCD и Интежер)


text

Снова о размере программ
Николай; 25.2.03

Имеется FB, в качестве параметра передается переменная пользовательского типа UDT.

Почему одна команда сброса бита на STL занимает 48 байт ? Другие команды работы с полями UDT занимают примерно столько же.
FB почти ничего не делает, а ее размер составил более 12 000 байт.
Как можно более разумно (в плане уменьшения размера кода) организовать
работу FB с DB пользовательского типа ?
С Уважением, Николай.
Re: Снова о размере программ
Виктор; 26.2.03

Не знаю уменьшит ли это размер программы, но можно попробовать вызывать косвенно

блок FB с DB.
Re: Снова о размере программ
иван жуков; 3.3.03

Надо уходить от операций косвенного вызова. Можете посмотреть в качестве примера, как сделан стандартный пид-регулятор. Только для этого надо снять с него защиту - где-то здесь на форуме упоминалось, как это сделать.ю

Re: Снова о размере программ
Чистяков Дмитрий ОАО СеверСталь; 3.3.03

Так, а может быть просто, стоит использовать этот стандартный пид-регулятор. ;-)

Re: Снова о размере программ
Baby; 5.3.03

Привет, Николай !!!!!

Если это не является секретом, несколько вопросов.....

1. Какую программу Вы пишите (регулятор или ......)....?
2. Какое закладывается время цикла....?
3. Какие оконечные приборы (клапаны, датчики обратной связи и т.д.)....???

Пока......
Re: Снова о размере программ
Николай; 21.3.03

Проблема решена.

Нужно использовать стандартную связку FB - instance DB.
Размер кода снижается в разы.Кроме того часть кода (самый затратный по памяти)переписал на STL.
Насчет использования стандартных блоков Siemens. Для примера, голый драйвер обработки АЦП занимает около
6 кБ, самописный блок с фильтрацией, различными шкалами, проверками на достоверность, алармами,квитированием и т.п. занимает 2 Кб.

Спасибо всем участникам темы.


text

EM277 Profibus Pc/PPI cable
Iurii Suhovic; 19.3.03

- MPI, PPI, Profibus - нет четкого понимания различий и совместимости - Возможен ли вариант включения PC/PPI кабеля в гнездо D9 в модуле EM277 и программировании с компьютера s7-200, через ЕМ277, или для таких целей необходим CP 5611(какое дополнительное

программное обеспечение при этом надо использовать)?

Re: EM277 Profibus Pc/PPI cable
Андрей Гуленок; 20.3.03

MPI, PPI, Profibus - это всё протоколы. PC/PPI кабель с ЕМ277 работать не будет, нужен СР5611. Доп софта для этого не надо.


text

СР341-441
АЛЕКСАНДР; 18.3.03

Друзья кто подскажет где можно взять доку по сопрцессорам СР341, СР441 (описание, параметрирование...) - желптельно ессно на русском - заранее спасибо

Re: СР341-441
Baby; 18.3.03

Привет,АЛЕКСАНДР !!!!

Покопай здесь......
http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&startNode=4000024&table=cs&foldersopen0=-434-433-395-156-155-435-436-440-437-441-&lang=en&aktprim=0&wttree=cs&nodeID0=10805384&siteid=cs&jumpto=435

Пока.....
Re: СР341-441
Чистяков Дмитрий "СеверСталь"; 19.3.03

Для Baby

Для более простого доступа к данным по ссылкам с сайта из Германии, лучше всего в ответах давать адрес в виде

http://www4.ad.siemens.de/news/cs/en/1188622

Где основная часть не изменна (до последних цифр.
А в качестве цифр используется идентификатор документа. Он всегда находится в начале документа и обозначается как:

Entry ID: 1188622

Дело в том, что не все пользователи способны склеить большой адрес воедоно.


text

Забыл пароль
Павел; 28.2.03

SIMATIC S7-300.CPU 315-2DP.

Забыл пароль. Конфигурация утеряна.


text

каким образом можно выгрузить программу из панели оператора системы C7-626?
makc; 13.3.03

Господа эксплуататоры систем SIMAIC!

Помогите советом: каким образом можно сделать копию программы (графические экраны) панели оператора системы C7-626?
Пробовал сделать копию с помощью программы PROSAVE-ничего не вышло(предварительно переводил панель врежим "serial transfer" с помощью комбинации клавиш "up"+"esc").
Программа PROSAVE выдавала только сообщение "ошика связи".
Может быть PROSAVE не поддерживает C7-626? (В инструкции к данной программе не указана данная панель в качестве поддерживаемой.)
Заранее благодарен за советы.
Re: каким образом можно выгрузить программу из панели оператора системы C7-626?
Baby; 17.3.03

Привет,makc !!!!

А у Вас есть ProTool v6.0+SP1 ????

Пока.......


text

Проблемма
Александр; 7.3.03

У нас пришло оборудование с SIMATIC S5

135u (CPU928)
Проблемма в том ,что во время транспортировки исчезло програмное обеспечение в RAM . Из италии,откуда это оборудование, нам прислали 3 файла
наверно в Step5 . Как нам восстановить
работоспособность контроллера.
Re: Проблемма
Чистяков Дмитрий ОАО "СеверСталь"; 7.3.03

Купить пакет STEP5.

Поискать у кого-нибудь программатор с установленным STEP5.
Воспользоваться софтом от третьих фирм.

В любом случае это будет стоить денег. ;-)

Re: Проблемма
файлы кинь на e-mail если не лень посмотрим; 14.3.03

файлы кинь на e-mail если не лень посмотрим


text

Использование памяти в контроллерах Siemens S7-300
иван жуков; 21.2.03

Здравствуйте!

Недавно мы начали работать с контроллерами Siemens S7-300 (модель процессорного
модуля CPU315 код 315-1AF03-0AB0), и в процессе работы у нас возникло
недоумение по поводу некоторых моментов. Количество рабочей памяти на борту
процессорного модуля - 48Кбайт (представитель фирмы Siemens посоветовал нам
именно этот процессор после того как мы выдали ему информацию о количестве
каналов ввода/вывода). Пишем программу для управления объектом с использованием
48 аналоговых каналов, 150 дискретных каналов, 5 контуров управления и
реализацией логики по блокировкам. В процессе работы оказалось, что даже
предварительный вариант программы (там реализованы только регуляторы и
обработка модулей ввода-вывода) не помещается в контроллер! Начали разбираться,
в чем тут дело. Оказывается, что значительный объем памяти занимают стандартные
системные блоки. Кроме того операторы языка SL/AVL занимают ненормально много
памяти: например, только вызов блока отхватывает сразу 70 байт! Сброс командой
R нескольких битов 8 раз подряд съедает 300 байт!! Возможно, мы что-то не так
делаем и в память вместе с программой записывается какая-то отладочная
информация? (Хотя в справке указывается, что это не делается). Может быть, в
конференции участвуют те, кто работает с контроллерами Siemens: хотелось бы
услышать совет, как нам поступить в данной ситуации.

Re: Использование памяти в контроллерах Siemens S7-300
Капустин Виталий; 21.2.03

А, к примеру, Simatic S7 карта памяти 4Мбайт Flash-EPROM (6ES7951-1KM00-0AA0) у Вас имеется? -:)

См. http://www.asc-ural.ru

Re: Использование памяти в контроллерах Siemens S7-300
иван жуков; 21.2.03

У нас есть карта flash 512кб 6ES7951-0KJ00-0AA0. Только непонятно, чем она может помочь? Ведь память Flash медленная и вряд ли ее можно использовать для расширения ОЗУ. Кажется, эта карта используется только для резервного хранения программы.

Re: Использование памяти в контроллерах Siemens S7-300
иван жуков; 25.2.03

Нам нужно получить ответ всего лишь

на один вопрос: можно ли прозрачно использовать в одном цикле обработки все
блоки и данные, которые записаны в ОЗУ и в памяти FLASH-карты без
дополнительных
программных ухищрений вроде считывания с карты и записи на нее?

Re: Использование памяти в контроллерах Siemens S7-300
Виктор; 25.2.03

Если Вам не хватает рабочей памяти, то это ёк!!!

Никакими способами рабочую память не расширишь.
Есть возможность не подгружать блоки данных в рабочую память, а по необходимости перекачивать их в процессе работы из загрузочной памяти в рабочую, работать с ними, а потом уничножать и грузить другие...
Re: Использование памяти в контроллерах Siemens S7-300
Витек; 26.2.03

А как вы оценивали объем занимаемой блоками памяти?

Я делаю так: в дереве проекта выбрать ветвь "блоки" и по правой клавише зайти в Object properties. Там и найдете сколько Ваши блоки занимают места в РАБОЧЕЙ памяти...
Re: Использование памяти в контроллерах Siemens S7-300
Витек; 26.2.03

В загрузочной то они занимают гораздо больше. Там все написано.

Re: Использование памяти в контроллерах Siemens S7-300
Чистяков Дмитрий ОАО "СеверСталь"; 27.2.03

Память можно расширить, используя модуль памяти типа RAM.

Ну, а вообще необходимо было изначально сделать правильный выбор типа CPU.

6ES7952-0KH00-0AA0

SIMATIC S7, КАРТА ПАМЯТИ ДЛЯ S7-400, ДЛИННОЕ ИСПОЛНЕНИЕ, 5В FLASH-EPROM, 256 КБАЙТ
Re: Использование памяти в контроллерах Siemens S7-300
Чистяков Дмитрий ОАО "СеверСталь"; 27.2.03

ОЙ!!!!

Извините не ту строчку скопировал

6ES7952-1AH00-0AA0

SIMATIC S7, КАРТА ПАМЯТИ ДЛЯ S7-400, ДЛИННОЕ ИСПОЛНЕНИЕ, RAM, 256 КБАЙТ

Re: Использование памяти в контроллерах Siemens S7-300
иван жуков; 27.2.03

ЧД> Память можно расширить, используя модуль памяти типа RAM.

В каталоге нет упоминания модулей для расширения памяти процессора S7-300 CPU315. Насколько я понял,кроме карты FLASH-памяти туда ничего нельзя установить. И все-таки, вопрос остается: для чего используется эта самая карта FLASH-памяти? Просто для хранения блоков или же ее можно задействовать в процессе работы?

Re: Использование памяти в контроллерах Siemens S7-300
DEE; 28.2.03

Насколько мне известно, в контроллерах Simatic S7 существует два типа памяти: 1. Load Memory Загрузочная память - это составная часть центрального модуля. Она содержит объекты,созданные устройством программирования. Она реализуется или как вставная плата

памяти FLASH EPROM, или как жестко встроенная память RAM. 2. Work Memery Рабочая память - это RAM–память в CPU, к которой процессор обращается во время
обработки прикладной программы.
Читайте мануалы, а также можно почерпнуть информацию на сайте www.simatic.nm.ru. Распеределение памяти в контроллере можно глянуть в режиме online - module information cpu - memory (Здесь же можно сделать и компрессию памяти) - но это, я думаю,Вы знаете.

Re: Использование памяти в контроллерах Siemens S7-300
Илья; 11.3.03

Мне кажется, вы ошиблись с выбором ЦПУ. Надо было брать больше рабочей памяти. Типа 315-2ДП. Или что-то из новой серии. Там есть и со 128к рабочей памяти! Кстати, когда вы описываете требования к ЦПУ, давайте ПОЛНУЮ спецификацию. Я бы тоже посоветовал 315-1. НО! У вас есть своя обработка блокировок (что не страшно) и РЕГУЛИРОВАНИЕ. А это уже ощутимые потери в памяти. Да, а сброс 8 бит занимает 56 байт максимум (включая все необходимое для вызова блока)!

Что касается наращивания памяти, то может Дмитрий Чистяков расскажет, как нарастить рабочую память в ЦПУ 300-й серии используя карты памяти РАМ для расширения ЗАГРУЗОЧНОЙ памяти в ЦПУ 400-й серии???
Re: Использование памяти в контроллерах Siemens S7-300
Fresco; 12.3.03

В общем, поскольку рабочая память в S7-300 не расширяется, придется вам менять процессор.

Варианты:
316-2DP (128KB) + имеющаяся флешка
315-2DP new (новая серия в узком корпусе, 128KB) + MMC флешка

Кстати, по времени цикла у вас прикидки есть или первые результаты испытаний? Скорости хватает?


text

Тима Чумак
315-DP2<-->PG cвязь через MPI при 187,5kbps; 11.3.03

Возможна ли устойчивая связь контроллера S300 CPU315-DP2 с программатором PG720 через MPI со скоростью 187,5kbps???

Пока реально работает 19,2kbps.
Re: Тима Чумак
Чистяков Дмитрий "СеверСталь"; 11.3.03

Она не только возможна на 187,5к, а даже и на 12 м/бит. ;-)

Скорее всего у Вас не стандартный кабель используется. И Вы его сделали из двух 9-пиновых разъёмов. При этом не установили резисторы терминаторов.
Ещё как вариант - это не достаточно хороший кабель. Так у нас в далёкие времена были проблемы со связью, когда мы использовали кабель витой телефонной пары. Возьмите кабель от Ethernet 5 категории и вперёд!


text

Нужна помощь по восстановлению ПО S7-200.
Oleg; 5.3.03

На Simatic S7-200 слетела программа. Программа запускается, но сильно глючит. Техника б/у, долго простояла без работы и нет возможности связаться с разработчиками. Я не программист и разобраться с криво работающей программой не могу. Есть точно такая линия с такими же задачами, которая нормально функционирует. Возможно ли клонирование с рабочей машины ПО и что для этого нужно? Если нет, то как можно решить эту проблему? Заранее благодарю за любую информацию.

Re: Нужна помощь по восстановлению ПО S7-200.
aim; 6.3.03

Вам необходимо:

1. PG от фирмы Siemens или PC с картой, работающей по PPI протоколу.
2. Пакет MicroWin.
3. Специалист по ПЛК фирмы Siemens

Если отсутствует любой из пунктов готов рассмотреть Ваше предложение...

Re: Нужна помощь по восстановлению ПО S7-200.
Oleg; 6.3.03

Ситуация такая: Эти две линии на Украине, в разных областях. Нужно считать программу с одного ПЛК и записать в другой. Желательно как можно быстрее.Сколько это будет стоить? Предложения направляйте на мыло.

Re: Нужна помощь по восстановлению ПО S7-200.
Oleg; 6.3.03

Забыл про мыло: magic_gsm@ua.fm


text

Замена IP 214
Алексей; 4.3.03

Подскажите чем можно заменить блок IP 241 в контроллере S5-155U.В принцепе нужен только счетчик для работы с инкрементальным датчиком.

Присмотрел IP 281 вроде подходит ,но нет полной документации.
Может кто чтонибуть посоветует что нибуть ?

Re: Замена IP 214
aim; 4.3.03

Можно брать :)


text

Аналоговый модуль и отрицательная темп-ра
Игорь; 24.2.03

К аналоговому модулю 6ES7-331-7KB02-0AB0 подключен термометр сопротивления 100П (-50...350 С). При переходе из положительных в отрицательные температуры единицы входа уменьшаются до 0 (1 градус=10 единиц), а затем происходит скачок единиц до максимального значения (65535) и последующее уменьшение. Скажите почему?

Re: Аналоговый модуль и отрицательная темп-ра
Виктор; 25.2.03

Датчик я так понял с токовым преобразователем 4..20мА?

Если так, то виноват скорее всего он...
Re: Аналоговый модуль и отрицательная темп-ра
В. Сорокин.; 25.2.03

А может информация у Вас становится представлена в дополнительном коде (65535 это -0). Обычно это типично. Поиграйте с преобразованием формата данных. Думаю получится.

Re: Аналоговый модуль и отрицательная темп-ра
Чистяков Дмитрий ОАО "СеверСталь"; 25.2.03

Проверьте правильность подключения с точки зрения земли на модуле.

Если он установлен в станцию ET200M, то снимите перемычку на разъёме птиания модуля IM153.
Re: Аналоговый модуль и отрицательная темп-ра
Игорь; 26.2.03

Термометр сопротивления подключен напрямую к модулю без преобразователя по 2х-проводной схеме. Переключатель установлен в положение А (80/250/500/1000mV/Pt100).

Получается, что выше нуля пропорция 1 градус = 10 единиц сохраняется, а вот ниже нуля температуру надо высчитывать уже по другому?
Re: Аналоговый модуль и отрицательная темп-ра
Виктор; 26.2.03

А как можно подключить PT100 по 2х проводной схеме? Он должен включаться по 4х проводной. 2х проводная сильно снижает точность измерения. Однако если Вы ее используете необходимо установить 2 перемычки ([M+ и Ic+] и [M- и Ic-]. См.документацию на модуль. А лучше подключить по 4х проводной.

Re: Аналоговый модуль и отрицательная темп-ра
Виктор; 26.2.03

А скорее всего В.Сорокин прав. Отрицательные числа представляются в дополнительном коде. Все знаки инвертируются и в последнем появляется "1" знак минуса.

Но все же переключите по 4х проводной..:))
Re: Аналоговый модуль и отрицательная темп-ра
Игорь; 27.2.03

Естественно перемычки ([M+ и Ic+] и [M- и Ic-] установлены! Как же иначе :-)

Re: Аналоговый модуль и отрицательная темп-ра
Виктор; 27.2.03

Все равно 2х проводная-это не по правилам! :-)

Re: Аналоговый модуль и отрицательная темп-ра
В. Сорокин.; 27.2.03

Извините, уезжал.

Если в двоичном представлениии Вашего числа в старшем разряде 1 (32768), то число в доп. коде. Отнимите 32768. И отнимите, то что получится, от 32768. получите что надо, ну ... и знак учтите.
Но,не помню точно, в СТЕП 7 преобразованием из формата в формат тоже должно получиться. Давно не пользовался, не помню, а букваря под рукой нет.
Извините.


text

S5-135U 6AV1242-0AB10
Сергей; 26.2.03

В контроллере S5-135U стоит модуль 6AV1242-0AB10. К нему подключен монитор. Не подскажете, что это за модуль и где можно достать какую нибудь документацию.

Спасибо!
Re: S5-135U 6AV1242-0AB10
Виктор; 26.2.03

Это коммуникационный процессор CP572-M для монитора M20/M23.

Re: S5-135U 6AV1242-0AB10
Сергей; 26.2.03

А где храниться само изображение, в блоке данных СPU?

Re: S5-135U 6AV1242-0AB10
Виктор; 27.2.03

К сожалению эта вся информация которую я нашел на немецком сайте...

http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo2&siteid=cs&lang=en&content=%2Fskm%2Fsearch%2Easp


text

Программирование SIEMENS
Панов Сергей; 24.9.02

Помогите !

Нужно запрограммировать S7-400.
Перепрошился с помощью адаптера 6ES7972-0ca21-0xa0 раза три, потом перестал. Пишет ошибку "Online: No other partner can be found." Поменял адаптер на 6ES7901-2BF00-0AA0 (подумал что в адаптере проблема). Та же самая ошибка. Под рукой нашёлся S7-300 номер ошибки не изменился. Я думаю, что оборудование исправно. Если кто знает в чём причина, принимаю любую помощь, советы...
Re: Программирование SIEMENS
siemargl; 24.9.02

Вероятно, порт куда цепляешься, перепрошил на другую скорость.

Re: Программирование SIEMENS
Чистяков Дмитрий ОАО "СеверСталь"; 25.9.02

Раз с другим контроллером не пошло, значит порт COM-овский спали.

Re: Программирование SIEMENS
aim; 25.9.02

По поводу порта абсолютно согласен. Лично наблюдал такую ситуацию с опрометчивым спецом ;-)))

Как правило, порт можно спалить если не разорвав соединения с Simatic`ом отключить адаптер от компа. В мануале это отдельным пунктом выделено.
Re: Программирование SIEMENS
Илья; 14.10.02

По поводу подключения вообще:

если у вас хорошая земля - то порт в РС-адаптере спалить очень трудно. А если земля плохая - то можно не только порт спалить, но и самому получить. В любом случае - выровняйте потенциалы общих точек или земли (а то портов не напасетесь)
Re: Программирование SIEMENS
Павел; 26.11.02

На адаптере есть переключатель скорости. Попробовать изменить скорость

Re: Программирование SIEMENS
Bиталий ; 7.12.02

Адаптер может быть исправным,попробуйте поковыряться в настройках интерфейса. У нас был подобный случай . Возможно у вас выделено несколько типов интерфейсныдх карт.

Re: Программирование SIEMENS
S7-Incognito; 3.1.03

А еще на адаптере есть рычаг ручного

тормоза , он должен быть в нижнем
положении (к совету Павлa)
Re: Программирование SIEMENS
Aleks_odessa; 25.2.03

Уменя подобное было после установки программы симулятора PLCSIM...

Пришлось полностью сносить и симулятор и СТЕП переустанавливать... :-(


text

Модули с выходом на электроклапана
Беспалов А.; 5.1.03

Подскажите, есть ли в модельном ряде серии S7 выходные модули для управления электроклапанами (=48В). Может это какие-нибудь специализированные модули, которых нет в общем каталоге продуктов Siemens?

Re: Модули с выходом на электроклапана
GorA; 5.1.03

6ES7422-5EH10-0AB0 SIMATIC S7-400, SM 422, МОДУЛЬ ВЫВОДА ДИСКРЕТНЫХ СИГНАЛОВ, ОПТОЭЛЕКТРОННОЕ РАЗДЕЛЕНИЕ ВНЕШНИХ И ВНУТРЕННИХ ЦЕПЕЙ, 16 ВЫХОДОВ =20...125В/1.5A, 8 ГРУПП ПО 2 ВЫХОДА, ДИАГНОСТИКА. ФРОНТАЛЬНЫЙ СОЕДИНИТЕЛЬ ЗАКАЗЫВАЕТСЯ ОТДЕЛЬНО

Re: Модули с выходом на электроклапана
Беспалов А.; 8.1.03

А нет ли модулей с нагрузочной способностью на канал > или = 3А? Т.к. используются достаточно мощные соленоиды, и не хотелось бы использовать дополнительные твердотельные промежуточные реле .

Re: Модули с выходом на электроклапана
Мимо проходил; 22.2.03

Ты лучше подумай прежде чем НЕ ставить реле, о тех людях которые будут обслуживать твой геморрой. Мне тут такие итальянские спецы подсунули такую свинью. А если еще и коротнет и стрельнет. Но СИМЕНС в убытке не останется.


text

CPU314 IFM - не могу поключится
Somebody; 19.2.03

не могу поключится к CPU314 IFM. Пишет: Online: No other active partner can be found. Хотя Accessible Nodes показывает MPI 3 адреса : ноутбука, CPU314 и CP343-5. На CP343-5 горит ошибка SF.

На индикаторах CPU нет ошибок.
Посоветуйте что-нибудь!
Re: CPU314 IFM - не могу поключится
Baby; 20.2.03

Привет,Somebody !!!

Куда непосредственно подключаетесь кабелем MPI c ноутбука ???
И какая конфигурация стойки ???

Пока......

Re: CPU314 IFM - не могу поключится
Somebody; 22.2.03

решил проблему. был конфликт с сетевой картой на ноуте


text

Cpu315(контроль со стороны контроллера "жива" ли станция WinCC)
Александр; 17.2.03

По рекомендации aim немного изучили мат часть.Выяснилось, что существует блок OB84 (cpu hardware fault), который в том числе позволяет определять наличие MPI связи. Но в CPU 315 он не реализован .Подскажите есть ли его "заменители" либо какая нибудь друга возможность.....

Это необходимо для того что бы в случае "падежа" рабочей станции => отсутствия MPI связи между контрол. и раб станцией управление контроллером автоматически переходило на OP7(автоматич режим)
Заранее благодарен.
Re: Cpu315(контроль со стороны контроллера
aim; 17.2.03

Привет Александр!

Рад за тебя, продвигаешся ;)

Вот ты и сам ответил на свой вопрос. С помощью OB84 и соответствующих SFx контролируешь наличие соединения с конкретным партнёром по MPI.
Если связь есть - панель игнорируеш, если нет - учитываеш.

Удачи :)

Re: Cpu315(контроль со стороны контроллера
Александр; 18.2.03

Спасибо за пожелание удачи , но....

OB84 нет в CPU315
по крайней мере он мне не "дался"...

Re: Cpu315(контроль со стороны контроллера
aim; 18.2.03

А он и не "даётся" :)

Итак по порядку:
1.Сам в Step`е создаёшь енто OB.
2.Прописываешь в нем соотв-е процедуры.
3.Download

P.S.
Это OB вызовется само, когда произойдёт соотв-е событие. В локальных переменных блока имеется информация по какой причине он был вызван.

Удачи...

Re: Cpu315(контроль со стороны контроллера
Чистяков Дмитрий ОАО "СеверСталь"; 19.2.03

От себя добавлю, что описание на русском языке параметров OB84 можно найти вот здесь

http://www.automation-drives.ru/as/products/07_is/04_man/05_1_SFC_r.pdf

Re: Cpu315(контроль со стороны контроллера
Александр; 19.2.03

Всем спасибо!!!

мне бы такого босса aim.....
кстати если это ФИО
то гораздо "скромнее" быдет смотреться
Iam)))))
Re: Cpu315(контроль со стороны контроллера
Александр; 20.2.03

Да .....

поспешил я с выводами...
не "даунлодится" "самопальный" OB 84 .
Мы сотворили все просто , "пингуя" изменяемый с частотой 2 сек бит...
Если кому интересно с радостью обьясню как.(yevsukov@rambler.ru)
Это ж так прикольно чувствовать себя полезным. Шутка)))


text

Field PG
Кокин Юрий; 27.1.03

не пойму в чем дело...

постоянные сбои не то на аппаратном не то на программном уровне.
отказывает то сеть, то звук, то сд-рв
поготите пож-та разобраться
может нужно обновить драйвера?

Re: Field PG
Чистяков Дмитрий ОАО "СеверСталь"; 29.1.03

Скорее всего не верно распределяются или нехватка прерываний в системе.

Re: Field PG
Кокин Юрий; 17.2.03

нет дело оказалось не в прерываниях, а в маме...

мне ее в сайменсе поменяли и теперь все в порядке.

Спасибо за совет
Re: Field PG
Чистяков Дмитрий ОАО "СеверСталь"; 18.2.03

Версию BIOS не заметил?

Может просто более новая?
Re: Field PG
Кокин Юрий; 18.2.03

нет маму они точно поменяли.

а биос я уже сам к тому времени обновил.
но на новой маме тоже обнавленный биос стоит.
спасибо за совет
Юрий


text

Контроллер RS-485 - Modbus.
Алексей; 14.1.03

Помогите выбрать контроллер, работающий с панелью, на входе которого RS-485 а на выходе - Modbus.

Re: Контроллер RS-485 - Modbus.
kot; 17.2.03

CPU 226 (два порта) один порт работает

по RS-485 или MPI с панелью, а второй
строится по free port на ModBas (прог.
в какихто Tip&Triks.)
Re: Контроллер RS-485 - Modbus.
Чистяков Дмитрий ОАО "СеверСталь"; 18.2.03

Не совсем понятен вопрос.

Если Вам необходимо связать контроллер типа Simatic S7-300 или S7-400 с этой панелью, то Вам необходим коммуникационный процессор CP341 для S7-300 и CP441 для S7-400


text

Забыл пароль.
Олег; 27.1.03

Столкнулся с проблемой: при попытке выгрузить программ с контроллера S200 идет запрос пароля (пароль не знаю). Есть ли способ обойти пароль?

Re: Забыл пароль.
kot; 17.2.03

В Clear PLC надо написать clearplc без

пробелов. Обычно помогает.


text

Cpu315(контроль связи с WinCC и питания контроллера)
Александр; 14.2.03

CPU работает автономно WinCC-станция снимает показания

Необходима сигнализация присутствия/отсутствия питания подающегося на контроллер, MPI связи контроллера с рабочей станцией.
Есть ли спец бит в памяти контроллера отвечающий за MPI связь?
Заранее благодарен за помощь.
Re: Cpu315(контроль связи с WinCC и питания контроллера)
aim; 14.2.03

Мда. Воспрос поставлен некоректно!

Для WinCC по барабану, нет питания или обрыв MPI кабеля :).
Ну а по поводу "спец" бита - изучайте мат часть...
Re: Cpu315(контроль связи с WinCC и питания контроллера)
Юрий Оганесян; 16.2.03

Используйте ф-ции типа GetTagXXXState

Re: Cpu315(контроль связи с WinCC и питания контроллера)
Чистяков Дмитрий ОАО "СеверСталь"; 16.2.03

aim прав, и функция GetTagXXXState покажет, что нет связи и всё тут. :-)


text

Передача аварийных сообщений (с квитированием) на OP27
Заболотный С.В.; 1.7.02

Проичитал все, что только удалось найти в документации и в i-нет, но не могу передать сообщение об ошибке при помощи блоков SFC17 и ему подобных.

Научите кто-нибудь!!!
(PDiag-a нет!)
Re: Передача аварийных сообщений (с квитированием) на OP27
Владимир Романко; 30.8.02

Я решал такую проблему: к контроллеру S7-300 подключен OP7 и комп с WinCC. Задача состояла в том чтобы Alarm Login отображался и на панели и на компе. Квитирование следовало синхронизировать таким образом, что бы квитирование в WinCC приводило бы к автоматическому квитированию этого же сообщения на панели и наоборот.

Это то что вас интересует? Или я что-то не понял.
Re: Передача аварийных сообщений (с квитированием) на OP27, а как Вы это сделали (если можно то для чайников)
Александр; 14.2.03

Просьба описать порядок Ваших действий.

Передо мной стоит та же проблема,а мозгов не хватает.
Спасибо.


text

Как запустить 1Count 24V/100kHz для ET200S?
Елена; 14.2.03

Никак не могу запустить счетчик 1Count 24V/100kHz для ET200S. Может у кого есть идеи?


text

S5-150U cpu926
Размыслович Кирилл; 4.2.03

На Красноярском металлургическом заводе из закрамов достали

оборудование с процессором S5-150U. При перепрограммировании его
возникла проблема. Дело в том что в ОЗУ нельзя передать блоки, будь-то
программные, функциональные или блоки данных, размером больше 128W.
Процессор состоит из следующих плат:
6ES5924-3SA12
6ES5925-3SA11
6ES5926-3SA12
6ES5927-3SA12
и платы связи с программатором 6ES5511-AA14
Если есть тех.документация на эти устройства просим сообщить или
выслать.

Re: S5-150U cpu926
Чистяков Дмитрий ОАО "СеверСталь"; 5.2.03

В электронном виде такой документации не существует, так как контроллер давным-давно снят с производства.

Но тем не менее эту документацию можно заказать в бумажном виде. Это будет стоить денег и времени ожидания на поставку из Германии.
Re: S5-150U cpu926
Baby; 6.2.03

Привет, Кирилл !!!!!

У нас применяется ( пока, скоро будет реконструкция)
точно такая же конфигурация процессора.
Проблем никогда не возникало с загрузкой блоков размером больше
128 слов.
Если возможно, опишите более подробно проблему.
Дока у нас есть, но в бумажном виде.
Может всё дело дело в перемычках на ОЗУ .........,
хотя это не должно никак влиять на загрузку......

Я и ещё двое моих коллег около часа обсуждали Вашу проблему,
но информации слишком мало ...........

Пока.......

Re: S5-150U cpu926
Кирилл; 7.2.03

Всем спасибо за внимание!

Проблема с загрузкой программы решена
причина в кривой установке пакета STEP5. Но интересно что процессор не хочет связываться с PG685(хотя программатор однозначно вяжется с другими процессорами).
Если возможно вышлите информацию по перемычкам на плате памяти 350 и плате связи с программатором 511.

Re: S5-150U cpu926
Кирилл; 14.2.03

Помогите кто может информацией.

Есть S5-150U с 926 процессором, который работает с ПЗУ 32Кв вставленном в плату памяти 530.Мне нужно изменять программу, а внутренней памяти процессора не достаточно для хранения программы. У меня есть модуль ОЗУ 128Кв, но когда его вставляешь вместо ПЗУ процессор виснет. Нужна информация по плате памяти 350(по видимому на ней выставляется размер и тип памяти).


text

Simatic S5 115U CPU 945
Александров Константин; 30.9.02

Где можно взять документацию на русском или английском языке по Simatic S5 115U CPU 945?

Re: Simatic S5 115U CPU 945
Чистяков Дмитрий ОАО СеверСталь; 30.9.02

На русском языке

http://www.automation-drives.ru/as/products/05_s5/04_man/index.shtml

На английском
http://www.ad.siemens.de/csi_e

Re: Simatic S5 115U CPU 945
Борисов евгений ОАО ГАЗ; 13.2.03

Где можно взять документацию на русском или английском языке по Simatic S5 115U CPU 942


text

TS Adapter 6ES7972-0CA3x- 0XA0
Жарков А.Н.; 13.2.03

Требуется сделать диагности данного оборудования.

Сами находимся в Алтайском крае, г. Барнаул.
Нужны сервисных центров, представителей SIEMENS в г.Новосибирск, г.Москва


text

Куплю PC Adapter ^ES7 972-0CA2x-0XA0
Жарков А.Н.; 13.2.03

Не можем подключиться удаленно к производственному оборудованию через модем и данный адаптер. Причину выяснить не можем. Либо проблемы с адаптером (вероятнее всего), либо что то другое. Из германии говорят, что проще купить в России, но сказать где не могут.

Re: Куплю PC Adapter ^ES7 972-0CA2x-0XA0
Рябов Андрей; 13.2.03

Для подключения через модем Вам нужен TS Adapter 6ES7972-0CA3x-0XA0.

Re: Куплю PC Adapter ^ES7 972-0CA2x-0XA0
Жарков А.Н.; 13.2.03

Была допущена ошибка в запросе.

Имеется именно такой адаптер (TS)
Требуется сделать его диагностику и в случае неисправности приобрести новый.
Находимся в Алтайской крае, г. Барнаул


text

Декодер SSI
Константин ; 11.2.03

Поддерживает ли процессор S7-300

2 модуля FM 351 для опроса 4 Декодеров с интерфейсом SSI?

Re: Декодер SSI
Чистяков Дмитрий ОАО СеверСталь; 11.2.03

Таких процессоров как S7-300 не бывает ;-)

А существуют CPU315, CPU318

Ну, а так, например, CPU314 поддерживает до 8ми FM модулей.
Более подробно можно почитать в описании модулей CPU
http://www.automation-drives.ru/as/products/02_s7/04_man/index.shtml
или прямо в каталоге CA01 в разделе "Технические данные"


text

simatic S5
Продам; 1.11.02

Продам програмний контролер

Simatik S5-95U СРОЧНО
Re: simatic S5
Дмитрий; 20.11.02

Народ избавляется от Simatic?

Чем заменить simatic S5 или горький сахар
Дмитрий; 21.11.02

То есть народ пытается перейти на S7? Судя по количеству тем (читай - багов) с S5, мы по-прежнему бодры и веселы (поэтому и непобедимы!)

Re: simatic S5
Гордеев Борис; 11.2.03

Стартовая цена, комплектация?


text

Резервирование
Игорь; 11.2.03

ТРебуется построить систему с горячим

резервированием на S7 какую серию
лучше выбрать? Можно ли это сделать на 300 серии?

Re: Резервирование
Андрей Гуленок; 11.2.03

Лучше выбрать S7-400H. Но можно и на S7-300 при помощи пакета SoftRedundanz.


text

Резервирование ЦПУ 315-2DP
Александр Мишуткин; 6.2.03

Добрый день, коллеги !

Интересует следующий вопрос.

Предполагается создание системы АСУТП на базе 300-й линейки с вышеуказанным ЦПУ.
Периферия распределенная, на ET-200M.
Связь предполагается сделать на Profibus-DP.
Вопрос в следующем - можно ли поставить 2-й ЦПУ в "дежурном" режиме, чтобы в случае чего он полностью перехватил управление ВСЕЙ распределенной периферией ?

Re: Резервирование ЦПУ 315-2DP
shurik; 6.2.03

никаких проблем используя Software Redundancy

Re: Резервирование ЦПУ 315-2DP
Виктор; 10.2.03

Наверное лучше посмотреть про F- системы....Может быть

Re: Резервирование ЦПУ 315-2DP
fog; 11.2.03

Зависит от степени безопасности, предъявляемой к объекту автоматизации.


text

S5 диагностика связи и состояния
Дроздов Д.Е.; 7.2.03

Можно ли продиагностировать наличие связи с контроллером из WinCC и вообще его состояние? Есть ли в S5 какие-то стандартные области памяти с такой информацией?

И еще - удаленно из WinCC их можно перегрузить, остановить или что-то в этом роде?
Re: S5 диагностика связи и состояния
Алексей; 7.2.03

Пример для диагностики связи с контроллером Step5 :

DWORD dwState = 0;
GetTagWordState("Variable",dwState);
if (dwState == 0)
{
//Connect Ok
SetTagBit("Status",FALSE);
}
else
{
//Connect Error
SetTagBit("Status",TRUE);
}
А потом контролируй Status,можеш занести его в AlarmLogin для контроля.
Re: S5 диагностика связи и состояния
Чистяков Дмитрий ОАО "СеверСталь"; 7.2.03

>Можно ли продиагностировать наличие связи с контроллером из WinCC и вообще его состояние?

Можно. Точно так же как и любого другого контроллера. Например, через вставленный объект WinCC Channel Diagnostic, либо через галку Evaluate Status of Tag в Dinamic Dialog.

>Есть ли в S5 какие-то стандартные области памяти с такой информацией?

С какой информацией? Если имеется ввиду код ошибки, то он выдаётся соответствующим блоком передачи и приёма информации из сети.

Re: S5 диагностика связи и состояния
Дроздов Д.Е.; 10.2.03

Ага. Всем спасибо, понял.


text

Simatic в Барнауле
Михаил; 29.1.03

Привет! Откликнитесь, если у кого-то есть программатор для S5 в Барнауле или поблизости, очень нужен для запуска линии. Заранее благодарен, Михаил.

Re: Simatic в Барнауле
Andrey; 7.2.03

В Новосибирске!

Смотри www.sinetic.ru


text

Перегрузка компьютера ...
Хлопин Денис; 5.2.03

Есть контроллер S7-300(CPU315-2DP), соединение с компьютером MPI, (На компе проект WinCC, CP5611). Проблема в том, что, постоянно, через неопределенное время, при активном соединении с контроллером компьютер перезагружается! Если связи нет(отрублен кабель или CPU в стопе), то перезагрузки прекращаются! В чем может быть проблема? CP5611 менял на 5613 не помогло...

Re: Перегрузка компьютера ...
Евгений Трунов; 6.2.03

А не установлен ли в свойствах системы признак "выполнять автоматическую перезагрузку при фатальных сбоях"? Если да, то проблемы могут вызываться программными сбоями в драйверах плат CP5611/CP5613 (хотя вроде такого за ними не наблюдалось). Могут быть какие-то аппаратные проблемы при работе плат этой серии именно на Вашей рабочей станции, вызывающие сбои драйверов. Попробуйте вставить платы в другую станцию или хоть добейтесь появления BSOD Windows на Вашей - всё же поле для раздумий сузится.


text

позиционирование, абсолютный датчик SSI
Герасимов Иван; 3.2.03

Подскажите пожалуйста ссылки с описанием:

управление позиционированием с абсолютным датчиком SSI на FM- или CPU314C.

Заранее благодарен,
Re: позиционирование, абсолютный датчик SSI
Виктор; 4.2.03

Если я правильно Вас понял, то все, что вам нужно есть в описании FM-352. У меня есть. На английском, около 200стр.

Re: позиционирование, абсолютный датчик SSI
Чистяков Дмитрий ОАО "СеверСталь"; 5.2.03

Не совсем понятен вопрос.

Если вы хотите подключить датчик по интерфейсу SSI, то вам необходим соответствующий модуль ввода.
Для этого подойдёт Выше указанный модуль FM 352.
Только учтите, что количество этих модулей в одной корзине ограничено сравнительно большим током потребленя от источника питания (100ма).

Вся документация на английском языке по всем модулям доступна на сайте поддержки. В частности на этот модуль документация имеется вот здесь
http://www4.ad.siemens.de/news/cs/en/11054186

Или вы хотите какими-то хитрыми способами обойтись без каких либо специальных модулей?


text

размножение аналогового сигнала
АЛЕКСАНДР; 22.1.03

есть необходимость размножить и гальванически развязать аналоговый сигнал 4-20мА не прибегая к помощи контроллера - может кто-то знает подобные преобразователи (один вход - два выхода)

Заранее благодарен

Re: размножение аналогового сигнала
Виктор; 31.1.03

А почему нельзя соединить последовательно два приемника аналогового сигнала? Мы так делали и нормально...

Re: размножение аналогового сигнала
Ефременко Денис; 4.2.03

У нас стоит пирометр, а сигнал 4..20мА нужно вывести на аналоговый модуль и показометр.То есть, просто соединяем последовательно все и никаких не будет искажений сигнала? Я правильно понял?

Re: размножение аналогового сигнала
Илья; 4.2.03

Посмотри SITRANS I - может есть что подходящее. Кроме Сименса подобные изделия выпускает масса фирм. Российские не рекомендую.

Re: размножение аналогового сигнала
Виктор; 4.2.03

Никаких искажений сигнала не будет. Сопротивления приемников достаточно малы. Однако никакой гальваноразвязки здесь то же нет :)


text

Вопрос про прерывание С7-633
Андрей; 30.1.03

Подскажите где можно прочитать про работу с прерываниями в ОВ40 и примеры програм

Re: Вопрос про прерывание С7-633
Виктор; 31.1.03

Каждый модуль, дающий прерывание в OB40 по своему с ним работает. Поэтому лучше читать доку на тот модуль с которого Вы хотите анализировать прерывания.


text

аналоговый модуль 7KF02
Александр; 31.1.03

Нужно ли запитывать внешние цепи 4-20mA отдельным источником питания, либо аналоговый модуль 7KF02 обеспечивает питание непосредственно из каждого измерительного канала

Спасибо.

Re: аналоговый модуль 7KF02
Виктор; 31.1.03

Обеспечит, в режиме 2х проводной схемы. Внешнего питания не нужно.


text

S5-115U-Stop. Нет программатора.
Михаил; 29.1.03

Привет! Есть ли возможность определить причину STOP+BASP на S5-115U без программатора?

Есть ли возможность смоделировать программатор на РС?

С уважением, Михаил.

Re: S5-115U-Stop. Нет программатора.
Aleks; 30.1.03

Возможность есть

Собственно PC c Com портом
Адаптер RS232 - TTY
и нужен пакет Step5


text

S5 STOP BASP "Tetra Laval Food Hoyer"
Михаил; 29.1.03

Привет! Если кто-то имеет опыт работы на линии производства мороженого Tetra Laval Food (контроллеры на Simatic S5), прошу откликнуться, есть ряд вопросов. В частности, на контроллере коммуникации CP 523 отсутствует блок памяти в гнезде на лицевой панели. Может ли из-за этого происходить останов CPU 115U c индикацией "STOP", "BASP". Заранее благодарен. Михаил.

Re: S5 STOP BASP
Рябов Андрей; 29.1.03

Не может. В СР523 EPROM может быть установлен для загрузки параметров и настройки интерфейса и (в случае если CP523 работает в "принтерном режиме") сохранения текстов сообщения. Но наличие EPROM'а не обязательно, параметрировать СР523 можно и через программу PLC. А почему CPU переходит в "STOP" надо смотреть в I-стеке.

Re: S5 STOP BASP
Михаил; 29.1.03

Андрей, спасибо за ответ. I-стек, наверно, надо смотреть программатором, а он отсутствует. Возможно ли определить причину STOP+BASP без программатора? Есть ли возможность смоделировать программатор на РС? Михаил.


text

ET200B 6ES7 133
Ruslan; 27.1.03

Помогите найти ET200B , и сколько она стоит ,ее параметры 24DI, 8DO.

Re: ET200B 6ES7 133
Михайлин Сергей; 28.1.03

Параметры вот здесь

http://www.aud.ru/as/products/04_et200/03_cat/DP_r.pdf

Цены вот здесь
http://www.aud.ru/as/products/02_s7/02_pr/PriceListAS.zip


text

компиляция для FM352-5
Владимир; 28.1.03

Во время компиляции программы для FM352-5 получаю информацию об ошибке и в файле appfb появляется запись :

FATAL_ERROR:StaticFileParsers:Xml_Node.c:358:1.12.8.2 - Corrupt or missing Xml conversion files.


text

Modbus для CP441-2
Turt; 27.1.03

Господа, кто знает, нужно ли для CP 441-2 где оба порта работают по Modbus заказывать два Dongle (ключа)?? Или хватит одного?

Re: Modbus для CP441-2
Карлуша; 28.1.03

Привет крутым специалистам!!!!!

А вторую коробочку ты куда будешь вставлять????? В MPI порт контроллера?


text

COM Profibus Export to DP Master
Дима; 26.1.03

После включения питания IM 308 C загружает операционную систему но как DP устройство не виден хотя находящийся на этой-же шине ET 200S откликается, если кто сталкивался с подобной проблемой то поделитесь опытом


text

Модули outdoor (вне помещения)
Иван Жуков; 17.1.03

У меня следующий вопрос: чем отличаются модули в исполнении outdoor от обычных. В частности, меня интересует, можно ли поставить эти модули в условия с высокой влажностью (ок. 100%) и температурой (до +50 гр.)

Re: Модули outdoor (вне помещения)
Михайлин Сергей; 17.1.03

У этих модулей платы залиты лаком и заменены некоторые компоненты. Модули могут работать в диапазоне -25°C...+60 °C и при влажности до 95% Допускаются кратковременные воздействия, как-то лед, конденсат, вибрация и удары. Устойчивы к загрязнению и пыли.


text

LOGO
Яковлев Михаил АОММЗ; 27.12.02

Пропала верхняя строка индикации входов

Программа крутится, блок работает,но невозможно перепрограммировать.Подскажите можно ли что-либо сделать.

Re: LOGO
Барановский Валерий СЗАО ММЗ; 16.1.03

Попроси у ребят из КИПа

Logo!SoftComfort


text

Роман
CPU 416-2DP; 10.1.03

Не могу связатся с CPU 416-2DP(процессор еще не был в работе) ни по MPI, ни по Profibus. Програматор исправный, потому что с другим

CPU 416-2DP, который стоит на работающей установке я связывался без проблем и по MPI, и по Profibus.
Интерфейсы, адресса, скорости я устанавливал такие же, как при подключении к работающему CPU.
Когда установлена связь по MPI Simatic Manager всегда выдает сообщенние:
"On line:No other active partner can be found"
Причем при работе CPU на его индикаторах нет никаких аварийных сигналов, и при включении его видно как он делает полный Reset
Заранее благодарен за любую помощь!

Re: Роман
Сергей; 10.1.03

А о чем говорит список доступных адресов в разделе "диагностика" в приложении Setting PG-PC interface, где при соединении должен по идее появиться (считаться) MPI-адрес вашего CPU?

Re: Роман
Роман; 13.1.03

В разделе "диагностика", когда тестирую MPI, всегда появляется ошибка,что нет связи.

Re: Роман
Viktor; 15.1.03

Сделайте MRES полный.

Re: Роман
Григорий; 16.1.03

Возможно в Step'e включена работа с эмулятором (PLCsim). Нужно отжать эту кнопку (мышью) или не установлен нужный интерфейс в панели SET PC/PG interface


text

Переход в состояние DEFECTIVE S7-412
dda; 4.1.03

Переодически контролер переходит в состояние DEFECTIVE с кодом сообщения W#16#4550 и Z1=AC04, Z2=0047, Z3=0629 в чем может быть причина?

Re: Переход в состояние DEFECTIVE S7-412
Viktor; 15.1.03

А в диагностическом буфере чего?

Help on Event нажимали?
Re: Переход в состояние DEFECTIVE S7-412
dda; 15.1.03

Нажимал - написано обратитесь к разработчику

Re: Переход в состояние DEFECTIVE S7-412
Viktor; 16.1.03

Круто!

А попробуйте полностью память сбросить.
Re: Переход в состояние DEFECTIVE S7-412
dda; 16.1.03

Значит ситуация такая:

Процессор проработал 2 года без сбоев потом перешел в DEFECTIVE, после сброса памяти и перегрузки программы работал пару суток и начал переходить в DEFECTIVE через каждый час после сброса памяти. Дальше не проверяли заменили новым процессором 417H в одиночном режиме который пока работает нормально.
Вопрос в следующем - можно ли вернуть 412 к жизни или это уже все, и бывали у кого нибудь похожие ситуации.
Заранее спасибо за информацию.


text

Связь S5 135U (CPU 928 [6ES5928-3UA12]) с MP370
Анатолий; 13.1.03

Уважаемые господа!

Возможна ли связь CPU 928 с MP370, если да, то какая. Потому что в описании каталога CT80-HMI отдельно выделено что связь операторной панели с CPU 928 невозможна.

Зарание благодарен,
Антолий.

Re: Связь S5 135U (CPU 928 [6ES5928-3UA12]) с MP370
Кухаренко Сергей, SIEMENS; 16.1.03

Согласно каталогу связь МР370 невозможна с CPU 928 - 6ES5928-3UA11. У Вас CPU 6ES5928-3UA12, поэтому проблем не должно быть.


text

(новый) сброс настроек при выключении s7-300
алексей; 9.1.03

у нас установлен s7-300 с CPU 314 IFM с платой памяти, батареи нет. Достаточно ли внести во флешку изменения ,чтобы сохранялись установки после выключения питания.Или в дополнения к перепрошивке флешки нужно поставить еще и батарейку?Либо достаточно только батарейки без перепрошивки?

Re: (новый) сброс настроек при выключении s7-300
П. Ш.; 13.1.03

Без батарейки те данные, которые менялись в процессе работы, после выключения питания сбросятся. Для сохранения меняющихся данных обычно достаточно только каталожной батарейки siemens. Ее хватает по документации на 2 года, но реально может работать раза в два дольше. Флешка удобна для переноса программы на другой контроллер.

Re: (новый) сброс настроек при выключении s7-300
Viktor; 15.1.03

Здравствуйте!

Да, достаточно сохранить на Flash- память проект и можно работать без батарейки. Только в HW-Config нужно "сохранить и откомпилировать". Мы пробовали. Но, естественно несохраняются ни меркеры ни блоки данных и т.п.
С батарейкой кроме того сохраняются меркеры и DB.


text

Будет ли работать конфигурация
Ефремов Максим; 10.1.03

Уважаемые господа!

1. Не могли бы вы подсказать, будет ли работоспособна следующая схема и есть ли в ней «подводные камни».
Контроллер S7-400H с одним процессором 414-4Н (6ES7414-4HJ00-0AB0) (так нужно), на нем стоит СР 443-5 Extended (6GK7443-5DX03-0XE0). Контроллер планируется связать с РС. На РС стоит СР-5613 (6GK561-3AA00), пакет NET PROFIBUS S7-5613 (6GK1713-5CB60-3AA0), планируется использовать протокол S7-соединений. Для программирования – отдельный PG с РС адаптером (6ES7972-0CA23-0XA0).

Все ли правильно или надо что-то менять?

2. Возможно ли собрать схему как-то проще, может быть дешевле?

Мы только начинаем работать с Сименс контроллерами, извиняйте за незнание таких вещей.

Ефремов М.Н.
Герасимов Н.В.
ОАО Апатит

Re: Будет ли работать конфигурация
Михайлин Сергей; 10.1.03

Работать через S7 будет, но тогда вы будете иметь два комплекта тэгов и вы сами будете определять какой из них сейчас корректен или Мастер. Функции по автоматическому определению этого дела зашиты в пакет S7-RedConnect. С помощью него WinCC или другая SCADA или OPC работает с Н-системой через один комплект тэгов не заморачиваясь на проверку достоверности. Но есть проблем :-( сейчас RedConneсt работает либо с СР1613 Ethernet (версия 1.4) либо с СР5412 Profibus(версия 1.3). Полноценной поддержки СР5613 пока нет. Я советую все сдлеать на Ethernet. Т.е поставить в каждую корзину по СР443-1, а на компьютер поставить СР1613 и RedConnect. Так правильнее и без заморочек на проектирование и закупку оборудования. Так можно и программировать систему и работать с HMI очень просто. Если есть еще вопросы сконтактируйтесь со мной мылом.


text

Математические функции в S7-300
Редников Василий; 8.1.03

Существуют ли дополнительные функции, позволяющие возводить число в произвольную степень?

Re: Математические функции в S7-300
Редников Василий; 10.1.03

Сам себе и отвечаю- через логарифмы.


text

сброс настроек при выключении s7-300
алексей; 8.1.03

При выключении s7-300 происходит сброс программы из памяти контроллера. В чем может быть причина?

Re: сброс настроек при выключении s7-300
Любитель Симатика; 8.1.03

А батарейка-то есть и жива-ли она ваще?

Re: сброс настроек при выключении s7-300
Денис Ефременко; 9.1.03

Может у тебя стоит "аккумулятор", так он питает только часы, а для сохранения программы нужна батарейка, либо можно воспользоваться флешкой.

Re: сброс настроек при выключении s7-300
алексей; 9.1.03

Спасибо за консультацию! У меня стоит s7-300 с CPU 314 IFM с платой памяти, батареи нет. Достаточно ли внести во флешку изменения ,чтобы сохранялись установки после выключения питания.Или в дополнения к перепрошивке флешки нужно поставить еще и батарейку?Либо достаточно только батарейки без перепрошивки?

Re: сброс настроек при выключении s7-300
Aleks; 9.1.03

Достаточно поставить батарейку.


text

CP 341 задержка приема-передачи
APS; 9.1.03

Стоит CPU-417 и удаленое ET200M на котором стоит CP341. Работаем стандартными функциями P_RCV_RK и P_SND_RK. Заметили интересную вещь: согласно миганию лампочек и работе подключаемого к CP341 устройства ответ приходит сразу после передачи пакета. Но в контроллере ответ появляется с задержкой секунд 5. Диагностический буфер пуст. Ошибок нет, статус нулевой. Играли настройками CP - ноль эмоций. Скорость обмена есть 9600 есть 19200, и там и там задержка одинакова. Правда стоит два CP341 на одной рейке, но это как бы не должно влиять. Поможите люди добрые советом!!


text

обновление библиотеки hardware s7
канат; 4.12.02

где найти драйвер для ком.процессора

CP 343-1
как обновить библиотеку hardware s7
канат; 4.12.02

где найти драйвер для ком. процессора СР 343-1 и СР 443-1?

Re: обновление библиотеки hardware s7
Чистяков Дмитрий ОАО "СеверСталь"; 5.12.02

Это что ещё за драйвер? ;-)

Если для Step 7, то достаточно при установке Step 7 или при повторном запуске установки, включить галку на NCM for Industrial Ethernet.

Re: обновление библиотеки hardware s7
Nec; 6.12.02

Да, наверное, простого подключения GSD-файла может не хватить. Нужно поставить NCM for IE, там и диагностика платы есть. После установки плата появится в списке оборудования.

Re: обновление библиотеки hardware s7
S7-Incognito; 3.1.03

http://www4.ad.siemens.de/csinfo/livelink.exe?func=ll&objaction=csbrowse&objid=11092156&lang=de&siteid=cs&listlength=-1


text

С Новым 2005 годом!!!!
Василий; 31.12.04

Всех с наступающим Новым годом!

Здоровья, счастья и семейного благополучия.
Чтобы техника Siemens работала хотя бы
до 11.01.05г. и Наши праздники прошли без вызовов на работу.
ОАО "Уралэлектромедь" <


text

Учебная конфигурация S7-200
Виктор; 27.12.04

Здравствуйте! Имеется сеть из трех S7-200, каждый из которых на разьеме имеет вход для подключения адаптера RS-485 для программирования. Можно ли обеспечить одновременную работу программаторов, чтобы иметь доступ с любого места до любого из PLC? Чтобы не выдергивать постоянно разьемы. Просто периодически возникают зависания при программировании. Адреса PLC разные, нужно ли устанавливать различные адреса PPI-адаптеров?

Заранее благодарен.
Re: Учебная конфигурация S7-200
Гуленок Андрей; 27.12.04

Да.

а) При наличии мультимастер - PPI кабелей
б) При наличии уникальных адресов у всех участников сети.
Re: Учебная конфигурация S7-200
Виктор; 28.12.04

Попробовал это сделать, и столкнулся с такой проблемой - при установке флажка мультимастера Windows просто перезагружается. То же самое происходит при попытке посмотреть наличие устройств в сети. Все адреса в сети уникальны, в том числе и PPI - кабелей. Может патч какой-нибудь есть..

Re: Учебная конфигурация S7-200
Андрей Гуленок; 28.12.04

А первое условие выполнено?

Re: Учебная конфигурация S7-200
Виктор; 29.12.04

Все понял, Андрей, спасибо за консультацию. У меня стоит старый кабель. Хотя иногда все работает, проблемы начинаются при подключении TD200 к системе. Еще раз, спасибо!


text

Пропадание связи WinCC - profibus - STEP5
Vladimir; 24.12.04

Помогите почему может пропадать связь S5 Siemens - profibus - WinCC,с очерёдностью 1-4 дня.WinCC работает через плату CP1413.Контроллер CPU945, работает - пропадает только связь со SDADA.После restart PLC - ok.В чём может быть проблема?

Re: Пропадание связи WinCC - profibus - STEP5
Чистяков Дмитрий ОАО СеверСталь; 24.12.04

Ещё раз скажу, что CP1413 - это Ethernet, а не Profibus и как это оно у вас там работаит? :-)

По какому протоколу работаете?
Какой канал в WinCC используете?
Re: Пропадание связи WinCC - profibus - STEP5
Vladimir; 27.12.04

Добрый день - Дмитрий!

Спасибо за ответ.
Дело в том,что у нас этот проект выполняли англичане,мы сами такие работы не выполняем.Я только работаю,частично обслуживаю систему,поэтому большого опыта в прораммировании нет.Если есть возможность Вы немогли скинуть мне Ваш e-mail или телефон. За раннее спасибо.
Я постараюсь собрать информацию на заданые Вами вопросы.
Re: Пропадание связи WinCC - profibus - STEP5
Vladimir; 27.12.04

Плата,на станции стоит CP1613,но она сконфигурирована под CP1413. Связь PLC-модем-SCADA.В PLC коммуникационный процессор стоит 6GK1143-OTA02. Модем установлен на коммуникационном - CentreCOM 210TS.

Где можно посмотреть протокол и канал связи WinCC,для того чтобы я мог Вам передать информацию. <


text

привязка DB к FB
qwe; 22.12.04

вопрос смешной, но имеет место:

где в STEP7 v 5.2 находится диалог <New Data Block>, в котором необходимо проставить галочку о привязке DB<Data Block referencing a function block>.
не стрелять
Re: привязка DB к FB
Чистяков Дмитрий ОАО СеверСталь; 22.12.04

Когда в программе Step7 будете вызывать Ваш FB, то пакет вас спросит номер DB и создаст его сама.

Re: привязка DB к FB
ЗАО ЭЛАКС Русланов Константин; 24.12.04

В менеджере проектов вставь новый DB, откроется окно свойств, в этом окне есть combobox Shared or Instance DB....дальше уже сам разберешся


text

S7-200 пароль
Андрей; 9.5.04

Как можно обойти пароль в проекте

Re: S7-200 пароль
Андрей Гуленок; 11.5.04

Пароль для того и сделан, чтобы защитить проект от несанкционированного вмешательства.

Re: S7-200 пароль
Андрей; 12.5.04

Ну,а если надо позарес его обойти???

Re: S7-200 пароль
Андрей Гуленок; 12.5.04

Один мой знакомый написал прогу, которая тупо перебирает пароли. Вот только симатик устроен так, что полный перебор занимает 64 года. Так что...

Re: S7-200 пароль
error; 12.5.04

Пишите письма в сервис или производителю оборудования :-)

Re: S7-200 пароль
Мифка; 21.12.04

Всегда есть выход!!!

Сам не пробовал, но вот че нарыл в инете:
вставляли модуль ПЗУ МС291,
давали команду запрограммировать его,
выключали/включали питание,
при этом та же программа из модуля садилась в ПЛК,
но уже без пароля.

Если есть какие други способы, буду рад их узнать
Re: S7-200 пароль
Pavel; 21.12.04

Уродов ставящих пароли на ПЛК нужно прибивать. Доступ к программе нужен не только для внесения изменений, но и для оперативной диагностики работы перефирии. Делается это как правило с одной целью-содрать денег за сервис.

Нормальные поставщики прилагают всекда копию программы на диске, да еще и листинг с коментариями.

Re: S7-200 пароль
Юрий; 23.12.04

Так как написал г.Мифка сделать не удалось, при попытке программировать картридж появляется запрос пароля.


text

CP341-Как жить без DONGLE?
Garris; 20.12.04

Кто-нибудь знает как в CP341 обойти использование аппаратной заглушки (Dongle)? У меня ее нет. СP341 будет Modbus Slave для передачи данных в SCADA под FIX 7.0

Спасибо.
Re: CP341-Как жить без DONGLE?
Чистяков Дмитрий ОАО СеверСталь; 21.12.04

Написать самому драйвер протокола, только я думаю проще будет купить заглушку. :-)

Re: CP341-Как жить без DONGLE?
Garris; 21.12.04

Дмитрий, я из документации не понял, заглушка для каждого загружаемого драйвера особенная, или это просто способ разрешения загрузки дополнительных драйверов со стороны Сименс. Драйвер-то есть на сайте.

Есть возможность использовать драйвер FIXа типа SIE (под S5), но я не знаю формата сообщения (ответа) драйверу FIXа. Запрос FIXа в CP341 принимается, что в запросе я вижу. Может, кто знает формат данных ответа (служебные байты и т.д.)?
Re: CP341-Как жить без DONGLE?
Garris; 21.12.04

Да, забыл указать, что протокол, используемый драйвером FIXа "SIE" - стандартный 3964R (т.е. заглушка не нужна)

Re: CP341-Как жить без DONGLE?
григорий; 22.12.04

Dongle это способ защиты от несанкционированного копирования для драйверов Модбус. протокол 3964R родной для СР, поэтому Донгл не нужен.


text

привязка DB к FB
qwe; 22.12.04

вопрос смешной, но имеет место:

где в STEP7 v 5.2 находится диалог <New Data Block>, в котором необходимо проставить галочку о привязке DB<Data Block referencing a function block>.
не стрелять<


text

Ошибка синхронизации в 400Н контроллере
Иванов Сергей; 10.12.04

Контроллер S7400H с подключёнными по резервированному PROFIBUSу тремя станциями ET200M. Периодически резервный процессор переходит в STOP. В буфере висит сообщение 16#43DA Stop due to synchronization error between H CPUs.

Какие могут быть причины возникновения этого сообщения и как с этим бороться?

Re: Ошибка синхронизации в 400Н контроллере
Михайлин Сергей; 21.12.04

Во-первых, прочитать диагностические буферы обоих ЦПУ и локализовать слот синхромодуля, который дает ошибку. Попробовать переставить модуль в другой слот и посмотреть измениться ли ошибочный слот.

Проверить затяжку всех синхромодулей и их крышек.
Может влиять грязь, пыль и повышенная температура. Соответственно продуть, охладить.
Кардинально, пробовать заменять ЦПУ и синхромодули.
Подробности в мыло.<


text

Верхний уровень LOGO
Еськов Алексей; 19.12.04

Уважаемые коллеги!

Есть ли верхний уровень у логический модулей LOGO?
Re: Верхний уровень LOGO
Сергей.; 20.12.04

Вам сюда.

См. http://www.automation-drives.ru/cgi-bin/forum/forum.cgi?dir=1008101932&root=1097066810&year=2004


text

Адаптер USB_COM для STEP7 v5.2
Алексей; 15.12.04

Не работает адаптер USB_COM тип GMUS-03 в STEP7 v5.2 под Win2k.sp3 и WinXP.

Были опробованы различные варианты драйверов - не помогло.
Посоветуйте, пожалуйста, реально работающий адаптер и где его можно приобрести?
Re: Адаптер USB_COM для STEP7 v5.2
Советчик; 16.12.04

Пожалуйста, MPI-USB 6ES7972-0CB20-0XA0 L-Price 306 Евро.

Re: Адаптер USB_COM для STEP7 v5.2
Алексей; 16.12.04

Хотелось бы по прежнему использовать MPI/RS232 адаптер.

Re: Адаптер USB_COM для STEP7 v5.2
Дмитрий; 17.12.04

Я поступил так. Пришел в компьютерный магазин, взял с собой компьютер, контроллер и кабель и методом перебора нашел USB COM адаптер.

Re: Адаптер USB_COM для STEP7 v5.2
Алексей; 20.12.04

Дмитрий скажите пожалуйста какой адаптер Вы выбрали. У нас в магазинах нет подобных вещей в наличии.


text

Программатор
Игорь; 11.12.04

Есть программатор S5 PG 685 II

6es5685-0ua12. Работать категорически отказался ;)
На экране пишет:
Ausgabe:A08 20/12/89
pg 685: Personal CP/M-86 Version 2.1/1
FEHLER in B: Disketten Schreib/Lese fehler BDOS.
Как вернуть к жизни? Что посоветуете.
Re: Программатор
Игорь; 13.12.04

Уважаемый Siemens, неужели не подскажете....

Re: Программатор
Kad; 13.12.04

Замени дискету....

Re: Программатор
Игорь; 13.12.04

Это не на дискете а на винте пишет.Что делать?

Re: Программатор
Alecs; 14.12.04

А где Вы? Есть ли набор комплектных дискет?

Re: Программатор
Чистяков Дмитрий ОАО СеверСталь; 14.12.04

Если винт сдох, то его даже заменить нечем будет, т.к. MFM винты сняты с производства уже лет 10 как.

Если не полетел, то форматнуть низким уровнем и установить всё с дискет.
Re: Программатор
Игорь; 14.12.04

Re: Программатор
Darwin; 15.12.04

Выбросить хлам такой. Или денег нет на простейший адаптер-кабель?

Re: Программатор
Kad; 15.12.04

Некоторые команды CP/M:

Емкость диска:
D>stat b: {RETURN}
Помощь:
D>help {RETURN}
Просмотр системных файлов:
D>dirs {RETURN}
Копирование файлов:
D>pip {RETURN}
Монтирование дискет:
D>dskmaint {RETURN}
и т.д....

Re: Программатор
ВК; 16.12.04

В "Мосматике" таких программаторов помню было как грязи. Может и сейчас есть :-)

Re: Программатор
Pavel; 16.12.04

Выкинуть конечно можно, но кабель с адаптером это прибор не заменит целиком, там ведь и с EPROM-ами можно работать

Re: Программатор
григорий; 18.12.04

В старых книгах по IBM pc типа Нортона, или может быть Фигурнова или TechHelp упоминается точка входа в ПЗУ для отладчика для форматирования винчестера. Как вариант можно попробовать DISK Manager версии примерно 3.3, точно не помню. Когда то уменя был на больших флопах, при заинтересованности можно попытаться поискать. Он позволяет форматировать MFM винчестеры на низком уровне. Возможно это поможет.

Кстати, можно поискать на FTP Курчатова - имя типа kiearchi<


text

Реле в модуле выходов S5
Chainic; 29.11.04

Модуль выходной 6ES5 451 8MR12 (реле).На плате стоят реле OW 5699.01/184/61K, питание 24 VDC, также обозначено сопротивление катушки 4350 Ом, 1 НО контакт на 5А/250В. Кто может подсказать замену, чтобы подошло по посадочным размерам. Или промышленные реле этого размера все должны подходить. Нашел реле Relpol http://www.atof.ru/pea/relay/list.shtml, но у них всех ток катушки слишком большой (сопротивл 1200-2000 Ом). Заранее благодарен за помощь

Re: Реле в модуле выходов S5
Pavel; 29.11.04

Думаю ничего страшного не произойдет, так-как ток ключа управляющего реле будет все равно на уровне 10-15мА, а это допустимо

Посмотри еще на сайтах Omron и Finder, у них очень широкая номенклатура.
Re: Реле в модуле выходов S5
Алекс; 18.12.04

Попробуйте реле RM96 (адрес по ссылке) либо на 24 либо на 48В

См. http://www.atof.ru/pea/relay/rm96.shtml


text

подскажите
DM; 17.12.04

такая ситуация: имеется программа для S7-300, в ней ОВ1, который нормально открывается.

На программаторе Feild PG загружаю эту программу на memory card MC 951 64K, после чего пробую открыть на флешке ОВ1- появляется ошибка:LAD/STL/FBD (34:40) Compiler information: type conflict, после этой ошибки появляется сообщение о невозможности открыть блок и он естественно не открывается. Пробовал менять в программе в ОВ1 язык с LAD на STL и FBD и загружать- таже история. Если загружать эту программу в CPU без вставленной МС, а затем посмотреть содержимое через Accessible Nodes- OB1 также не открывается. Проверял ОВ1 и всю полностью программу на консистентность- никаких ошибок и предупреждений.
Re: подскажите
DM; 17.12.04

в ОВ1 вызывается системная функция SFC20, если ее из блока выкинуть, то блок после загрузки открывается нормально, остается 2 вопроса:

1. системные функции вызываются не только в ОВ1, но и в других блоках (FC,FB), после загрузки в МС эти блоки открываются (хотя и появляются сообщения об ошибках), а места вызовов системных функций подсвечиваются красным. Можно ли что-нибудь сделать, чтобы и ОВ1 загружался, а потом открывался (наподобие как FC и FB)?
2. одна программа с открывающимся ОВ1 у меня есть, но есть еще один контроллер, в котором программа почти похожа на первый (но не совсем- ОВ1 в этих программах различаются например по размеру). При загрузке программы со 2-го контроллера ОВ1 не открывается. Могу ли я как-то открыть этот ОВ1? другого источника получения программы (кроме как из контроллера) у меня нет.
<


text

CPU 313С-2PtP и ГАММА-7М
Андрей; 16.12.04

Пытаемся связать CPU 313С-2PtP и ГАММА-7М по RS-485. Используем системные функции SFB 60 и SFB 61. Возникли трудности с приемом данных от ГАММЫ. Фирменная документация ссылается на пример ZEn26_01_TF_____31xC_PtP, которого у нас нет. Подскажите где его можно взять,желательно нахаляву :))))


text

CP342-5 как Master и его Slaves.
Klim; 16.12.04

Доброе утро!

Есть корзина с CPU 313C-2DP, в которой установлен CP342-5 и сконфигурирован как Master. В качестве Slaves пробовались ET200M и ПЧ MM440. Обмен данными соответственно осуществляется через FC- DP_Send и DP_Recv. Вроде как все тривиально?! Но обмен не получался, хотя и ошибок НИКАКИХ не было. Обмен получился только в единственном случае, когда Я сконфигурил стартовую область Slave с 0 адреса. Вроде все делал согнасно Manual'ам, но про такой изврат там ничего нет! Подскажите пожалуйста, где собака порылась? А если уже занята эта облась, что во всей проге менять? И если я применяю два CP, какую у него ставить область, ведь нулевая уже будет занята первым CP?
Всем заранее благодарен! <


text

ТСМ-50 и Simatic S7-300
Eugene Sergeev; 8.12.04

Добрый день!

Можно ли подключить медный термометр сопротивления ТСМ-50 непосредственно к аналоговому входу S7-300?

Re: ТСМ-50 и Simatic S7-300
Михайлин Сергей; 9.12.04

Подключить можно к любому аналоговому входу, настроенному на измерение сопротивления. Вопрос, кто будет пересчитывать Омы в градусы. Если модуль будет с номером 6ES7331-7PF01-0AB0, то в него эта градуировка заложена, если другой - то будете сами пересчитывать в программе ЦПУ.

Re: ТСМ-50 и Simatic S7-300
Eugene Sergeev; 10.12.04

А таблица пересчета официальная/работающая есть?

Re: ТСМ-50 и Simatic S7-300
Михайлин Сергей; 10.12.04

Таблица соответствия Омы - Градусы в ГОСТе. Официальной программы или функционального блока у нас нет, но я знаю что наши партнеры сами ее делают. Киньте клич, может кто-нить и поделится. Проще уж новый модуль использовать.

Re: ТСМ-50 и Simatic S7-300
Eugene Sergeev; 10.12.04

Подключать предполагается к 331-7KB02-0AB0, все остальное неоправданно удорожит проект, бо градусник этот там только один.

Re: ТСМ-50 и Simatic S7-300
Pol; 13.12.04

ГОСТовскую таблицу вводили в Exсel,получали полином 5- степени T(R)- и программировали. Отклонения от табличных были 0,02, так что достаточно и 3 степени.

Re: ТСМ-50 и Simatic S7-300
Гуленок Андрей; 14.12.04

А зачем с ёкселем упражняться? В госте же все полиномы прописаны в приложении. Прям по гостовскому полиному пересчитываешь.

Re: ТСМ-50 и Simatic S7-300
Павел Кобелев; 15.12.04

Для пересчета народ использует функциональный блок.


text

ШИМ в S7-312C
Eugene Sergeev; 10.12.04

S7-312C умеет ШИМ? Как он реализуется программно?

Re: ШИМ в S7-312C
Чистяков Дмитрий ОАО СеверСталь; 10.12.04

Ну, наверное на 312-ом можно сделать ШИМ, только вопрос с какой максимальной частотой. :-)

Re: ШИМ в S7-312C
Eugene Sergeev; 12.12.04

2.5 кГц. Мне не надо хитрую синусоиду формировать, мне надо привод по аналоговому входу разгонять/тормрзить.

Re: ШИМ в S7-312C
Чистяков Дмитрий ОАО СеверСталь; 14.12.04

Ну, на чистом голом CPU S7-312 это не реально, т.к. программа в этом CPU может крутится с циклом не менее 10мс. Отсюда максимальная частота 50 Гц.

Для Вашей задачи необходим модуль FM (350,351)

Re: ШИМ в S7-312C
Eugene Sergeev; 14.12.04

Из документации на S7-312C

· Импульсные выходы 2
· Максимальная выходная частота 2.5 кГц
Насколько я понял, ШИМом там заведует некая SFB49, но скудость документации подвергает в уныние.
Если еще расскажете, как с помощью модуля счета FM351 сделать ШИМ, будет совсем хорошо (с учетом того, что быстрых выходов у него нет)

Re: ШИМ в S7-312C
Андрей Гуленок; 14.12.04

А чем вам двухсотый не угодил? Уж там ШИМ так ШИМ. Или нужно именно 312-ый приспособить?

Re: ШИМ в S7-312C
Pavel; 14.12.04

А зачем вообще нужен ШИМ, когда достаточно аналогового выхода

Re: ШИМ в S7-312C
Eugene Sergeev; 14.12.04

Да задачка есть небольшая, управлять двумя частотниками по аналоговому входу, причем сделать надо как можно дешевле.

У 312С вроде почти все в одном флаконе - дискретные входа, выхода + пресловутый ШИМ, которым планирую формировать управляющее напряжение.
Двухсотый не угодил по той причине, что программить надо на STL-e (не люблю я его, предпочитаю SCL), надо где-то искать новый Микровин ( у меня какой-то 5-летней давности, наверное уже устарел ), программить надо по компорту, которого в моем ноуте нет как класса - все это по совокупности перевешивает разницу в цене 60 евро.
Аналоговые выходы не хочется навешивать по выщеизложенной причине - цена. Ж8-(((

Re: ШИМ в S7-312C
Pavel; 14.12.04

Если тактовая частота ШИМ 2,5Кгц, длительность импульсов регулируемая будет соответствовать частотам как минимум на порядок выше. И вообще зачем такая высокая частота? Если потом ставить простейший RC-фильтр, то может можно обойтись более никой? Тогда можно реализовать на 312.


text

UPS и Симатик
Eugene Sergeev; 10.12.04

Необходимо включить S7-300 через УПС.

Возникнут ли какие-либо проблемы при подключении ширпотребовского упса с развязанным нулем?
Re: UPS и Симатик
Чистяков Дмитрий ОАО СеверСталь; 10.12.04

Ну, тут всё будет зависеть от ваших условий.

А что сейчас нуль симатика не сидит на земле?
Re: UPS и Симатик
Чистяков Дмитрий ОАО СеверСталь; 10.12.04

Ой! убежало :-)

Мы используем APC Symmetra для защиты S7-400. При этом нуль питания контроллеров непривязан к земле.
Тут главное дело следовать одному принципу - как начал делать питание, так и продолжай на всём объекте.
Re: UPS и Симатик
Eugene Sergeev; 10.12.04

Сейчас сидит. Просто как-то включили Симатик через трансформатор 380/220 и такой цирк начался. Все моргало, как елка новогодняя. Вот и интересуюсь...

Re: UPS и Симатик
Pavel; 14.12.04

Кстати включение через трансформатор

является желательным(У немцев обязательным). Может мощность транса была неправильно выбрана? Заземление нейтрали вообще-то является обязательным, только выполнять это нужно соответствующим образом-в одной точке.<


text

piw, pqw
sergei; 10.12.04

можно ли посмотреть в onlin-e сигналы на контроллере piw, pqw?

Re: piw, pqw
Eugene Sergeev; 10.12.04

PIW - можно, PQW - нет.

Re: piw, pqw
ВДВ; 10.12.04

Можно оба в HWKonfig, наводишь указатель мыши на модуль в корзине, правая клавиша мыши на всплывающем меню Monitor/Modify.


text

temp
новичок; 18.11.04

Есть временная переменная, например #TEMP3, как я могу посмотреть где и что ей присваивается, если через Go to Location поиска этой переменной не происходит? Например переменная стоит в FB60, я начинаю искать откуда она берется (открывая все подряд блоки) и нахожу, что она появляется из FB10, ей присваивается другая времееная переменная, которая тоже неизвестно где находится.

Re: temp
VVV; 19.11.04

Все временные переменные на то и временные, потому, что они действуют только внутри блока.Их нельзя использовать из других блоков. Разные названия временных переменных в разных блоках- это разные переменные. Но для блоков типа FB, которые вызываются с блоками DB есть переменные не TEMP а STAT, которые автоматически берутся из DB вначале выполнения FB и записываются обратно в DB вконце FB.

Re: temp
VVV; 19.11.04

Вывод :)) Если Вам нужно найти временную переменную, то ищите ее только в этом блоке. Для этого в Степе 5.1 по CTRL+F, а в 5.2 и 5.3 уже можно искать по GoTo и временные переменные тоже.

Re: temp
новичок; 19.11.04

я все это понимаю, а что делать, если в блоке эта переменная только одна и выступает в роли открытого контакта, при вызове блока она не присутствует и переменная именно TEMP. В online эта переменная меняется- т.е. может быть и "1" и "0". Может ли эта переменная задаваться извне? (контроллер соединен с переферией по profibus и по Ithernet)

Re: temp
VVV; 19.11.04

Скорее всего используется не явное присвоение этой переменной. Например это булева переменная и имеет адрес TEMP 0.3. А где нибуди в программе есть, например такая строка:

А I 0.0
= L 0.3
То есть здесь мы присвоили этой переменной значение со входа 0.0 периферии. То есть обратились к ней не по имени, а по адресу.
Слышал я, что есть способ еще хитрее. Если мы вызываем несколько FC, а в ней еще FC и еще FC, то есть локальный буфер загружен данными из нескольких FC, то возможно писать и читать данные из локальной области других блоков,а не только из своей...

Re: temp
новичок; 19.11.04

да, но как определить тогда адрес TEMP3- это 0.3, 1.3 или 3.0-?

Re: temp
новичок; 19.11.04

нашел я, что Initial adress этой переменной Temp3 1.1, а как найти где и что присваивается этому адресу?

Re: temp
новичок; 22.11.04

нашел я , что при вызове блока FB60 устанавливается как раз через =L 1.1 при появлении метки М0.0 (метка инициализации). Теперь другая проблема-во всех цепях эта метка используется в виде условиий, а установки или задания этой метки в поиске-нет.

Re: temp
VVV; 22.11.04

Ну вот, значит разобрались, что зависит от М 0.0.

Скорее всего (если как то программисты придерживались правил), то это какой либо системный (вспомогательный бит). Обычно М 0.0 - это всгда "0", а М 0.1 - всегда "1".
Либо другой вариант. Это системный меркер импульсов, то есть аппаратно конфигурится, что, например, байт МВ 0 - будет байтом импульсов.
Посмотрите в Hardware Config, в свойствах контроллера, закладка Cycle\Clock Memory, стоит ли галочка Clock Memory и если да, то какой байт.
Re: temp
новичок; 22.11.04

галочка действительно стоит, memory byte: 300

Re: temp
VVV; 23.11.04

Нет, ну МВ 300 - это не то.

Значит к этому байту обращаются косвенно, например, через такой оператор
......
S M[#Adress]
где Adress - адрес этого бита в памяти.
А откуда Вы знаете, что это метка инициализации?
Может, если инициализация, то при старте контроллера инициализируется в ОВ 100?
Re: temp
VVV; 23.11.04

Нет, ну МВ 300 - это не то.

Значит к этому байту обращаются косвенно, например, через такой оператор
......
S M[#Adress]
где Adress - адрес этого бита в памяти.
А откуда Вы знаете, что это метка инициализации?
Может, если инициализация, то при старте контроллера инициализируется в ОВ 100?
Re: temp
VVV; 23.11.04

Нет, ну МВ 300 - это не то.

Значит к этому байту обращаются косвенно, например, через такой оператор
......
S M[#Adress]
где Adress - адрес этого бита в памяти.
А откуда Вы знаете, что это метка инициализации?
Может, если инициализация, то при старте контроллера инициализируется в ОВ 100?
Re: temp
Darwin; 23.11.04

Попробуйте поискать " М0.0" через "Go to Location" и установив в окне "Go to Location" чек бокс "Overlapping access to memory areas". Т.е. при установке этого чек бокса будут найдено также использование " М0.0" в составе байтов, слов, двойных слов. Если " М0.0" устанавливается косвенно то ничего не поможет т.к. как найдешь М 310.0 если используют

L P#M 300.0
A [AR1,P#10.0]

Re: temp
новичок; 24.11.04

Всем большое спасибо. В ОВ100 вызывается FC10, в котором 0-му байту передаются значения блока данных. Через Go to location и overlapping access to memory areas также этот байт легко находится. Последний вопрос- если бы адрессация метки была косвенная (S M#adress)- адрес этого бита в памяти был бы отражен в таблице определения временных переменных?

Re: temp
VVV; 24.11.04

Нет. Переменная #Adress это просто переменная. Локаляная, из блока данных или из меркерной области. Ей где то должен присваиваться адрес, например так:

L P#25.3
T #Adress
set
= M[#Adress] //Установить бит памяти 25.3
Где Adress локальная переменная типа DWORD.
Или так:
L 203 //Это тоже 25.3
T MD100 //Пишем адрес сюда

A I 124.7
= M[MD100] // M 25.3 = I 124.7
Re: temp
Новичок 2; 7.12.04

А все-таки как новичок нашел что при вызове блока FB60 переменная

устанавливается через =L 1.1 при появлении метки М0.0
Re: temp
новичок; 8.12.04

в самом FB60 установки адреса 1.1 я не нашел, через go to location нашел откуда вызывается FB60- это оказались FC1, FC2, FC3. Перед вызывом блока FB60 в FC1 (например)есть такая строка:

A M102.0
= L1.1
Re: temp
Новичок 2; 8.12.04

А если адрес 1.1 имеет несколько присвоений? Как тогда?

Re: temp
Павел Кобелев; 9.12.04

В редакторе LAD/FBD/STL по меню Options->Reference data->Display открывается окно, в котором можно посмотреть много чего полезного, в том числе и где что чему присваивается. Адреса без имен там тоже можно посмотреть.

Re: temp
новичок; 9.12.04

что-то я не нашел в Options->Reference data->Display адреса без имен, не подскажешь где посмотреть? (не могу найти там адрес 1.1)

Re: temp
Павел Кобелев; 10.12.04

В окне, которое открывается по Options->Reference data->Display

в меню View есть пункт "Addresses without Symbol"<


text

ET200S и генерация драйверов
Алексей; 7.12.04

В проекте используется CPU 416-3 мастер DP и slave ET200S 6ES7 151-1AA03-0ABO. В HW Config конфигурим, в CFC, по аналогии с S7-400, на каждый вход ET200S кидаем стандартный CH_DI, на выход - CH_DO для автоматической генерации драйверов. Запускаем компиляцию и накидываются автоматически только OB_DIAG (FB124) для каждого RACK ET200S. Маловато,что-то. Хотелось бы как для ET200M и чтоб блок для модуля (DI и DO) сгенерился и на вход CH_DI.MODE связь завелась. А то есть функция генерации драйверов, но какбы выборочная. Возможно ли настроить генерацию или оно так и задумано?? PCS7 V6.0_SP1+HF1

Re: ET200S и генерация драйверов
Михайлин Сергей; 8.12.04

А что содержит лог файл Driver Wizard?

Просто информацию о сделанных действиях или есть ошибки? Если есть то какие?
Re: ET200S и генерация драйверов
Алексей; 9.12.04

W: No hardware found for symbol DI101_0 with address I28.0.

И так по всем входам-выходам. Причем HW Config ошибок на конфигурацию не выдает и его функция Edit Symvols отрабатывает корректно, т.е., как я понимаю, четко привязывает модуль к адресам. Используется GSD файл SI02806A, скачаный с германского сайта, в стандартной поставке PCS7 упомянутого IM нет.
Re: ET200S и генерация драйверов
Михайлин Сергей; 9.12.04

Сорри, сразу не заметил заказной номер IM. Данный IM не поддерживается Driver Wizard, о чем он и пишет в лог файле кстати(я проверил). Поддерживается пока только 6ES7 151-1BA00-0ABO.

Всегда говорил и говорю всем: читайте список разрешенных модулей для PCS7. (по ссылке)
См. Список модулей

Re: ET200S и генерация драйверов
Алексей; 9.12.04

Грустно это. Модуль есть, а не поддерживается... Причем нам его навязали спецы Сименса, мы как раз хотели 151-1BA00-0ABO, но нам сказали - типа старый очень, не производится, берите новый крутой..... Да ладно, в связи с чем 2 вопроса:

1. Надеюсь c адресами работают нормально?? Т.е. мне на вход модуля DI придет сигнал то в бите привязаном в HW Cjnfig получим 1??
2. А в конфигурационном файле Driver Wizard можно что-либо поправить, чтоб брал наш IM? Или качнуть апгрейд из инета с сайта производителя, родного??
Re: ET200S и генерация драйверов
Михайлин Сергей; 9.12.04

А можете сказать в личку, кто присоветовал: ФИО и тд? Потому как 1ВА00 вовсе не старый. И еще вопрос кто спецуху составлял и сразу ли закладывался PCS7?

Ответы.
1 Работать будет. Только Вам уже не нужен тогда СH_DI можете напрямую заводить сигнал скажем на DIG_MON или куда нужно.
2. Поправить врядли получится и апдейта нет. Можно попробовать обмануть подставив в HWConfig то что нужно, вместо того что есть. Может и съест... Но гарантий нет.
Re: ET200S и генерация драйверов
Алексей; 9.12.04

ФИО и тд. легко! Но дело в том, что фирма работает с нами давно, и никаких подстав в принципе не было, да и думаю это они сделали не со зла. Тем более скидки они нам как хорошим клиентам дают нормальные и поддержка не плохая (железо в смысле). PCS7 наш "личный", для этого проекта спецом не заказывался, тока WinCC.

Не понятно: а причем здесь спецуха и PCS7, что если заказать что-то другое, то там драйвера сгенеряться?? Интересно, что же это?? А еще, сроки апдейта на PCS7 с поддержкой на наши IM известны?? Должны же они выпускать программную поддержку на свое железо??? Самое обидное, что когда библиотека драйверов была платная, она БЫЛА ЧЕСТНО КУПЛЕНА!!!
Подстава не пройдет, проект передается открытым для изменения заказчику, и могут возникнуть нехорошие вопросы.
Re: ET200S и генерация драйверов
Алексей; 9.12.04

Сергей! Самое интересное, что по словам наших поставщиков замена прошла по инициативе Московского Siemensа! Поставщики честно транслировали наш заказ в Москву, и именно из Москвы пришло предложение о замене, с мотивировкой, что хоть и новый, но практически такой же, а тот снят с производства..... Но предлагаю поиск виноватых на этом закончить. Время в принципе ушло. Прект сдавать, а диагностику придется наверно самим ручками писать......

Re: ET200S и генерация драйверов
Михайлин Сергей; 9.12.04

Да не в подставе дело. Просто если PCS7 ваш и Вы им это не сказали или они не услышали, то они создавали спецуху не оглядываясь на требования PCS7 и соответственно пролетели с IM. А список для того и создан что бы пользователи знали какое железо поддерживается Driver блоками в данной версии и не ошибались с заказом.

Апдейт ждем в конце января вместе с версией PCS7 6.1<


text

Модули расширения к S7-200 CPU-214
Микуров Александр; 9.12.04

Научите!Можно ли использовать модули расширения ЕМ-22x совместно с CPU-214.

Re: Модули расширения к S7-200 CPU-214
Гуленок Андрей; 9.12.04

Нет


text

MM 400 работа по PPO3 через PB DP
Юра; 8.12.04

кто нибудь!!!

помогите!!!
1.какие параметры надо установить на частотнике что бы запустить и остановить частотник по профибас?
2.какая последовательность установки битов в слове управления1?
3.где задается коэфициент пропорциональности между уставкой, которую я посылаю по профибус и частотой вращения привода?
Re: MM 400 работа по PPO3 через PB DP
Astronom; 8.12.04

описание слабо почитать

Re: MM 400 работа по PPO3 через PB DP
Юра; 8.12.04

не получается как написано...

Re: MM 400 работа по PPO3 через PB DP
Михайлин Сергей; 9.12.04

Послал по почте демо пример работы ММ4 и Simatic S7. Настройки в ММ4 описаны в доке. Последовательность битов и коэффициент в примере. Есло пишите напрямую.


text

загрузка MC
dm; 9.12.04

попробовал загрузить программу S7-300 с программатора Field PG на memory card (64 кБ), возникли 2 вопроса:

1. В memory card загружаются только блоки, а конфигурацию не могу загрузить? А что, если мне необходимо будет изменить конфигурацию?
2. после загрузки блоков на карту и попытки открыть ОВ1- появляется ошибка: "compiler information: type conflict" и блок не открывается, хотя в программе на программаторе этот блок открывается без ошибок. Почему это возникает?
Спасибо
<


text

Как Обнулять Блок данных разного размера
Михаил; 1.12.04

Есть такая вот задачка, у меня имеется блок данных DB1, в котором забиты биты ошибок, система только запускаеться и необходимо периодически добавлять и удалять количество битов, тоесть размер блока данных DB1 будет меняться, мне необходимо периодически обнулять данные биты ошибок.

я обнуляю с помощью BLKMOV, там надо задать нач. адрес, кол-во байт которорые нужно занести в блок DB, каждый раз при изменении размера DB1, приходиться менять и значение в параметрах ф-ии BLKMOV, Как сделать так чтобы автоматически подставлялся размер обнуляемого DB, (если можно примерчик пожалуйста).
Re: Как Обнулять Блок данных разного размера
В. Хрижановский, BTC; 1.12.04

Во-первых, можно просто зарезервировать нужное число битов. DB тогда будет иметь постоянную длину. А теперь по существу.

OPN DB1
L DBLG
В ACCU1 в результате имеем длину блока. А далее - ее в пойнтер для BLKMOV. В явном виде уже не получится, нужно самому сформировать этот пойнтер. Если длина большая, может потребоваться не один вызов BLKMOV.
См. http://www.btc-automation.lv/

Re: Как Обнулять Блок данных разного размера
Михаил; 2.12.04

У меня как раз проблемы каким образом запихать эту длину DB в BLKMOV, тоесть как сформировать этот поинтер?

Re: Как Обнулять Блок данных разного размера
В. Хрижановский, BTC; 2.12.04

Вот пример:

VAR_TEMP
pDB1 : ANY ;
DBLen : INT;
SaveAR1: DWORD;
NETWORK
TITLE =
//Preparing of pointer.
OPN DB1;
L DBLG;
T DBLen;
TAR1;
T SaveAR1;
LAR1 P##pDB1;
L B#16#10; // Syntax ID
T LB [AR1,P#0.0];
L B#16#2; // Data type: byte
T LB [AR1,P#1.0];
L DBLen; // Repetition factor
T LW [AR1,P#2.0];
L 1; // DB1 as destination
T LW [AR1,P#4.0];
L P#0.0; // From start of DB1
T LD [AR1,P#6.0];
L B#16#84; // Memory area: DB
T LB [AR1,P#6.0];
Ну а далее надо указать pSource как аргумент для BLKMOV. Как и где вы будете вызывать этот кусок, я не знаю. А тут есть нюансы. Поэтому рекомендую сохранять AR1 в SaveAR1. После выполнения BLKMOV восстановите командами L SaveAR1; LAR1.
Re: Как Обнулять Блок данных разного размера
Михаил; 3.12.04

В. Хрижановский, спасибо друг я понял. Я просто почти не работал ранее с указателями, поэтому для меня эта задачка стала проблемой. Буду пробовать.

Re: Как Обнулять Блок данных разного размера
Валентин; 6.12.04

Если DB не находится на флэш-карте и не UNLINKED , его можно удалить с помощью SFC23, а следующей строкой программы восстановить блок с помощью SFC22, но уже с нулевыми значениями в битах DB. В данном случае длина DB не имеет никакого значения.


text

Время реакции системы
Дроздов Денис; 1.12.04

Ситуация такова - система визуализации сделана на WinCC, отлажена и работает. Сервера подключены через СР 1613 к Simatic S5 с установленной CP 1430 TCP.

Проблема в следующем - после подачи сигнала управления со станции визуализации и появлением этого сигнала в ячейке контроллера проходит уж очень много времени - примерно от 5 до 10 секунд. Есть ли способы повысить скрость реакции контроллера?
Re: Время реакции системы
Чистяков Дмитрий ОАО СеверСталь; 3.12.04

Проверьте цикл обновления объекта ввода вашего тэга. Желательно выставить 250 мс.

А покакому протоколу работаете?
ISO или TCP IP?
Re: Время реакции системы
Дроздов Денис; 6.12.04

Работаем по TCP\IP. Но решение проблемы кажется найдено - при открытии картинки считать значения управляющих тегов или разместить на картинке невидимые элементы связанные с этими тегами и опять же их прочитать.


text

Кабель TTY
IgorTs; 5.12.04

Почему кабель TTY/S232 для соединения S5 с PC,с S5 115U работает,а с S5 100U нет. Может дело в распайке разъемов?

<


text

S7-200 CPU 224 помехи по быстрым счетчикам
Aleksandr; 27.11.04

При использовании контроллера для управления технологическим процессом совместно с преобразоваителями частоты для управления асинхронными двигателями возникает проблемма для подключения угловых датчиков перемещения типа ЛИР 158. Счет координат происходит со сбоями. Каким образом решить эту проблемму.

Re: S7-200 CPU 224 помехи по быстрым счетчикам
GorA; 27.11.04

А как подключен датчик?

Re: S7-200 CPU 224 помехи по быстрым счетчикам
Pavel; 29.11.04

Выкинуть ЛИР.

Та еще штука. Для этого датчика нужно
хорошая экранировка и согласование входных сопротивлений датчика и платы.
Re: S7-200 CPU 224 помехи по быстрым счетчикам
Alex; 30.11.04

По ЛИРам: ставим их везде вместо импорта - работают сразу без всяких согласований.

Счетные входы контроллера имеют частоту среза, наблюдал в некоторых устройствах ее на уровне 30-50КГц, хотя в доках дана частота оцифровки несколько МГц (охота вспомнить Котельникова с его 2f). Промерьте осцилоскопом частоту с датчика на предельных оборотах. Ну и подробнее о подключении и считывании, возможно там собака порылась.
Re: S7-200 CPU 224 помехи по быстрым счетчикам
SET; 4.12.04

Проблемма устойчивого счёта решилась при заземлении нулевой точки питания контроллера и экранов трасс от датчиков.


text

К специалистам Сименс. Новое поколение LOGO, вопрос
Гвоздев Игорь; 3.12.04

Доброе утро господа!

Нашим предприятием давно и с успехом у используются модули LOGO!, однако в последнее время наметились задачи для решения которых не хватает входов/выходов, в том числе и аналоговых выходов. Ожидается ли выход нового LOGO! (OBA5) с расширенными функциональными возможностями и соответственно нового ПО.

Ожидаю ответа!

Re: К специалистам Сименс. Новое поколение LOGO, вопрос
Sergey; 3.12.04

Из рекламы ПРОСОФТ, к нам ее много приходит:

1) Модули LOGO!
Появились новые 16-канальные (8DI/8DO) модули расширения, при этом несколько подорожали 8-канальные. Цены на остальные модули не изменились. Хочу обратить особое внимание на то, что "красный"(6ED1056-4BA00-0AA0) и "желтый"(6ED1056-1BA00-0AA0) модули памяти НЕСОВМЕСТИМЫ с логическими модулями -0BA4.

2) Блоки питания
В серии LOGO!power появился новый источник питания 24 В/4 А (6EP1332-1SH51). Среди SITOP существенных изменений не произошло.

3) ПЛК S7-200
Появились новые модификации контроллеров CPU 224 (более мощные и имеющие аналоговые входы), новые панели оператора: TD200C с конфигурирумой клавиатурой и пользовательским дизайном передней панели, OP 73 micro с графическим дисплеем, сенсорные графические панели TP 170 Micro и TP 177 Micro. Цены не изменились.
<


text

FM 350
S_e_r_g; 22.11.04

Подскажите где взять принципиальную схему FM 350 или FM 355?????

Очень нужна для курсовика, хочу описать принцип работы счетчика или регулятора.

Re: FM 350
Чистяков Дмитрий ОАО СеверСталь; 23.11.04

Ни где.

Разве что сам возьмёшь тестер, лист бумаги, карандаш и сам нарисуешь её.
Siemens, как и большинство других производителей, не распространяет схем своих устройств. :-)
Re: FM 350
S_e_r_g; 23.11.04

Всё ясно. А жаль...

Re: FM 350
Чистяков Дмитрий ОАО СеверСталь; 23.11.04

Ну, если бы схему 350-ого вы и нашли бы, и даже разобрались в ней, то в 355-ом стоит свой процессор и своя программа, т.е. всё это слишком сложно для курсовика.

Совет - возьмите схему от старого советского модуля. Там всё будет проще, т.е. на микросхемах малой интеграции.
Re: FM 350
S_e_r_g; 24.11.04

Дмитрий, подскажите пожалуйста какой нибудь аналог модуля FM??? Для которого не сложно найти схему???

Re: FM 350
Sergey; 3.12.04

В документации есть функциональные и схемы подключений. Для курсового, думаю, хватит и таких. Будет серъезно


text

ZEN, LOGO, ALFA20 что лучше??
Chainic; 6.10.04

Посоветуйте кто работал с разными этими сабжами, что лучше? Учитывая цену, наличие модулей расширения, возможность связи, удобство программной оболочки. В настоящее время надо решить небольшую задачу. Т.е. требуется наличие в контроллере 16 таймеров задержки включения, счетчики.Заранее благодарен

Re: ZEN, LOGO, ALFA20 что лучше??
На сайте Siemens лучший только ЛОГО ))); 6.10.04

а сколько вх/вых в системе?

Re: ZEN, LOGO, ALFA20 что лучше??
Chainic; 7.10.04

20входов, 20 выходов, 16 таймеров задержки нужно использовать в программе.

Re: ZEN, LOGO, ALFA20 что лучше??
Вячеслав Прунцев, "Электростиль"; 7.10.04

ЛОГО - это Siemens

Техническое описание на www.aud.ru
купить можно:
http://shop.elektrostyle.ru/m310se/ispsearch?nmainid=33128&nsectid=24253
АЛЬФА20 - это Mitsubishi Electric
Техническое описание на http://www.elektrostyle.ru/Rus/pdf/Mitsubishi.htm или http://www.elektrostyle.ru/Rus/Katalog/AvtElPrivod/Kontrolleri/Kontrolleri.htm
Купить можно:
http://shop.elektrostyle.ru/m310se/ispsearch?nmainid=33128&nsectid=12269
Сравнивайте характеристики и цены и выбирайте.
См. Электростиль

Re: ZEN, LOGO, ALFA20 что лучше??
Сапельников Артем (Матис-М); 10.10.04

LOGO удобен в программировании, кроме того новый софт позволяет проводит on-line тест, что существенно упрощает процесс наладки оборудования. Кроме всего прочего очень удачно написан софт для программирования.

Купить можно у нас ООО "Матис-М",тел. (095) 725-23-04
Re: ZEN, LOGO, ALFA20 что лучше??
Chainic; 11.10.04

Я получил дистрибутив LogoSoftComfort v4. При установке ничего не спрашивал. Работает без вопросов. Т.е. вопрос в следующем- это не триал версия или LogoSoftComfort не требует регистрации??

Re: ZEN, LOGO, ALFA20 что лучше??
Сергей.; 12.10.04

У Лого OB4 появились модули связи, то есть можно построить распределенную систему управления, плюс поднять данные на верхний уровень. Насколько я знаю, у остальных производителей это только еще заявлено.

Re: ZEN, LOGO, ALFA20 что лучше??
Сапельников Артем (Матис-М); 12.10.04

Регистрации не требуется. Вот такой хороший Сименс.:)

Re: ZEN, LOGO, ALFA20 что лучше??
Chainic; 13.10.04

ToСергей, что именно по верхнему уровню? Есть модуль ASi, это я знаю. Это про него речь? Или что-то другое есть?

Re: ZEN, LOGO, ALFA20 что лучше??
Сергей; 13.10.04

То Chainic. Смотрите Руководство для CM LON, Руководство для CM EIB/KNX. На этом сайте. Данные протоколы обладают OPC серверами.

См. http://www.automation-drives.ru/as/products/doc.php?l1=%CC%E8%EA%F0%EE%F1%E8%F1%F2%E5%EC%FB%20LOGO!%20%E8%20S7-200&l2=LOGO!&l3=doc

Re: ZEN, LOGO, ALFA20 что лучше??
Дмитрий; 30.11.04

Chainic имей в виду что максимальная конфигурация логического устройства LOGO! – это 24 дискретных входа + 8 аналоговых входов, + 16 дискретных выхода. С написанием программы я думаю проблем не возникнет можно использовать аж 130 функциональных блока, этого вполне должно хватить! А ещё в скором времени обещали сделать аналоговые выходы, и можно будет мутить ПИ – регулятор!

Re: ZEN, LOGO, ALFA20 что лучше??
Chainic; 1.12.04

Кстати насчет этой конфигурации. Это вопрос к специалистам Сименса я думаю.

Основной модуль 8DI/4DO
Модуль расширения 4DI/4DO
Получается если основной модуль+4 модуля расширения, то 24DI/16DO- где 4DO? получаются они просто теряются.Так? Может тогда имеет смысл делать основной модуль+3 модуля расширения=20DI/16DO, чтобы не терять понапрасну выхода.
Re: ZEN, LOGO, ALFA20 что лучше??
Vladimir; 2.12.04

А как на счет EASY от Moeller

Re: ZEN, LOGO, ALFA20 что лучше??
FFF; 2.12.04

Очень не плох ALFA AL2-24 , 15 входов , 9 выходов , 200 функциональных блоков , встроенный симулятор и цена ниже LOGO.

Re: ZEN, LOGO, ALFA20 что лучше??
Alfa; 2.12.04

Alfa всем хорош, есть даже визуализация. Почти миниSCADA. Одно только НО. Большие программы на нем отлаживать очень тяжело, а еще тяжелее потом в них разобраться. По этому я все делаю именно на LOGO.


text

К специалистам Сименса. По LOGO вопрос
Chainic; 1.12.04

Насчет максимального расширения LOGO. При этом происходит потеря 4х выходов?

Основной модуль 8DI/4DO
Модуль расширения 4DI/4DO
Получается если основной модуль+4 модуля расширения, то 24DI/16DO- где 4DO? получаются они просто теряются.Так? Может тогда имеет смысл делать основной модуль+3 модуля расширения=20DI/16DO, чтобы не терять понапрасну выхода.<


text

Intouch и S7-300
Николай; 30.11.04

Существует ли возможность связи Intouch 7.1 или 8.0 и контроллеров Simatic S7-300 по Ethernet без использования OPC сервера?

Re: Intouch и S7-300
Штыка Игорь; 30.11.04

Такая возможность есть. Для этого надо использовать набор драйверов ввода/вывода, которые находятся на диска (IOServer), если вы приобретали лицензионный пакет

Re: Intouch и S7-300
Николай; 30.11.04

2 Штыка Игорь; 30.11.04

Спасибо.
Re: Intouch и S7-300
Чистяков Дмитрий ОАО СеверСталь; 30.11.04

ВОзможность то есть, только вот работоспособность сей связи (драйвера от InTouch) не всегда работает надёжно.


text

срочно нужен PG605U или что-то подобное
Klaive; 24.11.04

срочно нужен PG605U или что-то из PG U серии. форма оплаты любая.

P.S. Можно и как-нибудь в аренду. ХЕ...
Re: срочно нужен PG605U или что-то подобное
Alex; 25.11.04

А где находитесь?

Re: срочно нужен PG605U или что-то подобное
klaive; 30.11.04

Москва


text

Питание контроллера S7-224 от трехфазной сети 220VAC
ShitDown; 30.11.04

Есть S7-224, у него питание 85-265VAC 43-65Hz. Есть установка с подведенными 220VAC 50Hz без нулевой точки (развязывающий трансформатор, обмотки на выходе включены в треугольник). Как я могу запитать контроллер? Если возьму 220В двумя фазами будет это правильно?

Как насчет нулевой точки, если я правильно понимаю ее нет в этом случае?

Re: Питание контроллера S7-224 от трехфазной сети 220VAC
Pavel; 30.11.04

Лучше вснго поставь еще один развязывающий транс, не так уж это и дорого


text

Панель C7-633
Сергей; 12.10.04

Господа подскажите плиз как перевести панель C7-633 в режим "Готовность для переноса" проекта?

Re: Панель C7-633
Oleg Ableev; 29.11.04

Сначала в Protool запрограммируй клавишу (желательно с паролем) для включения режима - готовность к загрузке, а потом сколько раз надо столько загружай. Функция называется serial download. Описание можно найти в руководстве по OP-7.


text

Подавление дребезга
S_e_r_g; 23.11.04

Подскажите алгоритм подавления дребезга, который можно было бы реализовать на языке SCL????

Re: Подавление дребезга
Чистяков Дмитрий ОАО СеверСталь; 23.11.04

Таймер :-)))

Re: Подавление дребезга
Сергей Н.; 23.11.04

Для подавления дребезга контактов программно применяют некий алгоритм(подсчет заданного числа совпадающих значений сигнала или временную задержку).Допустим я знаю как это реализовать на SCL.Есть контроллер S7-300. Куда заливать программу? В контроллер или модуль FM 350(ведь он используется как счетчик)???

Извините за глупый вопрос...

Re: Подавление дребезга
Darwin; 24.11.04

Да, на самом деле, если высокоскоростной счетчик используется то как это реализуется- защита от дребезга? Таймером? Таймер обновляется асинхронно от цикла контроллера, поэтому если использовать например таймер задержки включения 3 (если это устраивает по частоте сигнала) миллисекунды то все ОК. Правильно?

Re: Подавление дребезга
Валентин; 24.11.04

Из вопроса неясно, что за устройсво у вас. Может проще вместо механического контакта поставить электронный?

Re: Подавление дребезга
Vit; 24.11.04

А в контроллере вроде как временной интервал таймеров минимум 5 мs. И потом цикл контроллера гораздо больше. Есть вероятность потерять импульсы...

В самом счетчике, при его конфигурации должна быть аппаратная защита от дребезга.
Re: Подавление дребезга
Чистяков Дмитрий ОАО СеверСталь; 24.11.04

Блин! Ну и вопросы вы господа задаёте. :-)

Всё перемешали. Когда спрашиваете, что-то, то укажите что как и к чему, а то тыкаете пальцем в небо. :-)
1. Если Вы устраняете дребезг на контактах, подключенных к дискретным входам, то здесь подойдёт простой таймер.
2. FM350 имеет два режима фильтра, которые борются с помехами. Что же касается дребезга, то FMка считает все импульсы с частотой до 20кГц или 200 кГц (в зависимости от установки фильтра). СОбственно говоря, это и есть задача модуля FM - считать импульсы с высокой частотой. И как ему (модулю) разобраться, какой импульс правильный, а какой не правильный?
Если Вы собираетесь считать этим модулем медленные сигналы, с дребезгом, то придётся бороться с оным на стороне источника сигнала.
В частности, как здесь уже советовали, поставить нормальный датчик (хоть оптический, хоть электромагнитный, хоть лазерный.
Re: Подавление дребезга
GorA; 26.11.04

Повесте на входе емкость.


text

PROFIBUS-DP
Егор ; 26.11.04

Подскажите, как организовать Profibus соединение между ЕМ 277 и СР 342-5.

Re: PROFIBUS-DP
Чистяков Дмитрий ОАО СеверСталь; 26.11.04

1. В параметрах CP342-5 установите режим работы DP-Master.

2. Затем привязываете из базы (мышкой) модуль EM277 на этот DP-Master.
3. Устанавливаете в EM277 модуль, на требуемое вам количесвто данных
4. В программе обращаетесь к входам-выходам модуля.
Вот и всё.<


text

Комп+CPU224+TD200 ?
Владимир; 25.11.04

Привет Всем! Подскажите пожалуста, может кто сталкивался с проблемой подключения компа (mikro-WIN), CPU224 и панели TD200 на один порт для отладки программы? Буду очень благодарен за Ваши советы.

Re: Комп+CPU224+TD200 ?
Назаров Дмитрий; 25.11.04

Владимир. Сделай тройник из обычных компьютерных 9-пиновых D разъемов. Обойдется рублей в 50 :-)

Re: Комп+CPU224+TD200 ?
Владимир; 25.11.04

Спасибо Дмитрий. Я так и сделал, прописал адреса для данных трех устройств, но..

При проверке данной импровизованной сети Micro-WIN находит 5-10 устройств, с каждый раз разными адресами...? Хотя попарно - все прекрасно.
Re: Комп+CPU224+TD200 ?
Владимир; 25.11.04

Спасибо Дмитрий. Я так и сделал, прописал адреса для данных трех устройств, но..

При проверке данной импровизованной сети Micro-WIN находит 5-10 устройств, с каждый раз разными адресами...? Хотя попарно - все прекрасно.<


text

Тех.обслуживание.
Sasha; 25.11.04

Кто подскажет где можно найти информация по регламенту ТО контроллеров Siamens S7-400,S7-300,ET.........

<


text

срочно нужен PG605U или что-то подобное
Klaive; 24.11.04

срочно нужен PG605U или что-то из PG U серии. форма оплаты любая.

P.S. Можно и как-нибудь в аренду. ХЕ...<


text

Подавление дребезга
S_e_r_g; 23.11.04

Подскажите алгоритм подавления дребезга, который можно было бы реализовать на языке SCL????


text

S7-200 и ProTool
Василий; 28.9.04

ProTool связан через PPI кабель c ПЛК. Но связь не находит, в чем может быть проблема? MicroWin нормально работает!

P.S. У меня WinXP стоит, может из-за этого?
Re: S7-200 и ProTool
Антон; 7.10.04

Скорости должны быть установленны одинаковые и там, и там: в ProToole - в свойствах контроллера, в МикроВине - в системном блоке.

В свойствах контроллера в ProTool должен быть установлен протокол PPI;
Меню File/Download/Preferences должен стоять правильный протокол.

Может из-за этого? Насчет ХР не знаю, у нас на 2000 стоит.
Re: S7-200 и ProTool
В. Сорокин; 8.10.04

С ХР у меня тоже не вышло. Вышло только с 2000-м, но только с "нерусским". С русским не получилось.

Но самое главное - на связь уходит уйма времени. Нажмёшь кнопку и ждёшь, когда опросится. Самое противное - это динамическая графика. Смотреть тошно, как что-нибудь по экрану прыгает да ещё в разнобой.
Для Протула лучше в комп поставить СР какую-нибудь.
Re: S7-200 и ProTool
Marat; 12.10.04

На счет медленной связи: тоже мучился, пока не догадался включить Advanced PPI.

Кстати на русском Windows 2000 SP4 все без проблем работает.
Re: S7-200 и ProTool
Уткин Дмитрий; 16.11.04

А где надо включить Advanced PPI.

Re: S7-200 и ProTool
Уткин Дмитрий; 18.11.04

Немного статистики.

PT6.0+SP2 заводится на W98 (с реаниматора) на машине Cyryx-150, 32Ram
И на нормальной машине W2000+SP4
И не заводится на С600 - 64RAm, W2000+sp4. Хотя все COM порты работают c MicroWin 3.1 и 4.0 . Сейчас всандалили в неё мултикарту попробуем.
PT-6.0+SP2 действительно тупит пока не поставиш режим Advanced PPI в настройках драйвера S7ONLINE (см. PC/PG interface)

Обнаружен такой феномен.

PT 5.2+SP3 работает на всем кроме C-600-64Ram (вероятно проблема с мамкой). И не тупит.
Выводы делайте сами.

Re: S7-200 и ProTool
Уткин Дмитрий; 22.11.04

Выяснили мултикарта не спасет.


text

связка PC+ProTool RT & S7-200 по PPI
Уткин Дмитрий; 12.11.04

Подскажите можно ли по кабелю PPI связать ProTool RT S7-200.

Попробовали что-то не сростается
Re: связка PC+ProTool RT & S7-200 по PPI
В. Сорокин; 19.11.04

Можно, но сложно. Посмотрите "S7-200 и ProTool".

Re: связка PC+ProTool RT & S7-200 по PPI
Уткин Дмитрий; 22.11.04


text

FM353/FM354
Alex; 17.11.04

Очень нужна русская документация по программированию модулей FM353 и FM354,

подскажите где можно найти...
Re: FM353/FM354
В. Сорокин; 19.11.04

Не существует. Да там и на аглицком всё понятно, если с УЧПУ знаком.


text

Выбор платформы для станка
Дмитрий; 16.11.04

Суть такая.

Есть станок (пильный центр)
Исполнительные механизмы все работают, а вот мозги на рассыпухе были собраны.
Короче там два процессора оба перестали клокать и шина в неизменном состоянии. В общем не ремонтопригодно.
Есть S7-214. Подскажите на чем лучше сделать для него HMI. Связка ProTool RT+S7-214 не пойдет, т.к. очень тормознутая.
Re: Выбор платформы для станка
Павел Кобелев; 17.11.04

Для ваших целей, ИМХО, подойдет TD200. Стандартное решение для большинства задач.

Re: Выбор платформы для станка
Уткин Дмитрий; 17.11.04

А во сколько обойдется энто удовольствие, хотя бы примерно.

А то с сименсом пока не могу поговорить.
Re: Выбор платформы для станка
Чистяков Дмитрий ОАО СеверСталь; 17.11.04

Цена 187 евро на границе в Германии. Т.е. плюс налоги и растаможка - умножте на 1,3.

Re: Выбор платформы для станка
Alex; 17.11.04

Все зависит от того, какие у Вас привода и измерительные системы. Если концевики, то подойдет контроллер с панелью. СКБ ИС (www.skbis.ru)дешево предлагает цифровые измерители пути с закозной логикой. Можно простенькое ЧПУ SIEMENS, это лучше переслать свою проблему в их бюро ЧПУ и привода, там очень умные ребята - подскажут решение. Н.Новгород (www.modmash.nnov.ru) выпускает ЧПУ FMS3000 со свободно программируемой логикой. Посмотрите еще www.cncinfo.ru. Если Ваше решение уложится в 5000$ - будет хорошо, мне так кажется. Ну и вообще, где Вы находитесь?

Re: Выбор платформы для станка
Уткин Дмитрий; 17.11.04

Находимся мы в Челябинске.

А на счет ЧПУ это их пушки по воробьям.
У нас всего одна ось. Управляется комплектом сервопривод+двигатель Yaskava. Есть режим задания импульсов двумя фазами. S7-214 это делает. Остается только управление. И хранение программ пользователя. Если использовать ProTool то придется ставить W2000, а это завышенные требования по аппаратной части к персоналке. Вот и встает вопрос что использовать????
Re: Выбор платформы для станка
Павел Кобелев; 18.11.04

Использовать ProTool не придется. TD200 конфигурируется с помощью того же Micro Win, что и S7-214.

Re: Выбор платформы для станка
Уткин Дмитрий; 18.11.04

Посмотрел описание TD200 похоже лучьше ставить TP070. только вопрос как хранить программы пользователя.

всего около десятка, в каждой по 30 строк, одна строка 3 байта.
Re: Выбор платформы для станка
В. Сорокин; 19.11.04

С TP070 не связывайтесь. Продукт не удачный и уходящий. Для ваших задач наиболее пригодна ОР7 (ну, ОР17 более приятна, но подороже). Протул не исключайте, он и под 95-м работает. Только нужно-ли?


text

Куплю БП для Simatic S5 S115U
Илья; 12.11.04

Куплю один блок питания для Simatic S5 серии 115U заказной номер 6ES5951-7LD21. Желательно не б/у, а новый или из ЗИПа (с наличием упаковки, коробки).

Re: Куплю БП для Simatic S5 S115U
Iван; 13.11.04

В каком городе-то???

Re: Куплю БП для Simatic S5 S115U
Илья; 15.11.04

В Екатеринбурге.

Если есть то, что нас интересует, то оставте свои координаты или связывайтесь с нами по адресу potrepalov@asc-ural.ru.
Re: Куплю БП для Simatic S5 S115U
Максим; 15.11.04

Есть такие в наличии в Москве. Новые в упаковке(упаковка завода не нарушена). 6ES5 951-7LD12. Цена 500 ЕВРО.Это 7А-ки.

Re: Куплю БП для Simatic S5 S115U
DDD; 18.11.04

Есть БУ отдам за 200$


text

Проблема с CP317-2dp
Olbear; 18.11.04

Люди! Кто сталкивался со следующей проблемой? Процессор CP317-2DP во время работы заморгал всеми своими светодиодами, перестал работать и ожил только после выключения питания. В диагностическом буфере прописал EVENT ID 16#4550. Если кто знает, что делать, и чем это вызвано - подскажите.


text

Outdoor & SIPLUS
В. Петров; 15.11.04

Где можно найти подровную документацию на модули S7-300 с расширенным диапазоном температур и новыми кодовыми номерами 6AG....?

Re: Outdoor & SIPLUS
Павел Кобелев; 17.11.04

А что вас интересует? Отдельной документации на SIPLUS нет. Функционально они полностью эквивалентны аналогичным не SIPLUS версиям.

Re: Outdoor & SIPLUS
В. Петров; 17.11.04

Прискорбно, что нет отдельной доки на целую серию модулей. Где можно посмотреть хотя бы табличку соответствия обычных модулей и SIPLUS с новыми кодовыми номерами 6AG....

Re: Outdoor & SIPLUS
Павел Кобелев; 18.11.04

Соответствие можно посмотреть в A&D MALL (см. ссылку). Там явно указывается на базе какого модуля построена Siplus версия.

Например для 6AG1312-5BD01-2AB0:
МОДУЛЬ SIPLUS CPU312С ДЛЯ S7-300, ТЕМПЕРАТУРНЫЙ ДИАПАЗОН -25...+60С, ОСНОВАН НА МОДУЛЕ 6ES7312-5BD01-0AB0

Просто перечень SIPLUS модулей с ценами есть в сборнике "Информация по продуктам". Получить можно в любом тех. центре.
См. CPU312С


text

К бывалым. Умер 416-2 DP
из NM.ru; 16.11.04

Привет всем. Без меня перегружали по питанию 416-2 DP. В настоящий момент при запуске CPU кратковременно зажигает STOP и RUN (одновременно - как и положено кажется), затем их гасит и зажигает моргающие INTF и EXTF. Ни через MPI, ни через DP CPU не виден - мёртвые полностью. Можно ли восстановить CPU через флэшку 2 Mb (типа ему фирмваре апдейту пропихнуть) или доктор в морг сказал? У кого бывало такое? Обидно блин за фирму делается. Ну, ничего на свете уже святого не остается :-(

Re: К бывалым. Умер 416-2 DP
Павел Кобелев; 17.11.04

Полный ресет CPU пробовали делать?

Re: К бывалым. Умер 416-2 DP
Лёха; 17.11.04

У меня умер 414-2 DP. Симптомы те же, увы, но мне так и не удалось раздобыть флэшку, чтобы попробовать реанимировать. Мне сказали, что это может помочь. Попробуй. Только потом сообщи, пожалуйста результат.

Re: К бывалым. Умер 416-2 DP
Чистяков Дмитрий ОАО СеверСталь; 17.11.04

Прошивка конечно же поможет, только если нет физической проблемы.

А у вас программа находится в памяти CPU или там есть ещё и флешка?
Если имеется, то попробуйте её вытащить.
И ещё вопрос, который задал Павел Кобелев, пробовали, т.е. перезапуск CPU с очисткой памяти?
Т.е. может быть всё значительно проще? ;-)
Re: К бывалым. Умер 416-2 DP
от автора; 17.11.04

Программа CPU была только в RAM (для расширения использовалась тоже карточка RAM - работоспособная, т.к. на запасном CPU работает без проблем).

Флэшку 2 метра у нас тоже найти проблематично. Так что пациент отправился в дальний ящичек. Если что-то выяснится, то сообщу дополнительно. Пробовали всякие перезапуски и с очисткой и без - результат без изменений.
Re: К бывалым. Умер 416-2 DP
григорий; 17.11.04

А может попробовать проц поставить в другую корзину без периферии. Кстати из источника убрать батарейки.

И как далеко находитесь? (город)<


text

К бывалым. Умер 416-2 DP
из NM.ru; 16.11.04

Привет всем. Без меня перегружали по питанию 416-2 DP. В настоящий момент при запуске CPU кратковременно зажигает STOP и RUN (одновременно - как и положено кажется), затем их гасит и зажигает моргающие INTF и EXTF. Ни через MPI, ни через DP CPU не виден - мёртвые полностью. Можно ли восстановить CPU через флэшку 2 Mb (типа ему фирмваре апдейту пропихнуть) или доктор в морг сказал? У кого бывало такое? Обидно блин за фирму делается. Ну, ничего на свете уже святого не остается :-(

Re: К бывалым. Умер 416-2 DP
Sergey; 17.11.04

нечто подобное было на 315 (старом) не виделся ни по MPI, ни по DP. Прошили конфигурацию во флешку на другом контроллере, грузанули "не рабочий" с этой флешки и все заработало как ни в чем не бывало


text

Считывание данных с EM277
ao; 15.11.04

Имеется 315-2DP и 226 с EM277. Подскажите пожалуйста, с помощью каких функций считать данные с 226-го по протоколу Profibus-DP?

Re: Считывание данных с EM277
Павел Кобелев; 17.11.04

Для начала по ссылке скачиваете GSD файл для EM 277 и устанавливаете его в HW Config. Далее, в проект с 315-2DP добавляете EM 277 в качестве DP-Slave устройства с требуемым количеством байт на вход и выход (максимум по 64 байта). В параметрах Slave устройства задаем смещение в области памяти V CPU 266 на начало буфера входов-выходов. Все. Дальше работаем как с обычной децентрализованой периферией. Никаких спец. функций не требуется.

См. Список GSD файлов


text

вопрос по S7
Igor; 15.11.04

Каким образом можно проконтролировать потерю связи в соединении контроллеров S7-300 по MPI ?

Re: вопрос по S7
Штыка Игорь; 15.11.04

Если контроллеры соединены по MPI,можно для передачи данных (GD Packet) использовать SFC60(посылка) и

SFC61 (прием). В качестве выходного параметра для данных функций выступает парметр RET_VAL (код ошибки. По данному коду можно судить о потери связи, т.к. обмен пакетами осуществляется циклически
Re: вопрос по S7
Штыка Игорь; 15.11.04

Если контроллеры соединены по MPI,можно для передачи данных (GD Packet) использовать SFC60(посылка) и

SFC61 (прием). В качестве выходного параметра для данных функций выступает парметр RET_VAL (код ошибки. По данному коду можно судить о потери связи, т.к. обмен пакетами осуществляется циклически
Re: вопрос по S7
GorA; 15.11.04

Если не нравится вышеуказанный способ, можно зарезервировать в таблице переменную типа INT (счетчик жизни).

В передающем контроллере установить счетчик циклов(например) от 1 до 1000.
В принимающем контроллере анализировать изменение переменной, если нет ошибка связи.
<


text

Modbus
Astronom; 4.11.04

Стыкуюсь через ср 341 по модбасу с девайсом... и возникла проблема такого плана - он мне в ответе не присылает “шапку” в которой указан адрес слейва, код функции, а присылает только одни данные.

Это у меня уже второй модбасовский девайс который работает в таком стиле. Может я что то делаю не так, могёт где то галочку поставить))

Re: Modbus
Чистяков Дмитрий ОАО СеверСталь; 4.11.04

А что за запрос посылаешь CP341?

Re: Modbus
Astronom; 5.11.04

Ну такой запрос...

адрес модбас 1
код функции 3
Нач. адрес чтения 1
количество регистров 108
Re: Modbus
Николай; 5.11.04

Я думаю, такой галочки просто нет,

ведь в запросе ты указываешь адрес
слейва - он тебе и отвечает.
Наверное эту ситуацию можно исправить
только если покапаться в FB3(receive).
Re: Modbus
Николай; 5.11.04

Кстати, посмотри описание

SerialInterface модуля,слейв и не должен присылать свой адрес.
Re: Modbus
Astronom; 5.11.04

например я посылаю 1-му слейву потом 2-му и мне прийдут значения сначало от первого потом от второго... как я пойму какие данные от кого...

я просто смотрю описание модбас и там прописано что данные полученные от слейва содержат “шапку” в которой указан адрес слейва, код функции
Re: Modbus
shurik; 5.11.04

шапку сообщения обрезает драйвер modbus

зашитый в dongle, а блоки fb отвечающие за связь CPU c CP341 и возвращают только данные.Надо организовать запрос и ждать ответа (или пока не выйдет таймаут) а затем опрашивать следующего слейва
Re: Modbus
Astronom; 5.11.04

я так и делаю, но как то хотелось по нормальному... а не через разсинхронизацию

Re: Modbus
В. Хрижановский, BTC; 5.11.04

Модбас вообще-то и построен на принципе "запрос-ответ". Неужели слэйвы такие тормознутые? Ерунда какая-то получается: первый слэйв получил запрос и начал думать; затем запрос получил второй и ушел в раздумья - и в это время забубнил первый. А если они решат забубнить вместе, что тогда? Нет, по-моему, тут только так, как и пишут: запрос, а дальше ответ либо таймаут.

Re: Modbus
Astronom; 8.11.04

Вообще я конечно точно не знаю как работают блоки сенд - рисива модбаса, точнее когда именно они выставляют и при каком условии Done… (в доке не нашел)

Возможно так-
Done в P_SND_RK выставляется когда послан запрос и получен ответ (удачно и именно для этой команды ), а done в P_RCV_RK что считаны данные из CP (удачно)

Ну или Done в P_SND_RK выставляется когда удачно послан запрос к слейву
а done в P_RCV_RK что считаны данные из слейва (удачно)
Задержка на слейве 100 – 500мс

Re: Modbus
Николай; 9.11.04

Да, слейвы действительно бывают

супер тормозные, но все равно должна
быть организация передачи, не просто так же люди парились с Ethernet'ом и всякими токенрингами, если они действительно решат ответить все разом,
просто всё потеряется.
Могу предложить свой пример, но боюсь
он немного кривоватый - это такой первый блин :)))
Re: Modbus
Astronom; 9.11.04

сейчас я анализирую два Done от P_SND_RK и P_RCV_RK после посылки запроса, вроде работает корректно. Так что всё вроде логично и нормально.

Re: Modbus
Чистяков Дмитрий ОАО СеверСталь; 9.11.04

Всё правильно - послал запрос на получение регистров - жди их. А затем переходи к работе со следующим слейвом.

Так работают все сети на основе жёсткой регламентации (Master-Slave). Асинхронный режим это уже должна быть сеть с поддержкой параллельной работы.
Re: Modbus
Astronom; 9.11.04

да да всё фунциклирует, просто я явно в доке сее не увидел и начал немцев вспоминать не тихим словом))

всем спасибо
Re: Modbus
В. Хрижановский, BTC; 9.11.04

Именно так Done и выставляются, как вы предположили? Я начал как-то ломать модбасовские функции и анализировать их поведение, но пришлось забросить из-за других задач. Так что мне интересно.

Re: Modbus
shurik; 9.11.04

может кто поделится примером или заготовкой какой блока

обмена по Modbus - интересна реализация
Re: Modbus
Astronom; 9.11.04

да именно как я и предположил

могу выслать
Re: Modbus
Чистяков Дмитрий ОАО СеверСталь; 10.11.04

Ну, самый простой пример появиться в Step7 после установки софта. Т.е. после установки Modbus Master или Slave. Ни кто не мешает установить и оба, только лучше не засорять себе мозги лишним, и выбрать, то что надо.

Этот софт можно скачать и с сайта поддержки в Германии.
Re: Modbus
shurik; 13.11.04

2Astronom

Вышли пожалуйста на мыло - у немцев
примеры какие-то уж совсем наивные
Re: Modbus
Чистяков Дмитрий ОАО СеверСталь; 14.11.04

Примеры, они и должны быть наивные, иначе в сложном примере будет трудно понять основную суть. :-)


text

Cинхронизация времени для S7-400?
Антон; 12.11.04

Кто делал синхронизацию, подскажите плз, как это сделать.


text

кабель 6ES5734-1BD20 работа с новыми PC?
Alex; 10.11.04

Может ли работать кабель 6ES5734-1BD20 на новых PC производства Fujitsu-Siemens с COM портом?

Необходимо заменить старый PC где установлен WinCC 4.0 соединненый по данному кабелю с S5-95,На новый. Заказчик приобретает WinCC 6.0.

<


text

Процессор переходит через 5 секунд в стоп.
Проблема с Simatic 115U CPU942; 5.11.04

Следующая проблема: есть 2 модуля Simatic 115U CPU942. После запуска оба переходят через 5 секунд в режим ST. На горит ST, QVZ i BASP, на другом ST, ZYK i BASP. Независимо от внешнего ПЗУ. Как запустить этот модуль процессора? Пробовали запускать без ПЗУ и входных сигналов датчиков - результат тот же.

Re: Процессор переходит через 5 секунд в стоп.
Pavel; 5.11.04

Скорее всего слетели данные хранящиеся в ОЗУ. Тут нужен программатор, что-бы посмотреть стэк прерываний.

Посмотри на сайте документацию по 115
Re: Процессор переходит через 5 секунд в стоп.
В. Хрижановский, BTC; 5.11.04

Для начала сохраните блоки из контроллеров в проект, сделайте архив. Затем в OB1 запишите BE в первом сегменте - т.е. чтобы из ОВ1 вообще ничего не вызывалось. Если оживут - глюк в программе. Надо затем по частям подключать вызовы, смотреть, на чем споткнется. Или же глюк по связи - не зря же вы 2 модуля упоминаете.

Re: Процессор переходит через 5 секунд в стоп.
В. Хрижановский, BTC; 5.11.04

Да, кстати - а в стопе что видно в онлайне?

Re: Процессор переходит через 5 секунд в стоп.
Pavel; 5.11.04

Судя по всему у них и подключиться нечем, а то бы ворос не задавали

Re: Процессор переходит через 5 секунд в стоп.
Alex; 9.11.04

Проверь батарею. Сделай без ППЗУ начальный системный старт.


text

Проблемы. Часть 2-ая
Павел; 8.11.04

Не так давно сгорел компьютер на конвейере, который был подключен к S-400. На время его воссстановления итальянцы выслали новый, со всем предустановленным ПО. Некоторое время он поработал, затем восстановили старый и все вернулось на свои места. Но теперь при загрузке программы управления тех. процессом (Movicon 2000) выдается сообщение:

Caution: you do not have a license !
You obtain you license for our product
SOFTNET-S7 PB Windows 98, NT 4.0, 2000 Pro
order no. 6GK1704-5CW53-3AA0

Папку (C:\AX NF ZZ) и ее содержимое никто не трогал.

P.S. Поясните методику установки лицензии и причину, по которой эта беда могла приключиться. Если можно - по-подробнее (для чайников).
Re: Проблемы. Часть 2-ая
Darwin; 9.11.04

Ага, "восстановить лицензию" :):):):). Ребята, вы что советуете... у них же была лицензия и им надо обращаться на хот лайн или просто в сименовский отдел автоматизации и приводов, ну а там подскажут


text

Freeport mode у S7-200
Yury; 3.11.04

Подскажите пожалуйста. Насколько я понимаю формат передачи в Freeport mode со включённой проверкой чётности Старт бит+8 бит данных+бит чётности+

стоп бит. А если я отключаю проверку чётности, данные передаются в 10-битном формате. Мне надо передавать данные в 11-битном формате с нулевым девятым битом. Подскажите пожалуйста как это можно сделать.
Re: Freeport mode у S7-200
В. Хрижановский, BTC; 3.11.04

Увы, но похоже, что никак. Разве что сваять самопальный шлюз на базе какого-нибудь Atmel или вроде того. Никаким иным способом нельзя это устройство связать с 200-м? Только через последовательный порт?

Re: Freeport mode у S7-200
Yury; 3.11.04

Спасибо за ответ. А в режиме "no parity" данные передаются в 10-битном формате или в 11-битном с двумя стоповыми битами ?

Re: Freeport mode у S7-200
В. Хрижановский, BTC; 3.11.04

Похоже, что в этом режиме 11 бит никак не получается. Когда я его использовал, у меня передавалось 10 бит. Вопрос: чем обусловлено применение именно S7-200? Скажем, тот же Unitronics может выдать 2 стоп-бита в режиме без четности.

Re: Freeport mode у S7-200
Yura; 4.11.04

Обусловлено тем, что S7-200 у нас уже используется и программа для него отлажена. А необходимость в передаче данных возникла только сейчас. Причём как всегда срочно. Я пока вижу только один вариант - передавать информацию по одному байту, выставляя предварительно parity check так, чтобы девятый бит был нулевым.

Re: Freeport mode у S7-200
В. Хрижановский, BTC; 5.11.04

Да, так и получается... Похоже, ничего лучшего предложить нельзя.


text

S5 CPU 948,928 и 524 ячейки for sale
Кирилл; 5.11.04

Продам:

6ES5928-3UB21 2
6ES5928-3UB12 1
6ES5948-3UA11 1
6ES5524-3UA13 1
6ES5524-3UA15 1
6ES5923-3UC11 1
6ES5928-3UB11 1
Все вопросы на email
или по тел. +7 0725 249543
<


text

Alarm-8
Грегорий; 4.11.04

Просьба пояснить:

Имею 320 сообщений (битовые). Чтобы получить сообщение об их изменение в Wincc Я должен 40 раз вызвать функцию Alarm-8 с соответсвующими параметрами, или тут иной механизм. Метод Scan меня не интересует. И сколько времени выполняется один такой вызов напрмер для 416 CPU?<


text

Протокол для CP341
Olbear; 25.10.04

Люди. Подскажите. Как заставить Siemens работать с нестандартным последовательным протоколом? В частности надо принимать и анализировать бит четности.

Re: Протокол для CP341
Eugene Sergeev; 26.10.04

IMHO никак. Мне, по крайней мере, не удалось.

Re: Протокол для CP341
Olbear; 26.10.04

Весьма жаль...

Re: Протокол для CP341
Илья [Одесса]; 4.11.04

с СР341 идёт утилита, которая интегрируется в Step7, вызывается из Hardware M. Из утилиты ставишь ASCII протокол, можно выбрать количество битов данных, чётность, стоп биты, способ обнаружения конца сообщения. Дальше пишешь руками протокол. Таким способом написал modbus драйвер.

Re: Протокол для CP341
Olbear; 4.11.04

Илья. Это все понятно, но эти настройки не позволяют сделать так чтобы CP341 тупо принимал и отправлял сообщения с битом четности установленным в произвольное состояние. Можно использовать только формирование бита как дополнение до четности или как добавление до нечетности. Если знаеш как принять байт, с "неправильным" для данной настройки, битом четности - напиши.


text

S7-400. Непериодичный сбой технологической программы CPU 6ES7 414-2XG02-0AB0
Павел; 4.11.04

Аналоговая плата 6ES7 432-1HF00-0AB0 не выдает команду позиционирования в конце технологического цикла. Уровень напряжения позиционирования робота 0,2 - 0,4 (В) управляет сервоприводом постоянного тока координатой 3-ех координатного робота. Опыта работы с программой STEP7 и S7-400 нет. Расскажите по-подробнее с чего начать, т.е. как локализировать сбой (аналоговая плата или CPU). Какие программные средства необходимо использовать для тестирования/поиска неисправностей, и где их можно взять.

Заранее благодарен за любой совет.
Re: S7-400. Непериодичный сбой технологической программы CPU 6ES7 414-2XG02-0AB0
Чистяков Дмитрий ОАО СеверСталь; 4.11.04

Re: S7-400. Непериодичный сбой технологической программы CPU 6ES7 414-2XG02-0AB0
Сергей; 4.11.04

для начала

Для этого нужен программатор
и с имулировать сигнал
L 100 задать значение и отправить в
T pqw 100 и номер выхода
все это можно прописать скажем в ОВ1
если на выходе напряжение будет меняться значит блок целый и надо разбираться в алгоритме машины а значит содиться с программатором плюс Step7 и проверять по алгаритмам связи
но чаще всего это или сам блок анлог.вых. или дуркует какой то датчик
Re: S7-400. Непериодичный сбой технологической программы CPU 6ES7 414-2XG02-0AB0
Павел; 4.11.04

Программатором может выступать компьютер, подключенный к S-400 ? (В компьютере стоит плата PCI Сименс xxxxxx - названия не помню). Всю эту линию эмалирования сочинили и установили итальянцы, ждать ихнего приезда - все равно, что ждать второго пришествия, да и заломят они не одну тысячу евро за свои труды. Нужно придумать что-либо сейчас. Да, и еще, ПО эти буржуи тоже никакого не оставили. Стоит MOVICON 2000 и он управляет тех. процессом. Аналоговую плату только что поменяли - эффекта никакого. Что именно сбрасывает кнопка RST на S-400 ? Если память данных, то может быть именно с этого начать,а главное - при этом ничего не напортачить (а то повесят :)) ?

Все знающие - please, откликнитесь.
Re: S7-400. Непериодичный сбой технологической программы CPU 6ES7 414-2XG02-0AB0
Руденко Алексей Невисс-комплекс; 4.11.04

Именно этот компьютер и должен выступать в роли программатора, но нужно еще ПО Step7 и навыки работы с ним, иначе выхода у Вас никакого - только звать итальянцев, либо специалистов со стороны, но и они могут потребовать хорошую копеечку...

Удачи...
Re: S7-400. Непериодичный сбой технологической программы CPU 6ES7 414-2XG02-0AB0
jokerssa; 4.11.04

где вы находитесь?

Re: S7-400. Непериодичный сбой технологической программы CPU 6ES7 414-2XG02-0AB0
Проверь контакты датчиков; 4.11.04

Если ты сотрешь программу - сможешь ли ты ее туда обратно загнать если тебе макаронники ничего не оставили?

Если ты не специалист трудно подсказать решение. Самые очевидные:

1. Во многих случаях помогает проверка/подтяжка клемм/разъемов, прозвонка гибких движущихся проводов/кабелей (даже фирменных). И часто дефект проявляется непериодичностью: то есть контакт, дернулось и нет контакта.

2. Проверь все датчики положения.

"Ошибка" может быть и программной, если в каком то месте возникла неопределенная комбинация (не)срабатывания датчиков, которая никак не обрабатывается программой.

См. http://simatic.nm.ru/phorum.dhtml

Re: S7-400. Непериодичный сбой технологической программы CPU 6ES7 414-2XG02-0AB0
Pavel; 4.11.04

Для начала проверь все обратные связи-целостность кабелей и т.д.

Судя по числу осей это манипулятор,
если у него есть кабельная гусеница,
то может быть обрыв провода.
Потом 0.3-0.4 В это штатный сигнал
или то что валится с платы?
Для стандартного сервопривода это означает скорость на уровне предела трогания. Да, еще посмотри срабатывают ли тормоза на двигателе(если они есть)
Мне кажется что контроллер скорее всего здесь ни причем.<


text

CPU в режиме on-line
Леонид; 3.11.04

При подключении к CPU 943В(S5-115U)в режиме on-line не видны блоки PB,FB,OB и т.д.Также не работают режимы передачи и сравнения

блоков,как будто контроллер пустой.И только после очистки памяти и востановлении программы,в режиме on-line все начинает работать(видны блоки и т.д.).Через некоторое время все повторяется.На работу машины это не влияет,но тяжело искать неисправности.К CPU подключена панель PCS-095(LAUER),может быть это влияет ? Благодарю всех кто ответит.<


text

Снова про FM355C
Eugene Sergeev; 3.11.04

Поскольку старая тема не открывается почему-то, придется начать новую.

Все-таки, при вызове функции FM_PID без установки READ_VAR в TRUE, происходит обновление значений в блоке данных?
Какая разница между LOAD_OP и LOAD_PAR?
А также вопрос, аналогичный первому - если я меняю какие-либо параметры в блоке данных и затем вызываю FM_PID без аргументов, измененные параметры попадут в модуль? <


text

fzl4141 в блоке вывода S5-135
Сергей; 2.11.04

Подскажите, что за микросхема

fzl4141 в блоке дискретного
вывода S5-135. Может, есть на нее описание? Спасибо.
<


text

memory card
Алексей; 14.10.04

memory card записана на 99%, при попытке сделать любое изменение в программе появляется ошибка недостатка памяти.

Есть ли возможность как-то "обойти" эту ситуацию или придется переписывать memory card полностью на программаторе?
Re: memory card
Штыка Игорь; 29.10.04

Не понятно, что значит записана на 99%?и как, допустим со сбойной флеш-памятью вы работаете с контроллером?

Если возникает сбой при записи на карту, то лучший вариант ее перформатировать.

Re: memory card
Валентин; 29.10.04

Когда делаете изменения, в память записывается измененный блок, а старый блок становится недействительным, но в памяти сохраняется.В Step5 есть режим сжатия памяти, который освобождает память от всех недействительных блоков. Как это сделано в S7 я не знаю.

Re: memory card
Михайлин Сергей; 29.10.04

Функция Compres в STEP7, аналогичная одноименной функции в STEP5, запускается из вкладки Memory окна PLC/Module Information. Сожмите память и грузите изменения дальше. Если карта забита на 99% именно основной программой, а не предыдущими версиями, то нужно удалить этот блок совсем, сжать и загружить его снова.

Опять про стакан
Память; 29.10.04

другом форуме он уже разобрался (пол месяца прошло). Ему объяснили, что если если хочешь всю водку из бутылки влить в маленький стакан, то надо взять стакан побольше, либо умерить свой аппетит и почистить посуду.

Просто в этом форуме специалисты Сименса сейчас молчат, хотя раньше оперативно старались ответить. Поэтому и интерес к форуму низкий.
Re: memory card
Алексей; 1.11.04

1.Что значит записана на 99%- а то и значит (и это не я ее записывал, а досталось по наследству)

2.Функция Compress в данном случае не помогает- память уже сжата
3.По поводу пьющих и не пьющих: я не собарюсь доливать- стакана мне для начала вполне хватит- хотелось сделать чуть покрепче.

Re: memory card
Ты правильно обиделся; 1.11.04

Ты правильно обиделся.

Ты четко сформулировал вопрос, что у тебя меньше 1% свободной памяти, описал свою конфигурацию, тип процессора, объем карты памяти, размер функции для замены и что ты хочешь вообще сделать в ней, что тебе действующая установка досталась тебе по наследству и ты не можешь на ходу из нее достать карту и поставить туда карту большего объема, и надо это лично тебе, а не твоему начальству.
А тут глупые люди не могут тебе помочь при стольких вводных.
Re: memory card
GorA; 2.11.04

Если есть возможность, то нужно поменять данную карту на карту с большей емкостью.

<


text

Проблема коннекта S7 315 2DP & MP370 (код ошибки 140010)
Alexander; 27.10.04

Уважаемые, помогите с таким траблом:

панель MP370 соединена с 315 2DP по PROFIBUS DP. Но прект загруженый в нее никак неможет связаться с 315 2DP. Изменение настроек связи панель- CPU (DP-адрес, master\slave) ситуацию не изменило. Пробывали связывать по MPI - эффект тот же.
По совету умных людей перепрошили ОС в панели ситуация таже.
Ситуация осложнена тем, что программа в контроллере закрыта паролем( ее нельзя скачать). Мне были открыты только блоки данных с помощью которых ведется обмен с панелью.
Пробовал "проэмитировать" обмен данных с помощью Step 7(функцией Compare Blocks) через порт DP не получилось.
Аналогичный тест обмена данных через порт MPI привел к запросу пароля.
Грешу на пароли. Прав ли я?
Может кто сталкивался с таким, подскажите.
Панель выдает следующий код ошибки 140010.
Заранее спасибо.

Re: Проблема коннекта S7 315 2DP & MP370 (код ошибки 140010)
Уточни; 27.10.04

Из этого сумбура я не понял - в самой панели программа от этих "скрытных" горе-программистов есть? Если нет - то чего ты хочешь - из Виндовса связаться?

Программа контроллера знает, что она должна работать с панелью?
В конфигурации контроллера жестко прописаны параметры подсоединения панели и ее адрес - стандартно через MPI. Адрес должен соответсвовать конфигурации.
Тип процессора какой - с MMC картой или с батарейкой?
См. http://simatic.nm.ru/phorum.dhtml

Re: Проблема коннекта S7 315 2DP & MP370 (код ошибки 140010)
Alexander; 27.10.04

Cпасибо за улыбки))

Прогу на панель писал сам. "Скрытные" отдали мне ток DBшки.
Адрес вычислял методом "тыка" но результата не получил.
Флэшка в нем торчит. А что есть некоторые рекомендации по лому пароля?:-)
У меня даже присмотрен такой же CPU?
Ток я не знаю как ломать((

Re: Проблема коннекта S7 315 2DP & MP370 (код ошибки 140010)
Полнее ответь; 27.10.04

На первый вопрос ответил - спасибо.

Ну пожалуйста ответь на остальные вопросы (умоляю)!!! ( с иронией)
У них в программе было предусмотрено подключение панели? Если было узнай у них адрес и шину. Обычно типа 1,2 или 3 по MPI. Если не было у них такой задумки - то пиши всю программу контроллера с нуля.
Если есть сименовский программатор Power/Field PG попробуй посмотреть содержимое MMC через Степ, вставив ее в евонную щель. Зависит от параметров способа защиты.
Re: Проблема коннекта S7 315 2DP & MP370 (код ошибки 140010)
Bkmz; 31.10.04

1. Для соединения ОР и контроллера в контроллере НЕ НАДО делать НИКАКИХ конфигураций для связи с панелью. Все делается в ОР-шке.

2. Думаю, проблема в конфигурировании панели - адрес ЦПУ, заданный при конфигурировании панели не совпадает с РЕАЛЬНЫМ адресом ЦПУ.
3. Найдипе ПроТульный проект и посмотрите его параметры: адрес цпу, интерфейс связи (MPI/DP) и скорость обмена.
4. Подключитесь к контроллеру и попытайтесь выяснить его параметры связи. Сравните с панелькой. Все остальное вы уже сможете сделать сами по результатам п.п.1-3
Проблема постановки задачи и тупых советов
Каков вопрос - таков ответ; 31.10.04

to Bkmz п.4

Ты еще пообещай через панель скачать программу из PLC и узнать все адреса станций.
Нельзя давать безответственные советы. Сначало выясни, что, зачем и для чего это ему надо.
Там же было написано:
>Прогу на панель писал сам.
>"Скрытные" отдали мне ток DBшки.
>Адрес вычислял методом "тыка" но результата не получил.
Где ты в панели узнаешь РЕАЛЬНЫЙ адрес ЦПУ (он кстати не реальный [REAL], а целый [INT] - шутка).
Если контроллер не знает, что к нему подключена панель, он не знает как реагировать на команды, полученные с панели. Ну не могли предусмотреть "скрытные" этого.
Он с панели тэг взведет и его установка выполнит, то чего ни он, ни его начальство никак не ожидало. Кто за это отвечать будет?
Что бы что-нибудь подключить снаружи надо знать листинг программы и конфигурацию, а не только одну ДБэшку.
Re: Проблема коннекта S7 315 2DP & MP370 (код ошибки 140010)
Alexander; 1.11.04

Всем спасибо за участие.

Трабл засолвили.
После сЛОМа пароля оказалось что там вообще не сконфигурирована сеть PROFIBUS DP, а MPI хотя и есть, но ЦПУ к ней не подключен.
Короче как всегда дело в мозгах.
Еще раз спасибо.<


text

Siwarex и IM153-1
Michael Ivlev; 1.11.04

При работе с весовыми приборами SIWAREX (7MH4601-1AA01) расположенными в децентрализованной периферии ET200M (IM 153-1AA03-0XB0) c центральным процессором CPU 414-3DP (6ES7414-3XJ00-0AB0 V 3.1.3.) нами выявлена следующая ситуация:

При работе через SFC – коммуникацию, при считывании текущих значений (REGNUM = b#16#1F т.е. DR 31) при указании длинны запрашиваемых данных 10 байт (согласно документации на весовой прибор) SFC 59 “RD_REC” в параметре RET_VAL возвращает код ошибки 80B1 (неверная длина запрашиваемых данных). В ходе экспериментов нами было установлено, что SFC 59 считывает только актуальные в данный момент значения, т.е. размер области в данном случае 6 байт – это значения веса и статус. Если сгенерировать асинхронную ошибку, то область считываемых данных должна быть указана уже 8 байт – получается какой-то динамический размер области данных, который нужно угадывать. Данные эксперименты были проведены с аналогичным процессором но с версией операционной системы 1.2.0, Конфигурировали систему в STEP 7 V5.2 и V5.3. результат оставался прежним пока не заменили IM 153 на интерфейсный модуль другой версии т.е. на IM 153-1AA02-0XB0. После замены ИМки область считываемых данных стала соответствовать документационной, т.е. 10 байт и ни какой ошибки.
Действительно новые ИМки так работают или мы, что-то не указали при конфигурации системы?
P.S. может будет такой же простой ответ как и по поводу кнопки download? :)<


text

где взять hsp-файл
григорий; 29.10.04

Где взять файл обновления для Hw-config cpu414-3 версии 4.02. Hw-config находит только для 4.0. Из-за этого не могу корректно загрузить проект в CPU.

Необходимый файл вместь c xml можно на е-mail.<


text

Проблемы с FM355C
Eugene Sergeev; 23.10.04

У меня возникли непонятки с FM355C.

Непонятка первая - сконфигурил модуль, загрузил конфигурацию. В блоке данных цифры те же, что я сконфигурил. Сделал MRES, загрузил конфигурацию снова. В блоке данных цифры те, что задаются по умолчанию. В экранах конфигуратора - все ОК, заданные мной значения.
Непонятка вторая - как то странно работает FB PID_FM. Вызываю из ОВ100
инициализацию. Вроде работает. Далее пытаюсь тут же изменить кое-какие параметры - поставить LMN_ON. Пишу -
(на SCL)
LMN_ON:=TRUE;
LOAD_PAR:=TRUE;
FM_PID.DB31();
- не работает.
Пишу дальше
LOAD_PAR:=TRUE;
FM_PID.DB31(LMN_OP:=12.34);
- работает.
Если пытаюсь написать
LOAD_PAR:=TRUE;
FM_PID.DB31(LMN_ON:=TRUE);
- не компилится, ругается на неправильные аргументы.
Кто нибудь может проконсультировать по этим вопросам? Да, модулей у меня 2, регуляторов, соответственно 8. И на всех такая ерунда.

Re: Проблемы с FM355C
GorA; 29.10.04

А что это за параметр LMN_ON?

Может быть LMNOP_ON?
Re: Проблемы с FM355C
Eugene Sergeev; 29.10.04

Да, LMNOP_ON. Писал по памяти, вот и ошибся. Вопрос остается - как-то не очень последовательно данные попадают из DB31 в модуль. Такое впечатление, что иногда попадают, а иногда и нет.

Re: Проблемы с FM355C
GorA; 29.10.04

Я попробовал вызвать в SCL аналогичный блок и у меня вышло следующее:

CTRL_PID.DBxxx(SAMPLE_T := // IN: REAL
,DEADB_W := // IN: REAL
,GAIN := // IN: REAL
,TN := // IN: REAL
,TV := // IN: REAL
,TM_LAG := // IN: REAL
,LMN_OFF := // IN: REAL
,NM_LMNHR := // IN: REAL
,NM_LMNLR := // IN: REAL
,NM_PVHR := // IN: REAL
,NM_PVLR := // IN: REAL
,MO_PVHR := // IN: REAL
,MO_PVLR := // IN: REAL
,PVH_ALM := // IN: REAL
,PVH_WRN := // IN: REAL
,PVL_WRN := // IN: REAL
,PVL_ALM := // IN: REAL
,HYS := // IN: REAL
,DISV := // IN: REAL
,M_SUP_AH := // IN: BOOL
,M_SUP_WH := // IN: BOOL
,M_SUP_WL := // IN: BOOL
,M_SUP_AL := // IN: BOOL
,CSF := // IN: BOOL
,SP_OP_ON := // IN: BOOL
,SPBUMPON := // IN: BOOL
,SP_TRK_ON := // IN: BOOL
,SP_HLM := // IN: REAL
,SP_LLM := // IN: REAL
,SP_EXT := // IN: REAL
,SPEXTHLM := // IN: REAL
,SPEXTLLM := // IN: REAL
,SPURLM := // IN: REAL
,SPDRLM := // IN: REAL
,SPRAMPOF := // IN: BOOL
,SPINT_EN := // IN: BOOL
,SPEXT_EN := // IN: BOOL
,LIOP_INT_SEL := // IN: BOOL
,SPEXON_L := // IN: BOOL
,P_SEL := // IN: BOOL
,PFDB_SEL := // IN: BOOL
,DFDB_SEL := // IN: BOOL
,INT_HPOS := // IN: BOOL
,INT_HNEG := // IN: BOOL
,LMNR_IN := // IN: REAL
,LMN_HLM := // IN: REAL
,LMN_LLM := // IN: REAL
,MAN_HLM := // IN: REAL
,MAN_LLM := // IN: REAL
,LMN_TRK := // IN: REAL
,LMN_SEL := // IN: BOOL
,LMNOP_ON := // IN: BOOL
,MANOP_EN := // IN: BOOL
,AUTOP_EN := // IN: BOOL
,LIOP_MAN_SEL := // IN: BOOL
,AUT_L := // IN: BOOL
,M_SUP_ER := // IN: BOOL
,ERH_ALM := // IN: REAL
,ERL_ALM := // IN: REAL
,ER_HYS := // IN: REAL
,MSG_EVID := // IN: DWORD
,MSG_LOCK := // IN: BOOL
,OPTI_EN := // IN: BOOL
,BA_EN := // IN: BOOL
,OCCUPIED := // IN: BOOL
,BA_NA := // IN: STRING
,STEP_N1 := // IN: DWORD
,RUNUPCYC := // IN: INT
,PV_IN := // INOUT: REAL
,SP_OP := // INOUT: REAL
,MAN_OP := // INOUT: REAL
,SPEXTSEL_OP := // INOUT: BOOL
,AUT_ON_OP := // INOUT: BOOL
,AUX_PR05 := // INOUT: ANY
,AUX_PR06 := // INOUT: ANY
,AUX_PR07 := // INOUT: ANY
,AUX_PR08 := // INOUT: ANY
,AUX_PR09 := // INOUT: ANY
,AUX_PR10 := // INOUT: ANY
,STEP_NO := // INOUT: WORD
,BA_ID := // INOUT: DWORD
);
:= DBxxx.QERR; // OUT: BOOL
:= DBxxx.QPVH_ALM; // OUT: BOOL
:= DBxxx.QPVH_WRN; // OUT: BOOL
:= DBxxx.QPVL_WRN; // OUT: BOOL
:= DBxxx.QPVL_ALM; // OUT: BOOL
:= DBxxx.QUPRLM; // OUT: BOOL
:= DBxxx.QDNRLM; // OUT: BOOL
:= DBxxx.QSP_HLM; // OUT: BOOL
:= DBxxx.QSP_LLM; // OUT: BOOL
:= DBxxx.Q_SP_OP; // OUT: BOOL
:= DBxxx.QSPEXTON; // OUT: BOOL
:= DBxxx.QSPINTEN; // OUT: BOOL
:= DBxxx.QSPEXTEN; // OUT: BOOL
:= DBxxx.QLMN_HLM; // OUT: BOOL
:= DBxxx.QLMN_LLM; // OUT: BOOL
:= DBxxx.QLMNOP; // OUT: BOOL
:= DBxxx.QMAN_AUT; // OUT: BOOL
:= DBxxx.QMANOP; 1098521727 d:1037014088106325821410437455441093331638 1037014088106325821410437455441093331638193887101220560110577528389550001151099552173  "1044017511102852248510777016801096170638 Х#981107907 ”
1020061471102464164810331299649692640919809328791077011985 њ#1020061471102464164810331299649692640919809328791077011985 d:10438255101000047111983181381  "1044017511102852248510777016801096170638 d:1037014088106325821410437455441093331638 д» 1046699983 Х#981107907 њ# Ё%10101347641018431611970118952ґ€930083434109809754794515565095858009410620551841034554952107580692010298288721026822958108269720894459826810825468381097040897103122367298551462010379742171094453735%Ѕ%9653682431013525035107511490221383510358780761075382586109801101610264607271081161809Advisories and threaded discussions. The threaded discussions allow you to ask questions, or look for solutions, on a subject that you may need help with where other PCS Users or Siemens staff may be able to assist you.
In closing let me assure you that we are firmly committed to providing you with regular up-to date information in order to make the integration of our Products and Systems, as well as the transition to new technologies, easier for you.
Yours sincerely!

Re: Проблемы с FM355C
GorA; 29.10.04

Кроме того данный FB, а также системные функции SFC58, 59 не должны прерывать друг друга, т.е. когда не закончена работа одного FB нельзя вызывать другой (управление другим устройством) или SFC58, 59 (доступ к некоторым коммуникационным, функциональным и интеллектуальным устройствам HW). Нужно отслеживать завершение работы FB и SFC.


text

FM351
Константин; 21.10.04

Модуль FM351 выдает сообщение,что не подключено внешнее питание для запитки

датчика абсолютного значения.
При этом питание подведено и данные с датчика читаются.
Что может вызвать данную ситуацию?
Re: FM351
GorA; 29.10.04

Питание подведено на Х1 pin 1, 2 - ?

Re: FM351
Константин ; 29.10.04

Если питание не будет подведено к

X1(1,2),то датчик не будет запитан,соответственно данные не будут читаться.<


text

EPROM
Александр; 20.10.04

Не читаются EPROM. Есть программатор Field PG с установленным STEP 5 v7, S5Prog.Adapter (6ES 798-0CA00-0XA0), и два модуля EPROM (6ES5 375-1LA41 и 6ES5 375-1LA15 ). При попытках читать или просматривать содержимое, STEP 5 определяет номера модулей 417 и 411 соответственно. Но после нажатия insert на вопрос IF EPROM CORRECT SIMPLY INSERT KEY получаю сообщение Submodule contents invalid, а в поле END ADDRESS выводится значение 00000000. Оба модуля только что сняты с контроллеров, рабочие, и содержат программу.

Подскажите, из-за чего может быть проблема.

Re: EPROM
GorA; 29.10.04

А ножки на разъеме не погнуты? Бывает.


text

Распиновка
Равиль; 21.10.04

Подскажите пожалуйста распиновку PC/PPI cable со стороны RS-485.

Re: Распиновка
Андрей Гуленок; 28.10.04

Ну, распиновки кабеля CP\PPI как таковой не существует. Зато в руководстве на S7-200 подробно расписан девятипиновый разъём контроллера. Откуда её можно творчески перенести на кабель. Имейте в виду следующее, конвертор сосёт питание из контроллера, по этому если вы хотите как то удлиннить 485-ый конец, это надо учитывать.


text

Есть ли такие штекера?
А.Б.; 20.10.04

Как к S7-224 одновременно присоединить панель оператора и РС(программатор)?Спасибо.

Re: Есть ли такие штекера?
Павел Кобелев; 28.10.04

По штеккерам смотри ссылку. Если порт один (как CPU 224), то подойдет любой с гнездом для подключения программатора. Если порта 2, то для верхнего только с наклонным подводом кабеля.

См. штеккера RS-485


text

нужна-ли доп. защита по питанию(220В)
Новичок; 23.8.04

Посоветуйте ,нужно-ли защищать s7-200 по питанию,если он на 220В.Я думаю поставить встречно 2 сопрессора.Заранее благодарен.

Re: нужна-ли доп. защита по питанию(220В)
Чистяков Дмитрий ОАО СеверСталь; 23.8.04

Не совсем понятно из вопроса, что и как хочется защитить.

Я бы посоветовал бесперебойник или хотя бы стабилизатор или фильтр. Ну, это если есть серьёзные проблемы с питанием, а если особых проблем нет, то отсавь всё как есть. Защита в блоке питания S7-200 имеется.
Кстати, а от чего хочется защититься? От скачков перенапряжения?
Re: нужна-ли доп. защита по питанию(220В)
новичок ; 23.8.04

Да,от грозы и от случайного 380В.Мне еще интересно :обычно при скачке ,который бывает от грозы ,сопрессоры уходят в кз.Потом они сохраняют свою работоспособность?НЕ надо-ли там ставить какого нибудь резистора?

Re: нужна-ли доп. защита по питанию(220В)
Новичок; 23.8.04

Просто хочется с гарантией.Спасибо за ответ.

Re: нужна-ли доп. защита по питанию(220В)
новичок ; 23.8.04

Да,от грозы и от случайного 380В.Мне еще интересно :обычно при скачке ,который бывает от грозы ,сопрессоры уходят в кз.Потом они сохраняют свою работоспособность?НЕ надо-ли там ставить какого нибудь резистора?

Re: нужна-ли доп. защита по питанию(220В)
Pavel; 23.8.04

Обчно сами немцы рекомендуют питание

осуществлять через развязывающия
трансформатор (обычно 380/220В), далее
ставиться быстродейстующий автомат
(помоему серии D).
Наличие сетеврго фильтра тоже желательно<


text

Значение сопротивления заземления станции S7-400
ВДВ; 26.7.04

Здравствуйте!

Кто-нибудь подскажет ответ на вопрос (см. тему)? Или дать соответствующую ссылку, если вопрос уже поднимался.
Я слышал, что есть два значения: 4 и 8 Ом.
Заранее благодарю.
Re: Значение сопротивления заземления станции S7-400
Павел Иванов; 26.7.04

Согласно российским нормам - 4 Ом,

согласно немецким нормам (если не изменяет память) - 10 Ом
Re: Значение сопротивления заземления станции S7-400
Shade; 22.10.04

Хотелось бы расширить вопрос:

В условия вечной мерзлоты, есть проблемы с качественной низкоомной "землей". Есть ли у кого-нибудь сведения о работе Simatic в таких условиях? Потому что говорят, что компьютеры выходят из строя очень часто и именно по этой причине.<


text

Siemens PT89
Siemens PT89; 20.10.04

Есть принтер Siemens PT89. при подключени к компу пишет что нет бумаги , драйвера стоят от эпсона ФХ80. у кого нибуть есть руководство как выставлять джампера под Виндоуз 98 операционную систему. Ответ можно слать на kayratu@pochta.ru

Re: Siemens PT89
Павел Иванов; 20.10.04

Этот принтер прекратился выпускаться, когда еще даже не было Windows 3.1

Re: Siemens PT89
Pavel; 20.10.04

Этот сундук работал только от PG675-85, и более древними. Выкинь на помойку. Там знакогенератор жестко зашит в ПЗУ и всго 1 шрифт.Тебе это надо.

Re: Siemens PT89
Siemens PT89; 21.10.04

Спасибо всем!!!!!!!!!!!!!!!!!!!!

Выброшу с балкона сразу как только теща в магазин под ним пойдет :-)<


text

ET100 U
Александр; 20.10.04

Добрый день господа! у кого есть в продаже коммуникационник IM318-8, IM316


text

Сохранение данных в блоке данных при выкл питания
Scout; 13.10.04

Как заставить контроллер сохранять данные в глобальном блоке данных при выкл. питания, а не инициализировать переменные заного их начальными значениями?

Re: Сохранение данных в блоке данных при выкл питания
Валентин; 14.10.04

При выключении питания данные в блоке данных, я думаю, сохраняются. Другой вопрос, что при включении питания данные в нем обновляются(я не знаю как сделана ваша программа). Один из вариантов - сохранять данный DB во вспомогательном перед отключением питания. Другой вариант - занести значения из рабочего DB во вспомогательный при старте PLC (включение питания) с помощью пусковых OB.

А далее переносите значения в рабочий DB из вспомогательного так же, как и начальные значения.
Re: Сохранение данных в блоке данных при выкл питания
Дима; 14.10.04

А если используете старые S7-300, то в них есть такая возможность сохранения актуальных данных в реманентных областях паияти (меркера, DB, которые определяются в HWKonfig). Новые S7-300 (те, у которых ММС карта) не имеют таких областей, но данные можно записать на ММС (внимание! не больше 100000 циклов записи). S7-400 данные сохраняют.

Re: Сохранение данных в блоке данных при выкл питания
Gibbon; 14.10.04

8-) вопрос старый

у котроллеров с ММС картой: при сбое питания все блоки сохраняются в энергонезависимую память на ММС карте (там специально для этого стоит ионистр), поэтому на них холодного старта не может быть
у контроллеров с флеш памятью динамическая запись на нее невозможна, пока батарейка жива данные сохраняються а если умерла то только холодный рестарт

Re: Сохранение данных в блоке данных при выкл питания
Григорий; 14.10.04

400-е сохраняют все при наличии буферной батареи. Область сохраняемых меркеров нужно конфигурировать

Re: Сохранение данных в блоке данных при выкл питания
Scout; 14.10.04

Спасибо всем за ответы.

Контролер у меня S300 с ММС.
>>
При выключении питания данные в блоке данных, я думаю, сохраняются. Другой вопрос, что при включении питания данные в нем обновляются(я не знаю как сделана ваша программа). Один из вариантов - сохранять данный DB во вспомогательном перед отключением питания.
>>
Этот вариант не подходит, т.к переменные вспомогательного блока данных также при включении будут инициализироваться начальными значениями.
А второй вариант я думаю реален, если выполнение стартового OB действительно
происходит раньше, чем иниализирование
Блока данных.

>> Новые S7-300 (те, у которых ММС карта) не имеют таких областей, но данные можно записать на ММС (внимание! не больше 100000 циклов записи).

>>
Как я понял, на ММС можно записать с помощью системных функций. Интересно, куда же тогда записываются данные, если их принудительно не сохранять на ММС с помощью этих самых функций?

Пока у меня получилось сохранять значения переменных, определенных в таблице символов. И чего блин Сименсы сделали недоступной конфигурирование Реманентности в новых S300... Приходится затевать трахотню со вспомогательными блоками данных...
Или токо у меня параметры реманентности для DB "затемнены"(зачем тогда они есть, если их нельзя редактировать)?
<


text

WinCC и CPU317 2PN/DP
SiTrans; 14.10.04

Можно ли соединить WinCC с CPU317 2PN/DP через встроенний в него интерфейс

Ethernet.
<


text

Как корректировать 6ES5-466-3LA11?
Алексей; 12.10.04

Можно ли корректировать входные параметры(Iвх) 6ES5-466-3LA11(ЦАП-АЦП)?

У кого есть схемы по этому блоку?
Re: Как корректировать 6ES5-466-3LA11?
Кухаренко Сергей, SIEMENS; 13.10.04

Что означает "корректировать входные параметры"? Если имеется в виду изменение диапазона измерения тока, то для этого модуля он выставляется переключателями. Диапазоны следующие - 0-20мА, 4-20мА, -20+20мА.


text

S7-300 и InTouch
ПКБ; 8.7.04

Кто нибудь пробовал связать S7-300 c InTouch иначе, чем через OPC Server - OPCLink? Например, через I/O Server от Wonderware? Что лучше?

Re: S7-300 и InTouch
Lvbhbq; 12.7.04

WinCC!

Re: S7-300 и InTouch
Игорь Штыка; 7.10.04

В принципе, OPC Link представляется наиболле удобным и оптимальным инструметом для связи с S7300 (более прозрачная структура).

Re: S7-300 и InTouch
Чистяков Дмитрий ОАО СеверСталь; 8.10.04

Наши коллеги на комбинате раньше баловались с этой конфигурацией.

И у них было не млао проблем с драйверами связи, которые поставлялись с InTouch. Нормальная же связь у них заработала, только после закупки OPC (и был вариант с OLE/DDE менеджером) от самого Siemens`а. Но потом, расмотрев совокупную стоимость подобной конфигурации и дополнительную работу по установке связи, они перешли на следующих проектах WinCC.
ПонимаетеЮ два родственных продукта от одной фирмы они всегда легче собираются в проект.
Re: S7-300 и InTouch
Владимир; 8.10.04

У нас связь через Simatic Net и I/O Server ,но нужна лицензия Simtic SoftNet-S7 . Настройки конечно дубовые- нужно настроить в 3-х местах,создавать специальные файлы конфигурации. Поэтому лучше WinCC.


text

нужна тех инфа по программаторам
Alexxx; 6.10.04

нужна тех. информация программыторы:

1. PG685 6ES5685-0UK12
2. PG685 (или, скорее всего, PG675) 6ES5675-0UK11
Re: нужна тех инфа по программаторам
Кухаренко Сергей, SIEMENS; 6.10.04

А что имеется в виду под словами "техническая информация"?

Если мыслится техническое руговодство по этим устройствам, то таковое существовало только в печатном виде, т.к. другой вид в бытность производства этих устройств отсутствовал.
Re: нужна тех инфа по программаторам
Alexxx; 6.10.04

хотя бы ссылка на pdf-ник или где найти на сименсе.

ну не нашел я нигде такого. а надо!
Re: нужна тех инфа по программаторам
Alexander; 7.10.04

Что конкретно надо? Есть в печатном виде, могу по конкретному вопросу сделать купюры.

Re: нужна тех инфа по программаторам
Alexxx; 7.10.04

вопрос в том, выпускаются ли они.

Если да - как найти в каталоге.
Если нет - то чем можно заменить.
Re: нужна тех инфа по программаторам
Nec; 7.10.04

Они уже давно не выпускаются. 675 вообще без винчестера, с дискетты всегда грузить надо.

В настоящее время доступны программаторы FieldPG (6ES7711-) и PowerPG. Но в принципе, можно заменить и обычным PC, а у Siemens'a купить только софт и карту связи с контроллером. Если с S5-115U - можно спаять шнур и купить только софт. Потому что, PG это обычный ноутбук с картой связи - а стоит около 7килоевро<


text

Аналоговые модули S7 300
Denis; 24.8.04

Здравствуйте.

Подскажите пожалуйста, фраза (в руководстве по аналоговым модулям S7 300) "2-х проводные преобразователи для измерения тока" означает датчики, питание которых осуществляется от токовой петли?
Re: Аналоговые модули S7 300
Юрий Оганесян; 25.8.04

Да

Re: Аналоговые модули S7 300
Игорь Штыка; 7.10.04

Существуют так называемое 2-х проводное подключение для датчиков и 4-х проводное подключение в терминологии Siemens. Для 2-х проводного подключения питание на датчик идет от контроллера (2DMU). Для 4-х проводного подключения присутствует внешнее питания на датчик и 2 провода идут на контроллер (сигнал) (4DMU).


text

драйвер
roman; 5.10.04

подскажите какой драйвер необходим на Field Pg для программирования Memory Card?

Re: драйвер
Михайлин Сергей; 5.10.04

Никакого спец драйвера не надо. Достаточно поставить STEP7.


text

А можно ли?
Scout; 3.10.04

Возможно ли в программе проинициализировать блок данных, тоесть

сделать так, чтобы значения всех переменных установились бы в начальные значения?
Re: А можно ли?
Nec; 4.10.04

У меня есть подозрение что initial values вообще в контроллер не грузятся...

Re: А можно ли?
ASP; 4.10.04

В ходе выполнения программы это не возможно. Если только явно не присвоить. initial values грузятся, только через меню Stepа Initialize Data Block и последующей загрузки DB в контроллер.

Re: А можно ли?
Scout; 4.10.04

Тоесть, как я понял придется в программе вручную присваивать переменным их начальные значения, а у меня их(переменных) немало.

Re: А можно ли?
Валентин; 4.10.04

Можно создать блок данных с Вашими начальными значениями и в нужный момент скопировать их в рабочий блок.

Re: А можно ли?
Scout; 4.10.04

Неплохая идея, стоит попробовать.

Спасибо.<


text

Загрузка в CPU314C-2 PtP
Юрчик; 30.9.04

Имеется CPU314C-2 PtP 6ES7 314-6BF01-0AB0.

В Step7 v.5.2. в HW config только 6ES7 314-6BF00-0AB0. Проекты, созданные для BF00 не грузятся в BF01.

Если у кого есть gsd файлик для 6ES7 314-6BF01-0AB0, то буду рад увидеть его в своем ящике.

Re: Загрузка в CPU314C-2 PtP
Руденко Алексей Невисс-комплекс; 1.10.04

Честно говоря в Степе 5.2 есть этот контроллер, во всяком случае у меня есть!

Отдельно GSD дать не могу - не нашел как экспортировать к сожалению...
Как вариант попробуй сделать аплоад станции - может сам найдется...
Высылаю мой каталог контроллеров - экспортируй к себе и работай на здоровье...
Re: Загрузка в CPU314C-2 PtP
Юрчик; 2.10.04

Файлик получил, но не прижился :-(

В техцентре предложили Step 7 v 5.3 В понедльник буду посмотреть :-)

Re: Загрузка в CPU314C-2 PtP
Чистяков Дмитрий ОАО СеверСталь; 4.10.04

GSD файлы работают только с устройствами Profubus. CPU314C-2 PtP тут не причём. Он находится в другой базе, которая обновляется либо установкой обновлёния пакета Step7, либо SP.

Re: Загрузка в CPU314C-2 PtP
Руденко Алексей Невисс-комплекс; 4.10.04

Не может быть, чтобы не прижился!!!

Ты каким образом делал...
Там нужно в хард-конфигураторе зайти в "оптионс" и найти вкаладку "edit catalog profile" в открывшемся редакторе в главном меню выбрать импорт - найти этот файлик и дать новое название каталогу - все работает, таким образом я импортировал себе каталог для версии 5.3...

Re: Загрузка в CPU314C-2 PtP
Юрчик; 4.10.04

Не приживается - вместо интересующего меня контроллера отображается строка с с его типом, но вместо иконки контроллера показана иконка "каталога", как в проводнике.


text

Как увязать 315-2DP с CP342-5?
Виктор; 16.6.04

Столкнулся со следующей проблемой.

Существует две системы на основе контроллера S7-300 c ЦПУ S7 315-2DP (6ES7315-2AG10-0AB0). Для связи друг с другом используется Profibus-DP. С первой стороны законфигурирован внутренний канал ЦПУ как мастер, с другой - используется коммуникационник CP342-5 (6GK7342-5DA02-0XE0, v.5.2.8), настроенный как пассивный DP-Slave. Все настройки выполнялись в соответствии с документацией по Profibus-DP, выложенной на этом сайте.Участники сети упорно не хотят видеть друг друга. Физически подключение работает. Обмен удалось осуществить, установив в первую систему CP342-5 и настроив его мастером. Обмен осуществлялся с помощью функций DP_SEND и DP_RECV.
Вопрос. Почему не проходит первый вариант? На что обратить внимание? Это случаем не глюк нового ЦПУ?
Заранее благодарен.

Re: Как увязать 315-2DP с CP342-5?
Гуленок Андрей; 16.6.04

А программу обмена в слейв загрузили? Коммуникационник без блоков работать не будет, даже BF не погасит.

Re: Как увязать 315-2DP с CP342-5?
Виктор; 16.6.04

Была такая мысль, но она не сработала...

Re: Как увязать 315-2DP с CP342-5?
Илья; 28.9.04

DP_SEND/DP_RECV работают только в СР! Через встроенный в ЦПУ интерфейс они работать не будут. Учите матчасть, господа.

П.С. Я бы, наверное, сделал S7-connection...<


text

где найти полную информацию по интерфейсу RS485
alexi; 24.9.04

пришлите ссылки или информацию

Re: где найти полную информацию по интерфейсу RS485
Чистяков Дмитрий ОАО СеверСталь; 24.9.04

Ну, например, здесь

http://mayak-bit.narod.ru/rs485.html
А вообще поисковики выдают кучу ссылок по строке запроса типа:
"RS-485" описание
Re: где найти полную информацию по интерфейсу RS485
Григорий; 27.9.04

Журнал СТА 2 1997г

Re: где найти полную информацию по интерфейсу RS485
Павел Кобелев; 28.9.04

В техническом руководстве по сети Profibus (по ссылке) есть описание RS-485

См. Документация


text

Вопрос по Simatic
aeg; 26.9.04

Суть проблемы в следующем: сталкиваюсь уже третий раз При попытке просмотреть функцию в Step7 v5.1 SP3 в online контроллер переходит в STOP. 315-й контроллер связан с программатором через коммуканиционный процессор через Industrial Ethernet. В сети всего 6 контроллеров и 3 станции SCADA. Simatic Net на той станции с которой ведется программирование стоит без лицензии. Проблема возникает только при попытке просмотреть только эту функцию с другими всё нормально (обычный FC только в нем много циклических переходов, но ошибок нет железно)такое случается 1 раз из 100 может реже. В диагностическом буфере пишет что превышено время цикла и все три раза показывал на разные места. В нормальном режиме время цикла 60мс Вопрос может ли включение режима online увеличить время цикла или причина в другом

Re: Вопрос по Simatic
Юрий Оганесян; 27.9.04

Увеличь HW Config->CPU XXX->Object Properties -> Cycle/ClockMemory ->Scan Cycle Load from Communication (%)

Re: Вопрос по Simatic
Юрий Оганесян; 27.9.04

Увеличь HW Config->CPU XXX->Object Properties -> Cycle/ClockMemory ->Scan Cycle Load from Communication (%)

Re: Вопрос по Simatic
Михаил; 27.9.04

Да действительно увеличение сетевого обмена действительно может увеличить время цикла процессора. Попробуй в режиме online во вкладке plc\modul information\scan cycle time пощелкать быстро кнопку update и вы увидите как увеличивается текущее время цикла взависимости от того как быстро вы щелкаете. И действительно когда вы в онлайне открываете свой FC может происходить иногда превышение времени цикла.

Есть несколько способов от этого избавится:
1. Да действительно как написал Юрий Оганесян можно изменить Scan Cycle Load from Communication (%) по умолчанию там обычно ставиться 20%, но (пусть юрий меня извинит) его надо не увеличить а уменьшить. Так как это устанавливается макс % загрузки CPU на задачи связанные с комуникациями.
2. Либо увеличить Scan Cycle Monitoring Time ну поставить его больше того времени по которому перешел CPU в стоп.
3. Самый простой способ так как не требует перезагрузки system data и может быть осуществлен при запущенном CPU без его останова. Это добавить в программу еще один блок OB80 пустой и загрузить его в CPU, тогда процессор при превышении времени цикла не будет переходить в стоп а будет вызывать этот блок который ничего не делает и потом дальше будет прдолжать работать.<


text

CPU не видит OB86
Александр Клейн; 21.9.04

При аварии блока питания станции ET200M процессор CPU414-3 не видит запрограммированного блока ОВ86 и переходит в режим СТОП. Что-то где-то еще надо включить или этот ОВ86 к станциям децентрализованной периферии не относиться?

Re: CPU не видит OB86
Чистяков Дмитрий ОАО СеверСталь; 22.9.04

Я так всегда ставлю сразу несколько OB обработки ошибок OB81 - OB87.

Дело в том, что при отстутствии связи со станцией ET200M возникает сразу несколько ошибок.
Re: CPU не видит OB86
Александр Клейн; 22.9.04

Поставил все эти блоки ОВ81-ОВ87. Не помогло. А эти блоки могут быть пустыми или там обязательно надо что-нибудь написать?

Re: CPU не видит OB86
Ланецкий; 22.9.04

У Вас этот ET200M случайно не последний на кабеле Profibus?

С уважением,
Ланецкий.

Re: CPU не видит OB86
Александр Клейн; 22.9.04

Этот ЕТ200М единственный на кабеле.

Re: CPU не видит OB86
Павел Кобелев; 23.9.04

А вы уверены что он у вас в стоп из-за этого переходит? Вы буфер диагностики CPU смотрели? Там что написано по поводу стоп-а?

Re: CPU не видит OB86
Ланецкий; 23.9.04

Уважаемый Александр,

если Ваш ET200M единственный на Profibus или последний на кабеле, то при отключении у него питания выходит из строя сеть Profibus. В этом случае самый дешёвый выход - поставить 6ES7 972-0DA00-0AA00, запитанный от блока питания контроллера или любого другого БП, включенного во время работы контроллера, и добавить OB, отвечающие за обработку ошибок.
Всего наилучшего,
Ланецкий.
Re: CPU не видит OB86
Ланецкий; 23.9.04

Прошу прощения. Терминатор с этим номером подключить к концу кабеля Profibus, а всю периферию включать в разрыв кабеля между этим терминатором и контроллером.

Всего наилучшего,
Ланецкий.
Re: CPU не видит OB86
Александр Клейн, ООО "ВК-Инжиниринг"; 23.9.04

Проблема решена. Дело в том, что в перечне ошибок из диагностики ЦПУ, которые возникают в данной ситуации есть такая: I\O access error, reading. Details on event: P area, double-word access. Requuested OB: I/O access error OB (OB122).

Засылка в контроллер блока ОВ122 решила проблему. Большое всем спасибо за подсказку.<


text

OB1
roman; 6.9.04

Re: OB1
Дертунов Борис; 7.9.04

Если это в проекте на Step7 в РС -значит некорректно написан сам блок - нужно заново написать. А в PLC такой блок не грузится - и его свободно можно посмотреть в режиме online.

Re: OB1
roman; 7.9.04

Программа была загружена из PLC.

Ни в PC, ни в onlin-е OB1 не открывается.
Re: OB1
GorA; 8.9.04

Попробуйте установить SCL.

И снова открыть.
Re: OB1
Валентин; 17.9.04

Скорее всего в Вашем ОВ1 вызывается несуществующий блок. В STEP5 такое явление наблюдается при вызове в ОВ1 несуществующего FB.

Re: OB1
Mennonit; 20.9.04

1. Выбери язык STL или

2. В едиторе выбираешь "Options" -> "Customize"->"LAD/FBD"->убери галочку "Type check of Adress"
Re: OB1
roman; 20.9.04

гадочку убрал-ничего не изменилось


text

Переполнение GD Table
Михаил; 20.9.04

Подскажите пожалуйста такая у меня задачка, Есть 2 контроллера CPU315-2DP они связаны по MPI друг с другом через GD Table, причем GD Table забита под завязку. Мне необходимо подсоеденить к этим двум третий контроллер тоже CPU315-2DP и считывать с первых двух некоторые данные. В GD Table я уже добавить ничего немогу. Возможно ли всетаки еще связаться кроме GD Table с помощью X_GET, X_PUT. И не будет ли вся эта связь сильно тормозить. И с чем связано ограничение GD Table. Может какойнибудь другой способ подскажите?

Re: Переполнение GD Table
Чистяков Дмитрий ОАО СеверСталь; 20.9.04

Смотрите здесь

http://www.automation-drives.ru/cgi-bin/forum/forum.cgi?dir=1008101941&root=1092638900&year=2004
Re: Переполнение GD Table
Чистяков Дмитрий ОАО СеверСталь; 20.9.04

Смотрите здесь

http://www.automation-drives.ru/cgi-bin/forum/forum.cgi?dir=1008101941&root=1092638900&year=2004
См. http://www.automation-drives.ru/cgi-bin/forum/forum.cgi?dir=1008101941&root=1092638900&year=2004


text

Вопрос по преобразованию из формата PG675 в формат Dos
Александр Кудерков; 15.9.04

Подскажите кто нибудь если в природе утилитки способные пеобразовать формат PG675 в формат Dos, если кто имеет информацию об этом, просьба поделиться, за ранее благодарен

мой адресс appolon321@mail.ru
Re: Вопрос по преобразованию из формата PG675 в формат Dos
Pavel; 15.9.04

PG675 работает в формате PCP-M.

Что-то раньше было для преобразования.
А какя задача стоит конкретно.
Re: Вопрос по преобразованию из формата PG675 в формат Dos
Андрей; 16.9.04

Программы PDIR и PCOPY из под ДОС могли работать с дисками РСРМ-86 но если необходимо работать с файлами STEP5 для PG675 то мне приходилось с помощью PG685 преобразовывать данные дискеты в файл, а затем уже их передавать с помощью программ (см. выше)на дискетах или с помощью STEP5(для PG685) по кабелю.

Re: Вопрос по преобразованию из формата PG675 в формат Dos
Pavel; 17.9.04

Я кажется ошибся. PCP-M это операциока

для первых версий PG685,потом они туда
тоже стали стасить ДОС, а на 675 была
еще СР-M86.
ковертацию как предложено тоже делали,
но не всегда корректно получалось,
особенно для 150S,U.
Есть еще дубовый способ, перекачать программу с 675 в какой либо контроллер, а потом сдуть ее оттуда
в нужном формате.<


text

Блоки S5
Lego; 4.3.04

Можно ли в STEP5 закрыть FB от просмотра и редактирования (вроде know-how protection)

Re: Блоки S5
Pavel; 9.3.04

Поробуй пойти по пути Сименса.

Пишешь заголовок блока с перемнными,
затем :SPA M001
:BE
M001:
Программатор при выводе, после ВЕ
будет отображать тоько заголовок блока
Re: Блоки S5
Lego; 11.3.04

Таким образом были "закрыты" FB, скачанные мной с кокого-то сайта, но путем несложных манипуляций их можно открыть. А вот закрыть готовый блок не получается т.к после ввода команды BE step5 уже ничего не видит и говорит, что M001-неправильный идентификатор.

Re: Блоки S5
Павел; 15.3.04

Пятерка нормальная система и раньше

ставить пароль на всякий чих было
неинтелигентно. Сейчас пошла мода
закрывать все что можно, иногда до дури
когда пароль длиннее программы
Re: Блоки S5
Lego; 24.4.04

Не очень-то хочется дарить свою работу кому-то.

Re: Блоки S5
andrey; 24.4.04

Годам 4 назад я закрывал FB. Делал это через шестнадцатеричный код. Чтобы вспомнить нужно поковырятся некоторое время. Вообще-то есть несколько способов. Описаный сдесь выше самый простой и неудачный, при открытии блока через второй сегмент он, естественно, открывается. Тема большая, не для форума, если очень надо, свяжись по мылу, пообщаемся

Re: Блоки S5
Romanov; 17.9.04

У кого есть документация по S5-95U просьба выслать по адресу: aar75@ngs.ru


text

Дополнение к вопросу по преобразованию формата PG 675 в Dos
Кудерков Александр; 16.9.04

имеется ряд дискет с документацией и исходниками программ, вот из-за этого и нужно и преобразовать данные файлы в досовский формат


text

Модуль IM318-8
Alex_Juris; 16.9.04

Сообщите пожалуйста где можно найти информацию на коммуникационный модуль IM318-8 для ET100 контроллеров S5 серии

Спасибо<


text

FM355C в составе ET200M
roma; 15.9.04

Необходимо установить станцию ET200M в цехе удаленностью от AS 414-4-1H примерно метров 50-70. (В системе помимо проектируемой станции установленно еще 3 ET200M.) При этом стоит задача о регулировании 4 - мя температурами, плюс снятие других аналоговых величин о процессе, т.е. определено, что в составе ET200M содержатся SM331, SM321, SM322 и FM355C.

Возникают следующие вопросы:
1. Какой интерфесный модуль выбрать?
В документации указано что необходим IM 153-2 FO (с каналом связи оптоволокно), но в HWConfig FM355C удачно встает и на IM 153-2 без оптоволокна?
2. Нужен ли для данной протяженности канала связи Profibus повторитель?
3. Подскажите код для заказа 9-полюсного штекера соединителей D - типа
4. Как это повлияет на работу FM455C установленного локально в AS?
Re: FM355C в составе ET200M
Павел Кобелев; 16.9.04

1. Оптоволокно не обязательно

2. Максимальная длина Profibus-сегмента без повторителя составляет 1000м при скорости 9,6-187,5; 400м при 500кБит/с; 200м при 1500кБит/с; 100м при 12мБит/с. В вашем случае без повторителя должна обеспечиваться максимально возможная скорость.
3. Они разные бывают. Вам для чего нужно?
4. Никак повлиять не должно.
Re: FM355C в составе ET200M
roma; 16.9.04

Штекер необходим для подключения проектируемой станции ET200M c IM 153-2 к системе.

В нашей системе используются со следующими заказными номерами
6ES7 972-0BB12-0XA0 (подключен к CPU, а также на последней станции);
6ES7 972-0BA30-0XA0 (на остальных станциях)
Данных устройств в каталоге оборудования я не увидел.
Re: FM355C в составе ET200M
Павел Кобелев; 16.9.04

Смотрите по ссылке. Там в "технической спецификации" табличка есть.

См. ссылка


text

Сохранение даты/времени в С7-635
Николай; 15.9.04

Есть ли в С7-635 батарейка, которая держит установки даты/времени при отключении питания панельки? Подскажите, плиз, начинающему юзеру. В документации ничего на эту тему не нашел

Re: Сохранение даты/времени в С7-635
Павел Кобелев; 16.9.04

C7-635 внутри содержит S7-314C-2DP, у которого буфферной батареи нет.


text

Необъяснимое появление задержек
Panyov Konstantin; 7.9.04

Уважаемые господа! Имел ли кто-нибудь из вас дело с модулями телеметрии фирмы Siemens (такими, например как TIM32, TIM42). Если да, то подскажите, почему, при потере связи с КП (TIM32 + CPU315-2DP)появляются задержки при передаче данных от других КП. Мы установили, что эти задержки не результат неверных настроек ST7cc, так как при передаче данных через 400-й контроллер (наша старая конфигурация TIM42 + CPU416 на ПУ) они тоже имеют место. Вероятно тут что то с TIM42???

Re: Необъяснимое появление задержек
Дмитрий; 16.9.04

Зджравствуйте Константин, попробуйте посмотреть документацию по организационным блоком там вроде бы что-то было на эту тему


text

описание ПМК SIMATIK S5-155U
Сергей; 3.9.04

Подскажите, пожалуйста, где можно найти описание ПМК SIMATIK S5-155U

Заранее благодарю.
Сергей Лимарь
Re: описание ПМК SIMATIK S5-155U
Alex; 3.9.04

Какие-то проблемы с сервером, проверь указанный адрес.

Re: описание ПМК SIMATIK S5-155U
GorA; 5.9.04

Полистайте здесь - http://www4.ad.siemens.de/-snm-0135030360-1093967001-0000013979-0000002846-1094355904-enm-WW/llisapi.dll?func=cslib.csinfo&lang=en&siteid=cseus&aktprim=0&startNode=4000024&nodeID0=10805127&basisview=4000003&viewLevel=6&wttree=cs&foldersopen0=-170-171-172-184-210-&jumpto=210

Re: описание ПМК SIMATIK S5-155U
Павел Иванов; 15.9.04

а этом сайте есть каталог на русском языке по S5, а также руководство по S5-115/-135/-155H(CPU948H). В принципе они похожи.

Есть также отдельное руководство по модулям входов-выходов, оно тоже есть на сайте.
На центральном сайте поддержки есть руководства на английском и т.д. языках.
В принципе в свое время было руководство по ЦПУ 946/947 на русском языке в бумажном виде, но его никто не переводил в электронный.<


text

Где найти документацию FM 351 на русском
Сергей; 6.9.04

Re: Где найти документацию FM 351 на русском
Павел Иванов; 15.9.04


text

ET200M
roma; 6.9.04

Возможно ли на ET200M c IM 153-1 установить FM355C?

Re: ET200M
Назаров Дмитрий; 6.9.04

Можно.

Re: ET200M
Михайлин Сергей; 6.9.04

Дима и все остальные, осторожнее.

Не все FM поддерживаются IM153-1!
Всегда следует создать тестовую конфигурацию в STEP7 и посмотреть на результат.
Поддержка зависит от версии IM153-1 и версии FM.
Re: ET200M
Назаров Дмитрий; 6.9.04

Сергей! Я так и делаю. Взял IM153-1 последней модели и поставил туда FM355C последней модели. STEP7 не запретил мне этого. А поскольку вопрос "Возможно" без подробностей то и ответ краток.

Re: ET200M
roma; 15.9.04

Ну во-первых, попытка собрать конфигурацию в HWConfig на IM153-1 и FM355C у меня не увенчался успехом.

Во - вторых, необходимо установить станцию ET200M в цехе удаленностью от AS 414-4-1H примерно метров 50-70. При этом стоит задача о регулировании 4 - мя температурами.
Возникают следующие вопросы:
1. Какой интерфесный модуль выбрать?
В документации указано что необходим IM 153-2 FO (с каналом связи оптоволокно), но в HWConfig FM355C удачно встает и на IM 153-2 без оптоволокна?
2. Нужен ли для данной протяженности канала связи Profibus повторитель?
3. Подскажите код для заказа 9-полюсного штекера соединителей D - типа<


text

s7-200 и TCP/IP
Ден; 8.1.04

Коннектится данный контроллер с пк через Ethernet?

Re: s7-200 и TCP/IP
Unity; 8.1.04

В одном из номеров "СТА" за 2003г. в новостях сообщалось о выпуске Siemens'ом коммуникационника для Ethernet для 200-х S7. Смотрите в новом каталоге.

Re: s7-200 и TCP/IP
Назаров Дмитрий; 9.1.04

Заказной номер IE процессора 6GK7243-1EX00-0XE0 - 390 Евро L-Price, IE IT процессора 6GK7243-1GX00-0XE0 - 540 Евро L-Price.

Re: s7-200, TCP/IP, Protool
Den; 9.1.04

Возможно ли создание на базе s7-200 полноценной визуализации с исп ProTool на ПК + выгрузка из него данных в БД на ПК?

Re: s7-200 и TCP/IP
Роман Абзаев; 9.1.04

На Customer Support & Service посмотрите ID 14935877 Ethernet communication between a ProTool/Pro Runtime (PC) and a CP243-1 (S7-200) от 29 сентября 2003 года и, если есть желание, 14587200

См. Смотри здесь

Re: s7-200 и TCP/IP
svs; 10.9.04

Возможно ли создание на базе s7-200 полноценной визуализации с исп ProTool на ПК + выгрузка из него данных в БД на ПК используя кабель pc/ppi ?

Re: s7-200 и TCP/IP
Ден; 11.9.04

Возможно и данное решение работает только не по PPI а через CP243-1. По ppi до 20 тегов и очень глючно и медленно.

Re: s7-200 и TCP/IP
Marat; 14.9.04

Ден, откуда такая цифра - 20 тегов?

У меня тоже сначало было о-очень медленно, пока не поставил в настройках Advanced PPI.<


text

Радиоканал между S7 222 и PC
Alexander; 7.9.04

Необходимо организовать двухстороний обмен данными между пятью PLC S7 200 (CPU222) и PC по беспроводному соединению. Не требуется создание системы реального времени, допускается поочередное соединение с каждым из PLC. Если у кого то есть опыт внедрения или сопровождения подобных проектов подскажите состав программно(PC)аппаратной части. Заранее благодарен.

Re: Радиоканал между S7 222 и PC
Yuriy Pesha; 7.9.04

на какое расстояние разнесены устройства ?

какой объем информации предполагается к передаче , и с какой желаемой скоростью ?
Re: Радиоканал между S7 222 и PC
Alexander; 7.9.04

Максимальное расстояние (PC PLC) примерно 300м. Объем информации 2-3Kb за сеанс связи, может даже и меньше. К скорости никаких требований нет, возможна низкая скорость.

Re: Радиоканал между S7 222 и PC
Павел Кобелев; 8.9.04

Для организации radio-ethernet можно использовать модули Scalance W:

SCALANCE W744-1PRO (Client Module)
SCALANCE W788-1PRO (Access Point) SCALANCE W788-2PRO (Dual Access Point)

документация:
http://www4.ad.siemens.de/-snm-0135030360-1093967001-0000003426-0000000172-1094607373-enm-WW/skm/newSKM/frameset.asp?markerurl=%2FWW%2Fllisapi%2Edll%3Ffunc%3Dll%26objID%3D19384623%26objaction%3Dcsview%26lang%3Den%26siteid%3Dcseus&option=manual&showoptions=false&lang=en&searchID=0135030360109396700100000034260000000172&firstload=no&siteid=cseus&query=Scalance+w&hitsPerSite=10&BID=19384623&cur_pos=0

http://www4.ad.siemens.de/-snm-0135030360-1093967001-0000003426-0000000172-1094607373-enm-WW/skm/newSKM/frameset.asp?markerurl=%2FWW%2Fllisapi%2Edll%3Ffunc%3Dll%26objID%3D19386812%26objaction%3Dcsview%26lang%3Den%26siteid%3Dcseus&option=manual&showoptions=false&lang=en&searchID=0135030360109396700100000034260000000172&firstload=no&siteid=cseus&query=Scalance+w&hitsPerSite=10&BID=19386812&cur_pos=0
Re: Радиоканал между S7 222 и PC
Alexander; 8.9.04

А кто то использовал модули модули Scalance W...?

Re: Радиоканал между S7 222 и PC
Alexander; 8.9.04

В частности интересует возможность использования модулей Scalance W... с PLC S7 200, с S7 300 - понятно, а вот с S7 200 :-(

Re: Радиоканал между S7 222 и PC
Андрей Гуленок; 8.9.04

Откуда опыт, скальянс только-только вышел.

Вообще решений море. Если коротенько, то либо платить за аппаратную часть, программная приложится (как в случае с изернетом), либо дешёвая аппаратная часть при солидных затратах на программирование. В принципе можно использовать любые RS485 радиомодемы, мне лично известны положительные примеры на "Неводах" и сателовских Эпиках. Если работать в режиме свободного порта, то можно воплотить любые фантазии, всё зависит от исскуства программиста. Можно реализовать модбас и даже профибас, но тогда появляются определённые (и порой дорогие) требования к аппаратной части.
Re: Радиоканал между S7 222 и PC
Vladimir; 9.9.04

Есть вариант когда используется СР241-коммуникационный модуль для Ethernet и Wireless модемы у PLC PC.

В этом варианте контроллер ведет себя как подключенный проводом к PC.Расстояние зависит от типа антенны.
Re: Радиоканал между S7 222 и PC
Чистяков Дмитрий ОАО СеверСталь; 10.9.04

Только вот цифра 300 метров говорит о том, что придётся ставить ретрансляторы.

И ещё - какие условия? Цех, поле, здание железо-бетон и т.д.?
Я думаю, что в тяжёлых промышленных условиях, радиосвязь окажется дороже проводной.
Re: Радиоканал между S7 222 и PC
Михаил_SMV; 10.9.04

Насчет радиосвязи. Частоты, эфирный ресурс - это я об инспекции электросвязи или как там ее. Даже на

300 м. И о возможных помехах.
(т.е. наличие канала - не гарантировано, в отличие от проводного).
Если работает в "свободном диапазоне" -
должна быть "местная" лицензия СНГ.

<


text

Гальваноразвязка входов в SIMATIC S7 200
Denis; 9.9.04

Здравствуйте.

Помогите кто знает: действительно ли у контроллеров
SIMATIC S7 200 (с питанием от постоянного тока +24В) вход питания не
гальваноразвязан с логикой контроллера? Необходимость уточнения
данного момента вызвана тем, что в контроллерах с питанием =24В, клемма
"М" входа питания контроллера, клемма "М" выхода блока питания датчиков и модулей
расширения, и клеммы "1М" и "2М" дискретных входов контроллера имеют
гальваническую связь и в этом случае совершенно непонятен смысл
гальваноразвязки дискретных входов контроллера, т. к. в любом случае мы получаем
гальваническую связь (посредством клемм "1М" и "2М" дискретных входов) с 5-ти
вольтовой логикой контроллера через вышеупомянутую гальваническую
связь клемм "М", "1М" и "2М" (если конечно действительно правда, что
вход питания не отвязан от логики).
Re: Гальваноразвязка входов в SIMATIC S7 200
Андрей Гуленок; 10.9.04

А с чего вы взяли, что они гальваносвязаны? Достаточно взять мультиметр чтобы убедиться, что Мпитания и Мвходов\выходов изолированы друг от друга. А внутренний источник никто и не обещал гальваноразвязанным. Хотите полную гальваноразвязку - пожалуйста. Запитывайтесь извне. Хоть из четырёх источников. Если это не критично - можно всё посоединять и работать от одного источника.

Re: Гальваноразвязка входов в SIMATIC S7 200
Denis; 10.9.04

1.В том-то все и дело, что я взял тестер и прозвонил клемму М входа питания контроллера =24В, клеммы 1М и 2М дискретных входов и клемму М встроенного в контроллер источника питания =24В и они ГАЛЬВАНОСВЯЗАНЫ!!! И в случае если я даже возьму другой источник питания (именно так я и хотел сделать сначало), то по любому получу гальваническую связь по общему проводу c 5-ти вольтовой логикой контроллера (если конечно питание =24В не имеет развязки с логикой, а именно так и написано в руководстве по эксплуатации).

2. И потом вопрос был не по гальваноразвязке встроенного в контроллер источника питания =24В, а о гальваноразвязке питания контроллера (=24В) и логики контроллера.
P.S. Все вышеперечисленное касается только контроллеров с питанием от =24В (с питанием от ~220В не проверял - нет живого образца). А клеммы М ВЫХОДОВ действительно гальваноразвязаны.

Re: Гальваноразвязка входов в SIMATIC S7 200
Андрей Гуленок; 10.9.04

Странно, у меня М на входах и М на обоих питаниях не звонится. Да и если на плату посмотреть, там батарея оптронов стоит. А логика, да, она связана с внешним 24. Там стоит импульсный стабилизатор, но он именно стабилизатор. Там вообще на нижней плате почти ничего нет. Стоит проходной фильтр, защита и несколько ёмкостей. 24в просто проходят плату насквозь. Особнячком стоит маленький трансик с микросхемой ключевого стабилизатора +5В но он не даёт развязки. Зачем, напряжение то низкое. А вот входа-выхода отвязаны батареями оптронов и М в каждой группе своя.

Re: Гальваноразвязка входов в SIMATIC S7 200
Denis; 10.9.04

Взял другой контроллер, прозвонил его клеммы М - не звонятся. Значит, что-то с первым контроллером не то. Буду разбираться.

Андрей, спасибо что откликнулись на вопрос.<


text

cpu 224 и MPI
Владимир; 8.9.04

Можно ли программировать CPU 224 через MPI с нуля? Имеется ввиду не подключаясь к нему первоначально по PPI и не производя никаких настроек.

Поддерживает ли Step7 MicroWIn MPI/USB адаптер?
Re: cpu 224 и MPI
kot; 9.9.04

нет

Re: cpu 224 и MPI
Андрей Гуленок; 10.9.04

Да.

MicroWin 4.0 + адаптер V1.1.
<


text

TD200 и модем к одному порту?
Alexander; 9.9.04

Возможно ли подключить TD200 и модем к одному порту PLC?

Re: TD200 и модем к одному порту?
Андрей Гуленок; 9.9.04

Подключить то можно, только работать не будет.

Re: TD200 и модем к одному порту?
Alexander; 9.9.04

Просто надо как то выкрутится... Контроллер с одним портом (222) и TD200 обязательно нужен... а с модемами,подключёнными к ПЛК, работать не приходилось... Кто то выдаст вариант?

Re: TD200 и модем к одному порту?
Павел Кобелев; 10.9.04

Есть же модуль специальный EM 241 к S7-200. Или я чего не понял?

Re: TD200 и модем к одному порту?
Андрей Гуленок; 10.9.04

Зачем выкручиваться. Достаточно прочитать инструкцию. Там всё написано, и про ЕМ241 и про ЕМ277.

Re: TD200 и модем к одному порту?
Alexander; 10.9.04

Все понятно! Всем спасибо! Задача стоит, как всегда..., минимизировать затраты... но я так думаю что всётаки придётся раскошелиться... :-)

<


text

SIMATIK S5-155U
Сергей Лимарь; 3.9.04

Помогите найти тех. описание пмк SIMATIK S5-155U

Re: SIMATIK S5-155U
Чистяков Дмитрий ОАО СеверСталь; 10.9.04

А вообще-то с права на этой странице стоит "Быстрый переход", который и отвёл бы Вас к документации. ;-)

http://www.automation-drives.ru/as/products/simatic_s5/90/index.php<


text

MMC накрылась или нет?
Vinsent; 25.8.04

купили значит карту MMC 512 KB (2 шт)к CPU 315-2DP ну 2AG10 который,

Одна работает все нармально, а другая когда ее фтыкаешь в CPU и потом вкл. питание индикатор стоп мигает сначало быстро потом медленно, и кароче так и мигает медленно желтеньким, связи PG с CPU нет. Вопрос накрылась ли эта MMC или можно ченить сделать с ней?

Re: MMC накрылась или нет?
Чистяков Дмитрий ОАО СеверСталь; 25.8.04

Подождите какое-то время (минут несколько), а потом пытайтесь связаться с контроллером подбирая параметры связи (скорость и протокол (MPI/DP). Скорее всего в карте "сидит" проект, который инициализирует свою конфигурацию.

Re: MMC накрылась или нет?
Михаил_SMV; 27.8.04

Есть шанс.

1. Как мне и советовали здесь насчет аналогичной проблемы - самое оптимальное - воткнуть MMC в программатор Siemens из серии Simatic PG. Сразу будет видно - жива али нет.
Отформатировать.
2. Можно поэкспериментировать с режимами Reset на процессоре, но это по моему - глухой номер.
3. Если карточка уже работала, т.е. на ней что-то прописано, то я думаю есть в информации, хранящейся на MMC привязка к конкретному процессору. И на другом экземпляре CPU она может не работать в принципе. (надежность, Б_Л_И_Н !)
(см. п.1) Это есть моя гипотеза чайника(С).
Re: MMC накрылась или нет?
Михаил; 27.8.04

->Михаил_SMV

Ну вот есть у нас Field PG, и куда ее там фтыкать?
Re: MMC накрылась или нет?
docent; 27.8.04

в дЫрдочку :)

Re: MMC накрылась или нет?
Михаил_SMV; 7.9.04

Hi. Нашел у кого спросить. (т.е. SMV)

цитата из "меня" - "ах, если бы у меня был Field PG". А информация у меня из каталога Siemens ST70/2001/2 -
стр.9-3. (состав Field PG).
А насчет "дЫрдочки" - правильно.
Скорее всего слева сбоку. или справа.
Re: MMC накрылась или нет?
Михаил; 7.9.04

->Михаил_SMV

Да некуда там засунуть MMC это гон нкжен пади еще адаптер какойнить который стоит наверно миллион
Re: MMC накрылась или нет?
Павел Кобелев; 8.9.04

->Михаил

В Field PG слева есть 2 слота. Сверху большой под старые "большие" карты, под ним маленький слот под MMC. Рядом есть рисунок как правильно соориентировать карту в пространстве перед помещением ее в этот слот.
Re: MMC накрылась или нет?
Павел Кобелев; 8.9.04

->Михаил

Почитайте документацию на край. На странице 3-18 даже картинка есть.
См. Документация

Re: MMC накрылась или нет?
Михаил; 8.9.04

->Всем

хе-хе, извините блин, нашел я всетаки дЫрдочку. Сроду бы не подумал что она там есть :) Но это все равно не помогает карточка неисправна. <


text

Нестандартный протокол
mahsus; 20.7.04

Привет всем!

Скажите, может ли программируемый контроллер Siemens (какой-либо) работать с нестандартным протоколом. В данном случае шестиканальный термометр ТМ5101 фирмы "Элемер" с таким протоколом обмена:

скорость обмена - 9600 бит/сек (может изменяться);
информационная длина слова - 8 бит;
бит паритета - нет;
кол-во стоп-битов - 1.

:<номер прибора>;<команда>;<операнд1; ... ;операндN>;<контрольная сумма><CR>

Т.е. он собирает аналоговые сигналы с датчиков, проводит метрологическую аттестацию и на выходе у него уже цифровые сигналы (информация о всех датчиках). Я хотел бы подключится к такому прибору. Подскажитеб можно ли это сделать.
Заранее благодарен за ответ.
Re: Нестандартный протокол
kot; 20.7.04

S7-200 режим freeport

Re: Нестандартный протокол
sv; 21.7.04

подойдёт любой коммуникационный процессор с поддержкой ASCII протокола (просто приём/передача массивов байтов).

для формирования/разбора данных писать свою програмку.

правда есть ограничение - скорость, количество битов данных, четности, стопа конфигурируются один раз и в процессе работы не могут меняться.

какой именно коммуникационный процессор и центральный процессор выбрать зависит от сложности обработки данных и финансовых возможностей.
Re: Нестандартный протокол
Marat; 7.9.04

Решал такую же задачу для связи с термоподвесками. Проще всего это сделать на s7-200, используя режим свободнопрограммируемого порта.

Параметры связи можно менять программно в процессе работы.

Особенностью связи с термоподвеской было то, что первый байт (номер подвески) должен всегда содержать выставленный бит четноси. При отправке запроса пришлось проверять на четность адрес устройства и параметрировать порт на контроль четности или контроль нечетности.

Я думаю что на другом контроллере Siemens такое сделать невозможно.

Единственное ограничение: для всех конфигурации параметров связи генерируется один стоповый бит.<


text

без батарейки и без авторизации
fog; 1.9.04

Есть CPU315-2DP, нет батарейки и авторизации на STEP7. Гружу hardware configuration - начинает моргать BUSF (ключ ещё находится в положении STOP).

Вопрос: если программно сконфигурировано всё правильно (хотя бы со стороны мастера), то может ли отсутствие авторизации и/или батарейки привести к ошибке?
Re: без батарейки и без авторизации
Михайлин Сергей; 6.9.04

Нет! Отсутствие авторизации или батарейки не может привести к BusFault. У вас не правильно сконфигурирован DP интерфейс.


text

CP343-2
simag; 3.9.04

К CPU312 через CP343-2 подключена ASI-шина.

Подскажите, иеется ли возможность с помощью
программатора (со STEP7)посмотреть состояние
датчиков на ASI-шине?

Re: CP343-2
Назаров Дмитрий; 6.9.04

Раз СР343-2 опрашивает датчики по AS шине, значит и возможность посмотреть их состояние есть. Только надо изучить руководство на СР343-2 и понять куда эта информация записывается. Если память не изменяет, в блок данных.


text

to Eugene Sergeev
ChD; 1.9.04

Дока по CP 341-RS422/485 -- Eugene Sergeev -- 2004-07-14 10:30:30 Где-то с месяц назад качал - все нормально было.

А кстати - там примерчики, которые на диске идут, так там ошибка есть, смещение в модуле неправильно указано - день парился, пока разобрался...

если можно, поподробнее, плиз, о каком смещении идет речь?<


text

S7 200 и ProfiBus DP
Denis; 31.8.04

Здравствуйте!

Подскажите пожалуйста, кто знает наверняка:
1. Возможна ли корректная работа контроллера SIMATIC S7 200+коммуникационный модуль расширения EM277 (6ES7277-0AA21-0XA0) в сети ProfiBus DP, где в качестве mastera выступает IBM PC-совместимый контроллер с коммуникационной картой Hilscher? Ну и вообще в сети с контроллерами от других производителей?
2. Имеет ли коммуникационный модуль расширения EM277 (6ES7277-0AA21-0XA0) сертификат PNO?<


text

Срочно нужна помощь
Николай; 31.8.04

Можно ли подключать клапаны и датчики (24) В через разъем PORT 0 или Е-Stand 1.0 на контроллере CPU 224 и управлять ими? Если можно то где можно посмотреть как это можно сделать?

Re: Срочно нужна помощь
Павел Кобелев; 31.8.04

Вы документацию на 22x читали?

См. Документация


text

USB - PPI -Проблема
Alex; 25.8.04

Преобрёл кабель USB - PPI для S7-200 а всё програмное обеспечение не берёт его.

Помогите!!!
Re: USB - PPI -Проблема
Андрей Гуленок; 30.8.04

Надо обновить программное обеспечение. Уже вышел MicroWin V4.0, он этот кабель "умеет" без проблем.

Re: USB - PPI -Проблема
Алекс; 30.8.04

У меня есть это прогр SP4. Его не находит OPS server, и SIMATIC WinCC flexible 2004 Micro.


text

диапазон температур
Владимир; 30.8.04

Скажите пожалуйста рабочий диапазон температур для outdoor

Re: диапазон температур
Андрей Гуленок; 30.8.04

Как правило -25 +70


text

Kommunikazija s s7 300 314c
Vital; 26.8.04

Wopros: ja soedenil PC(RS232) s s7 300 314c DP 4eres RS232-RS485-Adapter. Is programmi posilaju Request-Telegrammu (cho4u usnatj sna4enie po sadannomu adressu), kak polo>|<eno v Profibus-Protokolle, no ne polu4aju nizego v otwet. Esli kto-to uze zto-to podobnoe programmirowal, pomogite - mo>|<et ja 4ego ne propustil?

pomogite
Re: Kommunikazija s s7 300 314c
Павел Кобелев; 27.8.04

Конкретней пожалуйста. Вы к контроллеру вообще доступ имеете? К какому порту подключены? Какой интерфейс (Set PG-PC interface)установлен? Какие параметры порта?

Re: Kommunikazija s s7 300 314c
Vital; 27.8.04

pro dostup ja ne w kurse? Zto on is sebja predstawljaet?

Na SPS estj 2 wichoda MPI i DP, podkljuzil kabel k DP.

Parametri Porta ja peredaju takie CommPort 1, "38400,O,8,1" -
Re: Kommunikazija s s7 300 314c
Павел Кобелев; 27.8.04

Через DP, как правило, без предварительной параметризации контроллера доступ получить нельзя. Первичная загрузка однозначно через MPI.

Имелся в виду порт контроллера (интерфейс, скорость коммуникации). Скорость по MPI по умолчанию (с завода или после сброса) в контроллере установлена в 187,5 kbps.
Наличие или отсутствие доступа определяется, например, в окне set pg-pc interface.
А вообще, вам надо бы документацию по STEP7 и по вашему контроллеру почитать.
Re: Kommunikazija s s7 300 314c
Vital; 27.8.04

v etom to i delo -> dlja menja ne zelateljno ispoljsowatj STEP 7 i tomu podobnoe. Objasnju popodrobnee:

Programma dlja SPS nachoditsja na Flash Card. Predpolozim 4to ona rabotaet.

ja cho4u usnatj sna4enie po sadannomu adressu, dlja etogo pischu programmu v Visual Basice, v kotoroj posilaju BYTE - array(Request-Telegramm ) i cho4u poluzitj v otwet ot SPS BYTE - array (Response-Telegramm) s nuznim mne sna4eniem(dopustim k SPS podkljuzen klapan, kogda on otkrit w Adrese na SPS na wchode sapisano 1, kogda sakrit - sapisano 0) eto snazenie ja sobirajusj ispolsowatj daljsche w moej programme.
<


text

Проблема с MMC в С7-635TP
Михаил_SMV; 20.8.04

ОНО (C7)не позволяет загрузить в себя проект.

1. С7-635 6ES7635-2EB00-0AE3
MMC - 64k 6ES79538LF000AA0
2. COMport-MPI 6ES7972-0CA23-0XA0
3. Step7 V5.1 + Windows98SE
Главный симптом:
Когда вставлена ММС, контроллер принципиально отказывается общаться с PC.(Глухо)
Когда MMC извлечена - можно выкачать имеющиеся блоки и обмен есть.
(т.е. MPI, разъем на C7, адреса итд - OK)
"Номера" с RESET комбинациями кнопок на контроллере и промигиванием проводились неоднократно.
Как побороть ЗалиЗяку?
(или MMC - неисправна ?)
Re: Проблема с MMC в С7-635TP
Михаил_SMV; 26.8.04

Судя по отсутствию Re, или вопрос ниже чайникового, или "все пропало".

Меня смущает только одно. Если MMC неисправна, почему нет сигнала SF ?
Или почему не идет дым ?
А если исправна - почему ее нельзя сбросить в "0" через контроллер. Или специально для этого случая приобретать программатор (у Siemens, естественно).
Re: Проблема с MMC в С7-635TP
Михаил; 26.8.04

У меня такаяже фигня с MMC только она у меня 512kb для cpu 315-2dp мы ее покупали, тоже все глухо, хорошо додумались икупили их сразу две, одна работает нармально. И меня интересует почему связи то нет с CPU и диагностический буфер нельзя посмотреть, ну определил бы ну плохая память ну а зачем загибаться то полностью. ведь без нее то связь есть :) Вот сименс БЛИН!

Re: Проблема с MMC в С7-635TP
Чистяков Дмитрий ОАО СеверСталь; 26.8.04

Я же писал, что если в карте "сидит" проект и в нём установлены другие (отличные от значений по умолчанию) параметры связи, то придётся либо очистить флэшку на программаторе, либо подобрать эти самые параметры, путём перебора всех вариантов.

Поэтому говорить о том, что карта не исправна нельзя!
Re: Проблема с MMC в С7-635TP
Михаил_SMV; 26.8.04

OK. Благодарю, что нашлись-таки неравнодушные. Насчет "БЛИН" - при всем уважении к Siemens - согласен полностью.(ну нет у меня программатора). А forum 2003 я просматривал. Насчет перебора - это конечно, выход. Но насколько реально - не знаю. Только адресов 32. другие параметры перебирать - вспоминаем школьную алгебру - кол-во из X по Y шт.

Меня удивляет одно. Нет функции сброса "всего" на заводские установки, в том числе и MMC.("новая жизнь с понедельника"). Спасибо за ответы. Если "победю" проблему - сообщу инф.
Кто может помочь советом - e-mail
(или программатором ;) )
См. SMV

Re: Проблема с MMC в С7-635TP
Павел Кобелев; 27.8.04

Да не надо все адреса перебирать :). Скорее всего первый порт контроллера работает по MPI. Вопрос, на какой скорости. В set pg-pc interface можно задать параметры интерфеса (скорость, максимальный адрес лучше оставить как есть) и просканировать сетку на предмет наличия активных устройств, работающих с заданными параметрами порта. Если вы подключены только к одному контроллеру, и в списке устройств что-то появилось, то это оно и есть. Перебрать нужно только скорости порта.

Re: Проблема с MMC в С7-635TP
Чистяков Дмитрий ОАО СеверСталь; 27.8.04

Ну ещё возможно могли установить и протокол не MPI, а Profibus.

Ну, а вообще, это одна из причин по которым желательно купить хотябы один программатор на предприятие. А так же я думаю в вашем городе можно найти где-нибудь PG. Пообщайтесь с коллегами в своём городе.
Re: Проблема с MMC в С7-635TP
Михаил_SMV; 27.8.04

"не надо все адреса перебирать" - это обнадеживает. Без MMC в контроллере и обмен есть, и адреса видны. (в данном случае - для контроллера он у меня 2).

т.е. разъемы, скорость, протокол - ОК.
Но как только ставишь MMC - "все пропало".
Вопрос. Скорость COM1-адаптерMPI установлена 19200. все работает. Следовательно, надо перебирать адреса MPI и скорости ? Это прописано (возможно) в MMC ?
Еще вычитал, что MMC можно "переформатировать". Опять же на Field PG.( "Ах, если бы у меня был PC PG".... ;) ).
Приступаем к перебору адресов и скоростей.<


text

Прошивка
Лёха; 25.8.04

Как прошить карту памяти через комп?

Есть комп с PCMCIA слотом. Вставлял память - винды требуют дрова.
Немцы говорят, что надо обнулить память через СТЕП манаджер, но я там указанного пункта не нашёл. Какие компоненты степа нужны?
Народ, ПОМОГИТЕ!!!!!
Re: Прошивка
Андрей Гуленок; 25.8.04

А какая плата-то? Если для S7-400, то увы. Только специальным проммером или в программаторе. Стандартный PCMCIA прошивать платы не умеет.

Re: Прошивка
Лёха; 25.8.04

Карта 6ES7 952-1KL00-0AA0 для S7-400

Re: Прошивка
Чистяков Дмитрий ОАО СеверСталь; 25.8.04

Увы. Вам придётся обратится к тому, у кого имеется программатор. Через PCMCIA ничего не получиться.

Re: Прошивка
Lucky; 26.8.04

ili external prommer ot Siemens, USB..

890 evrikov po katalogu..:-(<


text

MMC накрылась или нет?
Vinsent; 25.8.04

купили значит карту MMC 512 KB (2 шт)к CPU 315-2DP ну 2AG10 который,

Одна работает все нармально, а другая когда ее фтыкаешь в CPU и потом вкл. питание индикатор стоп мигает сначало быстро потом медленно, и кароче так и мигает медленно желтеньким, связи PG с CPU нет. Вопрос накрылась ли эта MMC или можно ченить сделать с ней?

Re: MMC накрылась или нет?
Павел Кобелев; 26.8.04

Попробуйте контроллеру ресет сделать.

Re: MMC накрылась или нет?
Михаил; 26.8.04

Делал ресет не помогает

Re: MMC накрылась или нет?
Vinsent; 26.8.04

Да я Reset делал он не помогает опять мигает медленно желтый огонечек


text

помогите
макс; 24.8.04

У кого нибудь есть описание FM353 на русском языке?

Re: помогите
Михайлин Сергей; 25.8.04

В Сименс Москва данная документация не переводилась. Если только кем-то частным путем.


text

S7-400
Лёха; 14.7.04

Есть CPU 414-2 DP 6ES7 414-2XG03-0AB0.

Перестал работать и на нём загорелись все индикаторы.
Кто чем поможет? Неужели совсем хана контроллеру?
Re: S7-400
sasha; 14.7.04

коммуникация с PG есть. очки дает?

Re: S7-400
Lucky; 14.7.04

Backup программы есть или карта памяти с копией проги? Если есть что то из этого в наличии, выруби питание, вытащи буфферные батареи, вытащи карту памяти из ЦПУ, и включай систему снова.. Когда горят все индикаторы в начале, идет self check, продолжительность в зависимости от размера мозгов. Если оживет, грузи прогу снова с программатора или с карты. Удачи!

Re: S7-400
Лёха; 15.7.04

Для Sasha: Коммуникации с PG нет. Даже при сканировании сети не виден.

Для Lucky: вырубали питание, вытаскивали карту памяти, только батарейку не вытаскивали. Не ожил.
Re: S7-400
Кобелев Павел; 15.7.04

На блоке питания Batt1f Batt2f горят?

Re: S7-400
Кобелев Павел; 15.7.04

На блоке питания Batt1f Batt2f горят?

Re: S7-400
Валентин; 15.7.04

Из практики ремонта других устройств.

Необходимо проверить в первую очередь все внутрение напряжения (=5V,=24V) на величину и на пульсации.

Re: S7-400
Lucky; 15.7.04

Снимите ЦПУ с рэка, визуальный контроль.. У меня была подобная фича с 417-4H, подвисал проц.. Полная промывка мозгов помогла (urloeschen, und 'ne schoene Portion an Geduld ..:-) ) По сути нужно с нуля стартап для системы проделать. Когда проц снова в рэк вставите, включайте питание и ждите мин 5, не спешите. Ключ отставляйте в положении стоп. Отключите коммуникационные сети, пока не заведется, и прогу не загрузишь.

Если не заведется,A&D Reparaturzentrum Fuerth laesst freundlich gruessen!:-)
Re: S7-400
Лёха; 16.7.04

На блоке питания индикаторы 5V и 24V горят, остальные нет.

Вопрос: где можно проверить внутренние напряжения? на каких выводах их искать?

ЦПУ снимал. Визуальный осмотр ничего не дал. С виду всё ОК. Вставлял обратно, ждал. Даже держал ключ в положении очистки памятя в течении 1,5-2 минут. Индикаторы моргают, а реакция та же самая.
Re: S7-400
koma ; 16.7.04

был аналогичный случай

пришлось менять CPU
Re: S7-400
koma ; 16.7.04

кстати а Вы уверены что делаете сброс правильно?

Re: S7-400
Лёха; 16.7.04

А что значит ПРАВИЛЬНО, а что НЕПРАВИЛЬНО?

Re: S7-400
Lucky; 16.7.04

Opishi pls, kak vi CPU sapuskat pitaetes'? KARTU PAMAJTI NE VSTAVLAJTE!!! OTKLJUCHITE SET! Kstati, pered tem kak otrubilos CPU, is hardware menjali 4e to? Blok pitanija kak ja ponjal dolgen rabotat, kakaja voobsche konfigurazija? Esli ni4ego ne pomoget, otprvljyte v service. Udachi!

Re: S7-400
Лёха; 16.7.04

Для Lucky. А что у тебя с русским стало-то? Мыша клаву скушала что ли?:))

А запускали по-разному: и с картой памяти, и без неё. Вынал батарейку, переставлял CPU и блок питания в другой слот.
Что значит твоё "отключите SET"? Hardware не менялось давно. Контроллер проработал с такими настройками год.
Re: S7-400
Lucky; 16.7.04

Я тут малехо поузнавал у немецких коллег, был аналогичный случай, с 416 ЦПУ, отправили в ремонт, оказалось полетел внутренний Profibus интерфейс,

поменяли и перепрошили firmware, работает снова. Я писал прошлый пост на транслите, не видно его больше или база форума глючит? Удачи, надеюсь что смог как то помочь.
Re: S7-400
Lucky; 16.7.04

Просто есть большая разница между клавой на работе и дома, дома она русская..:-) На работе тока немецкий и энглиш, и арабский:-) Пока руки не дошли и инсталляхи нет W2k, чтоб винде на работе мозги вставить. otkljuchite SET - кабель сетевой с интерфейсов MPI и Profibus если есть скрутить..:-)

Re: S7-400
Лёха; 19.7.04

Спасибо за помощь.

Re: S7-400
Lucky; 4.8.04

Mne esche koe chto na um prishlo: esli ne sdali esche v garantijku, sdelaj na CPU firmware update na poslednjuu dosupnuju versiju. Udachi!

Re: S7-400
Лёха; 5.8.04

А как это сделать, если я не могу добиться до него? Он не отвечает на запросы.

Re: S7-400
Lucky; 5.8.04

Nafiga tebe do ne nego dobivatsja???

Grusish firmware update s ad.siemens.de/support.. Raspakovivaesh archiv, tam budet filik CPU..UPD, beresh memory kartu 4 MB, pishesh nee update, est v Zielsystem punkt enu Betriebsystem aktualisieren, kogda sprosit fayl firmware ukasivaesh direktoriju kuda raspakoval update i fayl CPU....UPD. Pitanije kontrollera OFF, kartu v shachtu, pitanije ON, vse LED budut goret 2 minuti potom, budet migat' stop, overall reset request. Kogda samigaet Power OFF. Posle etogo vitaschi kartu s update, i probuy sapuskatsja, sna4ala bes karti pamajti s programmoj polsovatelja. Udachi!!!
Re: S7-400
Лёха; 24.8.04

Вставили карту в слот, винды требуют драйвер на карту. Где его взять?


text

Распайка разъема MPI на S7-300
Игорь; 23.8.04

Подскажите распайку разъема MPI на контроллерах S7-300.

Re: Распайка разъема MPI на S7-300
Чистяков Дмитрий ОАО СеверСталь; 23.8.04

3ий pin одного разъёма к 3-ему пину другого

8-ой к 8-му

Т.е.
3-3
8-8

Желательно ещё и терминаторы прилепить бы.
Т.е. можно воспользоваться стандартным Profibus кабелем.
Re: Распайка разъема MPI на S7-300
Игорь; 23.8.04

Мне надо знать на какой ноге какой сигнал. Например: 5 - GDN, 6 - power, и т.д.

Re: Распайка разъема MPI на S7-300
GorA; 23.8.04

3 - RxD/TxD-P

8 - RxD/TxD-N

Re: Распайка разъема MPI на S7-300
Игорь; 23.8.04

Это понятно. Но в этом же разъеме еще есть питание +5 В для адаптера PC/MPI! Про это почему ниикто не говорит? Какая нога питание, какая - земля? Мне нужна полная распиновка разъема - от 1 ноги до 9й.

Re: Распайка разъема MPI на S7-300
Gibbon; 23.8.04

смотри доку

SIMATIC
PC Adapter USB
Manual
Re: Распайка разъема MPI на S7-300
Чистяков Дмитрий ОАО СеверСталь; 23.8.04

Ну, тады загляни на страницу 22 вот этого описания http://www.automation-drives.ru/as/download/doc/simatic_net/profibus/G_OLM_r.pdf

Re: Распайка разъема MPI на S7-300
Игорь; 24.8.04

Вот это конкретный ответ! Спасибо! Только я не пойму, откуда на разъеме контроллера берется 24 В на 7й ноге? И для питания адаптера нужно 5 В с 6й ножки или эти 24 В с 7й? У меня вся проблема в том, что на другом контроллере не работает адаптер PC/MPI (не горит светодиод Power). Я думаю, с контроллера не поступает питание. Адаптер рабочий.

Re: Распайка разъема MPI на S7-300
Чистяков Дмитрий ОАО СеверСталь; 24.8.04

Тогда скорее всего в CPU сгорел преобразователь, который даёт напряжение питания для внешних схем. Он представляет собой импульсный источник питания, который гальванически развязан со всеми шинами контроллера. Сжигают его часто, т.к. он имеет весьма малую мощность, а народ любит подключать на него всякую нагрузку.

Как вариант, у нас был такой случай. При подключенном PG 740 к контроллеру по каналу MPI, кабелем от BT200, отключили контроллер. При этом светодиоды на CPU отсались светиться. Но это продлилось не долго, т.к. в PG сгорел этот самый преобразователь. Обратно эксперимента мы проводить не стали (не хотелось сжечь ещё CPU ;-) ).
После этого случая пользуемся либо родным кабелем, либо самопалом, но только с двумя проводниками (3-3, 8-8).

А по всем схемам (заглянул ещё и в описание PG740) на 7-ой ноге напряжения быть не должно.<


text

Вопрос по циклам
Сергей; 17.8.04

Господа, подскажите пожалуйста где можно достать примеры программ для Step7 с применением циклов. Желательно с комментариями. Ну и описание оператров циклов...

Re: Вопрос по циклам
Чистяков Дмитрий ОАО СеверСталь; 17.8.04

Операторы циклов в STL отсутствуют - их (циклы) делют командой условного перехода. Хотя циклами в программе Step7 не стоит особо увлекаться.

Для управления данными и большими массивами, удобно использовать SCL - это паскале подобный язык программирования
Re: Вопрос по циклам
Алексей Родионов, ЗАО "Искра-Энергетика"; 17.8.04

L #COUNT_CYCLE //Загружаем число циклов

CYC1: T #CUR_CYCLE //Текущий цикл
. . .
Тело цикла
. . .
L #CUR_CYCLE // Загружаем текущий цикл в ACCU1
LOOP CYC1 // повтор цикла, если ACCU1 > 0, при этом ACCU1 уменьшается на 1
Re: Вопрос по циклам
Игорь; 17.8.04

Заявление "Операторы циклов в STL отсутствуют - их (циклы) делют командой условного перехода. Хотя циклами в программе Step7 не стоит особо увлекаться." не соответствует действительности.

В STL есть оператор LOOP хххх, который декрементирует содержимое ACCU1 и делает переход к метке xxxx, если ACCU1>0. Циклы реализуются очень просто.
Описание и примеры использования есть во встроенном HELPe по STL.

Re: Вопрос по циклам
GorA; 17.8.04

Каких циклов?

Re: Вопрос по циклам
Сергей; 18.8.04

Господа, спасибо, благодарю за совет... С уважением, Сергей...

Re: Вопрос по циклам
Darwin; 19.8.04

По быстродействию что предпочтительнее из двух вариантов для реализации FIFO (сдвиг всех данных на одну смену вниз для записи данных по сменам) для блока данных объемом 1300байт:

1. Сдвиг с использованием циклов, общее количество 350 циклов.
2. Сдвиг с использованием SFC20(BLKMOV), но при этом еще необходимо использовать доп. промежуточный блок данных, т.к. использование SFC20 не допускает перекрытия областей данных.
Re: Вопрос по циклам
Сергей; 19.8.04

Darwin-у, вот если Вам не трудно поделиться информацией, то хотелось бы получить информацию по сдвигу с использованием SFC20(BLKMOV). Увидеть примерчик программы с хорошими комментариями. Я конечно имею скупенькую доку по SFC20, но этого описания мне не достаточно. В описании говориться какие данные она может считать и куда передать, а вот как их сформировать не сказано... Вобчем, если можно то поподробнее по данному случаю...

Re: Вопрос по циклам
Чистяков Дмитрий ОАО СеверСталь; 19.8.04

То Игорь

Команда STL LOOP не что иное, как условный переход по условию. ;-)
Под "операторами циклов" в программировании принято называть конструкции типа
"For ... next"
"Do WHile"
и т.п.
Данные конструкции позволяют устанавливать гибкие условия продолжения цикла.
Re: Вопрос по циклам
Игорь; 19.8.04

To Чистяков Дмитрий

Разумеется, я с Вами согласен.
Однако, товарища интересовал вопрос - как организовать цикл в Step7.
Согласитесь, что конструкции типа "For ... next" и "Do WHile" легко реализуются в STL с помощью "LOOP" и вложений. А если написать цикл в SCL, то после компиляции получится то-же самое.

Best regards!

!!!!!!! Вопрос по циклам !!!!!!!
Сергей; 20.8.04

Darwin-у, и если Вам не трудно то могёте кинуть примерчик мне на майл, ну это я про сдвиг с использованием SFC20(BLKMOV)... Потому как мне интересна пока именно эта функция. А про "LOOP" я уже знаю... С уважением, Сергей...

Re: Вопрос по циклам
Darwin; 20.8.04

CALL "BLKMOV"

SRCBLK :=P#DB14.DBX0.0 BYTE 36
RET_VAL:=MW166
DSTBLK :=P#DB3.DBX10.0 BYTE 36

CALL "BLKMOV"
SRCBLK :=P#DB2.DBX0.0 BYTE 5
RET_VAL:=MW166
DSTBLK :=P#DB3.DBX0.0 BYTE 5
//
//BYTE 36 это множитель, т.е. начиная с DB2.DBX0.0 копируется 36 байтов. Если например указать слово то слов. Word 5, это значит 5 слов. P#DB3.DBX0.0 это указатель на начало области.
SRCBLK источник
DSTBLK место назначения
как я говорил, перекрываться области не должны.
Re: Вопрос по циклам
Сергей; 20.8.04

Darwin-у, благодарю за совет, очень пригодился...

С уважением, Сергей...
Re: Вопрос по циклам
Сергей; 20.8.04

Да кстати, господа, никто не может пояснить:

LAR1 P##ANY
L W#16#200
T LW [AR1,P#0.0]
L 8
T LW [AR1,P#2.0]
ITD
SLD 3
T #Сikl
L 10
T LW [AR1,P#4.0]
L P#DBX 0.0
T LD [AR1,P#6.0]

Конткретно интересен формат записи:
"LW [AR1,P#0.0-P#2.0-P#4.0]"
и
"LD [AR1,P#6.0]"
Как я понял это формирование источника "SRCBLK", но мне бы попонятнее описать эти точки...

С уважением, Сергей...
Re: Вопрос по циклам
Сергей; 20.8.04

То есть далее идет:

call sfc 20
SRCBLK:=#ANY
и т.д. и т.п.

С уважением, Сергей...

Re: Вопрос по циклам
Сергей; 20.8.04

Ещё пунктик для дополнения картинки, переменная #ANY формируется для чтения данных из блока UDT...

Напомню, мне непонятен формат:
"LW [AR1,P#0.0-P#2.0-P#4.0]"
и
"LD [AR1,P#6.0]"

С уважением, Сергей...

Re: Вопрос по циклам
GorA; 20.8.04

Почитайте руководство по программированию на STL, конкретно по косвенной адресации через регистры AR1, AR2 и станет все понятно

Re: Вопрос по циклам
GorA; 20.8.04

А так

LW[AR1,P#0.0] - загрузить в аккумулятор число в формате word по адресу в AR1 со смещением 0.0
LD[AR1,P#6.0] - загрузить в аккумулятор число в формате dword по адресу в AR1 со смещением 6.0

<


text

DP V0 для 315-2AF03-0AB0
fog; 20.8.04

Поддерживает ли CPU315-2DP 315-2AF03-0AB0 протокол DP V0 ? Т.е. могу ли я воспользоваться для программирования циклического обмена (V0) блоками SFC13,14,15, если интегрирован GSD вендора для DP V0 (Slave поддерживает только DP V0)?


text

MPI/DP адаптер и CPU315-2DP
fog; 10.8.04

Не получается подключиться по DP.

CPU 315-2DP 315-2AF03-0AB0 V1.2.0 поддерживает STEP7 по DP-порту совместно с RS232/MPI-DP адаптером 6ES7-972-0CA23-0XA0?
СПАСИБО!!!!!

Re: MPI/DP адаптер и CPU315-2DP
Чистяков Дмитрий ОАО СеверСталь; 11.8.04

Если честно, то мне вопрос показался несколько сумбурным - Чего хочешь-то?

Параметрировать из Step7 через этот адаптер или ещё чего?
Если первое, то попробуй сверить скорости передачи на адаптере и в CPU, а так же типы протоколов.
Re: MPI/DP адаптер и CPU315-2DP
fog; 11.8.04

Привет, Дмитрий!

Давно уже вижу тебя на форуме.
Хочу проверить работоспособность порта DP на этом CPU, воспользовавшись для это MPI/DP-адаптером (будет связь - значит исправен). Но связи НЕТ!
Не хочется верить, что CPU неисправен, поэтому и спрашиваю А ВОЗМОЖНА ЛИ ТАКАЯ СВЯЗЬ В ПРИНЦИПЕ?
Re: MPI/DP адаптер и CPU315-2DP
Михайлин Сергей; 11.8.04

Связь возможна. Только предварительно надо заказчать по MPI в CPU конфигурацию DP интерфеса и потом подключаться к нему переключившись на PC Adapter(Profibus).

Re: MPI/DP адаптер и CPU315-2DP
fog; 12.8.04

Спасибо, Сергей!

Так я и делал, но связаться не получилось - значит неисправен порт DP. А можно в диагностике CPU увидеть, что DP порт неисправен, или не всегда?
Re: MPI/DP адаптер и CPU315-2DP
GorA; 12.8.04

Проверить порт можно установив одну станцию, например ЕТ200М.

Re: MPI/DP адаптер и CPU315-2DP
Павел Кобелев; 16.8.04

Проблема с портом маловероятна. Скорее всего вопрос в конфигурации порта. Сам порт необходимо обязательно посадить в конфигураторе на Profibus-шину с заданными параметрами. Просто задать адрес порта и спараметрировать шину недостаточно.

Re: MPI/DP адаптер и CPU315-2DP
mvi; 18.8.04

У нас такая же проблема с этим процессором CPU 315-2DP 315-2AF03-0AB0 V1.2.0. Может есть особенность какая-то в его конфигурированнии или его DP порта.

Re: MPI/DP адаптер и CPU315-2DP
fog; 20.8.04

Нашёл PG, проверил порт - работает, но с адаптером ничего всё-равно не вышло.


text

~20 OP в сети
Astronom; 19.8.04

Имел ли кто опыт ~20 ОР-шек на MPI или Profibus. Были ли проблемы?

Re: ~20 OP в сети
Darwin; 20.8.04

В описании что-то про ограничении на 5 ресурсов для операторских панелей для контроллера. Это значит со стороны контроллера в сторону панели коммуникация наверно. А проблемы были такие- 6 контроллеров панель не могла подключиться, 1 все время не подключался. С 5 все нормально

Re: ~20 OP в сети
Чистяков Дмитрий ОАО СеверСталь; 20.8.04

Количество панелей ограничено максимальным количество связей для конкретного CPU. Это значение можно узнать в описании CPU.

При этом следует учитывать все связи, в том числе и станции на сети Profibus, связи между контроллерами и не забыть про связь с PG.
Re: ~20 OP в сети
Astronom; 20.8.04

У меня была такая мулька...

Была такая хардвара-
На профибас висели 3-и OP
на МПИ 1-а ОР и 2-а контроллера.
Так одна опешка не хотела заводиться.
Причем какая первая подхватит (на мпи или профибасе) такая и работает т.е в сети профибас - мпи работало 3-и ОР и 2 контроллера, 4 -я ОР-ка не хотела влазить.
Я так понял для нового 315 это 15?<


text

USB адаптер
Коротов Д.В.; 18.8.04

Коллеги! При связи через USB адаптер перилодически подвисает STEP 7 или любое приложение, использующее ONLINE соединение с контроллером. Может кто сталкивался с Этим.

Re: USB адаптер
Николай; 18.8.04

Если я правильно понял это USB на Com адаптер - тогда с ними было куча проблем и не только на сименс. Лучше всего работал под XP с неродными драйверами. Особенно плохо работает на маленькой скорости

Re: USB адаптер
Коротов Д.В.; 18.8.04

Вот код этого адаптера.

6ES7972-0CB20-0XA0
Re: USB адаптер
Григорий; 18.8.04

На Customer Support выложено обновление драйвера и еще чего-то (поскольку весит >60Мб) для адаптера MPI - USB. Может поможет.


text

Работа в сернистых газах
Shade; 6.8.04

Уважаемые господа!

Кто-нибудь имел опыт работы контроллеров при повышенном содержании серных соединений в воздухе? Как они себя показали?
Re: Работа в сернистых газах
Shade; 11.8.04

Ну ладно поставлю вопрос по другому. Какие контроллеры порекомендуете для производств с повышенным содержанием серы в атмосфере (10мг на кубометр)?

Re: Работа в сернистых газах
Shade; 18.8.04

Вопрос представителям Siemens: есть ли возможность заказать технические характеристики контроллера? Например: в характеристиках S7-300 Outdoor заявлено работа при 0,5 ppm SO2, можно ли заказать контроллер для работы при концентрации к примеру в 5 ppm SO2. Если да, то как это отразится на цене. Спасибо.


text

Как проще сделать "будильник"?
Не программер; 29.7.04

Re: Как проще сделать
Юрий Оганесян; 30.7.04

На LOGO! 230RC и звонке громкого боя (типа школьного) - точно что проснешся :)

Re: Как проще сделать
Diana; 30.7.04

Звонок громкого боя - это все ерунда. Сирена от тепловоза - вот, что нужно.

Re: Как проще сделать
Не программер; 16.8.04

Спасибо, спасибо!!!

Я сообщил Нобелевскому комитету Ваши реквизиты - ждите! :-)

Реализовал более простым методом - итегрировал медный таз и обрезок рельса!
С надеждой на дальнейшее сотрудничество!
Ваш ...
Re: Как проще сделать
Сергей; 17.8.04

Re: Как проще сделать
Часовых дел мастер; 18.8.04

Делаю будильники на всём. Оплата в EURO по курсу.


text

SFC 20 ???
Сергей; 17.8.04

Господа где можно найти информацию по функции SFC 20?

Re: SFC 20 ???
Чистяков Дмитрий ОАО СеверСталь; 17.8.04

Про этот блок написано вот здесь

http://www.automation-drives.ru/as/download/doc/software/base/03_Copy&Control_Block_r.pdf

А вообще стоит запомнить адресок на этом сайте.
http://www.automation-drives.ru/as/products/software/
Re: SFC 20 ???
Сергей; 18.8.04

Большое спасибо, за помощь! Вы очень помогли мне. С уважением, Сергей...


text

Активный шинный модуль
Дмитрий; 16.8.04

Подскажите пожалуйста чем отличается активный шинный модуль от активного шинного соеденителя ? Кроме цены конечно, она как раз отличается в два раза.

Re: Активный шинный модуль
Михайлин Сергей; 17.8.04

А заказные номера какие?

Потому как по разной трактовке это могут быть разные вещи. Модуль и соединитель близкие понятия в этом контексте.
заказные
Дмитрий; 17.8.04

6ES7195-7HE80-0XA0 активный шинный модуль

6ES7195-7HD80-0XA0 активный шинный соединитель
Заказные номера и описание из каталога CA01
Re: Активный шинный модуль
Павел Кобелев; 18.8.04

6ES7195-7HE80-0XA0 предназначен для установки интерфейсных модулей ...-0AA81-... , а 6ES7195-7HD80-0XA0 для

...-0AA82-...

См. Читать тут


text

адрес германского сайта Siemens?
Ольга ; 16.8.04

какой адрес германского сайта Siemens?

или где еще взять дрова для FM 350-1?
Re: адрес германского сайта Siemens?
Чистяков Дмитрий ОАО СеверСталь; 17.8.04

http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.csinfo&lang=en&siteid=CSEUS

Firmware Updates for FM350-1 (6ES7 350-1AH03-0AE0)
http://www4.ad.siemens.de/WW/news/en/16812649

Configuration Package for Counter Module FM 350-1, FM 450-1 V5.1 (03.2003)
http://www4.ad.siemens.de/WW/news/en/14732973
Re: адрес германского сайта Siemens?
Чистяков Дмитрий ОАО СеверСталь; 17.8.04

Да, а вообще он (на сколько помню) идёт на CD в комплекте с модулем.

И на всякий случаю ещё раз даю ссылку на сайт Siemens в Германии.
См. http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.csinfo&lang=en&siteid=CSEUS

Re: адрес германского сайта Siemens?
Павел Иванов; 17.8.04

Адрес центрального сайта поддержки приведен справа и назвается Customer Support

См. http://www.ad.siemens.de/csi_e


text

Связь Master-Master через Profibus
Михаил; 12.8.04

Помогите пожалуйста.

Как просто и быстро передать данные между двумя станциями S7-300
по profibus обе станции с процессорами 315-2DP.
(Ну можно не просто и не быстро хоть как нибудь :)
Re: Связь Master-Master через Profibus
Fanat; 12.8.04

По моему в сети профибаса может быть только один мастер, так что выход - либо MPI либо одного мастера нужно делать интелектуальным слэйвом...

Еще как вариант CP - Ethernet и все будет работать - но нужно тогда настраивать соединение и обмен, что гораздо сложнее...

Re: Связь Master-Master через Profibus
Михаил; 12.8.04

Дело в том что система уже существующая в ней два контроллера s7-300 CPU 315-2DP они оба в сети Profibus DP подключены с помощью встроенных интерфейсов Profibus DB также подключен ряд частотных преобразователей тоже к этому же профибасу, оба CPU сконфигурированы как мастеры. Так вот возможно ли переслать по этому же профибасу пару байт из одного контроллера в другой не ломая существующей системы.

Re: Связь Master-Master через Profibus
Shade; 12.8.04

Есть преобразователь который делает слейвом мастера для другого мастера и наобарот. Ребята из Сименса знают подробней.

Re: Связь Master-Master через Profibus
Lucky; 12.8.04

DP-DP Coupler, posvolit vam soedinit dve Master sistemi po seti Profibus DP, for more detailed information refer approriate manuals ! Good Luck!

Re: Связь Master-Master через Profibus
Михаил; 12.8.04

-> Lucky

Где документацицию на этот куплер мне найти. посоветуйте пожалуйста.
Re: Связь Master-Master через Profibus
GorA; 12.8.04

Я сам не пробовал, но если есть время и возможность попробуйте SFC65-69 (X_SEND, X_RCV, X_GET, X_PUT).

Re: Связь Master-Master через Profibus
Михаил; 12.8.04

->GorA

Да нет нефига мне чувак из сименса
написал невозможно говорит это
надо кароче еще бабок вбухать
или купить комуникационный процессор
или кароче 400-ый ставить.
Re: Связь Master-Master через Profibus
GorA; 12.8.04

Коммуникационный процессор стоит 690 евро.

Re: Связь Master-Master через Profibus
GorA; 12.8.04

А процессор 315 дешевле 315-2DP более чем на 400 евро

Так что считай куда бабки вбухивать.

Re: Связь Master-Master через Profibus
GorA; 12.8.04

Есть еще вариант

http://www.automation-drives.ru/cgi-bin/forum/forum.cgi?dir=1008101941&root=1070429814&year=2003
Re: Связь Master-Master через Profibus
Михаил; 13.8.04

Я все понял. Только я не пойму всеже почему так дело то обстоит, в чем принципиальеая невозможность соединения мастера с мастером. Как я понимаю просто встроенный интерфей DP у 315-2DP недоделанный какойто.

Re: Связь Master-Master через Profibus
Darwin; 13.8.04

Re: Связь Master-Master через Profibus
Михаил; 13.8.04

Да,да именно два мастера со своими слэйвами в одном сегменте DP, а GDT в MPI уже забита просто да я канечн по MPI свяжусь, просто хотелось так скать использовать "суперскоростной" Profibus. Ну нет так нет :(

Re: Связь Master-Master через Profibus
Чистяков Дмитрий ОАО СеверСталь; 13.8.04

Такая ситуация имеется только в 300-ой серии (на то она и дешевле). Два мастера в 400-ой связываются без проблем.

Происходит это из-за того, что в 300-ых CPU мозги (аппаратные и программные) несколько усечены. Да и сама серия контроллеров позиционируется как не дорогое решение. Вот и нет там поддержки такой связи. Назначение же DP-порта там - подключение периферии децентрализованной.
На мой взгляд, если планируется система из нескольких контроллеров и есть необходимость взаимосвязи этих контроллеров, то стоит предусмотреть CP, которые снимут проблемы и нагрузку с CPU.
Re: Связь Master-Master через Profibus
Михаил; 13.8.04

->Чистяков Дмитрий ОАО СеверСталь

Она не планируется а уже существует
просто возникла необходимость получения некоторой информации одному контроллеру от другого контроллера, в связи с некоторыми доработками системы.
Re: Связь Master-Master через Profibus
Михаил; 13.8.04

->Чистяков Дмитрий ОАО СеверСталь

Она не планируется а уже существует
просто возникла необходимость получения некоторой информации одному контроллеру от другого контроллера, в связи с некоторыми доработками системы.
Re: Связь Master-Master через Profibus
Чистяков Дмитрий ОАО СеверСталь; 13.8.04

Раз появилась необходимость в доработке, значит должен был появиться и новый план. ;-)

Re: Связь Master-Master через Profibus
Lucky; 15.8.04

http://www4.ad.siemens.de/-snm-0135030360-1088511457-0000006186-0000003026-1092591195-enm-WW/llisapi.dll?aktprim=99&lang=en&referer=%2fWW%2fllisapi.dll?aktprim=99&func=cslib.csinfo2&siteid=cseus&firstload=no&optionengewaehlt=yes&content=skm/newSKM/main.asp?option=manual

Re: Связь Master-Master через Profibus
Кобелев Павел; 16.8.04

А через общий слейв этот вопрос не решить?

Re: Связь Master-Master через Profibus
GorA; 16.8.04

Есть устройство DP/DP Coupler 6ES7158-0AD00-0XA0, которое предназначено для обмена данными между мастерами размером до 244 байт.


text

Y-link
Дима; 13.8.04

Для построения Y-link предполагается использовать IM 157 6ES7 157-0AA82-0XA0 и коплер 6ES7 197-1LB00-0XA0

Однако при формировании HW Config удается установить только интерфейсные модули IM 157, которые в свою очередь автоматически выставляют свой собственный DP master system, хотя это возможно только через коплер. Не пойму как прописать коплер Y-link в HW. Или он устанавливается в HW автоматически при установке IM 157 ?
Спасибо.
Re: Y-link
Кобелев Павел; 16.8.04

Есть готовый модуль Y-Link 6ES7197-1LA02-0XA0

Re: Y-link
Назаров Дмитрий; 16.8.04

Готовый Y-Link и содержит IM и коплер. В HW Config это делается автоматически.


text

Как ЕЩЁ проще сделать "будильник"?
Не программер; 30.7.04

Помогите решить задачку - на S7-300 (CPU314) нужно реализовать будильник типа "Включить во вторник в 9-30, выключить в среду в 16-00".

Заранее благодарен за любую инфу!
Re: Как ЕЩЁ проще сделать
GorA; 1.8.04

Можно сделать следующее:

1. Установить в PLC текущую дату и время PLC->Set time of day...
2. Существуют организационные блоки прерываний OB10 - OB17 нужно их активизировать. Для этого в HW Config кликнуть два раза на процессор и выбрать вкладку Time-of-Day Interrupts. В данной вкладке активизировать (для предложенного примера), например, ОВ10 для включения, ОВ11 для выключения. Затем в графе EXECUTION выбрать Every week и далее Start day установить, например, 3 августа, Time of day - 9-30. Аналогично для ОВ11 - EXECUTION - Every week, Start day - 4 августа, Time of day - 16-00.
3. Теперь необходимо создать сами ОВ10, ОВ11 и запрограммировать деиствия. Например, устройство включается/выключается выходом Q10.5.
Тогда в ОВ10 пишем
Set
S Q10.5

В ОВ11 пишем
Set
R Q10.5

И тогда получаем - начиная со вторника 3 августа в 9-30 и в дальнейшем каждый вторник в контроллере будет вызываться организационный блок ОВ10, где выполняется включение устройства.
И, аналогично, работает ОВ11, только там производится отключение устройства начиная со среды 4 августа и каждую неделю.
Re: Как ЕЩЁ проще сделать
MooR; 2.8.04

Все бы хорошо только у CPU314, на сколько я помню, всего один блок временного прерывания ОВ10 соответственно:) Я выдерал день недели и час из DATE_AND_TIME и сравнивал с уставками.

Re: Как ЕЩЁ проще сделать
Не программер; 2.8.04

Во-во!!!

Не даёт включить ещё один ОВ...
MooR, а нельзя как ить по-подробнее?
Или, хотя бы - что и где почитать(желательно на нашем)???
Спасибо всем, кто откликнулся!
Re: Как ЕЩЁ проще сделать
Diana; 3.8.04

Есть такие функции у 314-го: FC14-FC40. Они лежат в stdlibs. Насколько я понимаю, вам нужны функции READ_CLK (SFC1), DATE and TOD to DT (FC3) и, например, LE_DT (FC18). Help по ним имеется. Вот этот хитрый формат есть просто количество тысячных долей секунды, прошедших с начала 1990-го года.

Re: Как ЕЩЁ проще сделать
GorA; 3.8.04

Действительно можно использовать только ОВ10.

Тогда возможно использовать функции SFC28 - SFC31 для установки и активизации прерывания ОВ10.

Re: Как ЕЩЁ проще сделать
MooR; 3.8.04

Пишите на мыло вышлю пример. А вобще Уважаемая(ый) Diana как раз про то и пишет.

Re: Как ЕЩЁ проще сделать
Чистяков Дмитрий ОАО СеверСталь; 4.8.04

Ну раз уж вы не "Не программер", то пригласите "программера". ;-)

Re: MooR; - написал на мыло!
Не программер; 4.8.04

Спасибо!

Жду!
Re: Как ЕЩЁ проще сделать
Darwin; 5.8.04

CALL "READ_CLK"

RET_VAL:=#CUR_RETVAL // Contains error code
CDT :=#OUT_TIME_DATE // Contains read time

LAR1 P##OUT_TIME_DATE

L B [AR1,P#0.0]
T "Data time".Year
L B [AR1,P#1.0]
T "Data time".Month
L B [AR1,P#2.0]
T "Data time".Data_month
L B [AR1,P#3.0]
T "Data time".Time_hour
L B [AR1,P#4.0]
T "Data time".Time_minute
L B [AR1,P#5.0]
T "Data time".Time_second

A(
A(
L "Data time".Time_hour
L B#16#8
==I
)
A(
L "Data time".Time_minute
L 0
==I
)
A(
L "Data time".Time_second
L 0
==I
)
O
A(
L "Data time".Time_hour
L B#16#20
==I
)
A(
L "Data time".Time_minute
L 0
==I
)
A(
L "Data time".Time_second
L 0
==I
)
)
AN "Reset_complete"
JC rst
BEU

Re: Как ЕЩЁ проще сделать
Darwin; 5.8.04

Это для записи данных в конце смен 08:00 и 20:00. Ну а будильник или что еще там делается аналогично

Re: Как ЕЩЁ проще сделать
Не программер; 5.8.04

Спасибо!

Про двигатель внутреннего сгорания я понял! И куда бензин заливать - понял!
Я не понял - ЛОШАДЬ-ТО КУДА ЗАПРЯГАТЬ??? (Шутка с бородой) :-))
А как ввести - то "RET_VAL:=#CUR_RETVAL // Contains error code
CDT :=#OUT_TIME_DATE // Contains read time", например???
Степ 5.2 красным цветом ругается...
и про "rst" он что-то неприличное рассказывает! :-)
НЕ ПРОГРАММЕР Я! (Так получилось - вынужден!)
Всё остальное, вроде, принял, а вот это-то я и не догнал... :-(
Где описать CUR_RETVAL и т.п.???

Спасибо заранее!
Re: Как ЕЩЁ проще сделать
Darwin; 6.8.04

CUR_RETVAL - это TEMP переменная тип Word, вводится в описании интерфейса блока (сейчас речь о функции). В редакторе вверху есть таблица такая, там есть in out in-out temp. Также и OUT_TIME_DATE там надо прописать тип DATA_AND_TIME.

rst это метка перехода, ставишь ее далее и пишешь что там тебе надо сделать при совпадении этих условий.
Re: Как ЕЩЁ проще сделать
Не программер; 13.8.04

Спасибо, уже лучше!!!

вот только со строчкой типа:
L "Data time".Time_hour
какие-то проблемки....
Не принимает, хоть и пробовал как-то прописывать, но, видимо, не угадаю где...
Подскажите, плиз!!!
И ещё - где поситать-то по-понятнее про эти вещи?!!
Re: Как ЕЩЁ проще сделать
Darwin; 13.8.04

L "Data time".Time_hour

"Data time" это символьное имя глобального блока данных (т.е. доступного везде) вы можете использовать любой свой блок данных или создать новый, но есттно необходимо создать там области подобно Time_hour-это в блоке данных,если проще, строчка с типом данных БАЙТ т.к. мы загружаем туда временную переменную БАЙТ типа, потом мы считываем Time_hour или в СТеп программе или в Протуле или где еще.
<


text

Помогите по PG 720Р
Eleria; 23.7.04

Сгорел блок питания у себя найти не можем.

Вопрос:
Можно ли использовать блоки питания других номиналов типа 15В или 19В?
Если располагаете информацией по допустимым пределам расхождения питания то буду очень признателен за информацию.
Re: Помогите по PG 720Р
Кухаренко Сергей, Siemens; 29.7.04

Можно использовать другие блоки питания, подходящие по току. допуск напряжения +/- 1-1,5 вольта.

Re: Помогите по PG 720Р
Eleria; 11.8.04

Для тех у кого может возникнуть такая проблема..

Поставил блок питания 19.5В 4.1А от Sony (прибор показывал 19.7В)
РАБОТАЕТ !!! без заиканийм (Даже в слот питания вилка подошла)
Отдельное спасибо Сергею за поддержку
;)<


text

Вопрос по FM352 (CAM-Controller)
Игорь; 10.8.04

Хочу использовать этот FM в новом проекте, однако терзают смутные сомнения... "Живого" модуля под руками нет, чтобы проверить реализуемость задачи, поэтому прошу помощи у тех, кто с ним работал.

Суть вопроса: что реально произойдёт, когда я из программы в PLC напрямую (через I/O-область этого модуля, определённую в "HARDWARE Config")модифицирую биты "TRACK_EN" ? Мне нужно "на лету" в зависимости от пройденного пути разрешать или запрещать выходные сигналы от запрограммированных "кулачков". Или биты "TRACK_EN" просто внаглую устанавливают и сбрасывают выходы?
В мануале это описано очень расплывчато...
Кто знает - подскажите, пожалуйста!

Best regards всем...<


text

S7 224 + TP070 Cyrillic трабл
Eleria; 23.4.04

В ТР070 шрифт Regular даже при выставлении настроек Russian language не хотит понимать кирилицу из DB S7 224 сообщения показывает но там написано каракулями, в общем ничегго не понятно.. кто сталкивался помогите их подружить , т.е. заставить ТР070 понимать русские сообщения из DB S7 224

PLZ
Re: S7 224 + TP070 Cyrillic трабл
В.Сорокин; 23.4.04

На прошлой неделе был на Сименсе в Москве. Совершенно нечаянно узнал, что это не возможно. Пишите латинскими буквами похожими на наши. Увы.

Re: S7 224 + TP070 Cyrillic трабл
Eleria; 23.4.04

Ммм .. насколько я понимаю в ТР070 установленна система Windоws CE следовательно возможно ли найти файл *.img в котором прошиты шрифты с поддержкой кирилицы ... или редактор чтобы это возможно было бы сделать самому.... подскажите ПЛЗ.

Re: S7 224 + TP070 Cyrillic трабл
В.Сорокин; 23.4.04

Я не переспрашивал, но понял так, что это касается только строковых переменных вывода. Была проблема с надписями на кнопках, но решилась преходом от ХР к 98-му.

А вообще-то, если бы в Микровине подменить шрифт на Тахому, чтобы с ТР совпал ... . Может и выйдет?
Re: S7 224 + TP070 Cyrillic трабл
Eleria; 24.4.04

Да и еще одно:

"А вообще-то, если бы в Микровине подменить шрифт на Тахому, чтобы с ТР совпал ... . Может и выйдет?"
т.е. МикроВин закачивает в S7 2xx и шрифты .. так??
Re: S7 224 + TP070 Cyrillic трабл
Eleria; 26.4.04

Уважаемый В.Сорокин помогите ... ответь те на предыдущее высказывание.

Re: S7 224 + TP070 Cyrillic трабл
В.Сорокин; 27.4.04

Виноват, командировка.

Сам не успел попробовать. Там в Микро Вине можно шрифты подбирать для разных полей. А в ТП-дизайнере - тахома (на смерть). Правда, на Сименсе мне заявили (сегодня) две вещи: никаких вариантов - латиница (один человек), пробуй - у Виндуса и Виндуса СЕ кодировки разные, может совпадёт когда-нибудь, а в СЕ на ТР не прорвёшься и не думай (другой человек).
Завтра попробую.
Re: S7 224 + TP070 Cyrillic трабл
Eleria; 28.4.04

Re: S7 224 + TP070 Cyrillic трабл
Андр; 6.8.04

Так это что получается, если в строковой константе в памяти контроллера - русский текст,

так я его в строковом индикаторе в ТР070 НЕ УВИЖУ ???

ТОВАРИЩИ! ну подскажите, плс, а то я ни 224 ни ТР070 в руках еще не держал.
Re: S7 224 + TP070 Cyrillic трабл
Юрий; 10.8.04

Возьмите вместо ТР070 - ТР170micro, цена та же, но заявлено, что символы кирилицы она понимает.


text

А нету извлечения абсолютной величины числа в микровине!!
Андр; 9.8.04

А нету извлечения абсолютной величины числа в микровине!! Опять городушки городить... елы-палы,

ну может у кого завалялся оператор извлечения абсолютной величины ?? 8-)<


text

Выбор коммуникационного процессора
"tea-pot"; 9.8.04

Всем доброго времени суток!

Успешно работает оборудование на S5-100U (100, 102) и PG-710.

Появилось оборудование под S7-200 (224), но без программатора. :-(

Увы, местный поставщик внятно не ответил на вопрос, какой коммуникационный процессор (к ПК СР-5611; 5613...) приобрести, чтоб не было проблем и с S5. Посоветуйте...

Есть еще одна заморочка. Как организовать съем информациb с S5-100U, S7-200 во время технологического процесса.

Заранее спасибо.
Re: Выбор коммуникационного процессора
Андрей Гуленок; 9.8.04

Появилось оборудование под S7-200 (224), но без программатора. :-(

Увы, местный поставщик внятно не ответил на вопрос, какой коммуникационный процессор (к ПК СР-5611; 5613...) приобрести, чтоб не было проблем и с S5. Посоветуйте...

Не совсем понятно что имеется в виду. Для S7-200 достаточно PPI кабеля или 5611. Но причём здесь S5?

Есть еще одна заморочка. Как организовать съем информациb с S5-100U, S7-200 во время технологического процесса.

А нужно что, связать сотку и двухсотку, или увязать их в сеть с головным устройством?

Re: Выбор коммуникационного процессора
"tea-pot"; 9.8.04

Спасибо, что откликнулись. :-)

Не совсем понятно что имеется в виду. Для S7-200 достаточно PPI кабеля или 5611. Но причём здесь S5?

А для S5-100U тоже подойдет 5611?
В чем преимущество 5611 перед PPI кабелем?

----------------
А нужно что, связать сотку и двухсотку, или увязать их в сеть с головным устройством?

Есть изолированные CPU. Нужно организовать протоколирование сигналов в ПК. Похоже надо будет увязывать в сеть с головным устройством.

Re: Выбор коммуникационного процессора
Андрей Гуленок; 9.8.04

А для S5-100U тоже подойдет 5611?

Нет

В чем преимущество 5611 перед PPI кабелем?

5611 универсальнее.

Похоже надо будет увязывать в сеть с головным устройством.

Двухсотки - по инструкции. С сотками сложнее. Для них был СР 541, но все старые S5 потихоньку перестают выпускаться и 90-95-100 в первую очередь. Возможно будет дешевле демонтировать сотую серию и заменить её на S7-200.

Re: Выбор коммуникационного процессора
"tea-pot"; 9.8.04

>А для S5-100U тоже подойдет 5611?

>Нет

Т.е. для S5-100U только кабель и нет чего-нибудь единого для S5-100U и S7-200?

---------------------------------
>Возможно будет дешевле демонтировать сотую серию и заменить её на S7-200.

Дело в том, что есть в наличии сотки. Не хочется чтобы просто лежали на полке.
Насколько я понимаю, надо сначало связать в сеть контроллеры (сотки через СР 541), а уже потом их опрашивать на предмет данных.
В ПК нужна плата или только Soft?
А S7-200 c S5-100U связать можно?
<


text

S7-200 и PID
Vladimir; 5.8.04

Возможно ли сделать 2 ПИД-регулятора с помощью Instruction Wizard на двух системных прерываниях?

Буду очень признателен за ответ!
Re: S7-200 и PID
Андр; 6.8.04

я вот тут тоже этой темой занимаюсь...

под системными преррываниями имелось ввиду прерывания по времени 0 и 1 ??

...имхуется мне, что невозможно,
на мой взгляд надо вручную делать.
есть такая команда PID называется, если по ней хелп посмотреть - сразу все ясно (стало мне, по крайней мере)

я вот все как там написано так и сделал.
Re: S7-200 и PID
Vladimir; 6.8.04

Такая команда есть ;)...однако примеры в документациях и хелпах ориентированы на аналоговый выход. Мне необходимо чтобы выход ПИД-регулятора воздействовал на два встроенных цифровых выхода S7-200 для открытия и закрытия соответствующего ИЭМ, управляющего процессом. Есть ли примеры реализации ПИД-регулятора с таким выходом?

Re: S7-200 и PID
Vladimir; 6.8.04

Такая команда есть ;)...однако примеры в документациях и хелпах ориентированы на аналоговый выход. Мне необходимо чтобы выход ПИД-регулятора воздействовал на два встроенных цифровых выхода S7-200 для открытия и закрытия соответствующего ИЭМ, управляющего процессом. Есть ли примеры реализации ПИД-регулятора с таким выходом?

Re: S7-200 и PID
Андр; 9.8.04

и я вот тоже пытаюсь воздействовать на два электромеханизма...

имхо надо смотреть на выход пи регулятора если он положительный то к примеру закрывать, а если отрицательный то открывать, а вообще все не так просто.
Re: S7-200 и PID
JP MIMARD; 9.8.04

If your PID output is between -100% to 100%, you can try to do something

like this :

Compare output with Zero, and wire as case box

If greater put your first relay ( for heating) to ON (or off depend on
your process), and wait a time of X.Pid output
(for example PID = 50% waiting = 500 ms, PID = 100% waiting 1000 ms, and so
on ...)
After waiting invert the digital ouput

If lower make the same action with the second relay (for cooling if exist)
and wait the absolute value of Pid.

You can have better result with a third state case, for example :
Less than -10 : R1 On, wait Pid.X, R1 Off
Between -10 to +10 : Nothing, the system is stable and the control loop can
terminate
greater than +10 : R2 On, wait Pid.x, R2 Off

good luck

Re: S7-200 и PID
JP MIMARD; 9.8.04

If your PID output is between -100% to 100%, you can try to do something

like this :

Compare output with Zero, and wire as case box

If greater put your first relay ( for heating) to ON (or off depend on
your process), and wait a time of X.Pid output
(for example PID = 50% waiting = 500 ms, PID = 100% waiting 1000 ms, and so
on ...)
After waiting invert the digital ouput

If lower make the same action with the second relay (for cooling if exist)
and wait the absolute value of Pid.

You can have better result with a third state case, for example :
Less than -10 : R1 On, wait Pid.X, R1 Off
Between -10 to +10 : Nothing, the system is stable and the control loop can
terminate
greater than +10 : R2 On, wait Pid.x, R2 Off

good luck

<


text

Подключение слейва к 315-dp( 6ES7 315-2AF03-0AB0)
mvi; 5.8.04

Неоднократные попытки подключение по Profibus-DP слейва к данному процессору не увенчались успехом.

С 315-2AG10-0AB0 никаких проблем не возникло. А этот обычного IM-153 в упор не видит. Может кто-то может сказать в чем осбенности этого 315-2AF03.../V1.2 и как с ним бороться.
Re: Подключение слейва к 315-dp( 6ES7 315-2AF03-0AB0)
Владимир; 6.8.04

У нас с ним нет проблем . На встроенном DP висит 4 IM153-1 все работает

Re: Подключение слейва к 315-dp( 6ES7 315-2AF03-0AB0)
Ланецкий; 6.8.04

Достаточно много таких контроллеров, практически у всех задействован интерфейс Profibus-DP. Никогда не было никаких проблем.

С уважением.
Ланецкий.<


text

to sergio19 - CPU945
Alexander; 5.8.04

Прошу уточнить адрес электронной почты или по телефону (095) 136-63-88


text

проблема в подключении ноутбука
Den; 27.7.04

У нас возникла проблема в подключении обычного ноутбука к SIMATIC S5 115U CPU943.

Приобрели STEP5 V7.11 с авторизацией, конвертор RS232/TTY (6ES5 734-1BD20, V3). Пытался связатся на AS511, но пишет то таймаут, то неопределенный знак AG. Что еще нужно?
Через программатор связывается без проблем

Re: проблема в подключении ноутбука
GorA; 27.7.04

Попробуйте поиграть скоростью COM порта, куда подключен преобразователь, в сторону уменьшения в настройках.

Re: проблема в подключении ноутбука
sasha; 29.7.04

У меня была неустойчевая связь (связь прерывалась через пару минут связи по таймауту ).Все стало отлично работать после установки win2000 и step5 v7.23.

Re: проблема в подключении ноутбука
Den; 30.7.04

с S5-100U CPU102 он связывается. Почему нет связи с S5-115U?

Re: проблема в подключении ноутбука
Den; 30.7.04

Скорость Сом-порта менял,

не помогло.
Настройки СОМ порта: 9600, 8, 1, е

Re: проблема в подключении ноутбука
Den; 30.7.04

Выдает при попытке включения online

“Undefined character from the AS”
Re: проблема в подключении ноутбука
Александр; 3.8.04

Re: проблема в подключении ноутбука
GorA; 4.8.04

У нас в Step5-е при подключении через СОМ2-преобразователь RS232/TTY в настройке стоит AS511.Sonder7 Teleservice COM2. Может быть и вам что-то такое нужно сделать?

Re: проблема в подключении ноутбука
Den; 5.8.04

Win98

Re: проблема в подключении ноутбука
Александр; 5.8.04

С 98 уже давно не работал, а с 2000-й были похожие проблемы. Про них и на форуме писали. На XP все ОК, а под 2000 то видит, то нет, причем нет, гораздо чаще.


text

Подключение слейва к 315-dp( 6ES7 315-2AF03-0AB0)
mvi; 5.8.04

Неоднократные попытки подключение по Profibus-DP слейва к данному процессору не увенчались успехом.

С 315-2AG10-0AB0 никаких проблем не возникло. А этот обычного IM-153 в упор не видит. Может кто-то может сказать в чем осбенности этого 315-2AF03.../V1.2 и как с ним бороться.<


text

Рабочая память cpu414-3
Алексей; 19.7.04

Господа! Не подскажет ли кто-нибудь, есть ли возможность перераспределить рабочую память для блоков данных частично в пользу памяти для программного кода?

Re: Рабочая память cpu414-3
Wlad; 2.8.04

По опыту работы сужу - увы, невозможно.

Re: Рабочая память cpu414-3
Чистяков Дмитрий ОАО СеверСталь; 4.8.04

Купите модуль SRAM.

Или ещё как вариант, уменьшить максимальное количество входов-выходов. Это даст какой эффект, но на увеличение в двое расчитывать не стоит.
Рабочая память cpu414-3
Алексей; 5.8.04

Спасибо, за счёт ограничения максимума входов-выходов несколько десятков килобайт выиграл - мне пока больше и не нужно.


text

FM453+датчик
GorA; 4.8.04

Коллеги, кто использовал, или использует FM453 ответьте.

Возморжно-ли управляя шаговым двигателем посредством FM453-FM STEPDRIVE с абсолютным датчиком выключать или включать позиционирование устройства по желанию.
А также, возможно-ли подключение абсолютного датчика, не параметрируя его во вкладке MD, и передача полученного сигнала в CPU.<


text

роутинг
Astronom; 4.8.04

Не подскажите, ограничение по роутингу для новых 315-2DP (2AG10), по старым в доке написано ограничение 4, из практики вроде это ограничение и для новых процессоров.


text

Проблема с CPU S7-414H
Max; 23.7.04

Здравствуйте! Описание проблемы.

Имеется полигон- два CPU S7-400H объединённые в резервированную систему, переферия, etc. Один процессор через промежутки времени (15-60 мин) начинает мигать всеми лампочками сигнализируя о неисправности CPU. После отключения питания и паузы времени (остывание?) процессор тестирует память и после закачки программы приходит в норму. С принудительным обдувом процессор работает. Второй процессор работает нормально.
Что посоветуете делать? Cдавать на Siemens?
Re: Проблема с CPU S7-414H
Кухаренко Сергей, Siemens; 29.7.04

Обменивать по гарантии.

Re: Проблема с CPU S7-414H
Lucky; 4.8.04

Sdelajte firmware update na poslednjuu dostupnuju versiju, esli ne pomoget, garantijnij sluchay.


text

Аналоговые модули S7331 разного разрешения
Marina; 4.8.04

Вышел из строя блок ввода анал сигналов S7331 -7NF00-OABO 8x16bit.

Представительство Simemens предложило
взамен блок S7331-7KF02-0ABO 8x12 bit.
Смущает разница в разрешаюшей способности 16 и 12 bit модулей. Как это влияте на процесс чтения аналогового сигнала? Какие тонкости существуют при этом? Помогите.
Re: Аналоговые модули S7331 разного разрешения
Николай; 4.8.04

Разница в точности обработки сигнала - в 7NF00 - стоит АЦП 16 бит, а в предлагаемом 12. Поэтому все упирается в точность, с которой вы хотите получать аналоговые сигналы. Еще нужно посмотреть каким образом у вас подключены датчики к 7NF00 и возможен ли такой же способ подключения на предлагаемом модуле, а также типы датчиков


text

Modbus conversion table
Wlad; 2.8.04

S_MODB uses a Modbus Data Conversion Table located in a Data Block to map Modbus addresses to SIMATIC S7 PLC memory areas. Такое указание содержится в хэлпе по FB81 (S_MODB) из библиотеки ET200sSi. Но нигде не описан формат используемого при этом DB, равно как и не сказано, формирует ли система его самостоятельно при инициализации функции (что сомнительно), или же требуется создать его вручную. Собственно, в этом и заключается вопрос - что это за структура и с чем ее едят?

См. http://www.btc-automation.lv/

Re: Modbus conversion table
GorA; 3.8.04

Скорее всего структура DB определена самим FB81. Нужно просто в пользовательской программе вызвать FB81 и указать неиспользуемое или новое DB и система сама его сформирует.


text

Люди! Пример не могу найти импульсного ПИ регулятора для S7-200...
Андр; 29.7.04

Может кто чем поможет??

Re: Люди! Пример не могу найти импульсного ПИ регулятора для S7-200...
MooR; 2.8.04

В документации по двухсоткам отдельно расписан ПИД и отдельно использование импульсного выхода.


text

CP341 +dongle
koma; 27.7.04

Подскажите пожалуста назначение этого dongle если есть желание использовать modbus протокол.

Заранее спасибо.
Re: CP341 +dongle
Григорий; 27.7.04

В моем понимании - защита от копирования. Один процессор - одна программа.

Re: CP341 +dongle
koma; 30.7.04

Спасибо разобрался.


text

CP342-5(мастер), IM153-2(слэйв), SM331-7TB00 (модуль с HART), однако при конфигурации имеем проблемы со слэйвом - на CP342-5 мигает BUSF и горит RUN.
Трушин Михаил; 29.7.04

Имею CP342-5, периферию IM153-2, SM331-7TB00 (модуль с HART) и проблемы с ней.

На периферию навешан модуль аналоговых входов с HART протоколом.
Значения сигналов на входе аналогового модуля меняются (что видно в
программе) с изменением входного сигнала.
Проблема следующая на CP342-5 мигает сигнал ошибки BUSF и горит RUN. На IM153-2 и аналоговом модуле сигналов ошибок нет. Как убрать BUSF?
Из документации выяснил, что BUSF мигает при неправильно сконфигурированной
периферии. Внимательно неколько раз перичитал имеющуюся документацию как по
Profibus, так и по модулю аналоговых входов с HART протоколом.
В функциях приема - передачи данных ошибок нет (поля ERROR = 0).
Не один раз пробовал менять параметры и создавать заново проекты, но видимо
допускаю одну и ту же ошибку.
Т.е. в чем может быть ошибка?

Re: CP342-5(мастер), IM153-2(слэйв), SM331-7TB00 (модуль с HART), однако при конфигурации имеем проблемы со слэйвом - на CP342-5 мигает BUSF и горит RUN.
Николай; 30.7.04

Я использовал тоже IM153-2 с такими же модулями с поддержкой Hart - проблем не возникало. Вообще диод BUSF у меня моргал (и горел) при неустойчивой связи по Profibus - проблема устранилась понижением скорости сети


text

LOGO<->PC, связь
Александр Пятков; 25.9.03

Есть ли возможность связать Logo с компьютером, через какой порт, где взять драйвера?? Имеется в виду возможность оперативной связи в режиме RUN, например для считывания состояний выходов Logo.

Спасибо.
Re: LOGO<->PC, связь
Назаров Дмитрий; 25.9.03

Эта возможность появилась в ЛОГО 4-го поколения. Наблюдать за выполнением программы, стотоянием входов и выходов можно будет через программу LOGO SoftComfort 4 и стандартный кабель связи.

Re: LOGO<->PC, связь
Димон; 24.6.04

где скачать Logo soft v.4

я скачал обновление, программа загружается и работает но перед запуском требует дискету.
Re: LOGO<->PC, связь
Назаров Дмитрий; 25.6.04

Обновление ставили на старый LogoSoft 3?

Re: LOGO<->PC, связь
error; 26.6.04

как всегда siemens не последовал международным стандартам, а ввел свои собственные. Во-первых разработан S7-200 как центральное устройство для работы с LOGO! Во-вторых, создан свой кабель для соединения устройств. В-третьих, собственное ПО. И все эти удовольствия за деньги.

Re: LOGO<->PC, связь
Андрей Гуленок; 29.6.04

А что, есть международные стандарты на LOGO! ? Сименс вообще был пионером выведя на рынок подобное устройство. Интерфейсный разъем это вообще-то гнездо под модуль памяти и связь с РС - всего лишь дополнительная приятность. Нестандартный кабель - следствие этой опциональности. Это дешевле, чем сделать дополнительный "стандартный" порт и увеличить стоимость LOGO! хоть на несколько евро. Кстати сказать, стоимость кабеля сопоставима со стоимостью фирменного шнура для сотового телефона. Что касается софта, то его стоимость весьма формальна. Найти "халявный" диск в России не проблемма. Кроме того, LOGO! это интеллектуальное реле и все "если бы" просто не уместны. Если бы был порт, если бы была математика, если бы была поддержка сетей, если бы... то это называлось бы "S7-200". И стоило как двухсотка. (кстати сказать, он не на много дороже)

А на счёт софта... Скачивается абгрейт. Он в принципе самодостаточен, но требует предъявления предыдущей версии. По этому нужно сначала поставить рабочий логософт (например с наших дисков микросистемы) а потом накатить абгрейт с интернета.

А на счёт связи и визуализации по мимо логософта, - Сименс работает в этом направлении. Будет специальный комплект поддержки интерфейса.
LOGO <--> датчик PT100
Dimka; 28.7.04

Logo научился работать с датчиками PT-100 но немогу найти датчик накладной на трубу 1/2" - 1" в корпусе. подскажите где это моно найти


text

6ES5 095
Alex; 12.7.04

ES5 095 8MD01 ВКЛЮЧЕН КАК СТАНЦИЯ СОВМЕСТНО С ЕТ200.ГОЛОВНОЙ CPU 115 ПЕРЕСТАЛ ОПРЕДЕЛЯТЬ ЕГО АДРЕС.ПОМОГИТЕ.

Re: 6ES5 095
GorA; 13.7.04

Попробуйте сделать пререзапуск отключением питания: строго - сначала станции ET200, затем контроллер.

Re: 6ES5 095
Aex; 28.7.04

робовал не получается.как програмируется адрес в Е5 095??


text

Дисплей при t= -20 oC
mahsus; 28.7.04

Всем добрый день!

Помогите найти дисплей или панель фирмы Siemens, которая бы работала при температуре от -20 до +50 oC.
Заранее благодарен.
<


text

CPU 945
Alexander; 27.7.04

Необходим CPU 945 для S5-115U

Телефон (095)136-63-88 или на почту
sigalov@nobetek.ru<


text

s7-200 и ТрэйсМоуд
RS; 15.4.04

Кто нибудь их соединял? Нужна помощь, уже из сил выбился, не хотят по PPI связываться.

Re: s7-200 и ТрэйсМоуд
Олег Грузевич; 23.4.04

Думаю, что должно получиться с использованием SIMATIC S7-200 OPC Server. Проверено на практике для WinCC и Genesis.

Re: s7-200 и ТрэйсМоуд
ASLAN; 26.7.04

у меня работает как по драйверу так и через опс.

Если есть вопросы пиши на bukeev@cnpc-amg.kz<


text

S5-115
влад&мир; 21.7.04

Продаются з/ч к контроллеру SIMATIK S5 115U(4 комплекта) и остатки S5-100,135

6ES5951-7LD21
6ES5942-7UB11
6ES5943-7UB21
6ES5945-7UA23
6ES5420-7LA11
6ES5430-7LA12
6ES5454-7LA11
6ES5456-7LA11
6ES5306-7LA11
6ES5375-0LA41
6ES5705-0AF00
6ES5700-1LA12
6ES5701-1LA12
6ES5434-7LA12
6ES5451-7LA11
6ES5981-0HA11
6ES5103-8MA02
6ES5180-3AA11
6ES5245-1AA12
6ES5312-5AA21
6ES5316-8MA12
6ES5373-0AA21
6ES5400-7AA13
6ES5410-7AA11
6ES5421-8MA11
6ES5421-8MA12
6ES5340-3KB42
6ES5430-3BA11
6ES5430-4UA12
6ES5436-4UA12
6ES5455-6AA12
6ES5456-4UA12
6ES5490-7LB21
6ES5705-0BB50
все позиции складского хранения в упаковках. С уважением, Владимир

<


text

А что к S7-222 пять модулей нельзя подцепить? и чтобы работало??
Андр; 21.7.04

Уважаемые коллеги!

К CPU S7-222 реально нельзя подцепить 5 модулей EM: 221, 222, 231, 231, 232 ?
Чтобы соответственно все потом заработало, так сказать, программно??
Что-то в мануале сказано, что только 2 модуля расширения...
Re: А что к S7-222 пять модулей нельзя подцепить? и чтобы работало??
kot; 21.7.04

нет


text

А что к S7-222 пять модулей нельзя подцепить? и чтобы работало??
Андр; 21.7.04

Уважаемые коллеги!

К CPU S7-222 реально нельзя подцепить 5 модулей EM: 221, 222, 231, 231, 232 ?
Чтобы соответственно все потом заработало, так сказать, программно??
Что-то в мануале сказано, что только 2 модуля расширения...
Re: А что к S7-222 пять модулей нельзя подцепить? и чтобы работало??
Assa; 21.7.04

Если так сказано в руководстве, то так и есть. Не зря пишут руководства.


text

Field PG,PG720,PG685
Влад&мир; 21.7.04

Продам промышленные программаторы Field PG 128Mb, Windows2000, Step7v5.1, Step5v7.15,Microwin v3.1. PG720,PG740 и совсем "динозавр"PG685:)

Также есть много модулей,плат к SIMATIKу S5.
Пишите на мыло.Отвечу.
<


text

Метрологическая аттестация на Siemens
mahsus; 20.7.04

Привет всем!

Скажите, пожалуйста, можно ли запрограммировать контроллер фирмы Siemens на прием аналоговых сигналов с датчиков и проведение метрологической аттестации.
Заранее благодарен за ответ.
Re: Метрологическая аттестация на Siemens
Павел Иванов; 21.7.04

Если Вы посмотрите внимаетельнее на нашем сайте даже выложены метрологические сертификаты и методики поверки.

Поэтому я не пониманию постановку вопроса.
См. http://www.automation-drives.ru/as/support/cert/index.php


text

S5-135 продается в большом комплекте
AndyShcher; 14.2.03

Имеется 3 корзины с блоком питания(и две дополнительные) + набор модулей.

6ES5 928 3UB12
6ES5 446 3LA11
6GK1 143 0AA0
6ES5 470 4UA12
6ES5 308 3UA11
6ES5 300 5CA11
6ES5 188 3UA11

6ES5 184 3UA11
6ES5 451 4UA13
6ES5 454 4UA13
6ES5 312 5CA11
6ES5 430 4UA13

6ES5 318 8MB11
6ES5 482 8MA13
6ES5 421 8MA12
6ES5 441 8AA11
6ES5 463 4UB12
6ES5 460 4UA13.

Модули поставлены в 1996 году, в работе не были. Продажа или обмен на S7.
Re: S5-135 продается в большом комплекте
v10as; 14.4.03

Цены и способ оплаты, на E-mail, пожалуйста: v10as@rambler.ru.

Интересуют блоки 6ES5 928,6ES5 441.
Re: S5-135 продается в большом комплекте
AlexSYS; 21.7.04

Интересует блок 6es5 421-8ma12, есть ли в наличии, какая система оплаты и есественно цена.

AlexSYS@ngs.ru<


text

Подключение аналогового модуля -1KF01-
Андрей; 20.7.04

В английской документации на этот модуль есть замечание, что для предотвращения ошибок измерения необходимо соединить клеммы M-.

Возникает вопрос: это обязательное требование для используемых каналов, для всех каналов модуля или нормально работает без такого соединения? Возникали ли какие-нибудь проблемы при эксплуатации модуля? <


text

Перезапуск контроллера
Илья; 18.7.04

При перезапуске контроллера, который в свою очередь связан с коммуникационным процессором CP340, не хочет запускаться CP340.

Как синхронизовать бит запуска посылки CP340 после перезапуска, если во время перезапуска он выполнял посылки команд?
Заранее спасибо.<


text

CPU315-2DP и Step7
Владимир; 15.7.04

В Step7 v5.2 в хадварэ версия CPU315-2DP 2.0 ,а сам процессор у нас версии 2.0.5 Будет ли он корректно работать.А как можно апгрейтнуть Step , чтобы там версия была тоже 2.0.5

Re: CPU315-2DP и Step7
Кобелев Павел; 16.7.04

Заказной номер процессора какой?

Re: CPU315-2DP и Step7
Владимир; 16.7.04

6ES7 315-2AG10-OAAO v.2.0.5

Re: CPU315-2DP и Step7
Назаров Дмитрий; 16.7.04

В STEP 7 в HW крнфигураторе есть пункт меню HW Update. Возпользуйтесь им и скачайте обновления аппартаной части контроллеров.

Re: CPU315-2DP и Step7
Лёха; 16.7.04

А по-моему он и так будет работать


text

Карта памяти S7-315 2DP
Владимир; 12.7.04

Получили новый CPU 315 2DP тонкий и там стоит карта памяти другая , не как в старом. Есть ли отличия по работе новой картой? И где можно взять доку на неё?

Re: Карта памяти S7-315 2DP
Darwin; 13.7.04

Другая, т.к. эта карта (если речь идет о MMC) работает как Загрузочная и рабочая память. А зачем доку?

Re: Карта памяти S7-315 2DP
Владимир; 13.7.04

Карта ММС 512 кб .Документация нужна чтобы понять как с ней работать.

Re: Карта памяти S7-315 2DP
Кобелев Павел; 13.7.04

Про новые карты памяти можно почитать на Customer Support

Entry ID:18483013
Ссылка ниже.
См. http://www4.ad.siemens.de/-snm-0135030360-1088511457-0000031167-0000000027-1089706022-enm-WW/skm/newSKM/frameset.asp?markerurl=%2FWW%2Fllisapi%2Edll%3Ffunc%3Dll%26objID%3D18483013%26objaction%3Dcsview%26lang%3Den%26siteid%3Dcseus&lang=en&aktprim=0&siteid=cseus&query=new%20MMC&searchinprim=&BID=18483013&cur_pos=0


text

Написание GSD-файла
LV; 5.2.04

Как написать свой GSD-файл для своего нестандартного устройства, подключенного к Profibus?

Re: Написание GSD-файла
Назаров Дмитрий; 5.2.04

Вы что сами устройство Профибас сделали!!? Если сами сделали то должны уж знать...

Re: Написание GSD-файла
Роман Абзаев; 5.2.04

Если Вы его сделали, то, по идее, Вы использовали ASIC-микросхему и соответствующую документацию и т.п. Разве там нет описания общей процедуры подготовки .gsd файла?

Re: Написание GSD-файла
VVV; 5.2.04

Почитайте на http://www.profibus.com/

Re: Написание GSD-файла
LV; 5.2.04

Не устройство Профибас, а устройство с выходом на Профибас через стандартный мультиплексор. И когда люди знают, они не задают вопросы.

Re: Написание GSD-файла
GUI; 28.6.04

Молодец, товарищ LV! А то некоторые любят воду в ступе взбалтывать попусту, чем дельный совет дать... Наверное не знают... И имеют весьма поверхностное представление о микросхемах ASIC в том числе :-)

Re: Написание GSD-файла
Григорий; 30.6.04

Вообще на Customer Support примерно в разделе net - Profibus - ... asic должна быть ссылка на Gsd.pdf - это и есть файл описания как писать GSD. Я пошел другим путем - отредактировал существующий GSD-файл от siemens.

p.s. если не секрет, то на какой мелкосхеме разрабатываете. Ответ можно на майл.
Re: Написание GSD-файла
Владимир; 13.7.04

Поищите в инете .В свое время я скачал оттуда редактор GSD файлов.Но уже потер.


text

Межконтроллерная связь по Ethernet
Сергей К.; 9.7.04

Господа!

Возможно ли организовать связь между контроллерами S7-300 по Ethernet с использованием соответствующих CP и при этом по этой же сети должна получать данные WinCC.
Один контроллер ведущий и два ведомых или все три независимые.

Заранее спасибо.
Re: Межконтроллерная связь по Ethernet
GorA; 11.7.04

Это все возможно, главное не превышать количество возможных link-ов в конкретном CPU

Re: Межконтроллерная связь по Ethernet
Сергей К.; 12.7.04

Спасибо за ответ.

Если можно уточнить на счет Link-ов.
На сколько я понимаю Link-и можно считать по количеству поддерживаемых CP. Но сразу возникает вопрос о встроенном DP интерфейсе, считать ли его отдельной CP или нет (в каталоге он помечен как CP 342-5) и входят ли IM 365 в разряд CP?
Если не трудно пояснить на моем примере.
Есть CPU 316-2DP:
- по встроенному Profibus DP обрабатываем ET-200M
- через IM 365 обрабатываем рейки расширения
- через CP 343-1 организуем связь между аналогично сконфигурированными контроллерами и WinCC.

Будет ли это работать?

Заранее спасибо.<


text

СРОЧНО!! Карты памяти
Георгий; 7.7.04

Г-да подскажите, срочно нужно поменять карты памяти для контроллера S7-300 (не хватило :( памяти )не подойдут ли обычные флэшки, а то ждать поставки долго, а надо уже сейчас:)

Заранее спасибо.
Re: СРОЧНО!! Карты памяти
Darwin; 8.7.04

Суть в том, Сименовская флэшка отформатирована особым образом, так что обычные флэшки не подойдут.

Re: СРОЧНО!! Карты памяти
Сапельников Артем; 12.7.04

А какая карточка нужна (по объему)


text

Карта памяти S7-315 2DP
Владимир; 12.7.04

Получили новый CPU 315 2DP тонкий и там стоит карта памяти другая , не как в старом. Есть ли отличия по работе новой картой? И где можно взять доку на неё?


text

Синхронизация времени в S7-200
Дмитрий; 12.7.04

Можно-ли в S7-200 привязаться к биту Clock_60s (SM0.4) или Clock_1s (SM0.5) для синхронизации программного счетчика миллисекунд с началом секунды внутрених часов контроллера? т.е. изменение значения этих бит привязано к внутренним часам или нет?


text

CP341 modbus master
Чистяков Дмитрий ОАО СеверСталь; 1.7.04

Модуль CP341 стоит в станции ET200M (IM153-2). В него закачан протокол Modbus Master.

А проблема в том что хоть блок передачи и вызывается, но все его статусные выхода всегда по нулям. Хотя передача происходит (это видно по светодиоду).
Кто нибудь с таким случаем сталкивался?
Re: CP341 modbus master
Григорий; 1.7.04

Насколько я понял, читая в свое время, описание реализации протокола, то он просто добавляет определенный функциональный блок, реализация которого производится CPU,+ картинку для параметризации, поэтому я полагаю, что в ЕТ протокол работать не будет ввиду отсутствия CPU.

Re: CP341 modbus master
Astronom; 12.7.04

Modbus Master на ЕТ-ке работать будет и нормально (у меня фунцыклирует)

мигает, я так понимаю лампочка -Send.
Горит ли SF.
в коде я так понял вы не видете Done?<


text

обмен данными м-ду CPU в многопроцессорной схеме
McClane; 8.7.04

С помощью каких функций обмениваться данными между процессорами через системную шину, если их стоит в крейте два или более?


text

Что есть ММС?
ИГОРЬ; 6.5.04

Отличается ли Micro Memory Card, используемая в S7 314С от Multi Media Card, и если отличается, то чем?

Re: Что есть ММС?
Олег; 6.5.04

Физически ничем.

Но сименсовские Micro Memory Card
прошиваются при изготовлении своим
идентификатором, без которого контроллер их не воспринимает.
Re: Что есть ММС?
Вячеслав; 8.7.04

А можно ли самому перепрошить Multi Media Card под Siemens.

Re: Что есть ММС?
Андрей Гуленок; 8.7.04

Видимо нельзя. Или никто не знает как. Мы восстанавливали затёртую флешку специальной сервисной программой. Но она работает только с оригинальными ММС. Если взять произвольную, то программа её не признаёт и форматировать отказывается.


text

Размещение S7-200
Андрей; 8.7.04

Возможно ли размещение S7-200 в одном шкафу с контакторами SIRIUS 3R на мощность 45 кВт. Могут ли возникнуть проблемы в работе контроллера из-за помех?

Re: Размещение S7-200
ABC; 8.7.04

У меня аналогичные мощные контакторы с одном шкафу с S5 стояли неплохо, но потом пошел механический дребезг, пришлось их перевесить на другую стенку.


text

Карты памяти
Георгий; 7.7.04

Г-да подскажите, срочно нужно поменять карты памяти для контроллера S7-300 (не хватило :( памяти )не подойдут ли обычные флэшки, а то ждать поставки долго, а надо уже сейчас:)

Заранее спасибо.<


text

Требуется аналоговая карточка 6ES5460-4UA12
mvi; 6.7.04

Куплю б/у аналоговую карточку 6ES5460-4UA12, есть также необходимость в карточке аналоговых выходов 6ES5 470-4UA13, а также цифровых входов 6ES5 436-4UA12.

Предложения можно слать на mail.
<


text

S 5 Adapter for S 7 400
Sasha; 2.7.04

Уважемые, столкнулся с такой проблемой.

Похоже "накрылся" модуль IBS S7 400 DSC/I-T, с начальным адресом 20, в HW Config он обозван как S 5 Adapter. Вообще говоря к нему подлючена ветка Interbus. Сам этот модуль стоит в Стопе соответственно CPU там же с INTF.
Проверили всю переферию - все живое. Программа CPU рабочая. Лично я грешу на то что в самом модуле слетела его "прошивка" либо чет апаратное.
Прошу Вас подтвердить или развеять мои сомнения.
Да .
Вот что дает диагностический буфер CPU.
Diagnostic buffer of module CPU 412-1

Order No./ Description Component Version
6ES7 412-1XF03-0AB0 Hardware 6
- - - Firmware V 3.0.2

Rack: 0
Slot: 2

Event 1 of 120: Event ID 16# 5961
Parameter assignment error in CPU module parameters
Parameter: subrack
subrack: 0
Error type: type ID of central unit: actual ID does not match set ID
Operating mode: STOP (internal)
External error, Incoming event
12:25:53:622 pm 07/01/04

Event 2 of 120: Event ID 16# 5961
Parameter assignment error in CPU module parameters
Parameter: slot
Input address: 20 of the module with parameter assignment errors
Error type: configurable slot empty
Operating mode: STOP (internal)
External error, Incoming event
12:25:53:622 pm 07/01/04

Event 3 of 120: Event ID 16# 530D
New startup information in STOP mode
Startup prevented by:
- STOP request exists
- Cold restart or warm restart necessary
Startup information:
- Time for time stamp at the last backed up power on
- Single processor operation
Current/last startup type:
- Warm restart triggered by switch setting
Permissibility of certain startup types:
- Manual warm restart permitted
Last valid operation or setting of automatic startup type at power on:
- No startup type/following memory reset
Operating mode: STOP (internal)
Incoming event
12:25:53:607 pm 07/01/04

Event 4 of 120: Event ID 16# 5311
Startup although ready message not received from modules
Operating mode: STOP (own initialization)
Incoming event
12:25:53:603 pm 07/01/04

Event 5 of 120: Event ID 16# 4300
Power on backed up
Initialization information: Initialization after power on (backed up CPU)
Previous operating mode: No voltage
Requested operating mode: STOP (own initialization)
Incoming event
12:24:48:786 pm 07/01/04

Re: S 5 Adapter for S 7 400
Sasha; 2.7.04

Чуть не забыл ...

Мот у кого есть мануал на такой или подобные модули.
Кинте на мыло .
Заранее...<


text

Как запустить таймер?
Новичок-Алексей; 28.6.04

У меня PG720 115U программа на STEP5.Необходимо реализовать задержку на 5сек в шаговом блоке.Загоняю в таймер значение,а он не запускается.Может кто подскажет новичку как его пинуть.Вот текст:

c db 36
l dw 120
t t 36
sd t36

a t 36
Re: Как запустить таймер?
VVV; 29.6.04

Мне кажется у вас нет запускающего условия перед командой SD T36

Например
A i 100.1
Re: Как запустить таймер?
VVV; 29.6.04

И загружать время в таймер не нужно.То есть не нужна команта Т Т36.

Классический запуск таймера:
А I 100.1
L KT 005.2 //Смотри константы времени
SD T 36

A T36
.....//Что то делаем
Re: Как запустить таймер?
Алексей; 30.6.04

Спасибо за ответ VVV,вот только не прошел и этот вариант.Условие A I 100.1 у меня было(A F233.0).Значение в таймер я хотел подставить то,что устанавливается с панели оператора,но даже и в Вашем варианте(без команды T t36) таймер занеся значение 5сек стоит и не считается RLO=1 RN S 005.2

Но мы выкарабкаемся,надеюсь

Re: Как запустить таймер?
vvv; 30.6.04

Значит у вас запускающее условие не делает фронт.

Re: Как запустить таймер?
Алексей; 1.7.04

Спасибо за содействие.Рад что нашел такой форум и человека, с которым поделился проблемой и он дал мне вариант решения.Спасибо


text

два ТД200 и S7-200
Михаил; 30.6.04

как соединить между собой CPU224 и TD200? в каталоге нарисована PPI сеть.

как и с помощью чего ее организовать?
Re: два ТД200 и S7-200
Андрей Гуленок; 30.6.04

>> как соединить между собой CPU224 и TD200?

Согласно инструкции. Которая есть на этом сайте в разделе микросистемы. Там подробно рассказано как соеденить, как настроить, какие ограничения. Целая глава этому посвещена.
>>в каталоге нарисована PPI сеть.
как и с помощью чего ее организовать?
C помощью Profibus компонентов. Понадобится кабель и BUS-коннекторы. Только их надо брать с разъёмом для программатора.
В рукаводстве на S7-200 всё очень продробно расписано. С картинками.<


text

Вопрос по эксплуатации TD 200 и о возможности хранения параметров в памяти S7-200
Big; 28.6.04

Вопросы такие:

1. Насколько удобно использовать TD200 как человеко-машинный интерфейс? (не мелковаты лы буквы, подсветка, удобство работы, срок работы)
2. Можно ли в памяти контроллера S7-200 (энергонезависимой)организовать хранение данных, которые можно будет корректировать и воспроизводить при новых включениях контроллера?

Заранее благодарен за ответы
Re: Вопрос по эксплуатации TD 200 и о возможности хранения параметров в памяти S7-200
Андрей Гуленок; 29.6.04

1) Смотря для каких целей. На стенку её конечно не повесишь, но в пульте дисплей смотрится очень неплохо.

2)Да, можно. Но именно организовать.<


text

Непонятные области и блоки S5
Михаил; 21.6.04

Здравствуйте,специалисты по SIMATIC S5!

Анализируя программу управления линией,у меня возникло несколько вопросов.(Контроллер S5-135U,сеть INTERBUS,соединен с компьютером с помощью SINEC L2)
1.В программе неоднократно происходит безусловный вызов блоков OB150,OB152,ОВ180,ОВ220.Однако,в списке блоков таковые отсутствуют!Программу скачивал с помощью оболочки PG-95 и S5W.Что это за хитрые блоки и как их просматреть(редактировать)?
2.В списке блоков имеются блоки FX,FC,PV,FV,OC,DV,DC,PC,FBDO,PBDO,DBDO.
Там что-то похожее на комментарии,но хотелось бы иметь более глубокое представление об этих блоках:зачем и для чего они существуют,где происходит их вызов?
3.Дайте пожалуйста более полное объяснение понятиям P-и Q-областям памяти?
Заранее благодарен
Михаил
lacuss@mail.ru

Re: Непонятные области и блоки S5
Константин; 22.6.04

Какой-то тут грустный форум. Никто не отвечает :-(

Re: Непонятные области и блоки S5
Igont; 22.6.04

На все вопросы ответа краткого не дам.

Но....
Перечисленные ОВ блоки - встроенные в
операционную систему S5-135.
В программерской доке по S5-135
эти OB расписаны. Если не найдете,
пишите в форум - распишу.

Re: Непонятные области и блоки S5
Lucky; 23.6.04

FX- FB, dopolnitelnaja oblast nomerov (esli FB nomera vse ispolsovani)

PV,FV,FXV - sagolovki blokov PB,FB, sodergat informaziju tipa imen metok prigkov (V-Vorkopf(nem, sagolovok, header))
DV,DXV-sagolovok bloka dannich, sodergit tipi dannich
xC-bloki kommentariev,sodergat sagolovki k kagdomu segmentu bloka i kommentarii k otdelnim kommandam (tolko v AWL )
xDO-dokumentazija, kommentarij k kagdomu segmentu
Naschet P-Q- dolgaja istorija, vkratze rech' idet ob adresazii periferii, P- ZG, zentralnaja stojka, Q- EG, stojka rasshirenija,(po opredeleniju) adressuetsja cheres interfehsnij modul'..
Ispolsuetsja esli ne chvataet osnovnoj oblasti adresov dlja DI/DO, AI/AO. Podrobnosti esli nugno napishu na milo..
Re: Непонятные области и блоки S5
Lucky; 23.6.04

FX- FB, dopolnitelnaja oblast nomerov (esli FB nomera vse ispolsovani)

PV,FV,FXV - sagolovki blokov PB,FB, sodergat informaziju tipa imen metok prigkov (V-Vorkopf(nem, sagolovok, header))
DV,DXV-sagolovok bloka dannich, sodergit tipi dannich
xC-bloki kommentariev,sodergat sagolovki k kagdomu segmentu bloka i kommentarii k otdelnim kommandam (tolko v AWL )
xDO-dokumentazija, kommentarij k kagdomu segmentu
Naschet P-Q- dolgaja istorija, vkratze rech' idet ob adresazii periferii, P- ZG, zentralnaja stojka, Q- EG, stojka rasshirenija,(po opredeleniju) adressuetsja cheres interfehsnij modul'..
Ispolsuetsja esli ne chvataet osnovnoj oblasti adresov dlja DI/DO, AI/AO. Podrobnosti esli nugno napishu na milo..<


text

Ошибка с регистром DI при настройке FB 41
Максим; 24.4.04

При настройке FB 41 в буфере обмена появляется ошибка доступа к регистру DI, CPU переходит в состояние STOP?

Re: Ошибка с регистром DI при настройке FB 41
VVV; 26.4.04

Что значит "при настройке FB41"? Что конкретно Вы делаете?

Re: Ошибка с регистром DI при настройке FB 41
Blkz; 23.6.04

Are You downloaded instance DB?

Re: Ошибка с регистром DI при настройке FB 41
GorA; 23.6.04

А что такое FB41?

Это ваш собственный FB или из какой-то библиотеки?
Каждому FB (функциональному блоку) соответствует DB (блок данных), сформированный по переменным в FB (in-, out-, in-out-, stat-), если вы меняете эти переменные необходимо перетранслировать и соответствующий DB.
Полученный экземпляр DB, в функциональном блоке адресуется посредством регистра DI. В вашем случае нарушается адресация FB к экземпляру DB.
Чтобы лишний раз CPU не выходил в состояние стоп нужно создать (можно пустые) OB80 - OB87, OB121, OB122.<


text

gsd editor
Григ; 16.6.04

Как скачатю gsd editor c profibus.com

или еще откуда-нибудь?
Re: gsd editor
Константин; 22.6.04

Скачали?!

Re: gsd editor
Григ; 22.6.04

пока нет. Нужен пароль для входа, хотя и утверждается , что это свободно


text

S5 !!! Срочно !!! Нужна помощь!!!
Александр; 16.6.04

Привет всем!!!

У меня возникла огромная проблемма с 5-м симатиком - не хочет выходить в режим RUN, находится в стопе и моргает светодиод DIAGN (s5 95F + s5 95F соединены меж собой и оба в таком состоянии) я с помощью s5w смотрю ошибку, они оба пишут "Ошибка самотестирования" (это-то в принципе и так видно :((( )
Помогите плз.
Re: S5 !!! Срочно !!! Нужна помощь!!!
Pavel; 16.6.04

А что было первопричиной?

Можно попробовать перезагрузку программы?
Re: S5 !!! Срочно !!! Нужна помощь!!!
Александр; 17.6.04

Спасибо, всем кто откликнулся, все нормально...


text

Модем ТС35
Артем; 16.6.04

Столкнулся с проблемой. Используется модем Сименс ТС35 для приема/передачи sms сообщений, так вот на передачу все работает, на прием не хочет. При этом до модема с мобильного дозваниваешься, а sms не доставляются, как будто модем выключен.


text

s7-200 modbus master
rs; 15.6.04

может ли быть s7-200 modbus master'ом???

Re: s7-200 modbus master
Андрей Гуленок; 16.6.04

Штатно он слейв. Причём реализован протокол в режиме свободнопрограммированного порта. В принципе никто не мешает написать программу для реализации модбас мастера, вот только никто этого ещё не сделал.

Re: s7-200 modbus master
rs; 16.6.04

спасибо, я попробую, если что, буду первым ;)


text

PC Adapter RS232/RS485
Константин Власкин; 11.6.04

Будут ли работать данные адаптеры(заказной номер 6ES7 972-0CA2x-0XA0) с несименовским оборудованием?

Re: PC Adapter RS232/RS485
Андрей; 12.6.04

Этот PC Adapter не просто конвертор RS232/RS485(внутри куча чипов),а что-то похожее на модем, потому что скорость RS232 отличается от RS485. Я думаю, работать не будет. Если нужен просто конвертор RS232/RS485 то бери 6ES7901-3CB30-0XA0 и стоит гораздо дешевле.

Re: PC Adapter RS232/RS485
Владимр; 14.6.04

I-7520 - ~60 у.е

Re: PC Adapter RS232/RS485
Григорий; 15.6.04

Лучше adam-4520. Гальваническая развяязка, хорошая дальнобойность и автоматическое переключение прием/передача

Re: PC Adapter RS232/RS485
Константин Власкин; 16.6.04

Спасибо за ответы. Я тут подумал и решил что adam-4561 будет в самый раз.


text

аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Николай; 5.5.04

Никто не сталкивался с такой проблемой: при выключении питания модуля ток в выходной цепи просаживается, т.е. в выходной цепи модуля М- стоит еще один измеритель тока после которого идет заземление и на нем видна просадка сигнала.

И вообще кто работал с модулями аналогового ввода 6ES7331-7KF01-0AB0 не сталкивался ли с проблемой влияния каналов друг на друга - при том что все датчики с заземлением и земля та же что и у питания контроллера???
Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Валентин; 1.6.04

По какой схеме (2-х или 4-х проводной) включены датчики?

Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Николай; 1.6.04

по 2х проводной схеме

Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Валентин; 1.6.04

Что значит "просадка сигнала"?

Какой величиной она выражается?
Имеет ли второй измеритель тока вывод входа , связанный с общим проводом?
Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Pavel; 1.6.04

Таких проблем не замечали. Но сигнальный (-) не должен быть соеденен с землей. Вообще при двухпроводной схнме экранировка как

правило не нужна, только при больших растояниях.
Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Валентин; 1.6.04

Вы не ответили про величину просадки тока при отключении питания, о которой говорили в вопросе

Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Николай; 2.6.04

Объясню все более подробно:

Существовала задача сделать следящую систему по датчикам производства (АСОДУ), которая работала бы параллельно с АСУТП фирмы HoneyWell.
Заказчик выдал ТЗ на то, что в нашу систему приходят только активные токовые датчики (соответственно на модуле используются только 2 клемы I+ и M-). Соответственно в цепи датчика получается последовательно включенными наша следящая система и АСУТП. При этом на АСУТП все датчики заземляются на общую землю (соответственно все M- на модуле висят на одной земле). И вот возникли следующие проблемы:
- влияние датчиков друг на друга (некоторые)
- а при снятии питания с модуля (например на станции ET200) на АСУТП происходит просадка всех сигналов на 10-15%
Долго разбирались с проблемой и ребята из сименса помогали, только вот у этого модуля интересная схема, по которой не понятен принцип его работы. Ну вообще понятно что по модулю идут перетоки, да и в самом модуле есть еще непонятно для чего источник питания.
В данный момент вопрос планируется решить установкой гальванических развязок на каналы.
Спасибо за ответы,
если есть идеи пишите
Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Валентин; 2.6.04

Я извиняюсь, но,очевидно, не понял все до конца. Вы говорите об активных датчиках, подразумевя у них питание от отдельного источника? 4-х проводной схемой подключения называется схема, когда цепь питания датчика и токовая цепь разделены. 2-х проводная схема подразумевает, что цепь питания и сигнальная цепь об"единены. При выборе на модуле ввода 4-х проводной схемы подключения измерительный резистор модуля (25 Ом) не связан с L- и включен между клеммами М+ и М-. Если Вы выбираете 2-х проводную схему подключения (получя тем самым питание датчика от модуля с клеммы М+), измерительный резистор модуля подключается одним концом к М-, а вторым - к L-.

Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Николай; 2.6.04

Датчики есть как по 2х проводной так и по 4х, только для нашей следящей системы это не имеет значения так как все датчики питаются от независимых источников - т.е. на модуль аналогового ввода подключается 2 провода - один на I+ другой на M- и все (только сигнальная цепь - т.е. от модуля мы датчики не питаем).

Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Pavel; 2.6.04

Или я ничего не понимаю, или одно из двух.

Четырехпроводная схема означает в общем случае что датчик является активным, т.е. он выдает на измеритель
токовый сигнал.
Двухпроводная схема-датчик пассивный,
источником питани является измеритель,
а величина тока потребляемого датчиком и есть измеряемая величина, вот для этого режима и имеется встроенный источник питания.
Далее-модуль имеет разбивку входов на 4 группы по 2 входа в каждой.
Соответственно режим работы каналов устанавливаемый переключателем, должен
быть одинаковым.
У вас если я правильно понял, питание
датчиков четырехпроводное(на каждый датчик свой источник), положение
переключателя -С.
Мы подобную задачу решали когда подцеплялись к системе где стоял S5,
и у нас все работало.
Если можно, скинь схему, тогда
разговор будет более предметный
Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Pavel; 2.6.04

Вдогон.

Схема соединения должна выглядеть
примерно так- Выход датчика(+) --
Вход S7 (+М) -- Выход S7 (-M) ---
Вход АСУ (+) --- Выход АСУ(-) ---
Выход датчика (-).
Заземляется только (-) на стороне АСУ.
Модуль в режиме четырехпроводной схемы. А то похоже у вас токовый сигнал подпн паралельно на две системы.
Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Николай; 4.6.04

схема соединения так и выглядит

если интересно могу прислать схему подключения, так как на словах понять тяжело. Только вот куда прислать не знаю
Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Валентин; 7.6.04

Николай, Вы пишете про 2-х и 4-х проводные схемы подключения датчиков, в то же время - про независимое питание всех датчиков, так не бывает. Проблемы могут возникать только в том случае, когда на выход одного датчика необходимо подключить два и более приемников, имеющих входы, соединенные с общим проводом. В таком случае нужна гальваническая развязка. Можно еще,имея карты аналогового вывода, повторить сигнал для других приемников через свободные выходы на них.

Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Николай; 7.6.04

На словах сложно объяснить - если хотите могу прислать вам по email cхемы подключения, только напишите куда. Или отправьте мне письмо на email я вам отвечу и приложу схемы

Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Валентин; 7.6.04

gornovski@jvbelpak.com

Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Scowl; 8.6.04

Николай, судя по описанию, у вас все же четтырехпроводдная схема подключения датчиков. Попробуйте понавтыкать дополнительно гальванические развязки, в нашем случае это помогло

Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Николай; 9.6.04

Данный модуль предполагает подключение датчиков по 4х проводке, т.е. на модуль приходит сигнальный конец от датчика. Если подключать по 2х проводной схеме, то нужно использовать внешний источник питания (см. сайт сименс). Таким образом для модуля нет разницы каким образом подключен датчик. В итоге будем просто ставить гальванику между каналами

Спасибо всем за ответы
Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
pavel; 10.6.04

Николай, ты ошибочно утверждаешь,что

при 2-х проводной схеме можно подключать источник питания.
Она потому и 2-х проводная, что мудуль является источником тока и измерителем одновременно.
Включение источника питания приведет
к сложению напряжений и ты можешь
превысить предел питания датчика,
обычно это 36в.
Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Николай; 10.6.04

для данного модуля предполагается именно так как я написал (модуль SM331 - 1KF01) - вычитал это только в технических характеристиках на него на сайте на англ. языке - на русском про это ничего не сказано

Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Pavel; 10.6.04

В каком положении стоит переключатель

выбора режимов?
Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Николай; 11.6.04

У данного модуля нет переключателей никаких

Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Pavel; 11.6.04

Это как?

На левой боковой стороне, должны быть
втычных 4 штеккера,меняя положение
кторых, меняешь режим.
Для этого необходимо снять плату
с несущей рейки
В доке лист 4-1, там есть рисунок
Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Николай; 11.6.04

Модуль SM331-1KF01 не имеет никаких аппаратных настроек, не имеет внешнего питания 24В. И к сожалению нет нигде его описания ни в каком мануале )))

Он такой единственный
Re: аналоговые модули ввода с питанием от внутренней шины контроллера 5В
Scowl; 15.6.04

Вначале был 7KF01, теперь 1KF01. В 7KF01 есть все что полагается


text

Проблема IM308-B
Igont; 11.6.04

Возникла необходимость рассмотреть, продиагностировать сеть ProfiBus,

писанную под STEP5. COM PROFIBUS
файл кофигурации (xxxxx.200) брать
- не взял. А нужен COM ET200 под DOS.
Помогите пожалуйста... Файликом, а может есть конвертор. Или кто знает
формат xxxxx.200 - дальше я сам.
Или формат данных в карте ПЗУ для
IM308B.
Опять Я
Igont; 13.6.04

Так пямо и "легли" перед западом.

Файла нет ни у кого?
Стыдно.
Что жалеем? Ихние баксы?<


text

SM 331 7KF00
Игорь; 3.6.04

Есть ли у этого модуля гальваническая развязка между каналами и цепью питания электроники или нет?

Есть ли мануал на этот модуль и где взять?
Re: SM 331 1KF01
Игорь; 3.6.04

Пардон 1KF01

Re: SM 331 7KF00
Чистяков Дмитрий ОАО СеверСталь; 3.6.04

А здесь не смотрел?

См. http://www4.ad.siemens.de/WW/llisapi.dll?func=cslib.csinfo&lang=en&siteid=CSEUS&objid=10928415

Re: SM 331 1KF01
Игорь; 4.6.04

Смотреть то смотрел - а толку ? :о(

Там только анонс на 1KF01 и краткие ТТХ, а мне нужен МАНУАЛ подробный (желательно)
HELP ME-EEEE !!!!!!
Re: SM 331 7KF00
Николай; 4.6.04

Мануал есть в каталоге и соответственно должен и в инете лежать.

Там есть гальваника между каналами и управляющей шиной контроллера, а вот в строке гальванической развязки каналов с питанием стоит прочерк. Тут питание идет от внутренней шины контроллера 5В, так что скорее всего есть.
Я с этими модулями работал - было много проблем с влиянием каналов друг на друга - до сих пор не решились - обсуждаю в форуме - можешь посмотреть тему
Re: SM 331 7KF01
Scowl; 8.6.04

Да, странные модули. Проблемы постояннно, а действительно исчерпывающего мануала нет.

Проблемы с модулями приходилось решать вплоть до постановки дополнительных развязок на входа (в нашем случае были отечественные 2000РС, думаю и какие-нибудь ADAM3014 тоже подойдут)
Re: SM 331 7KF00
Pavel; 11.6.04

Работаем с ними 5 лет и вроде ничего,

правда используем в основном двухпроводные датчики и немного потенциальных сигналов 0-10в.
С термопарами не работали, как правило все проблемы возникают с ними
и не только у Сименса.
Документация действительно отстойная.
специально разобрал плату и посмотрел потроха-развязка есть только относительно питания CPU поступающего
с внутренней шины. В остальлном по входу стоят ключи, коммутирующие
сигнал на АЦП
<


text

Связь s7-300 - CP5611
Владимир ; 28.5.04

Господа, помогите несведущему.

Есть абоненты: комп с CP5611, S7-300 - 2 шт, связь по MPI, трассы - 10-20 м. Соединительные кабели не поставляются. Какое "дополнительно приобретаемое заказчиком коммуникационное оборудование" кроме кабеля мог иметь ввиду поставщик?

Re: Связь s7-300 - CP5611
ViK; 10.6.04

В принципе, все что требуется, это кабель с разъемами, карта и контроллер. Возможно речь шла о повторителях или разветвителях сигнала.

Заходите на forum.aldis.ru Там Вам ответят более подробно.

ViK<


text

HART
shurik; 9.6.04

Уважаемый Михайлин Сергей.

Пожалуйста,вышлите,как обещали,по почте проект с блоком опроса HART устройств
Re: HART
Михайлин Сергей; 9.6.04

Библиотека с блоком и описанием выложена в разделе PCS7/Download или по ссылке. Блок предлагается "as is". Исходный код открыт. Блок работает с HART модулями SM331/332.

См. Тыч сюда


text

Проблемы с С7-613
Коротов Д.В.; 9.6.04

Господа!

Кто-нибудь сталкаивался с панелью С7-613. Не можем добиться поддержки русского языка.
Re: Проблемы с С7-613
Роман Абзаев; 9.6.04

И не сможете. С7-613 (6ES7613-1CA00-0AE3) не поддерживает русский язык. Новый (6ES7613-1CA01-0AE3) - вроде будет.


text

S7-400H, CPU 417-4H, проблема с синхромодулем
Lucky; 5.6.04

Коллеги, столкнулся с интересным феноменом: периодически выходит из строя синхромодуль на одном из редундантных CPU.. в буфере ничего полезного не стоит, отказ синхромодуля такого то, т.д. и т.п. Кто либо сталкивался с такой или подобной проблемой? Реально ли полечить синхромодуль? Спасибо заранее за советы!

Re: S7-400H, CPU 417-4H, проблема с синхромодулем
Любитель Симатика; 8.6.04

Один раз такое было. Дело было в плохой пропайке соединительных разъемов в ЦПУ. Отдавали в гарантийный ремонт. Но может быть и в другом дело.


text

Максимальный входной ток аналогового модуля
AndySher; 4.6.04

Модуль 6es7-431-1kf00-0ab0 ver.2.

Через вход включен датчик с последовательно установленным токоограничительным резистором 470 ом.
Дотчик глюкнул и замкнул. Через вход пошел ток 44 мА (измерено!).
Соответствует расчету
24в/(470+80)ом=43.6 мА
Входной резистор канала модуля (эти 80 ом) разрушился.

По всему получается, что токоограничительный резистор рассчитан неверно.
Какой в реальности максимально допустимый ток по входу у такого модуля и на какой документ можно опираться в спорах с проектировщиком?
Re: Максимальный входной ток аналогового модуля
Валентин; 4.6.04

Согласно технической характеристики на данный блок максимальный входной ток 50mA. данные взяты из каталога ф. Siemens.

Re: Максимальный входной ток аналогового модуля
AndySher; 4.6.04

Из какого документа конкретно?

В бумажной версии документации C79000-G7076-C425-02 на стр 6-54 указывается:
Permissible input current for current input (destruction limit) = 50 mA сonstant
В электронной версии 2003 года на диске значится:
Максимальный входной ток для каналов измерения силы тока 40 мА непрерывно

И по виду резистор 1 мм * 3 мм.
Рассеиваемая мощность (40 ма)^2 * 80 ом = 128 мВт
Не похоже, чтобы резистор обладал такой мощностью рассеивания...
Re: Максимальный входной ток аналогового модуля
Pavel; 4.6.04

может был бросок напряжения который

спалил и датчик и входной канал<


text

Схема подключения 6ES7321
Андриец В.Л.; 4.6.04

Возможно ли подключать питание внешнего источника L+ на 1 и 21 клему модуля 6ES7321-BL00-0AA0.

Если нет, то почему?
Если да, то из каких соображений?
Re: Схема подключения 6ES7321
Pavel; 4.6.04

А зачем. Можно и 1 не подключать.

Это не питание модуля, на + через диоды
подключаются защитные цепи от перенапряжения. В принципе достаточно подключить только (-) питания датчиков и все будет работать<


text

GSD file for ET200M
Александр Рысс; 2.6.04

По требованию Заказчика,Мы разрабатываем систему управления на базе контроллеров OMRON.Однако для перефирии должны использовать ET200M(153-2)ProfiBus-DP (Siemens),имеющийся у Заказчика.

Подскажите где можно достать GSD file для ET200M и соответствующих устройств ввода-вывода ?
Re: GSD file for ET200M
В. Сорокин; 2.6.04

Кидай Омрон, бери Симатик. Меньше живот болеть будет.

Re: GSD file for ET200M
Алексей; 3.6.04

ProfiBus.com

Re: GSD file for ET200M
Чистяков Дмитрий ОАО СеверСталь; 3.6.04

Смотри ссылку. Там даны файлы с учётом различных языков. Берёшь нужный тебе, скачиваешь и переименовываешь в *.gsd

См. http://1084460314-0000027811-0000000116-1086284174-enm-WW/llisapi.dll/113498?func=ll&objId=113498&objAction=csView&nodeID0=10805317&foldersopen0=-170-171-361-456-&lang=en&siteid=cseus&aktprim=0

Re: GSD file for ET200M
Чистяков Дмитрий ОАО СеверСталь; 3.6.04

Поле ссылки чего-то не работает, потому даю как раньше в сокращённом

виде ссылку.

http://www4.ad.siemens.de/WW/news/en/113498
См. http://www4.ad.siemens.de/WW/news/en/113498


text

типы данных в контроллерах
Юрий; 2.11.99

Ребята, подскажите в чем различие между битами меркеров и битами в блоках данных.

Re: типы данных в контроллерах
Андрей Гуленок; 4.11.99

В способе доступа. Меркер изначально адресовался побитно, а в младших S5-ых к DB можно было обратиться только побайтно.

Да и скорость доступа к меркерам почти в полтора раза выше.<


text

Ограничения на размер OB1
Eugene Sergeev; 1.6.04

Недавно столкнулся с такой ситуацией - при попытке загрузить ОВ1 в процессор, получил сообщение "Недостаточно места для загрузки ОВ1". Процессор - 315DP2, новый, с ММС, памяти 512 к, занято было ок. 58К. После переноса некоторых фрагментов из ОВ1 в подпрограммы все загрузилось.

Что, существуют какие-то ограничения на размер ОВ1?
Re: Ограничения на размер OB1
Андрей; 2.6.04

Если размер MMC 512к, то это не значит, что размер программы может быть 512к.

Программа из MMC загружается в RAM, размер которой для CPU315-2DP 128к.
При загрузке ОВ1 в PLC, если ОВ1 уже в PLC, вы должны иметь свободное место в PLC размером с загружаемый ОВ1. Это связано с тем, что во время загрузки старый ОВ1 работает, а новый загружается в свободную память, как только загрузка закончена, запускается новый ОВ1, а старый стирается. По этому можно обновлять программы в режиме RUN. Выход только один, сотрите старый OB1 и загружайте новый OB1.
Большой размер ММС нужен для хранения проекта и для Блоков данных, которые вы можете создать только в MMC и общий размер таких блоков данных как раз зависит от объема MMC. Одно из применений таких Блоков данных, хранение статистической информации напр., за месяц.

Re: Ограничения на размер OB1
Андрей; 2.6.04

Еще забыл написать, размер любых блоков OB, до 16k

Re: Ограничения на размер OB1
Eugene Sergeev; 3.6.04

Спасибо за внятный ответ. Такое здесь редкость.


text

Возможность регулирования в CPU 315-2DP
Сергей; 28.2.04

Подскажите, есть ли в CPU 315-2DP возможность настроить ПИД-регулятор с применением FB 41? Если да, то можно ли в инете найти пример как это сделать.

Re: Возможность регулирования в CPU 315-2DP
VVV; 1.3.04

Немного не понятно, Сергей. Что значит настроить регулятор с применением FB41?

Re: Возможность регулирования в CPU 315-2DP
Александр Козлов; 1.6.04

FB-41 стандартный блок регулирования в пакете Step-7. Настройка его приведена в HELP самой среды разработки Step-7. Задайте поиск.


text

PID регулятор
Igor; 21.5.04

Из трехсотой серии надо выбрать

контроллер, у которого ресурсов хватит
на 15 контуров ПИД регулирования, и на
6-8 задвижек
Помогите!!!!!!!!
Re: PID регулятор
komatoz; 21.5.04

Да практически все!

Re: PID регулятор
Козлов александр; 1.6.04

уточните задачу!

наличие 15 регуляторов подразумевает сложную технологию!
возможно более обоснованно применение 400 серии?<


text

SM 338 POS и датчики абсолютного перемещения
Игорь; 1.6.04

В описании на модуль сказано, что он предназначен для подключения синхронно-последовательных (SSI)датчиков. Нашел у фирмы Balluff измеритель пути с SSD интерфейсом. Подойдет ли он к модулю? Где поконкретнее узнать про SM 338 POS? Может кто использовал этот модуль, поделитесь опытом. Заранее благодарен.


text

Диагностика системы
Коротов Дмитрий; 29.4.04

Есть необходимость в Step 7 призводить диагностику Hardware. Затем сию информацию вытаскивать на WinCC. Может кто сталкивался с данной прооблемой, то помогите.

Re: Диагностика системы
GorA; 29.4.04

Есть универсальная функция SFC51,посредством которой возможно получение данных по существующим модулям и станциям. Занести данные в пользовательский DB и использовать по желанию.

Пример:
CALL "RDSYSST"
REQ :="1_"
SZL_ID :=W#16#B2
INDEX :=W#16#104
RET_VAL :=#RV
BUSY :=#QQQ
SZL_HEADER:=#S_HEADER
DR :="DIAG_OUT".OUT_10

Re: Диагностика системы
Рачев Дмитрий; 4.5.04

Функция эту я использовал, но где взять более подробную информацию по полученным данным?

Например, получил я событие из диагностического буфера, вижу:
1-одно слово идентификатора события (это понятно)
2-пять слов описания (нет информации)
3-четыре слова штампа времени (тоже не ясен формат)
Re: Диагностика системы
GorA; 7.5.04

Более подробное описание диагностических данных приводятся в описании на конкретный модуль

Re: Диагностика системы
Константин Власкин; 16.5.04

А никто не пробовал использовать для подобных целей пакеты S7-PDIAG и WinCC/ProAgent

Re: Диагностика системы
Дмитрий; 31.5.04

Поставь итеграцию c Step7 при установке WinCC. В Simatic Manager создавай проект WinCC, в Hardware определяй Error Messages. Вобщем там есть Help.


text

Связь s7-300 - CP5611
Владимир ; 28.5.04

Господа, помогите несведущему.

Есть абоненты: комп с CP5611, S7-300 - 2 шт, связь по MPI, трассы - 10-20 м. Соединительные кабели не поставляются. Какое "дополнительно приобретаемое заказчиком коммуникационное оборудование" кроме кабеля мог иметь ввиду поставщик?

Re: Связь s7-300 - CP5611
Николай; 28.5.04

Сетка по MPI состоит из контроллера, CP5611, кабеля и еще коннекторов шины profibus (например 6ES7972-0BB120XA). Кабель можно свой, и вместо коннекторов обычный 9pin разъем, только так как у тебя 2 контроллера он не подойдет, если у тебя конечно один CP5611 и ты все хочеш в сетку завязать

Удачи
Re: Связь s7-300 - CP5611
Владимир ; 28.5.04

Большое спасибо!

А не знаете ли Вы, Николай, что по сути представляет собой коннекторы http://www.sea.siemens.com/automat/product/net/pfb/cable/
auconnector.html ? Нельзя ли обойтись просто установкой терминатора в один из разъемов?
Re: Связь s7-300 - CP5611
Чистяков Дмитрий ОАО СеверСталь; 29.5.04

В принципе можно, и самому терминаторы влепить и кабель взять какой-нить другой. Единственное то что потом могут быть проблемы и глюки в сязи.

Терминатор это три резистора, питающихся от разъёма же (вернее аппаратуры через разъём). А кабель бери типа не хуже чем Ethernet`овский.
Да, ещё важно, чтобы была единая земля на всех устройствах. Если её нет, то необходимо проложить «кабель уравнивания потенциалов», т.е. провод между всеми землями этих устройств сечением не менее 2,5 мм в квадрате

Re: Связь s7-300 - CP5611
Николай "НПФ РАКУРС"; 31.5.04

Я честно говоря не стал бы самому лепить, просто уже сталкивался с определенными моментами, после которых решил, что Сименс такая фирма, у которой надо брать фирменное иначе будет много ненужной работы.

Кабель лучше брать специальный для профибас на нем мне всегда удается получить более лучшие характеристики чем на обычной витой паре. Разьемы вещь вообще очень удобная и конструктивно, и функционально. Конечно, если очень ограниченный бюджет, можно все самому сделать, но потеряете как минимум в надежности...
Так что смотрите сами<


text

Cyclic Interrupt
Юрчик; 30.5.04

Как в OB30...OB38 поменять уставку времени, через которое вызываются OB?

Требуется, например, изменить уставку блока OB38 с 10мс до 2 мс. Сейчас стоит блокировка на изменение. Может где написано про лечение трабла?
Re: Cyclic Interrupt
fresco; 30.5.04

Прочитайте в документации, допускает ли ваш CPU использование OB38.


text

Электронное управление сельсин-приемником
Андрей; 26.5.04

Вопрос в следующем, можно ли использовать ШИМ, которая очень широко применяется для управления силовым приводом (в том числе синхронными машинами, которой по сути является сельсин), для управления сельсин-приемником? Будут ли мешать нормальной работе сельсин-приемника высокочастотные гармоники, равные частоте несущего пилообразного сигнала?

Re: Электронное управление сельсин-приемником
Alex; 27.5.04

Както мудрено формулируешь. Сельсин обычно запитывают, и получают ответ. Если работают в паре передатчик-приемник на разность положения валов, то какой смысл лезть в их связи?

Мы экспериментировали с питанием сельсинов, проверяли погрешности при запитке аналоговыми штатными синусоидальными сигналами и отдельно цифровыми меандрами, разницы в результатах не заметили.
Электронное управление сельсин-приемником
Андрей; 27.5.04

Согласен, сформулировал сумбурно!

Поясняю ситуацию:
Из системы сельсинов (датчик-приемник) удаляется сельсин-датчик. Необходимо сформировать электронным способом (ШИМ, ЦАП, или что-либо еще) сигналы, имитирующие фазные сигналы сельсин-датчика. Опорное (или питающее) напряжение по прежнему запитывает сельсин-приемник (а точнее фазовый дискриминатор, т.к. сельсин-приемник работает в трансформаторном включении), а фаза формируемых сигналов (имитирующих сельсин-датчик) привязана к фазе питающего напряжения.
И теперь тот же вопрос: не повлияет ли нормальной работе приемной части (сельсин-приемник в трансформаторном вкючении с фазовым дискриминатором) если фазные сигналы будут формированы методом ШИМ, не будут ли высокочастотные гармоники отрицательно влиять на работу приемной части?
Re: Электронное управление сельсин-приемником
Alex; 28.5.04

Собственно по вопросу: не слышал, чтобы на сельсин влияли высокочастотные гармоники, наверное это маловероятно в силу конструкции. Т.ч вариант с ШИМ скорее всего пройдет.

Соображения по схеме: если выкидывать задатчик, то почему не выкинуть и приемник? Опора и так должна передаваться в следующий каскад, а ШИМ вместо выхода сельсина, в каком-то месте можно вместо ШИМ подключить АЦП. Или подключить сельсин по одинарной схеме.
Если не лень будет, сообщи о результатах.<


text

Параметры надежности контроллеров
Сергей; 17.5.04

Не где не смог найти параметры надежности контроллеров.(Среднее и минимальное время наработки на отказ, срок службы и пр.). Контроллеры и модули S7-300. Проектируется телемеханика на Sinaut ST7, требуется рассчитать параметры надежности всей системы.

Re: Параметры надежности контроллеров
Дмитрий; 18.5.04

Сергей! Обратите внимание, справа вверху под баннером системы A&D Mall есть ссылочка Customer Support. В иностранной терминологии время наработки на отказ называется MTBF. Если там поискать, то под Entry ID:16818490 можно найти методику расчета времени и файл xls с параметрами наработки на отказ каждого модуля. Удачи!

Re: Параметры надежности контроллеров
ruslan; 19.5.04

Обзор средних времен безотказной работы (MTBF) для различных продуктов

SIMATIC вы найдете в часто задаваемых вопросах (FAQ) о SIMATIC FAQs по
адресу
http://www.siemens.com/automation/service&support
под идентификатором 1160399.
Re: Параметры надежности контроллеров
Сергей; 19.5.04

Спасибо за ответы, кое-что нашел.

Скачал файл upmtbf.exe , файл mtbf.exe скачать не получается, спрашивает SIMATIC Card / Automation Value Card AVC, а жаль. В первом файле не все нашел. Можно это обойти?
systems(собака)aport.ru<


text

SIMATIC-TI505
Yrok; 19.5.04

Подскажите где взять gsd файл на коммуникационик DP 505-7202, Задача связать 505 контроллер с S7-300.

Может надо другое железо?<


text

CPU942B-IM308-ET200B осенне-весенние глюки
Валера; 18.4.04

Переодически осенью и весной система начинает глючить. На модуле IM308 промыргивает BF. Выхода в этот момент сбрасываются. Пробовал ставить на выходы и тригер и таймер ни какого толку, всё одно сбрасываются. Блоки менял, питание усиливал, кабель связи протягивал. Если у кого такое было, то подскажите ответ.

Re: CPU942B-IM308-ET200B осенне-весенние глюки
Юрчик; 18.4.04

Длина кабеля не превышена?

Согласующие сопротивления (терминаторы) исплавны?
Заземление правильно сделано?
Re: CPU942B-IM308-ET200B осенне-весенние глюки
Саня; 19.4.04

Осень и весна коррелируют с водой в ямах, крышах и т.д. Может там собака порылась?

Re: CPU942B-IM308-ET200B осенне-весенние глюки
Валера; 19.4.04

Провели в прошлом году отдельное заземление. Согласующие сопротивления в порядке. 16 апреля в пятницу днём машина работала нормально, вечером как взбесилась. А в субботу опять работала. Сделала только 3 сбоя. А сегодня 19 числа вообще ни одного. Уменя есть подозрения на влажность в этот период времени года. Но как обьяснить это руководству.

Re: CPU942B-IM308-ET200B осенне-весенние глюки
Валера; 19.4.04

Да и чуть не забыл поблагодарить ВАС за отклик на мой вопрос.

Re: CPU942B-IM308-ET200B осенне-весенние глюки
Serge_n; 17.5.04

Сбои Simatic - это сложный вопрос, особенно для руководства, потому как причины не видимы и не ощутимы. Мы на производстве с этим воевали лет 5 (оборудованию 14 лет). Пробовали устанавливать UPS. Но как оказалось достаточно установить новые модули питания и проблема закрыта ...

Re: CPU942B-IM308-ET200B осенне-весенние глюки
Николай; 18.5.04

Ошибки BF возникают при потере связи и синхронизации с контроллером. Бывает, например, когда слишком большая скорость сети. На это могут влиять: помехи, некачественное питание, влажность.

Можете попробовать немного снизить скорость сетки и посмотреть не уйдут ли глюки.<


text

115U cpu942
Эдуард; 6.5.04

Re: 115U cpu942
Сергей; 7.5.04

Если не найдете схемы... готовы Вам "уступить" такой же. Остальное в мэйл.

Re: 115U cpu942
Alex; 11.5.04

В схему лучше не лезь! Для Siemens, как правило, собака зарыта в другом месте. Пробуй перезапуск системы, сначало без ПЗУ-он должен перейти в работу, потом ставь модуль и опять перезапуск. Какой результат?

Re: 115U cpu942
Serge_n; 17.5.04

Уточните пожалуйста, как именно Вы запускаете Simatic при установке другого модуля.

Насколько помню:
ST - стоп CPU;
QVZ - не получен сигнал подтверждения от периферийного устройства;
BASP - блокировка выходных сигналов.
(если это надо)
<


text

TS адаптер, подключение через модем, установка связи
Darwin; 17.5.04

Установил TS adapter, modem US Robotics message 56K, подключился первый раз, все ОК. Подключился второй раз, пишет "ошибка пока переносится работа", потом вообще при подключении модемы обмениваются затем зацикливается звук, по кольцу гудят гудят и затем связь обрывается пишет "партнер не отвечает". Поставил как написано в ТО строку инициализации для модема, никаких изменений. Модем на стороне адаптера отвечает, то есть когда позвонишь на него снимает трубку свистит ждет так сказать.

Есть какие подсказки?<


text

Загрузка с ММС
Сергей; 14.5.04

Объясните как загрузиться с ММС ( загружена ), если стереть память на S7-315-2DP

Заранее благодарю.

Re: Загрузка с ММС
Дмитрий; 15.5.04


text

Установка CPU313C (313-5BE01-OABO)
Lafi; 30.4.04

В документации на этот ЦПУ сказано, что для программирования нужен Step7 v5.2.

А v5.1. SP4 ему уже не подойдет?
Или есть какие-нибудь варианты?
Re: Установка CPU313C (313-5BE01-OABO)
Дмитрий; 4.5.04

v5.1 SP4 Подойдет, если найдете в HW конфигураторе этот цпу :-)

Re: Установка CPU313C (313-5BE01-OABO)
Николай; 5.5.04

Недавно столкнулся с похожей проблемой - делал проект с ЦПУ 314С-2DP у меня тоже стоял S7 v5.1 SP4 - такого процесора там нет - долго искал заплатку не нашел, затем позвонил в сименс сказали, что надо тока S7 v5.2 - пришлось его поставить тогда все заработало

Re: Установка CPU313C (313-5BE01-OABO)
Олег Грузевич; 5.5.04

Для работы с 6ES7313-5BE01-0AB0 необходим Step7 v5.2.

Вариант работы со Step7 v5.1 возможен. В этом случае в проекте нужно использовать CPU 313C с заказным номером 6ES7313-5BE00-0AB0. Недостаток этого способа в ограничении функциональности нового CPU 313C до характеристик старого.
См. Подробная информация

Re: Установка CPU313C (313-5BE01-OABO)
Bkmz; 5.5.04

Если пользуешь Степ 7 в5.1, то уж ставь тогда СП6, а не СП4.

Re: Установка CPU313C (313-5BE01-OABO)
Николай; 11.5.04

>Вариант работы со Step7 v5.1 >возможен. В этом случае в проекте >нужно использовать CPU 313C с >заказным номером 6ES7313-5BE00-0AB0

- у меня такой вариант с подменой 6ES7314-6CF01-0AB0 на 6ES7314-6CF00-0AB0 - не пошел - все равно ругался
Re: Установка CPU313C (313-5BE01-OABO)
Олег Грузевич; 11.5.04

Николаю:

Ругательства справедливы, но работать должно. Согласно документации: 6ES7314-6CF01-0AB0 являвляется полностю совместимой заменой для 6ES7314-6CF00-0AB0 без каких либо изменений в проекте и без обновления Step7.
Re: Установка CPU313C (313-5BE01-OABO)
Николай; 13.5.04

Олегу:

теоритечески должно сам понимаю, попробовал - но запустить не смог - постоянно горит ошибка конфигурации
Советовался с представителями сименс - говорят полный аналог и что теоретически должен )))
Если есть опыт или будет, буду благодарен если поделитесь...<


text

Документация по новым 315DP
Eugene Sergeev; 11.5.04

Где взять доки по новым 315DP? Особенно ту часть, где описывается инициализация флешки (последовательность дергания переключателя)

Re: Документация по новым 315DP
Дмитрий; 13.5.04

На этом сайте :-)


text

радиомодем
Igor; 6.5.04

можно ли подключить два девайса по profibus DP черезе радиоканал?

(используя радиомодем).

где взять информацию по связи через радиоканал для Simatic??????
Re: радиомодем
Роман Абзаев; 6.5.04

Отвечаю на вторую часть вопроса - это SINAUT. Описание в разделе SIMATIC NET.

Re: радиомодем
Гуленок Андрей; 7.5.04

Отвечаю на первую часть вопроса, можно. C помощью модемов Satel и какой то матери мы вполне успешно гоняли профибус в пределах комнаты. Учитывая что эти "Эпики" разгоняются до 10 ватт дальность можно получить приличную.

Информация на satel.fi <


text

сохранение данных без буф. батареи в CPU 312IFM
Сергей; 6.5.04

Подскажите пожалуйста, как сохранить данные в CPU312IFM при выключении питания. В руководстве написано, что возможно сохранение 72 байт.

Re: сохранение данных без буф. батареи в CPU 312IFM
Олег Грузевич; 7.5.04

В "HW Config" в "Properties CPU" в разделе "Retentive Memory" назначаются области памяти с сохраняемыми данными.


text

Cвязь с панелью оператора
Максим; 23.3.04

Имеется Touch-панель...В Simatic Manager добавляю OP1(панель оператора)...при диагностике у меня определяются два контроллера на местах MPI3 и MPI4...а обе панели на MPI1 и MPI2....но не могу привязать их к сети.....захожу в Conection, и связи панели с линией сети MPI нет....и не получается её сделать........Как быть?

Re: Cвязь с панелью оператора
Дертунов Борис; 6.5.04

В ProToolе надо связь прописывать


text

Диагностика обрыва провода в SM431
Marusckevich Sergey; 1.5.04

Есть модуль 6ES7 431-7KF00-0AB0. Его предназначение - измерение температуры в металле (термопара типа B). При надетой термопаре, напряжение (mV) слишком мало, что бы мерять "уличную" температуру и поэтому показывает значение "-32768". При выходе на рабочую температуру, все ОК. Вопрос: "Каким способом можно узнать, что термопара одета"? Можно ли ,например, при помощи диагностики "Обрыв провода/ Break wire"? Может при данной диагностике модуль меряет сопротивление, а не mV? Спасибо


text

Соединение компа с s-200 в ProTool RT
Den Tigarbo; 24.3.04

Re: Соединение компа с s-200 в ProTool RT
В. Сорокин; 24.3.04

С нетерпением жду ответа, т. к. именно сегодня влип в тоже самое. Кто знает, подскажите: где мы с господином Den Tigarbo не правы. Пробовал и через СР5511 РРI и через "шнурок" PPI - картина одинакова.

Re: Соединение компа с s-200 в ProTool RT
Роман Абзаев; 25.3.04

Для Дэна:

Ответы на вопросы лежат в ID 16650850 на CSS
Для г-на Сорокина:
Посмотрите ещё и ID 14188898
Re: Соединение компа с s-200 в ProTool RT
В. Сорокин; 25.3.04

Спасибо Роман, но я слаб в этих ссылках. Прошу дать указние подробнее.

С уважением, Владимир Сорокин.

Re: Соединение компа с s-200 в ProTool RT
Роман Абзаев; 25.3.04

В каком смысле слабы?

Re: Соединение компа с s-200 в ProTool RT
В. Сорокин; 25.3.04

Как добраться до этих ID и CSS?

Re: Соединение компа с s-200 в ProTool RT
Роман Абзаев; 25.3.04

О-о-о-о-о-о... CSS - это Customer Support & Service, ID просто вводится в строку поиска.

См. http://www.ad.siemens.de/csi_e

Re: Соединение компа с s-200 в ProTool RT
В. Сорокин; 25.3.04

Вот и о-о-о-о... . Работать приходится, а знаний-то о-о-о-о...

Спасибо Вам.

Re: Соединение компа с s-200 в ProTool RT
Den Tigarbo; 26.3.04

Всем. Воспользовались инфой с сайта, не работает. Общая ошибка соединения.А вообще в какой порт в контроллере встремлять?

Сорокину. А у Вас получилось, если да разжуйте по пунктам.
Роману. Может еще знаете где чего посмотреть или у кого спросить?
Re: Соединение компа с s-200 в ProTool RT
Роман Абзаев; 26.3.04

У Вас, кстати, MLFB PPI адаптера какой?

Re: Соединение компа с s-200 в ProTool RT
Den Tigarbo; 26.3.04

Если Вы про номер кабеля, то 6ES7 901-3BF20/21-0XA0

Re: Соединение компа с s-200 в ProTool RT
kot; 29.3.04

А в PG/PC Interfase S7online conection стоит???

Re: Соединение компа с s-200 в ProTool RT
Den Tigarbo; 29.3.04

Да, именно так. Все выполнено по инструкции Сименс. Меня смущает на кабеле 6 переключателей, ну первые 3 понятно скорость, а еще 3 как должны быть установлены? Но по этому кабелю упр пр-ма отлично грузится в контроллер.

Re: Соединение компа с s-200 в ProTool RT
kot; 30.3.04

Скорость передачи на шнурке, в контроллере и в PT везде одинаковая???

Re: Соединение компа с s-200 в ProTool RT
kot; 30.3.04

Кстати адрес контроллера в system blok и РТ одинаковые????

Re: Соединение компа с s-200 в ProTool RT
Den Tig; 30.3.04

Да ск-ть везде 9600, и адрес то же. Все по сименсовскому букварю, ан не ботает

Re: Соединение компа с s-200 в ProTool RT
kot; 31.3.04

А порт в программе не инитишь ни где??? Али режим свободно программируемого порта???

Re: Соединение компа с s-200 в ProTool RT
Den Tigarbo; 1.4.04

Поподробней п-та, что это такое и где оно

Re: Соединение компа с s-200 в ProTool RT
kot; 1.4.04

в программе не должно быть обращений к

SMB 86,87 (??? точно не помню) которые настраивают порт на особые режимы передачи. Все настройки должны быть сделаны только в систем блоке. И еще свойства контроллера в РТ должны быть такими:интерфейс DP/MPI, адрес OP 1,
адрес коммуникац. партнера такой как в систем блоке в микровине, нетворк параметры PPI скорость 9600. На кабеле скорость 9600 все остальное выключено.

Re: Соединение компа с s-200 в ProTool RT
Den Tigarbo; 2.4.04

SMB 86,87 в одной из подпрограмм искать? Так куда этот кабель втыкать, вместо панели или во второй разъем?

Re: Соединение компа с s-200 в ProTool RT
kot; 2.4.04

В любой. Только проверь настройки порта в систем блоке. А SMB проще найти в кросс референц, он покажет все во всей программе.

Re: Соединение компа с s-200 в ProTool RT
Den Tigarbo; 2.4.04

А в РТ Network Parameters какой ставить профиль PPI или MPI или DP или Standart или Universal?

Re: Соединение компа с s-200 в ProTool RT
Den Tigarbo; 2.4.04

kotu/ У нас MicroWin v3.2.0.105 c дровами s7200.sig от 29.04.2002 Feutures.dvp от 13.03.2002, кабель 6ES7 901-3BF21-0XA0, ProTool Pro CS 6 sp 2 и RT 6sp2. Для особо одаренных можно по пунктам описать что, зачем, куда?? Вроде все делаем по описанию, все равно не але.

Re: Соединение компа с s-200 в ProTool RT
Den Tigarbo; 2.4.04

kotu/ У нас MicroWin v3.2.0.105 c дровами s7200.sig от 29.04.2002 Feutures.dvp от 13.03.2002, кабель 6ES7 901-3BF21-0XA0, ProTool Pro CS 6 sp 2 и RT 6sp2. Для особо одаренных можно по пунктам описать что, зачем, куда?? Вроде все делаем по описанию, все равно не але.

Re: Соединение компа с s-200 в ProTool RT
kot; 4.4.04

РТ Network Parameters надо поставить PPI , скорость 9600. на шнурочке 9600. в систем влоке микровина 9600. в сет РС/PG интерфейсе PPI 9600, S7 online connection.И соответственно чтобы везде совпадали адреса.

Re: Соединение компа с s-200 в ProTool RT
DenTigarbo; 5.4.04

Добавлю, у нас в ПроТуле проект эмуляция PC-panel? процессор 226xm, в параметрах op адрес 1, в партнере 2 (протул), в систем блоке в микровине ремот адрес 2, в общем все по Вашему описанию и id 16650850, все равно не хочет, smb86?87 не встречается в проге. Упр. прога работает c панелью тр070, в проге ничего не трогали, только перенесли интерфейс из панели в PC. Может чего еще в упр. пр-ме надо дописывать? А какие настройки при подкл через cp5611?

Re: Соединение компа с s-200 в ProTool RT
В. Сорокин; 6.4.04

Здравствуйте!

Был в командировке и, поэтому, выпал из разговора.
Но проблемы те же, что и у господина Tibargo, и до сих пор не решены. Причём, никакие ID не помогают.
С МикроВином и по РР-шнурку, и по СР5511 контроллер связивается. С ТР070 - тоже всё ок.
А с Рантаймом ни в какую.
Re: Соединение компа с s-200 в ProTool RT
Den Tigarbo; 7.4.04

Сорокину. Так и через CP5611 рунтайм не работает? мне пишут знающие люди что без проблем, но никак не дождусь ее поюзать. А че за cp5511, опечатка или то же плата.

Re: Соединение компа с s-200 в ProTool RT
Симахин Александр; 8.4.04

В панели управления (Windows) наидите

Set PG/PC Interface в точке доступа S7ONLINE (Step 7) установите PC/PPI cable. Ну и конечно в свойствах установите параметры вашего соединения.
Re: Соединение компа с s-200 в ProTool RT
Den Tig; 8.4.04

Симахину. Все это проделывалось, не помогает.

Re: Соединение компа с s-200 в ProTool RT
Симахин Александр; 8.4.04

Какая у Вас операционная система на компютере?

Re: Соединение компа с s-200 в ProTool RT
Den Tig; 8.4.04

xp prof, пробовал и по 98se

Re: Соединение компа с s-200 в ProTool RT
Симахин Александр; 8.4.04

Я пробовал на Win2k SP4, работает без особых проблем.

Re: Соединение компа с s-200 в ProTool RT
Роман Абзаев; 8.4.04

А Вы в конце концов где территориально расположены-то?

Re: Соединение компа с s-200 в ProTool RT
Роман Абзаев; 8.4.04

Кстати, у вас S7-200 Programmable

System Manual SIMATIC (6ES7298-8FA23-8BH0) под рукой-то есть?
Re: Соединение компа с s-200 в ProTool RT
Den Tig; 8.4.04

Win2k sp4 не пробовал, а на Win2k rus sp2 протул вообще не ставится. Да есть руководство, если Вы имеете ввиду то которое в компл. с контроллером идет.

Re: Соединение компа с s-200 в ProTool RT
Симахин Александр; 9.4.04

Все верно, ProTool можно поставить только при sp3. Я выслал Вам проект, там всего идет обмен 1 байтом выходов.

И действительно где Вы расположены, может у Вас под боком находится бюро технической поддержки.
Re: Соединение компа с s-200 в ProTool RT
Den Tig; 9.4.04

Мы находимся в Ростовской обл. За проект спасибо, попробуем, напишу.

Re: Соединение компа с s-200 в ProTool RT
Den Tig; 9.4.04

Установил sp4, после этоко протул про установился, а рунтайм не хочет запускать проекты, пишет типа "не могу загрузить файл" по-английски

Re: Соединение компа с s-200 в ProTool RT
Симахин Александр; 9.4.04

А авторизацию на RT установили.

А, что ProTool пишет (поконкретнее)?
Re: Соединение компа с s-200 в ProTool RT
Den Tig; 9.4.04

Авторизация стоит, запустили OPC_PC после этого рунтайм проект запускает, пока не пробовали коннектиться т.к. под 2000-м возникла другая проблема, не могу загрузить прогу из микровина в контроллер. Под 98 и xp без проблем.

Re: Соединение компа с s-200 в ProTool RT
В. Сорокин; 16.4.04

Господа! Разве вопрос закончился? Напишите как?

У меня он "стоит", до сих пор.
Выручайте, а то даже с помощью спецов Сиемнс я это не разрешил.

Re: Соединение компа с s-200 в ProTool RT
Den Tig; 19.4.04

Устал от попыток. Жду чудо-модуль 243 и чудо-плату cp5611. Как попробую, отпишусь.

Re: Соединение компа с s-200 в ProTool RT
Симахин Александр; 19.4.04

В чем у Вас проблемма я не понимаю. Пришлите свой проект попробую посмотреть. А какой смысл в наличии 243 коммуникационного процессора и платы 5611 + ProTool. СР 243 есть 3 штуки: СР 243-1 (Ethernet), CP 243-1IT (тот же Ethernet + IT) и CP 243-2 (AS-interface). Плата СР 5611 это коммуникационная плата PSI для PPI/MPI/Profibus ни с одним СР 243 она связатся не может.

Re: Соединение компа с s-200 в ProTool RT
Den Tig; 19.4.04

CP 243-1 и CP 5611 это 2 варианта решения проблемы запуска проекта с PC. Хочу попробовать оба.

Re: Соединение компа с s-200 в ProTool RT
В. Сорокин; 20.4.04

Здравстуйте. Вопрос, похоже, завис.

К Den Tig: СР5611 - это PCI-й вариант 5511. У меня не работает. С МикроВином - без проблем, с 300-м контроллером из-под Протол Про - то же, с Симатик-Менеджером - вопросов нет. С 200-м из-под Протол Про - наотрез. Сбои 140001 и 140003.
В пятницу был на Сименсе в Москве: у них всё работает, даже со старым кабелем PPI, который не рекомендуют.
У меня только из 10 раз один раз проскочила связь с 5511 из-под ОРС-сервера, потом, как отрезало.
Пробовал с ХР, с 98-м - толку нет.
Может нам сговориться и встретиться на Сименсе в двоём, Рязань не шибко далёко.
К Симахину Александру: проект банальный - в 200-м QB0=23, в Протуле окно вывода. Всё. На ОР070 - 23, в Протуле - 0 и сбои.
Все настройки - как положено, на Сименсе часа 2 упражнялись.
Re: Соединение компа с s-200 в ProTool RT
Den Tig; 21.4.04

Сорокину. Оставьте мыло, у меня есть вопросы не касающиеся данного сайта... Может так и прийдется делать, брать ноутбук и ехать к Вам в Рязань. А у Вас что такое крутое представительство, что все показывают на реальных вещах? Но я вот только дождусь оной платки и модуля, попробую. Кстати а какой у Вас процессор и на каком они Вам показывали. У меня 226xm, может в этом дело?

Re: Соединение компа с s-200 в ProTool RT
Симахин Александр; 21.4.04

Не спорю проект банальный, но связь идет (у меня:-)). Самое главное торопиться не надо после запуска RT в течении 1 мин связь не устойчивая, потом все ОК. Хотя еще раз говорю многое зависит от операционной системы сам пробовал с Win98 и Win2K.

Re: Соединение компа с s-200 в ProTool RT
В. Сорокин; 22.4.04

К Den Tig: я думал это Вы в Рязани, извините. Глянул - в Ростове, далёко. Представительство Сименса у меня ближайшее в Москве, туда и езжу, спасибо, пока привечают. Мыло - seima@mnogo.ru.

К Симахину Михаилу: 1 мин. - это здорово, но почему-то у Юрченко В. работает сразу, а у меня никогда. Увы.
Re: Соединение компа с s-200 в ProTool RT
Den Tig; 22.4.04

Симахину - кстати Ваш проект при открытии ругается что сделан в пред версии нежели 6 sp2 и говорит что откроется но перед этим конвертнется.

Сорокину - я так думаю надо брать ноутбук со всеми причиндалами, все платы и модули, которые приедут, кабелек с процессором и катить в представительство, пусть запустят на моих шалагушках. Лучше 1 раз увидеть... Конечно если с платками не получится у самого... А то сроки заканчиваются а результата нет.
Re: Соединение компа с s-200 в ProTool RT
В.Сорокин; 23.4.04

Пусть конвертнётся, может заработает. Доп. информация к размышлению, а может, если заработает, как эталон будет для нас. Перешлите мне тоже, пожалуйста.

Re: Соединение компа с s-200 в ProTool RT
Darwin; 29.4.04

Извиняюсь, может не по теме. Как сделать визуализацию PC-S7-315 2DP?

Хотя бы в общих чертах. Т.е., как я понимаю, 1.Создать проект в ProToolPro под РС, далее нужно установить ProToolPro RT, авторизацию, далее каким образом можно осуществить связь?
Re: Соединение компа с s-200 в ProTool RT
Den Tig; 29.4.04

Всем! Приехал модуль CP 243-1 все поставил, соеденили, у Сименса взял очередной букварь настроил по нему соединение и ничего......

Кто что знает подскажите?
Меня еще смущает цена фирменного сименского кабеля для связи, он что особенный какой - то?
Re: Соединение компа с s-200 в ProTool RT
В.Сорокин; 29.4.04

Дарвину. Рисуйте проект в Протол ЦС, связывайте с программой Симатика (процесс разработки того и другого одновременный), по ходу дела компилируйте и проверяйте совместную работу в Рантайме. Авторизацию поставите когда всё готово будет. Проще сказать, чем сделать.

Для связи надо либо 5611, либо 5511. С 300-ми то проблем нет.
Ден Тиг. Ну так, как - встречаемся в Москве?
Re: Соединение компа с s-200 в ProTool RT
Den Tig; 29.4.04

Еще помучаемся, а после 10 мая если не получится будем договариваться как и где встретимся в Москве.

Re: Соединение компа с s-200 в ProTool RT
Den Tig; 30.4.04

Еще помучаемся, а после 10 мая если не получится будем договариваться как и где встретимся в Москве.


text

Синхронизация часов в ОР170В и S7-300
Eugene Sergeev; 2.3.04

Как осуществить синхронизацию (установку) времени в OP170B с контроллера S7-300? Способ, изложенный в хелпе Протула для 170А IMHO несколько мутноват для понимания.

Re: Синхронизация часов в ОР170В и S7-300
Илья; 3.3.04

PLC-jobs или соответствующая область в Interface Area

Re: Синхронизация часов в ОР170В и S7-300
Romik; 27.4.04

Зачем синхронезировть просто можно вытащить время контоллера вплоть до сикунд ивсё тут.

Re: Синхронизация часов в ОР170В и S7-300
Eugene Sergeev; 28.4.04

Чтобы на графиках время правильно отображалось.

Кстати, рассказал бы кто про эти PLC-jobs. Как я понял, я должен создать соотв. area в контроллере, помесить туда номер job-a и параметры, а вот как узнать, что оно уже закончилось?
<


text

Не подкините ссылочку....
Eleria; 27.4.04

Где взять редаткор *.IMG файлов (образы дискет и т.д.).

Помогите ПЛЗ.
Re: Не подкините ссылочку....
Vitjok; 27.4.04

Например http://www.winimage.com/

http://www.google.com/
Re: Не подкините ссылочку....
Eleria; 28.4.04

спасибо по Гугле уже все исколесил .... кучу ссылок проверил не одну прогу попробовал ....

И WINImage тоже не работает :(
Надо поправить *.img файл с ТР070...<


text

ET200M IM153-2 6ES7 153-2BA00-0XB0 нет в HARDWARE Catalog! Где взять?
Зверев И.С.; 27.4.04

имеем в железе IM153-2 код 6ES7 153-2BA00-0XB0

имеем в софте PCS7 v5.0 в Hardware Catalog что угодно (153-2А...),но нет именно такого (153-2В..)
вопрос - где взять 153-2BA00 для каталога, чтоб сконфигурить hardware? или как использовать то что есть?
Заранее спасибо.
Игорь
Re: ET200M IM153-2 6ES7 153-2BA00-0XB0 нет в HARDWARE Catalog! Где взять?
Михайлин Сергей; 27.4.04

В Simatic Manager, который входит в PCS7 v5 этих модулей нет. Надо апгрейдить PCS7 или как минимум STEP7 хотя бы до версии 5.2 Если такой возможности нет, используете из каталога старый IM153-2 2AA02 например, но тогда все новые функции от 2ВА ессно будут недоступны.

Какие ф-ции конкретно? Интересует HART
Зверев И.С.; 27.4.04

Собсно для этого и планируем использовать - подключение к модулям ан.входа датчиков с HART

Re: ET200M IM153-2 6ES7 153-2BA00-0XB0 нет в HARDWARE Catalog! Где взять?
Михайлин Сергей; 27.4.04

Если дело только в HART тогда можно использовать старую модель. В IM153-2 (2AA02) с HART все в порядке.


text

315-2DP 6ES7 315-2AG10-0AB0
Александр; 19.4.04

Re: 315-2DP 6ES7 315-2AG10-0AB0
Олег Грузевич; 23.4.04

Мигание всех светодиодов информирует о внутренней системной ошибке ЦПУ. В данном случае рекомендуется выполнить следующую процедуру:

1.Переключатель режимов установить в STOP.
2.Выключить, а затем включить питание.
3.С помощью Step7 прочитать диагностический буфер.
4.Обратиться в тех. поддержку "Сименс". <


text

PC-USB-S7-300
Владимир; 16.4.04

Можно ли использовать для программирования S7-300 USB адаптор (6ES7972-0CB20-0XA0)? На PC установлен STEP7 V5.1+SP6. Фирменное описание прямого ответа да или нет не даёт. Тот же вопрос по поводу USB/PPI кабеля (6ES7901-3DB30-0XA0) для S7-200. Используется STEP 7 Micro-WIN 3.1.1.6

Re: PC-USB-S7-300
Олег Грузевич; 22.4.04

РС адаптер MPI/USB можно использовать для программирования контроллеров SIMATIC S7. Со Step7 v5.1 работает - проверено на практике.

РС адаптер РPI/USB требует, согласно документации, Step7-Micro/Win v3.2 SP4.

Для надежной работы РС адаптера MPI/USB в сети PPI лучше также использовать Step7-Micro/Win v3.2 SP4 . <


text

Пропадают сообщения из буфера алармов С7-635К после перезагрузки....
Андр; 22.4.04

Уважаемые коллеги!

Пропадают сообщения из буфера алармов
С7-635К после перезагрузки....
Т.е. по-другому как добиться энергонезависимости буфера алармов и евентов??
Перечитал весь мануал, экспериментировал с buffer, page - ничего не получается, все равно все сообщения сбрасываются.

Что можно сделать еще ??
Re: Пропадают сообщения из буфера алармов С7-635К после перезагрузки....
Олег Грузевич; 22.4.04

К сожалению, энергонезависимого буфера сообщений у С7-635 нет. Первая мысль, которая возникла после постановки вопроса - нужно резервировать питание.

Re: Пропадают сообщения из буфера алармов С7-635К после перезагрузки....
Андр; 22.4.04

Так-что уважаемые коллеги, будьте бдительны!!

Сименс может подложить вам такую ...<


text

AG/TTY-конвертер для S5
error; 20.4.04

Как я понял, конвертер не решает всех проблем. В step5 все поля для работы с AG остаются "холодными". То ли его как-то настраивать надо, то ли просто конвертер не работает. Судя по схеме там нечему не работать. Так где искать связь PC (step5) с AG?


text

Пропадает связь PG720-CPU942
Валера; 19.4.04

В режиме тестирования "Статус програмных блоков" через некоторое время пропадает связь. Приходиться отключать кабель от PG и в установках проекта снова включать режим "ON LINE". После нескольких раз програматор вообще приходиться перезагружать посредством выключения. На програматоре установлен пакет STEP5 v7.2.


text

Куплю S5 6ES5944-7UB11 CPU944B - 1 шт. Operator panel OP25/A 6AV3525-1EA01-0AX0 - 1 шт.
Black; 15.4.04

Куплю

S5 6ES5944-7UB11 CPU944B - 1 шт.
Operator panel OP25/A 6AV3525-1EA01-0AX0 - 1 шт.
Re: Куплю S5 6ES5944-7UB11 CPU944B - 1 шт. Operator panel OP25/A 6AV3525-1EA01-0AX0 - 1 шт.
Jack; 19.4.04

По чём хочешь?


text

Замена PG на PC ?
Serge_n; 5.1.04

Вот проблема (по крайней мере для меня):

Старенький PG675 скоро прикажет долго жить, а мне без него нельзя. Новый руководство не купит. Нашел схемы адаптеров AG->PC, прогу PG2000.
Этот "комплект" мне заменит PG675 ?
Или все-таки добиваться покупки нормального PG ?

Re: Замена PG на PC ?
Serge_n; 5.1.04

Еще уточню: обязательно нужна возможность записи EPROM.

Re: Замена PG на PC ?
Nec; 6.1.04

Не знаю что за PG2000, но адаптеры работают только с S5-115, со 150-ми не смогли связаться. Зато есть адаптер для компьютера. Программатор EPROM можно купить внешний. Тут вообще в прошлом году была тема про замену программатора на ноутбук и сколько при этом сэкономишь.

С уважением, Алексей.
Re: Замена PG на PC ?
Serge_n; 6.1.04

У нас и так только S5-100 и S5-115.

Все дело в том что я пока не знаю за что зацепиться, с чего начать. Большая часть EPROM-ов у нас с впаяными микросхемами, а перетаскивать полсотни микрух в панели не очень интересно. Хотелось бы знать, существует ли внешняя писалка для "родных" EPROM-ов?
FieldPG (в комплекте со всем) нам предлагали за 8000 зеленых (или даже дороже).
Re: Замена PG на PC ?
Владимир; 7.1.04

Осторожней с покупкой FieldPG. У меня во время гарантийного срока вышли из строя CP5611 и затем винчестер. Может мне не повезло но это информация к размышлению.

Re: Замена PG на PC ?
Nec; 8.1.04

Что значит родных EPROMов?

Field так и стоит.
Но его нужно заказывать со Step5, тогда будет переходник для записи старых EPROMов.
Re: Замена PG на PC ?
Павел; 3.2.04

http://www.process-informatik.de/

Посмотри у них есть проммеры для модулей EPROM для S5.
Кстати пакет PG95/2000 это их изднлие.
По поводу замены на бук проблем нет.
только нужно выбрать нормальную схему
конвертера, там возможны варианты.
Большинство схем в инете питаются от
источника в ЦПУ, а в 150 сери через 511 плату питания нет, нужен внешний БП.
Кстати Сименсовский софт для РС не поддерживает USB, а только СОМ
Re: Замена PG на PC ?
Юрчик; 3.2.04

Ну 511 платы тоже разные имеются, есть и с активыным портом - там на плае преобразователь токовый можно увидеть в этом случае.

Re: Замена PG на PC ?
Oleg K.; 6.4.04

Замена PG на PC-ноутбук вполне нормальна и даже полезна, но при наличии внешней SIEMENS-гарнитуры (PC-адаптер для S7, AG/TTY-конвертер для S5, внешний проммер, и.т.д.). А вот излишним "немецким" качеством SIEMENS PG и некоторые OP/TP не страдают, особенно в плане HDD и видео.

Re: Замена PG на PC ?
Павел; 19.4.04

А зачем тебе обязательно иметь возможность переписывать EPROM?

В 100 там он стоит только как резервная память. Программа в рабочем режиме работает с RAM, если их в руки
часто не брать то и из строя они не выйдут. Пакет PG2000 в общем то неплох, но полностью ПГ не заменяет.
Нет там некоторых функций (например
просмотр состояния переменных..)
А так для архивирования программ и
редактирования вполне подходит.
Чтобы не дергаться, пользуйся повседневно буком, а ПГ675 оставь для
работы с EPROM. Прибор вообще железный и еще неизвестно что у тебя
накроется первым<


text

Сигналы 12 V DC
Юрчик; 11.4.04

Имеется потребность в работе с 12 вольтными сигналами, причем, требуется применять стандартные модули (модули развязки, собранные на коленки не подходят)

Нашел модули CQM1-ID111 от OMRON, но для их подключения к S7 по PROFIBUS-DP подходят только интерфейсы CQM1-PRT21 PROFIBUS slave, которые позволяют подключать только по 1 модулю на интерфейс
:-(((

Может я ошибаюсь или кто-то знает другие варианты приживления 12 вольтных модулей? Желательно от Siemens или по сети PROFIBUS-DP.

Re: Сигналы 12 V DC
Илья; 12.4.04

А развязывающие реле не пробовали ставить?

Re: Сигналы 12 V DC
Юрчик; 18.4.04

Реле увеличивают габариты шкафа управления и не позволяют диагностировать обрывы и к.з. на сигнальных линиях.


text

Полином для ТС 50М
RomanAS; 16.4.04

Подскажите, пожалуйста. У меня такая проблема к контроллеру S7-414-3DP необходимо подключить медное термосопротивление ТС50М, какой модуль из 4-х сотой серии наиболее подходит, и как преобразовать сигнал на входе в температуру (какой полином использовать?)

Re: Полином для ТС 50М
Kolik; 16.4.04

Думаю, что любой модуль, который способен мерять сопротивление. Мы используем 6ES7 431-7QH00-0AB0.

"Полином" можно найти в ГОСТ 6651-94
Полином для ТС 50М
RomanAS; 16.4.04

Спасибо!!!

Re: Полином для ТС 50М
Никита; 16.4.04

В Excel заполняешь соответствие R(T) и получаешь полином любой степени и точности.


text

входные/выходные сигналы модулей контроллера
Александр; 14.4.04

Подскажите пожалуйста, где можно найти описание (что эти сигналы из себя представляют) импульсного, резистивного входного сигнала, а также цифрового выходного сигнала (открытый транзистор)? буду очень благодарен

Re: входные/выходные сигналы модулей контроллера
григорий; 15.4.04

В описании модуля, а сейчас и в последнем каталоге (2003) нарисованы входные и выходные цепи модулей, откуда можно оценить вид гальванической развязки, ключи/реле и т.п.

Re: входные/выходные сигналы модулей контроллера
Александр; 16.4.04

На сайте siemens я описание не нашел.

Re: входные/выходные сигналы модулей контроллера
Alex; 16.4.04

Посмотри справа, кнопка "Заказать СА01", нажми ее.

Re: входные/выходные сигналы модулей контроллера
Александр ; 16.4.04

Дана только форма заказа. А разве описания на самом сайте нет?


text

Батарейка W79084-E1003-B1, аналоги?
Vikond; 16.4.04

Пром компьютер siemens оснащен такой батарейкой. Визуально ее не видать, разобрать компьютер нет возможности.

Есть ли описание этой батарейки? Обязаьельно ли использовать только такую или есть ее аналоги?<


text

входные/выходндые сигналы на модули контроллера
Александр; 14.4.04

Подскажите пожалуйста, где можно найти описание (что эти сигналы из себя представляют) импульсного, резистивного входного сигнала, а также цифрового выходного сигнала (открытый транзистор)? буду очень благодарен


text

Внешнее запоминающее устройство для S7-200
PAL; 13.4.04

Подскажите, пжалста, существуют ли в природе доп. внешние модули, стыкуемые с Simatic S7-200, для хранения полученных от S7-200 данных (внешнее запоминающее устройство для последующего переноса данных в компьютер)? Или, может быть, сторонние производители создали такое устройство?

Re: Внешнее запоминающее устройство для S7-200
Симахин Александр; 14.4.04

Какой объем данных и какие данные Вы хотите хранить.

Re: Внешнее запоминающее устройство для S7-200
PAL; 14.4.04

Обьем чем больше, тем лучше(от 1-4 Мег). Этот модуль хочу использовать как накопитель информации для последующей передачи на компьютер. Допустим, каждую минуту сохранять в нем 8 значений по 4 байта Real из V памяти в течении месяца (обьем порядка 1 Мег.


text

ввод-вывод
григорий; 26.3.04

Просьба уточнить в рамках ликбеза:

Для примера работаем со словом ввода, контроллер S7-400.

команда IW адрес - читает инормацию ввода из области процесса, считанную в начале цикла;
команда PIW адрес - заставляет считать информацию с устройства ввода в момент издания команды;

если адрес принадлежит устройству Profibus DP - вызовет
ли это немедленное (с точностью до 1мс) обращение к устройству на Profibus DP
или нужно использовать системные функции для обращения.
Мне нужно в рамках цикла обратиться к одному и тому же устройству Profibus DP
несколько раз.
Re: ввод-вывод
Scowl; 12.4.04

Периферийные входа считываются в начале циклла. Илли я не прав?...

Re: ввод-вывод
fresco; 13.4.04

>вызовет ли это немедленное (с >точностью до 1мс) обращение к >устройству на Profibus DP

Нет, не вызовет. Прочитаются данные, переданые устройством в последнем цикле Profibus-DP.

Кстати, мне тоже интересно, есть ли в данном случае разница между IW и PIW. Предполагаю что нет.

Re: ввод-вывод
Григорий; 13.4.04

PIW читает данные из регистра устройства, IW - из облпасти отображения.


text

градуировки Pt100
Николай; 1.4.04

Не подскажите какую градуировку Pt100 поддерживают модули аналогового ввода SM331

При работе с градуировкой ТСП100 w1,3910 - большая погрешность

Заранее спасибо
Re: градуировки Pt100
Гуленок Андрей; 1.4.04

3910 это стараГОСТовская градуировка. SIMATIC её пока не поддерживает. Набор коэффициентов индивидуален для каждого модуля и отражён в руководстве. Как правило это 3850

Re: градуировки Pt100
Валентин; 13.4.04

Pt100- она и есть Pt100.


text

Горячий Резерв
Константин Власкин; 11.4.04

Можно ли по сети IndustrialEthernet к H-Системе подключить два сервера, которые бы работали в горячем резерве? Какое дополнительное програмное/аппаратное обеспечение для этого необходимо?

Re: Горячий Резерв
Назаров Дмитрий; 12.4.04

Можно. Если имеются в виду сервера с WinCC, то необходимо приобрести дополнительно WinCC Redunanсy (один на два сервера). Естественно на каждом серевере должны стоять одинаковые лицензии WinCC. Более подробно см. каталог ST80

См. ST80 - Глава 2 WinCC


text

PG 720 P2 & Windows XP
Сергей; 24.3.04

Захотел на програматоре поставить Windows XP ,а при установке пишет что неправельная дата и что такое оборудование отсутствует в списке установки что делать?

Re: PG 720 P2 & Windows XP
Oleg K.; 6.4.04

Дело в том, что PG720PII программатор старого типа (рубеж 1999-2000 гг.) и ориентированы они были на системы WIN98 или NT4, по крайней мере в фирменной поставке с ним шел диск BACKUP PG 720/740 5/99. Думаю, что отсутствие драйверов видео, звука и др. в стандартной базе не даст установить XP.

Re: PG 720 P2 & Windows XP
Дмитрий; 9.4.04

Я поставил на данный программатор Windows XP - работает без проблем, софт стал меньше глючить (раньше стояли 98 винды), а дрова можно в

И-нете найти под видео и звук.<


text

Как формируется EventState
Diana; 6.4.04

Пытаюсь залезть в тэги 400-го зверя через OPC.

Когда работаем с обычными тэгами оттрансференными в WinCC, то на такие блоки, MEAS_MON, MOTOR и т.д. формируется 32-битное знаковое значение EventState. Его потом удобно использовать в GroupDisplay. Через OPC мы обязаны обращаться сразу к инстансным DB. WinCC-шный тэг EventState ссылается на тот же инстансный DB, что и все остальные сигналы нашего FB. А если открыть этот DB, то по тому смещению, на которое ссылается WinCC-шный тэг находятся другие данные.
Все очень запутано, а вопрос, на самом деле, такой: где формируется EventState и что это за формат данных такой DD?
Re: Как формируется EventState
Чистяков Дмитрий ОАО СеверСталь; 6.4.04

Ох и скока гемороя любят люди себе поиметь. ;-)

Чего ж было не испльзовать стандартный канал-то?
EventState - это словосостояние тэга. Где указываются биты состояния (ошибки, готовности и т.д.
Например, оно используется для отображения потери связи с контроллером. Так при обрыве связи все тэги на кадре визуализации будут серыми. Так вот они становяться серыми на основании информации этого самого словосостояния.

Re: Как формируется EventState
Diana; 7.4.04

Да я собственно догадываюсь об этом. Исторически как-то сложилось, что этот тэг удобно использовать для сложного отображения. Идея такая - я беру значение этого евентстэйта и по нему изображаю картинку, скажем мотора, разными цветами, (вместо того, чтобы тянуть отдельно тег аварии, отдельно алярмы и варнинги, состояния всякие..). Теперь у меня на экране тот же мотор, только я его подвязываю не к тегам S7-конекшона, а к тегам из ОПИСИ.

EventState мне действительно нужен.<


text

Вопрос о сертификации
Денис; 6.4.04

Может ли кто-нибудь сказать, сертифицированы-ли промышленные контроллеры Simatic для использования в системах управления и защиты в атомной энергетике.

Re: Вопрос о сертификации
Чистяков Дмитрий ОАО СеверСталь; 6.4.04

http://www.automation-drives.ru/as/support/cert/index.php


text

Какие то глюки...
DEE; 30.3.04

Hi!

Вот, народ, вопрос по новым 315-2DP...(которые с ММС)
Этот CPU( в сети - мастер) связан через встроенный Profibus порт с SIMADYN D (последовательно с двумя SS52), так вот загружаем SYSTEM DATA в CPU 315-2DP (или просто выключаем, а потом включаем питание контроллера 315-2ДП) - рушится связь по профибасу, симадин стреляется (вываливается коммуникационная ошибка).Опять выкл питание 315 -> переталк. симадин -> вкл. питания 315 в реж. стоп -> в реж. RUN - всё работает, но не всегда, иногда после переталкивания симадина и вкл. питания на 315 симадин опять стреляется - короче х...я какая то. Со старым 315 такого не было. Может кто знает как с этим бороться?
Re: Какие то глюки...
Bkmz; 1.4.04

Проапдейти операционку. У первых ЦПУ с ММС были глюки с профибасом.

Re: Какие то глюки...
DEE; 2.4.04

Hi!

Блин, здорово!!! :-( Хотя, пост был отправлен 1.4.04 :-) А что нам на это скажут придставители Siemens?
Re: Какие то глюки...
DEE; 6.4.04

Взяли старый 315-2DP (ну который с батарейкой), всё заработало...


text

Проблемы с S5-100
Максим; 3.10.03

Не работает линия на базе S5-100.Есть подозрения на EPROM.Нет никакого оборудования.Считал программу с микросхемы EPROM 2764 программатором Стерх.Есть листинг программы в виде списка команд.как проверить соответствие?есть ли какие то программы конвертации?

Re: Проблемы с S5-100
Шура; 16.10.03

Максим!

Где Вы находитесь и какой у Вас E-mail?

Re: Проблемы с S5-100
Serge_n; 5.1.04

Если проблема еще осталась напиши мне на мыло.

Re: Проблемы с S5-100
Олег К.; 6.4.04

Очень сомневаюсь, что виноват EPROM-модуль, сам работаю с SIEMENS-оборудованием PLC около 10 лет, работаю с разными моделями на реальном производстве и ни разу не видел "битого" EPROM'а от S5. F djn проблемы с CPU бывали и с S7 и S5


text

«Новый пуск» (COM_RST) регулятора SFB42 CONT_S
Кириллов Владимир; 2.4.04

Не смог найти описание встроенной в регулятор «программы нового пуска».

Не совсем понятно, за что она отвечает? Это просто инициализация переменных соответствующего DB или этот «новый пуск» обеспечивает безударное включение автоматического регулятора? Рекомендуется ли осуществлять новый пуск после переключения из ручного режима (LMNS_ON = False)? Или только после запуска контроллера?

Re: «Новый пуск» (COM_RST) регулятора SFB42 CONT_S
Валерий; 5.4.04

вот что делает эта подпрограмма:

A #COM_RST
JCN A7d0
L #LMNRSVAL
T #LMNR_SIM
CLR
= #QLMNUP
= #QLMNDN
L 0.000000e+000
T #PV
T #ER
= #LMNRS_ON
T #LMNRSVAL
T #LMNR_SIM
T #sFbPVal
T #sThrOn
L 0
T #siImpAus
L T#0MS
T #stImpDauer
T #stPausDauer
JU A7d1
<


text

как связать мобилу и S-200
dukat; 1.4.04

Интересует возможность связать мобильник и S-200 на предмет отправки SMS при нештатных ситуациях на производстве по заранее прописанному адресу.

См. Валерий

Re: как связать мобилу и S-200
Андрей Гуленок; 1.4.04

Re: как связать мобилу и S-200
dukat; 1.4.04

Не совсем понял.Имеется в виду ЕМ241?Если нет, то кто? Нельзя ли поподробней.

Валерий
См. 0712357822


text

OS simatic
Eugene Sergeev; 1.4.04

В описании программного обеспечения требуется указывать операционную систему, для которой разрабатывалось ПО.

В случае S5/S7 что можно написать?<


text

DC12V input - output
Юрчик; 30.3.04

У сименса не смог найти модули входов и модули выходов на 12 VDC. Кто-нибудь встречал подобные модули от других производителей, чтобы можно было подцепить их к Simatic S7 ?

Re: DC12V input - output
Алексей; 30.3.04

В таких случаях обычно применяют внешний блок питания на 12В и реле.

Re: DC12V input - output
Юрчик; 31.3.04

Реле для выходов, конечно, неплохо. А если надо для входов? ;-)

А если еще и диагностика каналов нужна нужна? :-D<


text

CPU 314C-2DP
Николай Новиков; 12.3.04

В S7 (SP6 стоит) в каталоге hardware есть цпу 314-6CF00-0AB0, а 314-6CF01-0AB0 нет

Подскажите кто знает где найти заплатку чтобы проинсталить его в S7
если не сложно киньте ответ по асе 143973518
Re: CPU 314C-2DP
Роман Абзаев; 16.3.04

ID 16832226 на CS

Re: CPU 314C-2DP
Максим; 31.3.04

У меня есть такая заплатка.

Re: CPU 314C-2DP
спасибо за советы; 31.3.04

я уже вылечил это глобальным способом - сделал апргрейд степа (благо было возможно)


text

cp-527 S5-135
Валерий, cp-527 S5-135; 25.3.04

Как найти, где пишется (рисуется) статический текст в COROS COM GRAPH v2?

Re: cp-527 S5-135
Nec; 26.3.04

Не знаю как у CP527, но у СP526 в пакете COM GRAPH рисуются сегменты, потом из них составляются статические дисплеи (Static Display), программируются динамические дисплеи (Dynamic Display), а уже потом все это объединяется в DOC (Display Output Commands)

Re: cp-527 S5-135
Валерий, cp-527 S5-135; 29.3.04

в cp526 где рисуются сегменты, какое меню? У меня такие вопросы, так как КОРОС на немецком, трудно сориентироваться.

Re: cp-527 S5-135
Валерий; 29.3.04

Как отредактировать символы того или иного языка,

используемые для отображения информации CP52#?

Re: cp-527 S5-135
ВАЛЕРИЙ; 31.3.04

в COM GRAPH где рисуются сегменты, какое меню? У меня такие вопросы, так как КОРОС на немецком, трудно сориентироваться.


text

Проблемы со скачиванием проекта с контроллера.
Vikond; 30.3.04

Контроллер AS488.

В оболочке asbedien при пропытке архивации проекта командой AR_PC с MemoryCard выходит ошибка "не найдена структура пользователя". Хотя по команде DI такая структура есть.<


text

SIMATIC S5
Геннадий; 29.3.04

Срочно куплю 6ES5 095-8MA05и6ES5 482-8MA13


text

Куплю S5-95
Юрчик; 26.3.04

Ищется ценральный процессор

6ES5095-8MA0х

О форме оплаты договоримся.<


text

S7-300 DP & Micromaster440
Fred; 22.3.04

Коллеги! Пмогоите схалявить ;) Стоит задача организовать опрос текущей скорости у ММ440 по DP. Знаю, что с помощью SFC - не вопрос. Но наверняка у народа имеется какой-либо FB, использующий SFC. Заранее благодарен. Нужно же как-то облегчать друг другу жизнь ;))) В свою очередь, чем смогу тем помогу...

Re: S7-300 DP & Micromaster440
Любитель Симатика; 26.3.04

А зачем халявить-то в таком простейшем деле? По DP через режим PPO3 с Микромастера можно читать и задавать скорость вращения и получать статус слово и давать контрольное слово непосредсвенно через адресное пространство. НИКАКОГО блока, даже SFC не нужно. Команды в СТЕПе L PIW и T PQW рулят. RTFM!


text

С7-635К невозможно медленно переключает экраны! Ну прямо тормоз перестройки!
AVR; 6.3.04

Люди! С7-635К невозможно медленно переключает экраны! Ну прямо тормоз перестройки!

Не берите С7-635К - будете 4 секунды
ждать обновления экрана. Вот такой опыт нехороший - лучшие программисты человечества не смогли ничего сделать,
Спасибо WinCE.

Re: С7-635К невозможно медленно переключает экраны! Ну прямо тормоз перестройки!
Дмитрий; 8.3.04

Интересно, вы сами писали проект для панели или видели уже готовый?

Re: С7-635К невозможно медленно переключает экраны! Ну прямо тормоз перестройки!
AVR; 17.3.04

Да сам лично и написал, а что тут такого ??

Re: С7-635К невозможно медленно переключает экраны! Ну прямо тормоз перестройки!
Психолог; 22.3.04

Уважаемый AVR, вместо того чтобы разобраться и найти решение проблемы, Вы выплескиваете эмоции.

Рекомендации: конкретизируйте ситуацию (количество тегов в проекте и на каждый экран, количество экранов, количество элементов на экране).
Re: С7-635К невозможно медленно переключает экраны! Ну прямо тормоз перестройки!
AVR; 24.3.04

Около 27 экранов, 350 тэгов,

на некоторых экранах до 130 элементов,
Протул постоянно предупреждает, что превышено кол-во элементов на экране,
но ессно я это игнорирую, т.к. надо выжать все возможное из панели.

Re: С7-635К невозможно медленно переключает экраны! Ну прямо тормоз перестройки!
Психолог; 24.3.04

Любой опыт интересен и полезен, в том числе и Ваш, уважаемый AVR. Однако, я думаю, что панель лучше эксплуатировать согласно ее техническим характеристикам. А именно: количество переменных не более 250, полей на экране не более 50, переменных на экране также не более 50. В нашем случае есть возможность увеличить количество экранов (максимально возможно 100), разгрузив уже имеющиеся. Конечно, придется тщательно продумать навигацию.

Re: С7-635К невозможно медленно переключает экраны! Ну прямо тормоз перестройки!
Василий; 25.3.04

Такая же ситуация с MP270. Спасибо WinCE. Голые экраны переключает 2-3 сек. Наиболее загруженный экран 10-14 сек. Не покупайте такую панель и не выкидывайте деньги на ветер. Оптимисты могут купить и попробовать.

Хотя МР370 переключает 1-2 сек (со средней загрузкой экрана), но там и внутренности мощнее.
Re: С7-635К невозможно медленно переключает экраны! Ну прямо тормоз перестройки!
fresco; 25.3.04

>предупреждает, что превышено кол-во

>элементов на экране
>но ессно я это игнорирую

То есть эти ограничения не жесткие, их можно превысить при необходимости?
Re: С7-635К невозможно медленно переключает экраны! Ну прямо тормоз перестройки!
Психолог; 26.3.04

Вопрос Василию: Вы тоже игнорируете технические характеристики МР270 и эксплуатируете ее значительно перегрузив?

Говоря отвлеченно, мне не понятен смысл приобретения продукта, который не удовлетворяет моим требованиям. Ведь предложение фирмой ряда продуктов с постепенным увеличением мощности и цены - это вполне логичное действие. И я уверен в нелогичности применения "слабого" продукта там, где по техническим требованиям должен стоять "сильный". По сему вывод: необходимо хорошо анализировать требования, технические условия и характеристики для правильного выбора продукта.<


text

Прграммирование CP-527 S5-135
Лобков Е.; 2.11.01

Необходим пакет для программирования сопроцессора CP-527 S5-135 желательно руский для S5 v7.1 PG-720 PII. Для PG-685 PCP/M-86 он называется COROS COM GRAPH.

Re: Прграммирование CP-527 S5-135
Никаноров, Сименс; 2.11.01

Он уже давно не поставляется и для S5 v7 его нет.


text

CP341/CP340
Михаил Ивлев; 23.3.04

Подскажите, есть ли где описание распределенния памяти в CP340/341?

Дабы работать с ними с помощью системных функций SFC58/59, а не с помощью библиотечных FB.
Т.е очень хочется написать свою программулину для работы с этими CP... есть такая необходимость.<


text

CPU314 -> Stop!!! Help!!!
Olga; 22.3.04

Новый CPU314 (тот что с ММС картой)работает-работает, а затем переходит в Stop, при этом в Диагностическом Буфере сообщение: "Переключатель режимов был переведен в Stop" и все... Лечится это только путем Mres-а

Буду благодарна за любые советы!!! (очень надо!!!)
Re: CPU314 -> Stop!!! Help!!!
Максим; 23.3.04

Возможно дело в загружаемой программе, попробуй загрузить просто конфигурацию и самую простейшую программу....


text

LOGO! (Вывод текста на дисплей)
Aleksey; 24.2.04

Можно ли редактировать параметры сообщения выводимого на дисплей при помощи блока Message texts? Какие параметры можно редактировать в выводимом сообщении, а какие нельзя?

В режиме симуляции вроде как можно редактировать (изменять) выводимые параметры, а на LOGO не получается редактировать параметры. Какими клавишами нужно пользоваться на LOGO для выбора и редактирования необходимого параметра.
Re: LOGO! (Вывод текста на дисплей)
BooDi; 22.3.04

Изменение параметров в активном тексте сообщения

Параметры и фактические значения можно изменять в
активном тексте сообщения, введя знак «+» в первой
строке. Чтобы воспрепятствовать изменениям, введите
знак «-».
Если текст сообщения активен, то для перехода в
режим редактирования нажмите клавишу ESC.
С помощью клавиш и выберите нужную строку (вы
можете выбирать только строки, содержащие
параметры). Для изменения параметра нажмите OK.
Используйте клавиши <,>,^ и V.
Подтвердите изменения клавишей OK. Теперь вы
можете редактировать другие параметры в тексте
сообщения (если они имеются). Нажмите ESC, чтобы
выйти из режима редактирования.<


text

CPU -224
ASLAN; 18.3.04

Всем привет.

Можно ли на порт CPU-224 ОДНОВРЕМЕННО ПРИСОЕДИНИТЬ 2 КОМПЬЮТЕРА?

Re: CPU -224
kot; 19.3.04

Можно


text

ещё по PID-регулированию
Максим; 17.3.04

В STEP-7 добавляем блок PID-регулирования FB41 CONT_C...необходимо регулировать уровень...все настройки блока оставляю по умолчанию... устанавливаю только задание уровня на входе блока SP_INT, уровень завёл на PV_PER...на выходе блока LMN_PER значение не изменяется, при том что значение уровня PV_PER изменяется...

В чём причина....быть может нужно задать ещё какие-либо настройки или с настройками по умолчанию всё должно работать?
Re: ещё по PID-регулированию
Любитель Симатика; 17.3.04

Я дико извиняюсь, но он(регулятор) в автоматический режим переведен или нет?

А еще может быть, что регулятор среагировал на разбаланс и вывел клапан на полное открытие или закрытие, т. е. он начал управлять, а реального отклика от процесса, например падение уровня из-за открытия сливного клапана нет. Вот он и держит тупо открытым клапан этот и ждет реакции процесса. Одним словом, обратную связь по процессу проверь.<


text

Зависание цифровых выходов
Вячеслав Прокунин; 16.3.04

Здравствуйте!

Наша проблема не совсем в области SIMATIC а скорее STEP5, но может здесь найдется «гуру». Имеется основной и резервный CP948R к которым подключены IM308C (Master), на другом конце кабеля ET200M с двумя IM153-2 (Slave) т.е. резервированный Profibus.
ET200M наполнен 4-мя SIM DI-DO и двумя SIM AI. Так вот при обрыве (отключении) любого кабеля происходит нормальный переход на резерв, а при обрыве обоих после восстановления связи все входы в норме, а на выходах устанавливается какой-то бред и сбрасывается только при выключении обоих СР (а это – полный останов котла). В каком направлении рыть, может есть какие мысли? Озвучте pls, а то очень сложно с экспериментами.

Re: Зависание цифровых выходов
Astronom; 16.3.04

А что у вас стоит в обции - реакция на стоп CPU?

Re: Зависание цифровых выходов
Вячеслав Прокунин; 16.3.04

Мы пользовались английской ComProfibus. Параметры: Response monitoring=Yes, Error reporting mode=QVZ. Это наверное то, о чем вы спрашивали.


text

Shift register в LOGO!
Ted; 15.3.04

Подскажите пожалуйста, как можно сдвинуть регистр не на 8 бит, а, к примеру, на 15 бит в LOGO! 0BA4.


text

Подключение по Profibus DP
Сергей; 10.3.04

Имеется контроллер Siemens S7-400 на шасси UR2-H. К нему подключаются Simocode по Profibus DP через Y-Link. Подключаются с помощью модулей СP443-5 Ext. Данные модули выстыпают только как master. Есть ли возможность соединить S7-400 по Profibus DP с СУ верхнего уровня по Profibus DP, с учётом того, что СУ может быть тоже только master в связи по Profibus DP? Каким образом реализовать данную конфигурацию системы, чтобы все работало устойчиво и без сбоев?

Re: Подключение по Profibus DP
Eugene Sergeev; 10.3.04

DP/DP link спасет отца русской демократии. Он в обеих сетях будет слейвом.

Re: Подключение по Profibus DP
Сергей; 11.3.04

А что это за устройство DP/DP link? Модуль или конвертер?

Re: Подключение по Profibus DP
aim; 11.3.04

DP/DP Link это просто шлюз между двумя сегментами PB сети. С "обоих" сторон работает как слейв. "Пишешь" с одной стороны, с другой "читаешь". И наоборот.

Re: Подключение по Profibus DP
Илья; 15.3.04

Чтой-то мудрено ето все... И вряд ли удовлетворит требованиям СУ - 240 байт маловато! И, вааще, когда есть Н-система (бешенных бабок стоит!) Проще добавить в обе корзины еще по одному СР (профибус или езернет) и вывести на резервируемый сервер ВинСС. А остальное самодеятельностью попахивает, что в Н-системах чревато боком...


text

C7-624
Андрей; 15.3.04

Здравствуйте.

Возникла проблема, необходимо подвязать датчики давления 4..20мА(двухпроводные) к C7-624.
Аналоговый модуль С7-624 не активный(нет источника тока).
Может кто имел дело? Подскажите.
Заранее благодарен.
Re: C7-624
Илья; 15.3.04

Последовательно с датчиком подключить источник питания на 24 вольта. Главное правильно подобрать источник.


text

Пид-регулирование
Mаксим; 12.3.04

Вопрос таков. В STEP7 добавляем блок FB41 (Пид-регулятор)...На вход PV_IN приводим входной сигнал с контроллера..а на LMN_PER выходной сигнал...остальные входы и выходы блока оставили по умолчанию...при загрузке программы на контроллер, на котроллере загорается красный индикатор ошибки SF. В чём причина?

Re: Пид-регулирование
komatoz; 12.3.04

Неправильная адресация наверно.

А вообще смотри диагностику на CPU, там все должно быть написано.

Re: Пид-регулирование
Ольштейн Эдуард; 15.3.04

Возможно не загрузили в CPU ЭКЗЕМПЛЯРНЫЙ БЛОК ДАННЫХ.


text

Дискретные входы
Serg; 9.3.04

Что такое тип входа PNP, NPN, открытый коллектор?

Re: Дискретные входы
Ольштейн Эдуард; 15.3.04

PNP, NPN - это тип транзистора, надо смотреть учебник по электронике. Вообще будет отличаться полярность управления, реакция на логические 0 и 1 на входе.

Открытый коллектор надо смотреть в том же учебнике, но речь идет о выходе. У транзистора выведен коллектор для подклюения в него нагрузки.
<


text

FM 357-2
Виталий; 22.11.03

Есть ли где докуметация на русском по FM357 и можно ли в Минске пройти обучение по позиционированию?

Re: FM 357-2
DRON; 24.11.03

В Феврале, когда я разбирался с FM357-2, документации на русском я не нашел ... И на сколько я понял, людей с опытом позиционирования этой FM, на територии СНГ- единицы... Из опыта скажу, что модуль интересный, но замороченный... Окуратнее с ним!:) Удачи

Re: FM 357-2
Олег; 24.11.03

Не заморачивайтесь с FM, возмите сразу SIMOTION - проще и эффективней, хотя наверное дороже.

Re: FM 357-2
В. Сорокин.; 25.11.03

Прочитайте документацию на Синумерики, есть русская. Для начала по 802S/C, а потом по 840Д. Этот модуль - УЧПУ без операторного интерфейса. Схожесть- на 90%. Но! применяя его на прессах, я скатился к 840Di. Немного дороже, но проще и сильнее. Если задеча не очень спецефилная, то это лучше.

Re: FM 357-2
Виталий; 26.11.03

МЗХ закупил уже 4 штуки, зимой должны уже дверки холодильников гнуть.Не разберёмся-расстрел.Описание не то чтобы сложное но сильно громоздкое-800 стр на английском.

Re: FM 357-2
В. Сорокин.; 27.11.03

А Вы попробуйте на ф. Ситек обратиться, они же в Минске. Там народ грамотный, и упомянутая документация есть.

К стати, холодильники у Вас хорошие. Спасибо. Только отвод талой воды постоянно перемерзает. Тонкий слишком.
Хотите перешлю свой проект с прессом, для примера.

Re: FM 357-2
Виталий; 1.12.03

Спасибо, у Ситеков был конфликт с Ген директором,но постораемся восстановить связи. Если трубка с фреоном не в центре корпуса, а прилегает к стенке, там намерзает-гарантия на шкаф 10 лет-пусть меняют.

Re: FM 357-2
Кирилл; 3.12.03

Если уже зимой ваша установка должна работать, а вы ведёте речь о курсах по позиционированию, то дело может кончится расстрелом. И не вижу смысла с проработкой пусть и русскоязычной документации, но по Sinumerik, т.к. последние ориентированы на решение контурных задач. В вашем случае приоритетными будут задачи не FM, а скорее PLC (задание скорости, пути, управляющих сигналов). Если будут конкретные вопросы – обращайтесь.

Re: FM 357-2
В. Сорокин.; 4.12.03

Дело в том, что в этой документации как раз и описываются задачи, которые должно решать в PLC-программе. Из 3-х книг на 802С 2 посвящены PLC. А если работать с FM357 на полную катушку, то не грех почитать 840Д (> 3000 стр.). И читать необходимо, т. к. модуль не имеет ОР интерфейса. Писать его надо самому, пользуясь NC-var selektor-ом, а описано это в док. на 840Д. И только по ненашему, и только очень мало.:)

А насчёт зимы - это очень верно подмечено, весна - сумрак рассеивается и приходит радость (окончания долгих трудов).

Re: FM 357-2
Виталий; 5.12.03

Спасибо,кто откликнулся, начинаем собирать макет CP315-FM357-OP17,появятся конкретные вопросы - буду обращатся.

Re: FM 357-2
В. Сорокин.; 8.12.03

Вам легче, с ОР17 писать интерфейс не очень придется, у неё свой доступ к FM. Рад за Вас. Хотя и куцая она.

Re: FM 357-2
ВИТАЛИЙ; 14.3.04

ПАКЕТ 357-2 ОРГАНИЗУЕТ БЛОК FC22, КОТ

ИСП ASI ИНТ- КОТОРЫМ МОЖНО ПРЕНЕБРЕЧ?

МЗХ, КАК И ЛИПЕЦК , ОПЛАЧИВАТ ВСЁ-НЕУЖЕЛИ СПЕЦЫ СИМЕНСА - ТУПЫЕ?

Re: FM 357-2
fresco; 15.3.04

>ИСП ASI ИНТ- КОТОРЫМ МОЖНО ПРЕНЕБРЕЧ?

Когда вы копируете в проект блок с уже существующим номером, Step предложит переименовать копируемый блок.<


text

Аналоговые модули S7-200
Grey; 12.3.04

Кто работал с ЕМ231 и с ЕМ235, подскажите где достать документацию на эти модули, в частности положение микротумблеров? Также пришлите у кого есть какие примеры с аналоговой переферией в S7-200.

Re: Аналоговые модули S7-200
Павел Иванов; 12.3.04

Все это вы можете посмотреть на этом же сайте в разделе посвященным микросистемам (S7-200). Там же лежит и полное руководство на русском языке.

См. http://www.automation-drives.ru/as/products/doc.php?l1=Микросистемы%20LOGO!%20и%20S7-200&l2=S7-200&l3=doc


text

Вопрос по Logo!
kao; 27.11.03

Есть лого с часами и в нем программа, которая в заданное время (в 5:30) включает нагрузку и через некоторое время отключает(в 6:00). Ошибок скорее нет, т.к. все кто можно уже ее посмотрел и ошибок не нашел. Глюки в том что периодично (~раз в 4 дня) таймеры не срабатывают.

Причем как на включение так и на отключение (при нажатии внешней кнопки активации включения нагрузки замыкается одно выходное реле (просто для "визуализации") и это реле не отключается когда должно было отключиться по таймеру отключения.
Вопрос - встречался ли кто с такими глюками в лого и как их устранял ?
Re: Вопрос по Logo!
Симахин Александр; 27.11.03

Возникает вопрос какой тип LOGO! (0BA2, 0BA3 ... и т.п.). И всетаки я склоняюсь к тому, что глюк в программе. Можно ли её посмотреть?! Вышли её по mail.

Re: Вопрос по Logo!
CGS; 12.3.04

ну и чем дело то закончилось?


text

СНОВА FM352
Евгений; 11.3.04

Подскажите кто работал с FM352?

Где взять темплату UDT 1(В которой
прописаны все параметры обмена
с FM352) ИЛИ этот UDT нужно набирать
вручную(Тогда что конкретно?).
В библиотеке FM 52LIB есть только
FC0,FC1,FC2,FC3.

ПОДСКАЖИТЕ КАК ПРИВЯЗАТЬ FC К БЛОКАМ
ДАННЫХ.
ЗАРАНЕЕ БЛАГОДАРЕН.
Re: СНОВА FM352
Андрей Сычёв; 12.3.04

Давай e-mail, скину библиотеку.

Re: СНОВА FM352
Евгений; 12.3.04

burevg@yandex.ru

Большое спасибо.<


text

Двухпроводное подключение к SM331
Василий; 25.2.04

На аналоговый модуль ввода SM331-7KF02 подключены все датчики по 2-х проводной схеме (4-20мА, питание с модуля).Все подключения выполнены в соответствии с руководством.Всё работает нормально. Как только на любой канал подключаем датчик по 4-х проводной схеме (естественно с изменениями в конфигурации и питание датчика от гальванически развязанного БП), то все двухпроводные датчики затыкаются и переходят в переполнение.

Кто что толковое может сказать по этому поводу. Кто сталкивался с подобной проблемой и как выходил из неё.
Re: Двухпроводное подключение к SM331
VVV; 26.2.04

В руководстве говорится, что нужно аналоговую землю посадить на цифровую. Это действительно помогает. Как то раз на раз не приходится. Иной раз нормально работает, а иной раз только это и помогает. Последний раз подключали самописец и была такая же проблема. Только так и решили.

Re: Двухпроводное подключение к SM331
Василий; 26.2.04

Всяко пробовали замыкать - бесполезно. Причем отрубаются только двухпроводные.

Re: Двухпроводное подключение к SM331
VVV; 27.2.04

Значит у вас помехи от этого устройства или перекос напряжений....

Не скромный вопрос :)) А вы переключатели на корпусе меняете? И не забываете, что меняются 2 входа сразу, а не один? (Ну это так на всякий случай спросил)
Re: Двухпроводное подключение к SM331
Василий; 1.3.04

Re: Двухпроводное подключение к SM331
Павел; 9.3.04

У нас имеется опыт подключения, можно сказать все время такая ситуация, на одной плате и 2-х проводное, и 4-х проводное подключение, и все работает. В 4-х проводной схеме "-" сажаются на Mana, а она соединена с цифровой землей в 1 точке. В 2-х проводной "-" не соединяются (а какую вы плату SM331 используете? Что за датчики по 2-х проводной схеме?). Наверное, где-то есть перетекание тока между БП и датчиками. Если совсем ни чего не помогает, посадите 4-х проводные и 2-х проводные датчики на разные платы.

Re: Двухпроводное подключение к SM331
VVV; 11.3.04

Вот вернулся из коммандировки и Ваша ситуация, Василий, вскрылась там. В общем на одной плате были датчики давления (2х пров.) и расходомеры Danfoss (4х пров.). Все работало нормально. Но потом расходомеры пришлось заменить на ультразвуковые Krohne. Подключение точно такое же как и было. В результате все входа расходомеров ушли в переполнение. При этом ток по миллиамперметру был в норме.

В общем ситуацию удалось разрешить только посадив все (!) аналоговые минусы с расходомеров на цифровой -24В. Если хотя бы один не посадить- все в переполнении.<


text

Возможна ли реализация ПИД регулирования на CPU312IFM и какое железо необходимо?
Sergey; 18.2.04

Возможно ли реализовать ПИД регулирование на CPU312IFM. Управлять регулирующими клапанами для поддержания требуемого давления в трубопроводе.

Необходимо не менее 3-х контуров?
Какие модули для этого необходимы?
Re: Возможна ли реализация ПИД регулирования на CPU312IFM и какое железо необходимо?
Симахин Александр; 11.3.04

Встроенных аналоговых входов/выходов у 312 IFM нет (есть 10/6=DI/DO), но есть модули расширения SM331(AI), SM332(AO), SM334(AI/AO). 3 контура регулирования реализовать можно, а вот что касается модулей то их достаточное количество и подбирать их предется Вам под характеристики обекта. Нужно только учесть, что максимально можно подсоеденить 8 модулей расширения в 1 ряд. По подбору модулей можете обратиться в ближайшее представительство SIEMENS A&D (см. Link).

См. http://aud.ru/about/index.php


text

FM352
Евгений; 10.3.04

Помогите кто знает!

Перестал работать модул FM 352--
горит красная мампа на нем.
В диагностике модуля пишет:
1. End of system parameter assignment
ID: 16#F181:0F02
2. Absolute encoder errors
ID: 16#F981 :8091
3. Start of system parameter assignment
ID: 16#F181:0F01
Кто может что подскажет и где найти
документацию на этот модуль.
Заранее благодарен.
Re: FM352
Павел; 10.3.04

Доки только на английском. Тут посмотри http://www4.ad.siemens.de/-snm-0135030360-1078737597-0000005374-0000000097-1078909872-enm-WW/llisapi.dll?func=cslib.csinfo&objid=10912361&objaction=csbrowse&lang=en&siteid=cseus&aktprim=0


text

Связь S5-135 - IM308C - TP270
ДмитрийД; 9.3.04

Не сталкивался ли кто нибудь?

Что надо для этого<


text

Работа с портами DP на S7-300
Константин Власкин; 7.3.04

Здравствуйте!

Подскажите можно ли работать с портами DP или MPI на процессоре на болие низком уровне чем сообщения profibus. Идея в том чтобы на CPU-318-2 реализовать подобие коммуникационного процессора для связи по RS-485.
Re: Работа с портами DP на S7-300
Роман Абзаев; 8.3.04

Для этого нужно применить 340 или 341.

Re: Работа с портами DP на S7-300
Константин Власкин; 9.3.04

Это самый очевидный вариант. Просто есть не задействованный CPU, а CP в наличии нет, поэтому хотелось использовать CPU.

Re: Работа с портами DP на S7-300
Чистяков Дмитрий ОАО СеверСталь; 9.3.04

Это практически не возможно, т.к. для DP используется специализированная БИС, которая решает задачи связи по Pofibus на своём аппаратно-программном уровне. А потому управление на передачу своих данных минуя эту чипу невозможен.

О чипе можно почитать вот здесь http://www4.ad.siemens.de/WW/news/en/6945238
Re: Работа с портами DP на S7-300
Власкин Константин; 9.3.04

Спасибо Дмитрий!

Ответ просто исчерпывающий.
Жаль, конечно, что все надежды разбились об эту статью.:-))<


text

Кто upg S7 5.0 на S7 5.1 ???
Eleria; 8.3.04

Или может сами Сименс подскажите почему после апгрейда он спрашивает уже не апгрейд лицензию, а почемуто полную установочную... Зачем тогда вообще так обманывать и продавать апгрейды ???

Re: Кто upg S7 5.0 на S7 5.1 ???
Назаров Дмитрий; 8.3.04

Судя по всему вы не выполнили процедуру апгрейда авторизации. На дискете идет ключ для перевода авторизации с версии 5.0 до версии 5.1 . В программе AuthorsW надо выбрать ключ и запустить процедуру Upgrade. Программа найдет ключ версии 5.0 и преобразует его в ключ 5.1 - "полную установочную". Так что никто никого не обманывает.


text

Как управлять с PC
Den Tigarbo; 3.3.04

Подскажите п-та в каком направлении двигаться. Имеется s7-200, программа к нему на step под 070 панель. Задача в следующем, управлять контроллером не с панели, а с пром. компьютера, соединенного с контроллером через интерфейсный модуль по tcp/ip с визуализацией тех процессов. Я так понимаю нужен ProTool, но как туда воткнуть имеющуюся программу управления, непонятно. Еще непонятно, клиенту продавать придется и ProTool Runtime, чтоб у него с PC все управлялось?

Re: Как управлять с PC
Гуленок Андрей.; 3.3.04

Если не задаваться вопросом, "зачем усложнять себе жизнь", то направление правильное. Нужен рантайм протула, и нужно переписывать проект с учётом управления с РС. Проект для ТР070 использовать удасться разве что как образец картинок.

А если не усложнять?
Den Tigarbo; 3.3.04

Если не усложнять, как эта задача по другому реализуется?

Re: Как управлять с PC
Андрей Гуленок; 3.3.04

С помощью ТР070. Ну или 170, она круче. Эти ТРшки как раз и были разработаны что бы не заморачиваться с персоналками. Просто аналогичная панельная РС стоит на порядок дороже даже без софта.

А ещё есть пакет микрокомпютинг. Это набор ОСХ объектов ориентированный на S7-200 для программирования на виджил бэйсике.
Re: Как управлять с PC
Den Tigarbo; 3.3.04

А где этот пакет на сайте представлен?

А насчет панели, просто задача стоит еще и в БД всю статистику из контроллера складывать а потом на PC делать отчетность по ней а за одно и управлять.
Re: Как управлять с PC
Андрей Гуленок; 3.3.04

Ткнуть в кнопку Customer Support

Набрать в строке поиска MicroComputing

А если у вас такие требования, то может сразу на протуле всё комплексно реализовать? Или на WinCC.
Re: Как управлять с PC
Den Tigarbo; 3.3.04

Об чем и речь. Значит нужен Protool для разработки и по Runtimу на каждого клиента? Т.е. сколько я продам систем столько лицензий надо покупать на рунтайм. А чем ProTool 6 защищен, какое лекарство ему нужно?

Re: Как управлять с PC
Андрей Гуленок; 3.3.04

Совершенно верно. Протул-про для разработчика и по одной лицензии на каждое рабочее место в соответствии с количеством переменных. Защита стандартная, лекарство - ключевая дискета. Если есть неодолимое желание работать через изернет, то потребуется ещё и АРС. Вкупе с СР 243-1 дешевле получится замутить всё через СР 5611.

Re: Как управлять с PC
Den Tigarbo; 3.3.04

Если я Вас еще не утомил, это что за зверь, а там встроен tcp/ip или в чем соль?

Re: Как управлять с PC
Андрей Гуленок; 3.3.04

Совершенно верно. Протул-про для разработчика и по одной лицензии на каждое рабочее место в соответствии с количеством переменных. Защита стандартная, лекарство - ключевая дискета. Если есть неодолимое желание работать через изернет, то потребуется ещё и АРС. Вкупе с СР 243-1 дешевле получится замутить всё через СР 5611.

Re: Как управлять с PC
Den Tigarbo; 3.3.04

Если я Вас еще не утомил, это что за зверь, а там встроен tcp/ip или в чем соль?

Re: Как управлять с PC
Роман Абзаев; 5.3.04

1.Это не зверь. Это PROFIBUS-карта для ПК.

2.Всё-таки, зачем управлять с ПК? Неужели панели не хватает?
3.Чаще, чаще смотрите каталоги, дорогой товарищ!
Re: Как управлять с PC
Den Tigarbo; 5.3.04

Уважаемый товарищ, задача поставлена управлять с компа, БД скачивать в комп и привязать к ERP системе фирмы.

Re: Как управлять с PC
Роман Абзаев; 5.3.04

Кто производитель ERP и конкретно как цепочку от 200 собираетесь строить?

К МР270 присматривались?

Re: Как управлять с PC
Den Tigarbo; 5.3.04

Производитель ERP любой т.к. мы продаем клиенту, главное получить в компе файл любого формата (txt,bdf) мы из него уже че хошь сделаем. Но проблема, в 6 протуле 2sp не могу найти где архивирование лежит, а описание с сайта на 5-й. Может Вы подскажете как в 6-м реализовано. А что такое mp270

Re: Как управлять с PC
Роман Абзаев; 5.3.04

О. Да Вас батенька надо срочно приобщать к счастью Симатика. :)

1. Почему бы не использовать возможности ОРС?
2. МР 270 - это мультипанелька. На ней, кстати,, можно реализовывать "тонкого клиента".
3.Документация на 6-ку это ID 1143018 на CS.
Re: Как управлять с PC
Den Tigarbo; 5.3.04

OPC для s-200 качаю с немецкого сайта, а что еще надо для оного полного счастья?

Re: Как управлять с PC
Роман Абзаев; 6.3.04

1.Забуриться в ближайшее бюро.

2.Чаще бывать на www.aud.ru и www.ad.siemens.de
<


text

Программирование FM353
Алексей; 6.3.04

Нужна докаментация по программированию на русском языке, желательно подробная...

<


text

Проблема с установкой Siwarex (U,M) в Step7 W2k, XP
Александр; 1.3.04

Как можно установить модули Siwarex (U,M) в Step7 c ОС W2000, Win XP?

Имеющиеся у нас версия позволяют установить эти модули только на NT, либо W98. Существуют ли какие либо обновления данного продукта для указанных ОС?

Re: Проблема с установкой Siwarex (U,M) в Step7 W2k, XP
Дмитрий; 1.3.04

Существуют :-) Помотрите A&D Mall - баннер в правом верхнем углу.

Re: Проблема с установкой Siwarex (U,M) в Step7 W2k, XP
Игорь; 3.3.04

Меня тоже очень интересует этот вопрос.

Нельзя ли поподробнее указать ссылочку, где можно скачать SIWATOOL M для W2k (который интегрируется в Step 7).
Заранее благодарен...
Re: Проблема с установкой Siwarex (U,M) в Step7 W2k, XP
Александр; 3.3.04

Как я понял , речь идет не о скачивании, скорей всего надо будет покупать новые версии Siwatool (U,M). :-(

Re: Проблема с установкой Siwarex (U,M) в Step7 W2k, XP
Дмитрий; 4.3.04

Или апгрейд с предыдущей версии

Re: Проблема с установкой Siwarex (U,M) в Step7 W2k, XP
Александр; 5.3.04

To Дмитрий: А где искать апгрейд ? В A&D Mall чего-то не нашел (или не там искал?). Подскажите плиз, если владеете етой инфой :-).

Заранее благодарен.
Re: Проблема с установкой Siwarex (U,M) в Step7 W2k, XP
Дмитрий; 5.3.04

Что-то я тоже апгрейд не нашел :-( А реньше был... Есть только софт 5.1 для SIWAREX U 7MH4683-3AA63 - 164 Euro.

Re: Проблема с установкой Siwarex (U,M) в Step7 W2k, XP
Александр; 5.3.04

Пасиба :) Теперь осталось тока начальников на 164 еврика раскрутить или прописывать железо со станции с NT... Хотя, может и получится приобрести :)


text

С помощью чего слить данные из S-200 в БД
Den Tigarbo; 4.3.04

Каким ПО воспользоваться, чтобы экспортировать данные тех. процесса из S-200 в любом виде (txt,dbf) в компутер?

Re: С помощью чего слить данные из S-200 в БД
Роман Абзаев; 5.3.04

См. здесь

Re: С помощью чего слить данные из S-200 в БД
Роман Абзаев; 5.3.04

Посмотрите так же ID 7208460, 1232912 и 9927643 на CS и диск Microsystem

Re: С помощью чего слить данные из S-200 в БД
Den Tigarbo; 5.3.04

Везде в описании на протул есть меню Archiv, не могу его найти в 6 sp2, подскажите может в нем архивирование как-то по другому реализовано?


text

Как добавить 6GK7343-1EX20-0XE0 в проект написанный на STEP7 V5.1+SP6 ?
Серых Андрей; 26.2.04

Собственно сабж. Если какой то апдейт конфигурации в STEP7? Или прийдется ставить V5.2?

Заранее благодарю за ответ!
См. рабочая страничка

Re: Как добавить 6GK7343-1EX20-0XE0 в проект написанный на STEP7 V5.1+SP6 ?
Илья; 26.2.04

А 1ЕХ10 или какой другой ставится? Если нет - то надо NCM for IE ставить.

Re: Как добавить 6GK7343-1EX20-0XE0 в проект написанный на STEP7 V5.1+SP6 ?
Серых Андрей; 26.2.04

NCM стоит. 1EX00,1EX10 или 1EX11 ставится без проблем.

См. рабочая страничка...

Re: Как добавить 6GK7343-1EX20-0XE0 в проект написанный на STEP7 V5.1+SP6 ?
Серых Андрей; 5.3.04

Выход найден...

Есть обновления http://www4.ad.siemens.de/-snm-0135038936-1077799501-0000027576-0000000002-1078414225-enm-WW/skm/newSKM/frameset.asp?markerurl=%2FWW%2Fllisapi%2Edll%3Ffunc%3Dll%26objID%3D14564731%26objaction%3Dcsview%26lang%3Den%26siteid%3Dcseus&lang=en&aktprim=99&siteid=cseus&query=NCM%207&searchinprim=0&nodeid0=10805639&cur_pos=0 здесь и надо смотреть.

Так что если у кого то такая проблема есть, решаемо хот фиксом.
См. рабочая страничка...


text

S7-300
Hunter; 5.3.04

Приходиться работать с Симатик 7-300. Перед тем как воспользоваться курсами ПРО-1 решил разобраться в той информации, что выставлена на сайте. Вопрос: какой версии ассемблера, описанной в литературе, близок язык Step 7(список загружаемых инструкций).

Олег.<


text

В каких CPU, кроме CPU 314 есть возможность регулирования ?
Максим; 2.3.04

В каких CPU, кроме CPU 314 есть возможность регулирования ?

Ответ
Дмитрий; 3.3.04

Используя стандартные блоки регулирования вы можете их применять в любом CPU

Re: В каких CPU, кроме CPU 314 есть возможность регулирования ?
Максим; 3.3.04

Спасибо за ответ. Я просто перепутал встроенное регулирование у CPU 314

Re: В каких CPU, кроме CPU 314 есть возможность регулирования ?
Дмитрий; 4.3.04

Встроенные блоки регулирования есть у котнроллеров 313С и 314С - они аналогичны стандартным блокам.


text

Com- порт программатора Siemens PG720
Павел Ш.; 28.4.03

В программаторах Siemens используются специальные Com -порты (V24). Однако очень часто необходим нормальный RS232, например для связи с другими контроллерами. Схем превращающих обычный RS232 в V24 в инете полно, а схем обратной трансформации сигнала не встечал. Помогите советом или схемой.

Re: Com- порт программатора Siemens PG720
Любитель Симатика; 28.4.03

Насколько я помню в PG 720 2 КОМ-порта.

№1 25pin мама действительно V24/TTY служит для программирования S5
№2 9pin папа самый обычный RS232.
Так что ничего не надо превращать.
Re: Com- порт программатора Siemens PG720
Павел Ш.; 28.4.03

Да нет, около обоих разъемов есть соответствующая надпись V24, да и реально много раз убеждался в специфичности этих интерфейсов RS232

Так что жду других советов
P.S.
Sorry за двойной вопрос - неудачно обновил страницу
Re: Com- порт программатора Siemens PG720
Алексей; 28.4.03

Любитель Симатика прав в Pg720

COM 1 для S5,а COM2 обычный RS232.
Проверено.

Re: Com- порт программатора Siemens PG720
Павел Ш.; 28.4.03

Ну раз вы так уверены, то может быть прога для связи с контроллером(проверял на контроллере Automax) была кривая. Пробовал с Com1 и Сom2 - связи не было(менял и настройки в проге), а с обычным компьютером связь нормальная(правда проверял только на Com1).

Попробую проверить еще раз.
Всем спасибо за помощь.
Re: Com- порт программатора Siemens PG720
Андрей Гуленок; 30.4.03

Сом2 там самый обычный. А вот Сом1 действительно совмещённый, TTY и Сом в одном разъёме. Разумеется его можно использовать как стандартный Сом, нужно только отбросить "лишние" пины на разъёме. Самый простой путь использование переходника 25->9, только 25 папу заменить на маму. Разводка штатная.

Кстати, разводка Сом1 есть в руководстве на программатор.
Re: Com- порт программатора Siemens PG720
Саша ВАСИЛЕНОК; 3.3.04

Как откалибровать или зарядить батарею

в PG720<


text

Как правильно вызывать асинхронную SFC 13?? ??
Андр; 13.2.04

Уважаемые коллеги!!

Намучался конкретно, не могу правильно вызывать асинхронную SFC 13,
все время возвращает ненулевое значение.
Надо видимо контролировать что-то, или считать кол-во вызовов и что-то делать?? В настоящий момент функцию вызываю из OB через каждые 50 мс.
Прошу помощи клуба знатоков!
Re: Как правильно вызывать асинхронную SFC 13?? ??
Тараненко Виктор; 16.2.04

Некоторые замечания, на которые натыкался сам:

1. Адрес в входном параметре LADDR д.б. не Profibus, а диагностический адрес ID (который впрочем жеско привязан к PROFIBUS адресу). Его можно посмотреть в HW.
2. Надо контролировать Busy при считывании.

Пока все. Вспоминаю, что все шероховатости убирал по информации в RET_VALUE.
Re: Как правильно вызывать асинхронную SFC 13?? ??
Андр; 17.2.04

А вот период вызова 50 мс - он сильно влияет, может его увеличить, предположим до 500 мс ??

Ну а насчет Busy - я так понял если "занята" функция, то не вызывать ??

Re: Как правильно вызывать асинхронную SFC 13?? ??
Чистяков Дмитрий ОАО СеверСталь; 17.2.04

Именно.

Т.е. вызвать её в следующий скан (или несколько сканов), когда BUSY выдаст готовность.
Re: Как правильно вызывать асинхронную SFC 13?? ??
Илья; 27.2.04

Функция запускается ПО ФРОНТУ. Для последующего запуска необходимо перебросить входной сигнал. Для экспериментов замечательно подходит Clock Memory (see HardwareConfig). По умолчанию это МВ0. Привяжитесь к биту с нужной частотой изменения и вперед!

Re: Как правильно вызывать асинхронную SFC 13?? ??
Андр; 27.2.04

Уважаемый Илья, вы пишете:

"Функция запускается ПО ФРОНТУ" - т.е. в момент вызова функции необходимо организовать переход из нуля в единицу на входе "REQ" функции SFC13 ??

"Для последующего запуска необходимо перебросить входной сигнал".
Под входным сигналом подразумевается вход "REQ" ??
Спасибо за ваш ответ.

Re: Как правильно вызывать асинхронную SFC 13?? ??
Илья; 3.3.04

Active - BOOL

SFC_BUSY - BOOL
// ---------------------
A "Init"
FP "Init_FP"
AN #SFC_BUSY
= #Active
S SFC_BUSY
CALL SFC_XYZ
REQ:= #Active
.
.
.
O SFC_XYZ.OK
O SFC_XYZ.ERROR
R SFC_BUSY
Ну, типа того, только еще код для обработки различных событий...<


text

S5-90, 100
demos; 2.3.04

Насколько S5-90 и S5-100 совместимы со старыми программаторами?

Re: S5-90, 100
Павел Иванов; 2.3.04

С какими старыми программаторами?

PG670, PG675, PG685, PG 635?
PG710, PG730, PG750?
PG 720, PG740?<


text

MPI адаптер и S7-200
Anton; 19.1.04

Добрый день!

Просьба ответиь - возможно ли программирование S7-200 через MPI адаптер?
Re: MPI адаптер и S7-200
kot; 19.1.04

Нет.Для этого нужно перевести порт в MPI в System Blok , а для этого нужен PPI-кабель.

Re: MPI адаптер и S7-200
Anton; 19.1.04

у меня 222, вроде как по умолчания порт должен определяться и по MPI, и по PPI, но он просто не хочет по MPI,

а на данный момент PPI кабеля нет
Re: MPI адаптер и S7-200
kot; 21.1.04

по умолчанию порты 200 настроены ppi 9600.

Re: MPI адаптер и S7-200
Игошев ; 1.3.04

По MPI можно программировать S7-200 если в сети есть S7-300 (естественно мастер), или берите карточку CP5611 и все проблемы пропадут


text

Изменение UDT и последствия
Aлександр; 25.2.04

Есть проект для S7-300 + ProTool на PC.

В программе для контроллера используется UDT1; DB1, состоящий из UDT и вызовы этого DB.
В PtoTool имеются переменные, ссылающиеся на DB1.
При изменении UDT1 (добавление в него переменной, соответственно изменяется размер UDT) в программе контроллера получаются конфликты при обращении к DB1, а в ProTool переменные вообще отвязываются от DB1.
Как правильно измененить UDT ?
Re: Изменение UDT и последствия
VVV; 26.2.04

Так и изменить, как Вы изменяли. Только после изменения и сохранения UDT необходимо открыть DB1. Там старые переменные будут красного цвета. Щелкнуть правой кнопой на имени переменной из UDT и сделать Update Declaration.

Но! Конфликта с протулом скорее всего не избежать, так как адресное пространство все равно перераспределится.
Re: Изменение UDT и последствия
Gibbon; 27.2.04

в открвтом блоке можно выполнить команду file->check and update accesses

или из менеджера сделать
edit->check block consistancy
Re: Изменение UDT и последствия
Александр; 27.2.04

В открытом блоке команда File->Check and Update Accesses помогает обновить декларации переменных и блоков.

А вот символьные ссылки на UDT в DB1, которые из такого вида "DB1.DATA1.X" были преобразованы в вид "P#DB1.DBX0.0 BYTE 76" так и остаются.
Edit->Check Block Consistancy... при компиляции обновляет DB1, а в FC и FB остаются ошибки.
A с ProTool-ом я разобрался: Edit->Restore Symbols.
Re: Изменение UDT и последствия
VVV; 1.3.04

Да, но Restore Symbol, только если проект интегрирован и там символьная таблица контроллера настроена.

Можно же разинтегрированный проект писать...<


text

Вопрос по новым 315-2DP
DEE; 9.2.04

Hi!

У меня вопрос такого плана. Есть контроллер (новый, который ММС) 315-2DP, и по Profibus DP со встроенного порта к нему законекчены два слэйва (модули SIMADYN D) SS52, так вот при закрузки ПО в контроллер 315-2ДП, а точнее именно системных данных (данные из HW Config, или NCM), связь по профибасу рушится и контроллер перестаёт видеть слэйвов...приходится переталкивать симадин д, тогда восстанавливается нормальная работа. Кстати если грузить в контроллер только блоки, то такого бага не происходит. И ещё, раньше, до получения оборудования основного (куда входит новый 315-2дп) упражнялись со тарым 315-2дп( который исчо с батарейками), так вот такой проблемы не было! Так, может, кто скажет в чём тут дело?
Re: Вопрос по новым 315-2DP
Илья; 27.2.04

Новый 315-й с глюками. Попробуй обновить ему операционку. Говорят. помогает...

Re: Вопрос по новым 315-2DP
Astronom; 27.2.04

Так может просто в симодине поставили параметр авария при потере профибаса, а когда грузишь конфиг у тебя контроллер рестартует, ну соответственно пропадает мастер. У меня тоже симореги, симоверты и т.д. если установлю параметр (авария по профибасу) в них при перезагрузке контроллера вылетаютю Приходиться бежать к преобразователям и квитировать ошибку...

Или чёт не понял<


text

Курсы Siemens
Konstantin; 11.1.04

Здравствуйте!

Если кто нибудь проходил обучение на курсы то просьба высказать своё мнение о качестве и целесообразности обучения на данных курсах.
Re: Курсы Siemens
Александр; 12.1.04

многее зависит от кандидата которого посылают

если кандидат соответствует требованиям
то после курсов начинает програмировать
Re: Курсы Siemens
Konstantin; 12.1.04

Ну, многие программируют и без курсов.

А каким требованиям таким должны соответствовать кандитдат? Мне просто кажется сомнительной идея, ято за 4-5 дней можно чему то научить.

Re: Курсы Siemens
Александр; 13.1.04

не 4-5 ,а две недели pro1 & pro2

а требования там описаны (книги на курсах дают по которым учат)
,а на тему самому освоить тоже реально но дольше
Re: Курсы Siemens
Виктор; 13.1.04

Я считаю, что курсы нужная и полезная вещь. После них все распределяется по полочкам, в нужные места :))

Пройти нужно обязательно обе части и не считать, что мне это не нужно...
Таково мое мнение
Re: Курсы Siemens
mr.Sheyh; 14.1.04

Учился я в Самаре на Про1 и через 1год по сетям. Если честно, то после Про1 во многом доезжал сам до всяких мелочей, зато уже через год умея нормально программить в легкую отучился по сетям. Учиться стоит если будешь потом программить, а если учишься для какой-нить поддержки, где в прогу будешь влазить 1 раз в месяц - не стоит!

Re: Курсы Siemens
Alex; 14.1.04

Прежде чем на курсы идти нужно самому

документацию почитать.Тогда на курсах
многое станет понятным сразу.
И не будешь слушать там все с широко раскрытыми глазами.
Re: Курсы Siemens
Андрей; 14.1.04

Стоит или не стоит - это если для себя учишься. Нормальное предприятие (при нормальном руководителе) должно в обязательном порядке посылать на учёбу. На рабочем месте учиться дольше и, в итоге, дороже для предприятия. Сам учился в Москве (9 курсов) и не жалею. Остальная группа училась в Питере и немного в Москве. Много зависит от преподавателей и от обучаемых.

Кстати, по обслуживанию тоже курсы есть, но по моему лучше всё-таки обычные Pro1+Pro2 и т.д..
Re: Курсы Siemens
Konstantin; 15.1.04

Re: Курсы Siemens
Виктор; 15.1.04

Да, я считаю, самые нормальные курсы.

Потом можно и Протул поизучать...
Re: Курсы Siemens
Андрей; 15.1.04

Для выбора курсов надо знать Вашу ситуацию. Обслуживание или разработка (или обслуживание + модернизация)? Обслуживание чего?

В любом случае Pro1+Pro2, далее - визуализация, сети, доп. пакеты и т.д. по необходимости. Желательно учесть перспективу (слияние веток WinCC и ProTool).
Re: Курсы Siemens
Konstantin; 15.1.04

Ситуация такая.

Система автоматизации на базе S7-400H
Верх на WinCC.
Обслуживание сведётся к небольшим модернизациям как верха так и низа, в случае необходимости подключения новых датчиков или исполнительных механизмов.
Т.е. задача разработки с нуля не предполагается.
Re: Курсы Siemens
Андрей; 16.1.04

Тогда:

Pro1+Pro2 - программирование контроллера;
ST-BWINCCS+ST-BWINCCV - визуализация (WinCC);
KO-7KPROFI - Profibus;
KO-7KETHER - Ethernet.

Кроме этих основных курсов может быть нужно будет что-нибудь добавить, например S7-KPTP, ST-7GRAPH, ST-7SCL, ST-7CFC, если это у Вас используется.
По поводу добавочных курсов посоветуйтесь в Вашем представительстве Сименса (или приехав на учёбу), показав Вашу программу.
Небольшие модернизации всё равно требуют хорошего знания всей чужой программы, а с Вас спросят жёстче, чем со специалиста со стороны.

Желаю Вам удачи.
Re: Курсы Siemens
Роман Абзаев; 16.1.04

А ещё курсы очень ценны живым общением. :)

Re: Курсы Siemens
mr.Sheyh; 17.1.04

Могу сказать точно, что курсы про ПроТулу нафиг не нужны - сам за 1 неделю разобрался со всем протулом - все очень просто. Тока один момент - разные панели имеют свои фичи.

Re: Курсы Siemens
Слава; 5.2.04

Мне курсы по 7 Симатику очень понравились!!!Много конкретного материала с разъяснением сложных моментов!Моделирование ошибок, изучение инструментов их поиска!!! Да и просто живое общение, отличные обеды и атмосфера курсов!!!!

Re: Курсы Siemens
Илья; 27.2.04

Для mr.Sheyh: Для банальных вещей можно ProTool за 2 недели расковырять. Но, если хочешь наворотов... Задумайся:

1) Как сделать двухуровневую бар-диаграмму на ОР270 (типично для нефтянки, где надо показать не только уровень в танке. но и границу раздела сред)
2) Синхронизация времени между панелью и контроллером для 2-х случаев
а) контроллер тайм-мастер
б) ОР тайм-мастер.
И это только начало... Скромнее надо быть, а то вы похожи на ламера. который научился лабать формочки и считает себя крутым программером...<


text

Где найти пример реализованого FB41
Максим; 22.2.04

Где найти пример реализованого FB41, существующей инструкции не хватает?

Re: Где найти пример реализованого FB41
komatoz; 23.2.04

В примерах, устанавливаемых с S7 называется: zEn01_13_STEP7__PID-Temp

Re: Где найти пример реализованого FB41
Илья; 26.2.04

Только это слабо помогает. До тех пор, пока сам не определишь параметры (характеристики) регулируемого процесса..


text

Тип чипа процессора в контр-ах S7-300/400
Дмитрий ; 17.2.04

Подскажите пожалуйста

или информацию где поискать
Заранее спасибо

Re: Тип чипа процессора в контр-ах S7-300/400
fresco; 18.2.04

>или информацию где поискать

Открыть корпус и посмотреть на плату :о)
Re: Тип чипа процессора в контр-ах S7-300/400
Дмитрий; 18.2.04

>Открыть корпус и посмотреть на плату :о)

А может быть уже кто-то открывал :-)
Re: Тип чипа процессора в контр-ах S7-300/400
fresco; 19.2.04

В 318-2DP стоит AMD386-40

В младших 400-х должен быть такой же.
В CP342-5 стоит Intel 386EX-25.
В новых 315-х секретный чип под названием "Infineon S7 Controller" =)
Но вряд ли они ушли от х86.

Re: Тип чипа процессора в контр-ах S7-300/400
Дмитрий ; 23.2.04

Спасибо, очень помогло.

А Infineon S7 Controller это все таки что такое?
Re: Тип чипа процессора в контр-ах S7-300/400
Роман Абзаев; 24.2.04

А Вы у Инфинеона и попробуйте спросить.

См. http://www.infineon.com

Re: Тип чипа процессора в контр-ах S7-300/400
fresco; 25.2.04

Infineon это бывший Siemens Semiconductor, а S7 Controller - заказной чип, спроектированый вокруг какого-то существующего ядра. Если спросить то могут даже ответить, если у них нет обязательства держать это в тайне.

Re: Тип чипа процессора в контр-ах S7-300/400
Павел Иванов (Сименс-Москва); 26.2.04

Обычно в контроллере стоят несколько процессоров:

- один стандартный, для операций над словами, вычислений с плавающей запятой и т.д.
- и один или больше специализированных, для быстрых битовых (логических) операций, задач коммуникаций и т.д.<


text

Протокол для СР341
Eugene Sergeev; 30.1.04

Где все-таки скрывается эта загадочная прога с помощью которой можно сконфигурить свой протокол для СР341

Re: Протокол для СР341
Ивлев Михаил; 3.2.04

если ты про недоступную кнополку "Parametrs", то вместе с CP идет диск на которм есть софт для нее

Re: Протокол для СР341
Eugene Sergeev; 3.2.04

Нет, я про некую софтину, с помощью которой можно создать свой загружаемый протокол (наряду с уже существующими модбасом, аскии и проч.)

Re: Протокол для СР341
kot; 4.2.04

Физику ты прописываеш в HW-Config, а

програмно что чего кому куда send-reciv
ты должен прописать сам в блоках для передачи или приема данных.
Re: Протокол для СР341
Григорий; 4.2.04

Вообще во флэш СР, по крайней мере 441-2, можно занести некую программу, реализующую протокол и обиен с CPU. Поэтому хотелось бы иметь средства написания энтой программы. Как я полагаю, речь идет о подобных средствах.

Re: Протокол для СР341
Eugene Sergeev; 6.2.04

Именно об этом и идет речь. Вроде как оно на сименсовском сайте валялось, но теперь нету.

Re: Протокол для СР341
Роман Абзаев; 6.2.04

Как нет? ID 12310504 на CSS разве не то?

Re: Протокол для СР341
Михаил Ивлев; 6.2.04

на каком сайте?

Re: Протокол для СР341
Роман Абзаев; 6.2.04

Ну-у-у-у-у.... Сколько раз было говорено http://www.ad.siemens.de/csi_e Вот ссылочка справа вверху - как раз под "Заказать СА01"

См. CUSTOMER SUPPORT!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Re: Протокол для СР341
Григорий; 7.2.04

А нельзя ли более детальную ссылку. В свое время облазил вроде весь CSS в поисках оного средства

Re: Протокол для СР341
Роман Абзаев; 10.2.04

Хм... Вводите в строку поиска Software CP 341 и внимательно смотрите выданные ссылки. Конкретно ID 12310504!

Re: Протокол для СР341
Григорий; 10.2.04

Увы, но это то, что поставляется с СР на компакт-диске.

Re: Протокол для СР341
Eugene Sergeev; 12.2.04

IMHO, искомый продукт обитал под ID 5666115 или что-то около того. Потом его снесли.

Re: Протокол для СР341
Pi; 25.2.04

И все же. Подскажите, ГДЕ найти программу для написания своего! протокола.

Re: Протокол для СР341
Константин ; 25.2.04

А с чего Вы взяли что такая возможность существует?

В документации про такую возможность ни полслова не сказано.
Re: Протокол для СР341
Eugene Sergeev; 25.2.04

В середине прошлого года были где-то анонсы, потом появилась на сименсовском сайте софтина вроде как для этого, потом ее убрали.

Re: Протокол для СР341
Pi; 26.2.04

А может быть у Вас есть, Eugene Sergeev, a.

Re: Протокол для СР341
Eugene Sergeev; 26.2.04

Сам ищу, не подсуетился в свое время, теперь локти кусаю...

Re: Протокол для СР341
Константин; 26.2.04

Странно что и служба поддержки по этому поводу молчит. Я им пару писем отослал-а в ответ тишина.


text

Ток потребления от рез. источника?
Pribor; 24.2.04

Здравствуйте коллеги!

Как определить ток потребления резервного источника (батарейки) при выключенном питании контроллера? Залезть и измерить амперметром или где-нибудь написано? Контроллер S5-115U.
Re: Ток потребления от рез. источника?
alex-b3; 25.2.04

А зачем?

Похоже он близок к току саморазряда. У нас на двух S5-115U стояли L-120 девять лет. Отключения от сети за это время бывали до месяца. Заменили на всякий случай.
Берите просто хорошую батарейку.
Re: Ток потребления от рез. источника?
Роман Абзаев; 26.2.04

И меняйте батарейку раз в полтора года...


text

Модуль связи СР-542
Баженов Сергей; 18.2.04

Что это за модуль и где достать описание его описание, в каталоге и впрайсе о нем ни слова, упоминается только ср-541.

Re: Модуль связи СР-542
Чистяков Дмитрий ОАО СеверСталь; 25.2.04

6ES5541-8AA11

SIMATIC S5, КОММУНИКАЦИОННЫЙ ПРОЦЕССОР CP 541, ИНТЕРФЕЙС L2 ДЛЯ ПОДКЛЮЧЕНИЯ SIMATIC S5 К ПРОГРАММАТОРУ
цена 752 евро за бугром.

практически снят с производства. Sinec L2 - это прародитель Profibus.
Документация есть вот здесь http://www4.ad.siemens.de/WW/news/en/1456021
<


text

Ошибка при диагностике связи MPI
Константин ; 24.2.04

При диагностике связи через CP5613 вываливается следующее сообщение:

System error: device not available.
(53275).
ОС win2k SP4.
Кто нибудь встречался с подобным?<


text

Ключ для CP341
Константин ; 20.2.04

Подскажите для каждого загружаемого драйвера используются разные аппаратные ключи или один и тот же.

Имеется в виду драйвера modbus slave и master для RS485
<


text

Кто работает в проектах с IEC FC
Дертунов Борис; 18.2.04

Стал прописывать диагностику контроллера и получил такой баг: в FC8(DT to TOD) STEP7 v5.2 RETVAL - INT, вместо TOD. Кто сталкивался: что делать? Или самому писать?

Re: Кто работает в проектах с IEC FC
Дмитрий; 18.2.04

Попробовал вставить как писали у меня все нормально

RET_VAL (TIME_OF_DAY)
STEP7 v5.2 попробуйте повторить.<


text

Non-Simatic PLC как DP-мастер в STEP7 Hardware Config
asv; 17.2.04

Необходимо связать по профибасу несименовский контроллер, в котором установлена карта SST 5136-PFB, выступающая как DP-мастер, с SIMATIC PC Station с карточкой CP5611, работающей как DP Slave. Проблема в том, что для того, чтобы сконфигурировать входные и выходные области PC-станции в Hardware Config в STEP7 необходимо наличие DP Master System (к ней можно прицепить компонент PC Station as DP Slave, в который уже можно накидать универсальных модулей). Что делать в случае non-SIMATIC контроллера, непонятно... Конфигурирование в STEP7 необходимо для получения xdb-файла, который можно было бы загрузить в Station Configuration Editor...

Re: Non-Simatic PLC как DP-мастер в STEP7 Hardware Config
Михайлин Сергей; 17.2.04

Чужой DP мастер вставить в СТЕП невозможно и проектировать его надо в своем собсnтвенном софте, то бишь в софте для карты SST, а потом подсоединять в него файлы для слейва, который будет формироваться в СТЕПе.

СР5611 как DP слейв в СТЕПе необязательно тянуть к мастеру, нужно просто его описать. А вот как описать его для мастера, это как раз задача софта для карты SST.
Может проще сделать мастером СР5611? Тогда все проще решается.
Re: Non-Simatic PLC как DP-мастер в STEP7 Hardware Config
asv; 17.2.04

В этой системе контроллер должен быть мастером (к нему помимо PC цепляются другие DP-слейвы).

1. Просто описать CP5611 как слейв... В этом случае непонятно, как конфигурировать области входов и выходов (это ведь делается в конфигурации мастера). А если их не сконфигурировать, то не будет работать OPC-сервер, через который идет обращение к CP5611 (метод AddItem будет возвращать ошибку)...
2. Если CP5611 выставить как мастер, как организовать обмен с контроллером, который тоже будет работать как мастер?
Через DP/DP Coupler? Как в этом случае сконфигурировать входа и выхода?
Re: Non-Simatic PLC как DP-мастер в STEP7 Hardware Config
Михайлин Сергей; 17.2.04

Адреса не прописываются в мастере они там перенимаются. Сколько слейв может передать и приянть столько и будет в конфигурации мастера.

Т. е. сколько Вы опишите в конфигураци СР5611 входов-выходов, столько потом в конфигурации мастера и надо будет восстановить.
Хотя конфигурация очень непонятная. Причем здесь ОРС интерфейс, если обмен налаживатеся по PROFIBUS-DP и оба устройсва его поддерживают, не понимаю.
Re: Non-Simatic PLC как DP-мастер в STEP7 Hardware Config
asv; 17.2.04

Входы и выходы описываются не в конфигурации CP5611.

Если открыть в HW Config PC-станцию с картой CP5611, там просто нет никакого виртуального рэка, в который можно было бы вставить т.н. универсальные модули.

А вот если открыть там конфигурацию, например, станции SIMATIC 400, подключить dp master system, повесить на нее объект PC Station as DP Slave (находится в каталоге здесь: PROFIBUS DP -> Configured Station), и ткнуться мышкой в этот объект, внизу появится этот самый виртуальный рэк.

Беда в том, что у нас не SIMATIC 400... И даже не 300...

С OPC проблема такая: OPC сервер не будет работать правильно, если не загрузить в станцию правильную конфигурацию (xdb-файл). Он попросту не будет видеть входов и выходов, которые не сконфигурированы.

Или я все-таки где-то не прав?
Re: Non-Simatic PLC как DP-мастер в STEP7 Hardware Config
asv; 17.2.04

Пробовал импортировать в STEP GSD-файл для карты SST 5136-PFB-VME, но STEP не позволяет импортировать мастера, только слейва

Re: Non-Simatic PLC как DP-мастер в STEP7 Hardware Config
asv; 17.2.04

В-общем, проблема в том, что мне нужен xdb-файл, чтобы работать через OPC c CP5611. Этот файл делает только STEP7. А в нем DP-мастером можно установить только сименовское железо.

Re: Non-Simatic PLC как DP-мастер в STEP7 Hardware Config
MooR; 18.2.04

Что то я тоже не понял про ОРС. Если есть два устройства работающие на профибасе, то зачем ОРС нужен? Вопрос не в том как его сконфигурировать, а для чего он нужен в принципе? Может Вы более развернуто опишите задачу?

Re: Non-Simatic PLC как DP-мастер в STEP7 Hardware Config
asv; 18.2.04

PC-станция с CP5611 подключается к профибасу как слейв и изображает из себя некую периферию со входами и выходами. На этом компьютере запускается некоторая программа (в данном случае это WinCC, но это не имеет принципиального значения), которая записывает входы контроллера и читает его выходы. Если еще конкретней программа эта имитирует пульты.

Доступ этой программы к профибасу осуществляется посредством OPC-сервера: в WinCC заводится канал типа OPC. В канале заводятся теги, имеющие адрес типа DP:[CP 5611]Slave_IX0.3,1.
Для того, чтобы WinCC могла обращаться к этим тегам через OPC-сервер, OPC-сервер должен быть правильно сконфигурирован. Конфигурация загружается посредством xdb-файла, который создается в STEP7.
В том случае, когда все компоненты, висящие на профибасе - SIMATIC, все просто: в HW Config и Netpro конфигурируется мастер и слейв, в слейве конфигурируются универсальные модули (входные и выходные), все компилируется, STEP создает xdb-файл, который загружается в станцию (в Station Configuration Editor есть такая кнопка - Import xdb).
Если конфигурация в станцию не загружена или эта конфигурации неправильная, доступа к тегам через OPC-сервер работать не будет (для WinCC это выражается в том, сообщается о невозможности добавления тегов в OPC-сервер - это можно увидеть в Channel Diagnostic).
Если нужно еще подробней, я могу рассказать. Проблема серьезная, и что с ней делать, я понятия не имею.

Re: Non-Simatic PLC как DP-мастер в STEP7 Hardware Config
asv; 18.2.04

Кстати, для случая, когда DM-мастером является SIMATIC S7, процесс конфигурирования описан в этой статье:

http://www4.ad.siemens.de/-snm-0135041160-1076665660-0000020068-0000000040-1076946673-enm-WW/skm/newSKM/frameset.asp?markerurl=%2FWW%2Fllisapi%2Edll%3Ffunc%3Dll%26objID%3D16650883%26objaction%3Dcsview%26lang%3Den%26siteid%3Dcseus&showoptions=false&lang=en&searchID=266391769&firstload=no&siteid=cseus&query=DP+Master&hitsPerSite=10&Next.x=4&Next.y=5&cur_pos=10

Re: Non-Simatic PLC как DP-мастер в STEP7 Hardware Config
asv; 18.2.04

Более короткая ссылка:

http://www4.ad.siemens.de/-snm-0135041160-1077029867-0000003673-0000000684-1077099943-enm-WW/llisapi.dll/16650883?func=ll&objId=16650883&objAction=csView&lang=en&siteid=cseus&aktprim=0<


text

Стандартный FB 40 в S5 и S7
Березин; 11.2.04

Не могу найти какому блоку отвечает стандартный FB 40 из S5 (PLC 135U) в S7 (PLC 400)

Заранее благодарен за помощь
Re: Стандартный FB 40 в S5 и S7
Baby; 11.2.04

Hallo !

В смысле "какому блоку отвечает стандартный FB 40 " ????
Re: Стандартный FB 40 в S5 и S7
GorA; 13.2.04

В базовых функциях S5 - 135 FB40 нет.

Re: Стандартный FB 40 в S5 и S7
Чистяков Дмитрий ОАО СеверСталь; 17.2.04

Скорее всего это или переименованый стандартный блок (напишите его абривиатуру) или чейто самопальный закрытый.


text

hart
shurik; 16.2.04

подскажите пожалуйста как считать с аналогового HART модуля измеренное значение - каким блоком,или библиотекой PCS7 или как ???????

Re: hart
Михайлин Сергей; 16.2.04

Первичную переменную датчик передает непосредственно через 4..20мА Все остальное надо брать через HART команды. Формируется запрос через SFC58 и получается ответ через SFC59. Шаблон запросов и ответов есть в доке на Ех модули. Готового блока от Германии нет, я пишу свой, с хелпом и тд, к июню обещаю закончить и выложить в свободное пользование. Подробности в мыло.


text

ГосГорТехНадзор и LOGO
Lexman; 14.2.04

Есть ли разрешение ГосГорТехНадзора на применение контроллеров LOGO на газоиспользующем оборудовании?

Встречал комплектные горелки с этими устройствами, но мне нужна бумажка.
Re: ГосГорТехНадзор и LOGO
Дмитрий; 16.2.04

Нет разрешения. И говорят не будет. Все остальные контроллеры разрешение ГосГорТехнадзора получили.


text

SFC1 - чтение времени
Oльштейн Эдуард ; 5.2.04

Параметрирую в программе вызов SFC

CALL "READ_CLK"
RET_VAL:=MW156
CDT :=P#DB36.DBX44.0

Cроку P#DB36.DBX44.0 STEP7 не принимает, она краснеет.
По этому указателю в DB36 действительно прописана строка с типом DATE_TIME.
Что нужно написать в этой строке, так понять и не смог.
Может быть где-то надо отдельно как-то обявить тип данных DATE_TIME.

Помогите вызвать SFC1
Заранее благодарен за помощь.

Re: SFC1 - чтение времени
Михаил Ивлев; 6.2.04

попробуй вот так:

CALL "READ_CLK"
RET_VAL:=MW156
CDT :="Array".Time_Begin
где "Array" это соответсвенно название DB, Time_Begin - имя перемнной DATE_AND_TIME в DB
Re: SFC1 - чтение времени
GorA; 10.2.04

Можно сделать следующее:

В локальных данных создать переменную типа DATE_TIME и при вызове SFC1 указать в CDT ссылку на созданную локальную переменную. А затем делать с полученным временем-датой что-угодно.<


text

Защитное шунтирование выходов S7-200 в случае переменного тока
Юрий Оганесян; 28.1.04

Имеются ввиду выходные полупроводниковые модули при использовании их на ~220В (нагрузка с индуктивной составляющей, например, катушка пускателя).

Ситуация след: в старом руководстве на русском языке (21х) рекомендуется шунтировать выход модуля RC-цепочкой и варистором. И в этом же руководстве на рисунке подключения модуля EM222 нарисовано, будто RC-цепочка и варистор у него уже встроены. Парадокс.
В новом руководстве (22х) на английском языке RC-цепочкой и варистором шунтируется уже сама индуктивная нагрузка. А в этом руководстве на рисунке подключения модуля, нарисовано, будто у него внутри только RC-цепочка без варистора.
Господа, у кого есть в наличии модуль 6ES7222-1EF22-0XA0 !! Разберите его, плиз, посмотрите, есть ли у него на выходе варистор? А если нет, то лучше бы все-таки варистором сам модуль шунтировать, а не индуктивность? Я правильно понимаю?

Re: Защитное шунтирование выходов S7-200 в случае переменного тока
Юрий Оганесян; 9.2.04

Ну, что? совсем никто? и никак?


text

Не писал ли никто ModBus master для S7-22x
Olzhan; 8.1.04

226 по одному порту должен опрашивать по МодБасу несколько других контроллеров а по другому отправлять на ВинСиСи.

Re: Не писал ли никто ModBus master для S7-22x
Влад Коваленко; 6.2.04

Я писал, но только клиент.

См. Tips&Tricks #41 Modbus RTU Slave для S7-214<


text

one-to many
Astronom; 16.12.03

Пробовал ли кто - коммуникационные связи Master-Slave при перекрестной связи.

Т.е. шоб было в сети DP более одно мастера и шоб усе всех видели
Какое железо это потдерживает?

Re: one-to many
drt; 16.12.03

Нужна спецовая харддверная примочка. Называется она DP-Copler (Короче как то так)

Re: one-to many
astronom; 16.12.03

Да, не...

Koppler связывает две сети DP, но не позволяет видеть слейвов
не то)
Re: one-to many
Unity; 8.1.04

Открываем Simatic Manager -> Help -> Contents -> Configuring the Hardware -> Config the Distributed I/O -> Config with Two DP Master Sysytems и все всех видят. Good Luck!!!

Re: one-to many
Astronom; 8.1.04

Дак, я и написал после прочтения сего)))

я ведь написал - пробывал ли кто...
читать хелп мы умеем, реализовывать о де загвоздка:)
Re: one-to many
михаил; 5.2.04

При конфигурировании слэйвов, выбирается не m-s a directX связь и тогда можно выбрать из выпадающего меню те слэйвы, которые могут это делать, например ЕТ200М, но не ЕТ200B и так далее, указав области обмена, можно с них читать входные данные чужих слэйвов.

Re: one-to many
Astronom; 5.2.04

Спасибо всё понял


text

А что в новые 6ES7 315-2AG10 процессоры буферная батарея не нужна?
Nec; 4.2.04

Cмотрим каталог - не находим. И блок питания теперь встроенный?

С уважением, Алексей.
Re: А что в новые 6ES7 315-2AG10 процессоры буферная батарея не нужна?
Роман Абзаев; 4.2.04

Не нужна. ID 13406642 :)

Re: А что в новые 6ES7 315-2AG10 процессоры буферная батарея не нужна?
Nec; 5.2.04

Спасибо за ответ.

С уважением, Алексей.<


text

PG 675
Анатолий; 26.3.03

Помогите разобраться с этим зверем.

Нужна документация и штатные дискеты.
Re: PG 675
Иванов Сергей; 26.3.03

Дискеты у нас сохранились. Но их давно никто не смотрел - наверное осыпались от старости. Есть также PG685(старший брат). Но IMHO самый лучший вариант - купить софт под персоналку и не будет проблем(если у Вас только не 150-я серия). Если есть вопросы - мыльте.

Re: PG 675
Андрей; 26.3.03

Кой чего сохранилось. Даже с некоторыми играться приходиться. А по поводу отсутствия проблем вопрос спорный.

1. проблема на физическом уровне --- необходим преобразователь интерфейса RS232 <--> 20mA токовая петля и кабели.
2. На програмном для параметризации интелектуальных модулей. А не голым STEP-ом 5-ть.
3.Проблемы не только со 150-ой серией, а везде где применяется плата AS 511 для связи с PG <->PLC. см.п.1.
Хотя согласен, что много достоинств в персоналке.
Re: PG 675
Александр А. 12.04.03; 12.4.03

Есть такой "зверь"(даже работает), руководство пользователя, но как скачать на 5 дюймовые дискеты в РС.

Есть комплект дискет
VK; 15.4.03

В своё время сделал несколько копий дискет для этого аппарата. Могу переслать, вопрос - как? Есть даже руководство пользователя в переплёте.

Re: PG 675
Serge_n; 5.1.04

Пиши на мыло. Есть рабочие программы на STEP 5 и GRAPH 5 для PG675.

Re: PG 675
Serge_n; 10.1.04

А вот есть ли у кого-нибудь S5-DOS для PG675 ?

Без этого не могу работать с EPROMами 64кБ.
Re: PG 675
/; 4.2.04

Его и не было никогда, только начиная с ПГ685


text

Микросхемы SPC3
LV; 4.2.04

Кто-нибудь работал с контроллером Profibus SPC3?


text

EPROM & notebook
Sir; 30.1.04

подскажите, какими средствами с ноутбука программировать EPROM,

при условии, что спектр контроллеров довольно широк - Siemens S5,S7,
Allen-Bradley, Schleiher (если не ошибаюсь) и проч. В частности
интересует, можно ли обойтись одним программатором EPROM, какой
нужен софт и т.п.
Re: EPROM & notebook
Михайлин Сергей; 30.1.04

Я думаю такое невозможно! У каждой фирмы, во-первых, свои форматы карт памяти, во-вторых, свои форматы записываемых данных, и эти форматы как правило закрыты. Поэтому одного устройства и одного софта не хватит.

Re: EPROM & notebook
Sir; 30.1.04

софт можно и специализированный использовать, разумеется. Суть в том, чтобы обойтись минимальным количеством "ноубуков" и программаторов EPROM.

Re: EPROM & notebook
Vadim; 2.2.04

Nu,dlya Siemens suschestvuet PROMMER kotoriy goditsya dlya S-5 i dlya S-7(esli zahochesh zavtra posmotryu katalogoviy nomer).A dlya ostal'nogo chto-to svoe konechno imeetsya

Re: EPROM & notebook
Sir; 3.2.04

спасибо, на данный момент не актально.


text

Скольжение и Simatic
Юрий; 1.2.04

Может кто сталкивался с подобной проблеммой: с помощью станции S-400 в состав которой входит FM-450 (счетчик импульсов) необходимо оценить скольжение ленты на обычном ленточном конвейере (т.е. имеются импульсные датчики на барабане привода в конце ленты и надо оценить скольжение , т.е. постоянной расхождение между скоростями вращения ведущего и ведомого барабанов, возникающее из-за проскальзывания ленты. )


text

Не грузится программа в новый 315DP
Eugene Sergeev; 14.1.04

Добрый день!

Дело срочное, надеюсь кто-нибудь поможет.
Не могу загрузить программу в 315-2DP,
который 315-2AG10-0AB0. ММС карта воткнута, память я успешно стер, но при попытке загрузится Степ7 5.2 не видит процессора. Что еще нужно делать?
Грузиться пытаюсь по MPI.

Re: Не грузится программа в новый 315DP
Назаров Дмитрий; 15.1.04

А как вы стерли память, если процессора не видите? Если Степ не "видит" CPU то надо смотреть правильно ли настроен MPI. Когда грузитесь с помощью адаптера PC/MPI то чаще всего неправильно указана скорость.

Re: Не грузится программа в новый 315DP
VVV; 15.1.04

Вообще нет контроллера, если Доступные узлы в Степе нажать? Если так, то скорее всего неправильно адаптер настроен.

Может просто у вас карта не пустая, он с нее подхватил конфигурацию, а там адрес у контроллера другой.
Re: Не грузится программа в новый 315DP
Чистяков Дмитрий ОАО СеверСталь; 15.1.04

Или наоборот -такой же адрес. ;-)

Re: Не грузится программа в новый 315DP
DEE; 16.1.04

Hi!

В Степе в PG/PC Interface какой тип интерфейса стоит? Может вовсе и не MPI?
Re: Не грузится программа в новый 315DP
Eugene Sergeev; 28.1.04

Проблема решилась переключением режима 5511 с MPI на авто. Почему - не знаю...

Re: Не грузится программа в новый 315DP
Чистяков Дмитрий ОАО СеверСталь; 29.1.04

Потому, что в контроллере интерфейс был назначен, как PROFIBUS. :-)

Re: Не грузится программа в новый 315DP
Eugene Sergeev; 29.1.04

С каких пор по умолчанию загрузочный интерфейс стоит в Профибас? При всем при этом в поиске доступных устройств при загрузке программатор увидел контроллер как MPI усторйство с адресом 2 еще ДО загрузки хардверной конфигурации.


text

Память для нового контроллера 315-2DP
Стас; 27.1.04

В каталоге обнаружил на новый контроллер память NFlash 6ES7953-8LF00-0AA0. Кто-нибудь пояснит мне, что это за память и подойдет ли она для этого контроллера 6ES7315-2AG10-0AB0?

Re: Память для нового контроллера 315-2DP
Назаров Дмитрий; 28.1.04

Не подойдет, нужна 6ES7953-8GL00-0AA0 на 128 кбайт. Что это за память долго рассказывать, но внешен похожа на ММС карточки для фотоаппаратов. Карты фотоаппаратов для контроллера на ПОДХОДЯТ!


text

PG740
Вадим; 28.1.04

Куплю TFT панель для программатора PG740,б/у или аналог.


text

Загрузка конфигурации
DEE; 27.1.04

Hi!

Вот один чайниковский вопрос: допустим есть у нас конфигурация контроллера, прописанная в HWConfig, и есть конфигурация сети, прорисованная в NCM. Так вот, если мы делаем Download из HWConfig в контроллер, значит ли, что конфигурация в NCM при этом тоже загружается? И наоборот, если мы делаем Download из NCM, грузится ли при этом конфигурация из HWConfig автоматически? Я, например, делаю всё последовательно: сначала гружу конфигурацию из HWConfig, затем из NCM, ну а потом программные блоки. Правильно ли это? Может одна из двух операций лишняя? :-)
Re: Загрузка конфигурации
Baby; 27.1.04

Привет !!!!

Сделали конфигурацию в HW.
Затем NCM, и сохранили в NCM или с компиляцией или просто.
А затем всё -> PLC.....
Re: Загрузка конфигурации
DEE; 27.1.04

Hi!

Ну так ещё раз,последовательность действий какова?
1. Создали конфигурацию в HWConfig, затем её сохранили+скомпилировали, так? Download делать не обязательно?
2. Прорисовали сетевые дела. Сохранили+скомпилировали+Download? При этом и скомпилированная конфигурация в HWConfig загрузится вместе с конфигурацией сети в NCM?
Re: Загрузка конфигурации
Baby; 27.1.04

Привет !!!

Нет, я имел ввиду , А затем всё -> PLC......, что всё и блоки программы, и
SDB загружаются в PLC.
Итак....
1. Создали конфигурацию в HWConfig, затем её сохранили+скомпилировали, так? Download делать не обязательно?
’Если загрузка впервые этого проекта в PLC , то лучше сделать Download ’
2. Прорисовали сетевые дела. Сохранили+скомпилировали+Download->
SDB и остальную программу.......
Re: Загрузка конфигурации
DEE; 28.1.04

Hi!

Ну, ладно, вроде я так всё и делаю.
ЗЫ: Во прикол, вот так вот проектируешь, проектируешь на этой технике, вроде не одну систему уж запустили, всё работает, а потом вдруг задаёшь себе элементарные вопросы и удивляешься :-)<


text

Очистка памяти нового 315-2DP
DEE; 27.1.04

Hi!

Господа, подскажите плиз, если производить очистку памяти нового CPU (315-2DP, который с ММС)обычной последовательностью действий, ну теперь через тумблер на CPU RUN-STOP-MRES, при этом стираются данные из ММС или нет? А если нет, то как очистить ММС? Или её только перезаписывать можно новыми данными?
Re: Очистка памяти нового 315-2DP
Роман Абзаев; 27.1.04

ID 10095508 и ID 13008499 на Customer Support

Re: Очистка памяти нового 315-2DP
Дмитрий; 27.1.04

см. также "Общий сброс S7-300 новой серии" за 21.05.03 в этой категории.

Re: Очистка памяти нового 315-2DP
DEE; 27.1.04

Господа, спасибо...


text

Илья
S7-200 кол. вх/вых.; 26.1.04

Подскажите пожалуйста, какое ограничение на количество внешних модулей и точек ввода/вывода имеет S7-200 (226XM)

Re: Илья
Худяков Александр; 26.1.04

Если внимательно посмотреть в каталоге то там написано что 226(XM) имеет возможность подключения до 7 модулей расширения и максимальное кол вх/вых 128DI+ 120DO; 28(0)AI + 7(14)AO


text

Объясните популярно - что такое PCS7?
LVV; 2.12.03

Чем этот пакет отличается от применения STEP7 и WinCC как отдельные пакеты? Что дает применение PCS7? Кому-нибудь из Вас стало удобнее работать от того, что такой пакет у Вас появился? Кто-нибудь может сказать что конкретно полезного можно извлечь от применения пакета PCS7? Я прочитал документацию тут же на сайте - только одни общие слова, одна вода! Можно объяснить коротко и ясно - что это такое?

Re: Объясните популярно - что такое PCS7?
DRON; 8.12.03

Коротко и ясно... это врятли !:)

Могу сказать,что работа с большими проектами на 400 контроллерах (другие просто не поддерживаются!) намного проще в PCS7, чем в голом STEP7. Единственно, что использовать стандартные блоки, не удобно! преходиться свои делать.

Re: Объясните популярно - что такое PCS7?
Дмитрий В.; 9.12.03

Из своего опыта могут сказать, что на PCS7 удобно делать комплексные проекты, например, металлургия (установка "ковш-печь", МНЛЗ, станы холодной и горячей прокатки), химия (производство глицерина), где имеется большое количество аналоговых и дискретных датчиков, вентилей, приводов, технологических контуров регулирования и управления. Например, для производства глицерина было: 30 насосов, 150 вентилей, 300 дискретных и аналоговых датчиков, реализация автоматического управления путями перекачки + технологическое регулирование (давление, тем-ра, уровень, уровень кислотности рН). Есть стандартные библиотеки PCS7, содержащие стандартные блоки: вентиль, привод, место измерения аналогового сигнала, дискретного сигнала, блок ПИД-регулятора. Названные блоки помимо логики содержат интерфейс визуализации и выдачи сообщений (так называемый faceplate). Также имеются блоки диагностики аппаратной части SIMATIC. Параметризация блоков происходит в графическом редакторе СFC (не в WinCC, передача данных туда запускается через Simatic Manager, он сам все делает в WinCC, а пользователь отдыхает).

Теперь представьте, что все это Вы делаете вручную на STEP7 и WinCC и Вам станет понятен объем работы. Так что PCS7 - это автоматизация проектирования.
Re: Объясните популярно - что такое PCS7?
Илья; 6.1.04

Это ОЧЕНЬ дорогая и ОЧЕНЬ удобная вещь,благодаря которой сроки разработки проекта сокращаются прямо пропорционально денежкам, выложенным за PCS7 (есть базовый комплект, а есть куча примочек к нему). А, вообще, это программно-аппаратный комплекс.

Re: Объясните популярно - что такое PCS7?
Сергей; 23.1.04

Вопрос по ПО для PCS7.

На предприятии используется централизованная АСУ Honeywell TDC 3000, все программирование на ней сводится к настройке и связыванию точек(аналоговый вход, ПИД, логическая, цифровой выход, и т.д). Т.е. в табличке забивается сколько точек какого типа нужно, затем каждой точке дается имя, размерность, ав.уставки, откуда брать данные и куда передовать, коэффициеты и пр. Я так понял, что в PCS7 существует нечто подобное, или все таки требуется программировать?
Встает вопрос об автоматизации оставшейся части производства (примерно 1000точек в/в) и соответственно нужно выбрать АСУ. PCS7 устраивает по цене, но насколько сложно будет ее строить?
P.S. Кстати по-чемуто никто не отвечает на мои письма в службу поддержки Support@AuD.ru
Re: Объясните популярно - что такое PCS7?
Михайлин Сергей; 26.1.04

Примерно так, но немного не так!

Программировать конечно не надо на низком уровне. Это можно назвать проектированием. Drag-n-drop притягиваешь блоки в форму, соединяешь как тебе надо и вперед. Система получается намного гибке чем по принципу "заполни бланк". Потому как можно задать любую структуру логики управления. И сама программа получается очень наглядна и скорость проектирования высока и ошибок практически нет. Если что требуется подробнее, пишите на мыло.
Re: Объясните популярно - что такое PCS7?
Михайлин Сегей; 26.1.04

2 Сергей

По поводу вашего письма на suport оно у меня в обработке и есть вопросы. Позвоните мне по возможности
(095)737-24-31<


text

очистка памяти S7-200
SLM; 23.1.04

Подскажите, как можно очистить память у CPU-226, не через MicroWin?


text

S7-224 и S7-315 по MPI- протоколу?
Olzhan; 17.1.04

Треба соединить 200 и 300 по МПИ. Знаю делаетсяна 300 с помощью X_GET, X_PUT но что окромя этого должно быть на 300 и что на 200???

Пожалуйста кто знает подмогните, подскажите!!!!
Re: S7-224 и S7-315 по MPI- протоколу?
Симахин Александр; 19.1.04

В блоке данных S7-200 нужно выложить нужные данные для обмена. Командами X_PUT (записать в S7-200) и X_GET (читать из S7-200) можно считывать и записывать переменные в блок данных S7-200 указав блок данных 1 (или 0 точно не помню) и адрес ячейки в нем (естественно команды X_PUT, X_GET вызываются из S7-300).

Re: S7-224 и S7-315 по MPI- протоколу?
olzhan; 21.1.04

Как создать блок данных в 200, то что есть ведь просто пишу к примеру VB100 112! Где разместятся полученные данные в 200? Что указывать в Х_РUТ в полях SD, Var_ADDR и остальных? Какой МПИ адресс 200-такой же как в СистемБлок?

Вожусь не могу разобраться подмогните плизз!!!
Re: S7-224 и S7-315 по MPI- протоколу?
kot; 21.1.04

В 200 есть только один DB1, поэтому

пишеш все в 300. Поэтому пишеш примерно так- P#db1.dbx50.0 byte 50 если хочешь
прочитать или записать 50 байт.<


text

S5-115U CPU943 i OP E-700 Mitsubishi
Vlad; 21.1.04

Nugna konsultazija!!

K S5 podkluhay E-700 panel operatora ot
Mitsubishi herez AS-511
Vopros : nado li v PLC pisat kakoi libo kod dlja svjazi s panelju?
esli da to gde mogno posmotret primer?
Spasibo<


text

ищу МЭО
виталий; 20.1.04

Ищу МЭО производства Сименс


text

S7-200 и PID
Денис; 14.1.04

Подскажите кто-нибудь как преобразовать аналоговый сигнал стандартного ПИД-регулятора в импульсные в контроллере S7-226

Re: S7-200 и PID
Симахин Александр; 19.1.04

В Step7MicroWin специальный программный инструмент. В меню Tools нажмите на Instruction Wizard и в открывшемся окне выбирете PID и далее следуйте инструкциям wizard. Там можно выбрать аналоговый или дискретный выход PID-регулятора.

Re: S7-200 и PID
Денис; 19.1.04

В Step7MicroWin дискретный выход регулятора либо "1" или "0" мне неоходимо управлять МЭО где есть входы "больше" и "меньше". Если привязать выход регулятора к МЭО получается или полностью открыть или полностью "закрыть". Необходим импульсный выход. Подскажите пожалуйста как это сделать. Заранее спасибо.

Re: S7-200 и PID
Alex; 19.1.04

Попробуй крутануться: Дискретный выход перенаправь через простой единичный вход, свяжи его с перезапускающимся таймером, а лучше с двумя,- на канал и двумя единичными выходами - на МЭО. Есть вариант, что при 1 и 0 включаться разные выходы, а время таймера будет влиять подобно коэффициенту усиления в регуляторе и вылезет через обратную связь.

Успехов.
Re: S7-200 и PID
Денис; 19.1.04

Спасибо попробую!

Re: S7-200 и PID
Олег; 20.1.04

Вообще, это ШИМ-регулирование. Обычно реализуется так. Имеется время перехода механизма от закрытого в открытое положение. И минимальное время включения двигателя. Соответственно, в зависимости от выхода регулятора, можно рассчитать время, на которое необходимо включить двигатель. Двигатель должен включаться с периодом ШИМ (время закр-откр). Теперь, как реализовать два выхода. Обычно в СУ блок ПИД может выдавать значения от -100 до +100. Переход через 0 - это признак реверсирования выхода. Если этого нет, т.е. выход от 0 до 100%, то в качестве реверса можно использовать выход регулятора 50%. И еще, необходимо проверять на каждом цикле условие, произошла ли смена знака ошибки переменной процесса. Если да, то необходимо отключать выход. Хотя это можно достичь и настройками регулятора. Вообще, так реализовано в локальных регуяторах Сименс.


text

MPI адаптер и S7-200
Anton; 19.1.04

Добрый день!

Просьба ответиь - возможно ли программирование S7-200 через MPI адаптер?
Re: MPI адаптер и S7-200
Симахин Александр; 20.1.04

Нет, нельзя.

Re: MPI адаптер и S7-200
RIG; 20.1.04

222 можно


text

S5 Замена 6ES5244-3AA22 на 6ES5244-3AB31???
Дмитрий; 20.1.04

Как заменить 6ES5244-3AA22 на 6ES5244-3AB31 процессор SIMATIC S5 115U CPU944?

Хоть что-нибудь подскажите!
Может кто знает где найти в файле основной программы Е.....S5d сообщение "Message 16" или где прописывается номер этого блока, если он вообще в этом файле прописывается? <


text

время цикла в S7-200
Дмитрий; 13.1.04

Каково максимальное время в S7-200 от поступления входного сигнала до выдачи воздействия на выход

Re: время цикла в S7-200
проро; 13.1.04

Оно ведь зависит от программы...

Re: время цикла в S7-200
Дмитрий; 14.1.04

Это понятно, но как время реакции системы расчитывается?

А если использовать прерывания?
Re: время цикла в S7-200
проро; 14.1.04

Максимальный цикл ОВ1+ прерывания, если будут...А вообще лучше попробовать, дописать в конце ОВ1 феньку, что бы каждый раз инвертировать выход и померять осциллографом.

Я скажу, мы пробовали на 314 контроллере, и при минимальной загруженности получилась 1 миллисекунда.
Re: время цикла в S7-200
Astronom; 14.1.04

Вообще в доках есть как считать время реакции контроллера.

Сходу доку не помню.
Re: время цикла в S7-200
Дмитрий; 14.1.04

В доках то есть, но не про двухсотые контроллеры.

Re: время цикла в S7-200
Astronom; 14.1.04

а... да да

подзабыл
Re: время цикла в S7-200
Юрий Оганесян; 15.1.04

см. в инструкции на S7-200 "Операции управления программой", "Сброс времени контроля". Там что-то такое сказано..

Re: время цикла в S7-200
Anton; 19.1.04

Время реакции - считается 1-3 секунды,

а реально брать не менее секунды
Re: время цикла в S7-200
Alex; 19.1.04

Два-четыре цикла сканирования, в любом случае - миллисекунды. А фактически - нужна фенька и осцилоскоп.

<


text

Возможно ли реализовать на S7-200 контроль и сохранение событий?
Sergey; 16.1.04

Прошу подсказать возможно ли осуществить на S7-200, контроль и сохранение событий с датой и временем. События по логическим входам контроллера, с возможностью дальнейшего просмотра или распечаткой. Какое оборудование для этого необходимо?

За ранее благодарен.

Re: Возможно ли реализовать на S7-200 контроль и сохранение событий?
Симахин Александр; 19.1.04

В общем конечно можно с помощью операций LIFO, FIFO или самим написать обработчик таблиц сообщений в S7-200 (такое детище видел лично, выдавалось всё на TD-200 построчно). Я бы посоветовал использовать панель ОР-7. В ней будут храниться сообщения с датой и временем прихода (программируется в ProTool довольно просто) не занимая памяти контроллера. И самое главное, что к ОР7 можно подключить принтер для распечатки этих сообщений (принтер должен быть с последовательным портом).


text

Аналоговые сигналы
Михаил; 16.1.04

Имеется контроллер S7 CPU314IFM 6ES7 314-5AE03-OABO v1.2(со встроенными аналоговыми входами/выходом).

Подключаю датчик температуры(4-20 мА)на PEW128.Пытаюсь с помощью блока FC105 SCALE CONVERT промасштабировать входной аналоговый сигнал(с целью получения реальной температуры на выходе из блока в формате REAL)В параметры блока HI_LIM и LO_LIM подставляю соответствующие значения границ измерения температуры датчика.
В результате на выходе из блока я еаблюдаю не температуру,а милиамперы выходящие с датчика!!(да и то в 10 раз больше)
Подскажите,какие блоки надо ипользовать для получения реальной температуры с датчика(неужели подбирать HI_LIM,LO_LIM в FC105?)
Где задавать диапазон токового сигнала датчика ?и диапазон сигнала напряжения?
Заранее благодарен.

Re: Аналоговые сигналы
Baby; 16.1.04

Привет !!!

Завтра вышлю программу ,
как у нас это сделано....
(как Вы делаете, правильно)...

Re: Аналоговые сигналы
aim; 18.1.04

Также следует учесть, что у CPU314IFM рабочий диаппазон аналогового входа при подключении токового сигнала 0-20мА :(

В связи с этим придется ещё и коррекцию вводить.<


text

SIMATIC ET200iS
Евгений; 14.1.04

Конкретно в данной системе меня интересует работа модуля аналогового входа с протоколом HART, разницы нет 2 или 4 проводное подключение.

Аналоговый сигнал есть, но вот HART сигнала нет. Подобный модуль есть в системе ЕТ200М, там работает. Может кто-то знает секреты, поделитесь.<


text

FM350-1
Константин; 13.1.04

Из документации на FM350-1 непонятно,

имеется ли гальваническая развязка
между счетным входом и S7-шиной.
Если нет,то что из оборудования SIEMENS
можно использовать,чтобы развязать датчик BERO и шину?<


text

Peripheral input can never be modified
Konstantin; 10.1.04

Как можно(или нужно) в PLCSIM эмулировать входные аналоговые сигналы

Re: Peripheral input can never be modified
Konstantin; 12.1.04

Кажется разобрался. Может кому будет интересно. Проблема решилась простой заменой в проекте процессора на другой. Оказывается в тех процессорах которые распознают подключенную перефирию автоматически данная процедура(эмуляция входных аналоговых сигналов, так называемых peripheral input) невозможна. Необходимо на время отладки заменить процессор на другой, и загрузить в него системные блоки.


text

PC+PC ADAPTER=Death Screen?
V; 6.1.04

Здравствуйте!

Такая вот проблема. Для связи с контроллерами использую ПиСи адаптер. Все было нормально, пока новый комп не купил, а там нет ком-порта. Купил переходник USB COM. На компе W2000.
Так вот проблема в следующем. При попытке обращения к адаптеру из Степа система либо наглухо виснет, либо вывыливается в голубой экран смерти...
С другими программами, общающимися с данным устройством (переходником) такой проблемы нет.
Может кто знает в чем дело?
Спасибо.
Re: PC+PC ADAPTER=Death Screen?
Дмитрий; 8.1.04

При покупке USB MPI адаптера СИМЕНС в комплект поставки входят драйвера. После их установки все работает. Как со сторонними переходниками не знаю.

Re: PC+PC ADAPTER=Death Screen?
V; 8.1.04

А тогда нет ли у кого этих дров? Может и к моему переходнику они подойдут?

Re: PC+PC ADAPTER=Death Screen?
Александр; 8.1.04

насколько я знаю (видел в работе)

проблема в переходнике , нужен полный переходник USB COM и всё должно работать (вроде в дешовых нет аппаратного UART )<


text

Отображение входов и активирование выходов
Игорь; 6.12.03

Если это возможно, как в Step7 увидеть входы и активировать выходы???

S7-300
Re: Отображение входов и активирование выходов
Мимо проходил; 7.12.03

Ну прочитай хотя бы что-то

Re: Отображение входов и активирование выходов
Игорь; 7.12.03

Уже в глазах от прочитанного рябит.

Как увидеть входа и выхода я нашел, а возможно ли выхода активировать или такая возможность отсутствует???
Re: Отображение входов и активирование выходов
Мимо проходил; 7.12.03

Теперь посмотри меню в редакторе

Re: Отображение входов и активирование выходов
Назаров Дмитрий; 8.12.03

Есть в STEP7 такие блоки VAT для отладки. Есть там кнопочки наблюдения, принудительного изменения. Пробуйте!

Re: Отображение входов и активирование выходов
Друг; 8.12.03

Если ты самостоятельно не можешь разобраться как активировать выходы, Step7 не для тебя. Не лезь ты в автоматизацию темное это дело.

Re: Отображение входов и активирование выходов
Игорь; 11.12.03

Дорогой ДРУГ читай повнимательнее. Я же не спрашивал тебя куда лезть. Если есть контролер, то его можно понасиловать, а если уже готовая работающая машина, то появляется вероятность ее испортить. Поэтому надо быть осторожным. ЗЛОЙ ТЫ ЧЕЛОВЕК.

Re: Отображение входов и активирование выходов
VVV; 15.12.03

Так, Игорь вы разобрались?

Re: Отображение входов и активирование выходов
Александр Скрябин; 18.12.03

Есть два способа.

1. Из меню PLC \ Monitor/Modify variables запускается Varible table, где прописываются интересующие Вас переменные, в том числе входы и выходы.
Если самому прописывать в лом см. п.2
2. В Hardware выделяется требуемый сигнальный модуль и либо из главного меню PLC \ Monitor/Modify либо из контекстного после нажатия правой кнопки мыши запускается форма Monitor/Modify.

Re: Отображение входов и активирование выходов
Игорь; 19.12.03

Я в принципе это все уже пробовал. Состояние я вижу, а вот включить физические аутпуты не получается, может потому что программа уже в контролере есть.

Re: Отображение входов и активирование выходов
В. Сорокин.; 19.12.03

Конечно чистит. Мы пишем, а логика программы переписывает. Если только поиграть надо для развития, то пробуйте на незадействованных по схеме. А если не работает и надо разобраться, то есть в меню "Option" - "Reference Data" - "Display", там все ссылки "что-куда входит", перепись всех сигналов (внешних и внутренних), есть OB FB FC DB. Берись, да разбирайся. А в чём надобность то всей этой затеи? Уточните.

Re: Отображение входов и активирование выходов
aim; 21.12.03

В контроллерах серии S7-300 управление выходами (режим FORCE) не предусмотрено.

Если очень надо :), можно устанаваливать выходные биты в конце ОВ1.

! ! ! ВНИМАНИЕ ! ! !
aim; 21.12.03

ЭКСПЕРЕМЕНТЫ НА ДЕЙСТВУЮЩЕМ ОБОРУДОВАНИИ ПРОВОДИТЬ НЕ РЕКОМЕНДУЕТСЯ !!!

P.S.
Меньше знаешь - спишь спокойно :)
Re: Отображение входов и активирование выходов
Игорь; 2.1.04

Надобность затеи в том, что надо было немного изменить программу. А для этого сначала надо разобраться что к чему. Всем большое спасибо. Вопрос закрыт.

Re: Отображение входов и активирование выходов
Опоздавший; 6.1.04

А я! Можно, я скажу?! А еще можно установить тригер на конец цикла и выставлять выхода циклически!


text

S5
Sinbad; 21.1.03

Есть 2 идентчных установки на S5-100.

В одной была стерта программа. Я снял оба CPU, установил на стенд и переписал прогу с одного на другой. При ВКЛ и переключении в RUN рабочий CPU переходит в STOP (т.к. сигнальные модули не подключены). В буфере ошибок ISTACK естественно появляеться ошибка PEU, т.к. CPU на стенде и сигнальные модули не поключены, но второй CPU, на который была переписана программа, при тех же условиях не выдает PEU, а выдает ошибку NINEU, т.е. неисправность программы, хотя программу я копировал один в один. Может я что-то упустил.
Буду признателен за любые советы.

ЗЫ. На установку CPU пока не устанавливал.
См. http://Sin-bad.narod.ru

Re: S5
Dima; 26.1.03

А зачем вообще было снимать CPU

Что нельзя было просто скачать с одного а потом записать на другой
Re: S5
Sinbad; 28.1.03

Потом так и сделал, все равно контроллер не пустился.

См. http://Sin-bad.narod.ru

Re: S5
Serge_n; 5.1.04

S5-100 имеет три (по моему) вида CPU

CPU100, CPU102, CPU103.
Может они у тебя все-таки разные ?
Re: S5
Sinbad; 5.1.04

Заказные номера одинаковые

Re: S5
Serge_n; 5.1.04

Так у тебя оба CPU точно одинаковые (прямо на CPU смотри)?

Какие именно ?
Re: S5
Serge_n; 5.1.04

Я однажды слепил программку, испытал на стенде, все было ОК.

Установил на оборудование, а она не пускается. Только потом обратил внимание что на стенде был CPU102, а на оборудовании CPU100.<


text

АДАПТЕР ДЛЯ ПРОГРАММИРОВАНИЯ МИКРОКАРТ (Siemens)
Alex Kulikov; 31.12.03

С Новым годом!

6ES7798-0BA00-0XA0
SIMATIC PG, АДАПТЕР ДЛЯ ПРОГРАММИРОВАНИЯ МИКРОКАРТ ПАМЯТИ (MMC) С ПРОГРАММАТОРОВ PG
720 И PG 740
А как будет обзываться адаптер для PC?
Он обязателен для S7 315-2DP (6ES7315-2AG10-0AB0) ?
Кто может дать ссылку на описание 315-2DP (6ES7315-2AG10-0AB0)?
У меня многие сайты Siemens не доступны без выключения AtGuard, что сильно затрудняет
поиск.
На старом диске нет, новый заказал, давно, но когда позвонил напомнить, сказали, что
рассылать будут только в конце декабря.
А когда получу, неизвестно.

Re: АДАПТЕР ДЛЯ ПРОГРАММИРОВАНИЯ МИКРОКАРТ (Siemens)
VVV; 5.1.04

Для 300 и 400 контроллеров он не нужен. Прошивать флеш-карты можно прямо с PG из степа.


text

desylab
dima; 16.12.04

что это за desylab такая? можно ли с ее помощи записать сигналы контроллера (s7,s5), если да, то насколько быстрые сигналы? что нужно для подключения к PLC? (дополнительные драйвера, спец. кабели?)

Re: desylab
kirill; 10.1.05

насколько знаю DesyLab способна считывать и записывать данные с ОРС сервера. насчет быстроты - видел раз в 0.5 сек (хотя не в связи с Siemens). осталось создать SIMATIC OPC Server как-нибудь


text

S7-200 Выходное значените PID-функции
Juri; 1.1.00

Подскажите мне, пожалуйста, как выходное значение PID-регулятора контроллеров S7-200 (параметр Output) может быть не только выходным по отношению к функции (это понятно), но и входным? Мне может понадобиться такая возможность. А то, что этот параметр может быть входным/выходным я взял из описания S7-200 Programmable Controller System Manual 6ES7298-8FA00-8BH0 стр 9-32, а также из On-line Help на Micro/Win

PID - конторллеры
Студент НГТУ Сергей; 13.10.01

Подскажите мне, пожалуйста, где найти HELP по

PID - конторллерам?

Re: S7-200 Выходное значените PID-функции
Алекс; 20.1.05

Посмотри текст PID, там полсотни строчек и перепиши, как тебе надо. Быстрее получится.


text

Связь с теплосчетчиком "Взлет-ТСР" по RS-232 с помощью CP-341. Проблемы...
Alien; 29.12.04

Доброе время суток!

Мне требуется связать вышеозначенный прибор с CPU по внутреннему протоколу "Взлет"а...
Проблема в том, что он ни в какую не хочет отзываться на команды, хотя стандартный софт (из поставки "Взлет"а) находит его на мах и свободно получает с него все данные.
Может быть у меня неправильное описание протокола?
Помогите, кто чем может!!!
Re: Связь с теплосчетчиком
Штыка Игорь; 29.12.04

1. Каким образом происходит связь с CPU?

2. Необходимо правильно сформировать строку запроса в зависмости от протокола прибора, например,
<команда>;<адрес прибора>;<контрольная сумма>;<CR> (ASCIll)
3. При ответе прибора данные должны записываться,например, в строковую перменную определенной длины в STRING [254]. Затем необходимо анализировать данную строку в программе, чтобы изъять данные.
4. Для вызова можно использовать программные блоки, которые идут в комплекте с СР или воспользоваться из стандартной библиотеки SFB60-посылка данных; SFB61-прием данных. Также вызов происходит по переднему фронту.

Re: Связь с теплосчетчиком
Alien; 29.12.04

Я использую CPU 414-2 DP к которому подключена по профибасу ET-200M, на борту которой находится CP 341 RS 232C c подключенным "Взлетом".

Про адрес прибора и строку запроса понятно, но КАК установить адрес прибора для RS-232??? Да, у него есть адрес RS-485, но как это влияет на мой случай?
Для связи пытаюсь использовать стандартные CP-шные функции P_SND_RK и P_RCV_RK. Фнкция передачи выдает ошибку "Партнер не готов к передаче" (DSR=OFF or CTS=OFF)...
В качестве приемного буфера использую DB со 100 байтами...
Re: Связь с теплосчетчиком
Штыка Игорь; 29.12.04

1.Адрес прибора должен задаваться через специальную программу конфигурации прибора (должна идти в комплекте), т.е. для каждого прибора Вы задается свой адрес

2. СР необходимо установить в центральную стойку (есть такая рекоммендация Siemens)иначе возникают определенные проблемы
3. При отсутствии такого программного пакета обратитесь к производителю прибора
Re: Связь с теплосчетчиком
Alien; 11.1.05

1. Программа в поставке есть, но она только для мониторинга 8(((

Кстати, я подключал "Взлет" непосредственно к ПК - все работает "на ура"...
2. Все бы хорошо, но в центральную стойку СР сунуть не удастся, т.к. она 400-тая.
3. Я уже тоже об этом думаю...


text

Симулятор
Saden; 29.9.04

Подскажите, есть ли что-нибудь похожее на программный отладчик/симулятор для S7-200. Можно ли где-нибудь найти описание формата mwp файла STEP 7-MicroWin? А то прогу написал, хочу посмотреть, а к железу доступа нет...

Re: Симулятор
MooR; 1.10.04

Есть такая программа. валяется тут:

http://personales.ya.com/canalPLC/

Re: Симулятор
Владитир; 20.1.05

Ребята, может кто "подобрал access key" к этому симулятору :-), дайте знать, плиз..