text

Программа S5W для S5-100U
Выблый Алексей; 9.3.99

Где можно найти англоязычную версию для сабжа.

Есть немецкая, жутко непонятная.
Какой разъем используется для программирования блока, похож на толстый Ethernet?
Re: Программа S5W для S5-100U
Гуленок; 10.3.99

Для программирования контролера S5-100U Сименс предлагает программный пакет STEP5. Он поставляется на пяти языках. Приобрести его можно у наших представителей в Москве или регионах.

Пакет S5W это продукт фирмы IBH. Он не поддерживает некоторые типы контролеров и не позволяет работать с COM пакетами. Сименс не занимается поддержкой и распостранением этого продукта и не отвечает за его функционирование.
Программирование контролеров семейства SIMATIC S5 осуществляется через TTY интерфейс. Распайка разъёма приведена в технической документации на контролер. Штатно этот интерфейс имеют только программаторы фирмы Сименс. Для программирования с помощью стандартного ПК необходим конвертор интерфейса V24->TTY
Re: Программа S5W для S5-100U
Теслер Слава; 23.3.99

Требуются обучающие программы

для программироьания технологических процессоь
на PLC SIEMENS S5-100 MICRO(РЕЛЕЙНО-КОНТАКТНОЕ
ПРОГРАММИРОВАНИЕ) на русском языке.
Re: Программа S5W для S5-100U
Гуленок А.; 30.3.99

В Москве проводятся курсы обучения по STEP 5. Можно организовать и выездное обучение. Мультимедийных обучалок по пятому степу как таковых нет, а уж тем более на русском языке.

Re: Программа S5W для S5-100U
Сасалин Валерий; 14.4.99

У нас в Кривом Роге есть системы Симатик и

S5W полная английская версия с GRAPH 5.
но с зашитой от копирования.
Я прошу Хакеров взломавших S5W связаться со мной.
Могу предложить ПО к контролерам Симатик S5.
Re: Программа S5W для S5-100U
Кабанов А.А.; 12.6.99

Уважаемый Mr. Гуленок А.

не могли бы подсказать мне, где можно найти схемы
для V24 -> TTY адаптера.
С уважением Кабанов А.

Преобразователь RS232->TTY
max; 5.8.99

Преобразователи продаются, например в ПроСофте (www.prosoft.ru), но

посмотрел я на цену (в среднем 100-150$), заскучал и слепил на картонке
этот преобразователь сам, вставил в компьютер и подключил к 12В inside.
Не очень эстетично, зато дешево (стоимость всех компонентов около 40 руб.)
и практично (за полгода не сломался и не сбоил). Пиши, если что...
ПО к контролерам Симатик S5.
demidovich konstantin; 12.9.00

можно ли переслать Simetic S5 через e-mail

Re: Программа S5W для S5-100U
aim; 8.12.00

если предложение в силе - просьба ответить на мыло.

Re: Преобразователь RS232->TTY
Ярослава; 18.12.00

Уважаемый Mr. Гуленок А.

может схему обнародуете...
Re: Программа S5W для S5-100U
Ярослава; 19.12.00

Данная программа используется мной уже дано

Разуметеся нет причин сомневаться в ее целостнсти.
Могу предложить обмен и взаимовыгодное сотрудничество. Интересует в частночти упомянутый Вами GRAPH.

С уважением.

Re: Преобразователь RS232->TTY
Кузьменко; 23.6.01

Используется стандартный преобразователь уравней RS232/TTY в связи мы лично вытащили преобразователь или нового телефона, а информацию надо искать у производителей микросхем


Распечатка программ в S5 на русском языке
Редников Василий; 19.10.99

Для подготовки листинга программ на русском языке установили STEP5 V6.65(6ES5894-0MA63-0UG5) на PG740PII.Однако S5 категорически отказывался выводить распечатку на русском языке, хотя все ваши рекомендации в информации о продукте были сделаны и даже больше.

Может что посоветуете?

И попутно:
STEP7/MicroWIN16 всю документацию печатает нормально,а STEP7/MicroWIN32 отказывается печатать по-русски. Как быть?
Re: Распечатка программ в S5 на русском языке
Виктор; 29.10.99

Напишите подробно.

Что вы делали?
Под какой ОС и как запускаете Step5?
Каким принтером пользуетесь?
Пишите на мыло, чем смогу помогу.

Re: Распечатка программ в S5 на русском языке
Иванов Павел (Сименс-Москва); 10.1.00

1. STEP 5

Русская версия пакета STEP 5 V6.6 и V7.12 поддерживают печать программ с русскими комментариями.
При этом вывод на печать возможен только на принтеры, аппаратно поддерживающие кирилицу
(в которых прошит знакогенератор кирилицы).

Поддерживаются принтеры со следующими знакогенераторами кирилицы:
- кодовая страница 866
(кодовая страница, используемая в MS-DOS)
принтеры, продающиеся в России с аппратной прошивкой кирилицы
- ECMA (ISO норма 8859-5)
(стандарт, распространенный в Европе, но не применяемый никем в России)
например, принтеры SIEMENS DR 23x-N
- и специальный принтер PT88-русский (это вообще очень старая нестандартная раскладка)

Можно выбрать следующие заранее сконфигурированные таблицы символов:
S5866KY.INI ( для кодовой страницы 866)
S5ECMAKY.INI ( для ECMA)
S5PT88KY.INI ( для PT88-русский)
Для активизации выбранной таблицы символов, необходимо скопировать ее из каталога
\STEP5\S5_ST\INSTALL в системный каталог \STEP5\S5_ST и переименовать в файл S5DRU_KY.INI.

В информации о продукте для STEP 5 V6.6 русская версия указано неверное имя INI-файла
(вместо S5DRU_KY.INI напечатано 5DRU_KY.INI).

Если у Вас возникают проблемы, при печати из STEP 5,
то попробуйте напечатать какой-нибудь русский текст из чистого DOSа.
При этом не должен быть загружен какой-нибудь загружаемый драйвер принтера.

(Многие принтеры поддерживают печать русского текста после загрузки в него русских шрифтов, соответствующей командой.
При этом это работает только с программами, которые не перезагружают принтер.
STEP 5 не относится к числу таких программ. - Она перезагружает параметры принтера).

Например создав текстовый файл и послав его на принтер (команда COPY filename PRN).
Если он будет напечатан нормально, тогда Ваш принтер поддерживает кирилицу на аппаратном уровне.
И соответственно проблема в параметрах STEP 5, что можно будет обсуждать дальше.
До этого у нас не было проблем с печатью из STEP 5.

2. STEP 7-MicroWin V2 32-bit
Да есть такая проблема.
В новой 32-битной версии STEP 7-MicroWin V3 все печатается нормально.

Re: Распечатка программ в S5 на русском языке
Alexey Zaytsev; 14.4.01

Может я несюда попал но всётаки время моло и етнто последняя надежда . мне нужна распайка подлючения PT88 к PC может есть у кого Plzzzz...


AS функция недоступна .....
Андура В.; 16.6.99

При попытке считать блоки в файл из AG S5-115U

CPU943B, появляется сообщение AS функция недоступна. Так же невозможно просмотреть блоки в контроллере, кроме DB, но их нельзя редактировать, то же сообщение.
Как с этим бороться?
Re: AS функция недоступна .....
Альтерман И.; 21.6.99

Вероятно, причина в том, что программа в вашем CPU защищена паролем, который хранится в настройках блока DB1.

А как можно снять пароль, если он забыт, или узнать вообще он стоит или нет? (subj)
Андура В.; 22.6.99

subj

Re: AS функция недоступна .....
Гусаков Константин; 27.8.99

Нет сто процентной уверености в том, что стоит пароль в DB1.Так как после его (DB1) удаления ситуация не изменяется. Причина вероятно кроется в перепадах электроснабжения.

И увы лечится она только OveralReset'ом.
На вопрос о возникновении данного рода ошибок шведские наладчики открестились девиацией частоты сети переменного тока (49-51Hz), что естественно чушь....
С уважением Гусаков Константин

Re: AS функция недоступна .....
Степанов Александр; 5.10.99

Возможно, поможет вот это решение...

См. Customer Support

Re: AS функция недоступна .....
Степанов Александр; 5.10.99

Customer Support Entry ID:762567

Com Graph - не могу найти описание пользователя
Stepanov Alexey; 22.11.00

Нужно сделать полную распечатку существующего проекта, сделанного на панели операторя МР14


регулятор температуры
Николай Бескровный; 26.11.99

Ваше сообщение...Где посмотреть, как можно создать регулятор температуры поддерживающий постоянной разницу между температурой среды и температурой нагревателя.

Re: регулятор температуры
Дедовец Павел; 6.12.99

Посмотреть структуру регулятора можно практически в любом учебнике по ТАУ (Теории автоматического управления), а пример реализации в документации на контроллер с PID регулятором.

Если нет ни того, ни другого, пишите мне на E-mail.

dedovetc@online.ru
Привет!
Re: регулятор температуры
Даниленко Ольга Леонидовна; 15.11.00

Ваше сообщение...На нашем предприятии работают электронные регуляторы температуры Щ-4528 и

Щ-4538 ( от 0 до 400 градусов С) с хромель-копельной градуировкой. К сожалению они вышли из строя, а мы не можем найти им аналоги или техническую литературу, чтобы отремонтировать, т.к. производство этих приборов в нашей стране закончилось 10 лет назад. Не могли бы Вы нам помочь?
Re: регулятор температуры
Вахутинский М.В.; 15.11.00

Вы можете найти информацию по регуляторам по адресу http://www.siemens.ru/ad/pa.

Серия называется Sipart DR.


Как использовать FB если их нет в CPU
Чистяков Дмитрий; 12.5.99

Мы имеем Simatic S7-400 с CPU 413-2DP (413-2XG00-)AB0). В пакете Step 7 имеются стандартные функциональные блоки для работы с системой сообщений (FB17...19), при попытке их использовать в программе появляется сообщение об ошибке - блоки отсутствуют в памяти процессора.

Вопрос каким образом можно воспользоваться этими ф.блоками?
Имеется ли возможность обновить внутреннюю память процессора с занесением туда этих блоков?
И каким образом определить при заказе процессора наличие функциональных блоков в ПЗУ процессора (не только по сообщениям)?
Re: Как использовать FB если их нет в CPU
Альтерман И.; 22.6.99

Давайте для начала определимся в терминологии. Вас, может быть, интересуют стандартные блоки SFC17-SFC19?

Относительно FB17-FB19, могу сказать , что такие блоки относятся к пользовательским блокам, которые свободно программируются, либо заимствуются из всевозможных библиотек, а потому должны загружаться в S7 CPU 300/400 Л Е Г К О.
Re: Как использовать FB если их нет в CPU
Чистяков Дмитрий ; 21.7.99

Да-да меня интересуют системные блоки SFC, извините, что сразу не написал.

Так вот как же их туда записать?
И ещё нет ли где таблички в которой, были бы все CPU и перечень наличия в них системных блоков?
как использовать SFB 41
Smirnov; 27.10.00

Не получается загрузить SFB41 (блок непрерывног регулирования CONT_C). Может у кого либо есть опыт разработок ПО с использованием SFB.

Заранее благодарен.


OLE/DDE
Мокрицин Дмитрий; 6.7.99

Между SIMATIC S7-300 и InTouch 6.0b (WinNT) через CP343-5 и CP5412A2 организована связь с помощью OLE/DDE-Manager (FMS). Передача данных по OLE/DDE осуществляется с очень низкой скоростью: несмотря на то, что Polling = 50 ms, данные обновляются примерно раз в секунду при относительно небольшом их объеме (200 байт), плюс постоянно обрывается связь.

При использовании вместо FMS протокола S7 ситуация усугубилась тем, что часть данных вообще не передается.
Каким образом можно решить данную проблему?
Заранее благодарен.
Re: OLE/DDE
siemargl; 6.7.99

Вытащить для начала через OLE|DDE те-же данные, скажем в EXCEL, а затем посмотреть, кто виноват...

(вдруг excel быстрее intouch??)
Re: OLE/DDE
Чистяков Дмитрий; 21.7.99

Вопрос этот достаточно изъеденный молью и возникает он у всех пользователей начавших использование систему визуализации, которая является "не заточенной" под конкретный контроллер. Особенно актуален этот вопрос, там где требуется достаточно высокое быстродействие. Например, для нефтегазовой промышленности вполне достаточным временем скана контроллера ( по заявлению всех фирм, включая и WonderWare) 200мс, а 100мс - это что-то сверхестественное и невероятно быстрое. Ну а зачем тогда более быстрая система связи?

На мои вопросы по повышению быстродействия и поддержки фирменных (в данном случае Simens Simatic) протоколов на семинарах в Институте Проблем Управления РАН, ответ был всегда один - "А Вы закажите его и мы Вам его напишем, только это будет очень дорого стоить (ведь придётся этот протокол купить у Siemens)".

И теперь вернёмся непосредственно к вопросу, а для этого распишем из чего же состоит полное время обмена информацией:

1. Формирование данных, которые необходимо передать по каналу обмена (по сети). Выполняется это в CPU командами контроллера SEND/RECV. По сути дела по этим командам данные лишь заносятся в память коммуникационного процессора.
2. Формирование пакетов информации для передачи их в сеть. Выполняется ком.процессором, причём асинхронно по отношению к программе контроллера.
3. Передача пакетов в сеть.
4. Приём пакетов коммуникационным процессором (CP) системы визуализации.
5. Формирование (востановление данных) из информационных пакетов отправленных контроллером. Эти данные помещаются в буфер CP.
6. Циклический (либо по прерываниям) опрос DDE-сервером буфера CP и подготовка данных для передачи DDE-протоколом.
7. Запрос (PULL) системы визуализации к DDE-серверу.
8. Передача данных в систему визуализации.
9. И наконец отображение состояния объекта на экране монитора.

Отсюда видно, что собственно говоря PULL играет далеко не самую главную роль в общем времени обмена, а именно всего два пункта 7 и 8. При этом нужно учесть, что его влияние не сказывается даже на работу CP персоналки, а пересылка данных из одной области памяти в другую не представляет особой задачи. Поэтому во всех системах DDE-серверов и фигурирует значение 50мс.

Кстати это значение появилось не случайно, оно продиктовано MS Windows, который привязан к системным часам PC. При этом если измерить интервалы между пулами, то можно увидеть, что интервал постоянно плавает и может достигать до 80мс, при условии отсутствия дисковых операций в этот момент времени. Но это уж наследие MS и тут никуда не денешься.

Так вот все фирмы, разрабатывающие универсальные системы визуализации, которые используют для получения информации DDE-сервера, всегда указывают именно эту священную цифру 50мс. Таким образом они открещиваются от всех проблем связанных с сетью. А фирма Wonder Ware даже и DDE-сервера сама не пишет, а использует разработки третьих производителей. Тут упомяну тот факт, что один DDE-сервер для связи с Omron-oм написан нашим коллегой из отдела АСУ - Смирновым Юрием Борисовичем. Его DDE-сервер сертифицирован Wonder Ware и включён в диск I/O Servers.

Ну вернёмся к проблеме. Как показали наши испытания, самая большая часть времени в обмене информацией, выпадает на непосредственную передачу и приём информации коммуникационными процессорами.

Здесь конечно многое зависит от количества абонентов (узлов в сети), скорости приёма/передачи и естественно объёма информации. Так для сети Sinec H1 с её 10Мбитами и 16-тью узлами цикл обмена составил около 100мс, при общем объёме информации < 10кБайт. Здесь следует учесть, что далеко не каждый информационный пакет доходит до абонента в с первой попытки.

Для Profibus-DP фирма Siemens составила целую таблицу зависимости времени передачи информации от количества станций, скорости и объема информации. Так при скорости 12Мбит/с и при двух абонентах в сети время передачи одного символа (слова) составит 60мкс. При скорости 187кБит (наиболее часто используемой) и при тех же условия - 500мкс. А в реально используемых системах время передачи может иметь значение порядка 20-500мс.

Следует также отметить, что протокол Profibus-FMS несколько медлительнее своего собрата DP, потому как разрабатывался как универсальное средство для связи устройств различных производителей, и соответственно имеет много дополнительной обработки, которой нет в Profibus-DP и Profibus-PA.

Вообще для передачи информации с очень высоким быстродействием, не стоит возлагать надежд на сеть в её классическом варианте с DDE-сервером.

Что же предлагают производители для решения этой проблемы. В частности Siemens.

Siemens имеет разработки, которые ведутся начиная с середины 80-х годов начиная с системы визуализации COROS. Ну во первых решение проблемы с отображением на экране монитора быстрее чем 100-200мс не имеет смысла - просто оператор не в состоянии уловить такие мультики, поэтому работы в этом направлении не очень-то продвигаются.

Быстродействие же необходимо для таких процессов, как протоколирование изменений состояния объекта, т.е. изменение состояния дискретных (логических) датчиков и протоколирование аналоговых величин. Для решения обеих задач часть этих функций по сбору и предварительной информации перенесена непосредственно в сам контроллер.

Так протоколирование изменения состояния логических сигналов возможно при помощи системы сообщений встроенной в как в CPU так и в CP. В чём её прелесть? А вот в чём. При изменении сигнала фиксируется системное время контроллера и создаётся информационный блок, называемый сообщением. В этот блок входит:
 Идентификатор сообщения (сигнала), называемый номером сообщения.
 Тип сообщения (класс) - аварийное, предупреждающее, информационное и т.д. всего до 16 классов назначаемых пользователем.
 Время последнего переднего фронта сигнала (переход из 0 в 1)
 Время последнего заднего фронта сигнала (переход из 1 в 0)
 И много другой информации (всего 22 поля) описанной в документации.

Так вот система сообщений фиксирует изменения сигналов и складывает сообщения в буфер, а затем по мере возможности передаёт содержимое буфера системе визуализации, которая, на основе информационных полей сообщения, формирует протокол, наиболее известный как ALARM.

Такая система протоколирования очень удобна в системах управления объектом, в которых используется несколько контроллеров, объединённых в сеть. Так используя встроенную систему синхронизации системного времени всех контроллеров, можно получить достоверную информацию и ходе процессов объекта автоматизации. Как это происходит? Так как время во всех контроллерах идентично, то система сообщений контроллеров будет формировать сообщения о событиях (фиксирование времени) в том порядке, в каком они происходят непосредственно на объекте. А система визуализации сформирует протокол на основе полей времени, уже по событиям, а не по времени поступления значений сигналов в персоналку.

Так у нас имелся горький опыт в этом. Дело происходит так, сигналы в контроллере о состоянии насосной аккумуляторной станции передаются в PC с разных контроллеров и фиксируются системой InTouch по мере поступления сигналов в персоналку. И таким образом мы зачастую получали картину удивительную - сначала включался дополнительный насос, а потом падало давление. Хотя реально всё наоборот.

В добавок ко всему при фиксировании изменения сигнала, имеется возможность зафиксировать в этот момент ещё до десяти значений каких либо переменных в контроллере. Например текущее давление, скорость и всё что угодно. Зафиксированные значения переменных затем будут отображены в протоколе - непосредственно в тексте сообщения (это конфигурируется пользователем по желанию и вкусу).

Здесь программист может сказать, "Ну ё-моё! Это же целая задача, на решение которой уйдёт много сил и средств". Так вот фирма Siemens давно всё за нас сделала и предлагает полный спектр услуг по решению таки задач.

Во-первых, в системе STEP7 имеются стандартные функциональные блоки ALARM_xx, которые вызываются в любой части программы.

Для упрощения работы с сообщениями имеется специальный пакет STEP7 P-Diag, который позволяет несколькими щелчками мышки за конфигурировать требуемые события на объекте. А в добавок, если Вы используете WinCC , то можете привязать текстовые сообщения, которые будут автоматически появляться на экране, без какой либо дополнительной работы в WinCC.

В паре с P-Diag может работать другой программный пакет - Pro-Agent, котрый следит за ходом событий на объекте и в случае отклонений от заданного хода, формирует дополнительные сообщения, предупреждающие о непорядке на объекте.

Вообще при использовании контроллеров фирмы Siemens идеальной парой для визуализации, является пакет WinCC. Которые заточен под все "фенечки" контроллеров Siemens`a. Да и ко всему прочему дешевле InTouch почти в два раза.

Особенно (естественно) удобна реализация системы связи в WinCC. Так для того чтобы описать связь достаточно указать WinCC адрес(а) контроллеров с которыми необходима связь. В контроллере же не требуется абсолютно никаких дополнительных программных решений, таких как команды SEND/RECV. Все данные передаются автоматически коммуникационным процессором, без задействования CPU, что благотворно сказывается на его производительности. Это очень удобно, когда надо добавить новую переменную на экран визуализации, не надо лезть в программу контроллера, достаточно просто в WinCC указать адрес переменной контроллера.

При этом производится автоматическая оптимизация передаваемых данных. Данные передаются не все используемые для отображения состояния объекта, а только те которые используются в активных окнах. Что также благотворно сказывается на загрузке сети.

Ой ну ладно и так много по-написал. Чтобы описать проблемы связи понадобиться много времени, а в результате получится цела книга.. Если у Вас появятся вопросы по системам, обращайтесь к нам.

По вопросу OLE/DDE-Manager (FMS).
Этот менеджер производства Siemens или WonderWare? У нас, например, их сервер для связи с S5 по Sinec H1 ни в какую не пошёл, а родной Siemens - без проблем.
Свяэь же может сбоить по многим причинам. Здесь и неверный выбор кабеля для сети, и неверно установленные терминаторы на станциях, и совместное использование единой сети для Profibus-DP и -FMS (в этом случае DP всегда имеет более высокий приоритет). Вообщем надо знать подробности, что бы ответить на этот вопрос.

С уважением,
Вед.инженер Службы Технологической Автоматики ПХЛ Чистяков Дмитрий Николаевич sta5@stal.ru 56-04-65, 56-77-77, 56-78-67
Благодарю за полный ответ....
Никаноров; 27.7.99

Могу только поблагодарить за обстоятельный ответ и выразить надежду, что и в дальнейшем наши партнеры и заказчики, имеющие опыт работы с продуктами фирмы Siemens, будут активно помогать своим коллегам, делясь своим опытом.

По существу вопроса могу только добавить, что упоминаемый Вами буфер, который создается в контроллере, а затем передается в WinCC (технология называется PMC S5/S7, имеется только у Siemens), может содержать не только так называемые Alarm'ы, но и архивы. При этом в контроллере может быть создан буфер типа "метка времени - значение", который затем автоматически передается на транспортном уровне в архивы WinCC и расшифровывается с помощью специальной dll (так называемые Process Controlled Archive). Размер буфера может быть до 1600 значений типа Integer или 1300 значений типа Real. Этот буфер передается в SCADA с помощью SFB37 AR_Send. Таким образом может быть достигнуто истинно realtime архивирование.

Еще раз спасибо
Все правильно, кроме...
max; 5.8.99

Все сказано правильно, кроме того, что стоимость пакета WinCC

ниже только для большого количества тэгов (больше 1000), а ресурсов
системы он требует несравненно больше.
Re: Все правильно, кроме...
Иванов Павел (Сименс-Москва); 26.8.99

ПОЛНУЮ версию WinCC на 128 переменных + очень много дополнительных пакетов мы даем БЕСПЛАТНО.

А по ресурсам, если Вы будете сравнивать последнюю версию InTouch c WinCC, то требования к ресурсам будут одинаковыми.
Т.к. во всех последних версиях пакетов, разрабатываемых современными средствами перед всеми разработчиками стоит задача быстрее реализовать запросы пользователя и поддержать пользователя дружественным интерфейсом. Поэтому все последние пакеты становятся все удобнее для пользователя, предлагают все больше и болшьше и больше возможностей, но как обратная сторона требуют больше ресурсов от компьютера.
Это можно очень хорошо видеть так же на пакете Microsoft Office, разрабатываемой самой фирмой Microsoft, которая знает все тонкости своей операционной системы.
И т.к. сегодня аппаратные компоненты компьютеров дешевеют каждый день, то во главу угла все ставят не оптимизацию быстродействия существующих версий, а как можно более быструю реализацию новых запросов и пожеланий пользователей.
DDE Server Profibus FMS (карта CP5412)
Валерий Поляков; 16.10.00

Укажите, пожалуйста, дилера вышеуказанного сервера для сопряжения с оболочкой RSView

фирмы Rockwell Automation и его цену.
С уважением Поляков В.А.


forum
Марочкин Григорий; 8.12.99

При попытке просмотра вопросов форума страница была пустой без каких-либо сообщений от MS IE5.0(кроме готово).

Аналогично и при ряде других страниц сайта.
Нужны ли какие-то особые настройки браузера или это "висячие" ссылки?

Re: forum
Никаноров (Сименс - Москва); 8.12.99

Пока проблем не было.

Вы - первый.

Re: forum
Марочкин Григорий; 27.1.00

Сейчас действительно нет проблем


Работа в Step7 v.5.0 в режиме клиент-сервер
Чистяков Дмитрий ОАО ; 10.11.99

Подскажите пожалуйста, основные шаги настройки сервера и клиента.

У меня сейчас в Set PG/PC установлен "адаптер" TCP/IP 3Com.
На сервере установки в сервере Step7 по умолчанию.
Сам сервер NT Server 4.0 и работает он один без проблем через CP5412(A2).
Открываю проект на клиенте с сервера (тот же самый - рабочий), и вовсех режимах работы связанных с непосредственной работы с контроллером (on-line, VAT, изменение в программе) получаю ответ о том, что CPU недоступен.

Вопрос - что здесь я не так сделал?
Если можно копию ответа - на почту, а то у меня ограниченный доступ в Internet on-line.

Заранее благодарен.
Чистяков Дмитрий sta5@stal.ru


PLC-ANALYZER (программный регистратор работы контроллера)
Андрей Тураев; 15.9.99

У кого есть опыт работы с этой программой, интересует в первую очередь ее быстродействие и влияние на время цикла самого контроллера.

Re: PLC-ANALYZER (программный регистратор работы контроллера)
Никаноров (Сименс, Москва); 28.9.99

Если Вы хотите приобрести этот продукт или получить больше информации о нем, зайдите на эту ссылку, может быть, что-нибудь и найдете.

См. http://www.autem.de


Привязка софта к железу
Афанасьев И.; 12.8.99

Есть:

Четыре мостовых крана работающих под управлением S7-300. Железо у них полностью идентично. А вот в софте есть некоторые различия (уставки таймеров и пр.).

Надо:
Привязать каждую программу к своему крану т.к. организационных мер недостаточно. В случае если загружена программа не для того крана не дать запустить Simatic (SFC 46-STP).

Исползование свободных входов для кодирования механизма в данном слечае не подходит (обслуживающий персонал такие прибамбасы выкидывает в первую очередь для облегчения своей жизни Ж:-[]).

Re: Привязка софта к железу
Гуленок Андрей.; 17.8.99

Хм.... Так сразу в голову ничего и не приходит....

Уникального идентификатора, к которому можно обратиться из программы пользователя в документации нет. Можно опросить поставочный номер, версию операционной системы, но у однотипных CPU они одинаковы. Наиболее простой путь - нарушить идентичность системм. Например изменить порядок следования модулей входов-выходов. Мало того, что "поплывёт" адресация, каждый контроллер будет иметь собственную аппаратную конфигурацию. Если программу защитить паролем,потребуется перемонтаж контроллера.


Об OB13...
Андура В.И.; 16.6.99

Вопрос в следующем:

пишем L KF xxx
T BS 97
Чему должно равняться xxx для 10мс, 100мс, 1с,
10с, 1 мин 10 мин.
Спасибо.
Re: Об OB13...
Альтерман И.; 21.6.99

Друзья! Советую заказать у нас курс обучения по SIMATIC S5, который называется ST-5SERV1, или документацию на русском, например, руководство по S5-115U.

Кстати, программы обучения по системам SIMATIC имеются в разделе обучение.
Так вот именно в руководстве то этого нет. Если вы найдете сообщите страницу, пожалуйста. (subj)
Андура В.; 22.6.99

Subj

В руководстве это есть.
Никаноров Владимир - Siemens Москва; 28.6.99

Поведение ОВ прерываний от таймера (ОВ 10-18)зависит от типа CPU, который Вы применяете. Поэтому смотреть нужно документацию на конкретный процессор (или список команд- по немецки называется Tabellenheft).

Например, процессоры CPU 928/928B имеют 9 фиксированных интервалов прерываний от таймера (в зависимости от номера ОВ), CPU948 имеет также 9 интервалов, однако они могут быть заданы в системном блоке данных DX0.

Что касается контроллера S5-115U CPU 941/942/943/944, то интервалы вызова задаются через системные слова данных BS. В руководстве на этот контроллер на русском языке описано подробно как это сделать и приведены примеры (страница
6-15, 6-16).
Например, для установки такта в 10мс необходимо в BS97 занести константу 1, 100мс-10, 1с-100, 10с-1000, 1мин-6000 и т.д.

Успехов


Пакет STEP5 - недостатки
Андура В.; 18.6.99

А недостатки есть:

1. Нет эмуляции, т. е. нельзя проверить программу без наличия контроллера.
2. Невозможно просмотреть и отредактировать блок (OB, FB, PB), если в нем вызван не существующий блок, например если скопировать из контроллера только один OB1 в файл, то его невозможно просмотреть и редактировать.
И еще неустойчивость связи с контроллером через СОМ порт, связь рвется в самые неожиданные моменты, а иногда вообще невозможно связаться с контроллером без перезагрузки компьютера.
Вот и создается впечатление, что STEP5 сырой продукт, а денег стоит не малых.
Re: Пакет STEP5 - недостатки
Гуленок А.; 22.6.99

Это не баг, это фича.

STEP 5 создавался более пятнадцати лет назад, когда небыло даже понятия такого, персональный компютер. Изначально он был написан под PC/РМ. Потом был сделан эмулятор PC/РМ для DOS. STEP5 поддерживает множество СОМ-пакетов, библиотеки, разные форматы программ. Концепции STEPа заложены 20 лет назад и стех пор не менялись. Может сегодня он и выглядит архаичным, но для своего времени это передовой продукт. Есть пакеты другиж фирм для программирования SIMATIC S5, но они ограниченно совместимы.
А проблеммы связи скорее всего связаны с помехами. Надо внимательнее относиться к заземлению. И из опыта замечено, что программаторы работают значительно устойчивее чем COM-конвертор и менее критичны к внешним условиям.
Так я не об истории говорю...
Андура В.; 22.6.99

Версия пакета 6.65 не является 20 и даже 10 летней давности, просто все прелести, которые можно было сделать для облегчения труда программисту отодвинуты на задний план. Кстати еще один недостаток - неудобство при копировании, т.е. нет буфера, через который можно было бы перенести кусок из одного блока в другое. Даже в MultiEdit 10-ти летней давности возможно было переносить текст из окна в окно.

Этим я хочу сказать, что по нормальному надо сделать релиз и продать его по символической цене в 10 баксов например. А потом собрать от народа пожелания и сделать нормальный интерфейс.
О буфере в STEP5
Альтерман И.; 22.6.99

Что касается буфера в STEP5, то можно рассказать о функции копирования/вставки сегмента, которая поддерживается ничем иным, как встроенным буфером.

Если не трудно расскажите как, например, перенести часть сегмента из OB1 в FB21(subj)
Андура В.; 22.6.99

subj

О буфере STEP5 ...
Альтерман И.; 22.6.99

В буфер сегменты помещаются целиком, а не по частям. Для этого Вы выбираете в режиме "Вывод" фунции для работы с сегментами (F5 и т.д.)

Завершение дискуссии
Райчев Николай; 22.6.99

Уважаемый господин Андура,

мы хотели бы выразить Вам благодарность за Ваши столь ценные замечания по поводу STEP5, а также нетривиальный способ их изложения. К счастью, всегда можно опереться на такую конструктивную критику, как Ваша, чтобы и дальше иметь возможность успешно разрабатывать с Вашей помощью новые продукты.
Именно так происходило со STEP5.
С появлением нового поколения SIMATIC S7 был разработан новый язык программирования STEP7, который, в свою очередь, стал стандартным в мире ПЛК. Для Вашей информации: конкурирующие с Siemens фирмы-производители аппаратных средств (железо)используют в качестве инжинирингового программного обеспечения STEP7.
От имени нашего отдела, занимающегося SIMATIC в России, я хотел бы поблагодарить Вас за Ваши замечания и пожелать Вам успешного поиска других недостатков STEP5, исправление которых внесет свой вклад в дальнейшее улучшение этого продукта -"ветерана".
На этом мы завершаем с Вами дискуссию относительно STEP5.
Мы непременно свяжемся с Вами - если, конечно, Вы откажетесь от анонимности и укажете свой адрес и фирму - и дадим подробные ответы на все Ваши вопросы.

С уважением
Д-р Н. Райчев, Директор по сбыту A&D S
В том то и дело что целиком...
Андура В.; 23.6.99

Длинна сегмента 255 строк, а перенести надо, допустим, 100, вот и неудобство. Либо переноси весь сегмент и удаляй 150 ненужных строк, либо пиши их заново.

А зачем продавать этого ветерана до сих пор...
Андура В.; 23.6.99

Дело в том что у меня на работе львиную долю оборудования занимают именно контроллеры S5 и с ними приходится работать каждый день. Поэтому мной и была высказана идея об усовершенствовании оболочки.

А насчет конкурентов, так они предлагают программировать свои контроллеры на Basic, Pascal и C++.
С уважением ко всем принявшим участие!


Режим статус
Андура Виктор; 1.3.99

Hi, All!

У нас на линии имеется контроллер S5-100 c CPU102.
При выходе в режим статус в блоках FB, PB и OB оператор не обрабатывается, то есть не работает режим статус.
Если вынуть ПЗУ и записать в ОЗУ считанную из ПЗУ программу, то режим статус работает нормально, но не правильно работает установка.
С чем это связано?
Может это какой то вид защиты?
См. Это наша страничка

Re: Режим статус
A&D S Никаноров; 2.3.99

В CPU102 существует следующая особенность. Этот процессор работает в двух режимах: Normal и Test.

В режиме Normal функции "Статус" неработают, так как в этом случае выполняется скомпилированная ассемблерная программа. Для реализации функций "Статус" необходимо переключиться в режим Test.
Если Вы запускаете контроллер путем включения питания и при этом установлен модуль EPROM, то контроллер переходит в режим Normal. В режим Test контроллер можно перевести несколькими способами. Один из способов, если Вы загружаетесь из EPROM, это удерживать клавишу Copy в нижнем положении при включении питания контроллера до окончания мигания красного светодиода. Другие способы Вы сможете найти в руководстве по контроллеру S5-100U (в том числе на русском языке).
Успехов.


Файлы Step5
Андура; 12.2.99

Ответьте пожалуйста, что сохраняется в файлах ******z1.ini,******z2.ini,******zf.ini,******dr.ini,******td.ini,******xr.ini? И можно ли их удалять, для чего они нужны? Как списать с ПЗУ программу со стандартными блоками? Мы пробовали, но при записи в озу эта копия не работает. Как можно получить из файла ******st.s5d комментарии в текстовом виде, а потом записать их обратно (необходимо иностранные коментарии перевести на русский язык)? На этом пока все.

Заранее спасибо за ответ.
Инженер по автоматизации Очаковского моспивкомбината Андура В.И..

Re: Файлы Step5
A&D S Nikanorov; 15.2.99

Файлы z1.ini и z2.ini являются промежуточными ступенями преобразования последовательного исходного файла z0.seq в файл символики z0.ini. Если Вы сохраняете файл z0.seq, то можно удалять файлы zx.ini, т.к. из файла z0.seq всегда можно получить все файлы zx.ini. Если же Вы удаляете z0.seq, то Вы должны сохранить все файлы Zx.ini для нормальной работы с проектом в символьном виде. Файл Zf.ini: здесь хранятся сообщения об ошибках, возникающих при преобразованиях *.seq - *.ini и наоборот. *dr.ini- здесь хранятся установки принтера. *xr.ini- это таблица перекрестных ссылок (можно сгенерировать в любой момент; можно удалять) td.ini - этот тип файла мне неизвестен (возможно *TP.ini - это файл макрокоманд, который Вы можете создать, нажав CTRL-A, записав последовательность действий и закончив CTRL-E. Вызвать этот файл можно с помощью CTRL-D.) Комментарии к блокам в файле *ST.S5D хранятся в следующих блоках- PK, FK, OK ... Например, комментарии к блоку РВ100 хранятся в блоке РК100, который Вы можете свободно редактировать. Экспорт из этого блока можно сделать, распечатав его в файл. Однако стандартных средств импорта обратно- нет. По вопросу ПЗУ - нужна более подробная информация: какой контроллер, какой процессор, какие функциональные блоки.