text

AKUT
Eugene; 29.10.00

Получил от SIEMENS демо-версию программы AKUT.

Установил. При запуске каждое из приложений запрашивает имя пользователя и пароль. Как с этим бороться?
И еще - после установки авторизации на 21 день программа Authors перестала работать - говорит, что не может найти SCPW32.DLL и SCPW32A.DLL. После удаления вышеуказанной авторизации программа Authors заработала. С чем это связано?


CFC driver wizard
Шурик; 15.10.00

Что это такое и как им пользоваться ?

Куда делись из библиотеки PCS7 ver.5 драйверы на 8 и 16 дискретных канала ?

Спасибо
Re: CFC driver wizard
Михайлин Сергей (SIEMENS-Москва); 16.10.00

В PCS7 v5 изменилась концепция доступа к периферии. Причем в существенно лучшую сторону. Теперь не надо в лоб заносить адреса модуля, рэка и канала, да еще и hex-виде. Теперь каждый блок-драйвер напрямую соединяется со своим входом или выходом через команду Interconnection to address. Далее нужно запустить именно CFC driver wizard. Он сам сформирует системный чарт с именем @1. В него он добавит блоки которые непосредственно обсуживают канал, модуль, корзину, сегмент сети, отвечают за их работу и диагностику. Подробнее о этих модулях и о визарде можно прочесть в руководстве по Библиотеке Драйвер-блоков. Много канальные драйвер-блоки выведены из библиотеки. Один драйвер-блок для одного канала. Это нормально, ведь теперь драйвер-блок просто берет сигнал из периферии, а вся остальная обработка лежит на других, как раз много канальных, блоках.

Ну а на худой конец можно проинсталировать старые библиотеки, только зачем....?


CPU 948
Logunov Ivan; 6.9.00

Уважаемые господа! Как при работе с CPU 948, возможно произвести обращение

к ячейке памяти в области маркеров связи по абсолютному адресу этой ячейки?
В случае с CPU 928B, это делалось просто, например:

L KH F220
LIR 1
T FY32

Для CPU 948 аналогичный адрес для FY32 - F F220H.
В имеющейся у меня документации коротко указано, что непосредственное
обращение даёт "FF H" в старшем байте и данные в младшем?


PCS-7 v5.0 где библиотека PCS7 basic block
Соловьев А.; 31.10.00

В 5 версии PCS7 нет очень удобной библиотеки

PCS7 basic block, в частности блоки IN_A1,IN_A1C
и аналогичные дискретные. Это что, какие-то новые технологии, как сейчас работать? Будут ли проблемы с переносом старых проэктов?

Re: PCS-7 v5.0 где библиотека PCS7 basic block
Михайлин Сергей; 31.10.00

Библиотека есть, она так еще и называется! Но если Вы ищете драйвер блоки In_A1 и др, то всех их переместили в бибилиотеку PCS7 Drivers Block. Вместе с этим изменилась концепция доступа к периферии, хотя старая тоже поддерживается. Советую почитать докуметацию на эту библиотеку!


Prodave для S200
Илья Шустиков; 21.6.00

При использовании функций из пакета Prodave для записи данных в область variable memory (vw)возвращается код ошибки 8301-запись и 8303-чтение. Запись данных в другие области памяти (меркерную (m)область) все проходит нормально. С чем это может быть связано?

Re: Prodave для S200
Aleksandr_Kuzmenko; 19.10.00

А где достать Pradave MPI


S5W software
А.Китайгора; 1.8.00

Где достать полнофункциональный "S5W" с минимальными затратами


S5W
aim; 13.12.00

Народ помогите!!!

Если кто юзает пакет S5W (аналог Step5)-помогите чем можете (дайте слить ;o)). Если есть стоит защита - поможем сломать.
Re: S5W - имеется.
Ярослав; 18.12.00

Имеется компашка S5W S7W ..... и многое другое, причем на S5W есть необзодимая авторизация...

Заинтересован в плодотворном сотрудничестве.
Готов к труду и обороне ;o)))
aim; 8.1.01

В плодотворном сотрудничестве заинтересован. Жду ответа на мыло.

Re: Готов к труду и обороне ;o)))
Яросллав; 1.2.01

не могу найти адрес...

;o)))
aim; 10.2.01

Пиши на мыло - aim@land.ru


S7W
Ярослав; 18.12.00

Ребята может кто поможет с кодом....

Посмотреть уж больно хочется.
Очень благодарный.

Re: S7W
Андрей Гуленок; 22.1.01

А что это?


SFC 51(S7-400) в "стопе"
Дима Веткин; 16.10.00

Здравствуй всезнающий All!

Как я понял, узнать что-нибудь о состоянии контроллера можно вызвав sfc51. Эта функция может вернуть текущий режим контроллера, причем этим режимом может быть и стоп. А вот теперь не понял,
:( как и откуда можно запустить данную функцию, чтобы она вернула текущий режим стоп. Я думал можно что-нибудь запускать только в run-e/.

Спасибо за ответ. Всего хорошего.
Дима.


SIEMENS & Win2K
Eugene; 1.8.00

Когда программное обеспечение SIEMENS (в частности Protool/Pro) будут поддерживать Windows 2000?

Re: SIEMENS & Win2K
Павел Иванов (Сименс-Москва); 2.8.00

Ориентировочно следующие версии программных продуктов будут сертифицированы для работы под Windows 2000:

STEP 7 V5.1 - конец 2000 года
STEP 5 V7.13 - 4/2000
WinCC V5 SP2 - 9/2000
ProTool/Pro V5.2 SP2 - 9/2000
WinAC V4.0 - 11/2000

Драйвера для сетевых карт уже с 05/2000 работают с Windows 2000
Re: SIEMENS & Win2K
Eugene; 5.8.00

Чем WinAC V4.0 будет отличаться от WinAC V2.1?

Re: SIEMENS & Win2K
Павел Иванов (Сименс-Москва); 7.8.00

Вначале об отличиях WinAC v.2 <-> v.3:

- поддержка подключения панелей оператора
- поддержка удаленного программирования
- поддержка новых карт - CP5613/CP5614
- поддержка нескольких сетей Profibus DP
- поддержка телесервиса по TCP/IP
- поддержка стандартного RTX for Windows NT (от фирмы Ventur COM)
- новые улучшенные элементы управления ActiveX

Теперь о том, что будет нового в WinAC v.4:
- поддержка коммуникаций ЦПУ - ЦПУ по сетям MPI, Profibus, Ethernet
- работа с модулями, использующими К-шину (например, FM357)
- и наверное еще много чего хорошего.


Simatic PDM
Валентины Булгаковой; 26.9.00

Где найти описание возможностей программы

Simatic PDM?
Re: Simatic PDM
Вахутинский М.В.; 26.9.00

Информацию о программе Simatic PDM можно найти по адресу

http://www.siemens.ru/ad/pa/html/simaticpdm/index.htm


Step 5 не работает на Pentium II
Морозов В.; 10.2.00

Взломаннный Step 5, прекрасно работающий на первом Pentium 100, не запускается на Pentium II

При запуске s5kxs01x.com вывливается divide overflow error.
Какие будут советы?
Re: Step 5 не работает на Pentium II
Юрий О.; 10.2.00

Насчет взломанного ничего сказать не могу, а нормальный у нас не пошел на FAT32, может быть в этом дело?

Re: Step 5 не работает на Pentium II
Морозов В.; 10.2.00

Нет. У нас не FAT32. Это одна из проблем со вторыми пнями. На них и старые игрушки дохнут.

Step 5 не работает на Pentium II
Buenos Aires, Argentina; 23.10.00

Necesito el programa STEP5 para el SIMATIC S5

Re: Step 5 не работает на Pentium II
Морозов В.; 21.11.00

Раздобыл другую версию Step5. Работает без проблем. Так что ищите и обрящете.

Re: Step 5 не работает на Pentium II
Dimm; 2.12.00

Поделись адресом, обрящущий.


STEP 7-MicroWIN V3.1 проблемы с адресацией входов
Андрей Таранов; 24.7.00

В subj. СPU - 224 входы адресуются только до

I0.7 , I0.8 - уже не ест, но у него на борту
больше восьми входов, в чем дело, и как это лечить?
Re: STEP 7-MicroWIN V3.1 проблемы с адресацией входов
Дедовец Павел; 24.7.00

Лечить это не надо, Вы не чем не болеете ;-)

Дело в том, что адресация устроена следующим образом:
Первая цифра - это номер байта
Потом точка "."
Потом вторая цифра - это номер бита в указанном байте.
Просто замените "0" на "1" и продолжайте изменять цифру после точки от 0 и до ...

Удачи!


Update Service
Eugene; 8.8.00

Есть ли ограничения на покупку услуг обновления (update service) для программного обеспечения?

Расскажите подровнее об этих услугах.


Update Service
Eugene; 21.10.00

Есть ли ограничения на покупку услуг обновления (update service) для программного обеспечения?

Расскажите подровнее об этих услугах


блок FB194 simovert
Александр Карпачев; 5.9.00

Я подключил привод MICROMASTER Vector с картой СВ15 (6ES3290-0XX87-8PB0) к PLC S7-416-2DP по PROFIBUS DP, для управления использую блок FB194 Simovert.

В местном режиме все работает и управляется из WinCC, при выборе режима Remote невозможно управлять приводом по месту.
Вопрос: работает ли эта функция блока с MICROMASTER или только с Simovert? Если нет, существует ли специальный блок для управления MICROMASTER-MIDIMASTER?
Буду рад получить любую информацию на эту тему.


Глюки STEP5 в режиме Block status
Шишков Сергей; 19.1.00

Hecколько раз наблюдалась такая ситуация:

при редактировании программы в режиме Block status после ввода отредактированного сегмента STEP5, без запроса подтверждения ввода измененного сегмента, отображает на экране сегмент в новом виде, однако в PLC сегмент остается неизменным, что видно при повторном входе в режим Block status.
STEP5 / ST version 6.5 DATE 02.03.95
CPU948 S5-155
Re: Глюки STEP5 в режиме Block status
Никаноров - Сименс; 19.1.00

После окончания редактирования надо нажать ввод(Insert). И, после этого, на запросы о подтверждении еще 2 раза нажать Insert. Только после этого блок будет записан в контроллер.

Если у Вас нет запроса на подтверждение, то, возможно, оно отменено в маске при входе в режим Статус блока.

Re: Глюки STEP5 в режиме Block status
Шишков Сергей; 19.1.00

Запрос на подтверждение в маске включен. Ситуация случается очень редко и никаких закономерностей не обнаружено. Изменение отоьражаемого сегмента произходит после первого же нажатия Insert или F7. Выходим из неё делая то же самое через Edit block in PLC.


докум. на русском языке по scl
Григорий; 22.11.00

Есть ли документация по SCL на русском языке?

Можно выслать директом.


Документация (русский язык) STEP7 и OPC
Зайцев Евгений; 11.11.00

Подскажите, где взять подробную документацию на русском языке для STEP7 v.5.0 и SIMATIC NET DP-OPC ProfiBas DP6813/Windows NT v.4.0.

Заранее благодарю.
Re: Документация (русский язык) STEP7 и OPC
Никаноров В. - Сименс; 13.11.00

Документация на русском на STEP7 v.5.0 выпускается бесплатно на CD. Планируем также выложить ее на этот сервер. По вопросу получения документации на CD обращайтесь в наш ближайший офис.

На SIMATIC NET DP-OPC ProfiBas DP6813/Windows NT v.4.0 док-я не переводилась.

Re: Документация (русский язык) STEP7 и OPC
Алексей Карзыков; 22.11.00

Поскорее- бы выложили, а то в нашей деревне Междуреченск рядом представительства Сименс нету...

А может на E- mail скинете?
Re: Документация (русский язык) STEP7 и OPC
Александр Дрозин; 19.9.01

Ваше сообщение...

Просим Вас выслать нам бесплатную документацию на CD по STEP7 на русском языке по адресу:
61002 Харьков, ул.Мироносицкая, 25, НИОХИМ, лаб.автоматизации, Дрозину А.Н.
Заранее благодарен
С уважением
Александр

Re: Документация (русский язык) STEP7 и OPC
Марков Евгений; 3.11.01

Присоединяюсь к просьбе своего тезки о получении подробной документации на STEP7 на русском языке. В принципе переводы есть, но с "сюрпризами". Заключаются оные в том, что при чтении имеющейся переводной документации часты ссылки на контекстную подсказку в самом STEP7. А там все на английском (немецком, испанском). Или для Сименса рынок Росии не есть перспективен?


Как поменять шрифт в MicroWin32 V3.1
Колмогоров Сергей; 17.8.00

При установке MicroWin32 V3.1 под W98 в symbol table неверно отображаются русские буквы. Как исправить?


Кириллица в MicroWin32 v. 3.02
Eugene; 28.9.00

Как настроить русский шрифт в символьной таблице MicroWin32 v. 3.02?

Сам себе отвечаю
Eugene; 1.2.01

Решение найдено: см. "Я не одинок".


Математические функции в S5
Шишков Сергей; 19.1.00

Какие есть программные средства для вычисления математических функций (например тригонометрических) для CPU948 S5-155U.

Re: Математические функции в S5
Никаноров (Сименс - Москва); 19.1.00

см.ссылку

См. http://www.siemens.ru/ad/as/ru/forum/s5/forum.cgi?message=48


Обновление Hardware Catalog
Шурик; 18.10.00

Подскажите пожалуйста, как обновить данные о новом оборудовании в разделе Hw Config->Hardware Catalog(Standart),т.е.где взять dat-файлы например по CPU-417 , и что такое файлы DDB (Simatic Manager->HW Config->Option)

Re: Обновление Hardware Catalog
Иванов Павел (Сименс-Москва); 18.10.00

Поддержка CPU 417 возможна только со STEP 7 версии 5.

Когда выходит какой-то новый модуль, то часто для него существует обновление каталога для текущей версии пакета STEP 7.
Эти обновления можно скачать с нашего центрального сервера. В разделе Product Support и далее по дереву до соответствующего продукта.


Проблема разработки своего ПО SCADA (через PPI) для S7-22X
Влад; 19.9.00

Контроллеры S7-22X позволяют подключаться по PPI.

Т.е. для реализации двухуровневой системы управления (контроллеры S7-22X и ПК)необходимо лишь приобретение PC/PPI кабеля. Это достаточно для управление контроллерами от PC и намного дешевле чем покупать карту MPI для PC.
Все хорошо пока Вы используете WinCC.
Но правильно ли я понял, что не существует никакой библиотеки DLL позволяющий встроить функции управления контроллерами для ПО собственной разработки в случае связи по PPI, как в случае DLL для карты MPI для PC?
Или я не прав?

Re: Проблема разработки своего ПО SCADA (через PPI) для S7-22X
Никаноров В. - Сименс, Москва; 20.9.00

1. Цена PC/PPI кабеля не сильно отличается от карты (например, CP5611). С картой, кроме того, Вы получаете дополнительные преимущества.

2. Существует пакет, который называется Prodave MPI. Собственно, это библиотека для разработки своего ПО под Win9x/NT, работающего как по MPI, так и по PPI (в том числе и через PC/PPI кабель).

3. Кроме того, протокол PPI открыт, имеется соответствующее описание. Так что, если есть желание, можно самому поковыряться с протоколом, не используя дополнительных пакетов.
Re: Проблема разработки своего ПО SCADA (через PPI) для S7-22X
Влад; 20.9.00

1.На мой взгляд разница между 80 EUR(PC/PPI ) и 400 EUR(CP5611) - значительная. Или здесь Вы имели совокупную стоимость разработки(хотя и здесь цена на "драйверы" отличается в 2 раза) Или я неправильно посчитал.

2.Prodave MPI для S7-200 вроде (если верить каталогу) только под DOS/Win 3.1!
3.Ковыряться самому оставляешь всегда как последнее средство..
Re: Проблема разработки своего ПО SCADA (через PPI) для S7-22X
Никаноров В. - Сименс, Москва; 20.9.00

1. Prodave MPI, начиная с версии 4, работает только под Win95\NT. DOS/Win 3.1 не поддерживаются.

2. Стоимость PC/PPI кабеля действительно 80 EUR, я перепутал стоимость с PC\MPI адаптером.
Re: Проблема разработки своего ПО SCADA (через PPI) для S7-22X
Влад; 20.9.00

А что есть более дешевые варианты соединения PC и MPI устройств (например меня волнует вопрос подключения S7-300 к одноплатным компьютерам NEAT-400 или Wafer (есть RS-232/485)(Тогда я бы не задумывался о использовании S7-22X). Причем для управления установкой в некотрых случаях достаточно двух контроллеров.(Т.е. не нужно сложное сетевое взаимодействие, только PC управляет S7). Естественно, что при этом стоимость платы MPI - заметна+размер самой платы(и способ ее монтажа) увеличивает габариты в вышину). Вот прочему для меня важен вопрос стоимость и самого факта использования платы MPI

См. Одноплатные PC

Re: Проблема разработки своего ПО SCADA (через PPI) для S7-22X
Никаноров В. - Сименс, Москва; 20.9.00

Если Вам нужно подключить к S7-300 что-то по RS232\RS485, то можно использовать коммуникационный процессор последовательной связи для S7-300, типа Cp340, 341.

Вопрос только в протоколах. Если Вы сможете обеспечить, например, свободный ASCII протокол с Вашей стороны, то нет проблем.
Re: Проблема разработки своего ПО SCADA (через PPI) для S7-22X
Влад; 20.9.00

Использование Cp340, 341 - однозначный проигрыш св стоимости+самому городить протокол.

А другие способы есть?
Re: Проблема разработки своего ПО SCADA (через PPI) для S7-22X
max; 5.10.00

А чего городить-то. Заходишь на ftp://ftp.process-informatik.de/pub/demos/newdownload.htm - там для S5 полно примеров на всех языках, а для S7 - тоже есть, но только на VB

Re: Проблема разработки своего ПО SCADA (через PPI) для S7-22X
Дедовец Павел; 9.10.00

Если я не ошибаюсь то для того, чтобы подключить к персоналке имеющей только RS232C устройство MPI достаточно и PC-адаптера RS232C/MPI-DP за 278.00 Евро. Его каталожный номер 6ES7972-0CA23-0XA0. Или проблема в ПО?

Re: Проблема разработки своего ПО SCADA (через PPI) для S7-22X
Влад; 9.10.00

Я встречал только адптер для RS232/PPI.

По Вашему номеру я ничего в каталоге(04/99)не нашел.
Re: Проблема разработки своего ПО SCADA (через PPI) для S7-22X
Дедовец Павел; 10.10.00

Да действительно в каталоге (04/99) этого номера нет. Но устройство существует на самом деле. Это шнурок длиной сантиметров 15 с небольшой коробочкой с одной стороны. Обратившись в ближайшее к Вам бюро СИМЕНС Вы сможете его купить.


Работа платы DF32-L1 в QNX
Nik; 8.12.00

Где можно достать драйвер qnxdrv для работы с DF32-L1 в QNX ?


регуляторы, SFB41
Костыгов Константин; 27.10.00

Возможно ли использовать системные блоки для

встроенного регулирования SFB 41, 42 в контроллерах с любыми процессорами (не только в
314FM).
Сейчас для написания программ для СРU-315
мы используем симулятор, и блок SFB41 невозможно в него загрузить. При выделении блока - значок
загрузки затемняется.

Re: регуляторы, SFB41
Eugene; 29.10.00

В описании "System Software for S7-300/400. System and Standard Functions" (поставляется в электонном виде вместе с STEP7) сказано, что SFB 41 - 43 (SFBs for Integrated Control) доступны для использования только в контроллере CPU314 IFM.

Поэтому используйте FB 41 - 43 из библиотеки Standart Library / PID Control Blocks или прикупите Standart (или Modular) PID Control.
А SFB(SFC) вставляются в программу для того, чтобы можно было их вызывать из других блоков. Но закачивать SFB(SFC) в контроллер нет смысла, так как они являются частью операционной системы.


Русификация PCS7
Аркадий; 17.10.00

Как быть с русификацией имен блоков в CFC планах?

Может быть версия 5.1 PCS7 поддерживает эту возможность?

Re: Русификация PCS7
Михайлин Сергей; 18.10.00

Если речь идет о непосредсвенно имени блока в CFC, то это не у меня не прошло из-за ошибка компиляции, да и я не рекомендую этого делать, так как потом это имя пойдет в имя тега WinCC, а там потом кто знает. Проще, после перевести Text Library и поставить в соответвие английскому имени имя русское!


Русификация STEP5
Репин В.А.; 16.8.00

Имею пакет STEP5 V6.6, установленный на программаторе PG 720. В файле конфигурации русский язык отсутствует. Подскажите, какие файлы нужно заменить, чтобы пакет работал на русском языке. Кто может в этом помочь?

Re: Русификация STEP5
Никаноров В. - Сименс, Москва; 16.8.00

Вам нужно заказать обновление до русского языка для версии 6.6.:

6ES5 894-0MA63-0UG5, 428 Евро.


Русский шрифт в STEP 7
Сергей Олейник; 12.10.00

При работе Step7 v5.0 под Win98 можно использовать русский шрифт для написания комментариев к блокам, цепочкам, меркерам и т.п., выбрав для этого русский шрифт из списка языков, установленных в Windows (Options->Languages for Display->Available Languages). При работе под WinNT4.0+SP6 этот список почему-то пустой, хотя такой же экран, открытый для настройки клавиатуры, содержит полный набор языков (от Afrikanas до...). Как это лечится и где эта настройка сохраняется (в System Register`е)?

PS По-возможности, скиньте на e-mail, пожалуйста.

Re: Русский шрифт в STEP 7
Олейник Сергей; 12.10.00

PPS e-mail: asuespc@donmz.donetsk.ua


Совместимость S7-PDIAG
Ковалев Михаил; 18.5.00

Добрый день!

Хотелось бы узнать, совместима ли версия S7-PDIAG V4.01 с версией Step7 V5.0(SP3)?
При компиляции возникает следующая ошибка:
X:FZe 000567 Sp 005

Re: Совместимость S7-PDIAG
Павел Иванов (Сименс-Москва); 7.8.00

Да совместим.

Он совместим даже с STEP 7 V5.1


Требуется помощь-закрытые блоки в STEP 5
Михаил Зинченко; 31.10.00

Подскажите пожалуйста, что мне делать с S5 программой, в которой имеются закрытые функциональные блоки (это не стандартные

SIEMENS-блоки). При попытке редактирования,
открывается только список параметров, один
операнд и :BE. Между тем размер некоторых из этих
блоков довольно большой(DIR-функция),они вызываются в программе и выходные данные
тоже используются.

Заранее благодарен,
Михаил.

P.S.:Могу послать саму программу по E-mail, если кто заинтересовался

Re: Требуется помощь-закрытые блоки в STEP 5
Шаклеин Вадим; 31.10.00

Привет, Михаил!

Давно я это делал.
Программа обычно выглядит как две команды:

JMP =M001
BE

Для начала надо попробовать удалить команду BE.
Если сегмент программы не слишком длинный, то
текст его появится.
Так программы защищали поначалу. Затем её усили-
ли тем, что стали удалять (вернее - искажать) ра-
зделители сегментов путём исправления команд "NOP"
и "BLD 255" на команду типа "L KH 1083" (не уве-рен, что она). Из-за этого получался очень боль-шой сегмент, и он не мог отобразиться. Так что велика вероятность, что одного первого исправ-ления будет недостаточно.

Преодолеть это можно так.
1. Достать CPU943.
2. Записать этот блок в процессор контроллера.
3. Найти адрес этого блока в памяти (с пом. DIR).
4. Просматривать содержимое памяти этого блока (что можно сделать только в 943) и искать "подо-
зрительные" коды.
5. Исправить "подозрительный" код на "NOP" (0000) и "BLD 255" (10FF).

Успехов!

Re: Требуется помощь-закрытые блоки в STEP 5
Никаноров В. - Сименс; 31.10.00

Все правильно.

Могу только добавить.
Используются команды не "L KH 1083", а команды, похожие на "BLD 255" по коду (и по функциям). Эти команды не документированы. Поэтому нужно искать код команды, похожий на "BLD 255" (кстати, не обязательно использовать именно CPU943), и заменить на "BLD 255" или NOP 0.
Но этого может оказаться недостаточно. Часто бывает, что дополнительно используется еще один фокус. Точно не помню, но суть в следующем. В конце прграммы блока может оказаться конструкция, похожая по коду на следующую:
SPA =M001
L DH X Y
M001: BE
Но, если смотреть код в контроллере, то получается следующее:
Код SPA - смещение на метку
Код L DH
Метка: Первая часть операнда (X)
Вторая часть операнда (Y)
Т.е. смещение на метку стоит не на команду BE, а на операнд команды L DH. STEP5 такое понять не может, и не отображает сеть. Нужно просто изменить смещение на границу команды, например BE, как показано выше.
Такой подход не пройдет со стандартными блоками Сименс, зашитыми в ПЗУ ЦПУ.

Re: Спасибо ! Всё получилось !
Михаил Зинченко; 9.11.00

Спасибо !

Всё получилось !
Re: По поводу закрытых программ S5
Сергей; 31.1.01

Давно я это делал, но с помощью программы HexEdit(шестнадцатиричный код)

т.е.с помощью этой программы открываешь программу
S5 и меняешь определенные цифры. И потом эта программа будет открыта в STEP5.
Правда я уже не помню, но если потренироваться снова, то вспомню.


Установка STEP7 Microwin v 2.11 на WIN98
Клейн Александр; 11.2.00

При попытке установить пакет STEP7 Microwin на компьютер с WIN98 появляется сообщение инсталлятора:

C:\WINDOWS\SYSTEM\OLE2NLS.DLL
The destination file is on-use. Please ensure that all other application are closed.

При этом все приложения закрыты, вероятно, этот файл используется системной программой.
Используемый компьютер IBM ThinkPad 390E, WIN98 - лицензионная.
Что делать со всем этим?

Re: Установка STEP7 Microwin v 2.11 на WIN98
Макс; 18.2.00

Александр! Вот что значит любовь к брэнду!!! На noname все идет прекрасно ;)))

Re: Установка STEP7 Microwin v 2.11 на WIN98
Александр Клейн; 20.2.00

Максим! Брэнд здесь не причем. Если WIN98 - полное "Г", то никакой компьютер не поможет. Кстати, анализ с помощью "DLL Show" показал, что указанная выше библиотека никакой программой не используется. Поэтому, это либо глюк конкретной версии WIN98, либо глючит STEP7 Microwin. Но мне-то от этого не легче.

Re: Установка STEP7 Microwin v 2.11 на WIN98
Максим; 24.2.00

Re: Установка STEP7 Microwin v 2.11 на WIN98
Клейн Александр; 26.2.00

Лучше бы что дельное посоветовал.

Re: Установка STEP7 Microwin v 2.11 на WIN98
Макс; 28.2.00

Саша, неужели ты думаешь, что проблема внутри продукции Сименса? Скорее всего нет... И искатьее надо в связке продукции MS и IBM. Возьми другой бук (не IBM) и поставь на него S7 - и ве узнаешь. У меня на продукции IBM (камень) даже просто W95osr2 не пошла (и НТ тоже).


Экспорт/Import WMF-файлов в DOCPRO 5.0
Харгелия Олег; 16.10.00

DOCPRO 5.0 экспортирует Лайоуты в достаточно странный WMF формат (похож на Placeble WMF от Adult Corporation), который мало кто понимает(например его не понимает Word 97, ACDSee 2.3, но его понимает Word 2000, ACDSee 3.0). При изменении этого WMF-a (например в Visio 5.0) во первых он увеличивается раза в 4-5, а во вторых не экспортируется обратно в DOCPRO (налицо не совпадение форматов). Подскажите чем можно редактировать(создавать) WMF-файлы, чтобы они нормально импортировались обратно в DOCPRO.

Заранее благодарен.
Re: Экспорт/Import WMF-файлов в DOCPRO 5.0
Харгелия Олег; 16.10.00

Произошла опечатка.

Вместо Adult надо читать Aldus.
Видимо когда писал письмо думал о чем то другом :)
Re: Экспорт/Import WMF-файлов в DOCPRO 5.0
Михайлин Сергей (SIEMENS-Москва); 16.10.00

Редактирование и создание шаблонов для DokPro лучше делать в Disagner! Привожу выдержку из FAQ!

QUESTION:
How can I create two additional fields in a standard layout (e.g. A4_L_B_A)? For example, for the name of the printed block (5-digit, e.g. FC100) and for the page numbering (4-digit: 0...9999)?

ANSWER:
You can change the layout using the following graphics programs:

Designer 4.0
Designer 7.1
Corel Draw 7.0 (8.0 isn't supported by DOCPRO V3.02)
The control character $50 is used for page numbering. You edit the block name and number as "free text0" in DocPro. Use control character $40 in the layout.

Procedure with Designer 4.0:

In DocPro export the layout (e.g. A4_L_B_A) as .wmf file via the menu "Tools->Settings…"
Import the .wmf file into Designer
Set the menu "Change -> Convert to curves"
Enlarge text with Zoom+
Edit the texts $50 and $40 respectively in the positions required
Select the menu "Edit -> Select All" and then export the file
Import the changed layout into DocPro
Enter the relevant block name and number in the print job (under the object property "Free fields Text0" for this job)
Under "Tools -> Settings -> General" set "SIMATIC S5 Print Properties"
Note:
There is an alternative solution for block names and numbers with the non-documented control character $54 (used in the layout A4_lKBTA.WMF). $54 >> FC1 - <OFF displays block number and name; <OFF... stands for the off-line data base. In this solution it is not necessary to enter the block as free text.

Экспорт/Import WMF-файлов в DOCPRO 5.0
Харгелия Олег; 16.10.00

Извиняюсь за назойливость.

Эти FAQ-и я уже читал. Единственное чего я не понял, что такое Disigner. Я такого графического редактора не видел. Если Вас не затруднит дайте по нему более полную информацию: фирма производитель и т.д. Можно ли где-нибудь взять демо-версию.

Заранее благодарю.

Название пакета!
Михайлин Сергей; 17.10.00

Полное название редактора Micrograf Designer фирмы Micrograf Inc.


Проблема с пакетом S5 на P-||
Сергей Ляушкин; 21.7.00

Поставил пакет S5 на Пентиум-2.

Оказалось, что не редактируется файл Z0.SEQ. При попытке редактирования выдается сообщение, что этого файла нет вообще. Тоже самое происходит при попытке создать новый Z0.SEQ.
На простом Пентиум-100 все нормально.
Что за беда такая и как с ней бороться?
Заранее благодарен.
С уважением, Сергей.
helloo@chat.ru

Re: Проблема с пакетом S5 на P-||
Дедовец Павел; 24.7.00

Смотри ссылку

См. http://www.siemens.ru/ad/as/ru/forum/gen/forum.cgi?message=101


Проблема с пакетом S5 на P-||
Сергей Ляушкин; 21.7.00

Поставил пакет S5 на Пентиум-2.

Оказалось, что не редактируется файл Z0.SEQ. При попытке редактирования выдается сообщение, что этого файла нет вообще. Тоже самое происходит при попытке создать новый Z0.SEQ.
На простом Пентиум-100 все нормально.
Что за беда такая и как с ней бороться?
Заранее благодарен.
С уважением, Сергей.
helloo@chat.ru
Re: Проблема с пакетом S5 на P-||
Дедовец Павел; 24.9.00

Если можно, то опишите подробнее свои действия. Такое обычно происходит, когда Вы задаете параметры нового проекта и сразу приступаете к редактированию (созданию) программы в PLC. дело в том, что указанный Вами файл создается применительно к файлу находящемуся на диске, а не в PLC. Поэтому нужно сначала скопировать содержимое PLC в программатор (или сразу создавать программу на диске), а уж потом заняться файлом *ZO.SEQ

Re: Проблема с пакетом S5 на P-||
Ярослава; 19.12.00

Предлагаю обмен

Имеею S5W - программа под Windows и не каких проблем нет.