text

Download STEP7-Micro/WIN
Alexey Karzykov; 19.9.01

Откуда можно скачать STEP7-Micro/WIN ?

Re: Download STEP7-Micro/WIN
tЫndervald; 20.9.01

От верблюда...

Re: Download STEP7-Micro/WIN
Светлана; 27.11.01

http://www4.ad.siemens.de/csinfo/livelink.exe/fetch/8578380/STEP7-MicroWIN32_SP2.exe


Allen Bradley дискеты
Alex Ovchinnicov; 10.12.01

Приветствую! Может кто поделится дискетами активации для ПО RSView, RSLogic5. Уж очень хочется на кафедре в родном институте поставить ...


comet100
Vladimir; 26.3.01

Где достать программу "comet100" для программирования EPROM IM 308-3UA12?


GRAPH 5 если русский
Александр; 10.4.01

Стоит S5 V6.6 R ,а GRAPH только немецкий

если русская версия.
ST5r- при выводе на печать латинские буквы,
но по русски.Как избавиться от этого.
Александр.

Re: GRAPH 5 если русский
Mike; 26.4.01

О русском GRAPH5 не слышал, но вроде бы английский есть.


instruction wizard в Step7 Micro/Win32
Роман Чуликов; 27.2.01

Я понимаю,что такие вопросы как кде найти литературу по тому или иному вопросу вас уже достали все же решусь спросить по поводу более подробного описания instruction wizard,в Step7 Micro/Win32, а именно тот пункт в котором говорится по поводу выходного регулирующего воздействия (Аналоговый или Цифровой).Там всего лишь один цифровой выход, а что делать когда исполнительный механизм имеет два дискретных выхода на увеличение и на уменьшение управляющего воздействия?

Пожалуйста не оставляйте без внимания с уважением
Роман Чуликов
Re: instruction wizard в Step7 Micro/Win32
Андрей Гуленок; 27.2.01

Если интересует описание на русском языке, то его нет.

Описание на англ/нем есть во первых в самом визарде, во вторых во встроенной справке к STEPу. Сам визард, это ни что иное, как шаблон по заполнению "обвязки" команды PID регулятора. Эта команда подробнейшим образом рассмотрена в системном руководстве на страницах 9-89 по 9-103. Если не устраивает "продукт жизнедеятельности" визарда, пишите вручную. Эта команда гораздо более гибкая, чем то, что представлено в визарде.
Ещё можно посмотреть FAQи и примеры на немецком сервере, в разделе поддержки пользователей.


m_podjidaev@capcs.zsmk.ru
Максим Поджидаев; 3.8.01

Существуют ли версии OLE-DDE manager работающие под Windows 2000?

OLE-DDE manager
Максим Поджидаев; 7.8.01

Существуют ли версии OLE-DDE manager работающие под Windows 2000?

Re: OLE-DDE manager
Чистяков Дмитрий ОАО "СеверСталь"; 8.8.01

Я пока не встречал. А вообще, Siemens, как и все другие производители взяли курс на OPC сервера. Он и под 2к работает.

А развитие OLE-DDE возможно будет похерено, как и CP1413,CP5412. Хотя жаль, платы-то ведь имеются у многих пользователей и работают они нормально без проблем.
Re: m_podjidaev@capcs.zsmk.ru
Никаноров, Сименс; 13.8.01

Нет, не существуют.


MicroComputing для S7-200
Андрей Гуленок; 12.2.01

В разделе "О продуктах - Simatic S7 - документация" выложено описание пакета МicroComputing. Это собственно драйвер связи S7-200 <-> РС и набор анимированных объектов для встраивания их в другие приложения.


ProDave & PlcSim
Бисер Гидолов; 10.12.01

Можно ли использовать ProDave вместе с PLC-SIM?

См. http://www.econsulting.hit.bg


PRODAVE 95R
Н.Терещенко; 18.3.01

Откуда можно скачать сабж?

PRODAVE 94R (было PRODAVE 95R)
tnp@cit.poltava.ua; 19.3.01

Есть ли возможность скачать сабж? Адрес?


PRODAVE
ADG; 20.2.01

Спасибо за предыдущий ответ.

Подскажите возможно ли использование
PRODAVE Mini для целей передачи данных от контроллера в приложения (например с помощью DELPHI). По имеющейся у меня информации, отличие PRODAVE Mini от PRODAVE MPI в том, что он не поддерживает работу с Teleservice и не работает со словами данных ?
Re: PRODAVE
Никаноров В. - Сименс; 20.2.01

PRODAVE Mini служит для:

-чтения и записи блоков данных
-чтения информации о PLC (версия CPU, Firmware...)
Почитайте документацию (или каталог)
Re: PRODAVE
adg; 20.2.01

Будет ли работать PRODAVE если компьютер на котором он установлен будет подключен к S7 с помощью интерфейсного субмодуля IF 962-COM, а не через MPI. Возможно ли такое подключение.

Еще раз спасибо.


protokol RS232
Lekona; 9.2.01

kak napisat programmy , 4to by posilat, dannie 4erez com1 ili com2 porty ?

Re: protokol RS232
Maximka; 19.3.01

Открываешь описание протокола, берешь компонент Comm и в BCBuilder рисуешь программку. Или берешь WinCC - и там уже все есть ;)


S7 Routing?
Маруськевич Сергей; 13.2.01

CPU414-1 в количестве 4-х шт (каждый CPU находится в своей корзине; корзины находятся практически в одном шкафу) объединены между собой по MPI и ProfiBus (CP 443-5 Ext). В одну из корзин вставил CP443-1 и подключил ее в Industrial Ethernet (тип разъема RG-45). С удаленной РС, которая также подключена в эту-же Industrial Ethernet, я вижу только тот CPU, в корзину которой вставлен CP443-1. А остальные CPU (3 шт.) я не вижу. Вроде бы логично. Но тут случайно прочитал в Catalog IK10-1999 (Industrial Comminication) на стр.4/10, что можно увидеть с помощью S7 Routing все CPU. Что это такое и как сделать так, что бы я видел все 4 CPU? Поделитесь опытом.

С Уважением Маруськевич Сергей
АО СеверСталь
PS Этот вопрос также продублировал в форуме "Промышленные сети Simatic Net"
Re: S7 Routing?
Чистяков Дмитрий "СеверСталь"; 13.2.01

Сходите вот сюда:

http://www4.ad.siemens.de/news/cs/en/584459

Re: S7 Routing?
Чистяков Дмитрий "СеверСталь"; 13.2.01

А вот ещё более подробный пример реализации.

Его можно найти в службе поддержки (по предыдущему адресу)

Routing with S7 modules via MPI, PROFIBUS and Industrial Ethernet connections

Entry ID: 2383206


STEP 7
Баландин Дмитрий г.Пермь ЗАО Камасталь; 12.4.01

Имеется STEP 7 v.5.0 sp 3 и СP443-1EX10-0XE0 (TCP) , который отсутствует

в библиотеке STEP 7.
Как решить проблему ?

Re: STEP 7
Никаноров-Сименс, Москва; 12.4.01

ПОставить SP4, или использовать предыдущую версию модуля.

Re: STEP 7
Илья; 17.4.01

Подобная штука была с CP для PROFIBUS - вылечилась путем установки NCM for PROFIBUS. Вероятно, Вам надо установить NCM for Industrial Ethernet.


Step7 v5.1 и s7-226
Сергей Колмогоров; 9.10.01

Может кто подскажет...

Из Step7 v5.1 через MPI-карту CP5611 не могу соединиться ни по PPI, ни по MPI с S7-226.
А S7-315 вижу без проблем. С Step7 v5.0 такого не было.
Re: Step7 v5.1 и s7-226
Чистяков Дмитрий ОАО "СеверСталь"; 9.10.01

Так ведь там нужен STEP-7 Micro/WIN :-)

Со STEP 7 S7-200 работать не будет.

Re: Step7 v5.1 и s7-226
Сергей Колмогоров; 14.10.01

Извините за неполную информацию...

Нет связи из STEP-7 Micro/WIN SP2 при установленном Step7 v5.1. Когда стоял Step7 v5.0, то такой проблемы не было.
Re: Step7 v5.1 и s7-226
Чистяков Дмитрий ОАО "СеверСталь"; 17.10.01

Скорее всего у Вас сбились предустановки в Set PG/PC interface в следсвии того, что STEP 7 при установке их назначил по умолчанию.

Т.е. для Micro/WIN необходимо создать свою настройку, а для STEP 7 свою.
Re: Step7 v5.1 и s7-226
Сергей Колмогоров; 18.10.01

Прежде чем писать в форум, я перепроверил все настройки. Причем ситуация следующая:

Через PPI и последовательный кабель RS232-RS485 связь с S7-226 есть, а через MPI(или PPI) и CP5611 - как ни бился, связи нет. Попросил проверить эту ситуацию друзей на их машине в той же конфигурации - ситуация та же, связи нет.

Re: Step7 v5.1 и s7-226
Андрей Гуленок; 6.11.01

У меня версия STEP7 5,1 +SP1 и Микровин 3,1. Всё работает и через плату и через кабели, проблем никаких нет. Видимо дело в настройках.


STL Batch Compiler для S5-115F и S5-95F.
Dima U.; 27.3.01

Из мануала STEP 5/ST Ver. 7.1 (6ES5998-0MA24) не совсем ясно, можно ли использовать компилятор для написания Softa для контроллеров S5-115F и S5-95F помимо трех стандартных способов представления логики. Стоит ли пробовать? Или сразу забить на это? Заранее признателен за ответ!


WinAc и WIndows-2000pro
Григорий; 24.2.01

WinAC не желает устанавливаться под Windows2000,

-неподдерживаемый тип ОС. Есть ли заплатка для установки под 2000?


Библиотеки для автоматизированного проектирования
Тарасов Всеволод; 23.3.01

Подскажите, где можно скачнуть библиотеки Siemens`а для программ автоматизированного проектирования. Или найти информацию о них?


Булевские константы в STEP7v5
Андрей Таранов; 4.7.01

Как определить булевскую константу на входе блока FB41?

TRUE или 1 понимает только в представлении STL, в формат LAD не переводится
а в LADe не воспринимает ни FALSE, ни TRUE ни 0 ни 1.
как быть?
Re: Булевские константы в STEP7v5
Чистяков Дмитрий ОАО "СеверСталь"; 5.7.01

Обычно в начале скана программы забиваются две метки (меркеры), например, m0.1 и m0.0. Они приравниваются соответственно "1" и "0". А затем подставляются, там где надо. Можно так же в таблице символов вбить, что-то типа _0_, _1_


Вопрос новичка в STEP 5.
Vladimir; 4.4.01

Три строки из программы:

o M 43.3
UN M 191.1
= A 64.5
Так какая функция организована на выходе А 64.5 из входов M43.3 и M 191.1: "И" или "ИЛИ"?
При этом сигнал M 191.1 не встречается в программе в виде строки "= M 191.1 ", а указанное упоминание о M43.3 вообще единственное в тексте программы.
Re: Вопрос новичка в STEP 5.
Никаноров В. - Сименс; 5.4.01

1. Здесь реализована функция "И".

Первая команда в логической связке (в данном случае О) всегда просто опрашивает бит и устанавливает флаг VKE (RLO по англ.). А вторая команда связывает уже этот флаг VKE по "И" с UN M 191.1.
2. Если перекрестные ссылки по этим меркер-битам не показывают их использование, возможно, что они устанавливаются в составе байта (слова, двойного слова) или через косвенную адресацию. Возможно также, что они устанавливаются извне (например, с панели оператора или по сети).
В общем случае нужно смотреть программу.


Где можно взять STEP 5 ?
Sergey; 21.2.01

Скажите, пожалуйста, где можно взять STEP 5 ?

Re: Где можно взять STEP 5 ?
Андрей Гуленок; 27.2.01

Купить. Например на фирме Сименс.

Re: Где можно взять STEP 5 ?
Дмитрий Поединок; 7.4.01

А если негде купить? То где скачать?

Re: Где можно взять STEP 5 ?
Михайлин Сергей; 8.4.01

Как это негде? Вы хотите купить? Звоните нам или в наши представительства! SIEMENS продает везде! Судя по адресу почты, Вам проше обратиться в представительство в Казахстане, там это тоже есть.

А скачать официально нигде!!!
STEP 5 ? А НЕ ОФИЦИАЛЬНО?
AlexY; 26.4.01

А не официально где?

www.найди.сам ;-)
Михайлин Сергей; 28.4.01

Я не знаю. Может где-то на теневых сайтах. Хотя оооочень вряд ли.

бесплатно
Claus; 24.8.01

Сотрудничество должно быть взаимовыгодным!?!

Re: Где можно взять STEP 5 ?
Andrej; 27.8.01

Ну могу помочь...За пол-цены,или в обмен на STEP7(full)

Re: Где можно взять STEP 5 ?
Andrej; 27.8.01

Ну могу помочь...За пол-цены или в обмен на STEP7(full)

Можно взять
Морозов В.; 5.12.01

здесь

http://www.plcman.co.uk/

Только это старая версия и на некотрых кампутерах вываливается, при запуске, divide overflow error, но взять-то можно.


где можно скачать STEP 7 V5.1 SP1
Сергей Давидовский; 29.11.01

где можно скачать STEP 7 V5.1 SP1

Re: где можно скачать STEP 7 V5.1 SP1
Чистяков Дмитрий ОАО "СеверСталь"; 29.11.01

Сейчас его уже удалили с сервера поддержки пользователей. Летом (в августе он ещё там был). Но очень уж много тянуть надо было - чуть больше черырёхсот мегабайт.

Но самое главное, что скачав его, Вы не сможете им воспользоваться без авторизации. Авторизация от версии 5.0 не подойдёт.


Где скачать softwere на FM 357 ?
Михаил Загорный; 16.10.01

Где скачать softwere на FM 357 ? Нормальных представительств SIEMENS нет в радиусе 500 км. Если все таки заказывать это затянется на два месяца.

Re: Где скачать softwere на FM 357 ?
Чистяков Дмитрий ОАО "СеверСталь"; 17.10.01

http://www4.ad.siemens.de/news/cs/en/6510650


Где скачать STEP7-Micro/WIN ?
AlexeyK; 19.9.01

Где можно скачать STEP7-Micro/WIN ?

Re: Где скачать STEP7-Micro/WIN ?
Худяков А.Н.; 3.10.01

Намного проще обратиться в местное представительство SIEMENS (адреса см. на сайте) и там решить этот вопрос.

См. http://www.simpart.ru

Re: Где скачать STEP7-Micro/WIN ?
Alfonsino; 16.11.01

Eto (sory za lieksiku) adries, otkuda mozno skacat demo versiju Step 7 MicroWin. Iesli u tiebe rostut ruki tam, gdie nado, ty sumieies naiti put :)

http://195.146.64.23/ad/as/ru/forum/sw/index.html

Eto ja:
Ramioji2000@yahoo.com


графики в PID-control
Дехтярчук Павел; 9.2.01

Для Step7 V5.1 не могу активизировать графики в PID-control(FB41,FB42)

Start>Step7 V5.1>PID-control Parameter Assignment>Debug>Curve Recorder

Re: графики в PID-control
w_smirnov@hotmail.com; 3.4.01

Нужно работать on-line и все будет в порядке


Документация к STEP 7.
Зацев Дмитрий; 5.12.01

Подскажите пожалуйста где взять документацию по STEP 7. Очень нужно!

Re: Документация к STEP 7.
Чистяков Дмитрий ОАО "СеверСталь"; 6.12.01

На английском можно скачать от сюда

http://www4.ad.siemens.de/news/cs/en/1123338
http://www4.ad.siemens.de/news/cs/en/1129048
http://www4.ad.siemens.de/news/cs/en/1127178

Когда зайдёте туда, то увидите ещё охапку руководств.

На русском языке доступно в сети руководство
STEP7: Первые шаги
по адресу http://195.146.64.23/ad/as/ru/info/07_ind_soft/04_man/

Полный комплект документации на русском эзыке можно получить у представителей Siemens. Как это сделать почитайте здесь
http://195.146.64.23/ad/as/ru/support/doc.htm


Другие форумы
Шкенев Виктор; 14.4.01

Господа, подскажите, какие ещё есть форумы по

пром.автоматике, ибо не только Симатиком жив
человек, хотя именно он, трижды проклятый, дает
хлеб с маслом.


защита от копирования
Григорий; 16.2.01

Возникла проблема. Идет совместная разработка проекта в двух разных организациях для одного контроллера. Производится совместная пусконаладка.

Можно ли сделать так, чтобы моя часть была недоступна для выгрузки из контроллера после пусконаладки, т.е. ее нельзя было бы скопировать в другой контроллер?


Как добавить оборудование в каталог
Nechaev Alexey; 7.9.01

Здравствуйте!

Столкнулись со следующей проблемой:
в каталоге оборудования в Step7 v5.1 нет платы ASM470. В принципе догадались что нужно обновление для каталога, но где его найти или скачать не поняли. Если кто может объяснить где взять обновление помогите пожалуйста.

Заранее спасибо!
См. -

Re: Sorry! отбой.
Nechaev Alexey; 7.9.01

Не там искали!


Как распечатать таблицу символов на русском языке в S7
dmi3o; 20.6.01

Сами описания выглядят нормально, а вот в "Print preview" и на бумаге - @#$

Спасибо. Дмитрий
Re: Как распечатать таблицу символов на русском языке в S7
Андрей Рябов; 23.11.01

В реестре ->

путь:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage

изменить параметры:
1250 c_1250.nls на c_1251.nls
1252 c_1252.nls на c_1251.nls


Многопользовательская конфигурация SIMATIC Workstation
Владимир Данилов; 5.3.01

Как же все-таки работать с проектом нескольким пользователям? В хелпе указано только как конфигурировать станцию.

При этом какой из пользователей может загружать проекты в контроллеры? Только тот у которого установлена карта коммуникационного процессора (СР5611 или др.)? Если да, то какой во всем этом смысл?


Настройка иконок в панели инструментов Step7 версии 5.1
Nechaev Alexey; 17.10.01

Здраствуйте всем!

Не смог найти как добавить убрать иконки в панелях инструментов программ Step7 (LAD/STL Editor, Modify Variables и т.д.)
Неужели монстр в 150Mb не позволяет этого сделать?

С уважением Нечаев Алексей


Не устанавливается под Win2000RU SIMATIC S7 STEP 7 V 5.0 SP3 (V5.1)
Давыдовский Сергей; 23.11.01

Суть проблемы:

Программное обеспечение SIMATIC Software
SIMATIC S7 STEP 7 V 5.0 SP3 (V5.1)
От 11/99 F06 S79220-A5301-F000-01
Необходимо установить под операционную систему Windows 2000 (Рус);
Под ОС Windows 95/98/NT устанавливается без проблем, а под Windows 2000 – не желает.
Как решить данную проблему?

Заранее благодарен за ответ.
Re: Не устанавливается под Win2000RU SIMATIC S7 STEP 7 V 5.0 SP3 (V5.1)
Никаноров, Сименс; 23.11.01

Под Windows 2000 STEP 7 начинает работать с версии 5.1 SP1 и выше. А у Вас STEP 7 V 5.0 SP3.

Нужен апгрейд на 5.1.
Re: Не устанавливается под Win2000RU SIMATIC S7 STEP 7 V 5.0 SP3 (V5.1)
Юрий Оганесян; 26.11.01

А у меня V5.0 SP3 работает под Win2000,

Правда под Юзером не работал, а под Адванстнутым юзверем уже ОК.


отладка программы в STEP5
AlexanDer; 28.5.01

Есть STEP5 v7.11 и программа xxxxxxST.S5D на PC, кабель PC/TTY. Как программу засунуть в

S5 100U/CPU102 если на все попытки в режиме
TRANSFER переслать один отредактированный
блок ,STEP5 выдает :
"Block list does not exist in PLC" ?
Может PLC память очистить?

См. http://www.stroyfarfor.ru

Re: отладка программы в STEP5
Виктор; 28.5.01

А в ОВ1 он есть? А очистить PLC всегда полезно.

Если Вы в Москве позвоните 89021638664. Успехов.
Re: отладка программы в STEP5
AlexanDer; 29.5.01

Если подробнее,то...

Я скачал сначала все(All)блоки в xxxxxx.s5d ,
затем в скачанном блоке PB14 изменил существующий вход на существующий маркер , а назад в ОЗУ PLC не могу его переслать ни в режиме FILE-BLOCKS-TRANSFER ,ни в режиме EDIT-PROGRAM BLOCKS.
Выдает :"Block list does not exist in PLC" .
Можно ли это сделать в режиме RUN PLC ?


ПИД-регулятор S7200-аналоговое регул.возд.
Романа; 26.2.01

Имеется исполнительный механизм МЭО-63,с аналоговым датчиком положения,который осуществляет открытие или закрытие дроссельной заслонки на всасе компрессора. Сигнал на открытие или закрытие заслонки является дискретной величиной.

Вопрос заключается в том, что каким образом можно с помощью програмного ПИД регулятора контроллера S7215 у которого регулирующее воздействие представляется аналоговой величиной заставить регулировать положение дроссельной заслонки.(Как в 300-ой серии SFB42)Может быть есть какие нибудь TIPсы на эту тему?

Re: ПИД-регулятор S7200-аналоговое регул.возд.
Никаноров В. - Сименс; 26.2.01

Не нужно дублировать один и тот же вопрос в разные разделы форума. В дальнейшем одинаковые вопросы будут стираться принудительно и без предупреждения.

Re: Прошу прощения
Романа; 26.2.01

Но все же прошу помочь с данным вопросом с уважением Роман.

Re: ПИД-регулятор S7200-аналоговое регул.возд.
Max; 1.3.01

Можно, но это уже извращение. Тут нужен позиционный регулятор.


ПОМОГИТЕ !
Aleksey; 17.1.01

Люди !

У кого есть документациа по Step5 на русском !
Очень нужна !
Re: ПОМОГИТЕ !
Никаноров В. - Сименс; 17.1.01

.

См. http://www.siemens.ru/ad/as/ru/support/doc.htm

Уважаемый Никаноров !
Aleksey; 23.1.01

Уважаемый Никаноров В. !

Не могли бы Вы подсказать мне, как можно получить
документацию по Step5 на русском языке в электронном виде. Я живу на Украине.Работаю на Одесской кондитерской фабрике. У нас много
оборудования фирмы Сименс и нет документации на
русском.
Можно ли скачать документацию с вашего сайта ?

regards,
Aleksey
Re: Уважаемый Никаноров !
Никаноров В. - Сименс; 26.1.01

Вы можете скачать документацию на этом сайте.

См. http://www.siemens.ru/ad/as/ru/info/03_s5/04_man/


Помогите понять
Богатырев А.К.; 4.11.01

Есть САУ построенная на S7-400. Два оптоволоконных кольца Profibus-DP и оптоволоконное кольцо MPI. На операторских станциях используется WinCC. На операторских станциях с переодичностью в 15...18 мин постоянно выводится сообщение "Ошибка приема данных из САУ". В чем может быть причина. Посоветуйте.

Спасибо.
Re: Помогите понять
Чистяков Дмитрий ОАО "СеверСталь"; 5.11.01

Вот так вот прям по русски и пишет? ;-)

Во первых вопрос, связь с WinCC идёт через MPI?
Какой CP стоит в WinCC?
Какая там скорость, какое количество станций?
На чём оптика сделана (OLM/S3, OLMG/11 и т.д.), соответствуют ли переключатели на OLM-ке скорости обмена, включен ли на них режим кольца, длина линии, какой кадбель (и оптика, и медь)?
Имеются ли ошибки в буфере обмена CPU/CP? Если есть, то что пишет.

В общем куча вопросов возникает - по подробнее пожалуйста.


ПРОГРАММАТОР PG740
КОГАН ВАДИМ ; 18.4.01

В программаторе Сименс PG740 обломились контакты у трехвыводного элемента с

обозначением 1F s 99. (КОРПУС ПОХОЖЕ SOT23) Теперь не программируются ППЗУ.
Может быть кто нибудь подскажет, что это за элемент, где его можно купить
или чем заменить.


програмное обеспечение
Олег Карауш; 24.11.01

Ваше сообщение...

нужна программа simovis 6se3290-0xx87-8sa2
для sinematic s7-200
Re: програмное обеспечение
Худяков А.Н.; 26.11.01

Уважаемый Олег,

спрашиваемая Вами программа Simovis предназначена для осуществления обмена данными приводами и ПК через последовательный интерфейс RS232, считывания и загрузки параметров, управления приводами с ПК и не имеет абсолютно никакого отношения к упомянотому Вами PLC S7-200.
Сама программа Simovis может быть поставлена Вам на диске любым ближайшим к Вам отделением Siemens A&D.
Для большей информации позвоните нам по телефону (8462) 41-99-11


Продукт PRODAVE S7
ADG; 12.2.01

Помогите начинающим... Требуется снимать информацию с PLC S7-400 в компьютер и передавать в другое приложение. Используем функцию из DLL расширения: LOAD_TOOL.

Документация на английском. Помогите разобраться, что означают параметры данных функций.
Для LOAD_TOOL указатель на список адресов формируется как структура:
adr
segmentid
slotno
rackno
Что означает каждый из параметров и КАК ИХ ОПРЕДЕЛИТЬ на конкретном контроллере.

Re: Продукт PRODAVE S7
Никаноров В. - Сименс; 12.2.01

Все эти параметры - это параметры CPU, которые можно посмотреть в STEP7 в свойствах CPU и которые необходимы для связи.

-adr - == адрес процессора в сети MPI
-segmentid - ==0
slotno - ==номер слота CPU
rackno - ==0


Русификация S5 STEP 5-Basis V7.14
ОАО ЗФЗ, Чумак Тима; 8.8.01

Что требуется для русификации S5 STEP5-Basis V7.14 установленного на программаторе PG720 II. Возможно ли перевод комментарий к сетям и символики из S5DOS Ver.1.5 (корректный просмотр которых требует загрузки KEYRUS.exe) , а также выбор германской мнемоники как это сделано в STEP7 V5.1 (U E1.0 , A2.2).

С уважением Тимофей Чумак.

Re: Русификация S5 STEP 5-Basis V7.14
Никаноров, Сименс; 13.8.01

Нужно приобрести пакет русификации:

6ES5 894-0MA64-0UG5 - 428 EURO


русификация STEP5 V7.14
Александр; 26.2.01

Если русификация STEP5 V7.14

Где можно взять пакет GRAFH5.
PG только приобрели.
Re: русификация STEP5 V7.14
Павел Иванов (Сименс-Москва); 15.3.01

Русификация STEP5 V7.14 есть.

Номер для заказа: 6ES5 894-0MA64-0UG5.

GRAPH 5 тоже можно заказать:
Сам пакет V7:
6ES5 894-0MA04
и Функциональные блоки для ПЛК:
6ES5 848-7DA04


русификация STEP5 V7.14
Александр; 23.2.01

Если русификация STEP5 V7.14

Где можно взять пакет GRAFH5.
PG только приобрели.

Re: русификация STEP5 V7.14
Никаноров В. - Сименс; 26.2.01

Русификатор STEP5 7.1: 6ES5 894-0MA64-0UG5 - 428EURO.


Связь STEP5 v7.02 с PLC
Алексей Нечаев; 29.1.01

У нас возникла проблема при переходе с версии STEP5 v6.6 на v7.02 - не выходит в Online, выдается ошибка "PLC timeout!", хотя в версии 6.6

связь с контроллером есть. Программатор: Notebook Toshiba 1555CDS, CPU AMD K6-2 380MГц. OC : Win98SE.
Заранее спасибо.


Семейство Step7 под Windows 2000
Александр Родин, ООО "Нева Электрик"; 12.2.01

Возникли проблемы с установкой Step7 на машину с Windows 2000. Начинает ставиться нормально, но перед самым окончанием установки слетает, каждый раз с разными ошибками.

Устанавливаем Step 7 V.5 SP3
Конфигурация станции: CPU Intel Pentium III 650 MHz, Mb GYGABITE 6OXMM7 на Intel815, RAM 128 Mb PC133, SVGA Matrox G200 8Mb, ОС Windows2000 Pro

Вообще, хотелось бы побольше узнать об отношениях ПО Сименса с различным железом. В частности с новыми разновидностями чипсетов. А так же с какими ОС данное ПО возможно использовать.

И где можно найти необходимые Service Packs, Hot Fixes, etc ?
Читайте ReleaseNotes (внимательно!!!)
Никаноров В. - Сименс; 13.2.01

Step 7 V.5 SP3 не работает под Win2000, о чем написано, например, в ReleaseNotes файле.

Начиная с версии Step7 V5.1 SP1 разрешена работа под Win2000.
Получить информацию по текущим Service Packs, Hot Fixes, etc можно (и нужно) на сайте CustomerSupport, Германия (см. линк). Ну или набрать один из номеров телефонов службы техподдержки (в СПб тоже есть !!!).
Все достаточно просто.

См. http://www.ad.siemens.de/simatic-cse

Re: Читайте ReleaseNotes (внимательно!!!)
Чистяков Дмитрий "СеверСталь"; 13.2.01

К тому же новую версию STEP7 5.1 SP1 можно скачать с немецкого сервера (400Мбайт). Или там же заказать CD диск.

Вот Адрес:

на сервере поддержки http://www4.ad.siemens.de/
Service Pack 1 zu STEP 7 V5.1 Professional Edition 08/2000

Beitrags-ID: 6440922
Datum: 22.01.2001


Симулятор S7-PLCSIM
Андрей Попов; 29.6.01

При разработке программы симулятора объекта управления столкнулся с такой проблеммой - ActivX ProSim который поставляется вместе с симулятором S7-PLCSIM позволяет работать только с входами и выходами контроллера, для иммитации же С7 необходимо иметь возможность писать из своей программы в область маркеров и в блоки данных эмулируемого контроллера. Подскажите как можно это сделать.


Симулятор S7-PLCSIM
Попов Андрей; 29.6.01

При разработке программы симулятора объекта управления столкнулся с такой проблеммой - ActivX ProSim который поставляется вместе с симулятором S7-PLCSIM позволяет работать только с входами и выходами контроллера, для иммитации же С7 необходимо иметь возможность писать из своей программы в область маркеров и блоки данных эмулируемого контроллера. Подскажите как можно это сделать.


Фаззи- и нейрорегуляторы под Windows 2000/NT
Eugene; 18.11.01

Пакеты Fuzzy Control ++ и Neuro Systems, успешно работающие под Windows 9x, под Windows 2000/NT не закачивают сконфигурированные блоки данных в контроллер. Приходится ради этого держать две операционных системы на программаторе. Пробовал различные коммуникационные процессоры, ставил для них последнее ПО - не помагает. Что за проблема у SAPI с Windows 2000/NT? Существуют ли какие либо заплатки? Почему вышеуказанные "наукоемкие" пакеты не сохраняют блоки данных в проект STEP7, как пакеты ПИД-регуляторов? Когда планируется выход новых версий?

Re: Фаззи- и нейрорегуляторы под Windows 2000/NT
Никаноров, Сименс; 20.11.01

ПОд Win2000 и не должно работать.

А под Win9x/NT - все Ок.
Softnet Вам нужно поставить соответствующий, вот и все.
А в блоки данных STEP7 не сохраняют, потому что эти пакеты могут работать вообще без STEP7.
Re: Фаззи- и нейрорегуляторы под Windows 2000/NT
Eugene; 25.11.01

Что значит - не должно? Пакеты - последний писк моды, а между тем никакого развития до сих пор нет (кроме заплаток под WinCC разных версий).

Под WinNT пакеты не работают, библиотека S732.DLL ищется в каталоге Softnet для Win9x, а при создании такой же папки и при копировании туда S732.DLL от Softnet для WinNT - программы "выполняют недопустимую операцию".
А по поводу работы "без STEP7" - кому это все без STEP7 нужно? Нелогично как-то запрещать загрузку блоков данных традиционным способом.
Re: Фаззи- и нейрорегуляторы под Windows 2000/NT
Никаноров, Сименс; 26.11.01

1. По поддерживаемым ОС см.файл Readme.

2. По заплаткам к WinCC- это не заплатки, а библиотеки интеллектуальных Fuzzy и Neuro объектов к разным версиям WinCC.
3. Под WinNT пакеты работают. Местоположение библиотеки Softnet можно указать.


Я не одинок
Роман; 31.1.01

Как настроить русский шрифт в символьной таблице MicroWin32 v. 3.02? Если не знаете то тоже дайте знать.

Заранее спасибо Роман
Re: Я не одинок
Андрей Гуленок; 31.1.01

Простого пути нет. Там используется какой-то системный шрифт из Windows, который не кирилизован. Может его и можно подменить, но не понятно как.

Re: Я не одинок
Eugene; 1.2.01

Для воспроизведения русских букв в

нелокализованных програмах необходимо, чтобы
последняя работала с кодовой таблицей 1251.
Для этого в реестре изменяется соответствия
между кодовой страницей программы и
используемым при отображении символов файлом
кодовой таблицы.

Изначально они соответствуют друг другу:

HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Control\Nls\CodePage

1250 = с_1250.nls
1251 = с_1251.nls
1252 = с_1252.nls
...

Большинство нелокализованных программ
использует в качестве кодовой страницы
альтернативного языка страниу 1250.
При этом вместо русских букв выводятся символы
европейских языков с надстрочными знаками.
Данная операция позволяет обмануть программу и
подставить в ее родную кодовую страницу таблицу от кодировки 1251 (кириллица).
В итоге запись в реестре будет выглядеть так:

1250 = c_1251.nls
1251 = c_1251.nls
1252 = c_1252.nls
....

Программа будет нормально воспроизводить
русские буквы.

Есть "продвинутые" программы, использующие
кодовую страницу 1252.
В этом случае корректируется строка

1252 = ....

Если Вам попалась более хитрая программа, то
можно попытаться изменить другие таблицы, для
чего достаточно расставить галочки в нужных
местах.

В системе Windows NT помогает следующее
изменение ключа

HKEY_LOCAL_MACHINE\SOFTWARE
\Microsoft\Windows NT\CurrentVersion\FontMapper
Установить параметр
DEFAULT=0xcc (204) вместо 0x00
(Именно DEFAULT, а не Default).

Попробуйте, должно получиться, но на всякий случай запишите предыдущие значения ключей для "отката".

Русские буквы
Андрей Гуленок; 5.2.01

Очень дельное замечание. После замены ключа в реестре, в системе NT-4анг. появились русские буквы. Под WIN 98 рус ничего менять не пришлось, так как русские буквы были изначально.

MicroWin 3.1.1.6
Re: Русские буквы
Чистяков Дмитрий "СеверСталь"; 15.2.01

К сожалению это не всегда помогает.

Так есть проблема в пакете CFC, там в коментариях всё равно пишуться крякозяблики. И исчезает проблема, только тогда когда увеличиваеш план (схему, CHART) дважды.
Re: Русские буквы
shurik; 18.2.01

Шо за ерунда - не помогает (да и в принципе не может помочь)этот способ для правильного отображения букв в CFC ,т.к.используется галимый (матрица 7х8) нерусский шрифт из файла S7JCFCAX.FON.Так что меняйте файл (кстати могу дать его собственной обработки)

Re: Есть SP 1 для Micro/Win3.1 на нем. сервере
Чуликов Роман; 27.2.01

Service Pack 1 (V3.1 to V3.1.1) for STEP 7 Micro/WIN V3.1

http://www4b.ad.siemens.de/csinfo/livelink.exe/fetch/2995093/mw_service_pack.exe