text

AuthorsW_1
Диденко Е.; 5.7.02

Интересуюсь из чистого любопатства!

Можно ли установить авторизацию без программы AuthorsW, а просто скопировав с авторизационной дискеты необходимые файлы в каталог AX NF ZZ ( если уже он существует, т. е. если уже есть какая-нибудь авторизация )?

Re: AuthorsW_1
Юрий Оганесян; 5.7.02

Нет


AuthorsW_1
Диденко Е.; 5.7.02

Проблема: при установке авторизации ( на любой продукт Step 7, WinCC и т.д.) под ОС Win NT 4.0 или Win 2000 выдаётся ошибка ( "Текст сообщения( точно не помню) Err 0 ). Проблему удалось решить установив авторизацию с другого компьютера ( связанного с требуемым по ЛВС) из под Win 98. Процесс завершился нормально. Ответьте плиз - с чем это связано?

Re: AuthorsW_1
Гуленок Андрей; 11.7.02

Могу предположить физическое несоответствие пары дисковод-дискета. Либо флоп изношен, либо дискету "запилили" и она начинает сбоить. В первом случае надо сменить дисковод, но если эффект проявляется на разных дисководах то можно поменять дискету.

Re: AuthorsW_1
Диденко Е.; 12.7.02

На самом деле были опробованы и разные дискеты, и пробовали ставить на разные "тачки" - результат одинаков.

Re: AuthorsW_1
Чистяков Дмитрий ОАО "СеверСталь"; 12.7.02

Сей эффект просматривается на "хитрых" конфигурациях компьютеров.

Так, например, ко мне обращались с подобной проблемой. Люди купили Step7 и компьютер HP Vectra VL7 на базе чипсета от SIS. Так вот ни в какую авторизация не ставилась с дискеты. Помогло только подключение сетевого диска.
Вывод. Не берите "хитрых" компьютеров. Будьте проще - покупайте чипсеты от Intel.
Re: AuthorsW_1
Рябов Андрей; 12.7.02

У меня на PG 740PIII подобная же проблема. Тоже видать хитра машинка :)

Re: AuthorsW_1
Диденко Е.; 15.7.02

Да, Дмитрий, возможно Вы и правы! У нас как раз компьютеры HP Vectra PC VL800 и чипсет от SIS. Однако ж "как всё запущено"...

Re: AuthorsW_1
Чистяков Дмитрий ОАО "СеверСталь"; 15.7.02

Проблема в том, что у SISовского чипсета какой то хитрый мост стоит. А AuthorsW лезет к регистрам контроллера. Почему SIS сделал не стандартный конроллер флопика - это вопрос к ним.

TO Рябов Андрей
А у Вас как раз случай с грязными головками дисковода. ;-)

Re: AuthorsW_1
Рябов Андрей; 15.7.02

Должно быть Wынь2000 так гадит, ведь под 98-ми все работает. Опробовано на 4-х разных машинах (с Win2000) и везде одно и то же. А вообще есть ли прецедент, где бы авторизация нормально ставилась под Win2000?

Re: AuthorsW_1
Андрей Гуленок; 16.7.02

Да, есть. CELSIUS 400 под столом стоит. Нормально всё живёт под Win2000

Re: AuthorsW_1
Чистяков Дмитрий ОАО "СеверСталь"; 17.7.02

Аналогично - всё работает и под W2k Prof и W2k Server


COM PROFIBUS
Алексей; 25.11.02

Хотел бы узнать где и как можно взять

пакет COM PROFIBUS V5.1 для IM-308C.


Field PG & NT4
Дмитрий ; 27.8.02

Имеется программатор Field PG. Поставка шла с WinME!!!? При установке NT4 не нашлись драйверы на видео, звук, и т.д. Может быть, кто нибудь сталкивался с такой проблемой? Помогите, буду очень признателен. Дмитрий.

Re: Field PG & NT4
Eugene; 28.8.02

Была такая проблема. Драйвера нашлись на диске с драйверами для POWER PG (Backup PG 07/2001, возможно есть и новее). Да и на драйверном диске для SIMATIC PC кое-что найти можно.

Re: Field PG & NT4
siemargl; 3.9.02

В заказном номере кодируется, с какой ОС поставлять (NT4, W2K, WMe). Что заказали, то и получили ;-)


Field PG и ULTRA ATA
Дмитрий; 29.10.02

Имею Field PG с HDD Futjitsu MHM2200AT,

который поддерживает ULTRA ATA.
Field PG с WIN2000 показывает что IDE контроллер работает в режиме MultiWord DMA 2.
Чипсет Intel 82801BA вроде как поддерживает ULTRA ATA, но при
установке стандартных драйверов от Intel программа установки говорит что не нашла чипсет 800х, хотя например видео драйвер от Intel установился.

Вопрос, можно ли включить режим ULTRA ATA на Field PG ?


field PG
олег; 18.5.02

куда делись field PG? их что перестали выпускать? я на сайте ничего не нашел...

Re: field PG
Павел Иванов (Сименс-Москва); 18.5.02

Информация по ним находится в разделе:

Продукты - PC-based Automation

См. http://www.aud.ru/as/products/06_pc/02_pr/index.shtml


FM453
Петров Владимир; 19.3.02

У кого есть рабочий пример или проект для модуля FM453 в варианте с панелью оператора ОР37_Pro. Нужны стандартные видеоформы (маски) для OP37_Pro. Имеющиеся видеоформы для OP37 при переносе на OP37_Pro теряют часть своего содержимого.


MAX
Авторизация с ext.FDD; 22.5.02

Можно ли использовать для установки/снятия авторизации внешний FDD ( USB ) , внутренний отсутствует на notebook-е. Если да, то какие могут быть подводные камни (пр: тип FDD, драйвера и т.д.)

Re: MAX
Михайлин Сергей; 29.5.02

Начиная с версии AutorsW авторизацию можно поставить с любого диска обозначенного в комьютере(хоть с сетевого) и никаких траблов замечено не было.


memory error in PLC
Андрей; 18.10.02

Возникла необходимость подправить болок FB. Раньше получалось без проблем и не раз, а сейчас после исправления и записи в память появляется сообщение о том, что не хватает места и предлагается провести компресию памяти. Я подверждаю, появляется сообщение "Compressing completed". Я опять подверждаю, и появляется сообщение "Memory error in PLC". Контроллер работает, но блок так и не получилось подправить. PLC S5-135U. Пробовал проводить компрессию памяти в режиме старт и стоп, никакой разницы. В чем может быть проблема?

Заранее блогодарен.
Re: memory error in PLC
Alex; 18.10.02

Может быть стоит попробывать стереть полностью (сделать общий сброс)и загнать заново программу уже исправленную.

Ну а так возможно у вас проблемы с памятью.
Re: memory error in PLC
AndyScher; 21.10.02

Уточните, какой модуль памяти используете.

Re: memory error in PLC
Андрей; 23.10.02

Плата процессора 6ES5-928-3UB21, но никакой модуль памяти не установлен. PLC постоянно включен через безперебойник.

Re: memory error in PLC
Андрей; 23.10.02

Плата процессора 6ES5-928-3UB21, но никакой модуль памяти не установлен. PLC постоянно включен через безперебойник.

Re: memory error in PLC
Сорокин В.; 28.10.02

Не работал с S5, но буквально недавно столкнулся с тем же на S7. Правильно, кончается загрузочная память процессора. Короткие FB качаются, а длинные нет. Попробуйте разрезать свой пополам. Или сотрите в памяти один корокий, закачайте длинный и потом назад стертый.

Re: memory error in PLC
Андрей; 31.10.02

Спасибо за предоставленную консультацию.

А проблема была в следующем:
На сколько я разобрался по описаниям, распределение памяти у моего котроллера следующее: 0000H-8000H - память пользователя, 8000H-DD80H - память блоков данных, далее не важно...
А на самом деле блоки OB,PB,FB,FX грузяться в 0000H-8000H, а DB,DX в 0000H-DD80H.
Вот и получилось, что перезаписывая блоки данных, я заполнил область памяти для OB,PB,FB,FX.
Пришлось стереть всю программу; записать блоки OB,PB,FB,FX; перезаписывать произвольный блок (кроме блока дынных), до тех пор, пока не заполниться вся область до 8000H; записать блоки данных(они пишутся в область 8000H-DD80H); выполнить компрессию памяти.
Неприятность заключается в том, что если опять возникнет необходимость переписать блок данных, он опять пишеться в область блоков OB,PB,FB,FX (0000H-8000H).

Это нормально?


Modular PID Control
Влад; 17.5.02

Задача: поддержание температуры в отопительной системе. На паровой трубе перед теплообменником стоит электрогидравлический сервопривод с датчиком положения, который управляется блоком LMNGEN_S. Время от времени PID перестаёт реагировать на изменения температуры и сетпоинта. Например клапан открылся на 100%, температура поднялась значительно выше сетпоинта а PID всё равно держит клапан на 100%.

Подскажите в чём тут проблема или где можно найти подробное описание Modular PID Control и 3-step controllera желательно на русском.

Re: Modular PID Control
Михайлин Сергей; 19.6.02

Смотреть проект надо. Есть возможность передать? А доку по ModPIDCtrl можно либо скачать с немецкого сайта поддержки или получить у нас(СД или мылом). На русский она пока не переведена.


OB в Step7
Пименов Денис; 27.6.02

Никто не подскажет, каким образом будет вести себя программа контроллера, если сделать доступным на какое-нибудь прерывание OB (организационный блок), но тело программы этого блока оставить пустым. Контроллер перейдет в режим Stop или сработает прерывание (но выполняться ничего не будет) и дальше программа возобновится с точки срабатывания прерывания?

Re: OB в Step7
Андрей Гуленок; 27.6.02

Ничего не будет. Будет вызван соответствующий ОВ, но поскольку он пуст никаких действий производится не будет и управление вернётся обратно в ОВ1


OPC Server ???
Aleksey; 24.5.02

Люди! Подскажите, плиз, где скачать Siemens OPC Server для работы с S7 и S5 c помошью Send-Receive через Ethernet. А то на имеющемся в наличии диске есть OPC только для работы по Profibus

Re: OPC Server ???
Павел Иванов (Сименс-Москва); 28.5.02

Если у Вас официальный диск SIMATIC NET, то на нем находятся OPC-сервера как для Profibus так и для Industrial Ethernet

Re: OPC Server ???
Aleksey; 28.5.02

Спасибо нашли.

Но вопрос как правильно запараметрировать связь с S5 c помошью функций Send-Receive.Может есть какая
программа или подробное описание.

Re: OPC Server ???
Павел Иванов (Сименс-Москва); 29.5.02

Есть диск Quick Start, на котором содержатся примеры готовых сетевых проектов для различных вариантов сетевых конфигураций.

Этот диск есть во всех региональных бюро фирмы Сименс и у большинства наших партнеров (системных интеграторов).


PDIAG
Mike Lourier; 29.11.02

где можно почитать о возможностях этого пакета, и т.д.?

Re: PDIAG
Чистяков Дмитрий ОАО "СеверСталь"; 2.12.02

На русском в кратце

http://www.automation-drives.ru/as/products/07_is/02_pr/04_PDiag+ProAgent_r.pdf

На английском - подробно
http://www4.ad.siemens.de/news/cs/en/1137078


PG605U
Алексей; 15.2.02

Случайно оторвали разьем

на кабеле прогроматора PG605U.
Может кто подскажет его распайку.

Re: PG605U
Чистяков Дмитрий ОАО СеверСталь; 19.2.02

Возьмите описание PG на английском (немецком)языке с сайта поддержки по адресу

http://www4.ad.siemens.de/news/cs/en/1199173
Или напишите мне - вышлю по почте 882кБ
Re: PG605U
aim; 21.2.02

Дайте угадаю с трёх раз - наверное не хватает 15-ти пиновых разъёмов ;-)))

Кстати - в описание ничего нет про распайку.


PID control(fb41)
Роман Стадник; 11.9.02

Интересует такой вопрос: в блоке есть вход I_ITL_ON и, соответственно, I_ITLVAL. Как они конкретно работают?

И еще: в ПИ регуляторе пропорциональная часть gain=990, а время интегрирования IT=5c. Имеет ли вообще смысл интегральная часть в данном случае.
Заранее благодарю откликнувшихся.
Re: PID control(fb41)
Евгений; 20.9.02

Включение/выключение интегральной составляющей и её величина соответственно.

На мой взгляд такое огромное значение пропорциональной составляющей "нивелирует" интегральную, хотя она и влияет всё равно. А вообще настройка регулятора отдельная большая история.


PID(FB41)
Роман Стадник; 11.9.02

Интересует такой вопрос: в блоке есть вход I_ITL_ON и, соответственно, I_ITLVAL. Как они конкретно работают?

И еще: в ПИ регуляторе пропорциональная часть gain=990, а время интегрирования IT=5c. Имеет ли вообще смысл интегральная часть в данном случае.
Заранее благодарю откликнувшихся.
Re: PID(FB41)
Eugene; 12.9.02

При I_ITL_ON = true значение интегральной составляющей инициализируется значением из I_ITLVAL. При снятии сигнала I_ITL_ON интегратор продолжает работать как обычно.

По поводу интегральной составляющей - тут трудно сказать без знания сути управляемого процесса. В большинстве случаев качество регулирования ПИ-регулятора лучше, чем П-регулятора (при правильном выборе коэффициентов, естественно).


PLC Simulation
Andrey; 1.3.02

Всем привет!!!!

Подскажите, где можно взять PLC Simulation (дополнительный пакет программ для тестирования программ
на имитируемом программируемом контроллере).
Re: PLC Simulation
Baby; 4.3.02

Привет, Андрей !

Стандартный ответ Siemens - купить у них. И они правы.
А так надо спрашивать может кто.....


PLC_SIM
Евгений; 17.7.02

Можно ли выводить сообщения пользователя с использованием SFC 52

-- работая с PLC_SIM
Re: PLC_SIM
aim; 17.7.02

К сожалению PLCSim не позволяет корректно использовать SFC ;-(

Re: PLC_SIM
Юрис; 17.10.02

На сайте www4.ad.siemens.de поищи на тему PLCSIM получишь много ответов.

На вопрос "Чем отличается PLC от PLCSIM?" точно есть ответ. Там описано какие системные функции поддерживает PLCSIM.


PLC_SIM
Евгений; 2.9.02

Подскажите пожалейста можно ли работать с функцией форсирования используя PLC SIM

спасибо
Re: PLC_SIM
Андрей; 9.9.02

В этой же теме хочу добавить вопрос: где взять документацию по Русски для PLC SIM? На страницах Siemensa я не нашел.А вообще вопрос Евгения меня тоже очень интересует, ответьте кто нибудь !

Re: PLC_SIM
Юрис; 17.10.02

Зачем Вам в PLCSIM форсирование? PLCSIM - зто же симулятор контроллера. Меняй из симулятора входы как тебе хочется, а выходы к оборудованию не подключены, поэтому форсирование выходов без надобности.


PLCSIM и WinCC
Гульнур; 10.12.02

Можно ли и как "подключить" проект WinCC к PLCSIM V5.x

Заранее благодарю за ответы

Re: PLCSIM и WinCC
Михайлин Сергей; 11.12.02

Можно через канал MPI из состава S7 Protocol Suit.


PLCsim
Sergey; 30.12.02

Нужен PLCsim не ниже V5.0+SP1+HotFix2

где можно взять у меня есть PLCsim V5.0


Restorator не сохраняет файлы
Илья Кл.; 2.12.02

Restorator 2.5x перестал сохранять отредактированные файлы.

При попытке сохранить их, ишет "Access violation at address 4027F5 in module 'RESTORATOR.EXE'. Write of address 8474600C".
Реинсталляция не помогает. Что делать ?

Re: Restorator не сохраняет файлы
Алексей; 3.12.02

Здраствуйте.

Я так понял вы пытаетесь что-то перевести этой программой.У меня есть
другая прога называется ResHacker.
Принцеп тодже вытягивать ресурсы и переводить,но попроще.Если надо пиши кину.


S7-313C DP и S7 v 5.0
Евгений; 26.7.02

Что нужно чтобы в конфигураторе S7 v5.0 SP4 появился процессор S7-313C DP

Re: S7-313C DP и S7 v 5.0
Михайлин С.; 26.7.02

Надо провести апргрейд STEP7 до v.5.1+SP2 как минимум. В вашем случае надо получить пакет апгрейда.

Заказной номер апгрейда с любой версии до актуальной 6ES7810-4CC05-0XY4.

Re: S7-313C DP и S7 v 5.0
Евгений; 10.9.02

Что означает получить -купить или скачать


S7-314 и OP7
Андрей; 13.7.02

Есть S7-314 и OP7. Никогда этим не занимался но решил прочитать записанную в PLC программу. PC adapter подключил не отключая OP7. Включил машину, включил компьютер. PLC перешел в режим RUN, а OP7 продолжал тестироваться по кругу. Step7 не смог связаться с PLC.

Откинул OP7. Программу прочитал. Оказалось у PLC MPI адресс-7, у программатора-1.
При подключении OP7 без программатора, OP7 так и не запустился.
Почему пропала связь PLC c OP7? Есть подозрение, что кто-то потерял настройки интерфейса. У нас четыре одинаковые машины, можно прочитать настройки с них. Как это сделать?

Re: S7-314 и OP7
Андрей; 14.7.02

Извините, все работает!!!

Все четыре машины были зязаны в сеть, и именно эта одна не запускалась без других. Остальные могут работать самостоятельно.
P.S. 13 число - плохой день.


SCL, FB и DB
Иван Данилушкин; 26.7.02

Скажите, пожалуйста, есть ли способ автоматически "пересоздавать" DB-шки, привязанные к FB (referencing a function block) в случае, когда FB программируется на SCL?

Пока ничего лучше, чем убить все DB-шки и заново их создать в DB Editor после изменения секции VAR .. END_VAR в исходниках SCL в ручную я не придумал :(
Re: SCL, FB и DB
vzozulja; 30.7.02

Эл-но. Определить/описать блок данных в тексте после FB. При каждой компиляции и пересоздается.

SCL, FB и DB
Иван Данилушкин; 31.7.02

А нельзя ли какой-нибудь пример определения блока данных после FB на SCL?

Re: SCL, FB и DB
Иван Данилушкин; 31.7.02

Сам разобрался:

function_block FB1
var
x: real;
end_var
begin
x := 0.0;
end_function_block

data_block db1
FB1
begin
end_data_block

Большое спасибо !!!


SFB34
Сергей; 14.8.02

Здравствуйте.

Наверно вопрос тривиальный, а ответ где-то рядом. Раньше пользовались исключительно Transfer...:(, а сообщения параметрировались из CFC путем настройки подменю messages в вызывающих блоках :(. Если делать вручную, то:
1.Как генерируются номера сообщений, точнее, как правильно к ним привязаться в Alarm Logging (Transfer рождал какие-то невероятные ID)
2.Висит проблема связи (error - 1, status - 1)В самом блоке параметр ID - канал данных для сообщения. Из каких соображений, и какие особенности?
Может это вообще кривой подход, а transfer - лучший друг программиста?


SFB41
Тулупова Виктория; 20.2.02

Могу ли я, имея два контроллера CPU-314 и CPU-315,

использовать в целях унификации функцию непрерывного регулирования
SFB41 (встроенную только в CPU-314)?
Первые опыты оказались вроде бы удачными...

Re: SFB41
Михайлин Сергей; 21.2.02

Можно. Эта функция везде есть в процессорах выше 312. Только в 314 это SFB41, а в остальных просто FB41.


Simatic S0
Петр Герасимов; 21.6.02

Меня интересует совместимость Simatic S0 с Windows XP Professional Edition. Где можно найти информацию на эту тему?


Step 5
Сергей; 17.4.02

Что значит при програмирование на Step 5 НОМЕР БИБЛИОТЕКИ

Re: Step 5
Александр Туманов; 6.5.02

Нсколько я могу вспомнить STEP5 (в 1996 - 2000 г.г. я проводил курсы по STEP5), номер библиотеки - это просто метка (номер версии, например) для идентификации блока, т.е. его можно игнорировать, можно писать - как нравится. Для "фирменных" блоков по номеру библиотеки можно, видимо, получить искомый блок.


Step 7 под Win XP?
Ruslan; 1.12.02

Как поставить SIMATIK 8/2000 Professional под Windows XP ?

Re: Step 7 под Win XP?
Дертунов Борис; 6.12.02

Чтозначит SIMATIK 8/2000 Professional?

Step7 V5.1SP3 как часы работает, даже S5 удалось, а 8-ой для чего используется?
Re: Step 7 под Win XP?
Nec; 6.12.02

Скорее всего имелся в виду диск "Backup PG 08/2000". Не знаю как на ХР, а на 98 и 2к все ставится.

P.S. Если ставите не на PG - не пользуйтесь стандартным установщиком всего диска, а зайдите проводником в каталог Software, далее в каталог нужного приложения и запустите Setup.exe оттуда.


Step 7. Печать SCL по русски!!
Григорий; 18.5.02

Поблема тут у нас возникла!! Появилась необходимость распечатать STL файлы.

Благо их немного, пишем в основном на STL. Но русские комментарии Step отказывается печатать!! Даже в предпросмотре показывает нечитабельные значки. В Options->Customize->Editor все установлено как надо. Кто знает Что ему надо?? Работаем под NT4.

Re: Step 7. Печать SCL по русски!!
Максим Елхов; 11.7.02

Поменяйте драйвер принтера на какой-нибудь встроенный из Windows


Step 7. Функция Force
Андрей; 9.9.02

Step 7 позволяет с помощью функции Force подавать в реальный PLK входные сигналы, которых на самом деле нет.А можно ли делать тоже самое из WinCC с целью отладки PLC?

Re: Step 7. Функция Force
fog; 10.9.02

Два способа отладки:

1. Отладить программу ПЛК на столе без "железа" с помощью PLCSim, WinCC и STEP7.
2. На "железе" в программе ПЛК подменить адреса всех входов на адреса в блоках данных, которые и изменять из WinCC, а после отладки выполнить обратную подмену.
Re: Step 7. Функция Force
Андрей; 10.9.02

Минусы варианта 1:

а)PLK SIM не полностью имитирует контроллер;
б)при использовании PLK SIM нужно вручную задавать значения на входы и т.д., а если программа писалась для объекта в 1000 сигналов то вручную их не очень то попроверяешь.Есть вариант написать (например в WinCC c использованием программирования) программу позволяющую автоматом воздействовать на контроллер, но не хватает этой самой функции Force, (которая есть в Step 7 и позволяет блокировать входы контроллера).
Минусы варианта 2:
а)При подмене адресов нужно перелопачивать всю программу, где упоминаются эти адреса! А было бы так хорошо проверять связку PLC+WinCC с использованием (например второго компьютера) весь проект, не ломая при этом программу контроллера и WinCC.


Step5 V3
Игорь; 4.3.02

Как работать Step5 V3 на PC

Re: Step5 V3
Павел Иванов (Сименс-Москва); 12.3.02

Если мне не изменяет память STEP 5 V3 выпускался в 1991 году и работал он только на программаторах.

Есть текущая версия STEP 5 V7.2, она работает и на ПК.

Re: Step5 V3
Игорь; 15.3.02

Где можно приобрести Step 5 работающую на ПК.

Re: Step5 V3
Андрей Гуленок; 15.3.02

В представительствах Сименс или у наших партнёров. Адреса можно посмотреть на этом сайте.


STEP5
Алексей; 26.2.02

Люди может у кого имеется пакет S5W

или PG2000 Это аналоги STEP5
только под Win32.
подилитесь плиз.
Re: STEP5
Любитель СИМАТИКа; 6.3.02

Смотри вот здесь www.ibhsoftec.de

Извращение страшное!!!


Step7. Коментарии на русском
Олег; 19.4.02

В программе Step7. Редактирование текста комментария в окне Edit Symbols есть проблема, если он написан на кириллице, в окне не поддерживается русская кодировка приходиться все комментарии редактировать в окне Symbol Editor, здесь кириллица отображается правильно. Посоветуйте где поменять кодовую страницу.

Re: Step7. Коментарии на русском
Рябов Андрей; 22.4.02

Попробуй в реестре:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\CodePage
параметры:
1250 -> c_1251.nls
1252 -> c_1251.nls

Re: Step7. Коментарии на русском
Ефременко Денис, НКМЗ; 18.5.02

А еще проще используй программу lenrover (выслал тебе по почте).


Step7
Андрей; 21.5.02

Где можно скачать Step7. Купить не подходит.

Re: Step7
Baby; 22.5.02

Привет,Андрей !

Если купить не подходит -
поищи в инете альтернативные пакеты
для Step7.
Естественно Siemens не будет гарантировать нормальную работу оборудования.
Всё должно быть фирменным.....


WinAC RTX
Олег; 1.11.02

Могут ли WinAC RTX, и WinAC RTX ODK работать под управлением Windows 2000 или только под NT4.

Re: WinAC RTX
Юрченко Владимир; 13.11.02

В текущей версии (3.1) WinAC RTX может работать только под NT4.0 SP6 или выше.

В версии WinAC RTX 4.0, которая выйдет
в ближайшем будущем будет поддержка
Win2000 и XP.


WINCC и DDE
Роман Снегирев; 2.3.02

Как связать проект WINCC с проектом, написанном, например в DELPHI.

Re: WINCC и DDE
Максим; 7.3.02

Через OLE ;-) Могу выслать пример на билдере или дельфях

Re: WINCC и DDE
Роман Снегирев; 8.3.02

Если не затруднит, то жду с нетерпением. Еще одна просьба. При сжатии лучше не разбивать архив на диски и сделать саморазархивирующийся файл, а то почта Яндекса не любит почему-то такие архивы.

Огромное спасибо.
Re: WINCC и DDE
Максим Елхов; 11.3.02

Общая канва в CBB следующая

#include "ComObj.hpp"
//-------------------------------------
AnsiString __fastcall TForm1::GetValue(AnsiString p)
{
AnsiString v;
if(VarIsEmpty(mcp))mcp=CreateOleObject("WinCC-Runtime-Project");
if(!VarIsEmpty(mcp))v=mcp.Exec(Function("GetValue")<<p);
return v;
}
//-------------------------------------

(см.справку в WinCC ;)

Re: WINCC и DDE
Максим Елхов; 11.3.02

Конечно надо объявить

Variant mcp;
Re: WINCC и DDE
Ланна Розанова; 11.3.02

Максим, загляните, пожалуйста в почтовый ящик.

Спасибо.
Re: WINCC и OLE in Delphi
Максим Елхов; 20.3.02

Пример реализации на Delphi

implementation

{$R *.DFM}
uses ComObj;
var mcp: Variant;

procedure TWinCC_OLE.GetValueButtonClick(Sender: TObject);
begin
if(VarIsEmpty(mcp))then mcp:=CreateOleObject('WinCC-Runtime-Project');
if(Not VarIsEmpty(mcp))then Value.Text:=mcp.GetValue(Name.Text)
else ShowMessage('Нет связи с WinCC');
if (Value.Text='')then ShowMessage('Не могу получить данные');
end;

procedure TWinCC_OLE.SetValueButtonClick(Sender: TObject);
begin
if(VarIsEmpty(mcp))then mcp:=CreateOleObject('WinCC-Runtime-Project');
if(Not VarIsEmpty(mcp))then
begin
if (mcp.SetValue(Name.Text,Value.Text)) then ShowMessage('Данные установлены')
else ShowMessage('Не могу установить данные');
end
else ShowMessage('Нет связи с WinCC');
end;

procedure TWinCC_OLE.ExitButtonClick(Sender: TObject);
begin
Close;
end;

end.


АВТОРИЗАЦИЯ STEP 5 V7.1
АЛЕКСЕЙ; 10.12.02

КАК ВОССТАНОВИТЬ АВТОРИЗАЦИЮ ПАКЕТА STEP 5 V7.1

Re: АВТОРИЗАЦИЯ STEP 5 V7.1
Михайлин Сергей; 10.12.02

Либо надо ходить в ФАК, либо напрямую по ссылке

См. Тыч сюда


Авторизация
Дмитрий; 20.3.02

Господа, подскажите, где можно найти/приобрести авторизацию SIK/SIMATIC WINCC Modbus Serial? С уважением. Дмитрий.

Re: Авторизация
Михайлин Сергей; 25.3.02

Приобрести можно у нас(Сименс)! ;-)

Обратитесь в любое региональное бюро.
Заказной номер 6AV6 371-1CD05-0DX0
Стоимость 550Евро на границе Германии.


вопросы по SFC51, Halt-режиму
Григорий; 18.6.02

1.Не поможет ли кто с примером использования Sfc51 на SCL.

Не отказался бы и от примера SFC52
2.Хотелось бы организовать исполнение одной своей программы в halt-режиме. Можно ли это сделать каким-либо образом?


Где взять....
Ivan; 20.8.02

Вы не могли бы подсказать где можно в сети нарыть бесплатную документацию по step5 и step7. Помогите плиз. Если есть сайты посвяшённые этим вещям то всю доступную информацию шлите пожалуйста на vandos.mail@berlin.de

Спасибо зарание.
Re: Где взять....
Eugene; 21.8.02

Документация по STEP5/7 сейчас, насколько я знаю, вся бесплатная. А взять ее можно... Ну хотя бы на этом самом сайте.

http://www.automation-drives.ru/as/products/07_is/04_man/index.shtml
Re: Где взять....
oleg; 22.8.02

можно взять и на немецком сайте

http://www4.ad.siemens.de
в поиске набиваешь in russian

Re: Где взять....
Ivan; 22.8.02

Спасибо вам большое. Мне это очень помагало. Вот то что я нашёл на сайте на этом мне пока выши крыши для разбора :))) Ещё раз спасибо.


Документация на русском по SCL
Диденко Е.; 3.7.02

Уважаемые господа! Не подскажите ли где взять документацию по SCL на русском ( откуда можно скачать )!

А может таковой и нет ( не перевели ещё )?
Заранее спасибо!
Re: Документация на русском по SCL
Диденко Е.; 3.7.02

Может на www.aud.ru/as/products/07_is/04_man/index.shtml скоро появится?

Re: Документация на русском по SCL
Григорий; 6.7.02

На последнем CD с русской документацией (да и на предыдущем, только оно не в разделе SW.

Re: Документация на русском по SCL
Павел Иванов (Сименс-Москва); 9.7.02

Документация по SCL V5.1 была переведена на русский язык еще в прошлом году.

Она естьна диске с русской документацией.
На сайт просто не успели выложить.
В скром времени выложим.


документация по программированию
Сергей; 18.3.02

Подскажите начинающему, где можно достать (в электронном виде) документацию по программированию на STEP 7 и все что с этим связано.

А то проблема, человек, который за автоматизацию отвечал, ушел, и теперь мне приходится за это хозяйство отвечать, я в этом деле несилен. Поскажите кто чем может, с чего лучше начать изучение ? (система построена на SIMATIC S7-300 с процессором CPU 315). Спасибо
Re: документация по программированию
Чистяков Дмитрий ОАО СеверСталь; 18.3.02

А слабо было выбрать справа на страничке Industrial Software. ;-)

http://www.aud.ru/as/products/07_is/04_man/index.shtml

Re: документация по программированию
Сергей; 19.3.02

спасибо конечно, но может быть есть что-то типа 'пособие для начинающих'?

Re: документация по программированию
Чистяков Дмитрий ОАО СеверСталь; 19.3.02

Ну вот, по проще. :-)

Есть такой "букварь".
Напишите мне - вышлю по почте (2МБ).
Там некий филин в картинках рассказывает о программировании и контроллерах.
Сей документ имеется на бесплатном CD-ROM с русской документацией.
Его можно взять в ближайшем представительстве Siemens или у его дилеров
Re: документация по программированию
Сергей; 19.3.02

спасибо, такая уже есть :)

просто я сам по профессии программист, но на уровне железа никогда неприходилось программировать, да и в электронике тоже несилен, поэтому есть проблемы с пониманием, как же все это работает.
Re: документация по программированию
Чистяков Дмитрий ОАО "СеверСталь"; 26.3.02

Мм-да, Сергей. Как с Вами сложно. :-)

То Вам слишком сложно, то слишком просто.

А если серьёзно, то лучшее, что можно предложить - это проити курс по обучению на Simatic. Такие курсы сейчас имеется не только у Siemens`а. У нас, например, в Череповце даже в ТУ-34 есть такие курсы.

Второй вариант - это найти знающего человека и пригласить его в гости, угостить чем нибудь. И он Вам проведёт курс молодого бойца по программированию в Step7.

Третий вариант - это купить SCL (это паскаль для Step7) и это, может быть упростит Вам восприятие системы.

Хотя раз уж Вы по профессии программист, то принцип проектирования описан в файле Programming_r.pdf на CD-ROM с русской документацией.

Re: документация по программированию
Сергей; 26.3.02

спасибо :)


дополнительные пакеты под W2000
Павел Швецов; 5.3.02

Под операционной системой Windows2000 невозможна установка дополнительного программного

обеспечения для модулей интегрирующихся в пакет STEP7 V5.1: в частности, для функциональных
модулей автоматического регулирования "FM455S" и модулей "Siwarex U".
В связи с этим вопрос: как эту проблему решить? Или есть какие либо обновления? если есть, где взять?


Драйвер TELEPERM M
Дмитрий; 22.3.02

Господа, необходима информация по использованию драйвера TELEPERM M WIN CC/TM-OS OPTIONS (заказной номер по каталогу 6DL2203-.....-.....). Можно ли с его помощью производить визуализацию процессов системы TELEPERM M (шина CS 275) на станциях с WinCC? С уважением. Дмитрий.

Re: Драйвер TELEPERM M
Михайлин Сергей; 25.3.02

В принципе можно! Другое дело - практика. Насколько я знаю, в Краснодаре этим развлекались. Сейчас это больше относится к теме миграции TELEPERM M в PCS7. Почитайте для начала вот эту брошюру.

См. Качать брошюру


Драйвера для PG720 P2 под WIN2000
Sergez; 20.12.02

Нужны драйвера для программатора SIMATIC PG720 P2 под WIN200 где можно достать?


Еще о PLC SIM
Евгений; 19.7.02

Может кто знает почему PLC SIM нехочет

правильно работать с оператором LOOP,
то проходит хорошо то переводит эмулятор в STOP.Работаю в пошаговом режиме с точками прерывания.
Может какая нибудь установка неправильная?
Спасибо.

Re: Еще о PLC SIM
AlKu; 8.8.02

Может быть превышается максимальное время цикла CPU ?


Завороток мозгов STEP7 V5.0
Владимир Петров; 10.3.02

Происходит следующее: при переносе проекта с программатора на программатор иногда (что и обидно)теряется кодировка русского языка. В результате комментарии на русском языке изображаются незнамо как. Поиски ссылок на кодировку в реестре успеха не принесли. Может кто уже эту проблему поборол ?

Re: Завороток мозгов STEP7 V5.0
Максим Елхов; 11.3.02

Да, заменил Arial на Arial Cyr (прочие кодировки в нем отсутствуют). Если надо - пишите - вышлю директом.

Re: Завороток мозгов STEP7 V5.0
Владимир Петров, АО АВТОВАЗ; 11.3.02

Этот вариант пробовал в первую очередь. Корень проблемы, видать, глубже, но все равно, - СПАСИБО.

V.Petrov@vaz.ru
Re: Завороток мозгов STEP7 V5.0
Максим Елхов; 12.3.02

Корень конечно глубже - но решение с заменой щрифта помогает в 100% случаев - стоит ли копать? Кстати, а Вы пробовали печатать из Step7 всякие приблуды на русском? :-)

Re: Завороток мозгов STEP7 V5.0
Владимир Петров; 12.3.02

Так в том-то и дело, что не помогает! Дело доходило до того, чтобы восстановить проект, приходилось переустанавливать STEP.

Печать комментариев в таком же виде, что и на экране.
V.Petrov@vaz.ru
Re: Завороток мозгов STEP7 V5.0
Иван Данилушкин; 7.6.02

Возможно поможет следующее:

измените значение следующего параметра в реестре с "*_1252.nls" на "*_1251.nls". "*" зависит от версии Windows, и ее содержимое менять не нужно.
Адрес [HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ Nls\ CodePage]

Параметр 1252 (Строковый)

После этого, по крайней мере стало возможно скпировать русский текст из Notepad в редактор SCL. Правда, при печати, по-прежнему абракодабра

Успехов!


Загрузка DB в WinLC
Николай Федун, АО АНХК; 20.8.02

Здравствуйте!

Проблема у меня следующая. Для испытания алгоритма блокировки, написанного на LADDER'e, пытаюсь использовать WinLC. И WinLC не даёт загрузить в себя блоки данных. PCS7 v5.0 говорит "Unable to copy the block DB1". Номер DB допустимый. Все рекомендации из Help'а выполнены. Попробовал WinLC 1.0 - 3.0. То же самое. Может, проглядел чего в свойствах CPU? Прошу прощения, если вопрос слишком элементарный.

А PLCSIM использовать не могу, так как нет авторизации на него.

С уважением, Николай.
Re: Загрузка DB в WinLC
aim; 20.8.02

Ну да, грузить то можно, только режим надо поставить RUN-P

Re: Загрузка DB в WinLC
Николай Федун, АО АНХК; 21.8.02

Спасибо за ответ.

Я это пробовал в первую очередь. Извините, забыл сказать, что у меня WinLC DEMO. Только я нигде не могу найти описание отличий DEMO версии от "нормальной". При отсутствии авторизации вроде нет возможности грузить программу вообще, это понятно. Может, отказ в загрузке DB и есть одно из отличий?

С уважением, Николай.


Загрузка проекта при совместном доступе
Колесов Владимир; 31.3.02

Возможна ли загрузка проекта в контроллер CPU315 при совместном доступе к проекту с любой другой машины сети , а не только с той которая подключена напрямую к контроллеру (STEP 7 v.5.1)

Re: Загрузка проекта при совместном доступе
Михайлин Сергей; 2.4.02

Пожалуй, это возможно только в одном случае: когда контроллер сидит на той же Ethernet сети что и все другое станции и имеет свой уникальный TCP/IP или МАС адрес. А иначе никак... Я не знаю ни одной примочки к Виндам, которая бы делала роутинг между двумя сетевыми платами в РС.


ЗагрузкаNew и откат (Step7)
AlKu; 23.7.02

Прогружали новую версию программы - грузили папу Bloсks в CPU, версия не пошла и прогрузили из старого рабочего проекта Blocks (hardware не трогали) - программа начала "глючить" - мерцали сигналы на всех модулях DO. Что сделали неверно ?


Запрос CALL очень странный?
Popov V N; 23.10.02

В программе есть вызов

CALL
...
операторы
...
end CALL
Вызов естественно помечен как ошибка, но есть ли в этом смысл? Может кто подскажет. В документации ответ не нашел. Спасибо!


Защита программы
Евгений; 3.4.02

Подскажите как защитить от просмотра

FB в STEP 7
Re: Защита программы
Михайлин Сергей; 3.4.02

При создании блока использовать свойство KNOW_HOW_PROTECT. После компиляции такого блока, его тело нельзя будет посмотреть и поправить.

Далее смотри стр 8-13 русской документации по программированию на STEP7
Re: Защита программы
Андрей; 4.4.02

Спасибо Сергей, но проблема заключается в том , что данная опция не доступна( серая) уже при создании блока, а из документации не ясен сам механизм как установки так и снятия защиты (если такое возможно)

Re: Защита программы
Рябов Андрей; 4.4.02

В свойствах блока эта опция не доступна для изменения, она только показывает текущее состояние. Чтобы поставить защиту надо создать исходный файл (AWL) и там в описании свойств блока прописать KNOW_HOW_PROTECT. После компиляции этого исходника получите защищенный блок. (см. гл.11.2.5 руководства по программированию). Можно, конечно, и напрямую редактирую xxx.dbf установить/снять эту защиту, но это уже недокументированные возможности.

Re: Защита программы
Андрей.; 4.4.02

Спасибо Андрею :-)

А можно поподробней по поводу dbf. Уж больно много их, а какой конкретно имеется в виду, и что подправить?
А по поводу редактирования авл, уж больно на партизанщину смахивает ;-), но работает.


Изменение даты (Last modified) блоков в Step 7
Венский Мирослав; 5.6.02

Оборудование на гарантии но для нормальной работы мы должны делать изменения в Step 7 (недопустимо по гарантии). Какой програмой и каким образом можна изменить дату последней модификации блока.

Заранее благодарен.

Re: Изменение даты (Last modified) блоков в Step 7
Чистяков Дмитрий ОАО "СеверСталь"; 5.6.02

Измените время на машине со Step7 и сохраните блок.


Инсталяция ProTool/Pro
Пименов, Псковкабель; 14.10.02

Инсталировал Simatic ProTool/Pro Cs V5.2 SP2, Aug 4 2000 под Windows XP.

Инсталяция прошла успешно, но при запуске выдаются окна:
DDE Server Window ProTool.exe - Точка входа не найдена.
Точка входа в процедуру COMResModuleIntance не найдена в библиотеке DLL ComRes.dll. Что это может означать и будет ли далее ProTool нормально функционировать
С уважением Инженер-программист Псковкабель Пименов Вячеслав
См. http://(8112)-79-19-53

Re: Инсталяция ProTool/Pro
Сергей; 14.10.02

Все продукты от Сименса будут совместимы с ХР только в конце года. Возможно это сделают новые сервис паки.

Об этом было написано на одном из офиц. сайтов Сименса
Re: Инсталяция ProTool/Pro
Дертунов Борис; 6.12.02

У меня ProTool/Lite v6.0 от апреля 2002

работает нормально под ХР


Как восстановить ключевую дискету?
Иван; 22.8.02

Приобрели Step 5 v6.6, после первой установки авторизации всё прошло успешно. Но так как у нас уже есть Step 5 на PG 740, эта программа приобреталась как резервная для PC, авторизацию убрали обратно на дискету. После повторной установки авторизации на диск комп выдал проблемы с HIMEM, и завис. После перезагрузки, авторизации не оказалось ни на дискете, ни на ж.диске. Помогите, пожалуйста, подскажите куда обратится, и что нужно для этого? И как в последующем избежать таких вещей?

Re: Как восстановить ключевую дискету?
Чистяков Дмитрий ОАО "СеверСталь"; 23.8.02

http://www.automation-drives.ru/as/support/copy.shtml

Re: Как восстановить ключевую дискету?
Иван; 23.8.02

Огромное спасибо!!!


Как все ПО (Step 5,Step 7,ProTool,WinCC,Drive Monitor,SoftNet)работает под Windows XP+SP1?
Dmitry N.; 12.4.02

Как все ПО (Step 5,Step 7,ProTool,WinCC,Drive Monitor,SoftNet)работает под Windows XP+SP1?

Re: Как все ПО (Step 5,Step 7,ProTool,WinCC,Drive Monitor,SoftNet)работает под Windows XP+SP1?
Логинов Павел; 15.4.02

XP весчь канечна модная, однако не советую......

С S5 и её прибомбасами замучаятесь!!!
Re: Как все ПО (Step 5,Step 7,ProTool,WinCC,Drive Monitor,SoftNet)работает под Windows XP+SP1?
Dmitry N.; 16.4.02

А кроме Step 5, все что под винду предназначено, нормально идет?

Под W2000 вроде все работает.

Re: Как все ПО (Step 5,Step 7,ProTool,WinCC,Drive Monitor,SoftNet)работает под Windows XP+SP1?
Stah; 17.4.02

Эксплуатация Step5, Step7, Step7 micro, COM Profibus под Windows XP на Siemens Field PG в течении более полугода показала полное отсутствие каких-либо сбоев (в отличие от Windows 2000 professional). В то же время все попытки заставить нормально работать WinCC не увенчались успехом.

Re: Как все ПО (Step 5,Step 7,ProTool,WinCC,Drive Monitor,SoftNet)работает под Windows XP+SP1?
Мехти; 15.5.02

Лучше всего софты SIEMENS работают под NT4.0, т.к. писались под него.


Как работать с множеством однотипных сигналов на STEP7
Тулупова Виктория; 17.1.02

Подскажите новичку, как работать с множеством однотипных сигналов (например несколько десятков входных дискретных сигналов).

Можно ли для этого использовать массивы или необходимо применять какие-либо функции более нижнего уровня?

Re: Как работать с множеством однотипных сигналов на STEP7
Чистяков Дмитрий ОАО СеверСталь; 17.1.02

А что значит "работать с множеством однотипных сигналов"?

Если это просто пересылка, то стандартная функция SFB20 решит Ваши проблемы.

Уточнение вопроса
Тулупова Виктория; 17.1.02

Мне нужно опросить несколько групп дискретных входов и по каждой группе сформировать некоторое значение состояния группы.

Таких групп много и хотелось бы опросить все группы в одном цикле.
Подобная задача, но с аналоговыми входами - преобразование к физическим значениям измеряемой величины: для каждого канала заданы коэффициенты градуировочной характеристики. Неужели необходимо вызывать преобразование для каждого канала, задавая на входе значение измерит. кода и коэффициенты ГХ?
Re: Как работать с множеством однотипных сигналов на STEP7
Юрий Оганесян; 21.1.02

Есть несколько способов -

1 это создать свой тип данных (UDT), инкапсулирующий все сигналы и работать с ним
2 есть возможность шерстить массивы любых данных - внутри меркеров, внутри блоков данных, можно перебирать по порядку таймеры,счетчики и разные блоки данных. Конкретно эту одну цепь придется написать на ассемблере а остальные - (начало / конец цикла, реализуемые условными переходами, и т.д. )- на чем угодно. В мануалах косвенная адресация рассмотрена довольно подробно.
3 Использование мультиэкземпляров- т.е. когда один программный код трудится над разными блоками данных.

Не забывайте, что ещё жизнь может облегчить тот факт, что аргументом для функции может быть блок данных - чтобы не маяться по одному параметру.


конвертирование программых блоков написанных на SCL в формат STL
Шныренков Александр; 10.1.01

Есть ли возможность конвертировать блоки написанные на SCL в формат STL.

Re: конвертирование программых блоков написанных на SCL в формат STL
aim; 11.1.01

Ну вот, приехали. Ты чё, со степом не работал?

Ведь SCL блоки (написанные на языке "высокого уровня" ;o)) всегда можно представить в виде машинных кодов симатика, которые прекрасно мнемонически отображает STL.
Re: конвертирование программых блоков написанных на SCL в формат STL
***; 23.7.02

ПРИВЕТ, меня зовут Шныренкова Оксана

Мы не родственники?

См. ***

Re: конвертирование программых блоков написанных на SCL в формат STL
AlKu; 25.7.02

Пробовал так конвертировать - небольшой блок на SCL преврвщается в огромный кусок страшного STL-кода. Какой смысл этого преобразования ?


Можно ли так делать?
Ярослав Евдокимов; 6.12.02

Я нашел одну интересную возможность работы с FB. Вовсе не обязательно вызывать их с DB, а можно сделать следующим образом:

Исходник 1:
Function_block MyBlock1
VAR_INPUT
var1 : REAL;
var2 : INT;
...
END_VAR
VAR_OUT
out : REAL;
...
END_VAR
...
END_FUNCTION_BLOCK

Исходник 2:
FUNCTION_BLOCK mainFB
VAR_INPUT
...
END_VAR
VAR_OUT
...
END_VAR
VAR
...
block1 : MyBlock1;
block2 : MyBlock2;
END_VAR
...
block1(var1 := ..., var2 := ...);
block2(var1 := ..., var2 := ...);
... := block1.out;
... := block2.out;
END_FUNCTION_BLOCK

При этом нет необходимости назначать какие-либо DB, описывать их в таблице символов и т.п. Компилятор сам не создает никаких DB. Описанная структура нормально работает, при этом появляется возможность создавать что-то вроде объектов с нормально инкапсулированными данными, а не глобально видимые DB. Вопрос: что же на самом деле при этом делает компилятор, неужели динамически конструирует объекты в памяти? И вообще, я не нашел нигде описания такой методики, документирована ли она и не пробовал ли кто-то делать что-то подобное? Работает, повторюсь, нормально. Не только на WinLC, а и на реальном технологическом объекте.
Re: Можно ли так делать?
Илья; 10.12.02

До боли напоминает использование модели мультиэкземпляров. Что это такое и как его использовать описано в доках. Удачи!

Re: Можно ли так делать?
В. Сорокин.; 15.12.02

Может я не понял изюмины, но вызвать FB без DB:

UC FB...(где ... номер или имя)


Настройка PC-PG для PLCsim..........
Сергей Борисович; 14.8.02

Как настроить PLCSim так чтобы компьютер с сети MPI выполнял роль PLC????? (конкретнее точки доступа какие?????)....и второй вопрос....трабл при установке WINLC он ругается на SIMATIC NET (хотя SIMATIC NET нужен для работы карты CP5613_CP5614)????? Help me please !!!!

Re: Настройка PC-PG для PLCsim..........
Eugene; 16.8.02

Правильно ли я Вас понял: Вы не смогли поставить WinLC и решили заменить его PLCSim'ом?

А насчет ПО SIMATIC NET: так поставьте его, теперь оно абсолютно бесплатно, его наверняка может предоставить региональное представительство Siemens.

Re: Настройка PC-PG для PLCsim..........
Сергей Борисович; 19.8.02

Делал я наоборот.........установил PLCSim (нужен для отладки проекта операторской панели OP37)....не мог привязять его к MPI чтобы панель его видела....Установил кое как WinLC .... WinCC и STEP7 его видят...панель ни в какую (хотя PROTOOL нормально по MPI в панель проект загружает).......

Re: Настройка PC-PG для PLCsim..........
Павел Иванов (Сименс-Москва); 30.8.02

PLCSim не предназначен для отладки проекта ОР. Он используется для отладки проекта для контроллеров S7-300/-400/-C7


Не инсталлируется SIMATIC NET
Александр Туманов; 25.4.02

Не инсталлируется софт с диска "SIMATIC NET Networkingfor Industry PC/Windows 07/2001", заказной номер S7920-A5802-F000-01.

Пробовали ставить с двух разных фирменных дисков на разные ПК (Windows 2000 Proffisional и Windows 2000 Server)- выдаёт сообщение о внутренней ошибке № 2721. Кому-нибудь удалось корректно установить этот Software?
Re: Не инсталлируется SIMATIC NET
Павел Иванов (Сименс-Москва); 27.4.02

Да! Удалось!

Проблема с поддержкой русского языка, установленной у нас у всех в России.
Это с чем-то конфликтует.
Одно из решений убрать на время поддержку русского в ОС, проинсталировать ПО, восстановить поддержку.
Второй вариант, который использовал Дмитрий Чистяков (Северсталь) редактирование реестра, а именно переназначение кодовых страниц.


Не работает мышь в окне S5 под Win2k
Nec; 15.10.02

Почему-то не работает мышь в окне Step5 v7.2 под Win2000Pro и в FullScreen. Посмотрел все настройки ярлыка - там про мышь только один пункт во вкладке Misc, но его активизация не помогает. Мышь Microsoft с колесом, но и TouchPad не работает. Заранее, спасибо!

Re: Не работает мышь в окне S5 под Win2k
Alex; 15.10.02

А разве там удобно работать мышью?

Re: Не работает мышь в окне S5 под Win2k
Nec; 16.10.02

Конечно, в окне настроек или в диалоге копирования гораздо удобнее поставить пару галочек мышкой, чем перебирать поля Tab'ом а потом выбирать пробелом.

Re: Не работает мышь в окне S5 под Win2k
Alex; 16.10.02

Если ты работаеш с контроллером только через ком порт, то лучше используй версию 6.6 с ней работать приятнее.


не ставитится авторизация
Сергей С.А.; 25.3.02

Привет из Твери.Прошу ответить на мой вопрос . На авторизованный step 5.0 на программатор PG720 поставил upgrade step7 v5.1 Service Pack 2 +NCM S7 ,а авторизация step7 upgrade v5.1 6ES7810-4CC05-0YX4 (зеленый ключ)не ставится .Заранее благодарен за любую информацию.

P.S.Виноват я или немцы.
Re: не ставитится авторизация
Михайлин Сергей; 25.3.02

Зеленый ключ не надо ставить!!!

Надо на него встать и сказать через меню Autorization/Upgrade и отвечать на вопросы программы. Иногда спрашивает путь к этой программе. Тогда на дискете должен быть ехе-файл с соответствующим именем типа
UP 5.0->5.1.exe
Удачи и поосторожнее с этой процедурой, внимательно читай вопросы! ;-))
Re: не ставитится авторизация
Сергей С.А.; 26.3.02

Огромное спасибо за ответ!

Авторизация прошла успешно.
Возникает вопрос :каким образом переносить авторизацию на другие машины при необходимости.Заранее благодарен .
Re: не ставитится авторизация
Чистяков Дмитрий ОАО "СеверСталь"; 26.3.02

При помощи всё той же AuthorsW.

Либо через дискетку, либо по сети.
Но если Вас интересует вопрос, как разнести upgrade на все остальные машины, то надо было закупать количество апгрейдов по одному на каждую машину.


Неизвестная команда
Виктор; 18.7.02

Здравствуйте, господа.

Помогите, пожалуйста разобраться в следующем:
В Степ7 встретил такую команду
L B#(1,2)
Что она означает?

Re: Неизвестная команда
Андрей Гуленок; 18.7.02

После выполнения в левый байт аккумулятора будет занесена 1 а в правый 2.


Некорректная работа HiGraph
Сергей; 17.9.02

Написал на HiGraph 5.0 + SP1 функцию. В ней вызываю функциональный блок. Компилирую. В уставках компилятора стоит птичка "Generate referance data".

Просматриваю перекрестные ссылки и с удивлением нахожу вызываемый функциональный блок среди неиспользуемых в программе.
Открываю функцию редактором блоков, компилирую. Перекрестные ссылки сразу становятся адекватными. Получается, HiGraph некорректно генерирует перекрестные ссылки. Или как?


Необходима связь.
Лана Розанова; 19.7.02

Всем привет.

Возникла такая проблемма. В сети PROFIBUS две операторские машины. На одной из них умерла сетевая карта. Такой у меня больше нет. Можно ли выйти из положения применив на одной машине простую сетевую карту и связаться со второй машиной простым сетевым кабелем, а вторая так и будет соединена с контролером через PROFIBUS.

Кто может откликнитесь, пожалуйста. Потому что я совсем не зная что делать.
Заранее спасибо.
Re: Необходима связь.
Евгений Трунов; 19.7.02

Нет, так выйти из положения нельзя. Стать полноправным абонентом сети PROFIBUS, не имея соответствующего коммуникационного процессора для ПК, разумными средствами невозможно.

Re: Необходима связь.
Юрий Оганесян; 22.7.02

Можно пересмотреть весь проект и создать классичскую клиент-серверную архитектуру, но лишняя карточка не стоит такой работы :)

Re: Необходима связь.
Лана Розанова; 23.7.02

Спасибо всем. Но выход я нашла.

1. Перевела (не переделала) проект под мультисессию.
2. Машину, соединенную с контроллером обозвала сервером. С другой машиной она соединена через простую сетевую карту. В проекте сервера она добавляется как клиент.
3. Все поехало.

Re: Необходима связь.
Евгений Трунов; 23.7.02

Если Вам уже не до равноправия обеих рабочих станций, то вариант "клиент-сервер" - действительно выход из положения.


необходимые авторизации
Сергей; 2.8.02

Здравствуйте.

Подскажите пожалуйста, кто сталкивался, нужны ли лицензии на рантайм базовых, технологических и полевых блоков для PCS5.2?
В СА01 нашел только на технологические...
Re: необходимые авторизации
Михайлин Сергей; 6.8.02

Ну конечно нужны!!!! ;-) (по правилам)

Для 5.2 идут Runtime лицензии на технологические коммуникационные и driver блоки. Они должны быть на кждую станцию S7-400. А на самом деле это все только бумажки, которые подтверждают легальность вашего софта.
Если покупается сразу сборка AS, то все это уже включено, а если россыпью то докупать(если хотите). Но помните о злом дяде с проверкой! ;-)

Re: необходимые авторизации
Сергей; 7.8.02

Слова благодарности... ;-)


Ограничения на DIG_MON (FB62)
Андрей Петров; 27.5.02

При попытке прогрузки программы в S7-414-4H возникает сообщение о невозможности копирования далее DB блоков порожденных блоком DIG_MON (FB62), хотя DB другие продолжает копировать. Что в конфигурации контроллера может ограничивать их количество?

Re: Ограничения на DIG_MON (FB62)
Shurik; 28.5.02

Отстойнее контроллера еще мир не видывал!!!!! У него очень мало памяти программ для полноценной работы с PCS7. Вобщем У нас было то же самое,а надо в HARDWARE встать на CPU и сделать OBJECT PROPERTIES и далее в разделе MEMORY найти пункт MAXIMUM COMMUNICATION JOBS,это распределение буфера для коммуникациий,по умолчанию стоит 600,а надо увеличить сначала с запасом (до 1000) а затем уменьшать до необходимого значения.Удачи


описание протокола DUST6 (SIMADYN)
Анрей Усенко; 23.12.02

Необходимо описание протокола DUST6 для организации связи между модулями коммуникации CS41 и CS6.

Re: описание протокола DUST6 (SIMADYN)
Чистяков Дмитрий ОАО "СеверСталь"; 25.12.02

Описание самого протокола Вы вряд ли найдёте.

Описание же как запараметрировать в SCTRUC функциональные блоки для этих модулей, имеется в описании STRUC`а.
D7-SYS этих модулей не поддерживает.


Ошибка кадра при связи PC с SINUMERIK 8
DJ; 1.11.02

Я написал программу которая через RS232 связывается с ЧПУ (Shiron) Sinumerik 8.

Персонал вместо DNC терминала, подключает к станку Лаптоп и запускает программу.
При передаче информации в станок возникает ошибка "Ошибка кадра" или
"Кольцевая память исчерпана" (перевод с немецкого). Все параметры соединения
выставлены правильно, т.к. часть данных (до возникновения ошибки) попадает в ЧПУ,
и при просмотре, это подтверждается (текст передаваемой программы, верен).
В то же время при передаче тех же данных из DNC терминала в ЧПУ - все нормально,
ошибок не возникает. Не сталкивались ли Вы с подобной проблемой ?

P.S. Программа, без каких либо проблем, закачивает данные, в Fanuc 6,
получает данные из того же Sinumerik 8

icq#102880147


Пакет Step 5
Владимир Шулика; 19.1.02

Подсажите, где и как приобрести (скачать) subj? Необходим для некоммерческого использования.

Re: Пакет Step 5
Чистяков Дмитрий ОАО СеверСталь; 22.1.02

Приобрести можно у любого дилера Siemens.

http://www.aud.ru/about/


Параметрирование DB1
Mamasoliev Ziyod; 24.8.02

Как мне параметрировать DB1 в STEP 5/ ST Version 6.5 (02.05.95). Можно через пакет COM DB1, но его у меня нет.

Re: Параметрирование DB1
fog; 10.9.02

Пакет COM DB1 не обязателен, можно программировать и без него, но нужно строго соблюдать синтаксис текстов DB1 (все пробелы, точки и запятые - иначе PLC не запустится, а COM DB1 просто позволяет об этом не думать).

Re: Параметрирование DB1
fog; 10.9.02

Да, кстати, открывать DB1 нужно в текстовом формате.


Перезагрузка в Step7
AlKu; 23.7.02

Можно ли при перегрузке всего проекта в STEP7 определить это событие в программе, каким образом ?


Перенос DB в Excel
DEE; 9.12.02

Как перенести данные из DB в Excel ( желательно с адресами внутри самого DB) и чтобы комментарии к полям остались на русском?

Спасибо.


Перенос блоков между проектами
Ярослав Евдокимов; 30.10.02

Следующая проблема при переносе исходников на SCL 5.1 из одного проекта Step7 в другой: перенесенные блоки не всегда нормально компилируются, хотя не содержат ошибок (работали в старом проекте). Компилятор выдает "Different time stamps..." После нескольких попыток удается скомпилировать проект. Подчеркну, что речь идет о копировании десятка исходников из проекта в проект, поэтому решения типа "экспортировать исходники в текстовые файлы и потом импортировать" - не предлагать :( Вообще, хочется понять, в чем проблема, и какую информацию об SCL-исходнике содержит БД проекта.

Re: Перенос блоков между проектами
Александр, СКТЦ; 31.10.02

БД проекта содержит информацию о всех объектах SCL-исходника (UDT, DB, FC, FB ).

Проблема в том, что папка Blocks содержит объекты, генерируемые из SCL, имеющие метку времени отличную от метки времени в SCL-исходнике. Т.е. компилятор "подозревает" о том, что
был изменен интерфейс объекта.

Решение проблемы в правильном порядке компиляции. Т.е. сначала должны компилироваться (перекомпилироваться) те объкты, которые не включают в себя каких-либо ссылок (объявлений, вызовов и т.д.) на другие пользовательские объекты, и только затем объекты, включающие в себя то, что было уже перекомпилировано.

Полезно использовать
SCL Cmpile control file
Re: Перенос блоков между проектами
AlKu; 13.11.02

Не подскажете, где он лежит - Cmpile ?

Re: Перенос блоков между проектами
AlKu; 13.11.02

Не подскажете, где он лежит - Cmpile ?

Re: Перенос блоков между проектами
Александр, СКТЦ; 14.11.02

Он не лежит, его делают. В папке Sources выбрать пункт меню Insert New Object->SCL Compile control file.

Внутри этого файла перечисляются названия SCL исходников в том порядке в каком их нужно компилировать.

Re: Перенос блоков между проектами
Илья; 25.11.02

Поппробуйте выставить одинаковые системные время и дату на всех машинах - должно помочь


Печать по русски.
Kulakov G.; 25.11.02

Кто может объяснить, почему после инсталляции на два компьютера разной конфигурации с одних и тех же дисков Win98 (или NT, или WIN2000), Step7 V5.1 и ProTool один позволяет печатать комментарии в символьной таблице и документацию из ProTool с русским текстом, а другой никак. И как с этим бороться. Кодовые страницы в реестре менял, не помогло.


Преобразование форматов
Андрей; 31.7.02

Существуют ли в STEP 7 функции преобразования формата REAL в S5TIME (CPU 414-2DP).

Re: Преобразование форматов
Чистяков Дмитрий ОАО "СеверСталь"; 1.8.02

Округляем число с плавающей запятой MD100 и передаём его в число типа DI (длинное целое)MD104
L MD 100
RND
T MD 104

Преобразовываем его в код BCD.
DTB
T MD 108

А теперь в младшем слове время в формате S5TIME
Остаётся, только установить в этом слове биты 4 и 5 в зависимости от единицы измерения времени.
Более подробно формат S5TIME описан и даже разрисован в Help`е

Re: Преобразование форматов
Илья; 2.10.02

Только не забыть бы, что формат S5TIME имеет размер 2 байта. Соответственно, число не должно быть больше 999. Вот...


Работа с системными функциями
Евгений; 16.7.02

Подскажите как правильно ввести параметор "SDT" В SFC28, для установки прерывания по времени.

Спасибо.
Re: Работа с системными функциями
Чистяков Дмитрий ОАО "СеверСталь"; 17.7.02

Вот вырезка из help`a

NETWORK
TITLE = Combine time and date to form interrupt time
CALL FC 3 ( //FC3 "D_TOD_DT" (conversion D and TOD

//to DT)
IN1 := #IN_DATE, //Input variable date (format DATE)
IN2 := #IN_TIME, //and input variable time (format
//TIME_OF_DAY)
RET_VAL:= #OUT_TIME_DATE); //are combined to form output variable (format
//DATE_AND_TIME)

NETWORK
TITLE = Set start date and time
A #OK_FLAG ; //Time-of-day interrupt requirements fulfilled?
JNB _005 ; //If so, set time-of-day interrupt using
CALL SFC 28 ( //SFC 28 "SET_TINT" (set time-of-day interrupt)
OB_NO := 10, //Time-of-day interrupt OB10
SDT := #OUT_TIME_DATE, //Start date and time
PERIOD := W#16#1201, //Periodicity, here weekly
RET_VAL:= MW 200) ; //Actual parameter for error code

_005: A BR ; //M 202.3 = 1 if time-of-day interrupt set without error
= M 202.3 ;

Т.е. этот параметр подготавливается путём преобразования типа при помощи FC3.


Редактирование DB
Тулупова Виктория; 29.1.02

Есть проблема: при редактировании блока данных (DB) - удалении или вставки новых переменных, программа, использующая этот DB не находит переменных, следующих за адресами после

редактированных полей, хотя в программе используются мнемонические названия полей DB (например "PID".P_Sel)
Не существует ли способов избежать этой проблемы?

Re: Редактирование DB
Юрий Оганесян; 30.1.02

Нет - ведь символические имена - это только для удобства программиста и не более того. Выход - заранее резервировать пустое место или вставлять в конец DB.


Редактирование DLL файлов
Cергей Иванив; 5.6.02

Изините может вопрос не совсем по SIEMENS, но у мне нужно сравнить 2 DLL файла из Step7,какой програмой и каким образом я могу просмотреть этот файл и смогу ли я редактировать их после сравнения.

Re: Редактирование DLL файлов
Василенко; 1.8.02

Есть утилиты для просмотра структуры DLL. Я видел под Win98, показывает список экспортируемых функций. Редактировать в полном смысле слова нельзя.

Re: Редактирование DLL файлов
Aleksey; 21.8.02

А можно спомощью Hex редактора

Re: Редактирование DLL файлов
DJ; 4.9.02

Есть dllview , есть утилита в VStudio , посмотреть можно с помощью любого дебаггера, редактировать можно только Type-либрари, и то только с целью сделать доступными, функции которые заблокированы или требуют лицензии и т.п.


Русифицированная версия STEP
Рахматуллин Илья; 19.8.02

Кто имеет Русифицированную версию STEPa прошу откликнуться приобрету, или дайте ссылку где её найти.

Re: Русифицированная версия STEP
Какого?; 19.8.02

Какого?

Re: Русифицированная версия STEP
aim; 19.8.02

Если относительно Step 5 - имеется верия 6.6

Если речь о Step 7 - официальные источники говорят об отсутствии таковой (локализация производиться только после превышения 15-ти % порога продаж в регион), но можно заняться самому. Например с пом-ю программы ResHacker. Только стоит-ли игра свеч?


Русский интерфейс для STEP 5/ST v7.14
Тима Чумак; 15.2.02

Возможно ли добавить в пакет STEP 5/ST

v7.14 русский язык. Были ли вообще пакеты STEP 5/ST c русским интерфейсом.
Re: Русский интерфейс для STEP 5/ST v7.14
Михайлин С.; 15.2.02

Да, пакет руссификации оболочки для STEP5 существует и его можно заказть. Стоимость 428 Евро на границе Германии.

Re: Русский интерфейс для STEP 5/ST v7.14
Павел Иванов (Сименс-Москва); 15.2.02

Номер для заказа:

Дополнение русского языка для STEP 5 V7.1
6ES5 894-0MA64-0UG5
Руководство по STEP 5 V7.1 на русском
6ES5 998-0MA64


САПР CADDY
Тарасов Всеволод; 26.3.01

Хотел бы услышать отклики о системе CADDY для проектирования электрических схем.

Re: САПР CADDY
Илларионов Анатолий; 29.3.01

Модули Электротехники в CADdy позволяют проектировать схемы с автоматической генерацией документов по ГОСТ или DIN (кабельный журнал, таблица соеминений, клемная таблица с астоматической генерацией перемычек, ведомость поупных, спецификацию и т.д.),

вести базу данных изделий с возвожностью автоматически посчитать стоимость проекта и сравнить его с аналогичными проектами,
компонавать электротехнические шкафы с автоматической объемной визуализацией
и многое другое...
Информацию об опыте внедрения модулей "Электротехника" в "Стальпроект" можно найти в журнале "САПР и графика" за 1999 г №7.
Демо-версию нового направления CADdy - CADdy++
можно скачать с сайта www.caddy.ru
См. http://www.sms-samara.ru

Re: САПР CADDY
Вадим; 11.5.02

Никак не могу скачать демо-версию CADdy с официального сайта.Помогите советом

Re: САПР CADDY
Андрей; 23.5.02

Рекомендую Eplan21 - ей все буржуйские

организации пользуются, типа Rittal
и т.п. я даже иногда пользуюсь.

Re: САПР CADDY
Ланецкий; 11.6.02

По поводу E-Plan и Caddy: преимущество последней в том, что она полноценно русифицирована (я имею в виду не только подписи под кнопками). А насчёт буржуйских организаций - так тут надо выбирать, для кого рисуем.

Re: САПР CADDY
Пол; 3.7.02

Есть крэк на CADdy++Basic (англоязычная версия), ну и сам CADdy++Basic конечно. Пробуем недавно, ограничений по количеству листов нет


Связь с S7
Алексей; 18.10.02

Имеется программатор PG740 по MPI соеденен с контроллером S7-400.

Сам PG имеет сетевую карту 3Com и подсоеденен в сеть.Вопрос такой получится ли у меня со своего компьютера также подлюченому к сети подсоединится через PG к контроллеру,
и что для этого нужно.
Re: Связь с S7
Baby; 21.10.02

Привет, Алексей !!!!

Как дела....?
Что-то не писали мне давненько....
Ваш вопрос : ..........
Ответ: некоторые компоненты Simatic Net....
К сожалению (для Вас) и к радости Siemens за отдельную плату.....

До скорого......

Re: Связь с S7
Алексей; 21.10.02

И что это за компоненты если не секрет?


Символьная таблица
Дмитрий Балтайс; 30.8.01

Здравствуйте!

Подскажите пожалуйста как правильно и быстро поменять символьное имя переменной в STEP7? Возникла необходимость поменять несколько имен, попробовал через Symbol Editor, а Симатик очень болезненно на это отреагировал.
Re: Символьная таблица
aim; 8.9.01

И какая была реакция?

Re: Символьная таблица
Максим Елхов; 12.3.02

Options->Rewiring

Re: Символьная таблица
Юрис Гекиш; 17.10.02

Вопервых непонятно что значит "болезненно", кашлять начал что-ли. Options->Rewiring меняет адрес переменной, а не символьную таблицу.

Если у тебя программа написяна без абсолютной адресации то:
1. Создаешь исходний файл File->GenerateSourceFile с симбольной адресацией
2. Меняешь символьную таблицу как хочешь
3. Компилируешь исходний файл


Система контроля и управления сигналами аварий
VIKA; 23.5.02

Где взять демо версию программного обеспечения для системы контроля и управления сигналами аварий.


Системные атрибуты
Евгений; 27.8.02

Кто-нибудь может подсказать как работать с системными атрибутами

(для чего они вообще нужны и как
с ними работать)-для FB
Хоть основную идею.
Спасибо.


Сканирование программы
Евгений; 26.7.02

Подскажите с какого места начнется сканирование программы в CPU 3152DP

после перевода его в STOP в ручном режиме и пуск в ручном(не по включению
питания)
Re: Сканирование программы
Юрий Оганесян; 29.7.02

С начала..

Re: Сканирование программы
Чистяков Дмитрий ОАО "СеверСталь"; 29.7.02

Я бы добавил - с первой команды в OB100, OB101 а если их нет, то с OB1

Re: Сканирование программы
siemargl; 30.7.02

Слово то какое - "сканирование". Явный шпион конкурентов! - у Siemens'a другая терминология.


Совместный доступ к проекту
Пашков Андрей; 10.2.02

При попытке открыть проект в Simatic Manager через сеть становятся недоступными ресурсы, относящиеся к CPU: bloks, charts, source, hardware. В версии PCS5.0 все отлично работало, а в 5.1 и 5.2 нет. Настройки для совместного доступа для Simatic и операционки остались те же.

Re: Совместный доступ к проекту
Михайлин С.; 15.2.02

Опробировал под PCS7 v5.2 - все работает. Проверьте состояние SIMATIC Workstation в Контрольной панеле. Должно стоять Multi Node System и нужные настройки адресов.

Re: Совместный доступ к проекту
Парфентьев Константин; 2.4.02

Для совместного доступа проект должен лежать в сетевой папке,-проверено.


стандартные библиотеки
oleg; 12.3.02

У нас STEP 7 v4.02.8 в приложении HWconfig отсутствуют в библиотеке новые блоки, может быть кто подскажет как обновить библиотеку.

Re: стандартные библиотеки
Андрей Гуленок; 15.3.02

Вопрос не так прост как кажется. На немецком сайте есть сервиспаки для обновления HW каталога но не все модули поддерживаются 4-ой версией. Например новые ЦПУ требуют версию 5. В этом случае необходимо преобретать абгрейт.

Re: стандартные библиотеки
oleg; 16.3.02

Спасибо за ответ


Стоимость апгрейда Step 7 v5.1 -> v5.2
Михаил; 15.12.02

Сколько стоит апгрейд Step

7 c v5.1 до v5.2?
Re: Стоимость апгрейда Step 7 v5.1 -> v5.2
Михайлин Сергей; 19.12.02

Стоимость продуктов у Сименса не меняется в течение финансового года. Т. е. апгрейд с любой версии до 5.2, который будет официально в январе, будет стоить столько же сколько сейчас стоит апгрейд с любой версии до 5.1

А именно 409 Евро на границе Гемании


Установка Step 7 на Win2000
Sergey; 20.12.02

У нас есть программатор PG720 емкость ОЗУ 64 килобайта решили поставить WIN200 ,а STEP 7 не хочет ставиться на нее то делать? На WIN2000 стоит SERVIS PAck 3

Re: Установка Step 7 на Win2000
Чистяков Дмитрий ОАО "СеверСталь"; 20.12.02

Для начала сообщите версию STEP 7.

Ну и на 64 килах( ;-) ), конечно не покатит сей зверь.
Вообще только для самого Win2k желательно иметь 128 метров памяти. А вообще, не плохо завести привычку заглядывать в файл readme. Там обычно приводяться требования к компьютеру. ;-)
Вот вырезка от туда
In order to work with the STEP 7 software, you require:

· For Windows 95/98: a programming device or PC with an 80486 (or higher) processor and at least 32 Mbytes of RAM. We recommend a Pentium processor with 64 Mbytes of RAM.
· For Windows Me: a programming device or PC with a Pentium processor of 150 MHz or higher and at least 64 Mbytes of RAM.

· For Windows NT: a Pentium processor and at least 32 Mbytes of RAM. Should you want to install or operate an operator station (WinCC), we recommend 64 Mbytes of RAM.
· For Windows 2000: a Pentium processor of 233 MHz or higher and at least 128 Mbytes of RAM.
· An external programmer for SIMATIC memory cards if you are using a PC and want to save your user programs in EPROMs and a SIMATIC NET interface if you want to use on-line functions to the automation system with your personal computer.
Use a programming device or PC with the latest performance capabilities if you are editing hardware configurations containing several hundred modules, for example (CPUs, slaves, I/Os) in your STEP 7 project.

Re: Установка Step 7 на Win2000
Чистяков Дмитрий ОАО "СеверСталь"; 20.12.02

Забыл уточнить - это для версии Step7 ver 5.1

Re: Установка Step 7 на Win2000
Евгений Трунов; 23.12.02

STEP7 версии 5.0, например, "общим" сетапом действительно не поставится, сразу написав что-то типа: "Version of Operating System not supported". Попробуйте запустить его "родной" setup.exe, который в \Step7\disk1. У нас он (STEP7 V 5.0, SP3) стал на Win 2000 нормально.

Re: Установка Step 7 на Win2000
Чистяков Дмитрий ОАО "СеверСталь"; 25.12.02

Да нет, Евгений, у них другая проблема - памяти маловато будет. ;-)

Вообще, сам W2k на 64-рёх метрах еле ползает, а тут ещё и монстр STEP7.
Даже если и установиться, то будет всё это работать как черепаха.

Для обхода же огранияения памяти, можно поробовать добавить виртуальной памяти.

Re: Установка Step 7 на Win2000
Евгений Трунов; 28.12.02

Sergey написал "не ставится". "Поставиться", наверное, всё-таки должен и на 64 Мб, в отличие от "нормально работать" :).

Re: Установка Step 7 на Win2000
Sergey; 28.12.02

Ребята я розабрался в чем дело.Оказывается я заходил под русским логином,а нужно английский Память я добавил до 128 метров


Установка Step7 SP6
Сергей Г.; 9.12.02

Установка Step7 Professional (SP6) под windows 98 (русская версия) проходит с ошибкой - после перезагрузки Windows появляется сообщение "Необходимый файл DBL50T.DLL не найден", хотя он есть в папке Siemens\common\sqlany\.

Имеются следующие ошибки в работе:
При создании проекта появляется сообщение "Open Project (257:5)
One or more objects of a type cannot be represented. Unable to load the server 's7uvpomx.dll' for _S7UV_LIST_CT objects.
Make sure that the required optional packages are installed."
Файл s7uvpomx.dll находится на своем месте.
В редакторе HW Config при сохранении и компиляции конфигурации контроллера появляется сообщение:
"Save and Compile (13:76)
Error while creating the system data.
Do you want to continue?"
Независимо от подтверждения этого сообщения (Да/Нет) выдается
сообщение: "Creating system data failed"


установка Step7 v5.1 под Win2000
Parfentyev K. (Promatis); 24.8.01

На "винте" два раздела - Win98 и Win2000. Оба раздела в одной файловой системе FAT32, что очень удобно, т.к. видно все дисковое пространство. Win98 занимает логический С:, а Win2000 - логический D:.

Под Win98 давно и надежно работает Step7 v5.1 + SP1. Теперь хочу установить его и во второй раздел. Однако инсталляция завершается через 30 секунд без сообщений об ошибках. Более того, по окончанию выскакивает транспорант "установка завершена успешно". А в результате на диске ни каких следов установки, кроме обновленного файла RASETUP.TXT.
Вот такой интересный Setup.
Re: установка Step7 v5.1 под Win2000
Дедовец Павел; 27.8.01

Было и у меня такое. Только я причин искать не стал. Убил Win98 и оставил Win2000 (оказалось не зря). Но ситуация забавная ;-)

Re: установка Step7 v5.1 под Win2000
serg; 18.1.02

Я поступил иначе:

разбил витн на две партиции
1-Win98(FAT32)
2-Win2000(NTFS)
В итоге Win98 видит свой диск и CD.
Win2000 -оба диска и CD.
Но предупреждаю проги установленные под
Win98 могут не работать под 2000
Re: установка Step7 v5.1 под Win2000
Сергей; 18.1.02

Если при установке Win 2k раздел форматируется в NTFS, то весь софт встает без проблем. Если на FAT 32 или уже после установки раздел преобразуется в NTFS нифига не работает. Деталь действитель смешная :)

Re: установка Step7 v5.1 под Win2000
Владимир Петров, АО АВТОВАЗ; 10.3.02

Проблема возникает в том случае, когда программа устанавливается из-под

аккаунта, заданного русским именем (например, из-под стандартного аккаунта
"Администратор", создаваемого системой). Это вызвано тем, что инсталлятор
InstallShield (по крайней мере, версии 5.53) не понимает длинных русских
имен.

Что можно сделать, чтобы установить такую программу в настоящий момент:

1. Временно (на один сеанс) поменять переменную окружения TEMP. Для этого
достаточно в командной строке набрать SET TEMP=<путь к временной
директории>, например SET TEMP=C:\TMP . После этого запустить инсталлятор.
Желательно, чтобы указанная в TEMP временная директория существовала, иначе
Install Shield будет пытаться распаковать инсталлятор в директорию Windows.
2. Изменить переменную TEMP можно в свойствах "Мой компьютер" ("My
Computer") на закладке "Дополнительно" ("Advanced") -> "Переменные среды"
("Environment Variables"). Это изменение сохраняется постоянно для данного пользователя.
3. Создать на компьютере пользователя с английским именем и правами
администратора и запускать установку из-под созданного аккаунта.


Учебник по S7-HiGraph
Den; 18.6.02

А нет ли где учебника по S7-HiGraph на русском языке? Занятная вещица...

Re: Учебник по S7-HiGraph
Михайлин Сергей; 19.6.02

Документация по HiGraph пока не переводилась, но доступна на европейских языках и ее можно либо скачать с немецкого сайта поддержки(см. раздел ссылки) или получить у нас или мылом(1М весит). А учебник (в смысле документация по обучению) она только с курсом поставляется.


учебник по step 7
Sergey; 22.1.02

Если у кого есть учебник или методичка по step 7 скинте пожалуйста на ssl11@newmail.ru

Re: учебник по step 7
Юрий Оганесян; 22.1.02

http://195.146.64.23/ad/as/ru/info/07_ind_soft/04_man