text

com 530 и com et 100u
Володя; 30.1.03

срочно нужны в.у. ПО к контроллерам SIMATIC S5

Re: com 530 и com et 100u
Павел Иванов (Сименс-Москва); 3.2.03

Добрый день, Владимир!

Это очень старые пакеты параметрирования для уже снятых с продажи продуктов.
Напишите мне напрямую по эл. почте, что у Вас за проблема, как назвается Ваше предприятие.
Постараемся помочь.


? user defined attributes в STEP7
Шимолин Сергей; 13.10.03


AuthorSW - едет крыша
Eugene Sergeev; 10.11.03

Добрый день!

Неожиданно съехала крыша у AuthorsW2.2 - оно начинает считать авторизации до бесконечности, w2k думает, что прога висит - в таскменеджере пишет "не отвечает". На дискете-ли, на харддиске - все едино.
Чем залечить?

Re: AuthorSW - едет крыша
GorA; 11.11.03

Попробуй снести, а затем установить еще раз. Желательно версию по новее.

Re: AuthorSW - едет крыша
Андрей; 15.12.03

ну на сколько я знаю, никто и не гарантировал работу версии 2.2 под W2K. ставте версию 2.5. работает без проблем!:) А у 2.2 такой глюк действительно наблюдается!


AuthorsW
Алексей; 13.2.03

Что нужно сделать чтобы Step7 видел авторизацию на ... скажем на диске D, или E,F.

Re: AuthorsW
Чистяков Дмитрий ОАО "СеверСталь"; 16.2.03

Самое простое это указать при установке диск на который будут установлены авторизации.

Ну, а ежели уже установили и переустанавливать не хочется, то путь в реестр:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\SIEMENS\AUTSW\Tools\s7erdapx\data]
"AUT_DIR"="C:\\"
"Test1"="GetDrive: C:\\ : Nr: 3"
"Test2"=""
"Test3"=""
"Test4"=""
"Test5"=""
"Test6"=""
"Test7"="Drive is not compressed"
"Test8"=""
"Test9"="return GetDrive: (C=3,D,E,F,G,H=8) = 3 "


Braumat
Иванов Сергей; 23.8.03

Где можно взять Demo-версию или скачать для ознакомления Braumat - это спец. система для пивоварения на PCS7

Re: Braumat
Михайлин Сергей; 26.8.03

Посмотрите по ссылке. Там все что касается Braumat.

См. Тут


CFC SFC
Виктор; 9.3.03

Где можно скачать демо языков CFC SFC для Step7

Re: CFC SFC
Чистяков Дмитрий "СеверСталь"; 11.3.03

Скачать, на сколько я знаю, нельзя.

Можно обратиться к ближайшему представителю и попросить бесплатный CD-ROM "Demo Soft". Там есть все пакеты, включая CFC


CPU 313C и step7
Таранов; 20.6.03

надо запрограммить cpu313C, есть step7 v 5.0, но он такое cpu не признает, поможет ли сервис-пак, если да, то какой, и можно -ли запрограммить этого зверька с помощью step7 v5.1, с каким сервис-паком? Есть авторизация дословно называется так- Step7 М5юЧ

сгодится ли она для версий 5.1 и 5.2 ? дле версии 5.0 работает, проверено.
Re: CPU 313C и step7
Роман Абзаев; 20.6.03

Согласно Support&Service Entry ID: 9274152 от Date: 12/17/2001 The STEP7 version V5.1 SP2 is required for the configuration and programming of the compact CPUs. Processing with older STEP7 versions is not poSsible.

The Service Pack 2 can be downloaded from the Internet under the entry ID: 7914192.

См. Service & Support

Re: CPU 313C и step7
Таранов; 20.6.03

10-ks!!

Re: CPU 313C и step7
ЙЦУКЕН; 21.6.03

Ну, блин, Андрюха... Учили тебя, учили... Учи матчасть!


DB (Data View) -> Excel
Baby; 19.3.03

Приветствую !!!!!!

Как перенести из DB (вид "Data View")
в Excel, со всеми (ячейками)адресами и т.д.
Что-то простыми методами не получается.

Версия Step5.1 SP6

Пока.......

Re: DB (Data View) -> Excel
DEE; 24.3.03

А простыми и не получится...

В версии 5.2, говорят, можно стало.
Могу посоветовать www.runmode.com Раньше скачивал инфу оттуда на английском как импортировать DB в Excel со всеми адресами. Хотя попробовал - ничего не вышло, может у тебя получится....
Re: DB (Data View) -> Excel
Baby; 24.3.03

Привет,DEE !!!!

Да, Вы правы, я также воспользовался
советом с www.runmode.com , но ничего приемлемого не получилось....
Буду ждать, когда начальство по моей просьбе закупит Update к нашему Step5.1 SP6.

Удачи....
Пока......


M0.2
Евгений; 6.6.03

Немогу найти в программе кто включает метку M0.2 подскажите делитанту(CPU-315_2DP)

Спасибо.
Re: M0.2
Илья; 6.6.03

Смотри кросс-таблицу (Cross Reference)

Re: M0.2
Евгений; 6.6.03

В этой таблице эта метка встречается один раз как входной сигнал.

Re: M0.2
VAM; 6.6.03

Скорее всего это бит из синхробайта (см. св-ва CPU)

Re: M0.2
Александр; 6.6.03

Раз только - как входной сигнал, то ты, скорее всего, удалил елемент, к-й установил её в состояние 1 и метка осталась не сброшенной.

нарисуй ей управление и сбрось её в "0"
И ваще - зачем тебе метка как входной сигнал?? Не из сети ли ей управляют??? :-)

Re: M0.2
Евгений; 9.6.03

Это реальная программа которая работает

К контроллеру по MPI подцеплена панель
OP7-- может это её метка?
Re: M0.2
Илья; 9.6.03

Очень может быть. Если есть ОР-шный проект - посмотри привязку всех тегов. Ну, или как вариант, МВ0 используется как Clock Memory (см HardWare)

Re: M0.2
АЛЕКСАНДР; 9.6.03

Обрати внимание - может она образуется в слове(байте) или получаешь по шине (например от SIMADIN) - во всяком случае помни - чудес не бывает

Re: M0.2
Чистяков Дмитрий ОАО СеверСталь; 17.6.03

Скорее всего всё намного проще.

У тебя часы (системный байт) галка в настройках CPU не установлена случайно?


M7
Kirill; 23.3.03

Господа!

Занимается ли кто-нибудь программированием под М7?
Как скопировать flash eeprom с М7?

Re: M7
Михайлин Сергей; 24.3.03

Карты Flash памяти в М7 форматируются и несут информацию как обычные сменные диски. Чтобы ее прочесть надо иметь программатор или считыватель и в Контрольной панели во вкладке Memory Card Parameter поставить галку Flash File for M7. После этого появиться новый сменный диск. Или, если в системе М7 есть флоповод и монитор, можно прямо на ней с диска В: на диск А:! ;-)

Re: M7
Kirill; 24.3.03

Я имел в виду сделать копию flash eeprom, т.е. получить ещё одну РАБОТАЮЩУЮ flash eeprom.

Отформаторовать её нет проблемы. Как скопировать туда с оригинала приложения проекта, да так, что бы они заработали потом, вот в чём вопрос.

Re: M7
Григорий; 25.3.03

Если есть модуль MSM478 (наскольку я помню, цифры такие) и имея, субмодуль IF962VGA(хотя, вроде, можно обойтись и без последнего), можно загрузится с обычной MS-dos дискеты, после чего легко сдублировать флэш. Остальных фокусов пока не помню по перебрасыванию проекта. У меня упомянутые модули есть.

Если не секрет, то какую систему Вы делаете на М7?

Мы вынуждены были остановить эти разработки в связи с собщениями от Siemens о прекращении производства и поставок в течении 3х лет.
Eeprom copy
Kirill; 10.4.03

Господа!

Очень интересно, нет ли программы для копирования модулей EEPROM. Копировать просто модудь памяти как микросхему, используя драйвера Simatic для PG.
Re: M7
Григорий; 10.4.03

Насколько я помню, нет. Но кто мешает выгрузить проект ( и конфигурацию) из контроллера с последующей ее занесением во флэш. Только флэш нужно форматировать при отсутствии другого железа только в программаторе.т ( и не вставляйте флэш в PCMCIA гнездо - толку не будет, хотя разъемы похожи)

Re: M7
Kirill; 10.4.03

Это всё известно, а если это Flash с программой для...,например, сенсорной панели оператора, или ещё придуманного в будущем устройства не S7,M7.

Re: M7
Kirill; 7.5.03

Очень интересные вещи: на модуль Flash S7 проекты записываются, а под М7 не отформатировать этот модуль. Имел ли кто такие проблемы.

Re: M7
Григорий; 1.6.03

1. Формат флэш для M7 и S7 различен, несмотря на одинаковый номер.

2. Ты можешь попытаться отформатировать флэш с консоли (команду - утилиту смотри в описании), я полагаю, что она спросит уверен ли ты в желании форматировать флэш? после чего можно вставить новую флэшку.
3. Для копирования фэшки можно написать утилиту на борланде (типа Diskcopy), засасывющую содержимое исходной флэш в ОЗУ. Что не должно составить проблемы, учитывая что макс. размер флэш 16мб. После чего должен следовать запрос на замену флэшки, и из ОЗУ записывается новая флэш.
4. Если с флэшкой потребуется что-то сделать, то не забывай, что RMOS мультипрограммная и мультиконсольная система - можно переключиться на другую задачу и сделать необходимые действия.

Успехов! Григорий
Re: M7
Kirill; 8.8.03

Григорий!

Send me please (мыло не работает)!

Re: M7
Григорий; 9.10.03

Что хочешь? Уточни. (я был в командировке)


Modbus
Ян; 14.8.03

Добрый день, Господа.

Маленький вопрос по протоколу Modbus.
Поддерживают ли контроллеры SIMATIC передачу типов данных длиной 32 бита?
Классическая длина типа данных в Modbus 16 бит и дискретники.
Заранее спасибо.
Re: Modbus
kot; 18.8.03

Какой-то из режимов позволяет читать из памяти контроллера произвольное кол-во байт. Поэтому никаких проблем.


OB 0
DEE; 4.9.03

Что это за чудо такое (subj)? При выполнении программы (CPU 416-2) в диагностическом буфере появляется ошибка, причина которой OB 0 (ну примерно так).


OB1
Gluhov Yury; 2.1.03

Зауплоадиный (UpLoad) проект с контроллера С7 626/P DP при открытии блока OB1 выдает сообщение:

Compiler information: type coflict,
после чего отказывается открыть этот блок. Пробовал скачать в другой проект (другая hardware configuration) - бесполезно. Онлайном этот блок также не открывается. В чем дело? Очень нужно внести изменения.
Re: OB1
Туманов А.; 4.1.03

Попробуйте сделать сначала upload hardware в чистый проект, а потом - upload OB1.

Re: OB1
Gluhov Yury; 6.1.03

Пробовал - не помогает.

Re: OB1
Дертунов Борис; 28.1.03

Вопрос:Чем делали upload?Каким адаптером?

У меня подобное было-СР5511 не определил, что программатор может коннектиться по РТР протоколу. Скачать не удавалось, пришлось скопировать прогу из онлайна по профибасу, но хард ессно никак не получалось качнуть.Как только подключился программатором к коммуникациннику по РТР все заработало.
Правда, у меня был S7-414.

Re: OB1
Gluhov Yury; 31.1.03

Скачиваю программатором PG720.

Что-то не могу разобраться с назначением входов Author. Они (их две клеммы) расположены на разъеме питания C7 626 DP. Может, дело в них?

Re: OB1
Илья; 7.4.03

Auth - этот вход для ограничения доступа к телу контроллера, ведь ключ смены режимов работы у С7 в виде кнопки на лицевой панели (жми - не хочу!). Чтобы разблокировать доступ - поставьте перемычку на этот вход, т.е. замкните клеммы между собой. Кроме того, может стоять парольная защита на доступ к С7.


OB100
Eugene Sergeev; 2.12.03

Вот попробовал вставить в код ОВ100 некие проверки, типа if not I1.4 then

M10.1=true и т.п. Не работают. Такое впечатление, что ОВ100 не видит ни черта из имиджа. Это фича или баг?

Re: OB100
aim; 6.12.03

А может сначала надо разобраться когда этот блок вызывается?

Re: OB100
aim; 6.12.03

А может сначала надо разобраться когда этот блок вызывается?

Re: OB100
Eugene Sergeev; 7.12.03

А чего тут разбираться. Вызывается один раз при старте программы. На то он и ОВ100...

Re: OB100
GorA; 8.12.03

I1.4 - это память в центральном процессоре - образ входов, которая по умолчанию обновляется перед вызовом OB1. В OB100 никакого обновления памяти(получения образа входов) не производится (также по умолчанию). Поэтому нужен прямой доступ к входу.

Re: OB100
aim; 8.12.03

Вполне логичное объяснение (см. выше :)

Осталось только добавить, что бращение напрямую к переферии производится командой L PIW x.

P.S. Вот, правда, зачем Вам этот гем-й в OB100 нужен - непонятно.
Re: OB100
Eugene Sergeev; 11.12.03

Ну как зачем - после включения система может находиться в одном из нескольких состояний, определяемых состоянием актуаторов - т.е. входов от концевиков на этих актуаторах. Логично проанализировать это при пуске и сказать "Мы в таком-то положении"

Re: OB100
Алексей Родионов, ЗАО "Искра-Энергетика"; 11.12.03

OB100 обычно используют для инициализации программных блоков при запуске, типа сброса таймеров, счетчиков, триггеров, установки режима "По умолчанию", ну и т.д.

А состояния входов более актуально уже при циклических OB, когда система собственно и начинает работать


online
Парфентьев Константин; 28.1.03

Не знаю к какому разделу отнести свою проблему, потому что причина не понятна. Суть в том, что пытаюсь связаться из Step7 с S7-300 с помощью СР5613, в ответ - "нет активных партнеров". Проверил настройки интерфеса, провел диагностику платы, при чем тест определяет!!! все узлы в сети, переставил драйвера и т.д. И это после того как эта плата у меня проработала более года. Кто может подсказать причину того, что все по отдельности работает исправно, а через Step7 нет связи.

Re: online
Чистяков Дмитрий ОАО "СеверСталь"; 29.1.03

Кабель стандартный или нет?

Все узлы в сети - это по какому протоколу?
Re: online
Парфентьев Константин; 31.1.03

Переставил плату на другой комп, остались те же контроллер и кабель - есть online и все как надо. Сейчас вернул плату на свой комп, на всякий случай поставил в другой PCI слот, в результате все то же, что и было: из Set PGPC interface узлы видно, а Step7 и WinCC в соединение не входят.

Re: online
Сергей; 7.2.03

Вы решили проблему? А то у меня примерно таже ситуация возникла.

Re: online
Юрий Оганесян; 8.2.03

Если ты супер-спец, то заранее извиняюсь, но если начинающий, то, может, в этом и дело.. В Set PC/PG в верхнем окошке указывается тип связи, используемый конкретным приложением. Может ты тестировал связь для какого-нить другого приложения, а прилага S7 Online (Step7) настроена на другой протокол? И еще: в SIMATIC Manager'е View->Display Accessible Nodes делал?

Re: online
Парфентьев Константин; 12.2.03

Все решилось так же неожиданно, как и возникло, поэтому убедительно причины возникшей ситуации не могу. Просто на третьи сутки, когда устав менять настройки протокола, я занялся работой в WORDe. STEP7 в это время был запущен и часа через два он выкинул какое-то сообщение, которое я даже читать не стал - начитался за три дня, но там упоминался PLCSIM. Сообщение сбросил, а еще через некоторое время глянул в Доступные Узлы, ну и сами понимаете, все как надо показало.


PCS7 v.6
Евгений; 27.5.03

Кто работал с PCS7 v.6? поделитесь опытом, как поставить и что для этого нужно?

Re: PCS7 v.6
Чистяков Дмитрий ОАО СеверСталь; 27.5.03

PCS7 Вы купили?

У вас есть дискетка с авторизациями?

Аппаратные иребования для компьютера:

Mindestausstattung der Basisgerдte fьr ES, OS und SIMATIC BATCH
· Programmiergerдt oder Personal Computer mit:
- Prozessor ab Pentium 4
- min. 512 Mbyte RAM
- min. 40 Gbyte Festplattenspeicher
· Empfohlene Ausstattung:
- Programmiergerдt oder Personal Computer mit:
- Prozessor Pentium 4 ab 2 GHz
- 1 Gbyte RAM fьr Server/Single Stations, 512 Mbyte fьr Clients
- min. 60 Gbyte Festplattenspeicher
· Grafikkarte und Monitor mit Auflцsung 1280 x 1024 (min. 1024 x 768)

Re: PCS7 v.6
Евгений; 28.5.03

Есть у меня и авторизация, есть и соответствующая машина. При установке требуется дополнительно поставить много стандартного софта. В поставке соответственно этого нет. Можно ли это обойти и стоит ли это делать, вот в чем вопрос.

Re: PCS7 v.6
Чистяков Дмитрий ОАО СеверСталь; 28.5.03

Это какого софта требуется много доставить?

Re: PCS7 v.6
Михайлин Сергей; 30.5.03

Действительно перед утсановкой PCS7 v6 требуется доставить другой софт, который идет тем не менее вместе с комплектом, так что ищите в поставе, если она конечно законная. ;-)

Без этого система работать вообще не будет.
Софт следующий:
Windows 2000 SP3
Internet Explorer 6.0 SP1
MS SQL server SP3(на PCS7 CD)
Message Queuing services must be installed (Windows CD)
Index service must be disabled
Internet Information Service (IIS) must be disabled
Обойти это нельзя.
Удачи


PCS7 v6.0 SP2
shurik; 21.10.03

Можно ли получить в России пакет обновлений PCS7 v6.0 SP2

Re: PCS7 v6.0 SP2
Михайлин Сергей; 3.11.03

Пакет обновления можно получить совершенно бесплатно через Интернет, указав ID KHE номер Вашем предыдущей лицензии. Пакет придет Вам по почте.

Путь я вывесил в новостях сайта AS.


pcs7 и WIN2000
Виктор; 18.4.03

можно ли поставить PCS7 v5.2 под WINDOWS 2000 , родная под него NT.

Re: pcs7 и WIN2000
Роман Абзаев; 18.4.03

Вообще-то, согласно документу с Support&Services Entry ID: 2334224 SIMATIC PCS 7 V4.0x and V5.x is not comatible to Windows9x, Windows ME and Windows 2000. Так что ждите шестую версию. (Хотя ЧАСТИЧНО 5.2 ставится и под Win2K SP2, по крайней мере со вторым SP у PCS 7 5.2 - но вот за работоспособность такой связки Сименс ответственности, естественно, не несет)

См. Support&Services

Re: pcs7 и WIN2000
Чистяков Дмитрий "СеверСталь"; 18.4.03

PCS7 v5.2 прекрасно работает под Win2k

В частности на моём компьютере. ;-)
Шестая версия имеется уже в новом каталоге CA01 04` 2003. Она официально выйдет, после выхода WinCC 6.0, т.к. неразрывно связаны они друг с другом.
Выход WinCC 6.0 назначен на 24-25 апреля сего года. По крайней мере разработчикам дана команда, хоть ночевать на работе выдать продукт на гора.
Так что на следующей неделе ожидается официальный выход версии 6.0.

Из новшеств там, то что теперь базой для пакета стал не PC Anywery SQL server, а MS SQL server 2000.
Минимальные требования 512 метров ОЗУ и PIII800.
Увеличилась скорость протоколирования - до 100 событий в секунду. Но минимальные требования для сервера архивирования - P4 2ГГц.

Стоп! Лучше буду дописывать отчёт о песещении выставки Factory Automation в Ганновере.
Re: pcs7 и WIN2000
Михайлин Сергей; 18.4.03

PCS7 v6 уже вышла. Оффициально. Смотрите новости и соответсвующий раздел.

Что касается 5.2 то ее можно заточить под 2000, там только 2 пакета отказываются ставиться, но они не критичны.
Re: pcs7 и WIN2000
Виктор; 20.4.03

В начале устоновки ругается не та версия WINDOWS . Как это обойти?

Прбовал устанавливать по пакетам , WINCC не устанавливается а так остальное пролазит.
Re: pcs7 и WIN2000
Роман Абзаев; 21.4.03

Если у Вас, уважаемый, WinCC древнее, чем 5.0 + SP 2 то и не поставится.

Re: pcs7 и WIN2000
Виктор; 21.4.03

Версия WinCC 5.1 для NT и 2000

доходит до установки smart tools и сообщает что не могу установить smart
tools. Под NT все проходит.


PCS7
Виктор; 7.3.03

Где можно взять PCS7 demo?

Re: PCS7
Михайлин Сергей; 7.3.03

Диск PCS7 Demo можно получить в любом нашем представительстве. Смотри раздел "О нас".

Re: PCS7
Виктор; 7.3.03

Меня интересует програмный продукт

Re: PCS7
Михайлин Сергей; 7.3.03

К сожалению Полноценной демо версии PCS7 не существует. Очень сложно собрать такой комплекс софта воедино в демо версии. Выходы таковы: либо договориться с региональными менеджерами и взять на время полный софт, либо попробовать у нас в тех центрах.


pcs7
Вмктор; 22.5.03

Где можно взять описание библиотеки блоков на русском языке

Re: pcs7
Чистяков Дмитрий ОАО СеверСталь; 22.5.03

http://www.automation-drives.ru/as/products/doc.php?l1=SIMATIC%20PCS7&l3=doc

Re: pcs7
Чистяков Дмитрий ОАО СеверСталь; 22.5.03

Только вот там на страничке адреса даны в виде

http://www4.ad.siemens.de:8080/news/csi/en/9830511
Так вот порт 8080 и двоеточие удалить надо.
Т.е. адрес будет такой
http://www4.ad.siemens.de/news/csi/en/9830511


pcs7
Вмктор; 22.5.03

Где можно взять описание библиотеки блоков на русском языке

Re: pcs7
Василенко; 23.5.03

В на диске с русской документацией от Siemens


PCSPROWIN
Сергей; 6.10.03

Помогите кто сталкивался с прошивкой понелей Lauer PCS095 нужен драйвер

PG 195.203.3 021098

Re: PCSPROWIN
kip; 9.10.03

Отправил по мылу PCSPRO 5.71 с драйверами

Re: PCSPROWIN
kip; 9.10.03

Отправил по мылу PCSPRO 5.71 с драйверами


PLCSim - связь с "несименс" приложениями?
Алексей, Переславль; 22.1.03

Может ли симмулятор работать с приложениями не S7 (а например с Вижуал Бейсик). Хотелось бы подавать входа и получать выхода на внешнее приложение для более полной симуляции процесса. Или все - только "галочками" и только внутри siemens'a?

Re: PLCSim - связь с
DEE; 24.1.03

>Или все - только "галочками" и только внутри siemens'a?

Сдаётся мне, что именно так!

Re: PLCSim - связь с
Андрей; 28.1.03

В папке симулятора лежит несколько обычных ocx-ов которые позволяют работать с входами-выходами. Есть там и ocx-ы позволяющие читать-писать в маркеры, но они требуют лицензии. Может кто нибудь подскажет как можно работать с маркерами.


PLCSim и ServiceLab
Baby; 18.2.03

Приветствую !!!

Может ли ServiceLab соединяться с
PLCSim. Я пробовал не получается.
Сообщение "Fehler Toolbox", появляется.
Но может что-то не так делаю ???
Или в принципе невозможно ?????

Пока ......


Prodave S5?
VVV; 11.2.03

Здравствуйте!

Подскажите, пожалуйста, есть ли в природе Prodave для пятых Симатиков, и если есть, то где можно его достать?
Заранее благодарен.
Re: Prodave S5?
VVV; 26.2.03

Так есть ли Prodave AS511?

Re: Prodave S5?
Чистяков Дмитрий ОАО "СеверСталь"; 27.2.03

Загляните в каталог CA01

----------------------------------
Инструментальные средства PRODAVE позволяют устанавливать связь между программируемым контроллером и программатором/ компьютером. PRODAVE управляет передачей данных по протоколам AS511 или 3964R (RK512).
PRODAVE обеспечивает автономное управление передачей данных и работает в фоновом режиме.

PRODAVE DOS/WIN
PRODAVE DOS/WIN выполняет передачу данных по последовательному интерфейсу между центральным процессором контроллера и программатором/ компьютером.

PRODAVE DOS 64R, PRODAVE WIN 64R
PRODAVE DOS 64R или WIN 64R обеспечивает связь с контроллером через последовательный интерфейс программатора и коммуникационные процессоры CP 521/CP 523/CP 524 или CP 525.

PRODAVE DDE (для SIMATIC S5)
PRODAVE DDE обеспечивает связь программатора, подключенного к интерфейсу программатора в контроллере. Возможна организация связи через последовательный интерфейс программатора/компьютера и PPI коммуникационный процессор контроллера.

PRODAVE для SIMATIC S7-300/-400
PRODAVE для SIMATIC S7-300/-400 работает под управлением MS-DOS/Windows и обеспечивает связь с контроллером по MPI интерфейсу (не может работать через телекоммуникационный блок TK 858 и модем).
-------------------------------------
6ES5886-2WQ01

SIMATIC S5, TOOLBOX PRODAVE DOS/WIN 511 V5.0, ДЛЯ ОРГАНИЗАЦИИ СВЯЗИ МЕЖДУ ПРОГРАММАТОРОМ/ КОМПЬЮТЕРОМ И КОНТРОЛЛЕРОМ ПО ПРОТОКОЛУ AS511 ПОД УПРАВЛЕНИЕМ DOS/WIN 3.X; 3,5"-ДИСК, ДОКУМЕНТАЦИЯ НА НЕМЕЦКОМ И АНГЛИЙСКОМ ЯЗЫКЕ

589 евриков


Profibus & PLCsim
АлександрЗ; 8.4.03

Друзья !

Кто подскажет можно ли воспользоваться программой симулятором для отладки программы, где участвуют Profibus Мaster & Slave - может кто пробовал, просто под руками нет железа, а одну идею проверить хочется.
Спасибо

Re: Profibus & PLCsim
Назаров Дмитрий; 8.4.03

Смело грузите в PLCSIM такой проект! И все будет работать!


Profibus
Евгений; 30.6.03

Может кто подскажет как правильно

организовать программу для управления
частотным регулятором по Profibus
(какие блоки и периодичность их
вызовов).
Заранее благодарен.
Re: Profibus
Baby; 30.6.03

Привет !!!

Ооо, это большой вопрос.
Если можно подробности.....
Какой привод, сколько на сетке их будет и т.д.
Re: Profibus
Евгений; 30.6.03

Должно быть три привода MASTERDRIVERS MC. При возникновении каких либо

неполадок в любом из них должны отклю-
читься все а информация о неполадке--
--в DB для анализа на панели оператора.
Еще раз спасибо.

Re: Profibus
Назаров Дмитрий; 1.7.03

Для управления приводами MASTERDRIVES MC по Profibus DP Сименсом разработаны готовые функциональные блоки. Поставляются они в составе дополнительной программы Drive ES SIMATIC для STEP7 заказнsм номером 6SW1700-0JC00-0AA0 Цена 563 Евро в Германии. В пакете есть все что Вам необходимо.


Runtime Software
Iurii Suhovic; 19.3.03

- Что понимается под начением "Runtime Software" на коробке пакета Microcomputing под операционной системой Windows 2000 ( насклько это тогда Runtime или что его таковым делает?). Нужен ли при этом для нормальной работы CP 5611 в нашем ведущем компьютере?

Re: Runtime Software
Михайлин Сергей; 25.3.03

Runtime Software - это лишь термин, которым обзывается программное обеспечение, которое непосредственно загружается в ЦПУ. А есть еще например инженерное ПО - оно для разработки.


S7ProSim
Александр; 19.8.03

Здрасьте!

Подскажите, пожалуйста, что ЭТО такое...
Упоминается ЭТО в документации на PLCSim.
Заранее спасибо!
Re: S7ProSim
Михайлин Сергей; 19.8.03

S7ProSim is an ActiveX™ Control that provides programmatic access to the process simulation interface of S7-PLCSIM. This control may be used in any application that can accept ActiveX

controls. You can use this control to attach a process simulation to S7-PLCSIM.
Дока есть на инглише! Могу выслать или обратитесь в наше представительство.
Re: S7ProSim
Дмитрий; 21.8.03

Дока и примеры лежат в папке с руководствами на Plcsim после утановки программы на ПК.

S7ProSim
Александр; 21.8.03

Привет всем!

Re Дмитрий
Дмитрий!
Я как раз эту документацию и читал...
Но ни черта из того что написано не понял!

Re Михайлин Сергей
Сергей!
Это у меня есть! Спасибо за беспокойство.

Вопрос!
Вернее, сначала проблема.
Есть контроллер S7-400, с рабочей программой, есть SCADA Wizcon (Axeda)
c проектом под рабочую программу...
А вот теперь вопрос - как мне загрузив программу в симулятор (PLCSim) и запустив проект на Wizcon, связать их между собой ??? Не используя контроллер.

С уважением Александр!
Re: S7ProSim
Дмитрий; 22.8.03

Со SCADA Wizcon такой фокус скорей всего не пройдет. Он проходит только с ProTool и WinCC.

А в документации описаны свойста и методы которые есть у ActiveX компонента. С помощью этих свойств можно получать данные о состоянии выходов и управлять входами виртуального контроллера из внешней программу например Excel или проект VB. Это позволяет создать виртуальную модель установки и достоверно протестировать программу контроллера для ее управления.
S7ProSim
Александр; 22.8.03

Привет Дмитрий!

И как мне все это дело организовать-то, пусть это будет ProTool (WinCC)
???

мыло : aleks_ostrov@inbox.ru

С уважением Александр.
Re: S7ProSim
Дмитрий; 25.8.03

Выслал на мейл пример

S7ProSim
Александр; 25.8.03

Спасибо огромное!


ServiceLab - описание на русском?
Александр; 11.7.03

Существует такое???

И если приобретать, то - ServiceLab или PLS Analizer??? Отзовитесь, кто пользовал!!!
Re: ServiceLab - описание на русском?
Baby; 15.7.03

Привет !!!!

Конечно, ServiceLab 7.0 ,
возможности бесконечность,но для каких целей Вам нужен.
Это в смысле описания на русском.
Минимальные знания немецкого или англ.
уже позволяют делать неплохие вещи +
очень хорошие есть примеры даже в демо версиях.

Пока......
Re: ServiceLab - описание на русском?
Александр; 15.7.03

Спасибо!

Мне нужен самописец и инструмент для отыскания "плавающих" ошибок, например...


SFB12(BSEND), SFB13(BRCV)
DEE; 8.4.03

Hi!

Народ, кто может популярно объяснить..Правильно ли я понимаю:
У сабжевых SFB вход ID - это Local ID партнёра по соединению (т.е Partner ID), соединений, которые организуются в NetPro?
А что такое R_ID? Это номер использоемого в пользовательской программе коннекта (сенд-ресив)? Ну, т.е. я могу прописать в своей программе несколько раз BSEND, и R_ID должно соответствовать количеству прописанных вызовов? Так? Если не так, то объясните, плиз?


SFC20 blkmov
ищущий; 5.2.03

Помогите разобраться пожалуйста: как в stl переместить задаваемую область памяти, не используя фиксированную адресацию? Стандартная функция sfb20 передает один в один участки памяти, но фиксированно. А как передать элемент массива структур, в другой элемент? (пословное копирование ест слишком много времени).

Re: SFC20 blkmov
VVS; 5.2.03

Я тут как-то писал функции для копирования одной области памяти в другую и сравнения двух произвольных областей. Если надо могу намылить исходник.

Best regards
Re: SFC20 blkmov
Nec; 5.2.03

Можно создать свой FB для переноса данных, и задать в его заголовке temp (временные)переменные формата ANY. Потом в теле блока через LB и LW присвоить нужные адреса для этих переменных и при вызове SFC20 в качестве параметров использовать именно эти переменные. Описание формата ANY есть в Help к Simatic Manager (задай поиск "Format of ANY Type"). Там, вобщем-то, все понятно и просто.

С уважением, Алексей.

P.S. Я успешно использую этот метод на работающей системе. Если что-то непонятно поясню.

Re: SFC20 blkmov
ищущий; 7.2.03

благодарю за подсказку, разобрался как адресовать....


Siemens Insight
Александр; 6.6.03

Прошу откликнуться кто встречался с программой визуализации Siemens Insight, устанавливали эту программу турецкое представительство Siemens.

Re: Siemens Insight
Чистяков Дмитрий ОАО СеверСталь; 17.6.03

Если честно, то даже название такое на слышали нигде.

Re: Siemens Insight
Роман Абзаев; 18.6.03

Re: Siemens Insight
Назаров Дмитрий; 18.6.03

5 минут поиска в Интернет и готов ответ. Insight - продукт фирмы Insight Consulting (http://www.insight.co.uk/). Ставил Вам этот продукт СИМЕНС, но не наш департамент A&D, а департамент SBT. Вам к ним.

Re: Siemens Insight
Роман Абзаев; 18.6.03

И, скорее всего, в этом случае, Вам необходимо одно из подразделений SBT, сформированное на базе Cerberus

Re: Siemens Insight
Александр; 20.6.03

Спасибо за помощь!


SIEMENS и NT
Сергей; 14.8.03

Насколько я понимаю, весь сименсовский софт не будет поддерживать Windows NT?

Применять XP в промышленности? Забавно...)))
Re: SIEMENS и NT
Михайлин Сергей; 14.8.03

Ну в обозримом будущем конечно так и будет. Ведь не поддерживается сейчас win95! :-) Но и ХР в промышленности еще рано применять. Сейчас ориентация идет на win2k. К тому сам мелкомягкий прекращает поддержку NT вскоре. А в России получает по анеку "...вас, Петровых, не поймешь! Она говорит хорошо, ты говоришь не хорошо!" Скока разговоров было"Даешь win2k, долой NT!" ;-)

Re: SIEMENS и NT
Андрей В.; 5.9.03

Внесу ясность.

NT, 2000, XP имеют одно ядро, это одно и тоже. Писало эту операционку таже команда (не Microsoft), которая написала ОС RSX-11 для архитектуры PDP-11. Старшее поколение знает, что это - основа информатизации СССР. Более того, компания Microsoft выпускает версии специально для систем реального времени с приставкой Embedded, т.е. для систем жесткого реального времени. Оне могут работать без HD, c CD, c ROM, или с HD в котром раздел помечен как Read Only. В ядро встроено новое API, для возможности программирования систем реального времени для промышленности.
И именно эти версии использует SIEMENS, в своих новых устройствах.
Темень...
Re: SIEMENS и NT
Любитель Симатика; 5.9.03

Стоп машина...

В каких это новых устройствах используется или требуется Embedded? Я ни в одном readme не видел такого требования. А потом, разве где-то написано что встраивамые системы (embedded) обязательно РВ?
Насчет жесткого РВ, НЕ ВЕРЮ. Форточки никогда не станут ОСРВ.
Насчет ядра, может оно и одинаково, но тогда обвязка этого ядра делает их разными системами. По мне, так NT самое подходящее для промышленности как основа.
Re: SIEMENS и NT
Андрей В.; 10.9.03

Устройства SIEMENS PCU-50, PCU-70 - Персоналки для пультов управления ЧПУ.

Microsoft лицензировла ядро РВ у www.vci.com лет 5 назад.
Все наладонники уже давно с ядром РВ.
Читайте не переодику а первоисточники.
А вообще ядро NT это мечта. Я работаю с ней с того момента как она называлась OS/2. Потом Б.Г. с IBM не сошлись характерами. IBM доделала OS/2 с ядром на ассемблере. А Б.Г. приглосил команду из DEC и они написали ядро NT. Изночально это была многозадачная, переносимая и надёжная система. С тех пор ничего не изменилось. А что навесить на ядро, это уже не важно.
У нас такой неграмотный народ, что достаточно вывести на дисплей не DOS V6.2 а Windows 95, как все с умным видом говорят:- "Это не чистый DOS!".
------------------------------------
Ученье свет, а неученье тьма.

Re: SIEMENS и NT
Андрей В.; 10.9.03

Прошу прощения за ошибки :)

В моей голове смешались русский, белорусский, английский, немецки и С++.

Re: SIEMENS и NT
В. Сорокин.; 11.9.03

Некоторый комментарий по PCU.Занимаются они в УЧПУ вопросами общения с оператором, подготовкой файлов и массивов данных, визуализацией. Т. е. вопрсами не спешными, когда можно подумать, ошибиться и исправиться. Управлением станком, интерполяцией, слежением за осями, т. е. всеми вопросами в РВ управляет спец. процессор MCI (УЧПУ). И никаким Вин-ом в нём не пахнет (не бутылка он), ни NT, ни XP, ни 95, ни 98.

Re: SIEMENS и NT
Андрей В.; 15.9.03

У меня за плечами разработка УЧПУ.

Чего там у SIEMENS MCI делает тоже знаю. Конструкторов SIEMENS в Гарварде и Масачусете учили преподаватели с сильным русским акцентом, которые Б.Г. не любят :)
Это раз.
А во вторых на NT 4.0, 2000, XP работают другие системы РВ, типа TraceMode - нашего производства. На пне 100 успевали ловить импульсы от датчика двигателя, и ещё на Word время оставалось, отчёт писать.
Только перевели ядро на приоритет RealTime.
Скорость обработки прерываний на P100 и NT 4.0 = 90 мкс.
...отвечаю.

Re: SIEMENS и NT
Чистяков Дмитрий ОАО СеверСталь; 15.10.03

Windows Embedded - это не что иное как Windows CE. А это как известно отнюдь не ОС РВ. :-)

-
fresco; 17.10.03

Re: SIEMENS и NT
Андрей В.; 19.11.03

и много здесь:

www.vci.com

в Windows СЕ ядро РВ от этой фирмы.


SP4 для STEP 7 v5.1
Петров Андрей; 19.6.03

Не подскажите, как можно заполучить SP4 для STEP 7 v5.1. Заранее благодарен.

Re: SP4 для STEP 7 v5.1
Роман Абзаев; 19.6.03

А почему не SP6 сразу? В принципе, если есть желание, то можно скачать с www4.ad.siemens.de. Только предупреждаю - это МНОГО (130 МБ)! Либо в ближайшее бюро обратиться.


STEP 7 V 5.2 с авторизацией
Vadi; 18.12.03

У меня STEP 7 V 5.2 без авторизации, установленная на WinXP.

Вопрос 1: где можно достать авторизованную дискету или crack (patch) для версии STEP 7 V 5.2.
Вопрос 2: можно ли работать или тестировать программы в PLSIM без авторизации.
Хотелось бы найти patch или авторизованную дискету для работы, без нее не могу. Спасибо заранее кто ответит

Re: STEP 7 V 5.2 с авторизацией
Baby; 20.12.03

Привет !!!!

Vadi, нехорошо на официальный сайт обращаться за "crack (patch)" и т.д.
Для этого есть неофициальные сайты , да и вообще англо... и т.д. ...язычный инет.........
Ответ на вопрос 2 : нет.

Re: STEP 7 V 5.2 с авторизацией
Дмитрий; 22.12.03

Четно говоря на вопрос 2 ответ "можно", но с версии симулятора 5.2. Но постонянный поиск авторизации сильно затрудняет процедуру отладки.


Step 7 v.5.2
Владимир; 30.4.03

Подойдет ли ключ от Step7 v.5.1 к Step7 v.5.2? Или нужна новая ключевая дискета?

Re: Step 7 v.5.2
Андрей Гуленок; 30.4.03

Нет. Не подойдёт. Нужна новая ключевая дискета


Step7 & WindowsXP
Iva; 20.1.03

Пытаюсь установить Step7 V5.1 на WindowsXP - не получается. После выбора языка установки выводит окно - не могу найти файл. И всё. Кто нибудь смог установить?

Re: Step7 & WindowsXP
Viktor; 20.1.03

У нас было то же самое на W2000. Попробуйте вручную указать ему этот файл. У нас так пошло.(S7 V5.1 SP4)

Re: Step7 & WindowsXP
Iva; 20.1.03

Ага. В ручную указать.

Вот только какой файл ему надо он не пишет. И возможности найти самому этот файл - тоже не даёт. Просто выводит окно с Run-Time error '53' File not found и всё. Дальше вылетает.
Конкретно я ставлю S7 V5.1 SP1.
Runtime Error 53
Михайлин Сергей; 20.1.03

Ну дык насчет Runtime Error 53 давно уже выяснили в чем фишка. Она связана с наличием в именах файлов, относящихся к НЕ-английской (немецкой, французской, испанской и итальянской) документации, непропечатавыемых символов при использование русской или руссифицированной операционной системы.

Для решения этой проблемы есть 2 пути:
- на время инсталляции в Контрольной Панели-Региональных установках убрать поддержку Русскоя языка и установить, например Англию.
- скопируйте дистрибьютив на винчестер (кроме указанных выше файлов) и произвести установку с копии

Эта методика кстати относится и к другим пакетам, если выскакивает сабж.

Re: Step7 & WindowsXP
Seven; 2.2.03

Очень.. очень странно... у меня Win ХР русская, при установки Step7 V5.1 SP1 ни каких проблем не было, даже умудрился установить Siwarex-U, который на Win2000 не устанавливался...

Re: Step7 & WindowsXP
Crazy; 29.8.03

на одну машину встало без проблем , а на другой пришлось w2k ставить


Step7 Internal Error
VVS; 4.2.03

Кто-нибудь знает, что означает след. сообщение : (257:26) Internal error: Unable to set up the connection between two objects.

Появляется эта ерунда когда делаешь cross-reference. Самое интересное, что сделать Save as with reorganization она не дает. Избавиться-то я от этого ибавился, но хотелось бы понять в чем фича.
Избавился так:
1Create new Program folder
2Copy Blocks folder into this new Program folder
3Delete old Blocks folder
4Move new folder on his place
не знаю на сколько это корректно, однако сработало.

См. S7 internal error


Step7 Sp
Евгений; 3.7.03

Подскажите где можно скачать последний

(SP 6) для step7 v5.1
Заранее спасибо.

Re: Step7 Sp
Назаров Дмитрий; 3.7.03

Эдесь! Размер файла около 120 Мб.

См. http://www4.ad.siemens.de/csinfo/livelink.exe?func=cslib.csinfo&objId=11123192&objAction=csBrowse&lang=en&siteid=cs&aktprim=0


Step7_51_SP4_and_PLCSim_5_SP1
vvgut; 18.3.03

Среда: Win2000Pro+SP2, Step7 V5.1+SP4, PLCSIM V5.0+SP1.

В процессе загрузки S7Program.Blocks cтанции S7-400 с CPU 416-2DP (6ES7 416-2XK02-0AB0) в PLCSIM после положительного ответа на вопрос: "Do you want to delete system data on the module [0/3/0] 416-2DP completely and replace them with offline system data?" появляется диалоговая панель со следующим сообщением (формат сообщения изменен):
The configured module (offline) is different from the taget module (online):
Order number
Offline 6ES7 416-2XK02-0AB0
Online 6ES7 841-0CC02-0YE0
Firmware version C5.1.0

Почему появляется это сообщение и на что это может повлиять? Можно ли сделать так, чтобы сообщение не появлялось?
Проверка проведена (в т.ч.) на PowerPG с предустановленными Step7 V5.1+ SP4 и PLCSIM V5.0 + SP1 после установки авторизаций. Для других CPU (в т.ч. S7-300) - то же самое.
При использовании Step7 V5.1+ SP1 этого предупреждающего сообщения НЕТ.
Благодарю за внимание.
Re: Step7_51_SP4_and_PLCSim_5_SP1
Чистяков Дмитрий "СеверСталь"; 18.3.03

Встречалось такое дело.

Проблема в самом проекте.
Попробуйте сохранить проект с реорганизацией (есть там такая галочка).
Если не поможет, то придётся переделать описание конфигурации в HardWare.

Re: Step7_51_SP4_and_PLCSim_5_SP1
Назаров Дмитрий; 27.3.03

Ничего страшного в этом нет. STEP7 "поумнел" и когда загружаете проект в PLCSIM он видит, что контроллеры (а PLCSIM - это для STEP контроллер!)разные и честно вам об этом сообщает. Кликаете ОК и работаете дальше.


SWRedun-cy в WinCC
Петров Андрей; 20.10.03

Кто-нибудь подскажет почему в WinCC v5.0 sp5 отсутствуют компоненты для создания резервировной связи между контроллерами (DynWizEdit.exe). Может нужна другая версия WinCC. Если кто либо что-нибудь знает, поделитесь пожалуйста.

Re: SWRedun-cy в WinCC
Дмитрий; 4.11.03

Возьмите за основу проекта WinCC v5.1 все мастера на месте. А в вашей версии может были ошибки при установке и визард просто не установился?


Update Micro/win v3.1
Wert; 11.6.03

Нигде не нашел информации как можно и можно ли обновить Micro/win 3.1.1.6 до версии 3.2.х. Помогите пожалуйста.

Re: Update Micro/win v3.1
Роман Абзаев; 11.6.03

Можно. Просто савите апгрейд с диска "Микросистемы", только учтите что на самом деле все немножко хитрее. Вам придется начать установку 3.2, затем ручками деинсталлировать 3.1, а потом ставить 3.2


Update STEP7
walet; 29.4.03

Как за минимальные деньги обновить STEP7=Micro/WIN Ver. 2.0 до STEP7 Micro/Win 3.2?

Re: Update STEP7
Роман Абзаев; 29.4.03

А Вы где, батенька, живете?

Re: Update STEP7
walet; 30.4.03

В Томске.


WinAC функция чтения данных
Papik; 10.12.03

Кто может описать функцию

Компонента S7DATA --- ReadVariable(BSTR VariableName, VARIANT* Value, long* State,long TimeOut);
Если можно то по подробнее


WinAC
Дмитрий; 1.5.03

Подскажите, где можно найти WinAC Basic V3.0 или выше? Демо или полноценная версия - не имеет значения. И стоит ли с этим (WinAC) связываться?

Re: WinAC
Назаров Дмитрий; 6.5.03

Смотря где проживаете. WinAC Demo можно найти в ближайшем офисе или у партнера СИМЕНС. В мире много применений WinAC, и связываться с ним можно.


Авторизация UPGRDE STEP7 V3.2 --> V5.1
Кирилл; 4.8.03

Возможна ли авторизация UPGRDE STEP7 V3.2 --> V5.1, если для V3.2 имеется только аварийная авторизация (14 дн.).


Вопрос к Sigraph
Павел Синица; 16.8.03

Меня заинтересовала програма promis engin·e®/SIGRAPH CAE но как ее можно скачать.

Свяжитесь со мной snaric@rambler.ru

Re: Вопрос к Sigraph
Павел Иванов (Сименс-Москва); 18.8.03

Это продукт другого департамента фирмы Сименс. Департамент называется I&S (Industrial System & Solutions). Свяжитесь с ними. У них свой сайт.


Вопрос представителям SIEMES по STEP7
SAP; 8.12.03

Уважаемые господа! Мы перешли на новую версию STEP7, которая определяется в HELP как STEP 7 V 5.2+HF2 REVISION LEVEL K5.2.0.2. Как я понимаю это 6 версия. При компиляции проекта генерируется SCL файл, который содержит явные ошибки. Игра с опциями настройки компиляции не дала результатов. Хотелось бы передать информацию об этой ошибке разработчикам. Как это сделать??

Re: Вопрос представителям SIEMES по STEP7
В. Сорокин.; 8.12.03

Могу добавить. Иногда 5.2 забывает, что такое компаратор. Правда только для меркеров. Такую муть несёт, ругается. Правда всё работает, но страшно ведь.

Re: Вопрос представителям SIEMES по STEP7
Дмитрий; 8.12.03

А в STEP7 v5.2 SP1 такая ошибка есть?

Re: Вопрос представителям SIEMES по STEP7
SAP; 8.12.03

Нет. Мы переносим типовой проект на новую версию. В старом все ок. Самое обидное, неизвестно это единичный баг, или еще их немерено... Ну этот нашли на этапе тестирования, не дай бог новый вылезет на объекте. У нас опасное производство. Рванет, мало не покажется.......... :(( Все сроки коту под хвост. Надо отладку и тестирование систем, даже переносимых один в один из старого проекта, проводить по полной программе...

Re: Вопрос представителям SIEMES по STEP7
Михайлин Сергей; 23.12.03

Вообще-то очень странно! Но разберемся... Присылайте лог файл на мой ящик. Теперь уточнения, которые тоже хотелось бы получить в письме: у вас был просто STEP7 или STEP7 Pro, потому как не очень понятна фраза SCL код. У Вас SCL тоже стоит или стоял? Это отдельный пакет. Потом V5.2 это именно 5.2 а не 6. Конечно первое что можно порекомендовать, это установить последние сервис паки на STEP и на SCL(если он действительно есть). Но лог все равно надо глянуть.

Re: Вопрос представителям SIEMES по STEP7
Алексей Родионов, "Искра-Энергетика"; 23.12.03

Отвечу за SAPа. Мы перешли на PCS7 v6.0 Туда, соответственно, входит и SCL.

Проблема в следующем:
В CFC связан выход FC с входом FB, связанные переменные имеют тип TIME. В сгенеренном SCLкоде, выход FC записывается в промежуточное DB, где есть массив типа TIME и, главное, запись туда заносится в символьной адресации (DB.time[1]), а на вход FB считывается через абсолютную (DB.DD1), а должно быть DB.DD4 или DB.time[1].
2 Михайлин Сергей: Этот фрагмент SCL-кода Вам вышлем. Может еще что-то надо?
Компилятор ошибок не выдает.
Re: Вопрос представителям SIEMES по STEP7
Astronom; 25.12.03

Можно и я ругнусь по поводу STEP7 5.2 SP1. На мой взляд довольно сырой продукт и глючный (даже с первого захода видно много сырого)... У меня был опыт на объекте, но операционка ХР и озу 128 было,под 2000 вроде более стабильно.

Так вот, в онлайне стока глюков было, шо ни пером описать ни....
и глюки конкретные, не связанные с профанизмом)
С сименом уже совсем не первый год...
Сижу за 5.1 sp6 переходить не собираюсь
Re: Вопрос представителям SIEMES по STEP7
Григорий; 25.12.03

У меня некоторые мысли по поводу высказанных проблем, хотя может я не прав:

1. В step5.1 приоритет (умолчание) отдано абсолютной адресации, а в 5.2 - символьной
2. Скаждый новый продукт почему-то становится все больше и больше как по расходу материальных ресурсов компа так и временных, несущественно добавляя функциональности. Было бы хорошо ставить его более избирательно.
В новом году ожидается очередная версия Step a, и я с ужасом думаю об очередном монстре, который, скорее всего, будет требовать глючную Windows XP, хотя для целей разработки ПО этого не надо. Мне кажется, что связи Siemens и Microsoft стали слишком близкими :-)

Re: Вопрос представителям SIEMES по STEP7
Nec; 29.12.03

У нас тоже была проблема связи через Profibus с помощью версии 5.2, после установки версии 5.1 все заработало. Правда несколько нововведений мне понравилось (например отображение процесса при сравнении), но пришлось от нее отказаться.


Вызов FB
Eugene Sergeev; 8.12.03

Можно ли вызвать один и тот же FB c разными данными одновременно ( не совсем, конечно, одновременно, но до того, как предыдущий вызванный блок закончит работу)

Типа такого
OB1
CALL FB15.DB15(Param:=1);
CALL FB15.DB15(Param:=2);
END_OB1
etc

Re: Вызов FB
Baby; 9.12.03

Привет !!!!

Конечно можно, естественно, адреса
в DB15, должны быть разными.
Re: Вызов FB
Eugene Sergeev; 10.12.03

Меня больше такой вопрос интересует - DB15 - один, и все переменные в нем статические. Если вызвать ФБ второй раз, когда первый еще работает, эти значения перепишутся - т.е. побьются для первого ФБ. Или как-то по другому все это будет?

Re: Вызов FB
Nec; 12.12.03

Судя по сегменту ты вызываешь блок с параметром 2, после того как закончит работу блок с параметром 1. Так что, никаких переписей значений быть не должно.

Re: Вызов FB
Baby; 14.12.03

Привет !!!!!!

У нас есть DB (называется DB настроек)
, так он вызывается в местах 20, в разных FC, FB,OB всё работает ОК.
Re: Вызов FB
Иван Данилушкин; 15.12.03

Вопрос вообще некорректно поставлен: не может новый FB вызываться до тех пор пока старый не отработал! Это же распараллеливание процессов!

Re: Вызов FB
Baby; 16.12.03

Привет !!!!

Special for Иван Данилушкин.....
Например, у Вас есть 20 клапанов...
Для управления 1 клапаном Вы написали
FB15, а теперь хотите управлять 20 клапанами с помощью 20 FB15 и одним DB15..
Будет это работать или нет ?! ;-) !!!!

Re: Вызов FB
Mennonit; 16.12.03

Это возможно с использованием Multiinstanz. В этом случае создаёте другой FB (Например FB20). Декларируете в нём 20 STAT-Variabl с типом данных "FB15". Например

VAR
Klapan1 : FB 15;
Klapan2 : FB 15;
..............
END_VAR
И вызываете Ваши мултиинстанцы:
CALL #Klapan1
CALL #Klapan2
Но проще создать 20 Инстанц-DBs и не мучиться.
Re: Special for ...
Иван Данилушкин; 18.12.03

В общем случае нельзя гарантировать корректной работы. В частном, если DB содержатся только переменная Param и неизменяемые в FB15 данные, то работать будет нормально.

Но "правильным" подходом, с точки зрения идеологии Step7, я думаю, является создание двадцати DB

Типа такого
OB1
CALL FB15.DB15(Param:=1);
CALL FB15.DB16(Param:=2);
CALL FB15.DB17(Param:=3);
etc

END_OB1

С уважением


Где "достать" PLC Analyzer Pro ???
Александр Ковальчук; 10.4.03

Только не ДЕМКУ, а живую...

На демку налюбовался, а на "живую" денег не дают!
Re: Где
Юрий Оганесян; 11.4.03

А что это такое, если не секрет...?

Re: Где
Александр; 12.4.03

Это типа самописца для S5 - S7 с обалденными возможностями :-)

Re: Где
Baby; 15.4.03

Приветствую !!!

"Обалденные возможности" у ServiceLab и DASYLab.....

Пока......
И Где взять???
Александр Ковальчук; 22.4.03

"Обалденные возможности" у ServiceLab и DASYLab..... да?!!!

И Где взять???
Заранее благодарен!

Re: Где
Baby; 28.4.03

Приветствую,Александр !!!!!

" Где взять??? "
По хорошему раскручивать начальство на покупку....
По плохому искать у тех -> cм.выше....

Удачи........


Где взять STEP 7
Александр; 21.5.03

Подскажите, где можно взять STEP 7?

Может кто может выслать по e-mail?
Re: Где взять STEP 7
Чистяков Дмитрий ОАО СеверСталь; 21.5.03

Ну, ты даёшь! :-)

1. Дистрибутив STEP7 весит 430 метров в упакованном виде.
2. Всё равно потребуется дискета с авторизацией. Ключик то бишь.
3. Купить можно у любого представителя ближайшего.

Re: Где взять STEP 7
Семен; 17.6.03

так что, нет вариантов найти step7.

Я вот например хотелбы хоть глянуть как и с чем его едят

Re: Где взять STEP 7
В. Сорокин.; 17.6.03

Когда-то, давным-давно, у Сименса была демо версия 3.1. Качать в контроллер не могла, но развлечся можно было. Попросите на Сименсе, может ещё не все компакт-диски выкинули.

Re: Где взять STEP 7
Назаров Дмитрий; 18.6.03

В ближайшем офисе СИМЕНС есть диск STEP7 & Engeneering Tools Demo. См. раздел "О нас"


где взять STEP5
Andrey; 21.11.03

нужно посмотреть программу в S5 90U, где можно найти STEP5 ?


где взять
александр; 4.9.03

кто знает где взять Simatic Step7 V5.2

и WINCC 6 . А то посмотреть хочется .

Re: где взять
Чистяков Дмитрий ОАО СеверСталь; 4.9.03

У предеставителей, партнёров, есть Demo диски.


Где можно
Сергей; 26.6.03

Необходим Service Pack для Step7

и ProTool желательно последний

Re: Где можно
Lexus; 8.7.03

Скиньте мыло на Lexus_SL@ngs.ru, то которое указано не пашет почему то.


где можно скачать STEP 7 V5.1 SP1
Сергей Давидовский; 29.11.01

где можно скачать STEP 7 V5.1 SP1

Re: где можно скачать STEP 7 V5.1 SP1
Viktor; 2.12.01

Позвоните(или пишите) мне, возможно помогу.

Re: где можно скачать STEP 7 V5.1 SP1
Алексей Войлочников; 23.10.03

Здравствуйте, Виктор!

Помогите скачать STEP 7 V5.1,
с целью ее изучения.

См. http://(3532)73-32-90 доб.1-43

Re: где можно скачать STEP 7 V5.1 SP1
Дмитрий; 28.10.03

Обратитесь к ближайшему региональному стортуднику СИМЕНС. См. радел "О нас"


Глючит программатор
Дмитрий; 24.9.03

Доброго всем времени суток. У меня вот какая проблема: на программаторе Siemens PG 720PII при работе в STEP7 V5.1 под Windows98 SE (всё лицензионное) наглухо зависает компьютер при выборе какого-нить пункта из выпадающего меню. Скорее всего это глюк виндов - иногда такое бывает и в других приложениях, но в степе7 - постоянно. Может кто чего посоветует? Заранее благодарен.

Re: Глючит программатор
Симахин Александр; 18.11.03

Поставь вместо Win98 NT или Win2000.


Загрузка программ в S7-400
Григорий; 4.11.03

Можно ли каким-либо образом загружать программные блоки в S7-400, не используя Step7, чтобы не давать последний на объект.

Prodave позволяет грузить DB. Может есть что-либо аналогичное и для FC и FB


Задача про бассейн.
Николай Федченко; 25.8.03

Через трубу А бассейн наполняется. Скорость наполнения, расход через

трубу А нам пеподконтролен и может меняться по разным причинам.
Через трубу Б мы сливаем из бассейна, есть датчик расхода. Расход можем
регулировать, в трубе Б стоит задвижка с эл.приводом и датчиком
положения затвора задвижки. В бассейне есть также датчик уровня.
ВНИМАНИЕ ВОПРОС. Нужно обеспечить удержание уровня в определенных
пределах, не слишком часто дергая эл.привод задвижки, необходимо ли
здесь дискретное ПИД-регулирование, или учитывая большую инертнось
системы (бассейн большой - трубы маленькие) можно обойтись более
простыми средствами. Если было у кого что либо подобное , поделитесь
опытом.


Закрытые функции в STEP7 (не системные!!!)
Дмитрий; 15.12.02

Дали переделать проект, а там есть закрытые функции (не системные!!!).

Есть ли возможность ломануть их?
Если есть, то подскажите как.
И еще - не могу найти информацию о структуре проекта STEP7 (что и в какие директории и файлы он пишет). Поможите кто чем может. Заранее благодарен.
Re: Закрытые функции в STEP7 (не системные!!!)
fog; 19.12.02

Чтобы открыть функцию нужно исправить 1 в 0 в одном из файлов (в каком не помню - давно это было).

Re: Закрытые функции в STEP7 (не системные!!!)
Андрей; 28.1.03

Это наверно FC1 и FC2, получить и принять данные с PROFIBUS или что-то подобное из библиотеки?

Re: Закрытые функции в STEP7 (не системные!!!)
Игорь Кайдашов; 29.1.03

Всем привет!

Защита на FC, FB.
Открываете в MS ACCESS файл
C:\SIEMENS\STEP7\S7proj\Имя_проекта\ombstx\offline\00000001\subblk.dbf
в таблице находим колонку Password, на защищенном блоке стоит признак "3", меняем на "0" и всё в порядке.

Re: Закрытые функции в STEP7 (не системные!!!)
fog; 30.1.03

Не всё в порядке!

MS ACCSESS 2000 выдаёт ошибку -
"Нераспознанный формат базы данных".
Re: Закрытые функции в STEP7 (не системные!!!)
Игорь; 30.1.03

Если MS ACCSESS 2000 выдаёт ошибку-может проблема в нем. Так как у меня все работает.(Специально попробовал ещё раз)

Можете открыть базу в DATABASE DESKtop от Delphi или ....
Re: Закрытые функции в STEP7 (не системные!!!)
Baby; 30.1.03

Привет, Игорь !!!!

Знаете, Вы подарили мне несколько минут огромной радости !!!!!!!
Зарубежная фирма делала у нас проект.
Мне было очень интересно (чисто спортивный интерес), как работает одна функция. К сожалению, блок оказался под защитой. Пользуясь Вашими рекомендациями защита оказалась обойдена !!!!!!!!!!!!!!!!!!!!!
Ооо, я прыгал от счастья до потолка !!!!!! и всё благодаря Вам !!!!!!

Спасибо за всё !!!!
Удачи !!!!!

Пока........

Re: Закрытые функции в STEP7 (не системные!!!)
Любитель Симатика; 30.1.03

Просто интересно...

Сколько проживет этот тред прежде его покоцает модератор из Зюменса? ;-)))

ЗЫ А фича известная правда не очень нужная. ИМХО мне брать на себя ответственность за такие вещи не очень хочется; хим. реактор под боком! :-)
Re: Закрытые функции в STEP7 (не системные!!!)
Игорь; 30.1.03

Ещё раз привет!

Рад за всех.
Хотелось бы чтобы это помогло вам в профессиональном росте (тяжело вариться в собственном соку).
Кстати есть программулька, которая делает тоже самое при этом достаточно ввести только название проекта.

Re: Закрытые функции в STEP7 (не системные!!!)
VVS; 4.2.03

А вот насчет программулины эт - интресно. Намыль, если не в лом.

Re: Закрытые функции в STEP7 (не системные!!!)
Владимир; 13.3.03

И мне намыль плиз.

Re: Закрытые функции в STEP7 (не системные!!!)
San; 13.3.03

Посмотрите сайт www.runmode.com - там много всяких полезных программок


Использовать SIMATIC BATCH
Diana; 5.12.03

В комплекте PCS7-6.0 имеется некто SIMATIC BATCH. Кто знает что это за зверь и для чего он нужен, а также что позволит сделать приложение SIMATIC BATCH, вставленное в конфигурацию Simatic PC Station?

Re: Использовать SIMATIC BATCH
Михайлин Сергей; 5.12.03

Это целая область, которая называется автоматизация рецептурных процессов и SIMATIC BATCH предназначен именно для этого. С помощью него можно легко автоматизировать производства где часто и широко используются для производства рецепты (фармакология, тонкая химия, пищевка, смешение и тд)


Как производить отладку в пошаговом режиме в Step 7
SLK; 30.7.03

Как производить отладку в пошаговом режиме в Step 7

Re: Как производить отладку в пошаговом режиме в Step 7
GorA; 31.7.03

Нужно включить on-line в Blocks SIMATIC-menager. Затем загрузить требуемый FB,OB в режиме STL. Появляется возможность устанавливать точки прерывания. С любой точки прерывания можно выполнять пошаговый режим. Переключатель на процессоре должен быть в RUN-P.


Киньте W95_S7.DLL из пакета PRODAVE S7
Nec; 13.4.03

На RUNMODE программку скачал, а она требует PRODAVE или W95_S7.DLL. Если не сложно киньте на мыло.

Заранее благодарен. С уважением, Алексей.

Re: Киньте W95_S7.DLL из пакета PRODAVE S7
Andrey; 14.4.03

Эта dll стоит денег. Она входит в PRODAVE.

Re: Киньте W95_S7.DLL из пакета PRODAVE S7
Kirill; 7.5.03

ПОПОДРОБНЕЕ


кириллица в STEP-7
Вадим; 23.7.03

введённые кириллицей комментарии в редакторе символических имён неправильно отображаются во всплывающей подсказке в редакторе программных блоков (нечитаемая белиберда). Что это? Глюки Win98SE, который установлен в программаторе PG740 или это кде-то настраивается в самом пакете STEP-7? Системные шрифты менял все - не помогает. Кто сталкивался, помогите.

Re: кириллица в STEP-7
Чистяков Дмитрий ОАО СеверСталь; 23.7.03

Старая тема. Раньше даже был ответ в FAQе.

Проблема в кодировке кириллицы. Необходимо в реестре переписать все ссылки на кодировки 1250 и 1252 на кодировку 1251.

Re: кириллица в STEP-7
Вадим; 24.7.03

Спасибо, помогло


Кто- нибудь видел самописец на S7 (типа Fahrt)
Nec; 3.10.02

Иногда при отладке S5-программ пользовался FAHRTом, теперь хотелось бы найти что-то подобное для S7.

Re: Кто- нибудь видел самописец на S7 (типа Fahrt)
Baby; 4.10.02

Привет,Nec !!!

Как настроение ?????
Да, для S7 есть множество самописцев...
В сети их полно, НО (!!!!) они все демо...
Родной пакет Siemens, ServiceLab
http://www.ad.siemens.de/servicelab/html_00/support/download.htm
Я пользуюсь ServiceLab 4.Х ( не помню точно версии)...
Кстати, по моему ServiceLab можно и для S5 использовать необходим модуль S5, у нас как раз появилась необходимость протестировать программу на S5 с помощью самописца...
Nec,расскажите о FAHRT может можно скАчАнуть откуда-нибудь.....
Рад..встрече...

Re: Кто- нибудь видел самописец на S7 (типа Fahrt)
Nec; 8.10.02

FAHRT - это DOS-овская программа, которая связывается с S5 и при наличии в контроллере двух FB и трех DB записывает до 16 битовых сигналов (входа, выхода, метки, данные, таймеры). По объему небольшая - могу послать по почте. Встроенные возможности анализа и распечатки результатов. Если надо оставь свой E-mail.

Re: Кто- нибудь видел самописец на S7 (типа Fahrt)
Alex; 8.10.02

PLC-ANALYZER

Посмотрите здесь:
http://www.autem.de/e_index.htm

Baby, свяжись со мной по почте
Nec; 15.10.02

Хочу задать пару вопросов по ServLab.

Жми на Nec - там ссылка на почту.
Re: Кто- нибудь видел самописец на S7 (типа Fahrt)
Baby; 18.10.02

Привет,Nec !!!

Как у Вас с погодой ????
Или я что-то не так делаю.....
или у Вас не рабочий (в смысле адрес)
е-mail.....

До скорого......

Re: Кто- нибудь видел самописец на S7 (типа Fahrt)
Борис; 19.2.03

Есть ещё PLC-ANALYZER Pro http://www.drawtrend.com/

Re: Стоимость написания программы на S7
Андрей; 8.4.03

Сколько стоит шаг программы на Simatic


Кто работает с ElectriCS?
Victor; 1.10.03

Каковы впечатления от ElectriCS? Чем лучше других подобных программ. Если другие лучше, тоже - чем?


лицензионный пакет- восстановление
Iurii Suhovic; 19.3.03

- Что происходит в случае, если обнаружится сбой в операционной системе с лицензионным пакетом программирования и требуется переустановить Windows. Как мы можем восстановить ключевую дискету - где и в какие сроки, в случае повреждения и др.( Понимаем, что пакет MicroComputing V1.0 с красной дискетой предназначен для установки только на одно рабочее место...)
Re: лицензионный пакет- восстановление
Чистяков Дмитрий "СеверСталь"; 19.3.03

Чуть правее вашего вопроса имеется ссылка "Ответы на часто задаваемые вопросы"

Там всё расписано


Можно ли найти учебник по LAD
Григорьев Сергей; 13.7.03

Имеются справочники по LAD, SFC в формате pdf, но для самостоятельного обучения информации не хватает. Можно ли найти учебник по LAD, SFC. Заранее спасибо.

Re: Можно ли найти учебник по LAD
Дмитрий; 14.7.03

Как стало известно в особо приближенных кругах, переводится на русский язык учебник Ганса Бергера по программированию в STL,LAD,FBD для STEP7. Есть перевод старого учебника для STEP5.

Re: Можно ли найти учебник по LAD
Дертунов Борис; 15.7.03

Что конкретно интересует? В pdf по-моему всё очень подробно описано. Есть конкретно, по LADу и SFC хорошие файлы. А если не хватает информации может лучше обучение пройти?

Re: Можно ли найти учебник по LAD
gregar; 17.7.03

А где можно скачать эти справочники в формате .pdf по LAD, STL, FBD и старый (или новый) учебник Ганса Бергера по программированию для STEP7? Может поделитесь ссылочкой или на мыло (gregar@mail.ru)сбросите? А то жуть как хочется почитать эти детективы:).

Re: Можно ли найти учебник по LAD
Дмитрий; 18.7.03

На этом же сайте в разделе "Системы автоматизации СИМАТИК" можно скачать учебник по программированию для STEP5. Учебника для STEP7 в электронном виде нет, только английский вариант в бумажном виде. А детективы очень интересные...

См. http://www.aud.ru/as/


Нужна ваша помощь, специалисты!!!
Роман; 4.6.03

Здравствуйте, господа!

Очень нужна ваша помощь! У меня тема дипломного проекта - "Автоматизация выпарной установки томат - пасты на консервном заводе". Используется ПЛК Simatic S7-200. Нужна какая - нибудь программа на STEP 7-Micro/WIN 32 v.3.2 или на Delphi, имитирующая контроль хотя бы над похожим процессом. Можно вообще что-нибудь из области консервной промышленности, слабо связанное с моей темой. Если можете, помогите, а то защита диплома 16 ИЮНЯ, совсем скоро!!! Заранее спасибо.


Обновление STEP7
walet; 29.4.03

Как за минимальные деньги обновить STEP7=Micro/WIN Ver. 2.0 до STEP7 Micro/Win 3.2?

Re: Обновление STEP7
В. Сорокин.; 5.5.03

Micro/WIN - бесплатное приложение к стандартному STEP7, входит в диск "Руководства на русском языке" - д. б. у всех Сименс-партнёров. Для полного счастья нужен ещё "шнурок" PC/PG - его покупают.

А чаще нанимают людей или фирму (www.technopolus.ru).
Re: Обновление STEP7
walet; 6.5.03

"Шнурок" PC/PG у меня есть, есть и STEP7 Micro/Win 32 Ver. 2.0 но как мне сказали эта версия не работает с S7-200 (CPU224). Поэтому нужно обновить до STEP7 Micro/Win32 Ver.3.2.

Нашёл в каталоге Siemens под 6ES7810-2BC02-0YX0 обновление, подойдёт ли оно в моем случае?

Re: Обновление STEP7
Андрей Гуленок; 6.5.03

Micro/WIN это коммерческое ПО, которое стоит некоторых денег. То, что Сименс закрывает глаза на его безконтрольное копирование не делает его бесплатным. А обновление имеет каталожный номер 6ES7810-2BC02-0YX3

Re: Обновление STEP7
В. Сорокин; 6.5.03

Бесплатное - термин, прошу прощения, имеется в виду: без авторизации.


Обучение Step 7
Алексей; 20.4.03

Подскажите, где пройти обучение по Step 7 в С-Петербурге?

Re: Обучение Step 7
Андрей Гуленок; 21.4.03

Обратитесь в Питерское представительство к Игорю Долганову.

Re: Обучение Step 7
Алексей; 26.4.03

Андрей, спасибо! А телефон Долганова не подскажете?

Re: Обучение Step 7
SDolganov; 5.5.03

http://www.aud.ru/about/regions/6/index.php


Описания языков программирования по стандарту IEC 1131-3
Евгений; 2.3.03

Где взять детальные описания языков программирования промышленных контроллеров по стандарту IEC 1131-3 (МЭК 1131-3)?


отсутствие cpu 414-4h
Aleksey_1980; 3.11.03

Не могу найти в HW Config cpu 414-4h (v 5.2). Вроде нужен какой то пакет s7-h - так ли это и где его можно качнуть???

Re: отсутствие cpu 414-4h
Евгений Трунов; 4.11.03

А как же. S7 H Systems V5.2, 6ES7833-2AC01-0YA0, 300 евро.

Re: отсутствие cpu 414-4h
Aleksey_1980; 5.11.03

А скачать нахалявку нигде нельзя?????

Re: отсутствие cpu 414-4h
Aleksey_1980; 5.11.03

Re: отсутствие cpu 414-4h
Aleksey_1980; 5.11.03

А скачать нахалявку нигде нельзя?????

Re: отсутствие cpu 414-4h
DRON; 12.11.03

Ну скачать, может быть и можно... Дык к нему еще и авторизация требуется!:(


Отсутствие CPU313C-2DP?
Andrey; 28.3.03

Не могу найти в каталоге HW Config(Step7) блок CPU313C-2DP. Его там нет. Может нужно обновить каталог? Если -да, не подскажите где его можна скачать?

Re: Отсутствие CPU313C-2DP?
oleg; 30.3.03

Если у тебя step7 v5.1 то качни sp6 на немецком сайте http://www4.ad.siemens.de/csinfo/livelink.exe/fetch/12642848/STEP7_V5_1_SP6.zip

после установки он там есть

Re: Отсутствие CPU313C-2DP?
Andrey; 1.4.03

Спасибо. Все ОК!


По для MP370
DEE; 15.9.03

Hi!

Подскажите, для панели MP370 нужна ли Run Time лицензия или достаточно пакета Pro Tool Pro CS (пает разработки)? И для каких систем нужно заказывать Run Time лицензию? Для PC Based? Только для проектов, исполнительные модули которых будут крутиться на PC?

Re: По для MP370
Дмитрий; 16.9.03

Все верно. Для МР370 достаточно пакета CS. RT лицензия только для проектов под PC. А что имеется ввиду под PC Based - WinAC? Для него своя лицензия.

Re: По для MP370
DEE; 16.9.03

Прошу прощения, это я не подумав написал "PC Based". В данном конкретном случае я имел ввиду проекты, рантайм которых работает на компе. А за ответ, спасибо...


ПО Для моделирования процессов
Михаил; 7.8.03

Хотелось бы узнать есть ли вообще такое программное обеспечение у сименса или у других производителей с помощью которого можно было бы смоделировать какой либо производственный процесс и как это все будет работать под управлением контроллеров фирмы сименс.

Re: ПО Для моделирования процессов
Михайлин Сергей; 8.8.03

Вопрос сложный и интересный. Первое что надо определить, для чего Вам требуется моделирование? Для проведения оптимизации или для проведения обучения персонала управлению процессом?

Если первое то посмотрите это http://www.ad.siemens.de/sw-haus/apc/html_76/inca.htm
Если второе, то www.siemens.com/simit
Но в любом случае такие вещи очень специфичные и можно сказать уникальные для каждой задачи, но базовое обеспечение конечно есть.
Re: ПО Для моделирования процессов
Viktor; 15.8.03

Самый простой вариант:

Пишется обычный проект для контроллера и проект WinCC. Запускается симулятор и WinCC работает с данными от симулятора. Полноценная система!
Re: ПО Для моделирования процессов
Олег; 20.8.03

Не совсем полноценная...

- циклические прерывания только на предустановленной частоте
- не работает bsend/brecv (если не ошибаюсь.)
- тормоза жуткие
- не удобно имитировать входа/выхода контроллера.

Но в некоторых случаях помогает.
Re: ПО Для моделирования процессов
Дмитрий; 21.8.03

По поводу неудобства имитировать входа/выхода. Напиши прогамму на VB пусть она имитирует - механизм есть. Будет полноценней и будет помогать чаще :-)

Re: ПО Для моделирования процессов
Unity; 10.9.03

Неясно поставлен вопрос: "смоделировать какой либо производственный процесс". Смоделировать - что? Работа регуляторов? Отработка технологических блокировок? Уточните, будет более предметный разговор.

зы. А ПО ЕСТЬ.
Re: ПО Для моделирования процессов
Михаил; 10.9.03

Хотелось бы конечно смоделировать работу регуляторов например расхода жидкости или уровня жидкости.

Тоесть может уже есть какие либо мат. модели например емкости с жидкостью.
И хотелось бы например задав параметры
резервуара(объем, форму, и д.п.)
диаметр входной трубы, производительность насоса.
характеристику задвижки и т.д.
получить более или менее точную
модель процесса.
Re: ПО Для моделирования процессов
Неверов; 12.9.03

Есть программа на VBA которая моделирует именно резервуары и клапана.

Сервис минимальный т.е. изменения в параметрах только по тексту программы.
Во многом сырая, но ее можно использовать если сможешь править текст программы на VBA.
Работает в связке с симулятором S7ProSim.
Re: ПО Для моделирования процессов
Astronom; 25.12.03

Вообще немцы с разными пакетами (ПИДы)

дают простенькую модель процесса 1,2,3 порядка с постоянной помехой и возмущением. Просто и со вкусом.


ПО для панелей VT160W фирмы ESA
Николай; 12.9.03

Нужна программа VTWIN для прошивки терминальных панелей оператора VT160W фирмы ESA. Если кто видел, скиньте ссылку пожалуйста. Эти панели у нас работают в связке с S7-200.


Помогите нужен Standart PID Controls
Михаил; 8.8.03

Помогите пожалуйста нужен дистрибутив функциональных блоков Standart PID Controls - авторизация есть а самого дистрибутива нет.

pustozvonov@mail.ru
Re: Помогите нужен Standart PID Controls
Павел Иванов (Сименс-Москва); 18.8.03

Дистрибутив занимает 7 МБ.

Обратитесь в ближайшее к Вам представительство нашего департамента, Вам постараются помочь.


Порча пунктов меню
Григорий; 25.3.03

После установки STEPa 7 5.1 (англ. язык) в Windows (98SE rus) некоторые пункты меню в проводнике, Iexplorer и Help изменились с прусского на немецкий. Что нужно сделать, чтобы вернуть русские пункты назад.


Преобразование ТСП100 в Pt100
Андрей; 13.6.03

Необходимо измерять температуру с помощью термосопротевлений ТСП50, ТСП100. Как получить физическое значение температуры с помощью Simatic S7-400?

(Возможно существует программа перещёта с градуировки Pt100 в ТСП100 или ТСП50).
Re: Преобразование ТСП100 в Pt100
Владимир; 14.6.03

А как такой вариант:

Измеряем сопротивление датчика ТСПхх.
Берём градуировочную таблицу ГОСТ.
Строим табличную зависимость Т (Y) от R (X).Вычисляем полиномиальные коэффициенты (например в ORIGIN). Степень в зависимости от точности.Пользуемся ими в программе S7-400. Такой метод приемлем к любым термометрам сопротивления в т.ч. и к любым термопарам.


принтер
Евгений; 22.10.03

Может кто подскажет как подсоединить

к ОР 27 принтер и распечатывать то что нужно и когда нужно.(хотя бы основную идею). ---CPU s7-314 2DP.
заранее спасибо.

Re: принтер
Дмитрий; 28.10.03

Обратитесь к руководствам на русском языке на панель оператора ОР27 и к руководствам по конфигурированию в программе ProTool. Все "идеи" там описаны.

См. http://www.automation-drives.ru/as/products/doc.php?l1=SIMATIC%20HMI&l2=Панели&l3=doc


Проблемы ХР и Step7
kip; 25.2.03

После инсталяции Step7 ноутбук перестал выключаться(завершение работы

Windows). На РС под Win2000 - та же проблема. Step7 V5.1
Переустановка Windows и Step не решают проблемы. :=))
Кто нибудь сталкивался?
Re: Проблемы ХР и Step7
Юрий Оганесян; 26.2.03

Сделай юзера адванснутым

Re: Проблемы ХР и Step7
kip; 26.2.03

Вообщето мы работаем под эккаунтом админа

Re: Проблемы ХР и Step7
Чистяков Дмитрий ОАО "СеверСталь"; 27.2.03

Какой SP у Step 7 V5.1?

Ранние версии официально не поддерживали XP, так как его просто напросто ещё не было. ;-)
Скачайте SP6 для Step7 V5.1 с немецкого сайта

Re: Проблемы ХР и Step7
kip; 27.2.03

Step7 v5.1 sp4

А ссылку не подскажете?
Re: Проблемы ХР и Step7
Чистяков Дмитрий ОАО "СеверСталь"; 27.2.03

http://www4.ad.siemens.de/news/cs/en/12642848

Re: Проблемы ХР и Step7
Чистяков Дмитрий ОАО "СеверСталь"; 27.2.03

Да, забыл ещё.

Попробуйте накатить SP3 от Windows`а
Re: Проблемы ХР и Step7
Чистяков Дмитрий ОАО "СеверСталь"; 27.2.03

Блин, сегодня, сплошные очепятки у меня.

SP1
Re: Проблемы ХР и Step7
kip; 4.3.03

Проблема оказалась в ProTool.

После установки v5.2 Service pack 3 все заработало (Step 7 не апгрейдили)
Re: Проблемы ХР и Step7
Eleria; 10.3.03

А где взять SP3 под ProTool

Та же проблема
Re: Проблемы ХР и Step7
kip; 11.3.03

Когда-то качалось с официального сайта Siemens . Точно ссылку уже никто не помнит, пытались искать не нашли :-)

Надо ставить сначала ProTool 5.2 SP2, поверх него SP3. SP3 весит около 50 метров :=))
Re: Проблемы ХР и Step7
Cтрельников; 21.3.03

Ребяты снесите ХР и юзайте NT4.0 =)

проблем не будет эт точно...

Re: Проблемы ХР и Step7
aim; 24.3.03

По поводу NT согласен, да только вот повалила последнее время периферия в основном под USB :(

На данный момент оптимальным решением будет Win2K. Весь Сименсовский софт с ней отлично работает (последние версии :)

Re: Проблемы ХР и Step7
kip; 25.3.03

Кто нибудь из вас пробовал одуплить новый ноут , когда он идет с предустановкой ХР?

Так попробуйте, а потом говорите об NT и Win2K. :=)
Re: Проблемы ХР и Step7
aim; 25.3.03

А в чём проблема ???

Была у меня XP. Перевинтил на Win2K.
Ноут IBM ThinkPad.
???
Re: Проблемы ХР и Step7
александр; 7.11.03

народ у меня такая же проблема с protool6 после установки sp1 не перегружается но как то странно глюк происходит только на p4 на p3 всё нормально при том что нет разницы w2k или xp

Re: Проблемы ХР и Step7
Роман Абзаев; 8.11.03

А в чем проблема? Я на своем Ф.-Сименсе снес ХР, поставил 2К и всё ОК.

Re: Проблемы ХР и Step7
Андрей В.; 19.11.03

Пробуйте запускать программы в XP в режиме совместимости. У меня в 90% случаев помогает.

Re: Проблемы ХР и Step7
александр; 20.11.03

да они работают только компы работу не завершают


Программа-симулятор, но не PLCSim.
Александр Туманов; 4.3.03

Требуется отладить программу на STEP7.

Чтобы сделать это с помощью PLCSim нужно написать дополнительные программные блоки, имитирующие поведение объекта управления. Можно ли написать программу-имитатор отдельно от рабочей (так как рабочая програма может использовать все ресурсы, например, блоки данных или таймеры).

Re: Программа-симулятор, но не PLCSim.
Назаров Дмитрий; 27.3.03

Есть прекрасная возможность связи PLCSIM с VisualBasic через ActiveX. Можно считывать выхода и записывать входа в симуляторе. И тестируете свою программу. На мейл высылаю пример.


Программное резервирование (HELP)
АЛЕКСАНДР; 23.5.03

Re: Программное резервирование (HELP)
Илья; 26.5.03

В стандартной комплектации Step7 этого нет. Необходимо установить пакет программного резервирования Software Red...

Re: Программное резервирование (HELP)
АЛЕКСАНДР; 26.5.03

Может подскажешь, где его взять - по описанию он должен быть включен в стандартный пакет ???

Re: Программное резервирование (HELP)
Андрей Гуленок; 29.5.03

Это отдельный продукт.

Re: Программное резервирование (HELP) (обращение к специалистам SIEMENS)
АЛЕКСАНДР; 30.5.03

Если это отдельный продукт то он , мне думается , должен иметь каталожный номер. Вот с этого места, если кто то владеет ситуацией хотелось бы поподробнее

Re: Программное резервирование (HELP)
Андрей Гуленок; 2.6.03

6ES7862-0AC01-0YA0 SIMATIC S7, SW REDUNDANZ V1.2 SINGLE LICENSE F.1 INSTALLATION R-SW, SW UND DOKU. AUF CD KLASSE A,5-SPRACHIG(D,E,F,I,S) ABLAUFFAEHIG UNTER WIN95/98/ME/ WINNT/2000PROF REFERENZ-HW:SIMATIC S7-300/400 AB CPU 315

550 1 Stück


Прошу консультации
Дмитрий; 3.12.03

Здравствуйте!

До недавнего времени мы работали со STEP 7 под WINNT 4.0.
После перехода на WIN2000RUS SP4 неудается установить
Siwarex U и Siwarex M под STEP 7.
Установка в режиме совместимости программ тоже ничего не дала.
В чем проблема?
Re: Прошу консультации
Назаров Дмитрий; 8.12.03

Проблема скорее всего в версиях программного обеспечения.

Re: Прошу консультации
Baby; 14.12.03

Привет !!!

Конечно, несколько банальный совет....
Поставте WIN2000ENG SP2, и работать будет абсолютно ВСЁЁЁЁЁ ......

Re: Прошу консультации
Назаров Дмитрий; 15.12.03

Будет работать ВСЁЁЁЁЁ, только если ваш софт совместим с WIN2000. У нас тоже были проблемы с SIWAREX U под WIN2000. Версия не поддерживала эту операционку. После установки версии 1.7 все заработало.


Русификатор "LogoSoftComfort"
ОмГТУ; 27.3.03

Говорят, что на сайте "Сименс" была свободно выставлена программа русификатора "LogoSoftComfort"! Где ее найти?

Re: Русификатор
oleg; 28.3.03

Поищи здесь

http://www.siemens.ua/industry/ad/?AS/LOGO!Soft
Удачи
Re: Русификатор "LogoSoftComfort"
ОмГТУ; 28.3.03

Русификатор нашел, спасибо, но он не работает на "LogoSoftComfort" v3.1 !!

На какие версии он рассчитан и как им пользоваться???

Re: Русификатор
Евгений Гросфельд; 29.3.03

Нужно предварительно удалить из установочной папки английский вариант файла Language. И после этого все прекрасно работает. Так делают выпускники ОмГТУ :).


Русификация PCS7 v.6
Сафронов; 16.7.03

Возможна ли русификация стандартных блоков CFC (названий, комментариев, сообщений, faceplate и т.д.)? Если да, то где написано, как это сделать ?

Re: Русификация PCS7 v.6
Михайлин Сергей; 16.7.03

Да, возможно. Как раз сейчас этим занимаюсь. Хочу законченый пакет сделать. Работы для этого много. Подробное описание как это сделать штатно не существет. Я написал небольшое описание касательно версии 5. Вышлю Вам по почте, но естьтока на английском(писал для буржуев). От 6 там будем немного отличий, а именно в faceplate и небольших тонкостях.

Re: Русификация PCS7 v.6
Сафронов; 25.7.03

Перевел сообщения блоков с помощью команд Options > Manage Multilingual Texts > Export, Options > Manage Multilingual Texts > Import в SIMATIC Manager на русский язык. После чего в CFC-редакторе при просмотре сообщений (Properties > Message) и установленном русском языке в SIMATIC Manager (Options > Display Language) cообщения отображаются нормально. При просмотре сообщений в Text Library WinCC в переведенных сообщениях вместо русских символов вопросительные знаки (шрифт Fixedsys/Кириллица). Если отредактировать сообщение в Text Library, то после закрытия и повторного открытия Text Library русские символы отображаются вопросительными знаками. Такая же ситуация и при вводе русских имен и комментариев блоков, текстов в CFC-редакторе.

Re: Русификация PCS7 v.6
Михайлин Сергей; 25.7.03

Проходил! В Step7 для русского языка назначте фонт не Fixedsys, а Courier и сделайте трансфер. У меня заработало.

Re: Русификация PCS7 v.6
Сафронов; 30.7.03

Не помогло !

Вы писали, что проводите работы по русификации. Хотелось бы узнать срок окончания этих работ. Нас интересует в первую очередь русификация сообщений и faceplate библиотечных блоков CFC ?

Re: Русификация PCS7 v.6
Сафронов; 30.7.03

Вдогонку к предыдущему. Что понимается под трансефором в v.6 - команда PLC > Compile And Download Objects ?


Русский хелп к step 7 micro/win 32
Евгений Гросфельд; 10.3.03

Уважаемые коллеги и представители концерна SIEMENS! Подскажите, пож-та, можно ли где-нибудь найти русский хелп к Step 7 Micro/Win 32?

Re: Русский хелп к step 7 micro/win 32
Чистяков Дмитрий "СеверСталь"; 11.3.03

Существует, только русское описание, хелпа нет. Дело в том, что с каждой, новой версией появляется и новый хелп. И что ж его каждый раз переводить? :-)

Re: Русский хелп к step 7 micro/win 32
Евгений Гросфельд; 15.3.03

Подскажите, пож-та, где можно найти русское описание на Step 7 Micro/Win 32.

Re: Русский хелп к step 7 micro/win 32
Худяков Александр; 17.3.03

Скачать с этого сайта руководство по S7-200 в котором всё описано.


связь из Дельфи с Siemens S7-200 по RS232
Владимир; 30.3.03

Здравсвуйте уважаемые. Получил задание связаться из Дельфи с Siemens PLC S7-200 по RS232, не используя стандартные библиотеки, т.е. обмениваться по PPI протоколу. С Siemens я никогда не работал. Может кто-нибудь подсказать с чего начать?

А еще лучше примерчик бы какой-нибудь на мыло получить. Заранее спасибо.
С уважением, Владимир.

Re: связь из Дельфи с Siemens S7-200 по RS232
Andrey; 1.4.03

Да, такое можно сделать. Начни с описания на PPI. Но можно купить Prodave MPI и связывать прогу не только с S7-200, но и S7-300 и S7-400.

Re: связь из Дельфи с Siemens S7-200 по RS232
Andrey; 1.4.03

Кстати, по RS232 у тебя не получится связаться- нужен будет адаптер(RS232->RS485)

Re: связь из Дельфи с Siemens S7-200 по RS232
Andrey; 3.4.03

Или его (адаптер) можно сделать.


Сколько стоит апгрейд Step7 c v5.0 на 5.2
Хоружевский Роман; 18.7.03

Сколько стоит апгрейд Step7 c v5.0 на 5.2, а так же новая авторизация, на v 5.0 все есть.

Re: Сколько стоит апгрейд Step7 c v5.0 на 5.2
Назаров Дмитрий; 21.7.03

Заказной номер апргрейда 6ES7810-4CC06-0YX4 - 409 Евро в Германии. Во время процедуры апгрейда старая авторизация v5.0 преобразуется в v5.2

Re: Сколько стоит апгрейд Step7 c v5.0 на 5.2
Хоружевский Роман; 21.7.03

Не понял про авторизацию, т.е. при апгрейде перезаписывается дискета авторизации?

Re: Сколько стоит апгрейд Step7 c v5.0 на 5.2
Назаров Дмитрий; 21.7.03

Собственно апгрейд - это замена старой авторизации на новую. В поставке приходит Upgrade authorization diskette которая после запуска находит старую (если она есть) преобразует ее и устанавливает новую. После этого пользоваться можно только ей. Есть процедура Downgrade - возврат в исходное состояние.

Re: Сколько стоит апгрейд Step7 c v5.0 на 5.2
Mag; 4.8.03

Менял 5.0 на 5.1 Ни фига подобного ... Авторизация теряется :(


Сохранение проекта на FLASH в PLC
Mike Lourier; 12.3.03

Каким образом можно сохранить проект на карту Flash, которая всавлена в PLC? CPU 414, в компьютере интерфейсная карта cp5611, софт - Step 7 5.1

Re: Сохранение проекта на FLASH в PLC
oleg; 13.3.03

Для этого нужен программатор.

Re: Сохранение проекта на FLASH в PLC
Харгелия Олег, ЗАО "Искра-Энергетика"; 14.3.03

Для 416 это делается командой меню

PLC/Download user program to memory card
Для 312IFM - PLC/Copy RAM to ROM

в компьютере карта CP5613/
Re: Сохранение проекта на FLASH в PLC
Харгелия Олег, ЗАО "Искра-Энергетика"; 14.3.03

Для 416 это делается командой меню

PLC/Download user program to memory card
Для 312IFM - PLC/Copy RAM to ROM

в компьютере карта CP5613/

Re: Сохранение проекта на FLASH в PLC
Mike Lourier; 14.3.03

у меня 414-2 и кроме как через программатор похоже никак. =(


Стандартные блоки для S5
Павел; 3.6.03

Помогите найти стандартные блоки для SIMATIC S5 - FB62 (PID-REG), FB177(IMP-AUSG), или подобные.


Таблица символов
SERG; 30.7.03

Существует проблема с печатью русских букв в таблице символов в STEP7 v.5.1 SP4,

печатает всякую абрукадабру

Re: Таблица символов
Внимательно изучающий; 30.7.03

Посмотри в разделе SCADA, там у WinCC подобные проблемы рассматривали, думаю "ноги" из того же места растут.


тип данных POINTER в Step7
Сергей, Тверь; 6.3.03

Может, кто-нибудь объяснит, как использовать при написании FC/FB в Step7 тип данных POINTER? При создании FC я присваиваю входной переменной (in) с именем, донустим "X", тип данных POINTER. Но как использовать эту переменную в тексте программы? Ничего не получается, кроме следующей конструкции:

L P##X
Но это явно не то...
В документации я тоже ничего толкового по этому вопросу не нашёл.
Как же использовать этот тип для косвенной адресации????
Заранее благодарен за ответ.
Re: тип данных POINTER в Step7
Владимир Романко; 24.3.03

Я тоже намучался с этим POINTER. Решил проблему следующим образом:

Первые 2 байта содержат номер DB блока, 4 последующих байта адрес ячейки. При этом, если номер блока не 0 - то это адресс ячейки указанного DB блока. Иначе это может быть либо адрес входа, либо маркерной области и т.д.
Далее в функции я делаю следующую махинацию:
TAR1 #BufAR1 //сохраняю AR1 во временной переменной
L P##Alarm_Address //загружаю адрес входной переменной (не само значение, а именно адрес!!!!)
LAR1 // и загружаю его в AR1
L W [AR1,P#0.0] // вычитываю первые 2 байти из 6 байт
T #BlockNumber // и запоминаю в переменной BlockNumber
L D [AR1,P#2.0] //вычитываю следующие 4 байта
LAR1 // и сохраняю в AR1

// далее следует простая проверка на равенство номера блока 0
L #BlockNumber
L W#16#0
==I
JC Lb2
// если блок не нулевой - то открываю его
OPN DB [#BlockNumber]
Lb2: NOP 0

A I 0.0
= [AR1,P#0.0] // сохраняю значение входа I0.0 в первом бите указанного адреса

.......
// востанавливаю значение регистра AR1
LAR1 #BufAR1

Даный способ я опробовал на объекте - все работает без проблем. При этом абсолютно безразлично указали ли Вы адрес ввода/вывода, маркерной области или DB-блока.

Надеюсь объяснение не очень сумбурное.

Re: тип данных POINTER в Step7
Сергей, Тверь; 24.3.03

Спасибо большое за ответ!

Объяснение абсодютно понятное, я попробовал - всё работает.
Re: тип данных POINTER в Step7
Сергей, Тверь; 24.3.03

Спасибо большое за ответ!

Объяснение абсолютно понятное, я попробовал - всё работает.
Re: тип данных POINTER в Step7
Илья; 7.4.03

Ну, пример ПОЧТИ работоспособный. Есть одна особенность, на которую можно НАПОРОТЬСЯ. Тип данных POINTER на самом деле имеет размер 3 слова (6 байт). При этом старшее слово содержит номер DB, а 2 младших - указатель на область, где храняться данные. Особенность в том, что указатель содержит признак области (зоны), где храняться данные. Указатель на данные, хранящиеся в блоке DI имеет другой признак зоны, чем указатель на данные, хранящиеся в блоке DB. А перед использованием таких указателей вы ДОЛЖНЫ открыть блок - занести его номер в соответствующий регистр. Поэтому, если у вас указатель на данные в DI, а вы делаете:

OPN DBxxx
а потом используете указатель - будет полная шняга! Надо:
OPN DIxxx
Вот...
Re: тип данных POINTER в Step7
Либбо Александр; 30.10.03

Все равно не въехал как работать с POINTER. Попробовал разобраться с FC 81 (Indirect block move)так и не смог заставить работать, хотя функция удобная может кто нить с ней сталкивался? Подскажите!

Заранее благодарен!

Re: тип данных POINTER в Step7
Astronom; 25.12.03

Вообще то есть нормальная описаловка в хелпе степ 7. (набираешь в поиске поинтер) Читаешь там все прозрачно.


Требуются драйверы для CIF30-DPM к WinAC
Бардичев Виктор; 13.5.03

Здравствуйте!

Может ли кто нибудь прислать драйверы для CIF30-DPM к WinAC под NT4 и под Win2000?.

Когда мы покупали коммуникационные платы, WinAC -а еще не было в природе.

А сейчас не можем перейти на него из-за отсутствия драйверов.

С уважением, Бардичев Виктор.


Формальные параметры типа BLOCK_DB.
Александр Туманов; 12.2.03

Хочу написать свой FB1, в котором вызывается библиотечный FC91.

FC91 имеет формальный параметр: Declaration-INPUT, Type-BLOCK_DB. Чтобы принимать номер блока данных в FB1 создаю формальный параметр: Declaration-INPUT, Type-BLOCK_DB. В ОВ1 вызываю свой FB1 с фактическим параметром - DB10.
Вопрос: из FB не удаётся вызвать FC91, если в качестве фактического параметра для FC91 использовать формальный параметр FB1 типа BLOCK_DB. При этом параметры других типов передаются без проблем.
Re: Формальные параметры типа BLOCK_DB.
fog; 12.2.03

Это невозможно!!!

см. Manual "Programming with STEP 7 V5.0", Appendix A-70.